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Chapter Contents

What Is Aperture?
Importing Images
Browsing and Viewing Images
Adjusting Images
Sharing Images

Welcome to Aperture

Going out in the morning to shoot gigabytes of

photos is easy. Editing and organizing those

photos is a little harder. Ten years ago, editing

and organizing photographs was easy. You’d lay

your slides across a lightbox, grab a loupe, and

discard any image you didn’t like. After you

selected your images, you’d label the slides and

store them in sheets within organized folders.

For many photographers, one of their biggest

frustrations with digital photography is the lack

of a similarly simple and elegant workflow.

Throughout this book, we’ll show you how

Aperture allows you to reclaim that workflow

freedom and do more than you ever imagined

possible with your images.
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What Is Aperture?
Over the past few years, digital images have replaced slides, and many pieces of soft-
ware, from Adobe’s Bridge to Apple’s iPhoto, have replaced the lightbox/loupe/slide
sheet combination. Unfortunately, easy-to-use programs often can’t meet the demands
of a professional photographer, and the programs that can meet those demands often
aren’t very easy to use.

Apple’s Aperture program aims to strike a balance, providing both power and
ease of use. Over the next few hundred pages, we’ll show you how to incorporate
Aperture into your workflow. We’re confident that once you see everything Aperture
can do and how easy it is to use (with a little bit of help at first), you’ll never yearn for
slides again.

Aperture’s goal is to make it as simple as possible for photographers to import,
select, annotate, organize, and share their images, regardless of file format or experi-
ence level. The process of managing and organizing photos is commonly called a work-
flow. Photographers tend to have a range of workflow styles, ranging from just copying
the images from the camera to the computer and never really organizing them, to
importing and organizing in iPhoto (Apple’s consumer-oriented photo management
tool), to extensive work in a third-party digital asset management program.

In fact, many of the concepts in Aperture are similar to iPhoto. However, iPhoto
was designed to work with JPEG files, and Aperture was designed from the ground up
to work with RAW files. As far as Aperture is concerned, a RAW file is just another
image file, basically similar to a JPEG file. This makes working with a RAW file in
Aperture as easy as working with a JPEG in iPhoto. This does not mean that Aperture
handles only RAW files. Aperture can import and work with many image formats,
from RAW to PSD to JPEG to TIFF.

Why Shoot RAW?

If Aperture can work with JPEGs, why should you bother shooting RAW? One big reason is that a
RAW file contains more information than a JPEG. A JPEG can contain only 16.7 million (that is, 224)
possible colors, whereas some RAW files can contain 68.7 billion (that is, 236) colors. That is over
four thousand times more colors than a JPEG file can contain. Also, settings such as white balance
are not actually applied to the image stored in the RAW file until you view it, meaning that you
can change those settings without losing any data. When you shoot JPEG, settings like white bal-
ance are permanently applied to the image data as soon as the camera writes the image file to its
storage card.

Because RAW files contain more information and the adjustments haven’t been forcibly applied to
the image, some image adjustment operations, such as highlights and shadows, can be performed
only to a RAW file. Furthermore, JPEG is a lossy format. The first time the camera saves the image, it
throws away information from the sensor, and each time you save the JPEG file, it will throw away
more information. By starting with a RAW file and working with a lossless format such as TIFF,
you’ll be working with all the information that the camera can capture and you won’t lose any
data as you continue to work with the image.
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The Photo Library

When you import your image into Aperture, the digital image file is stored in the 
Aperture photo library. (We will discuss importing your images in Chapter 2, “Import-
ing and Organizing Your Images.)” A library is simply a special folder on your hard
drive that contains every image file you import into Aperture, as well as information
about each image. By default, Aperture places your library folder in the Pictures direc-
tory in your Home directory. If you want to see it, in the Finder, you could select Go >
Home and click the Pictures directory. You can change the library’s location, perhaps to
an external hard drive, under the Aperture preferences. Also, if you’re importing pic-
tures from iPhoto’s library or from somewhere else on your hard drive, Aperture will
copy the images to its own library and leave your original files untouched. Figure 1.1
shows Aperture’s Welcome screen, which is designed to get you started importing
images into Aperture.

Figure 1.1: The Aperture Welcome screen

Unlike other file management programs that let you scatter your images where-
ver you want to put them and then help you browse those folders, Aperture manages
your photos for you. Aperture is what digital photographers call a digital asset manage-
ment tool (DAM). Because DAMs allow you to quickly search for and view your
images, many people prefer using DAMs to scattering their files all over their comput-
ers. Furthermore, because you only interact with your images through the DAM, your
images rarely get lost. DAMs often provide tools to help you share your work via
slideshows, email, and more. The one downside to using a DAM is that you must inter-
act with your images via the DAM: you can’t go into the Finder and rearrange your
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images. However, for many people, not having to deal with manually rearranging your
files isn’t a disadvantage. It’s an advantage. 

If you were to look at the photo library on your hard drive, it would appear as a
file and not a folder that you can look inside, as seen in Figure 1.2. Aperture saves your
photo library as a special type of folder called a bundle, which is a folder that appears
in the Finder as a file, discouraging people from looking inside. You don’t have to
worry about what’s inside the bundle because again, Aperture is a DAM. Instead of
using the Finder to find, open, and move your images around, you do everything from
within Aperture and let Aperture figure out what to do with your image files. Within
Aperture, everything starts with your photo library.

Figure 1.2: The Aperture photo library

Aperture allows you to have only one photo library active at a time. That means
that all of the images you actively work with inside of Aperture are stored within the
same folder on your hard drive. One library is beneficial because all of your photos are
in one place, but having only one library can also be a pitfall because your hard drive
can hold only so much data. If you don’t edit carefully, Aperture’s photo library can
take over your hard drive. The program provides a way to export certain parts of your
photo library to a format that you can move elsewhere and reimport later. (You can
even import those photos to another computer, which we will talk more about in Chap-
ter 6, “Exporting Images.)” However, Aperture does not provide a way to browse these
exported files without reimporting them to your photo library.

N o t e : Creating additional photo libraries is easy. Under Aperture’s Preferences, you can select your photo

library’s location.To create a new library, select a folder that doesn’t already contain a photo library.To switch

photo libraries, you must change the preference to point to whatever photo library you want to use and

restart Aperture.
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Peeking Inside the Photo Library

For the advanced user, if you really want to look inside your Aperture library, you can Control-click
(right-click if your mouse has two or more buttons) the library icon in the Finder and select Show
Package Contents. This opens a new window that lets you browse the bundle just as if it were
another folder. We’ll discuss the contents of your photo library more in Chapter 10,“Advanced
Aperture.” We’ll also explain how you can always get to your images so that if something goes
wrong with Aperture, your photos will still be safe. Additionally, because you can access your pho-
tos directly, you can use another program to convert your RAW files and then import the converted
file into Aperture.

Projects

Back in Aperture, within your library, you create projects to group your images. A
project is a virtual collection of images, albums, and other files you create using the
photos in the given group, such as web galleries or books. Projects appear in the panel
on the left, as seen in Figure 1.2, which is called, appropriately enough, the Projects
panel. If the Projects panel is hidden, pressing W or choosing Window > Show Projects
will reveal it. You can create a project by choosing File > New Project (~+N). You can
rename the project by selecting it, pressing Return, and typing a name. Figure 1.3
shows the project in detail, highlighting a project, album, and folder. We’ll discuss each
container in the next few sections.

Figure 1.2: The Aperture user interface, showing the Projects panel, Viewer, and Browser
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Projects provide a handy way to do large-scale grouping of your photos. For
instance, if you are shooting in Yosemite one week and in King’s Canyon the next, you
could create two projects called “Yosemite” and “King’s Canyon” and separate your
images accordingly, or you could create one project called “California National Parks”
and just put all of your images in there. If you were going on an assignment to take
photos of California parks for a magazine, you would probably choose the latter
because it would organize all of your images for the assignment into one project. If you
were shooting for a stock agency, the former would be more useful because later, you
could quickly find and grab an image from Yosemite for your stock agency without
having to sort through King’s Canyon images too. As another example, rather than just
having one project called Weddings, you could make one project called Smith Wedding
and another project called Jones Wedding. We’ll cover projects more in Chapter 2,
including how to move images between projects.

N o t e : As you name your projects, albums, and folders, use only letters, numbers, and spaces. Other spe-

cial characters and punctuation, from colons to brackets, might cause problems down the road. For example,

third-party programs and scripts that work with Aperture’s photo library may not handle filenames with

slashes correctly, as Mac OS X uses a slash to indicate a directory.

Figure 1.3:

The Aperture Projects panel

Project

Album

Folder
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Albums

Generally, though, you’ll want an even finer grouping for your images than projects
provide. For instance, if you were shooting slides, you might have a group of slide
sheets for waterfalls and another group for wildlife within your Yosemite folder. 
Aperture has a similar notion called albums. Albums appear in the Projects panel,
shown in Figure 1.3, grouped under the project within the album. You can also create
folders within each project to contain your albums and other files, such as web galler-
ies, associated with your images. You create folders by selecting File > New Folder
(~+Shift+N). To put items into the folder, drag and drop albums and files into the
folder.

Unlike physical slides, photos within Aperture can exist in multiple albums. That
way, if you have a slide that falls into multiple categories, you can put the slide into
each category. For instance, on a multiday shoot, you might first organize your photos
into albums depending on when you took the photo. At the end of a shoot, you would
have albums named from “Yosemite 11/05 AM 1” to “Yosemite 11/05 PM 3.” Then,
you could make an album named “Yosemite Best” and pick out and copy your top
images into that album so that you could quickly show people your best images. Then,
you might make another album named “Yosemite Wildlife” that you’d copy wildlife
images into so that if your stock agency wanted a picture of a deer in front of Half
Dome, you could quickly look in one album rather than sort through all of your
albums to find the image that the agency wanted. Similarly, a wedding photographer
can create albums for subcategories such as bride portraits, wedding guests, wedding
party, ceremony, etc. To create an empty album to copy images into, select the project
you want the album to be in, and select File > New Album (~+Option+L).

N o t e : You can also make an empty album by selecting the project you want the album to be in, click-

ing the + button next to the All Projects text, and choosing New Empty Album.

N o t e : Unlike an album, a folder cannot contain images, and unlike a folder, an album cannot contain

non-image files.
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A Summary of Key Terms

The diagram provides a visual representation of 
the relationships among the library, projects,
albums, and folders.

Library A special folder on your hard drive
that contains every image file you import into
Aperture, as well as information about each
image.

Project A virtual collection of photos, albums,
and other files that you create using the photos
in the given group, such as web galleries or
books.

Album A grouped collection of photos that
exists within a project.

Folder A container for albums and other files,
but not images.

Metadata “Information about the information”: data about the image, such as exposure or copy-
right. Each metadata entry contains a “field,” such as shutter speed, and a “value,” such as 1/30 sec.

Smart Album An album whose contents are based on the metadata in each image and a user-
defined query.

Stack A collection of images that are related in some way, usually images that were taken within
a short timeframe of a similar subject.

Browser A panel that lets you see a sortable, filterable table or a thumbnail view of all of your
images within the album or project.

Viewer A panel that lets you view the full version of your image or images.

Light Table A view that lets you arbitrarily position and resize images.

Filmstrip The full-screen version of the Browser.

Heads-Up Display (HUD) A partially transparent window containing controls to interact with
your image, from making adjustments to setting metadata.

Inspector A panel or window that lets you see details related to an item such as a photo.

Master The original image that you imported into Aperture.

Version The modified version of the master file, stacked with the master. It can be a reference to
the master, if you’re making changes within Aperture, or a new image file, if you’ve opened the file
in an external editor.

Vault A copy of your photo library that can be automatically synced to your library or that your
library can be restored from.
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Metadata

Within each album, you can label each image with metadata. Metadata is data about
the image, ranging from exposure information to copyright information that is attached
to the image.

Back in the days of slides, you had to remember where and when you took each
image. Although you might have a rough idea as to what exposure and lens choice you
used for the image, information you might tediously cram on a slide label, you pro-
bably couldn’t remember the details. If someone asked you exactly how you took a
photo, it was nearly impossible to determine if the image you took with your 16–35mm
lens was set at 16mm or 18mm, f/5.6 or f/6.3, and at 1/250 or 1/500 of a second.

Digital cameras automatically capture and record tons of information, from
exposure and compensation to (in some cases) GPS data. This information is metadata
that is automatically attached to digital photos. For each piece of metadata, there is a
“field” such as shutter speed and a “value” such as 1/30 sec. Aperture allows you to
add additional metadata, such as your name and address, to each image, and it lets you
tag each image with keywords. In fact, you can set Aperture to add metadata to each
image as it’s being imported. Figure 1.4 shows Aperture’s Metadata Inspector for the
given image. An inspector is a panel or window that lets you see specific details, such
as metadata, related to an item, such as a photo.

Once you’ve imported the image into Aperture, you can edit some of its meta-
data, add or remove keywords, and apply a rating to each image. Ratings help you
quickly edit through the images you shoot. Images that you dislike, perhaps due to

Figure 1.4:

The Aperture Metadata Inspector
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composition or focus, are called rejects and are flagged with an X, and images that you
really like are called selects and are flagged with five stars. Other images can be rated
from one to five stars or left unrated.

However, metadata goes beyond rating and exposure. Aperture allows you to
tag each image with keywords. You can bring up the Keywords window (Figure 1.5) by
pressing Shift+H or by choosing Window > Show Keywords HUD. This display con-
tains a hierarchical listing of keywords that you can drag and drop onto images. You
can also add your own keywords, reorganize them, and drag and drop groups of them
onto images. We will explain how to do this customization in Chapter 4, “Finding the
Keepers.”

Keyword controls, as seen in Figure 1.6, appear at the bottom of the main win-
dow in the control bar. You can use them to apply groups of keywords with one click.
If the control bar isn’t visible, you can show it by choosing Window > Show Control
Bar (Shift+D). You can reveal the keyword controls by choosing Window > Show Key-
word Controls (D).

Figure 1.6: The keyword controls within the control bar

Continuing the earlier example, when you’re in Yosemite, you can have Aperture
automatically tag each image with “Yosemite” and “California” keywords on import
(we’ll explain how in Chapter 2). You can also automatically add your name, copyright
information, and contact information. As you’re viewing and rating your images, you
can add keywords such as “wildlife” to the images with wildlife and more specific key-
words such as “deer,” “squirrel,” “tourist,” and “half dome” to the appropriate pho-
tos. You might also want to rate any image that you really like as either four or five
stars and flag any image that you don’t like as a reject. Rejected images aren’t deleted
right away, and we’ll show you how to retrieve a rejected image in Chapter 4. By
applying this metadata, you can quickly set up a smart album to automatically show
your best wildlife images from Yosemite.

Figure 1.5:

The Keywords HUD
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Smart Albums

One big benefit of Aperture is the ability to create a “smart album.” A smart album is
an album whose contents are based on the metadata in each image and a user-defined
query. Smart albums can be global for your entire image library or local to each project.

To create a smart album, select the project you want to contain it, and choose
File > New Smart > Album (~+Shift+L). A Query panel, shown in Figure 1.7, will
appear to help you set up the album.

To quickly see your wildlife images, assuming you’ve tagged them all with a
“wildlife” keyword, you can make a smart album with a query for keywords contain-
ing “wildlife.” Similarly, if you want an album with your best images, you can make
another smart album by querying for ratings greater than or equal to four stars. If you
want to see your best wildlife images, you can make a smart album with both queries,
by querying for ratings greater than or equal to four stars and keywords that contain
“wildlife.” Figure 1.7 shows what this combined query would look like. Note that this
smart album query is set to match “all” criteria (an “and” operation) and not “any”
criteria (an “or” operation). This will give us pictures that are of wildlife and four stars
or better and not pictures that are of wildlife or four stars or better.

The next day, after you import, tag, and rate your new images, if you were to
click your “best wildlife” smart album, it would automatically be updated with your
best wildlife photos from earlier that day. You don’t have to manually copy your pho-
tos into the album. Smart albums can significantly enhance your workflow, and we’ll
discuss them in depth in Chapter 2.

The Library Project

Let’s broaden our view from fine-grained keywords back to the overall photo library at
the top of the Projects panel. There you’ll find an item called Library, as shown in Fig-
ure 1.8. The Library is the collection of all the images in all the projects and albums in

Figure 1.7:

The smart album query HUD

N o t e : You can quickly rate a five-star image (a select) by selecting the image and pressing the slash

key (/). For any image you don’t like (a reject), select the image and press the O key to reject it.
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Aperture. It comes preloaded with several smart albums, such as all five-star images, all
images from 2005, and all rejected images. All Images shows you every image that
you’ve imported into Aperture.

If you want to define items that use images from multiple projects, you can add
your own albums and other items into the Library project. Any items you add will
appear at the top level of the Projects panel, alongside your other projects, and not
underneath the Library project. This is different from what happens when you add an
item, such as an album, to a project and the new item appears as a child of the project.

Importing Images
Above the Projects panel is the Import panel, shown in Figure 1.9. The Import panel
lets you bring images into Aperture from either your hard drive or a digital storage
device, such as a compact flash card. You can bring up the Import window by clicking
where you want to import pictures from within the Import panel (either a storage card
or a disk) and selecting the project into which you want Aperture to import the images.
Aperture will display an arrow with the tail indicating the source and the arrowhead
pointing to where the images will be imported. On the right, you will see a panel with
image previews, metadata, and other controls for grouping images.

Figure 1.8:

The Projects panel with the

Library project highlighted
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Figure 1.9: The Import panel and window

Stacking

If you’re like many photographers, you tend to shoot in bursts. You point your camera
at the bear that’s running at you, fire off the largest burst you can, and run for your life
hoping that you’ve captured the picture of a lifetime. Later on, when importing your
images so that you can recount the escapade to your friends with some visual aids, you
will want to group the related set of images from each burst together and pick the best
images. In Aperture, these photos can be grouped together into a stack.

A stack is a collection of images that are related in some way, usually images
that were taken within a short timeframe of a similar subject. When you’re importing
your images, you can tell Aperture to automatically stack images by time, and you
define this time period by using the Time slider at the bottom of the Import window
seen in Figure 1.9. As you change the auto-stacking duration, Aperture will visually
group and collapse your photos into an expandable stack. The buttons along the bot-
tom will let you close or expand all stacks and manually edit the image groupings
(splitting or joining images) in each stack. After importing, you can also manually add
and remove images from a stack, and you can expand them to view specific images
within the stack, and more.

By stacking related images, finding your best images for a given pose/subject is
easy. For instance, the storage card with your bear photos would have a burst of photos,
a pause, and another burst of photos. You might tell Aperture to stack images taken

4019X_c01_p3_3.qxd  6/8/06  9:21 AM  Page 13
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within 1 second of each other. This would give you have a handful of stacks for each
time you stopped to take photos of the charging bear. Later on, you can compare images
within each stack and select your best image from each time you stopped to shoot.

Metadata

The metadata controls on the right side of the Import window let you add captions, key-
words, location, and other bits of metadata to the photos you’re importing. Aperture
also provides a time zone adjustment tool that will automatically correct the date and
time stamp in your photos’ metadata in case you didn’t reset your camera’s time zone
while shooting—something we’ve all forgotten to do at least a hundred times As soon as
you have your thumbnails stacked, your metadata set up, and you’re ready to import,
select the images you want to import (or don’t select any image to import every image)
and click the Import button. Aperture will import your photos in the background and
allow you to start viewing the full version of the first image before the second image has
finished downloading. We’ll discuss importing in greater detail in Chapter 2.

Browsing and Viewing Images
The center portion of the screen in Aperture’s main window, as seen in Figure 1.10, has
two portions, the Viewer and the Browser. The Browser is where you can see a thumb-
nail view or a table view of your images within the selected album or project and select
images to view. The Viewer shows the selected image.

Figure 1.10:

Aperture’s image

viewer and Browser
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Aperture is not limited to viewing just one image at a time. In fact, it offers five
different ways to view your images, including a way to view multiple images at once so
you can compare two non-stacked images and a special viewing mode to compare
images within a stack.

Often, you don’t just want to view the images in the stack, you want to sort the
stack with your best image on top. Aperture provides the Stack Compare mode that
lets you show two images from a stack at once, keeping your pick on the left and
showing another image from the stack on the right. In Chapter 3, “Viewing Images,”
we’ll show you how to select the best image by promoting and demoting the images in
the stack. The new pick replaces the one on the left and the Viewer adjusts to let you
continue sorting through the stack. After you finish sorting through the stack, the best
image appears on the top of the stack.

Sometimes it’s easy to pick which image is better, because one image will be out of
focus or have a bad composition. At other times, you’ll need to look closely at the image
and perhaps pick the one with the better catch light in the eye. Aperture provides a digital
loupe that you can pull up nearly anywhere you can see an image by pressing (`), (not a
single quote; this key is variously known as the accent grave, backtick, or tilde key) or by
selecting View > Loupe. The Loupe provides a quick way to see part of an image at 100
percent magnification or higher, and the Loupe will actually grab its data from the origi-
nal RAW file and convert the data on the fly. We’ll cover the Loupe more in Chapter 3,
but for now, Figure 1.11 shows what the Loupe looks like.

Figure 1.11:

The Loupe
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Proxy Images

When you first select an image, Aperture loads a proxy image while loading the full image in the
background. The proxy image is smaller than 1024 × 1024 and should not be used to judge sharp-
ness. Furthermore, you cannot loupe the proxy image. You will see a status icon saying “loading”
until the full image is ready, at which point the large image will appear to sharpen and an image
will appear in the Loupe. After the current image has loaded, Aperture will preload the next image
in your browser so that when you switch to it, you’ll have a shorter load time.

Sometimes a loupe isn’t enough, and you want to zoom in and view the image at
100 percent. To zoom the Viewer to 100 percent, press the Z key or select View >
Zoom To Actual Size. When zoomed in, Aperture overlays a small rectangle represent-
ing the image with a red rectangle representing the portion you’re looking at, as seen in
Figure 1.12. You can drag the red region around to scroll over the image.

If you want to compare multiple images in detail, you can select each image and
press Z to zoom in on all of them. In addition to scrolling each image individually,
Aperture also allows you to lock scroll the images. By holding down the Shift key as
you scroll one image, the other images automatically scroll in exactly the same way.
For instance, to compare a catch light in an animal’s eye to an eye positioned in
roughly the same spot in your images, ~+click the images to select them, press Z, and
while holding down the Shift key, drag the red rectangle around to scroll the visible
region over the animal’s eye. Once you’ve picked the best image, you can rate it as a
select by pressing the button with the green check in the control bar or by pressing the
backslash key (\).

N o t e : When you press Z to zoom in, Aperture will automatically zoom the image to wherever your 

cursor is, assuming your cursor is on the image.

Figure 1.12:

The small rectangle with the

visible area in red
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Light Tables

Sometimes, picking the best images isn’t as simple as comparing focus and catch lights
between similar shots. Back in the days of slides, it was nice to be able to just spread
our slides out on a lightbox, arrange them in some arbitrary fashion, and pick our
favorites. Aperture digitizes this concept and moves it forward by providing a light
table view. In Aperture, a light table lets photographers select some images, drag and
drop them onto the light table, and arbitrarily move them around, rotating and scaling
as desired and providing the ultimate visual organization tool. You can use the light
table for a variety of purposes, from comparing similar images side-by-side to trying
out image arrangements for a website to creating a photomontage. Figure 1.13 shows a
sample light table.

We’ll discuss the light table more in Chapter 3. If you want to explore a little
before you get there, you can create a new light table in a fairly straightforward process: 
1. Select some images in the Browser.

2. Choose File > New From Selection > Light Table. A new item will appear in the
Projects panel to represent your light table, and within the light table, you will
see the familiar Browser/Viewer layout. 

3. To place an image, drag it from the Browser onto the light table. 

You can use a light table for everything from moving images around in order to
compare them to creating a collage of photos that you’ll print. Plus, if you want to see
an image’s detail, you can even pull up a loupe to view it on the light table.

Figure 1.13:

A sample light table
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Full Screen Mode 

Sometimes you just don’t have enough space to really see your image, even with the Loupe,
perhaps because the Projects panel and inspector are taking up too much space. To max-
imize the amount of space devoted to your image, you can go into Full Screen mode.

Unlike full screen modes in other programs, Full Screen mode in Aperture is
more than just a slideshow, and Chapter 3 will cover all of the different things you can
do in it. Part of this power comes from two special heads-up displays (HUDs). HUDs
are partially transparent, small sets of tools that are quickly accessible, and they can be
hidden or locked on the screen for even quicker access. Through the HUDs, you can do
nearly everything that you can do in Windowed mode, from rotating images to viewing
metadata. The first HUD is called the Filmstrip (Figure 1.14), and it provides a way to
jump through images. The Filmstrip can be either docked to an edge of the monitor,
hidden, or docked and set to avoid the image (it positions itself so that it doesn’t cover
the image). In case you’re wondering, you can even use the Loupe in the Filmstrip.

Figure 1.14: The Filmstrip

The second main HUD is a toolbar (Figure 1.15) docked to the top of the screen
and hidden until you move your cursor near it. This non-customizable toolbar provides
quick access to a number of common functions ranging from expanding stacks to 
cropping. All of these buttons have hotkeys, and once you learn the hotkeys, you can
avoid wasting screen space with this toolbar.

Figure 1.15: The Full Screen toolbar

Adjusting Images
The Filmstrip and the Full Screen toolbar are available only in Full Screen mode. How-
ever, Aperture has other HUDs, such as the Adjustments HUD that provides quick
access to Aperture’s image enhancing tools and is shown in Figure 1.16, and you can
pull them up in Windowed mode. You can bring up the Image Enhancing Tools HUD
by pressing H or by choosing Window > Show Adjustments HUD. We will cover the
adjustment tools in depth in Chapter 5, “Nondestructive Image Processing.” These
tools include exposure adjustment, color correction, white balance, a histogram, and
more. These tools are considered nondestructive because you can always remove the
adjustment or change its properties without actually modifying the pixels in your origi-
nal, master image file. In fact, throughout this book, you will see references to your
master image, and the master is simply the original file that you imported.

4019X_c01_p3_3.qxd  6/8/06  9:21 AM  Page 18



19

■
A

D
JU

S
T

IN
G

 IM
A

G
E

S

In Aperture, each adjustment is actually a filter that’s applied to your image. Think
of a filter as a step on an assembly floor, and each time you view an image, Aperture
assembles the image you see by taking the master and running its pixels through the
assembly line. That way, you’re always working with the original pixels in a nondestruc-
tive way, and you can always change your mind about various adjustments and their val-
ues. In fact, after you’ve made some adjustments, if you were to go look at your image in
Photoshop, you wouldn’t see the various changes you’ve made within Aperture; you
would only see the original image. The filters you’ve applied to each image are stored
within Aperture, and the only way to make an image file with your changes so that you
can see them outside of Aperture is to export your image, as covered in Chapter 6.

Unlike Aperture, most other image editors are destructive. In them, once you’ve
changed the image (unless you used a layer adjustment mask or some other more
advanced technique), the only way to modify that change is to undo everything else you
did after that change and/or start over—from scratch. Plus, if you actually look at the
file after you work with it in other programs and click Save, you will see only see your
modified image stored in the file; you won’t see the original image anymore (unless it’s

Figure 1.16:

The Adjustments HUD
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a layered file). Again, if you were to look at the image that you modified within Aper-
ture, you would see the original image, not the modified one, and a list of steps telling
Aperture how to create your modified image. Chapter 5 will explain nondestructive
editing in depth and how to incorporate it to your workflow.

Another benefit to Aperture’s method of storing instructions for changes rather
than changing the image itself is that the set of instructions you apply to a given image
can be “lifted” from one image and “stamped” onto one or more other images, another
topic that we will cover in Chapter 5. For instance, if you accidentally set the camera’s
white balance incorrectly, you can quickly correct it in one image and apply that cor-
rection to other images taken under similar lighting conditions. However, if you decide
you like the incorrect white balance better than the corrected white balance in one
image, you can remove the correction just by turning off those choices.

If you want to experiment with an image, perhaps to see what it might look like
with a different white balance setting and compare the two images side-by-side, you
can make a new version of the master instead of duplicating the master and creating a
copy of the original file. A version is a reference to the master file with a different set of
filters applied. Furthermore, because Aperture stores information about the changes to
an image, rather than the image with the changes applied, creating a new version of an
image uses very little disk space.

External Editors

Despite their destructive nature, for many of us, an image-editing program such as
Adobe Photoshop is essential to our workflow. Aperture provides many of the basic
tools we use to modify images, especially for RAW conversion, but it is by no means a
Photoshop replacement. Whenever we want to make complicated changes to an image,
we need to go to an external editor, which is set within the Aperture preferences.

You can open an image quickly in your external editor by pressing ~+Shift+O or
by choosing Image > Open With External Editor. Aperture automatically makes a new
version of the image for you. Unlike the New Version From Master command, the ver-
sion created with this command is tied to a new master image file, either a TIFF or PSD
file, depending on your preferences, with all of your enhancements applied. Aperture
has to make a new file because programs like Photoshop can’t access or understand

N o t e : Opening a RAW file in an external editor from within Aperture isn’t easy, but we’ll show you how

to hack Aperture so that you can get to the RAW file in Chapter 10.That way you can convert it using a differ-

ent RAW converter if you want.

N o t e : You can always get a new, fresh version of a photo with no adjustments by selecting Image >

New Version From Master (Option+G).
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Aperture’s internal list of changes; they can work only with a new image file with the
changes applied. The downside to using this new file is that you consume disk space
every time Aperture has to make a new image file for your external editor; a RAW file
converted to a 16-bit TIFF can be 100MB or larger.

After you make your changes in your editor, click Save (not Save As) and go
back into Aperture. After a few seconds, you’ll see the thumbnail for the new image
version update with your changes. The version of the image you worked with in your
editor is automatically stacked with your original image, and you can set it to be the
stack pick by selecting it and pressing ~+\. Alternatively, you can extract it into its own
stack by selecting it and pressing Option+Shift+K. Keep in mind that some of things
you can do in an external editor, such as converting to CMYK, will prevent Aperture
from reading the edited image. In case you’re wondering which buttons to press to
make sure color management from Aperture to print stays consistent, we’ll answer that
question and more in Chapter 6.

Sharing Images
Once your best images are selected, keyworded, and tweaked, it’s time to share them
with the world. You can share images from inside of Aperture through books, websites,
prints, slideshows, email, and exporting them.

Books

Aperture lets you create books from numerous templates and provides the ability to
customize each template.

Your first choice is to determine whether you want a small or large book. If you
pick a large book, what style do you want? Perhaps you want to create a special occa-
sion book for your cousin’s wedding, with its white background and ample room for
writing wedding stories. Perhaps you’re preparing a book of stock images for a submis-
sion to a stock agency, and you prefer a professional black background with limited
text. Either way, the process of making a book is the same: pick your template, drag
images onto the book pages, move them around, and add/remove/modify the pages.
Figure 1.17 shows what the book layout feature looks like, and Chapter 9, “Creating a
Book,” will show you all the secrets of bookmaking in Aperture. When you’re ready,
either you can print the book to a high-resolution PDF for self-publication, or you can
click Buy Book to have your book printed using Apple’s print service. Keep in mind,
however, that even though Aperture’s books are higher in quality than those you can
order in iPhoto, the image quality is not on par with prints from high-end inkjets.

N o t e : You can start a book from anywhere in Aperture by selecting some photos and then selecting

File > New From Selection > Book.

4019X_c01_p3_3.qxd  6/8/06  9:21 AM  Page 21



22

C
H

A
P

T
E

R
1

: 
W

E
L

C
O

M
E

 T
O

 A
P

E
R

T
U

R
E

■

Figure 1.17: The Book Layout view

Web Pages

Books are so 1999. In today’s world, everyone wants to see a web page of your work.
Don’t worry—you don’t have to know HTML to make a professional-looking site.
Aperture provides the tools you need to make two types of web pages. The first type is
a web gallery. A gallery includes an index page with thumbnails of each of your pho-
tos, and a detail page showing a large version of the image for each, as well as optional
and customizable metadata for each image. The second type of site is a web journal.
The main difference between a journal and a gallery is that a journal is focused on pho-
tos and text (including, but not limited to, metadata), whereas a gallery only lets you
place images and metadata. Figure 1.18 shows what the two types look like in a web
browser.
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Figure 1.18: A sample web gallery (left) and a web journal (right)

Chapter 8, “Creating Web Content,” will cover creating websites from start to
finish. Both types are created the same way you create a book—select your images, and
choose File > New From Selection > Web Gallery (or Journal). Also like a book, you
can drag and drop to rearrange images, double-click text to edit it, and change your
theme. Creating web pages in Aperture provides one big advantage over other pro-
grams—they’re live. This means that within Aperture, you’re actually looking at a web
browser. You can click links to see what happens, and you don’t have to worry about
your site looking different when you view it outside of Aperture.

When you’re ready to publish your site, you can save it to a folder on your com-
puter, a folder that you can upload to a server or move to wherever you want, or you
can automatically publish it to a .Mac account with one click.

Printing

As great as web pages are, sometimes you or your clients just want to see a contact
sheet of your images or perhaps a print of one or two of them. In Aperture, printing
your images is as simple as selecting the image or images you want to print (or just
choosing File > Print Images to print all images) and choosing how you want to print
them. Chapter 7, “Printing,” will cover printing in detail, including creating your own
print presets.

N o t e : If you’re worried about someone else taking credit for your image, you can specify that Aper-

ture should automatically apply a watermark to every image you export. Select the watermark from

within the Aperture > Presets >Web Export menu. Isn’t it great to be able to share your work without

being afraid of not getting credit? We’ll show you how to add watermarks to your exported images in

Chapter 5, and we’ll cover watermarks with websites in Chapter 8.
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Aperture has two bundled print presets, one for contact sheets and the other for
single images. For contact sheets, you specify either a desired number of pages or a
desired number of rows and columns, and Aperture will configure its print job to meet
your request. You can also select what type of metadata to display with the contact
sheet and how big the font to print it should be. Figure 1.19 shows the Print panel with
contact sheet printing selected and some options, such as metadata, enabled.

Figure 1.19: The contact sheet Print panel

For a single image, you can explicitly set the size to scale your image to, from
filling to fit the page to a custom size, perhaps 8.5 × 12.5. We’ll discuss color manage-
ment with printing more in Chapter 7. One important point to remember is that if you
select the System Managed ColorSync profile, make sure to turn color management off
in your print driver after you click Print. Otherwise, you’ll get a double-color-managed
image, but the print won’t be twice as good.

Slideshows

Sometimes, when a client is sitting with you, you might like to share what you’ve been
shooting. A slideshow of your images can be quite effective. Aperture has six preset
slideshow modes, including dissolve and manual, and you can choose Edit from the
Slideshow Preset menu to create your own preset mode or modify one of the built-in

N o t e : If some of the options in this panel are a bit confusing, don’t worry.We’ll explain them to you in

Chapter 7.
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ones. Figure 1.20 shows the Edit panel and some of the options that you can configure.
These options include manually advancing the images or having Aperture time the
images to match music you picked from your iTunes library. You can also set the
slideshow to show up to 10 × 10 images at once, instead of the usual one-at-a-time,
providing a way to easily see sequences of images within the slideshow. We’ll cover
slideshows more in Chapter 3. 

Figure 1.20: The various slideshow options

Email

Speaking of smooth, it would be hard for Aperture’s email tool to get any easier to use.
Under Aperture’s Preferences, you set your preferred email program and the file format
to which you want your emailed images to be reformatted, such as Medium JPEG.
Then, simply make sure your email client is open, select some photos in Aperture, and
choose File > Email (Option+E). A copy of your image will automatically be reformat-
ted to the format you specified under Preferences, optionally with a watermark. Aper-
ture will create a new, blank message with your photos in your mail program. See
Chapter 6, “Exporting Images” for more detail.

N o t e : You can set the slideshows to use the smaller preview files that Aperture creates for each

image, rather than the full image, allowing your slideshow to run smoothly if you’re trying to show 

large files.
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Exporting Images

Despite all of these slick ways to share your images, sometimes you just want to export
the file from Aperture to use elsewhere, perhaps to send to a print service. We’ll cover
exporting in depth in Chapter 6. For a quick overview, if you want to export the master
image, such as a RAW file, select the image you want and choose File > Export Master
(~+Shift+S). You can select to keep the filenames or rename them based on image date,
version number, or custom text. If you’re exporting multiple images, Aperture will auto-
matically append an index number to each image. Figure 1.21 shows some of the
options you have for naming your images when you export them.

Figure 1.21: The Naming Presets panel

If you’ve altered your image in Aperture (for example, cropped it or changed the
exposure) and you want to export the modified image, select File > Export Version
(~+Shift+E) instead of Export Master. This type of export provides the same flexible
naming scheme that Export Master does, but it allows you to select the type of image
file you want, as Aperture can’t give you a new RAW file with your changes applied.
You can pick from a variety of image types, ranging from a full-sized 16-bit PSD file to
a JPEG that fits within a 640 × 640 square. Keep in mind that Export Version uses the
same export settings as the Mail exporter. In other words, if you have a particular type,
such as Email Medium JPEG, set to add a watermark, Export Version will also add the
watermark if you pick that format, in this case Email Medium JPEG.

Vaults

A common reason to export your images is to back up your work. Rather than export-
ing thousands of images, Aperture provides a way to automatically clone your photo
library elsewhere, perhaps to an external hard drive. This backup of your images is
called a vault, and you can have multiple vaults wherever you’d like them, as long as
the drive you select for the vault has enough free space. Vaults are shown in Aperture
in the bottom of the Projects panel, and you can see them by selecting Window > Show
Vaults. Once you have set up a vault, the panel will look similar to Figure 1.22.
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When you sync your vaults after you make changes to your Aperture library,
only the changes that you’ve made since the last sync are copied. Your entire library,
potentially gigabytes of data, is not copied. Because only the changes are copied, sync-
ing your vaults can be very fast, depending on your changes.

If something happens to your photo library, you can restore your library, or set
up a copy of your photo library on another computer by selecting File > Vault > Restore
Library. The panel you see in Figure 1.23 will appear, and you can select a vault file.
Aperture will replace the contents of your photo library with the data from the vault.
We will cover backup more in Chapter 4, including tips on how to safely store your
backups. 

Figure 1.23:

Restoring from a Vault

Figure 1.22:

The Vaults panel with 

a sample vault
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