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Chapter 1

Getting to Know V1Z

Welcome to Mastering Autodesk VIZ 2007. Once again, Autodesk VIZ 2007 benefits from the devel-
opment of its sister product, 3ds Max, to give architects and other design professionals an indis-
pensable design tool. VIZ 2007 gives designers cutting edge rendering technology, easier-to-use
architectural materials, improved communication with other software, enhancements to modeling
and animation tools, and improvements in the user interface.

This chapter introduces some of VIZ 2007’s special features and then gets you started working
with the VIZ 2007 interface.

@ Introducing VIZ 2007 Features
Getting Started

Touring the Interface
Working with Objects

Getting the View You Want

* 6 & o o

Working with the Custom UTI and Defaults Switcher

Introducing V1Z 2007 Features

With each new version of VIZ, Autodesk inevitably adds some cool bells and whistles that old and
new users will certainly appreciate. VIZ 2007 is no exception to that new-feature rule. Autodesk has
smoothed out some old rough edges when it comes to using multiple files on a project, asset and
support searches, the implementing of XRefs, DWG importing/exporting, and more still. Take a

look at the features in the Asset Tracking System, the improvements to XRefs, and other features
listed next.

Asset Tracking System You've probably noticed when you are working with complex
projects using many file assets acquired from several sources that keeping track of all the
required files is an arduous task. Any files that you can’t locate when a file is opened or rendered
can trigger a warning dialog box to appear and cause the rendered output to be inaccurate. VIZ
2007’s new Asset Tracking System simplifies this issue by presenting a dialog box for display
and repathing of scene assets including image maps used in materials, external references,
linked AutoCAD files, and output files. Figure 1.1 shows the new Asset Tracking dialog box.

User Paths, which define the program’s asset and support search parameters, can now be exported
into text files. You can distribute these files to other project contributors to ensure that all users
access the file assets from the same location. This ensures that any changes to files used in a project
are updated in all instances in which they were used. These text files can also be utilized to help
migrate the VIZ 2007 settings when you set up a new PC.
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FIGURE 1.1 151
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XRefs Autodesk has made improvements to the implementation of externally referenced
files (XRefs) including the new Overlay feature to reduce to occurrences of circular references.
You can now XRef materials without referencing geometry in a scene. XRef’d cameras are now
properly saved in the new scenes. Autodesk has revised the layout of the tools in the XRef
Objects dialog box to make the tools easier to access. They’ve also improved the overall
performance of the XRef system.

DWG Import/Export The DWG import and export functionality and the DWG File Linking
has been updated to coincide with the 2007 family of Autodesk products.

Mental Ray Rendering Autodesk has upgraded the mental ray renderer that ships with
VIZ 2007 to version 3.4 of the high-level, production-quality rendering system. This version
includes faster final gathering for smoother light distribution and more accurate raytrace ren-
dering. You can now use the Distributed Bucket Rendering feature to allow up to eight sys-
tems running Autodesk VIZ to each contribute the mental ray rendering of a single project.

OpenEXR VIZ now supports the OpenEXR file format. OpenEXR is an HDRI file format used
by Industrial Light & Magic in the production of major motion pictures. The new HDR Data and
Luminance HDR Data Render elements output High Dynamic Range information as separate
image files from the Render Scene dialog box. These can be used to analyze a scene’s lighting

information.

Getting Started

Although many of VIZ’s components are typical for a Windows program, quite a few are unique.
To begin exploring the VIZ 2007 interface, start the program by doing one of the following:

¢ Double-click the Autodesk VIZ 2007 icon on the Desktop.
¢ Choose Start » Programs » Autodesk > Autodesk VIZ 2007 » Autodesk VIZ 2007.

You'll see a variety of components in the VIZ window (see Figure 1.2)—some that are familiar
and others that are not.
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At the top, you see a typical menu bar and toolbar. You may also see up to five floating toolbars
containing additional VIZ tools. In the center, you see the viewport area, which currently shows a
Perspective viewport. At the lower right corner of the screen, you see the viewport navigation tools
for adjusting your views in the current viewport. You also see the time controls for creating anima-
tions, the prompt line and status bar, and the MAXScript Mini Listener (for creating macros). On
the right side, you see the Command Panels, which contains nearly all the tools you'll use to create
and edit objects in VIZ. Let’s take a closer look at each of these components. VIZ often offers several
methods including toolbars, Command Panels, menus, shortcuts, and so on for accomplishing
many tasks.

Touring the Interface

VIZ offers a wealth of tools, and their sheer number can be overwhelming. To get a basic under-
standing of the VIZ window, let’s look at each of the window components individually, starting
with the menu bar.

The Main Menu Bar

At the top of the screen is the main menu bar. Here, you find the typical Windows commands for
file maintenance, as well as commands specifically for Autodesk VIZ 2007.

The options in the menu bar are organized in the same way as they are in most other Windows
applications. Clicking an option issues a command, and you're expected to take some action. An
option that’s followed by three periods, called an ellipsis, opens a dialog box, usually to allow you
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to make changes to settings related to the option. An option with a right-pointing arrow displays
more options in what is called a cascading menuu.
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Try out the menu bar by taking a look at the Units Setup dialog box.
1. Choose Customize > Units Setup. The Units Setup dialog box displays.

2. Select the US Standard radio button, and make sure that Feet w/Decimal Inches is selected
below it and that the Inches radio button is selected for Default Units.
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3. Click the System Unit Setup button and you will see another small dialog box. Make sure 1
Unit is set equal to 1 inch. Do not change anything else in the System Unit Setup dialog box
and click OK twice to close both dialog boxes.
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By setting the Units Setup dialog box, you ensure that in future exercises, you’ll be working with
the same units that are discussed in this book.

NOTE Autodesk VIZ 2007 is something of a chameleon. It can change its appearance, depending
on the focus of your modeling needs. If your VI1Z 2007 window doesn’t look the way it does in the
figures in this book, choose Customize » Revert to Startup Layout. You’ll see a warning message
telling you that any user interface (Ul) changes you have made will be lost. Click OK to set up your
V1Z windows to match the interface you see in this book.

The Main Toolbar

Just below the menu bar is the Main toolbar. The tool icons on this toolbar offer tooltips to help you
remember their purpose.

To the far left of the toolbar are the Undo and Redo options. Left-click to step backwards or
forwards through your recent steps or right-click to see the history of your recent steps.

Kakad
Next is a set of tools for selecting objects. These selection tools let you select objects by clicking
them or by selecting them by name. You can also set the method for selecting objects by using a
selection window, which provides a way of indicating a selection by placing a rectangle, circle, or
other border around the objects.

To the right of the selection tools are the transform tools. This set of tools lets you move, rotate,
and scale objects. You can also choose the reference coordinate system, set the center of the trans-
form using the pivot options, use different snap options, work with named selection sets, and use
tools to mirror and align objects.

|4 O Al g8 £ ¢ & % o3| iy @ |

The next group of tools to the right include the layer and graph editor tools and the materials and
rendering tools. The graph editor tools display your scene information as graphs or wiring diagrams
to indicate the functionality or relationships of scene objects. The materials tools give you control over
the appearance of objects. With these tools, you can create color, texture, opacity, and other material
characteristics, and then apply these characteristics to objects in your model. You can also open the
new render dialog, select the render type, and perform a quick render with these buttons.

== E '==[§’z|ss|a|mu‘

The rendering tools give you control over the output of your Autodesk VIZ 2007 scene. Unlike
output from most applications, output from VIZ 2007 is most likely to be image or animation files.
The rendering tools let you set the type and size of output, from single, large format stills to video-
ready animations.

TIP I1fyou’re working with a screen resolution of 1024 X 768 or less, you won’t see all the tools on the
Main toolbar. Some of the tools are off the screen to the far right. To access these tools, place the cur-
sor on the toolbar so that a hand icon appears, and then click and drag the toolbar to the right. The
hidden tools will emerge. You can also click the Rendering menu item to access all the rendering
tools. The smallest supported resolutionin VIZ 2007is1024 X 768, but the recommended resolution
is 1280 X 1024 or higher.
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Docked and Floating Toolbars

In addition to the Main toolbar, you see several “floating” toolbars sitting on top of the viewport
(see Figure 1.2). There are also five toolbars that are hidden. You can open hidden toolbars by right-
clicking a blank part of any toolbar. A context menu will appear listing the available toolbars. Let’s
take a quick look at the floating toolbars.

1. Right-click a blank area of the main toolbar and click any of the toolbar items that do not
have a checkmark next to them.

A e s =

= Custamize...

& v Command Pael
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= Axis Constraints
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2. Repeat the process until all five floating toolbars are exposed.

All five toolbars float over the Perspective viewport: the Layers, Render Shortcuts, Snaps, Axis
Constraints and the Extras toolbar. As with most toolbars, you can move these floating toolbars to
the side or hide them altogether to gain better access to objects in the viewport.

TIP InVIZ and many other graphics programs, screen space is always at a premium. Using a two-
monitor system allows for alessening of screen clutter by moving items such as floating toolbars,
the Material Editor, graph editors, and so on to the second monitor, freeing up as much screen
real estate as possible.

Let’s preview these toolbars briefly in the section below:

Layers Layers are like overlays that help you organize the objects in your model. If you are an
AutoCAD or Photoshop user, you should have an idea of how layers work. You'll learn more
about layers in Chapter 6.

x|

layers
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Render Shortcuts Render shortcuts contain predefined render settings, such as resolution and
output file type, used to create content from your VIZ scenes. The Render Shortcuts toolbar is
where you will find the tools for saving and storing your preset values. You'll learn about ren-
dering in Chapters 10 and 11.

x
B G-

Snaps Snaps are features that control where the cursor jumps to, adding a degree of precision
to your scene, when it is near a characteristic in the scene. Using snaps you can easily move the
corner of one object to the midpoint of another or nearly any other characteristic combination.
Snaps are important in producing accurate architectural models.

- @
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Axis Constraints Transforming objects (moving, rotating, or scaling) is often done along a
particular axis, or direction, relative to the object or the scene. This functionality is usually
utilized through the Transform gizmo, an on-screen tool used to facilitate the transforms; the
Axis Constraints toolbar also contains these tools.

avis Constraints |
XY Z xr &Y

Extras The Extras toolbar contains tools that don’t fit cleanly into other categories. You can
override existing shortcuts and turn on a creation grid relative to the surface of any scene object
with the tools on this toolbar. You can also create numerous, precise clones of objects in matrices,
along a path, or at equal intervals.

You can dock the floating toolbars or float the docked toolbars. Try the following exercise to see
how to change the location of toolbars:

1. Click and drag the title bar of the Layers toolbar so that the toolbar is below the Main toolbar
(see Figure 1.3). The Layers toolbar appears ghosted as a horizontal outline just before you
release the mouse button.
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2. When the outline is in the position shown in Figure 1.3, release the mouse button. The Layers
toolbar is now in a docked position.

3. Dock the Extras toolbar just to the right of the Layers toolbar (also just under the Main toolbar).

File Edit Took Group Yiews Create Modfiers Animation Graph Editors Rendering  Customize
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4. Right-click the two vertical lines (called the toolbar handle) on the left side of the Extras tool-
bar to open the shortcut menu.
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5. Select Float from the shortcut menu. The Extras toolbar returns to its floating position.
Another way to do this is to drag the toolbar by its handle down into the viewport.

6. Select the Snaps toolbar and dock it to the left side of the user interface. (Toolbars can be
docked on either side of the viewports.)

B

7. Select the remaining floating toolbars and dock them on the top of left edge of the viewport.
Your screen should look similar to the VIZ window shown in Figure 1.4.

i

RE X2V AR AR

In this brief exercise, you learned how to dock and float toolbars, and how to access the shortcut
menu where you can toggle the toolbars on and off. Hide, dock, or float the toolbars however you wish.

Toolbar Flyouts

You may have noticed that some of the tools in the Main toolbar show a small arrow in the lower
right corner of the tool icon.

O Al = B
That arrow indicates that the tool is one of several offered in a flyout. A flyout is like a graphical
version of options in a menu bar. If you click and hold a tool that’s part of a flyout, you see a set of

4~ 40
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other tools appear. For example, if you click and hold the Select and Uniform Scale tool, two addi-
tional tools appear.

Once you select an option from a flyout, it becomes the default button that you see in the toolbar.

Tool Palettes

Tool palettes are collapsible boxes containing materials and tools for quick on-screen access. The
palettes are collapsed by default, taking up a minimum of screen space, but they expand when-
ever the cursor rolls over them. Clicking any of the named tabs switches the visible category of
tools or materials.
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To constantly view the tools, right-click the palette’s title bar and uncheck the Auto-hide option
in the context menu that appears.
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You can change the visible palette by right-clicking the title bar and choosing the palette that you
want from the bottom of the context menu. The All Palettes option display a single palette with all
categories available. To access the contents of a specific palette, right-click below the last visible tab
and choose the palette from the menu that appears.
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The Viewport

At the center of the window is the viewport (see Figure 1.5). This is where you'll be doing most of
your modeling work. In a blank file, the viewport shows a grid that you can use as a reference for
orientation and size. The grid is labeled with distances in the current, default unit setting. The labels
also indicate the X and Y axes.

If you look in the lower left corner of the viewport, you see the world axis tripod hat indicates
the orientation of the X, Y, and Z axes. The world axis tripod helps you get your bearings when
looking at other types of views. This is similar to the UCS icon in AutoCAD.

. 4 1|0
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FIGURE 1.5

A typical Perspective
viewport in the open-
ing screen

Currently, the viewport shows the Perspective viewport, as indicated by the label in the upper
left corner. You can also tell that it’s a Perspective viewport by the way the grid squares get smaller
and converge in the distance. As you'll see toward the end of this chapter, you can configure and
view your model in a variety of ways, depending on your needs.

Tools for Working with the Viewport

At the bottom of the window, there are several other options that are grouped into four sections: the
status bar, the prompt line, the time controls, and the viewport navigation tools (see Figure 1.6).
Most of these tools affect the viewport, either by modifying the display of the viewport directly or
by affecting the way you interact with objects within the viewport.

The viewport navigation tools give you control over the main graphic display in the center of the
window. With these tools, you can zoom and pan over the display, as well as alter the viewpoint
of your model. You can also switch between multiple views and a single view. Try the following:

1. Click the Maximize Viewport Toggle button in the far lower right corner of the window.
This is a tool you'll be using often. You can also press Alt+W on the keyboard.

|Q EHF
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FIGURE 1.6
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The graphic display changes to display four separate viewports. Each viewport shows a dif-
ferent type of view, as shown in Figure 1.7. Notice that the viewports are labeled in their
upper left corners.

2. Right-click the upper left viewport, labeled Top. Notice that the border of the Top viewport
becomes highlighted in yellow.

3. Click the Maximize Viewport Toggle again. Now the Top viewport fills the graphic area.
Notice how you can quickly expand the view of a viewport to see more detail.

4. Click the Maximize Viewport Toggle again to return to a four viewport layout.

5. Place your cursor at the intersection of the four viewports until it changes to a crossing
arrow cursor. Click and drag to resize all viewports simultaneously. You can also place the
cursor between just two viewports to resize the viewports in only one direction.

FIGURE 1.7

Four viewports, show-
ing the top, left, front,
and perspective views
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6. Right-click the border between two viewports and choose Reset Layout from the menu that
appears to return to the default layout.

7. Click anywhere within the Perspective viewport.
8. Click the Maximize Viewport Toggle to restore your original window setup.

You'vejust seen how you can expand the graphic area into multiple viewports showing the top,
front, left, and perspective views. Several other views and viewport arrangements are available, as
you'll see later in this chapter.

TIP You can set the current, active viewport to display a top, front, or left side view by pressing the
T,F, orL key. You can also press B for the bottom view. Pressing P will display the perspective view,
and pressing U will display an isometric user-defined view. If you have added a camera, you can
press C to select from a list of camera views. The hotkeys of R for right view and K for back have
beenremoved from the defaultsin VIZ. You can easily assign your own hotkeys to commands; this
procedure is covered later in the chapter.

Tools for Working with Time

To the left of the viewport navigation tools are time control tools. These tools give you control
over the animation functions of VIZ. Here, you can set your creations in motion by selecting the
length of time for your animation, as well as setting the precise location of objects within that

time frame.
ay Auto |Sesec|eu v bt [5] e e
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Near the bottom center of the interface there is a large button with the symbol of a key on it and
two smaller buttons to the right that are used to create animation keyframes, called keys.

The long horizontal elements across the bottom of the viewport are the time slider and track
bar, used for animation. You can hide the track bar to save space on the screen. Choose Cus-
tomize » Show UI » Show Track Bar to toggle this part of the interface off until you're ready
to make animations.

Just to the left of the animation controls are the Transform Type-Ins. This area displays the
location of your cursor in X, Y, and Z coordinates. It also displays other types of data, depend-
ing on your current activity. For example, if you're rotating an object, the coordinate readout
displays the rotation angle of the object being rotated. If you're scaling the data, these text
boxes will show percentages.

In addition to the Transform Type-Ins, there is a Grid panel, which may lie hidden to the right
if your display is set to low resolution. To find it, place the cursor on the vertical bar just to the left
of the prompt line until you see a double-pointed arrow.

«JyMane Select=d S []
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When you see the arrow, click and drag to the left. The Grid panel will be revealed to the right

of the transform type-ins.
Grid = 10.0
[ Add Time Tag

You can display a grid in the current, active viewport by clicking this panel or by pressing the
Gshortcut key. Right-click the panel to open a dialog box that lets you set the grid spacing and other
grid parameters.

Below and to the left of the Grid panel is the Communication Center icon. Click this icon to
establish the settings that determine when VIZ checks for official updates, patches, and news
from Autodesk. Once this is set up, an information bubble will appear whenever information from
Autodesk is available from the provided Internet link.

LT T
| _fdlAddTime Teg

Communication Cenber

Finally, to the far left at the bottom of the VIZ window is the MAXScript Mini Listener. MAX-
Script is a programming language that allows you to create custom macros in Autodesk VIZ 2007.
A macro is like a prerecorded series of instructions. The MAXScript Mini Listener serves two func-
tions: the pink area displays your activity when the MAXScript MacroRecord function is turned on,
and the white area provides a space where you can enter commands through the keyboard.
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Getting to Know the Command Panel

You'll be using the Command Panel for most of your work in VIZ. If you're an experienced
AutoCAD user, you might think of the Command Panel as the equivalent of the AutoCAD com-
mand line; it’s a single entry point for nearly all of the program’s functions. The Command Panel
offers nearly all the tools for creating and editing in VIZ.

Across the top of the Command Panel, you see a set of six tabs, each displaying an icon.

| @] 5| @D T

From left to right, the tabs are Create, Modify, Hierarchy, Motion, Display, and Utilities. If you
place the cursor on a tab, you'll see a tooltip displaying the name of the tab. When you click a tab,
the functions relating to the tab appear in the rest of the Command Panel. Here’s a brief rundown
of what each tab offers:

Create Allows you to create two-dimensional and three-dimensional objects. You can also cre-
ate light sources, cameras, and helper objects that are used to determine distance and relation-
ships between objects. Light sources, cameras, and helpers are objects that don’t appear when

your view is rendered.
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Modify Gives you control over the dimension, shape, and parameters of your objects. You
find tools (called modifiers) to extrude, twist, bend and otherwise manipulate your objects.
You can also control methods for applying material definitions to objects (called mapping
coordinates) in this tab.

Hierarchy Offers a set of tools aimed primarily at animation. The options in this tab let you
build relationships between objects to simulate joint movement or to constrain motion of one
object in relation to another. It also offers a way to control the location of an object’s pivot point.

Motion Another tab that gives you control over animation. Here, you can control the actual
motion of objects over time and view the trajectories of objects.

Display Lets you turn the visibility of objects on or off in your model. There may be times
when you don’t want a particular object visible while you render your model or while you're
editing a complex model full of objects. Display lets you temporarily hide objects from view or
lock them out from being selected. Objects can be hidden individually or by category.

Utilities A kind of catchall tab that provides access to special features and plug-ins. This is
where you find the Camera Match utility that lets you match your model view to a photograph.
You can also get access to the MAXScript customization features in this tab.

TIP  You can move the Command Panel just like any toolbar or close the panel entirely by clicking
the Close button (the one with the X, in the upper right corner of the window) when the panel is
floating. To bring the Command Panel back, right-click the blank area of any toolbar and then
select Command Panel from the shortcut menu. You can also right-click the Command Panel’s
title bar to dock the panel on the left or right side of the screen.

Understanding VIZ’s Tools

There are a few ways of working in VIZ that are a bit unusual for a Windows program. In this sec-
tion, you'll explore the Create tab of the Command Panel as a way to understand some of VIZ’s
quirks. There aren’t many, but understanding them now will make it easier for you to learn how to
use the program.

GETTING TO KNOW SCROLLING PANELS AND ROLLOUTS

Autodesk VIZ 2007 has a rich set of creation and editing tools—so many, in fact, that VIZ’s pro-
grammers had to come up with a way to get to them easily without making the program too arcane.
Two of these tools help you navigate its interface: the scrolling panel and the rollout. A scrolling
panel is an area that can be scrolled up or down using a hand cursor. A rollout is a set of tools that
can be opened or closed, much like a drawer in a dresser. Let’s start by looking at how a scrolling
panel works.

1. Click the Create tab of the Command Panel. Notice the row of icons just below the title of the
tab. These icons are buttons, or tools, that offer different categories of objects.

(0™ v & o %

2. Place the cursor over the tool that looks like a movie camera. Notice that a tooltip displays,
offering the name of the tool.

- @
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3. Click the Cameras tool. You see the options change below the tools.

w| | &)@ T||
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4. Click the Targetbutton. A set of additional options appears. Although it may not be obvious,
these options extend beyond the bottom of the Command Panel.

5. Move your cursor down to a blank spot in the Command Panel. The cursor changes to a hand.

{ﬂ'? 6. Click and drag upward with your mouse. Notice that the options in the Command Panel scroll
upward, following the motion of your mouse. This is an example of a scrolling panel. This
scrolling action exposes the rest of the options in the lower portion of the Command Panel.
Release the mouse button at any time once you've seen how this scrolling action works.

7. Place the cursor on a blank area again so that the hand cursor displays. Then click and drag
downward to view the Target and Free buttons under the Object Type bar.

8. You can also scroll the Command Panel by rolling the wheel on your mouse or by dragging
the dark gray slender vertical scroll bar on the right side of the command panel. Try both of
these methods.
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9. Another way to see more of the Command Panel is to increase its width by dragging the ver-
tical border between the Command Panel and the viewport. Position your mouse along this
edge and drag to the left and expand the Command Panel to two and then three columns.
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10. The advantage to having a three-column Command Panel is obvious—you can see all the con-
trols within the Command Panel at once. The disadvantage is equally apparent—the viewport
becomes much smaller. Drag the Command Panel back to one vertical column to give yourself
the maximum amount of screen space. It's better to learn how to scroll within the Command
Panel than to sacrifice valuable viewport space.

In this exercise, you see that the entire set of options can be changed by clicking a single tool. You
can also see that the set of tools can extend beyond the bottom of the Command Panel. You can
scroll the options upward or downward within the Command Panel in several ways. This allows
VIZ to offer a wide variety of options within the limited space of your display.

The Main toolbar also acts like a scrolling panel whenever a portion of the toolbar extends
beyond the screen area. For example, if your screen resolution is 1024 x 768, a portion of the Ren-
dering toolbar isn’t visible to the right of the screen. If you place the cursor on a blank area of the
Main toolbar, it turns into a hand cursor. You can then click and drag to the left to display the addi-
tional tools.

When you clicked the Target button in step 4 of the preceding exercise, a set of options appeared
under a bar labeled Parameters. There are three other bars, labeled Depth of Field Parameters,
Object Type, and Name and Color. Notice the minus (-) sign to the far left of these bars. These are
called rollouts. They let you open and close a set of options to get them out of the way, or to roll them
out for use. Try the following:

1. Click the rollout labeled Parameters. The options below the Parameters rollout disappear.
Also notice that the minus (-) sign to the left of the rollout changes to a plus (+) sign. This
indicates that the rollout is in its closed state. The plus tells you that there is more informa-
tion inside, waiting to be rolled out.

1+ Parameters |

2. Click the rollout labeled Name and Color. It also closes and displays a plus (+) sign to the
left. Click the rollout to open it again. Right-click a blank part of the interface within any one
of the rollouts and you'll see a context menu. Select Close All.

w2 & @@ T
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+ Reset Rollout Order
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3. Notice that the Parameters and Depth of Field Parameters rollouts closed but Object Type
and Name and Color remained open. This is because all objects on the Create Panel have
Object Type and Name and Color rollouts, and these always remain open. Any additional

%
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rollouts belong to the object you have chosen to create and can be controlled with this con-
text menu. Try dragging the Depth of Field Parameters rollout above the Parameters rollout.

AuloGnd

Taigel Free ]
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4. You will see a horizontal blue bar appear with an image of the rollout you are dragging
ghosted. When you release the mouse, the rollout you are dragging gets docked where the
blue bar was. Now the Depth of Field Parameters rollout should appear above the Parame-
ters rollout.
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5. Click the Parameters and Depth of Field Parameters rollouts again to display the options.

Now you can see how easy it is to control and customize the Command Panel interface. In this
and later chapters, you'll explore the rollouts that appear in the Command Panel and throughout

the program.

CREATING OBJECTS AND SETTING THEIR PARAMETERS

By now, you've seen most of VIZ’s interface and how it functions. However, you will want to know
about a few more tools and methods before you really delve into using VIZ. In the following exer-

cises, you'll get a chance to create a simple object, and in the process, you'll be introduced to a few
new tools.

1. In the Create tab of the Command Panel, click the Geometry tool at the top of the panel.
NPT ol
[ ¥ & o
SriGeometry fijec o

You see the Object Type rollout with a set of object types.
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2.

FIGURE 1.8
The rectangle so far

5.

FIGURE 1.9
The finished box

—

TOURING THE INTERFACE | 19

Click the Box button. Additional rollouts appear in the Command Panel. These include
Creation Method, Keyboard Entry, and Parameters. Notice that a message displays in the
prompt line at the bottom of the screen that says, “Click and drag to begin creation process.”
Also, the cursor in the graphic area displays as a cross, telling you that you're in object cre-
ation mode.

Place the cursor at the center of the graphic area at coordinates 0,0 and click and drag diag-
onally to the upper right corner of the screen—don’t release the mouse button just yet. As
you move the mouse, a rectangle follows your cursor. Notice that the values in the Length
and Width input boxes in the Parameters rollout change as you move the mouse.

Place the cursor so that the rectangle looks similar to the one shown in Figure 1.8, and then
release the mouse button. (You don’t need to match the rectangle in the figure exactly.) Now,
as you move the cursor, the rectangle changes in height. Notice that the Height parameter in
the Parameters rollout also follows the change in height.

Adjust the height so that the Height parameter shows about 2°0” and click your mouse. The
box is now fixed at the height you selected. It should look similar to Figure 1.9.

You'vejust created your first object in VIZ, and in the process, you've seen how the dimensions
of an object are reflected in the Parameters rollout. Once you've created an object, you can continue
to modify its parameters, as the following exercise demonstrates.

NOTE The following steps only work as directed if you have not deselected the box. If you have,
create a new box and then proceed with the following steps.

1.

In the Parameters rollout, locate the Width input box and click the upward-pointing arrow
to the right of the box several times. Arrows like this one are called spinners, and they allow

%
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you to graphically adjust the value of the input box they are associated with. Notice that the
box in the Perspective viewport begins to widen as the value in Width input box increases.

[ Pammetes ]
Leah 552 2]
width:[FEIET T
Heohl[ZIZT 2!

2. Click and hold down the left mouse button while pointing to the upward arrow of the Width
spinner. Notice that the box continues to grow in width as you hold down the mouse button.
When you hold the mouse button down and move the mouse forward or backward, the rate
of change of the values is accelerated.

3. Right-click the spinner arrow. The box shrinks in width to 0. Right-clicking the spinner
changes the spinner value to its lowest possible non-negative value, which is 0 in this case.

4. Click and drag the mouse upward from the Width spinner. The box grows in width. Click
and drag downward, and the width shrinks back down.

5. Clickand drag the Width spinner upward until the cursor reaches the top of the screen. Then
continue moving the mouse upward. Notice that the cursor reappears at the bottom of the
screen. This circular action of the spinner lets you scroll continuously without being limited
by the screen area.

TIP When adjusting a spinner, you can immediately undo any changes you make by right-clicking
the mouse while still holding the left mouse button. This allows you to quickly experiment with
spinner settings while you work.

You'vejust seen how you can change the parameters of an object by using the spinner. Now let’s
take a look at the absolute way of entering values into input boxes.

1. Click the Length input box in the Parameters rollout and type 60”. Notice how the box’s
length changes and the Length value changes to 5°0.0”, the feet and inches equivalent of 60”.

2. Press the Tab key. Notice that the Width value is now highlighted.

Farzmeters
Lergh{FTT— 2|
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3. Type 607 for the width and press Tab again. The Height value is highlighted.

4. Enter 5" again. The box is now a cube 60” square.

NOTE You can also create a cube directly by selecting the Cube radio button in the Creation
Method rollout.

If there is a series of related input boxes—such as the Length, Width, and Height boxes in
the previous exercise—the Tab key lets you advance from one value to the next. You'll find that
numeric input boxes and spinners are quite common throughout Autodesk VIZ 2007.

TIP 1fyouhold down the Ctrl key while you drag a spinner, the rate of change in the spinner value
increases. The Alt key has the opposite effect, decreasing the rate of change. The higher the
numeric value in the spinner, the faster the rate of change, and vice versa.

- @
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Working with Objects

Now that you've seen the main elements of the VIZ interface, let’s take a look at how you interact
with objects in the viewport. You'll start by looking at a way to move the box you've just created.
Then you’ll learn how you can view your box from different angles.

Selecting and Moving Objects

VIZ’s basic editing tools are simple and straightforward, although it may take a little explaining for
you to grasp the finer points. As with most graphics programs, you use a selection tool to select
objects. This tool is typically shown on the toolbar as an upward-pointing arrow that looks like the
standard Windows cursor.

1. Click the Select Object tool in the Main toolbar.

o
C
-

Select Object

2. C(lickin a blank area of the viewport. This clears any selections that may currently be active.

3. Move the cursor over the box. Notice that the cursor turns into a plus (+) sign. This tells you
that the cursor has found a selectable object.

4. Click the box. A graphic displays, showing the X, Y, and Z orientation of the box in relation
to the viewport. Also notice that marks like 3D corner marks appear at the corners of the box.
These are called selection brackets, and they indicate graphically the objects that are selected.

0

With the box selected, you can go to the Modify tab of the Command Panel and edit its properties,
or you can use any number of other editing tools to affect the box.
Let’s continue by looking at one of the more basic editing tools you'll use—the Select and Move tool.

1. Click the Select and Move tool. Notice that the graphics indicating the box selection change
and new ones appear.

Select and Move

4~ 40
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2. Place the cursor on the box. It changes into the Select and Move icon.

3. Click the box if it isn’t still selected. A graphic known as the Move Transform gizmo dis-
plays, showing the X, Y, and Z orientation of the box in relation to the viewport. Selection
brackets also appear at the corners of the box.

4. Place the cursor on the blue Z axis handle of the Move transform gizmo; the blue arrow rep-
resents the Z axis. Notice that the Z axis label is highlighted in yellow and the X axis label
turns back to red. When you move the cursor away from the Z axis, the X axis is highlighted
again and the Z axis returns to blue.

The yellow highlighting shows you which axis is currently active. The Y axis is the default
constraint direction. If the Constraints toolbar is still open, you'll see that the Y axis button
is selected. As you've seen in this step, you can select an axis to constrain just by placing your
cursor on the axis coordinate arrow.

TIP The axis that is highlighted in yellow is the last axis constraint that was used. For example, if
you transform an object in the Y direction, the next time you go to transform an object, the Y axis
will be highlighted.

5. Place the cursor on the XY plane handle, the square that joins the X and Y handles of the
Move gizmo. Notice that the XY plane handle highlights in yellow. Click and drag the box
on the grid. The box now moves in the XY plane. When you click and drag the X arrow,
movement is constrained along the X axis only.

6. Click and drag the blue Z coordinate arrow upward. Now, movement is constrained in the
Z axis, away from and toward the grid. As you may guess, clicking and dragging the green
Y coordinate arrow constrains movement in the Y axis.

If you click an object in a location other than the coordinate arrows but still on the object, you
can freely move the object in the current axis or plane restriction. Notice that the coordinate
location of the object is displayed in the status lineat the bottom center of the interface.

Asyou see, moving an object in VIZ is fairly straightforward. But what if you want to move an object
a specific distance or to a known position? The following exercise demonstrates how this is done.

1. With the box still selected and the Select and Move tool still active, click the Absolute/Offset
Mode Transform Type-In button at the bottom of the VIZ window.

@xh'n_zsy' jv:|-2'a.14“ jz;
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CONSTRAINING MOTION

The tools in the Constraints toolbar constrain the motion of an object in the X, Y, or Z axis. For example,
to constrain motion in the X axis, click the Select and Move tool, and then click the X tool in the Con-
straints toolbar. The selected object’s motion is constrained to the X axis. In early versions of VIZ, this
was the only method available to constrain motion.

Another important function that the Constraints toolbar offers is the selection of the default free motion
plane. In step 5 of the preceding exercise, you were able to move the box freely in the XY plane, but you
were constrained to that plane. The Constraints toolbar lets you select the default plane to which you are
constrained. The Restrict to XY Plane tool is a flyout offering three options: XY, YZ, and ZX. You can select
the plane in which you want to constrain motion by selecting one of these three options. The XY option is
fine for nearly all of your work; every now and then, though, you’ll want to use one of the other options, so
it’s good to be aware of this tool. You can also access these constraint planes simply by dragging the appro-
priate parts of the Transform gizmo—it’s very intuitive.

If you prefer to use shortcut keys instead of a toolbar, the F5, F6 and F7 keys toggle the X, Y, and Z axis con-
straints respectively. Pressing the F8 key repeatedly cycles through the XY, YZ, and XZ plane constraints.

Finally, a tool that is related to the transform tools is the Selection Lock Toggle.

[aB x[o7s 2

ok Td3election Lock Togale

This tool helps prevent the accidental loss of a selection due to a mouse click. It also allows you to use the
transform tools without actually placing the cursor on the selected objects. You can also toggle this tool
on and off by clicking it or by pressing the spacebar while in a selection mode.

The tool changes to show that the Offset mode is active.
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When the Absolute/Offset Mode Transform Type-In button is in the “up,” or Absolute,
mode, you can enter the specific coordinates of the point where you want to move your
object. When it’s in the “down,” or Offset, mode, you can enter a relative distance from
the object’s current location.

2. (lickin the X inputbox in the coordinate readout and type 10.1. The box moves 10 feet in the
positive X direction.

3. Click and drag the Z axis coordinate readout spinner upward. The box moves vertically.

E 4. Click the Absolute/Offset Mode Type-In button to switch to Absolute mode. Then click in
the Z coordinate readout input box and enter 1. The box moves so that its base is exactly
at 1” for the Z coordinate.
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5. Right-click the X coordinate readout spinner. Remember that right-clicking a spinner con-
verts the value associated with the spinner to lowest value, which is 0 in this case. Notice that
the box moves to 0 for the X coordinate.

6. Right-click the spinners for the Y and Z coordinates in the coordinate readout. The box
moves to the center of the screen at the origin (coordinates 0,0,0).

Just as with the spinners in the Command Panel, the transform type-in spinners let you set val-
ues by clicking and dragging. You can also return to the default values of zero by right-clicking the
spinners. When in Offset mode, the spinners automatically reset to zero because the values repre-
sent numerical values away from its current, baseline location. The spinners in the coordinate read-
out appear when you turn on the Select and Move, Select and Rotate, or Select and Scale tools from
the Main toolbar.

TIP 1fyou are used to earlier versions of V1Z, you can still use the floating Transform Type-In dia-
log boxes that appear when you right-click the Select and Move, Rotate, and Scale tools. Also, you
can access the Transform Type-In dialog boxes from the quad menu by right-clicking in the view-
port then choosing Settings button to the right of the Move/Rotate/Scale transforms. These are
handy because you see the results before you commit to them.

Rotating and Scaling Objects

Besides the Move tool, the transform tools also include the Rotate and Scale tools. Try the following
set of exercises to see how these tools work.

TIP  You can also activate the Move, Rotate, and Scale tools by right-clicking an object and select-
ing Move, Rotate, or Scale from the quad menu.

1. With the box selected, click the Select and Rotate tool in the Main toolbar. A graphic known
as the Rotate Transform gizmo, a kind of virtual trackball, displays showing rings for rota-
tion about the X, Y, and Z axes.

2. Place the cursor on the red ring that circumscribes the X axis. Notice that the ring is high-
lighted in yellow. Click and drag the X axis ring upward. The box rotates about the X axis.

- @
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A tangent indicator arrow will appear indicating the direction of rotation, and a transparent
red slice along with a text tooltip will appear displaying the amount of rotation.

Make sure the Absolute/Offset Mode Transform Type-In button is in the Absolute mode
and look at the coordinate readout. Notice that the X value is not zero, because you rotated
it in step 2. It now shows a number of degrees.

3. Right-click the X spinner in the coordinate readout to set the X value rotation back to zero.
Notice that the box snaps back to its original orientation.

The Select and Rotate tool’s methods are the same as those for the Select and Move tool. You
can rotate an object graphically by clicking and dragging the object, or, with an object selected,
you can enter an exact rotation value in the coordinate readout. When the Absolute/Offset Trans-
form Type-In button is in the Absolute mode, you can control the orientation in relation to the
object’s original orientation when it was created. In the Offset mode, you can control the orien-
tation relative to the object’s current orientation.

Now try out the Scale tool:

1. With the box selected, click the Select and Uniform Scale tool in the Main toolbar. The Scale
Transform gizmo displays, showing the X, Y, and Z orientation of the box in relation to the
viewport.

Ul"m Kl

Select and Unform Scae

2. Click in the center of the Scale gizmo or the box and drag the box upward. The box grows
uniformly in size.

3. Click and hold the Select and Uniform Scale tool. Then select the middle tool, which is the
Select and Non-uniform Scale tool. This step is not absolutely required, but it is presented here
to clarify the concept. The axis handles alone can be used to scale an object non-uniformly.

g 2
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4. Drag the XY plane handle of the Scale gizmo (highlighted in yellow) to non-uniformly scale
the box in the XY plane in this case. Similarly, the axis handles can be dragged to constrain
the scaling of an object to one axis.

e

Now, take a look at the coordinate readout. The values you see are percentages of scale.
When the Absolute/Offset Transform Type-In button is in the Absolute (up) position, the val-
ues are percentages of the original size of the object. When it’s in the Offset position, the values
are the scale in relation to the current size and are immediately reset to 100 percent when you
release the mouse button.

NOTE Lookatthebox’s Length, Width, and Height values in the Parameters rollout in the Com-
mand Panel. They all read 5°0.0” even though the box has been scaled. This is an important
indicator as to how V1Z handles object data. For example, if you have a box that is 1 unit long
on each side and then you scale it to twice its size, VIZ does not now see this as a box that is
2 units on each side, it sees it as a 1 unit box with a 200 percent scale factor applied.

1. With the Absolute/Offset Transform Type-In tool in the Absolute position, click and drag
E the Z spinner upward. Notice that the box grows in the Z axis.

2. Right-click the Y axis spinner. The box distorts to a 0 value in the Y axis.

3. Click in the X value input box and enter 100.!. The box’s X value is restored to its
original size.

4. Press the Tab key to move to the Y value input box and enter 100...

5. Press Tab again to move to the Z input box and enter 75.1. The box is now slightly shorter
than it is wide and long.

The Select and Scale tool works in a slightly different way from the other two transform tools.
For one thing, a zero value in the coordinate readout doesn’t return the selected object to its original
shape. This is because the values in the coordinate readout represent percentages, where 100 per-
cent is the original size.

The new Scale gizmo allows you to both uniformly and non-uniformly scale an object by auto-
matically switching between scale modes. Which operation you perform depends on which part of
the Scale gizmo you drag.




é 72725book.fm Page 27 Tuesday, August 15,2006 6:12 PM é

WORKING WITH OBJECTS | 27

1. Try dragging the center of the Scale gizmo. You will see the object get uniformly bigger or
smaller when you drag up or down.

2. Thistime, put your mouse over one of the edges of the Scale gizmo. When you drag over one
of the plane handles, you are performing a non-uniform scale in two directions at once. Look
closely at the gizmo and you can see the axes labeled. Try non-uniformly scaling the box in
the YZ plane.

3. The last operation you can perform using the Scale transform gizmo is a non-uniform scale
in one direction. To accomplish this, put your mouse directly over the axis handle at the tip
of an axis. For example, put your mouse over the green dot at the end of the Y axis and drag
to scale in that direction only.

Once you master the mechanics of the new transform gizmos, you will find that you have much
finer and more intuitive control over your objects as compared to early versions of VIZ.

%
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Copying an Object

You've covered just about all the ways of moving, rotating, and scaling an object in the Perspective view-
port. If you want to copy an object, you use the same methods you would use to move, rotate, or scale
objects—with the addition of holding down the Shift key. Try the following steps to see how copying, or
cloning as it’s called in VIZ, works. (Copying is one of the forms of a more general function called cloning.)

1. From the File menu, choose Open. The Open File dialog box appears. Navigate to the Chapter 1
e files on the companion CD. Select the Chair.max file and then click the Open button.

2. Click the Select Object button in the Main toolbar if it’s not already highlighted, and then
select the chair.

3. Click the Select and Move button.
4. While holding down the Shift key, drag the chair to the left. A second chair appears.

5. Release the mouse button. The Clone Options dialog box displays. This dialog box lets you con-
trol the quantity and type of copies you're making, as well as the name of the new objects.

cone opuons TP
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o | Cancel |

6. In the Object group of the Clone Options dialog box, make sure Copy is selected.
7. Click OK. The new chair object is added to your scene.

TIP Youmay experience times when you want to make a copy of an object in exactly the same loca-
tion as the original object. To accomplish this, first select the object you wish to copy, and then
select Edit > Clone from the menu bar or Ctrl+V on the keyboard. You see a Clone Options dialog
box similar to the one that you saw in the preceding exercise. Set your options and click OK. Note
that the new copy doesn’t appear at first, because it occupies the same space as the original. (You
can accomplish the same thing by Shift+clicking an object with the Select and Move tool or by
selecting Clone from the transform quad menu, which can be accessed by right-clicking the object.
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In step 6, you selected the Copy option in the Clone Options dialog box. This option creates a dis-
tinct copy of the original object. The other two options, Instance and Reference, create clones that
are linked to the original, so that changes in one object affect the other. You'll learn more about
these options in Chapter 2.

Selecting Multiple Objects

You've now learned how to select, move, and copy a single object, but what do you do if you want
to move or copy several objects at once? You can select multiple objects, or selection sets as they are
called in VIZ, using two methods. The first is one that is also employed in other graphics programs.

[t? 1. Click the Select Object tool on the Main toolbar.
2. C(lick a blank area of the viewport to clear any selections you may already have.

3. Click and hold your mouse at a point below and to the left of the original chair. Then drag
to the right and upward. Notice that a dotted rectangle follows your cursor, as shown in Fig-
ure 1.10.

4. Continue to drag the cursor up and to the right until it encloses both chairs. Then release the
mouse button. Both chairs are selected.

FIGURE 1.10
Placing the selection
rectangle around
the chairs

Click and drag from here.

Notice that selection brackets (or bounding boxes) appear at the corners of both chairs, and a
Transform gizmo appears between the two chairs, showing you that the two objects are selected.
You can select objects in a couple of other ways, which you'll learn about in a moment, but first, let’s
use the current selection to make a few more copies of the box.

1. Click the Select and Move tool in the Main toolbar.

! 2. Shiftand drag the Y axis arrow downward so that copies of the two chairs appear in the loca-
tion shown in Figure 1.11. (You don’t need to be exact about the placement of the copies.)

3. When you have the copies in place, release the mouse button.
4. In the Clone Options dialog box, make sure Copy is selected in the Object group and click OK.

The four chairs help to demonstrate some of the other selection methods available to you. First,
let’s look at another property of the selection window.

%
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FIGURE 1.11

Place the copies just
beyond your first
two chairs.

1. Click the Select Object tool.

2. Click a blank spot in the viewport to clear your selection set.

3. Click and drag the cursor from the point indicated in Figure 1.12.
4

. Drag the rectangle up and to the right so that it encompasses just a portion of all the chairs,
as shown in Figure 1.12. Then release the mouse button. Three of the four chairs are selected.

Notice that you didn’t need to enclose the chairs completely to select them. In the current selection
mode, you only need to have the selection window cross over the desired objects. This is known as a
crossing window. If you're an AutoCAD user, this type of window should be familiar to you.

You can change the way the selection window works by using the Window /Crossing Selection
tool. The following exercise demonstrates this.

1. Click a blank area in the drawing in order to clear your selection set.

2. Click the Window /Crossing Selection tool in the Main toolbar.

Window | Crossing

Notice that the icon highlights in yellow and changes to one showing a sphere that’s com-
pletely within a dotted rectangle. This tells you that you are now in Window Selection mode.

FIGURE 1.12
Selecting points for a
crossing window

Click and drag from here.
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3. Clickapointabove and to the left of the front left chair in the foreground, as shown in Figure 1.13.

4. Drag the rectangle down and to the right until it includes all of the chairs in the front, as
shown in Figure 1.13. Then release the mouse button. Notice that the only objects selected
are the two chairs in the front.

When you use Window Selection mode, only objects that are completely within the selected win-
dow are selected. Unlike with the crossing window, objects that are partially inside the selected
window are left out of the selection.

You can use the Ctrl key in conjunction with any selection method to continue to add more
objects to your selection set. You can also remove objects from your selection set by using the
Ctrl or Alt key. Let’s see how adding and subtracting from selections works.

NOTE The Ctrlkey act as a toggle when you click on an object with it pressed. Selected objects are
deselected and unselected objects are selected. Holding the Alt key down when you click on an
object only deselects it if it is selected, but does not select it if it is not.

1. Switch back to the Crossing Selection method, then Ctrl+click and hold a point above and to
the left of the chair near the top of the viewport, as shown in Figure 1.14.

2. Drag the window down and to the right so that it encloses a portion of the two chairs in the
back. Then release the mouse button. Now all four chairs are selected.

3. Hold down the Ctrl key and then click the chair in the upper right of the screen, as shown
in Figure 1.15. Now all chairs except the upper right one are selected.

FIGURE 1.13
Placing a selection
window

Click here to start the selection window.

FIGURE 1.14

Adding objects toyour Ctrl+click here.
selection set using the

Ctrl key and a window

Release mouse here.
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FIGURE 1.15 .
Removing an object Place a Wl'ndow
using the Ctrl key around this box.
and a click

You can change the shape of your selection window to help select objects. There are rectangular,
circular, polygonal, lasso, and paint selection region options. The next exercise explores the Lasso
selection region that allows freeform sketching for a selection.

1. Drag open the selection window flyout and choose the Lasso button.

2
Jaim
=

2. Switch back to the Window selection option.

3. Sketch a Lasso selection region by dragging the mouse in a freeform manner around two of
the chairs to select them.

Right now, you have only a few objects in your model, but as your model develops, you'll find
that selecting objects in a crowded model becomes more of a challenge. Knowing about the differ-
ent selection modes you've just used will go a long way toward making your work easier.
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One more selection method will be an invaluable tool as your model becomes more complex.
You can select objects by their names, using the Select Objects dialog box. The following is a quick
exercise that will introduce you to this important tool.

1. Click the Select by Name tool in the Main toolbar or press H on the keyboard.

-Select by Namel
The Select Objects dialog box displays. Notice that it contains a list showing the names of
the objects in your drawing with the currently selected objects appearing in blue. Groups of
objects appear in brackets. Right now, the list shows the default names given to the objects

by VIZ. You can always change the name of an object in the Command Panel. (You can
rename an object on every tab except Utilities.)
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Click the None button near the bottom left of the dialog box. This clears the selection set.

. Click [Bruer02] and then Ctrl+click [Bruer04] in the list of object names. This list lets you
select multiple names as you would in a typical Windows list box. You can Shift+click
to select a group of adjacent names or Ctrl+click to select a group of individual names.

4. Click the Select button. The two chairs are selected.
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The preceding exercise showed you how to select objects based on their names, but it also indi-
rectly showed you the importance of the names of objects. Giving objects meaningful names helps
you locate and select them more easily, especially in a crowded model.

NOTE VIZ is a parametric, object-oriented program, and every object has its own name. Each
object has its own parameters that can be accessed from the Modify tab.

Whenever you create an object in Autodesk VIZ 2007, you have the opportunity to give the new
object a name. If you don’t indicate a new name, VIZ provides a name for you. If the new object is
a copy of an existing one, the new name that VIZ provides is the name of the original object, with a
number appended to its name. If you don’t give an object a meaningful name when you create the
object, it’s easy enough to change it later. Just select the object, and then enter a new name in the object
name input box at the top of the Modify tab or in the Name and Color rollout of the Create tab.

| | &)@\ T
[Boxns T -

Naming Selection Sets

Suppose you've gone through a lot of effort selecting a set of objects, and you know you will want
to select the same set of objects again at a later time. VIZ offers the Named Selection Sets tool, which
lets you name a selection set for later recall. Here’s how it works:

1. Make sure two of the chairs are selected. It doesn’t really matter which two, because you're
just practicing using the Named Selection Sets tool.

2. C(lick inside the Named Selection Sets input box that’s just to the left of the Mirror tool in the
Main toolbar.

BN =l pN

3. Type the name SampTle. You've just given the current selection set a name. (You can enter
a selection set name up to 15 characters long.)

4. Click in a blank area of the viewport to clear the current selection set.

5. In the Main toolbar, click the downward-pointing arrow to the right of the Named Selection
Sets input box. Select Sample. The two chairs you selected earlier are now the current selec-
tion set.

In these early stages of learning VIZ, the concept of named selection sets may seem simple, but
it’s one tool you'll likely use quite a bit as you expand your skills.
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TIP The Edit option in the menu bar offers some additional selection commands, such as Select
All, Select None, and Select Invert. You can also use the Edit > Select By cascading menu to
select objects by color or name or to change the selection region style.

Editing Named Selection Sets

Named selection sets are not fixed in stone. You can add to or subtract from them, or you can delete
them entirely through the Named Selection Sets dialog box.

1. Open the Named Selection Sets dialog box by choosing Edit > Edit Named Selection Sets, or
by clicking the Named Selection Sets button just to the left of the Named Selection Sets input
box you used before. The Named Selection Sets dialog box appears with a list of all of the
selection sets that have been created.

@a | {} Sample j

Marmed Selection Seks

2. Click the plus (+) symbol next to your Sample named selection set to see which objects are
contained within this set.
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The list shows several objects contained in the named selection set, but only two chairs were
added. The chairs are actually groups composed of several objects that respond as if they are
a single object. Groups are covered in Chapter 2.

3. Click Samplein the list. Then click the Select Objects by Name button in the Named Selection
Sets toolbar.
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4. The Select Objects dialog box displays. Select one of the names in the list that doesn’t already

appear in the Named Selection Sets dialog box, and then click the Select button. This selects
the listed object in the scene.
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5. Click the Add Selected Objects button within the Named Selection Sets dialog box.
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The name of the object you selected, or the members within the groups, now appears in the
list of objects contained in the selection set.
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6. Close the dialog box and deselect all objects by clicking off to the side in the viewport.

7. Select Sample from the Named Selection Sets drop-down list. Now you see that three of the
chairs are selected.

8. Click in a blank area of the viewport to clear the selection set.
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There are several other tools in the Named Selection Sets dialog box. These tools let you select
objects from a set, highlight selected objects, delete objects from a set, or remove a set altogether.
You can also create new named selection sets using the Create New Set tool at the far left of the
Named Selection Sets toolbar.

You've now seen most of the selection tools you'll need to get started with VIZ. You'll learn
about a few other selection tools as you work with VIZ, and you’ll also get a chance to apply the
tools you've already learned as you start to build and edit 3D models in later chapters.

In the next section, you'll learn about the tools that enable you to view your model from different
angles and how these different views can aid you in creating and editing your model.

TIP Named selection sets can also contain selections of subobjects, such as vertices, edges, or
polygons, the components that make up an object. You will learn about subobjects in Chapter 4.
When a subobject named selection set is created, it is only available when that object is selected
and the subobject level is accessed.

Getting the View You Want

So far in this chapter, you’ve done all of your work without making any modifications to the point
of view of your model. Now let’s take a look at ways you can control your view. Understanding the
viewport controls is essential for manipulating objects in your model, so take some time to become
familiar with all the tools discussed in this section.

Understanding the Perspective Viewing Tools

If you look at the viewport tools in the lower right corner of the VIZ window, you'll see some icons
that are common among most graphics programs. These include the magnifying glass and the
hand. Other tools in this area may be a bit more mysterious. In this section, you'll learn how these
tools let you get around in your model.

PANNING AND ZOOMING YOUR VIEW

Let’s start by looking at the tool with the hand icon, known as the Pan tool. Like similar tools
in other programs, the Pan tool displaces your view up or down, or to the left or right. But in
VIZ’s Perspective viewport, you're also changing your point of view. Do the following to see
what this means.

1. Click the Pan tool.
11 8T H
2| 2> &b B

2. Click and drag the viewport to the left and upward until the chairs are roughly centered in
the viewport.

3. Clickand drag the viewportin a circular fashion. Notice that your view of the model appears
to change as if you were rocking side to side while looking at the chairs.
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Next, try the Zoom tool.
1. Click the Zoom tool.

IR |&8E T
! i
Zoam

2. Click and drag the Zoom tool upward from the center of the viewport. Notice how you
appear to get closer to the chairs.

3. Click and drag the cursor downward in the viewport. Now you appear to be moving away
from the chairs.

4. Continue to click and drag downward until your view looks similar to the one shown in
Figure 1.16.

You may have also noticed that, as you moved farther away, the grid became denser. Then, at
a certain point, the grid changed to a wider interval. VIZ does this so that the grid doesn’t over-
whelm the view when it becomes too dense.

Again, as with other graphics programs, the Zoom tool enlarges or reduces your view. In addi-
tion to the Zoom tool, the wheel of the mouse can also be used to zoom in and out within a view-
port. In VIZ’s Perspective viewport, zooming has the effect of moving you closer to or farther away
from the objects in your model. You can click and hold the wheel down while moving the mouse
to pan the view. These two methods of panning and zooming can be used transparently while in
the middle of any other command in VIZ without leaving that command.

Now, suppose you don’t like the last view change you made and you want to go back to the pre-
vious view. Try the following steps to return to the previous view.

1. Choose Views > Undo View Change. You return to the previous view. (Alternatively, press
Shift+Z.)

2. Choose Views » Undo View Change or press Shift+Z again. Your view returns to the view
prior to the last view.

FIGURE 1.16
Zooming out to view
alarger area
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3. Choose Views » Undo View Change a third time. You return to the view you had before you
panned your view.

The Views > Undo View Change command lets you step back to a previous view in case the last
view change you made is one you don’tlike. Views » Undo View Change undoes any view change,
regardless of which viewport tool you used last.

WARNING Don’t confuse Views > Undo View Change with the Edit » Undo command. Edit >
Undo undoes creation and editing operations but not view changes.

SAVING A VIEW YOU LIKE

If you happen to get a view that you know you want to go back to later, you can save the view with
the Views » Save Active command from the menu bar. Use it in the next exercise to save a view that
you'll return to later in this chapter. And, as you'll see in Chapter 9, you can also create a camera
object and align it to a view.

1. Click the Zoom Extents tool to set up your view for the next exercise. Zoom Extents causes
the viewport to display the entire model.

2. Save this view by choosing Views > Save Active Perspective View.

The Zoom Extents tool repositions your view so that the entire model fits within the viewport,
filling the viewport as much as possible. If you're an AutoCAD user, you're familiar with this tool,
because its counterpart in AutoCAD performs the same function.

TIP You can restore the default perspective view (the one you see when you open a new file) in a
blank file by clicking the Zoom Extents tool or by choosing File > Reset to reset the scene.

CHANGING YOUR VIEWING ANGLE

Two other tools are specifically designed for viewing 3D objects: Field-of-View and Arc Rotate
Selected. The Field-of-View tool changes the viewable angle of the viewport without changing the
point of view. The Arc Rotate Selected tool lets you rotate your view around a selected object.
The Field-of-View tool appears to do the same thing as the Zoom tool, but as you’ll see in the
following exercise, there is a significant difference between the Zoom and Field-of-View tools.

1. Save the current view by choosing Views > Save Active Perspective View. This lets you
return to the current view later.

2. Click the Field-of-View tool.

1R EEH

Field-of-Yiew

3. Place the cursor in the viewport and click and drag downward until your view looks similar
to Figure 1.17.
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FIGURE 1.17

View of the Perspec-
tive viewport after
increasing the field
of view

In one sense, it appears as though you’ve zoomed out from the chairs, but if you compare this
view to the zoomed-out view in the previous exercise, you'll notice a difference. When you use the
Zoom tool in the Perspective viewport, your view changes as though you were physically moving
closer to or farther away from the chairs. As the name implies, the Field-of-View tool widens or nar-
rows your field of view, much as a zoom lens on a camera does. You're not actually changing the
distance from the object; instead, you're changing the area that your viewport displays. The Field-
of-View tool has the potential to distort your view, just as a super-wide-angle fish-eye lens or a
super-telephoto lens tends to distort a photograph. Until you find yourself in a situation where you
really need to change the field of view, you should refrain from using the Field-of-View tool.

Now let’s take a look at the Arc Rotate Selected tool.

1. Return to the view you had before you used the Field-of-View tool by selecting Views >
Restore Active Perspective View.

2. Click the Select Object tool. Click in a blank space in the viewport to clear any selections that
may be active. In the next exercise, you'll see why this is significant.

3. Click the Arc Rotate Selected tool.

QLETH
A

Arc Rokate Selected

q You see a yellow circle with squares at each of the four cardinal points on the circle. If you
C%D o place the cursor inside the circle, the cursor looks like two overlapping ellipses.

4. Place the cursor on the square at the far left of the circle. Notice that the cursor changes shape
to what looks like a horizontal ellipse.

5. With the cursor on the square, slowly click and drag the cursor to the right. Notice how the
view rotates.

%
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6. Place the cursor on the square at the top of the circle. Now the cursor changes to a vertically
oriented ellipse.

7. With the cursor on the square, click and drag the cursor downward. The view now rotates
in that direction.

The squares on the yellow circle are like handles that you can grab and turn to change your view
orientation. The left and right squares constrain the rotation to the horizontal plane, and the top and
bottom squares constrain the rotation to the vertical plane. If you prefer, you can adjust the view
freely without constraint in the vertical or horizontal direction by clicking and dragging the cursor
anywhere within the circle. You can also rotate the view by clicking and dragging anywhere out-
side the circle. The following exercise demonstrates these features. Pay attention to the shape of the
cursor in each step.

1. Place the cursor anywhere within the circle. Then slowly click and drag in a small, circular
motion. Notice how the view changes as if your point of view was rotating around the group
of chairs.

2. Place the cursor anywhere outside the circle. Then slowly click and drag in an up-and-down

motion. Now the view rotates around the circle as if you were tilting your head from side to side.

You may have noticed that the cursor changes, depending on whether you're inside or outside
the circle. This gives you further cues regarding the way the Arc Rotate tool affects your view.

You've been introduced to nearly all of the viewport tools. However, there’s one more feature
of the Arc Rotate Selected tool that you’'ll want to know about before you move on. The Arc Rotate
Selected tool uses the center of the viewport as the center about which it rotates when no object
is selected. But the Arc Rotate Selected tool works in a slightly different way when objects are
selected. Try the following exercise to see how this variation works.

1. Choose Views > Restore Active Perspective View to restore the view you saved earlier.
2. Click the Select Object tool from the Main toolbar.
3. Click the chair on the left side in the back row.

4. Click the Arc Rotate Selected tool again.

%
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5. Slowly click and drag the cursor within the circle. Notice how the view appears to be fixed
at the center of the selected chair.

6. Slowly click and drag the cursor in a vertical motion outside the circle. The view appears to
rotate around the selected chair.

7. Return to the saved view by choosing Views > Restore Active Perspective View.

If you click and hold the Arc Rotate Selected tool, you'll see two other Arc Rotate tools in the Arc
Rotate flyout. The tool at the top, called simply the Arc Rotate tool, rotates the view about the view
center, regardless of whether an object is selected. You've already seen how the second tool, the Arc
Rotate Selected tool, works. The tool at the bottom of the Arc Rotate flyout is the Arc Rotate Sub-
Object tool. This tool rotates a view about a subobject-level selection. You'll learn about subobject-
level editing in Chapter 4.

TIP  You can Arc Rotate by holding down the Alt key on the keyboard and dragging the wheel button of
your mouse inaviewport. Don’t turn the wheel, but dragit asif the wheel was a middle mouse button.
Thisisahuge timesaver because you’ll find that you don’t have to spend time exiting the current com-
mand and clicking the Arc Rotate button when you want to rotate your viewing angle.

By being able to select an object or set of objects as the center of rotation for your view, you are better
able to set up your views for rendering or editing. The combination of the Zoom, Pan, and Arc Rotate
tools allows you to obtain just about any view you may need as you work within VIZ’s Perspective view-
port. But you aren’t limited to a perspective view of your model. In fact, there are many situations where
the perspective view is not ideal, especially when editing your model. In the next section, you'll look at
other viewport types that give you greater flexibility in creating and editing objects in your model.

Using Multiple Viewports

So far, you've done all your work in the Perspective viewport, but this isn’t the only view you have
available. You saw earlier how you can divide the VIZ window so that it displays four equal view-
ports, each representing a different view. Let’s go back to that viewport arrangement to explore the
uses of some of VIZ's display tools. The first item you’'ll look at is the way that the Field-of-View
tool changes when your active viewport changes.

1. Click the Maximize Viewport Toggle in the set of viewport navigation controls.

QAEEF
=5

maximize Viewporkt Togglel

VIZ’s window changes to display four viewports.

2. Right-click anywhere in the viewport labeled Top in the upper left corner of the display.
Notice that the Field-of-View tool changes to a magnifying glass with a rectangle. This is the
Region Zoom tool.
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Also notice that the Top viewport now shows a thick yellow border around it, indicating that
it is the current, active viewport.

3. Click the Zoom Region tool.

4. Click and drag the cursor on a pointbelow and to the left of the chairs, as shown in Figure 1.18.
As you drag the cursor, you see a rectangle appear. Don't release the cursor just yet.

5. Position the rectangle above and to the left of the bottom row of chairs, as shown in Figure 1.18,
and then release the mouse button. The view enlarges to the region you just indicated with the
Zoom Region tool.

FIGURE 1.18
Selecting a view to
enlarge withthe Zoom
Region tool

The Zoom Region tool acts like the magnifying tools in many other graphics programs. Also, the
Zoom and Pan tools perform the same functions in orthogonal views in VIZ as they do in other pro-
grams, allowing you to zoom in and pan over the view.

You may have noticed two other tools in the viewport navigation controls that haven't been dis-
cussed yet: the Zoom All and Zoom Extents All tools. Now that you have multiple viewports displayed,
you can try out these two tools.

1. Click the Zoom All tool.

2. Inany viewport, click and drag the cursor upward. Notice that the view in all of the view-
ports is enlarged.

3. Click and drag the cursor downward, and the views expand to show more of the model area.
4. Click the Zoom Extents All tool.

Q&5
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Zoom Extents All
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All of the viewports change to show enlarged views of the chairs zoomed out to show all
objects in the scene.

Two additional tools exist as flyouts under the Zoom Extents and Zoom Extents All tools. The
Zoom Extents Selected and Zoom Extents All Selected tools have the same functionality as their
companions, but they only work relative to the selected objects. For example, if two chairs are
selected and you use the Zoom Extents Selected tool, the current viewport is zoomed in to view
those selected chairs, rather than all of the objects in the scene.

Although not as frequently used as the other viewport navigation tools, the Zoom All tool and
the Zoom Extents All tool can be helpful when you need to adjust the overall view of your model
in multiple viewports.

You should be aware that the Arc Rotate Selected tool you used in the Perspective viewport also
works in the other viewports. Try it out on the Top viewport in the next exercise.

1. Click the Arc Rotate Selected tool.

2. Click and drag the cursor from the center of the Top viewport upward and to the right so it
shows a view similar to Figure 1.19.

The view changes to a type of 3D view known as an isometric projection. Also notice that the
label in the upper left corner of the viewport now reads User. This indicates that the view is
a custom view based on your changes.

- @
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FIGURE 1.19

Top viewport after
using Arc Rotate
Selected

3. Click the Zoom Extents tool to center the view in the viewport.

The User view in the upper left corner of the display differs in many ways from the perspective
view. But, as you'll see in the next section, it’s different only because a few of the settings for that view-
port are different from those of the Perspective viewport.

Changing the Viewport Display and Configuration

If you compare the User viewport with the Perspective viewport, you notice one thing that is dif-
ferent. As mentioned in the previous exercise, the User viewport shows a 3D orthographic projec-
tion. Parallel lines do not converge as the distance from the viewpoint increases as it does with
perspective views. The second difference is that the User viewport isn’t shaded; the chairs are dis-
played as simple line outlines called a wireframe view. These display characteristics can be modified
for each viewport.

In the following exercise, you'll see how you can alter viewport settings to obtain specific view
characteristics such as shading and perspective.

1. Right-click the User label in the upper right corner of the User viewport. A pop-up menu
displays.

Wigws 3

v Smooth + Highlights
Wireframe
Other »
Edged Faces
Transparency ]

v Show Grid
Shiow Backaround
Show Safe Frame

Viegwpart Clipping
Texture Correction
Disable Yiew

Unda Wigw Rotate
Reda

Configure. ..
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2. Select Wireframe from the menu. The chairs now appear as lines, just as they do in the other
viewports.

3. Change the User viewportback to a shaded mode by selecting Smooth + Highlights from the
viewport label right-click menu.

4. Right-click the Perspective viewport label. Then select Wireframe from the pop-up menu.
The perspective view changes to a wireframe representation.

Notice that the pop-up menu is the same for both the User and Perspective viewports. This
menu gives you control over the display characteristics of the viewport. Try out a few other options
in the Viewport pop-up menu.

1. Right-click the User label, and then select Views > Perspective. The User viewport changes
to a Perspective viewport. Notice that the label changes to read Perspective, so that you now
have two Perspective viewports.

4~ 40
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2. Right-click the Perspective label of the upper left viewport, and then select Views > Top. The
view now changes back to the original top view. Notice that the chairs are still shaded.

3. Right-click the Top label and select Wireframe

Now all the viewports show wireframe views of the chairs. Wireframe views are often better for
many types of editing operations. Wireframes also redraw faster when your model is very large
and full of complex geometry. Another type of view, called bounding box, is even faster than a wire-
frame view, but bounding box views reduce the representation of objects to rectangular boxes. The
Edged Faces mode, available when the viewport is in any of the available shaded modes, displays
both the shaded mode and the edges of the visible objects.

Besides changing the way the viewport displays your model, wireframe view also gives you
control over the layout of the viewports themselves. The following exercise shows you the variety
of layouts you can create in VIZ.

1. Choose Customize > Viewport Configuration. The Viewport Configuration dialog box

displays.
2=l
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2. Click the Layout tab. You see the current viewport layout. Above it is a set of predefined
layouts.

3. Click the layout that looks like three small rectangles stacked on the left side with one large
rectangle on the right.

4. Click OK. The viewports change to the selected layout.

5. Click the Zoom Extents All button to zoom all viewports to show the contents of
B the scene.
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You aren’t limited to the canned layouts either. You may decide that you want the layout to
reflect a more traditional mechanical drawing layout, with a top, front, and right side view. Here’s
how you can set up such a viewport arrangement:

1. Choose Customize > Viewport Configuration.

2. With the Layout tab selected, click the layout showing four equal viewports, which is the
rightmost layout in the bottom row of layout options.

Viewport Configuration - EHE|
RenderingMethod | Lapout | SaleFrames | Adeplive Degadstion | Regons |
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3. Click the sample viewport labeled Front in the upper right corner of the large sample layout
and select Perspective in the pop-up menu.

Viewport Configuration M
Rendesng Hethod |me| SefeFiomes | Adepivelegiedatin | Regiors |

Espon
selach Vi

4. Click the sample Perspective viewport in the lower right corner and select Right from the
pop-up menu.

5. Click the sample left viewport in the lower left corner and select Front from the pop-up menu.

6. Click OK, then click the Zoom Extents button. Now you have a layout that shows the top,
front, and right views, plus a perspective view, arranged in a more traditional manner. The
sample layout should now look like Figure 1.20.

As you can see from what you've learned so far, Autodesk VIZ 2007 provides a wide array of dis-
play options, but most of the time, you'll stick with one viewport layout that you are comfortable with
and use the Maximize Viewport Toggle to swap between a single and a multiple viewport layout. For
the purposes of this book, you'll use the default layout that shows the four equal-size viewports.

FIGURE 1.20
The four-viewport lay-
out with modifications
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Before you conclude your tour of the VIZ interface, let’s see how the Move tool acts in the non-
Perspective viewports. The following exercise will give you a feel for the ways that you can use
multiple viewports.

$ 1. Click the Select and Move tool.

2. In the Top viewport, click and drag the cursor from a point below and to the left of the
bottom row of chairs.

3. Drag theselection rectangle around the two chairs in the lower row, so that they are enclosed
in the rectangle. The two chairs are selected.

4. Right-click in the Right viewport.

TIP By right-clicking in a viewport, you can make it active without disrupting any selections you
may have active at the time.

5. Inthe Right viewport, click and drag the green Y arrow upward. Notice how the chairs move
in the Right, Front, and Perspective viewports as you do this.

6. Position the chairs so they are higher by about one-half the height of a chair.

7. Click and drag the red X axis of the chairs to the right of the screen, so they merge with the
chair to the right, as shown here.

8. You can save or discard this file. You won’t need it anymore.

- @



%I% é 72725book.fm Page 52 Tuesday, August 15,2006 6:12 PM

52 CHAPTER 1 GETTING TO KNOW VIZ

In this exercise, you've seen a number of methods in action. First, the Select and Move tool can be
used to select objects as well as move them. This can help you move objects quickly by reducing the

number of clicks. But be careful, or you might select and move the wrong object when you're in a hurry.

You also saw how you can right-click in a viewport to make it active. Had you simply clicked
in the Right viewport in step 4, you would have lost the selection set you created in step 3.

Finally, you saw how objects in VIZ don’t conform to one of the basic rules of physics. In VIZ,
more than one object can occupy the same space at the same time. This characteristic can be useful
in a number of ways as you build models in Autodesk VIZ 2007.

Working with the Custom Ul and Defaults Switcher

The Custom Ul and Defaults Switcher provides an easy and unified method for managing all
the myriad preference settings within VIZ 2007. Let’s explore what the Custom Ul and Defaults
Switcher has to offer.

1. Choose Customize » Custom UI and Defaults Switcher.
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lﬁ, “ustomize Lser Interface. .

Load Custam UL Scheme
Save Cusbom LIl Scheme
Rzyett bo Stamun Layous

Custom LT and Def aults 5

Shiows LT

Lok LT Layaut

Canfigure User Paths...,
“Configure System Paths..
ks Setup,.,

i and Snap Satings...
Vit Configuration, .

Plugen Menager...

Praferences...

2. Click the DesignVIZ initial settings for tool options in the upper left of the dialog to see the
settings listed in Figure 1.21.

FIGURE 1.21
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3. Scroll down in the dialog box and read through the changes that the DesignVIZ settings rep-
resentin the HTML file that is part of the Custom Ul and Defaults Switcher dialog box. There
are two initial settings for tool options: DesignVIZ and DesignVIZ.mentalray.
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The DesignVIZ settings are configured to provide you with good rendering performance
in large scenes with many lights; this assumes you’ll be using the radiosity renderer and
photometric lights.

The DesignVIZ.mentalray initial settings are meant to be used in conjunction with the mental
ray renderer. Each of these settings automatically configures multiple preferences in layers: the
Material Editor, Lights, Daylight System, Rendering, Cloning, Select by Name, i-drop, Inverse
Kinematics, and Viewport Shading.

NOTE See Chapter 11 to learn more about the radiosity renderer and Chapter 12 to learn how to
use the mental ray renderer.

If you have already saved custom Ul schemes, you will see them listed on the right side of the
Custom UTI and Defaults Switcher dialog box. Here, you can conveniently select which Ul scheme
you’d like to use. Ul schemes hold in one place all the customization you can make to the keyboard
hotkeys, toolbar, quad menus, standards menus, and color schemes. To make changes to an exist-
ing Ul scheme, you'll use the Customize User Interface dialog box.

1. Choose Customize > Customize User Interface to display this window.
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2. Click each of the tabs at the top of this dialog to become familiar with all the ways you can
customize your user interface (changes can be made to the keyboard, toolbars, quads,
menus, and colors). If you do decide to make any changes, simply click the Save button on
the tab within this dialog box to record your specific changes to disk.

3. Choose Customize » Save Custom UI Scheme. Open the Save As Type pop-up. You will
notice five different file formats that can be saved (and loaded) through Save (and Load)
Custom UI Scheme from the Customize menu. Each one of the lower four formats—UI File
(*.cui), Menu File (*.mnuy), Color File (*.clr), and Shortcut File (*.kbd)—correspond to each of
the tabs in the Customize User Interface dialog—Toolbars and Quads, Menus, Colors, and
Keyboard, respectively.

[ — e —— j 2%
| « @& of =

File name: [zt i =l 5“_|

Save 4z bpe: |Inleiface Schemel* ui ll L

When you choose to save the first format in the Save Custom UI Scheme dialog (Interface
Scheme format), you are saving a composite file that contains all the customization present
in all the other formats combined. It is this Interface Scheme format (*.ui) that is displayed
in the UI Schemes portion of the new Custom UI and Defaults Switcher.

Summary

In this introduction to Autodesk VIZ 2007, you've learned how to use the many different tools
available in VIZ. You saw how some tools work in familiar ways, while others, like the spinners and
rollouts, are a slight departure from other typical Windows programs. You were also introduced to
some of the basic object-creation and editing methods in VIZ. These basic methods are the founda-
tion on which you will build your skills in this program.

You've covered a lot of ground in this first chapter. Don’t worry if you can’t remember everything.
You'll be exposed to many of these tools frequently as you work through the following chapters. In
the next chapter, you'll take a closer look at how objects are created and edited.




