UNDERSTANDING COLOR
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“In my mind’s eye, | visualize how a particular . . .
sight and feeling will appear on a print. If it excites
me, there is a good chance it will make a good photo-
graph. It is an intuitive sense, an ability that comes
from a lot of practice.” — Ansel Adams

We've all heard about a hundred different definitions
of color as it pertains to digital images and computer
monitors, and what’s not needed is another chapter to
rehash all the stuff you already know. But just in case
we aren’t in sync with our definitions, let’s talk a little
about some of the more important aspects of color in
images and a little about general color management
that we should clearly understand together. Beginning
with creating the best color correction environment to
some basic understanding of digital images, let’s
move forward to get a handle on a few basic princi-
ples. Pull up a chair next to the fireplace, grab a latte,
and let’s sit down and agree on some understanding
of color and how to manage color in Photoshop.

UNDERSTANDING WHAT You NEED FOR
| Goob CoLOR HANDLING

|Without getting into the technical aspects of view-
ing color, looking at reflective versus subtractive
color, examining the anatomy of your eye and all the

other scientific rules and axioms related to color view-
ing, there are some essential ingredients you need to

become familiar with when it comes to color viewing,
color correction, and printing correct color.

Quite simply, the most important of these ingredients
include

> Controlled lighting. One of the most commonly
overlooked areas related to good color viewing
conditions is carefully setting up your viewing
environment (see Figure 1-1). If you work on a
super professional color monitor, have your moni-
tor tweaked with a $5,000 color calibrator, and
use the most sophisticated color profiles, you're
only halfway to color correction. If light coming
through your window and your overhead lights
results in a colorcast on your monitor, you’re not

working in an optimum viewing environment. The
first consideration you need to make is controlling
the lighting of your workplace.

> Monitor calibration. You’ve heard it all before,
and we repeat it here — you need to be certain
your viewing device reflects the best possible
brightness and gray balance that you can get. On
the low end, you can purchase some inexpensive
calibration equipment; on the high end, you can
purchase some very sophisticated calibration
tools. At some point, you need to use a device to
get your monitor to display the best you can get
in terms of brightness and gray balance, as we
explain in Chapter 2.

> Color profiles. You have options for using source
color profiles, viewing profiles, and output profiles.
Getting your color translated from one device to
another is always an important consideration when
getting color right.

| PIXELS AND RESIZING IMAGES

|Since you’ve been around pixels for a long time,
you pretty much have an understanding that those
tiny little squares all bunched together ultimately com-
prise the makeup of a digital photograph. You know
that the number of pixels in one way or another relate
to image quality. Furthermore, you’re certain that no
matter how many pixels you have in an image, the
quantity of those tiny little dots doesn’t have a darn
thing to do with improving color. We have to manipu-
late, finesse, and mess around with those pixels to
balance the color.

PIXELS AND DOTS

Wouldn'’t it be a great world if an input dot, a viewing
dot, and an output dot were all at a 1:1 ratio? In other
words, you see a bright red pixel, you shoot a photo-
graph and capture the hues precisely, you see the
same bright red color on your monitor, and you print
the photo resulting in a print that shows that red pixel
exactly as you saw it before taking the picture.



Unfortunately, digital life is not so easy, and a caveat
is always thrown into the mix. The imbalance of dots
related to different devices is one of many factors that
confuse us when it comes to image color correction
and preparing files for various output devices.

You might have a color printer capable of rendering
1440 pixels per inch (ppi) of resolution. Your input
image (obtained from a scanner or digital camera)
might be a 300-pixel-per-inch image file. When it
comes time to open your image in Photoshop, you're
working on a 72-pixel-per-inch display. What’s more
confusing is that the output resolution on your printer
is really a lie. Take an Epson color printer, for exam-
ple, that renders a 1440 ppi resolution. Does that
mean you need 1440 pixels in your image to take full
advantage of your printer? The answer is definitely
NO. The reason being is because the printer fires off

microscopic droplets of ink in at least four colors
(Cyan, Magenta, Yellow, and Black) or more to give
you the illusion of continuous-tone color. These many
droplets define each pixel in terms of color and
brightness.

If you prepare images for commercial printing on film
setters and plate setters, resolutions of the equipment
can exceed 2500 pixels per inch. Again, your image file
at 300 ppi is plotted in dots, and each dot is formed by
many smaller dots to create all the gray tones needed
to reproduce the file at a specified halftone frequency.

| X-REF |

For a little more understanding of what we mean

by gray tones in color images, see the section
later in this chapter “RGB Color.”
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PIXELS AND IMAGE SIZES

Digital cameras are marketed, with among many other
features, the total number of pixels the camera’s sensor
is capable of capturing. You hear numbers such as 6.3
megapixels, 7.2 megapixels, 11 megapixels, and so on.
These figures describe images captured with the total
number of pixels per image. When you first open a dig-
ital camera image, the resolution of the image may be
72 ppi. As a result, you need to resize the image to the
correct proportions for your desired output; when you
do, the image resolution increases proportionately.

_NOTE  _[| | i

Some digital cameras saving in JPEG format
default to 72 ppi at dimensions producing the
total pixels captured by the camera sensor.

Cameras capable of saving files in Camera Raw
format typically save with higher resolutions also
at the dimensions that produce the total pixels
captured by the camera sensor.

As an example, follow these steps to resize an image
without affecting the resolution:

1. Open an image taken with a digital camera in
Photoshop CS2.

2. Choose Image => Image Size or press
Command/GCtrl+Option/Alt+l to open the Image
Size dialog box (see Figure 1-2).
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3. Type a new number in the Resolution box to
change the resolution. Leave the Resample Image
checkbox deselected when changing the image
size. As you increase the amount in the Resolution
text box, the values change proportionately in the
Width and Height text boxes. The more resolution
you add to the Resolution text box, the lower the
values appear in the Width and Height text boxes.

Individually resizing images works well when color
correcting a single image or maybe just a handful.
However, if you've filled up your memory card and
need to size many files, it's best to use an automated
Action when files need to be the same size.

CREATE AN ACTION FOR RESIZING IMAGES

To create an Action for resizing images, follow these
steps:

1. Open an image taken with a digital camera in
Photoshop CS2. Start with one image open in
Photoshop to create the action.

2. Choose Window => Actions if the Actions palette
is not currently open.

3. Click the right-pointing arrow to open the Actions
palette menu and select New Action (see Figure 1-3).

4. Choose Image => Image Size or press Command/
Ctrl+Option/Alt+l to open the Image Size dialog box.

5. Type the resolution value you want for a batch
of images and then click OK in the Image Size
dialog box.

6. Choose File => Save As and select the format you
want to use for the file from the Format drop-down
menu. Click Save to save the file.

7. Close the file by clicking on the Close box or
choosing File > Close.

8. Click the Stop playing/recording button in the
Actions palette. At the bottom of the Actions
palette you see a row of tools. The first tool in
the palette, represented as a square, is the Stop
playing/recording button.
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NOTE

Try to avoid resaving files as JPEG if you happen
to open JPEG images. Each time you save a file
as JPEG, you lose more image data. Use a loss-
less compression format such as Photoshop
(PSD) format or TIFF when saving your files. If
your files need to be saved in JPEG format, per-
haps because JPEG is the preferred format for
your photo lab or service center, save as JPEG
with the Quality setting at the maximum (12) when
saving the final file.

PLAY AN ACTION

When it comes time to use your action, follow these
steps:

1. Choose File => Automate => Batch to open the
Batch dialog box shown in Figure 1-4.
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You can create a new group and nest all your own
custom actions in the group. First, select New Set
from the palette menu and the Name dialog box
appears. Type a name for your new group and
click OK. The new group appears as a folder in the
Actions palette. To nest a new action below the
folder name, click the new group folder to select
it. Open the palette menu and choose New Action
when you want to create an action. All your actions
can then be grouped together in your new folder
apart from the default actions Photoshop pro-

vides you.

After you click the Stop playing/recording button the
Action is listed in the palette and ready to use on a
folder of files. Be certain to copy all your files from
your memory card to your hard drive and place them

in a single folder.
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2. From the Set and Actions drop-down menus,
select your Set (if you created one) and select
the new action you created to resize images.

3. Click Choose under the Source item in the Batch

dialog box to open the Choose a folder dialog box.
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4. Navigate your hard drive in the Choose a batch
folder dialog box to locate the folder where you
saved the images from your media card. Select
the folder and click Choose to return to the Batch
dialog box.

5. Click Choose in the Destination area. Follow the
procedures in step 4 to specify the folder where
you want to save the resized images.

If you need to create a new folder for your saved
images, you can click Choose and click New
Folder in the Choose a batch folder dialog box.

6. Click OK.

Photoshop automatically opens files in the source
folder, resizes images according to settings you
supplied when you created the action, saves the
results to the destination folder, and closes each
file after saving.

RESAMPLING IMAGES

Going back to the Image Size dialog box, if you select
the Resample Image check box you change the number
of pixels in an image to a value higher or lower than
the total pixels you started with depending on what
values you type in the Resolution box. For example, if

Bicubic

Bilinear

you size an image at 6 x 4 inches with the Resample
Image check box deselected, the resolution may
increase to 600 pixels per inch. At this point, the total
pixels in your image remain the same. Check the
Resample Image check box and change the resolution
to 300 ppi. When you click OK, half the pixels in the
file are tossed away and the image is said to be
downsampled, which means the resolution is lowered.

Ideally, plan on downsampling images to the optimum
resolution of your output device. In terms of color
printing on continuous-tone devices, 300 ppi can gen-
erally be applied to most color printers.

Quite often you’ll need to downsample digital photo
images. When you select the Resample Image check
box in the Image Size dialog box, the drop-down menu
adjacent to the check box offers five resampling modes.
The default is Bicubic, and for most of your continuous
tone images, this is the mode to choose. In Figure 1-5
you can see the results of using the Bicubic method
compared to using Bilinear and Nearest Neighbor.

Nearest Neighbor



The other two options, Bicubic Smoother and Bicubic
Sharper, are helpful when sampling images such as
portraits or photos that need some sharp detail. Use
Bicubic Smoother when downsampling portraits
where facial features are rendered a little smoother.
Use Bicubic Sharper when you want sharper detail like
when shooting aerials or architecture.

[PROTIP _[| | |

When in doubt, however, use Bicubic and be done
with it. Other modes use different algorithms to

calculate new pixel values, but none works better
overall as a default than the Bicubic method.

Bicubic is always superior to Nearest Neighbor or
Bilinear for general use with photographic images

UPSIZING IMAGES

As a general rule, upsizing images by adding more
resolution to a file often produces undesirable results.
Too much upsampling can make your image look like
mush. Photoshop uses an algorithm to calculate new
pixels based on the values of the original pixels and at
best produces a guess at what those pixel values
should be. Sometimes the result of the guesswork is a
less-than-desirable image.

| .

GF PRINT PRO UPSAMLED 400%

There are some circumstances, however, where upsizing
images can be helpful. The results may or may not be
desirable, so you have to run tests and print samples to
see if your resampling efforts are satisfactory. A good
example might be a digital camera image that needs to
be printed as a large poster. If the output of the original
file is pixelated, you can try to upsample the image and
print a small area of the photo to test the results.

_LNOTE || | |

Photoshop’s algorithm for resampling images
has improved over the years and offers you some

impressive results. In Photoshop CS2, the Bicubic
method of resampling is more impressive than
found in earlier versions of the program.

For a more sophisticated approach to resampling, you
can acquire a Photoshop plug-in designed to resample
images. Genuine Fractals is a product developed by
onOne Software (www.ononesoftware.com)
designed exclusively for the purpose of upsampling
images. In Figure 1-6, you can see the results of
upsampling an image 400 percent using Genuine
Fractals. The original image appears in the center

v
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inset. On the right is a close-up of the file upsampled
in Photoshop using Bicubic resampling, and Genuine
Fractals upsampling on the left.

Whether you use Photoshop or a plug-in like Genuine
Fractals, don’t expect to take a wallet size image at
72 ppi from your Web page and upsample the image.
You need to start with a file that is at leasta 4 x 6
inches at 300 ppi or greater for best results and keep
the resizing of the image to within certain sizing limi-
tations such as 800 percent or less.

| UNDERSTANDING COLOR MODES

| hotoshop supports working in, converting to, and
saving files in a number of different color modes.
For digital photographers, the default and most popu
lar color mode is RGB. In addition to RGB, you can
convert to other color modes for editing images or
submitting files to clients for various types of output.

You don’t need to be concerned with every color
mode Photoshop can handle. Most often you’ll work
with one of four color modes that include RGB,
CMYK, Lab, or Grayscale.

RGB coLor

You’re probably familiar with the standard RGB color
mode that you see when viewing color images on
your monitor, take color photos with your digital cam-
era, or scan pictures with your scanner. RGB is the
default color mode for working on color images and
correcting color.

Color in Photoshop is represented in channels. In an
RGB color image, you have three channels — one for
red, one for green, and one for blue. When you open
the Channels palette and look at each of the three
RGB channels, you see various levels of gray. The
RGB composite channel is seen as color, but the three
individual channels are seen as white, gray, or black
depending on the color represented in the composite
channel (see Figure 1-7).

Each of these three channels can be changed for color
value and brightness. Whatever change is made on the
individual channels is reflected in the composite
image. If you use Photoshop tools for correcting color
and brightness, most of your correction tools offer
options for selecting the composite image where you
make changes to all three channels simultaneously, or
you can make changes to a selected channel. In Figure
1-8, a curves adjustment is made on the Red channel.

You have options for adjusting individual channels in
other dialog boxes, t0o, such as Levels and Channel
Mixer.

CMYK coLor

CMYK color is process color using mixes of Cyan,
Magenta, Yellow, and Black. If your digital photography
is limited to output for photo prints and Web graphics,
you don’t need to be concerned about CMYK. However,
if you prepare files for commercial printing at print
shops, CMYK is something you need to understand.

Whereas RGB encompasses a large color gamut rep-
resenting more that 16 million colors on your color



monitor, the CMYK model offers you fewer colors that
can be seen on your monitor and reproduced on a
printed piece. Regardless of whether you output RGB
or CMYK files, your working environment stays in
RGB color and all your color correction is performed
on RGB images.

What is important when editing images for CMYK out-
put is to be certain you see the color as closely as pos-
sible to what will be rendered in CMYK. While editing
in RGB mode, choose View = Proof Setup = Working
CMYK. Your monitor then displays colors more closely
to the CMYK color gamut.

LAB COLOR

Lab color, like RGB color, represents color images in
three channels. These channels are L or Lightness
channel, and the a channel and the b channel. The L
(Lightness) channel represents all the brightness in
your image while the a and b channels represent all
the color. The entire color spectrum is split in half with
each of these two channels taking one-half of the full
color spectrum.

When it comes to editing Photoshop images for color

and brightness, you can use Lab color when you want

to make changes without affecting the color in the
image. For example, you might convert an RGB image
to Lab color and select the L (Lightness) channel in the
Channels palette (see Figure 1-9) or press Command/
Ctrl+1. After selecting the Lightness channel, you
might sharpen an image using the Unsharp Mask filter.
Doing so sharpens the image without changing color.

GRAYSCALE

Grayscale images are single-channel files with only
a Gray channel. Grayscale images have no color, and
in order to add a color tint to an image, such as a

Color Correction in Photoshop versus Photoshop Elements

Throughout this book are screen shots and
references to Adobe Photoshop with little
mention of Adobe Photoshop Elements 4.
Elements is a truly great image-editing
tool that provides an abundant number of
features for editing and printing your digi-
tal photographs. Many cameras ship with
Elements on a CD-ROM so you may get the

program free with the purchase of your
camera.

Unfortunately, Photoshop Elements doesn’t
have some critical editing tools for cor-
recting color and brightness that are avail-
able in Photoshop. Among other features,
Elements does not provide you a Channels
palette where you can edit individual
channels. The channels are there and visible
when you open a dialog box like the Levels

dialog, but you can’t edit individual chan-
nels with other editing tools. Nor does
Elements support a Curves dialog box that
provides you with more brightness control
than you get with the Levels dialog box.

In addition to the lack of editing features
for channels and curves, Elements does not
support much in the area of color profil-
ing. You only have two choices when man-
aging color using either the Adobe RGB
(1998) color space or sRGB. Custom profil-
ing is not part of the program.

Due to the lack of these critical tools, we
recommend that all serious digital photog-
raphers who want the most out of color
correction avoid using Elements and stick
to Photoshop.

v

1y3ry 4010 Bunye9

11



10)0) Suipuelsiapun I

sepia tone, you need to convert the grayscale image
to RGB color.

If you are printing a black-and-white photo, you may
get better results on some equipment by first convert-
ing the grayscale image to RGB color. On some other
printers, you might be best leaving the image in
Grayscale mode.

.l L X-REF ||

For information on working with grayscale images,

see Chapter 8. For information on printing grayscale
images, see Chapter 11.

| UNDERSTANDING BIT DEPTH

12

|As we previously explained, your color images

are represented in three channels. Each of these
channels contains a level of gray to express any given
color. Essentially, the gray values block out or hold
back light. A level of 0 in each channel means no light
passes through each channel resulting in a black
image. Conversely, a level of 255 is wide open and lets
all light pass through resulting in a pure white image.

l LNOTE _|| | |

The number 255 is a figure you want to remember.

Because 0 (zero) is a number, too, there are a
total of 256 levels of gray in an image.

When you work with 256 levels of gray for each chan-
nel, you are working on an 8-bit image. If you take
256° (256 x 256 x 256), the result is a number in
excess of 16 million, which is the total number of col-
ors in the RGB color gamut. When it comes time to
reproduce your images on a printer, the printer outputs
your file from 8-bit images in an effort to reproduce as
many of those possible 16.7 million colors as it can.

If you use a digital camera capable of capturing
Camera Raw images, your camera sensors are likely

to capture 12-bit or higher images — the most com-
mon higher bit being 16-bit. A 16-bit image has 4096
levels of gray per channel. This extra data permits you
to decide which 256 levels of gray ultimately are used
on your final printed piece. In Figure 1-10, for exam-
ple, the Levels dialog box is opened on an 8-bit image.
The left side of the histogram reports no data showing
on this side, which means there is no detail in the
darker areas of the image.

Because your printer can only print 8-bit images, the
extra image data is tossed during printing. However,
when you edit an image for brightness and color cor-
rection, you want to perform as much of your editing
as you can while in a higher bit mode. Having the
extra data in an image lets you decide which 256 lev-
els of gray from the 4096 levels will be used when
printing the image.

Figure 1-11 shows the Levels dialog box for a 16-bit
image with data across all 256 levels of gray. You can
skew the input sliders on this image to the left or right
to pick up a little more detail in either the highlights or
shadows. In essence, you are telling Photoshop which
levels of gray you want to reproduce.
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For more information on using the Levels dialog

box to adjust brightness and contrast, see
Chapter 4.

|UNDERSTANDING DYNAMIC RANGE

| D ynamic range is the measure of capturing data in

the highlights and shadows. If your images are
clipped (showing no data on either end of a histogram),
the dynamic range is much less than a photo captured
where you see a histogram containing data at both
ends and all through the midtone areas.

Input devices such as cameras and scanners are cate-
gorized in terms of dynamic range as well as output
devices. Looking at a digital camera, you can find
many point-and-shoot models that boast more than

7 or 8 megapixels that cost less than $500. You can
also find digital cameras in the 4- to 6-megapixel area
that cost more than $2000. One of the primary differ-
ences between the cameras is the dynamic range of
the sensors. Obviously, the more costly cameras pro-
vide you a greater dynamic range, which means you
see much more detail in the shadows and highlights.

ADDING MORE IMAGE DATA

If you use a digital camera capable of capturing
images at higher bit depths with a dynamic range suf-
ficient for capturing details in shadows and highlights,
you can’t always get all the necessary data you need
to produce a good quality print. You have to consider
lighting conditions and the amount of available light
you have to work with. At times, there won’t be enough
light to get all the detail you want in shadow areas, and
the light may be too much to get any detail in highlights.

If you do photo reproduction and copy work, you’re
stuck with the dynamic range as it exists on your
source material. Old photographs that may be washed
out don’t provide you with a good quality image to
obtain a quality copy no matter how good your cam-
era may be.

Photoshop has a few tricks that can help you improve
dynamic range and add more data to a file. In the case
with photocopy work, take an antique or aged photo
that appears washed out and shoot the print with your
digital camera. To add more data, follow these steps:

1. Open an image that appears washed out in
Photoshop.

2. Open the Layers palette and drag the Background
layer to the New Layer icon to duplicate the layer.

3. Open the Layers palette mode menu and select
Multiply (Figure 1-12).

The top layer appears darker as the Multiply mode
takes all the black on one layer and adds it to all
the black on the second layer. Note that you can
change the Opacity on the top layer to control the
amount of darkening you want in the composite
image by dragging the Opacity slider left and right.
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\PROTIP || |

Using the AutoContrast adjustment when working
with 16-bit images can accomplish similar results
as described in these steps. If you have 8-bit
images, follow the steps outlined here.

v
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4. Open the palette pop-up menu and select Flatten
to flatten the layers.

5. Adjust Levels and Curves to optimize the brightness.

6. Compare the results of the edited image to the
raw image you opened in Photoshop.

In Figure 1-13, you can see a comparison of the
image before and after following the steps out-

lined here.
)
wl L ‘m =
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.| | X-REF ||

For information on using Levels and Curves, see
Chapter 4.

.l [PROTIP L[ | |

If you have a portion of an image that needs to be
darkened, use the Lasso tool and create a selec-
tion where you want to improve contrast. Choose
Select => Feather to open the Feather dialog box.
Type a value to add a large feather to the selec-

tion. The amount of the feather depends on your
image size and resolution so you may need to
test it a few times. Start with at least 20 pixels
for your feather radius. Click OK and press
Command/Ctrl+J to duplicate the selection as a
new layer. Select Multiply from the Mode pop-up
menu and only the selection is darkened.

IMPROVING CAPTURED DYNAMIC RANGE

In a controlled shooting environment, you have another
option for adding more data that will improve the
dynamic range in your photos. This method requires
you to use a tripod, and your subject matter should
be still with no visible motion such as people walking,
automobiles passing, or sporting events action shots.

A super-wide captured dynamic range cannot be
reproduced on any known hardcopy output device,
but this option retains all the captured tonal data,
allowing the user to manipulate it later in the editing
process to fit the output device, without clipping
shadows or highlights.

To improve dynamic range where the lighting condi-
tions may not be optimum to capture sufficient detail
in shadows and highlights, you need to take three to
five photos of the exact same image at different expo-
sures then merge them together in Photoshop. Follow
these steps to see how to do it:

1. Take a photo using your tripod, then change the
Exposure Value (EV) one to two stops to over- or
underexpose the image and take a second photo.
Repeat the process of changing EV to one to two
stops again in the opposite direction producing at
least one underexposed and one overexposed
photo along with your original photo.

The photos you use can be either 8-bit or 16-bit
images. The Merge to HDR command ultimately
creates a 32-bit image after you run the command. If
you reduce the image bit depth after converting to
32-bit, some clipping is likely to occur and you lose
a little tonal range when dropping the bit depth.

2. Add your photos to Adobe Bridge so you can
clearly see the thumbnails of each photo.

3. In Adobe Bridge, choose Tools => Photoshop =>
Merge to HDR (see Figure 1-14).

You can also use the Merge to HDR command in
Photoshop if you don’t have the files displayed in
Adobe Bridge. Choose File = Automate = Merge
to HDR.



Label View Window Help

Batch Rename... {r#R
1 Version Cue >

Photoshop Services >
_Photoshop > [T

Illustrator Contact Sheet Il...

Image Processor...

»
>
| Werge to HDR..
Cache > ;
»
»

InDesign

PDF Presentation... ©
Append Metadata Photomerge...
Replace Metadata Picture Package...

1 Web Photo Gallery...

1-14

1 second@F-22 1/4 second @F-22

1/15 second @F-22

4. Wait a few minutes for Photoshop to process your
image and view the results in a new Photoshop
document window. Photoshop merges all the data
from the individual images and effectively increases
the dynamic range. If you expose for shooting
shadows, shoot for properly exposing highlights,
and the third shot for the midtone ranges, the
Merge to HDR command combines the dynamic
range from the images to provide you with ample
data in the shadows, highlights, and midtone
areas. In Figure 1-15, you can see the five images

we started with and the end result after merging
the photos.

1/60 second @F-22 1/250 second @ F-22
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Don captured the river scene in Figure 1-15 with a

12 f-stop range from bright sun to deepest shadows.
This type of capture is near impossible with negative
film, but Photoshop’s Merge to HDR ultimately creates
a composite image with a rich tonal range. The overall
image sharpness suffers a little because a slight breeze
moved the trees a bit. Printed at 5 x 7, it’s hardly
noticeable, but larger prints show a slight lack of
crispness in the trees.

UsING COLOR PROFILES

You have two major issues to deal with when it
comes to managing color. One is your eye and
how you see color, and the other is your hardware
and how color is seen and interpreted by all your
devices. When it comes to you seeing color, you need
to be concerned with controlling light and setting up
your monitor for the best viewing conditions. With
respect to devices, you need to be concerned with the
capture device — in this case, your digital camera —
and the output device.

X-REF |

For viewing color and setting up your color-
viewing environment, see Chapter 2.

Color is managed on devices through the use of color
profiles. Color profiles are data files used by your
devices, and color profiles in your Photoshop images
are lines of code added to the image files. One of the
most important uses of color profiles is for translating
colors from one device to another so that you are
assured of, as closely as possible, colors ultimately
appear the same across all your equipment. The oper-
ative here is translation, and it’'s important to know
that quite often you need to convert color from one
source to another.

MONITOR COLOR PROFILES

You'’ve probably read much about the fact that color
viewing and management is not an exact science and
you can’t expect to get color precisely the same
between your monitor and your output. This is true,
but what we expect is to get things pretty darn close
where the anomalies between various sources han-
dling color are very subtle and have little effect on
how you properly view and manage color.

When it comes to viewing color, the viewing device
needs to be calibrated, and the result of your calibration
efforts is creating a monitor profile. Essentially, this
means quite simply that when you turn your computer
on, your operating system loads the monitor color
profile with all the settings used to calibrate your
monitor into memory so you see the same monitor
brightness each time you start working in Photoshop.

A monitor color profile doesn’t have a direct impact
on your Photoshop image and printing the file.
Monitor profiles are simply used to be certain that
your monitor has the correct brightness, absence of
colorcasts and color tints, and displays your photos
on-screen with colors as true as possible.

_ X-REF ||

To learn how to create a monitor color profile, see
Chapter 2.

CRT versus LCD MONITORS

LCD (liquid crystal display) monitors are the rage
today and with prices continually dropping, more peo-
ple are discarding their traditional CRT (cathode-ray
tube or television-type) monitors in favor of the much
smaller footprint of the LCD monitors.

If you want the best viewing conditions for correcting
color in Photoshop, resist the temptation to purchase
an LCD monitor. The color clarity of CRTs cannot be

matched by any LCD screen produced today. Among



other things, you have a number of different adjust-
ments you can make on CRT monitors for changing
contrast, brightness, and hues. The end result is that
CRT monitors are better able to represent actual doc-
ument colors. In many cases you can purchase a
super-quality CRT monitor at much less cost than an
average-priced LCD monitor.

If you’re a color professional, stay away from the
LCDs (see Figure 1-16) and buy a good-quality CRT
display. It’s the tool of choice for color specialists.

_ X-REF ||

For more on CRT monitors, see Chapter 2.

COLOR WORKSPACES

If there’s a monkey wrench in the color-management
process, it’s the confusing idea of knowing that you
have a monitor color profile and a color working pro-
file. Color working profiles define your color workspace
that impacts how your image color is translated
between different color monitors and viewing

conditions. If, for example, you want to exchange a
file with another user, you embed (or save your pro-
file) with the color workspace you use. The recipient
of your file may use another color workspace, in
which case the user might convert your image from
your color workspace to his or her workspace.
Through this conversion, the color is translated as
near as possible to maintain as much of the same
color from your original workspace to the converted
color workspace.

Photoshop provides you with two primary color work-
spaces when you install the program. In Photoshop,
choose Edit &> Color Settings. The Color Settings dia-
log box appears. Click the RGB item in the Working
Spaces area of the dialog box, and you see prein-
stalled color profiles as well as any custom profiles
you create or import (see Figure 1-17).

> Adobe RGB (1998). The first of the two primary
workspaces used by most photographers and
artists is Adobe RGB (1998). This workspace
is popular with anyone who prepares images
for some form of print output. This workspace
provides a wide range of RGB colors that theoreti-
cally can be reproduced on a printing device.

v
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> sRGB. The official name for this profile is SRGB
IEC61966-2.1, but most of us commonly refer to
it as simply sRGB. This workspace is designed for
use with images displayed on monitors such as
Web viewing or images intended for screen pre-
viewing. The color gamut can display some colors
that may not be reproduced on some printing
devices.

You may hear some people recommend that you
stay away from sRGB when preparing files for
print. However, don’t completely dismiss this
workspace when sending your files off to a photo
lab. Some photo-reproduction equipment that
prints in RGB (not CMYK) may take advantage of
the full SRGB color gamut.

| X-REF |

For information on when to use sRGB for output,
see Chapter 11.

CAMERA COLOR PROFILES

Digital cameras can also capture your images while
embedding a color profile. The Canon 20D is capable
of embedding either Adobe RGB (1998) or SRGB
when capturing files saved as JPEG. The Canon 20D
lets you choose between the two profiles by adjusting
the camera’s settings.

If you want to quickly check to see if your camera
saves files with a color profile, open Adobe Bridge and
select a thumbnail of a photo taken with your camera.
Take a look at the Metadata pane, and you should see
Color Profile if your camera supports it. Figure 1-18
shows how the Metadata shows the selected image
has the sRGB color profile embedded in the image.

- sRCB IECE1966-2.1

Calor Profile
IPTC Core

OUTPUT PROFILES

Output color profiles are used by equipment to print
your photographs. Assuming you have set up your
working environment with the proper lighting, cali-
brated your monitor for the proper viewing of your
images on-screen, and identified your color workspace
in Photoshop’s (or Adobe Bridge’s) Color Settings
dialog box, you are viewing colors as true as possible
that can be reproduced on some device. Your color
then needs to be converted properly to the output
device so the entire range of colors as best as possi-
ble can be output when you print your pictures. This
is where the output profile comes in. Output profiles
are used to match the color you see on your monitor
to the printed piece.



Color Settings Adjustments in Adobe Bridge

Users of two or more of the CS2 applica-
tions may want to open Adobe Bridge
and choose Edit => Creative Suite Color
Settings. When the Suite Color Settings
dialog box opens, you can select a Settings
option that defines all your color work-
spaces. When you make a selection in the
Suite Color Settings dialog box, colors

across all your Adobe CS2 applications are
synchronized, meaning you use the same
workspaces when working in Photoshop,
Illustrator, InDesign, and Adobe GoLive.
Making your choice for color settings in
Adobe Bridge eliminates the need to
choose Edit => Color Settings in Photoshop
and all the other CS2 programs.

Suite Color Settings ]

Synchronized

Your Creative Suite applications are synchronized using the same
color settings for consistent color management.

software-products in North America,

MNorth America Prepress

Preparation of content for commaon printing conditiens in North America. CMYK
values are preserved. Profile warnings are enabled.

North America Web /Internet

Preparation of content for non-print usage like the World Wide Web (WWW) in
MNorth America. RGB content is converted to sRGB.

Photoshop 5 Default Spaces

Preparation of content using the default working spaces from Photoshop 5.

US. Prepress Defaults

Preparation of content for common press conditions in the US.

Web Graphics Defaults

Preparation of content for the worldwide web [WWW),

¥

™ Show Expanded List of Color Settings

| Show Saved Color Settings Files

Output color profiles are available to you in one of
three forms:

> Developer profiles. The printing device manufac-
turer may provide color profiles created specifically
for your equipment or equipment used by your
photo lab. You might acquire the profiles through
the developer’s Web site or directly from your
photo lab or service center.

> Custom profiles you create. If you have available
to you equipment capable of creating color profiles
directly from test prints on your equipment, you
can use your calibration equipment to create your
own custom profiles. This is particularly helpful
when printing to desktop printers.

Files

€ Apoly )

> Custom profiles developed by a service. You can
purchase color profiles for your equipment from
sources that you can find on the Internet. For a small
service fee, the service creates a profile for you and
sends you the profile in an e-mail attachment.
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What’s important for you to know before you plunge
into the other chapters in this book is that you need
to address all the issues here related to viewing
environment and color profiling. Attempting to print
your photos on any output device is a shot in the dark
if you don’t use color profiles and understand the
need for managing color throughout your workflow.

EMBEDDING COLOR PROFILES

When you edit a Photoshop image using a color
workspace that you established in the Color Settings
dialog box, you want to embed the working-space
profile in your image. Embedding a profile has several
advantages. First, if you exchange files with other
users or work between a Mac and a Windows machine,
your images can be converted to color workspaces on
other computers. Second, when outputting a photo to
a printing device, your workspace color can be con-
verted to the device profile. Finally, if you eventually
upgrade to another version of Photoshop where newer
profiles are introduced, you can convert your work-
space in legacy files to the newer profiles.

Photoshop offers you three options for embedding a
color profile in a image:

> Use the Save As dialog box. First, identify your
color workspace in the Color Settings dialog box,
then choose File = Save As to open the Save As
dialog box. Select the check box for Embed Color
Profile: (name of color profile to embed), as
shown in Figure 1-19. If you don’t see the check
box, you don’t have a Format selected from the
Format drop-down menu that supports saving
your file with an embedded profile.

> Use the Assign Profile dialog box. With an image
open in Photoshop, choose Edit => Assign Profile to
open the Assign Profile dialog box. The second
radio button reflects your current RGB workspace.
In Figure 1-20, the workspace is Adobe RGB
(1998). If you want to temporarily use another color
profile while working on the file, click the drop-
down menu adjacent to Profile shown in Figure

1-20. A list of all profiles appears in the menu. You
might use the Profile option and select a profile dif-
ferent than your current workspace. For example,
suppose you work in Adobe RGB (1998) and you
want to edit a file for Web hosting. You can select
SRGB from the Profile menu and click OK.
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The assign profile dialog box should be used with
caution. Its main purpose is to assign a profile to
a color file that was saved without a profile. If you
always use the Ask When Opening option in the
Color Settings dialog box, you’ll be aware of the
lack of a color profile when you open your file. To
change the color profile, use the convert option.
Assigning a profile that is not correct is a sure
way of ruining the color accuracy of your file.

> Use the Convert to Profile dialog box. Your third
option is to choose Edit = Convert to Profile. The
Convert to Profile dialog box shown in Figure 1-21
opens where you can see the current profile
assigned in Photoshop in the Source Space area,
and you can choose from the Profile a destination
space from the drop-down menu. Whereas Assign
Profile changes the current workspace and has
nothing to do with embedding the profile in your
document, this option actually changes the profile
in the document. You use the dialog box to actually
convert the pixels in your file to the destination
profile. When you choose File => Save As, the des-
tination profile appears by default in the Save As
dialog box. When you click Save, the profile is
embedded.

Convert to Profile ®
Source Space =
Profie: Adobe RGB (1998) _
Destination Space

s [ ereview

= %) |- Carvas.ice

Conversion Options

Engine: = Adobe (ACE) -

Intent: | Relathve Colorimetric v
[“]use Black Paint Compensation
[“]use Dither
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CONVERTING COLOR

When you identify a color workspace and open a file
where another workspace is embedded in the file, a
color mismatch occurs. You have a number of differ-

ent options for handling color mismatches that are
established in the Color Settings dialog box (refer to
Figure 1-17). In the Color Management area of the
Color Settings dialog box are three drop-down menus
for handling RGB color, CMYK color, and Gray conver-
sions. Below the drop-down menus are three check
boxes used to determine how color mismatches are
handled by Photoshop.

For RGB color, which is our primary concern in digital
photography, the drop-down menu offers three
options that include:

> Off. This turns off all color management. Don’t
select this item because you’ll defeat the purpose
for managing color.

> Preserve Embedded Profiles. Select this if you
know you work on images that have different pro-
files assigned for different purposes and don’t
want to mess with them.

> Convert to Working RGB. More often than not,
this is your best choice for all your Photoshop
work. Any image you open is converted to your
current color workspace.

Below the drop-down menus are check boxes for how
to handle the options you select in the pull-down
menus. These include:

> Ask When Opening. If you see an annoying dialog
box appear each time you open an image in
Photoshop, it’s because this check box is selected.
You’re being prompted for making a choice for
converting color. If the check box is not selected
and you select Convert to Working RGB, Photoshop
automatically converts your color without you
knowing it. To stay informed and know what’s
happening with your color conversions, keep this
box selected.

> Ask When Pasting. This check box performs the
same action as Ask When Opening when you copy
pixels from one Photoshop file and paste them into
another file. Check this box to be prompted if you
copy data from a file where a mismatch occurs.
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> Ask When Opening (Missing Profiles). This
option relates to any images where no profile is
embedded in the document. You might have a col-
lection of Photos taken with your digital camera
where no profile is embedded. If this is the case,
selecting this check box prompts you upon open-
ing each file. In a production environment where
you need to open many files and you know you
want them all converted to your current work-
space, do not select this check box.

If you select Convert to Working RGB from the pull-
down menu in the Color Management area of the
Color Settings dialog box and you select the Ask
When Opening check box, you are prompted in the
Embed Profile Mismatch dialog box each time you
open a file. The dialog box, shown in Figure 1-22, pro-
vides you with three choices that include:

> Use the embedded profile (instead of the work-
ing space). This option preserves the current
embedded color profile. You can use this option if
you edit a number of images you want to output
for Web use while your current workspace is set
up with Adobe RGB (1998).

v

Convert document’s colors to the working space.
By default, this is the selection you want to use. If
this selection is made, you convert the embedded
profile in a document you open to your current
color workspace.

> Discard the embedded profile (don’t color man-
age). This option again defeats the purpose for
color management. As a matter of rule, don’t
select this option.
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PHOTOSHOP’S COLOR AND TONAL
| CORRECTION TOOLS

| f you travel back in time to Photoshop 1, 1.7, or

later in Photoshop 3 when Layers were introduced,
you find some essential correction tools that are still
present in the latest version of Photoshop. Your cor-
rection tools for adjusting brightness and contrast and
correcting color that were available in the first release
of Photoshop were Levels, Curves, and
Hue/Saturation. These three tools are your most
important assets when it comes to correcting your
digital camera images.

In later versions of Photoshop, we saw the introduc-
tion of some tools that were intended to make the job
of color correction easier such as the Auto tools (Auto
Levels, Auto Contrast, Auto Color), Match Color,
Replace Color, Selective Color, Channel Mixer, Photo
Filter, Shadow/Highlight, Exposure, and Variations.

Are these newer tools better for handling brightness and
color adjustments with your digital photos?

Quite simply, let us put it this way. If you gave us
Photoshop 3, we could correct just about any photo
using only Levels, Curves, and Hue/Saturation. (We
could perform all these corrections in Photoshop 1, but
having Layers makes the job much easier). These three
tools are incomparable when it comes to balancing
color and making brightness/contrast corrections in
Photoshop. Upon occasion, you can get a little help
from some of the newer tools, but nothing is better for
any given adjustment in Photoshop than the three staple
tools. Throughout this book, we show you various tech-
niques using these three tools for just about all correc-
tions made on images with a wide range of problems.

Some of the essential basics for color correction
involve using:

> Levels. Your first step in correcting any image
involves observing the Levels dialog box. Press
Command/Gtrl + L to open Levels. As shown in
Figure 1-23, you see a histogram containing 256
levels of gray and the frequency for each gray



level represented by the peaks in the graph. You
can adjust the tone levels by moving the Input
sliders for the composite RGB channel, or you can
select a channel from the Channel drop-down
menu where adjustments are made to individual
channels.

The spikes at either end of the histogram show
data clipping. In the histogram in Figure 1-23 some
of the highlight and shadow data is clipped, mean-
ing there is data loss in these areas of the photo,
perhaps because the camera’s sensor was unable
to capture the full dynamic range of the image.

On the left, you find the black point, on the right
is the white point, and the middle slider is the
midtone adjustment. You also find three Eyedropper
tools that can be used to sample an area in a
photo (by selecting an Eyedropper and clicking in
the background photo) to set the black point, mid-
tones, and white point.

[ PROTIP _[| | i

For information on using the sliders and buttons
in the Levels dialog box, see Chapter 4.

> Curves. Your single most important correction

tool in Photoshop is the Curves dialog box. You
can adjust brightness and contrast as well as per-
form color correction all within the Curves dialog
box. Many of the adjustments you make in Curves
can also be handled in Levels, but the Curves

dialog box provides you an easier, more intuitive
method for corrections once you become familiar
with how to use Gurves.

As is the case with the Levels dialog box, you also
find a Channel drop-down menu where adjust-
ments can be made to the composite RGB channel
or the individual channels as shown in Figure 1-24.
You also find a tone curve representing all the 256
levels of gray and you make adjustments by click-
ing on the diagonal line to plot points and move
them along the tone curve.

Curves [

0 E}E 15,0
Input: 206 F
i
Qutput; 255 Emr
&
1-24

We talk about using the Curves dialog box
throughout this book. The first thing you'll want to
do is set up the Curves dialog box to make it easy
to follow our mention of using Curves. You press
Command/Gtrl + M to open the Curves dialog box
and press the Option/Alt key and click on the grid.
The grid changes from a default view of four hori-
zontal and vertical gridlines to ten horizontal and
vertical gridlines. Keep the Curves dialog box set
to ten gridlines for easier manipulation of the tone
curve.

Another adjustment you want to make in Curves is
to change the direction of the curve. By default
the curve begins with the white point and extends
to the top right corner to the black point. This
direction is opposite the Levels dialog box where
the tone curve runs from black to white. To change
the direction so black appears in the lower left

v
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corner and white appears in the top right corner,
click one of the arrows on the gradient bar below
the grid. The direction is changed and matches
the same direction as the Levels dialog box.

You'll note that the Curves dialog box also
includes three Eyedropper tools. These tools are
used the same as when working in Levels to set
white point, midtone, and black point.

Hue/Saturation. The Hue/Saturation dialog box
opens when you press Command/Ctrl + U. From
the Edit menu in the Hue/Saturation dialog box, you
can target colors for adjusting the Hue, Saturation,
and Lightness by moving the respective sliders as
shown in Figure 1-25. You also find three eyedrop-
per tools used for sampling areas in the photo
where colors can be identified for making adjust-
ments within a range of a given color.

Adjustment layers. Quite often a single Levels,
Curves, or Hue/Saturation adjustment may not be
enough to color balance or correct brightness in
images. Once you make an adjustment, you may
want to return to a dialog box and make some
changes to the settings applied in the dialog box.
Handling these options is best performed using
an Adjustment layer. You can create many adjust-
ment layers and you can return to any adjustment
layer to change the settings.

Adjustment layers are created by clicking the Create
new fill or adjustment layer icon in the Layers palette
and selecting the adjustment you want to make from
the drop-down menu as shown in Figure 1-26.

Solid Color...
Gradient...
Pattern...

Levels...

Color Balance... !

Brightness/Contrast...

Hue/Saturation...

Layers Channels P Selective Color

Channel Mixer...

s a

Gradient Map...
Photo Filter...

Invert
Threshold...

Posterize...
== §_ 0O W m—wr— T

You can also apply a blend mode to an adjust-
ment layer. You can make a change from the
Normal blend mode to any one of the other blend
mode options after creating an adjustment layer
or you can choose to select the blend mode you
want at the time an adjustment layer is created.

Many times throughout this book we use the
Luminosity blend mode to apply corrections to
the brightness values in an image. Luminosity
doesn’t disturb the color balance when using

any of the correction tools when you make tonal
adjustments. To change the blend mode when you
create an adjustment layer, press the Option/Alt key
when you select an adjustment layer menu item
from the Create fill or adjustment layer drop-down
menu. After making a menu selection, the New
Layer dialog box opens as shown in Figure 1-27.

In Figure 1-27 we pressed the Alt key down and
selected Curves from the Create a new fill or
adjustment layer drop down menu to open the
New Layer dialog box. From the Mode drop-down




menu we can select a blend mode before the
Curves dialog box opens. As we make adjustments,
the image preview is applied to the background
image using the blend mode we choose in the
New Layer dialog box.

> Layer masks. You may often find images needing
color balancing and/or tonal corrections applied
independently to different areas of an image.
Backgrounds and foregrounds, for example, may
require different adjustments. When you make a
selection in an image, then create an adjustment
layer, you additionally create a layer mask. The
layer mask enables you to make adjustments to
only the selected area without affecting the unse-
lected portion of your image.

To create a layer mask, first create a selection.
While the selection is active, create an adjustment
layer. In Figure 1-28 we created a selection and
chose Hue/Saturation from the Create new fill

or adjustment layer drop-down menu. The Hue/
Saturation dialog box opened. In the Layers
palette, the white area in the layer mask is the
only area that will be affected by our edits in the
Hue/Saturation dialog box.

Upon occasion we use a few other tools in Photoshop
to perform color and tonal corrections; however,
many of the other tools are used in combination with
the three basic correction tools you’ll find used

Hue/Saturation

Edit; | Master V|
Hue: EI
3
Saturation: EI
Q
Lightress: EI
3
s A2
| — e

Layers ~ Channels Y Paths 40
|Luminosity v| Opacity:| 100% * |
Hs+a Fill:| 100% *
[ colorize
[ Preview

throughout this book. Once you learn how to effec-
tively use Levels, Curves, and Hue/Saturation dialog
boxes and you understand all the blend modes and
masks used in adjustment layers, you can use the full
potential in Photoshop to correct any image.

New Layer
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[Juse Previous Layer to Create Clipping Mask

Opacity: %
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Why don’t | get 16-bit images with my digital camera?

You may be saving pictures in JPEG format, and Photoshop doesn’t support 16-bit in JPEG format. Try changing
the capture mode to saving Camera Raw format. Another reason might be that your camera doesn’t support
Camera Raw and capturing 16-bit images. Consult your camera’s manual to see what formats and bit depths
are supported.

If all you have to work with are 8-bit JPEG images, either because your camera doesn’t support shooting Raw
or because you have files where only JPEG is used in a photo shoot, you can convert 8-bit images to 16-bit as
explained in Chapter 4.

Why does a dialog box open when I try to use Merge to HDR informing me that my images
don’t have enough dynamic range?

There is not enough total dynamic range (exposure difference) in the bracketed image files being used to create
a 32-bit file. Try using wider camera exposure variations for the files to be merged to HDR.

If you shoot images with a one-stop difference, try changing your EV (Exposure Values) to more extreme dif-
ferences such as two or three stops. At first you’ll see radical over/underexposures; but when you use the
Merge to HDR command, Photoshop is likely to create the merged file.

Why don’t | embed my monitor color profile after | calibrate my monitor?

Your monitor profile is used for correcting views on your monitor and doesn’t have anything to do with the file
you are editing and saving from Photoshop. The color working space affects your image and should be embed-
ded in your photos so the color can be converted to other monitor workspaces and output profiles.

If 1 print files to my desktop color printer, do | need to set up my CMYK color workspace and
convert to CMYK color?

Everything depends on the printing equipment you use. In most cases, desktop color printers are designed to
print RGB files. Although these printers have CMYK inks and variations thereof, many take advantage of the
larger RGB color gamut.

When printing files to your printer or using service centers, read the printer manual documentation or ask the
technicians printing your photos what color mode is preferred for the device that ultimately prints your photos.



