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Time-Saving Adobe
Bridge Strategies

Chapter 01

Techniques for Batch File Renaming in
Adobe Bridge

by David H. Wells

Customize Bridge Workspaces
by Charlotte Lowrie

Save Time Using Metadata Templates
by David H. Wells

Add Keywords
by Charlotte Lowrie
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Contributor: David H. Wells n Specialty: Photojournalism and Editorial
Primary Tool Used: Batch Rename in Bridge

As image collections grow, using a file-naming strategy that helps narrow the search for images can
save significant time. The first step is to create a naming strategy that is useful throughout multiple
image collections, and then use Bridge’s Batch Rename feature to automate file naming. Another
advantage of using Bridge is that it helps automate backup by allowing you to create a backup copy of
renamed files in a separate folder.

1
In Adobe Bridge, open the folder that contains the images you want to rename. Then select the images
that you want to rename. If a folder contains images of different subjects, places, or assignments,
select only one group of similar images to rename. You may want to create subfolders to group images
by subject, location, or assignment either before or during the renaming process.

�1.1

Techniques for Batch File Renaming
in Adobe Bridge
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2
Choose Tools ➤ Batch Rename. Bridge displays the Batch Rename dialog box. In the Destination Folder
section, you can choose among three options. Your choice of folder depends in part on the workflow
and backup process that you’ve established. For example, if your first workflow step is to create a
backup of RAW images with a naming system, you can choose Copy or Move to other folder. The
options are as follows:

l Rename in same folder. This is the option to use if you aren’t backing up images and simply
want to rename the files.

l Move to other folder. When you choose this option, Bridge displays a Browse button for you to
choose the folder or create a new folder.

l Copy to other folder. If you want to back up the original files, this option accomplishes both the
backup and the renaming in a single step. 

�1.2

7

To navigate complex file directories quickly,
choose Window ➤ Workspace, and then
choose File Navigator. To gain additional
space to view the file structure, drag the
vertical divider bar between the Folders and
content panes in Bridge to widen the Folders
panel.
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Although you can also use the earlier ver-
sions of Photoshop’s Batch dialog box to
rename files, they require that you run an
action on the files and save them. In Bridge,
you can simply rename the files without run-
ning an action or saving the RAW files.
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3
In the New Filenames section, Bridge offers a set of options with drop-down menus. Here you can
implement a universal file-naming strategy that you can apply to current, existing, and future images.

In the first drop-down menu, you can choose Text, New Extension, Current Filename, Preserved
Filename, Sequence Number, Sequence Letter, Date Time, or Metadata. If you want to include the date
and time, choose Date Time in the first option box. In the second option box, choose any option except
Yesterday; then in the third option box choose HHMMSS (Hour, Minute, Second) or HHMM (Hour,
Minute). Bridge inserts the option you chose in the filename.

�1.3

4
Choose the options you want, and then click the
plus sign at the right to add more filename fields.
Bridge displays additional selection boxes based
on the selection made in the first option box on
the first row.

Try selecting different options until you get the set of fields you need to implement your preferred file-
naming strategy. At the bottom of the Batch Rename dialog box, Bridge previews a sample of the file-
name as you build it.
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If you choose an option that includes a
sequence number, Bridge automatically
increments the number for each file that is
renamed.
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�1.4

5
Select the Preserve current filename in XMP Metadata
option to retain the existing filename. If you have not
edited the files in Camera Raw then choose this option
to retain the original filename. If you’ve edited the files
in Camera Raw, the filename gets embedded with the
Camera Raw settings. But because restoring original filenames from XMP sidecar files is difficult, pre-
serving the original filename is a good idea. If you need to undo renaming, you can choose the Batch
Rename command, and then choose Preserved Filename to return to the original filenames. However,
many photographers rename and make a copy of the original files as a first step in the workflow. In that
scenario as well, turning on the Preserve current filename in XMP Metadata option is best.
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For more information on XMP sidecar
files and setting Bridge preferences,
see Appendix A.
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�1.5

6
Choose the operating systems that you want the images to be compatible with. The current operating
system is selected by default and cannot be deselected.

�1.6
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7
Click Rename. Bridge displays a message saying that it will save the updated metadata in the XMP side-
car file rather than in the original RAW file. If you later copy the file to another computer or to disk, be
sure to copy the XMP file along with the image file.

Click OK in the Batch Rename dialog box. Bridge applies the modified filenames.

�1.7
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The camera gives each image a unique name and number. Usually the camera uses the date as a
starting point, and then it adds a number for each image. However, with some cameras, you can
choose to name files continuously or to restart numbering with each new session. In the latter sce-
nario, you can end up with duplicate filenames. To avoid duplicate names, use the continuous num-
bering option on your camera. This system has the added advantage of tracking the camera’s
actuations, or number of total shots. Additionally, if you want to know the number of images per
shoot, you can use continuous numbering coupled with some simple math to track the number of
the camera’s actuations.

After you get the files on the computer, be sure to rename files using a consistent naming conven-
tion that is universal throughout your system of shooting, archiving, processing, printing, and dis-
seminating images. It can be as simple as the month, year, the location where the images were
made, and the original filename. In this example, images from India made in December of 2005
would start with 1205India followed by the image number generated by the camera. The final file-
name would be something like 112005India3723.ORF. To view your files, choose View ➤ Sort, and
then sort the files by date and order that you want.
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Create a File-Naming Strategy
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Contributor: Charlotte Lowrie n Specialty: Editorial and Stock
Primary Tool Used: Adobe Bridge Workspace

Depending on the phase of the workflow, being able to view images in folders in different ways is help-
ful. For example, during image selection, seeing images at a large size is important, but when it’s time
to add metadata, having an enlarged view of the Metadata panel in Bridge is more important to work
most efficiently. This technique shows you how to switch among and customize Bridge workspaces to
facilitate different phases of the image workflow.

1
In Adobe Bridge, choose Window ➤ Workspace, and then choose one of these options:

l Lightbox. Choosing this view hides the left panels in Bridge and displays only the image thumb-
nails. This view is equivalent to an electronic contact sheet.

l File Navigator. Choosing this workspace
removes the left-pane image Preview,
Metadata, and Keywords tabs and creates
a spacious area in which to navigate
among Favorites (pre-populated by
Adobe) and Folders on various drives.

l Metadata Focus. Choosing this work-
space narrows the left-hand panes to
Favorites, Metadata, and Keywords.

l Filmstrip Focus. Choosing this work-
space hides the left-hand panels, displays
the selected image at the maximum dis-
play size of 512 pixels, and displays the
other images in the folder as a filmstrip
along the bottom of the window.

Customize Bridge Workspaces

12

To display the left panel when it is hidden or
to enlarge or shrink its size, drag the hori-
zontal bar between the panels. You can also
use the display buttons to the right of the
status bar to modify the size and arrange-
ment of image previews and to display or
hide metadata.
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2
To resize the left panel panes horizontally, drag
the horizontal divider bar located between
panels up and down. For example, if you want a
larger area to work with in the Metadata work-
space, drag the horizontal divider bar between
the Favorites and Metadata panels to the top to
hide the Favorites panel. The horizontal divider
bar remains accessible so that you can quickly
reconfigure the panels as you work.
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�1.9

Bridge displays up to three icons under thumb-
nails to indicate the status of the image. Icons
show whether an image has been edited in
Camera Raw and the settings preserved, an
image has been cropped in Camera Raw, or
the image is open in Photoshop.
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3
After you have a workspace pane modified as
you want, drag the Thumbnail size slider to
change the size of the thumbnail display.

When creating a workspace for the image-
selection phase of the workflow, enlarge the
thumbnails to a medium or large size so you
can see a series of similar images at a large
enough size to make selection decisions.
Saving the modified workspace saves the pre-
view size as well.

�1.10

If a specific workspace view isn’t adequate,
you can also open additional Bridge win-
dows and adjust the displays and work-
spaces to compare images in different
windows. To open a new Bridge window,
choose File ➤ New Window. Then size the
windows for side-by-side viewing.
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4
Click a display button in the lower right to
select the type of display you want in the con-
tent area. The choices are, from left to right:
Thumbnails view, Filmstrip view, Details view,
or Versions and Alternates view.
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Some redundancy exists between the
Filmstrip workspace and the Filmstrip dis-
play button. The noticeable difference is
that the Filmstrip workspace automatically
displays filmstrip thumbnails at the maxi-
mum size and overrides smaller sizes you’ve
chosen using the Filmstrip display button.
Regardless, you can resize thumbnails with
the Thumbnail size slider.

N
o

te
�

�1.11

05_782645 ch01.qxp  6/6/06  10:49 PM  Page 14



5
To save a modified workspace, choose 
Window ➤ Workspace ➤ Save Workspace to
open the Save Workspace dialog box. Type a
name in the Name field. If you don’t want
Bridge to position the workspace in the current
position, you can deselect the Save Window
Location as Part of Workspace check box. Click
Save in the Save Workspace dialog box.
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�1.12

To reduce the size of the Bridge window, click the Switch to Compact Mode button on the toolbar. Bridge
becomes a small window that stays on top of other open windows. To reduce Bridge further, try Ultra-
Compact Mode, which you can select after you select Compact Mode. In Ultra-Compact Mode, Bridge is
displayed as a floating bar that you can drag and dock anywhere on the screen.
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p

�

In a perfect world, when you change options in the Bridge Preferences dialog box, your changes
would be saved with customized workspaces, but such is not the case. Instead, display options in
the Preferences dialog box apply to all workspaces and displays. To check out the options available
in Bridge Preferences, choose Edit ➤ Preferences(Bridge on a  Mac) ➤ Preferences.

In the General section of the Bridge Preferences dialog box, you can set the background color in
the Content pane from white to varying shades of gray to black. The changes you make apply to all
Bridge displays and workspaces.

A careful review of all the Bridge Preference options is worthwhile. In the Advanced section of the
Preferences dialog box, you can choose to use centralized cache or distributed cache files. If you
routinely back up files on disk, using a distributed cache allows you to burn the cache files to the disk
rather than having to export a centralized cache to the disk. For additional information, be sure to
check out the details in Appendix A.
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Contributor: David H. Wells n Specialty: Photojournalism and Editorial
Primary Tool Used: Photoshop File Info Templates

Metadata provides the foundation for organizing, finding, and tracking images and modifications you
make to the images in Bridge. And the metadata that you add stays with files as you create variations
of them. This technique shows you how to create a template to automate the process of adding meta-
data and append the template to all or some of the files in a folder.

1
Open a blank file in Photoshop CS2. The name, dimensions, resolution, and other details of the new file
are not important because the file is only used to create a metadata template. Once you have created
the metadata template, you can delete this file.

Choose File ➤ File Info. Photoshop displays an Untitled dialog box. If you typed a name for the new file,
the dialog box is titled with the name you typed. On the left of the dialog box is a list of categories,
most of which offer fields where you can add metadata. However, not all categories have editable
fields. To make the template most useful, identify the categories and the fields that have the broadest
application for all the files that you create or for
all or most of the files in the current folder. The
most likely categories are Description, IPTC
Contact, IPTC Content, IPTC Image, IPTC Status,
and Origin.

�1.13

Save Time Using Metadata Templates

16

Metadata describes an image, including the
filename, date, resolution, and exposure
(EXIF) information. Bridge also includes IPTC
Core fields.
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2
As you choose categories at the left, fill in the fields that apply to the images.

�1.14

3
Click the Menu button at the upper right of the dialog box, and then choose Save Metadata Template
(1.15). Photoshop displays the Save Metadata Template dialog box.

�1.15

4
Type a name for the template in the Save
Metadata Template dialog box and click Save.
Click OK to close the new file dialog box.

�1.16

It’s unlikely that a single template will fit all the images that you work with. You can create multiple templates
that fit your most common shooting scenarios, and then append multiple templates to files. Alternatively,
you can also create temporary templates that contain the metadata information for a single shoot.
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5
In Bridge, switch to the folder of images to which you want to apply the metadata template. Select the
images you want to apply the metadata template to. To select all images, press Ctrl/Ô+A.

�1.17

6
Choose Tools ➤ Append Metadata, and then choose the name of the template containing the meta-
data you created in the previous steps. Click OK to append the metadata. Bridge appends the template
to the files.

Bridge appends the metadata only to fields where no metadata currently exists. This ensures that no
existing information is overwritten. The beauty of this technique is that you can go back to existing
folders and append one or more metadata templates to images in the folders.

In Bridge, you can also choose File ➤ File Info to view and change metadata for individual files or to edit
the information in the Metadata panel. There may be differences between the field labels (names) in
the Metadata panel and those in the File Info dialog box in Bridge. However, the underlying XMP prop-
erty is the same—simply a different view.
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Contributor: Charlotte Lowrie n Specialty: Editorial and Stock
Primary Tool Used: The Synchronize option for batch processing

One of the most powerful features of Adobe CS2 is its search capability. Keywords can be an integral
part of the search criteria provided that you add keywords via the Bridge Keywords panel. As with
adding other metadata, Bridge offers ways to add keywords and keyword sets to multiple files simulta-
neously, making this task relatively pain-free.

1
The keyword sets, or categories, and keywords
provided by Bridge are, at best, a starting place
for creating more useful keywords. To change
the name of an existing keyword set, right-click
the keyword set name, and then choose
Rename. Bridge displays an edit box where you
can type a new name. You can repeat this
renaming process for the individual keywords
under the keyword set name.

20

Keywords added in Bridge are distinct from
keywords you add to XMP metadata via the
File ➤ File Info command.
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Entering keywords is easier if you switch
to the Metadata Focus workspace. (Choose
Window ➤ Workspace ➤ Metadata Focus.)
Bridge separates the Metadata and
Keywords tabs and provides a larger work-
space for entering keywords.
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Add Keywords
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2
To create a keyword set, choose the New
Keyword Set button at the bottom of the
Keywords panel. Type a name for the keyword
set in the Keywords Set field, and then press
Enter.

�1.20
New Keyword Set

Consider adding keyword sets with key-
words that fit the photography you shoot
most often. If you shoot landscapes, create
a Mountainscapes set and add individual
keywords. Or create a keyword set with key-
words that apply to a specific shoot. This
approach is effective for images with a com-
mon subject.
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3
To add a new keyword, choose the Keyword set to which you want to add a new keyword. Then choose
the New Keyword button at the bottom of the Keywords panel. Type the new keyword and press Enter.

Repeat this step for all the keywords you want to add to a keyword set.

�1.21

You can quickly rearrange keywords by dragging a keyword
from one keyword set to another. Also, if you want to delete
a keyword or keyword set, select it and click the Delete
Keyword icon at the bottom of the Keywords panel (it looks
like a trash can).
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4
To apply a keyword, select one or more images. Select the check box to the left of the keyword you
want to add. Bridge displays a message asking whether you want to apply edits to multiple files. Click
Yes in the dialog box that appears (if you only select one image, the dialog box does not appear).
Bridge adds a check mark next to the keyword and adds the keyword to the sidecar XMP file of the
image or images selected.

�1.22

05_782645 ch01.qxp  6/6/06  10:49 PM  Page 22



23

Ti
m

e-
S

av
in

g
 S

tr
at

eg
ie

s
01

Although keyword fields are available in File Info fields, keywords added in the File Info dialog box are
added as XMP keywords and are distinct from keywords added in the Keywords panel in Bridge.
Keywords added in the File Info dialog box are displayed in Version Cue files in the Other Metadata
section of the File Info dialog box. And from a workflow standpoint, adding keywords in the Bridge
Keywords panel, where you can create sets of keywords and apply all or part of them to one or more
images simultaneously, is more efficient. If you rename a keyword, however, the original name con-
tinues to appear in the files you’ve applied it to. To apply the changed name, select the files and
apply the changed keyword name by checking it in the keyword panel.

You can ensure that keywords persist by adding the keyword to the Other Keywords category.
Then just right-click to display the context menu, and choose Make Persistent.

Because keywords are important in the ability to find and retrieve files, creating a consistent strat-
egy for keywords is a good idea. The advantage is clear. When a client or stock agency asks for exist-
ing lifestyle imagery of a 20’s-something woman drinking coffee with friends, you can search for and
retrieve all the files in your library that fit the description based on your consistent and careful key-
word implementation. And, after Bridge finds the images, you can save the search criteria and
results in a Collection. You can find out more about image Collections in Chapter 3.
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