Introduction

Welcome to Macromedia Flash MX For Dummies, your friendly Web-ani-
mation companion. In this book, we explain in plain English how to
make the most of Flash to create stunning Web site animations. Macromedia
Flash MX For Dummies aims to give you all the information you need to start
using Flash right away — with no hassle.

About This Book

As though you hadn’t guessed, Macromedia Flash MX For Dummies covers the
powerful animation product Flash MX, from Macromedia. (The preceding ver-
sion was Flash 5.) Flash MX is the latest version of the popular software used
on some of the coolest Web sites on the Internet. We comprehensively
explain the Flash features, including

v Working with the Flash screen, toolbars, and menus

v Understanding what Flash can do

v Creating graphics and text in Flash

v Using layers to organize your animation

v Creating symbols, or objects you save for repeated use

v Creating Web page buttons

v Animating your graphics (the key to Flash)

v Creating interactive Web sites

v Adding sound

v~ Publishing your Flash movies to your Web site

The material in this book gives you the tools you need to create Web site
animation yourself. It’s lots of fun, so read on.
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How to Use This Book

You don’t have to read this book from cover to cover. Macromedia Flash MX
For Dummies provides just the information you need, when you need it. If
you’ve never used Flash, start with the first three chapters. Then play around
with graphics until you create what you need for your Web site. You may
want to check out Chapter 6, on layers, to help you organize it all. Then feel
free to jump right to Chapter 9, on animation, to create your first real Flash
movie. Chapter 13 tells you how to get your movie on your Web site. Then
fire up your browser, sit back, and marvel.

Of course, you’ll want to refer to other chapters as you need them so that
you can create text and buttons, add sound, and create an interactive Web
site. Chapter 12 provides some ideas for putting all the Flash features
together for your best Web site ever.

If you're already using Flash but need some assistance, you can probably
skim Chapters 1 and 2. Then refer to the chapters that provide the informa-
tion you need in the nick of time.

Keep Macromedia Flash MX For Dummies by your computer as you work.
You'll find it to be a loyal helper.

Foolish Assumptions

We assume that you're not already a master Flash developer. If you want to
use Flash to create high-quality Web sites and you’re not an expert animator
already, you’ll find this book to be a great reference. Macromedia Flash MX
For Dummies is ideal for beginners who are just starting to use Flash or for
current Flash users who want to further hone their skills.

Because Flash is generally added to Web sites, we also assume that you know
some of the basics of Web site creation. You should know what HTML is and
understand the process of creating and structuring HTML pages as well as
uploading them to a Web site.

If you need some help on the topic of Web sites, you may want to refer to
Building a Web Site For Dummies, by David A. Crowder and Rhonda Crowder,
also published by Hungry Minds, Inc.
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Conventions Used in This Book

Sometimes it helps to know why some text is bold and other is italic so that
you can figure out what we’re talking about. (A typographic convention is
not a convention of typographers meeting to discuss the latest typography
techniques.)

New terms are in italics to let you know that they’re new. In the unusual sit-
uation where we suggest that you type something, what we want you to type
is shown in bold. Messages and other text that come from Flash are in a
special typeface, Tike this.Programming code, which you may see
only occasionally, is also shown in the same way.

When we say something like “Choose Filem>Save As,” it means to click the File
menu at the top of your screen and then choose Save As from the menu that
opens. To distinguish between choosing a menu item or toolbar button from
choosing an object, we always say “Select the circle” or something similar to
refer to the object. So you choose menu items but select objects on your
screen. When we want you to use a toolbar or toolbox button (or tool), we
tell you to click it. So now you know the difference between choose, select,
and click.

How This Book Is Organized

We've tried to organize Macromedia Flash MX For Dummies logically. We start
by presenting an overview of the Flash universe and then continue in the gen-
eral order you would use to create a Flash animation. More basic material is
at the beginning of the book, and more advanced material (but not too
advanced!) comes later on. You may never use all the material in this book
for one Flash movie.

To be more specific, this book is divided into seven parts (to represent the
seven states of consciousness — okay, we don’t have to get too cosmic here).
Each part contains two or more chapters that relate to that part. Each chap-
ter thoroughly covers one topic so that you don’t have to go searching all
over creation to get the information you need.
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Part I: A Blast of Flash

Part I contains important introductory information about Flash. In Chapter 1,
we tell you what Flash is all about, show you what the Flash screen looks like,
and explain how to get help when you need it most. You can also find instruc-
tions for starting Flash, starting a new movie, and opening an existing movie.
We end Chapter 1 with a few steps to guide you in creating a short Flash
movie so that you can get a feel for the entire program and have some fun

at the same time.

Chapter 2 explains in more detail the steps for creating a Flash movie. There,
you get a good idea of what Flash can accomplish. We also explain some basic
concepts that all Flashers need to know. We hope that this chapter will start
your creative juices flowing and give you some ideas for your own movies.

Part 1I: 1,000 Pictures and 1,000 Words

Part Il explains all the tools available for creating graphics in Flash. Chapter 3
explains the unique drawing tools included in Flash. And you'’ll find that the
Flash graphics have some unusual characteristics but offer some great
opportunities. Of course, we also explain how to import graphics if you don’t
feel like creating your own. Chapter 4 shows you how to edit and manipulate
graphic objects, and Chapter 5 is all about creating text as graphic objects.

Chapter 6 explains layers, which help you organize your graphics so that
they don’t interfere with each other. Layers are an important feature of any
good animation, so don’t skip over this chapter.

Part 111 Getting Symbolic

Symbols are graphical objects that you save to use again and again. Whenever
you may want to place an object on a Web page more than once, you can
save the object as a symbol. By using symbols, you can also group together
many individual objects, making them useful when you want to manipulate,
edit, or animate them all at one time. Chapter 7 explains all about creating
and editing symbols.

Chapter 8 explains how to create Web page buttons — not the kind you sew,
but rather the kind you click with your mouse. Buttons are a kind of symbol,
but they execute an action when clicked. Flash can create cool buttons that

morph, or otherwise change, when you use them.
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Part IU: Total Flash-o0-Rama

Part IV explains how to animate your graphics into movies and how to create
Web sites that react to users’ actions. In this part, you get to put all your
graphics together and make them move.

Chapter 9 covers animation in detail — from frame-by-frame animation to
tweening, where Flash calculates the animation between your first and last
frames. You can tween movement to make your objects move and also to
make your objects morph into new shapes. Flash can also tween color and
transparency for a full range of exciting options.

Chapter 10 shows how to create Web sites that react to your viewers. For
example, if a viewer clicks a certain button, Flash can jump to a different part
of a movie, stop all sounds, or go to a different Web page entirely. To create
interactivity, you use ActionScript, the JavaScript-like programming language
available in Flash. But don’t worry — you don’t have to write code from
scratch. We tell you how to put ActionScript to work — even if you're a
complete programming newbie.

Chapter 11 is about adding sound, music, and video to your Flash movies.
These multimedia elements add an element of excitement to a Web site. You
can add sound to both animated movies and to buttons.

Part U: The Movie and the Web

This part helps you put all your animated graphics and cool buttons together
and publish your work on the Web. Chapter 12 outlines the various techniques
you can use to create a great Web site using only Flash.

Chapter 13 explains how to test your animation for speed and suitability for
all browsers and systems. Then we cover all the details of publishing movies
as well as the other available formats, such as HTML and GIF. You can also
create projectors — movies that play themselves.

Chapter 14 answers some frequently asked questions about Flash and intro-
duces some fun techniques, such as creating drag-and-drop objects and simu-
lating 3-D effects.
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Part Ul: The Part of Tens

What’s a For Dummies book without The Part of Tens? Chapter 15 offers you
the top ten Web-design tips, knowing that your Flash work must fit into the
context of an entire Web site. Chapter 16 provides you with the ten best
resources for learning about Flash (besides this book, of course). Chapter 17
lists our ten winners for ten great Flash Web sites, although new ones pop up
every day. You'll find lots of helpful information in this part.

Part VII: Appendixes

Last, but not least, we come to the appendixes. They add some valuable
information to the end of this book, including setting preferences and
options, illustrations of all the tools and panels in Flash MX, what those
obscure terms really mean, and what’s on the CD-ROM.

About the CD-ROM

Don’t forget to check out our CD-ROM. It’s stuffed with Flash movies you can
play with, a library of graphics, and trial versions of Flash and other cool
Macromedia and third-party products.

Icons Used in This Book

As you flip through this book, you’ll notice little pictures in the margin.
They’re called icons, and they help point out special information in the text.
Sometimes, they help you know quickly that you don’t care about this infor-
mation and can skip over it without fear.

Look for this icon to quickly find new features in Flash MX. If you have been

using Flash 5, you may want to skim through this book and look for this icon
to help you quickly get up to speed in the new version.

Look for this icon to find all the goodies on the CD included with this book.
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This icon alerts you to information you need to keep in mind to avoid wasting
time or falling on your face.

Flash has some advanced features you may want to know about — or skip
over entirely. This icon lets you know when we throw the heavier stuff at you.

Tips help you finish your work more easily, quickly, or effectively. Don’t miss
out on these.

Uh-oh! “Watch out here!” is what this icon is telling you, or else you never
know what may happen.

Where to Go from Here

If you don’t already have Flash installed, use the 30-day trial version of Flash
on this book’s CD-ROM and install the program. Complete instructions for
installing Flash are in Appendix A. Then open Flash, open this book, and
plunge in.

Contacting the Authors

We would love to hear your comments about this book. You can contact Gurdy
Leete at gleete@mum. edu and Ellen Finkelstein at el 1enfinkl1@bigfoot.com.

Please note that we can’t provide technical support on Flash. (If you need tech-
nical support, check out the resources listed in Chapter 16.)

Flash Time!

Enough of all this talk. Let’s move into the real part of this book and start
creating cool movies!

Enjoy!

/
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In this part . . .

n this part, you discover what Flash can and can’t do

and start to make your way around the Flash world. In
Chapter 1, we introduce you to Flash, what it looks like,
and how to use its toolbars and menus. You find out about
the Stage and the Timeline, two of the central Flash con-
cepts. Play your way through your first animation to get
firsthand experience in the power of Flash.

In Chapter 2, you get an overview of the entire process of
creating a Flash animated movie, from developing your
concept to publishing your movie in the format a browser
can display. We explain how to set properties that affect
your movie as a whole and how Flash works with various
kinds of graphics. We close with the steps for printing
your movie on paper. This part provides the foundation
for future success.




Chapter 1

Getting Acquainted with Flash MX

In This Chapter

Introducing Flash

Figuring out what you can create with Flash MX
Deciding when not to use Flash MX

Perusing the screen

Using Help

Creating your first animation

Closing Flash

0 nce upon a time in a galaxy that seems far, far away by now, there was
the Internet, which contained only plain, unformatted text. Then came
the Web, and we gained text formatting and graphics. Then the Web grew up
a little, and Web page graphics got fancier with things like small animations in
banner ads. But people, being used to movies and TV, wanted an even more
animated and interactive Web experience. Along came Flash.

Flash, created by Macromedia, Inc., is the software that runs some of the
coolest Web sites around. When you surf the Web and see sites that contain
animation across the entire page or buttons that do spectacular stunts
when you click them, you’re probably seeing some Flash magic. If you create
a Web site, you can use Flash to rev up the basics so that your viewers will
say “Wow!”

In this chapter, you find out what Flash is all about, what the screen looks

like, and how to use Help. Then you create your first, simple animation so
that all the rest of this book makes sense.

Discovering Flash

Flash offers a powerful system for creating animation on the Web. In a nut-
shell, here’s an overview of what you can do with the system:
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v Create a Flash movie by creating graphics and animating them over the
duration of the movie.

v Use the Publish command within Flash to publish the movie into a Flash
Player file. At the same time, Flash creates HTML code you need for your
Web page.

v Insert HTML code into your HTML document that creates the Web page
to reference the Flash Player file. It’s similar to adding a graphic to a Web
page. Or, you can use the HTML code alone as a new Web page.

v Upload the new or edited HTML document and the Flash Player file to
the location where you keep other files for your Web pages.

v Open your browser, navigate to your Web page, and — presto! — there’s
your cool animation on your Web page.

You need the Flash viewer to see the effects that Flash creates. These days,
Flash viewers come installed in most computer systems and browsers, so
most people can view Flash-driven Web sites immediately without any special
download or preparation. When you display a Web site that contains Flash
effects, your system uses the Flash viewer to play the animation. Users

who don’t have a Flash viewer can download it for free from Macromedia

at http://www.macromedia.com/shockwave/download/index.
cgi?P1l_Prod_Version=ShockwaveFTash.

Web sites are getting more and more sophisticated. By using animation and
special effects, you can distinguish your Web site from the also-rans. Using
animation isn’t hard, and you don’t have to be a professional graphic artist,
either. Anyone can create simple animations to enhance a Web site; it just
takes a little time.

To find the most up-to-date Web sites that use Flash, check out the Macro-
media site at www.macromedia.com/flash and go to the Gallery. Don’t get
discouraged by seeing some of the truly professional results at these sites.
You can start with a simple, animated site and go from there. (Chapter 17
lists ten great Web sites that use Flash.)

Understanding What You Can
Create with Flash MX

You can use Flash MX to create simple animation to add to your Web page.
Or, you can create an entire Web page or site and incorporate text, graphics,
interactive buttons, and animation.
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This book helps you use Flash to create a simple or complex Web site. The
following list describes some ways you can manipulate text, graphics, and
sound by using Flash MX:

1 Create text that remains still or appears animated on your Web page.
You can choose to stop the animation after a few seconds or repeat it
while your viewers view the page.

v Use Flash tools to create your own graphics for your Web page, or
import graphics. You can lay out a Web page graphically or add graph-
ics to only a part of a Web page.

v Animate graphics and make objects appear and disappear by using
the transparency feature. Objects can move, get bigger or smaller, or
rotate. Flash also lets you morph — that is, transform — shapes into
new shapes.

v+~ Fill shapes and text with gradients, which are colors that gradually
change into new colors. You can even fill shapes and text with bitmap
images you import into Flash. For example, you could fill the letters of
your name with dozens of flowers. (You aren’t a flower child any more?)

v Create Web page buttons that not only lead your viewers wherever you
want them to go but also change shape or color at the same time. You
can make buttons change as you pass your mouse over them. People
who view your page can click a button to display a movie (animation).

v Add sounds or music to your movie. You can control how long the
sound or music plays and whether it loops to play continuously.

v Create pop-up menus that viewers can use to navigate your site.

As you can see, you can go far with Flash if you want. And why not? It’s
great fun!

Determining When Not to Use Flash MX

If Flash MX is so wonderful, why doesn’t every Web site designer use it? Why
aren’t most Web sites created completely with Flash?

Here’s the other side of the story.

Although the vector graphics and animation of Flash load quickly, they don’t
load as quickly as plain text and simple graphics. Adding a movie to your
Web page creates some overhead. There’s no point in using Flash if you want
simple pages consisting of mostly text and a few graphics that you want to
stay put and not move.
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You can create certain graphic effects much more easily by using bitmap
graphics. Painted brushstroke and textured effects are examples. Graphic
artists create these types of graphics by using graphics-editing software,
and the results are bitmaps. Similarly, to add photographs to your Web page,
you need to scan the photographs as bitmaps. Flash creates vector graphics
(defined mathematically), which are different from bitmap graphics (defined
by lots of dots). You can find out more about bitmap and vector graphics in
Chapter 2.

If you want simple animation, such as a few blinking dots or a marquee effect,
animated GIFs (the animated bitmap graphics you often see on the Web) are
smaller than Flash movies, so they load faster. You can create animated GIFs
by using animated GIF editing software.

Flash provides little in the way of 3-D graphics or animation. For those, you
need to go to more sophisticated software, such as Poser or 3D Studio Max.
(See Chapter 14 for more 3-D possibilities in Flash.)

Getting the Right Start

Well begun is half done, as the saying goes. The easiest way to begin using
Flash MX is with a shortcut or alias right on your desktop. Double-click the
Flash icon and you’re on your way. (See Appendix A for information on
installing Flash.)

Starting Flash on a PC

Whether you installed Flash from the CD or by downloading it from the
Macromedia Web site onto your PC, you may or may not have a shortcut

on your desktop. To create one, point to Start=>Programs=>Macromedia=>
Macromedia Flash MX. Right-click the Macromedia Flash MX item and choose
Create Shortcut. The new shortcut appears on the menu. Drag that shortcut
to your desktop.

To rename the shortcut, click the shortcut on your desktop. Then click the

text beneath the icon. Type Flash MX (or whatever you want) and press
Enter. Just double-click the icon to open Flash.

Starting Flash on a Mac

Whether you installed Flash from the CD or by downloading from the
Macromedia Web site onto your Mac, you may or may not have an alias
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on your desktop. To create one, open your drive and find the file named Flash
MX in the Macromedia Flash MX folder. Click the file to select it. Then choose
FileroMake Alias. This action creates the alias in the same folder, named Flash
MX Alias. Drag that alias to the desktop.

Click the alias on your desktop. Then click the text beneath the icon. Type
Flash MX (or whatever you want) and press Enter. Now you can just double-
click the icon to open Flash.

Creating a new movie

Files you create by using Flash are commonly called movies. When you start
Flash, you're immediately ready to create a new movie. You usually start by
creating or importing some graphics. (To find out more about working with

graphics, see Chapter 3.)

Opening an existing movie

If you want to work on a movie you’ve already created, press Ctrl+O (Windows)
or 38+0 (Mac) or choose Filem>Open; then double-click the movie to open it.
The first frame appears on your screen, and you can edit the movie any way
you want.

Windows users can click Open on the Standard toolbar. If the Standard tool-
bar isn’t displayed, choose Window=>Toolbars=>Main.

Taking a Look Around

If you've never created animation, the Flash screen is different from the
screens in other programs you may be used to, so take the time to get to
know it. You can also customize the Flash screen. Figure 1-1 shows one
possible display.

If your screen opens with several rectangular panels strewn about the screen,
choose Windowr>Close All Panels to close them. We explain how to open and
use these panels throughout this book, but you don’t need them for this
chapter.
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Tooling around the toolbars

Flash contains two toolbars in the Mac version: the Drawing toolbox and
the Controller. To display or hide these toolbars, choose Window=>Tools or
Window=Controller. In Windows, Flash offers the four toolbars described
in the following list. To display or hide the first three listed here, choose
Window=>Toolbars and click the toolbar you want to display or hide. Here
is a description of the toolbars:

v The Standard toolbar (Windows only), called the main toolbar, contains
commonly used commands. Many of these are familiar from other
Windows programs. By default, Flash does not display the Standard
toolbar.

v The Status toolbar (Windows only) contains a brief description of tool-
bar buttons and tells you when the Caps Lock and Num Lock buttons are
on. By not displaying this mostly useless toolbar, you can reclaim some
real estate on your screen. By default, Flash does not display the Status
toolbar.
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v The Controller lets you control the playback of movies. For more infor-
mation, see Chapter 9.

v The Drawing toolbox contains all the tools you need to draw and edit
objects. At the bottom of the Drawing toolbox are options that modify
how the tools function. (See Chapters 3 and 4 for a complete description
of the features of the Drawing toolbox.)

Using panels

Panels give you access to the many Flash settings. You access them from the
Window menu. The specific panels are discussed throughout this book. In
this section, we explain how to keep control over your panels.

Flash MX introduces several improvements in the panels. Most are dockable,
which means that they can sit at the side or bottom of your Flash window
without covering up your work. To dock a panel, drag it to the right or
bottom of your screen. To undock a panel, drag it from its grabber, at the left
edge of its title bar. To open or close a panel, choose it from the Window
panel. You can also close a panel by clicking its Close button.

You can now stack panels just like you stack plastic containers in your refrig-
erator. Drag a panel by its grabber and drag it beneath another panel to stack
it. You can also collapse or expand panels. Use the arrow on the left side of
the title bar to collapse or expand a panel.

The Property inspector has also changed. It is now context-sensitive, which
means that its contents change according to what you’re doing. If you're
working on the Timeline, the Property inspector provides settings relating
to the Timeline. If you're working with an object, you can use the Property
inspector to edit that object.

For the best in customization, you can save any layout of panels you like.

Set up the panels and choose Windowr>Save Panel Layout. In the Save Panel
Layout dialog box that opens, give the layout a name and click OK. To restore
that layout at any time, choose Window=>Panel Sets and choose your very
own layout.

Discovering the Flash menus

Most drawing functions are available only in the Drawing toolbox. Similarly,
you often use the Timeline, as discussed in “Following a timeline,” later in
this chapter, for creating animation. Almost every other function in Flash is
on a menu somewhere. You just need to find it. In general, we discuss the
specific menu functions as appropriate throughout this book. Table 1-1 offers
a brief overview of the menus.
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Table 1-1

Flash Menus

Menu

What It Does

File

Enables you to open and close files; save files; import and
export files; print; publish movies for the Web; send a
movie as an e-mail attachment (Windows only); and quit
Flash.

Edit

Provides commands that let you undo and redo actions;
cut, copy, and paste to and from the Clipboard; delete,
duplicate, select, and deselect objects; copy and paste
entire frames; edit symbols (see Chapter 7 for the whole
story on symbols); set preferences; and create keyboard
shortcuts for commands.

View

Helps you get a better view by letting you zoom in and out;
show or hide various parts of the screen; and view a grid
for easy layout.

Insert

Enables you to insert symbols or create symbols from
objects on your screen (Chapter 7 explains this topic);
insert and delete frames and keyframes (see Chapter 9 for
more); insert layers (covered in Chapter 6); and create
motion tweens (see Chapter 9).

Modify

Helps you modify symbols, frames, scenes, or the entire
movie. Offers tools for transforming, aligning, grouping,
ungrouping, and breaking objects apart.

Text

Enables you to format text.

Control

Provides options that let you control the playing of movies;
test movies and scenes; engage certain interactive func-
tions; and mute sounds.

Window

Enables you to open lots of things, including a new
window; panels that help you control objects; the Library
(more on libraries in Chapter 2); windows for creating
interactive controls (explained in Chapter 10); and the
Movie Explorer (to help manage your movie — see
Chapter 12).

Help

Comes to the rescue when you need help.

Many menu commands offer keyboard shortcuts. You can create your own
keyboard shortcuts. (See Appendix A for instructions.)
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The shortcuts are displayed on the menus, next to the command name. Here
are some of the most commonly used keyboard shortcuts (for more short-
cuts, see the tear-out Cheat Sheet at the front of this book):

v Ctrl+N (Windows) or 88+N (Mac): Start a new movie.
v Ctrl+O (Windows) or 38+0 (Mac): Open an existing movie.

v Ctrl+S (Windows) or 88+S (Mac): Save your movie. Don’t forget to use
this shortcut often!

1 Ctrl+X (Windows) or 88+X (Mac): Cut to the Clipboard. Chapter 4 explains
more about using the Clipboard.

v Ctrl+C (Windows) or 38+C (Mac): Copy to the Clipboard.
v Ctrl+V (Windows) or 38+V (Mac): Paste from the Clipboard.

v Ctrl+Z (Windows) or 8+Z (Mac): Undo. Would you believe that by
default Flash remembers your last 100 actions and can undo them? What
a relief! The only problem is that Flash doesn’t provide a drop-down list
of each action, so you're somewhat in the dark about what the next
undo will undo. Think of it as a journey into the long-forgotten past.
(See Appendix A for details on customizing the number of Undos that
Flash remembers.)

v Ctrl+Y (Windows) or 38+Y (Mac): Redo redoes actions you undid by
using the Undo button. (Got that?) This button remembers just as many
actions as the Undo button. If you undo more actions than you want,
click Redo (or press Ctrl+Y) until you're back where you want to be.
Using the Undo and Redo buttons is like traveling through Flash time —
and it gives you lots of slack while you’re working.

v Ctrl+Q (Windows) or 38+Q (Mac): Exit Flash.

We mention other keyboard shortcuts throughout this book as we discuss
their corresponding commands.

You should note, although it’s not a shortcut, that you can find the Zoom
Control box in the upper-right corner of the Stage. Click the arrow and
choose a zoom factor to zoom in and out.

You aren’t limited to the choices on the Zoom drop-down list. Type a number
in the Zoom Control box and press Enter to set your own zoom factor. For
example, type 85 to set the zoom factor to 85 percent.
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Figure 1-2:
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Staging your movies

The white box in the center of your screen is the Stage. Think of the Stage as
a movie screen where you place objects. Each screen is a frame, just like the
frames of a movie. You make an animated movie by creating a number of
frames that play quickly, one after the other. Flash also plays back movies
on the Stage.

Following a timeline

The Timeline window divides your movie into frames. Each frame represents
a tiny stretch of time, such as % of a second. Creating a movie is simply a
matter of assembling frames, which are then quickly played in order.

Chapter 9 explains in detail how to make using the Timeline completely pain-
less. For now, you should just understand the basics. See Figure 1-2 for the
basic Timeline.
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On the left side of the Timeline is the layer list. When you open a new movie,
you see only one layer, unimaginatively named Layer 1. A layer is like a sheet
of transparent acetate on which you draw objects. Layers help you keep
objects from running into each other, causing unfortunate, messy results. You
organize your entire movie by using layers. For example, if you want to keep
some text constant throughout the movie but animate a bouncing dot, you
would give the dot its own layer and animate it on that layer. The layer list
has room for more layers, and you can add as many layers as you want.
(Chapter 6 gives you the lowdown on layers.)

You can move the bottom edge of the Timeline to make room for more layers.
Hover the mouse cursor over the bottom line until you see the two-headed
arrow. Drag downward to add room for more layers.
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To the right of Layer 1, you see a bunch of rectangles, each representing a
frame. (Actually, before you start using the Timeline, they’re just potential
frames, like unexposed frames on a roll of film.) By default, each frame lasts
Y12 of a second. Each layer has its own row of frames because you can have
different animations or objects on each layer.

A keyframe is a frame that defines some change in your animation. In some
animations, every frame is a keyframe. Other animations need keyframes for
only the first and last frames.

You don’t use the Timeline until you're ready to animate. As you work, how-
ever, you should organize your objects on separate layers. Don’t worry —
you can always move an object from one layer to another.

Getting Help in a Flash

This book is all you need to start creating great animations, but we would be
remiss if we didn’t tell you about the Flash Help system. The Flash manual
(you already have it if you didn’t purchase Flash by downloading) is exactly
the same as online Help. Even the index is the same. Online Help simply adds
a search engine. All online Help files are in HTML format, so your computer
opens them in your browser.

To use Flash Help, choose Help=>Using Flash or press F1 (Windows only). You
see a screen like the one shown in Figure 1-3.

Four Help manuals

Flash Help contains three sections. Using Flash is the main Help manual, and
another section contains the ActionScript dictionary. ActionScript is the pro-
gramming language you use to create complex interactive movies. A new
ActionScript reference is available as a window on the main Flash screen.
(See Chapter 10 to find out more.) Finally, Flash provides tutorials to help you
find out how to use Flash. In this section, we concentrate on the Using Flash
section.

Contents, index, and search

The main Help screen has three tabs on the left panel. Click the tab that you
think may help you find an answer quickly. The following list describes how
to use the tabs:
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v~ Contents: Click a topic and look at a list of subtopics. Click again and
helpful text appears on the right side of the screen.

v Index: Click a letter of the alphabet or click A-Z to peruse the entire list.
Click any topic to display it on the right side of the screen.

v Search: Type a search word or words to open the Flash search facility. If
you search by typing multiple words, put a plus sign (+) between them.
Uncheck Case Sensitive for more flexibility. Click List Topics to show the
results in the Search box. Double-click the topic to display it on the right
side of the screen.

Using the tutorial

Flash contains a set of lessons plus a tutorial to help get you started. We
recommend starting with the lessons by opening Flash and choosing Help=>
Lessons=Introduction. Follow the on-screen instructions to move from
lesson to lesson.
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For updates and downloads, visit the Flash Support Center.
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After you finish the lessons, try the tutorial. If you have the printed manual,
you can find the tutorial in Chapter 1. Otherwise, choose Help>Using Flash.
On the left side of the main Help screen, under Contents, click Tutorial. You
may want to print the pages so that you don’t have to switch back and forth
between Flash and the tutorial page.

Finding more help on the Web

Macromedia offers some support on its Web site. To access it, choose Help=
Flash Support Center. The Macromedia Flash Web site, which you can find at
www.macromedia.com\software\flash, also has a showcase of Web sites
(www.macromedia.com/showcase/) that use Flash (and other Macromedia
software) — a great place to see what Flash can do.

You can also click the Flash Support Center link to www.macromedia.
com/support/flash, at the bottom of the main Help page, for updates
and downloads.

Choose Window=>Answers to access more online Flash resources from
Macromedia.

Try It, You'll Like It

Perhaps by now you’re getting impatient to try out Flash. Getting started is
easy. You collect a few ideas, put together some art, add animation, save your
movie, and publish it. Then you view it in a browser either online or offline.
That’s the gratifying part. In the following sections, you get to give Flash a try
by working through a basic animation.

Conceiving your first animation

Suppose that you want to add an animated logo to a home page you have
already set up. You want the animation to run when the page loads and then
stop. Figure 1-4 shows the Rainbow Resources company logo — unanimated,
of course — that you can find on the CD that comes with this book.
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|
Figure 1-4:
A company
logo that
could stand
some
animation.
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Suppose that you want the word Rainbow to fly into your page from the right
and the word Resources to fly in from the left. At the same time, you want the
graphic to rotate 180 degrees. You find out in the following section how to
create this animation.

Creating flashy drawings

You can use Flash to create a company logo, but importing one from this
book’s CD-ROM is simpler. Often, you import existing graphics (such as a
company logo) from a file rather than create them from scratch. (Chapter 3
explains how to import and manipulate graphics.)

If you're going through the steps and make a mistake, choose Edit=>Undo
(or press Ctrl+Z) and try again. You can use Undo repeatedly to undo several
steps, if necessary.

To import the Rainbow Resources logo into Flash, follow these steps (the
steps may vary if you're importing some other graphic in a different format):
1. Start Flash.

See the instructions in “Starting Flash on a PC” or “Starting Flash on a
Mac,” earlier in this chapter, if you need help.

You see a spanking-new movie on your screen.
2. Choose Filec>Import.
The Import dialog box opens.

3. Browse the dialog box until you find rainbow.gif in the ch01 folder of
the CD-ROM.

4. Click to select rainbow.gif and then click Open.

You see the logo on your screen. You need to break the logo into pieces
and make it a vector graphic so that you can animate it.

5. Choose Modify~>Trace Bitmap. In the Trace Bitmap dialog box, set the
color threshold to 100, the minimum area to 1, the curve fit to Pixels,
and the corner threshold to Many Corners. Click OK in the Trace
Bitmap dialog box.
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Flash creates a vector graphic and breaks up the graphic into individual
components. The entire graphic, however, is selected.

6. Click anywhere outside the graphic to deselect it.

7. Delete the invisible square around the graphic (which is unnecessary)

by clicking near, but not on, the logo.

You see the square selected.

. Press Delete.

The square goes away, but the rest of the logo stays behind.

You've got your logo! Now you need to set it up for animation.

Turning your objects into symbols

In the logo you imported in the preceding section, each letter is a separate
object, which can get pretty confusing. Each line in the logo’s design is also
separate. But you want your words to stay together and the little design, too.
So combining each word and the logo into a symbol is necessary.

To turn the words and the logo into symbols, follow these steps:

1.

Click the Zoom Control drop-down box and choose 200%.

Use the scroll bar to scroll the words of the logo into view, if necessary.

. Click the arrow tool on the Drawing toolbox if it’s not already

selected.

. Click the upper-right corner of the word Rainbow (just above and to

the right of the w) and drag to the lower-left corner of the R.

Dragging from right to left makes it easier to avoid selecting the logo at
the same time. You should see the entire word selected. If not, click out-
side the word and try again.

. Choose Insert=>Convert to Symbol. In the Convert to Symbol dialog

box, click OK.

You can accept the defaults in the Convert to Symbol dialog box. When
you click OK, Flash places a box around the word so that you can see
that it’s one object.

. Repeat with the word Resources the procedure outlined in Steps 3

and 4.

In this case, you may want to start clicking and dragging from the upper-
left area of the word; then choose Insert>Convert to Symbol again and
click OK. Now all the letters of the word Resources are a single object.

. Click the Magnification drop-down box and choose 100% so that you

can see the entire logo.
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7. Click the upper-left area of the logo and drag to the lower right to
select the entire logo.

8. Hold down the Shift key and click each word to remove both words
from the selection.

9. Press F8 (the keyboard shortcut to create a symbol) and click OK.

Flash creates a symbol from the lines of the logo’s design.

See Chapter 7 to find out more about symbols.

Putting your graphics on layers

Placing different components on different layers is required when you’re ani-
mating. You need to use layers to organize your movie and keep shapes sepa-
rate so that they don’t bump into each other. (See Chapter 6 for the complete
story on layers.)

To split your three components onto three separate layers, you can use a
new feature of Flash MX: Distribute to Layers. Follow these steps:

1. Click the arrow tool on the Drawing toolbox if it’s not already
selected.

2. Drag diagonally across the entire logo, including the two words, to
select it.

You should see two rectangles inside one bigger rectangle. All three
objects in the logo are selected.

3. Choose Modify->Distribute to Layers.

You now have three new layers, named from Symbol 1 through Symbol 3.
The three objects of the logo have been distributed to Symbol 1 through
3 and removed from Layer 1.

4. Click outside the Stage to deselect any objects.

You're now ready for the animation process.

Making graphics move

We explain earlier in this chapter that your goal is to have the word Rainbow
fly in from the right and the word Resources to fly in from the left. You also
want the graphic to rotate 180 degrees at the same time. What you see now
is how the animation will end — the last frame of the movie.
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Follow these steps to create the last frame of the movie and save the file:
1. In the second row (Layer Symbol I), click frame 30 of the Timeline
and choose Insert=>Keyframe.
You can find out more about keyframes in Chapter 9.

2. In the middle row (Layer Symbol 2), click frame 30 and choose
Insert->Keyframe.

3. In the third row (Layer Symbol 3), click frame 30 and press F6 (the
shortcut for creating a keyframe).

4. Choose Filer>Save and pick a location where you save other docu-
ments you create.

We don’t recommend saving the file in the Flash MX program folder —
it may get lost among your Flash program files.

5. Give your movie a name, such as Movie of the Year, and click Save.
Flash creates a file named Movie of the Year.fla.
Go back and create the beginning of your movie. Flash can fill in all the blanks

in between. Follow these steps to create the beginning of the movie and the
animation:

1. If the Properties panel is not already open, choose Windowr>Properties
to open it.

2. Select the word Rainbow. Click the first frame of the Timeline in the
highlighted row.

When you select the word Rainbow, you can tell which layer it is on by
looking at the highlighted layer.

3. Press and hold down the Shift key while you drag the word to the
right, just off the Stage into the gray area.

You may need to use the horizontal scroll bar to see the gray area.
Pressing Shift keeps the object from moving up or down as you drag to
the right.

4. Click the word Rainbow'’s layer, anywhere between the first and the
30th frame.

5. On the Tween drop-down list of the Properties panel, choose Motion.

You now see a solid arrow and a light blue color on the Timeline
between the first and 30th frames.

6. Repeat Steps 2 through 4 for the word Resources. When you move
the word Resources, hold down the Shift key and drag the word to
the left, just off the Stage.
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10.

11.

12.

13.

14.

. Select the logo design and click the first frame of the Timeline in the

highlighted row.

. Choose Modify~> Transform>Rotate 90° CW to rotate the design

90 degrees clockwise.

. Repeat the Modify~> Transformr>Rotate 90° CW command to rotate the

design a total of 180 degrees.

Click the logo’s highlighted layer, anywhere between the first and
30th frames and choose Motion from the Tween drop-down list of the
Properties panel.

If necessary, drag the horizontal scroll box until the Stage is in the
center of your screen.

Otherwise, you won'’t be able to see the entire animation — and you
don’t want to miss this one!

Click the first frame of any layer.
Your screen should look like the one shown in Figure 1-5.

Press Enter (Return) and watch the animation. (Start writing your
Academy Award acceptance speech.)

Save your movie again by choosing Filez>Save.

Publishing your first animation
for posterity

You can’t watch the animation in a Web browser until you publish it and
insert it into an HTML document. To do so, follow these steps:

1.

Click the Stage to change the display of the Property inspector.
You should see the Flash Player 6 button next to the Publish label.

. Click Flash Player 6 in the Property inspector.

The Publish Settings dialog box opens.

3. Click the HTML tab.
4. Click the Loop check box in the Playback section to uncheck it.
5. Click Publish and then click OK to close the dialog box.

With scarcely a blip, Flash publishes your movie and creates two files,
one named Movie of the Year.swf (assuming you used that name) and
Movie of the Year.html. They’re in the same folder as your .fla movie
file. Movie of the Year.html contains the HTML code required to display
your movie on a Web page.
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6. Open your Web browser and work offline.
7. Choose File~>Open and find Movie of the Year.html (or whatever you
named your movie file).
You may need to click Browse and navigate to the file.
8. Double-click the file.
Click OK to close the Open dialog box if necessary. Your browser opens
the HTML document and reads its instructions to play the Flash movie.
9. Sit back and watch it roll.
Don’t blink or you’ll miss it. (If you do miss it, click Refresh in your
browser.) You can see the movie in Figure 1-6.
¢ c 10. When you finish watching the movie, close your browser.
W

folder on the CD-ROM.

§@ You can find the Movie of the Year files (.fla, .html, and .swf) in the Ch01
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|
Figure 1-6:
The Movie
of the Year
animation

in detail.
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Exiting Flash

When you finish creating something in Flash, choose File>Exit (Windows) or
choose Filer>Quit (Mac).



