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Chapter 1
The 37-Minute Overview

In This Chapter

Starting the program

Opening a database that’s already there
Thumbing through the parts of a database
Finding a record

Changing a record

Printing a report

Saving your changes

Getting out when you're finished

It’s confession time. This chapter probably takes longer than 37 minutes to
finish. Then again, you may spend less time than that if you're somewhat

familiar with the program or if you're a speed-reader. Either way, the chapter
does give you a good overview of Access 2003 from start to finish (and [ mean
that literally).

Because the best way to get into Access is to literally get info it, this chapter
leads you on a wild, galloping tour of the software, covering the highlights of
what you and Access will probably do together on a daily basis. Think of the
chapter as a “Day in the Life” story, designed to show you the important stuff.

If you're new to Access 2003, this chapter makes a good starting point. If you're
familiar with older versions of Access, | recommend that you skim this chapter
anyway to see the changes introduced in this new version. Enjoy the trip!

In the Beginning, There Was
Access 2003

To start Access, click the Start button and choose Microsoft Access 2003
from the Start menu (see Figure 1-1). If Access is hiding from you, look for a
program group with a name such as Office or Microsoft.

.
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If you still can’t find Access on the Start menu, you have to create your own
shortcut (egads!). Follow these steps to create a shortcut:

1. Click the Start button. Then, depending on which version of Windows
you use, choose Find=>Files or Folders or choose Search-=>For files and
folders.

The Find: All Files dialog box appears.
2. For the file name, type msaccess.exe, and then click Find Now.
Windows finds the program file.

If Windows finds two copies of the program (as Figure 1-2 shows), that
usually means your system has both an older and a newer version of
Access installed. To tell the two programs apart, right-click the first
entry, and choose Properties from the pop-up menu. A little window
appears, sharing all kinds of nifty information about the file. Click the
Version tab along the top of the little window. For Access 2003, the file
version number should start with 11. If it begins with something smaller
than 11, close the window and repeat the process with the other file. If
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|
Figure 1-2:
Drag the
Accessicon
onto the
Start menu
to add

it to the
computer’s
program list.

neither file shows the right version number, Access 2003 apparently isn’t
installed on your machine (or at least Windows can’t find it). In that
case, haul out the CD-ROMs and install the little fellow.

3. Right-click (hold down the right mouse button) and drag the file from
the Search Results window to the Start button.

The Start menu opens.

4. Drag the file to Programs and release the mouse button where you
want Access to appear (see Figure 1-2).

A pop-up menu appears, asking you what you want to do.
5. Choose Create Shortcut Here.
Congratulations. You just added a shortcut to the Start menu!
Granted, the shortcut’s name needs some help (something called shortcut to
msaccess.exe looks pretty geeky on your menu), but you can correct that with
just another click or two. To rename the shortcut in your menu, right-click

and choose Rename. Type a clever new name in the Rename dialog box, and
then click OK.
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Opening an Existing Database

Access without a database file is like a CD player without a CD: Nice to look
at, but you can’t dance to it.

Database files fall into two distinct categories:

v Database files that exist: Odds are good that you're working with an
existing database (after all, you build a database once, but use it for-
ever). If so, read on — this section is for you.

v Database files that don’t exist: If you're bound and determined to create
a database, flip to Chapter 4 for detailed help on design and creation.

If you just started Access 2003, your screen looks like Figure 1-3. By default,

AW . : :
Access opens with the task pane displayed. The task pane sits on your
screen, looking quite handsome, waiting for you to open an existing database,
create a new one, and so on. Opening an existing database takes only a
moment — simply select it from the list in the Open section.
2 Microsoft Access |- (=]x]
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If you don’t see the database you're looking for, follow these steps:

1. In the Open list, click More.
The Open dialog box appears, as shown in Figure 1-4.
2. Double-click the database you're interested in.
The database loads, and you’re ready to work.
If you still can’t find the database you want, it’s probably in another directory

folder. Skip to the sidebar in Chapter 6 for help with tracking down the data-
base in your hard driveor network.

If you've worked with Access for a while (printing reports, checking out a
form or two, and generally keeping yourself busy) and now want to open
another database, follow these steps:

ﬁ 1. Choose File=>Open or click the Open button on the toolbar.

The Open dialog box (still appearing for your viewing pleasure in
Figure 1-4) pops onto the screen.

¥ Microsoft Access INEIES
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2. Double-click the name of the database you want to use.

If the database isn’t listed, it’s probably in some other folder. Skip to the
sidebar in Chapter 6 for help with tracking down the database in your
hard drive or network.

If you see an ominous-looking message asking whether you want to convert or
merely open your file, it means that the database file you want to use came
from an older version of Access. Access 2003 wants to convert your existing
files to the current database file format — and you probably want it to do that,
too. Follow the on-screen instructions for turning the database into a cool, new
Access 2003 table, and everything should turn out just fine. Remember to back
up the file before converting it (just in case something goes wrong)!

Touring the Database Window

A\

When a database opens, it usually looks like Figure 1-5. Although Access
stores all the parts of your database in one big file, it organizes them inside
that file by what they are: tables, queries, forms, and so on. Access refers to
all these things as objects, because it just can’t bring itself to use the term
stuff. To list a particular kind of object in your database, click one of the but-
tons under the Objects bar (on the left side of the window). The right side of
the window changes to show all the stuff — er, objects — in the category,
along with a few extra entries for making new objects and fiddling with the
ones already there.

The top of the database window tells you the file format. In Figure 1-5, the
format is Access 2000. You can use Access 2003 to open prior file versions
(such as Access 2000 or Access 97), but you can’t use anything older than
Access 2000 to open an Access 2003 file. That’s why everyone you work with
should use the same software version!

After opening the database, you can fiddle with its parts:

v To open a table, click the Tables item under Objects, and then double-
click the table you want to see.

v To run a report, query, or form, click the appropriate item in the Objects
section and then double-click the item you want to work with.

» When you get tired of a database, close it by clicking the Close button
(the X box in the upper-right corner of the window) or by choosing
File>Close. If you're a keyboard fan, Ctrl+W does the deed without dis-
turbing the mouse. (No, [ don’t know how they got Ctrl+W from the word
Close either. I guess all of the good letters were taken.)

If you want to know more about working with the cool Access 2003 interface,
check out Chapter 2.

.
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If some kind soul invested the time to make your life a little easier, a startup
screen (or switchboard) resembling Figure 1-6 appears automatically when
you open the database. The switchboard is basically a glorified menu of
things to do with the database. Chapter 4 has more information about startup
screens.

B Main Switchhoard

How to Get Started
_I Enter/View Addresses
_I Find Addresses.

_I Preview Repoits...
_| Create and Print Label:
| Merge Itwith word
_I Administration

_I Cloze Database

Finding Information Amongst the
Grass Clippings

If you want preschoolers to eat something, just let them take it outside and
drop it into the yard first, preferably right after you cut the lawn with a
mulching mower. Finding specific information in your Access table is a little

.
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like a toddler’s method of sifting through sticky grass in search of candy.
Whether you're looking for last names, first names, part numbers, or postal
codes, Access makes finding your target records a whole lot easier — and
infinitely less messy.

Here’s one way to find records:

1. Open the table that you want to search.
If you don’t know how to open a table, go back to the preceding section.
2. Click the column you want to search.

The blinking toothpick cursor leaps into the column, showing that
Access really heard you.

ﬁ’a 3. Choose Edit~>Find or click the Find toolbar button.

The Find and Replace dialog box appears, as shown in Figure 1-7. Access
displays the name of the current field in the Look In section of the dialog
box. To look in the entire table, click the down arrow next to the field
name, and then choose the table entry from the drop-down list.
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4. In the appropriately named Find What text box, type the text you
want to find.

Spell carefully because Access looks for exactly what you type!
5. To start the search, press Enter or click the Find Next button.

The search begins — and probably ends before you know it. If the pro-
gram finds a matching record, Access highlights the data, as shown in
Figure 1-8.

If no record matches your criteria, a big, officious dialog box informs
you that Microsoft Access finished searching the records but found no
matches. (If the Office Assistant is on the screen, you are quietly told the

.
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search results rather than whacked by the big dialog box.) Click OK and
smile as the dialog box disappears; then double-check what you typed in
the Find What text box. You probably just mistyped something. If so,
correct it and try the search again.

Custamer 10 Fitst Name Last Marne | Organization Marne Addressl Address2 -
Findﬂld Replace B ‘ S - I );le ;;A S;iapeer
Find | Repree | Fishe
Find What  [nelson =] [FEndTiEE ] ﬁ:‘hﬁz
p— Gregr
Lok In: [rsrttiame =] C—I \Tﬂ%
Match: whole: Field - Dakla
B seacht [ 5 Wune
I~ Match Case [V Search Fields As Formatted pt. F Braver
o] Carmt
—__TH[Faula Hiler S VVaterbury Cir Carrmi
— 20[Erika Whitechurch 3672 E. Sediak Tr Browr
- = 21|Bruce Vatsak BY C . Inc|1 Captain's Square Suite 3100 Indian
Flgure 1-8: 22|Sam Gregory Whimseco 1620 Edmondson Ave Plainf
o] 23[Amanda Tiller: B E. Market Suite 201 Indian
Customer 24| Gretchen Hankla Daisyfield Shops | 227 Daisyfield Dr. Mable
Nelson is T S5 C oo A e
27 [Mario Schussler 1625 Euclid Ave Fortyil
foundl 3 28[Harry 19474 Wermeer Dr. Carri
rr——| LR [ 2 > as*|of a2 Pl | _>|—|
® Access automatically tries to match an entire field in the table with
what you typed. So, if you type Kaufeld in the Find dialog box, Access
won'’t find a record containing Kaufeld School of Creative Writing. Why?
Because that entry is not an exact match for Kaufeld — it’s only a partial
match. To make Access accept partial matches as well as full ones,
change the Match setting in the Find and Replace dialog box from
Whole Field to Any Part of Field.
If you still can’t find the record, Chapter 10 provides more details about
the Find dialog box.
6. When you’re finished, click Cancel or press Esc to close the Find
dialog box.
S
é\("N— TU&

The right mouse button also provides some devious ways to find records, but
I'm saving those tricks for Chapter 10.

Making a Few Changes

Unfortunately for fruit growers and dairy farmers, life isn’t always peaches
and cream. Your customers move, the phone company changes an area code,
or the digital gremlins mess up your typing skills. Whatever the cause, your
job probably includes correcting the various problems in your database.
Lucky you.

17
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Changing the stuff in your tables isn’t hard. In fact, making changes is almost
too easy. The follow list outlines the precise steps you need. Keep in mind
that Access 2003 automatically saves your changes. When you finish working
on a record, Access writes the new information to the database right then. If
you make a mistake, immediately press Ctrl+Z to undo your changes — don’t
put it off until later.

Here’s a quick word from the Society of the Perpetually Nervous: Be very
careful when changing the records in your database. Making changes is easy;
recovering from them can be tough. Access can help you undo only the last
change you made.

When you’re ready to change a record, follow these steps:

1. Open the table by double-clicking it in the database window.

Your table appears, with its data hanging out on the screen and gener-
ally looking cool.

2. Click the field you want to change.

A flashing toothpick cursor appears in the field, and the mouse pointer
changes to an I-beam.

3. Perform whatever repairs the field needs.

All the standard editing keys (Home, End, Backspace, and Delete) work
when you’re changing the contents of a field in Access. See Chapter 6 for
the key-by-key details.

4. When the field looks just right, press Return to save the changes.

As soon as you press Return, the data is saved — and [ do mean saved. If
you immediately decide that you like the old data better, press Ctrl+Z or
choose Edit=>Undo Saved Record.

Reporting the Results

A\\S

Capturing all those wonderful details in your tables is nice, but seeing those
records fill a printed page looks even nicer. That’s where the Access report
system comes into play.

Making your database look wonderful on paper is a cinch with Access. The
program has all kinds of report options, plus a reasonably strong report
wizard to walk you through the hard stuff. Part IV tells you all you could ever
want to know about the really cool report features.

Because printing a report is one of the most common things people do with
database programs, here’s a quick look at how it works in Access:

.
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No matter where you are in Access, help is
always nearby. Chapter 3 covers all your help
options in gory detail, but here’s one to get you
started.

If you're stumped for what to do next, press
the F1 key; this is the Windows universal help me
key. The F1 key displays a task pane that’s jam-
packed with help topics ranging from an
overview of the newest, coolest features of

Help is always just a few clicks away

Access 2003 to phenomenally trivial explorations
of macros. If your computer has a live Internet
connection, the Help task pane also connects
you a multitude of online Office assistance, too.

Unless you're in the mood to browse, pose your
question to the Office Assistant or type your
search topic into the box at the top of the
window and see what the Help system offers.
Either way, your answer is only a moment away!

1. In the database window, click the Reports button.

Access lists all of the reports available in this database, as shown
in Figure 1-9. If the list shows only the two Create report options, no

reports exist yet. In that case, flip ahead to Part IV for help building and

using reports.

&8 Hawktions2003 : Database (Access 2000 file format)
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2. Right-click the report you want to print.

A menu pops up next to your mouse pointer.

19
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3. Choose Print from the pop-up menu, as shown in Figure 1-10.

Access puts a little dialog box in the middle of the screen to tell you how
the print job is going. When the print job is finished, the dialog box van-
ishes without a trace.

If you change your mind while the report is printing, click Cancel in the
Print dialog box to stop the process.

g% Hawktions2003 : Database {Access 2000 file format) [ (O]
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Figure 1-10: || & Favont.. i Print
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Saving Your Hard Work

The Access 2003 automatic save feature is good because it’s one less detail
left lying around to clutter up your life. Whether you entered a bunch of new
records or simply corrected a couple that were ever-so-slightly wrong, your
work is automatically safe and sound.

On the other hand, the automatic save feature isn’t so good because Access
doesn’t pay any attention to what it saves — it just saves everything in the
database file. If you accidentally wipe out 237 records and then make a few
errant clicks, you can say good-bye records, hello backups.

[ said it before, but it bears repeating: When you change the records in your

tables, please be careful. Messing up a record takes only a second. Don’t let
this tragedy happen to you.

.
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The Great Backup Lecture

\\3

A\

[ know you've probably heard this before, but the PC support nerd in me
won'’t let the chapter close without a few words about backing up your data-
bases. Although I joke about it, regular backups are a vital part of using
Access (or any program, for that matter).

Why is backing up so important? Take a minute and imagine life without your
computer. Don’t reminisce about business in the Good Old Days of the 1970s —
think about what would happen if you walked in one morning and found no
computer awaiting your arrival. None. Zippo. The desk is empty — no business
letters, no receivables, no customer list, nothing. Everything was on the com-
puter, but now the computer is history.

Unless you want to wave good-bye to your business, you need a formal
backup plan. Even if it’s just you and your computer, make some notes about
how your backup process works:

1+ How often is the computer backed up? A better question is “How much
data can you afford to lose?” If your information changes daily (an
accounting system, for example), you need to make backups every day
or two. If you mainly play adventure games on your machine and use
Access as infrequently as possible, back up every week or two. No uni-
versal rule is right for everyone.

1 Where are the backup disks or tapes stored? If the backups are conve-
niently stored right next to the computer, they’ll be conveniently
destroyed along with the computer in the event of a fire, tornado, or hur-
ricane. Keep your backups in another building, if possible, or at least in
another room.

1 How do you back up the data? Write down a step-by-step procedure,
along with a method for figuring out what tape or disk set to use in the
backup process.

+ How do you restore the data? Again, create a step-by-step process.
Your mind won’t be particularly clear if tragedy strikes and you have to
restore destroyed data, so make the steps simple and understandable.

After you settle into the backup routine, try restoring your data once to make
sure that your system works. You're much better off finding out before the disk
dies rather than afterward. Set aside a few hours to ensure that your efforts
pay off on that fateful day when the disk drive dies. You’ll thank me later.

If you're in a corporate environment, it’s possible that your local Department
of Computer People automatically backs up your data. To find out for sure,
give them a call.

21
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Making a Graceful Exit

When it’s time to shut down for the day, do so the right way:

1. If you have a database open, choose File=>Close or click the Close
button in the upper-right corner of the database window.

\3
P I'm old-fashioned enough not to trust my program to close everything by
itself without screwing something up. Whenever possible, I save and
close my work manually before shutting down the program.
2. Close Access by choosing File- Exit.
\‘&N\BEB Go ahead and shut down Windows as well if you're finished for the night. To
& do so, click the Start button and then click Shut Down. When Windows asks

whether you’re serious about this shutdown, click Yes. After Windows does
whatever it is that software does just before bedtime, turn off your computer
and make your escape to freedom.



