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Using Workbook
Files

orking with files is critical to using any software. Microsoft

Excel files are known as workbooks. This part covers the
procedures that you need to know to manage workbook files
efficiently.
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Changing the Default File Location

After you open a file in Excel, by default the Open dialog box points
to the My Documents folder as the starting location to open files. If
you keep frequently used documents in a different folder, you may

want the Open dialog box to point to this different folder instead to

save some navigation steps. To change this default folder, follow
these steps:

1. Choose Tools=>Options from the menu bar.
2. In the Options dialog box that appears, select the General tab.

3. In the Default File Location text box, enter the path of the new
default starting location to open files. For example, if your new
default file location is in a subfolder named Excel, which itself
is in a folder named Program Files on drive C, enter the path
C:\Program Files\Excel.

4. Click OK

Creating Multiple Window's
(Views) for a Workbook

Sometimes, you may want to view two different parts of a work-
sheet at once. Or, you may want to see more than one sheet in the
same workbook. You can accomplish either of these actions by dis-
playing your workbook in one or more additional windows.

To create a new view of the active workbook, choose Windowr>New
Window from the menu bar. Excel displays a new window for the
active workbook. To help you keep track of the windows, Excel
appends a colon and a number to each window.

Dep-budg.xls:1
A B [ [ [ D \ E | F
| 1] Quarter 1 Quarter 2 Quarter 3 Quarter 4
| 2 |Salaries | $375,000.00 | $375,000.00 | $375,000.00 $375,000.00
| 3 |Travel $ 320000 % 320000 % 320000 $ 3,20000
| 4 |Supplies  § 25,000.00  $ 2500000  $ 2500000 ¢ 2500000
5 |Facility $ 13,500.00 | $ 13,500 N .
;Total $416,700.00 | 416,700 e b:dg')dls'z = I = ‘ = QCT]
1 | 1] Quarter 1 Quarter 2 Quarter 3 [l
% | 2 |Salaries | $490,000.00 | $490,000.00 $490,000.00
Bl | 3 |Travel $ 220000 $ 220000 § 220000
BT 4 |Supplies | $ 18,500.00 | § 18,500.00 $ 18,500.00 | |
3 | 5 |Facility $ 2290000  $ 2290000 ¢ 22,90000
A \Operations[ Man.fachring %Tota\ $533,600.00 | $533,600.00 $533,600.00
8 |
| 9|
10 =
(LI 2 ] /( Cperations S\Manufacturing/fh | | 4 H—

.
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See also “Arranging Windows Automatically,” in Part II to see all
your workbook views simultaneously.

Remember: A single workbook can have as many views (that is,
separate windows) as you want.

Displaying multiple windows for a workbook also makes copying
information from one worksheet to another easier. You can use
Excel’s drag-and-drop procedures to copy a cell, a range, a graphic
object, or a chart.

Deleting a Workbook File

If you no longer need a workbook file, you may want to delete it
from your floppy disk or hard drive to free space and reduce the
number of files that appear in the Open dialog box.

You can delete files by using standard Windows techniques (for
example, by using the Delete option in Windows Explorer or in a
third-party file manager program), or you can delete files directly
from Excel by following these steps:

1. Choose either Filer>Open or Filer>Save As from the menu bar
to open a dialog box that displays a list of filenames.

2. Right-click a filename, and choose Delete from the shortcut
menu that appears. Depending on how your system is set up,
you may need to confirm this action.

Open
Lack in: [= Budgets = ~@Q K [y [ ~ Toos~
1 Name Size | Type ”~
Lmﬁ account-db, =" 79KE Microsoft Excel Wor,..
Iy Rece. .. BLdgetDat:  Select 1,796 KB Microsoft Excel Wor...
. jBuslness Plal 99 KB Microsoft Excel Wor. ..
I % ACalculator>)  Open 4728 KB Microsoft Excel War...
¥ car loan.xls Edit 18 KB Microsoft Excel Wor, .
Desktop %)Commission New 15KB  Microsoft Excel Wor...
MDep-budg x 3 15KB  Microsoft Excel Wor...
s SEmployees;  Print 15KB Microsoft Excel Wor.. | _
__—/ ]Equ\pmentf Open With 3 14 KB Microsoft Bxcel Wor,.. |~
Iy Documents Five Year Sa TextPad QEKB  Microsoft Excel Wor,..
— ]GHNG Forec 4B KB Microsoft Excel Wor,..
:};g ]Jusufy Exan Send To » 14 KB Microsoft Excel Wor, .
Link summa 12 KB Microsoft Excel Wor, .
My Computer LinkSoLrce Cut 12 KB Microsoft Excel Wor,.,
— Lo Calewl: 14 KB Microsaft Excel Wor, .,
Marketing Bt Copy 17 KB Microsoft Excel Wor, .,
v jMoﬂlﬁly Res 18KB Microsoft Excel Wor...
My Metwo... ‘Operations £ Create Shorteut 16 KB Microsoft Excel Wor ...
Msses Budge  Delete 35 KB  Microsoft Excel Wor, ..
%)5des Report Rename 14 KB Microsoft Excel Wor, . I"]
8 | 2)
File pame: Properties ﬂ Open -
Files of fype: All Microsoft Excel Files (*.xI*; * xls; *.xlt; *.htm; *.html; *‘mhtj Cancel
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P If your system is set up to use the Recycle Bin, you can often
recover a file that you delete accidentally. Before you empty the
Recycle Bin, open it and drag out any items that you want to save.

Opening Nonstandard Files

In The Big Picture part, we describe the procedure for opening
standard workbook files. In this section, we show you how to open
non-Excel files, older Excel files, and workspace files.

Opening a non-Excel or older Excel file

Excel 2003 can open files that weren’t saved in its native format by
using filters to open the foreign file as a workbook file.

To open a non-Excel or older Excel file, follow these steps:
1. Choose File=>Open to display the Open dialog box.
2. Select the file type from the Files of type drop-down list box.

3. Specify the folder that contains the file in the Look In drop-
down list.

4. Select the file and click Open, or double-click the filename.

Excel can open files saved in any earlier version of Excel (*.XLS,

* XLT, * XLC, *.XLW, *.XLM) or files saved in Lotus 1-2-3 (*.WKS,

* WK1, *.WK3, * WK4), Quattro Pro (*.WQ1, *WB1, *.WB3), text
(*.CSV, *.TXT, *.PRN, *.DIF, *.SLK), Microsoft Works for DOS or V2.0
for Windows (*.WKS), HTML (*.HTM, *.MHT), XML (*.XML), Access
databases (*.mdb, *.mde) and Dbase (*.dbf) files.

Opening a workspace file

To open a workspace file, follow the steps outlined for opening a
non-Excel or older Excel file, except in Step 2, select Workspaces
(*.XLW) in the Files of type drop-down list box. Excel opens all the
workbooks that you originally saved in the workspace.

See also “Saving a workspace file,” later in this part.

Protecting a Workbook File

Sometimes, you may want to protect a workbook by preventing
users from adding or deleting sheets. Or, you may want to ensure
that the workbook’s window size or position doesn’t change. To
protect a workbook, follow these steps:

1. Choose Tools=>Protection=>Protect Workbook from the menu
bar to open the Protect Workbook dialog box.

.
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2. Select the appropriate check box, as follows:

e Structure prevents any of the following changes to a workbook
sheet: adding, deleting, moving, renaming, hiding, or unhiding.

e Windows protects the workbook window from being moved
or resized.

3. Supply a password in the Password (optional) text box if you
feel that you need a level of protection.

4. Click OK.

To remove protection from a protected workbook, choose
Toolst>Protection>Unprotect Workbook and enter a password if
you used one to protect the workbook.

Recovering Workbook Files after
a System Crash

Excel 2003 enables you to recover previously opened files following
a system crash, application lockup, or power failure. Excel analyzes
the files that you were working on for errors. Depending on the
extent of the error, Excel repairs or recovers information in the
working files. Usually, but not in all cases, Excel can recover
unsaved data.

Document Recovery
Excel has recovered the following files. Save
the ones you wish to keep.

Available files

@ carloan.xls [Original] =]
Last saved by user
14:56 31 Juby 2003

@ Monthly.xls [Criginal]
Last saved by user
15:07 04 August 2003

@ Dep-budg.xls [Original]
Last saved by user
15:01 31 Juky 2003

=l

(@) ‘hich file do I want to save?

Close

.
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The Document Recovery task pane displays all files that were res-
cued from the last Excel session and indicates whether the files were
recovered by placing the word Recovered in brackets next to the
filename. To open, delete, or save a recovered file, follow these steps:

1. Place the mouse cursor over the recovered file in the
Document Recovery task pane.

An arrow appears on the right side of the filename.
2. Click the arrow next to the recovered file.
A menu appears.
3. Perform one of the following actions from the menu:
e Select Open to view the file.
You can also click the filename directly to open the file.
e Select Save As to save the file.
Save it by using the same or a new filename.
e Select Delete to delete the file.
e Select Show Repairs to view what repairs Excel made (if any).

4. Repeat Steps 1 and 2 for each recovered file.

You can also click the filename to open the file.
TIP

By default, Excel saves information for document recovery every
10 minutes. To change this default interval, follow these steps:

1. Choose Tools=>Options from the menu bar, and click the Save
tab in the Options dialog box that appears.

2. Make sure that the Save AutoRecover info every check box is
selected, and enter the new recovery save interval in the
Minutes text box.

You can enter from 1 to 120 minutes in the Minutes text box.

3. Click OK.

P You can turn the Document Recovery task pane on and off whenever
Excel lists recovered files by choosing Views>Toolbars=>Document
Recovery from the menu bar. This procedure is different from that
of clicking the Close button in the Document Recovery task pane,
which requires you to delete the recovered files unless you want to
view them the next time that you start Excel.

WhRNI, You don’t want to use the document recovery feature as a substi-
tute for periodically saving files, because Excel can’t always
recover unsaved data. And the recovery feature can’t help you if
you close your files normally without saving changes.

.
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Remember: If the word Original appears in brackets next to a file
in the Document Recovery task pane, Excel hasn’t recovered the
file. The version of the file that you open with an Original desig-
nation is based on the last manual save.

Saving Files

TIP

TIP

In The Big Picture part, we describe the procedure for saving stan-
dard workbook files. In this section, we show you how to save a
workbook file under a different name, save a workbook file in a dif-
ferent file format, save your work automatically, and save a work-
space file.

Saving a workbook under a different name
Sometimes, you may want to keep multiple versions of your work
by saving each successive version under a different name.

To save a workbook with a different name, follow these steps:

1. Choose Filem>Save As from the menu bar to open the Save As
dialog box.

2. Select the folder in which you want to store the workbook from
the Save In drop-down list.

3. Enter a new filename in the File Name text box. (You don’t
need to include the XLS file extension.)

4. Click Save.

Excel creates a new copy with a different name, but the original
version of the file remains intact. (Notice that the original file is no
longer open.)

You can also use the Filer>Save As command to make a backup
copy of a workbook simply by saving the file (with the same name)
to a floppy disk, a different drive, or a different folder. Excel remem-

bers only the last place that it saves the file, however, so you may
want to save the workbook again in its original location.

To prevent others from opening a workbook or from making changes
to it, select Tools>General Options in the Save As dialog box and
enter a password in the Save Options dialog box that appears.

Saving a workbook in a different or
older file format

To share a file with someone who uses an application that opens
files in a format that is different from Excel 2003, such as a much

.
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TIP

TP

older version of Excel or a version Lotus 1-2-3, be sure to save the
file in a format that the application can read.

To save a workbook in a different file format, follow these steps:
1. Choose FilervSave As from the menu bar.

2. Select the format in which you want to save the file from the
Save As Type drop-down list.

3. Click Save.

Remember: Excel 2003, Excel 2002, Excel 2000, and Excel 97 all use
the same file format so that you can use the Filem>Save command
(or click the Save toolbar button) if you're saving files to share with
users of Excel 2002, Excel 2000, or Excel 97.

To save your workbook as a Web page so that people can view it
within a browser, choose Filem>Save as Web Page from the menu
bar. In the Save As dialog box that appears, select the Entire
Workbook radio button (this is the default setting), give the file a
name with the HTM extension, and click Save.

Excel can save to any earlier version of Excel workbook (*.XLS,

* XLW), Lotus 1-2-3 (*.WKS, *.WK1, *.WK3, *.WK4), Quattro Pro for
DOS (*.WQ1), text (*.CSV, *.TXT, *.PRN, *.DIF, *.SLK), HTML
(*.HTM, *MHT), XML (*.XML), and so on.

Saving a workspace file

The term workspace means all the workbooks and their screen posi-
tions and window sizes — sort of a snapshot of Excel’s current state.

You may have a project that uses two or more workbooks, and you
may also like to arrange the windows in a certain way to make them
easy to access. Fortunately, Excel enables you to save your entire
workspace to a file. Then you can open the workspace file, and Excel
is set up exactly as it was when you saved your workspace. To save
your workspace, follow these steps:

1. Choose Filer>Save Workspace from the menu bar.

2. Use the filename that Excel proposes (resume.xlw or resume),
or enter a different name in the File Name text box.

The file extension appears only if you turn off the Hide file
extensions for known file types option on the View tab of the
Folder Options dialog box in Windows Explorer. This option is
on by default.

3. Click the Save button, and Excel saves the workspace file to a
disk.

.
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only the information that Excel needs to recreate the workspace.
Excel saves the workbooks in standard workbook files. If you distrib-
ute a workspace file to a coworker, therefore, make sure that you
also include the workbook files that the workspace file refers to.

»shl“"’c A workspace file doesn’t include the workbook files themselves —

Switching among Open Workbooks

If you have multiple workbooks open, the workbooks usually
appear maximized on-screen so that you can view only one work-
book at a time.

To switch the active display among workbooks, use either of the
following methods:

v Click the Window item on the menu bar, and select one of the
workbook names in the lower portion of the menu that appears.

1 Press Ctrl+F6 or Ctrl+Tab to cycle the active display among the
open workbooks.

Working with Workbook Templates

A workbook template is basically a workbook file that contains one
or more worksheets that are set up with formatting and formulas
and are ready for you to enter data and get immediate results. A
workbook template can use any of Excel’s features, such as charts,
formulas, and macros. Excel includes templates that automate the
common tasks of filling in invoices, expense statements, and pur-
chase orders. You can also create your own templates.

Creating a workbook template

To save a workbook as a template, follow these steps:

1. Choose Filem>Save As from the menu bar to open the Save As
dialog box.

2. Select Template from the Save As Type drop-down list box.

Excel displays the Templates folder in the Save In drop-down
list box.

3. Select the Templates folder or a subfolder within the Templates
folder, and save the template workbook in the folder that you
choose.

To create a new folder in the Templates folder in which you
can save the template, click the Create New Folder button in
the Save As dialog box and give the new folder a name.

.
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4. Enter a name for the template in the File name box, and click
Save.

Excel saves templates with an XLT file extension.

To prevent overwriting the template file when you create a new
workbook from a template, always save your templates in the
Templates folder or a subfolder within the Templates folder.

Creating a workbook from a template

If you create a new workbook that you base on a template, Excel
creates a copy of the template in memory so that the original tem-
plate remains intact. The default workbook name is the template
name with a number appended. For example, if you create a new
workbook based on a template by the name of Report xlt, the work-
book default name is Reportl.xls. The first time that you save a
workbook that you create from a template, Excel displays the Save
As dialog box so that you can give the file a new name.

To create a workbook from a template, follow these steps:
1. Choose FilecoNew from the menu bar.
Excel displays the New Workbook task pane.

2. In the New Workbook task pane, select a link to the template
you want to use from one the following categories:

¢ [n the Templates category, click the On my computer link to
display the Templates dialog box. Templates that you create
appear on the General tab if you save your template files in
the Templates folder. If you save your files in a subfolder
within the Templates folder, your files appear on the tab
with the subfolder’s name. Templates that Excel supplies
appear on the Spreadsheet Solutions tab. You can double-
click the filename in a tab to open a copy of the template.

¢ [n the Templates category, click the Templates home page
link to open a browser window that displays the Microsoft
Office Templates home page. This page provides several
Office templates that it groups in various categories and
subcategories. Click a category and subcategory heading
until you find an Excel template that you want to use. On
the page that contains the Excel template, click the
Download Now button and follow the instructions to import
a copy of the template into Excel.

¢ In the Templates category, click the On my Web sites link to
display the New from Templates on my Web Sites dialog
box. In the File Name drop-down text box, type the URL
(Web address) of the template location and click the Create

.
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Now button to import a copy of the template into Excel.
Notice that you must have an active Internet connection for
this option to work.

You can click the arrow in the File Name drop-down text box
to select the URL of previously used templates.

e Under the Recently used templates category, Excel 2003 dis-
plays the last four templates used. You can click one of
these filenames to open a copy of the template directly.

 tNew Workbook w X

New
] 8lank workbaook
E:] From existing workbook...

Templates
Search Office Online:

‘Q Termplates home page

EJ O my computer..,

&_I on iy Web sites, .,

Recently used templates

Sales Invoice
Config Yersion 30401 xlt
Balance Sheet
ExpenseStatement

3. Save the workbook after you enter the appropriate data in the
template copy. See also “Saving Files,” earlier in this part.

See also “Creating a workbook template,” earlier in this part.

Creating a default workbook template

You can create a default workbook template that defines the for-
matting or content of the new (blank) workbooks that open after
you start Excel. Excel bases blank workbooks that you create by
clicking the New button on the standard toolbar (or by pressing
Ctrl+N) on the default workbook template. The default workbook
template that you create replaces Excel’s built-in default workbook
template.

Follow these steps to create a default workbook template:

1. Create a new workbook. See also “The Basics: Creating an
Empty Workbook File,” in The Big Picture.

.
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2. Add or delete as many worksheets as you want to appear in
new workbooks. See also “Adding a New Worksheet” and
“Deleting a Worksheet,” both in Part II.

3. Apply the desired formatting, sheet names, text, style, and so
on. See also Part VII if you need help applying different format-
ting options.

4. Choose FilerbSave As from the menu bar, and select Template
from the Save As Type drop-down list box.

5. Locate an xIstart folder in the Save In drop-down box.

Excel can use more than one xlstart folder and will open all
files located in these folders on startup. The locations of the
xlstart folders depend on the version of Windows that is
installed in your system.

For Windows 2000 and XP, the xlIstart folders reside in the
C:\Documents and Settings\Username\Application
Data\Microsoft\Excel and C:\Program Files\
Microsoft Office\0ffice 11 folders, respectively.
Username is your login username.

6. Type book.xlt in the File Name text box.
7. Click Save.

All new (blank) workbooks that you create are now replicas of the
book.xIt workbook that you saved in Step 7.

You can always edit the book.xlt file or delete it if you no longer
want to use it.

P Although you can’t change the locations of the xIstart folders,
Excel allows you to place startup files (including book.xlt) in a
folder of your choice. Choose Tools=>Options to display the
Options dialog box, and select the General tab. In the At startup,
open all files in box, enter the complete path to your chosen folder.
On startup, Excel then opens all files in your chosen folder in addi-
tion to any files that are in the xIstart folders.



