
Chapter 1

Introducing Your New Best Friend
In This Chapter
� Introducing the new features of Dreamweaver MX 2004

� Examining your Web site objectives

� Finding your way around in Dreamweaver

Welcome to the wonderful world of Dreamweaver. If you’re an experi-
enced Web designer, you’re going to love the power and sophistica-

tion of this HTML editor. If you’re new to Web design, you’ll appreciate its
simplicity and intuitive interface. Either way, this chapter starts you on your
way to making the most of Dreamweaver by introducing you to the menus
and panels that make this program so useful.

Dreamweaver can help you with every aspect of Web development, from
designing simple pages, to fixing links, to publishing your pages on the World
Wide Web. Dreamweaver can handle the simplest HTML, as well as some of
the most complex and advanced features possible on the Web, including
Cascading Style Sheets and Dynamic HTML (see Chapters 8 and 9 for more
information on these features). Dreamweaver also integrates a powerful
HTML text editor into its easy-to-use graphical design environment.

If you already work in another Web design program, don’t worry — you can
use Dreamweaver to modify existing Web pages and continue to develop your
Web site without losing all the time you already invested. All Web design pro-
grams create HTML pages, and those pages can open in any other Web design
program. So, for example, if you’ve been working in a program such as
Microsoft FrontPage or Adobe GoLive, you can still change to Dreamweaver
to edit and develop your site further. At the end of this chapter, you find tips
about some of the challenges in the section called “Working on Web Pages
Created in Another Web Design Program.”

In this chapter, you find an introduction to the new features in Dreamweaver
MX 2004, get a tour of the desktop, and an overview of what makes Dream-
weaver such a powerful Web design program. (If you don’t understand a new
vocabulary term as you read through this book, look it up in the comprehen-
sive glossary included on the accompanying CD-ROM.)
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So What’s New in Dreamweaver
MX 2004?

Now the good stuff. All those requests you make to Macromedia, all that
wishful thinking . . . believe it or not, they heard you and many of the little —
and not so little — things we all have been wanting in this program are finally
here! 

The following list provides you a quick overview of some of the new features
you find in version MX 2004:

� The changes to the interface in this version aren’t as dramatic as the
changes to the Workspace made in the previous version, Dreamweaver
MX, but you find some lovely enhancements. Beware that you no longer
have the option of using the floating panels interface, the only option in
the Dreamweaver versions prior to MX. You now have a choice between
the Designer interface, which is graphical and features panels that lock
into place, or the HomeSite/Coder-Style, which (as the name suggests) dis-
plays the HomeSite text editor. You have the option when you first turn on
the program, and you can always make the changes in Preferences. If you
choose the Designer interface, you can expand and collapse panels as
needed and move them around to create a work environment that suits
your preferences. Throughout this book, most of the screenshots and
instructions reflect the Designer interface. If you’re a code head (forgive
me, someone who prefers working in the raw HTML), choose the
HomeSite option, and you find many great features that make writing
HTML code easy so you don’t have to type all those tags in manually.

� The Designer interface is more streamlined and intuitive in its organiza-
tion in this new version. You also find the interface easier to customize.
For example, if you don’t like the Properties inspector at the bottom of
the screen, just drag it to the top and it locks into place. 

The Insert bar at the top of the screen is smaller in this version to take
up less room in the work area. And, if you want to keep your favorite fea-
tures handy, select Favorites from the pull-down list and right-click to
easily customize the bar to hold your favorite features.

� Keeping up with the general trend in Web design, Macromedia greatly
enhanced support for Cascading Style Sheets. You find many predefined
style sheets to get you started and the Dreamweaver graphical interface
renders those styles better so you don’t always have to preview your
work in a browser to see how it looks. The CSS panel and rules inspector
are also improved to provide more options and make creating your
entire design with CSS easier. You find more on these great features in
Chapters 8 and 9.
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� Dreamweaver is finally better suited to handling content from Microsoft
Office documents. I have to say I think this one is long overdue, but now
you can copy and paste content from Word and Excel and not lose the
formatting. Dreamweaver even makes tables out of Excel spreadsheets.

� When you open Dreamweaver, you’ll notice a new Start Screen. Anytime
you don’t have a file open, this screen reappears, providing quick access
to a variety of page formats, premade templates and styles, and recently
opened documents.

� Small, file-like tabs across the top of the work area make moving among
open documents easy. In previous versions, the filename of open docu-
ments was at the bottom of the work area.

� No matter what language you speak, you can now work in Dreamweaver
thanks to full Unicode support. Even languages that Dreamweaver is not
localized for render properly in the work area.

� Dreamweaver is the best Web design tool for developing sites that work
across multiple browsers, and Dreamweaver has great tools for checking
your work to ensure that it displays well on the browsers you want to
target. Now, those features work in real time thanks to Dynamic Cross
Browser Validation. Specify the browsers you want to design for and
Dreamweaver checks your work every time you save your pages.

� Want to crop, resize, or sharpen an image without launching an image
editor? Now you can perform these common tasks right in Dreamweaver.
You can also adjust brightness and contrast. Look for these new features
in the Properties inspector and enjoy saving time on those quick image
fixes and edits.

� You no longer have to use the Dreamweaver Site Setup before you can
work on a Web site. If you prefer to just log in to a server and make
quick changes or open files on your hard drive without setting up the
main folder first, you can skip this previously required step. 

However, if you want to use the Dreamweaver wonderful site manage-
ment features, which allow you to easily move files and folders without
breaking links and automatically fix links if they do get broken, you still
want to use Site Setup. But don’t worry, that’s really an easy step, espe-
cially with the Dreamweaver Site Setup Wizard. You find detailed steps
for setting up your site in Chapter 2.

� If you build your site with ASP, you will be pleased to find that ASP.NET
server controls now include real objects and Properties inspectors.
Look for the new ASP.NET tab on the Insert bar.

� A collection of new templates makes creating complex designs with a click
of a button even easier. Templates are covered in detail in Chapter 4.
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Introducing the Many Components
of Dreamweaver

Dreamweaver can seem a bit overwhelming at first. It has so many features
that all the panels, toolbars, and dialog boxes can be confusing when you
start poking around. To help you get familiar with all the great options in this
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So, what’s the big deal about Dreamweaver?
Dreamweaver has gotten great reviews and
attracted considerable attention because it
solves common problems found in other Web
programs. Many Web designers complain that
WYSIWYG design tools create sloppy HTML
code, alter the code in existing pages, and make
manually customizing pages difficult. Most of
these problems stem from the fact that people
who know how to write HTML code manually
are used to having total control over their HTML
pages. Unfortunately, many Web design pro-
grams force you to give up that control in order
to have the convenience and ease of a graphi-
cal design tool.

Dreamweaver gives you both control and con-
venience by packaging an easy-to-use graphi-
cal design environment with a powerful HTML
text editor, and in this latest version of
Dreamweaver, the built-in text editor is even
more powerful. Then Dreamweaver goes a step
further with a feature Macromedia calls
Roundtrip HTML. With Roundtrip HTML, you can
create your HTML pages in any program, open
them in Dreamweaver, and not have to worry
about your original HTML code being altered. 

Dreamweaver respects your HTML code. A big
problem with many other Web design programs
is that they can dramatically change HTML
code if it doesn’t conform to their rules.
Unfortunately, the rules on the Web constantly

change, so many designers like to break the
rules or at least add their own variations to the
theme. If you create a page with custom HTML
code in a text editor and then open it in a pro-
gram such as Microsoft FrontPage, you run the
risk that FrontPage may change your design
when it tries to make your code fit the rules of
FrontPage.

Dreamweaver promises not to alter your code,
which is one of the reasons it’s become a best
friend to so many professional designers. Still,
Dreamweaver is not perfect, especially if you
use the Clean Up HTML feature on custom code
or special scripts. If you’re a programmer cre-
ating advanced features, you may want to turn
off some of the Dreamweaver automatic 
code rewriting features by choosing Edit➪
Preferences➪Code Rewriting.

The challenge was in figuring out how to display
HTML code created in any editor in the Dream-
weaver graphical design environment without
changing the code to match Dreamweaver’s
rules, even when you use some special code
Macromedia has never seen before. The suc-
cess that Macromedia has had in solving this
problem is a big part of the reason why
Dreamweaver has gotten so much attention,
won so many awards, and attracted the loyalty
of even the most die-hard HTML coders.
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program, the next few sections introduce you to the interface and provide an
overview of the basic functions of Dreamweaver. You also discover where to
find most of the features and the functions of the buttons and menu options.
All these features are covered in more detail in the rest of the book.

The Workspace
Creating a basic Web page in Dreamweaver is easier than ever, but it does
take an extra step in this new version. When you launch Dreamweaver, the
Start Screen appears in the main area of the program (and it reappears any-
time you don’t have a file open). From this Start Screen, you can choose to
create a new page from one of the many Dreamweaver pre-made templates,
or you can create a new blank page by selecting HTML from the Create New
options in the middle column. When you select HTML, Dreamweaver creates
a new blank HTML page in the main Workspace, as shown in Figure 1-1. You
can type text directly into any page in the Workspace and apply basic format-
ting, such as bold and italics, simply by selecting Text➪Style➪Bold or Text➪
Style➪Italics.

You build HTML pages, templates, style sheets, and so on in the Workspace,
which consists of a main window that shows the page you’re working on and
a number of panels and windows that provide tools that you can use to design
and develop your pages (shown in Figure 1-1). The Dreamweaver Workspace
consists of the following basic components: the menu bar (at the very top),
the Insert bar (just below it), the Document window (the main area of the
screen, just below the Insert bar), the Properties inspector (at the bottom of
the screen), and the Vertical Docking panels (to the right of the Document
window) that expand and collapse as needed.

The Document window
The big, open area in the main area of the Workspace is the Document
window, which is where you work on new and existing pages. If you use the
Designer interface and are in Design View, you see your page as it would dis-
play in a Web browser, but if you look at the HTML code behind it (which you
can do by clicking the Code buttons at the top of the work area), you see that
it’s a simple HTML file. If you choose the Split button, you can see the HTML
code and the Design view simultaneously.

Pages viewed on the World Wide Web may not always look exactly the way
they do in the Document window in Dreamweaver because not all browsers
support the same HTML features or display them equally. For best results,
always test your work in a variety of Web browsers and design your pages to
work best in the browsers that your audience most likely uses. Fortunately,
Dreamweaver includes features that help you target your page designs to
specific browsers. (For more information on browser differences, check out
Chapter 9.)
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Customizing the interface
The docking panels, palettes, and bars in Dreamweaver provide easy access
to many of the program’s features. You can move these elements around the
screen by selecting them and dragging and dropping them. If you find that
having all these windows open distracts you from your ability to focus on
your design, you can close any or all of them by clicking the tiny icon in the
top right of all the main panels and selecting Close Panel from the pull-down
menu (it looks like three bullet points with lines next to them with a little
arrow underneath, and it’s really, really small). You can close them all at
once by choosing Window➪Hide Panels, and you can access any or all the
panels through the various options on the Window menu. If you want to open
a panel — the CSS Styles panel, for example — choose Window➪CSS Styles
and it expands to become visible on your screen.

The Properties inspector, Insert bar, and panels are integral parts of this pro-
gram, and you find a lot more information about them throughout the book.
Check out the Cheat Sheet at the front of this book for a handy reference to
the Properties inspector options. In Chapter 2, you discover some of the
most common features, such as inserting images (the icon for inserting an
image is in the Common Insert bar at the top of the page). 

menu bar

Vertical Docking panelsProperties inspector

Insert bar

Figure 1-1:
The

Workspace
includes a
Document

window,
menu bar,
Insert bar,

and the
Vertical
Docking
panels.
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The Insert bar
The Common Insert bar at the top of the page contains buttons that provide
quick access to many common features. For example, click the icon that
looks like a piece of a chain and you insert an HTML link into your page. Click
the little envelope icon and you insert an e-mail link.

The Insert bar has eight subcategories that offer separate sets of buttons for
various functions: Common, Layout, Forms, Text, HTML, Application, Flash
Elements, and Favorites. The Favorites Insert bar is blank by default, and you
can customize it to hold your favorite options. Simply right-click in the bar
and you can easily customize this bar. Throughout the book, I refer to these
by their full names, such as the Forms Insert bar or the Layout Insert bar. You
find more information on each of these in their relevant chapters. For exam-
ple, the Forms Insert bar is covered in detail in Chapter 12, and Application is
covered in Chapters 13, 14, and 15.

Use the small arrow to the right of the name to access the pull-down list and
switch from displaying the buttons on one subcategory to showing the but-
tons for another. Figure 1-2 shows the pull-down list with the Common Insert
bar selected. To change the icon display, choose Edit➪Preferences, and
select the Panels option.

Figure 1-2:
The Insert

bar provides
quick

access to
options for

forms,
tables,

images, and
more.
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The Properties inspector
The Properties inspector is docked at the bottom of the page in Dreamweaver.
If you prefer it at the top of the screen, you can drag it up there, and it locks
into place. The Properties inspector displays the properties of a selected ele-
ment on the page. A property is a characteristic of HTML — such as the align-
ment of an image or the size of a cell in a table — that you can assign to an
element on your Web page. If you know HTML, you recognize these as HTML
attributes.

When you select any element on a page (such as an image), the inspector
changes to display the properties, or attributes, for that element, such as the
height and width of an image or table. You can alter those properties by
changing the fields in the Properties inspector. You can also set links and
create image maps using the Properties inspector.

Figure 1-3 shows the image options displayed in the Properties inspector,
including height and width, alignment, and the URL (Uniform Resource
Locator or, more simply, Web address) to which the image links.

At the bottom-right corner of the Properties inspector, you see a small arrow.
Click this arrow to reveal additional attributes that let you control more
advanced features.

Figure 1-4 shows the Properties inspector when you select a table. Notice
that the fields in the inspector reflect the attributes of an HTML table, such
as the number of columns and rows. (See Chapter 6 to find out more about
HTML tables.)

The Vertical Docking panels
The Vertical Docking panels, shown in Figure 1-5, are located to the right of
the work area (although you can easily move them to the left). The Vertical
Docking panels display a variety of important features in Dreamweaver,

Figure 1-3:
The

Properties
inspector

displays the
attributes of

a selected
element,
such as 

an image
shown here.
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including Files in a site, Assets, CSS (Cascading Style Sheets), Behaviors,
History, and the Application features (the Databases, Data Bindings, Server
Behaviors, and Components). You can open and close panels by selecting the
panel name from the Windows menu, and you can hide these panels by click-
ing the tab with the small arrow on the left of the panels.

Figure 1-5:
The Vertical

Docking
panels

provide
easy access

to various
Dream-
weaver

features,
including

CSS,
Behaviors,

and
Application

features.

Figure 1-4:
The

Properties
inspector

displays the
attributes of

a selected
HTML table

or cell when
selected.
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The following list offers a description of some of the elements that you
access through the Vertical Docking panels (the others are described in
greater detail in their respective sections of the book).

� Files panel: Shown in Figure 1-6, the Files tab in the Files panel lists all of
the folders and files in a Web site and helps you manage the structure
and organization of the site. The Files tab is also where you access FTP
(file transfer protocol) capabilities. You can use the Connect button at
the top of this dialog box to dial quickly into your server. The Get and
Put buttons enable you to transfer your pages back and forth between
your computer and the server. (See Chapter 2 to find out more about the
Site panel.)

� Assets panel: The Assets panel provides easy access to the images,
colors, external links, multimedia files, scripts, templates, and Library
items in a Web site. The Library panel, shown in Figure 1-7, enables you
to store items in a central place so that you can easily add them to multi-
ple pages. After you store an element in the Library (you store an item
simply by dragging the element onto the Library panel), you can then

Get

PutConnect

Figure 1-6:
The Files tab

provides 
a view of

the site
structure

and files in a
Web site.
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drag that element from the Library onto new pages. The Library is ideal
for elements used throughout a Web site, as well as those that you must
update frequently. The other parts of the Assets panel work in much the
same way, providing easy access to related elements. You find more on
the Library feature in Chapter 4.

These features work only if you define your site using the Site Definition
dialog box, available by selecting Site➪Manage Sites. If you find that the
Library options aren’t available to you, go to Chapter 2 and follow the
steps for defining a site. 

� Design and Rule panels: These two panels enable you to define styles
by using Cascading Style Sheets (CSS). CSS styles are similar to style
sheets used in word processing and desktop publishing programs, such
as Microsoft Word and QuarkXPress. You define a style and name it, and
the style is then included in the CSS Styles panel, which is accessible
through the tab at the top of the panel (see Figure 1-8). The Design panel
provides access to the CSS Styles panel, shown in Figure 1-8, where you
can specify the type, size, and formatting of the style. After you define a
style, you can apply it to text or other elements on a page. The Rules
panel is a Tag inspector for CSS. Style sheets are a big time-saver
because they let you set several attributes simultaneously by applying a
defined style. (For more information about CSS, see Chapter 8.)

Figure 1-7:
The Assets

panel stores
items in a

central
place,
which
makes

placing the
same

element,
such as a

navigation
row, on
multiple

pages easy.
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� Tag inspector: The Tag inspector provides access to the Attributes,
Behaviors, and Relevant CSS tabs. In Dreamweaver, behaviors are scripts
(usually written in JavaScript) that you can apply to objects to add inter-
activity to your Web page. Essentially, a behavior is made up of a speci-
fied event that, when triggered, causes an action. For example, an event
may be a visitor clicking an image or section of text, and the resulting
action may be that a sound file plays. Figure 1-9 shows the Behaviors
panel. The left pane displays events; the right pane displays the actions
triggered by those events. (Chapter 9 provides more information on cre-
ating and applying behaviors.)

� History panel: The History panel, shown in Figure 1-10, keeps track of
every action you take in Dreamweaver. You can use the History panel to
undo multiple steps at once, to replay steps you performed, and to auto-
mate tasks. Dreamweaver automatically records the last 50 steps, but you
can increase or decrease that number by choosing Edit➪Preferences➪
General, and changing the Maximum Number of History Steps.

� Application Panel: This is where you find Data Bindings, Server
Behaviors, Components, and Databases options, but you use these only
if you work with a database. These options are described in more detail
in Chapter 14.

Figure 1-8:
The Style
Definition

panel
makes

creating
new combi-

nations of
formatting

features as
CSS easy.
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Code and Split views
The Code view in Dreamweaver reveals the best-integrated HTML text editor
of any Web design program. In Figure 1-11, the Split View option is selected,
which makes seeing the graphical design area and the HTML code at the
same time possible. Notice that the highlighted text in the graphical area is
also highlighted in the HTML Code view. Changes made in one immediately
appear in the other. This integration makes moving back and forth between
writing HTML code manually and creating it in the graphical editing environ-
ment nearly seamless.

The menu bar
At the top of the screen, the Dreamweaver menu bar provides easy access
to all the features that you find in the Insert bar, Properties inspector, and
panels, as well as a few others that are available only from the menu. The
following sections provide a general description of each of the menu options.

Figure 1-10:
The History

panel keeps
track of 
all your

actions in
Dream-
weaver,

which
makes

undoing or
replaying

steps easy.

Figure 1-9:
Clicking 

the + button
opens a

drop-down
list of

behaviors.
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The File menu
You find many familiar options, such as New, Open, and Save, on the File
menu, shown in Figure 1-12. You also find a Revert option, which is similar to
the Revert feature in Adobe Photoshop. This sophisticated undo feature
enables you to return your page quickly to its last-saved version if you don’t
like the changes you made. Dreamweaver automatically keeps track of up to
50 actions, but you can increase or decrease that number by choosing Edit➪
Preferences➪General and changing the maximum number of history steps.

The File menu also includes access to Design Notes, a unique feature that
associates private notes with HTML and other files. Take a look at Chapter 4
for more information about Design Notes and other Dreamweaver features
that make collaboration easier.

You can also find features useful for checking your work in Web browsers on
the File menu. Most Web design programs include some way of previewing
your work in a browser. Dreamweaver takes this feature two steps further by
enabling you to check your work in a number of browsers and even test the
compatibility of your pages in different versions of different browsers.

Figure 1-11:
The Split
view lets
you view 
the code

and the
graphical

design
environment

at the 
same time.
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Figure 1-12 shows the Check Page options, which includes Check
Accessibility, Check Links, and Check Target Browsers — all great tools for
testing your work. The Check Target Browsers option enables you to specify
a browser and version, such as Netscape 3.0 (still a widely used browser on
the Web) or Internet Explorer 3.0. When you do a browser check, Dreamweaver
generates a report listing any HTML features you use that the chosen
browser doesn’t support. 

The Check Links feature verifies all the links in a site and produces a report
with all broken and unresolved links. The Check Accessibility feature checks
to make sure the page displays properly in browsers for the blind and other
systems for the disabled.

The Edit menu
The Edit menu contains many features that you may find familiar, such as
Cut, Copy, and Paste. One feature that may be new to you is the Edit with
External Editor option, which enables you to open an element in another pro-
gram, such as an image editor, and make changes without ever leaving
Dreamweaver.

Figure 1-12:
The Check

Target
Browsers

feature
produces a

list of HTML
tags on a
page that

older
browsers do
not support.
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You also find the Preferences settings on the Edit menu. Before you start
working with a new program, going through all the Preferences options to
ensure that the program is set up the best way for you is always a good idea.

The View menu
The View menu provides access to some helpful design features, such as
grids and rulers. The Visual Aides option on the View menu gives you the
option of turning on or off the borders of your HTML tables, frames, and layers,
as well as controlling visibility of image maps and other invisible elements.
This option is useful because you often want to set the border attribute of
these HTML tags to zero so that they’re not visible when the page displays in a
browser. However, while you work on the design of your page in Dreamweaver,
seeing where elements, such as tables and layers, start and stop is very useful.
Checking the frame options in the View menu lets you see the borders in
Dreamweaver even if you don’t want them visible to your site’s visitors.

The Insert menu
As shown in Figure 1-13, the Insert menu offers access to a number of fea-
tures unique to Web design. From this menu, you can insert elements such as
a horizontal rule, a Java applet, a form, or a plug-in file.

Figure 1-13:
The Insert

menu
makes

adding a
variety of

elements to
your pages,

including
multimedia
files, easy.
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Dreamweaver offers extra support for inserting Flash and Shockwave
Director files, both of which are products from Macromedia. (You can find
out more about using multimedia files in Chapter 11.)

The Modify menu
The Modify menu is another place where you can view and change object
properties, such as the table attributes shown in Figure 1-14. The properties
(usually called attributes in HTML) let you define elements on a page by set-
ting alignment, height, width, and other specifications.

Page Properties
You can also set individual attributes using the Properties inspector. To alter
properties for an entire page, use the Page Properties dialog box, available
from the Modify menu or by clicking the Page Properties button at the bottom
of the Properties inspector. Changing page properties (see Figure 1-15)
enables you to set link and text colors for the entire page and specify the
background color or image.

Figure 1-14:
The Modify

menu
makes

changing
object

properties,
such as the

table
attributes

shown here,
easy.
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The Text menu
You can easily format text with the Text menu by using simple options, such
as bold and italic, as well as more complex features, such as font styles and
custom style sheets. Text formatting options have evolved dramatically on
the Web. Just a few years ago, you didn’t even have the option of specifying a
particular font style or controlling leading and spacing. Today, although these
options aren’t yet universally supported, you have more control than ever
over the look of your Web pages.

For example, if you choose a particular font for your text, that font must be
available on the user’s computer for the text to display properly. Because of
this limitation, HTML enables you to specify several font possibilities to
improve your odds that a font you want displays. The browser searches the
user’s computer for one of these fonts in the order in which you list them.
Dreamweaver recognizes the importance of specifying more than one font
and the safety of using the more popular fonts.

The Commands menu
The Commands menu, shown in Figure 1-16, provides access to a host of
options in Dreamweaver. These options include the Start and Play Recording
features, which let you quickly save a series of steps and then repeat them.
To use this feature, choose Commands➪Start Recording, perform whatever
actions you want to record — for example, copying and pasting some text —
and then choose Stop Recording. Then to perform that action again, choose
Commands➪Play Recorded Command. You can download an action by
choosing Command➪Get More Commands, which automatically launches a
browser and takes you to the Macromedia Web site. You can download new
commands from the Web site that adds functionality to Dreamweaver.

Figure 1-15:
The Page

Properties
dialog box

provides
access to

background
and text

color
attributes.
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The Clean Up HTML option on the Commands menu helps you correct bad
HTML code, and the Clean Up Word HTML feature is designed especially to
correct the common problems caused by the Save As HTML feature in
Microsoft Word.

The Add/Remove Netscape Resize Fix option on this menu inserts or
removes a JavaScript script designed to help correct a Netscape bugby auto-
matically reloading the page when users resize their browser windows.

The Create Web Photo Album option launches Macromedia Fireworks and
uses it to automate the creation of a photo album with a series of images. If
you choose Optimize Image in Fireworks, a selected image automatically
opens in the optimization area in Fireworks.

Another great feature on the Commands menu is the Set Color Scheme com-
mand. This option includes a list of background and text colors specially
designed to work well together on the Web.

Figure 1-16:
The

Commands
menu offers
easy access

to some of
Dream-

weaver’s
most

advanced
features.
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The Site menu
The Site menu provides access to the options you need to set up your site, a
process required before many of the other Dreamweaver features work prop-
erly. (This process is covered in detail in Chapter 2.) The Site menu also gives
you easy access to the Check In and Check Out features, which are options
that can help you keep a team of designers from overwriting each other’s
work. (Chapter 4 also talks about this feature.)

The Window menu
The Window menu lets you control the display of panels and dialog boxes,
such as Insert, Properties, and Behaviors. To turn on these features, select
the panel name so that a check mark appears next to the feature you want to
display; to turn the feature off, click again to remove the check mark. Other
panels and dialog boxes, such as CSS Styles and HTML Code Inspector, are
also listed on the Window menu for easy access.

The Help menu
The Help menu provides easy access to help options that can assist you in
figuring out many features of Dreamweaver. You also find access to the
Dreamweaver template and example files under Help. 

Templates and examples provide visual samples of common HTML designs,
such as tables and frames, and provide design ideas and great shortcuts for
creating complex layouts.

The Status bar
The Status bar appears at the very bottom-left of the Dreamweaver screen.
On the right end of the Status bar, you can see shortcuts to many other
features. On the left end, you find HTML codes that indicate how elements
on your page are formatted. If you run your mouse pointer over text that is
centered, for example, the Status bar displays <CENTER>. This feature makes
double-checking the kind of formatting applied to any element on your
page easy. 

You can also use the Status bar to identify a section on your page. For exam-
ple, if you click the name of a tag in the Status bar, the section of your page
where that tag is applied is highlighted. This makes selecting certain sections
of a page easier, such as a table.
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Working on Web Pages Created in
Another Web Design Program

In theory, all Web design programs should be compatible because HTML files
are, at their heart, just ASCII (or plain-text) files. You can open an HTML file
in any text editor, including Macintosh SimpleText and Windows Notepad.
However, HTML has evolved dramatically over the years and different Web
programs follow different standards, which can cause serious conflicts when
a page created in one program opens in another.

One of the reasons Dreamweaver is so popular is because it creates very
clean code and is considered more accurate and more respectful of HTML
standards than other programs. Dreamweaver is also better at creating pages
that work in different browsers and on different platforms, but importing files
created in another Web program can be challenging, even in Dreamweaver. 

To help with the transition, Dreamweaver includes some special features,
such as the Clean UP Word HTML option, designed to fix some of the
common problems with Microsoft Word’s HTML code. 

Before you start working on a site that was developed in another program,
you need to import the site into Dreamweaver. I recommend you make a
backup of the site first so you have a copy of all the original pages. You find
step-by-step instructions for importing an existing Web site in Chapter 2.

The following sections describe the most popular HTML editors and what
you need to know if you’re moving files from one of these programs to
Dreamweaver.

Microsoft FrontPage 
Microsoft FrontPage is one of the most popular HTML editors on the market,
in large part because Microsoft Office is so popular. FrontPage also offers
some powerful features as well as an attractive bundle of programs for Web
developers, including Image Composer, a bundled graphics program designed
for creating images for the Web. FrontPage also includes Web components
that you can use to add interactive features, such as a simple search engine
or a discussion area, to your Web site. Web components work only if their
corresponding programs reside on the Web server that you use, but many
commercial service providers now offer FrontPage Web components. 
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If you are migrating a site from FrontPage to Dreamweaver, first make note
of any FrontPage Web components that you use, such as search engines
or forms. Dreamweaver doesn’t offer these same built-in features, and you
won’t be able to continue editing them in Dreamweaver the way you did in
FrontPage. Though the components still work, thanks to the Dreamweaver
Roundtrip HTML, which respects unique code, you sacrifice some of the con-
venience of the FrontPage built-in components for Dreamweaver’s more stan-
dard approach to creating code. If you use a number of components, are used
to the way they work in FrontPage, and feel that you can’t live without them,
you may be better off sticking with FrontPage for a while. 

If you’re ready to graduate to Dreamweaver (and I’ve spoken to many frus-
trated FrontPage users who are happy after they make the switch), you can
re-create all the components you use in FrontPage by using CGI and other
programming in conjunction with your pages in Dreamweaver. If you don’t
know how to do that yourself, consider hiring a programmer to help you
make the transition and then maintaining the site yourself in Dreamweaver
after those features are re-created.

If you use CSS or Layers in FrontPage, you need to pay special attention to
those features as you convert your site to Dreamweaver. Microsoft FrontPage
isn’t as good as Dreamweaver at creating high-end features that work in both
Netscape Navigator and Microsoft Internet Explorer, so you probably want to
improve your code if you expect viewers to use any browser other than
Internet Explorer. Because CSS and layers are more complex than HTML
to code, you probably don’t want to edit this code manually — converting
from other editors to Dreamweaver can get pretty tricky. Tables can also
get messy when you switch from one program to another. In some cases, you
may find that the simplest solution is to delete the elements that you created
in FrontPage and re-create them in Dreamweaver. (For more on CSS and
layers, check out Chapters 8 and 9.)

Microsoft Word
Although Microsoft Word is a word processor and is not considered an
HTML editor per se, it does have HTML output capabilities. As a result,
you will likely encounter pages that have been output from Microsoft Word
at some point. The problems you find in HTML code generated from Word are
similar to the problems generated from FrontPage: They both tend to output
verbose and redundant code that deviates from HTML standards. Because
Word-generated HTML is so common, Dreamweaver includes a special Clean
Up Word HTML command. To use this feature, choose Commands➪Clean Up
Word HTML and then specify the code you want altered in the Clean Up Word
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HTML dialog box. When you use this feature, Dreamweaver removes excess
code, which can help your pages load faster and work better in different
browsers.

NetObjects Fusion
If you work in NetObjects Fusion, you face a more dramatic transition to
Dreamweaver than you do coming from almost any other HTML editor dis-
cussed in this section. That’s because Fusion took a unique approach to Web
design and HTML code output. Although the program is not widely used any-
more, many Web sites out there were created with it.

The biggest challenge with Fusion sites is that Fusion uses complex HTML
tables and a transparent graphic to control spacing. The down-to-the-pixel
design control enticed many graphic designers because they can create com-
plex layouts with less effort, but those designs are not well supported by all
browsers — meaning that the designs don’t work well for broad audience sites.

The problem if you import a Web site created with Fusion is that it has very
complex code that doesn’t lend itself easily to further editing in any other
program. Unfortunately, if you want the cleanest HTML code possible, which
speeds up download time and makes editing pages easier in the future, your
best bet is to re-create your designs from scratch. I’m sorry to break this to
you, but if you import a site created in Fusion, you should probably start
over with Dreamweaver; the transition process is just too daunting to be
worth it. Move all your images into new image directories, set up a new site
in Dreamweaver, and start over with your design work.

Adobe GoLive
Adobe GoLive offers some great features for easy page design and a lot of
similarities with Dreamweaver, but it also brings some of the same problems
as pages created in NetObjects Fusion (see the preceding section). GoLive
makes using a grid to provide down-to-the-pixel layout control possible, in
much the same way Fusion does. So, like Fusion, GoLive often outputs very
complex code that is difficult to edit in other programs.

Because you can see the alignment grid in GoLive, you may be more aware of
the complex table that GoLive creates in the background. The grid feature in
GoLive is optional, and if the site you import was created without this fea-
ture, converting your pages to Dreamweaver is a much easier task. If the site
was created using the grid, you may find that re-creating your pages from
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scratch in Dreamweaver is your best option. The code used to create the
complex HTML tables that GoLive uses in its grids is extremely difficult to
edit outside of GoLive. If you work with people who use GoLive, try to get
them to avoid using the Layout Grid feature when designing their pages and
you have an easier time working on the site with Dreamweaver.

If you add any JavaScript actions to your pages in GoLive, you can’t edit them
in Dreamweaver, either, but the actions still work. Likewise, CSS and other
Dynamic HTML features created in GoLive do not work well in Dreamweaver
unless you know how to edit the code manually. If your page contains any
actions or DTHML features, you may find re-creating the page in
Dreamweaver is easiest.

Other HTML editors
In the early days of the Web, lots of different visual HTML editors were being
used. Today only a few major ones are left. The few that I discuss here seem
to capture most of the market. Still, you may find yourself inheriting sites
built in really old editors such as Adobe PageMill, Claris HomePage, or
Symantec VisualPage, to name a few. Each of these programs present fewer
problems than either Fusion or GoLive, because they aren’t capable of creat-
ing the complex, high-end features that are hardest to migrate from one pro-
gram to another.

No matter what program your site is originally created in, as you consider
how best to convert your work into Dreamweaver, pay special attention to
unusual code output, nonstandard rules about HTML tags and syntax, and
sophisticated features such as CSS, Dynamic HTML, and sophisticated pro-
gramming, such as ASP, Java, or CGI scripts. These Web page elements are
most likely to cause problems when you import them into Dreamweaver.

For the most part, you can open any HTML page with Dreamweaver and con-
tinue developing it with little concern. If you run into problems, remember that
you always have the option of re-creating the page from scratch in
Dreamweaver — a sure way to get rid of any unwanted code. You may also
want to use the Dreamweaver Clean Up HTML feature to identify potentially
problematic code. To use this feature, choose Commands➪Clean Up HTML and
then select the elements you want to alter in the Clean Up HTML dialog box.
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Also be careful if you use Adobe ImageReady to automatically output HTML
with images, for example, if you use the slicing feature to break up a large
image into smaller images arranged in an HTML table. ImageReady also relies
heavily on the transparent image trick for alignment and makes heavy use of
the Colspan attribute in tables. Both of these tricks are problematic if you
change the table width values. If you have trouble getting your images to
align the way you intend, you may again be better off deleting the original
page and re-creating the table in Dreamweaver. The good news is after you
migrate your site into Dreamweaver, your work goes much more smoothly
and your sites works better for a broader audience in the future.
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