Getting Started
with Visio

H umans are visual creatures, so it isn’t surprising that
we visualize and communicate our ideas, designs, and
final products graphically. In the past, high-quality graphics
were the work of professional graphic artists and illustrators,
but with Visio 2003, anyone can produce informative and
attractive diagrams, drawings, and models. Visio is so straight-
forward that you can use it to capture the fast-paced output of
brainstorming sessions or the frequent changes made to ini-
tial designs and models. At the same time, Visio is powerful
enough to develop sophisticated models, and precise enough
to document the details of existing systems.

Visio 2003 is like a good friend with expertise in dozens of
fields. It jumpstarts your efforts with solutions designed
specifically to produce different types of drawings. Visio tem-
plates set up your work environment with menus of special-
ized tools, sets of predefined shapes, and drawing settings
such as page size and orientation typical for the type of draw-
ing you want to create. Visio stencils categorize thousands of
predefined symbols by industry, drawing type, and applica-
tion. These Visio SmartShapes have built-in behaviors and
properties to help you quickly assemble drawings and collect
information.

Simplicity and convenience are key to Visio’s power. To con-
struct a drawing, you drag and drop predrawn shapes from
stencils onto drawing pages. Defining relationships between
shapes is as easy as dropping one shape onto another or
dragging and dropping connectors onto shapes. Specialized
tools help lay out drawings and perform typical tasks. The
simplicity of integrating Visio with tools such as Microsoft
Office, AutoCAD, Adobe Framemaker, and database manage-
ment systems makes it easy to maintain drawings and docu-
mentation of systems.
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What's New in Visio 2003?

Visio 2003 delivers brand-new templates and shapes as well as significant improve-
ments and enhancements to many existing ones. In addition, Visio 2003 includes
new and improved features to boost your productivity and enhance collaboration
with others. You can send Microsoft feedback about the product or rate the useful-
ness of help topics and templates.

New '\ Look for the New Feature icon throughout this book to learn more about what's
Reatip new and improved.

New and Improved Shapes and Templates
The Visio team expands the scope of the product with every release. Visio 2003
introduces the following new templates and shapes:

4+ Business Process templates — New templates for event-driven process
chains, fault tree analysis, and work flow, plus a new home for other business
process templates

4 Brainstorming — A replacement for the Mind Mapping template
4+ Timeline — A new template for documenting project timelines

4 Space Plan Startup Wizard (Visio Professional only) — A new tool for building
space plans quickly

4 Detailed Network Diagram (Visio Professional only) — A replacement for the
Logical Network Diagram

4+ Rack Diagram (Visio Professional only) — A new template for designing equip-
ment placement in racks

4+ Windows XP User Interface (Visio Professional only) — A new template for
designing Windows XP user interfaces

You’ll appreciate the enhancements added to many existing templates and shapes,
including the following:

4+ Calendar

4 Organization Chart

4 Basic Network Diagram

4 Space Plan Import Data Wizard (Visio Professional only)

4+ Web Site Map (Visio Professional only)

4 Electrical Engineering (Visio Professional only)

4 Building Plan (Visio Professional only)
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Productivity Enhancements

Visio enhances its reputation for being quick and easy with the following new
features:

4+ Task panes— You can access many of Visio’s most popular features on ten
new task panes, which are docked to the right of the drawing page by default.

4+ Shape management — You can find shapes faster with Search for Shapes, an
improved replacement for the Find Shape feature. You can organize your fre-
quently used shapes on the Favorites stencil or add them to custom stencils,
which you can store in the new My Shapes folder for easy access.

4+ Editing tools — Shapes now include rotation handles so you can rotate them
without switching drawing tools. To select multiple shapes, you can choose
from the Pointer, Lasso Select, or Multiple Select tools. It’s also easier to coor-
dinate colors if you use templates with built-in color schemes.

4 Getting started — The Diagram Gallery provides an overview of Visio drawing
types to help you select an appropriate template. Microsoft Office Online
includes additional templates and clip art, as well as starter drawings that
already contain basic content to get you going. For an introduction to Visio’s
features, you can use the Getting Started Tutorial on the Visio Help menu.

4+ CAD integration — The DWG Converter produces more accurate Visio repre-
sentations of your original CAD drawings.

4 Help resources — Online help from Microsoft Office Online provides up-to-the-
minute help and in-depth articles about Visio and other Office applications.
The Help and Template Help task panes provide access to almost all of Visio’s
help resources, with a few more on the Visio Help menu and online. You can
pause the pointer over a shape on a stencil to view a description and access a
Help link.

4 Customer feedback — You can help improve future versions of Visio by
choosing to participate in the Customer Experience Improvement Program, in
which Microsoft collects information about your hardware configuration and
how you use Microsoft Office programs. In addition, you can provide feedback
about programs, the effectiveness of help topics, templates, and Microsoft
Office Online content.

4 Features for developers —In addition to a Visio 2003 ActiveX control for incor-
porating Visio into host applications, developers can increase their productiv-
ity with new ShapeSheet functions, keyboard and mouse events, and other
tools. New interface elements such as ShapeStudio and the Formula Tracing
window make it easier to create SmartShapes. (Visio Professional only)

Collaboration and Sharing

Collaboration and the subsequent sharing of documents are key initiatives for
Microsoft today. Visio 2003 includes a number of new features to simplify collabora-
tion with your colleagues:

5
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4+ Track markup — You can propose changes to drawings and review the
changes proposed by your coworkers. Each person’s changes appear in a
unique color on a separate overlay.

4 Ink— You can add hand-drawn shapes or handwritten notes to drawings
using a tablet PC or any computer with an electronic pen device. You can
edit Ink shapes or add them to stencils just like other Visio shapes.

4 Scalable Vector Graphic format— Visio 2003 now supports the Scalable
Vector Graphics (SVG) format.

4+ Microsoft Office Visio Viewer 2003 — People who don’t have Visio can view
and print your Visio drawings after downloading the Visio Viewer from the
Microsoft Download Center.

4 Document Workspaces—People can collaborate on documents stored in
Document Workspaces, which are Microsoft Windows SharePoint Services sites.
Contributors can work on the master copy in the Document Workspace or edit
their own copy, which they can synchronize periodically with the master.

4+ Language handling — Visio 2003 supports Unicode, End User Defined
Character sets, and the new Chinese character-encoding standard, GB18030.
In addition, Multilingual User Interface packs simplify Visio deployment in
global enterprises by displaying text for the user interface, Help, and wizards
in other languages.

Features Discontinued in Visio 2003

A few templates and tools are no longer available. However, you can search
Microsoft Office Online or other Web sites for replacements.

¢ Cross- "\ Tofind other sources for Visio shapes and templates, refer to Chapter 39.

| Reference \

s Data Flow Model Diagram Model Explorer (Visio Professional only) — The
Data Flow Model Diagram template no longer contains the Model Explorer.

However, the UML template still has its Model Explorer.

4 Directory Services Directory Navigator (Visio Professional only) — The
Directory Services Diagram template no longer contains the Directory
Navigator.

4 Forms — The Forms template is no longer available. You can use Microsoft’s
new product, Infopath, to build forms and communicate data.

4+ Import Flowchart Data Wizard — You must import data into a flowchart in an
earlier version of Visio and save the result in that version. You can then open
the file in Visio 2003.

4 Organization Chart Conversion Utility — You must convert an organization
chart in an earlier version of Visio and save the result in that version. You can
then open the organization chart in Visio 2003.
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4+ Visio Network Equipment Sampler (Visio Professional only) —Shapes in
the VNE Sampler are no longer available, but many equipment manufacturers
provide shapes for their equipment on their Web sites.

Visio has dropped support for the following file formats and their converters:

4 Adobe Illustrator

4+ ABC Flow Charter, versions 2.0, 3.0, and 4.0
4 CorelDRAW!, versions 3.0 through 7.0

4 CorelFLOW 2.0

4 Corel Clipart

4+ Computer Graphics Metafile

4+ Microstation (DGN)

4 MicroGrafx Designer 3.1

4+ MicroGrafx Designer 6.0 English

4 Postscript and Encapsulated Postscript

4 Initial Graphics Exchange Specification

4+ ZSoft PC Paintbrush (PCX)

4 Mac Clipboard

4 Text Files (TXT) and Comma Separated Values (CSV)

What Visio Is and Isn't

Visio can be many things to many people. Applied properly, Visio 2003 can help you
produce simple diagrams or complex models. These far-reaching capabilities can
be confusing if you don’t understand how they differ. Even worse, you can become
quite frustrated if you try to use Visio for tasks for which it wasn’t designed.

Many drawings are simple diagrams with some basic connections and little or

no associated data. For these drawings, you can simply drag and drop shapes and
connectors in either Visio Standard or Visio Professional. The remaining chapters
in Part I, Understanding Visio Fundamentals, describe the basic tools you need to
diagram with Visio.

However, Visio Professional can also produce intelligent models and specialized
documentation for numerous fields, including software engineering, architecture,
mechanical and electrical engineering, and business process modeling. Templates
for these advanced applications contain tools for performing specialized tasks.
The shapes contained in the stencils for these templates have smart features —
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built-in behaviors and attributes that fit the shapes to their role. For instance, inter-
secting walls in building plans are smart enough to clean up their overlapping lines.
Cubicle shapes might contain properties that identify the people occupying the
enclosed space for occupancy reports. These features are time-savers when you
know how to use them, but can make Visio seem to have a mind of its own when
you don’t. Parts III, IV, and V of this book teach you the ins and outs of Visio’s more
sophisticated solutions.

You can draw precise plans to scale with Visio. Visio Standard supports only basic
building plans, whereas Visio Professional supports a variety of architectural and
engineering plans. Nonetheless, you’ll probably want the extra power of a CAD
application, such as AutoCAD, to design and document large or complex plans.
Even so, Visio can be a helpful companion to your CAD application. You can create
shapes faster and more easily in Visio and then import them for use in AutoCAD or
other CAD applications. Team members who don’t have access to AutoCAD can cre-
ate their drawings in Visio using CAD drawings as a backdrop and import their work
into AutoCAD if necessary. Visio also simplifies preparing presentations for large
projects.

Understanding Visio Concepts

Visio enhances your drawing and modeling productivity because so many of its ele-
ments include features that incorporate industry expertise. Most of the time, you
don’t even think about how much Visio does for you because the templates, sten-
cils, and shapes do just what you would expect. However, some of Visio’s special-
ized capabilities might surprise or even confuse you at first. By understanding the
concepts that make Visio so powerful, you can prevent problems and maintain your
productivity.

Using Templates and Stencils

In the real world, templates are patterns you use to build something. For example,
you could use a standard design for a log house to simplify the construction of your
home. In Visio, templates are solutions that facilitate the construction of a specific
type of drawing. Each template comprises settings, stencils, styles, and special
commands to make your work on a drawing as easy as possible.

Visio stencils are categorized collections of shapes. To continue the house analogy,

a Visio stencil is like a catalog of cedar logs and connecting brackets that are avail-
able from your local building supply store. To build your home, you order the compo-
nents you need from the store and assemble them according to your house design.

In Visio, you assemble your drawings by dragging and dropping shapes from stencils
onto your drawing page.
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When you create a drawing based on a template, Visio does the following things:

4+ Opens stencils with shapes — Visio opens stencils that contain the shapes
you need for the type of drawing you are creating.

4+ Includes styles— Visio provides special formatting styles typical for the
current drawing type. For example, a construction project created from a
floor plan template includes line styles typically used to dimension architec-
tural plans.

4+ Automatically displays menus and toolbars —If the template contains a spe-
cial menu, Visio adds an entry for the menu to the menu bar. If the template
contains a special toolbar, Visio floats the toolbar in the drawing area.

4+ Specifies settings — Visio specifies settings typical for the type of drawing.
For basic block diagrams, Visio uses letter-size paper, portrait orientation,
one-to-one scale, and inches for measurement units. For site plans, it specifies
a 36" x 42" architectural drawing size in landscape orientation, a scale of 1
inch to 10 feet, and measurement units of feet and inches.

4+ Displays rulers and grid — To make positioning shapes easy, the rulers and
grid take into account the scale and units for the drawing. For example, a
block diagram shows inches on the rulers with each grid cell equal to one-
quarter inch. Conversely, rulers for a site plan display feet in the rulers with
each grid cell equal to ten feet.

Dragging and Dropping Shapes to Create Drawings

Visio’s philosophy is elegantly simple — you construct drawings by dragging and
dropping predefined shapes onto drawing pages. Although working with Visio can
seem like copying clip art into a document, Visio shapes are much more powerful,
quickly transforming a blank page into a professional document with a few applica-
tions of drag and drop.

What Makes Shapes Smart

Visio shapes can represent many things: ideas, processes, components of a model,
and real-world objects such as people, places, and things. Visio calls them
SmartShapes because they have built-in properties and behaviors that give them
intelligence. As you work on a drawing, shape behaviors help you position the
shapes and connect them appropriately to other shapes. For example, when you
place a door shape in a wall, the door lines up with the wall and creates an opening
into a room, as shown in Figure 1-1. That same door might contain properties to
modify the shape or identify it, also shown in Figure 1-1. For example, one door
property specifies whether the door is centered in the wall. Other door properties
can define a door’s dimensions, its catalog number, or its associated room number,
so you can produce a schedule of the doors you need and where they belong in
your building.
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Door shapes can create openings in walls
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Figure 1-1: Shapes include behaviors and properties that give them intelligence.

rﬁrjj To learn about how to define properties and behaviors for shapes, see Chapter 32.
\ eierence

In Visio, predrawn shapes are called masters, which are stored and categorized in
stencils. When you drag and drop a master from a stencil onto your drawing page,
you create a copy, which is called an instance of that master. Each instance inherits
its master’s behaviors, so it knows how to act when you add it to your drawing. It
also inherits its master’s properties, so you can assign unique values to an instance.

Using Handles to Manipulate Shapes

Shapes have other features to help you position, resize, and connect them to one
another. When you select a shape, Visio marks these features with colored graphics,
as illustrated in Figure 1-2. Shapes include the following types of handles:

4+ Selection handles — Red or green boxes appear when you select a shape.
You can drag these selection handles to resize a shape or attach connectors
to them.

4+ Connection points — Blue Xs mark locations where you can glue connectors
or lines.
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4+ Rotation handle — This is a red circle that you can drag to rotate a shape.

4 Control handles — Yellow diamonds that appear on some shapes. You can
drag control handles to modify a shape’s appearance —for instance, to
change the swing on a door.

4+ Eccentricity handles — Green circles that you can drag to change the shape
of an arc.

Shapes can be one-dimensional or two-dimensional. Two-dimensional shapes, such as
rectangles and office tables, have selection handles at each corner and the midpoints
of each side, which you can drag to modify a shape’s height and width. 1D shapes,
such as connectors, lines, and arrows, have end points that you can drag to change
the length of the shape. You can change the length of 1D shapes as well as the width
of some 1D shapes, such as the 1D single arrow. However, you can’t change length
and width at the same time because a 1D shape doesn’t have selection handles at its
corners.

Rotation handle

Control handle
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Figure 1-2: Visio uses colored marks to identify handles you can use to modify shapes.
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€ Cross-
| Reference '\

Connecting Shapes

Relationships can convey as much information as the elements they connect.
Whether you are showing who reports to a manager in an organization or defining
the relationship between two database tables, connections between Visio shapes
are important. In Visio, connections not only provide information about a relation-
ship, they also help you lay out and rearrange the shapes on your drawing.

T .
\  To learn more about connecting shapes, see Chapter 5.
A

Tip

What Connectors Do

Connectors are Visio shapes that define the relationships between other shapes.

In essence, connectors are lines with shapes attached to each end. When you move
two connected shapes, the connector between them adjusts to maintain that con-
nection. Likewise, connectors maintain shape connectivity when you use Visio’s
automatic layout tools. For example, you can change the layout of an organization
chart from horizontal to vertical and the connectors alter their paths as the
employee shapes take up their new locations.

Connectors have start and end points that define direction for a connection between
shapes. Which end you connect to a shape can make a big difference in behavior. For
example, in a database model, the table shape at the start of a connector is the par-
ent, whereas the table at the end of a connector is the child. When you define a one-
to-many relationship between those connected tables, the one is associated with the
table at the connector’s start point, and the many belongs to the table at the connec-
tor’s end point.

When you want to differentiate the predecessor and successor for two connected
4 shapes, such as in a data flow diagram or project schedule, make sure you glue

"4 the start point of the connector to the shape you are connecting from and the end

point to the shape you are connecting to.

Straight Versus Dynamic Connectors

Straight connectors are straight lines that connect shapes. They lengthen, shorten,
and change their angle to maintain shape connectivity, but they draw straight over
shapes that are in their path, as shown in Figure 1-3.

Dynamic connectors are smarter. They automatically bend, stretch, and detour
around shapes instead of overlapping them. They can also jump over other connec-
tors to make connections easier to follow on a drawing. By default, dynamic con-
nectors use right angles to bend around shapes. You can change the path of a
right-angled connector by moving any of its vertices. You can also add or move
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segments of a right-angled connector by dragging a midpoint of a segment. Curved
connectors are dynamic as well. You can drag their control points and eccentricity
handles, to modify the shape of the curve.
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Figure 1-3: You can connect shapes with
straight or dynamic connectors.

Using Glue

Just as in real life, Visio needs glue to make things stick together. Visio “glue” comes
in two varieties: shape-to-shape and point-to-point. Shape-to-shape glue, also known
as dynamic glue, builds dynamic connections between shapes. When you reposition
shapes connected with shape-to-shape glue, the end points of the connector move
to the closest available connection points, as shown in Figure 1-4. Point-to-point glue,
also known as static glue, keeps the connector end points glued to the specific
points you selected on the shapes, also illustrated in Figure 1-4. In addition, you can
combine dynamic and static glue, gluing a connector to a shape at one end and a
specific point at the other.

By default, you can glue to entire shapes, connection points, or guides. You can
change glue settings to also glue to shape handles, shape vertices, or any point on
a shape’s geometry. As you draw a connector, a red box appears around a shape
when you are connecting to that shape. If you are connecting to a point, the connec-
tion point turns red.
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Dynamic glue draws shortest connection.
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Static glue maintains the points you select.

Figure 1-4: Dynamic glue draws the shortest
connectors between two shapes.

Exploring the Visio 2003 Interface

When you begin a drawing session, Visio 2003 conveniently populates the Visio
desktop with features to help you work. By default, the Visio environment positions
menus and toolbars across the top, the Shapes window with stencils and shapes to
the left, the task pane to the right, a status bar along the bottom, and the drawing
window in the center, as shown in Figure 1-5.

Menus and Toolbars

You can find most features on one of Visio’s menus or toolbars. However, the fastest
route to many tasks is right-clicking a shape or interface element to access a short-
cut menu.

The Visio menu bar contains menus familiar to Microsoft Office users. In addition,
when you work with some of the specialized templates, the Visio menu bar contains
an additional entry for a specialized menu, such as Plan shown in Figure 1-5.



Chapter 1 4+ Getting Started with Visio

Shapes Window Drawing Window
Toolbars Menu Bar Task Pane
iﬂ,| 557246 Ch01 Office Layout - Microsoft Visio =R
-5_1 File Edit View Insert Format Tools Shape Plan Window Help Type a question for hel - f X

paRa=a" RETI=REYe AN

WEEH -,

LA Gl A LB

'u'g‘a

i arial

it B I O |§@§|A-gv\'»v's

i

Sh.

ape:

*

il B Boren P

||||||||l|‘||||I|lnllllll‘u‘l?ﬁ,ﬂ,":h - %

]
Search for Shapes. ::
Type your searchhere [w| B [ .
~ 3 Assistance
Bl Cubickes - I » T Search for:
[El Office Accessories =
[ Office Equipment: = Q
& Office Furniture E 43 Table of Corkents
[ Wwalls, Dooes and Windows =]
A | (!
I = o M3 .
(5 @ E @ - Office Online
n . o =
e Connect ko Microsoft
— = Office Online.
— - = Get the latest news
wiall Cunad Diaor = about using Visio
wal = Automaticaly updabe
..... = this list from Ehe web
s A - (< el
Cpening  Window  Couble door 4
[ = @] Assistance
o ]
# = ME & Training
SEE smE Cm E gfa Communities
ol = 3 Dovrload
P! - 3
Calaut W 4 » W[\ Page-1/ 1K jJ R
| Page 1/1
Status Bar

Figure 1-5: The Visio environment provides convenient access to tools.

Shortcuts for many tools are available on the Standard or Formatting toolbars,
which appear by default. Some templates include specialized toolbars, which float

in the drawing window by default. You can easily show or hide a toolbar:

4+ To display a toolbar, choose View => Toolbars and choose the toolbar you
want to use. A check mark appears when the toolbar is displayed. A special-
ized toolbar appears in the toolbar list when a drawing of its type is active.

4 To hide a toolbar, choose View > Toolbars and uncheck the checked toolbar

that you want to hide.

You can dock a toolbar along the top, bottom, or sides of the Visio window. When
you dock a toolbar to the left or right, the toolbar hangs vertically along the side.

Toolbars are easily manipulated:

15
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4+ To reposition a docked toolbar, drag its move handle to a new location. The
move handle is a series of dots to the left of a horizontal docked toolbar and
along the top of a vertical docked toolbar.

4+ To float a toolbar in the middle of the window, drag its move handle to a new
position.

4+ To reposition a floating toolbar, drag its title bar to a new location.

Task Panes

Task panes provide easy access to common tasks such as creating new drawings,
obtaining help, and collaborating with others. Task panes dock on the right side of
the screen by default. To show or hide a task pane, choose View = Task Pane. You
can also display the task pane by pressing Ctrl+F1.

T - - - =
rCross- '\ For more information about task panes and Visio help resources, see Chapter 38.

\
| Reference \

The Visio 2003 Drawing Area

The drawing window, which contains your active drawing, takes center stage in
the Visio drawing area. The drawing window is visible whenever you work on a
drawing. However, you can display several other windows to facilitate your work.
To display one of these other windows, choose View and then the window name.

The Drawing Window

Drawing pages appear in the drawing window, where you can add shapes or modify
and format the contents of your drawing. You can view different areas of a page
using the horizontal and vertical scrollbars. To view another page, select the tab
for that page below the drawing window.

A drawing grid and rulers make it easy to position and align shapes on a page. To
display a grid in the drawing window, choose View = Grid. To display rulers, choose
View => Rulers. The units that rulers display vary depending on the type of drawing
and scale you are using. For example, the rulers for a block diagram use inches,
whereas rulers for a site plan use feet.

To change the ruler units, choose Tools => Options and select the Units tab. Click
the Change button and choose the units you want from the Measurement Units
drop-down list.
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The Shapes Window

You drag and drop shapes from the Shapes window onto a drawing page. The Shapes
window contains active stencils and their shapes, docked by default on the left, as
shown in Figure 1-5. However, you can reposition the Shapes window or individual
stencils to suit your needs. For instance, you can dock the Shapes window at the top
or the bottom of the drawing area to provide more room for pages set to landscape
orientation.

4 To add another stencil to the Shapes window, choose File => Shapes, and navi-
gate to the stencil you want.

New '\ Instead of choosing File = Stencils as in Visio 2002, you open stencils in Visio 2003
feati> by choosing File > Shapes.

4+ To display the shapes for an open stencil in the Shapes window, click the sten-
cil’s title bar.

4+ To resize the Shapes window, drag the vertical divider between the Shapes
window and the drawing window to the left or right.

4+ To change the information displayed in the Shapes window, right-click the
Shapes window title bar and choose one of the options, such as Icons Only,
from the shortcut menu.

"Note To change the information in the Shapes window, you can also right-click a stencil
title bar, choose View, and then choose the type of information you want to see.

By default, in the Shapes window you see the title bars for all open stencils, but
only the shapes for the active stencil. To view multiple stencils at the same time,
you can

4+ Drag a stencil out of the Shapes window and float it on the screen, as shown in
Figure 1-6.

4 Drag a stencil to the top or bottom of the Shapes window to create a second
stencil pane.

17
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Multiple stencil panes in the Shapes window A docked stencil
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Figure 1-6: You can dock stencils in the Shapes window or float them on the

screen.

The Drawing Explorer

The Drawing Explorer, shown in Figure 1-7, offers a hierarchical view of your draw-
ing. You can use the Drawing Explorer to find, add, delete, or edit the components
of your drawing, including pages, layers, shapes, masters, styles, and patterns. For
example, you can select and highlight a shape on a drawing by double-clicking its
name in the Drawing Explorer. To display the Drawing Explorer, choose View &>
Drawing Explorer Window.
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Figure 1-7: You can exploit the
hierarchy of drawing components
in the Drawing Explorer window.
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Tip You can conserve screen real estate by docking and merging view windows. You
4, can dock other view windows within the Shapes window or you can merge sev-
4 eral windows into one. To dock a view window, such as Pan & Zoom, drag it into
the Shapes window. To merge view windows, drag one window by its title bar into
the center of another window. To switch between merged windows, select the tab
for the view you want.

The Size & Position Window

The Size & Position window is particularly useful when you work on scaled draw-
ings such as building plans, where precise measurements are important. You can
use the Size & Position window to view and edit a shape’s dimensions, position,
or rotation.

rCross- '\ To learn more about how to use the Size & Position window, see Chapter 4.
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The Custom Properties Window

The Custom Properties window is the best place to modify the custom properties
for a number of shapes. The window remains open until you close it and displays
the values for a shape when you select that shape. To edit a property in the Custom
Properties window, click the property box and enter or edit a value.

The ShapeSheet Window

You can modify any aspect of a shape in its ShapeSheet. You can display the
ShapeSheet by choosing Window = Show ShapeSheet.

rCross- '\ To learn more about ShapeSheets, see Chapter 33.
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Viewing Drawings

Examining your work is essential when you draw. As you progress from a blank
page to a completed drawing, you want to view your drawing in different ways,
and Visio 2003 provides the tools to do this.

r Cross- "\,‘ People who don't have Visio installed on their computers can still view Visio draw-
| Reference’, ;o To learn about using the Microsoft Visio Viewer or viewing Visio drawings on

= Web pages, see Chapter 11.

Panning and Zooming

Sometimes you want to see the big picture, and at other times you want detail.
In Visio, you can pan and zoom in several ways to see the area and detail that
you want.
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Tip

Tip

Using Pan and Zoom Shortcuts
Two keyboard shortcuts provide the fastest way to zoom in and out:

4 To zoom in, use Ctrl+Shift+left-click.

4+ To zoom out, use Ctrl+Shift+right-click.

You can change the center of the zoom area by repositioning the magnifying glass
that appears when you press Ctrl+Shift.

If you want Visio to center the zoom area on the selected shape when you zoom
in or out, choose Tools+> Options. Select the General tab and put a check in the

"4 Center Selection on Zoom check box.

Using the Pan & Zoom Window

The Pan & Zoom window shows the entire drawing page, with the zoom area out-
lined in red. Visio docks the Pan & Zoom window within the drawing window, but
you can dock it within the Shapes window if space is at a premium. Use one of the
following methods to specify the area you want to see:

4 On the right side of the Pan & Zoom window, drag the zoom scrollbar up or
down to zoom in or out, respectively.

4+ Drag a side or corner of the red outline to resize it, thereby changing the part
of the drawing visible in the drawing window.

4 Click and drag to define a new zoom area box in the Pan & Zoom window.

4 Click a point in the Pan & Zoom window to relocate the center of the zoom
area box.

Panning and Zooming from Menus and Toolbars

The View menu and the Standard toolbar both contain zoom options, but the zoom
list on the Standard toolbar is faster. You can choose from several predefined zoom
percentages as well as the entire page, the entire width of the page, and the last
zoom used.

If you use a mouse with a scroll wheel, you can use the mouse wheel to pan and
4, zoom. To pan up or down, roll the mouse wheel. Press the Shift key while rolling
4 the wheel to pan from side to side. You can zoom in and out by pressing the
Control key while rolling the mouse.

Working with Drawing Windows

Sometimes one window for your drawing isn’t enough —for instance, when you
want to copy shapes from one drawing to another or view details in two widely
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separated areas of the same drawing. You can create additional windows for your
drawings and arrange them in several ways.

Creating New Windows

When you create a new window, Visio displays the same drawing contained in the
previous window. The new window, identified by the “:2” that follows the filename
in the Visio title bar, fills the drawing window.

4 To create a new window, choose Window => New Window.

/' Note When you create a new window, the Shapes window doesn’t contain any open
-~ stencils. However, windows docked in the Shapes window are docked in the new
Shapes window as well.

4 To bring another window to the front, choose Window and then the name of
the window you want to see.

Viewing Multiple Windows

You can view several drawing windows at the same time. Tiling and cascading both
create panes for each open window. Tiling is helpful for viewing several areas of
detail at the same time as it arranges the panes side by side in the drawing area.
You can view all the windows at the same time, but each pane takes up a smaller
area of the screen.

Cascading is better when you want larger panes for each window but want to
switch between them quickly. Cascaded windows overlap, with each window
slightly lower and to the right of the previous one. When you cascade windows,
the current window appears in front.

4+ To tile the windows in the drawing area, choose Window => Tile.

4 To cascade windows, choose Window => Cascade.

4+ To bring a hidden window to the forefront, click any visible part of that
window.

4+ To fill the drawing area with one of the tiled or cascaded windows, click the
window’s Maximize button.

Summary

Visio is an essential tool for effectively communicating ideas and documenting busi-
ness results. Using drag and drop drawing techniques, anyone can produce great-
looking diagrams, drawings, and models. This chapter introduced you to Visio 2003.
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Specifically, in this chapter you learned about the following:

4+ New and updated features in Visio 2003

4 Features discontinued in Visio 2003

4 The concepts that make Visio so powerful
4+ The components of Visio’s interface

4 How to view your Visio drawings

¢+ o+



