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CHAPTER

TAKING COMMAND
OF WINDOWS XP

onsider this story line: Man creates

technology; technology gains power;

technology controls Man. This story

line is a popular theme in science

fiction, but when we consider the
important roles that computers play in modern soci-
ety the theme feels more like reality than fiction.

Fortunately, humans haven’t entirely given up con-
trol to the machines just yet, not even those machines
that run Windows XP. You can control virtually every
aspect of the way Windows XP looks and behaves,
whether youre running XP on your personal laptop
or your company’s network server.

This chapter shows you how to take command of
Windows XP’s behavior. You can take charge of the
way Windows starts up, as well as control if and how
others use your computer. You can specify which
program is used to open files of a certain type.
Techniques in this chapter also show you how to track
errors and system events, and how to take charge of
the way Windows XP handles system memory.

——
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ABOUT THE FEATURE . )
little more than a decade ago home computers weren’t very

common. But today many households have two or more

computers, and modern offices often have more computers

on hand than people. But even with so many computers on

hand, many computers are still used by more than one per-
son. At home you may use your computer to shop online and file taxes,
while your children use the same PC to do their homework.

If you share your computer with others, you may find it handy — or even
necessary — to control who can use the computer and what features they
can access. Windows XP helps you do this with user accounts. The com-
puter shown in Figure 1.1 has two user accounts, named Keith and Dean.
Each authorized user can have his or her own account on the computer. As
an administrator, you control who gets an account and what they are

Whether your computer is in
a home full of nosy teen-
agers or a fully-staffed office,
it's not a good idea to let
anyone and everyone have
free access to your computer.
Windows XP uses individual
user accounts to control who
can use a computer and what
each user is allowed to do.
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allowed to do when they log on. Creating separate
accounts for each user has several benefits:

m Your personal files, e-mail, and documents
remain private.

m You can prevent others from modifying impor-
tant system settings.

m Each user can use his own unique display and
appearance settings for Windows.

m Restricted users may not install new programs.
m Favorite Web sites and other Internet files are
unique to each user.

STEP 1: CREATE AN ACCOUNT

At a minimum, your computer already has an admin-
istrator account. As the name implies, the adminis-
trator account is for the person in charge of the
computer, probably you. Before you can create a user
account, you must log in to Windows as an adminis-
trator or with an account that has administrator
rights. The steps below show you how to specify
whether or not an account has administrator rights.
To create a new user account:

m Open the Windows XP Control Panel by
choosing Start > Control Panel.

m Click the User Accounts icon. The User Accounts
control panel appears as shown in Figure 1.2.

m Click Create a new account. Type a name for
the account when prompted to do so, and then
click Next.

—

Even if you don't share your computer with any-
one, it’s a good idea to set up a user account for
yourself. This helps ensure that unauthorized
persons can’t use the computer.

——

Chapter 1  Taking Command of Windows XP

m On the Pick an account type screen shown in
Figure 1.3, choose an account type. If you choose
Computer administrator, the user will have full
access to the computer. An administrator can
install software, create or delete user accounts, and
access all files on the computer. If you want to
limit access to the computer, choose the Limited
account type. A limited user cannot create, mod-
ify, or delete accounts, nor can a limited user
install new software. Limited users can only access
files they create, as well as any files located in the
Shared Documents folder.

m Click Create Account to complete the process.

—

Account types can be changed easily. Simply
open the User Accounts control panel, click the
name of an account that you want to change,
and click Change the account type in the list of
options that appears.

€. User Accounts [BE=]

e Back () @2 Home

Learn About
2] User account types

© Computer administrator @ Limited

With 3 limited account, you can:
o Change or remove your password
o Change your picture, theme, and other desktop settings
o view Files you crested
o view files in the Shared Documerts folder

Users with limited accounts cannck ahways instal programs. Depending on
the program, = ussr might nesd administrator privileges ko instal i,

alsa, programs designed prior to Windows %P o Windows 2000 might not
work properly with imited accounts. For best results, choose programs
bearing the Designed for Windows %P logo, or, to run older programs,
choose the "computer administrator” account type

1.3
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Managing User Accounts

STEP 2: SET LOG ON/OFF OPTIONS

An important aspect of managing user accounts in
Windows XP is controlling how users log on and off
Windows.

m Open the User Accounts control panel if it isn’t
already open, and then click Change the way
users log on or off from the list of tasks.

m Choose whether or not you want to use the
Windows XP Welcome screen like the one shown
in Figure 1.4. The Welcome screen is faster and
easier to use if some or all of your user accounts
don’t use passwords. If you choose not to use the
Welcome screen, users instead use a classic login
dialog box like that used by older versions of
Windows.

m Choose whether you want to use Fast User
Switching. Like the name implies, Fast User
Switching lets you switch between users faster.

To use Fast User Switching you must also use

the Welcome screen. With Fast User Switching
enabled, you can change user accounts without
closing programs. To use Fast User Switching,
click Start and then Log Off. As shown in Figure
1.5, the Log Off Windows dialog box has a button

—

If your screen saver activates and you use the
Windows XP Welcome screen, you'll have to go
through the Welcome screen every time you
turn off the screen saver and try to get back to
work. This can be annoying if your account hap-
pens to be password protected, because it
means you must retype your password every
time the screen saver starts. To avoid this,
uncheck the Use the Welcome screen option in
the User Accounts control panel.

—IGd

named Switch User. Click this button to open the
Welcome screen and switch to a new user account.
m Click Apply Options when you are done adjust-
ing log-on and log-off options.

Passwords in Windows XP are case-sensitive. If
your password includes a combination of upper-
and lowercase letters, such as APRILfools, you
must type your password exactly the same when
you log in to Windows.

Microsoft’ [ ’
Windows

To begin, click your user name

Switch User

Cancel
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STEP 3: CREATE PASSWORDS
(OPTIONAL)

Passwords aren’t absolutely mandatory for all user
accounts in Windows XP, but it’s usually a good idea to
at least create a password for all administrator accounts.
For more on advanced password management tech-
niques, see “Managing Passwords” in Chapter 6.

m Open the User Accounts control panel if it isn’t
already open, and then click the name of an
account for which you want to create a password.
m Follow the instructions on-screen to type and
retype a password for your account. You should
also type a word or phrase in the password hint
field, but keep in mind that this hint is visible to
anyone who uses your computer. For example, if
your password is the name of your dog, and the
hint is, “What is the dog’s name?” other family
members can probably figure out the password.
m Click the Create Password button to create the
password.

——

Chapter 1  Taking Command of Windows XP

STEP 4: DELETE ACCOUNTS (OPTIONAL)

It’s always a good idea to get rid of old user accounts
that are no longer needed. To delete an account, open
the User Accounts control panel, click the name of
the account you want to delete, and click Delete the
account. Keep in mind that when you delete an
account, you usually delete all of the files and docu-
ments associated with that account, including:

m E-mail messages

m Internet files and favorites

m Display settings

m Desktop items

m The My Documents folder and all of its
contents

You can preserve items from the account’s desktop
and My Documents folder. To do so, click Keep Files.
If you click Delete Files, all of the above listed items
are deleted along with the account.
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TECHNIQUE

CONTROLLING STARTUP ITEMS

.2 System Configuration Utility

General | SYSTEM.INI | WIM.INL | BOOT.IMI | Services | Startup

Startup Item Cornmnand Location ~
SynTPERh C:\Program FilesiSyna...  HELMISOFTWARE MicrosoftyWindowslCurrentyer,
DireckCD "C:\Program Files\Roxi,..  HELMSOFTWARE \MicrasaftiWindows\Currentver,
cpgset C\Program FlestHPGY...  HELMSOFTWARE MicrasaftiWindows\Currentyer.
navapwsz CAPROGRA~LINORT...  HELMISOFTWARE MicrosoftyWindows|Currentyer,
printray CHWINDOWS\System,,,  HELMSOFTWARE MicrasaftiWindows\Currentver,

Adobe Gamma Loader  CPROGRA~LWCOMM,.,  Common Startup
Microsoft OFfice CHPROGRA~IWMICR,..  Common Startup
[ realsched Ci\Program Files\Com,.,  SOFTWARE\Microsoftiwindows\Current¥ersion|RL
[ Eillminder CAPROGRA~1LQuicke. ..  Common Starkup
[ quicken Scheduled ... CHPROGRA~1Guicke...  Commaon Startup
[ Guicken Startup CAPROGRA~1icke. .. Commaon Startup

L

C O % GHA K ) s:03am

2.1

ABOUT THE FEATURE

When you launch Windows,
various other
launch as well. Some of
these programs — such as
antivirus programs — are
important, but others simply
waste system resources. You

programs

can control which programs
start up when you launch
Windows XP.

3 >
[ Enable Al ] [ Diablesl ]
2.2

ake a look at the Windows XP system tray, which is the area

in the lower-right corner of the screen next to the clock. Your

system tray probably shows a collection of icons similar to

the system tray shown in Figure 2.1. Some of these icons

provide a visual indication of system status. If youre using a
laptop, for example, you should see a small power cord icon in the system
tray if you are plugged in to AC wall power, and you should see a battery icon
if you are currently running on battery power. Other system tray icons —
like the speaker — provide links to basic Windows features.

Many system tray icons represent third-party programs that launched
when Windows XP started up and are currently running in the back-
ground. These programs are often called memory resident programs,
because they’ve taken up residence in your computer’s memory and have
no plans for moving out. Among the most annoying types of memory resi-
dent programs are spyware or adware, programs that I describe in
Technique 40, “Finding and Destroying Spyware” in Chapter 6.

Some memory resident programs, such as antivirus programs and fire-
walls, are desirable. But others may be just wasting system resources. This
technique helps you identify and disable startup items on your system

7

.
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using tools such as the System Configuration Utility,
shown in Figure 2.2. Disabling startup programs
simply turns them off; it does not delete the program,
so this is a change that can be safely undone if you
don’t like it or if it causes problems.

STEP 1: REVIEW STARTUP ITEMS IN THE
SYSTEM CONFIGURATION UTILITY

One of Windows XP’s most useful yet little-known
tools is the System Configuration Utility. This utility
is little known because you won’t find it in the
Windows Control Panel or the Start menu. To launch
the System Configuration Utility, choose Start>
Run. In the Run dialog box, type msconfig as shown
in Figure 2.3, and then click OK. The System
Configuration Utility opens.

In the System Configuration Utility, click the
Startup tab to bring it to the front. A list of items
similar to Figure 2.4 appears. Each item in the list

— Al

It's a good idea to create a system restore point
before you make any system changes such as
the ones described here. See Chapter 4 for more
on using system restore points.

——

Chapter 1  Taking Command of Windows XP

represents an application that launches with Windows
and runs in the background. To disable a startup
item, simply remove the check mark next to it in the
list. Consider each item carefully. Some items are easy
to identify based on their name. In Figure 2.4, the last
two items have “Quicken” in the name, which identi-
fies them as part of a personal finance software
installed on this computer. I can safely disable those
items because they don’t serve a function that is cru-
cial to system function. The third-to-last item,
“Billminder,” has a less descriptive name, but the
Command column shows that it resides in the same
“Quicken” folder as the other two items. I can safely
disable “Billminder” as well.

Click OK to close the System Configuration Utility.
Windows prompts you to restart your computer to
put your changes into effect.

When in doubt, keep it. Some startup items
may serve important system functions such as
antivirus protection or laptop touch pad con-
trols. Only disable items that you can clearly
identify as noncrucial.

. System Configuration Utility

General | SYSTEM.INL | WIN.INI | BOOT.INI | Services | Startup

Starbup Item Command Location

Run 2J&

- Type the name of a program, Folder, document, or
Internet resource, and Windows will open it For you.

Open: | msconfigl w

I [o]8 H Cancel H Browse. .,

2.3

SynTPEnh

DirectCD

cposet

navapw3z

prinkray

Adnbe Gamma Loader
Microsoft Office

[ realsched

[] Bilminder

[ uicken Scheduled ..,
[ Quicken Startup

<

C:\Program Files)SynapticsiSynTPiSyn. ..
"CiiProgram Files\Roxio\Easy CD Crea...
CtProgram FilestHPQ\Defaul: Settings. ..
CHPROGRATYNORTON- 1inawapw3. ..
AW INDOWS | System32) spooliDRIVE. ..
CHPROGR A~ ICOMMON~11AdobeiC.. .
CHPROGR A YMICROS~30Ficel0s. .
C:\Pragram Files\Common Files\Realil...
CHPROGRA~1YQuickentbillmind, exe -s. ..

CPROGRA~1Quicken\bagent, exe
C:\PROGR A~ 11QUicken|QWDLLS EXE

HKLMISOFTW AREMicrosoft|Windc
HKLM\SOF TWARE Microsoft|Wind:
HELM\SOFTWAREMicrosoftiwinde
HKLMSOF T AREMicrosaft winde
HKLMASOF TWARE Wicrosoft|Winde
Comrmon Starkup
Common Startup
SOFTWARE MicrosoftiwindowsiCr
Common Startup
Zommon Startup
Cormrmon Starkup

[ Enable Al

| [ Cisableal |

2.4
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Controlling Startup Items

STEP 2: CLEAN OUT THE STARTUP
FOLDER

Some startup items are stored in a Windows Start
menu folder aptly titled Startup. To view the con-
tents of this folder choose Start> All Programs >
Startup. You can easily remove an item from the
Startup folder. Just right-click the item and choose
Delete from the menu that appears. Deleting items
from the Startup folder is usually safe because the
programs themselves are not deleted. The only thing
you delete here is a shortcut to the program.

Although this technique is about removing startup
items, you can add items to the Startup folder as eas-
ily as you remove them. Simply click and drag items
to the Startup folder. For example, if you want your
e-mail program to open when you start Windows,
click and drag the shortcut for the e-mail program to
the Startup folder.

STEP 3: EDIT THE REGISTRY

The Windows registry controls some Windows startup
items. The registry is a fundamental component of
the Windows XP operating system, and it should be
modified with great care. If you accidentally delete
the wrong thing in the registry your computer may
stop working, and your only solution may be to rein-
stall Windows. Still, sometimes the only way to com-
pletely disable a startup item is to edit the registry.
To review and disable startup items in the registry:

m Choose Start > Run to open the Run dialog box.
m Type regedit in the Run dialog box and click
OK. The Registry Editor opens as shown in Figure
2.5. Registry keys are listed on the left side of the
screen in a folder-tree manner. Click a plus sign
next to a key to expand the list.

m Open the key HKEY_LOCAL_MACHINE\
SOFTWARE\Microsoft\Windows\CurrentVersion\
Run. A list of values appears on the right. Your list

.

——

may look similar to Figure 2.5. To remove an item,
select it in the list on the right and choose Edit >
Delete. Remember, deletions are permanent; the
Registry Editor does not have an undo feature.
Don’t delete any value unless you can positively
identify it as a noncritical item. For example, if
you see a key that is obviously related to a program
that you uninstalled, you can safely delete it.

m Open the key HKEY_CURRENT_USER\
Software\Microsoft\Windows\CurrentVersion\
Run. As before, review and delete values as needed.

The Windows Registry Editor does not have an
undo feature, and changes take effect immedi-

ately. Because of this, trial and error is not a
good methodology to use when editing the reg-
istry. Be very careful and absolutely certain
before making any registry changes. Also, set a
system restore point before editing the registry.
See Chapter 4 for more about using system
restore points.It's also a good idea to back up the
registry. Chapter 4 also shows you how to back
up the registry and other system components.

2 Registry Editor 3= ]
File Edit View Favorites Help
(1 MediaContentlr~| | Name Type Data
(1 ModuleUsage | [ (Default) REG_SZ {value not sef)
(1 MS-DOS Emula | E5]AdaptecDire... REG_SZ *C:\Program Files\Roxio\Easy CD Creator ...
= (1 Nis B]ATIModeCha... REG_SZ Ai2mdzx.exe
(1 OemStartMenul || BIATIPTA REG_SZ CiProgram Files\ATI TechnologiesiaTI C...
(1 OptimalLayout [sb)CARPService REG_SZ carpserv.exe
-3 policles (s8] Cpgset REG_SZ C:\Program Files\HPQ\Default Settingsicp...
+ 03 Reinstall [a8]Display Setti... REG_SZ C:\Program Files\HP Q\Notebook Utilities...
@B Reliability @MSCnnﬁg REG_SZ C:\WINDOWS'PCHealthiHelp CtriBinaries...
R B]NAV Agent  REG_SZ C:APROGRA~1T\NORTON-~T\navapw32.exe
& RunOnes [PreloadApp  REG_SZ p
O RunOnes: @]PrinTray REG_SZ CAWINDOWS!System32ispool\ DRIVERSWA...
a S““ neekx [=5)QT4HPOT REG_SZ C:\Program Files\HPQ'One Touch\OneTo...
# etup [¥]srmclean REG_SZ CACpysi'Scom'srmelean.exe
(1 SharedDLLs [38)SynTPEnh REG_SZ C:\Program Files\Synaptics\SynTP\SynTP...
= (1 Shell Extension || Gy TPLpr REG_SZ C:\Program Files\Synaptics\SynTP\SynTP...

# £ ShellCompatibi
< —— 3 |2 >
My ComputertHKEY_LOCAL_MACHINE\S OFTWARE i i

2.5
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TECHNIQUE
Folder Options EE
General | Wiew | File Types
Reqistered file types:
Eutenzionz | File Types -~
ﬂ POF &dobe Acrobat Document
- = ﬂ PO IDS_CATALOG_INDEX
—F’,:“V "E'j_“‘“s ——— S |@PFM Type 1 Font file
= Lo Fe BS_ = = P Persanal Infarmation Exchange
@opack - () (T O search Folders [f]~ ﬁﬁmm PICT File
= FIF PIP File
burnout =
%) @ Windows Media AudioVideo file =t o Bloblic Voo ©omecibes Mbinot >
" 1,207 KB
& Copyto D cat fan Mew ] [ Delete ]
Windows Media Audio/Video file
ile and Fold k: ¥ 373 KB
7L Dretails for 'POF extension
Chapter 1
Other{places ¥ ‘ ?z\f:x"d;; Opens with: |i‘|' Acrobat Reader 5.1
Doty = :;wg'm Media Audioffideo fil Files with extenzion 'PDF are of type 'Adabe Acrobat Document’.
R Spres 1 [IIEI]':(“I;S etia fudiodvidea fite To change zettings that affect all ‘Adobe Acrobat Document’ files,
Adobe Acrobat Document ’ click Advanced.

Date Modffied: Friday, May 03, PDF vidspecs
2002, 1110 PM ﬂ Adobe Acrobat Document
M vidspecs
Ei Microsoft Word Document
61 KB

ar. l [ Cancel l

31 3.2
f you've been using PCs since the days of DOS, you're probably
When you double-click a familiar with filename extensions. Extensions are typically two-,
file, Windows automatically three-, or four-character suffixes appended to a file’s name, and
chooses which program they identify the file’s format. For example, a Microsoft Word doc-
should be used to open it. ument has the extension .doc, and a JPEG image usually has the
You can control which pro- extension .jpg or .jpeg. Extensions are still used by Windows XP, although
grams are associated with the extensions are usually hidden when you view a list of files in Windows
various file types. Explorer or My Computer. By default, Windows XP hides extensions that

are understood, so that only unknown file extensions are displayed.

When you double-click a file, Windows XP looks at the filename exten-

sion to determine the file’s format. This information is used to determine
which program should be used to open the file. Of course, some files can be

11

.
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opened by more than one program. A text file (.txt)
can be opened by Notepad, WordPad, or any word
processor. A JPEG image can be opened by Internet
Explorer, Windows Picture and Fax Viewer, Microsoft
Paint, or any graphics program.

You may or may not be happy with the default pro-
grams used to open certain types of files. Fortunately,
Windows lets you change program file associations.
You may need to do this after installing a new media
player program. When you install a new program like
RealOne or QuickTime, the new program probably
takes over file associations for common media for-
mats such as MPEG video and MP3 audio. But if you
want to continue using your old media player — such
as Windows Media Player — for those file types, you
need to manually adjust file association settings. In
Figure 3.1 you can see that some of the video file for-
mats are associated with Windows Media Player,
while others are associated with RealOne Player.
Other programs in the list — non-video files — are
associated with programs such as Adobe Acrobat and
Microsoft Word. Windows XP lets you easily control
which programs are used to open certain types of
programs. In Figure 3.2 ’'m checking the file associa-
tion for Adobe Acrobat documents.

— il

If you get an error message stating that
Windows cannot find a program to open a given
file, the file association setting for that program
may simply be broken. If you know that a pro-
gram is installed that can handle the file type,
follow the steps here to fix the file association
setting.

——

Chapter 1  Taking Command of Windows XP

STEP 1: LAUNCH FOLDER OPTIONS

You can change file associations using the Folder
Options dialog box. To open the Folder Options dia-
log box, open Windows Explorer or My Computer
and then choose Tools > Folder Options. The Folder
Options dialog box appears. Click the View tab to
bring it to the front as shown in Figure 3.3.

As mentioned earlier, Windows XP normally hides
filename extensions. If you want to view extensions
all the time, scroll down the list of Advanced Settings,
and remove the check mark next to Hide extensions
for known file types. When you’re done reviewing
options on the View tab, click the File Types tab.

Folder Options [2JE3d

General | Yiew | File Types

Folder views

You can apply the view [such az Detailz or Tiles) that
wou are using for this folder to all folders.

I.-’-‘n.ppI_I,JtDAIIFUIders l [ Reset All Folders

Advanced gettings:

I3 Files and Folders #
Automatically search for netwark, folders and printers
Dizplay file size information in folder tips
Digplay simple folder view in Explorer's Folders list
[ Display the conterts of spstem folders
Dizplay the full path in the address bar
[ Display the full path in the title bar
[ Danat cache thumbnails
[ Hidden files and folders

(%) Do not show hidden files and folders
3 Show hidden files and folders

Hide extenszions for known file types hd
Restore Defaults
(] 4 ] [ Cancel ]

33
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Changing the Way Files Open

STEP 2: CHANGE A FILE ASSOCIATION

The File Types tab of the Folder Options dialog box
provides a list of all file types known to the computer.
The list on your computer is probably long. Formats
are listed in alphabetical order by extension, and you
may need to scroll down before you find the extension
that you want to change. To change a file association:

m Locate the file extension that you want to
change. Click it once to view details about the
extension in the bottom half of the File Types tab
as shown in Figure 3.4.

m Click Change. The Open With dialog box
appears as shown in Figure 3.5. Choose a
program from the list, preferably one from the
Recommended Programs list. If the program you

Folder Options B3] % |

General | View | File Types

Reaistered file types:

Eutenzions | File Types -
@) MPa  MPA Media
@) MPE  MPEG Media
MPEG  MPEG Video
@ MPG  MPEG Video
@) MPGA  MPEG Audio
@) MPS  MPEG Media

ANTI=¥] RADC I Y i,

b

Hew ][ Delete ]

Dretails for MPEG" extension

Opens with: .\L} Fieallne Player

Files with extension 'MPEG" are of type 'MPEG Video' To change
zettings that affect all MPEG Yideo' files, click Advanced.

0K I[ Cancel ]

—IGd
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want to use isn’t listed at all, click Browse and
browse to the executable program file for the
program you want to use.

m Click OK to close the Open With dialog box.

Some file formats are identified by several dif-
ferent filename extensions. For example, an
MPEG movie file can have the extension .MPG,
.MPEG, .MPE, or one of several other alternate
extensions. Carefully review the list of file exten-
sions in the Folder Options dialog box; you may
need to change the file association for several
different filename extensions.

Open With )&

] Choose the program you want to use to apen this File:
£

File:  .MPEG
Programs

|7 Recommended Programs: -~
(1) Realone Player

G}
Im Cther Pragrams:

E‘l acrobat Reader 5.1

ﬂ Adobe ustratar

E Adobe Photoshop Limited Edition

America Online

& Internet Explarer

B% MG Photosuite For Windows 95

W Microsoft WWaord For Windaws

A R L e e Fae o

Erowse, .,

If the program wou want is not in the lisk or on wour computer, you can ook
for the appropriste program on the Wb,

oK l [ Cancel

3.4

3.5
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STEP 3: CREATE A NEW FILE TYPE can easily edit PHP files in a text editor. This step
(OPTIONAL) is optional; if you don’t choose an Associated File

Type or if nothing in the list seems to match, you
can specify a program to open the file later. Follow
the instructions under step 2 to associate the
extension with a program.

m Click OK when you're done.

It is possible — though unlikely — that a file extension
you need to use isn’t associated with any program. In
that case, you can create a file extension from scratch
and associate it with a program.

m On the File Types tab of the Folder Options
dialog box, click New. The Create New Extension

dialog box appears. Create Hew Extension EE
m Click the Advanced button to expand the dialog [Hile Estiersfan FHA
box as shown in Figure 3.6.

m Type an extension in the File Extension field. fssocisted File Type: | Test Document ad
m Choose an Associated File Type from the [ ok || Cancel |
menu. In Figure 3.6 I am associating the extension

PHP with the Text Document file type so that I 3.6
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TECHNIQUE
Event Properties I
Event
[ ate: 9/28/2003  Sowce:  Application Hang +
Tirne: 09454 Categorny: [1071)
Type: Errar Ewvent ID: 1002 +
User: Tl /2, :
= Computer B[] Computer: COMPAQ 2170
= File Action View Window Help —1&] x|
@ iy ® Drezcrption:
[= Computer (Lo [ Type Date Source | category | Evenl~ - — -
= & System Tools Frror 9282003 1 Aulication Hang (101 1002 Hatging applic:ation IEXPLORE Ex<E. wersion £.0.2800.1106, hang
Q pp g (100 !
= (£ Event Viewer € Error 92012003 .. Application Hang (101} 1002 module hungapp, vergion 0.0.0.0, hang address 0:00000000.
%Applicatinn %Infﬂrmal... 9/27/2003 . Msilnstaller None 172
Security Informat... 9/26/2003 .. Winlogon None 1002 . .
System glnfurmal... 9/21/2003 Msilnstaller None 170, ER' T?'e |nflormat|an, Se,?f HFIE,Fnd Stuppolt Center at
42 Shared Folders Warning 972172003 WinMgmt None 63 p:/#go.microsaft. comdfwlink fevents. asp.
« & Performance Logs an | & Informat... 9/21/2003 Msilnstaller None 170
2 Device Manager Q Error 9/22/2003 Application Hang ~ (101) 1002
& Storage @ Informat... 9/16/2003 Msilnstaller None 1172
< i@ Services and Application | S Error 7/23/2003 Application Error ~ None 1000
@ Informat... 7/2/2003 . Automatic Updates (2) 17
@ Informat... 7/1/2003 . Msilnstaller None 1172
@ Informat... 7/1/2003 . Msilnstaller None 170
%Infﬂrmal... 7172003 . Msilnstaller None 170
Informat... 7/1/2003 Msilnstaller None 170 ;
glnfurmal... 6/30/2003 DAlatson None 4097 Data (& Bptes O Wards
Error 6/30/2003 Application Error  None 1000 z i
%lnfmmai... 6/30,2003 UploadM None 16891 0000: 41 70 70 6c 52 63 61 Y4 Applicat -~
Informat... 6/27/2003 DiWatson None 1007 DO0S8: 69 6f 62 £0 48 61 62 67 iomn Har
@) Informat... 6126/2003 . Msilnstaller None 170 i £l
%Infﬂrmal... 6/26/2003 Msilnstaller None 1172 0010: z0 zZ0 43 45 58 50 4o d4f IEXPLO v
Warning  6/26/2003 Usereny None 1517
D informat... 6:26/2003 Msilnstaller None  1172(
©Informat... 6126/2003 LoadPerf None 1000 v
< 2] > (]9 ] [ Cancel
4.1 4.2

ABOUT THE FEATURE . .
ave you ever experienced an error with a program, but

when you tried to explain the problem later — say, to

technical support staff — you couldn’t remember some

important details? Helpfully, Windows XP logs all sys-

tem errors, as well as security and network events. A
tool called the Event Viewer, shown in Figure 4.1, allows you to review
these logs, providing information that will prove useful whether you trou-
bleshoot the problem yourself or consult outside help. The Event Viewer
gives you more control over your computer by keeping you informed about
things that are happening.

Windows XP keeps track of
all errors, security events, net-
work events, software instal-
lations, and other important
actions. Logs of these events
and errors can prove invalu-
able as you troubleshoot
problems.

15
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STEP 1: OPEN THE EVENT VIEWER Figure 4.3 shows another type of event. This event
is a little more mundane; Microsoft Office 2000 was

The Event Viewer is part of the Computer Management
installed on this computer.

control panel. To open it:

m Choose Start > Control Panel to open the

Windows XP Control Panel. If your Control Panel STEP 3: FILTER RESULTS

is set up in Category view, click the Performance The Event Viewer logs can grow pretty long, with
and Maintenance category. many of the entries pertaining to mundane events
m Double-click the Administrative Tools icon in such as logging on to Windows. You can filter events
the Control Panel. A list of administrative tools in the Event Viewer so that only events of a certain
appears. type — errors or warnings, for example — are dis-
m Double-click the Computer Management icon. played. To filter events:

The Computer Management window opens. Click
the plus sign next to Event Viewer under System
Tools on the left side of the window, and click one
of the event categories to view it.

m In the Computer Management window, choose
View > Filter. The Filter tab of the properties
dialog box appears as shown in Figure 4.4.

m Remove check marks next to event types that
In Figure 4.1 T am viewing Application events, which you don’t want to view.

usually consist of application errors and crashes,
installations, and other program events. Security

events include security-related events, including pol- e b %]
icy changes. Every time a user logs in to Windows a Event
security event is logged, so the list of Security events Date  9/21/2003 Sowce:  Msinstaller +
can get quite long. System events are operating sys- Time:  240:37PM  Category: Mone
. . Tuype: Infarmation  Ewent ID: 17707 +

tem events, such as hardware drivers and Windows 0 o =

. . . ser. B
components. As with Security events, the list of System Computer: COMPARZ1T0

events can get lengthy because drivers and compo-

. . Description:
nents are loaded every time you start Windows.

Product; Microzoft Office 2000 Premium -- |nstallation operation completed
successfully.

For more information, see Help and Support Center at

STEP 2: REVIEW EVENTS http://go. microsoft. com/fwlink Aevents. azp.

To review details of an event, simply double-click it in
the Event Viewer. An Event Properties dialog box
appears, the contents of which vary depending on the
type of event. Figure 4.2 shows an error event that
was logged when the application IEXPLORER.EXE
hung, which is how Windows XP describes a pro-
gram that freezes or crashes. Additional information 0k [ Coneel
may prove useful when contacting technical support
or researching solutions. 4.3
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m If you know that you want to view events only
from one specific source, choose an option in the
Event source menu. If you choose a specific Event
source, you can further filter the results by choos-
ing a Category.

m Enter information in the Event ID, User, and
Computer fields if you want to filter results by
those criteria.

m Use the drop-down menus at the bottom of the
Filter tab to view results from a specific date range.
m Click OK when you have set up all of your filter
rules.

Security Properties &

General | Filter

Event types
[ Information [
Warning Failure audit
Errar

Ewent zource: &l w
Category: (&) I
Event 10:

Uzer:

Computer:

FErom: First Event e

To Last Ewent w

Restare Defaults

QK H Cahcel ][ Apply ]

——

4.4
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STEP 4: EXPORT A LOG

Event logs can be exported to a text file. This allows
the log to be easily shared with others. To export a log:

m Choose Action > Export List in the Computer
Management window. An Export List dialog box
appears.

m Choose a location in which to save the file, pro-
vide a filename, and click Save. The file is saved as
a tab delimited text file. You can open the file in
any text editor, as shown in Figure 4.5. Tab delim-
ited files can also be easily imported into a spread-
sheet program.

STEP 5: CLEAR EVENTS (OPTIONAL)

Your Event Viewer will start to get full after a while. If
you have resolved all outstanding issues, you can
clean up the logs by clearing out old events. To do so,
simply choose Action> Clear All Events. Before
doing so, I recommend you first export your logs as
described in the previous step. If a problem occurs in
the near future, you can use information in the
exported log files for troubleshooting.

) erors0928 - Notepad [S[E[=]
File Edit Format View Help

Type  Date  Time  Source category Event  user  Computer

Error  9/28/2003 10:58:14 Application Hang Cloly 1002 n/A COMPAQZ170
Error 072872003 5:03:45 AM Application Hang Cloly 1002 N/A COMPAG2170
Information 9/27/2003 00 P wsirnstaller  Mone 11728 M/A COMPAQ2170
Information 9/26/2003 106 PM winlogon MOne 1002 NAA COMPAQ2170
Information 0,212 Pu msiInstaller one 117 N/A COMPAQ2170
warning 9/71,/2003 152z winMgnt None 63 SYSTEM COMPAQ2L70

Informatian 9/21/2003 M wsirnstaller  wone 707 N/ COMPAQ2170
Error  9,22/2003 1201 Applicarion Hang Clony 1002 WAA CPQ28121814
Information 9/16/2003 3 wsiInstaller  None 11728 NAA CPQ28121814
Error  7/23/2003 Application Error Mone 1000 H/A CPQ2E121814
Information 7 P Automatic updates 2 17 /A crg
Information 7/L/2003 A wsirnstaller  none L1728 n/a CPQ28121814
Information 7172003 ol weiInstaller  wone 11707 H/A CPQ28121814
Information /172003 A wsiInstaller  none 11707 NAA CPQ28121814
Information 7//2003 2 Msilnstaller  MNone 11707  H/A CPQZEI21814
Information 6/30/20 am atson Mone 4097 MAA CPQ28121814
Error  6/30/2003 22z Application Error MOne 1000 NAA CPQ28121814
Information /30,2003 A Uploadk none 16896  N/A CPQ2E121814422
Information ©6/27,2003 A Drwatson Mone 4097 N/A CPQ28121814
Information 6/26/2003 &4 wsirnstaller  none 11707 nAA CPQ28121814
Information 6/26/20 44 am weiInstaller  wone 11728 W/A CPQ28121814
warning 6/26,/2003 11:32:4 Userenv nOne 1517 SYSTEM CPQZELZ1S14422

Information 6/26/20 11:00:30 AM MsiInstaller  Mone 11728 H/A cPQ2E121814
Information 6/26/2003 11:08:35 amM Loadperf Mone 1000 MAA CPQ28121814
Information 6/26/2003 11:08:34 AM Loadperf None 1o0L NAA CPQ28121814
< >

4.5
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TECHNIQUE
Virtual Memory €A% |
System Properties B[%) Drive [Yolume Label] Paging File Size (ME)
C 354 - e
System Restore Automatic Updates Remote
Gereral Computer Manme Hardware Advanced
System:
Microzoft Windows =P
PR Paging file size for selected drive
'I / Version 2002 Drive: C:
Z' ’ - Service Pack 1 Space available: 13412 ME
o Fegistered to: (%) Custom size:
W— Feith Underdahl Tnitial size (ME): 304
Maximurn size (ME): | 768
Computer: {:} System managed size

AMD Duron(tm)] processor C‘ Mo paging File Set

1.00 GHz

512 MB of RéM Total paging File size For all drives
Mlinirnurn allowed: 2 MB
Recommended: 766 MB
Currently allocated: 354 MB

ak, l [ Cancel ok ] [ Cancel
51 5.2

ABOUT THE FEATURE .
ne of the most important hardware components of your

computer is the random access memory, or RAM. If your

hard drive can be thought of as a filing cabinet, RAM is

the top of the desk where the computer actually does its

work. If you have a bigger desk, your work is more effi-
cient and you're less likely to lose something important. Likewise, if your
computer has more RAM it performs faster, more efficiently, and more
reliably.

Because RAM is so important, it’s usually one of the first things listed on
the spec sheet for a new computer. But no matter how much RAM is
installed, some programs need more. To accommodate this, the operating
system uses some hard drive space to supplement system RAM. Windows

Windows XP manages mem-
ory resources on your com-
puter, but the default
memory management set-
tings may not be ideal for
your computer and needs.
Windows allows you to
adjust the way memory is
managed.

19
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XP calls this space virtual memory, and it is similar to
the swap space used by other operating systems such

as Linux.

Windows XP manages the size and location of vir-
tual memory behind the scenes so effectively that
most computer users are never even aware of it. But
even though virtual memory seems to be working
fine in the background, it may not be set up for great-
est efficiency on your computer. This technique
shows you how to review the way Windows XP man-
ages memory usage on your system, as shown in
Figure 5.2, and adjust virtual memory settings for

best efficiency.

STEP 1: DETERMINE HOW MUCH RAM

IS INSTALLED

Before you start changing memory settings, you need
to know how much RAM is installed on your system.
Although you may remember the computer’s specs
from when you bought it or upgraded RAM, a more
reliable way to measure available RAM is to check the

Windows XP System Properties control panel:

m Choose Start > Control Panel to open the

Windows XP Control Panel. If you see the

Performance and Maintenance category, click

that category to open it.

m Double-click the System icon to open the
System Properties control panel as shown in
Figure 5.3.

m On the General tab, note how much RAM is
listed under the processor information. The sys-
tem shown in Figure 5.1 has 512 MB of RAM
installed, while the system in Figure 5.3 has only

192 MB of RAM.

——

Chapter 1  Taking Command of Windows XP

Checking the amount of RAM shown in the System
Properties control panel is important, because in
some cases the amount of RAM listed here isn’t what
you expect. For example, the computer in Figure 5.3
shows only 192 MB of RAM, even though the specs
for this computer listed 256 MB of RAM when I
bought it. The reason for this discrepancy is that the
computer’s built-in display adapter uses 64 MB of the
computer’s RAM. Such sharing of system RAM is
common, and any memory that is used by the com-
puter’s display adapter isn’t available for running
Windows XP or other programs. As far as Windows is
concerned those 64 MB of RAM don’t exist.

System Properties ] %|
Syztem Restore Automatic Updates Femote
General Computer Mame Hardware Advanced

System:

icrozoft Windows 2P
Home Edition

'l 7 Version 2002

!j Service Pack 1
d Feqistered to:
T — laura
Manufactured and supported by: FC
abile Intel[R)

Celeron[R) CPU 2.00GHz

COMPAQ ::-
192 ME of RA

I 0K l[ Cancel ]
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STEP 2: ADJUST VISUAL EFFECTS m Windows XP includes some new visual effects
SETTINGS that make the interface more attractive. These

effects include menus that fade gradually in and
out, drop shadows behind desktop icons, sliding
taskbar buttons, and more. These visual effects are

When you know how much RAM is available on your
computer, youre ready to start taking control of

memory management. _
cool, but they can negatively affect performance.
m In the System Properties control panel, click the This is especially true if your computer has a
Advanced tab to bring it to the front. processor that is slower than 1.0 GHz or less than
m Click the Settings button under Performance. 256MB of RAM. You can control whether or not
The Performance Options dialog box appears as these visual effects are enabled on the Visual
shown in Figure 5.4. Effects tab of the Performance Options dialog
box. It’s usually safe to just let Windows decide
what’s best for your computer, but if you feel that
- = the visual effects are just a pointless waste of sys-
A b i s it a[x] tem RAM and processor power, choose Adjust for
Wisual Effects | advanced best performance.
Select the settings vou want ko use for the appearance and m If you want to activate some visual effects but
performance of Windows on this computer., not others, choose Custom and remove the check
W S s s e marks next to effects that you don’t want to use.
) Adijust For best appearance
() Adijust for best performance
S STEP 3: REVIEW PROCESSOR AND
Animate windows when minimizing and maximizing ~ MEMORY USAGE
Fade or slide menus inko view
Fade or slide ToolTips inta view Click the Advanced tab in the Performance Options
Fade out menu items after clicking dialog box. This Advanced tab contains three cate-
Show shadows under renus R .
Show shadows under mouse pointer gories of options:
Shows translucent: selection rectangle . . . .
Show window contents while dragging m Processor scheduling: This setting determines
Slide open combo boxes whether priority for processor power is given to

Slide taskbar buttons

] Smocth sdqss of streen Forts whatever program you are currently using or

things that are running in the background. If you
have a compiler, printing service, or other memory-
intensive tool running in the background, you may
want to choose Background services to give those
background items priority with the processor.

5.4 Otherwise, keep the default Programs setting.

[ (0] 9 ] [ Cancel
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m Memory usage: If your computer is used pri-

marily as a server, choose System cache. This gives

priority for memory usage to server operations.
Otherwise, if your computer is a workstation or a
stand-alone unit, choose Programs.

m Virtual Memory: Here is where you manage
virtual memory settings. Click Change to open
the Virtual Memory dialog box as shown in

Figure 5.5.
Virtual Memory 2E
Drive [Yolume Label] Paging File Size (ME)
i 296 - 1536
Paging File size For selected drive
Drive: (o5
Space available: 13361 MB
(3' Cuskom size:
Initial size: (MB): 256
Maximurn size (MB): | 1536
C}Syﬂen1managedshe
()Mo paging File Set
Total paging file size For all drives
Timirnurn allowed: ZMB
Recommended: 76 ME
Currently allocated: 334 MB
(0.4 ] [ Cancel
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STEP 4: CHOOSE A LOCATION FOR
VIRTUAL MEMORY

Because virtual memory resides on a hard drive, it
works better if the hard drive is faster. Chances are
your computer only has one hard drive, but if you
have more than one hard drive and you know one of
them is faster — say, one is a 5,400 rpm drive and the
other is a 7,200 rpm drive — you should choose the
faster drive. Check the documentation for your com-
puter or hard drive if you're not sure how fast it is.
Virtual memory also works best on a drive with lots
of free space.

If your computer has more than one hard drive,
each is listed under Drive in the Virtual Memory dia-
log box. Click the drive you want to use to select it.

STEP 5: SET VIRTUAL MEMORY SIZE

When Windows XP is installed it analyzes the
amount of RAM installed on the computer and sets
the size of virtual memory based on what it finds. By
default, the initial size of virtual memory is 1.5 times
the size of RAM, and the maximum size is three times
the size of RAM. For example, if your computer has
192 MB of RAM, the default initial size is:

192 MB X 1.5 = 288 MB
The default maximum size is:
192 MB X 3 = 576 MB

This means that no matter what, 288 MB of hard
drive space is always used for virtual memory, and
the most that will ever be used by virtual memory is
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576 MB. On a computer with only 192 MB of RAM,
these are good settings to stick with. However, the
more RAM that is installed on your computer, the
less virtual memory is needed. Consider the default
initial and maximum virtual memory sizes on a com-
puter with 512 MB of RAM:

512 MB x 1.5 = 768 MB
512 MB X 3 = 1536 MB

On a computer with 512 MB of RAM, 768 MB is
excessive. If your computer has 512 MB or more
RAM installed, you can safely reduce the minimum
virtual memory size to one-half the size of installed
RAM. So on a computer with 512 MB of RAM, 256 MB

— Al

If you upgrade the RAM in your computer,
review the virtual memory settings and adjust
using the guidelines described here. Virtual

memory settings do not automatically update
when RAM is removed from or added to the
computer.

——
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is an acceptable minimum virtual memory size. No
matter how much RAM is installed, it’s safe to keep
the maximum virtual memory size at three times the
size of RAM. It is unlikely that virtual memory will
ever actually consume that much space anyway.

When youre done making changes, click Set to set
your changes. You must restart the computer to put
your changes into effect.

STEP 6: DIVIDE VIRTUAL MEMORY UP
OVER MULTIPLE DRIVES (OPTIONAL)

If you have two or more hard drives, you may specify
space on each drive for virtual memory if you want. If
both drives are equally fast, using both of them for
virtual memory provides the maximum possible
performance.

To add virtual memory to a second hard drive,
choose the drive in the list of drives in the Virtual
Memory dialog box, and specify virtual memory set-
tings as described in step 5. Divide virtual memory
up evenly over each drive. If you have 512 MB of
RAM and you want to divide virtual memory up over
two drives, specify minimum sizes of 128 MB on each
drive and maximums of 768 MB on each drive.
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