Introducing
Director

Ifyou’re a multimedia developer, you've probably been hit
with a request much like the following:

“We’re announcing our new product at a major trade show in
six weeks and we want to have an interactive kiosk for the
booth. We also want to hand out CD-ROMs that highlight the
product’s cool new features. Oh yeah, we also need to have a
Web site that goes along with it, and a version with pricing
information to put on our sales reps’ laptops. Can you get this
done for us?”

Welcome to the fast-paced world of multimedia authoring. The
preceding example may be a little extreme, but if you’ve been in
this industry for any length of time, you've probably had a
client ask you to do something similar. If you're new to multi-
media development, don’t be surprised if a client or your
employer asks you to pull off something along these same lines.

In today’s world, multimedia applications have to work on
multiple computer platforms, and they have to run on differ-
ent media, such as on DVDs, CD-ROMs, or the Web. To be suc-
cessful, you have to create several versions of your multi-
media applications to leverage the features and to adapt to
the drawbacks of each particular playback medium.

Director makes this process easier (and may help you get at
least a couple hours of sleep each night) by enabling you to
create sophisticated multimedia applications in a single
authoring environment and to output separate versions of
your application that are optimized for different computer
platforms and playback media.

Understanding How Director Works

For many years now, Macromedia Director has served as a
catalyst for many people to learn the art of programming. It’s
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a unique product — easy and intuitive enough for many people to create a reason-
ably impressive application the first time they sit down at the computer and use the
program, yet powerful enough to let developers put together sophisticated multi-
media applications with 3D interfaces, database access, and Internet connectivity.
Director is heavily graphics oriented, making it an ideal tool for graphic designers,
animators, and illustrators. But it also includes scripting capabilities that give you
precise control over every aspect of the program. Director is the ultimate left-brain/
right-brain tool.

Director accomplishes all this by borrowing from a metaphor that’s remarkably
well-suited to the creation of multimedia content: the world of film and animation.
When you author multimedia productions in Director —just as when you direct a
film —you integrate the sounds and images, movements across the stage, transi-
tions, pacing, and special effects that make up your movie. In Director, even the ter-
minology resembles the theatrical world. A Director file is called a movie. The
window where the final animation or interactive application is displayed is called
the Stage. The actors in a movie, called sprites in Director, have distinct behaviors
generated by scripts. The various resources used in the program are collectively
known as the cast members. The overall positions and choreography of the sprites
can be viewed and controlled with the Score. Just like traditional cel animation, the
sprites are drawn on the Stage by using various inks. Figure 1-1 shows an example
of a Director movie with the Stage, the Score, and various cast members visible.
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Figure 1-1: Director uses various elements to make up a movie.
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What's New in Director MX 2004

You'll find a number of interesting and useful changes in Director MX 2004. Many of
these changes were designed to make working within Director easier; a number of
other changes make it easier to share content between several different Macromedia
MX 2004 applications. None of the new features change Director so radically that
existing Director users will face a steep learning curve; instead, existing users will
find that Director MX 2004 simply makes life as a Director user more enjoyable.

Table 1-1 outlines the new features in Director MX 2004.

Table 1-1

New Features and Improvements in Director MX 2004

Feature What’s New or Improved

DVD-Video You can now embed, control, and play back DVD-Video content inside
Director movies.

Macromedia You can now integrate Director with Macromedia server technologies,

server technologies  such as Macromedia ColdFusion MX 6.1 and Macromedia Flash

integration Communication Server MX.

Macromedia You can use content from other Macromedia Studio MX 2004

Studio MX 2004 products, such as Macromedia Flash MX 2004 and Macromedia

integration Fireworks MX 2004, in your Director movies. In addition, Director now

Named sprites
and channels

Pre-built
components

Publishing to Mac
and Windows in
one step

Reference panel

Scripting in
JavaScript syntax

Workspace
customization

shares a similar interface with those products.

Sprites and channels can now have custom names, and absolute
references to sprites are no longer necessary. This feature means that
you can move sprites on the Score without worrying about broken
scripts.

You can now use pre-built Macromedia Flash MX 2004 components in
your Director movies. You can drop components, such as calendars
and user-interface elements, into movies to cut the time that it takes
to develop interactive features.

After you complete a movie, you can now publish across platforms in
one step, creating either stand-alone applications (projectors) or
Web-based Shockwave content that runs on both Mac and Windows.

A new reference help panel is now available in Director to simplify
getting help with using Director, behaviors, Xtra extensions, and
application programming interfaces (APIs) for both Lingo and
JavaScript syntax.

Director now supports scripting in JavaScript syntax, in addition to
Lingo.

You can arrange your workspace in multiple configurations and save
each workspace for later use.

5
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Note

Most older Director movies will continue to work in Director MX 2004, although

~~  they must first be opened and then saved in Director MX 2004 format if you want

to take advantage of some of the new features such as JavaScript syntax. In a few
cases, you may find that really old Director movies (such as those created prior to
Director 5) cannot be opened by Director MX 2004, but anything that old is prob-
ably due for replacement anyway.

Getting to Know the Director Interface

Tip

Doing a production, whether theatrical or multimedia, demands that you become
familiar with its framework. A traditional theater is more than just a stage. A good
director needs to understand the theater’s acoustics and lighting, what kind of back-
stage facilities are available, how many people can be seated, what the view looks
like from every seat, and even details such as how the curtains will open and close.

Multimedia is much the same: Your theater, in this case, is Director, and its support-
ing structures are the dialog boxes, panels, menu items, and other elements that
make up the program itself. You need to get to know Director before you start build-
ing your own world with it.

Director is a fairly complex program. Although using any of its features is not diffi-
cult, there are plenty of features to use. Indeed, most of the first part of this book
focuses on the various dialog boxes and panels that Director uses. This complexity
is the result of Director’s role as an infegrating program. Its primary purpose is to
bring a number of different kinds of elements together into one package. Each ele-
ment has its own particular characteristics that require special handling.

When Director is first launched, it remembers the last panels that were open in the

_», preceding session. If you want to return to the original set that appeared when

4 you first opened Director, choose Window => Panel Sets => Default.

The Score panel

The Score panel (often referred to simply as the Score), shown in Figure 1-2, is analo-
gous to an animator’s score sheet —it displays, from left to right, the time in the
movie as measured in frames. Frames can best be described as the individual views
of the movie as it changes over time. They are roughly similar to the frames of a film-
strip, where one frame may differ just slightly from the preceding frame (this can be
somewhat deceptive due to the introduction of interactivity into the movie).
Typically, a movie has 15 to 30 frames per second, although this rate —known as the
tempo— can vary dramatically, from 1 frame per second to 999 frames per second.



Tip

Chapter 1 4 Introducing Director

¥ landen6 Score —
B T begniames T erd lhmes 1

L [b e

1 gl ——————————C Sl Legs ol — 30 EhipLegs o 2 EhipL

_I;#I‘I | *Iﬂ

ik Cetinleine

Figure 1-2: The Score is Director’s cockpit, showing where all
the sprites are at a given time and providing detailed information
about their current state.

The Score is divided into up into 1,000 sprite channels. The 1,000 numbered chan-
nels are for graphic and text sprites; they show the position of each element and
their relationships to one another on the Stage at each frame of the movie. Five
other channels control the tempo, palette, sound, and transition, as well as instruc-
tions that control the sprites (called a scripf), which are applied to that particular
frame of the movie. Think of a sprite as a cast member that has been brought on
the Stage to perform a specific task; each sprite occupies a sprite channel. A sprite
channel is very similar to the cels used in traditional animation. You can stack up
many layers of cels on the Stage to create a multilayered animation: the sky, distant
mountains, a house, a character in front of the house, and so on. Each of these ele-
ments can be moved or switched to a different graphic, but they roughly corre-
spond to discrete sets of objects.

Sprites are drawn in the order in which they appear in the Score. A sprite in sprite
channel 1 (let’s call it the sky sprite) will appear behind the far mountains in sprite
channel 2, which will appear behind the near mountains in sprite channel 3, and so
forth.

You can change the order in which the sprites are drawn on the Stage by using
4 Director’s scripting language. This technique is covered in Chapter 16.

s

Sprites make up a significant part of Director’s mechanics and are discussed in
detail in Chapter 3.

The Cast panel

The Cast panel, shown in Figure 1-3, contains the actual graphics and text that are
used by each of the sprites, as well as sounds, digital video, transitions, scripts, and
any other resources that are used by Director. Each resource is known as a cast
member.

7
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Figure 1-3: The Cast panel contains the various elements that
you use to make up your movie.

By default, the Cast panel automatically docks at the bottom edge of the Score
. panel. Drag the Gripper (the two columns of dots at the left edge of each panel’s
4 title bar) to dock or undock panels.

One way to think of the distinction between the cast members and sprites is to
return to the theatrical metaphor. To put on a theatrical presentation, you need to
have actors to play the roles of the characters, technicians to control the lighting,
sound, and special effects to enhance the production. The sprite is the role or func-
tion that the actor or backstage technician will perform. The cast members are the
actors and technicians that will perform the tasks needed to put on the production.
In technical terms, a sprite is an instance of a cast member.

The Cast and cast members are discussed in greater detail in Chapter 2.

The other panels

Director includes many other panels that you use as you create and edit your
movies. For example, Director includes a bitmap graphics editor called the Paint
panel. It has been optimized for creating animation, but it’s not as powerful for cre-
ating realistic graphics as other image-editing programs such as Macromedia
Fireworks. Another editor, the Vector Shape panel, enables you to create Bézier-
based vector graphics. These graphic editors get a thorough examination in
Chapter 2.

Macromedia is somewhat inconsistent in its naming scheme. You may see the

-~ terms panel, palette, or even window used to describe the various windows that
you use in Director. Don't allow this to confuse you. All these objects function sim-
ilarly no matter what they're called.
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Because text is so important in multimedia, Director can actually edit text in two
different ways, as well as use externally generated text. The two text editors are
discussed in Chapter 4.

Finally, Director supports external editors for most types of media— graphics
(Chapter 2), sound (Chapter 5), and video (Chapter 6).

Figure 1-4 shows the Window menu in Director MX 2004. You use this menu to open
the various panels that you use.

New Window:

Toolbar Ctrl+Shift+Alt+B
Tool Palette Ctrl+7
Property Inspector  Ctrl+Alt+S
Script Ctrl+0
Stage Ctrl+1
Control Panel Ctrl+2

Cast Ctrl+3
Score Ctri+4
Message Ctrl+M
Paint Ctrl+5
Vector Shape Ctrl+Shift+\
Text Ctrl+6

Field Cirl+8
QuickTime Ctrl+3
Shockwave 3D Ctrl+Shift+\y
DVD Ctrl+Shift+E
RealMedia Ctrl+Shift+Y
Windows Media Ctrl+ShifteZ
AVl Video

Object Inspector Ctrl+Shift+
Library Palette

Behavior Inspector  Ctrl+Alts;
Text Inspector Ctrl+T
Memory Inspector

Align... Ctri+K
Color Palettes Ctrl+Alts7
Markers Ctrl+Shift+M
Panel Sets

Show Panels F4

Figure 1-4: The Director Window menu provides
quick access to all the panels.

The toolbar and ToolTips

One of the more useful Director tools is the toolbar, shown in Figure 1-5, which pre-
sents icon shortcuts to common functions and operations. Table 1-2 gives a quick
summary of the icon shortcuts in the Director toolbar (as they appear from left to

right).
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Figure 1-5: The Director toolbar provides one-click access to many
commonly used commands.

Table 1-2
Director MX 2004 Toolbar

Icon Tool Function

5] New Movie Opens a new movie.

5] New Cast Opens a new cast library.

Open Opens an existing movie or cast library.

=] Import Imports media.
Save Saves the movie or cast library.

E-I Save All Saves the movie and all the Cast windows.

Publish Saves the current movie as a Shockwave Movie and

creates the HTML page.

Undo Undoes the last action.

5

Cut Cuts the selected object and places it on the Clipboard.

e
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Icon Tool Function
E.--i.I Copy Copies the selected object and places it on the Clipboard.
- Paste Pastes the object on the Clipboard into the selected space.
;E:i Find Cast Lets you locate a specific cast member quickly.
Member
m Exchange Swaps the cast member on the Stage for the selected one.
Cast Members
4 Rewind Moves to the first frame of the movie.
- Stop Stops the movie if it is currently playing.
N Play Plays the movie if it is currently stopped.
-J Stage Opens the Stage.
Cast Window Opens the Cast window.

&

[

~| E| [&

=

3 >

Score Window

Property
Inspector

Library Palette

Paint Window

Vector Shape
Window

Text Window

Shockwave
3D Window

Behavior
Inspector

Script Window

Message
Window

Opens the Score window.

Opens the Property Inspector window.

Opens the Library palette.

Opens the Paint window.

Opens the Vector Shape window.

Opens the Text window.

Opens the Shockwave 3D window.

Opens the Behavior Inspector.

Opens the currently selected script, or opens a new script if

one isn't selected.

Opens the Message window.

11
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Tip

Don’t worry, you don't have to memorize all these toolbar icons right away.
», Director makes use of another Windows convention: ToolTips. When you place

4  your mouse pointer over an icon, button, or similar interface element for more

than half a second, Director displays a small text box that contains a one- or two-
word description of the item.

The Tool palette

Many of the tools you are likely to use the most are assembled in a conveniently
arranged package known as the Tool palette (see Figure 1-6). Use these tools to
quickly add text, buttons, fields, lines, basic (vector) shapes, and pattern fills, and
to change the foreground and background colors. You can also rotate and skew
text, as well as rotate and skew vector shapes. Turn the Tool palette on and off by
choosing Window = Tool Palette.

| Tools
Tool Palette Selector —default _
Arrow —+k 91— Rotate

Hand 7 G Magnifying Glass

Text ——A ~/—— Line
Filled Rectangle a O Rectangle
Filled Round Rectangle 2 O Round Rectangle

Filled Ellipse ——® ©—— Ellipse
Check Box —1 [#lH+— Radio Button
Field —=1 ——+— Button

Foreground/Background ___
Color Selector _!J_-l

Pattern — IR

Line Weight Selector —+

Figure 1-6: The floating Tool palette gives quick
access to a handy collection of often-used tools.

See Table 1-3 for a summary of functions available in the Tool palette.



Chapter 1 4 Introducing Director

Table 1-3

Floating Tool Palette Functions

Icon

Tool

Function

ol 8 N > & & @ =

ol O

Ol [©

E] & [E

Tool Palette Selector

Arrow

Rotate

Hand

Magnifying Glass

Text

Line

Filled Rectangle

Rectangle

Filled Round
Rectangle

Round Rectangle

Filled Ellipse

Ellipse

Check Box

Radio Button

Field

Enables the selection of different Tool palettes.

Enables the selection of objects (active by default
when the Tool palette is opened).

Rotates and skews text and vector graphics.
Moves the Canvas left, right, up, and down.
Zooms the Stage in and out.

Inserts text directly on the Stage.

Draws straight lines directly on the Stage.

Draws a rectangle filled with the selected
foreground color.

Draws an empty (unfilled) rectangle on the Stage.
(The border color is the foreground color selected
in the Tool palette.)

Draws a rectangle with rounded corners, filled
with the selected foreground color.

Draws an empty (unfilled) rectangle with
rounded corners. (The border of the rounded
rectangle is the selected foreground color.)

Draws circles and elliptical shapes, filled with the
selected foreground color, on the Stage.

Draws empty circles and elliptical shapes. (The
border of the ellipse is the selected foreground
color.)

Adds a check-box-style button.

Creates a radio button.

Creates editable text fields on the Stage.

Continued

15
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Table 1-3 (continued)

Icon Tool Function

= Push Button Creates a customizable push-style button on the
Stage. (The size of the button is dependent on
the amount and size of the text entered in the
button.)

] Foreground/ Allows selection of the foreground and

il Background background colors. (The foreground is the top-left

Color Selector

IEI Pattern

(= Line Weight Selector

color chip; the background is the bottom-right
color chip. Clicking either color chip opens the
Color palette of color choices.)

Selects the pattern fill to be used with the Tool
palette’s filled shapes. (Foreground and
background colors of the pattern are selected in
the Foreground/Background Color Selector.)

Selects the line weight to be used by the Tool
palette’s various drawing tools. (Choose from No
Line, One Pixel Line, Two Pixel Line, and Three
Pixel Line.)

The Library palette

The Library palette, shown in Figure 1-7, contains behaviors and other useful
objects that are stored independently of the movie. In this case we have opened the
Library palette window to show the broad selection of object types you can find in
the Library palette. When an object or behavior from the Library palette is used in
a Director movie, it becomes a new cast member in that movie, which then can be
edited without affecting the original object contained in the Library palette. Display
the Library palette by choosing Window => Library Palette.

The Library palette is basically just a collection of Cast windows, so you can add
anything to the Library palette that can be contained in a Cast window. This can be

4 very useful for any commonly used artwork, as well as for behaviors that you don't

want to be edited accidentally. To add your own elements to the Library palette,
create a new, unlinked Cast window that contains behaviors and graphics, save it,
and then drag the Cast file into the folder called LIBS, which is found in the

Director application folder.

The Library palette is discussed in detail in Chapters 7 and 8.
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Figure 1-7: The Library palette contains Director’s
powerful built-in behaviors and other objects
you can use in your movies.

Inspectors

You use inspectors to view and modify the attributes of text cast members, sprites,
and behaviors (scripts). For example, Figure 1-8 shows the Property Inspector.
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Figure 1-8: Director MX 2004’s Property Inspector gives you
almost infinite control over the individual elements
contained in your movies.
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There are four types of inspectors in Director; each performs a specific task:

4+ Property Inspector: Use the Property Inspector to display the current proper-
ties of any selected element, including the Stage, as well as the active movie.
You can adjust any available properties of nearly every element in your movie
by using this window.

4+ Behavior Inspector: Use the Behavior Inspector to create new behaviors
(scripts) and modify existing ones.

4+ Text Inspector: Use the Text Inspector to format text and add hypertext links.

4 Memory Inspector: The Memory Inspector displays the amount of memory
(RAM) that is being used by the Director application and the elements con-
tained in the movie.

The various aspects of each Inspector are discussed in later chapters that relate to
their functions.

Pop-up menus

Another trick in the Director MX 2004-interface arsenal is the deployment of those
handy context-sensitive pop-up menus (see Figure 1-9). You can activate pop-up
menus for most elements in Director, including cast members, sprites, behaviors,
scripts, and even the toolbar. A pop-up menu contains operations that are only
appropriate for the selected item. The contents of contextual menus vary from item
to item. They are intended to provide a list of operations or commands that you
can perform on that item, in the current context of the software.

View »] Figure 1-9: Right-click with the mouse on an element to

Cut Cast Members activate a pop-up menu that contains operations appropriate
(Corgy e e for the selected item.

Paste Text

Edit Cast Member

Launch External Editor
Find in Score
Find Cast Member...

Cast Member Properties...
Cast Member Script...

Cast Properties...
Cast Preferences...

Tip On a Macintosh mouse that lacks the essential right mouse button, you bring pop-
»,up contextual menus to life by holding down the Ctrl key and clicking the mouse
4 button over an interface element or object.
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The menu bar

Director uses a fairly complicated set of menus, submenus, and related dialog
boxes, in an arrangement that is consistent with Macromedia’s user-interface guide-
lines across its product line. The idea, of course, is that someone familiar with
other Macromedia products, such as Fireworks or Flash, can adapt to Director fairly

quickly.

This book discusses menus and their content as they become relevant. Table 1-4
summarizes the content of each menu in the menu bar.

Table 1-4
The Director Menus

Menu Name

Functions Handled

File

Edit

View

Insert

Modify

Control

Xtras

Window

Help

Opening, saving, and printing of files. Creating projectors (run-time
versions of your movies), Shockwave movies, and Java applets. Setting
preferences, previewing in a browser, and terminating the program.

Clipboard operations (cut, copy, paste) and various kinds of selection.
Searching and replacing text. Launching external resource editors.

Offers various ways of looking at the Score (the window that controls
where animation sprites are placed). Also controls onion-skinning in the
Paint window.

Insertion and deletion of keyframes and animation frames into the Score.
Serves as an alternate way of inserting media cast members into the Cast
window (the library of resources that Director uses).

Changing properties for the movie, individual cast members (resources),
sprites, and the Score. Also provides a means of editing text in a text field,
modifying scripts (interpreted code that is attached to sprites or other
interface elements and that executes when designated events occur),
rearranging the order of cast members on the Stage, and converting cast
members to different bit depths.

Playback of Director, moving from frame to frame, setting volume, handling
sprite recording, debugging features, and recompiling scripts.

Gives information and access to Xtras (Director plug-ins) and graphic filter
Xtras. Protecting and updating older versions of Director movies, and
importing PowerPoint files.

Calls up any of the control windows used in Director, such as the Score,
the Cast window, the Bitmap editor, the Library palette, Text Inspectors,
and others.

Accesses Director Help, which provides a detailed help and indexing system
for all sorts of Director and scripting problems. Also calls up Help tutorials.
Accesses registration information and links to Macromedia’s Web site.

17
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Docking options

With the great abundance of panels you find in Director MX 2004, it becomes very
important to have a means of organizing those panels so that you can work more
efficiently. One method of accomplishing this goal is to use the docking options that
are available. For example, earlier you learned that the Score and Cast panels are
automatically docked in the default panel layout. Because you often use these two
panels in association with each other, this docking arrangement is very convenient.

The Director panels fall into two general groups: document windows and tool win-
dows. You can dock together panels that are of the same type, but you cannot dock
ones that are not of the same type. So, for example, you can dock the Cast and the
Stage or the Behavior Inspector and the Property Inspector, but you cannot dock the
Stage and the Property Inspector together. You can also dock Movie in a Window
(MIAW) in Director MX 2004. See Chapter 24 for more information on MIAWSs.

You can save your favorite panel layouts by choosing Window > Panel Sets > Save
Panel Layout.

e

Each Director panel also has an expander arrow just to the left of the panel’s name
in the title bar. You can click the expander arrow to expand or collapse the panel as
needed. When the panel is expanded, the expander arrow points downward. When
the panel is collapsed, the expander arrow points to the right.

Using External Resources

For a multimedia program to be truly useful, it has to have some way of adding func-
tionality whenever new technology comes on the scene. With Director 5, Macromedia
realized this necessity, abandoning the rather haphazard Xobjects, which relied prin-
cipally upon a ten-year-old Macintosh programming specification that was almost uni-
versally ignored. Instead, some serious work was invested in developing an open
architecture. This architecture enabled developers to create new support programs
called Xtras, which added significantly to Director’s capabilities.

Xtras are analogous to plug-ins for browsers and for programs such as Adobe
Photoshop. Some Xtras — such as the filelO Xtra, which adds file reading and writ-
ing capabilities —are produced by Macromedia itself. Third-party software design-
ers produce others. Some of these are for adding functionality to Director, while
others are designed to open up access to system capabilities.

You access cast members that are created by Xtras, such as fonts and animated
GIFs, by choosing Insert => Media Element. These cast members are then imported
into the Cast window and are nearly identical to other cast members. You can set
their properties with standard dialog boxes, and open external media editors for
editing.
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Adding Xtras to your system

The same folder that holds your Director program contains a folder, or directory,
called Xtras. This folder is the repository for every Xtra in use by the program. If
you want to add a new Xtra (or remove a troublesome one), then you simply need
to add (or remove) the file that contains the Xtra. When Director starts up, it inven-
tories every Xtra it finds in the Xtras folder or in subfolders of that folder; and if
Director can use the Xtra, it registers the Xtra internally.

Director MX 2004 includes an option that enables end users to download Xtras
used in the movie that are not installed on their system via the Internet from a
secure server. This capability enables movies to be smaller by allowing Xtras to be
downloaded independently of the movie.

Using Xtras

When you create your own applications, you must distribute these Xtras as well.
As long as the Xtras folder is in the same directory as the application, all the Xtras
contained within it will be added.

How you invoke an Xtra depends on its type. For example, you access a Photoshop
filter by choosing Xtras = Filter Bitmap, which then lists all the available filters cur-
rently in the Xtras folder. Many other Xtras are added using the Scripting Xtras but-
ton in the Script panel. Xtras are covered in several chapters throughout this book
where they’re relevant.

Working with Cast Libraries

A Director movie can have, practically speaking, any number of cast libraries open
at any given time, making it possible to have one library that exclusively contains
common bitmaps (such as navigational elements); a second library that contains
nothing but behaviors and utility code; a third library that has only sounds; and so
on. Keep in mind that there’s nothing stopping you from mixing these resources
together.

You can link cast libraries to a movie by choosing Modify => Movie => Casts. Having
a linked file of any sort means that the information about that file is kept in a sepa-
rate file rather than within the Director movie itself. For example, if you linked a
bitmap image, every time Director started up it would load that image from the
disk, rather than from its own internal resources. This approach has the advantage
of making it easier to work with dynamic files, or pictures that change on a regular
basis. The disadvantage comes from the location of the file; the picture (or other
resource) isn’t already contained in the movie, so it has to be processed into a
Director cast member. Depending on the size and type of the image, this process
can involve an appreciable wait.
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¢ Cross- For more details on bitmap images, cast libraries, and resource linking, see
il Reference \,  chapters 2, 3, and 6, respectively.

Understanding Director’s Help System

A program as complex and feature-rich as Director cannot be learned in a day.
There are hundreds of commands, properties, keywords, and related terms used
just by Director’s scripting languages Lingo and JavaScript syntax, not to mention
the dozens of menu commands, dialog boxes, and other related bits of the Director
interface. With its new behaviors and other improvements, Director is now easier to
use than ever before —but that doesn’t mean that it won’t seem overwhelming to
even seasoned users.

Fortunately, the designers of Director have provided assistance with the program’s
complexity in the form of a remarkably comprehensive help system. This system
can aid everyone from beginners to advanced professionals.

You access the help system by choosing Help = Director Help or by pressing the F1
key. From here, you can go get help on most basic concepts in Director, including
Lingo scripting and incorporating Director movies into Web pages.

Getting a second opinion (or third or fourth)

Macromedia’s Web site is fairly comprehensive, but it's only a small part of the total collec-
tion of Web sites, mailing lists, newsgroups, and newsletters available to the Director devel-
oper. Many of these sites include downloadable Xtras, tips and techniques, and working
examples. Of equal importance, these Internet resources also facilitate your connections
with other Director users, an especially welcome capability when you're in the middle of a
project and discover that you don’t know how to get past a thorny problem.

The programming faculty at Maricopa Community College in Arizona maintains one of the
most exhaustive sites devoted to Director and Authorware, at www.mcli.dist.mari
copa.edu/director. The college also maintains the Direct-L mailing list, which is an
ongoing e-mail list where developers talk over problems and quirky happenings and dis-
cuss getting together at conferences and conventions. Check the Web site itself for details if
you want to subscribe. We recommend getting the Digest, but bear in mind that the list is
very busy and can easily generate a thousand messages in a few days.

The Director Online Users Group (DOUG) at www.director-online.com, produced by
Patrick McClellen and Zac Beldo, is a very comprehensive Web site for all things Director.
This site is full of tips and tricks, utilities, and shareware, as well as links to make searching
other Director resources a lot easier.

Developer Dispatch has an extensive site with news, forums, and resources for both
Director and Flash developers. You can find this site at http://developerdispatch.com.
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Tip You can find online help with Director by choosing Help => Director Support Center.
., This will open the Director Support Center Web site in your browser so that you
4 can find technical notes, examples, and tutorials.

Summary

Director is the most comprehensive multimedia authoring tool on the market today.
It enables you to create sophisticated multimedia applications for virtually every
medium that exists to deliver interactive content. You use Director to create and
combine all the elements commonly used in multimedia applications — text, graph-
ics, animation, sound, and video — and then add interactivity and multiuser func-
tionality with its powerful scripting languages (Lingo and JavaScript syntax).

Before moving on to Chapter 2, review some of the things that were covered in this
chapter:

4+ Director uses a theatrical metaphor for its interface. A Director file is called
a movie, the window that the movie plays in is called the Stage, resources
used in a movie are called cast members, sprites on the Stage are choreo-
graphed using the Score, and commands that tell the sprites what to do are
called scripts.

4+ Nearly every function in Director has a floating window associated with it.
This includes bitmap editing (the Paint panel), Bézier vector graphics (the
Vector Shape panel), text creation (the Text panel and the Field panel), shapes
(the Tool Palette), sprites (the Score), and navigation (the Control Panel).

4 Director is truly a right-brain/left-brain application. It combines a graphical
interface that is understandable to graphic artists and animators with a pow-
erful scripting language that enables programmers to create incredibly com-
plex applications.

4+ Xtras are individual components (like plug-ins) that add extra functionality
to the program. They are created by Macromedia and third-party developers.

4+ Director has a context-sensitive help system as well as a comprehensive
Web site that make it easier to learn how to use the program and to keep
current with the most recent features. ToolTips is another feature that
makes Director more understandable by giving a brief description of an item
while the mouse cursor pauses over it.

Chapter 2 discusses working with graphics in Director.

¢+ o+
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