SWiSHmax
QuickStart

What if you want to have an animated logo to add some punch
to your Web site? Or show your customers your products in
an interactive and attractive way? Or create a photo gallery showing
your vacation pictures? Or build a way for your customers to talk to
you directly online?

You can use one program to build all of these objects and many
more. For everyone from beginners to seasoned Web design veterans,
SWiSHmax has something to offer. With SWiSHmax, your imagination,
and some know-how, you can create a wide range of material to use
on your Web site— or even create an entire Web site. You can also
create material to use in a range of other programs from
Dreamweaver to PowerPoint.

Creating simple animations is one of SWiSHmax’s strong features,

yet it is only the tip of the SWiSHmax iceberg. Throughout this book,
you learn much more about working with different types of files and
effects, using actions to control a movie, and working with SWiSHmax
output in other programs.

First, | am going to take you on a quick stroll through the different
aspects of the program so you can gain an understanding of what can
be accomplished with this remarkable piece of software.

What Does SWiSHmax Do?

Anyone who has spent any time on the Internet has seen Flash movies
of varying degrees of complexity, interactivity, and skill. Historically,
the movies you saw online were built using Macromedia Flash. In
recent years, a number of other products have been developed that
can produce much of the same output or subsets of the output as the
Flash program does. Most notably among these other programs is
SWiSHmax.

SWiSHmax is a Flash creation tool that can be used for a range of pro-
jects from animation to interactive Flash presentations and Web site
interfaces. The program allows you to control both the appearance
of objects in a movie as well as the timing of objects. Movies are con-
trolled in one of three ways:
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4+ The content of a movie changes based on time. You work with the SWiSHmax Timeline
to control the appearance and location of objects.

4+ The content of a movie changes based on user interaction. You add controls that initi-
ate reactions to user actions such as clicking a button or moving the mouse cursor.

4+ The content of a movie changes based both on time and action. A user’s interaction
with an object, such as clicking a button or typing text, can cause an event to happen
over time such as running another movie.

A SWiSHmax movie is made up of one or more scenes. Each scene has a separate Timeline
sequence. The project you create in this QuickStart chapter uses one scene.

The scene or scenes in a SWiSHmax movie hold a number of components, including:

4+ Objects. SWiSHmax differentiates objects on the basis of their complexity. Simple
shapes, such as a square or circle, are a single indivisible shape; complex shapes, are
collections of shapes or text. There are also other types of objects such as sprites,
which are collections of objects and effects, and instances, which are copies of sprites.
These are covered in detail in Chapters 15 and 16.

4+ Effects. Effects are animations that change the appearance of an object over time.
Detailed explanations can be found in Chapters 12 through 14.

4+ Events. These are actions that occur when a movie reaches a specific frame on the
Timeline or as a result of a mouse or keyboard action. You learn more about events
in Chapter 18.

4+ Actions. Actions are operations that are triggered by events. There is a wide range
of actions with which you can work, ranging from movie controls to sounds to mouse
actions, all of which are covered in Chapter 19.

This chapter describes the basic workflow you use to create a SWiSHmax movie. In this chapter,
you get a head start on your adventures with SWiSHmax by completing a simple QuickStart
project. At the end of the project, not only do you have a sense of how the program works,
but you also have a logo in SWF (Shockwave Flash) format that you can use on a Web site.

'Note SWF is a standard file format used for exporting your SWiSHmax movies.
ji

You'll learn how to start a project and how to add or create elements of your logo, including
graphics, text, sound, and images. When you have assembled the parts, you add some anima-
tion. Finally, you’ll export the logo both as a SWF file and a Web page.

The processes used in creating the movie are broken down into a series of discussions and
steps. The steps contain both generic instructions if you are following along with your own
files, as well as instructions for using the files available from the book’s Web site.

Working with an Animation Program

As you see shortly when you get into SWiSHmazx, there are two major components of the
program — the Timeline and the Layout panel, shown in Figure 1-1.
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Figure 1-1: Your movie takes place in both the Timeline and the Layout panels.

In the Layout panel, you construct, assemble, and draw the elements that go into your
SWiSHmax creation. The Timeline is used to determine WHEN you see your graphics or text.
Not only must you draw or compose something to use in your project, but you must also
define when the objects are seen.

In addition to assembling visual components like images, text, and sound, such as a back-
ground score, you also work extensively with different actions. Actions are assigned and
controlled in the Timeline as well and are based on time.

Your First SWiSHmax Movie

The next sections take you through building a simple SWF (Shockwave Flash) movie in
SWiSHmax. As you work through the steps, you learn how to add different types of elements
to your project over time, how to draw a simple shape and add text, and then how to animate
the components of your movie. Finally, you learn how to save both the SWF movie and a Web
page used for displaying the movie.

SWF (Shockwave Flash) is the standard export format for SWiSHmax movies. You learn about
exporting and export file formats in Chapter 21.

r Cross-
Reference
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You can use the files provided for the sample project or work with your own files. The sample
project builds a simple animated logo complete with music for your company, Up and Away
Travel. Figure 1-2 shows several frames of the animation. The material required to create the
logo is available from the book’s Web site in the folder named chapter01. The logo starts with
an airplane moving across the screen. As it moves, a map of the world slowly appears, and
then starts to fade as the airplane moves out of the screen. The company name and a back-
ground rectangle slowly appear and overlay the fading map.

Up and Away
Travel

Figure 1-2: The sample project’s logo changes over time.
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Starting a SWiSHmax project

A SWiSHmax project contains all the objects used in the final movie, as well as actions,
scripts, effects, and other elements that together make up what you see in the final product.
To start, you create a new project using one of the SWiSHmax templates, define how it is
going to look, and set the speed at which the movie plays. To create a new project, follow
these steps:

"Note

On The Web
Site

1. Open SWiSHmax. Double-click the program icon in the Programs listing; the program

opens, and you are given a set of options for starting. You can choose from:
e Start a new empty movie
e Start a new movie from a template
* Work on an existing movie

* Reopen the last movie you worked on

. Choose a start option. To work with the project files, choose the option Start a new

movie from a template. The list of templates opens.

. Choose a template and click Open. For the project, choose Large Rectangle (336 x 280)

.swi and click Open. The dialog box closes, and you are in the program. You see a large
white rectangle (the stage) on the Layout panel’s workspace. The rectangle is the view-
able area of your movie. If you look at the Layout panel tab, the first horizontal row in
the Timeline, and the first heading in the Outline panel, you can see all three areas now
have a listing called Scene_1.

When SWiSHmax is installed on your computer a set of templates for common forms of
movies is installed automatically.

. Save the movie. Click File = Save to open the Save dialog box and name your movie. If

you have been following along with the sample project, type logo in the Save dialog box.

By default, the program saves your movies in a numbered sequence; you see the file is
named moviel.swi if you don't choose a name for it.

. Click the Save in dropdown arrow at the top of the dialog box and browse to the

location where you want to store your project files. Select your storage folder, and
click Save. The dialog box closes and you return to the program. The movie name
appears at the top of the program window.

A copy of the finished SWiSHmax file in this example is available from the book’s Web site. It
is in the chapter01 folder and named logo.swi.

To the right of the Layer panel, the Movie tab is displayed when you start a new project. You
can change the movie’s properties, such as its background color and frame rate, in the Movie
panel. To change a movie’s properties, follow these steps:

1. Change the Background Color on the Movie panel (Figure 1-3). Click the Background

Color swatch (it appears in white initially) to open the Color Selector.
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Select an alternate color for the background. To create the sample project, click the
dark blue color that is fifth from the top of the second row. The Color Selector closes,
and the Background Color swatch appears with the blue color you selected.

Basic primary colors are shown in the left-most column of the Color Selector; the blue color
you use is to the right of the bright yellow sample.

. Change the frame rate of the movie. Try clicking the 30 frames/sec field on the

Movie panel to activate the text. Type 10 to change the frame rate to 10 fps (frames
per second).

. Choose File > Save and save the file with the modified settings.

It is a good habit to save every few minutes and after you have spent some time configuring
settings.

Importing elements

There are a variety of program formats you can use in your projects. Table 1-1 lists the file
formats that SWiSHmax supports.

Table 1-1: File Formats Supported by SWiSHmax

Media File Formats

Text Plain text

Raster Images Windows bitmaps, GIF, JPEG, and PNG images

Vector Graphics Windows Metafile, Enhanced Metafile, Flash Graphics
Animation Animated GIF, Flash Animation, Flash Projector, SWiSH movie
Sound Wave and MP3 formats

-
€ Cross-
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You can learn about importing images in Chapter 8 and about importing and working with
sound in Chapter 11.
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The sample project has four visual elements and one sound used as a soundtrack. Two of the
objects are imported images, one is a shape you draw in the program, and the fourth is text
you add in SWiSHmax.

You can work with your own images and sound file if you prefer. You need one full-size
il image in any allowed format for the background, one GIF or PNG image with a transparent
background to apply motion effects to, and some music you can use as a soundtrack.

The steps include general instructions, as well as how to use the images and sound files from
the book’s Web site. The three files are in the Chapter01 folder. To import the files you need
for the project, follow these steps:

1. Choose File &> Import, and browse to the location of the folder where you are storing
the artwork for your SWiSHmax projects.

2. Press the Ctrl key, and select the files you want to use. If you are working with
the sample project files, click the two image files and the sound file to select them:
airplane.png, map.jpg, and score.wav.

3. Click Open. The dialog box closes, and the files are imported into the program. When a
sound file is imported, the program asks if you want to use the sound as a soundtrack.
Click Yes. The clips are added to the project.

When you add a graphic object, it is placed at the center of the movie automatically.

Take a look around the program and see what is happening before starting the drawing and
animating processes.

First, view the list in the Outline panel displayed by default to the left of the Layout panel.

In the listing you see the two images you imported as well as the soundtrack music file. Each
file is listed under the Scene_1 heading and has an eye icon indicating the layer is visible

(or audible in the case of the sound file). Each file also has an icon identifying the layer as a
graphic or music file. When you look at the list displayed in the Timeline, you see the files
listed in the same order.

The music file can be placed anywhere in the sequence, but you must use a particular order
for both the imported images and the layers you create. If you are working with your own
files, the GIF image with the transparent background must be placed higher in the list than
the solid image used for the background.

The higher the element appears in the list, the higher it is in the stacking order. For example,
if the airplane image is above the map image in the list, then it appears on top of the map; if
the map image is above the airplane in the list, then you wouldn’t be able to see the airplane
because the map covers it. Check your list, and make sure the order is correct. If it isn’t, click
one of the file names in either the Outline list or the Timeline list and drag it up or down.

When you move an image in one area (Outline panel or Timeline) it is also moved in the
=~  other area.
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Tip You can select the elements for your movie in the Open dialog box in the order you want
b Y them to appear in the scene, or simply select them sequentially and then shuffle the order in
~# the Outline panel.

Look at the music file you imported. The sample project’s music file is named score.wav. As
mentioned earlier, the order in the layer listing of files isn’t important. The score.wav row
stretches from 1 to 49 frames on the Timeline, as shown in Figure 1-4. A pale blue rectangle
with the label Play (49) fills the music’s row, meaning the music will play for 49 of the 50 frames
of your logo. To listen to the soundtrack, follow these steps:
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Figure 1-4: The sound file displays on the Timeline for the length
of the movie.

1. Click the music file’s name in either the Outline panel or the Timeline to select it.
The Sound panel at the right of the screen is active, as shown in Figure 1-5. The music
file’s name is shown in the dialog box.

2. Click Properties on the Sound panel (next to the music file’s label). The Properties
for Sound dialog box opens, also shown in Figure 1-5. The dialog box also includes the
name of your music file in quotations; the sample project’s file is named “score.wav.”

3. Click Play. When you finish listening to the music, click Stop.

4. Click OK to close the Properties for Sound dialog box.
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Figure 1-5: You can listen to the movie's soundtrack music.
Caution When you add files to a project an .sbk file is added to the project’s storage folder. Don't

delete this file —it is a backup for your movie.
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Creating objects

The SWiSHmax Toolbox contains a number of drawing tools that you can use to create graph-
ical elements for your movie. You can draw a variety of shapes by hand or use preconfigured
AutoShapes, explained later in this section.

Reference Chapter 7 to learn how to work with color.

risi/ﬂx See Chapter 5 to learn more about drawing, Chapter 6 to learn how to modify drawings, and

Tip You can hide and/or lock layers in the Layout window to make it easier to work. Select a layer,
h and click the eye icon to the left of the label’s name in the Outline panel to change the visi-
“ 4 bility status. Click once to display an x drawn through the eye icon, indicating the associated
layer is hidden. Click the eye icon twice and the associated layer is locked, indicated by a

gold lock to the left of the object’s label in the Outline panel.

"‘\Iote You leave the background layer locked for the remainder of the movie construction process.
~~  When you use stationary layers, locking them is a good idea. When you select other objects
on the stage, you can be sure the locked object(s) isn't moved by mistake.

SWiSHmax has a set of tools for drawing different shapes. Follow these steps to select an
AutoShape tool and draw a shape:

1. Click the visible AutoShape tool in the Tools panel, and hold the mouse button down
until the submenu opens, as shown in Figure 1-6.

Autoshape tool

Layeut - Scere_1 | Sorpt Figure 1-6: Select an AutoShape from the submenu.

2. Click a tool from the submenu. If you are working on the sample project, click the
rounded rectangle tool. The submenu closes, and the selected tool is active.

"‘\Iote The AutoShape displayed in the Tools panel continues to show the most recently selected
~  tool until you select a different one.

3. Click the stage on the Layout panel with the tool and drag to construct the AutoShape.
To complete the shape used in the sample project, click the stage at about the position
of Alaska on the map layer and drag to draw a rounded rectangle that covers most of
the continents shown on the map. The Shape panel becomes active in the panels at the
right of the program window.

11
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4. In the Shape panel, click the Name field to make it active and type a name to identify

o

"

the shape. The rectangle used in the sample project is named bkdg. The name changes
in both the Outline panel and the Timeline.

If you don’t name the objects you add or create in the program, the default names are used.
That isn't a problem when there are only a few objects, but when you are working with a
large number of objects it can be quite confusing. Naming objects as you add them is a
good habit to develop.

By default, any shapes you draw in SWiSHmax are filled with a bright red color. Here’s how to
change to a custom color:

€ Cross-
| Reference
f

Tip

1. In the Shapes panel, click the solid red sample to open the Color Selector

(Figure 1-7).

Click here to open the Color Selector
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Click on a color swatch to select a color
Figure 1-7: Select a color for the shape.

. Click a color swatch to select an alternate color. If you are creating the sample project,

click the dark blue color third from the top in the second row from the left (next to the
bright blue); or click in the field below the Hex label and type 000066. A dark blue is
applied to the shape.

There are a number of ways to choose a color. See Chapter 7, to learn more.

If you click a color swatch, the Color Selector closes automatically; if you type a color number,
click Done to close the Color Selector. The color is applied after the Color Selector closes.
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Hex refers to Hexadecimal, which is a color system. You learn more about this method of

| Reference \,  naming color in Chapter 7.

~ Cross-

In addition to selecting a color for your shapes, you can also modify the level of transparency,
referred to as an Alpha value. Learn about Alpha values in Chapter 7.

When you draw a shape on the stage, you can estimate its size and position, or you can use
the Transform tab to set a precise size and location. To precisely set the location and size,
follow these steps:

1. Click the shape on the stage to make it active.

2. Click the Transform tab to display the current size and position settings for the
shape.

3. Click the Resize checkbox to make it active in the Modes section of the panel.

4. Click a field to make it active and then type an alternate value. To re-create the size
and location of the sample project’s bkgd shape, type these values: X: 22, Y: 36, W: 290,
and H: 190.

The X and Y location references refer to the anchor point position. See Chapter 6 to learn

| Reference \,  about anchor points and other transforming processes.

Tip

5. Click File => Save to save the movie with the completed shape.

Before moving on, check the location of the Autoshape layer in the Outline panel and move
the layer, if necessary. It should be second to last in the listing (if you are creating the sample
project, only the background layer should be below it). Autoshapes can be used for a wide
range of purposes, including as a background for the text, which is explained in the next
section.

If you move anything around in a file, make sure to click Save before closing or the rear-
D, ranged version will be lost.

4

Adding text to a movie

One of the most common elements used in a movie is text. In SWiSHmax, you can animate any
basic text you add to the movie. A special command called Break Apart allows you to animate
the individual letters and apply effects, such as explosions. Follow these steps to add text to
a movie:

1. Click the Text tool in the Tools panel as shown in Figure 1-8, and then move the tool
over the movie. A cross-hair icon appears.

2. Click the stage on the Layout panel. A default block of text named Text is added to the
movie. The Text panel at the right of the program window is active.

3. In the Text panel, click the default name (Text) in the text area of the panel to select
it. Type replacement text. For the sample logo project, type Up and Away Travel. Press
Enter after Away to force the last word to its own line.

13
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Figure 1-8: Use the Text tool to add text to the movie.

SWiSHmax allows you to customize the text you add to a movie. You can change the font,
color, and other characteristics such as the spacing between letters. To customize text,

follow these steps:

1. Click the dropdown arrow to the right of the Font Name field at the top of the Text
panel to select an alternate font. Select a font such as Eras Demi ITC or a similar font

from the list for the sample project (Figure 1-9).
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Figure 1-9: Customize the text in the Text panel.
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There are a number of common fonts you can use if you don't have the suggested font in

~ your system. Arial, Bank Gothic, and Century Gothic are similar to Eras Demi.

2. Click the dropdown arrow to the right of the Font Size field and select an alternate
font size. The text size of the sample project is 36.

3. Click the color swatch to open the Color Selector to select a custom color. Click on a
color swatch in the panel to select it. You can also enter a Hex number in the Hex field.
For the sample project, type CC6699 in the Hex field, which is a dark pink.

4. Click the Text Justification icon and choose an alternate alignment for the text, if
desired. For the sample project, click Center Justify to center the text on the stage.

5. Click the Text type button and choose Static Text from the dropdown list. The Static
Text label appears on the button.

If you don't know the name of the buttons, move your mouse cursor over a button to display
A, a tooltip.
)
When you are finished editing your text, check its location in the Outline panel or the Timeline,
and move the layer, if necessary. For the sample project, make sure the text layer is third from

the bottom, above the bkdg shape and the map.jpg layers.

Aligning objects with one another

There is one thing you should check before you start animating. Look at the stage, and make
sure the objects are placed on the stage where you want them to appear. The location of a
drawn object or text depends on where you click the stage with the tool when you start con-
structing the object.

Before you begin to animate the objects in a movie, make sure the text and the text back-
ground Autoshape are aligned to your liking.

For the sample logo project, the center of both the text and the background should be the
~~  same.

When you set the position for an object, you can move the object and eyeball the location or
use menu commands and make sure its location is exact.

1. Select the text layer, and then press the Ctrl key and select the Autoshape layer.
Make sure you select the layers in this order.

2. Click the Align relative to button to display the dropdown list and choose Relative to
Stage.

3. Click Modify => Align => Center (Horizontally). This aligns both elements horizontally.

4. Click Modify => Align > Center (Vertically). The text position shifts to the center of the
Autoshape layer. Save the file.

Applying Effects to the Movie Layers

Now the fun starts! One of SWiSHmax’s strongest features is quick and effective animation. A
word of caution before you start — there are dozens (if not hundreds!) of pre-built animations
from which you can choose. With such a banquet of effects, it can be difficult to find the right
animations to use and to restrain yourself from choosing one of everything.

15
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There are numerous variations to use with the pre-built animations. Animations involve chang-
ing an object visually over time. The most common animation you may think of is movement,
but you can also animate size, color, and transparency for the layers of a movie.

Using a flying effect

Animation can be used to make images appear to fly across the screen. Whether you use the
airplane in the sample project or a picture of a flowerpot, the background of the image must
be transparent in order to make the effect realistic. Otherwise, you see a flying flowerpot and
its white background move across the screen. Somehow that doesn’t have the same impact!

When you add motion to an object, you see a dotted red line on the workspace that identifies
how the object moves over time. The dotted line is called a motion path and is a useful tool
for evaluating how an effect will look.

To create the effect that an image is flying across the screen, follow these steps:

1. Click the name of the object you want to animate in the Outline panel to select the
image on the Layout panel.

2. Choose View = Preview Frame. You can see the status of the animation at any specific
frame using this viewing option.

Caution There are different ways to preview your work. As you are constructing and animating, make

sure the option described in Step 2 is selected. This allows you to see where an object is at
any frame of the movie. Otherwise, you see only the starting location for the image or graphic.

3. Click the Zoom factor dropdown list in the Tools panel and select 75%. The stage is
shown in the Layout panel with workspace surrounding it as shown in Figure 1-10.

4. Click and drag the image down and left until just the upper-right tip of the image is
within the margins of the stage, also shown in Figure 1-10. The animation you apply
will move the object up and diagonally across the screen.

Zoom control
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Figure 1-10: Adjust the Layout before starting the animation.
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5. In the Timeline, click the Frame on the time ruler where you want to start the effect.
The play head moves to the selected frame. For the sample project, click Frame 1 as
shown in Figure 1-11.

Play head Play control
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Figure 1-11: Add and adjust the effect on the Timeline.

Timeline

6. Click the Add Effect button at the left of the Timeline to open the main effects list-

ings and choose an effect. For the sample project, click Slide = Out to Top Right. The
menu closes and the effect is added to the image’s row in the Timeline.

Effects are always added to the Timeline at their default frame lengths.

7. Extend the end frame for the effect in the Timeline by clicking and dragging the

right edge of the effect’s rectangle to the desired length. For the sample project, the
effect ends at Frame 50. When you see the cursor change to | |, click and drag the edge
right to Frame 50 on the Timeline. Remember to save the project.

For the sample project, the effect’s rectangle should extend across the entire animation’s
Timeline. That is, it should start at Frame 1 and end at Frame 50.

Look closely at the screen and see if you understand what happens when you perform dif-
ferent actions. Don’t worry if you don't. Starting in Chapter 12 you learn to work with effects
in depth.

To view the effect you’ve just added, click the Play button on the Control toolbar and watch.
In the sample project, you see the airplane start at the bottom left and move across the stage,
finally disappearing at the top right. Click the Stop button when you are finished viewing.

Fading the background

Although a static background is attractive, you can easily add effects to enhance a movie pro-
ject. One of the most common and useful effects is to fade in the background, often followed
by a fade-out toward the end of the animation. To add a fade effect, follow these steps:

"

If you are using the sample project, you are working with the map layer.
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1. Click the background image’s layer in the Timeline to select it. For the sample pro-

ject, click the map.jpg label.

The name of an object on the Timeline is referred to as a label. The layer is the object on the
stage.

You can also select the layer in the Outline panel or on the Layout panel.

. Click the Add Effect button on the Timeline, and then click Fade => Fade In (see Fig-

ure 1-12). The effect places a 10-frame rectangle on the image’s row in the Timeline.

(B AddEirect =

Place
Remove
Move

Fade Fade In
Zoom v Fade Qut
Slide 4
Blur

Repeat Frames

Revert

Appear into position ]
Disappear from position
Looping continuously 4
One off +
Return to start L
3D Wave_demo custom

Core Effects L

Figure 1-12: Select the Fade In
effect from the Effects menu.

. Move your cursor over the effect, and then click and drag left or right to position

the effect at the frame where you want it to start. For the sample map.jpg layer,
drag the effect until the first frame is at Frame 5.

. Move your cursor over the right margin of the effect, and click and drag to increase

the effect to the desired length. For the sample project, drag to increase the length
of the effect to 26 frames, ending at Frame 30.

When you change the length of an effect on the Timeline, the number in brackets after the
effect’s name also changes.

Click Play on the Control toolbar to play the movie and watch the effect. With SWiSHmax,
you can easily reuse an effect you've already added to a movie. Instead of selecting the same
effects through the Effects menu, here’s a quick way to add another effect:

1. Click the Fade In effect on the background image’s row on the Timeline to select it.

You added the effect in the previous set of steps. If you are working with the sample
project, the effect is applied to the map.jpg image.

2. Right-click the effect on the Timeline to open the shortcut menu. Click Copy Effect

from the shortcut menu.
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3. Click the frame on the image’s row on the Timeline where you want the new effect
to be placed. For the sample project, click Frame 31 on the map.jpg image’s row on the
Timeline to identify the location to place the new effect.

4. Right-click to open the shortcut menu again, and click Paste Effect. A copy of the
Fade In effect is added to the Timeline at the frame you selected in Step 3. For the
sample project, the copied effect is pasted to the Timeline starting at Frame 31 and
ending at Frame 56.

5. Adjust the length of the pasted effect, if desired. For the sample project, move the
mouse cursor over the right margin of the effect at Frame 56, and click drag left until
the effect reaches Frame 50, making the effect the length of the movie.

In addition to copying and pasting an effect for one object, you can paste the same effect to
other objects. In the sample project, a copy of the Fade In effect was added to the bkgd

A

" # Autoshape layer to make the animation smoother.

You may think this is quick, but the effect isn’t the right one because the idea is for the back-
ground image to fade in and then fade out again. Quite right. Follow these steps to modify the
copy of the effect:

1. Right-click the copy of the Fade In effect on the Timeline to open the context menu.
For the sample project, the second copy starts at Frame 31 and ends at Frame 50.

2. Click Properties in the shortcut menu to open the Fade In Settings dialog box.

Each time you open the Properties dialog box, the tab that was used when you last opened

~  the dialog box appears. For example, if you have been following along with the steps, earlier

you modified the Motion settings for the animation. This time, when you open the dialog
box, the Motion tab is displayed.

To quickly open the properties for an effect, you can double-click the effect’s rectangle on the
5 Timeline rather than using the shortcut menu.

3. Click the Fade tab and click Fade out. There are two directions for a fade. When you
select Fade out, the name of the dialog box changes to Fade Out Settings.

4. Click Close to close the dialog box. On the Timeline, shown in Figure 1-13, you see the
name of the effect has changed to Fade Out, which is what the background image is
supposed to do.

5. Click Play on the Control toolbar to preview the movie and see the effects you’ve
added. Don’t forget to save your project.
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Figure 1-13: Read the name and length of the effects on the Timeline.
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Adding text animation

Text can be boring; text can be interesting. [ vote for interesting. In this QuickStart, you have
seen how to add both text and an Autoshape. SWiSHmax offers many text effects from which
you can select that can add interest to a movie.

Having text appear into its position gives the text an interesting way to enter the movie. The
Appear into Position effect is one used specifically for text. Follow these steps to add the
effect to text:

1. Click a text object in the Outline panel or the label in the Timeline to select it.

2. Click the Add Effect button in the Timeline and then click Appear into position =
Kerning - Kern In. from the effects list. The effect is added to the Timeline at its
default length of 20 frames.

3. Reposition the effect by clicking and dragging it right or left on the Timeline to start
at the desired frame. For the sample project, drag the effect to start at Frame 20.

4. Click and drag an edge of the effect right or left with the mouse to increase or
decrease its length. If you are working on the sample project, increase the effect’s
length to 25 frames, ending at Frame 45.

Tip The Appear into Position effect used in the steps is one of dozens. The Kerning effect is about
), halfway down the second column of effects.
s
5. Click Play on the Controller to preview the movie. You see the text letters gradually
move closer to one another until they are in their final positions.

You can also change the way the text looks by changing its color. If you are working with the
sample project, you see that the text color is very similar to that of the background rectangle,
making it difficult to see the letters clearly. Follow these steps to change the text color as the
effect plays:

1. Right-click the Kerning - Kern In effect on the text object’s row on the Timeline to
open the shortcut menu.

2. Click Properties to open the Kerning - Kern In Settings dialog box. Click the Motion
tab as shown in Figure 1-14.

3. Click the Color button and select the Fade to Color option. Change the default value
from 100% to a lower value if you want to partially fade the color. For the sample pro-
ject, leave the default value of 100% in the Fade to Color value.

4. Click the color swatch to open the Color Selector, and select a custom color for the
Fade to Color effect. For the sample project, click the dark gold color as shown in
Figure 1-14, or type FF9900 in the field below the Hex column to select the color.

5. Click Done to accept the color and close the Color Selector. Click OK to close the
Kerning - Kern In Settings dialog box.

6. Preview your movie. The elements of your movie experience multiple changes in
animation over its duration and ends with a change in the text color.
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Figure 1-14: Choose a custom color to use
for the text animation.
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Previewing and Exporting a Movie

Once your movie is complete, you need to preview it to see how it will appear on a Web site.
And, it’s a good idea to test the movie before you export it. That way, you can see how the
movie looks in a player, not surrounded by the rest of the SWiSHmax program. It’s simpler to
see any errors when you aren’t distracted by the program’s interface.

Click File Test=> In Player. The Macromedia Flash Player opens and you see the movie running
as shown in Figure 1-15. It stops when it has played through. To view it again in the Flash player,
either click Control = Play in the Flash Player menu, or press Ctrl+Enter on the keyboard.

[?3 Macromedia Flash Player 6

BE]|

File Wiew Control Help

Figure 1-15: Preview

your movie in

the Flash Player before exporting.
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/' Note If the stand-alone Flash Player is not detected on your system, SWiSHmax uses a projector
il installed with the program.

™ - - -
~Cross- %  Read more about testing movies in Chapter 22.

|
\
i Reference \

SWiSHmax offers you several ways to export a movie. The options include:
4+ SWF (Shockwave Flash)
4+ SWF and HTML
4+ EXE file (a stand-alone executable file that doesn’t require a player to run)
4+ AVI (video format)

In this section, you learn how to export the Web page as well as the Flash movie. To export
the movie and its Web page, follow these steps:

1. Click File => Export=> HTML + SWF. The Publish SWiSHmax Movie dialog box appears.

- .
pCross- '\ You learn how to create other forms of exports in Chapter 22.

\
| Reference \

[
2. Browse to the location where you want to store the file, and change the name if
desired. By default, both the sample movie and Web page use the project name.

3. Click Save to save the files. The Publish SWiSHmax Movie dialog box closes.

/' Note By default, the files are named using the .swi file name and stored in the main SWiSHmax
~  folder on your hard drive.

4. A dialog box opens asking if you want to edit the HTML file. Click No to close the
dialog box.

5. Open your Web browser.
6. Click File = Open and click Browse.
7. Navigate to the folder where you saved your project file and select it from the list.

Click OK. The page loads, and your movie plays.

On The Web . . . .
Site Copies of the logo.swf and logo.html files are available on the book’s Web site in the chapter01

folder.

~ Cross- ﬂ'\ Chapter 23 describes how to use your movie and an exported Web page in a number of dif-
| Reference \,  ferent programs.
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Summary

This chapter described some basics of creating movies in SWiSHmax and gave you an oppor-
tunity to try out the program by creating an animated movie. You learned how to:

4 Open the program and create a new movie using a template
4 Import and arrange graphic elements
4 Draw and color a simple shape
4+ Add text to a movie
4 Add a soundtrack to a movie
4+ Animate objects over time
4 Animate color and opacity of elements
4 Preview a movie
4+ Export a Flash movie and a Web page
4+ + +
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