
Finder

The Finder is the heart of the Mac OS X user interface. The Finder is
so central to the Macintosh experience that beginning users don’t even
know it’s there: It’s just the desktop. Because the Finder is so impor-

tant and used so often, Apple’s crafty designers like to create well-worn paths
and little tweaks that make it more fun and easier to wrangle. You’re proba-
bly familiar with some of these, such as the power to choose from among
column, list, and icon views and to customize the Finder toolbar.

In this chapter, you’ll explore some of the cooler, odder, and wackier short-
cuts and tricks in the Finder. In the hackiest tradition, you’ll find some to
be so valuable that you’ll use them every day. Others are really fun, but are
pretty much for demonstration purposes only. I trust you to figure out
which ones are which.

List View Open Secrets
The Finder’s list view hides the hierarchy of folders by using little controls
called disclosure triangles. (That’s not a very catchy name, is it? Clearly,
Apple’s marketing department could do a little work here.) Click a disclosure
triangle next to a folder to see the contents of that folder, and click it again to
close the folder.

You can use various keyboard shortcuts to control disclosure triangles in
more powerful ways. When a folder is selected, you can press the right
arrow key to show its contents or the left arrow to hide them. It works just
as if you had clicked on the triangle.

If you hold down Option while clicking a disclosure triangle, the Finder
recursively opens all the folders inside the one you selected. This is a quick
way to see all the stuff in a folder and inside any subfolders it contains. You
can perform the same trick by holding down Option while you press right
arrow to open a disclosure triangle. This also works when you have multiple
folders selected, which makes it even more powerful.

Instead of double-clicking, you can open any file or folder in the Finder by
selecting it and pressing Command-down arrow, which acts exactly like the
Open command in the File menu. If you also hold down Option (that’s
Command-Option-down arrow) instead, the original Finder window closes
as the new ones open, one for each folder you have selected.

˛ Take control of
columns

˛ Play around with
icons and views

˛ Make the Finder
behave

˛ Find your hidden
files and folders
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4 Part I — Tips

Command-down arrow is very versatile—it opens both folders and files. If you select a bunch of
folders, documents, and applications and then press Command-down arrow, the Finder will hap-
pily open all of them. This can lead to disaster (or at least distraction) if this is not exactly what
you want to do. For example, if your memory of these wacky shortcuts is a little off, you might
decide to select a bunch of folders and files, hoping to see their contents (Option-right arrow),
but instead (using Command-down arrow) opening all of them and their applications. 

Attack of the Giant Icons
In case you haven’t discovered it yet, the Finder’s View Options dialog sports a slider for con-
trolling the size of icons. You can make your icons appear at sizes ranging from tiny (16 by 
16 pixels) to extra large (128 by 128). But with an extra tweak behind the scenes, you can have
some real fun and create impossibly enormous icons.

To make this work, you must modify the Finder’s property list. As described in the Introduction,
you can use Apple’s Property List Editor, although you can feel free to use a text editing tool 
if you prefer, because property lists are just text files. Here are the steps:

1. In the Finder, go to your Home directory.

2. Navigate to Library/Preferences: and select com.apple.finder.plist.

3. Choose File ➔ Duplicate to make a safe copy of Finder preferences. You’ll need this in
the unlikely event that you accidentally mangle the original.

As I describe in the Introduction, it’s a good idea to make a backup copy of preferences
and other system files before you change them. Although I won’t repeat this warning
every time you edit a file, please keep it in mind.

4. Double-click com.apple.finder.plist to open it in Property List Editor. If you don’t have
Property List Editor and some other application opens, see the section “Editing property
lists” in the Introduction.

5. In the Finder’s property list, open Root.

6. Open StandardViewOptions.

7. Under StandardViewOptions, open the icnv (icon view) branch.

8. In the IconSize item, double-click the value to select it. It will be set to some number
between 16 and 128, depending on the current global setting for the icon size.

9. Type 640 as the new value and press Return.

10. Save the file and close it.

11. Restart the Finder. You can do this by choosing Force Quit from the Apple menu, log-
ging out and back in again, or by using the method in this chapter’s “Quit the Finder”
section.

When the Finder restarts, go to any folder and choose icon view. You should see something
similar to the awesome monsters depicted in Figure 1-1.

Warning
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5Chapter 1 — Finder

To return the icon sizes to normal, open the View Options dialog and drag the icon size slider.
As soon as you click the slider, the Finder figures out that something is amiss, changes the
upper limit back to 128, and redraws the icons at a more reasonable size.

FIGURE 1-1: Giant icons! Hide the children!

Make Perfect Sidebars Every Time
Finder windows can show or hide their sidebars. You can drag the dot on the right edge of the
sidebar (see Figure 1-2) to decide how big you want the sidebar to be. Drag it all the way to the
left to make the sidebar vanish. The dot will still be there (in case you want to make the sidebar
come back). If you want the dot to go away, you’ll have to sacrifice the toolbar as well: Choose
View ➔ Hide Toolbar or click the oval in the top-right corner of the window.

FIGURE 1-2: Drag this dot 
to resize the sidebar.

A couple of cool shortcuts give you control over the sidebar’s size. Double-click the resize dot
to make the sidebar vanish completely—except for that pesky dot. Double-click the vestigial
dot to restore the sidebar to the size it was before you banished it.
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6 Part I — Tips

This one’s nifty but subtle. With the sidebar hidden, drag the dot slowly and at a steady speed.
When the sidebar is just big enough to allow all its items to appear fully, with no ellipses at the
ends of words, the sidebar will stick for a few pixels even as you drag, pinning the sidebar at its
optimal size. If you keep dragging, eventually the sidebar will unstick and let you make it bigger.

If the sidebar is wider than necessary to display all items, you can use this trick in the other
direction, as you drag to make the sidebar smaller. It doesn’t work exactly as you would hope,
reversing the pinning effect. Instead, when you drag within a few pixels of the optimal width,
the sidebar edge suddenly jumps to the left to hit the sticky point, where it stays until your drag-
ging catches up with it.

Each Finder window keeps its own view settings, so you can have some windows that display the
toolbar and sidebar and others that hide them.

Master All the Columns
You probably know that you can resize columns in column view by dragging the divider control
that appears at the lower-right edge of every column. The control, marked with two vertical
bars, is easy to miss if you don’t know it’s there (see Figure 1-3). If you hold down Option
while dragging, all the columns resize at once, making them all the same width.

FIGURE 1-3: The Resize control in 
the Finder column view window.

Unfortunately, the column view people weren’t talking to the list view people on this one,
because this trick only works in column view.

Set Your Columns Just Right
Column view has a trick to get a column just wide enough to display all its items. If you
double-click the column divider control, the column snaps instantly (or not so instantly, if there
are a lot of items in the column) to exactly the right width for showing everything it contains.

Note that there’s some inconsistency in what happens when you drag different user interface
elements in the Finder. The sticky sidebar dragging trick described earlier in “Make Perfect
Sidebars Every Time” would be handy here, but it doesn’t work; double-clicking the divider
control performs a very different action than double-clicking the sidebar dot.
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7Chapter 1 — Finder

Fun with View Options
Every Finder folder has its own collection of settings called view options. There are actually two
sets of options for every folder: one that’s used when the folder is displayed in list view and a
separate set for icon view. You set view options by choosing View ➔ Show View Options,
which brings up one of the dialogs shown in Figure 1-4.

FIGURE 1-4: The View Options dialog varies depending on the current 
window’s view type.

All Finder windows showing column view share common settings, and there are only two of
those. They control whether the window shows icons next to the file names and whether the last
column is used for a preview of the file. The main reason these options exist is so you can turn
them off to speed up cruising through files in the Finder.

Note that the title bar of the view options dialog has the name of the folder, and the top sec-
tion for icon and list views includes two radio buttons: This Window Only, and All Windows
(for icon view and list view). If you make a change with This Window Only selected, only the
current window is affected. If you change a setting with All Windows selected, you’re making
the change for every window of that type, except for those windows that already have their own
custom settings.

In this section, I’ll cover some of the more unusual and lesser-known features of Finder view
options.
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8 Part I — Tips

Use Background Colors and Pictures
The bottom of the View Options dialog contains the good stuff. In icon view, you get to design
the background of your Finder windows. By default, windows are set to have a plain white
background. To make things less boring, click Color and pick a shade you like. Your chosen
color is then used to fill the window background when you’re in icon view.

For more fun, use the Picture background option. Click the Picture button and then click
Select. Pick your favorite picture and watch it appear as the background of the Finder 
window, as shown in Figure 1-5. If you’ve ever downloaded software that contains a disk image
with a picture in its background and wondered, “How did they do that?” now you know. If 
you want, you can even apply the picture to every Finder window by using the All Windows
button.

FIGURE 1-5: A custom picture background for Finder windows.

The window keeps track of your choices for color and picture, no matter which background
option you’re using. So if you set up a picture, switch to a color, and then decide a year later
that you’d like the picture back, all you have to do is click the Picture button and you’ll see that
the faithful Finder remembered your choice of picture.

Show More Information
Two more view options let you control how much information you see about files in icon view.
Use the Show Item Info option to learn more about every item at a glance. For example, when
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9Chapter 1 — Finder

you turn on this nifty feature, folders display how many items they contain, images (such as
JPEGs and GIFs) show their resolution, movies display their length, and all your socks are
folded for you (just kidding about that last one).

The Show Icon Preview option lets you learn even more about your files just by glancing at
their icons. With this setting turned on, the Finder turns the icons for image files into tiny
replicas of their images.

Both of these options are nifty, but they can slow down your Finder windows, which is one
good reason to keep them turned off (at least, until you get that nifty new quad-processor G6
desktop for your birthday).

Quit the Finder
You’ve probably noticed that the Finder has no Quit item at the bottom of its application
menu, unlike virtually every other OS X program. That isn’t an accident: Apple does this 
to prevent folks from accidentally quitting an application that should be running all the 
time.

But sometimes you really do want to quit the Finder as, for example, in various sections of this
chapter when you work with with Finder preferences. You can always force quit the Finder by
choosing Force Quit from the Apple menu, but there’s a neater way. The Finder actually has its
own Quit menu item, but it’s disabled by default. We’re going to enable it, using that classic act
from the ‘60s, Terminal and the Defaults.

1. Open Terminal. It’s usually in the /Applications/Utilities folder.

2. Type this command, then press Return or Enter:

defaults write com.apple.finder QuitMenuItem yes

3. Restart the Finder by logging out or force quitting. (The next time you need to restart
the Finder, you can use the very Quit Finder item you’ve just enabled.)

That’s it! You should now have Quit Finder as the last item in the Finder’s application menu. If
you ever want to remove this menu item, just repeat the command, substituting no for yes.

Be a Quitter

There are other ways to quit the Finder. In addition to the two already described (force quit and
enabling the Quit menu item), another handy option is to type killall Finder in Terminal.
You might also want to check out TinkerTool, described in Chapter 7, which lets you enable the
Quit menu without any Terminal work.
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10 Part I — Tips

Make the Default Finder Window Behave
The Finder keeps track of a default window position and size that it uses whenever you open a
new window with File ➔ New Finder Window. You can tell the Finder what values to use for
these settings, but there’s no obvious user interface for doing it. To set up your default new
window, follow these steps:

1. Go to the Finder and close all windows.

2. Chose File ➔ New Finder Window. This will be your model window. Resize it and move
it until it has the size and location you want. You can also set your desired window view
and toolbar/sidebar settings.

3. Close the window.

4. Open a new window to test it out. The new window should have the size, location, view,
and toolbar/sidebar settings of the one you just closed.

Who’s Zooming Whom?
The Finder and zooming rectangles (zoomrects) go back a long way. Ever since the earliest
days of the Macintosh, the Finder has used zoomrects as an effective animation for showing
that something is moving or expanding, such as a file or application opening. Even in those
early days, some folks decided enough already with the zoomrects: They would rather have the
zoomrects turned off so they could regain that fraction of a second spent looking at the nice
animation. In today’s modern, twenty-first-century world, you can turn off the zoomrects in
the Finder by using the Defaults command.

1. Open Terminal.

2. Type this command and then press Return or Enter:

defaults write com.apple.finder ZoomRects no

3. Restart the Finder.

No more zoomrects will trouble you. To get them back, you can repeat the command, substi-
tuting yes for no.

The defaults command pays attention to upper- and lowercase in identifier names. For exam-
ple, QuitMenuItem is not the same thing as quitMenuItem (one starts with an uppercase letter
and the other doesn’t). Make sure you type the identifiers just right, or stuff won’t work and you’ll
be unnecessarily sad.
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11Chapter 1 — Finder

Go Directly to Secret Folders
Mac OS X is based on Unix, and lots of the system is hidden from view in the Finder. This
helps prevent unhealthy poking around and any subsequent catastrophic damage that might
result. Of course, you can use Terminal to see all the hidden stuff. But a trap door in the Finder
enables you to look at hidden folders.

1. In the Finder, choose Folder ➔ Go to Folder, or just press Command-Shift-G.

2. Type a directory path in the dialog box (see Figure 1-6).

FIGURE 1-6: The Go to Folder command lets you access 
hidden directories from the warm comfort of the Finder.

This command works for any directory, as long as you have privileges to see it. You can use it to
open system directories, such as /bin and /etc, or hidden directories, like ~/.ssh.

For a tip on how to make all files and folders visible in the Finder, see the section “Show Hidden
Files” in this chapter.

For even more Unix fun, this command comes with autocomplete, just as in the shell. You see
autocomplete work if you type a partial pathname and then press Tab (or just wait for a second
or so). The Finder automatically fills in the rest of the pathname, up to the next slash. Neato! 

Show Hidden Files
The Finder protects you from yourself by hiding a bunch of system files from view. But the
Finder-makers included a switch in defaults that lets you turn off this protection so you can see
the complete contents of disks and folders. To make all files visible in the Finder:

1. Open Terminal.

2. Type this command:

defaults write com.apple.finder AppleShowAllFiles –bool yes

3. Restart the Finder.

Now you’ll see all that was previously hidden. This includes Unix directories that are deliber-
ately kept out of sight by the Finder, such as /usr and /sbin, as well as directories whose names
start with a period, the traditional Unix mechanism for hiding things. Figure 1-7 shows what a
Finder window looks like with all files shown.
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12 Part I — Tips

FIGURE 1-7: The Finder window with hidden files 
shown.

This trick is especially valuable when used with an iPod. Apple uses hidden folders to squirrel
away music on iPods. If you want to see all the tunes stored on your iPod, just use this proce-
dure to show hidden files. Then take a look inside the iPod_Control folder on your iPod to
find folders full of music.

Fix a Frozen Archive
The Finder includes the built-in capability to create and expand ZIP archives. This is a very
handy feature, especially because the ZIP format works on other, non-Macintosh operating
systems as well. But every so often, the Finder gets stuck while unarchiving. You also see a
progress dialog in the Finder that includes a Cancel button. But here’s something funny: When
you click Cancel, not only does the unarchiving process remain stuck—the Cancel button van-
ishes! Ha, ha. Good one, Apple.

Of course, what if you really want to cancel the unarchiving that seems to be taking forever?
Here’s how:

1. Open the Activity Monitor application. If you haven’t moved it, you’ll find it in the
/Applications/Utilities folder.
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13Chapter 1 — Finder

2. Make sure the pop-up menu at the top of the window says All Processes (see Figure 1-8).

3. Make sure the Process Name column is selected. This causes the Activity Monitor to
show the processes in alphabetical order.

4. Look for the process named BOMArchiveHelper and click to select it.

5. Click the Quit Process button in the toolbar and then click Quit in the alert box.

FIGURE 1-8: The Activity 
Monitor pop-up menu.

Quitting the process with Activity Monitor should make the hung unarchive go away. Of
course, you still might not be able to get the information out of your archive, but at least the
hung process is gone.

Summary
The Finder is the most basic part of the Mac OS X experience, but it’s also very tweakable. You
can use a combination of deeply hidden features and completely buried tricks to make your
Finder experience better and more interesting.
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