Chapter 1: Understanding
Nondestructive Editing

In This Chapter

1~ Preserving pixels by using safe tools
1+~ Protecting the Background layer
1 Recovering from overediting

1~ Copying visible layers to new ones

C hange. Count on it. Change is the only constant. This chapter is all
about change, as in changing your mind and not having to work hard
to make a change. You read how to store all of your edits to a Photoshop
file in layers, beginning by creating a backup of the Background layer.
You understand how destructive tools work and how to replace

them with safe ones. You use layers to store adjustments,
modifications, and retouching. You discover how to
rework an overedited area without having to redo the
whole file. You begin to think about editing in a way
that always lets you go back and . . . change your
mind. Think of this chapter as revealing how to
have unlimited do-overs forever!

Artist Matt Lamb says that, “a painting is finished
when a dealer takes it out of [my] studio by force
and hangs it in the house or office of a client.” That
works for painters, sculptors, and other artists who
deliver one-of-a-kind works. Imagine how life would be
for them if they didn’t know when a work was done.

Now understand that as a digital photographer, your life is
that of an artist whose work never has to be finished. The reason
for the possibility of the neverending story is, of course, Photoshop. A prop-
erly executed work done in layers is one that can be changed as many times
as whim or inspiration strikes.
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Erasing the Evil Tools
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The Eraser Tools — Eraser,
Background Eraser, and Magic
Eraser — do exactly what their
names say they do. They erase
pixels. That’s why they are “evil.”
There needs to be a big red DON'T
USE symbol like the one in Fig-
ure 1-1 when they are clicked.

Okay. They aren’t really evil in the
horror movie or serial killer sense.
They are evil because they destroy
or permanently alter pixels. These
kinds of methods in Photoshop are
arguably fine as long as the file is
open and no more than 20 steps have
been done. After a pixel has been
erased, for example, and 20 more
changes are made on the file, the
change is permanent. When a file is
saved, closed, then opened again, Figure 1-1: Don't use these tools.
the history is cleared and the ability

to undo an edit is gone.

The default number of history steps or undos in Photoshop is 20. This set-
ting can be changed in Photoshop’s preferences.

Hiding versus Erasing

Here are quick demonstrations of what the Eraser does and how to do
exactly the same thing by hiding pixels instead of erasing them.

Erasing

The mission of the project is to make the roof of the car interior blend with the
corrugated tin roof so no black from the car photograph extends into the sky.

1. Download the folder for Book V, Chapter 1 from www.amesphoto.com/
learning.

The code to go to the login/registration page is 4D59776. If you have
already registered, type in your user name (your e-mail address) and
password.



2. Navigate to the sample folder in

Bridge.

. Double-click Eraser.psd to open

it in Photoshop CS2.

The file has three layers: the
Background layer of a corru-
gated tin roof and rafter, the
Eraser layer of the interior of an
old, deserted car, and a duplicate
Hide Pixels layer of the same old
car. As you see in Figure 1-2, the
layer Hide Pixels is hidden. The
lack of an eye tells you that.

. Choose the Eraser Tool from the

toolbox.

. In the Brush window in the

options bar, click the triangle to
open the settings.

Hiding versus Erasing 3 19

[4] [4]

Layers “Ghanngls \(__I_’aths\

[

Normal | : Opacity: | 100% Tr
L.:.cl::rlj-!__,_j--"_'_-*-}:]_ﬂ_-i Fill: [100% el
E‘ = Hide Pixels
- E = Eraser
Background a

=g /0 e ol

Figure 1-2: Hide Pixels is hidden.

. Make the eraser 60 pixels in size by moving the Master Diameter

slider until the window reads 60 px.

Refer to Figure 1-3.

. Make the hardness 0% by either dragging the Hardness slider all the

way to the left or typing 0 in the window.
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Figure 1-3: Move the slider.
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8. Click anywhere in the options bar to close the Brush window.

9. Working in the Eraser layer, erase the black portion of the layer that
extends into the sky.

Use one stroke of the mouse to follow the roof line. When you finish, your
work looks like Figure 1-4. Compare the thumbnails in the layers Eraser
and Hide Pixels. Notice that the pixels in the Eraser layer are gone.

Figure 1-4: Your work will look like this.

10. Click the Background layer’s eye icon to hide it.

You see only the car interior and the soft edge where the pixels were
erased. See Figure 1-5.

11. 8+Z (Ctrl+Z) to undo the erasing.

The erased pixels come back on the screen and in the Eraser layer’s
thumbnail. See Figure 1-6. If you did several strokes to erase the top of the
car interior, 38+Option+Z (Ctrl+Alt+Z) until all the erased pixels return.

12. If you did the erasing with one stroke of the mouse, type 3#8+Z (Ctrl+Z)
to redo the Eraser.

If you used several strokes to do the original erasing, you have to redo
each stroke. 88 +Shift+Z (Ctrl+Shift+Z) until your screen looks like
Figure 1-5.
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Figure 1-5: The erased edge is soft.

13. From the Photoshop menu, choose File->Save, then choose Filew>
Close.

14. Select Filer>Open Recent->Eraser.psd or double-click Eraser.psd in
Bridge.
See if you can undo the erased pixels. Typing the undo keystrokes are
all for naught. Those pixels are outta here, never to return. Keep this file
open and work through the following section.

Hiding

This part of the project introduces you to adding and using a layer mask to an
image. Layer masks on photographs work exactly as they do on adjustment
layers. (If you haven’t already done the projects in Book IV, Chapter 4, you
may want to do so now. Those projects help you understand layer masks and
bring you up to speed for this one.)
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Figure 1-6: The erased pixels are back.

[ [

1. In Eraser.psd, click the eye icon

on Eraser to hide the Eraser Layers “‘Channels \‘J\LPaths \\_ )
layer Normal 5= Opacity: | 100% E‘
Lock: || |+ | @ Fill: [ 100 E‘

2. Click the eye icons on the
Background and Hide Pixels | |
layers to make them visible. = E o Hide Fixels
3. Click the layer thumbnail of — —l

Hide Pixels to activate that
layer.

Eraser

Your layer stack looks like Fig-
ure 1-7.

4. Click the Add Layer Mask icon
in the Layers palette.

Backgrownd ﬁ

=g 0 e | 0/xR

Figure 1-7: This is your layer stack.
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<P Clicking the Add Layer Mask icon puts a reveal all layer mask on the layer Book V
Hide Pixels. The icon is circled in red in Figure 1-8. A reveal all layer mask Chapter 1
is filled with white. A hide all layer mask is filled with black. Refer to
Figure 4-1 in Book IV, Chapter 4 for the identification of the icons at the =
bottom of the Layers palette. S=

me- o
282
Reveal all layer mask EX=
(=] [&) »
Layers Q:lannels\{za.ths\ ()
" Normal | :] OPaCiT\fZ
Lock: [ #[+h @ Fill:[100% |
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__|
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Figure 1-8: Add Layer Mask icon and reveal all layer mask.
5. Select the Brush Tool from the toolbox.
6. Move the Master Diameter slider until the window reads 60px and
type 0 into the Hardness textbox. Opacity should be 100%.

P When you finish you have a
soft-edged, 60-pixel brush. &”J Ly
Appendix B has keyboard RS T,
shortcuts for brush size, edge I Exchange Colors (X) } |
hardness, and more. 1E) i

7]
7. Set the foreground color to : a
Black. .

Default Colors (D)

If the toolbox colors are not
white and black, click the default
color’s icon or type D. If white

is the foreground color, click

the exchange colors icon or type Figure 1-9: Exchange Colors and Default
X. Find the icons in Figure 1-9. Colors icons.
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) Photoshop’s painting tools use the foreground color in the toolbox. You

can change the color by double-clicking in the foreground color box to
open the picker or by clicking a color in the Swatches palette.

8. Paint on the layer mask with black over the parts of the car interior
that are in the sky above the roofline.

When you finish, your screen and Layers palette look like Figure 1-10.
Notice that an area of black is on the layer mask. The pixels are still
visible on the layer thumbnail. They are hidden from the screen by the
black on the layer mask.

Hide Fixels

Figure 1-10: This is what your screen should look like.
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9. Click the eye icon on the Background layer to hide the layer. Book V

The Hide Pixels layer looks like the Eraser layer, as you see in Figure 1-11. Chapter 1

The pixels are hidden by the layer mask. Bring them back.
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Figure 1-11: Hide Pixels and Eraser look the same.

10. Disable the layer mask by Shift+clicking inside the layer mask on the
layer Hide Pixels.

Ared X is displayed in the layer mask and the pixels that were hidden
appear on the screen, as shown in Figure 1-12.

11. Enable the layer mask by Shift+clicking inside the layer mask.

The red X is removed and the pixels on the screen are hidden where
there is black on the layer mask.

12. Choose File=>Save and then choose File->Close.
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Figure 1-12: Hide Pixels is disabled.

Cashing in on unlimited undos

Here’s the big difference between using a layer mask and the Eraser Tool. Put
back the left half of the pixels along the roofline.

1. Reopen Eraser.psd by choosing | "

File->Open RecentoEraser.psd |y T#)  opsanr[ico [0
or double-click its preview in wwOlF+@l e
Bridge. [
- ] Hide Pixels
2. Activate the layer mask by |

clicking its icon on the Hide
Pixels layer.

tf 4 Active Bnrderl

The active border appears
around the Layer Mask icon, as
in Figure 1-13. =[gOe a3

Background ]

e

3. Click the Background layer’s

Fi 1-13: The L Mask icon i ive.
eye icon to reveal the layer. igure 1-13: The Layer Mask icon is active
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4. Click the Exchange Colors icon (see Figure 1-9) or press X.
You made white the foreground color.

5. Paint at the upper-left edge of the interior of the car above the
roofline.

The black part of the car’s roof appears above the corrugated tin, as you
see in Figure 1-14. Even after the file was saved and closed, the pixels
are still there. And there’s more. The Eraser Tool only lets you undo the
whole stroke. Remember when you did 3+Z (Ctrl+Z) to undo the Eraser?
The entire stroke was undone.

Using a layer mask and painting with white allows you the control of
bringing back any part of the pixels hidden by black on the mask. How?
Simply paint with white.

g

"Channels M Paths ™\

Orpacity: | 100%

Fill: | 100%

Hide Pixels

Background
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Figure 1-14: The black part appears.
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Protecting the Background Layer
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The first best practice in Photoshop is to always protect the Background
layer. Make it a habit to never, ever make edits on this layer. You make a
duplicate of the Background and edit that layer. This serves two purposes:
First, it protects the Background layer. Second, it gives a before and after
comparison of the work you have accomplished by simply clicking the dupli-
cate layer’s eye icon on and off.

Make notes of the work you want

to do in Photoshop while you are
making photographs. Often a few
quick steps in Photoshop are all you
want, as in the case of the building 7
in Figure 1-15. I saw the leaves, the
sunspot, and the crane in the view-
finder. [ knew I would have to do
simple fixes to give a clean view

of this unique architectural angle.
Figure 1-15 shows the retouching for
this photograph of a building whose
sides meet at an acute angle.

Remove Leaves

Backing up the
background

Here’s how you protect your
Background layer:

1. Download the folder for
Book V, Chapter 1 from www.
amesphoto.com/learning.

Figure 1-15: These are the things | want
to fix.

The code to the login/
registration page is 4D59776.

If you have already registered, type in your user name (your email
address) and password.

2. Open the file by double-clicking it in Bridge.

3. Select Layer~>Newr>Layer Via Copy from the Photoshop menu bar to
duplicate the Background layer.
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More keyboard shortcuts! =]
Woohoo! 88+J (Ctrl+J) makes a
duplicate of the highlighted layer

Layers Channals \L{a.ths\_

Mormal & ]

[&]

(=
=

Dpacity:

and places the new layer directly
above the one copied. If the high-
lighted layer has a selection, only
the selection is copied onto a ®
new layer.

Lock:||:||_g‘|+|ﬂ|

i

Fill: [100% [+

.| Retouch

4. Rename the Background layer
duplicate by double-clicking
the words Layer 1 (immedi-
ately to the right of the layer

.| Background a2

thumbnail).

5. Type in Retouch and press

=G Ol®lC[a ]

Enter.

Figure 1-16: Your layer stack looks like this.

Your layer stack looks like Fig-

ure 1-16. All of the retouching in the
next steps takes place on the layer
named Retouch. Keep your file
open for the next section.

Doing the minor fives

The healing tools copy the tone and tex-
ture of the sampled area to the area
being healed. The underlying color of
the healed area is maintained.

Removing the leaves

Just for fun and to give you a brief
introduction to a few great retouching
tools — Clone Stamp and Healing
Brush and Patch Tools — finish the
fixes shown in Figure 1-15.

1. Click the Clone Stamp Tool icon
shown in Figure 1-17.

The flyout menu shows you the
other tool available: Pattern Stamp.
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Figure 1-17: Clone Stamp is the way to go.
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2. In the options bar, choose a 70-pixel, soft-edge brush.

The options bar is shown in Figure 1-18.

Figure 1-18: The Clone Stamp options bar.

Mode: L MNormal ﬁ Opacity: | 100% n Flow: [ 100% n @ ™ Aligned ) Sample All Layers

3. Option+click (Alt+click) in the clouds to the right of the leaves, as you
see in Figure 1-19.

4. Clone the blank clouds over the leaves.

The Clone Stamp Tool works just like a brush except that instead of
using paint, it copies the sampled area over the leaves. Figure 1-20
shows the cloning in progress. The cloned area is very obvious. Now
you use the Healing Brush to blend it together.

Sample here

Figure 1-19: Sample the clouds. .. Figure 1-20: ... and clone the clouds.
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. Click and hold the Spot Healing Book V
Brush icon. Chapter 1

f

The healing tools menu appears.

. Choose the Healing Brush. f Sl eyl |
- 65) Healing Brush Tool I

[
»
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.

.
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The Spot Healing Brush is the
default choice of the toolbox £y Patch Toal !
you see in Figure 1-21. gy Red Eye Tool [
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. Again, Option+click (Alt+click)
in the clouds shown in
Figure 1-22.

e

.

This samples the area of clouds
to the right and below the
cloned area.

.
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. Heal the mismatched cloned
area by painting over it with
the Healing Brush. »qP
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The result while you are
working looks, well, wrong!
See Figure 1-23. When you

B
I,

release the mouse, the healing L
happens automatically. Ta da!
The cloning is fixed. Remember

to heal where you cloned over E@

the leaves in the brighter areas

of the cloud, too.

Eeep your file open for more Figure 1-21: Here's the default.
ixes.
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Sample here

Figure 1-22: Sample the clouds ... Figure 1-23: ... and the
clouds are healed.

Fixing the sunspot

The sunspot is really a spec-
ular highlight. Specular
means mirror. What you are
seeing is the sun reflected in
the granite . . . the mirror in
this case.

1. Click and hold the Spot
Healing Brush icon and
choose the Patch Tool.

See Figure 1-21 for the
icons.

2. Draw a selection
around the sunspot.

Be careful to avoid

the centerline or the left
edge of the stone. Your
selection wants

to look like the one in  Figure 1-24: Avoid either edge.
Figure 1-24.
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3. Click inside the selection and
drag it across the centerline.

Book V
Chapter 1

Check Figure 1-25 for positioning.
The area you drag the selection
over replaces the original selec-
tion as you drag, giving you a
real-time preview of what will be
patched over the original pixels.
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4. Release the mouse button to
patch the selection.

5. Choose Select->Deselect from
the menu bar or press 8+D
(Ctrl+D).

Notice that the pattern of the
granite is duplicated in the
patched area in Figure 1-26.
This is a dead giveaway that
Photoshop has been used.

\\s

(SMBER Fixing the fix
& The goal of great work in Photoshop
is to be undetected by the viewer.

1. Get the Healing Brush from the
toolbox.
See Figure 1-21.

2. Option+click (Alt+click) in an
area of the stone that is free of
distinguishing marks.

Now heal in the area of the
repeated pattern.

Figure 1-26: A duplicate pattern: a dead
Photoshop giveaway.
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3. Brush over the obvious dupli-
cates of pattern.

Each time you release the mouse
button, Photoshop heals the
area. When you are finished,
your retouch is like Figure 1-27.
Look Ma! No patterns! Keep
going . . ..

Fixing the crane

This one is easy and demonstrates a
cool way to use the Healing Brush.

1. Sample on the edge of the
building above the crane.

You want to sample the build-

ing’s edge and the sky together, . )
as you see in Figure 1-28. For Figure 1-27: Healing stone.
clarity’s sake, the figure shows
the diameter of the brush. The
sample point is the crosshairs. Sa mp| 8] here

2. Click the building edge next to
the crane; drag down the edge
of the building and over the
entire area of the crane.
Release the mouse.

Magic! The crane is gone in one
stroke! The trick is to make cer-
tain that the sample point and
beginning of the Healing Brush
stroke are centered on the edge,
as in Figure 1-29.

The great part about this style of
using Photoshop is you get to see the
work you have done and compare it . o
to where you started. Click the eye Figure 1-28: This is your sample spot.

icon on the layer Retouch so it’s off.

You see your work disappear. Now click the eye icon again. All of the flaws —
the leaves, sunspot, and crane — vanish. Figure 1-30 shows the result. There
you have the basics. Making a copy of the background layer and always work-
ing only on that layer means you can always go back.
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Figure 1-30: Before and after.
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Recovering from Big Mistakes

A big mistake is when a lot of work
has been done on a retouch layer
and part of it isn’t right. A client
changes his mind and the fix he
wants looks like it would require
doing all of the work on the Retouch
layer over again.

Here is an example: Figure 1-31
shows a retouching strategy map

for this headshot of actress Tiffany
Dupont. Notice that the map calls
for plumping up her lip a little

bit. (You read how to do this in
Book V, Chapter 3, by the way.)
Figure 1-32 shows the lip before, on
the Background layer, and after,

on the Retouch layer. You see that
all the other retouching has been
done, including removing hair below
her chin and from across her eye. A
lot of work has been already accom-
plished to bring the image this far. Figure 1-31: The strategy map.

i1k

Background Layer | | Retouch Layer &

Figure 1-32: Before and after.
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At the point in a retouch where something drastic is to be done, duplicate
the layer and rename it with the procedure.

Had this example been properly executed, Retouch would have been dupli-
cated and renamed Liquify Lip. In this example, the work on the lip makes it
look too exaggerated. So it has to be redone. Sometimes you get caught up in
the heat of the work and forget to follow procedure. There was a time when
this kind of do-over meant starting completely over. Here is how to recover
from this boo-boo:

1.

Download the folder for Book V, Chapter 1 from www.
amesphoto.com/learning.

The code to go to the login/registration page is 4D59776. If
you have already registered, type in your user name (your
e-mail address) and password.

2. Open the file Tiffany.psd by double-clicking it in Bridge.

3. Click the eye icon on the layer Strategy Map to hide the

layer.

. Click the Retouch eye icon on and off several times, leav-

ing it on.

You see how much work has been done. It would be no fun
at all to do it over. Leave this eye icon on.

5. Click inside the layer thumbnail for the layer Retouch.

6. Select the Lasso Tool from the toolbox shown in Fig-

ure 1-33.

. Draw a selection around the exaggerated lips.

Your selection looks like Figure 1-34.
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Figure 1-33:

The Lasso
Tool.
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Figure 1-34: Circle the lips.

8. Click in the thumbnail of the Background layer.

Your layer stack looks like Figure 1-35. Now you make the selection into a
separate layer
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Figure 1-35: Your layer stack looks like this.
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9. Choose Layer~>Newr>Layer Via Copy, shown in Figure 1-36.

The selection is now a new layer named Layer 1.

lg Select Filter View Window Help
3N

i Layer...
Duplicate Layer...
Delete > Layer From Background...

Group...
CGroup from Layers...

Layer Properties...

Layer Style >
NEE Layer via Copy
New Fill Layer [ 2 Layer via Cut
New Adjustment Layer > ’,
Change Layer Content
Layer Content Options...
Layer Mask >
Vector Mask >
Create Clipping Mask NHEG
Smart Objects >
Type

RAasterize

New Layer Based Slice

Croup Layers G

Ungroup Layers G

Hide Layers

Arrange >
Align Layers To Selection >
Distribute

Lock All Layers in Group...

Figure 1-36: Choose Layer Via Copy.
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10. Click+drag the Layer 1 thumbnail up the layer stack until it is above
Retouch.
When you see a solid bold line between the layers Retouch and Strategy
Map (as you see in Figure 1-37), release the mouse button. The lips from
the Background layer now cover the exaggerated ones. All that’s left is
to merge Layer 1 with Retouch.

11. Click the flyout disclosure triangle at the top right of the Layers
palette. Select Merge Down from the menu, as in Figure 1-38.

12. Use the Healing Brush on the skin above her upper lip and below her
lower one.

Your layer stack is shown in Figure 1-39.
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Figure 1-37: Release the mouse when
you see this bold line.
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Layers " Channals Npaths ™
" Mormal I:]: Opacity:

Lock: [ D[ |4 @ | Fill:
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[==lgOle[C[a[H]

Dock to Palette Well

New Layer... 13N
Duplicate Layer...
Delete Layer

Delete Hidden Layers

New Group...
New Group from Layers...

= Layer 1
= L | A Group into New Smart Object
Layer Properties...
- 1 erouch Blending Options...
) Create Clipping Mask 3G
|§ | Background &
3 Merge Down 3#E
Merge Visible {+3#E
Flatten Image
Animation Options >

Palette Options...

Figure 1-38: Choose Merge Down.
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Background
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Figure 1-39: Here's your layer stack
again.




