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Chapter 1

This Is AutoCAD
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I n a few short years, the Internet has transformed the way we work
and play. It has helped break down barriers to the flow of informa-
tion and ideas. Gamers in distant locations battle each other in

simulated environments. Once-isolated seniors can exchange e-mail
notes with their grandchildren on the other side of the world. Docu-
ments that once took days to move from one business to another can
now be sent in a matter of seconds. Software companies are now
expected to integrate Internet and web capabilities into their products
to facilitate the flow of information. Autodesk is no exception.

AutoCAD 2002 is Autodesk’s latest effort in producing “Inter-
net- and web-enabled” design and documentation software. With
AutoCAD 2002, you have the ability to import symbols from web
pages and easily publish a set of drawings to your company’s web
site. You can quickly get the latest software upgrades and find the
answer to a technical problem you may be having. Working within
a team over an intranet or virtual private network is now a lot eas-
ier with AutoCAD 2002. Whether your team is in the same room
or dispersed across several states, AutoCAD 2002 is equipped with
the tools to help make project coordination easier.

But before you can start to make use of these new capabilities,
you’ll need to become familiar with the basics of AutoCAD. If you
are completely new to AutoCAD, this first chapter offers a look at
many of AutoCAD’s basic operations, such as opening and closing
files, getting a close-up look at part of a drawing, and making
changes to a drawing. If you are already familiar with earlier versions
of AutoCAD, you may want to read through this chapter anyway to
get acquainted with new AutoCAD 2002 features. So let’s get started!

• The AutoCAD Window

• The Pull-Down Menus

• The Toolbars

• Opening an Existing File

• Getting a Closer Look with the Zoom Command
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• Saving a File As You Work

• Making Changes

• Opening Multiple Files

• Closing AutoCAD

• If You Want to Experiment…

In this chapter, and throughout the rest of the book, you’ll see a small icon next to a topic or item being
discussed. The icon tells you whether the feature is new since AutoCAD R14 or AutoCAD 2000. If you’re a
veteran AutoCAD user, these icons can help you focus on the topics that are more relevant to your work.

Taking a Guided Tour
First, you will get a chance to familiarize yourself with the AutoCAD screen and how
you communicate with AutoCAD. As you do these exercises, you will also get a feel for
how to work with this book. Don’t worry about understanding or remembering
everything that you see in this chapter. You will get plenty of opportunities to probe
the finer details of the program as you work through the later chapters. To help you
remember the material, you will find a brief exercise at the end of each chapter. For
now, just enjoy your first excursion into AutoCAD.

AutoCAD 2002 is designed for Windows 98, 2000, and XP. It is not designed to run on Windows 95.

If you have already installed AutoCAD, and you are ready to jump in and take a
look, then proceed with the following steps to launch the program:

1. Click the Start button in the lower-left corner of the Windows screen. Then
choose Program ➜ AutoCAD 2002 ➜ AutoCAD 2002. You can also double-
click the AutoCAD 2002 icon on your Windows Desktop.

2. The opening greeting, called a splash screen, tells you which version of Auto-
CAD you are using, to whom the program is registered, and the AutoCAD
dealer’s name and phone number, should you need help.
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3. Next, the AutoCAD 2002 Today dialog box appears. This dialog box is a con-
venient tool for setting up new drawings, posting messages to project team
members, or visiting the Autodesk PointA web site. You’ll learn more about
this tool in later chapters. For now, close the AutoCAD 2002 Today window.

Message to Veteran AutoCAD Users
AutoCAD, like many popular programs, is continually evolving. Quite often, that evolution forces us to change some
old and cherished habits.

If you’ve been using AutoCAD for a while, and you’ve grown accustomed to certain behaviors of AutoCAD, there are
certain steps you can take to make AutoCAD 2002 a more familiar environment.

You can, for example, restore the right-click function to the Enter (↵) key instead of the newer right-click menu. Here’s
how it’s done:

1. Click Tools ➜ Options….

2. Select the User Preference tab.

3. In the Windows Standard Behavior group, click the Right-Click Customization button.

4. In the Right-Click Customization dialog box, select the ENTER radio button in the Command Mode group, and
then click the Apply & Close button.

You may also want to turn on the Repeat Last Command option in both the Default Mode and Edit Mode groups of
the Right-Click Customization dialog box.

From
2000
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If you prefer to enter commands and command options through the keyboard instead of using dialog boxes, you can
do so for a number of commands. Here is a list of commands that normally produce a dialog box.

Bhatch Mtext

Block Osnap

Boundary Pan

Group Style

HatcheditImage Wblock

Layer Xbind

Linetype Xref

To use these commands from the command prompt, add a minus sign (–) to the beginning of the command name.
For example, to use the old Layer command, enter –layer at the command prompt. To use the old Pan command,
enter –pan at the command prompt. (By the way, when you enter –pan from the command prompt, the command
reverts to the “classic” method of panning in AutoCAD, where you click two points to indicate the direction and dis-
placement, instead of the “real time” pan that was introduced more recently. This “classic” method is useful when you
want to pan your view a specific distance as it allows you to enter the pan distance and direction.)

Even if you don’t care to enter commands from the keyboard, knowing about the use of the minus sign can help you
create custom macros. See Chapter 21 for more on AutoCAD customization.

Finally, when creating new files, you may prefer the older AutoCAD R14 Startup dialog box to the new AutoCAD 2002
Today dialog box. The Options dialog box offers a setting that lets you control the dialog box used for new file creation.
Here’s how to find that setting.

1. Click Tools ➜ Options.

2. In the Options dialog box, select the System tab.

3. In the General Options group, select Show Traditional Startup Dialog from the Startup drop-down list. A third
option in the Startup drop-down list is Do Not Show A Startup Dialog. If you select this third option, you’ll be
prompted to enter the name of a template file or ↵ for none.

4. Click OK.

The AutoCAD Window
The AutoCAD program window is divided into five parts:

• Pull-down menu bar
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• Docked and floating toolbars

• Drawing area

• Command window

• Status bar

A sixth hidden component, the Aerial View window, displays your entire drawing and lets you select close-
up views of parts of your drawing. After you’ve gotten more familiar with AutoCAD, consult Chapter 6 for
more on this feature.

Figure 1.1 shows a typical layout of the AutoCAD program window. Along the top
is the menu bar, and at the bottom are the Command window and the status bar. Just
below the menu bar and to the left of the window are the toolbars. The drawing area
occupies the rest of the screen. (By the way, your screen may show the drawing area in
black. You can set the drawing area background color using the Options dialog box.
Appendix B describes how this can be done. The figures in this book show the drawing
area background in white for clarity.)

Figure 1.1 A typical arrangement of the elements in the AutoCAD window

Properties toolbarStandard toolbarMenu Bar

Drawing Area

Draw toolbar

Tab selection arrows
Model and Layout tabs

Modify toolbar
Command window

Status bar
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Many of the elements in the AutoCAD window can be easily moved and reshaped.
Figure 1.2 demonstrates how different AutoCAD can look after some simple rearranging
of window components. Toolbars can be moved from their default locations to any loca-
tion on the screen. When they are in their default location, they are in their docked posi-
tion. When they are moved to a location where they are free-floating, they are floating.

Figure 1.2 An alternative arrangement of the elements in the AutoCAD window

The menu bar at the top of the drawing area (as shown in Figure 1.3) offers pull-
down menus from which you select commands in a typical Windows fashion. The tool-
bars offer a variety of commands through tool buttons and drop-down lists. For example,
the name or number of the layer that you are currently working on is displayed in a drop-
down list in the Object Properties toolbar. Preceding the layer name are icons for tools you
can use to work with the layer. The tools and lists on the toolbar are plentiful, and you’ll
learn more about all of them later in this chapter and as you work through this book.
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Figure 1.3 The components of the menu bar and the Standard toolbar

A layer is like an overlay that allows you to separate different types of information. AutoCAD allows an
unlimited number of layers. On new drawings, the default layer is 0. You’ll get a detailed look at layers
and the meaning of the Layer tools in Chapter 4.

The Draw and Modify toolbars (Figure 1.4) offer commands that create new
objects and edit existing ones. These are just two of many toolbars available to you.

Figure 1.4 The Draw and Modify toolbars as they appear when floating

The drawing area—your workspace—occupies most of the screen. Everything you
draw appears in this area. As you move your mouse around, crosshairs appear to move
within the drawing area. This is the drawing cursor that lets you point to locations in the
drawing area. At the bottom of the drawing area, the status bar (see Figure 1.5) gives you
information at a glance about the drawing. For example, the coordinate readout toward
the far left of the status line tells you the location of your cursor.

Standard Microsoft Office functions

Current colorLayer Properties Manager Current line weight
Current line typeCurrent or object layer

Pan and Zoom tools
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Figure 1.5 The status bar and Command window

A set of tabs gives you access to the Layout views of your drawing. These are views
that let you lay out your drawing as in a desktop publishing program. You’ll learn about
the Layout tabs in Chapter 7. The arrows to the left of the tabs let you navigate the tabs
when there are more tabs than can fit in the window. The Command window can be
moved and resized in a manner similar to toolbars. By default, the Command window
is in its docked position, shown here. Let’s practice using the coordinate readout and
drawing cursor.

Some AutoCAD users prefer to turn off the scrollbars to the right and at the bottom of the drawing area.
This allows you to maximize the size of the drawing area. Settings that control the scroll bars and other
screen-related functions can be found in the Options dialog box. See Appendix B for more information on
the Options dialog box. You can also gain some extra drawing space by clicking the Maximize button in the
upper-right corner of the drawing area.

Picking Points
Let’s practice using the coordinate readout and drawing cursor.

1. Move the cursor around in the drawing area. As you move, note how the coor-
dinate readout changes to tell you the cursor’s location. It shows the coordinates
in an X,Y,Z format.

2. Now place the cursor in the middle of the drawing area and press and imme-
diately release the left mouse button. You have just picked a point. Move the
cursor, and a rectangle follows. This is a selection window; you’ll learn more
about this window in Chapter 2.

Command window
Tab selection arrows

Model and Layout tabs

Status barCoordinate readout
Command prompt
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3. Move the cursor a bit in any direction; then press and let go of the left mouse
button again. Notice that the rectangle disappears.

4. Try picking several more points in the drawing area.

If you accidentally press the right mouse button, the shortcut menu appears. Since
AutoCAD 2000, a right mouse click frequently brings up a menu with options that are
context sensitive. This means that the contents of the shortcut menu depend on where
you right-click as well as the command that is active at the time of your right-click. If
there are no appropriate options at the time of the right-click, AutoCAD treats the right-
click as a ↵. You’ll learn more about these options as you progress through the book. For
now, if you happen to open this menu by accident, press the Esc key to dismiss it.

The ↵ symbol is used in this book to denote the Enter key. Whenever you see it, press the Enter key, also
known as the Return key.

The UCS Icon
In the lower-left corner of the drawing area, you see an L-shaped arrow. This is the User
Coordinate System (UCS) icon, which tells you your orientation in the drawing. This icon
becomes helpful as you start to work with complex 2D drawings and 3D models. The X
and Y arrows indicate the x- and y-axes of your drawing. The little square at the base of the
arrows tells you that you are in what is called the World Coordinate System. Chapter 16 dis-
cusses this icon in detail. For now, you can use it as a reference to tell you the direction of
the axes.

If You Can’t Find the UCS Icon…
The UCS icon can be turned on and off, so if you are on someone else’s system and you don’t see the icon, don’t panic.
It also changes shape depending on whether you are in Paper Space mode in the Layout tab or in Model Space mode!
If you don’t see the icon or it doesn’t look as it does in this chapter, see Understanding Model Space and Paper Space in
Chapter 12 for more information on Paper Space and Model Space. Chapter 16 can give you more information on the
UCS icon.

CHAPTER ONE • THIS IS AUTOCAD12
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The Command Window
At the bottom of the screen, just above the status bar, is a small horizontal window called
the Command window. Here AutoCAD displays responses to your input. It shows three
lines of text. The bottom line shows the current messages, and the top two lines show mes-
sages that have scrolled by or, in some cases, components of the current message that do
not fit in a single line. Right now, the bottom line displays the message Command (see
Figure 1.5). This prompt tells you that AutoCAD is waiting for your instructions. As you
click a point in the drawing area, you’ll see the message Other corner. At the same time,
the cursor starts to draw a selection window that disappears when you click another point.

As a new user, pay special attention to messages displayed in the Command window
because this is how AutoCAD communicates with you. Besides giving you messages, the
Command window records your activity in AutoCAD. You can use the scroll bar to the
right of the Command window to review previous messages. You can also enlarge the
window for a better view. (Chapter 2 discusses these components in more detail.)

You can think of the Command window as similar to the Address or Location input box found in web
browsers. It allows you to manually input data through the keyboard. It also tells you what’s going on in
the program. As you become more familiar with AutoCAD, you may find you don’t need to rely on the
Command window as much. For new users, however, the Command window can be quite helpful in
understanding what steps to take as you work.

Now let’s look at AutoCAD’s window components in detail.

The Pull-Down Menus
As in most Windows programs, the pull-down menus available on the menu bar offer an
easy-to-understand way to access the general controls and settings for AutoCAD. Within
these menus you’ll find the commands and functions that are the heart of AutoCAD. By
clicking menu items, you can cut and paste items to and from AutoCAD, change the set-
tings that make AutoCAD work the way you want it to, set up the measurement system
you want to use, access the help system, and much more.

To close a pull-down menu without selecting anything, press the Esc key. You can also click any other
part of the AutoCAD window or click another pull-down menu.

The pull-down menu options perform four basic functions:

• Display additional menu choices

• Display a dialog box that contains settings you can change
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• Issue a command that requires keyboard or drawing input

• Offer an expanded set of the same tools found in the Draw and Modify toolbars

As you point to commands and options in the menus or toolbars, AutoCAD provides
additional help for you in the form of brief descriptions of each menu option, which
appear in the status bar.

Here’s an exercise to let you practice with the pull-down menus and get acquainted
with AutoCAD’s interface:

1. Click View in the menu bar. The list of items that appears includes the commands
and settings that let you control the way AutoCAD displays your drawings. Don’t
worry if you don’t understand them yet; you’ll get to know them in later chapters.

2. Move the highlight cursor slowly down the list of menu items. As you highlight
each item, notice that a description of it appears in the status line at the bottom
of the AutoCAD window. These descriptions help you choose the menu option
you need.

3. Some of the menu items have triangular pointers to their right. This means the
command has additional choices. For instance, highlight the Zoom item, and
you’ll see another set of options appear to the right of the menu.

CHAPTER ONE • THIS IS AUTOCAD14
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If you look carefully at the command descriptions in the status bar, you’ll see an odd word at the end.
This is the keyboard command equivalent to the highlighted option in the menu or toolbar. You can actu-
ally type in these keyboard commands to start the tool or menu item that you are pointing to. You don’t
have to memorize these command names, but knowing them will be helpful to you later if you want to
customize AutoCAD.

This second set of options is called a cascading menu. Whenever you see a pull-down
menu item with the triangular pointer, you know that this item opens a cascading menu
offering a more detailed set of options.

You might have noticed that other pull-down menu options are followed by an
ellipsis (…). This indicates that the option brings up a dialog box, as the following
exercise demonstrates:

1. Move the highlight cursor to the Tools option in the menu bar.

If you prefer, you can click and drag the highlight cursor over the pull-down menu to select an option.

2. Click the Options item at the bottom of the menu. The Options dialog box
appears.

TAKING A GUIDED TOUR 15
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The Files tab of the Options dialog box works much like Windows Explorer. Clicking the plus sign to the
left of the items in the list expands the option to display more detail.

This dialog box contains several “pages,” indicated by the tabs across the top,
that contain settings for controlling what AutoCAD shows you on its screens,
where you want it to look for special files, and other “housekeeping” settings.
You needn’t worry about what these options mean at this point. Appendix B
describes the Options dialog box in more detail.

3. In the Options dialog box, click the tab labeled Open And Save. The options
change to reveal new options.

In the middle-left side of the dialog box, you’ll see a check box labeled Automatic
Save, with the Minutes Between Saves input box set to 120 minutes. This setting
controls how frequently AutoCAD performs an automatic save.

CHAPTER ONE • THIS IS AUTOCAD16
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4. Change the 120 to 20, and then click OK. You have just changed AutoCAD’s
Automatic Save feature to automatically save files every 20 minutes instead of
every two hours. (Let this be a reminder to give your eyes a rest!)

If you want to know more about the settings in the Options dialog box, check out Configuring AutoCAD
in Appendix A.

The third type of item you’ll find on pull-down menus is a command that directly
executes an AutoCAD operation. Let’s try an exercise to explore these commands.

1. Click the Draw option from the menu bar, and then click the Rectangle com-
mand. Notice that the Command window now shows the following prompt:

Specify first corner point or
[Chamfer/Elevation/Fillet/Thickness/Width]:

AutoCAD is asking you to select the first corner for the rectangle, and in
brackets, it is offering a few options that you can take advantage of at this point
in the command. Don’t worry about those options right now. You’ll have an
opportunity to learn about command options in Chapter 2.

2. Click a point roughly in the lower-left corner of the drawing area, as shown in
Figure 1.6. Now as you move your mouse, you’ll see a rectangle follow the cursor
with one corner fixed at the position you just selected.You’ll also see the following
prompt in the Command window:

Specify other corner point:

3. Click another point anywhere in the upper-right region of the drawing area. A
rectangle appears (see Figure 1.7). You’ll learn more about the different cursor
shapes and what they mean in Chapter 2.

At this point you’ve seen how most of AutoCAD’s commands work.You’ll find that
dialog boxes are offered when you want to change settings, while many drawing and edit-
ing functions present messages in the Command window. Also, be aware that many of
the pull-down menu items are duplicated in the toolbars, which you will explore next.
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Figure 1.6 Selecting the first point of a rectangle

Communicating with AutoCAD
AutoCAD is the perfect servant: It does everything you tell it to, and no more. You communicate with AutoCAD using
the pull-down menus and the toolbars. These devices invoke AutoCAD commands. A command is a single-word
instruction you give to AutoCAD telling it to do something, such as draw a line (the Line tool in the Draw toolbar) or
erase an object (the Erase tool in the Modify toolbar). Whenever you invoke a command, by either typing it in or
selecting a menu or toolbar item, AutoCAD responds by presenting messages to you in the Command window or by
displaying a dialog box.

The messages in the Command window often tell you what to do next, or they offer a list of options. A single com-
mand often presents several messages, which you answer to complete the command. These messages serve as an aid
to new users who need a little help. If you ever get lost while using a command, or forget what you are supposed to
do, look at the Command window for clues. As you become more comfortable with AutoCAD, you will find that you
won’t need to refer to these messages as frequently.

Click on a point
roughly here.
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As an additional aid,you can right-click to display a context-sensitive menu.If you are in the middle of a command and are not
selecting points,this menu offers a list of options specifically related to that command.For example, if you had right-clicked
your mouse before picking the first point for the rectangle command in the previous exercise,a menu would have appeared,
offering the same options that were listed in the command prompt,plus some additional options.

A dialog box is like a form you fill out on the computer screen. It lets you adjust settings or make selections from a set
of options pertaining to a command. You’ll get a chance to work with commands and dialog boxes later in this chapter.

Figure 1.7 Once you’ve selected your first point of the rectangle, you see a rectangle 
follow the motion of your mouse.

The Toolbars
While the pull-down menus offer a full range of easy-to-understand options, they
require some effort to navigate. The toolbars, on the other hand, offer quick, single-
click access to the most commonly used AutoCAD features. In the default AutoCAD
window arrangement, you see only the most commonly used toolbars. Other toolbars
are available but they are hidden from view until you open them.

Click on another
point here.
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The tools in the toolbars perform three types of actions, just like the pull-down
menu commands: They display further options, open dialog boxes, and issue commands
that require keyboard or cursor input.

The Toolbar Tool Tips
AutoCAD’s toolbars contain tools that represent commands. To help you understand
each tool, a tool tip appears just below the arrow cursor when you rest the cursor on a
tool. Each tool tip helps you identify the tool with its function. A tool tip appears when
you follow these steps:

1. Move the arrow cursor onto one of the toolbar tools and leave it there for a
second or two. Notice that the command’s name appears nearby—this is the
tool tip. In the status bar, a brief description of the button’s purpose appears
(see Figure 1.8).

2. Move the cursor across the toolbar. As you do, notice that the tool tips and status
bar descriptions change to describe each tool. The keyboard command equiva-
lent of the tool is also shown in the status bar at the end of the description.

Figure 1.8 Tool tips show you the function of each tool in the toolbar. AutoCAD also displays a
description of the tool in the status bar.

A typical tool tip

Toll description in the status bar
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Flyouts
Most toolbar tools start a command as soon as you click them, but other tools dis-
play a set of additional tools (similar to the menus in the menu bar) that are related
to the tool you have selected. This set of additional tools is called a toolbar flyout. If
you’ve used other Windows graphics programs, chances are you’ve seen flyouts.
Look closely at the tools just below the Express or Dimension pull-down menu
options on your screen or in Figure 1.8. You’ll be able to identify which toolbar tools
have flyouts; they’ll have a small right-pointing arrow in the lower-right corner of
the tool.

The following steps show you how a flyout works:

1. Move the cursor to the Zoom Window tool in the Standard toolbar. Click and
hold the left mouse button to display the flyout. Don’t release the mouse button.

2. Still holding down the left mouse button, move the cursor over the flyout;
notice that the tool tips appear here as well. Also, notice the description in the
status bar.

3. Move the cursor to the Zoom Window tool at the top of the flyout and release
the mouse button.

4. You don’t need to use this tool yet, so press the Esc key to cancel this tool.

As you can see from this exercise, you get a lot of feedback from AutoCAD!

Moving the Toolbars
One characteristic of AutoCAD’s toolbars is their mobility. They can be either float-
ing anywhere on the AutoCAD window or in a docked position. Docked means the
toolbar is placed against the top and side borders of the AutoCAD window, so that
the toolbar occupies a minimal amount of space. If you want to, you can move the
toolbar to any location on your desktop, thus turning it into a floating toolbar.
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Later in this section you’ll find descriptions of all of AutoCAD’s toolbars, but first
try the following exercise to move the Object Properties toolbar away from its current
position in the AutoCAD window.

1. Move the arrow cursor so that it points to the vertical bars, called grab bars, to
the far left of the Object Properties toolbar, as shown here:

2. Press and hold down the left mouse button. Notice that a gray rectangle
appears by the cursor.

3. Still holding down the mouse button, move the mouse downward. The gray
box follows the cursor.

4. When the gray box is over the drawing area, release the mouse button and the
Object Properties toolbar—now a floating toolbar—moves to its new location.

You can now move the Object Properties toolbar to any location on the screen that
suits you. You can also change the shape of the toolbar. Try the following steps:

1. Place the cursor on the bottom-edge border of the Object Properties toolbar.
The cursor becomes a double-headed arrow, as shown here:

2. Click and drag the border downward. The gray rectangle jumps to a new, taller
rectangle as you move the cursor.

3. When the gray rectangle changes to the shape you want, release the mouse
button to reshape the toolbar.

CHAPTER ONE • THIS IS AUTOCAD22
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4. To move the toolbar back into its docked position, place the arrow cursor on
the toolbar’s title bar and slowly click and drag so that the cursor is in position
in the upper-left corner of the AutoCAD window. Notice how the gray outline
of the toolbar changes as it approaches its docked position.

5. When the outline of the Object Properties toolbar is near its docked position,
release the mouse button. The toolbar moves back into its previous position in
the AutoCAD window.

You can also move a toolbar from a docked position to a floating one by double-clicking the toolbar’s
grab bar. Double-click the title bar of a floating toolbar to move the toolbar to its docked position.

You can move and reshape any of AutoCAD’s toolbars to place them out of the way
and still have them ready to give you quick access to commands. You can also put them
away altogether when you don’t need them and bring them back at will, as shown in
the following steps:

1. Click and drag the Draw toolbar from its position at the left of the AutoCAD
window to a point near the center of the drawing area. Remember to click and
drag the grab bars at the top of the toolbar.

2. Click the Close button in the upper-left corner of the Draw floating toolbar.
This is the small square button with the x in it. The toolbar disappears.

Terminology to Remember: Cascading Menu
When this book asks you to select an option from the pull-down menu, you will see the notation Menu ➜ Option. For
cascading menus, the notation will be Menu ➜ Option ➜ Option; the second ➜ Option is in a cascading menu. In
either case, the selected menu option issues a command that performs the function being discussed. As mentioned
earlier, the actual command name appears in the status bar when you point to a menu option or toolbar tool.
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3. To recover the Draw toolbar, right-click any toolbar—the Properties toolbar,
for example. A popup list of toolbars appears.

4. Locate and select Draw in the popup list of toolbars. The Draw toolbar reappears.

5. Click and drag the Draw toolbar back to its docked position in the far-left side
of the AutoCAD window.

AutoCAD remembers your toolbar arrangement between sessions. When you exit
and then reopen AutoCAD later, the AutoCAD window appears just as you left it.
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You may have noticed several other toolbars listed in the list of toolbars that don’t
appear in the AutoCAD window. To keep the screen from becoming cluttered, many of
the toolbars are not placed on the screen by default. The toolbars you’ll be using most
often are displayed first; others that are less frequently used are kept out of sight until
you need them and select them from the list. Here are brief descriptions of all the tool-
bars available:

3D Orbit Tools to control 3D views, introduced in AutoCAD 2000.

CAD Standards Tools that let you check the layer, dimension, and text styles
against standard that you have created.

Dimension Commands that help you dimension your drawings. Many of these
commands are duplicated in the Dimension pull-down menu. See Chapter 9.

Draw Commands for creating common objects, including lines, arcs, circles,
curves, ellipses, and text. This toolbar appears in the AutoCAD window by default.
Many of these commands are duplicated in the Draw pull-down menu.

Inquiry Commands for finding distances, point coordinates, object properties,
mass properties, and areas.

Insert Commands for importing other drawings, raster images, and OLE
objects.

Layouts Tools that let you set up drawing layouts for viewing, printing, and
plotting, introduced in AutoCAD 2000.

Modify Commands for editing existing objects. You can Move, Copy, Rotate,
Erase, Trim, Extend, and so on. Many of these commands are duplicated in the
Modify pull-down menu.

Modify II Commands for editing special complex objects such as polylines, mul-
tilines, 3D solids, and hatches.

Object Properties Commands for manipulating the properties of objects. This
toolbar is normally docked below the pull-down menu bar.

Object Snap Tools to help you select specific points on objects, such as endpoints
and midpoints. See Chapter 3.

Refedit Tools that allow you to make changes to symbols or background drawings
that are imported as external reference drawings; introduced in AutoCAD 2000. See
Chapter 12 for more about external references.
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Reference Commands that control cross-referencing of drawings. See Chapters 6
and 12.

Render Commands to operate AutoCAD’s rendering feature. See Chapter 17.

Shade Offers tools to control the way 3D models are displayed; introduced in
AutoCAD 2000. See Chapter 15 for more on Shade.

Solids Commands for creating 3D solids. See Chapter 18.

Solids Editing Command for editing 3D solids; introduced in AutoCAD 2000.
See Chapter 18.

Standard Toolbar The most frequently used commands for view control, file
management, and editing. This toolbar is normally docked below the pull-down
menu bar.

Surfaces Commands for creating 3D surfaces. See Chapters 15 and 16.

UCS Tools for setting up a plane on which to work. UCS stands for User Coordinate
System. This is most useful for 3D modeling, but it can be helpful in 2D drafting, as
well. See Chapter 16.

UCS II Tools for selecting from a set of predefined user coordinate systems;
introduced in AutoCAD 2000.

View Offers tools to control the way you view 3D models; introduced in 
AutoCAD 2000. See Chapter 15 for more on 3D views.

Viewports Tools that let you create and edit multiple views to your drawing. See
Chapter 12 for more about viewports.

Web Tools for accessing the World Wide Web, as discussed in Chapter 24;
introduced in AutoCAD 2000.

Zoom Commands that allow you to navigate your drawing.

You’ll get a chance to work with all of the toolbars over the course of this book. If you
use the book simply as a reference, be sure to read through the exercises for explanations
of which tools to use for specific operations.
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Menus versus the Keyboard
Throughout this book, you will be told to select commands and command options from the pull-down menus and
toolbars. For new and experienced users alike, menus and toolbars offer an easy-to-remember method for accessing
commands. If you are an experienced AutoCAD user who is used to the earlier versions of AutoCAD, you still have the
option of entering commands directly from the keyboard. Most of the commands you know and love still work as they
did from the keyboard.

Another method for accessing commands is to use accelerator keys, which are special keystrokes that open and activate
pull-down menu options. You might have noticed that the commands in the menu bar and the items in the pull-down
menus all have an underlined character. By pressing the Alt key followed by the key corresponding to the underlined
character, you activate that command or option, without having to engage the mouse. For example, to issue File ➜
Open, press Alt, then F, and then finally O (Alt+F+O).

Many tools and commands have keyboard shortcuts; shortcuts are one-, two-, or three-letter abbreviations of a command
name. As you become more proficient with AutoCAD, you may find these shortcuts helpful. As you work through this book,
the shortcuts will be identified for your reference.

Finally, if you are feeling adventurous, you can create your own accelerator keys and keyboard shortcuts for executing
commands by adding them to the AutoCAD support files. Chapter 21 discusses customization of the menus, toolbars,
and keyboard shortcuts.

Working with AutoCAD
Now that you’ve been introduced to the AutoCAD window, let’s try using a few of
AutoCAD’s commands. First, you’ll open a sample file and make a few simple modi-
fications to it. In the process, you’ll become familiar with some common methods of
operation in AutoCAD.

Opening an Existing File
In this exercise, you will get a chance to see and use a typical Select File dialog box. To
start with, you will open an existing file.

1. From the menu bar, choose File ➜ Close. A message appears asking you if you
want to save the changes you’ve made to the current drawing. Click No.
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2. Choose File ➜ Open. The Select File dialog box appears. This is a typical Win-
dows file dialog box, with an added twist. The large Preview box on the right
allows you to preview a drawing before you open it, thereby saving time while
searching for files. To the left is a panel known as the Places List where you can
find frequently used locations on your computer or the Internet.

If you don’t see a Preview box in the AutoCAD File dialog box, click the word View in the upper-right corner,
and then select Preview from the list that appears.

3. In the Select File dialog box, open the Look In drop-down list and locate the
directory named Figures (you may need to explore the list to find it). The file
list changes to show the contents of the Figures directory.

4. Move the arrow to the file named Nozzle3d and click it. Notice that the Noz-
zle3d.dwg filename now appears in the File Name input box above the file
list. Also, the Preview box now shows a thumbnail image of the file.

The Nozzle3D drawing is included on the companion CD-ROM. If you cannot find this file, be sure you
have installed the sample drawings from the companion CD-ROM. See the Readme file on the CD-ROM
for installation instructions.
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5. Click the OK button at the bottom of the Select File dialog box. AutoCAD
opens the Nozzle3d file, as shown in Figure 1.9.

Figure 1.9 In the early days, this nozzle drawing became the unofficial symbol of 
AutoCAD, frequently appearing in ads for AutoCAD third-party products.

The Nozzle3d file opens to display the entire drawing. Also, the AutoCAD win-
dow’s title bar displays the name of the drawing. This offers easy identification of the
file. This particular file contains both a 2D and a 3D model of a fire-hose nozzle. The
opening view is actually a 3D view.

Getting a Closer Look
One of the most frequently used commands is Zoom, which gives you a closer look at a
part of your drawing. It offers a variety of ways to control your view. Now you’ll enlarge
a portion of the nozzle drawing to get a more detailed look. To tell AutoCAD what area
you wish to enlarge, you use what is called a zoom window.
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1. Choose View ➜ 3D Views ➜ Plan View ➜ World UCS.Your view changes to
display a two-dimensional view looking down on the drawing.

2. Click the Zoom Window button on the Standard toolbar.

You can also choose View ➜ Zoom ➜ Window from the pull-down menu or
type the command: Z↵ W↵.

3. The Command window displays the First corner: prompt. Look at the top
image of Figure 1.10. Move the crosshair cursor to a location similar to the one
shown in the figure; then left-click the mouse. Move the cursor and the rectangle
appears, with one corner fixed on the point you just picked, while the other cor-
ner follows the cursor.

4. The Command window now displays the Specify first corner: and Spec-
ify opposite corner: prompts. Position the other corner of the window so
it encloses the handle of the nozzle, as shown in the top image of Figure 1.10,
and left-click the mouse again. The handle enlarges to fill the screen (see the
bottom image of Figure 1.10).

If you decide that you don’t like the position of the first point you pick while defining the zoom window,
you can right-click the mouse, then re-select the first point. This only works when you enter Z↵ W↵ to
issue the Zoom Window command or when you select Zoom Window from the Standard toolbar.

In this exercise, you used the Window option of the Zoom command to define an
area to enlarge for your close-up view. You saw how AutoCAD prompts you to indicate
first one corner of the selection window and then the other. These messages are helpful
for first-time users of AutoCAD. You will use the Window option frequently—not just
to define views, but also to select objects for editing.
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Figure 1.10 Placing the Zoom window around the nozzle handle. After clicking the Zoom
Window button in the Standard toolbar, select the two points shown in the top image to
zoom as shown in the bottom image.

Getting a close-up view of your drawing is crucial to working accurately, but you’ll
often want to return to a previous view to get the overall picture. To do so, click the
Zoom Previous button on the Standard toolbar.
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Do this now, and the previous view—one showing the entire nozzle—returns to the
screen. You can also get there by choosing View ➜ Zoom ➜ Previous.

You can quickly enlarge or reduce your view using the Zoom Realtime button on the
Standard toolbar.

You can also zoom in and out using the Zoom In and Zoom Out buttons in the Zoom Window flyout of the
Standard toolbar. The Zoom In button shows a magnifying glass with a plus sign; the Zoom Out button
shows a minus sign. If you have a mouse equipped with a scroll wheel, you can zoom in and out just by
turning the wheel. The location of the cursor at the time you move the wheel will determine the center of
the zoom. A click-and-drag of the scroll wheel will let you pan your view.

1. Click the Zoom Realtime button on the Standard toolbar.

The cursor changes into a magnifying glass.

2. Place the Zoom Realtime cursor slightly above the center of the drawing area,
and then click and drag downward. Your view zooms out to show more of the
drawing.

3. While still holding the left mouse button, move the cursor upward. Your view
zooms in to enlarge your view. When you have a view similar to the one shown
in Figure 1.11, release the mouse button. (Don’t worry if you don’t get exactly
the same view as the figure. This is just for practice.) 
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Figure 1.11 The final view you want to achieve in step 3 of the exercise

4. You are still in Zoom Realtime mode. Click and drag the mouse again to see
how you can further adjust your view. To exit, you can select another com-
mand besides a Zoom or Pan command, press the Esc key, or right-click your
mouse.

5. Right-click now. A shortcut menu appears.

This menu lets you select other display-related options.

6. Click Exit from the popup menu to exit the Zoom Realtime command.
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As you can see from this exercise, you have a wide range of options for viewing
your drawings, just by using a few buttons. In fact, these three buttons, along with the
scroll bars at the right side and bottom of the AutoCAD window are all you need to
control the display of 2D drawings.

The Aerial View Window
The Aerial View window is an optional AutoCAD display tool. It gives you an overall view of your drawing, regardless
of the magnification you are using for the drawing editor. Aerial View also makes it easier to get around in a large-
scale drawing. You’ll find that this feature is best suited to complex drawings that cover great areas, such as site plans,
topographical maps, or city planning documents.

You’ll find a detailed description of the Aerial View window in Chapter 6. As you become more comfortable with
AutoCAD, you may want to try it out.

Saving a File As You Work
It is a good idea to save your file periodically as you work on it. You can save it under its
original name (with File ➜ Save) or under a different name (with File ➜ Save As),
thereby creating a new file.

By default, AutoCAD automatically saves your work at 120-minute intervals under
the name AUTO.SV$; this is known as the Automatic Save feature. Using settings in the
Options dialog box or system variables, you can change the name of the autosaved file
and control the time between autosaves. See the Using AutoCAD’s Automatic Save Feature
sidebar in Chapter 3 for details.

Let’s first try the Save command. This quickly saves the drawing in its current state
without exiting the program.

Choose File ➜ Save. You will notice some disk activity while AutoCAD saves the
file to the hard disk and you’ll see a progress indicator in the status bar. As an alterna-
tive to choosing File ➜ Save from the menu, you can press Alt+F S. This is the accelera-
tor key combination, also called hotkey, for the File ➜ Save command.
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Now try the Save As command. This command brings up a dialog box that allows
you to save the current file under a new name.

1. Choose File ➜ Save As, or type Saveas↵ at the command prompt. The Select
File dialog box appears. Note that the current filename, Nozzle3d.dwg, is
highlighted in the File Name input box at the bottom of the dialog box.

2. Type Myfirst. As you type, the name Nozzle3d disappears from the input box
and is replaced by Myfirst.You don’t need to enter the .dwg filename extension.
AutoCAD adds it to the filename automatically when it saves the file.

3. Click the Save button. The dialog box disappears, and you will notice some
disk activity.

You now have a copy of the nozzle file under the name Myfirst.dwg. The name of
the file displayed in the AutoCAD window’s title bar has changed to Myfirst. From now
on, when you use the File ➜ Save option, your drawing will be saved under its new
name. Saving files under a different name can be useful when you are creating alterna-
tives or when you just want to save one of several ideas you have been trying out.

If you are working with a small monitor, you may want to consider closing the Draw and Modify toolbars.
The Draw and Modify pull-down menus offer the same commands, so you won’t lose any functionality by
closing these toolbars. If you really want to maximize your drawing area, you can also turn off the scroll
bars and reduce the Command window to a single line. Appendix B shows how to do this.

Making Changes
You will frequently make changes to your drawings. In fact, one of AutoCAD’s chief
advantages is the ease with which you can make changes. The following exercise shows
you a typical sequence of operations involved in making a change to a drawing:

1. From the Modify toolbar, click the Erase tool (the one with a pencil eraser touch-
ing paper). This activates the Erase command.You can also choose Modify ➜
Erase from the pull-down menu.
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Notice that the cursor has turned into a small square; this square is called the
pickbox. You also see Select object: in the command prompt area. This
message helps remind new users what to do.

2. Place the pickbox on the diagonal pattern of the nozzle handle (see Fig-
ure 1.12) and click it. The 2D image of the nozzle becomes highlighted. The
pickbox and the Select object: prompt remain, telling you that you can
continue to select objects.

3. Now press ↵. The nozzle and the rectangle disappear. You have just erased a
part of the drawing.

Figure 1.12 Erasing a portion of the nozzle handle

In this exercise, you first issued the Erase command, and then selected an object by
clicking it using a pickbox. The pickbox tells you that you must select items on the
screen. Once you’ve done that, press ↵ to move on to the next step. This sequence of
steps is common to many of the commands you will work with in AutoCAD.

The Select Object pickbox
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Opening Multiple Files
Beginning with AutoCAD 2000, you can now have multiple documents open at the
same time. This can be especially helpful if you want to exchange parts of drawings
between files or if you just want to have another file open for reference. Try the follow-
ing exercise to see how multiple documents work in AutoCAD:

1. Choose File ➜ New.

2. In the AutoCAD 2002 Today dialog box, make sure the Create Drawings tab is
selected, and then select the Start From Scratch option from the Select How To
Begin drop-down list.

3. Move the cursor over the English (feet and inches) option. Notice that as you
move the cursor over the option, you see a brief description of the option’s
purpose in the dialog box.

4. Click the English (feet and inches) option just below the drop-down list. A
new, blank file appears.

5. Choose Window ➜ Tile Vertically to get a view of both drawing files. The
options in the Window pull-down menu act just like their counterparts in
other Windows programs that allow multiple document editing.

From
  R14
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You can now see both of the files you have open. Let’s see what can be done with these
two files.

1. Click in the window with the Nozzle3d drawing to make it active.

2. Choose View ➜ Zoom ➜ All to get an overall view of the drawing.

3. Click the words Nozzle 1984 near the bottom of the drawing.

4. Click and drag on the words Nozzle 1984. You’ll see a small rectangle appear
next to the cursor.

5. While still holding the left mouse button, drag the cursor to the new file window.
When you see the words Nozzle 1984 appear in the new drawing window,
release the mouse button.You’ve just copied a text object from one file to another.

Now you have two files open at once.You can have as many files open as you want, as
long as you have adequate memory to accommodate them.You can control the individ-
ual document windows as you would any window, using the Window pull-down menu
or the window control buttons in the upper-right corner of the document window.

Closing AutoCAD
When you are done with your work on one drawing, you can open another drawing,
temporarily leave AutoCAD, or close AutoCAD entirely. To close all the open files at once
and exit AutoCAD, use the Exit option on the File menu.

From
  R14
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1. Choose File ➜ Exit, the last item in the File menu. A dialog box appears, asking
you if you want to “Save Changes to Myfirst.dwg?” and offering three buttons
labeled Yes, No, and Cancel.

2. Click the No button.

3. AutoCAD displays another message asking you if you want to save Drawing2.dwg,

which is the new drawing you opened in the last exercise. Click the No button again.
AutoCAD closes both the nozzle drawing and the new drawing and exits without
saving your changes.

Whenever you attempt to exit a drawing that has been changed, you get this same
inquiry box. This request for confirmation is a safety feature that lets you change your
mind and save your changes before you exit AutoCAD. In the previous exercise, you
discarded the changes you made, so the nozzle drawing reverts back to its state before
you erased the handle. The new drawing is completely discarded and no file is saved.

If you only want to exit AutoCAD temporarily, you can minimize it so it appears as
a button on the Windows 98 or Windows NT 4 toolbar. You do this by clicking the
Minimize button in the upper-right corner of the AutoCAD window; the Minimize
button is the title-bar button that looks like an underscore (_). Alternatively, you can
use the Alt+Tab key combination to switch to another program.

If You Want to Experiment…
Try opening and closing some of the sample drawing files on the accompanying
CD-ROM.

1. Start AutoCAD by choosing Start ➜ Programs ➜ AutoCAD 2002 ➜ Auto-
CAD 2002.

2. Close the AutoCAD 2002 Today window, and then click File ➜ Open.
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3. Use the dialog box to open the Myfirst file again. Notice that the drawing
appears on the screen with the handle enlarged. This is the view you had on
screen when you used the Save command in the earlier exercise.

4. Erase the handle, as you did in the earlier exercise.

5. Click File ➜ Open again. This time, open the Dhouse file from the Figures
folder. The 3D Dhouse drawing opens.

6. Click File ➜ Exit. Notice that you exit AutoCAD without getting the Save
Changes dialog box for the Dhouse drawing. This is because you didn’t make
any changes to the Dhouse file.
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