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U nlike most discussions of web services that begin with an examination of the underlying
network protocols, this chapter sets aside the underlying details and lets you test drive a

variety of web services that other developers have created and made available on the Web.
You will first experience many of the web services by using your browser to view active server
pages that use the web service to implement their processing. Then, after you understand the
operation the service performs, you will create a program that puts the service to use.

This chapter’s goal is to give you a hands-on understanding of the types of web services
you can create. This chapter makes extensive use of the Microsoft Visual Studio .NET pro-
gramming environment to create programs that access the web services. You can take advan-
tage of web services using several programming languages. This chapter presents programs
and ASP.NET pages written in Visual Basic .NET and C#. If you are not yet programming
within the .NET environment, the ease with which Visual Studio .NET lets you integrate
web services into your programs should provide you with motivation to migrate to .NET.

In Chapter 2, “Creating Your First Web Services,” you will learn that Visual Studio .NET
also makes it easy for you to create your own web services. In Chapter 3, “Accessing Web
Services from within HTML Pages,” you will learn how to create HTML pages that interact
with web services from within Visual Basic and applications that incorporate Visual Basic,
such as Word and Excel. In later chapters, you will learn how to create and interact with web
services using other programming languages such as Java and Perl.

What’s a Web Service?
To break complex programs into manageable tasks, programmers make extensive use of func-
tions. Each function within a program should perform specific processing (a service). For
example, the following C program, Hello.c, uses the printf function to display a message to
the user:

#include <stdio.h>

void main(void)
{
printf(“Hello, Programming World”);

}

In a similar way, the following Visual Basic .NET code fragment, from the program Dis-
playDateTime.vb, uses the Now and MessageBox.Show functions to retrieve and then display
the current date and time and the Close function to close the current form:

Private Sub Form1_Load(ByVal sender As Object, ByVal e As _
➥ System.EventArgs) Handles MyBase.Load

Chapter 1 • Taking Web Services for a Test Drive
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MessageBox.Show(“Current Date and time is: “ & Now(), _
“Display Date & Time”)

Me.Close()
End Sub

Think of a web service as a function your programs can use to accomplish specific tasks. Just
as a function can receive (and possibly change) parameter values, so too can a web service.
Likewise, just as functions often return a value to the calling program, so too can a web service.

To use a function such as printf or MessageBox.Show, you must know the type of value the
function returns as well as the number and types of parameters you can pass to the function.
The same is true for a web service.

What makes a web service different from a traditional function is that the code for the web
service resides on a remote server. Before a program can use a web service, the PC running
the program must have a network connection (a dial-up connection will suffice).

When your program calls a web service (using a function call), your program, as shown in
Figure 1.1, will send a network message to the server that specifies the desired service. If the
web service requires parameters, the message will include values for each.

After the server completes the web service’s processing, the server, as shown in Figure 1.2,
will send a network message containing the service’s result back to your program.

ServerClient

Result

F I G U R E 1 . 2 :
After the server exe-
cutes the web ser-
vice’s instructions, the
server will send a net-
work message contain-
ing the service’s result
to the calling program.

ServerClient

Web Service
Method

Parameters

Web
Service
Code

F I G U R E 1 . 1 :
To call a web service, a
program sends a net-
work message to the
server upon which the
web service resides.
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Because a web service requires the exchange of network messages and because the server
that executes the service may be busy performing other tasks, a web service will execute 
substantially slower than a standard function. Depending on factors such as network traf-
fic, the amount of time a web service will require may vary from one use of the service to
the next.

Understanding Operations That Are Well Suited for Web Services
Because network overhead makes a web service execute much slower than a standard func-
tion, many operations are not well suited for implementation as a web service. Using a web
service to add two numbers, for example, or to calculate a random number, would introduce
unnecessary overhead to a program. Such operations are better suited for implementation
using standard functions.

Web services, in contrast, are ideal for operations that use data residing at a remote source
(most often within a database on a specific server). For example, web services are well suited
for the following operations:

● Responding to queries for stock quotes

● Returning information regarding the availability of specific inventory items

● Providing real-time information, such as weather and road conditions

● Offering airline flight arrival and departure information

● Implementing e-commerce operations, such as ticket sales for movies and 
special events

● Authenticating users or credit-card information

You may be saying to yourself that users already perform such operations on many sites
across the Web. Web services provide programmers with a way to integrate these operations
into their programs. By using web services to implement common user operations (such as
downloading stock quotes, ordering a book, and checking the weather) within your com-
pany’s website, you can keep users from leaving your website to perform these operations
elsewhere. By taking advantage of web services, you can integrate powerful processing devel-
oped by other programmers into your applications and web pages.

To help you better understand how web services extend the functionality of the Web into
your applications, the remainder of this chapter will let you test drive readily available web
services.

Chapter 1 • Taking Web Services for a Test Drive
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Web Service Updates from This Book’s Companion Website
The examples this chapter presents make use of web services existing on the Web at the
time of this writing. Over time, the services this chapter presents may change or become
unavailable. This book’s companion website, which you can find by following the links at
www.sybex.com, will provide updates to the chapter code as the services change.

From the companion website, you can download the source code for all of the programs and
services this book presents. You will find links to other key web development sites too.

Retrieving Weather Information
Each day millions of web users look up weather information. Across the Web, some of the
fastest growing websites provide specifics about weather. The HTML file ShowWeather.html,
which you can find at this book’s companion website, creates a form that prompts the user to
enter a zip code, city and state, or an Internet protocol (IP) address. After the user enters the
data and clicks the Submit button, the user’s browser sends the user input to an ASP.NET
page that uses a Web service residing on the ServiceObjects website. The FastWeather web
service will provide the ASP.NET page with weather data for a specific location. After the
ASP.NET page receives the data from the service, it will display the result, as shown in
Figure 1.3.

F I G U R E 1 . 3 :
Using a web service to
obtain weather data

Retrieving Weather Information
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NOTE The ServiceObjects website provides several powerful web services you can immediately inte-
grate into your applications. Take time now to visit the site at www.ServiceObjects.com.

Looking Behind the Scenes at the FastWeather Web Service
To use the FastWeather web service, programs can call one of three methods (functions),
passing to the methods the corresponding parameters:

string GetWeatherByIP(string IP, string LicenseKey)
string GetWeatherByCityState(string City, string State, string LicenseKey)
string GetWeatherByZip(string Zip, string LicenseKey)

Each of the functions, if successful (meaning the program provided a valid IP address, zip
code, or city and state combination), will return a structure of type Weather that contains the
following fields:

Weather
string LastUpdated
string TemperatureF
string WindChill
string HeatIndex
string Humidity
string Dewpoint
string Wind
string Pressure
string Conditions
string Visibility
string Sunrise
string Sunset
string City
string State
string Moonrise
string Moonset
string Error

Note also that each of the FastWeather web service methods requires that you pass a 
parameter that specifies your license key. If you visit the ServiceObjects website, you can
download a trial key that lets you use the service for a specific period of time. If you need
unlimited use of the service, you must purchase a license for service from ServiceObjects.
The GetWeather.aspx ASP.NET page uses the license key 0, which provides limited use of
the service.

The source code in Listing 1.1 implements the ASP.NET page GetWeather.aspx.

Chapter 1 • Taking Web Services for a Test Drive
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➲ Listing 1.1 GetWeather.aspx

Public Class WebForm1
Inherits System.Web.UI.Page

#Region “ Web Form Designer Generated Code “
‘ Code not shown.

#End Region

Private Sub Page_Load(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles MyBase.Load
Dim Zip, City, State, IP As String
Dim WebError As Boolean = False
Dim QueryPerformed As Boolean = True

Zip = Request.Form(“ZipCode”)
City = Request.Form(“City”)
State = Request.Form(“State”)
IP = Request.Form(“IP”)

Dim WeatherRequest As New net.serviceobjects.ws.FastWeather()
Dim Weather As net.serviceobjects.ws.Weather

Try
If (Zip <> “”) Then
Response.Write(“Weather conditions for “ & Zip)
Weather = WeatherRequest.GetWeatherByZip(Zip, 0)

ElseIf (City <> “”) And (State <> “”) Then
Response.Write(“Weather conditions for “ & City & _

➥ “ “ & State)
Weather = WeatherRequest.GetWeatherByCityState(City, _

➥ State, 0)
ElseIf (IP <> “”) Then
Response.Write(“Weather conditions for “ & IP)
Weather = WeatherRequest.GetWeatherByIP(IP, 0)

Else
Response.Write(“Must specify valid location”)
QueryPerformed = False

End If

Catch Ex As Exception
Response.Write(“Web service error: “ & Ex.Message)
WebError = True

End Try

If (Not WebError And QueryPerformed) Then
If (Weather.Error = “”) Then
Response.Write(“<br/>”)
Response.Write(“Temperature (F): “ & _
Weather.TemperatureF & “<br/>”)

Retrieving Weather Information
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Response.Write(“Conditions: “ & Weather.Conditions)
Else
Response.Write(“<br/>”)
Response.Write(“Web service returned an error: “ & _

➥ Weather.Error)
End If

End If

End Sub

End Class

As you can see, the code first uses the Request object to determine the values the user
assigned to the zip code, city, state, or IP fields. To use a web service, a program must create
an object specific to the service. The following statement creates a variable named Weather-
Request that corresponds to the FastWeather service:

Dim WeatherRequest As New net.serviceobjects.ws.FastWeather()

Throughout this chapter, you will create similar objects for the different web services. The
object name, in this case net.serviceobjects.ws.FastWeather, identifies the web service. 
As you will see when you create a C# program that uses the FastWeather web service, Visual
Studio .NET makes it easy for you to determine the object name.

As discussed, the FastWeather web service returns a value of type Weather that contains the
individual weather fields. The following statement defines a variable to store the Weather
structure:

Dim Weather As net.serviceobjects.ws.Weather

To use a web service, you simply call one of the methods the service provides. In this case,
the code uses an If-Else statement to determine which method to call based on whether the
user specified a zip code, city and state, or IP address. The following statement, for example,
calls the service’s GetWeatherByZipCode method:

Weather = WeatherRequest.GetWeatherByZip(Zip, 0)

Note that the code calls the web service methods within a Try-Catch block. Most web ser-
vices will generate an exception when an error occurs. When your programs call a web ser-
vice, they should always do so within a Try-Catch block so your code can detect and respond
to an exception generated by the service.

The application uses an ASP.NET page, as opposed to an active server page, because of the
ease with which Visual Studio .NET lets developers integrate a web service.

Chapter 1 • Taking Web Services for a Test Drive
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Retrieving Weather Information within a C# Program
Web services exist to help programmers integrate web-based operations into their programs.
The Visual Basic .NET program, TexasWeather.vb, displays a form that contains buttons
corresponding to Texas cities. After the user clicks a button, the program displays the corre-
sponding weather data, as shown in Figure 1.4.

In this case, the program uses only the FastWeather service’s GetWeatherByCityState
method. To create the TexasWeather.vb program, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual C# Projects. Then,
within the Templates field, click Windows Application. Finally, within the Location field,
specify the folder within which you want to store the program and the program name
TexasWeather. Select OK. Visual Studio .NET will display a form onto which you can
drag and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text box previously shown in
Figure 1.4 onto the form.

4. To use a web service, you must assign a Web Reference to the program that corresponds
to the object. To do so, select the Project menu Add Web Reference option. Visual Studio
.NET will display the Add Web Reference dialog box, as shown in Figure 1.5.

NOTE Over time, the URLs this book uses (such as the one in Step 5) for the WSDL (web service
definition language) files that describe a web service may change. See the section “Using
a Web Service 101” to determine the URL you should enter for a service’s WSDL file
within the Add Web Reference dialog box.

F I G U R E 1 . 4 :
Using the FastWeather
web service within a
Visual Basic .NET 
program

Retrieving Weather Information
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5. Within the Address field, you must type the URL of a special file (called the WSDL file)
that describes the web service. In this case, type http://ws.serviceobjects.net/fw/
FastWeather.asmx?WSDL and press Enter. The dialog box will load the file’s contents.
Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Within the source code (near the bottom of the GetWeather class definition), add
the following program statements:

private void GetWeather(String City, String State)
{

Boolean WebError = false;

net.serviceobjects.ws.FastWeather WeatherRequest;
net.serviceobjects.ws.Weather Weather = null;
WeatherRequest = new net.serviceobjects.ws.FastWeather();

try
{
Weather = WeatherRequest.GetWeatherByCityState(City, _

➥ State, “0”);
}
catch (Exception Ex)

F I G U R E 1 . 5 :
The Add Web Refer-
ence dialog box 
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{
textBox1.Text = “Web service error: “ + Ex.Message;
WebError = true;

}

if (! WebError)
{
if (Weather.Error == null)
{
textBox1.Text = “Location: “ + Weather.City + “\r\n”;
textBox1.Text = “Temperature (F): “ + _

➥ Weather.TemperatureF + “\r\n”;
textBox1.Text += “Conditions: “ + _

➥ Weather.Conditions + “\r\n”;
textBox1.Text += “Dewpoint: “ + Weather.Dewpoint + “\r\n”;
textBox1.Text += “Heat Index: “ + _

➥ Weather.HeatIndex + “\r\n”;
textBox1.Text += “Humidity: “ + Weather.Humidity + “\r\n”;
textBox1.Text += “Moon rise: “ + Weather.Moonrise + _

➥ “\r\n”;
textBox1.Text += “Moon set: “ + Weather.Moonset + “\r\n”;
textBox1.Text += “Pressure: “ + Weather.Pressure + “\r\n”;
textBox1.Text += “Sun rise: “ + Weather.Sunrise + “\r\n”;
textBox1.Text += “Sun set: “ + Weather.Sunset + “\r\n”;
textBox1.Text += “Visibility: “ + Weather.Visibility + _

➥ “\r\n”;
textBox1.Text += “Wind: “ + Weather.Wind + “\r\n”;
textBox1.Text += “Wind chill: “ + Weather.Windchill;

}
else
textBox1.Text = “Web service returned an error: “ + _

➥ Weather.Error;
}

}

private void Form1_Load(object sender, System.EventArgs e)
{

}

private void button1_Click(object sender, System.EventArgs e)
{

GetWeather(“Dallas”, “TX”);
}

private void button2_Click(object sender, System.EventArgs e)
{

Retrieving Weather Information
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GetWeather(“Houston”, “TX”);
}

private void button3_Click(object sender, System.EventArgs e)
{

GetWeather(“San Antonio”, “TX”);
}

private void button4_Click(object sender, System.EventArgs e)
{

GetWeather(“Waco”, “TX”);
}
}
}

The program provides an event handler that responds to each user button click. Within
each handler, the code calls the GetWeather function, passing to the function the name of a
specific city and the TX state abbreviation. Within the GetWeather function, the following
statements create an object named WeatherRequest that the program will use to access the
FastWeather web service:

net.serviceobjects.ws.FastWeather WeatherRequest;
WeatherRequest = new net.serviceobjects.ws.FastWeather();

Again, the FastWeather web service returns a value of type Weather. The following state-
ment creates a variable that will hold the specific weather fields:

net.serviceobjects.ws.Weather Weather = null;

The program calls the web service method GetWeatherByCityState within a try-catch block
to detect any exceptions the web service may generate:

try
{
Weather = WeatherRequest.GetWeatherByCityState(City, _

➥ State, “0”);
} 
catch (Exception Ex)
{
textBox1.Text = “Web service error: “ + Ex.Message;

WebError = true;
}

Finally, if the web service is successful, the code displays the various weather elements within
a text box.

Chapter 1 • Taking Web Services for a Test Drive
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Using a Web Service 101
Using a web service within a .NET program is a straightforward process. To begin, you must
add to the program a Web Reference that corresponds to the web service. To do so, you must
know the location of the WSDL file that describes the web service.

If you examine websites that make web services available to programmers, you will find
that the sites always contain a link to the web service’s WSDL file. If you click the link,
your browser will display XML-based data that describe the service, similar to that shown in
Figure 1.6. XML, as you know, is the Extensible Markup Language that developers use to
describe data. Throughout this book, you will make extensive use of WSDL, the web service
definition language. For now, think of WSDL as providing a description of the methods
(functions) a web service provides, as well as a description of the parameters each method
requires.

For now, you can ignore the XML statements that describe the service. Instead, note the
Web address that appears within the browser’s address field. You can either write down the
address or cut and paste the address into the Visual Studio .NET Add Web Reference dia-
log box.

F I G U R E 1 . 6 :
Viewing a web ser-
vice’s WSDL file

Using a Web Service 101
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After you add a Web Reference to your program code for the web service, you must then cre-
ate a corresponding object within your source code. The following statement creates an object
that a Visual Basic .NET program can use to interact with the FastWeather web service:

Dim WeatherRequest As New net.serviceobjects.ws.FastWeather()

After you add a service’s Web Reference to your program, Visual Studio .NET will display
the reference within the Class View window. As you view the web services within the Class
View window, you will find that most web service object names will begin with letter combi-
nations such as net. If you simply type the first two letters of the name, Visual Studio .NET
usually will display the service’s remaining characters, making it very easy for you to enter the
correct object names.

Regardless of the web service you want to use from within a .NET program and regardless
of whether you are writing the program using Visual Basic .NET and C# or if you are creat-
ing an ASP.NET page, the steps you will perform are the same. If your code requires multi-
ple web services, you must perform these steps for each object.

Retrieving Stock Quotes
Across the Web, many websites offer users the ability to retrieve stock information for a specific
company. To comply with securities regulations, the stock information is delayed by 15 minutes.

The StockQuote web service, available from the XMethods website at www.xmethods.com,
retrieves delayed stock prices for the company that corresponds to a stock symbol, such as
MSFT for Microsoft.

NOTE The XMethods website at www.xmethods.com provides many web services you can inte-
grate into your applications. Take time to visit the XMethods website—you will likely find
several web services you can put to immediate use.

The ASP.NET page StockPrice.aspx, which you can run from this book’s companion web-
site, displays the form shown in Figure 1.7 that contains buttons corresponding to several
software companies. When the user clicks a button, the page will display the company’s
(delayed) stock price.

Looking Behind the Scenes at the StockQuote Web Service
The StockQuote web service supports one method, getQuote, which returns a value of type
Float that corresponds to a company’s stock price. Your programs pass the stock symbol,
such as MSFT for Microsoft, to the method as a parameter:

float getQuote(string symbol)

Chapter 1 • Taking Web Services for a Test Drive

4172c01.qxd  2/11/03  12:36 AM  Page 16



17

If the symbol your program passes to getQuote is invalid, getQuote will return the value -1.
The source code in Listing 1.2 implements the ASP.NET page StockPrice.aspx.

➲ Listing 1.2 StockPrice.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents Button1 As System.Web.UI.WebControls.Button
Protected WithEvents Button2 As System.Web.UI.WebControls.Button
Protected WithEvents Button3 As System.Web.UI.WebControls.Button
Protected WithEvents Button4 As System.Web.UI.WebControls.Button
Protected WithEvents Button5 As System.Web.UI.WebControls.Button
Protected WithEvents Label2 As System.Web.UI.WebControls.Label
Protected WithEvents Button6 As System.Web.UI.WebControls.Button

#Region “ Web Form Designer Generated Code “
‘Code not show

#End Region

Private Sub Button1_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button1.Click

ShowStockPrice(“MSFT”)
End Sub

Private Sub Button2_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button2.Click

ShowStockPrice(“ORCL”)
End Sub

F I G U R E 1 . 7 :
Using the StockQuote
web service to retrieve
stock prices
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Private Sub Button3_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button3.Click

ShowStockPrice(“YHOO”)
End Sub

Private Sub Button4_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button4.Click

ShowStockPrice(“BMC”)
End Sub

Private Sub Button5_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button5.Click

ShowStockPrice(“INTC”)
End Sub

Private Sub Button6_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button6.Click

ShowStockPrice(“CSCO”)
End Sub

Private Function ShowStockPrice(ByVal Symbol As String) _
➥ As String

Dim StockQuote As New _
➥ net.xmethods.services.netxmethodsservicesstockquoteStockQuoteService()_

Dim Price As String

Price = StockQuote.getQuote(Symbol)

Label2.Text = “Current Price: “ & Price
End Function

End Class

As you can see, the code provides event handlers for each of the buttons. Within the han-
dler, the code calls the ShowStockPrice function, passing to the function a stock symbol that
corresponds to a specific company. Within the ShowStockPrice function, the following state-
ment creates a variable named StockQuote that corresponds to the object the code will use to
interact with the StockQuote object:

Dim StockQuote As New _
➥ net.xmethods.services.netxmethodsservices_
➥ stockquoteStockQuoteService()

To call the getQuote method, the code uses the StockQuote variable as follows:
Price = StockQuote.getQuote(Symbol)

Chapter 1 • Taking Web Services for a Test Drive
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Retrieving Stock Prices within a C# Program
The following C# program, GetQuote.cs, displays a form that prompts the user for a com-
pany stock symbol. After the user enters the symbol and clicks the Get Stock Price button,
the program will display the stock price, as shown in Figure 1.8.

To create the GetQuote.cs program, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual C# Projects. Then,
within the Templates field, click Windows Application. Finally, within the Location field,
specify the folder within which you want to store the program and the program name
GetQuote. Select OK. Visual Studio .NET will display a form onto which you can drag
and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text box previously shown in
Figure 1.8 onto the form.

4. To assign a Web Reference that corresponds to the object, select the Project menu Add
Web Reference option. Visual Studio .NET will display the Add Web Reference dialog box.

5. Within the Address field, type the URL of the service’s WSDL file. In this case, type
http://services.xmethods.net/soap/urn:xmethods-delayed-quotes.wsdl and press
Enter. The dialog box will load the file’s contents. Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Within the source code (near the bottom of the class definition), add the following
program statements:

private void button1_Click(object sender, System.EventArgs e)
{
float Price;
net.xmethods.services.netxmethodsservicesstockquote
➥ StockQuoteService Quote;

F I G U R E 1 . 8 :
Using the StockQuote
web service within a
C# program

Retrieving Stock Quotes
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Quote = new
➥ net.xmethods.services.netxmethodsservicesstockquoteStockQuoteService();

if (textBox1.Text.Length == 0)
label2.Text = “Must specify stock symbol”;

else
{
try
{
Price = Quote.getQuote(textBox1.Text);
if (Price == -1)
label2.Text = “Invalid symbol”;

else
label2.Text = “Current price: “ + Price.ToString();

}
catch(Exception ex)

{
label2.Text = “Web service exception” + ex.Message;

}
}

}

The previous program used the StockQuote web service to retrieve a stock price for dis-
play. The following C# program, NotifyMe.cs, again prompts the user to enter a stock sym-
bol. After the user enters the stock information, the user can minimize the program. The
program, behind the scenes, will “wake up” every 15 seconds and compare the stock’s cur-
rent price to the original price. If the stock’s price has changed by one dollar (either up or
down), the program will bring the form to the top of any active programs. If the user has
minimized the program, the program will highlight the program’s icon within the Taskbar.
See Figure 1.9.

F I G U R E 1 . 9 :
Using a web service
within a program that
performs background
processing
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To create the NotifyMe.cs program, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual C# Projects. Then,
within the Templates field, click Windows Application. Finally, within the Location field,
specify the folder within which you want to store the program and the program name
NotifyMe. Select OK. Visual Studio .NET will display a form onto which you can drag
and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text box previously shown in
Figure 1.9 onto the form. Then, drag a Timer control onto the form.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type the URL http://services.xmethods.net/soap/
urn:xmethods-delayed-quotes.wsdl and press Enter. The dialog box will load the file’s
contents. Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Within the source code (near the bottom of the class definition), add the following
program statements:

float OriginalPrice;
float DollarChange;

net.xmethods.services.netxmethodsservicesstockquote
➥ StockQuoteService Quote;

private void button1_Click(object sender, System.EventArgs e)
{
float Price;
Quote = new 

➥ net.xmethods.services.netxmethodsservicesstockquoteStockQuoteService();

if (textBox1.Text.Length == 0)
label4.Text = “Must specify stock symbol”;

else
{
textBox1.ReadOnly = true;
button1.Enabled = false;

try
{
Price = Quote.getQuote(textBox1.Text);
OriginalPrice = Price;
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if (Price == -1)
label4.Text = “Invalid symbol”;

else
{
label4.Text = “Original price: “ + OriginalPrice.ToString();
timer1.Interval = 15000;
timer1.Enabled = true;
DollarChange = 0;

}
}
catch(Exception ex)
{
label4.Text = “Web service exception” + ex.Message;

}
}

}

private void timer1_Tick(object sender, System.EventArgs e)
{
float Price;

try
{
Price = Quote.getQuote(textBox1.Text);

if (Price == -1)
{
label5.Text = “Invalid symbol”;
this.Activate();

}
else
{
label5.Text = “Current price: “ + Price.ToString();

if (((Price - OriginalPrice) > DollarChange) ||
((OriginalPrice - Price) > DollarChange))

{
this.Activate();
this.BringToFront();

}
}

}

catch(Exception ex)
{
label5.Text = “Web service exception” + ex.Message;

}
}
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The program uses a timer set to 15-second intervals. Each time the timer occurs, the code
uses the web service to retrieve the stock’s current price. If the stock price has increased or
decreased by a dollar or more since the user first requested the price, the code will bring the
form to the top of any open applications:

if (((Price - OriginalPrice) > DollarChange) ||
((OriginalPrice - Price) > DollarChange))

{
this.Activate();
this.BringToFront();

}

Retrieving Book Information
On the Web, Amazon (amazon.com) and Barnes & Noble (barnesandnoble.com) are two of the
largest online booksellers. Both sites let users shop for books electronically. To integrate the
capabilities of these two online sites into your own programs and web pages, you can take
advantage of web services.

To start, Amazon offers a software development kit (SDK) programmers can use to search
for books, videos, and music, and by keyword, author, artist, and more. Further, program-
mers can integrate support for the Amazon shopping cart into their own applications and
websites.

You can download the Amazon web services SDK from the Amazon website at www.
amazon.com/webservices. After you download the software development kit, you must apply
for a developer’s token (a key) that you must include as a parameter within your function calls
to the services.

Second, the BNQuote web service returns the price of a book at Barnes & Noble for a
given ISBN.

The ASP.NET page AmazonDemo.aspx on this book’s companion website uses the Amazon
web services to list the titles and prices of various Sybex books at Amazon. When you display
the page and click on the Get Amazon.com Pricing button, the page will use the Amazon web
service to perform a keyword search on “Sybex.” The page will place the search results for the
first 50 books within the text box, as shown in Figure 1.10.

Likewise, the ASP.NET page BarnesAndNoble.aspx at this book’s companion website 
displays buttons for several different book titles. If you click one of the buttons, the page 
will display the book’s current price at the online Barnes & Noble store, as shown in Fig-
ure 1.11.

Retrieving Book Information
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F I G U R E 1 . 1 1 :
Using the BNQuote
Web service to display
book prices at Barnes
& Noble online

F I G U R E 1 . 1 0 :
Using the Amazon web
services SDK within
an ASP.NET page
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Behind the Scenes of the Amazon Web Service
The Amazon web SDK provides several different web services. To search Amazon products,
you use the AmazonSearchService, passing to the service a parameter that specifies whether
you want to perform a keyword search or search by author, artist, and so on. To interact with
the Amazon shopping cart, you would use a different web service. Listing 1.3 implements the
ASP.NET page AmazonDemo.aspx.

➲ Listing 1.3 AmazonDemo.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents TextBox1 As System.Web.UI.WebControls.TextBox
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents Button1 As System.Web.UI.WebControls.Button

#Region “ Web Form Designer Generated Code “
‘ Code not shown.

#End Region

Private Sub Button1_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles Button1.Click

Dim AmazonQuery As New com.amazon.soap.AmazonSearchService()
Dim KeywordRequest As New com.amazon.soap.KeywordRequest()
Dim WebError As Boolean = False

Dim ProductInfo As com.amazon.soap.ProductInfo

KeywordRequest.devtag = “XXXXXXXXXXXXXX”  ‘Replace X’s with your key.

KeywordRequest.keyword = “Sybex”
KeywordRequest.mode = “books”
KeywordRequest.type = “heavy”
KeywordRequest.tag = “webservices-20”
KeywordRequest.version = “1.0”

Dim Page As Integer

For Page = 0 To 4
KeywordRequest.page = Page.ToString()
Try
ProductInfo = AmazonQuery.KeywordSearchRequest(KeywordRequest)

Catch Ex As Exception
WebError = True
TextBox1.Text = “Error in Web service “ & Ex.Message

End Try

If (Not WebError) Then
Dim Info As com.amazon.soap.Details

Retrieving Book Information
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For Each Info In ProductInfo.Details
TextBox1.Text &= Info.ProductName & “ “ & Info.OurPrice & vbCrLf
Next

End If
Next

End Sub
End Class

As discussed, before a program can use a web service, the program must create an object
that corresponds to the web service. The following statement creates a variable named 
AmazonQuery that corresponds to the AmazonSearchService:

Dim AmazonQuery As New com.amazon.soap.AmazonSearchService()

To perform a keyword search, the code must create a variable that specifies the search cri-
teria. The following statement creates a variable to hold the search fields:

Dim KeywordRequest As New com.amazon.soap.KeywordRequest()

Then, the following statements specify the search criteria. The Amazon web services soft-
ware development kit briefly describes the various fields. You must change the statement that
assigns X’s to the devtag field to contain the developer tag you download from the Amazon
web service site:

KeywordRequest.devtag = “XXXXXXXXXXXXXX”  ‘Replace X’s with your key.

KeywordRequest.keyword = “Sybex”
KeywordRequest.mode = “books”
KeywordRequest.type = “heavy”
KeywordRequest.tag = “webservices-20”
KeywordRequest.version = “1.0”

By default, the Amazon web service search operation will return 10 matching products. To
display 50 Sybex books, the code repeatedly performs the search operation within a For Each
loop. Note that the code calls the service’s KeywordSearchRequest method within a Try-
Catch block to detect any exceptions the service may generate.

To build the ASP.NET page perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual Basic Projects. Then,
within the Templates field, click ASP.NET Web Application. Finally, within the Location
field, specify the name AmazonDemo. Select OK. Visual Studio .NET will display a page
onto which you can drag and drop the program’s controls (label, buttons, and text box).
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3. Using the Toolbox, drag and drop the label, buttons, and text box previously shown in
Figure 1.10 onto the page. Using the Properties window, set the text box to support mul-
tiline operations.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type the URL http://soap.amazon.com/schemas/
AmazonWebServices.wsdl and press Enter. The dialog box will load the file’s contents.
Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Enter the program statements previously shown.

Behind the Scenes of the Barnes & Noble Web Service
The BNQuote web service supports one method, getPrice, which returns the price for a
book based on an ISBN number:

single getPrice(string ISBN)

Listing 1.4 implements the ASP.NET page BarnesAndNoble.aspx.

➲ Listing 1.4 BarnesAndNoble.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents Button1 As System.Web.UI.WebControls.Button
Protected WithEvents Button2 As System.Web.UI.WebControls.Button
Protected WithEvents Button3 As System.Web.UI.WebControls.Button
Protected WithEvents Button4 As System.Web.UI.WebControls.Button
Protected WithEvents Label2 As System.Web.UI.WebControls.Label

#Region “ Web Form Designer Generated Code “
‘ Code not shown.

#End Region

Private Sub Page_Load(ByVal sender As System.Object, ByVal e_
➥As System.EventArgs) Handles MyBase.Load

‘Put user code to initialize the page here
End Sub

Private Sub ShowPrice(ByVal Title As String, ByVal ISBN As String)
Dim BNQuery As New net.xmethods.www.BNQuoteService()
Dim Price As Single
Dim WebError As Boolean = False
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Try
Price = BNQuery.getPrice(ISBN)

Catch Ex As Exception
WebError = True
Label2.Text = “Web service error: “ & Ex.Message

End Try

If (Not WebError) Then
If (Price = -1) Then

Label2.Text = Title & “ not found”
Else

Label2.Text = Title & “ Price: “ & Price.ToString()
End If

End If

End Sub

Private Sub Button1_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button1.Click

ShowPrice(Button1.Text, “0672319225”)
End Sub

Private Sub Button2_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button2.Click

ShowPrice(Button2.Text, “0072223189”)
End Sub

Private Sub Button3_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button3.Click

ShowPrice(Button3.Text, “0596002246”)
End Sub

Private Sub Button4_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button4.Click

ShowPrice(Button4.Text, “0596000952”)
End Sub

End Class

As you can see, the program defines handlers that correspond to each of the form’s but-
tons. Within each handler, the code calls the ShowPrice function, passing to the function the
name of the corresponding book and the book’s ISBN. Within the ShowPrice function, to
interact with the BNQuote web service, the code first creates an object that corresponds to
the service:

Dim BNQuery As New net.xmethods.www.BNQuoteService()

Then, within a Try-Catch block, the code calls the service’s getPrice method. If the service
cannot find the book based on the specified ISBN, the getPrice method will return the 
value -1.
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To build the BarnesAndNoble.aspx ASP.NET page, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual Basic Projects. Then,
within the Templates field, click ASP.NET Web Application. Finally, within the Location
field, specify the name BarnesAndNobleDemo. Select OK. Visual Studio .NET will dis-
play a page onto which you can drag and drop the program’s controls (label, buttons, and
text box).

3. Using the Toolbox, drag and drop the label, buttons, and text box previously shown in
Figure 1.11 onto the page.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type the URL http://www.xmethods.net/sd/2001/
BNQuoteService.wsdl and press Enter. The dialog box will load the file’s contents.
Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Enter the program statements previously shown.

Retrieving Caller-ID Information
Most telephones and phone lines now support caller-ID, which displays an incoming caller’s
name. Sometimes your phone displays only the caller’s phone number.

The GeoPhone web service offered by ServiceObjects lets you determine the person or
business that corresponds to a specific phone number. For example, if you enter the phone
number 510-523-8233, the service will return the owner, “Sybex Computer Books.”

The ASP.NET page GetCaller.aspx, which you can run from this book’s companion web-
site, displays a form that prompts you to enter a phone number. After you enter the number
and click the Get Caller button, the page will use the GeoPhone web service to retrieve the
caller information, which the page will then display as shown in Figure 1.12. If the service
cannot determine a number’s owner, the page will display a message so stating.

Behind the Scenes of the GeoPhone Web Service
The GeoPhone web service supports the following method:

PhoneInfo GetPhoneInfo(string PhoneNumber, string LicenseKey)

Retrieving Caller-ID Information
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The GetPhoneInfo method returns a value of type PhoneInfo, which, depending on the
phone listing the service discovers, may contain an array of contacts and an array of providers
(the telephone companies that manage the numbers). Each entry within the contacts array
contains name and address information.

The PhoneNumber parameter that you pass to the GetPhoneInfo method should not contain
hyphens. To look up the number 800-555-1212, you would use the string 8005551212.

The GetPhoneInfo method requires that you pass a parameter that specifies your license
key. If you visit the ServiceObjects website, you can download a trial key that lets you use the
service for a specific period of time. If you need unlimited use of the service, you must pur-
chase a license for service from ServiceObjects. The GetCaller.aspx ASP.NET page uses the
license key 0, which provides a limited use of the service. The source code in Listing 1.5
implements the ASP.NET page GetCaller.aspx.

➲ Listing 1.5 GetCaller.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents Label2 As System.Web.UI.WebControls.Label
Protected WithEvents TextBox1 As System.Web.UI.WebControls.TextBox
Protected WithEvents TextBox2 As System.Web.UI.WebControls.TextBox
Protected WithEvents TextBox4 As System.Web.UI.WebControls.TextBox
Protected WithEvents Button1 As System.Web.UI.WebControls.Button
Protected WithEvents TextBox3 As System.Web.UI.WebControls.TextBox

F I G U R E 1 . 1 2 :
Using the GeoPhone
web service to retrieve
caller information
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#Region “ Web Form Designer Generated Code “
‘ Code not shown

#End Region

Private Sub Page_Load(ByVal sender As System.Object, ByVal e
➥As System.EventArgs) Handles MyBase.Load

‘Put user code to initialize the page here
End Sub

Private Sub Button1_Click(ByVal sender As System.Object,
➥ByVal e As System.EventArgs) Handles Button1.Click

Dim Phone As New net.serviceobjects.ws.GeoPhone()
Dim PhoneInfo As net.serviceobjects.ws.PhoneInfo
Dim Contact As net.serviceobjects.ws.Contact
Dim Provider As net.serviceobjects.ws.Provider
Dim PhoneNumber As String
Dim ProcessingError As Boolean = False

PhoneNumber = TextBox1.Text & TextBox2.Text & TextBox3.Text

If (PhoneNumber.Length <> 10) Then
TextBox4.Text = “Invalid phone number” & PhoneNumber

Else
Try

PhoneInfo = Phone.GetPhoneInfo(PhoneNumber, 0)
Catch Ex As Exception

TextBox4.Text = “Error processing number “ & Ex.Message
ProcessingError = True

End Try

If (ProcessingError) Or (PhoneInfo Is Nothing) Then
TextBox4.Text = “Error processing number”

Else
TextBox4.Text = “Contact: “
If (PhoneInfo.Contacts.Length = 0) Then

TextBox4.Text &= “Unknown”
Else

For Each Contact In PhoneInfo.Contacts
TextBox4.Text &= vbCrLf & Contact.Name
TextBox4.Text &= vbCrLf & Contact.Address
TextBox4.Text &= vbCrLf & Contact.City
TextBox4.Text &= “ “ & Contact.State
TextBox4.Text &= “ “ & Contact.Zip & vbCrLf

Next
End If

End If
End If

End Sub
End Class
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Within the button-click event handler, the following statement creates an object the pro-
gram will use to interact with the GeoPhone web service:

Dim Phone As New net.serviceobjects.ws.GeoPhone()

After the user enters a phone number and clicks the Get Caller button, the code calls the
GetPhoneInfo method within a Try-Catch block. If the web service is successful, the code
will use a ForEach loop to display each element within the Contacts array.

To build the GetCaller.aspx ASP.NET page, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual Basic Projects. Then,
within the Templates field, click ASP.NET Web Application. Finally, within the Location
field, specify the name GetCaller. Select OK. Visual Studio .NET will display a page
onto which you can drag and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text boxes previously shown in
Figure 1.12 onto the page. Using the Properties window, set the text box to support mul-
tiline operations.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type the URL http://ws.serviceobjects.net/gp/GeoPhone
.asmx?WSDL and press Enter. The dialog box will load the file’s contents. Click the Add
Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Enter the program statements previously shown.

Retrieving Traffic Information
To help motorists select the best route to a destination, the California Department of Trans-
portation provides a website at which users can look up current conditions for specific high-
ways. The CATraffic web service offered by XMethods lets you integrate the traffic report
into your own programs and web pages.

The ASP.NET page CalTraffic.aspx at this book’s companion website lets you select a spe-
cific California highway. After you choose a highway and click the Get Traffic Conditions but-
ton, the page will display the highway’s current traffic conditions, as shown in Figure 1.13.
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Behind the Scenes of the CATraffic Web Service
The CATraffic web service calls the getTraffic method that programs can use to look up
traffic conditions on a specific highway:

string getTraffic(string highway)

The source code in Listing 1.6 implements the ASP.NET page CalTraffic.aspx.

➲ Listing 1.6 CalTraffic.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents Label2 As System.Web.UI.WebControls.Label
Protected WithEvents ListBox1 As System.Web.UI.WebControls.ListBox
Protected WithEvents Button1 As System.Web.UI.WebControls.Button
Protected WithEvents TextBox1 As System.Web.UI.WebControls.TextBox

#Region “ Web Form Designer Generated Code “
‘ Code not shown

#End Region

Private Sub Button1_Click(ByVal sender As System.Object, _
➥ ByVal e As System.EventArgs) Handles Button1.Click

F I G U R E 1 . 1 3 :
Using the CATraffic
web service to retrieve
traffic information
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Dim Highway As New net.xmethods.www.CATrafficService()
Dim WebError As Boolean = False

Dim Conditions As String

Try
Conditions = Highway.getTraffic(ListBox1.SelectedItem.ToString())

Catch Ex As Exception
WebError = True

End Try

If (WebError) Then
TextBox1.Text = “Error accessing Web service”

Else
TextBox1.Text = Conditions

End If
End Sub
End Class

Within the button-click handler, the code first creates an object that the program will use
to interact with the web service:

Dim Highway As New net.xmethods.www.CATrafficService()

Then, within a Try-Catch block, the code will call the getTraffic method. If the method is
successful, the code will assign the traffic conditions to the text box. To create the CalTraf-
fic.aspx ASP.NET page, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual Basic Projects. Then,
within the Templates field, click ASP.NET Web Application. Finally, within the Location
field, specify the name CalTraffic. Select OK. Visual Studio .NET will display a page
onto which you can drag and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text boxes previously shown in
Figure 1.13 onto the page. Using the Properties window, set the text box to support mul-
tiline operations. Also, add entries similar to those shown within the list box.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type http://www.xmethods.net/sd/2001/CATrafficService.wsdl
and press Enter. The dialog box will load the file’s contents. Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Enter the program statements previously shown.
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Retrieving Airport Information
Whether you are a frequent traveler or you are finally getting away for a much-needed vacation,
you can use the AirportInfo web service offered by Web ServiceX.Net to determine specifics about
an airport, such as airport’s longitude and latitude, the length of the airport runway, and so on.

The ASP.NET page at AirportInfo.aspx at this book’s companion website prompts a user
to enter an airport code, such as JFK or LAX. After the user specifies the airport and clicks
the Airport Information button, the page will display current conditions at the airport, as
shown in Figure 1.14. Behind the scenes, web services make extensive use of XML-based
data. Within the .NET environment, your programs normally do not have to work directly
with the XML. The AirportInfo web service returns a string that contains its result in XML.
For simplicity and to introduce you briefly to XML-based data, the AirportInfo.aspx
ASP.NET page displays the service’s result using an XML-based format. In later chapters,
you will learn how to parse XML-based documents to extract the specific data you need.

Behind the Scenes of the AirportInfo Web Service
The AirportInfo web service supports myriad methods that your programs can call to get air-
port information by airport code, city, state, and more. The AirportInfo.aspx page uses the
getAirportInformationbyAirportCode method:

string getAirportInformationbyAirportCode(string Code)

The source code in Listing 1.7 implements the ASP.NET page AirportInfo.aspx.

F I G U R E 1 . 1 4 :
Using the AirportInfo
web service to retrieve
XML-based airport
information
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➲ Listing 1.7 AirportInfo.aspx

Public Class WebForm1
Inherits System.Web.UI.Page
Protected WithEvents Label1 As System.Web.UI.WebControls.Label
Protected WithEvents TextBox1 As System.Web.UI.WebControls.TextBox
Protected WithEvents Button1 As System.Web.UI.WebControls.Button
Protected WithEvents TextBox2 As System.Web.UI.WebControls.TextBox
Protected WithEvents Image1 As System.Web.UI.WebControls.Image

#Region “ Web Form Designer Generated Code “
‘ Code not shown.

#End Region

Private Sub Button1_Click(ByVal sender As System.Object, _
➥ByVal e As System.EventArgs) Handles Button1.Click
Dim AirportInfo As New net.webservicex.www.AirportInfoWebservice()

Dim Info As String
Dim WebError As Boolean = False

Try
Info = AirportInfo.getAirportInformationByAirportCode(TextBox1.Text)
Catch Ex As Exception
WebError = True
TextBox2.Text = “Web service error: “ & Ex.Message
End Try

If (Not WebError) Then
TextBox2.Text = “”

Dim I As Integer
Dim Letter As String

For I = 0 To Info.Length - 1
Letter = Info.Substring(I, 1)

If (Letter = “>”) Then
TextBox2.Text &= Letter & vbCrLf

Else
TextBox2.Text &= Letter

End If
Next

End If

End Sub
End Class
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Within the button-click event handler, the following statement creates an object the code
uses to interact with the web service:

Dim AirportInfo As New net.webservicex.www.AirportInfoWebservice()

Then, the program calls the service, passing to the method the airport code the user specifies.
If the service is successful, the code then displays the result within the text box. To create the
AirportInfo.aspx ASP.NET page, perform these steps:

1. Within Visual Studio .NET, select the File menu New Project option. Visual Studio
.NET will display the New Project dialog box.

2. Within the New Project dialog box Project Types list, click Visual Basic Projects. Then,
within the Templates field, click ASP.NET Web Application. Finally, within the Location
field, specify the name AirportInfo. Select OK. Visual Studio .NET will display a page
onto which you can drag and drop the program’s controls (label, buttons, and text box).

3. Using the Toolbox, drag and drop the label, buttons, and text boxes previously shown in
Figure 1.14 onto the page. Using the Properties window, set the text box to support mul-
tiline operations.

4. Select the Project menu Add Web Reference option. Visual Studio .NET will display the
Add Web Reference dialog box.

5. Within the Address field, type the URL http://www.webservicex.net/airport.asmx?wsdl
and press Enter. The dialog box will load the file’s contents. Click the Add Reference button.

6. Select the View menu Code option. Visual Studio .NET will display the program’s source
code. Enter the program statements previously shown.

Where to Find Web Services on the Web
Across the Web, you can find web services from a variety of sources. This chapter took
advantages of web services offered from the following websites:

www.XMethods.com
www.ServiceObjects.com
www.WebServiceX.net
www.Amazon.com\webservices

Later in this book, you will take advantage of web services available from Microsoft and
other key software developers. In addition, you will learn how to locate web services using
the UDDI directory within the Add Web References dialog box, as shown in Figure 1.15.

Where to Find Web Services on the Web
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Summary
Web services let developers extend website capabilities to their applications. By integrating
web services into an application, a programmer can integrate capabilities that correspond to
e-commerce operations at Amazon, search operations at Google, airline reservations at an
airline, and more. Web services provide a platform to extend a company’s key capabilities
beyond the company’s website.

In this chapter you learned how to build Visual Basic .NET and C# programs as well as
ASP.NET pages that consume Web services. Across the Web, many sites offer web services that
your programs can use to interact with the services the site offers. In this way, you can create pro-
grams that offer the same operations a user would traditionally find only at a company’s web page.

The Microsoft Visual Studio .NET environment makes it very easy for you to integrate a web
service into your programs. To start, you add a Web Reference to the remote web service by
specifying the WSDL (web service definition language) file that defines the service (the methods
the service offers as well as the parameters each method uses). Then, you create an object that
corresponds to the service. Finally, you use the object to call the web service methods.

This chapter taught you how to use existing web services. In Chapter 2, you will create
your own web services.

F I G U R E 1 . 1 5 :
Searching the UDDI
directory for specific
web services
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