Chapter 1

This Is AutoCAD

AuToCAD HAS BEEN AROUND since 1983 when version 1.4 was introduced. Its longevity

is the result of a solid product and a steadily expanding set of capabilities. The latest iteration,
AutoCAD 2004, is faster, has an improved interface, and includes new features based on the more
popular end-user wish-list items. AutoCAD 2004 also offers something that won't be visible at
first glance. Autodesk wanted to make sure that their latest version of AutoCAD would be one of
the most reliable ever, so AutoCAD 2004 has been through one of the most extensive beta—testing
programs in the history of AutoCAD. Users have always cited reliability as one of AutoCAD'’s
most important features, and AutoCAD 2004 should prove to be a solid performer.

Before you can start to make use of AutoCAD 2004’s new capabilities, you’ﬂ need to become
familiar with the basics. If you are compietely new to AutoCAD, you’ll want to read this first
chapter carefuﬂy. It introduces you to many of AutoCAD’s basic operations, such as opening and
closing files, getting a close—up look at part of a drawing, and changing a drawing. If you are
familiar with earlier versions of AutoCAD, you rnight want to read through this chapter anyway
to get acquainted with new AutoCAD 2004 features. So let’s get started!

Topics in this chapter include the foﬂowing:

¢ The AutoCAD Window

¢ Opening an Existing File

@ Getting a Closer Look with the Zoom Command
¢ Saving a File As You Work

¢ Making Changes and Opening Multiple Files

¢ If You Want to Experiment. ..

TiP  In this chapter, and throughout the rest of the book, when we say “AutoCAD;” we mean both AutoCAD and
AutoCAD LT. Some topics will only apply to AutoCAD. In those situations, you'll see an icon indicating that
the topic does not apply to AutoCAD LT. If you are using AutoCAD 2004 LT, these icons can help you focus on the

tOPi[S tkdt are more relevant toyom WO?’](,
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CHAPTER1 THISIS AUTOCAD

Taking a Guided Tour

First, you will get a chance to familiarize yourself with the AutoCAD screen and how you communi-
cate with AutoCAD. As you do the exercises in this chapter, you will also get a feel for how to work
with this book. Don't worry about understanding or remembering everything that you see in this
chapter. You will get plenty of opportunities to probe the finer details of the program as you work
through the later chapters. To help you remember the material, you will find a brief exercise at the
end of each chapter. For now, just enjoy your first excursion into AutoCAD.

WARNING ~ AutoCAD 2004 is designed to run on Windows NT4 with service pack 6, Windows 2000 and
Windows XP, It is not designed to run on Windows 98 or Windows Me though some users have reported running it
successfully on Windows 98. If you are using a network license version of AutoCAD, you may also use Windows 2000
server edition or Windows NT4 server edition with service pack 5. This book was written using AutoCAD 2004 on
Windows XP Professional with a Windows Classic desktop theme.

If you already installed AutoCAD and are ready to jump in and take a look, proceed with the fol-

lowing steps to launch the program:

1. Choose Start > All Programs > Autodesk > AutoCAD 2004 > AutoCAD 2004. You can
also double-click the AutoCAD 2004 icon on your Windows Desktop. LT users will use
AutoCAD LT 2004 in place of AutoCAD 2004.

2. The opening greeting, called a splash screen, tells you which version of AutoCAD you are using,
to whom the program is registered, and the AutoCAD dealer’s name and phone number,

should you need help.

3. After the splash screen closes, you see the AutoCAD Window with a blank default document
named Drawingl.dwg as shown in Figure 1.1.
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TAKING A GUIDED TOUR

NOTE  If you sce the Startup dialog box after step 3, click Cancel. AutoCAD displays a default document as shown in
Figure 1.1. You'll learn more about the Startup dialog box in Chapter 2.

Let’s take a look at the AutoCAD window in detail. Don't worry if it seems like a lot of informa-
tion. You don't have to memorize it all, but by looking at all the parts, you'll be aware of what is
available in a general way.

AutoCAD LT users will see the Active Assistance window. This window is an aid to new users,
and it provides immediate help with AutoCAD commands. For now, you can close it by clicking the
Close button in the upper-right corner. To prevent the Active Assistance window from appearing
automatically, right-click the Active Assistance icon in the Windows tool tray (it is a question mark
icon in the lower-right corner of the computer screen), and choose Settings from the shortcut menu
to open the Active Assistance Settings dialog box. Click the On Demand radio button, and then click
OK. You can open the Active Assistance window at any time by choosing Help > Active Assistance
from the AutoCAD menu bar.

MESSAGE TO VETERAN AUTOCAD USERS

AutoCAD, like many popular programs, is continually evolving. Quite often, that evolution forces us to
change some old and cherished habits.

If you’ve been using AutoCAD for a while, and you’ve grown accustomed to certain behaviors, you can take
certain steps to make AutoCAD 2004 a more familiar environment.

You can, for example, restore the Enter () function to the mouse right-click instead of using the newer
shortcut menu. Follow these steps:

1. Choose Tools > Options to open the Options dialog box.
2. Click the User Preference tab.

3. Inthe Windows Standard Behavior group, click the Right-Click Customization button to open the Right-
Click Customization dialog box.

4. Click the ENTER radio button in the Command Mode group, and then click the Apply & Close button.
Another option is to turn on the time-sensitive right-click option at the top of the Right-Click Customization
dialog box. With this option, a quick right-click is the same as pressing the Enter . key but you can still access

the right-click shortcut menus by holding down the right mouse button a bit longer. You can even set the
duration required to open the right-click shortcut menus.

[% Right-Click Customization 2=l

[+ Tum on time-sensitive tight-click:
Quick click for ENTER L
Longer click to dizplay Shortcut Menu

Longer click duration: | 250 milliseconds

Continued on next page
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6 CHAPTER1 THISIS AUTOCAD

MESSAGE TO VETERAN AUTOCAD USERS (continued)

If you prefer to enter commands and command options through the keyboard instead of using dialog boxes,
you can do so for a number of commands. Here is a list of commands that normally produce a dialog box.

Array Attdef Attedit
Bhatch Boundary Group
Hatcheditlmage Insert Image
Layer Layout Linetype
MtextBlock Osnap Pan
Partialopen Purge Rename
Style Units View
Whblock Xbind Xref

To use these commands from the command prompt, add a minus sign (-) to the beginning of the
command name. For example, to use the old Layer command, enter —layer at the command prompt. To use
the old Pan command, enter —pan at the command prompt. (By the way, when you enter —pan from the
command prompt, the command reverts to the “classic” method of panning in AutoCAD, in which you click
two points to indicate the direction and displacement, instead of the “real time” pan. This “classic” method
is useful when you want to pan your view a specific distance because it allows you to enter the pan
distance and direction.)

Even if you don’t care to enter commands from the keyboard, knowing about the use of the minus sign can
help you create custom macros. See Chapter 20 for more on AutoCAD customization.

The AutoCAD Window
The AutoCAD program window is divided into six parts:
¢ Menu bar
¢ Docked and floating toolbars
¢ Drawing area
¢ Command window
¢ Status bar
& Tool Palettes

TIP A seventh hidden component, the Properties palette, gives you detailed information about the objats in your dmwz'ng
You can also use it to modify some of those properties. You'll learn more about the Properties palette in Chapter 4.
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Figure 1.1 shows a typical layout of the AutoCAD program window. Along the top is the menu bar,
and at the bottom are the Command window and the status bar. Just below the menu bar and to either side
of the window are the toolbars. The drawing area occupies the rest of the screen. (By the way, your screen
may show the drawing area in black. You can set the drawing area background color using the Options
dialog box. Appendix B describes how to do this. (The figures in this book show the drawing area
background in white for clarity.)

You can easily move and reshape many of the elements in the AutoCAD window. Figure 1.2
demonstrates how different AutoCAD can look after some simple rearranging of window components.
You can move toolbars from their default locations to any location on the screen. When they are in
their default location, they are in their docked position. When they are moved to a location where they
are free-floating, they are floating.
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The menu bar at the top of the drawing area (as shown in Figure 1.3) offers pull-down menus
from which you select commands in a typical Windows fashion. The toolbars offer a variety of com-
mands through tool buttons and drop-down lists. For example, the name or number of the layer that
you are currently working on is displayed in a drop-down list in the Properties toolbar. To the right
of the layer name are icons for tools you can use to work with the layer. The tools and lists on the
toolbar are plentiful, and you'll learn more about all of them later in this chapter and as you work

through this book.

TIP A layer is like an overlay that allows you to separate different types of information. AutoCAD allows an unlimited
number of layers. On new drawings, the default layer is 0. You'll get a detailed look at layers and the meaning of the Layer
tools in Chapter 4.
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The Draw and Modify toolbars, which are normally docked on either side of the drawing area,
offer commands that create new objects and edit existing ones. These are just two of many toolbars
available to you. Figure 1.4 shows these two toolbars in their floating state.
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The Tool palettes ofter a quick way to gain access to frequently used symbols, known as blocks in
AutoCAD. You can create your own symbols and add them to the palettes. You'll geta closer look at
the Tool palettes in Chapter 2.
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The drawing area—your workspace—occupies most of the screen. Everything you draw appears in
this area. As you move your mouse around, crosshairs appear to move within the drawing area. This is
the drawing cursor that lets you point to locations in the drawing area.

At the bottom of the drawing area, you’H see a set of tabs. These tabs give you access to the Layout
views of your drawing. These views let you lay out your drawing as in a desktop publishing program.
You'll learn about the Layout tabs in Chapter 7. The arrows to the left of the tabs let you navigate the
tabs when there are more tabs than can fit in the AutoCAD window.

The Command window, located just below the drawing area, gives you feedback about AutoCAD'’s
commands as you use them. You can move and resize this window just as you move and resize toolbars.
By default, the Command window is in its docked position, as shown in Figure 1.6.
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Below the Command window is the status bar (see Figure 1.6) The status bar gives you informa-
tion at a glance about the state of the drawing. For example, the coordinate readout toward the far
left of the status line tells you the location of your cursor.

TIP  In a new installation of AutoCAD, you will see a message balloon in the bottom right corner of AutoCAD. This
message balloon alerts you fo the latest news and irjormation regarding AutoCAD tbroug}) a fmtwe called the Communication
Center. You'll learn more about the Communication Center in Chapter 2.

PICKING POINTS IN THE DRAWING AREA
Let’s practice using the coordinate readout and the drawing cursor.

1. Move the cursor around in the drawing area. As you move, notice how the coordinate readout
changes to tell you the cursor’s location. It shows the coordinates in an X,Y, Z format.

2. Now place the cursor in the middle of the drawing area and click the left mouse button. You
have just picked a point. Move the cursor, and a rectangle follows. This is a selection window;
you’ﬂ learn more about this window in Chapter 2.

3. Move the cursor a bit in any direction; then click the left mouse button again. Notice that the
selection window disappears.

4. Try picking several more points in the drawing area. Notice that as you click the mouse, you
alternately start and end a selection window.

9
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If you accidentaﬂy click the right mouse button, the shortcut menu appears. A right mouse click
frequently opens a menu that contains options that are context sensitive. This means that the contents of
the shortcut menu depend on where you right-click as well as the command that is active at the time
of your right—dick‘ If there are no appropriate options at the time of the right—click, AutoCAD treats
the right-click as a «l. You'll learn more about these options as you progress through the book. For
now, if you happen to open this menu by accident, press the Esc key to close it.

TiP The J symbol is used in this book to denote the Enter key. Whenever you see it, press the Enter key, also known as
the Return key.

THE UCS ICON

In the lower-left corner of the drawing area, you see an L-shaped arrow. This is the User Coordinate
System (UCS) icon, which tells you your orientation in the drawing. This icon becomes helpful as you
start to work with complex 2D drawings and 3D models. The X and Y arrows indicate the x- and y-
axes of your drawing. The little square at the base of the arrows tells you that you are in what is called
the World Coordinate System. Chapter 17 discusses this icon in detail. For now, you can use it as a refer-
ence to tell you the direction of the axes.

IF YOU CAN’T FIND THE UCS ICON...

The UCS icon can be turned on and off, so if you are on someone else’s system and you don’t see the icon,
don’t panic. It also changes shape depending on whether you are in Paper Space mode in a Layout tab or in
Model Space! If you don’t see the icon or it doesn’t look as it does in this chapter, see Chapter 13 for more
information on Paper Space and Model Space. Chapter 17 gives you more information on the UCS icon.

THE COMMAND WINDOW

At the bottom of the screen, just above the status bar, is a small horizontal window called the Com-
mand window. Here AutoCAD displays responses to your input. By default, it shows three lines of
text. The bottom line shows the current messages, and the top two lines show messages that have
scrolled by or, in some cases, components of the current message that do not fit in a single line.
Right now, the bottom line displays the message Command (see Figure 1.6 eatlier in this chapter). This
prompt tells you that AutoCAD is waiting for your instructions. As you click a point in the drawing
area, you'll see the message Specify Opposite Corner. At the same time, the cursor starts to draw a
selection window that disappears when you click another point.

As a new user, pay special attention to messages displayed in the Command window because this
is how AutoCAD communicates with you. Besides giving you messages, the Command window
records your activity in AutoCAD. You can use the scroll bar to the right of the Command window
to review previous messages. You can also enlarge the window for a better view. (Chapter 2 discusses
these components in more detail.)

Tip  You can think of the Command window as similar to the Address or Location input box found in web browsers. It
allows you to manually input data through the keyboard. It also tells you what’s going on in the program. As you become
more familiar with AutoCAD, you may find you don’t need to rely on the Command window as much. For new users,
however, the Command window can be quite helpful in understanding what steps to take as you work.
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Now let’s look at AutoCAD’s window components in detail.

The Pull-Down Menus

As in most Windows programs, the puﬂ—down menus on the menu bar offer an easy—to—understand
way to access the general controls and settings for AutoCAD. Within these menus you’ﬂ find the
commands and functions that are the heart of AutoCAD. By clicking menu items, you can cut and
paste items to and from AutoCAD, change the settings that make AutoCAD work the way you want
it to, set up the measurement system you want to use, access the help system, and much more.

TiP  To close a pull-down menu without selecting anything, press the Esc key. You can also click any other part of the

AutoCAD window or click another pull~down menu.

The pull-down menu options perform four basic functions:

*

*

*

*

Display additional menu choices
Display a dialog box that contains settings you can change
Issue a command to create or modify your drawing

Ofter an expanded set of the same tools found in the Draw and Modify toolbars

As you point to commands and options in the menus or toolbars, AutoCAD provides additional
elp for you in the form of brief descriptions of each menu option, which appear in the status bar.
help f the £ f brief d t f each hich th b
Here’s an exercise to let you practice with the pull-down menus and get acquainted with the way
you issue AutoCAD commands:

1. Click View in the menu bar. The list of items that appears includes the commands and settings

that let you control the way AutoCAD displays your drawings. Don't worry if you don't under-
stand them yet; you'll get to know them in later chapters.

| Wigw Insert  Format  Tools |

] Retxaw
Regen —

Regen Al

Zaarm »
Pan »
Aerial View

Clean Screen Chrl40

Viewports 3
Mamed Yiews.. .

3D Views 3
3D Orbit

Hide

Shade 3
Render 3
Display 3

Toolbars...
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2. Move the highlight cursor slowly down the list of menu items. As you highlight each item,
notice that a clescription of it appears in the status line at the bottom of the AutoCAD win-
dow. These descriptions help you choose the menu option you need.

3. Some of the menu items have triangular pointers to their right. This means the command has
additional choices. For instance, highlight the Zoom item, and you’ll see another set of options
appear to the right of the menu.

Tip  If you look mrgfully at the command descriptions in the status bar, you’ll see an odd word at the end. This is the
/ceyboard command eqm'valent to the bz’gblz’gbted option in the menu or toolbar. You can aftually type these keybom’d commands
to start the tool or menu item that you are pointing to. You don’t have to memorize these command names, but /enowing them

will be kel]_)ful to you later if you want to customize AutoCAD.

This second set of options is called a [astading menu. Whenever you see a pull—clown menu item with
the triangular pointer, you know that this item opens a cascading menu offering a more detailed set of
options.

You might have noticed that other pull-down menu options are followed by an ellipsis (...). This
indicates that the option displays a clialog box, as the following exercise demonstrates:

1. Move the highlight cursor to the Tools option in the menu bar.

TiP  If you prefer, you can click and dmg the l)igblz’gl)t cursor over the pull-down menu to select an option.

2. Click the Options item at the bottom of the menu to open the Options clialog box. (LT users
will not see a Profiles tab.)

21
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TiP  The list in the Files tab of the Options dialog box works much like Windows Explorer. Clicking the plus sign to the
left of the items in the list expands the option to display more detail.

This dialog box contains several “pages,” indicated by the tabs across the top, that contain settings
for controlling what AutoCAD shows you on its screens, where you want it to look for special files,
and other ”housekeeping” settings. You needn’t worry about what these options mean at this point.

Appendix B describes the Options dialog box in more detail.

3. In the Options dialog box, click the Open And Save tab. The options change to reveal new
options. (LT users will not see the Object ARX Applications group, and the Allow Other
Users To Refedit Current Drawing option in the External References (Xref) group is also not

available.)
21
Cunent profile: <<lnnamed Profilex> Cuarent drawing Drawingl.dwg
Files | Display [ | Plotiing | Systeen | ser Preferences | Diatting | Selection | Proiies |
File Save - File Open
Save as: 3 Humier of recenty-used files to list
&eCAD 2004 Diswing I dwg) El

' Display full path in tile

¥ Save a thumbnail preview image

- External References [Xrefs)
|5U Incremental save percentage Bt o s
Enabled with -
i~ File S afety Precautions [ nabec wih copy =l
2 Automatic save ¥ Retain ghanges to ref layers
o e ., [V llows other users to Refedk current drawing

¥ Create backup copy with sach save

X X - ObjectaRi Appli
™ Fulktime CRC yalidation Demand Inad ObjectARX spps:
™ Maintain a log file - -
|Db|ecr detect and command invoke d

act d
I File extension for temporary fles S O

[ show prosy oraphics =l
Securty Options... |
¥ Show Prosy Information dialog box

¥ Display dighal signature information

ok | Cancel tooy | den |

In the middle-left side of the dialog box, you’ﬂ see the Automatic Save check box, with the
Minutes Between Saves input box set to 10 minutes. This setting controls how frequently
AutoCAD performs an automatic save.

4. Change the 10 to 20, and then click OK. You have just changed AutoCAD’s Automatic Save

feature to automatically save files every 20 minutes instead of every ten.
Tip  If you want to know more about the settings in the Options dz'alog box, check out Appendz’x B.

The third type of item you'll find on pull-down menus is a command that directly executes an
AutoCAD operation. Let’s try an exercise to explore these commands.
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1.
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Click the Draw option from the menu bar, and then click the Rectangle command. Notice
that the Command window now shows the following prompt:

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:

AutoCAD is asking you to select the first corner for the rectangle, and in brackets, it is offer-
ing a few options that you can take advantage of at this point in the command. Don't worry
about those options right now. You'll have an opportunity to learn about command options in

Chapter 2.

Click a point roughly in the lower-left corner of the drawing area, as shown in Figure 1.7. Now
as you move your mouse, you'll see a rectangle follow the cursor with one corner fixed at the
position you just selected. You'll also see the following prompt in the Command window:

Specify other corner point or [Dimensions]:

Fike EGt Wew Inseet Fomiet Took Draw Diversion Modfy Edpress Window Help

Byl [ Byl
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Click another point anywhere in the upper-right region of the drawing area. A rectangle
appears (see Figure 1.8). You'll learn more about the different cursor shapes and what they
mean in Chapter 2.
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At this point, you’ve seen how most of AutoCAD’s commands work. Many drawing and editing
functions display messages in the Command window. You'll find that dialog boxes are offered when

you want to change settings. Also, be aware that many of the pull—down menu items are duplicated in

the toolbars, which you will explore next.

COMMUNICATING WITH AUTOCAD

AutoCAD is the perfect servant: It does everything you tell it to, and no more. You communicate
with AutoCAD using the pull-down menus and the toolbars. These devices invoke AutoCAD commands. A
command is a single-word instruction you give to AutoCAD telling it to do something, such as draw a line
(the Line tool in the Draw toolbar) or erase an object (the Erase tool in the Modify toolbar). Whenever you
invoke a command, by either typing it or selecting a menu or toolbar item, AutoCAD responds by presenting
messages to you in the Command window or by displaying a dialog box.

The messages in the Command window often tell you what to do next, or they offer a list of options, usually
shown within square brackets. A single command often presents several messages, which you answer to
complete the command. These messages serve as an aid to new users who need a little help. If you ever get
lost while using a command or forget what you are supposed to do, look at the Command window for
clues. As you become more comfortable with AutoCAD, you will find that you won’t need to refer to these
messages as frequently.

As an additional aid, you can right-click to display a context-sensitive shortcut menu. If you are in the middle
of acommand and are not selecting points, this menu offers a list of options specifically related to that com-
mand. For example, if you right-click your mouse before picking the first point for the rectangle command
in the previous exercise, a menu appears, offering the same options that are listed in the command prompt,
plus some additional options.

Continued on next page
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COMMUNICATING WITH AUTOCAD (continued)

A dialog box is like a form you fill out on the computer screen. It lets you adjust settings or make selections
from a set of options pertaining to a command. You’ll get a chance to work with commands and dialog boxes
later in this chapter.

The Toolbars
Although the pull-down menus offer a full range of easy-to-understand options, they require some
effort to navigate. The toolbars, on the other hand, offer quick, single—click access to the most com-
monly used AutoCAD features. In the default AutoCAD window arrangement, you see only the
most commonly used toolbars. Other toolbars are available, but they are hidden from view until you
open them.

The tools in the toolbars perform three types of actions, just like the puﬂ—down menu commands:
They display further options, open dialog boxes, and issue commands that require keyboard or
cursor input.

THE TOOLBAR TOOL TIPS

AutoCAD’s toolbars contain tools that represent commands. To help you understand each tool, a tool
tip appears just below the arrow cursor when you rest the cursor on a tool. Each tool tip helps you
identify the tool with its function. A tool tip appears when you follow these steps:

1. Move the arrow cursor onto one of the toolbar tools and leave it there for a moment. Notice
that a brief description of the tool appears nearby—this is the tool tip. In the status bar, a
more detailed description of the tool's purpose appears (see Figure 1.9).
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2. Move the cursor across the toolbar. As you do, notice that the tool tips and status bar descrip-
tions change to describe each tool. The keyboard command equivalent of the tool is also
shown in the status bar at the end of the description.

WORKING WITH FLYOUTS

Most toolbar tools start a command as soon as you click them, but a few tools display a set of addi-

tional tools (similar to the cascading menus in the menu bar) that are related to the tool you selected.

This set of additional tools is called a toolbar flyout. It you've used other Windows graphics programs,

chances are you’ve seen ﬂyouts. Look dosely at the tools just below the Express or Dimension puﬂ—down

menu options on your screen or in Figure 1.8 earlier in this chapter. You'll be able to identify which

toolbar tool has a flyout; it has a small right-pointing arrow in the lower-right corner of the tool.
The following steps show you how a flyout works:

1. Move the cursor to the Zoom Window tool in the Standard toolbar. Click and hold the left

mouse button to dlsplay the ﬂyout. DOI’l’t release the mouse button.
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2. Still holding down the left mouse button, move the cursor over the flyout; notice that the tool
tips appear here as well. Also, notice the description in the status bar.

3. Move the cursor to the Zoom Window tool at the top of the flyout and release the mouse
button.

4. You don't need to use this tool yet, so press the Esc key to cancel this tool.

As you can see from this exercise, you get a lot of feedback from AutoCAD!
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MOVING THE TOOLBARS
One characteristic of AutoCAD’s toolbars is their mobility. They can be either floating anywhere on
the AutoCAD window or in a docked position. Docked means the toolbar is placed against the top and
side borders of the AutoCAD window so that the toolbar occupies a minimal amount of space. If
you want to, you can move the toolbar to any location on your desktop, thus turning it into a ﬂoating
toolbar.

Later in this section you’H find descriptions of all of AutoCAD’s toolbars, but first try the follow-

Ing exercise to move the Standard toolbar away from its current position in the AutoCAD window.

1. Move the arrow cursor so that it points to the vertical bars, called grab bars, to the far left of
the Standard toolbar, as shown here:

File Edit Yiew Insec
WHI &L

P
=

2. CIICk and hOld down the Ieft mouse button. NOtiCG that a gray rectangle appears by the Cursor.

3. Still holding down the mouse button, move the mouse downward. The gray box follows the
cursor.

4. When the gray box is over the drawing area, release the mouse button and the Standard toolbar—
now a ﬂoating toolbar—moves to its new location.

YOLI can now move the Standard toolbar to any location on the screen that suits YOLL YOLI can also

Change the shape Of the toolbar. Tty the following steps:

1. Place the cursor on the bottom—edge border Of the Standard toolbar. The cursor becornes a
double-headed arrow, as ShOWI’l here:

- ——
i@{w-

2. Click and drag the border downward. The gray rectangle jumps to a new, taller rectangle as you
move the cursor.

3. When the gray rectangle changes to the shape you want, release the mouse button to reshape
the toolbar.
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4. To move the toolbar back into its docked position, place the arrow cursor on the toolbar’s title
bar and slowly click and drag so that the cursor is in position in the upper—left corner of the
AutoCAD window. Notice how the gray outline of the toolbar changes as it approaches its
docked position.

(@] autocap 2004
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5. When the outline of the Standard toolbar is near its docked position, release the mouse button.
The toolbar moves back into its previous position in the AutoCAD window.

TIP  You can also move a toolbar from a docked position to a ﬂoating one by double~[lit]<ing the toolbar’s gmlz bar. Double-
click the title bar g‘ a ﬂoating toolbar to move the toolbar to its docked position.

You can move and reshape any of AutoCAD’s toolbars to place them out of the way and still have
them ready to give you quick access to commands. You can also put them away altogether when you
don't need them and bring them back at will, as shown in the following steps:

1. Click and drag the Draw toolbar from its position at the left of the AutoCAD window to a
point near the center of the drawing area. Remember to click and drag the grab bars at the
top of the toolbar.

2. Click the Close button in the upper-left corner of the Draw floating toolbar. This is the small
square button with the X in it. The toolbar disappears.

3. To recover the Draw toolbar, right-click the border or grab bar of any toolbar—but not a
toolbar button. A shortcut menu of toolbars appears.

4. Locate and select Draw in the shortcut menu. The Draw toolbar reappears.

5. Click and drag the Draw toolbar back to its docked position in the far-left side of the Auto-
CAD window.

TIP  If you do not want the toolbar to dock but instead want it to appear “floating” near the border of the AutoCAD Window,
you can press the Ctrl ]eey bgfore you click and dmg the toolbar into position. This prevents toolbars from automatimlly falling
into a docked position.

AutoCAD remembers your toolbar arrangement between sessions. When you exit and then reopen

AutoCAD later, the AutoCAD window appears just as you left it.
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TERMINOLOGY TO REMEMBER: CASCADING MENU

When this book asks you to select an option from the pull-down menu, you will see the notation Menu >
Option. For cascading menus, the notation will be Menu > Option > Option; the second > Optionisin a
cascading menu. In either case, the selected menu option issues a command that performs the function
being discussed. As mentioned earlier, the actual command name appears in the status bar when you point
to a menu option or toolbar tool.

You may have noticed several other toolbars listed in toolbar shortcut menu that don't appear in

the AutoCAD window. To keep the screen from becoming cluttered, many of the toolbars are not
placed on the screen by default. The toolbars you'll be using most often are displayed first; others
that are less frequently used are kept out of sight until you need them and select them from the list.
Here are brief descriptions of all the toolbars available:

3D Orbit  Tools to control 3D views (not available in LT).

CAD Standards  Tools that let you check the layer, dimension, and text styles against standards
that you have created (not available in LT).

Dimension Commands that help you dimension your drawings. Many of these commands are
duplicated in the Dimension pull-down menu. See Chapter 9.

Draw Commands for creating common objects, including lines, arcs, circles, curves, ellipses, and
text. This toolbar appears in the AutoCAD window by default. Many of these commands are
duplicated in the Draw pull-down menu.

Draw Order Commands that let you arrange the order of overlapping objects. If an object covers
another object that you need to have visible, you can use the Draw Order to “move” an object
behind another or to the back of a set of objects (not available in LT).

Inquiry Commands for finding distances, point coordinates, object properties, mass properties,
and areas.

Insert Commands for importing other drawings, raster images, and OLE objects.

Layer Drop-down list and tools for controlling layer properties located just below the Standard
toolbar.

Layouts Tools that let you set up drawing layouts for viewing, printing, and plotting.

Modify Commands for editing existing objects. You can move, copy, rotate, erase, trim, extend,
and so on. Many of these commands are duplicated in the Modify pull-down menu.

Modify I’ Commands for editing special complex objects such as polylines, multilines, 3D
solids, and hatches.
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Properties  for a set of drop-down lists and tools for manipulating the properties of objects. This
toolbar is normaﬂy docked to the right of the Layer toolbar, just below the Standard toolbar.

Object Snap Tools to help you select speciﬁc points on objects, such as endpoints and midpoints,
See Chapter 3.

Refedit  Tools that allow you to make changes to symbols or background drawings that are
imported as external reference drawings. See Chapter 13 for more about external references (not

available in LT').
Reference Commands that control cross-referencing of drawings. See Chapters 6 and 13.
Render Commands to operate AutoCAD’s rendering feature. See Chapter 18 (not available in LT").

Shade  Offers tools to control the way 3D models are displayed. See Chapter 16 for more on
Shade (not available in LT).

Solids  Commands for creating 3D solids. See Chapter 19 (not available in LT).
Solids Editing Command for editing 3D solids. See Chapter 19 (not available in LT).

Standard The most frequently used commands for view control, file management, and editing,

This toolbar is normally docked below the menu bar.

Styles  Tools that control style options such as text styles and dimension styles.

Surfaces Commands for creating 3D surfaces. See Chapters 16 and 17 (not available in LT).
Text  Tools for creating and editing text.

UCS  Tools for setting up a plane on which to work. UCS stands for User Coordinate System.
This is most useful for 3D modeling, but it can be helpful in 2D drafting, as well. See Chapter 17.

UCSII Tools for selecting from a set of predeﬁned user coordinate systems.
View  Offers tools to control the way you view 3D models. See Chapter 16 for more on 3D views.

Viewports  Tools that let you create and edit multiple views to your drawing. See Chapter 13
for more about viewports.

Web  Tools for accessing the World Wide Web, as discussed in Chapter 22.
Zoom Commands that allow you to navigate your drawing.

You'll get a chance to work with all the toolbars over the course of this book. If you use the book
simply as a reference, be sure to read through the exercises for explanations of which tools to use for
speciﬁc operations.
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MENUS VERSUS THE KEYBOARD

Throughout this book, you will be told to select commands and command options from the pull-down
menus and toolbars. For new and experienced users alike, menus and toolbars offer an easy-to-remember
method for accessing commands. If you are an experienced AutoCAD user who is used to the earlier versions
of AutoCAD, you still have the option of entering commands directly from the keyboard. Most of the key-
board commands you know and love still work as they did.

Another method for accessing commands is to use accelerator keys, which are special keystrokes that open
and activate pull-down menu options. You might have noticed that the commands in the menu bar and
the items in the pull-down menus all have an underlined character. By pressing the Alt key followed by the
key corresponding to the underlined character you activate that command or option, without having to
engage the mouse. For example, to issue File > Open, press Alt, then F, and then finally O (Alt+F+0).

Many tools and commands have keyboard shortcuts; shortcuts are one-, two-, or three-letter abbrevia-
tions of a command name. As you become more proficient with AutoCAD, you may find these shortcuts
helpful. As you work through this book, the shortcuts will be identified for your reference.

Finally, if you are feeling adventurous, you can create your own accelerator keys and keyboard shortcuts for
executing commands by adding them to the AutoCAD support files. Chapter 21 discusses how to customize
menus, toolbars, and keyboard shortcuts.

Working with AutoCAD

Now that you’ve been introduced to the AutoCAD window, let’s try using a few of AutoCAD’s com-
mands. First, you’H open a sample file and make a few simple modifications to it. In the process, you’ﬂ
become familiar with some common methods of operation in AutoCAD,

Opening an Existing File
In this exercise, you will get a chance to see and use a typical Select File dialog box. To start with, you
will open an existing file.

1. From the menu bar, choose File > Close. A message appears asking you if you want to save
the changes you've made to the current drawing. Click No.

2. Choose File > Open to open the Select File dialog box. This is a typical Windows file dialog
box, with an added twist. The large Preview box on the right allows you to preview a drawing
before you open it, thereby saving time while searching for files. To the left is a panel known as
the Places List in which you can find frequently used locations on your computer or the Internet.
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TIP  If you don’t see a Preview box in the Select File dialog box, click the word View in the upper-right corner, and then
select Preview  from the list that appears.

3. In the Select File dialog box, open the Look In drop-down list and locate the \AutoCAD2004\
Projects\Chapter 01 folder. (You may need to explore the list to find it.) The file list changes
to show the contents of the \AutoCAD2004\Projects\Chapter 01 folder.

4. Move the arrow to the Clip.dwg file and click it. Notice that the C1ip.dwg filename now
appears in the File Name input box above the file list. Also, the Preview box now shows a
thumbnail image of the file.

TiP  The Clip.dwg dmwing is included on the companion CD. If you cannot find this filt; be sure you installed the
sample drawings from the companion CD. See the Readme file on the CD for installation instructions.

5. Click the OK button at the bottom of the Select File dialog box. AutoCAD opens the
Clip.dwg file, as shown in Figure 1.10.

23
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FIGURE 1.10 £F £\ AutoCADZ004' Projects Chapter 01'clip.dwg

The Layout view of
the C1ip. dwg file

The Clip.dwg file opens to display a Layout tab view of the drawing. You will know this by look-
ing at the tabs at the bottom of the AutoCAD Window. Currently, the Layout] tab is highlighted.

You may recall that a layout is a type of view that lets you lay out different views of your drawing
in preparation for printing. Also notice that the AutoCAD window’s title bar displays the name of
the drawing. This offers easy identification of the file.

This particular file contains both 2D drawings and a 3D model of a typical locking clip. The

Layout tab view shows a top, front, and right side view as well as an isometric view.

Getting a Closer Look
One of the most frequently used commands is Zoom, which gives you a closer look at a part of your
drawing. It offers a variety of ways to control your view. Now you'll enlarge a portion of the clip draw-
ing to get a more detailed look. To tell AutoCAD what area you want to enlarge, you use what is called
a zoom window.

You'll start by switching to a Model Space view of the drawing. The Model tab places you in a

workspace where you do most of your drawing creation and editing.

1. Click the Model tab at the bottom of the AutoCAD window.
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Your view changes to show the full 3D model with the 2D representations of the model.
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display changes to a two-dimensional view looking down on the drawing.
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2. Choose View > 3D Views > Plan View > World UCS. You can also type Plan! . Your

P

3. Click the Zoom Window button on the Standard toolbar.

You can also choose View > Zoom > Window from the puﬂ—down menu or type the com-

mand: ZAd W,

point you just picked, while the other corner follows the cursor.

. The Command window displays the First corner: prompt. Look at the top image in Fig-
ure 1.11. Move the crosshair cursor to a location similar to the one shown in the figure; then
left-click the mouse. Move the cursor and the rectangle appears, with one corner fixed on the

25
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FIGURE 1.11 & C:\Auto 4\Projects',Chapter 01',clip.dwg
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5. The Command window now displays the Specify first corner: and Specify opposite
corner: prompts. Position the other corner of the window so it encloses the lower image of
the clip, as shown in the top image in Figure 1.11, and left-click the mouse again. The clip
enlarges to fill the screen (see the bottom image in Figure 1.11).

TIP  If you decide that you don’t like the position of the first point you pick while defining the zoom window, you can right-
click the mouse and re-select tbeﬂrst point. This only works when you enter ZA Wl to issue the Zoom Window
command or when you select Zoom Window from the Standard toolbar.

In this exercise, you used the Window option of the Zoom command to define an area to enlarge
for your close-up view. You saw how AutoCAD prompts you to indicate first one corner of the selec-
tion window and then the other. These messages are helpful for first-time users of AutoCAD. You will
use the Window option frequently—not just to define views, but also to select objects for editing.
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Getting a close-up view of your drawing is crucial to working accurately, but you'll often want to
return to a previous view to get the overall picture. To do so, click the Zoom Previous button on the
Standard toolbar.

Dimepsion  Modify  Express  Window Help
£- |wxa=mmnal|
'I T £ |JJ I?boom Previous | j ||

Do this now, and the previous view—one showing the entire clip—rteturns to the screen. You can
also get there by choosing View > Zoom > Previous.

You can quickly enlarge or reduce your view using the Zoom Realtime button on the Standard
toolbar.

TIP  You can also zoom in and out using the Zoom In and Zoom Out buttons in the Zoom Window flyout of the Standard
toolbar. The Zoom In button shows a magnifying glass with a plus sign; the Zoom Out button shows a minus sign. If you have
a mouse equipped with a scroll wheel, you can zoom in and out just by turning the wheel. The location of the cursor at the time
you move the wheel will determine the center of the zoom. A click-and-drag of the scroll wheel will let you pan your view.

1. Click the Zoom Realtime button on the Standard toolbar. You can also right-click and choose
Zoom from the shortcut menu. The cursor changes to a magnifying glass.

2. Place the Zoom Realtime cursor slightly above the center of the drawing area, and then click
and drag downward. Your view zooms out to show more of the drawing,

3. While still holding the left mouse button, move the cursor upward. Your view zooms in to
enlarge your view. When you have a view similar to the one shown in Figure 1.12, release the
mouse button. (Don't worry if you don't get exactly the same view as the figure. This is just for

practice.)
FIGURE 1.12 =Iofxi
The final view you =
want to achieve in
step 3 of the exercise
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4. You are still in Zoom Realtime mode. Click and drag the mouse again to see how you can fur-
ther adjust your view. To exit, you can select another command besides a Zoom or Pan com-
mand, press the Esc key, or right—click your mouse.

5. Right—dick now, and choose Exit from the shortcut menu to exit the Zoom Realtime command.

As you can see from this exercise, you have a wide range of options for viewing your drawings, just
by using a few buttons. In fact, these buttons, along with the scroll bars at the right side and bottom
of the AutoCAD window, are all you need to control the display of 2D drawings.

THE AERIAL VIEW WINDOW

The Aerial View window is an optional AutoCAD display tool. It gives you an overall view of your drawing,
regardless of the magnification you are using for the drawing editor. Aerial View also makes it easier to get
around in a large-scale drawing. You’ll find that this feature is best suited to complex drawings that cover
great areas, such as site plans, topographical maps, or city planning documents.

You’ll find a detailed description of the Aerial View window in Chapter 6. As you become more comfortable
with AutoCAD, you might want to try it.

Saving a File As You Work

It is a good idea to save your file periodically as you work on it. You can save it under its original
name (choose File > Save) or under a different name (choose File > Save As), thereby creating a
new file.

By default, AutoCAD automatically saves your work at 10-minute intervals under the name AUTO.SVS$;
this is known as the Automatic Save feature. Using settings in the Options dialog box or system variables,
you can change the name of the autosaved file and control the time between autosaves. See Chapter 3
for details.

TIP By dg‘cmlt, in Windows XP, the AUTO. SV$file is stored in the C:\Documents and Settings\User
Name\Local Settings\Temp\. You can ﬁnd the exact location for your system by entering Savefilepath - at the
command prompt.

Let’s first try the Save command. This quickly saves the drawing in its current state without exiting
the program.

Choose File > Save. You will notice some disk activity while AutoCAD saves the file to the hard
disk, and you'll see a progress indicator in the status bar. As an alternative to choosing File > Save,
you can press Alt+F S. This is the accelerator key combination, also called hotkey, for the File > Save
command.

Now try the Save As command. This command displays a dialog box that allows you to save the
current file under a new name.

1. Choose File > Save As or type Saveas.] at the command prompt to open the Select File dialog
box. Notice that the current filename, C1ip.dwg, is highlighted in the File Name input box.
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2. Type Myfirst. As you type, the name Clip.dwg disappears from the input box and is replaced
by Myfirst. You don't need to enter the .dwg filename extension. AutoCAD adds it to the file-
name automatically when it saves the file.

3. Click the Save button. The dialog box closes, and you will notice some disk activity.

You now have a copy of the clip file under the name Myfirst.dwg. The name of the file displayed
in the AutoCAD window’s title bar has changed to Myfirst. From now on, when you use the File >
Save option, your drawing will be saved under its new name. Saving files under a different name can
be useful when you are creating alternatives or when you just want to save one of several ideas you
have been trying out.

TIP  If you are working with a small monitor, you might want to consider closing the Draw and Modify toolbars. The
Draw and Modg’fy pull~down menus offer the same commands, so you won’t lose any funftz’onalz’ty by flosing these tool-
bars. If you rmlly want to maximize ‘your dmwing area, you can also turn off the scroll bars and reduce the Command
window to a single line. Appendix B shows how to do this. You can also Qain some extra dmwz’ng space by clicking the
Maximize button in the upper~r{gbt corner of the dmwing area.

Making Changes

You will frequently make changes to your drawings. In fact, one of AutoCAD’s primary advantages is
the ease with which you can make changes. The following exercise shows you a typical sequence of
operations involved in making a change to a drawing:

1. From the Modify toolbar, click the Erase tool (the one with a pencil eraser touching paper). This

activates the Erase command. You can also choose Modify > Erase from the pull-down menu.

Notice that the cursor has turned into a small square; this square 1s called the pickbox. You also
see Select objects: in the command prompt area. This message helps remind new users
what to do.

2. Place the pickbox on the cross hatch pattern of the clip (see Figure 1.13) and click it. The
cross hatch of the clip becomes highlighted. The pickbox and the Select object: prompt

remain, telling you that you can continue to select objects.
3. Now press . The cross hatch disappears. You have just erased a part of the drawing.

In this exercise, you first issued the Erase command, and then you selected an object by clicking 1t
using a pickbox. The pickbox tells you that you must select items on the screen. Once you’ve done
that, press I to move on to the next step. This sequence of steps Is common to many of the com-

mands you will work with in AutoCAD.
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FIGURE 1 . 13 £ C\AutoCADZ004'Project s Chapter 01' clip.dwg ;IEIEI
Erasing a portion = =
of the clip

N

J RN

| A [k [ ¥} Model § Lapoufd

TIP  You can also click an object or a set of objects and then press the Delete key.

Opening Multiple Files

You can have multiple documents open at the same time in AutoCAD. This can be especially helpful
if you want to exchange parts of drawings between files or if you just want another file open for ref-
erence. Try the following exercise to see how multiple documents work in AutoCAD.

1. Choose File > New to open the Select Template dialog box.
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2. Make sure acad.dwt is selected, and then click Open.
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NOTE  If you see the Create New Drawing dialog box after step 2, click the Start From Scratch button and select Imperial,
then click OK and AutoCAD will display a default document. You'll learn more about the Create New Drawing dialog
box in Chapter 2.

3.

Choose Window > Tile Verticaﬂy to get a view of both drawing files. The options in the
Window pull-down menu act just like their counterparts in other Windows programs that
allow multiple document editing.

TP When you create a new file in AutoCAD, you are actually opening a copy of a template file as you saw in step 1.
A template file is a blank file that is set up for specific drawing types. The acad. dwt file is a generic template set up for
imperial measurements. Another template file called acadiso.dwt is a generic template useful for metric measurements.
Other templates are set up for specific drawing sheet sizes and measurement systems. You'll learn more about templates in

Chapter 6.

You can now see bOth Of the ﬁles you have open. Let’s see what can be done Wlth these two ﬁICS.

1.
2.
3.

5.

Click in the window with the clip drawing to make it active.
Choose View > Zoom > All to get an overall view of the drawing,

Click the 2D version of the clip at the bottom of the clip drawing to select it. A series of
squares appears on the drawing. These are called handles, and you'll learn more about them in
the next chapter.

Click and drag the selected object, but avoid clicking any of the blue squares. You'll see a small

rectangle appear next to the cursor.

i Drawing2.dwg M [=]E3]| 5 2 AutoCADZ004' Projects) Chapter D1 clip.dig -0 x|

||
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While still holding the left mouse button, drag the cursor to the new file window. When you
see the clip appear in the new drawing window, release the mouse button. You've just copied
part of a drawing from one file to another.
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Now you have two files open at once. You can have as many files open as you want, as long as you
have adequate memory to accommodate them. You can control the individual document windows as
you would any window, using the Window puﬂ—down menu or the window control buttons in the
upper-right corner of the document window.

Adding a Pre-Drawn Symbol with the Tool Palette

In the last exercise, you saw how you can easily copy an object from one file to another using a click-
and-drag method. Now let’s take a look at another tool that lets you click and drag symbols into
your drawings.

1. Click the Tool Palettes tool in the Standard toolbar to open the Tool palettes.

2. Make sure the Sample Office Project tab is selected in the Tool palettes, and then click and drag
the Chair - Desk symbol from the Tool palettes into the new file window. The chair symbol

appears in the window.

3. Click the Imperial Hatch tab, and then click and drag any of the solid patterns into the chair.
The chair is filled with the solid pattern.

While you’ve got the Tool palettes open, let’s look at some of its unique features.

1. Right-click the Tool palettes, and then choose Transparency from the shortcut menu to open
the Transparency dialog box.

@rranzporency

Less More
H | f

(L

Tranzparency Lewel

[~ Turn off window transparency

oK | Cancel |

2. Move the Transparency Level slider to the middle of the dialog box, and then click OK. You
now see objects that are “behind” the Tool palettes.

You can't actuaﬂy select points that are “behind” the palettes as you draw, but the Transparency
feature can help you visualize your drawing more easﬂy while the palettes are open.
Let’s take another look at a display feature of the Tool palettes.

Tip The Command window also bas a Transparency option. To use it, you must first move the Command window fo
an undocked position toward the middle of the AutoCAD window. You can then right~click the Command window title
bar and choose Transparency. You will see the same Transparency dialog box you see when you right~click the Tool palettes
and choose Transparency.
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1. Right-dick the Tool palettes again, and choose Auto-Hide.

2. Move the cursor away from the Tool palettes. The Tool salettes close so that just the Tool
palettes title bar is visible.

3. Move the cursor on top of the Tool palettes title bar. The palette opens to reveal the palettes.
4. Turn the Auto-Hide feature off by right-clicking the Tool palettes and selecting Auto-Hide.
5. Click the X in the upper-right corner of the Tool palettes.

The Tool palettes oftfer a way to quickly add fill patterns and pre-drawn symbols to your drawing.

It is a great tool to help you manage your library of custom, pre-drawn symbols. You've just gotten a
taste of what it can do, but to make full use of its capabilities, you’ﬂ need to learn about blocks, hatch
patterns, and the AutoCAD DesignCenter. You won't see much of this tool in the beginning of this
book, but keep it in the back of your mind as you begin to learn more about AutoCAD. After finish-
ing the first part of this book, you can skip ahead to Chapter 22 to learn how to use and customize
the Tool palettes.

Closing AutoCAD

When you are done with your work on one drawing, you can open another drawing, temporarily
leave AutoCAD, or close AutoCAD entirely. To close all the open files at once and exit AutoCAD,
choose File > Exit.

1. Choose File > Exit, the last item in the File menu. A dialog box appears, asking you if you want
to “Save Changes to Myfirst.dwg?” and offering three buttons labeled Yes, No, and Cancel.



34

CHAPTER1 THISIS AUTOCAD

&

x

L) ': Save changes ko Ci\AutoCADZ004 Projectsymyfirst dwg?
L]

Yes Mo | Cancel |

Click the No button.

AutoCAD displays another message asking you if you want to save Drawing2.dwg, which is
the new drawing you opened in the last exercise. Click the No button again. AutoCAD closes
both the clip drawing and the new drawing and exits without saving your changes.

Whenever you attempt to exit a drawing that has been changed, you get this same inquiry box. This

request fOI‘ confirrnation 1sa safety feature that lets YOLI change YOL]]C mind and save YOLII' changes before

you exit AutoCAD. In the previous exercise, you discarded the changes you made, so the clip drawing

reverts to its state before you erased the handle. The new drawing 1s completely discarded, and no file

is saved.

If you only want to exit AutoCAD temporarily, you can minimize it SO it appears as a button on
the Windows XP or Windows2000 status bar. You do this by clicking the Minimize button in the
upper—right corner of the AutoCAD window; the Minimize button is the title-bar button that looks
like an underscore (_) Alternatively, you can use the Ale+Tab key combination to switch to another

prograrn.

TIP  The AutoCAD Express Tools offer the Close All Drawings and Quick Exit tools that let you close multiple dwg
fz'les at one time. See C/mpter 20 for more on the Express tools.

If You Want to Experiment...

Try opening and closing some of the sample drawing files on the accompanying CD.

1.
2.
3.

Start AutoCAD by choosing Start > Programs > AutoCAD 2004 > AutoCAD 2004.
Close the AutoCAD 2004 window, and then choose File > Open.

Use the dialog box to open the Myfirst file again. Notice that the drawing appears on the
screen with the handle enlarged. This is the view you had on screen when you used the Save
command in the earlier exercise.

Erase the cross hatch, as you did in the earlier exercise.

Choose File > Open again. This time, open the Dhouse file from the Figures folder. The 3D

Dhouse drawing opens.

Choose File > Exit. Notice that you exit AutoCAD without getting the Save Changes dialog
box for the Dhouse drawing. This is because you didn't make any changes to the Dhouse file.





