
The Maya Interface

Three-dimensional modeling and animation are challenging tasks. Trying

to get your vision of a universe transferred into pixels is part science and part art and takes a

great deal of perseverance. Fortunately, the engineers at Alias have spent a large amount of

time and energy making Maya as helpful and transparent to use as a complex program can

be. Still, when you are confronted with a program as deep as Maya, a good introduction to its

components can be helpful in getting the most from your work as quickly as possible. This

chapter explores Maya’s user interface, examining each element of the work environment in

turn. After reading through the chapter, you should have a good understanding of the major

components of Maya’s GUI (graphical user interface) and know how to use these elements in

your modeling and animation work.

■ What’s behind the Maya interface?

■ Scene windows and scene objects

■ Window layouts

■ The Hotbox

■ Menus and shelves

■ The Outliner and the Hypergraph

■ The Channel Box and the Attribute Editor

■ The Timeline

■ The Command line, the Feedback line, and the Script Editor
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What’s Behind the Maya Interface?
What makes Maya work well as an animation package? First, interacting with it is a straight-

forward process, for several reasons. You can easily navigate all scene windows, plus the

Hypershade, Hypergraph, and other windows, via the same keyboard and mouse combinations

for zooming, tracking, and rotating. (Rotating works only in perspective camera views.)

Because navigating works the same way in all windows, you have to learn only one set of com-

mands to get around in Maya’s world. Moving objects around a Maya scene window is similarly

intuitive: select the Move, Scale, or Rotate (or any other) tool, grab a manipulator handle (or

the center box, to move on all axes simultaneously), and alter the object. To try an example,

create a new scene in Maya, and add a ball (by choosing Create ➔ NURBS Primitives ➔ Sphere).

Now rotate around the ball by holding down the Alt key and clicking the left mouse button.

This type of rotation is known as camera or scene rotation. To rotate the ball itself, choose the

Rotate tool from the Tool Box, located on the left of the scene window (or simply press the E

key on the keyboard), select any of the manipulator rings around the ball, and then rotate the

ball by dragging with the left mouse button, as in Figure 1.1. To move an object, select the

Move tool (or press the W key). To scale, select the Scale tool (or press the R key).

T H R E E - B U T T O N  M O U S E  C O N V E N T I O N S  I N  M A Y A

Maya makes extensive use of all three mouse buttons. This book—as well as the Maya documentation—uses a

shorthand notation to describe the basic mouse operations:

Click or LM click means to click (press and release) the left mouse button.

Drag or LM drag means to click the left mouse button, hold it down, and drag.

Shift+click means to LM click, hold down the Shift key, and click another item.

Choose means to either click or hold down the left mouse button and select an item from a menu.

MM drag means to click and drag with the middle mouse button.

RM choose means to hold down the right mouse button (in a specified area) and choose an item from the pop-

up contextual menu.

Rotate (Tumble) view means to rotate the (perspective) camera; that is, hold down the Alt key and the left

mouse button, and then drag in the perspective window to rotate the view.

Move view means to move any camera; that is, hold down the Alt key and the middle mouse button, and then

drag in any scene window.

Scale view means to scale—or zoom—any camera; that is, hold down the Alt key and the right (or left and mid-

dle) mouse button, and then drag in any scene window to zoom (or scale) the view in or out. This setup allows a

straightforward mouse button mapping of left=rotate, middle=pan, and right=zoom.
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Another powerful advantage of Maya lies in how you interact with the user interface. You

can almost always accomplish a task in two or more ways—called workflows—in Maya. For

example, if you prefer not to use menus on top of the screen, you can use Maya’s Hotbox

(which you can customize) to access all menus or any grouping therein by merely pressing

and holding the spacebar, as in Figure 1.2.

You can also create items using the current buttons on the shelf or, equivalently, using

menu commands. Most impressive, however, is that Maya will let you decide how you inter-

act with it. If you are not satisfied with Maya’s interface, you can alter it in many ways,

including creating marking menus, shelf buttons, and hot keys. Although all these user-

customizable features can contain extremely complex instructions, you can create them

rather quickly (especially the shelf buttons).

Finally, Maya’s plug-in architecture (its API, or application programming interface) and its

built-in scripting language, MEL (Maya Embedded Language), are open and comprehensive.

Because of Maya’s API, plug-ins (such as the built-in mental ray and Maya Fur) fit seamlessly

into the program, so much so that it is often difficult to determine where the main program

stops and the plug-in begins. Although the API is fairly

complex and is best left to knowledgeable program-

mers, MEL is a reasonably simple scripting language

that gives just about anyone with a bit of programming

experience access to nearly all of Maya’s powerful fea-

tures in the graphical user environment. Not only can

you create specialized, time-saving scripts with MEL,

you can also create entire windows or even a whole

new GUI for the program (because Maya’s entire GUI

is built on MEL scripts in the first place). For example,

a technical director can create a custom character

animation interface for their artists, allowing them to

animate this character without knowing anything

about the low-level details of the construction and

“rigging” (or animation setup) of the character.

As should be obvious from these features, Maya

provides an up-to-date, intuitive environment that

you can customize. Whether you have a shop of one

person or one hundred, Maya’s adjustable interface

will get you building complex animations extremely

quickly and efficiently. Let us now take a more thor-

ough tour of the Maya interface, looking at several

important elements of the GUI.

W H A T’S B E H I N D T H E M A Y A I N T E R F A C E? ■ 5

Figure 1.1

Rotating a 

sphere in Maya

Figure 1.2

The Maya Hotbox
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W H A T ’ S  N E W  I N  M A Y A  5

Alias continues to improve Maya in version 5 with a number of new features and upgrades

that make Maya easier to learn and use than ever before. Here are a few highlights:

• Maya’s rendering architecture has been completely reworked and now allows simple

access to all of Maya’s render options, including software and hardware rendering, the now

completely integrated MentalRay rendering engine (which includes global illumination and

caustics abilities), and the all new Vector renderer, which supports such vector formats as

Flash, SVG (Scalable Vector Graphics), and Illustrator, and can also render “toon shader”

bitmap images. The Vector rendering engine is only available for OS X and Windows ver-

sions of Maya, due to a lack of support for the vector output formats in Irix and Linux.

• Maya’s help pages have been completely revamped to provide a uniform look from one

platform to the next. The web pages are now properly searchable, due to Alias’s use of 

a mini web server embedded into the Maya startup actions, that provides server-side

functionality, including searchability. Now all platforms (including OS X) use a web

browser interface for help functions. Due to the way help files are now served, Maya

must be running in order for you to access help functions.

• Learning Movies and Tutorials, found in the Help menu, are a series of MPEG (Moving Picture

Experts Group) movies and web pages, respectively, that demonstrate essential Maya skills.

• The Move tool now has a Move Along Rotation Axis option, which allows objects to be

moved along each axis of an object that is no longer oriented with world space. To

access this tool, double-click the Move tool icon on the left side of the main window, or

with the Move tool selected, choose Window ➔ Settings/Preferences ➔ Tool Settings.

• Inverse and Forward Kinematic skeletons are now easier than ever to set up and use (see

the Skeleton menu in the Animation menu set), and FK/IK skeleton motion can now be

blended via the ikBlend attribute, which appears in the Channel Box when FK/IK skele-

tons are created.

• Animation muting, which turns off animation for selected channels of a node, can be

useful for a number of purposes, including model tweaking after animation work has

begun. To access this tool, right-click a channel, and choose Mute Selected to mute a

selected channel or choose Mute All to mute the entire node.

• Fluid Effects now allows creation of a pond (small body of water) as well as an ocean,

and you can now give both a pond and an ocean a wake function, which simulates

interaction of an object (such as a boat) with the surface of the body of water.

• Fur now has a clumping attribute, available upon creating a fur description, which allows

for “dirty” fur that is not evenly distributed across the body of an object. This feature,

which can be painted onto the fur map, allows for much more natural-looking long-haired

creatures, whose hair often clumps together in areas such as the chest or leg joints.

6 ■ C H A P T E R 1:  TH E MA Y A IN T E R F A C E
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Interface Elements
Although Maya is composed of many elements, they can be grouped into about eight cate-

gories. We will quickly examine each category in turn.

Scene Windows
The scene windows are your primary interface with the objects (and lights and cameras) you

create. Opening a new Maya scene opens the default configuration, which is one large scene

window (from the point of view of the default perspective camera), with the Channel Box

forming a column at right, similar to what is shown in Figure 1.3.

Once the default window is open, you can activate the perspective view panel by clicking

anywhere inside it. When you select this (or any) panel, its borders turn blue. At this point,

you can rotate, scale, or translate the view to adjust what you see in this window. (For

specifics on how to do this, see the earlier sidebar on mouse conventions.) The default scene

window is called the persp (for perspective) view and is simply the view from the default

perspective camera that Maya builds upon opening a new scene.

Figure 1.3

The Maya user interface

By default, the Channel Box toggles with the Attribute Editor. To force the Attribute Editor to

open in a separate window, choose Window ➔ Settings/Preferences ➔ Preferences, and click

the Open Attribute Editor In Separate Window radio button.

I N T E R F A C E E L E M E N T S ■ 7
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You can build other perspective cameras by choosing Create ➔ Cameras ➔ Camera. To

view the scene through this new camera, choose Panels ➔ Perspective ➔ camera1.

In addition to the default perspective camera, Maya also creates three orthographic

views—top, side, and front—that you can also see (in what’s called a “four-view” window) by

selecting the perspective window and then quickly pressing and releasing the spacebar, as

shown in Figure 1.4.

To fill the screen with one of the orthographic views, click in it (to select this window),

and press and release the spacebar again. Being able to switch quickly between view layouts

and window sizes greatly speeds up your workflow in Maya, because no extensive menu

selection process is required.

Figure 1.4

The four-view display

To switch views in Maya without losing your current selection, MM or RM click in the view you

want to activate (for example, the front view), and then press the spacebar.

8 ■ C H A P T E R 1:  TH E MA Y A IN T E R F A C E
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O R T H O G R A P H I C  A N D  P E R S P E C T I V E  V I E W S

An orthographic view is a non-perspective view from a 90-degree (or orthogonal) angle.

Because these are not perspective views, they do not reduce the size of objects as they move

away from the camera. A perspective view of a row of columns, for example, would show the

back column as smaller than the column nearest the camera. An orthographic view, on the

other hand, will show all columns as the same size, since scale is not reduced as a function of

distance from the camera in this view. You can think of an orthographic view as similar to a

blueprint drawing; a perspective view is similar to a picture from a camera.

Quick Layout Buttons

Another quick way to switch between view layouts is to use the Quick Layout buttons.

The Quick Layout buttons (see Figure 1.5) are in the Tool Box (more on the Tool Box

later), which is to the left of the Maya workspace. Simply click any of the first six but-

tons for a different view layout. To change a button, RM click it to display the Saved

Layouts pop-up menu and choose from a variety of view layouts.

Perspective View Orthographic View

I N T E R F A C E E L E M E N T S ■ 9

Figure 1.5

The Quick Layout 

buttons

4230c01.qxd  10/21/03  10:45 PM  Page 9



After you configure the Panel/Layout button to your liking, you might want to save the

layout. RM click the Panel/Layout button and choose Save Current Layout from the pop-up

menu. A small window will open, asking you to name your layout. Type My Layout (or any-

thing you please) and click OK. To access your saved layout, RM click any of the first six

Quick Layout buttons to open the Saved Layouts pop-up menu (as you did before) and

choose it from the menu.

Moving in Scene Windows

Moving around in scene windows is fairly straightforward, once you learn the keyboard and

mouse combinations for doing so. Additionally, because you use the same commands to

move in all scene windows (plus several other windows), once you learn how to move in one

window, you can move in all. Because the perspective window has the most options (you 

can rotate, or tumble, the view as well as zoom and translate), let’s quickly look at how to

maneuver in the default perspective window.

Open a new scene in Maya; then hold down the Alt key and the left mouse button and

drag the mouse around. The scene should spin around as you drag the mouse.

To translate a scene (move up/down or left/right), hold down the Alt key once again, hold

down the middle mouse button (MMB), and drag the mouse. You will see the scene move

around with the mouse movements. (Notice that the camera is actually moving opposite to

your mouse movements: as you drag right, the camera moves left, so the objects appear to

move right. You can see this clearly if you make cameras visible and look at the camera in a

different view as you drag.)

If the scene does not rotate as you drag (you might see the cursor become a circle with a line

through it), you could be in an orthographic view, which does not allow rotations. To move

to a perspective view, either press the spacebar to display the four-view layout or LM click the

four-view Quick Layout button in the Tool Box; then click in the perspective window (top

right) and press the spacebar again.

The appearance of the seventh button, the Panel/Layout button, depends on the view layout

you chose from the first six buttons. For example, if you click the first Quick Layout button

(which, by default, is the Single Perspective View) the Panel/Layout button has one arrow. If

you chose the Four View button, four arrows appear on the Panel/Layout button. You can

change a specific panel by LM clicking any of the arrows and choosing from the pop-up

menu. RM clicking will give you options to change the layout configuration such as Single

Pane or Two Panes Side By Side.

10 ■ C H A P T E R 1:  TH E MA Y A IN T E R F A C E
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To scale your view (zoom the camera in and out), hold down the Alt key once again, hold

down the right (or left and middle) mouse button, and drag. As you drag right, the scene

grows larger (you’re zooming in); as you drag left, the scene grows smaller (you’re zooming

out). To quickly zoom in to a specific area of your scene, hold down the Alt and Ctrl keys,

and then drag (with the left mouse button) a box around the area of the scene, starting on

the left side. When you release the mouse, the scene zooms in, covering the area you out-

lined. If you drag the mouse from right to left, the scene zooms out so that the entire scene

window you start with fits into the box you drag. (The smaller your box, the farther out you

zoom.) If you now open the Hypergraph or the Hypershade (choose Window ➔ Hypergraph

or Window ➔ Rendering Editors ➔ Hypershade), you can use the same key/mouse combina-

tions to scale or move around. You will notice, however, that you cannot rotate either of

these views, because this would accomplish nothing useful.

You can think of the Alt key as the “scene movement key.” Whenever you hold down the

Alt key, you are in scene manipulation mode, rather than in object manipulation (or some

other) mode. The consistent use of the Alt key for movement is just one example of the

thought that has gone into the Maya interface.

Scene Objects
Scene objects (primitives, curves, cameras, and lights) are the fundamental building blocks

from which you create a Maya scene or animation. The procedure for creating and manipu-

lating any object is generally the same: create the object (most often by using the Create

menu), choose a manipulation tool (such as Translate or Rotate), and alter the object. You

can also adjust the pivot point (or “center”) of an object, and you can manipulate the individ-

ual components of geometric objects.

Creating Scene Objects

Because you create most scene objects in much the same fashion, we’ll go through a few rep-

resentative examples here, rather than discuss how to create all possible objects in Maya. If

you have specific questions about creating a type of object that is not covered here, you can

always check Maya’s online documentation (accessed via the Help menu).

Maya’s built-in help files are a great (and easy-to-use) resource. To access them, choose Help ➔

Contents And Search (or Index). You can also press F1 to access the main help library. After

opening the Maya documentation window (which opens in a web browser because it is an

HTML document), you can search for a term, browse through a complete index of all Maya

documents (the index alone is about 2MB of data!), or read any of the Maya manuals in elec-

tronic form.

I N T E R F A C E E L E M E N T S ■ 11
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To create a primitive (a sphere or a cone, for example), you choose the type of primitive

you want to create from the Create menu. For a simple three-dimensional object (such as a

torus or a cube), you can choose from polygonal, NURBS, or Subdivision Surface primitives.

Using the NURBS option, you can also select a two-dimensional (nonsurface) square or cir-

cle. When you create an object, you can either use the last saved settings or open the Cre-

ation Options window, by clicking the option box (❑) next to the name of the object, and

adjust the object’s settings before creating it.

You create NURBS (Non-Uniform Rational B-Spline) objects via a series of curves (or

“isoparms”) that are mathematically derived from several points (control vertices, or CVs).

NURBS surfaces are more complex to calculate than, say, polygonal faces, but they can 

be warped and twisted more before they show excessive unnatural creasing. Polygonal 

surfaces, on the other hand, are created by placing many small triangular or rectangular sur-

faces together. Polygons are simpler to calculate—at least for simple surfaces—but tend to

show their constituent blocks if they are bent or distorted too much—especially if the sur-

faces are created with a minimal number of polygons, or facets. Subdivision Surfaces offers

the best of both geometric object types, providing the smoothness of NURBS with the 

benefits of more free-form polygonal modeling. NURBS and Subdivision Surfaces tend to 

be better suited to organic forms (such as bodies), and polygonal surfaces generally work

better for more mechanical objects (such as spaceships), but this is by no means a hard-

and-fast rule.

As an example, let’s create a default polygonal sphere and then use the option box to 

create a NURBS cylinder. To create the poly sphere, simply choose Create ➔ Polygon Primi-

tives ➔ Sphere. On releasing the mouse, you should see a

sphere appear at the center of Maya’s default grid. If you

look closely, you will see that the sphere consists of many

rectangular faces (more accurately called quadrilaterals)

that butt up against one another, forming the sphere. Now

move the sphere aside (press the W key and move the

sphere away from the center of the grid) and create a

NURBS cylinder with nondefault options. To access the

options window of the NURBS cylinder, choose Create ➔

NURBS Primitives ➔ Cylinder ❑ (choosing the ❑ symbol—

the option box—in a Maya menu item always opens an

options window). Upon releasing the mouse button, you

should see the window shown in Figure 1.6.

12 ■ C H A P T E R 1:  TH E MA Y A IN T E R F A C E

Figure 1.6

The NURBS Cylinder

Options window
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In this window, you can define any of the following:

• The pivot point

• The axis the cylinder will use as its long axis

• The start and end angles of the cylinder

• The radius

• The height (a higher number will make a taller cylinder)

• The number of sections (horizontal segments) and spans (vertical segments) the

cylinder has

For the purposes of this little example, try setting the End Sweep Angle to 270 (this will

create a three-quarters cylinder), set the Radius to 1 and the Height to 4 (making the cylin-

der taller), and set the Caps option to Both (creating a cap on both the top and bottom of the

cylinder). When you click the Create button at the bottom, you should get the object shown

in Figure 1.7.

You can almost always reset an object’s creation settings to their default values by choos-

ing Edit ➔ Reset Settings in the options window.

To see the object smooth shaded with textures (instead of a wireframe), press the 6 key on

your keyboard. To view an object at a smoother interactive resolution, press the 3 key. (Press-

ing these keys will not affect how the object renders, only how it is displayed.) Figure 1.7 uses

these settings to display the cylinder.

Creating a camera object is as simple as creating a geometric primitive object. Choose

Create ➔ Cameras, and then choose Camera, Camera And Aim, or Camera, Aim, And Up from

the submenu. A new perspective camera is created. (Perspective cameras are initially called

camera1, camera2, and so on until you save them with more specific names.) To adjust the

camera’s options as you create it, choose the option box (❑), and change the camera’s set-

tings. Although all the settings in the camera options window are a bit much for an introduc-

tory chapter, most are fairly self-explanatory to anyone familiar with photography or 3D

animation. The following are some notable options:

• You can make any new camera orthographic (as opposed to perspective).

• You have control over near and far clipping planes (where the camera stops “seeing”

objects that are too far away or too close).

• You can choose to have an aim point or an aim point and an up vector on the camera

(allowing you to manipulate where the camera is looking, for example, via a manipulator

handle outside the camera itself).

I N T E R F A C E E L E M E N T S ■ 13
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A cylinder created

using custom options
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Try creating a camera with an aim point (choose Create ➔ Cameras ➔ Camera And Aim).

When you create this camera, shown in Figure 1.8, it automatically has a second manipulator

handle for a new view node that you can move (by pressing the W key and dragging the han-

dle around), and the camera pans and tilts to point at the manipulator handle. For more on

camera options and other rendering basics, see Chapter 19, “Rendering Basics.”

To create lights, choose Create ➔ Lights and select a type of light. When creating lights,

you can choose from the following:

• Ambient (a light that fills all space evenly, such as indirect sunlight in a room)

• Directional (parallel light rays from one source, mimicking direct sunlight)

• Point (radial light such as that from a bare lightbulb)

• Spot (light as from a theatrical spotlight)

• Area (light emitted from a rectangular area that imitates a block light source such as a

window)

• Volume (a light that illuminates within the space of a given boundary)

For example, create a spotlight (choose Create ➔ Lights ➔ Spot Light ❑) with the follow-

ing options: Intensity 1.5, Cone Angle 50, Penumbra Angle 10, and Color a light blue. (Click

the default white color chip to display the Color Chooser; then choose a light blue color.)

The penumbra controls how quickly your spotlight “fades out” around its edges: a value of 

0 means that the spotlight goes from full intensity to 0 at its edges (not a very natural look);

a value of 10 or 20 degrees makes the spotlight fade out from full intensity to 0 over that

number of degrees. If your spotlight were aimed at a simple plane, the rendered image would

look something like the light on the right in Figure 1.9. (The one on the left is a spotlight

with a penumbra of 0.)

Figure 1.9

Two spotlights: the one

on the left has no

penumbra, and the 

one on the right has 

a Penumbra setting 

of 10 degrees.
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Figure 1.8

A camera with 

an aim point
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To see how an area light works, create a sphere, stretch it out, and add an area light. (Be

sure its direction vector is pointing at the sphere.) Stretch the area light out, and in the

Attribute Editor set the light’s decay rate to Quadratic. As you move the light (very) close to

the sphere, you will see an oblong of light appear on the sphere, shown in Figure 1.10,

matching the points where the light is closest to the sphere. Use the IPR renderer (click the

IPR icon in the status line) to see the light’s effect change as you adjust its attributes, and

note that the light falls off rapidly as distance from the area light increases.

You can also create either CV (control vertex) or EP (Edit Point) curves by using the

Create menu (choose Create ➔ CV Curve Tool or Create ➔ EP Curve Tool). The CV Curve

tool creates a CV with each click of the mouse. The EP Curve tool creates edit points as you

click the mouse button. There is really no difference between a CV curve and an EP curve

except in the way that they are created. Each type of curve tool is useful under certain cir-

cumstances—the basic rule of thumb is that for smoother curves, you use the CV Curve tool,

and for more tightly controlled curves you use the EP Curve tool. Figure 1.11 shows a CV

curve (on the left) and an EP curve (on the right) created with identical mouse clicks. Since

the CV curve does not pass through each point that you define, the resulting curve is

smoother than the EP curve. The extremes of the EP curve are much more pronounced

because the curve is forced to pass through exact points.

For more on creating and using lights, see Chapter 20.

Figure 1.10

An area light shining on

a distorted sphere
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To create, say, a CV curve, choose Create ➔ CV Curve Tool (or click the CV Curve Tool

button on the Curves shelf, selected by pressing the tab button at the left of the shelf and

choosing the Curves shelf), and then click several times in the scene window. You can also

drag the points around as you create them, and you can erase points by pressing the Delete

or Backspace key or by pressing the Z key to undo the last action. When you are satisfied

with the curve, press the Enter key to complete construction of the curve.

Moving Scene Objects

After you create an object, you will probably want to move, rotate, and/or scale it. Because

the procedures are the same for all objects (and lights, cameras, and curves), let’s just use a

cylinder as an example here. Create a new cylinder with default options. (Choose Create ➔

NURBS Primitives ➔ Cylinder ❑; then choose Edit ➔ Reset Settings, and click the Create but-

ton.) To move this cylinder, press the W key on the keyboard—you should now see the Move

tool manipulator handles that allow you to move the cylinder on any or all axes, as shown

in Figure 1.12.

If you do not see the manipulator handles, be sure the cylinder is highlighted by clicking it

(or click+dragging over it).

For more on creating and using curves, see Chapter 5, “NURBS Modeling.”

Figure 1.11

The curve on the left

was produced with the

CV Curve tool, and the

curve on the right was

produced with the 

EP Curve tool.
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Figure 1.12

A cylinder with Move

tool manipulator 

handles
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To move the cylinder on the X axis only, click and drag the red arrow; to move on the Y axis,

click and drag the green arrow; to move on the Z axis, click and drag the blue arrow. To move

the object freely in all directions, click and drag the yellow box at the center of the manipulator

handles. Try moving the object up a little on the Y axis and to the right on the X axis.

All manipulator handle colors are consistent with the axis marker, on the bottom-left of a

scene window—X is red, Y is green, and Z is blue. This consistency lets you know which axis

you are adjusting, no matter from what angle you are viewing the scene. Also, when you

select a manipulator handle, it turns yellow, indicating it is active, which makes it easier for

you to determine on which axis or axes you are adjusting.

To scale the cylinder, press the R key, and then scale the object on the X (red), Y (green),

or Z (blue) axis—or click and drag the yellow box at the center of the manipulator to scale

all axes simultaneously. Try scaling the cylinder up on the Y axis and then out in all direc-

tions, until you get something like Figure 1.13.

To rotate the cylinder, press the E key, and then rotate around the X (red), Y (green), or

Z (blue) axes—or click the yellow circle on the outside to rotate on all axes at once (rotating

on all axes at once is difficult to control and therefore not advisable). Try rotating clockwise

on the Z axis and then counterclockwise on the X axis, as in Figure 1.14.

Finally, it is possible to move the pivot point of your cylinder (or any object) so that it is

not in the object’s center. To move the pivot point, press the Insert key on your keyboard

(turning the manipulator handle into the pivot-point handle); then move the handle to where

you want the object’s center of rotation, movement, or scaling. Try moving the pivot point of

the cylinder to its bottom, as shown in Figure 1.15, so that any further rotation will occur

from that point.

After you move the pivot point, you must return the manipulator to its “normal” state by

pressing the Insert key once again.

On the Mac version of Maya, you need to press the Home key on the keyboard, not the Ins(ert)

key. This is one of the few differences between the various platform versions of Maya.

The shortcut keys for manipulator controls are arranged so that they follow the top row of a

QWERTY keyboard—Q for select, Ctrl+Q for lasso select, W for move, E for rotate, R for scale, T

for the Manipulator tool, and Y for the Last Used tool (the CV Curve tool, for example). This lay-

out makes the manipulator tools easy to access, and it’s easy to remember their shortcut keys.

I N T E R F A C E E L E M E N T S ■ 17

Figure 1.13

A moved and scaled

cylinder

Figure 1.14

The cylinder, rotated

Figure 1.15

The cylinder, with its

pivot point moved to

the bottom
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The Tool Box

In addition to using the shortcut keys to access the manipulator controls, you can access

them from the Tool Box (see Figure 1.16), which is to the left of the Maya workspace. Here

you will find the Select tool, the Lasso tool, the Move tool, the Rotate tool, the Scale tool, the

Show Manipulator tool, and the last selected tool. The Lasso tool is a selection tool that

works by dragging a lasso around the objects or components you want to select. The last

selected tool depends on (you guessed it) the last tool that was selected from a menu or 

a shelf.

Objects versus Components

All geometric objects are made up of component elements. In object mode, clicking or drag-

ging any part of an object selects the entire object. In component mode, however, you can

choose specific pieces of an object to manipulate. Using the cylinder from the previous sec-

tion as an example (just create a default cylinder if you deleted it), select the object (so it

turns green) while in object mode and click the Select By Component Type button in the

Status line (or just press the F8 key) to change to component mode. You will now see the

CVs that make up the cylinder, as shown in Figure 1.17—had you created a polygonal cylin-

der, you would see the points defining the edges of the polygonal facets.

The Select By Component Type button is on the Status line, just to the right of the floppy

disk (save) icon. The leftmost of these three buttons is Select By Hierarchy; the middle but-

ton is Select By Object; the right button is Select By Component Type.

You can adjust components of an object just as you adjust an object itself by using the

Move, Rotate, and Scale tools. Try selecting the top row of CVs on the cylinder (LM drag a

square around them or use the Lasso tool to draw a selection around them) and then move

them up some, scaling them out on the X and Z axes and rotating them a bit, as shown in Fig-

ure 1.18.

To select several components (CVs, facets, vertices, and so on) at once, you can drag a

selection marquee around them. (A selection marquee is the square box that you see when

you drag in a Maya scene window.) For more control, use the Lasso tool. To add more com-

ponents, hold down the Shift key and the Ctrl key and drag (or click) more points. Shift

alone+clicking or dragging will deselect the CVs already selected while adding points not

selected. To deselect CVs only, hold down just the Ctrl key and drag around those points.

Remember that you can always maneuver around the scene window (hold down the Alt key

as you drag the mouse) to make selection easier.

If you now switch back to object mode, you will once again be able to choose and manipu-

late the entire object. Modeling (and even animating) is often a dance between object-mode

and component-mode manipulation of your objects, and remembering that the F8 key

switches between these two modes can be a real time-saver.

Select By
Hierarchy

Select By Object

Select By
Component 

Type
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Selecting by Component Type

One of the trickier aspects of Maya is selecting the proper component of an object when in

component mode. You can select many types of components, including CVs, hulls, faces,

edges, and so forth (and there are usually several options in each of these choices), but you

can make these selections in only two ways. One way is more thorough; the other is better

suited to quick selections of the most common component types.

The quicker, easier method for selecting specific component types

is to use a contextual menu while your mouse is over an object. To try

this, create a sphere in an empty scene, and then, with your mouse

over the sphere, hold down the right mouse button. You will be pre-

sented with several options (shown in Figure 1.19) for component

masking, plus a menu of actions you can perform on the object (such

as templating or untemplating it).

By selecting Control Vertex (for example) from this pop-up menu,

you can easily move into component-selection mode for CVs and begin

manipulating your CVs. To return to object mode, press the F8 key

twice.

Although the contextual menu method is quick and easy, it does not

give you access to all the component types. To choose a component

Figure 1.18

The cylinder, with several CV components

manipulated

Figure 1.17

The cylinder, with CVs displayed in component mode
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type that’s not listed in the pop-up menu, you need to use the Status line. To the right of the

Object/Component text field and Hierarchy/Object/Component icons is a set of eight icons,

each representing a class of components you can enable or disable in your selection process.

To the left of these icons is a black triangle; clicking this triangle enables or disables all com-

ponents for selection. The component types you enable here are then available when you

drag your mouse over an object in component mode.

Holding down the right mouse button on any of the icons displays a menu of subtypes

that you can either enable (check) or disable (uncheck) for component selection. Enabling

or disabling component types is known as selection masking, and it’s a great way to simplify

the task of selecting a specific object or component in a complex scene. If you are not famil-

iar with components or selection masking, try playing around with these options in Maya

before continuing.

Window Layouts
In addition to the default window layout (the perspective view plus either the Channel Box

or the Attribute Editor), Maya provides many other built-in layouts, and—as is consistent

with the Maya interface philosophy—if you want, you can create your own.

Built-in Layouts

Maya offers two types of built-in layouts: generic layouts and saved layouts. Generic layouts

are just basic layout elements (such as a four-view layout), and saved layouts are useful com-

binations of the basic elements prebuilt into layouts for different purposes. To begin with,

let’s look at how to access a generic layout. You can use the Quick Layout buttons in the Tool

Box to select views and switch between layouts, as we did earlier in this chapter. But you can

also use the Panels menu located in the scene windows. Choose Panels ➔ Layouts

(accessed either via the Panels menu in the scene panel, as shown in Figure 1.20, or

from the Hotbox), which displays several layout choices for your scene windows.

Choosing Four Panes places the active view (often the perspective view) in the

upper-left quadrant of a four-view layout. (Note that this is different from the layout

you get by pressing the spacebar, as the perspective view—or whichever view you

have active—ends up in the top-right quadrant when using the spacebar, but at the

top left in this case). The Three Panes Split Top, Three Panes Split Left, Three

Panes Split Bottom, or Three Panes Split Right views place the active window on the

If you turn off all components, you will not be able to select anything in the scene window—

including objects in object mode! This is a good place to look first if you discover you cannot

choose any objects in a scene.
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top (or left, bottom, or right) half of the screen and then split this view into two; 

the other half of the screen has a single view window. The Two Panes Side By 

Side or Two Panes Stacked layouts are similar, except that they split the active 

view in half vertically and horizontally, respectively. There is also a single view, 

which is the same as selecting a view and pressing the spacebar to make it fill the

entire screen.

Although the generic views can be useful (especially for building your own layouts—

discussed later in this chapter), the saved layouts are more commonly used because they 

fulfill specific needs. To access the saved layouts, choose Panels ➔ Saved Layouts, as in 

Figure 1.21, and then select a saved layout to use.

You are already familiar with Single Perspective View and Four View. Rather than look at

each saved layout in a list, let’s examine just a few—once you understand a couple of the saved

layouts, the rest are fairly self-explanatory. Persp/Graph/Hypergraph is a three-panel layout with

the top half split between the perspective view and the Hypergraph, while the bottom half of the

screen is occupied by the Graph Editor. This view was created from the generic Three Panes

Split Top layout by changing each panel to the Perspective, Hypergraph, and Graph Editor

views, respectively, and then saving the layout. The Hypershade/Outliner/Persp view is a Three

Panes Split Bottom, with the Hypershade occupying the top half of the screen and the Outliner

and perspective view splitting the bottom half. Another useful layout is the Persp/Relationship

Editor layout, which stacks the perspective view on top of the Relationship Editor. If you have

Maya Unlimited and the MayaLive plug-in active, there are several layouts specifically for use

with Maya Live toward the bottom of the menu, including MayaLive Setup, MayaLive Track,

MayaLive Solve, and MayaLive Manual MatchMove.

Building Your Own Layout

If the prebuilt Maya layouts don’t quite fit your needs, never fear: the final choice in the

Saved Layouts menu (Edit Layouts) lets you create and save your own layout for later use.

You can even erase any or all of the prebuilt layouts from the menu.

As an example of how to create your own layout for later use, let’s create a layout with the

perspective view filling half the screen on the top and with the bottom being split between

the Hypershade and the Hypergraph. (This can be a useful layout if you need to connect

several materials to several objects at a time, because selecting the objects in the perspective

window can become tedious.) As with most things in Maya, you have a choice about how to

Don’t erase a saved layout unless you are sure that neither you nor anyone else working on

your machine is interested in using that layout any further. To get the layout back, you’ll

either have to reconstruct it manually or reinstall Maya.
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create your new layout: you can either start from a generic layout or modify a prebuilt lay-

out. Although starting from a prebuilt layout is often simpler, we will start from a generic lay-

out in order to describe the entire procedure. Follow these steps:

1. Choose Panels ➔ Layouts ➔ Three Panes Split Bottom.

2. Make sure the top half of the window is occupied by the perspective view (if not, select

the top half and then choose Panels ➔ Perspective ➔ Persp).

3. Select the lower-left quadrant and choose Panels ➔ Panel ➔ Hypershade. This should

turn the lower-left window into a view of the Hypershade.

4. Select the lower-right quadrant and choose Panels ➔ Panel ➔ Hypergraph, turning this

corner into a view of the Hypergraph, as seen in Figure 1.22.

5. To save the new layout, choose Panels ➔ Saved Layouts ➔ Edit Layouts, which displays

the Panel Editor.

6. If necessary, click the Layouts tab.

7. In the Layouts tab, click the New Layout button, rename the layout from its default

name (Panel Configuration) to something more memorable, such as Persp/Hypergraph

/Hypershade, and press the Enter key to change the name.

Figure 1.22

The custom Persp/

Hypergraph/Hyper-

shade window
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When you close the window, your new layout will be placed at the bottom of

the Saved Layouts menu (as shown in Figure 1.23). If you later choose to discard

this new layout, return to the Edit Layouts menu, select the new layout, and

press the Delete button.

You can actually build a custom configuration directly inside the Edit Layouts

menu, by using the Panels and Edit Layouts tabs. This method is more difficult

than the one outlined here, however, so our recommendation is to stick with the

method we just described.

The Hotbox
The Hotbox in Maya is a tool for displaying all the menus relevant to your work at a given

moment, without taking up any screen real estate when it’s not in use. Although you can do

everything you want in Maya without ever using the Hotbox, once you get used to the way

the Hotbox conserves space and puts nearly all of Maya’s tools in easy reach, you’ll wonder

how you ever got along without it. To access the Hotbox, just press (and hold) the spacebar.

In its default configuration, you will see something like Figure 1.24.

The top row of the Hotbox always shows the general menus (the menus that are available

in all menu sets), such as the File, Edit, Modify, and Create menus. The second row repli-

cates the menu set of the active panel (in this case, the perspective view), with menu items

such as View, Lighting, and Panels. The third row has a Recent Commands menu (showing

the last 15 commands you issued) and a Hotbox Controls menu, which allows you to fine-

tune how the Hotbox and general menus display information. The bottom row of menus is, in

this case, the Modeling menu set, with special menus for editing curves, surfaces, and poly-

gons. In the center of the Hotbox (where the A|W logo sits) is a quick way to change views

from perspective to front to side to top, as well as an options menu for how the Hotbox dis-

plays. Access to all these menus is the same: click (and hold—the Hotbox menus will not

remain open when you release the mouse button) the left mouse button over the menu; then

drag inside the new submenu that appears (called a marking menu) to select the item you

want, as in Figure 1.25, releasing the mouse when it is over your selection.

Figure 1.25

Selecting the top view using the Hotbox

Figure 1.24

The Hotbox in its default configuration
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In addition to the menus you can see, four regions, called zones (defined by the four lines

extending from the Hotbox at 45-degree angles), have special functions. You use the top

zone to quickly select from several saved layouts. You use the right zone to toggle elements

of Maya’s GUI on or off. You use the bottom zone to change the selected window to any of

several useful views (such as the Hypergraph or the Hypershade). You use the left zone to

toggle between object and component mode (mimicking the F8 key) and to toggle on and off

several masking modes.

Although you can use the Hotbox in its default configuration, it is more useful (if a bit more

cluttered) when you turn on all menu sets (Modeling, Rendering, and so on). In the Hotbox

Controls menu, choose Show All, which displays all menu sets, as shown in Figure 1.26.

In this configuration, you have access to nearly all of Maya’s tools in one place, and it’s all

available at the press of the spacebar. If you are not familiar with using the Hotbox, try forc-

ing yourself to use it for all your menu choices for a couple of hours of work; you may find

that you prefer using the Hotbox over the standard menu selection method.

Menus
Although we have discussed menu sets on and off throughout this chapter, let’s take a

moment to look at how Maya’s menus are organized. The top row of menus (or the top row in

the Hotbox) is split into two parts: the menus that are always present (the constant menus)

and those that change according to the mode of the program (the mode menus, such as the

Animation menu set, for example). Always present are File, Edit, Modify, Create, Display,

Window, and Help. To change the variable menus, choose the menu set you want from the

Status line (just below the menus—or under Hotbox Controls in the Hotbox). You can

choose from Modeling, Animation, Dynamics, and Rendering sets. If you have Maya Unlim-

ited, you will also see an entry for MayaLive.

In addition to the general menus, nearly every view and options window in Maya has a

built-in menu. The perspective view, for example, has the following menus: View, Shading,

Lighting, Show, and Panels. (You use the Show

menu to display and hide different types of objects.)

The Hypergraph view contains these menus: Edit,

View, Bookmarks, Graph, Rendering, Options, Show,

and Help. For perspective and orthographic views,

you can either access their menus from the top of

the window pane or use the second row of menus 

in the Hotbox. For views such as the Hypergraph 

or the Hypershade, clicking and holding the right

mouse button in the body of the pane displays the

menus (or you can use the menu across the top of

the window). There are also menus for the Channel
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Box and the Attribute Editor. Many of the options windows also have menus with Edit and

Help options.

Generally speaking, most windows in Maya have their own menu set, which explains why

Maya doesn’t use just one menu bar across the top of the screen: there are at least 100 indi-

vidual menus, and there would be no space to place all these menus across one screen.

Attempting to nest all these menus, on the other hand, might have taken 10 or more levels to

fit all the menus into one menu bar, making the task of choosing any individual menu item

both laborious and baffling. Given the complexity of the task, organizing Maya’s windows into

contextual subsets was both a necessity and a more elegant solution to the problem.

Even so, it is often difficult to locate a menu item you have not used in a while. Fortu-

nately Maya provides a menu search function. Choose Help ➔ Find Menu, enter the text of

the menu (a partial name is fine), and press Enter. For example, if you enter sm in the text

box, the menu search will find all occurrences of smooth, smoothness, smart, and smoke.

This is a handy feature and worth trying out.

Shelves
Although we have not yet dealt much with shelves, they are a convenient way to group your

most frequently used commands and tools. The shelf (see Figure 1.27) is one of the most

noticeable features of Maya’s GUI, appearing just below the Status line. Several icons, organ-

ized into tabs called General, Curves, and so on, perform useful commands. For example, to

create a NURBS sphere, you merely click the blue Sphere button when the Surfaces shelf tab

is selected; to create a spotlight, click the Spotlight button in the Rendering tab; to create a

CV curve, click the CV Curve Tool button with the Curves tab selected. Most useful are the

two widgets just to the left of the shelf icons. By clicking the top one (a gray tab icon), you

can quickly navigate to any tab (useful for selecting the preinstalled tabs, as well as any that

you create). Clicking the bottom widget opens a menu of common shelf commands, plus

access to the Shelf Editor.

Having these buttons available on a shelf makes the process of creating each item much

more straightforward than having to find them in a hierarchical menu set.

Figure 1.27

The shelf, with the 

Surfaces shelf tab

selected

You can customize any shelf tab, adding a new button to it by simply Ctrl+Shift clicking the

menu item (on a Mac, use Command+Control+Shift). To discard a shelf icon, just MM drag it

to the trash can icon at the right of the shelf.
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The Outliner and the Hypergraph
The basic purpose of the Outliner and the Hypergraph is the same: to allow you to see an

abstract (or outline) of the scene. The ways the two display a scene’s outline, however, are 

very different.

If you have used a 3D animation program in the past, you are probably familiar with a

scene management tool such as the Outliner, shown in Figure 1.28. From top to bottom, the

Outliner (choose Window ➔ Outliner) lists all objects in your scene, including cameras (note

that the orthographic views—top, side, and front—are just cameras listed in the Outliner),

lights, curves, and geometric objects. If you have objects that are parented to one another 

(a leg, for example, is parented to a body so that they move together), the Outliner indicates

this relationship by displaying a plus sign to the left of the parent object (the body in this

case). Clicking the plus sign displays the child object (the leg), which, because it is the child

object, is tabbed in under the parent.

The Hypergraph, by contrast, is probably like nothing you’ve seen before. It is, essentially,

a linked (or hyperlinked) outline of your scene, showing not only your scene elements, but

how they are connected. Although the Hypergraph may at first appear bewildering, its fash-

ion of laying out a scene can prove invaluable. Figure 1.29 shows how the scene shown in the

Outliner, in Figure 1.28, would look in the Hypergraph.

The Channel Box and the Attribute Editor
The Channel Box (to the right of the main scene window) and the Attribute Editor are

related windows that give you access to just about every aspect of the objects and materials

in your scene. The Attribute Editor (to open it, press Ctrl+A) gives you access to all of an

object’s attributes, and the Channel Box displays a more simplified view of only the object’s

keyable (or animatable) attributes. Because these two panels are counterparts, it makes

sense for them to be grouped together, and by default the two are set to toggle, the Attribute

Editor replacing the Channel Box on the right side of the window.

Figure 1.29

The Hypergraph with

leg and body
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As you’ll see throughout this book, the Attribute Editor and the Channel Box are your

keys to controlling all of an object’s attributes, including numeric inputs for translation, rota-

tion, scale, and visibility, as well as its construction history, such as spans of CVs and the

radius of a circular object. The Attribute Editor, in addition (via its tabbed windows), allows

you to access materials, tessellation criteria for NURBS objects, and other features. To toggle

between the Channel Box and the Attribute Editor, press Ctrl+A.

If you click the name (not the text box, but the actual name—see Figure 1.30) of an

attribute in the Channel Box and then MM drag in the scene window, you will get a “virtual

slider” that controls the number next to the channel name, as shown in Figure 1.30. This is a

powerful, time-saving feature in Maya.

Figure 1.30

Creating and using a

virtual slider

Materials? Tessellation? If you’re new to 3D animation, don’t worry about absorbing all the

jargon right away. The following chapters introduce all the essential concepts in a logical and

straightforward way as they are needed.

The Channel Box is so named because elements that can be animated in a 3D program have

often been termed channels. To animate a ball going up and down, you animate its Y-axis

channel (by setting several keyframes over time). Although Maya uses the term attribute for

anything that could potentially be keyable in a scene, those that have actually been set to

keyable are placed in the Channel Box.
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The Timeline
The Timeline, just below the main scene window(s) and shown in Figure 1.31, is the key to

animation in Maya.

By default, the numbers on the Timeline are set to frames (and by default, frames per

second is set to film rate—24—so 24 frames equals one second of animation). To the right 

of the Time Slider is the Current Time marker (probably set to 1.00). To change the current

time in your animation, you can either drag the Current Time marker in the Time Slider or

double-click the Current Time field and enter a number (such as 5). You will then see the

Current Time marker move to that frame. Larger numbers (such as frame 20) are, of course,

later in the animation. Below the Time Slider is the Range Slider (the gray bar with a 1 on

one end and a 24 on the other) that lets you control the range of the Time Slider within a

larger animation. To change the position of the Time Slider while maintaining the same range

(24 frames by default), drag the Range Slider by its middle. To change the starting point of

the range, drag the left square left or right. To change the ending point, drag the right square

to the left or right, as shown in Figure 1.32.

To the left of the Range Slider are two numeric fields. The leftmost field sets the anima-

tion start frame (often people set this number to 0 for the first frame instead of 1). The field

to its right sets the starting frame of the time range. (Changing this number is equivalent to

dragging the left square of the Range Slider.) To the right of the Range Slider are two more

fields; the left field sets the ending time of the animation range (equivalent to dragging the

right square on the Range Slider), and the right field controls the end point of the animation

(set to 48 frames by default).

To change the settings for the Time Slider, open the Animation Timeline and Playback

Preferences in the Preferences window (either click the Animation Preferences button, to the

right of the key icon at the bottom right of the screen or choose Window ➔ Settings/Prefer-

ences ➔ Preferences and then choose the Settings/Timeline category). In the Preferences

window, shown in Figure 1.33, you can control the height of the Timeline (useful when sound

files are imported), set playback speed to Play Every Frame, Real-time, Half, or Twice (Play

Every Frame is required for playback of dynamics), and even adjust animation beginning and 

Figure 1.32

Drag the right square

to change the ending

point of the Time

Slider.

Start Time Playback Start Time

Time Slider

Range Slider

Current Time

End TimePlayback End Time

Figure 1.31

The Timeline
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end points. In the Settings section, you can change your slider units from the default film

(24fps) to PAL (Phase Alternating Lines—used in Europe and other countries), NTSC

(National Television Standards Committee—used in the USA among other countries), sec-

onds, minutes, or even hours.

The Command Line, the Feedback Line, and the Script Editor
At the bottom of the Maya screen is the Command/Feedback line. The two halves of this line

function in tandem and are simply the last lines of the Script Editor’s input and history windows,

respectively, so it makes sense for us to first take a quick look at

Maya’s Script Editor. Although most of your interaction with

Maya is via the GUI, what you actually tell Maya to do is passed

to it via MEL. The selections and other actions you make in the

GUI are recorded as MEL commands. Creating a NURBS

sphere, for example, is simply the command . followed by sev-

eral optional flags. To access the Script Editor, either click the

Script Editor icon just to the right of the Feedback line (at the

bottom right of the screen), or choose Window ➔ General Edi-

tors ➔ Script Editor. The Script Editor, shown in Figure 1.34, is

To play back an animation, you can either use the VCR-like controls to the right of the Time-

line, or you can press Alt+V to start and stop the animation and Alt+Shift+V to reset the ani-

mation to its starting frame.

Figure 1.33

The Animation Time-

line and Playback 

Preferences in the 

Preferences window
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Figure 1.34

The Script Editor

window
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split into two halves. The top, which is the history window, probably has several lines of code in

it (the last commands you issued to Maya). The input window at the bottom awaits any MEL

commands you might want to give to Maya.

To see how the Script Editor works, type sphere (in lowercase letters) in the input win-

dow and press the Enter key on the numeric keypad (not the alpha keyboard). You should

see the line

// Result: nurbsSphere1 makeNurbsSphere1 //

appear in the history window (telling you what Maya has done to complete your command),

and a sphere will appear at the origin of your scene.

S A V I N G  M A Y A  P R O J E C T  A N D  S C E N E  F I L E S

A Maya project consists of several folders (or directories) of information about the scene (which is where your work-

ing scene file is stored), any rendering jobs, source images, output images, textures, and so forth. When you first

create a new scene in Maya, there are two steps to saving: first, save your project (which contains all the proper

places for Maya to store your project’s information), and then save the actual scene file.

To save your new project, choose File ➔ Project ➔ New. You might want to browse for your new project’s file

location. With the New Project window open, click the Browse button next to the Location text field, and use the

standard file browser to choose the location of your project.

Maya is based on the Unix operating system, which means you must never use spaces in your filenames—even if

you’re running the Windows or Mac versions of Maya. If you do, Maya may display an error message when you try

to open your scene later, and you won’t be able to access your earlier work! The Windows and Mac operating sys-

tems will allow you to save according to their filename conventions, but Maya’s file system will have problems rec-

ognizing names with spaces.

To save your scene file itself, just choose File ➔ Save (or Save As) and give your scene a name.

It is a good idea to append a number to the name of every scene (for example, rocket001). Maya does this 

automatically when you turn on the Incremental Save option. Choose File ➔ Save Scene ❑. When the Save Scene

Options window opens, click the Incremental Save check box. As you work, you will want to save your scene often,

in case you run into any problems. With Incremental Save turned on, each time you save, Maya will create a new

file, numbered sequentially (rocket002, rocket003, and so on). If you are concerned about disk space on your hard

drive, you can limit the number of incremental saves since new backup files are created each time you save. In the

Save Scene Options window, click the Limit Incremental Saves check box. The default limit is 20 increments, which

is a good number of backup copies to keep. If you would rather, you can enter a different number into this field or

just leave the limit turned off. Once the incremental save limit is reached, Maya deletes the oldest incremental file

and replaces it with the most recently saved one.

For information on how to use MEL commands with the Script Editor, see Chapter 17.
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Because the Command line is just the last input line in the Script Editor, you don’t have to

open the Script Editor for a simple command. Try closing the Script Editor and then, in the

Command line, type cone (all lowercase letters), and press Enter (or Ctrl+Enter on the

alpha keyboard). A cone should appear in your scene, and the Feedback line (to the right of

the Command line) should now read

Result: nurbsCone1 makeNurbsCone1

This lets you know what actions Maya has taken to complete your command.

Summary
This quick tour has shown that, while Maya is a deep and complex program, a great deal of

thought has gone into making the interface intuitive. Consistent interface elements (such as

using the Alt key and mouse drags to move around many different windows), grouping tools,

and even placing clues about your orientation in space and the type of tool you’re using

directly in the scene windows—all of these features work together to ease the new user’s

entrance into this complex environment and to make the experienced user more productive.

More importantly, you can customize the interface, from its smallest to its largest detail,

so you can tailor the program to meet your needs. As you grow more comfortable with using

Maya, you will want to optimize its interface to allow you to work more quickly with less 

clutter. Throughout this book, you will find tips and tricks that you can use to optimize your

workspace, making you that much more efficient. If you are new to Maya, spend a bit of time

playing with the interface after reading this chapter. Otherwise, move on to the next chapter

and start the process of creating a large-scale animation from scratch!

If you are very new to Maya and 3D animation and would like to create a smaller, simpler ani-

mation before you begin the book-sized animation project, you can read the Rocket Tutorial

PDF file on the accompanying CD (rocketTutorial.pdf). That bonus chapter will lead you

through the process of creating a simpler animation from start to finish.

To “focus” on the Command line when you are in a scene window (so you don’t have to click

in the Command line field with your mouse), press the ` (reverse apostrophe) key on your

keyboard.

You can also press Ctrl+Enter (on the main keyboard) to execute your command.
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