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Solution: Build and Burn a Looping Slideshow

Introducing DVD
Studio Pro 2

DVD Studio Pro 2 is a new, powerful and flexible

authoring tool for DVDs. DVD Studio Pro 2 helps

you transform plain video into interactive media,

complete with menus, subtitles, alternate tracks, and

more. In fact, DVD Studio Pro 2 provides many of

the professional features you’d normally find on

Hollywood-produced DVDs. DVD Studio Pro 2

helps you coordinate these capabilities, putting them

together to produce new ways of watching video.1
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DVD Studio Pro 2 means more than just movies. With DVD Studio Pro 2, you
can create training materials, personal histories, interactive catalogs, event videos, and
more. If you have video, audio, and graphics that you want to combine to present an
interactive experience, DVD Studio Pro 2 will help you deliver that experience on the
DVD platform.

In this chapter, you’ll meet DVD Studio Pro 2. You’ll explore the DVD Studio
Pro 2 interface, learn how to customize your screen, and get started building your own
DVD projects.

Configuring DVD Studio Pro 2

The best way to learn any program is to use it. To get started with DVD Studio Pro 2,
you need to sit down at your computer and, in a metaphorical sense, get your hands
dirty and your feet wet. If you have not done so already, install your copy of DVD Stu-
dio Pro 2. Navigate to your OS X Applications folder. Locate the DVD Studio Pro 2
icon and double-click it.

If this is your first time using DVD Studio Pro 2, you’ll be greeted with the win-
dow that appears in Figure 1.1, which asks you to select a configuration.

Configurations tell DVD Studio Pro 2 how to select and arrange windows. 
Each configuration specifies which windows to display and where to display them. 
The introductory screen allows you to choose from Basic, Intermediate, and Advanced
layouts.

Each layout provides a different look. The Basic layout offers a bare minimum
of screens, to mimic the look of Apple’s iDVD. Intermediate adds a timeline. The
Advanced layout offers the greatest power and complexity. It contains all essential
DVD Studio Pro 2 windows, with all the power that DVD Studio Pro 2 has to offer
and is the configuration used throughout this book.

Figure 1.1 The first time you run DVD Studio Pro 2, the

program asks you to choose an application configuration.

Before clicking OK, select from the Basic, Intermediate,

and Advanced configurations, and set your video standard

(NTSC or PAL). Although DVD Studio Pro 2 offers easy

ways to select configurations, you can revisit this dialog

at will: quit DVD Studio Pro 2, remove the DVD Studio 

Pro 2 folder from ~/Library/Application Support,

and relaunch.
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Running DVD Studio Pro 2 for the First Time

Follow these steps to get started with DVD Studio Pro 2.

1. Choose Advanced. Click the small screenshot button to the left of the word
Advanced. The Advanced configuration offers the most power and flexibility of
all the configurations.

2. Choose your video standard. Select either NTSC or PAL, depending on your
country of origin and the project you’re about to build.

3. Click OK. DVD Studio Pro 2 accepts your settings and opens a new project
using the Advanced configuration.

Choosing Configurations within the Program

After its first run, DVD Studio Pro 2 no longer displays the screen you saw in Figure 1.1.
Instead, DVD Studio Pro 2 starts new projects using the last-selected configuration. To
select a different configuration, follow these steps.

1. Choose Window > Configurations. DVD Studio Pro 2 opens a submenu that
offers Basic, Intermediate, and Advanced configurations. Figure 1.2 shows this
submenu.

2. Choose an Advanced layout. Select the Advanced option that matches the size of
your screen.

After selecting a configuration, DVD Studio Pro 2 resets the interface to the
specified layout.

During a long and busy editing session, you may move and resize many DVD Studio Pro 2 windows, making

changes you won’t want to preserve.To quickly reset your windows to their original positions, choose Window >

Configurations again, and choose the current configuration again.

If you are familiar with iLife programs, do not be swayed by the Basic configuration’s similarity to iDVD. DVD

Studio Pro 2 is not iDVD.The similarity between the Basic configuration and iDVD is, at best, flimsy.

NTSC (National Television Standards Committee) is the body that sets standards for television and video in

North America, Japan, and parts of South America. PAL (Phase Alternating Line) is the video standard used in

Europe (with the exception of France), the United Kingdom, Australia, and New Zealand.
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Choosing a Video Standard within DVD Studio Pro 2

As with configurations, DVD Studio Pro 2 defaults to the last-used video standard. Fol-
low these steps to set your video standard at any time.

1. Choose DVD Studio Pro > Preferences (Command-,). The Preferences win-
dow opens.

2. Click Encoding. The Encoding button appears on the top line, to the right of
Destinations.

3. Choose a video standard. Select either NTSC or PAL to match your project 
to the country system in which it will be played.

4. Click OK. DVD Studio Pro 2 closes the window and updates your 
preferences.

Each DVD Studio Pro 2 project can use either the NTSC or PAL system, but not both at the same time. DVD Stu-

dio Pro 2 offers no standards conversion tools: you must convert material to the proper system before import-

ing it. QuickTime Pro converts elementary video assets from one format to the other, with modest but usable

results. Final Cut Pro, which uses the QuickTime engine, lets you export to both NTSC and PAL, regardless of the

system used within your projects. By far the best conversion solution resides strictly on Windows: Canopus

ProCoder offers the highest quality conversion tools.The sample material provided on the DVD Studio Pro 2

Solutions companion DVD uses the NTSC format.

Figure 1.2 The Window > Configurations submenu

allows you to select a configuration that matches your

monitor. This figure shows the default list of built-in con-

figurations. DVD Studio Pro 2 allows you to add to this

list, introducing custom configurations to match your spe-

cific production needs. The configurations manager

(choose Window > Manage Configurations) lets you add

and remove configurations as needed.
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Looking at the DVD Studio Pro 2 Interface

A careful look at the DVD Studio Pro 2 interface reveals how the program is structured
on your screen. By default, Advanced configurations include a main window and two
floating tool windows. Figure 1.3 shows a typical Advanced configuration. As you
examine the layout, notice the following:

A tool bar appears at the top of the main window. This bar offers one-button access to
many of the most common functions in DVD Studio Pro 2. The tool bar lets you
bypass context-sensitive pop-up menus to get right to work.

The main window contains four subwindows. DVD Studio Pro 2 allows you to con-
trol the relative size of each subwindow, called a quadrant, so you can focus on the
task at hand with the window real estate you need.

Each quadrant contains tabs. Tabs include Outline, Story, Connection, and Menu,
among others. Each tab contains a different editor or information pane. Tabs allow
you to organize your work, reduce clutter, and fit a lot more information on screen at
one time. 

Two floating windows appear above the main window. The Inspector and the Palette
always appear as the frontmost windows of your interface. The Inspector provides
context-specific controls for the program. For example, click a DVD menu, and the
Menu Inspector allows you to set its name, its background image, and more. The
Palette provides instant visual access to interface components such as buttons and
menu layouts. The Palette also holds collections of audio, video, and still assets.

Manipulating the Interface

All DVD Studio Pro 2 windows are fully customizable. You can hide them from view,
resize them, and more. DVD Studio Pro 2 offers you the power to configure the inter-
face exactly how you’d like it to get your work done. To accomplish this, you need to
master several interface manipulation techniques detailed here.

Working with Tabs

Tabs allow you to choose which editor or information pane to display in a quadrant.
Common tasks include the following.

Selecting Tabs Click any tab to bring it to the front and display it. 

Reordering Tabs To reorder within a line of tabs, drag the tab into its new position.
DVD Studio Pro 2 makes space for the tab as it passes each of its quadrant mates.
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Figure 1.3 The default look of the Advanced configuration includes an attached tool bar �, within a paned main window �, and

two floating tools—the Inspector � and the Palette �.

Tearing off Tabs DVD Studio Pro 2 lets you to “tear off” tabs so they appear in new
windows, as shown in Figure 1.4. These new windows do not “float.” They can appear
in front of or behind your main window, depending on window ordering. Use F-` to
cycle through your windows and display any hidden ones.

Moving Tabs between Quadrants DVD Studio Pro 2 allows you to move tabs from
one quadrant to another and from one window to another. Place the cursor on any tab
and drag that tab to any other tab line. This method is shown in Figure 1.5.

The Window menu places a check mark next to all selected tool tabs.When you find more than four checks in

the menu, you know that you’re working with extra open windows.

�

�

�

�
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Here are some key points to remember about tabs:

• When you close a tab window, the tab does not revert to your main work win-
dow. Use the Window menu (and its shortcuts) to reopen that tab. If, for exam-
ple, you place the Outline tab in a new window and then close that window, you
must choose Window > Outline (F-5) to see it again.

• When you drag the sole tab from a one-tab window into another tab bar, the
window closes and the tab appears in that bar.

• Removing the last tab from a quadrant hides that quadrant. For example, you
can see this if you move the Story and Outline tabs from the top-left quadrant.
You must resize (discussed in the next section) to display the empty quadrant.

• To revert your display and restore your tabs, reload your configuration. Choose
Window > Configurations and select any configuration.

Figure 1.5 DVD Studio Pro 2 allows you to move tabs by

dragging them to the top gray line of any quadrant. A blue

outline surrounds this line when the cursor enters. To

reorder tabs within a quadrant, drag the tab within the top

line into its new position.

Curious about the built-in shortcuts? Choose Help > Keyboard Shortcuts to view a complete list.

Figure 1.4 Tearing off tabs opens new DVD Studio Pro 2

windows. Control-click (right-click) any tab. Select Tear Off

Tab from the contextual pop-up. Alternatively, drag the tab

to some part of your screen other than the top tab lines of

your windows.
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Adjusting Quadrants

DVD Studio Pro 2 allows you to resize the quadrants within your main window to give
them as much or as little space as needed. Use the following techniques to customize
your quadrant allocation.

• Move your mouse to any horizontal or vertical line between quadrants until you
see the resizing cursor. The cursor appears as two parallel or horizontal lines
with arrows on both sides. (When your horizontal and vertical lines meet, you’ll
see a plus-shaped cursor instead.) Unlike other resizing cursors used within the
program, this cursor has a slight blue tint. To reapportion space, drag in any
direction. If you drag entirely across, you may hide one or more quadrants.

• Hiding quadrants provides more screen space without opening new windows. To
detect hidden quadrants, examine the sides of your main DVD Studio Pro 2 win-
dow. Studio Pro slightly thickened window edges indicate hidden quadrants. In
addition, the resizing cursor appears over these thickened borders. To view a hid-
den quadrant (or quadrants), look for the resizing cursor to appear and then drag
to display the quadrant.
As with tabs, reselecting a configuration from the Window > Configurations 

submenu instantly reverts your quadrants to default positions.

Other Interface Elements

The DVD Studio Pro 2 Inspector, Palette and Toolbar all offer important functionality
in addition to the main window and tabs. These interface elements extend the program,
offering flexible tools that help you work on your projects.

Manipulating the Floating Windows

The Inspector and Palette, when visible, float over all other windows in your interface.
(They have the highest window priority.) DVD Studio Pro 2 allows you to show, hide,
and resize these floating tools as follows:

• To show either window, choose View > Show Palette or View > Show Inspector.

• Choose View > Hide Palette or View > Hide Inspector to close each window.

When quadrants align, either vertically or horizontally, they resize together. Pressing C allows you to resize

one quadrant independently of its mate.
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• Two keyboard shortcuts, F-C-I (for Inspector) and F-C-P (for Palette) toggle
floating window visibility on and off. The Palette and Inspector buttons found at
the very right of the toolbar also toggle window visibility.

• Move the Inspector or Palette by dragging the title bar at the top of either window.

• Resize the Palette by dragging the lower-right corner. You cannot resize the
Inspector.

• To close a floating window, click the tiny close button (the X at the top-left
corner of the window).

Revealing Basic’s Hidden Quadrants

The Basic configuration hides a lot more than it shows. A little manipulation discloses the quad-
rants that you find in the Intermediate and Advanced configurations.

Dragging from the left reveals one new quadrant (below left). Dragging the bottom border
exposes the remaining quadrants (below right).
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Customizing the Toolbar

As with many programs and tools in Mac OS X, DVD Studio Pro 2 provides full tool-
bar customization, offering one-button access to your most-used functions. Choose
View > Customize Toolbar to open the interactive customization editor, as shown in
Figure 1.6. In the editor, you can do the following:

Add Items Drag any icon up to the toolbar. The icons in the toolbar shift to make
room for the new addition.

Remove Items DVD Studio Pro 2 provides a small “puff” animation when you drag an
icon off the toolbar, letting you know it’s been removed.

Reorder Items When unsatisfied with the toolbar order, just drag an item into a new
position. As with adding, the icons in the toolbar shift to accommodate your reposi-
tioned icon.

Group Items Together Use separators to group icons by task. Add as many or as few
separators to your toolbar as needed. The Space and Flexible Space icons offer alterna-
tive approaches for toolbar layout and grouping.

Use Defaults Click the default set icon toward the bottom of the window to restore
default tool buttons.

Choose Icons, Text, or Both The Show pop-up menu at the bottom left of the cus-
tomize window allows you to select from Icon & Text, Icon Only, and Text Only.

After making any changes to your toolbar, click Done to apply your changes and
close the customization window.

Figure 1.6 Customize your toolbar to include features you use the most. DVD Studio Pro 2 allows you to add, move, and group

items as needed to create an effective set of one-click functionality.
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Saving Configurations

Configurations define ways to display the various panes, panels, toolbars, and windows
that make up the suite of tools. DVD Studio Pro 2 allows you create new configura-
tions, in which it stores these positions and preferences. Here’s how.

1. Arrange your workspace. Place your windows, quadrants, floating tools, and so
forth exactly as you want them to appear the next time you load this configura-
tion. Edit your toolbar as desired. Once you save, you cannot directly edit con-
figurations in DVD Studio Pro 2, so be sure to place each window item
thoughtfully.

2. Choose Window > Manage Configuration. This opens the small Configurations
Manager window at the top of your workspace.

3. Click +. The plus-button instructs DVD Studio Pro 2 to create a new configura-
tion based on your current layout.

4. Scroll down. Your new, untitled configuration appears at the bottom of the Con-
figurations list below Default, as shown in Figure 1.7.

5. Edit the name. Double-click Untitled and rename as desired.

6. Click OK. This applies your changes and closes the Configuration Manager.

Newer versions of DVD Studio Pro 2 (2.0.1 and later) allow you to save configurations directly by choosing

Window > Save Configuration.

Figure 1.7 Creating a new configuration allows

you to store the current window layout for later

recall. Configurations store the location and order-

ing of toolbar buttons as well as your windows.

Although you can’t edit configurations directly, you can always make a change, save as a new configuration,

and toss the old one.
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Fast Facts about Configurations

• To restore DVD Studio Pro 2 to its factory defaults, locate the DVD Studio Pro 2 folder in your
home ~/Library/Application Support folder. Quit DVD Studio Pro 2, drag this folder to
the desktop or the trashcan, and launch the program again.

• Configuration files use .dspconfig extensions.

• Configuration files are based on XML (Extensible Markup Language). You can open .dspcon-

fig files in TextEdit and read through them. For better readability, you might want to globally
replace tabs with single spaces. (This does not affect performance or usability in any way.)

• When you use TextEdit to modify .dspconfig files, the changes do not appear until you
launch the program again.

The Configuration Manager allows you to add, remove, and rename your con-
figurations—including the DVD Studio Pro 2 defaults. Here are some of the ways you
can use the Configuration Manger.

Removing Configurations Select any configuration and click – (the minus button) to
remove it from the active set of configurations.

Renaming Configurations Double-click any configuration to open a text-edit field on
its name.

Reordering Configurations DVD Studio Pro 2 uses alphabetic sorting (0–9, A–Z) in 
its Window > Configurations submenu. Name your configurations with this in mind.
Unfortunately, this sorting does not apply to new items in the Configuration Manager
window until you restart the program.

Viewing Configurations Click Apply after selecting a configuration to view it. Unfortu-
nately, in early versions of DVD Studio Pro 2, this action closes the Configuration
Manager. You must choose Window > Manage Configurations again to continue with
your edits.

Understanding the Interface

DVD Studio Pro 2 with its cluttered interface may intimidate first-time users. Numerous
windows—tabbed, paned, and floating—appear almost at random on your screen. Despite
a superficially messy appearance, a logical structure underlies this visual confusion, and

DVD Studio Pro 2 does not provide Undo support for these changes.
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DVD Studio Pro offers a solid structural workflow that allows you to build, test, and cus-
tomize your DVD projects. Figure 1.8 shows a typical DVD Studio Pro 2 workspace with
a project in progress.

Each DVD Studio Pro 2 window has a job to do. Some allow you to work with
tracks; others help lay out your interface. Once you understand the role of each win-
dow, it becomes easier to see how they work together. It also helps that you can cus-
tomize almost any DVD Studio Pro 2 interface through built-in and user-defined
configurations.

Identifying Windows

A quick tour offers a great way to become acquainted with the main program win-
dows. Visiting each window allows you to get an idea of their jobs and see what they
look like.

Figure 1.8 DVD Studio Pro 2 has a busy but flexible interface that allows you to build, test, and customize your DVD. This figure

shows how your screen might look like while you are working on a project.
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Assets

The Assets window (F-1) lets you organize and manage project assets. Here’s where
you store all the video, sounds, and graphic stills that you use to build your project.
The Assets window conveniently displays information about these items, including
their type, length, size, rate, and use.

Connections

The Connections window (F-2) allows you to create disc navigation links between
menus, markers, assets, and so forth. Connections specify the way your DVD flows
over time: how items connect and how control moves from one item to the next.
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Log

The Log window (F-3) collects and displays a running description of the way you
build, encode, and simulate your project. By providing a textual view of the progress of
these operations, the Log allows you to supervise what’s going on.

Menu Editor

The Menu window (F-4) provides interactive menu layout in which you can add but-
tons, define their navigation targets, add backgrounds, and more. You design project
menus using this window.
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Outline

The Outline window (F-5) provides an ordered
list of the menus, tracks, scripts, slideshows, 
and languages that appear in your project. This
window helps you manage these elements, allow-
ing you to add, rename, or remove items as
needed.

Script Editor

The Script Editor (F-6) allows you to add programmed functionality to your DVDs.
DVD Studio Pro 2 offers a dialog-based approach to building scripts, so you need no
programming experience, although such experience is a plus.
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Slideshow Editor

When you want to combine a series of still images into a dynamic, interactive presenta-
tion, look no further than the Slideshow Editor (F-7). This editor allows you to import
pictures, set their duration, add audio, and more.

Story Editor

With the Story Editor (F-8), you can create a “story” that moves selectively through
your tracks. Stories let you rearrange the way your movie plays back, to include (or
omit) scenes or to mix up the playback.
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Track Editor

The Track Editor (F-9) allows you to build and edit your video, audio, and subtitle
streams. Use this timeline to sequence your assets, add alternative languages, 
and more.

Viewer

As the name might suggest, the Viewer window (F-0) displays the contents of 
your audio and video tracks, providing playback that synchronizes with the 
playhead in your track editor. The Viewer window also helps you lay out your 
subtitles.
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Palette

The floating Palette (press F-C-P, or click the Palette
button in the toolbar) offers quick access to built-in
interface components, including templates, styles, and
shapes. You can add to these components by building
your own custom items. In addition, it offers media
tabs that integrate with iPhoto and iTunes.

Inspector

Like the Palette, the Inspector (press F-C-I, or 
click the Info button in the toolbar) floats over the
other windows in your interface. It displays context-
sensitive properties for selected items within DVD 
Studio Pro 2, allowing you to edit those properties
using a series of tabbed sheets. (The name in the
Inspector window’s title bar always reflects the item
being inspected.) Use the Inspector to specify the way
your disc and its menus, tracks, scripts, slideshows,
and languages behave.
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Simulator

The DVD Studio Pro 2 Simulator window (F-C-0) lets you preview, monitor, and
interact with your DVD projects. It offers a virtual DVD player for you to test 
your work.

Using Projects

DVD Studio Pro project files store the way you define, lay out, and put together your
DVD components, such as menus, tracks, scripts, slideshows, languages, and more.
Project files remember all the work you’ve done so you can save and pick up editing
exactly where you left off. Here are some tips about using DVD Studio Pro 2 projects:

Saving Projects To save your work, choose File > Save (Command-S). DVD Studio 
Pro 2 stores a record of your work up to the moment that you save it. Choose File >
Save As (Command-Shift-S) to save to a new file name.

New Projects To begin a fresh new project, choose File > New (Command-N).

Reverting Projects Choose File > Revert To Save to discard changes to your project
and revert to the last saved version.
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Unlike iLife titles such as iMovie and iDVD, DVD Studio Pro does not “remem-
ber” current projects. DVD Studio Pro 2 begins a new project each time you launch the
program from the Application icon. To load a recent project, choose File > Open
Recent or double-click a project file icon.

DVD Studio Pro 2 project files are not actually files—they are OS X bundles.
Each “file” contains both data files and folders. To see these components, select any
DVD Studio Pro 2 project file and Ctrl-click (right-click) its icon. Choose Show Pack-
age Contents from the pop-up menu. Navigate to Contents/Resources. Here, you’ll
view the items that make up your project. Figure 1.9 shows the typical initial contents
of this folder.

Figure 1.9 Your DVD Studio Pro 2 project “file” is not a file at all. It’s a bundle that contains

data files and folders. The ObjectDataB file that appears in the Resources folder stores all

the information about your project, including languages, tracks, colors, menus, formats,

styles, streams, and more. The ModuleDataB file preserves the saved layout of your project.

This ensures that your windows appear in the same positions that you left them.

If you’re curious, drag the ObjectDataB and ModuleDataB files into TextEdit to view their contents.

Although they are not by any means text-based, they do use text labels that offer fascinating insight into the

way DVD Studio Pro 2 stores projects.
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Loading Assets

To build a house, you need bricks and wood. To build a DVD, you need properly
encoded data files. DVD Studio Pro 2 project development begins by collecting sound,
picture, and movie files called assets. Assets are the audio, still, and video files you use
to build your tracks, menus, and slideshows.

DVD Studio Pro 2 offers two ways to organize and use assets in your projects:
the Assets tab and the Palette. The Assets tab provides a list of folders and files that
you can edit. The Palette offers easy-to-use integration with your iTunes and iPhoto
libraries.

Using the Assets Tab

The Assets tab helps you import, organize, and understand your project assets. 
Figure 1.10 shows what a typical session might look like.

Folders and subfolders help organize your assets into logical groups. You can
import entire folders (and their subfolders) at once, and DVD Studio Pro 2 will pre-
serve the folder structure. The columns help identify and describe your assets, provid-
ing information about each item in a structured table.

DVD Studio Pro 2 Assets

DVD Studio Pro 2 places certain requirements on your assets. When your assets do not initially
match these standards, DVD Studio Pro 2 will encode your files accordingly.

Video Standard DVD Studio Pro 2 supports both NTSC and PAL standards. All assets within any
single project must use the same standard, either NTSC or PAL.

Video File Types DVD Studio Pro 2 accepts both MPEG-1 and MPEG-2 elementary streams at up
to 1.856Mbps (MPEG-1) or 9.8Mbps (MPEG-2). All MPEG- 2 video must use a 4:2:0 chroma format.

Dimension DVD Studio Pro 2 MPEG-2 movies and full-screen still images occupy 720 × 480 pixels
(NTSC) or 720 × 576 pixels (PAL). MPEG-1 files use 352 × 240 pixels (NTSC) or 352 × 288 pixels
(PAL). DVD Studio Pro 2 supports both 4:3 and 16:9 aspect ratios.

Frame Rate For NTSC projects, use 29.97 frames per second. For PAL projects, use 25 frames per
second.

Audio Resolution DVD Studio Pro 2 accepts either 16-bit or 24-bit audio, using either 48 or
96kHz sampling.

Audio File Types DVD Studio Pro 2 supports Dolby Digital or AC-3 (64 to 448kbps), Stereo PCM
(16b/48kHz/1536kpbs or 24b/96kHz/4608kbps) and MPEG-1 Layer 2 audio.
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Here are some ways to manipulate the columns, to provide the most informative
views of your assets.

Choosing Columns To choose which columns to display, move your cursor over any
column header and Ctrl-click (right-click). Choose your columns from the pop-up list,
as shown in Figure 1.11.

Repositioning Columns You can reposition columns by dragging. Move your cursor to
any column header and drag the column to its new location.

Resizing Column Width Resize columns by moving your cursor into the horizontal
row of column headers. A resize cursor appears at the boundary between each pair of
columns. Drag the resize cursor to stretch or squeeze column width.

Sorting Assets When you select any column header (click its name), a small triangle
appears to its right. This triangle indicates sorting. An upward triangle sorts assets in
ascending order; a downward triangle indicates descending order. Click any selected
column to toggle between the two sorting methods.

Figure 1.11 DVD Studio Pro 2 allows you to customize which columns to

display. Choose from 15 available columns, as shown here. Ctrl-click (right-

click) the name of any column to view this pop-up menu. Select any item to

toggle its visibility between hidden and shown. Checked items indicate

viewable columns. Unchecked items are hidden.

Figure 1.10 A typical session in

the Assets tab. Notice the check

marks for in-use items. The dots in 

the Usability column indicate

encoding status for movies and

audio that were not encoded prior

to import. Here, Type, Length, Size,

and Rate columns display impor-

tant file status information that 

helps you manage your assets.
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Importing Assets

Importing assets allows you to create a list of project building blocks with which you can
construct your final DVD. Follow these steps to import assets into DVD Studio Pro 2.

1. Open the Import Assets dialog. The Import Assets dialog (shown in Figure 1.12)
allows you to select files or folders to import into DVD Studio Pro 2. You can
open this dialog in the following ways:

• In the Assets window, click Import….

• In the toolbar, click Import Asset.

• Choose File > Import > Asset… (F-Shift-I).

• Right-click (Ctrl-click) in the Assets window, and choose Import Asset…
from the pop-up menu.

2. Navigate to your assets. Select the files and folders you want to include.

3. Click Import. DVD Studio Pro 2 adds the selected files and folders to the Assets
window.

Alternatively, if your screen dimensions allow, you can simply drag files and
folders from the Finder and drop them onto the Assets window.

Examining Assets

DVD Studio Pro 2 offers several ways to look at your newly imported assets.

Columns Browse through the columns to view the attributes associated with an asset’s
data file. The information you can view depend on the columns shown.

Figure 1.12 The Import Assets dialog allows

you to import files, folders, or both. DVD Stu-

dio Pro 2 preserves the structure of nested

subfolders when you import a structured col-

lection of project assets.

You can import AAC audio from the Apple Music Store into your DVD Studio Pro Assets window so long as you

use the audio on an authorized computer.The DVD you produce will play in any computer or set-top player.
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Inspector The Inspector (F-C-I) allows you to examine and customize each of the
files that appear in your Assets tab. Until an asset is used in a project, the Inspector
shows only a general overview of that asset.

Viewer Double-click any asset (double-click its name) to preview it in the Viewer window.
(Alternatively, Ctrl-click or right-click and choose Preview Asset….) If the Viewer window
is hidden, DVD Studio Pro 2 will open the Viewer tab in a new floating window.

By default, when you import assets that have not previously been encoded, DVD
Studio Pro 2 automatically encodes them in the background with Compressor. This lets
you concentrate on authoring your disc rather than waiting for your computer to finish
encoding and catch up to you.

Here are some key points to remember about background encoding:

Status The Usability column helps identify the encoding status of certain audio and video
files. Yellow dots indicate that the files are, as yet, unencoded. Green dots reflect fully
encoded assets. (Red dots let you know that DVD Studio Pro 2 is busy parsing the asset.)

Enabling Background Encoding In DVD Studio Pro 2, background encoding is enabled
by default. To disable background encoding, Choose DVD Studio Pro > Preferences 
(F-,). Click Encoding, and choose Encode On Build. Click OK. Choosing this option
delays encoding until you’re ready to build your disc.

Viewing Encoding Preferences Use the Encoding preferences panel to set the bit rate,
encoding method, and so forth for your background encoding. To view (and/or modify)
the current settings, choose File > Encoder Settings (F-E) or Ctrl-click (right-click) in
the Assets tab and choose Encoder Settings from the pop-up.

Finding MPEG Folders By default, Compressor stores your encoded files in a subfolder
entitled MPEG. This subfolder appears in the same folder as and at the same level of
your original asset, as described by Figure 1.13.

When DVD Studio Pro 2 “parses” an encoded file, it scans the file to recover certain information such as the

file’s length, its type, and its overall integrity.When you import assets, DVD Studio Pro 2 creates small .par

files in ~/Library/Caches/DVD Studio Pro Files. A typical parse file might be named Main-

Menu.m2v.par, adding the .par extension to the original asset name.

Compressor, which ships with DVD Studio Pro 2, Final Cut Pro 4, Final Cut Express 1 and later, is explored further

in Chapters 4 and 5.
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Figure 1.13 By default, the background encoder (Compressor) creates a new folder at the same

level as your original asset. It names this folder MPEG and uses it to store the encoded files asso-

ciated with the asset. Use the Preferences dialog (F-,) to select an alternate destination. Click

Destinations and choose Encoding from the Show pop-up. Select from Same Folder as the Asset

(Default), Project Bundle (saves to the project file, a la iDVD) or Specified Folder (click Choose to

pick a folder).To set locations for your PAR folders, choose MPEG Parsing from the Show pop-up.

Managing Assets

Here are some key techniques you can use to manage the lists of assets in your 
Assets tab.

Removing Assets

To remove assets from your project, select an asset or assets and click Remove. Alter-
natively, select an asset and then choose Edit > Remove Asset or press Delete, or Ctrl-
click (right-click) the asset and choose Remove from the pop-up menu. Here are some
important points about removing assets:

• You can remove a single asset at a time or several assets at once. Your selection
controls which items are removed. Select assets, folders, or both.

• Removing assets from your Assets tab display has no effect on the actual files on
your computer. You remove the item or items only from the Asset tab.

• You cannot remove assets in use within your project. DVD Studio Pro 2 warns
you when you try to do so.

Renaming Assets

DVD Studio Pro 2 allows you to rename assets to choose more meaningful names to
use within your project. For example, you might rename f92x194j.m2v to main_

movie.m2v. Here are some things to know about renaming:

• Changing an asset name does not affect the file on your computer. To view the
original file, select the asset and choose File > Reveal In Finder. (Alternatively,
Ctrl-click (right-click) and choose Reveal In Finder from the pop-up menu.)
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• Changing an asset name does not override the built-in video- and audio-matching
feature that loads same-named audio tracks when you add a video to the Track Edi-
tor. With the above example, if you added main_movie.m2v as a new video stream,
DVD Studio Pro 2 would automatically add the matching audio file f92x194j.aif.

• Changing an asset name does not affect ordering. DVD Studio Pro 2 uses the
original asset name to determine alphabetic ordering.

Managing Folders

Asset folders work much as you’d expect, allowing you to group and organize your
assets. Some folder management techniques include the following:

Adding Folders Click New Folder in the Toolbar to add a folder to your list of assets.
Alternatively, Ctrl-click (right-click) within the Assets tab and choose New Folder from
the Assets contextual pop-up menu, or choose Project > New Asset Folder (F-C-B).
New folders appear at the same level as the currently selected item.

Renaming Folders Double-click a folder to rename it.

Reparenting Folders Drag items either into or out of folders to reparent them. Re-
parenting in the Assets tab does not affect the way items are stored on your computer.

Removing Folders Select a folder and click Remove to remove the folder and all items
within it. You cannot remove items that are in use, nor can you remove their parent
folders.

Relinking Assets

On occasion, DVD Studio Pro 2 won’t be able to find an asset you’ve added to a proj-
ect. You might have deleted it from your computer; you might have renamed it; or you
might have moved it to a new folder.

When DVD Studio Pro 2 cannot find your files, it displays the asset name in
bright red in the Asset tab. DVD Studio Pro 2 uses live links to your files, so this
update happens in real time. (To see this at work, temporarily drag a file to a new
folder and select that asset. Return the file to its original location to restore the link.)
As Figure 1.14 shows, DVD Studio Pro 2 searches for, and occasionally detects, missing
files whenever you load projects.

Relinking allows you to reconnect the project asset with an actual file on the
computer. To do so, Ctrl-click (right-click) the asset name and choose Relink Asset. 
The Relink dialog appears. Navigate to your asset file and click Relink.

To enable audio matching, open the Preferences dialog (DVD Studio Pro > Preferences… or F-,). Click Track,

check Find Matching Audio When Dragging, and click OK.
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Using the Palette Media Tabs

The Palette (F-C-P) offers another way to access audio, video, and still images stored
on your computer. Its three media tabs offer simple integration with the iLife applica-
tions that ship with Mac OS X.

The Audio Palette

The Audio palette provides direct access to
your iTunes libraries as well as other collec-
tions of sound files. This palette provides a
convenient way to iTunes audio in your DVD
Studio Pro 2 projects.

Using the Audio palette, you can drag
audio onto the Track Editor to create or add 
to audio streams. Or, you might add sounds to
the Slideshow or Menu Editor to introduce a
background track.

Whenever you relink a file, DVD Studio Pro 2 automatically searches the folder you select to detect other miss-

ing files.When it finds them, it notifies you, saying “Other missing files were found. Should these also be

relinked?” Click OK to automatically relink the detected files.

Figure 1.14 DVD Studio Pro 2 automatically

scans for missing asset files whenever you

load a project. When it finds them, it displays

this alert. Click a filename to open the Relink

dialog and search for that file.
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The Stills Palette

The Stills palette connects to your iPhoto
library, allowing you to select images from
your iPhoto albums. Use this palette to
add images to your menus, slideshows, and
tracks or store images in your Assets tab for
later use.

The Video Palette

The Video palette offers a collection of folders,
from which you can choose individual movies.
You can import any QuickTime-readable
movie into DVD Studio Pro 2.
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Using the Media Tabs

The following tips will help you make efficient use of the Palette media tabs (Audio,
Stills, and Video):

Adding Folders Click the plus (+) button to add folders to the top pane of each media
tab. You can add sound folders as new play lists, image folders as new albums, and
video folders for viewing and use in your projects.

Removing Folders Click the minus (-) button to remove selected folders, albums, or
play lists from the collection in the top pane. Removing items from the top pane won’t
affect sound and image libraries in iTunes or iPhoto.

Viewing Folder Contents Click any item in the top pane to view its contents in the bot-
tom pane.

Resizing Panes The resize handle (it looks like a long equal sign) lets you apportion
space between the top and bottom panes.

Searching Enter a search term in the space provided to search through your list. The
term matches all files that include the string you enter, whether it occurs at the begin-
ning, middle, or end of the filename. For example me matches both Mendelsohn.mp3

and Home.mp3.

Previewing Click the play button (right-pointing triangle button, Audio and Video tabs
only) to preview sound clips before using them in your project.

To use media from the Palette, drag an item or items onto the DVD Studio Pro 2
menus, tracks, or slideshows you’re editing. This lets you use media assets from the
Palette just as you would use assets from the Assets tab.

Once you add an asset to any part of your project, the file appears automatically
in the Assets tab with its In Use column checked. For example, if you drag an image to
a menu and use it as a background, the image file shows up in the Assets tab.

When you want to store assets for later use, rather than using them immediately
in the various editors, drag them directly from the Palette to the Assets tab. DVD Studio

Searching from the Palette does not look in or display subfolders.

Your home Music folder (Audio), Pictures folder (Stills), and Movies folder (Video) appear by default in the top

pane of the appropriate tab.
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Pro 2 adds them to the Assets list, parsing them and encoding them according to the
way you set your preferences (choose File > Encoder Settings or press F-E).

Solution: Build and Burn a Looping DVD

Whether you’re building a display for your point-of-sale or for a trade show, a looping
DVD presents your material without constant restarts and supervision, automatically
continuing from the beginning each time the end is reached. In these steps, you’ll build
a simple looping DVD using the QuickTime movie of your choice.

Add Your Movie

If you haven’t done so already, start a fresh new project (choose File > New or press 
F-N) before you begin.

1. Select the Track tab. In the typical Advanced layout, the Track tab appears in
the lower-right quadrant.

2. Locate the View pop-up menu. It appears at the top left of your Track window.
Track 1 should be selected. DVD Studio Pro automatically adds a track (Track 1)
and a menu (Menu 1) to each new project.

3. Locate V1, your primary video angle. It appears near the top of your track edi-
tor slightly below the View pop-up menu.

4. Drag a movie onto V1. You’ll find mainfeature.mov on the companion DVD.
Watch your cursor. The small second arrow indicates a DVD Studio Pro 2–
compatible movie. If you don’t see this double-arrow while dragging your 
movie over V1, select a different movie.

You don’t need to compress your movie or split it into audio and video components for this simple example.

You’ll use the built-in encoding of DVD Studio Pro 2 to process your QuickTime movie.
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5. Drop your movie. DVD Studio Pro 2 adds your movie and splits it into separate
video and audio streams, typically V1 and A1. If you’ve enabled background
encoding, DVD Studio Pro 2 begins encoding your movie and audio.

6. Choose your language. Locate the pop-up menu just to the right of A1. Choose
English or the appropriate language.

Set Up Your Disc

You’ll need to open the Inspector (F-C-I) before you work through these steps.

7. Select the Outline tab. It appears in the top-left quadrant of your main window
in default Advanced layouts.

8. Select UNTITLED_DISC. The Inspector 
(F-C-I) updates to show disc properties.

9. Rename your disc in the Inspector. Enter 
a disc name (for example, FIRSTLOOP) in
the Name field of the inspector and press
Return. You can use a maximum of 32 char-
acters in the name.

10. Set First Play. Choose Tracks And Stories >
Track 1 > [Track] from the Inspector’s First
Play pop-up menu (just below the Name
line). First Play specifies what happens when
a person inserts your DVD into a player.
Here, you tell it to play Track 1.
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11. In the Outline tab, choose Tracks > Track 1.
The Inspector updates again, showing your
track properties.

12. Set End Jump. In the Inspector, choose
Tracks And Stories > Track 1 > [Track] from
the End Jump pop-up menu. This tells DVD
Studio Pro to replay Track 1 after the track
finishes playing, creating a loop.

Test and Then Burn Your Disc

Be sure to save your work before proceeding.
Choose File > Save (F-S) and save to a new project,
for example, MyFirstLoop.

13. Click Simulator. You’ll find this button in
your toolbar, toward the middle.

14. Watch the Simulator window. Your movie should automatically begin to play in the
Simulator window and then repeat after its finished. When you’re satisfied that
everything works as expected, click the Close button to close the Simulator window.

If you don’t hear your audio track, be sure you’ve enabled background encoding and that DVD Studio Pro 2 has

fully encoded the audio.The Simulator may not be available while your movie encodes.
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15. Click Build. This button appears in your toolbar, toward the right.

16. Choose a build folder. Navigate to where you want to build your disc. Select a
folder and click Choose.

17. Wait. DVD Studio Pro 2 compiles your disc. The Log tab relates the progress of
the compilation. Ignore the menu warnings. Your repeating loop disc doesn’t use
any menus. When the Compile Completed Successfully alert appears, click OK.

18. Insert a recordable disc. You might want to use a rewritable disc to keep your
DVD costs down. When DVD Studio Pro 2 prompts for a blank disc, it some-
times rejects DVD-RW. To use DVD-RW, insert the disc before formatting and
burning. When OS X asks what to do with your disc, click Ignore.

19. Choose File > Burn (F-P). DVD Studio Pro 2 burns your file to disc.

20. Test your work. Walk your disc over to a compatible set-top player and play it
back to make sure that everything works as expected. You can also test your
disc using Apple’s DVD Player application.

Solution: Build and Burn a Looping Slideshow

Creating a slideshow loop is nearly as simple as creating a movie loop. In this project,
you’ll build a slideshow, add an audio track, and loop the results.

Build Your Slideshow

If you haven’t done so already, start a fresh new project (choose File > New or press 
F-N) before you begin.

1. A folder of slides, named FirstSlides appears on the companion DVD. Drag this
folder onto the Slideshows folder in the Outline tab. DVD Studio Pro creates a
new slideshow and adds these slides. You can add a maximum of 99 slides in
any slideshow.

2. Add audio. Select an audio file and drag it into the Overall Audio File well.

3. Select Fit To Audio. This option scales slide duration to match the length of the
audio track you just added.
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Set Up Your Disc

Be sure to open the Inspector (F-C-I) before you work through these steps.

4. Rename your disc. Select the Outline tab
and select UNTITLED_DISC. Edit the
name in the Inspector to reflect your proj-
ect (for example, SLIDELOOP).

5. Set First Play. Choose Slideshows >
Slideshow 1 > [Slideshow] from the
Inspector’s First Play pop-up menu. As
you saw with the previous project, First
Play specifies what your DVD plays when
it’s inserted in the player.

6. In the Outline tab, choose Slideshows >
Slideshow 1. The Inspector displays your
slideshow properties.

7. Set End Jump. In the End Jump pop-up
menu, choose Slideshows > Slideshow 1 >
[Slideshow]. This creates a loop, returning to 
the start of Slideshow 1 after the show finishes.

8. Delete Track 1. Select Track 1 in the Outline tab and click Delete. Your project
will not compile correctly if it contains a track with no video.

Finishing the DVD

Here, as with the previous project, all that’s left is to save, test, and burn.

1. Save your work (choose File > Save or press F-S) to a new project file.

2. Click Simulator to test your project.

3. Finish by writing your looping slideshow to disc (Build then Format, as you did
in the previous solution).

Expect the multiplexing (“muxing” the audio and video) of your project into the
DVD-Video Specification file structure to take a few minutes depending on the speed of
your computer.

In DVD Studio Pro 2, Build and Format are two distinct operations. Build creates structure, pro-

ducing the folders (Video_TS, Audio_TS) and files (BUP, IFO, VOB, and so on) that make

up your DVD. Format instructs DVD Studio Pro 2 to write those files to a blank DVD.
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