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Power Tips

Get the Most out of iMovie
and QuickTime Pro
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There’s more to iMovie and QuickTime Pro than
meets the eye. Both programs offer unexpected
functionality and flexibility. In this chapter, we’ll
dive behind the scenes and discover a few lurking
secrets. You’ll discover some of my favorite tech-
niques for making the best use of your movie
media—the video and sound clips that make up
your movie and the project files that put them
together. You’ll also learn how to manipulate your

clips and transfer them between iMovie and
QuickTime Pro.

Reveal iMovie's Secret Files

Get Started with QuickTime Pro
Move between iMovie and QuickTime
iMovie Power Edits
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Reveal iMovie's Secret Files

You won’t find much mystery
in iMovie. It’s a friendly and
easy-to-understand program
with just a few secret files.
iMovie stores these files—
your settings and project
files—as plain text, but it
takes a little fiddling to gain
access. Once in, you can
admire the elegance and
power that lies behind the
seemingly simple interface.
In this section, you’ll learn
how to sneak past the guard
and uncover those gems that
iMovie hides away from view.
You’ll learn how iMovie
projects are put together,
explore iMovie preferences,
and learn how to manipulate
media hidden away in your
iMovie project folder so you
can reuse these elements for

other purposes.

N4

Note: Whenever you save

your project, iMovie adds an up-to-
date movie file to your top-level
project folder. This “reference” movie
contains links to the resources in
your Media folder. To view, open the
reference movie in QuickTime and
press play.

Meet the Project

iMovie projects are very straightforward. In these steps, you’ll navigate

through the various resources that make up your iMovie project.

888 = My P =

1. Whenever you start a new project,
iMovie creates a project folder to hold
all the materials associated with that
project. Opening the project folder
reveals a subfolder called Media and
a project file. The project file has a
distinct icon with a star and a “clap-
board”-style top.
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3. TextEdit allows you to view and
edit your project file. You’ll find
TextEdit in your OS X Applications
directory. Navigate to the TextEdit
icon and double-click the icon to
launch the program.
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2. Your Media folder holds the
multimedia clips associated with your
project: all stills, video, audio, and
special clips. These clips include the
transitions, effects, and titles you
have added to your project. Here’s a
Media folder from a fairly typical
project; it includes clips, transitions,
stills, and an audio track.

O Clip @ Still
@ Transition @ Audio clip

safeivnnss pac
L tafrfones-pal pas

Clignee rich text commands

£l 1 Faanritas, (Cancel ) (S0pE

4. Choose File > Open Project
((#)-0). Navigate to your project
folder and choose your project file.
Click Open to open your project file
in TextEdit. You’ll be rewarded with
an interesting and somewhat readable
project description.
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5. Your project file details, in plain
text, how each clip is placed and
used, the order frames appear in,
and whether transitions and effects
have been applied.

Pav4_2.mav

Clip: Pawd_2.mov
File: Pawd_2.mov 181
Frames: 233 In:B Out:233 Thumb:@

6. With the text file open in TextEdit,
you can compare the text descriptions
of your project file with the actual
objects in iMovie. Here, you see the
same clip in both the Clips Viewer
and the project file. If you divide 233
frames by 30 (NTSC), you’ll see that
the 7-second 23-frame clip corre-
sponds exactly.

iMovie Help

Are you new to iMovie? If you are, the built-in tutorial offers the best and easiest way
to get up to speed. Select Help > iMovie Help to begin. When the iMovie Help window
appears, click Tutorial. With this tutorial, you work your way through a hands-on
introduction to iMovie. The tutorial takes about one to two hours to complete, but
the time is well invested. After finishing, you'll have mastered most of the skills
needed to put together your own movies.

_ 8eo0e iMovie Help

-~ iji Q

Back Help Center Ask a Question

% What's new

» Overview

# Tutorial

¢ Contents

¥ Website

=]
M
8eoe iMovie Help =g
— -
© 4 Q
Back Help Center Ask a Question
ﬁ iMovie Help
Tutorial

Click "iMovie-at-a-Glance" for an intreduction to the controls in the
iMovie window. Click a lesson title to open a PDF that explains each of
the basic concepts and tasks for creating and sharing your own iMovies.
= Basics: iMavie at a Glance

® Lesson 1: Cetting Your Video Into iMovie

# Lesson 2: Removing Unwanted Scenes

Lesson 3: Adding Transitions and Photos

Lesson 4: Adding Motion and Video Effects

Lesson 5: Adding Titles and Chapter Markers

Lesson 6: Working With Sound

Lesson 7: Watching Your Finished Movie

N/

Note: Apple offers additional iMovie support at www.info.apple.com/
usen/imovie. Find the QuickTime support page at www.info.apple.com/usen/

quicktime.

N/

Note: Join the discussion. Visit groups.yahoo.com/groups/iMovie-List
and sign up for one of the best iMovie resources around.

o
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Reset Your iMovie
Preferences

At times, you may want to reset your
copy of iMovie back to fresh out-of-
the box settings. Doing so couldn't
be easier. Just drag your current
com.apple.iMovie3.plist preferences
(from the ~/Library/Preferences
directory) to the Trash. The next time
you launch iMovie, it will automatically
create a newly initialized preferences
file. Further, iMovie will display the
dialog shown here that allows you to
start a new project, open an existing
project, or quit.

= Welcome To Mavie
i a T £ E Are=01 300 WA ] pn 80 1 67

(O et rogee 3 awe ) fSmmeProjeec)

Resetting preferences also helps
when iMovie tries switching country
systems on you. For example, some-
times it insists on starting an NTSC
project when you have a PAL camera
attached. To fix this, trash your pref-
erences, restart your computer, and
launch iMovie with your PAL camera
attached and powered on.

s/

Note: Before attempting

to edit your preferences, make sure
you save all prior work. You may
want to start a new, empty project
before beginning, just to be on the
safe side.

Edit Your Preferences

iMovie stores your preferences in a structured XML text-based format.
Follow these steps to change preferences using TextEdit. You’ll see how
to set a preference you cannot change in iMovie itself.

806 |7 Preferences =
& w=m & f A
Back Forward View i Computer Home Applications

1 of 123 items selected, 26.92 GB available

_ com.apple.iC.. Cache.plist |-

| com.apple.iCal.plist
) com.apple.iCal. saurces plist N
_ eom.appleiChat AIM.plist
_ com.apple.Chat.plist m
_1 com.apple.iDvVD.plist
| eom.apple.iMovie_plist
_ com.apple.iMovie3.plist

- com.apple.in...ework plist
| com apple.ink.inkpad plist
B com.apple.in.__pad.sketch

Name: com.apple.iMovie,
plist
Kind: XML Property List
_1 com.applen.. uilder.plist File
- _ com.apple.i...config.plist . Size: 4 KB
4 comappleinteretprelplist |4 Created: 1/21/03

1. Make sure iMovie isn’t running,

and locate your iMovie preferences file.

You’ll find it in the library of your
home directory: ~/Library/Preferences.
The file is named com.apple.iMovie3.plist.

From: | [id Pictures H

Finder001 tiff
B iMoviedd1.pdf
iMavie0 2 pdf
B iMovie00 3 pdf
iMovieQ04. pdf
L2 iPhoto Library

& MagCover copy.jpg
|3 MisePies -
T Picture 1 % Kind: Adobe Photoshop
Elements JPEG fike
T picture 2 1 P
C— 4 |
Go to:

(" Add 1o Favorites ) ([ cancel ) (EGgen )

3. Launch iMovie. Select File >
Import ((#}-Shift-I). Navigate to any
image. Click Open to import this
image into iMovie.
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Back  Forward WView
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_ com.apple.iChat.plist
) com.apple.DVD.plist
AP e Movie. plis:

Y com.apple.iMovie3 copy.plist
_) eom.apple.iMovied.plist
gin.apple.ink framework.pli
_ com.apple.ink.inkpad.pl

& com.apple.ink.inkpad. sketch Name:

Y com.apple.InterfaceBuilder.plist Kind: X

* % com.apple.interneteonfig.plist 4 Size: 1

T Y com.apple.internetpref plist v Create

& com annlodBhoto sllce I Modifie
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2. Select the preferences file and
type (8)-D to duplicate it. OS X
names this backup copy as
com.apple.iMovie3.copy.plist. As a rule of
thumb, always back up a preference
file before you experiment.

500

Fig

L

MagCove..ov.ipa

Clip Info
Name: MagCover copy.jpg
Media File: Clip 02
Size: 17MB
Captured: 2/6/03 9:02:20 PM

Duration: 05:00
Came) EOED

4. Wait as iMovie renders your
image with the current Ken Burns
effect settings. The red bar at the top
indicates iMovie’s progress. Select the
newly imported clip and play it. The
imported image will pan and zoom as
rendered. Double-clicked, the Info
dialog will not allow you to change
the length of your clip.



— Plain Text Encoding

5. Quit iMovie (iMovie > Quit
iMovie, (#}-Q). Launch TextEdit.
Select File > Open ((8)-O). Navigate
to your preferences file (not the
copy), select it, and click Open. The
preferences will appear in a new
TextEdit window.

|06 _ com.apple.iMovie3.plist
<string=2 4 1066 742 8 8 1624 P46 <'strings
ay=NIW1ntow Frome netalulndowr rone-/keys
<string=2 4 1866 742 8 8 1624 746 </strings
daya0atl aib1 w

LertinExpar

falzes

wbrugfs
<hay=lotion caveral laythrought #d

<falsa>
eyslption copturelntcovie: %

<falsess
-day=0atlon GrovP loybendmThumbe: &

<falze/= i
mwefint inn dreuTisaCadesnThome - 3 =

7. Change the value of
autoApplyPanZoomTolmportedsStills from
<true> to <false/>. Choose File > Save

(@8)-S).

kbfx.mov, iMovieHackPack.sit

<falze/= i
mwefint inn dreuTisaCadesnThome - 3 =

6. Your preferences file is a structured
XML property list made up of key
and value pairs. Keys are bracketed by
the tags <key> and </key>. Values vary
in type and can include numbers,
truth values (“true” or “false”), and
other data structures. Find the key
labeled autoApplyPanZoomTolmportedStills
in your file.

MagCove...pv.jpa | | MagCove..py.jng

Clip Info

Name:  MagCever copy.jpg
Media File: Still 01

Size: 117KB

2 03 10:09:37 PM

Duration: |05:00

Caj

’\Cam:eljf OK 3

8. Relaunch iMovie. Choose File >
Import ((&8)-Shift-I). Navigate to the
image chosen in step 3 and import it.
This time, the image imports without
the Ken Burns effect, producing a
normal still clip. Confirm this by
double-clicking the clip. You’ll be
able to set the still duration in the
Clip Info window.

continues on next page
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iMovie3. ;iﬂ ke . ] q . .
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better to simple edits. A little experi-
mentation allows you to discover
which items the Apple Development
Team left customizable. Scan through
the preference file to see which
items are more easily updated with
simple text edits.

Change only one item at a time to
determine if your modification can
be applied. Then relaunch iMovie
and test the program'’s behavior. If
iMovie uses your change, then you've
discovered another user-alterable
preference.

Always make sure to quit iMovie
before editing the preferences file.
If you forget, iMovie will overwrite
those preferences you modified as
the program exits.

s\l

Note: Under 0S 9, the

iMovie preferences file used to
state, “Do not edit this unless you
know what you're doing.” The same
warning holds true under 0S X.
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View Your
Preferences with
Property List Editor

Apple offers a number of useful
developer tools for the iMovie afi-
cionado. Property List Editor offers
a convenient way to view and edit
the property lists (plists) used as

0S X preference files. This program is
not part of the standard OS X instal-
lation. To find a copy, visit http://
developer.apple.com and sign up
for their free ADC online program.
Members may download the Mac 0S X
developer tools directly from the
ADC member site and install them on
their computer. Once installed, the
Property List Editor resides in the
Developer/Applications folder and
acts as the default editor associated
with any plist file. To view your pref-
erences file, double-click its icon in
the file browser. The Property List
Editor will launch.

ape * mm.appleiMovied copyplist

{ MewSibling %  Delete )

Fragerty st Class alie
¥An Ciclanary +

241007 TR0 107 TAG
241003 7420 0 1024 748

rin

Yes

aie: %l
et By
i

Boclean & Mo

Edit Your Preferences .ouiucd

'8 Preferences

General: | Play sound when export completed

¥ Use short time codes
| Show locked audio only when selected

Import: New clips go to: @ Clips Pane
O Movle Timeline

E Automatically start new clip at scene break

Advanced: ® Extract audio in paste over
E Filter audio from camera
_| Play video through to camera

9. Select iMovie > Preferences ((3)-,).
Examine the options presented to you.
iMovie 2 users may be dismayed: the
default still length option has disap-
peared from iMovie 3. Quit iMovie.

®00 com.apple.iMovie3.plist
<HEYSLONEY ORESPONSE T TIET %4 . 2T

</key>
<real=5.000EEEEEEE6B006e+88 < Teal>
<key-ComeraSpoo [Up: #4.27

<kay>
<real=5.000EE0EE8068006e+80 < Teal>
<ey=DefaultPonZoonburation: %4.2f

= ke
efeal>5.270000e+88 < real >

aEportSecondsBlack: %42

ke
<real>1.AB0ARINANAARAARE 0. raa >
ey=ExportSecondsBlackafter: 4.2
ke

11. Change the default still duration
from 5 to 8 seconds. Choose File >
Save (()-S) and save your changes

to disk. (As of iMovie 3.0.2, you may
need to edit DefaultPanZoomDuration
instead to achieve the same effect.)

200© | com.apple.iMovie3.plist

<eysComeraResponseTime: ¥4.2f
<y
-real=5.00EB0EBE6EE6E60e+00< Teq >
fey-ComeraSpoolUp: %4.2f
< kEy=
-real=5.AAEREARGAAARAANE+AA </ Teq |
key=Defoul tPanZoonburation: %4 .27

o155 . 2700008+ B0 o0 L=
<heysDefoultStil lDuration: a4 .2f

<readls=5,B0E0EI0E0aB0a0e 00 Tea
MiyExportSecondsElack: %4.21

-real=1.0EEBEEREGEEREA0E+00< Teq >
key-ExportSecondsE lockAfter: %4.2f
ey
10. Return to TextEdit and reopen
com.apple.iMovie3.plist. Search for the
key labeled DefaultStillDuration.

05:00 05:00

MagCove...py.ipg

¢
L -
MagCove..pv.ipg | | MagCove...pr.ipg

Clip Infa

Name: MagCover copy.jpg
Media File: 5till 01
Size: 117KE
Captured: 2/16/03 9:00:27 PM
Duration: |08:00 |

Cancel @

12. Relaunch iMovie. Select File >
Import ((8)-Shift-I). Navigate again
to the image chosen in step 3. Click
Open to import it. Due to the
changes made to the preferences file,
the new still imports with a duration
of 8 seconds.
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Slidey 00:00 (NTSC)

08:00

MagCove...py.jpg

13. It takes just a few steps to apply
the Ken Burns effect to your newly
imported still. Select your still and
drag it down to the Clips viewer.

DSCNO0O1 DSCNO002 DSCNOOO3

DSCNOOOS DSCNOO0G

DSCNO004

(o]}« T m = 0 1
cip) [Photon| Judio | Titles | Trans | effects | oD
opy.ipg T Q5.0#2/16/03 9:00:27 PM

14. Choose the Photos palette.

Ken Bu

oo
Heverse )

{_ Preview )
{ Apply ,

R—

Duration: 8.00

Photo Library

| 55 . |
15. Select Start. Drag within the
Preview to place the start of your
zoom effect within your image. The
cursor will indicate a clenched drag-
ging hand when repositioning your
picture. If desired, adjust the Zoom
slider to set the level of zoom.

Ken Bu

S D)

Reverse |

{_ Preview )
{ Apply ,

R—

Duration: 8.00

Phota Library 3} 286

| v . [ ‘m

16. Select Finish. As you just did, set
the level and position of your final
zoom. Click Apply to accept your
settings and apply the Ken Burns
effect to your still clip.

Ways to Disable the
Ken Burns Effect

As of iMovie 3 version 3.0.2, users
can disable the Ken Burns effect in
the following ways:

Stop iMovie in Its Tracks Pressing
Esc or (8] alerts iMovie 3 to stop
applying the Ken Burns effect during
import. Unfortunately, you must

wait for iMovie to acknowledge your
keystrokes, a process that can some-
times prove sluggish.

Set the Zooms to 1.00 When you
set the Start and Finish zoom levels
to 1.00, images import as still clips.
If you click any Ken Burns still, the
zoom levels revert to those inherent
in that clip. You must reset the Zooms
to 1.00 before any further imports.

Edit the Preferences File
Although scary to the novice user,
editing your preferences (as shown
in this project) offers the most
stable solution for disabling the
Ken Burns effect.

Hack the Preferences File

My own iMovie Hack Pack (included
on the companion CD) offers several
preference-setting hacks. These
include KBToggle, which toggles

the Ken Burns effect on and off,
and SetDefaultStillLength, which
does what its name suggests.

(For iMovie 3.0.2 and later, use
SetDefaultPanZoomLength instead.)
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Peek at Your
Apple Plug-ins

0S X10.2.1 and above offer a curious
trick that lets you peek at the Apple
plug-ins included in your copy of
iMovie. Navigate to your Applications
folder and select (but do not launch)
your iMovie application. Choose File >
Get Info ((38)-1). Between Languages
and Ownership & Permissions, you'll
find an item labeled Plug-ins. Click
the triangle to expand this section
and reveal the built-in plug-ins.

Add and Remove buttons allow you
to customize your iMovie application,
directly adding and removing plug-ins.

e 0 iMovie Info
¥ General:

a iMovie

Kind: Application
Size: 72.8 MB on disk (62,522,957 bytes)
Where: OSX:Applications:
Created: Sun, Jul 14, 2002, 5:27 AM
Modified: Wed, Jan 22, 2003, 6:43 PM
Version: 3.0, Copyright Apple Computer,
Inc., (c) 1999 - 2003

P Name & Extension:

b Preview:

P Languages:

2 H'V_\
Z AgedFilm.bundle b

E CircleTransition.bundle

™ Earthquake.bundle e

™ ElectricalArcs.bundle 3

{ Add... ) (" Remove.

nership & Permissions: /
P Comm:

Reuse Your Transitions

iMovie does not allow you to layer effects or transitions over your tran-
sition clips. In order to treat your transitions like other clips, you must

reimport transitions from your project media folder.

&L

=

@< () >
E A - 1
 TransitionRecover 21:09 INTSC)
09:14 07:25

£

PAV10_10.DV

PAVLO_16.0V

TR I

1. In iMovie, open a project that
includes transitions on the Timeline.
Select any transition. Here you see a
4-second Cross Dissolve transition in
place on the Clips Viewer.

0 Media (=]

= A

i Computer beme Applicatkns Modies
3 itams, 19.0 CB available
8 78

Cross Dissolve 01 PAVLIO_LO.DV 01 PAVLIO_LG.DV 01

3. Return to the Finder and locate
your project folder. Open it and then
open the Media folder within. Inside
you’ll find the materials that make up
your iMovie project. This example
includes two clips and the Cross
Dissolve transition.

i T TR T

Clip Infa

e

Captured: 2/16/03 9:58:42 FM

Duration: 04:00

Cancel ) (GOKSD

PAVL_10.00 PAVLO_16.0Y

2. Choose File > Get Clip Info
(Shift{88)-1, or just double-click the
transition) to bring up the associated
Clip Info window. Make a note of
the name of the media file associated
with your transition.

From: | [ Media &

1 Crass Dissalve 01 | m

] PAV10_10.0V 01 e

T PAVI0_16.0V 01
Kind: Document i
Size: 11.8 MB :
Feastad: 3116503

|-
Go to:
( Add 1 Favorites ) (Cancel ) (COpgn )

4. Return to iMovie. Select File >
Import ((#)-Shift-I). Navigate to your
project folder and to the media folder
within it (as in the previous step).
Choose the transition clip. Click
Open to reimport it into iMovie.
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iMovie File Types

Every file, whether in 0S 9.x or OS X, has a file type and file creator associated with
it. This file “metadata” allows your Macintosh to associate your file with an applica-
. tion and open the correct program when you double-click the file icon. iMovie files
SR _ use the Creator type Hway to indicate their association with the program. File types
vary, however, as shown in the following table. Imported images, on the other hand,
retain their original creator and type.

'Z
‘-8

ELEMENT TYPE

Sounds (AIFF, MP3, WAV, etc.) AIFF
5. Wait as the transition reimports V|d.eo C|IPS (clips, stills, titles, effects, transitions) dvc!

Project file TeXT

into your project. This may take sev-
?ral Secoflds- The new clip appears You can discover more about the contents of your project folder by using GetFilelnfo,
in the Clips shelf as a fully editable, a utility provided in Apple’s Developer Tools. (developer.apple.com, online member-
manipulable clip without any of the . . .

ship, and tool download are free). If you feel comfortable using the Unix command-
line interface, GetFilelnfo offers a convenient way to inspect your files and their

restrictions associated with normal

transitions.
properties. When you need to change your file attributes, Apple provides another
developer utility, SetFile.
8086 Terminal — ttypl
% s
Clip 81 Fairy Dust 81 PAYLE_16.04 B1
s Crozz Diszolve AL Icon?
g: Cross Dissolve AL Al Pauif 16 .04 61
4 : -
=@ =< () p)(D) % GetFilelnfo Cliph 81
SraAnsionRecover 25:09 (NTSC) file: “Clip B1"™
09:14 | Juz.zs 04:00 @ tvpe: “dyc!®
12 ] M = creqtor: “Hwoy™
S ot g attributes: avbstclinmed
PAV10_10.DV : PAVL0.16.0V _|Cross Dissolve 01 created: BZ2/16/2883 22:70:35
modified: B2/16/2003 22:28:36

6. To confirm that the new clip acts
like any other, drag it to the Clips
viewer and add an effect to it.

TransFX.mov
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Import and
Extract Sounds

iMovie allows you to import sounds in
AIFF, WAV, or MP3 format—although
it converts the latter two to AIFF in
your Media folder. (Up-conversion to
AIFF will not improve any degraded,
tinny MP3 quality.) You can also
import audio directly from a CD or
record sounds from your micro-
phone using the Audio palette. In
addition, you can disassociate the
audio from your video clips to gain
direct access to the audio track for
editing or other purposes. To extract
audio, start by selecting all or a por-
tion of a video clip or clips. Then
invoke Advanced »> Extract Audio
((8)-J). iMovie duplicates the audio
and places it in the voice track on
the Timeline, in orange. If you extract
just a portion of a clip’s audio,
iMovie automatically splits the clip
as needed to preserve the unsepa-
rated portions.

Normalize Sounds

When sound quality is too low, you can “normalize” your audio—extend

its dynamic range—using a sound-editing program. Follow these steps to

extract and normalize an iMovie audio track.

Window _Help

Extract Audig )
Paste Over at Playhead OBV
Reverse Clip Direction R
Restore Clip

1. Select the clip you wish to work
on. Choose Advanced > Extract

Audio ((#&)-]).

3 O3 Media = = 05K
Freview
Clip 2801 01 [ et
[ voice 02
s, Deskbop
Create | g Open |
[ Show Freview

A —

2. iMovie automatically switches to
the Timeline display, extracts the
audio, and displays it in purple. In
doing so, iMovie has copied your
clip’s sound to a new audio clip,
locked it with the start of the original
video clip (note the yellow-headed
pins), and muted the video clip.

" @ File Edit Selection Sound Effects Special Windaws Help

%
3[40 008k 6 e + [Chanmaie 1 3330 [T E e
1 [ [1TE8 15 sampin w0
@l == [

=

[FIE] i S iy b=

[ e & e i ]

a
FEEEER ————F
o [W u b B ol 5

3. Save your project. Launch your
favorite sound editing application.
(Here, I use SoundEffects, a shareware
package on the companion CD that
works well in Classic.) Select File >
Open and open the Voice file from
your project’s Media folder.

4. Examine your sound’s waveform.
A poor sound usually has little varia-
tion and lies very close to the centerline.
When you see a fuzzy waveform, as
shown here, do not expect too much
in the way of clarity. You’ll be able to
make things louder, which will help
differentiate voices, but the background
noise will grow louder too.
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" @ File Edit Sound Effocts Spacial Windows Help

=
Selecthone  ®D |& —————— —— ]
S oqenato e
@ [e75a0tm|  Extend to End G
Select Exactly., ®E ——— =
selectPenk. K
AR ek Select silence et 15
set Loop L :
Select Loop
) ‘ Crop ==
o Selection Info., % o m
FEEE ' — 2
ol T& uj 3 » o g

5. Select the entire waveform by
choosing Selection »> Select All ((8)-A,
or Edit > Select All in most other
sound editing applications).

" @ File Edit Selection Sound Effects Special Windaws Help
[] “Wolce 02 28

3 [90.0008k; 16 e + [Ernmeic 1 327 e [TIEHTE [ e
e [Earen [1188 [0
al (L - [TEFT

EEERE

S| [& uf b » o i

7. After normalizing, your waveform
looks different. All the amplitudes
will extend, offering a much larger
dynamic range. Play the sound clip
to hear the difference. Note that nor-
malizing is a more profound change
than simply adjusting the volume by
a certain percentage.

normsound.mov

" @ File Fdit Selection snumlspa.—inl Windows Help

O———————voi{ Hedo Eect x _EEI
[ Tiaaate kbl [crrer,  FIRSIIR Filters =
\:: ,::::,”& ; ,% Echoes & Reverbs b |- B
A [evesatme [EMmm  Mise : 0
Selection W B
e iAMDY
el T Dither e
Fade In
Fade dut
e | Nalse =
Quick Mi a
- ick Mix T
===l 2l Reverse g
. | Robotize
S| W ujf Selectionto Channel | H
Silence
Smooth
Waveform Generator
Weird Tempa

6. Determine where your editor
offers the normalization function. In
the case of SoundEffects, you will
find this under Effects > Normalize.
This feature varies by editor. Apply
the Normalize function to your sound.

" & [ET Fdit Seiection Sound Effects Special Windows Help

N |—volce024'§|

+[Gwmie o e (G0 Elem
a- O

TIEFE s
EAT sovands DG

S| [W ul v » o &l

8. If you like the result, select File >
Save, which updates your sound file
right in place. When you return to
iMovie and click Play, the sound plays
back as altered. If you feel less brave,
use Save As and save to another file.
Import that file into iMovie to substi-
tute it without altering the original.

Use Sound Effects
Judiciously and
Effectively

Although many sound editors offer
spiffy special effects, like robotic-
sounding voices, tunnel effects, and
echoes, use these with care. Every
time you alter your sounds, you're
more likely to remove quality than
add it. There are times, however, when
you're looking for a particular result.
For those times, be sure to experi-
ment on a copy of your audio file.

Each of the two audio tracks in the
Timeline is inherently stereo. Use
either track for audio content. You
can even overlap audio clips on the
same track, maintaining full stereo
in each clip.

s/

Note: Some sounds can

be very short and therefore hard to
move in iMovie. Instead of changing
your sound clip's position, you may
end up resizing or just selecting it.
When you find a sound that seems
too small to move, crank up the
zoom: The Timeline zoom pop-up
can magnify your small sounds. At
10x or above, most sounds become
large enough to grab and manipu-
late without having to touch the
resizing arrows at either end.
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Free Sample Sounds

Several sites offer excellent, free
royalty-free sounds. Two of my
favorites include ALC (alcljudprod.se)
and Hollywood Edge (hollywoodedge
.com/the_acb/webpage.cfm?&DID=9
&WebPage_ID=16). You'll find a range
of sound effects from rolling balls to
steam engines to rain splats.

Several Sounds
Make the Category

In iMovie 3 release 3.0.1, the program
adds sound categories in the Audio
palette only when the added folder
includes at least five or six sounds.
Otherwise, the added sounds appear
in Standard Sound Effects. This
behavior may change with later
releases.

s/

Note: In step 3, you're

directed to ~/Library/iMovie. If
you do not find an existing iMovie
folder at that location, you can
make the folder yourself. Add the
Plug-ins and Sound Effects sub-
folders and place your plug-ins
accordingly.

Add "Built-In" Sounds

Although iMovie offers access to iTune’s sound library, sometimes it

proves convenient to add sound effects to iMovie directly. In these steps,

you’ll see how to find and manipulate iMovie’s secret sound folder.

« ITunes Library
- Recently Played .
Song Time
T 5 Most Played
clay op=2 e 014

BEEL  iMovie Sound Effects 119

1. In iMovie, select the Audio
palette by clicking the Audio button.
When the palette appears, select
iMovie Sound Effects from the pop-
up menu at the top.

8eoce [ iMovie =
e - mEm ® 4 A ,

. Computer Home Applications
2 items, 19.92 CB available

3. Return to the finder. Open a new
finder window and navigate to
~/Library/iMovie. The iMovie folder
holds two subfolders: Plug-ins and
Sound Effects. Plug-ins holds third-party
plug-ins that allow you to add to
iMovie’s functionality. Sound Effects
stores user-added collections of sound
effects.

Xylophone 0508
Standard Sound Effects
Alarm 05:06
Bark 02:10
Bell Tower 09:20
Bubbles 10:02
Cartoon Boing 01:01
Crickets 09:10
Footsteps 12:1%
Hard Rain 09:16
Jet Fly By 08:16 | &
Race Car Drive By 01:16 | ¥
| Place at Playhea

2. Scroll to the bottom of the palette
and make note of the Standard Sound
Effects built into iMovie. You are
about to add a new library of sounds.
Select iMovie > Quit iMovie (#-Q).

m! = g A
E me Applkatians

Ik pkdinialallidaiin

4. In the Finder, create a new folder
on the Desktop named MySoundCollection.
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@ ® B 4 A @ @ m g A
Wack Fnrwaed e Computer  Wowe  Applications Tk Forward e Tomputer  Wnwe  Applications

2 kems, 19.92 GB avalabie 2 kems, 19.92 GB avalabie

g P

Plug-ir

5. Select some sounds (AIFF and 6. Drag MySoundCollection into
MP3 sounds only) and drag them Sound Effects.

into MySoundCollection. iMovie 3 only

recognizes those sounds stored within

subfolders of the Sound Effects folder.

By adding your sounds to a folder,

you’ll allow iMovie to detect them.

elp

bos Z'_O pen
Get Info

Race Car Drive By 01:16
+ iTunes Library

MySoundCollection
Recently Played - 747 Jet Takeoff 16:13 Movetotrash
Top 25 Most Played ApplauseShort 05:04
Carskid 04:20 Dupli
FireCrackle 20:01
FrogRibbit 04:03

KidsPlaying
SheepBaa

Copy "Plug-ins"

Stuffit >
T

7. Relaunch iMovie and return to 8. Scroll through the Effects list
the Audio palette. Again, select and you’ll discover your newly added
iMovie Sound Effects from the sounds.

pop-up menu.
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Preview Your Sounds

If you're not sure what one of your
iMovie effects sounds like, double-
click its name in the Audio palette.
You'll hear the sound before you use
it. If you like what you hear, drag the
effect to your Timeline and let
iMovie add it to your project.

Edit Your
Effect Volume

iMovie 3's new Edit Volume control
allows you to edit the volume in your
sound effects just as it allows you to
edit the volume in other audio assets.
To start, check the Edit Volume box.
When the Volume Lines appear,
adjust them as desired to personalize
the way your sound effects play
back. (&> “Sound Power,” later in
this chapter.)

Add Sounds Directly to Your iMovie Application

The previous project showed you how to add new sound collections to
iMovie. The following steps show how to add sounds directly to the

iMovie application.

0o |4 Applications

o = | i =
& fr=m : B 4 8 |
Back Forward View i Computer Home Applications M

€0 items, 19.9 GB avallable

= — e
HP Scanning Software Cal iChat
iovD 2 IDVD 2 buttonized Image Cap
e L
ﬁ @
[y 4
iMavie Installation Log Internet Co
@ s ©
Internet Explorer iFhoto iSync

1. Locate the iMovie app in the
Applications directory of your com-
puter (typically /Applications). Make sure
the application is not running. If it is,
quit from within the iMovie program
(iMovie > Quit iMovie, (#-Q).

)

iMoy  Help

Open
Get Info

Internet Show Package Contents
Move to Trash

;E Duplicate

.

Tum  Make Alias

Copy "iMovie”

P

Stuffit »

3. With iMovie selected, right-click
your mouse (Control-click for one-
button mice) and choose Show
Package Contents. In the following
steps, you will delve inside these
hidden files within your iMovie
application package.

i Help

Open

@ Get Info
Show Package Contents

Internet . Move to Trash

Duplicate
g1 Make Alias
iTum
Copy "iMovie”
(¢ stuffit >

2. Select iMovie and right-click your
mouse (Control-click for a one-button
mouse). Choose Duplicate. This
copies your iMovie application and
provides a backup in case things go
wrong—always a good strategy when
messing directly with an OS X pro-
gram package.

4. A new Contents window will
appear. Navigate to Contents >
Resources > Sound Effects >
Standard Sound Effects.
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E Dog Bark |A Carteon...g.mp3 =
'@ Drum Rell [0l Crickets.mp3 (el s
& Footsteps ] Footsteps. mp3
& Forest Rain nl Hard Rain.mp3
@ Glass Breaking 1l et Fly By, mp3
@ Horn Hank 1] Race Ca.
0 §) Horse Whinny
@ Kid Laugh
@ People Laugh
[ Skywalk_..Effects r

< [1 Standar._Effects » -
48 H

& Thunder
i fwagon Crash i

5. Choose a favorite MP3 sound
effect and drag it into the Standard
Sound Effects folder.

Standard Sound Effects

Alarm 05:06
Bark 0z:10
Bell Tower 09:20
Bubbles 10:02
Cartoon Boing 01:01
Crickets 09:10
Footsteps 12:15
Hard Rain 09:16
Jet Fly By 08:16

Race Car Drive By 01:16 |+

| Place at Playhead

7. Navigate to the bottom of the list
of built-in sound effects and locate
the effect you just added. The list
appears in alphabetical order.

« ITunes Library i
Recently Played

6. Launch iMovie. Select the Audio
palette and choose iMovie Sound
Effects from the pop-up menu at the
top of the palette.

SheepBaa 01

"

78 T

L3

8. Drag your new sound effect to
the Timeline. It will appear and act
just like any other built-in iMovie
sound. If desired, quit iMovie and
add more MP3 sounds to the Standard
Sound Effects folder you revealed in
step 4. When finished, close the
Contents window.

Remove Sounds,
Increase
Performance

The iMovie 3 launch process slows
dramatically when you add many
sounds to the various sound effects
folders. This is where resource man-
agement comes into play. Look
through your sound folders—both
within the iMovie package and in
your Library—and decide which
sounds you really need and use on
a reqular basis. If you can offload
some of your sounds into a tempo-
rary storage folder and away from
iMovie, you can effectively speed up
launch time. For obvious reasons,
don't give up the sounds you really
need. But when you master the tech-
nigue from this project, transferring
sounds back into iMovie takes a mat-
ter of seconds.

s/

%

Note: For another
performance enhancement,
launch a terminal window and run
[etc/monthly, /etc/weekly, and
[etc/daily. These maintenance
routines are scheduled for the
middle of the night, a problem for
machines that sleep or are regularly
powered off. To run each program,
use sudo—e.qg., sudo /etc/monthly.
You'll be prompted for your root
password.
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Beyond the Still Clip
Snap Button

This project allows you to add any
number of handy buttons to your
iMovie interface. Just select a differ-
ent function in the following step 6.
To experiment with a button you've
already created, click Disconnect
before connecting to a new function.
Here are some more of my favorite
button shortcuts.

Undo and Redo Buttons Placing
Undo and Redo buttons near my
editing area allows me to mouse
forward and backward through my
editing history.

Export Buttons | find it convenient
to keep a set of export buttons right
next to my playback screen. These
include exportMovieToCamera and
exportMovieToQuickTime. The latter
proves particularly useful as it offers
one-button-click access to a function
that usually takes several screens to
navigate through.

N/

Note: The Snap button

you create in this project bears no
relation to the Snap buttons that
appear in the Practical Plug-ins
Pack. Here, Snap refers to creating
a Snapshot of your movie at the
playhead. In the Plug-ins, Snap
refers to a snap-to-grid behavior
that allows you to size and align
overlays.

Super Geek Tricks

These steps show how to customize your iMovie application. Warning;:

this project is for Super Geeks only. This project requires Apple’s devel-

oper tools (developer.apple.com).

86eée 4 Applications =
(45} ffE=m E (?1 »
Back  Forward View { Computer  Home

&0 items, 19 B& CB availabke
[ !
= =
iovD 2 iDVD 2 buttonized Image

f Help ‘
iMov Open Internes
Get Info

Show Package Contents {

L Move to Trash
K.
. Duplicate ke
&————‘ Maka Alias | ] ATe

1. Ensure that iMovie is not running.
Follow steps 1 through 3 of the pre-
ceding project (& “Add Sounds
Directly to Your iMovie Application”)
to back up your iMovie application
and reveal iMovie’s package contents.
Revert to this backup copy to undo
changes or before installing any Apple
iMovie updates.

) —= Ter - | 2
= Pt A »
= Tert| 5% Tes i1

- =]
[sapr
! —H el
— g | L5
[ Switch | 1155
- | Finld2:
@ Radio Liised Fost Tew

C Radio ", | Sonall Systam Fore Tast

System Fanl Text

3. Drag a button from the Cocoa-
Views palette onto the top of your
main iMovie window. Double-click
the new button and edit the name to
“Snap”.

[-XsX ] [ English.|praj

Il plis
L Maens il
[0 Mac05Classic I cFizicns 1 woom
4 Peginfo ¥ EffectsTab.tif T
7 Pag-ins ¥ enc.f £5 wrsain
7 Plugins v Apia) B L3 e
|7 Resources
varsion.plist

¥ Fastior.bover.bf £ sty
¥ Fastforw...rmal.bé % InfoMis

2. Navigate to Contents >
Resources > English.lproj. Double-
click IMMainMenu.nib to launch
Interface Builder.

1 IMMainbenu_nib

| Instances [ Classes ] Images [Sounds ' N

A L (e

Mainkenu App Cantroller

_B e el

4. Adjust the windows so you can see
both the main iMovie layout window
(the one with the new button) and the
iMovie IMMainMenu.nib window
(Windows > IMMainMenu.nib), as
shown here. Most importantly, you
must see both the Snap button and the
App Controller cube at the same time.
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1 IMMainMenu.nib

#pp Contraller

T

Tewy | W

P \
_Bumon } ()

I Enebirte

5. Press and hold the Control key.
Drag from the new button to the
App Controller cube. A square
appears around the App Controller
cube to show you’re in the right
location. Release the mouse. Release
the Control key.

Ii]g Edit  Classes Format

New... BN
Open... O
Open Recent »
Import >
Close Document ORW

Save As... RS

Revert to Saved

Document Info
Compatibility Checking...

Test Interface R
Page Setup.., GHP
Print... we

7. Choose File > Save ((88)-S) to save
your work. (Remember you made a
back-up copy of iMovie just in case!)
Leave Interface Builder and launch
iMovie.

wal

bicrale

6. If you’ve performed step 5 cor-
rectly, the Info window (Tools >
Show Info, (88)-Shift-I) appears with
the Connections palette active. The
left side will say Target. The right
side offers a scrolling list. Scroll to
createStillClip and select it. Click
Connect.

IMovie: L1320 (NISL)

8. iMovie now offers the Snap but-

ton you created in the previous steps.
Move the playhead to any frame and
click Snap to create a still clip of that
frame. To revert your copy of iMovie,
quit the program, trash your altered
version, and rename iMovie copy to
iMovie.

Beyond the Valley
of the Geeks

If you want to achieve super-super-
geekiness, consider adding keyboard
equivalents to your custom buttons.
In Interface Builder, select your but-
ton and choose Tools > Show Info
(()-Shift-1). Select Attributes from
the pop-up menu at the top. Enter a
keyboard equivalent and check off
the Option or Command keys as
desired. The equivalent shown below
is (&)-Option-Shift-G. (Use lowercase
to skip the Shift modifier.) Don't for-
get to Save and relaunch iMovie.

[sXal:] NsBuston Infc

Anrributes =)

Title: Snap
Alt. Title: |

sound: |

Equiv: G <nokey> o) e M

Type: | Push Button =)
Behavior: 5
Options Alignment
¥ Bardered
£ Transparene | | {10 | o1 | 1|
] Cantinose
s

Note: Your new button

will move when you resize the
iMovie application unless you lock
it in place. Select the button and
choose Layout > Lock Frame
((s8)-Option-L).
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Get Started with QuickTime Pro

el e s & jporesil Getting Help and Learning QuickTime Pro

movie-editing tool. It works ) o
Apple offers a variety of QuickTime Pro resources through your com-

it me e Vst (sl puter’s Help menu and the online QuickTime help site. In these steps,

creates cool special effects, you’ll see how to find these resources.

and far surpasses iMovie in

power. iMovie, in contrast,
8086 Suare s b =

works only with a single video - BT Vi wrvmnn

track and, without third-party
plug-ins, does not handle

such professional features as

masking, transparency, and

Q OukaTime Player e |-
Q) QukaTime Ploves Kelr |+

0 ukckTime Flayer VR contros
=g tracks 103 mavie

video resizing. Unfortunately,

Ho
Tozic located in: SuickTime Flaver Hole

QuickTime Pro does not

provide the friendliness and

» i . 1. To access the QuickTime Help 2. Enter a question into the text
usability that make iMovie Center, select Help > Mac Help from field in the upper-right corner and
such a pleasure. Don’t let the Finder. Scroll down to Quick- press Return. Help Center returns a

Time Player Help and click it. list of topics related to your query.

this dissuade you from using o .
QuickTime Player Help includes

QuickTime Pro. It is an topics for both the basic player and
amazingly flexible and useful QuickTime Pro.

program, and you can get up

to speed quickly. The over-

views and examples presented

here will get you running in Zoja hm:wmm S 290 _smemme =

short order. —— ﬂ
N1/ =

Note: You'll find the basic

QuickTime 6 player on the companion

CD. Visit www.apple.com/quicktime g

to buy a license to unlock the Pro L

features ($29.99; the viewer-only

version is free). Be sure, either 3. Double-click any topic. Help Center 4. The QuickTime Tutorial offers an

displays the information for you. excellent resource for learning about

way, that you're using version 5 or
y y ; ff QuickTime and QuickTime Pro.
later. Versions 5 and 6 offer all the Launch your browser and navigate to

power you need for the projects in www.apple.com/quicktime/tools_tips/tutorials/.
this book.
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QuickTime Pro Playback Shortcuts

Use these shortcuts to help you control the playback of your QuickTime movie.

e
— SHORTCUT ACTION
Vomaeman] s | rocosn |
e —— [ Spacebar, Return, or Control-M Toggles playback on and off.
mem’"_hf s (38)-left arrow or (38}right arrow Plays movie in the direction indicated.
Left arrow or right arrow Moves the playhead one frame in the direction indicated.
Option-left arrow or Moves to the next major feature in the direction indicated.
Option-right arrow Major features include movie start, left crop marker, right
crop marker, and movie end.
Up arrow or down arrow Adjusts volume up or down.
5. Select a title and click the link to ggggz:ggﬁgr:rv:oo“rl Adjusts volume to the maximum setting or mute.
open the actual tutorial. Tutorials
inilu de overviews. sten-by-step instruc- Control-\ or Control-] These two key shortcuts act as the left and right arrows,
. » Step-by . P respectively, if your keyboard does not have separate
tions, and lots of helpful pictures. arrow keys.
(38} (period) or Stops playback.
click the movie image
Control button with Plays the movie without sound.
Play button in the window
Shift-double-click the Plays the movie backward.
movie image
- _— B (8L Sets/resets Loop Mode.
;: (s8)-0, (381, (382, (38)3 Sets playback at half, normal, double, or quadruple sizes.
6353 Plays back full-screen.

i Busic Bibtirg

T (T editing a QuickTime movie

Other Resources

You can find other QuickTime Pro resources on the Internet. Here are just a few.

Usenet The comp.sys.mac newsgroups may be able to help with your QuickTime

questions.
6j ) For more QuickTime Pro help, Apple Support Apple offers a comprehensive, searchable knowledge base at
visit http://helpgt.apple.com/qthelpcr/ http://kbase.info.apple.com/. Plug in your QuickTime question and discover what

english/QuickTimeHelp/. You’ll find more
tutorials and information.

answers Apple has on hand. Visit Apple's QuickTime specific Ice Floe at http://
developer.apple.com/quicktime/icefloe/. Apple offers additional QuickTime docu-
mentation at http://developer.apple.com/techpubs/quicktime/gtdevdocs/RM/
frameset.htm.

QuickTime Mailing Lists Sign up for a QuickTime-specific mailing list at
www.apple.com/quicktime/tools_tips/mailing_list.html.
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Set Your QuickTime
Pro Preferences

When you first start to work with
QuickTime Pro, you'll want to set
your preferences. Establishing these
will make your life a lot easier when
you actually sit down to work. Select
QuickTime Player > Preferences >
Player Preferences.

QuickTime Player

About QuickTime Player

Frefarences » Player Preferances. ..
Update Fxisting Software QuickTime Prefersnons

. Registration. .
Services

Hide QuickTime Player *H
Hide Others SCHH
Show All

fQuit QuickTime Player 503

There's one particular preference |
find vital. Ensure that Open Movies
In New Players has been selected
and click OK. This changes the
default File > Open Movie option to
File > Open Movie In New Player.
When you open a movie, QuickTime
adds a new window without auto-
matically closing any windows that
are already open.

Player Preferences
Movies:
# Open movies in new players
] Automatically play movies when opened
Sound:
E Play sound in frontmast player only
@ Play sound when application is in background
¥ show equalizer
Hot Picks:

[ show Hot Picks movie automatically

() @06

Know Your Tracks

Follow these steps to view and work with the tracks that form your movie.

Favorites  Wind
Mew Player BN

Open Movie in New Player... %0 |
Open Image Sequence

Open URL in B Gnen

Open Recent

From: | [ Saurce Waterial (B

i L -
Import.... ) ...::.:,n e
Expoi 2 mubticrpir.mes:

B scald sudio.naw
Page Setup... & singleirack.may MOVIE

Gata

P
e o Faverdnes )

Comr) Gom

1. To open a movie, select File >
Open Movie In New Player. (If you
haven’t set your preferences, the
menu item will read File > Open
Movie. Press the Option key before
you click File to reveal the alternate
menu item.) Navigate to your movie
and click Open.

8o singletrack.mov Properties
+ Mavie B [ Annotations ) :]

. Sound Track

Data

(add... ) ( Edit Delete
C )

3. The Movie Properties window
offers two pull-down menus. The left
menu gives you direct access to each
track in your movie, including all
audio, video, and the main “movie”
track. Here you see what a standard
movie with a single audio and video
track looks like.

2. With your movie window open,
select Movie > Get Movie Properties
(#8}]). This opens the Movie Properties
window, which is the heart and soul

of QuickTime and allows you to
directly control and manipulate the
tracks associated with your movie.

L )5) singletrack.me: Branactine
"~ Alternate E
Video Track 51 |« Annotations ]
. Files E
= Format
Properties
-2 Frame Rate =

Craphics Mode

High Quality
Layer
Data Mask
Preload
Size
/W\ Edit Delete
\add... )

4. The right pull-down menu offers
track-specific options. With this
menu, you can alter such features as
placement (the Size option), layer
ordering, and graphics mode.
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I 8_ Movie maov Properties
| + Video Track 1 General B: Delete Tracks

Video Track :
Sound Track 1 E—
Sound Track 2 0:05:00
Sound Track 3 5

Darta Size: 885.1k

Data Rate: 176.8 K bytes/sec

0:00:00

| Change Name |

5. When more than one video or
audio track are added, they are num-
bered accordingly. (You can change a
track’s name from this automatic
numbering system with the General
palette, if desired.) In this example,
I’ve added three sound and three
video tracks to this movie.

Graphics Made
High Quality

ioao Track 2 B

Layer Sumibar: -5

8. To change track order, adjust the
layer number for any track. This
example selects Video Track 2.
Choose the Layer palette from the
right pull-down menu.

multilayer.mov

Video Track 1
Video Track 2
Video Track 3
Sound Track 1
Sound Track 2
Sound Track 3

4 LY
Cancel E@

6. To remove a track, select Edit >
Delete Tracks. Choose the track or
tracks you wish to remove, and click
Delete. If you remove a track or
tracks by accident, select Edit >
Undo (&)-Z) to restore them.

Ny L

ab sl Lages i PriopeTies

(widea Track 2 19 [Laver 2]

Layar Number: < il
Zmaller layer numbers are fusther forward.

7. QuickTime assigns layer numbers
to each video track. Layers with
smaller (or, typically, “more negative”)
numbers lie on top of—and may
obscure—layers with higher numbers.
In this example, Video Track 3 (seen
in the window at —6) lies above Video
Track 2, which in turn lies above
Video Track 1.

SN e

e @

L

Sralar bier rumgers a0 uribar foraes.

] sy |

9. To lower the layer number, click

the small down-arrow. The up and
down arrows adjust the layer number
one level at a time. Here, at a layer
of -8, the second track arrives in front.

B0 munbnnm e

DT s [ (s =
— a0k
Gumere 00w ag pacts
T =

S

s = ey i I
10. With QuickTime Pro, you can

change more than layer ordering.
To change image orientation, select

Size from the right pull-down menu.
Clicking the first arrow button mirrors
your image horizontally; the second
mirrors vertically. The last two rotate
your image clockwise and counter-
clockwise. Click Normal to revert to
your original footage.

continues on next page
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QuickTime Pro
Sizing Shortcuts

QuickTime Pro does not offer many
(or very useful) editing shortcuts,
but there are some to be had when
working with a track after you click
Adjust on the Size palette:

+ Hold down the Option key while
resizing to automatically snap
between full-size and Yi-size.

+ Hold down the Shift key to limit
movement and resizing along
one direction.

You can also center a Ys-Size image
fairly accurately by resizing into one
corner and then using the original
crossed circles as placement guides,
as | do here.

Know Your Tracks .ouined

-X] multdayer.mov froperties kA
Cviden Trark = [8) [ iew ]

Harmal  TE0 w0 AA0 pikels
Cument: 2w 420 pleels (Marmal

eog mudtlags s
r 2

0§

"

= BRI = |

11. To change the image size, click 12. Drag any corner handle to resize.
the Adjust button. Small red handles If you press the Option key while
appear in the center, the corners, and dragging, you’ll automatically snap
the middle of each edge. These han- to full-size or, as shown here, %-size.
dles allow you to size and reorient Notice how resizing Video Track 2
your image. reveals Video Track 3 underneath.

et

= BRI = |

13. You can reposition the video by 14. The small crossed circles, at the
dragging in the middle areas (avoid- middle of each side, allow you to
ing the circle at the center). For this skew your video.

example, move the image roughly to
the center of the window. (Pressing
the Shift key constrains you to only
horizontal or vertical movement.)
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15. To rotate the image, drag out
from the center circle. A handle will
appear, following your mouse. Use
this handle to control the degree of
rotation. You may find a longer han-
dle easier to manage than a short one.

18. Click Adjust and the red handles
appear for the newly selected track.
Notice that the track ordering does not
change. In this example, I resize track
3 in place, as it lies behind track 2.

8o multilayer.mov Properties

"Video Track 2 -H Size H-]

Normal: 720 x 480 pixels
Current: 508 x 302 pixels

—E.’ Normal )
(=[] [o][9]

16. Click Done to finish adjusting the
video track, or click Normal to revert
to the original size and orientation.

it

rm

el

720 480 sl
1 TR1s2aalan

o

[=EF

o] o]

" @. I

19. Proceed to adjust the current
track. Then click Done to finish.

17. Now select another track to resize.

Save exported file as...

Save As: | multilayerdy

where: | Deskiop 3] Ej
Expor: | Movle to DV Stream 9 (options... )
Use: | Default Settings (3]

(camcel ) @SiD

20. Select File > Export (#)-E) to
export to a new movie that merges
your video layers into a single
video track.
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Sound Advice

Take care when using Add Scaled to
add a movie with a soundtrack. As
the video stretches or squashes to
fit the selected timeframe, so does
the audio. Squeeze it into a shorter
space, you'll end up with a high-
pitched audio. Similarly, if you
stretch your audio track, you'll wind
up with a low-toned, slowed-down
effect. Any audio overlay without
some fade-in and fade-out will pro-
duce sharp, noticeable, and uncom-
fortable transitions between the
original and added soundtracks. You
can hear an example of audio scaling
in scaled_audio.mov on the compan-
ion CD.

N/

Note: To save your work

after adding tracks, use File >
Save ((8)-S). Select Make Movie Self
Contained to create a file contain-
ing all the tracks—originals and new
ones. Selecting Normal takes up
much less space, but you have to
keep all the source files with the
movie. Your movie needs these
extra files. If you lose one, your
movie won't play back properly.

Add Tracks to Your Video

Follow these steps to add new tracks to your video. You can add tracks
in a QuickTime video, much as you add layers in a Photoshop or
Photoshop Elements image.

2. Open the movie you intend to
add to the first. Select the entire
movie track (Edit > Select All, (38-A)
and copy it (Edit > Copy, (#-C) it to
your computer’s memory. After copy-

1. Open your base movie in
QuickTime Pro. This is the movie
you’ll add tracks to.

ing, close the window (File > Close,

(88 W).

=0 ) ) () ) ) =0 ) ) () ) )

ey | -

4. After you add the track,
QuickTime Pro moves the playhead
to the end of the new material.

3. Position the playhead where you
wish to add the second movie. Edit >
Add (Option-{#}-V) adds the new
track to your movie starting at that QuickTime shows your added footage
position. Do not confuse Add with if its duration exceeds that of the
Paste. The Paste command does not

add new tracks.

original (as it does here) or the origi-
nal footage if it does not (as shown
in step 7).
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B HEFEE o B -
5. You may wish to specify the exact 6. Copy the footage you wish to 7. As with Add, Add Scaled causes
range of frames to overlay with a new add, as per step 2. Scale this footage the playhead to move to the end of
track. This stretches or squeezes your over movie with Edit > Add Scaled the addition. Move the playhead
footage to exactly fit the duration of (Option-Shift-(3)-V). back into the gray selected zone of
those frames. (This works particularly the scrubber bar. The new footage
well when adding still images to appears over the original.

moving footage.) To start, revert to
your original base movie and select
the frames you wish to overlay.

= : L R = T = SISICICICI
8. Open Movie Properties ((8)-]). 9. Move the playhead outside the 10. Return the playhead into the
Select Video Track 2 from the left dark-gray selected area of the scrub- selected area. The new track reap-
pull-down menu and Size from the ber bar, to either side. The new track pears. Remember that the key is the
right. Click Adjust. Resize your new disappears—it wasn’t added to that playhead location on the scrubber
track until you see both tracks at part of the movie. bar, not the selection. To prove this
once (& “QuickTime Pro Sizing to yourself, type ()-B (Edit > Select
Shortcuts” sidebar earlier in this None) and move the playhead to var-
chapter). ious locations on the scrubber bar.
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Royalty-Free Annotate Your Movies

°
Material QuickTime Pro offers a handy way to annotate your movies. Annotations

Take care when using clips, sounds (viewable by anyone with a QuickTime player) can take the form of

and other elements that you did not
capture or create yourself. Know
whether you comply with fair use

credits, copyright notices, and other labels.

8 6 basemaovie.mov Properties _ Add Annotation _
guidelines and whether you need to Vovie 5 ey ]
pay royalties. Royalty-free footage, —— E=as E;:L’:LT — ;mmw .
stills, and sound effects are easily ' 1§51 Freb - m 5]
purchased from a variety of vendors. e — e
You can use these elements in your Data Time E —
videos without having to pay any e
further fees. -

(Add... )

fadd.. y {edic. ) { Dolote )

Ulead (rfm.ulead.com) offers a wide

range of royalty-free products in their 1. Open the Movie Properties win- 2. Scroll through the list of available
Royalty-Free Media series. Titles dow ([&)-]). Select Movie from the left annotations and select one. Enter a
include Pick-AVideo. Pi k'A Sound pull-down menu and Annotations value for your annotation in the text
nciu _e Ic I0eo, IC_ ound, from the right. Click Add; the Add area and click Add. To view an anno-
and Pick-A-Photo. In particular, check Annotation window pops up. tation, click its name in the Properties
out their Pick-A-Video-Pro. These list. The associated information
media collections offer high-quality appears in the Data panel.
computer-generated art that includes
both video backgrounds and animated
overlays. Themes include Money,
Finance, FeStiVitieS, and Seasons, 3 () basemaovie.mov Properties 80 basemaovie.mov Properties
among others. Add Annotation Movie %) (Annotations %)
| Genre m :
Many, if not most, of the projects in idellos ; :‘;f::r'ef
this book use video clips and stock Make 3 information
Thi i W, reated usi
photography from Ulead Royalty Free QuiekTime and iviovie 3 for TMovie 3 oata
. . . Solutions"
Thi i ol usi ickTi
Media. If you spot a clip you fike, stop T e e g ks
by their website to discover more. (Cancel ) (@AdaD)
T ——— (add. ) (edic. ) (Delete )

3. In the Movie Properties window, 4. The new annotation appears with

click Add to add another annotation. the original in the Properties panel

When the Add Annotation dialog of the Annotations palette. Click an

appears, select a new annotation, annotation name to view the associ-

enter a value, and click Add to finish. ated data.
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Annotations
©® O © basemovie.mov Properties Don't feel limited to the annotations used in this project. QuickTime Pro offers an
Movie F#) (Annotations 4] extensive collection of predefined annotations. Pick those that best match your doc-
— umentation needs. The full list includes Album, Artist, Author, Comment, Composer,
haher ' Copyright, Creation Date, Description, Director, Disclaimer, Encoded By, Full Name,
Genre, Host Computer, Information, Make Model, Original Artist, Original Format,
DTaht; T Original Source, Performers, Producer, Product, Software, Special Playback
and iMovie 3 for "iMovie 3 Solutions Requirements, Track, Warning, Writer, URL Link, and Edit Date 1through Edit Date 9.

QuickTime Pro Selection Shortcuts

5. To update the stored information

select an annotation and click Edit. Use these shortcuts to help create selections in a QuickTime Pro editing window.
The Edit Annotation dialog appears,
displaying the current data for you SHORTCUT ACTION
to edit. 6373 Selects the entire movie.
(2B Selects nothing at all; deselects (this is the Select None command).
Control-Shift-[ A less-well-behaved equivalent of (8}-B/Select None.
Shift-left arrow or Moves the playhead one frame in the direction indicated and expands
Shift-right arrow the selection to that frame.

Shift-(38}left arrow or  Moves the playhead one frame in the direction indicated, expanding
Shift-(38}-right arrow the selection to that frame, and then starts movie playback, moving

S| Edit Annotation =

the crop marker with the play of the movie until the (88) and Shift keys
Information are released.
This movie was creatad using . . q a
QuickTime & and iMovie 3 using a Shift-drag Adjusts the selection according to the placement of the mouse along
variety of techniques| the scrubber bar.
P Control-left arrow or Moves right or left to the next major feature: the start or end of the
(aancel) 0N Control-right arrow movie or the selection start or selection end markers.
TThis movie was created using QUICKTIme (88X Removes the selection and copies the removed portion to your

and iMovie 2 for "iMovie 3 Solutions®

computer's memory.
= T = o (sg)-shift-v Replaces the selection with a clip from memory.

s

6. Enter a new value into the
Information field of the pop-up win-
dow and click OK. Select File >> Save
((38)-S) to save the annotations with
your movie.
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Move between iMovie and QuickTime

While iMovie and QuickTime
Pro are both excellent, pow-
erful programs, the problem
at times is that they aren’t, in
any way, the same program.
So you end up shuttling your
data between one and the
other a bit more than you
might like to. What’s worse,
these programs use slightly
different shaped pixels. This
can turn into a major pain,
producing stretched or
squashed pictures, or stills
lined with black bars. But a
funny thing happened on the
way to iMovie 3. Apple com-
pletely rewrote iMovie and
used QuickTime to handle all
of its file opening and saving
services. Suddenly, the two
programs became a lot more
compatible. Now, you can
export and import all sorts
of video from iMovie. You
can use lightweight reference
movies that keep your video
data within your project’s
Media folder. You can also

produce Windows-ready
AVI files.

Export and Import Movies

iMovie 3 can export or import nearly any file type that QuickTime
supports. From AVI to MOV to DV, iMovie 3 will handle it. Here’s how

to export your movies.

iMovie: Export

Expert v To Camera ,i
wait . 5 sady.

2 ToiDVD
I

Add 1 seconds of black before movie.

Add 1 E seconds of black to end of movie.

Please make sure your camera is in VTR mode and has a
writable tape in it,

f_ Cancel \ " Export :

1. From within iMovie, select File >
Export Movie ((#)-Shift-E). This
instructs iMovie to open the Export
dialog. Choose To QuickTime from
the pop-up menu.

IMovie: Expert

Export: | To QuickTime I :}
Formats: | Expert Settings... L :]

Your movie will be compressed with
appropriate semings and may be reduced
in width and height as well. This
operation may take several minutes 10
complete,

F ar— 6 k
Cancel Export

3. Click Export. This dismisses the
Export dialog and opens the Save
Exported File As dialog. From here,
you can specify how you wish to save
your movie and where to save it.

iMovie: Export

Export: | To QuickTime i+
Formats v Email i
Web

vourmg  Web Streaming
approprl  CD-ROM |

in width i
el Full Quality DV

complet

Expert Settings... .

f_ Cancel \ " Export :

2. To gain access to the widest vari-
ety of export choices, choose Expert
Settings from the pop-up list.

Sawe exported file as..

Save As: | CirclePraj.may

where: | MEDesktop =15
Export: | Movie to QuickTime Movie %) (options.. )
Use: | Most Recent Settings ]

4. Enter a name for your movie in
the Save As field. Choose where to
save your movie from the Where
pop-up menu. If desired, click the
down-pointing arrow on the right to
bring up the OS X file browser. This
allows you to save to any folder on
your computer.
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Export Types

_ e iMovie 3 offers many of QuickTime's file export and import capabilities. The sizes listed
Movie, sef-contined here refer to a test 10-second-long iMovie exported to various file types. Actual num-
i1 B bers will vary movie by movie.
]

Movie to BMP

Movie to FLC

e e . DV Stream (34.2 MB) DV Stream is the native iMovie video format. DV Stream
Movie to MPEG-4 - .
B BE (a.k.a. DV-25) uses a 5:1 compression scheme that can mangle sharp edges and overly
e 4 o to kT oV —f Goreee vivid colors.
Use Movie to Toast Video CD a
Sound to AIFF . . .. .
Sound o System 7Sound iy Reference Movie (0.13 MB) Reference movies use minimal disk space. The refer-
— Jr— ence movie refers to assets stored in your media folder. The reference movie will not
5. Choose a file type to export to work if you delete or rename your media folder. iMovie stores a reference movie in
from the pop-up Export list (& your project folder each time you save your project.
“Export Types” sidebar). Options . .
range from QuickTime MOV to Self-Contained Movie (50.2 MB) You can copy self-contained movies to other
Windows-compatible AVI. computers that have QuickTime installed and view them there. Unlike reference

movies, these movies contain all their video and audio assets within the file.
AVI (1.6 MB) AVI files provide highly compressed and very transportable movies.

MPEG-4 (0.8 MB) Highly compressed MPEG-4 files offer a way to share your movies
with others around the world via e-mail and the World Wide Web. iMovie cannot
reimport MPEG-4 files.

AIFF (1.8 MB) iMovie's native sound format, AIFF, allows you to extract the sound
track from your iMovie and save to a sound-only file format.

Save axported file as

sove i [CiraRialm 2 DV-Stream PAL/NTSC (34.2 MB) iMovie allows you to export from one country
s o system to another. To access the different format, click Settings in step 6 and select
L R T B Covson either NTSC or PAL as your Video Format.
Coner) R QuickTime Movie (Varies) When you select Movie To QuickTime Movie, you reveal
6. If desired, and if the button all the power of QUickTime e).<ports. Click the Options button in step 6 to set your
appears for your choice, click Options movie's quality, size, codec, filter, and more.

and set those options specific to the
file type you selected in step 5. Click
Save to export your file to disk.
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Know Your
Still Sizes

QuickTime and iMovie use slightly
different pixel shapes. A still that
works perfectly in iMovie may
appear distorted in QuickTime and
vice versa. QuickTime circles may
appear as iMovie ovals and iMovie
circles as QuickTime ovals. This hap-
pens because computers generally
use square pixels while television
and broadcast video use rectangular
pixels. Since iMovie pixels are rectan-
gular, they occupy more “space,”
allowing the same-size video to
appear with fewer pixels. Fortunately,
most image editors easily allow you
to resize your image—squeezing or
stretching to fit. The exact image
size varies by broadcast system, as
shown here:

NTSC PAL

iMovie 640x480 768576
QuickTime  720x480 720x576

N/

Note: “Rectanqular” and
“square” pixels are largely a matter
of convention. The physics of com-
puter and television displays are
not that different from each other.
Also, broadcast engineers and com-
puter scientists don't always agree
on how rectangular pixels are
shaped: taller than wide or wider
than tall. In the end what really
matters is the aspect ratio—the
proportion between the width and
height of the image.

Transfer Stills

If you want to transfer a single still, you’ll need to resize it in an image

editor. Here, you will see how to export a still from QuickTime, resize

it, and then properly import it into iMovie.

1. Open your movie in QuickTime
Pro. Standard DV movies occupy
720x480 pixels (720x576 for PAL
systems). Choose Window > Show
Movie Info ([#-). You may need to
click the arrow next to More Info to

reveal the size.

E
3. Launch iMovie. Choose File >
Import ((#)-Shift-I). Navigate to your
still and click Import. iMovie imports
your image. Notice how the odd size
forces black bands above and below
the image. It helps here to have turned
off the Ken Burns effect (&>~ “Edit
Your Preferences”).

2. Export a still from QuickTime
Pro using the bitmap export feature
(File > Export or (8¢}-E). Choose Movie
To BMP and use default settings.

muge 528

Al Bbrencies 17135
[0 ]
Wrgm [sn [ebaie |

Tniraes S

w10

Hewn [EEET |

4. To correctly import the still, you
must first resize it. This example uses
Photoshop Elements, a demo of which
is available on the companion CD.
The same method will work in any
good image-editing program. Open
the still in Photoshop Elements and
select Image > Resize > Image Size.
Ensure that Constrain Proportions is
unchecked.
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5. Enter the correct new pixel
dimensions and click OK. In this
case, I convert a 720x480 picture to
640x480. Enter 640 in the width
field and click OK. To go from
iMovie to QuickTime Pro, change
640 to 720 instead.

beachso...e2 bmp

7. In iMovie, the newly resized

image fits perfectly without needing

“filler” bands to pad the picture.

e C e ) e

6. Save the converted file back to
disk, in preparation for importing to
iMovie.

8. You can see the size difference

clearly in QuickTime. Here’s what the
resized still looks like when imported
into QuickTime and overlaid above
the original DV footage.

Create a Still

in iMovie

Creating stills in iMovie is as easy, or
even easier, than in QuickTime Pro.
To create one, just press (&8)-F (File >
Save Frame As), enter a name, and
press Save. iMovie saves the frame
found at the location of the playhead.
You can save in either of two formats:
JPEG or PICT; select one from the
Save Frame As Image dialog. While
JPEG offers smaller files and better
transportability between programs
and people, PICT offers higher image
quality and less compression.

Save as: | MyFrame|

‘Where: | [ Desktop Bv B

Formar: [ jpeg _B
o) @

N/

Note: Some early versions

of iMovie 3 (notably 3.0.1 and 3.0.2)
create inaccurate stills. The bug
seems to lie in that iMovie creates
a 720x480 image (720x576 PAL) and
crops the right 80 pixels to resize
it to 640x480 pixels. As you can
tell from this project, this is not the
proper way to produce an iMovie-
sized image from QuickTime-sized
data. Hopefully the Apple Engineers
will fix this bug before long.
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Import Small Videos
Directly into iMovie

With iMovie 3, you can import small-
sized videos directly, but you may
not like the results. iMovie scales
your movie to standard DV size
(720x480 square pixels for NTSC,
720x576 for PAL). When you enlarge
a video in this way, you magnify
defects and expand the “blockiness”
that results from low resolution. You
may prefer to place your smaller
video above a solid matte, as shown
in this project.

It may seem counterintuitive to add
the matte to the video, but there's

a good reason to do it. You add it
over the video because you want to
scale that matte for the entire video
duration. If you were to reverse this
procedure, adding the video over
the matte, you'd end up with either
an extremely short video (when
using Add Scaled) or the matte
would disappear after a single frame
(when using Add). Relayering proves
vital when creating a matte track
that extends for the full length of
your movie.

s\l

Note: 720x480 pixels

refers to NTSC DV. Have you ever
wondered about the name for
iMovie's 640x480 video? The
answer is D2. When working with
stock footage, you may also
encounter 720x486 pixel D1 video.
Visit www.uwasa.fi/~f76998/
video/conversion for a superb
discussion about video standards.

Prepare Nonstandard Sized Video

Web cams, USB digitizers, TV cards, and many other sources may all
produce small-sized video. In these steps, you’ll create a virtual matte
that preserves video size and resolution when exporting to an iMovie-

compliant DV stream.

1. In Photoshop Elements, create a
new 720x480-pixel blank RGB still
(720x576 for PAL) filled with any
color. (Screen resolution does not
matter. Choose any resolution you
like.) Save to disk in a PSD file and
open it in QuickTime Pro.

|| Redo Add Scaled %z ov

Cut wX
Copy e
Paste ®Y
Clear

Select All A REREE
Select Mone

r Enable Tracks...
Extract Tracks...

T

i. D.elete Tracks... (:’/\ \:; @ .
3. Open your small- or odd-sized
movie. (In this example, I use a
320x240 clip imported from an old,
analog camera.) Select all ((&)-A). Add
the matte with Edit > Add Scaled
(Option-Shift-#)-V). Your QuickTime
window will resize and the blank
matte will overlay your video.

298 or furebbime pot

" ¢

e  ceces o
2. In QuickTime Pro, select all of

the blank still ((3)-A), copy (#)-C),
and close the matte ((38)-W). This

copies the still matte to your

computer’s memory.

------

4. The virtual matte you just added
works like the cardboard rectangles
used by framing stores. It surrounds
your picture and enlarges it. Open
Movie Properties ((&€)-]). Select Video
Track 1 from the left pull-down
menu and Layer from the right menu.
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Matte Your Results
@oe siamon eiete wsorer You may encounter video with small
tracking problems or other flaws
S R around the edges. You'll find this
— = e — sort of feedback when you import
A N — from traditional video sources, such
e as VHS, Hi-8, and Beta. To fix this
problem, you can place a frame with
< . a cut-out over your matted movie.
e 2000 Ol e ©CCCC This technique can reveal just the

5. Click the small down-arrow
button to lower the number of your
layer. Smaller layer numbers display
further forward and are thus more
visible. After a few clicks, your video
appears in front of the matte. (&
more about adjusting layers in
“Know Your Tracks.”)

205 1) ki i

6. Select Size from the right pull-
down menu and click the Adjust
button.

205 1) ki i

| 8 dhchenmven biopeies
ez k1 T8 s ]

anal AT e

i1 () () (6 () L2
- E & s -

7. Manually, move your video track
into place as desired (&~ “Know Your
Tracks”). Finish by clicking Done.

ChickenMatte.mov

Sov o iR
B ]

v [ s ekl Waen DRCTTE
-

| W Fecar: Bakilnga

i1 () () (6 () L2
- E & s -

8. When you are satisfied with your

video placement, select File > Export
(8)-E) and save your work to disk.
Navigate as needed, name your file,
and click Save.

good parts of your video. To accom-
plish this, use Matte-tastic Lite,
included free on the companion CD
for purchasers of this book. Feel free
to design clever and interesting
frames, so long as they do not overly
detract attention from your actual
footage.
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Safety First

Always keep safety in mind when
creating movies for NTSC television.
NTSC demands certain accommoda-
tions with regard to color and viewable
area. Here are the issues you need
to know about.

NTSC Safe Colors NTSC televisions
often "bleed” when displaying over-
saturated colors (particularly red).
NTSC color-safe filters limit the
dynamic range of your colors in
accordance with ITU-R 601 (SMPTE-C).

Action-Safe Area Most picture-tube
televisions over-scan to compensate
for the aging of display elements.
Limit important movement within
your movies to an action-safe area,
roughly the middle 90 percent of
your screen, so your audience won't
miss out.

Title-Safe Area Although our
minds compensate for action that
takes place slightly off-screen, a
chopped-off title just looks wrong.
To make sure your titles display cor-
rectly, limit them to a title-safe area,
or about 80 percent of the middle of
your screen.

Safety Check: Color and Zones

Follow these steps to check broadcast compliance for your NTSC

videos. Avoid unsafe colors and stay within the visible boundaries of

your television set.

Pa * NTSC Safe Colors
o

[ Aged Film
[ Black & White

[ erightness & Contrast
[ Earthquake

1. In iMovie, select a clip or clips.
Open the Effects palette and select
NTSC Safe Colors. This free plug-in,
part of my Practical Plug-ins Pack, is
included on this book’s companion
CD and is an iMovie 3 Solutions
exclusive.

& 3
0000 10:00 10:00 00:00
| [ sharpen -

[ 50ft Focus

UL + Adjust Colors nverted)
UL « Color Bars

[ uL + Color Sliders
AL « Color Swapper
UL+ Cone TV

[ uL + Mangle saturation

UL « NTSC Briabiasselio

[P TriColorVision

E = Slick Matte-tastic Lite

b

3. Choose Slick Matte-tastic Lite from
the Effects palette. Click the Matte
button to bring up the interactive
dialog. (Matte-tastic Lite is included
for free as an exclusive to the readers
who have purchased this book.)

Pa * NTSC Safe Colors
[ Adiust Colars

[ Aged Film
[ Black & White

[ erightness & Contrast
[ Earthquake

pavll_5.mov

2. Click Apply and wait for iMovie to
finish applying the effect to your clip.
This step limits the number of colors
used in your clip to the legal range
defined in ITU-R 601 (SMPTE-C).
You’ll find side-by-side before-and-
after sample screens in the Practical
Plug-ins package.

Slick Matte-tastic Lite

el

Choose an image file to use as an overlay.

ECHOBSEIMGEN]) o race s been seeced

GeeThree makes a more full-featured version of Matte-tastic, plus.
many other fantastic plug-ins for iMovie. Come visit us on the web
at: “www.geethree.com/slick/ "

iCancelj " Ok j

4. Click Choose Image. This launches
a file browser that allows you to select
your matte.
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i Baeuman
Size 338 K2

{ Acd oo Fovohes ) {_cance  fShonse

Sliek Matte—tastie Lie

G

Chusss an inneps bl ues o an sl

[ Crcoseimage ) i

Canel ) (R

5. Navigate to your SafeQverlays
folder (you’ll find the files on the
accompanying CD) and select
iSafeZones.psd. Click Choose. Then,
click OK to dismiss the Matte-tastic
dialog box.

Effect In Effect Out

0000 10:00 10:00 00:00

B sharpen

B soft Focus

E! UL » Adjust Colors (Inverted)
ML« Color Rars

6. In the Effects palette, click Preview.
iMovie previews, overlaying your clip
with Safe Zones matte in the Monitor.
Use this playback to determine
whether or not your clip complies with
Action and Title safety zones. If not,
consider re-editing your work. Do
not click Apply. Steps 3 through 6
provide a safety preview only.

SafeOverlays.sit, PracticalPlugins.sit

QuickTime Pro Editing Commands

These QuickTime Pro shortcuts affect your selection in various ways.

SHORTCUT ACTION

Cut, (381X Removes the selection from your movie, saving it in the Clipboard.

Clear Removes the selection from your movie, without saving it in the Clipboard.
Copy, (8)-C Copies the selection to the Clipboard.

Paste, (8)-V If no selection exists, pastes the data from the Clipboard at the playhead.

If a selection has been made, this command overwrites the selection with
the Clipboard data. No scaling is done by a paste, and the pasted data
remains otherwise unaltered.

Replace, (38)-Shift-V  Replaces the selection with the data from the Clipboard.
Trim Removes everything from your movie except the selection.

Add, Option-(38}-V Creates a new track, adding the data from the Clipboard to that new
track, starting at the playhead location.

Add Scaled, Creates a new track, adding the data from the Clipboard to that new
Option-Shift-(38}V track, scaled to the start, end, and duration of the current selection.

Combine and Conquer

Whenever you save your project, iMovie creates a reference movie in your project
folder. Importing a number of these reference movies into a new project offers a great
way to combine edited footage to create a single block of video. | use this to help
keep my projects simple. Rather than edit a large project in a single file, | use several
projects to isolate each section. Dividing the footage allows me to combine the chunks
from each project into a final unified form, and the Reference Movie format lets me
do all this with a minimum of disk space. This practice offers several advantages:

+ A big mess-up in any one subproject will not affect any other part.

« It reduces export times for any block of video.

+ It allows me to focus specifically on a single section, without worrying about tying
down sounds and video clips unrelated to that section when | add or remove
material.

+ It avoids problems associated with file-size limits.
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Sometimes, the nonobvious

way to do things provides the

best results. When using

iMovie to edit your footage,

be aware of alternative editing

techniques. Here, you’ll find
tricks that I use to edit my
movies. They may not be the
simplest way, and they may
not be the most straightfor-
ward way, but they are
dependable. For example, my
cutaway technique separates
the audio before performing
the cut, avoiding unpleasant
sound glitches that crop up
as an iMovie bug. This bug
and others may get fixed in
later versions of iMovie, but
the techniques shown here

work correctly now.

N4

Note: Is iMovie 3 acting

oddly or running slow? Try resizing
its window. Sometimes a smaller
window allows iMovie (circa 3.0.1)
to run more efficiently.

\l/

Note: Is Preview broken

in iMovie? Try resizing the window
back to its maximum size. A full-
sized window allows iMovie (circa
3.0.2) to preview effects, titles,
and transitions.

Perfect Cutaways

Cutaways allow you to jump from one video source to another while

continuing the soundtrack. You’ve surely seen this on TV and in movies.

3

Ben-Primary Hands/Kbd

1. Import your primary and cutaway
footage into iMovie. This example cuts
away to footage of hands opening a
keyboard as the subject discusses
how the keyboard can be expanded.

Hands/Kbd

3. Select the cutaway footage on
the shelf.

Audio Selection: Ben-Primary - Audio Time: 19:1£

it Vol o & '5—0 0D %

2. Drag the primary footage to the
Timeline. Select Advanced > Extract
Audio (&)-]) to separate the audio
track from the video. The audio
appears as a single bright purple line
below the video track, regardless of
whether it is a mono or stereo track.

T TN i

>

With the cutaway selected, turn
your attention to the Monitor. Drag
the right triangular crop marker all
the way to the right, to select the
entire clip.
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Enhance the Audio

After extracting the audio (step 2),
you may want to follow the instruc-
tions from “Normalize Sounds” to
adjust your sound. Seize this oppor-
i .Tm_ls. T AT tunity to enhance your audio without
affecting the rest of your movie. This
_-_-T-_ step proves particularly important
when you use your camera's built-in

| i e E— microphone, which may not provide

5. Choose Edit »> Copy (&)-C). 6. Select the clip in the Timeline. the best sound quality. As my personal
Play through the video and determine camera does not offer an external
exactly where you wish to place microphone jack, | have no option

the cutaway. Move the playhead to other than the built-in. Therefore,

| usually normalize my audio with a
sound-enhancement program.

that spot.

Cutaway for Time

Cutaways do more than maintain
visual interest. They can also help
you edit overly long material. When
Window Help dealing with an extended stretch of
footage (or a particularly boring main
subject), you can use a cutaway to
move away from the speaker. Rather
than return directly to where you

Extract Audio %) AR, v & L

e inume=Ne T = Wk left (as done in the project shown
7. Choose Advanced > Paste Over 8. iMovie pastes your cutaway here), clever editing allows you to
At Playhead (Shift-3@}-V). material at the playhead, replacing pick up at a later time. Use this tech-
the original video footage and split- nique judiciously, and make sure to
ting your Clip into three parts: the edit your sound Carefu”y'

original start, the new material, and
the original end. The audio, having
been extracted earlier, remains
unchanged. iMovie removes the
audio from the cut-in clip, allowing
for a true cutaway.
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iMovie Sound Tricks

Crop Markers Drag the triangular
crop markers at either end of your
sound clips to adjust where sound
playback begins and stops. Click a
crop marker to snap the playhead
to its location.

Trim Sounds iMovie 3 allows you to
trim sounds as you do video. Move the
playhead into position, select a clip,
and choose Edit > Split Selected
Audio Clip at Playhead ((8}T).

Lock Audio To tie the selected
audio clip to the video clip at the
current playhead position, choose
Advanced > Lock Audio Clip at
Playhead ((s&)-L).

Record Sound Optional USB exter-
nal microphones, such as the Griffin
iMic (www.griffintechnology.com)
allow you to record voice and other
sounds. Use the Audio palette to per-
form your recording.

Extract Sound Choose Advanced >
Extract Audio ((8)-J) to copy a clip's
audio to a new Voice file in your
project's media file. Choose File >
Export > To QuickTime > Expert
Settings > Export > Sound To AIFF
to extract the sound for your entire
movie.

Sound Power

In this project, you will explore various ways you can control the volume

of sounds within your iMovies.

Msf2 Time: 15:21 1/26/03 8:02:44 FM

1 S T T 0 A 11

e f
] v

Clip 06 - Audio |g

4

—O4 150 % [y 32M8 u.qocnrm—%

Audio Selection: EmmaShots /7 - Audio Time: 25:19

— [ Edit Volum('—e 4 (150 9;2 3

1. Open up a project in iMovie that
contains a variety of sounds. In the
Timeline, locate the mute toggles at
the very right of the window. You’ll
find three. Each toggle allows you to
mute the track it lies next to. When
checked, sounds play normally. When
unchecked, the track is silenced.

2. Select any sound on your Timeline.
Locate the volume slider at the bottom
of your window. Adjust the relative
volume of your sound by adjusting
the slider between 0% (mute) and
150% (louder-than-recorded).

MavieTry 03:50 INTSC) 1:50 (NTSC) Audio !
" N7 03:17 L2 03:17 0 n 7 lﬂ
J
Zoom: —} " = w ) | ﬁ'—e— ™ Edit v@

3. Select another sound. Adjust the
zoom control so your sound takes up
a reasonable fraction of the visible
Timeline. You are about to interac-
tively edit your sound’s volume. The
more of the sound you can see, the
better you will be at making precise
adjustments.

4. Locate the Edit Volume toggle at
the bottom of your screen. Check it.
Purple volume control lines appear in
each of your audio and video assets.
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03:50 {NTSC)
i L 5 FEEFE] [y ; 1227, . — ; 1127 ; ,
\ - [N N 5
e P — TN
E{—_i_e— a—$—w.a ﬁT- mhli T‘- ™ Edit Volume 1-—6—{—

5. Move your pointer to any volume
control line. Click it and drag either up
or down. A yellow volume control
point follows your movement. A
smaller orange or purple dot anchors
the curve. Drag the yellow point
anywhere between the bottom of the
track (0 percent, mute) and the top
(150 percent, louder-than-recorded).

B8 Advanced  Window  Help

6. Add more volume control points
by clicking and/or dragging the vol-
ume line. Selected control points
appear in yellow and associated
orange or purple dots are visible.
Unselected points appear in orange or
purple and iMovie hides their small
dots. If desired, use the volume slider
to adjust a selected control point.

Unde ®Z

Redo ORI

Cut B

Select All A

Seluct Non 11:18 | L 14: L

split Video €1, -

Create Still Fr

[EEiay— ™ Edit Volume o ¢+

_$—k* ™ Edit Volume o ——— )

7. To reposition a volume control
point, drag it left or right. To control
the slope of the curve, drag the small
orange or purple dot. Here, I drag
the dot left to lengthen the duration
of the fade-out. Small dots do not
move up or down. Only control
points adjust volume.

A 12:26

] -
IE l ]
o & Edit volume o x Al 4

8. To remove a volume control
point from your clip, select a point
and choose Edit > Clear (or press
the Delete key). iMovie removes the
associated orange or purple slope-
control dot at the same time.

9. To remove all control points from
your clip, do the following. Click
away from the volume line to select
your clip. Make sure that no control
point remains selected.

10. Adjust the volume slider down to
zero. All your control points will
shrink as the clip volume decreases.
At zero, the control points disappear
when you release the mouse. Readjust
the slider as desired to set the volume
for the entire clip.
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Transform Conglomerate Clips

Other Elements A blank title provides a sneaky but very convenient way to combine a

As far as iMovie i concerned, speed few clips together without having to export and reimport footage.

and playback direction are a matter

of bookkeeping. Reverse a clip and

iMovie changes a single line of text — o
in your project file—it doesn't © o @=a
change the clip itself. Even when you
force iMovie to render (select File >
Export and click the Render Now _
button), you just optimize playback Plug-ins oo s
without really changing the clip.

When you import the rendered clip,

you end up with more or less the

oo =@l =< (=l D ‘- —
RukClp 1513 NTRO
[0 [%] |W:|‘u

[T

The Swan

same clip you started with. 1. If iMovie is running, quit the pro- 2. Launch iMovie. Using the Clip
When you want to import a reversed gram. Drag a copy of Sadun’§ NTSC Viewer, s‘elect th.ose clips you WiS.h to

. . plug-in to your iMovie Plug-in folder collapse into a single element. Click
AT T AFR 1S4 0 GO 705 (~/Library/iMovie/Plug-ins). An iMovie 3 the first clip to select it. Then Shift-
clips shelf reversed, use the Title Solutions exclusive, you’ll find a copy click the last in the series; iMovie
trick described here. Your new clip of this and the other Practical Plug-ins automatically selects all the clips
will work properly with any overlaid on the companion CD-ROM. between them.
effects, titles, and transitions, and you
can open and edit it with QuickTime
Pro. The same goes for time warping
as for reversing. Lengthen or slow
down a clip and apply this method to
create a well-behaved clip.

e | TN
) = = O o

Audio
Video Selection: <Multiple> Time: 13:05 Unknown ; . V 4 .\ -
@ O «f T = 0 1

; Clips | Protos | Audi Titles || Jrans | eecs | iovp
e Time: 13:05 Unknown \_/ =

water PAV1 14.DV/1

3. Examine the bar on top of the 4. Click the Titles button to select
Clip Viewer. It will show that you’ve the Titles palette.

selected multiple clips and tell you

the combined duration of those clips.

Make a note of this number. In this

example, the total time selected is

13:0S.
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Mind the Time
- When programming the Title Glom
T plug-in, | added several safety features
Mm° T lom 0 to ensure that clip conglomeration

E -
| 3

Pause

1 * Title Glom
QBounce Acrass

[E Bounce Rerass Multiple
[E Baunce In To Center

[ Cartwheel

[E) Cartwheel Multiple a

5. Locate Title Glom. (“Glom” is
computer-slang. It’s short for con-
glomeration). You’ll find it in the
Title palette’s scrolling list. If you do
not see it after scrolling up and down
through the list, revisit step 1 of this
project.

[l cartwhesl

[ Cartwheel Multiple .
| Centered Multiple ¥
T @F Margins [ Dver Black ™ Calor

00-13:05

Do m@: () »)(@)

L s ey
(IS I T |

[ Title Glom :|'=,‘

Tha Swan Black pud

7. Move the cursor to the Title
Glom label from the scrolling list.
Drag it to your Timeline and place
it before the first of the clips selected
in step 2.

PracticalPlugins.sit

[ Bounce Across
[ Bounce Across Multiple
[E Baunce In To Center

[E Cartwheel
[E Cartwheel Multiple -
[ Centered Multiple 1
_! QT Margins | Over Black 7| caler
qular ) A —O0—A
00:13:05
L3

6. Locate the first title line toward
the bottom of the palette. Enter the
time from step 3 in the form of
Minutes:Seconds:Frames. For 13 sec-
onds and 5 frames, enter 00:13:05.

e

ole] =@ («)»)DO)
Multiclip 19:13 (NTSC) — ——
06:08

13:05 53]

00:13:05 PAV1_14.0V/1

8. Wait as iMovie conglomerates
your clips into a single new clip using
the duration you specified in step 6.
This new clip is not just bookkeep-
ing. It appears in your Media folder
and can be imported, reused, and
treated like any other clip.

proceeded correctly. Here are a few
to keep in mind.

No More Than 8 Minutes Title
Glom limits clip conglomeration to
8 minutes. Any longer and your con-
glomerated clip might exceed 0S X's
2-gigabyte file limit.

Minutes Matter Do not omit the
minutes when entering a time for
your conglomeration, even if the
final clip lasts under a minute. To
request a 1-second glom, enter
00:01:00, not 01:00. (00:1:00 or 0:1:0
are acceptable. The plug-in does not
demand leading zeros).

Maximum Values Title Glom limits
the maximum values for each number.
Frames round down to 29, seconds to
59, and minutes to 7. Enter 0:90:00
and Title Glom adds a 59-second title.
For 90 seconds, enter 1:30:00 instead.

Overall Format Matters Title Glom
rejects negative numbers, words, or

badly formatted times. These default
to a zero-second title that does not

affect the rest of your footage.
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Slow Down
Your Clips with
Stupendous Software

The project on this page demon-
strates how to speed up the clips in
your project. Slowing down your clips
proves more complicated. Instead of
discarding frames, iMovie must add
frames to your movie so action occurs
over a longer period. To accomplish
this, iMovie doubles (or triples, or
whatever) the frames it encounters.
This can produce jerky-looking and
unrealistic results.

A better solution involves interpolation.
Interpolation is a method that uses
mathematical averaging to better
approximate differences between con-
secutive frames. To find an interpolated
solution, you must look to third-party
software. Stupendous Software
(www.stupendous-software.com)
sells two plug-in packs (Time Effects 1
and Time Effects 2) that address time
and time dilation in this manner.

Speed Up Your Movie

Go beyond iMovie’s speed limit. This project demonstrates how to create
time-lapse footage from your iMovie clips.

o0 m@ <

MovieTry 04:02 (NTSC)
04:02:07

Emmashots, 1

1. In iMovie, drag the clip (or clips)
you wish to speed up to the Clip
Viewer. Here, I use a 4-minute-long
clip that I will eventually speed up by
a factor of 25.

<
el =@=< («(»)(0)
MovieTry 05:22 (NTSC) ——ee
L 00O O P R TAT T p TRTA T TW TN TNTTRATATA

B

Zoom: £ = -~
= | =

3. Select your clip (or clips). Locate
the speed slider at the bottom of the
Timeline. Drag the handle all the way
to the rabbit and away from the turtle.
In iMovie 3.0.1, this speeds your clip
by a factor of 5. Here, clip duration
reduces from 4:02:07 to 48:13.

Zoom: £y = A -~

2. Click the Clock button to switch
from the Clip Viewer to the Timeline
display.

{3 Edit Advanced W

Mew Project... BN
Open Project... BO
Open Recent 3

Save Project =
Save Frame As... ®F

Import,., 898 £ W :
Export... = =N A EE
= - Ganrabs ane Bpbuins vean

Show Infc

Empty Tri
e, 28
Y endeTry

4. Select File > Save Project ((#8)-S).
Whenever you save your work in
iMovie 3, the program creates a new
reference movie in the top level of
your project folder.
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Show Info #| - et

Empty Trash..

5. Select File > Import ((#}-Shift-I).
Navigate to your project folder.
Select the reference movie you’ll find
there and click Open.

-
ojo] =@ («)»)(@)
MovieTry 05:22 (NTSC) e —

4B:13 >

EmmaShots /1

7. Drag your newly imported clip
down to the Clip Viewer and repeat
steps 2 through 6.

speedy.mov

Import Files

Time remaining: about 5 minutes lofl
]

MovieTry.mov ' 4 Cancel )

6. Wait as iMovie imports your
movie and converts it to a standard
DV clip. In iMovie 3.0.2, this can
take absurdly long periods of time
even for relatively short clips. You
may wish to take a coffee break.

(B/e] =@ =

MovieTry 10:00 (NTSC)
09:13

() ») (@)

MovieTry2.mav

8. After the import finishes, you will
have created a self-contained clip that
speeds through time at 25-times the
normal rate. The video that accom-
panies this project demonstrates the
overall effect this speed-up produces.

The Clear Trick

Edit »> Clear removes titles from

any clip labeled with a small T in the
top-right corner. Clearing undoes the
titling and returns you to an earlier
state of editing. If the title extended
over multiple clips, combining them,
the individual clips will return. If
adding the title split any clip in two,
this trick will restore the original
without the split.

Other clear tricks include the
following:

Undo Selecting Undo (Edit > Undo,
(8)-2) offers the simplest way to
restore your clips to an earlier state.
iMovie supports an unlimited number
of Undos. Beware of emptying the
Trash; when you do, most clip
changes become permanent. The
state of the restored media will only
go back in time to the last time the
trash emptied.

Remove a Transition When you
delete a transition, you restore the
clip material that was used to create
the transition. For a two-way transi-
tion, the restored material will last
twice as long—a two-way transition
gathers frames from both sides
when it's created.

Restore Clip Media Choose
Advanced > Restore Clip Media to
return a clip to its original state—at
least the latest state available since
the last time you emptied the trash.



