Installing, Licensing,
and Updating
Windows Server 2003

MICROSOFT EXAM OBJECTIVES COVERED
IN THIS CHAPTER:

v' Manage software update infrastructure.

v' Manage software site licensing.



Windows Server 2003 provides the highest level of features and
security compared to previous versions of Windows servers. This
chapter will begin by introducing you to Windows Server 2003.
You w1ll start by learning about the features of Windows Server 2003 and the key features and
differences between the versions within the Windows Server 2003 family of operating systems.

Before you can use Windows Server 2003, you have to install it. You need to know what the
basic hardware requirements are, how to check for system compatibility, determine whether
you will upgrade or use a clean installation, and understand the installation options. Once you
have considered the options for installing Windows Server 2003, you are ready for the installation.
To take advantage of Active Directory, you will need to upgrade your server to a domain
controller after it is installed.

After your computer has been installed with Windows Server 2003 and configured as a
domain controller, you will need to complete post-installation activation. This ensures that you
are running a valid copy of Windows Server 2003.

In addition to activating Windows Server 2003, you need to ensure that the clients that
connect to the server are properly licensed. You can manage licensing through a single server or
through enterprise management using a site license server.

You also need to manage software installation and maintenance for your network. You can
keep your software up-to-date through Windows Update, Windows Automatic Updates, and
Software Update Services. The Microsoft Baseline Security Analyzer is used to ensure that your
computer is configured in a secure manner.

Features of Windows Server 2003

The Windows Server 2003 family was originally going to be called Windows .NET Server. Early
in 2003, Microsoft announced that the product family would be called Windows Server 2003.
Windows .NET is a set of Microsoft technologies and software that are designed to work
together to provide a high level of services, compatibility, and XML (Extensible Markup
Language) Web services. Windows Server 2003 is the server component of NET services. Windows
Server 2003 builds upon the features of Windows NT and Windows 2000.

The main features of Windows Server 2003 include:

= Active Directory
= File and Print Services
= Security

= Networking and Communications
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Application Services

Management Services

Storage Management Services
Internet Information Server (IIS) 6.0
Terminal Services

Windows Media Services

Universal Description, Discovery, and Integration (UDDI) Services

In the following sections, you will learn more about the enhancements and new features

that have been added to Windows Server 2003 compared to Windows NT Server 4 and
Windows 2000 Server.

Active Directory

Active Directory has been enhanced so that it supports easier deployment and management,
increased security, and improved performance and dependability. New features within Windows
Server 2003 for Active Directory include:

Active Directory Migration Tool (ADMT) 2.0, which allows migration of users and passwords
from Windows NT 4.0 domains or Windows 2000 domains to Windows 2003 domains.

New support for renaming DNS and/or NetBIOS names of existing domains within a
forest. This allows greater support for companies that merge or are restructured.

New group policy management tool called Microsoft Group Policy Management Console
(GPMC), which allows users to manage group policy for multiple domains and sites
within a specified forest. The User Interface (UI) is simplified and allows drag-and-drop
support and functionality for backup, restore, copy, import, and reporting of Group Policy
Objects (GPOs).

Improvement to the MMC, which allows administrators to have better drag-and-drop
capability, ability to save and reuse queries, and the ability to select and manage multiple
objects concurrently.

Support for cross-forest authentication, which allows secure access for a user who is
located in one forest accessing resources in another forest.

Support for inter-forest permissions, which allows administrators in one forest to add users
and groups to Discretionary Access Control Lists (DACLs) from trusted forests.

Support for cross-certification, if cross-forest trusts have been configured. This allows
Internet Authentication Service/ Remote Authentication Dial-In User Server (IAS/RADIUS)
authentication for user accounts from the trusted forests. RADIUS (Microsoft’s TAS) is
equipment-to-equipment authentication. The equipment is authenticated first and then the
user is authenticated. For example, two routers verify password authentication and then
the user account can be authenticated in a normal manner.

Improved Credential Manager, which allows a secure store of user password and X.509
certificates.
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Software restriction policies, which are lists of software that is allowed to be installed on
client computers through the use of GPOs. You can specify that software that is not on the
list can’t be installed.

Enhanced logon for remote sites, which increases the speed by which remote users can log on.

Better management of how group membership changes are replicated. Only the delta changes
are replicated as compared to replicating all group information when changes are made.

Ability of the Active Directory database to be initially replicated from media as opposed to
being populated from the network.

Better dependability through a new feature called Health Monitoring, which is used to
verify replications between domain controllers. Improved scaling of forests and sites
(compared to Windows 2000) with the use of an improved Inter-Site Topology Gener-
ator (ISTG). The speed and dependability of global catalog replication has also been
enhanced.

) The Active Directory is covered in great detail in MCSE: Windows 2003 Active

TE Directory Planning, Implementation, and Maintenance Study Guide by Anil
Desai with James Chellis (Sybex, 2003).

File and Print Services

File and print management is one of the most critical server roles. Windows Server 2003
improves file and print services through higher dependability, increased productivity, and better
connectivity. New features for file and print services include:

Improved reliability with enhanced Automated System Recovery (ASR), which is used to
recover the system and restore files in the event of system failure. The key improvement

in ASR is one-step restore of the operating system, system state, and hardware configuration.
ASR is covered in greater detail in Chapter 10, “Performing System Recovery Functions.’
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Ability to support remote document sharing over the Internet through Web Distributed
Authoring and Versioning (WebDAV).

New command-line utilities for supporting disk management tasks and file system tuning.
The new command-line utilities for disk management are covered in greater detail in
Chapter 4, “Managing Disks.”

New GUID Partition Table (GPT) that is used with Windows Server 2003 64-bit edition,
which replaces the Master Boot Record (MBR) used with 32-bit versions of Windows.
With GPT partitions there are redundant primary and backup partition tables for better
data structure integrity.

Improved Windows Defragmenter Tool, which is faster and more efficient than the version
that was used with Windows 2000. The Disk Defragmenter utility is covered in greater
detail in Chapter 4.



Features of Windows Server 2003 5

Enhanced Distributed File System (DFS), which now can be used with Active Directory to
publish DFS objects as Volume objects and allow delegation of administration for DFS
objects. There is also a new service called DFS File Replication Service (FRS), which is used
to replicate DFS within the Active Directory.

Improved Encrypting File System (EFS), which now runs as an integrated system service.
EFS is covered in greater detail in Chapter 4.

New kernel APIs, which provide new support for antivirus applications.

Faster CHKDSK, which runs 20% to 38 % faster after an unplanned disk shutdown or disk
failure than it did in Windows 2000. CHKDSK is covered in greater detail in Chapter 4.

New feature called shadow copies, which creates copies of network shares, and is used to
roll back to a previous copy of a file in the event that a shared file is overwritten, deleted,
or corrupted. Shadow copies are covered in greater detail in Chapter 4.

New command-line utilities for managing printing. The new command-line utilities for
managing printing are covered in Chapter 7, “Managing Printing.”

New 64-bit print drivers for 64-bit editions of Windows Server 2003. The new Point-n-Print
64-bit drivers can support both 32-bit and 64-bit clients.

Added support for over 3,800 print devices.
Improved support for publishing printers to Active Directory.
New support for wireless (IEEE 802.11 and 802.1X, and Bluetooth) devices.

Broader support for cross-platform printing support for AppleTalk, LPR/LPD, and IPX
print protocols. Cross-platform printing support is covered in Chapter 7.

Security

Windows Server 2003 provides the highest level of security of any of the Windows platforms to
date. Security enhancements have been added through general improvements in security, public
key infrastructure, and secure Internet accessibility. Specific enhancements to security include:

Improved Internet Connection Firewall (ICF), which is designed to act as a firewall for
computers directly connected to the Internet.

Better support for authentication of users who connect to the network via wireless and
Ethernet LANs. New support is also included for IEEE 802.11 protocols.

New support for IAS, which is used by RADIUS to manage remote user connections and
authentication.

New software restriction policies, which are used by administrators to specify policy
or execution enforcement. For example, through software restriction policies specific
applications can only be run from specified directories, which is used to prevent Trojan
viruses from running.

Improved web server security through IIS 6.0. IIS is covered in Chapter 6, “Managing
Internet Information Services.”
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= New options to support the encryption of off-line files.

*  Protocol support for RFC 2617 and RFC 2222, which is a digest authentication protocol
and is used with IIS and the Active Directory.

= Better system security performance with Secure Sockets Layer (SSL), which is 35% faster
with Windows Server 2003 compared to Windows 2000 Server.

= Ability of SSL session cache to be used by multiple processes, which increases performance
by reducing the number of times reauthentication is required by applications.

*  Automatic enrollment and deployment of X.509 certificates to users. Certificates can also
be automatically renewed as they expire.

* Improved support for digital signatures in conjunction with Windows Installer packages.

*  Through the Certificate Server that ships with Windows Server 2003, support for delta

Certificate Revocation Lists (CRLs), which makes the publication of revoked X.509 certifi-
cates more efficient.

*  New support for Microsoft Passport integration with Active Directory and Windows
Server 2003.

= Support for cross-forest trusts.

Networking and Communications

Windows Server 2003 makes significant improvements to networking and security, which are
critical to network operations. Some of the key improvements are extended versatility, better
reliability and security, and more simplified management. Specific improvements include:

= Support for the latest generation of TCP/IP, which is [Pv6. IPv6 makes improvements over
IPv4 in the areas of address depletion, auto-configuration capabilities, and enhanced
security. Windows Server 2003 supports IPv6 through an enhanced Internet Explorer (IE),
1IS, and Internet file and print sharing utilities such as telnet and the ftp client software.

= A new Point-to-Point Protocol over Ethernet (PPPoE) driver that is used to make broadband
connections to Internet Service Providers (ISPs) without requiring additional software.

= Better support for network bridging when using wireless adapters, Ethernet adapters, or
dial-up adapters.

= Ability to support IPSec-based VPNs or IPSec-protected applications across Network
Address Translation (NAT). Also allows support of Layer Two Tunneling Protocol (L2T2)
over IPSec.

= Support for DNS client settings through Group Policy.

*  Enhanced Connection Manager Administration Kit (CMAK) for providing remote access to
clients running Windows XP, Windows 2000, Windows NT 4, Windows Me, or Windows 98.

*  Enhancements to IAS, which allows you to better support wireless network deployments
using RADIUS servers.

=  New Network Load Balancing Manager that is used to load-balance TCP/IP traffic on an
IEEE 1394 serial bus.
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) The networking and communications technologies are covered in greater detail

TE in MCSA/MCSE: Windows Server 2003 Network Infrastructure Implementa-
tion, Management, and Maintenance Study Guide by Michael Chacon with
James Chellis (Sybex, 2003).

Application Services

Windows Server 2003 is designed to better support application integration and interoperability,
help developers produce better applications, increase efficiency, improve scalability and reliability,
provide a high level of application security, and provide efficient deployment and management
of applications. To help support these goals, the following options have been added or improved
in Windows Server 2003:

Native support for XML Web services, for standards including XML, Simple Object Access
Protocol (SOAP), Universal Description, Discovery, and Integration (UDDI), and Web
Services Description Language (WSDL).

Enterprise UDDI support that allows companies to use their own custom UDDI services for
internal or external use.

A common .NET framework, which makes it easier for software developers to develop
applications across Windows platforms.

Integrated support for applications through IIS 6.0.
Improved ASP .NET cacheing model, which improves performance.

Improved security for applications through integration with Active Directory, plus added
support for .NET Passport.

New support for application-installed tools, such as Fusion, which makes deploying
applications easier and more reliable.

Management Services

The new management services in Windows Server 2003 are designed to make management
more dependable, provide greater productivity, and provide greater connectivity. Specific
improvements to management services include:

The Group Policy Editor has been added, which makes it easier to manage the Active
Directory.

A new tool, the Resultant Set of Policy (RSoP). The RSoP snap-in is used to determine what
the effective policies are when Group Policies have been applied at many layers of Active
Directory to a user or computer.

New policy settings that are used to manage configurations such as Remote Assistance,
AutoUpdating, and Error Reporting.

Improved help features within the Group Policy Editor that explain functions and supported
environments for group policy objects.
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= New support for creation and management of cross-forests.
*  More comprehensive software restriction policies.

*  Updated Remote Installation Services (RIS) to support remote installations of XP Professional
and 32-bit/64-bit editions of Windows Server 2003, with the exception of Windows
Server 2003, Datacenter Edition.

= New Windows Server 2003 tools, including remote server operation via an /s switch on the
command-line utility.

* Improved Windows Update to more fully support keeping all of your Windows files
up-to-date. Windows Update can also be configured for Automatic Updating, manually
or through Group Policy. Windows Update is covered in greater detail later in this chapter
in the section, “Using Windows Update.”

) The management services related to Active Directory are covered in greater
TE detail in MCSE: Windows 2003 Active Directory Planning, Implementation, and
Maintenance Study Guide by Anil Desai with James Chellis (Sybex, 2003).

Storage Management Services

Storage management services are used to manage volumes and disks, backup and restore opera-
tions, and access to Storage Area Networks (SANs). Windows Server 2003 adds the following
features and improvements in storage management services:

= A new service called Virtual Disk Service (VDS), which enables support for multi-vendor
storage devices through native Windows support.

= The Volume Shadow Copy service, which can be used to create shadow copies in conjunction

with SANs.
= Ability for offline files to be encrypted with EFS.

= Support for open file backups, which allow you to back up a file without it being closed,
in conjunction with shadow copies. Backups are covered in Chapter 10.

= A new command-line utility, Diskpart.exe, that includes all of the functionality of Disk
Manager, an MMC snap-in.

*  Enhanced DFS to allow support for multiple DFS roots on a single server.

Internet Information Server (lIS) 6.0

Internet Information Server is included with Windows Server 2003 to provide scalable, integrated
Web services. By default, IIS is not loaded on Windows Server 2003 during installation, and must
be manually installed through Add/Remove Programs. The enhancements to IIS 6.0 include:

*  Application health monitoring and automatic application recycling.
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*  Improved security and manageability over previous versions of IIS. By default, maximum
security settings are applied.

= A new kernel mode driver, http.sys, used to improve scalability and performance.

*  URL authorization in conjunction with Authorization Manager, used to control access and
manage administrator delegation.

= Ability for IIS to use URLs that are encoded with Unicode, which is used to support multi-
languages.

%’ IIS is covered in greater detail in Chapter 6.
ITE

Terminal Services

Terminal Server is used to provide Windows-based applications to clients, even if the client
computer is not capable of running Windows. This allows you to leverage server processing
power for client computers. The improvements to Terminal Server in Windows Server 2003
include:

= Better scalability; more users are supported than were with Windows 2000.

»  Improved user interface for the client software, the Remote Desktop Connection. Addition-
ally, users can more easily set up and save connections, and switch between windowed
and full mode screens.

=  Enhanced Remote Desktop Protocol (RDP) giving better support for accessing resources,
such as printers.

= Ability to set color depth and screen resolution higher than with previous versions on
Terminal Server.

=  Terminal Server now better able to take advantage of Windows Server 2003 features such
as software restriction policies, enhancements to roaming profiles, and new application
compatibility modes.

- Terminal Services are covered in greater detail in Chapter 8, “Administer-
ITE ing Terminal Services.”

Windows Media Services
Windows Media Services are used for distribution of digital media content over an intranet or
the Internet. Advances to Windows Media Services include:

*  Fast stream technology, which bypasses buffering delays, to provide instant-on playback
capabilities.
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= Always-on Fast Cache, which streams playback to the client computer via streaming
content as fast as the player’s cache and network will allow.

*  Fast recovery, which is used to reduce or eliminate packet corruption through local packet
correction technology.

»  Fast reconnect technology, which reconnects a connection to the Internet faster if a client
is disconnected during a broadcast.

= Support now provided for integrating with third-party AD servers, and support for advanced
usage reporting.

*  Improved wizards that provide scenario-based help for completing common management
activities for audio and video streaming needs.

Universal Description, Discovery, and
Integration (UDDI) Services

UDDI services are used to provide dynamic and flexible XML Web services. UDDI provides web
developers with the ability to create applications more easily and make the applications easier to
manage through Windows Server 2003. Some of the key improvements to UDDI services include:

*  Enterprise service based on the Microsoft .NET framework. UDDI services can be auto-
matically published and discovered through web-based interfaces.

= Can take advantage of Active Directory features such as authentication and authorization.
*  Supports programming inquiries through the UDDI API or a web interface.

= Active monitoring to allow auditing of all authenticated activities including the username
and the activity that was completed.

Windows Server 2003 Family Features

Windows Server 2003 is available in four different versions:
=  Windows Server 2003, Standard Edition

*  Windows Server 2003, Enterprise Edition

*  Windows Server 2003, Datacenter Edition

= Windows Server 2003, Web Edition

Windows Server 2003, Standard Edition is designed for the most common server environments.
Windows Server 2003, Enterprise Edition is designed for larger enterprise environments or
businesses that require higher reliability and performance. Windows Server 2003, Datacenter
Edition is designed for businesses that use mission-critical applications and also need a higher
level of scalability and reliability. Windows Server 2003, Web Edition is designed to be optimized
for hosting web servers. By offering different editions, Microsoft ensures that consumers and
businesses can select the product family that best suits their needs and budget.
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TABLE 1.1 Windows Server 2003 Feature Comparison

Standard Enterprise  Datacenter

Feature Web Edition Edition Edition Edition
.NET Framework Yes Yes Yes Yes
Act as a Domain Controller inthe No Yes Yes Yes
Active Directory
Microsoft Metadirectory Services No No Yes Yes
(MMS) support
Internet Information Services Yes Yes Yes Yes
(11S) 6.0
ASP .NET Yes Yes Yes Yes
Enterprise UDDI services No Yes Yes Yes
Network load balancing Yes Yes Yes Yes
Server clusters No No Yes Yes
Virtual Private Network (VPN) Only supports Yes Yes Yes
support one connection

per media type
Internet Authentication No Yes Yes Yes
Services (IAS)
Ipv6 Yes Yes Yes Yes
Distributed File System (DFS) Yes Yes Yes Yes
Encrypting File System (EFS) Yes Yes Yes Yes
Shadow Copy Restore Yes Yes Yes Yes
Removable and Remote Storage  No Yes Yes Yes
Fax services No Yes Yes Yes
Services for Macintosh No Yes Yes Yes
Print Services for Unix Yes Yes Yes Yes
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TABLE 1.1 Windows Server 2003 Feature Comparison (continued)

Standard Enterprise  Datacenter
Feature Web Edition Edition Edition Edition
Terminal Services No Yes Yes Yes
IntelliMirror Yes Yes Yes Yes
Remote OS Installation (RIS) Yes Yes Yes Yes
64-bit support for Itanium-based No No Yes Yes
computers
Datacenter Program No No No Yes

=

In addition to providing different product families, Windows Server 2003 also
comes in 32-bit editions, which are used with Pentium-based computers
(also referred to as x86-based computers), and a 64-bit edition (for Windows
Server 2003 Enterprise Edition and Windows Server 2003 Datacenter Edition).
The 64-bit edition of Windows Server is compatible only with Itanium-based
systems and can’t be installed on 32-bit x86-based systems. Previously known
by the code name Merced, the Itanium processor employs a 64-bit architecture
and enhanced instruction handling to greatly increase the performance of
computational and multimedia operations, and supports clock speeds of up to
800MHz. The Itanium 2 processor uses a 128-bit architecture and supports
speeds of 900MHz and 1GHz.

Preparing to Install Windows Server 2003

Planning and preparation are key to making your Windows Server 2003 installation proceed

smoothly. Before you begin the installation, you should know what is required for a successful

installation and h

ave all the pieces of information you’ll need to supply during the installation

process. In preparing for the installation, you should make sure you have the following

information:

*  What the hardware requirements are for Windows Server 2003

=  How to determine whether your hardware is supported by Windows Server 2003

*  Determine whether your system is compatible with Windows Server 2003

=  The difference between a clean installation and an upgrade

*  What installation options are suitable for your system, such as which disk-partitioning

scheme and fi

ile system you should select for Windows Server 2003 to use
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Hardware Requirements

In order to install Windows Server 2003 successfully, your system must meet certain hardware
requirements. Table 1.2 lists the minimum requirements as well as the more realistic recom-
mended requirements.

)/ The hardware requirements listed in Table 1.2 were those specified at the
&

time this book was published. Check Microsoft's website for the most current
information.

TABLE 1.2 Hardware Requirements for Windows Server 2003
Web Standard
Edition Edition Enterprise Edition Datacenter Edition

Minimum RAM 128MB 128MB 128MB 512MB

Recommended 256MB 256MB 256MB 1GB

RAM

Maximum RAM 2GB 4GB 32GB for x86-based 64GB for x86-based
computers, 64GB computers, 512GB
for lItanium-based for lItanium-based
computers computers

Minimum CPU 133MHz 133MHz 133MHz for x86-based =~ 400MHz for x86-based

Speed computers, 733MHz computers, 733MHz
for Itanium-based for Itanium-based
computers computers

Recommended 550MHz 550MHz 733MHz 733MHz

minimum CPU

speed

Multiprocessor Upto 2 Upto 4 Upto8 Minimum of 8, maxi-

Support mum of 32 for 32-bit

version, 64 for [tanium-
based computer

Free disk storage 1.6GB 1.6GB 1.56GB for x86-based 1.56GB for x86-based

for setup computers, 2GB for computers, 2GB
Itanium-based for Itanium-based
computers computers

Cluster nodes No No Upto 8 Upto 8
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) These requirements represent the operating system requirements. If you are
TE running any processor- or memory-intensive tasks or applications, factor those
requirements separately. When determining disk-space requirements for add-
on software and data, a good rule of thumb is to plan what you need for the
next 12 months, then double that number.

Depending on the installation method you choose, other devices may be required:

= If you are installing Windows Server 2003 from the CD, you should have at least a 12x
CD-ROM drive.

* If you choose to install Windows Server 2003 from the network, you need a network
connection and a server with the distribution files.

The Hardware Compatibility List (HCL)

Along with meeting the minimum requirements, your hardware should appear on the Hard-
ware Compatibility List (HCL). The HCL is an extensive list of computers and peripheral
hardware that have been tested with the Windows Server 2003 operating system.

The Windows Server 2003 operating system requires control of the hardware for stability,
efficiency, and security. The hardware and supported drivers on the HCL have been put through
rigorous tests. If you call Microsoft for support, the first thing a Microsoft support engineer will
ask about is your configuration. If you have any hardware that is not on the HCL, there is no
guarantee of support.

To determine if your computer and peripherals are on the HCL, check the most
P up-to-date list at www.microsoft.com/hcl.

Checking System Compatibility

The Windows Server 2003 CD comes with a utility to check system compatibility. When you
launch the CD, you’ll see several options, one being Check System Compatibility.
When you check system compatibility, you can select:

= Check My System Automatically
*  Visit The Compatibility Web Site

If your computer is not connected to the Internet, you would select Check My System Auto-
matically. If you are connected to the Internet, selecting Visit The Compatibility Web Site will
allow your computer to be checked against the most updated information.

The Windows compatibility check will determine whether your system meets the mini-
mum requirements for Windows Server 2003 and whether the hardware components that
are installed are compatible. If any errors are found, a report will be created and details can
be viewed.
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Clean Install or Upgrade

Once you’ve determined that your hardware not only meets the minimum requirements but
is also on the HCL, you need to decide whether you want to do a clean install or an upgrade.
A clean install installs Windows Server 2003 in a new folder and uses all of the Windows
Server 2003 default settings. An upgrade preserves existing settings from an operating system
that is on the upgrade list.

If you already have Windows NT Server 4 or Windows 2000 Server installed on your computer,
you might want to upgrade that system to Windows Server 2003. In an upgrade, you retain
previous settings such as the Desktop, users and groups, and program groups and items. During
an upgrade, you point to a prior operating system, and the Windows Server 2003 files are
loaded into the same folder that contained the former operating system.

The only operating systems that can be directly upgraded to Windows Server 2003 are
Windows NT Server 4 SP5 or greater and Windows 2000 Server. Any other operating systems
cannot be upgraded, but they may be able to coexist with Windows Server 2003 in a multi-boot
environment.

If you don’t have Windows NT Server 4 or Windows 2000 Server, you need to perform a
clean install. A clean install puts the operating system into a new folder and uses its default
settings the first time the operating system is loaded. You should perform a clean install if any
of the following conditions are true:

= There is no operating system currently installed.

= You have an operating system installed that does not support an upgrade to Win-
dows Server 2003 (such as DOS, Windows 3.x, Windows 9x, Windows XP, Windows
NT 3.51 Server, or Windows 2000 Professional).

*  You want to start from scratch, without keeping any existing preferences.

=  You want to be able to dual-boot between Windows Server 2003 and your previous
operating system.

Installation Options

There are many choices that you will need to make during the Windows Server 2003 installation
process. The following are some of the options that you will configure:

=  How your hard disk space will be partitioned

*  The file system your partitions will use

»  The licensing method the computer will use

*  Whether the computer will be a part of a workgroup or a domain

»  The language and locale for the computer’s settings

) The process for a clean installation is described in the next section.
TE
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Installing Windows Server 2003

Before you install Windows Server 2003, you should check for system compatibility. Once you
have ensured that your computer is compatible, you can begin the Windows Server 2003
installation process.

The Windows Server 2003 installation process consists of five main stages:

= Collecting information
»  Updating dynamically
*  Preparing installation
* Installing Windows

*  Finalizing installation

- The stages you see during your installation will vary based on the installation

ITE option you are using. For example, if you boot to the Window Server 2003
CD and start a new installation, you will not use Dynamic Update. If you are
upgrading or starting the installation from an existing operating system, you
would see the Dynamic Update stage.

Steps for Windows Server 2003 Installation

If you are installing Windows Server 2003 on an Itanium processor, you would insert the Windows
Server 2003 Itanium CD and restart the computer. When the EFI Boot manager appears, select
the CD-ROM option, and select Windows Server 2003 CD. You will then boot from the
CD-ROM and follow the onscreen instructions as if you were installing a 32-bit version of
Windows Server 2003.

The steps in the following sections assume that the disk drive is clean and that you are start-
ing the installation using the Windows Server 2003 CD.

) The following sections give the details of the installation process to show
TE how the process works. But you should not actually install Windows Server 2003
until you reach the “Setting Up Your Computers for Hands-on Exercises” section.
In the exercises in that section, you’'ll set up a domain controller and a Win-
dows XP Professional computer, which you'll use to complete the rest of the
exercises in this book.

If you have installed previous versions of Windows, you will notice that this is the most stream-
lined installation to date. Installing Windows Server 2003 can be broken into three phases:

1. Collecting information and preparing for the installation
2. Installing Windows

3. Finalizing the installation
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We will look at each of these phases in the following sections.

Collecting Information and Preparing Installation

To start collecting information and preparing for the installation, follow these steps:

1.
2.

Boot your computer using the Windows Server 2003 distribution CD.

The text mode portion of Setup will start, and through the process will advise you to press
F6 if you need to install any additional SCSI or RAID device drivers or F2 if you want

to run the Automated System Recovery (ASR) utility. If you have a SCSI or RAID driver
that is not provided through the Windows Server 2003 CD, you would press F6; otherwise
ignore these prompts and setup will continue.

The Welcome To Setup dialog box will appear. You can set up Windows by pressing
Enter, repair an existing Windows installation by pressing R to run the Recovery Con-
sole, or quit Windows Setup by pressing F3. In this example, you would press Enter
to continue.

The Windows License Agreement dialog box appears. You can accept the license agreement
by pressing F8, or Esc if you do not agree. If you do not agree to the license agreement, the
installation process will terminate. In this case, you would press F8 to continue.

The next dialog box asks you which partition you want to use to set up Windows Server 2003.
You can pick a partition that already exists, or you can choose free space and create
a new partition. To set up Windows Server 2003 on an existing partition, you would
highlight the partition you want to use for installation and press Enter. To create a new
partition, you would press C. To delete an existing partition, you would press D. If you
create a new partition, you can format it as NTFS or FAT32.

After you select your partition and it is formatted, the installation files will be automatically
copied to your computer. This requires no user intervention. Once this process is complete,
the computer will reboot.

Installing Windows

To actually start installing Windows, follow these steps.

1.

Once the computer has rebooted, the Windows installation will automatically continue
using the Setup Wizard. The installation process will detect and install device drivers and
copy any needed files. This process will take several minutes, and during this process, your
screen may flicker.

The Regional And Language Options dialog box will appear. From this dialog box, you
choose your locale and keyboard settings. Locale settings are used to configure international
options for numbers, currencies, times, and dates. Keyboard settings allow you to configure
your keyboard to support different local characters or keyboard layouts. For example, you
can choose Danish or United States—Dvorak through this option. Once you make your
selection, click Next to continue.

The Personalize Your Software dialog box appears. In this dialog box, you fill in the Name
and Organization boxes. This information is used to personalize your operating system
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software and the applications that you install. If you install Windows Server 2003 in a
workgroup, the Name entry here is used for the initial user. Type in your information and
click the Next button.

The Your Product Key dialog box appears. From the product key located on the yellow
sticker on the back of the Windows Server 2003 CD folder, type in the 25-character product
key and click the Next button.

The Licensing Modes dialog box appears. You can choose from Per Server licensing or Per
Seat licensing. Licensing is covered in greater detail in the “Managing Licensing” section
later in this chapter. Make your selection and click the Next button. If you’re unsure which
licensing mode to use, select Per Server.

The Computer Name And Administrator Password dialog box appears. Here you specify
a name that will uniquely identify your computer on the network. The Setup Wizard will
suggest a name, but you can change it to another name. In this dialog box, you also type
and confirm the Administrator password. An account called Administrator will automat-
ically be created as a part of the installation process. Verify that the computer name is
correct or specify a name and an Administrator password and click the Next button to
continue. If you do not use a complex password (upper case, lower case, number, or
symbol) a warning will appear.

ING part of a corporate network, you should also verify that the computer name follows

ﬁl‘ Be sure that the computer name is a unique name within your network. If you are

the naming convention specified by your Information Services (IS) department.

If you have a Plug and Play modem installed, you will see the Modem Dialing Information
dialog box. Here, you specify your country/region, your area code (or city code), whether
you dial a number to get an outside line, and whether the telephone system uses tone dialing
or pulse dialing. Select the applicable options and click the Next button.

The Date And Time Settings dialog box will appear. In this dialog box, you set your date
and time settings and the time zone in which your computer is located. You can also
configure the computer to automatically adjust for daylight savings time (recommended).
Verify that the correct settings are selected and click the Next button.

The Network Settings dialog box appears. This dialog box is used to specify how you want
to connect to other computers, networks, and the Internet. You have two choices:

Typical Settings installs network connections for Client for Microsoft Networks, as well
as File and Print Sharing for Microsoft Networks. It also installs the TCP/IP protocol
with an automatically (DHCP) assigned address.

Custom Settings allows you to customize your network settings. You can choose whether
or not you want to use Client for Microsoft Networks, File and Print Sharing for Microsoft
Networks, and the TCP/IP protocol. You should use the custom settings if you need
to specify particular network settings, such as a specific IP address and subnet mask
(rather than using an automatically assigned address).

Once you make your selection, click the Next button to continue.
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10. The Workgroup Or Computer Domain dialog box appears. In this dialog box, you specify
whether your computer will be installed as a part of a local workgroup or as a part of a
domain. Once you make your selection, click the Next button.

11. Based on your selections, the Windows installation process will automatically copy any
needed files. The computer will also perform some final tasks, including installing Start
menu items, registering components, saving settings, and removing any temporary files.
This will take several minutes (there is a countdown clock) and is fully automated. After
this process is complete, your computer will automatically restart.

Finalizing Installation
To finalize the installation, follow these steps:

1. Windows Server 2003 will automatically start. Press Ctrl+Alt+Delete to access the Log On
To Windows dialog box. By default, Administrator will be specified for the User Name.
Type in your Administrator password and click the OK button.

2. The Manage Your Server dialog box will automatically appear.

You will learn how to upgrade a member server to a domain controller using the Manage
Your Server utility in the next section.

Using Active Directory and
Domain Controllers

While the Active Directory is not a focus of this exam, you should have a basic understanding
of what it is and how it is organized. In this section, you will learn about the Active Directory
through an overview of Active Directory, and then you will learn how to promote a Windows
Server 2003 member server to a domain controller.

Directory Planning, Implementation, and Maintenance Study Guide by Anil

- Active Directory will be covered in greater detail in the MCSE: Windows 2003 Active
ITE
Desai with James Chellis (Sybex, 2003).

Overview of Active Directory

The Windows 2003 Active Directory (AD) is designed to be a scalable network structure. The
logical structure of the Active Directory consists of containers, domains, and organizational
units (OUs).

A container is an Active Directory object that holds other Active Directory objects. Domains
and OUs are examples of container objects.

A domain is the main logical unit of organization in the Active Directory. The objects in a
domain share common security and account information. Each domain must have at least
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one domain controller. The domain controller is a Windows Server 2003 computer that stores
the complete domain database.

Each domain can consist of multiple OUs, logically organized in a hierarchical structure. OUs
may contain users, groups, security policies, computers, printers, file shares, and other Active
Directory objects.

Domains are connected to one another through logical structure relationships. The relationships
are implemented through domain trees and domain forests.

A domain tree is a hierarchical organization of domains in a single, contiguous namespace.
In the Active Directory, a tree is a hierarchy of domains that are connected to each other
through a series of trust relationships (logical links that combine two or more domains into a
single administrative unit). The advantage of using trust relationships between domains is
that they allow users in one domain to access resources in another domain, assuming the users
have the proper access rights.

A forest is a set of trees that does not form a contiguous namespace. For example, you might
have a forest if your company merged with another company. With a forest, you could each
maintain a separate corporate identity through your namespace, but share information across
Active Directory.

An example of an Active Directory structure is shown in Figure 1.1.

FIGURE 1.1 Active Directory Structure

Forest A Domain A

In the following sections, you will learn about domains, organizational units, and trees and
forests in more detail.

Domains

The most basic Windows 2003 security structure is the domain. Domains are independent
administrative units, with their own security and administrative policies. All domain controllers
within a domain replicate their information to each other automatically. This is known as a
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multi-master replication model. Any domain controller can receive changes and then replicate
these out to other domain controllers within the domain.

To allow for an orderly migration from NT 4 to Windows 2003 domains, the Windows 2003
domain includes Active Directory support for communication with existing NT domain
structures and security. This is done through the use of a mixed-mode domain model. Then, after
all your domains have been upgraded to Windows 2003 domains, you can perform a onetime
conversion to native mode. Native-mode domains have additional features that are unavailable
to mixed-mode domains, but no longer support NT 4 domain controllers.

Since Windows 2000 and Windows 2003 share the same directory services model, the upgrade
from Windows 2000 Server to Windows Server 2003 requires no special configuration.

Organizational Units (OUs)

Within the Active Directory, you can categorize the objects in the domain by using organizational
units (OUs). Organizational units are typically defined based on geography or function and
the scope of administrative authority, such as the following examples:

Limiting administrative authority within the domain If your company has three campuses
(buildings within different geographic locations), you can create an OU for each, and assign
a different administrator to each.

Organizing users by function OUs can be created for Sales, Accounting, Manufacturing,
etc. Users and resources can then be added to these and can be managed as a group. In Figure 1.2,
users and resources have been arranged using organizational units.

FIGURE 1.2 Organizational units by function

| Foo |

Sales 4’
—LSales Admin I

—lﬁxles User1 1
»—-Eales Printer l

Accounting ]

L_{ Accounting Admin R
| Accounting User1 -
L Accounting Printer al
L—l Manufacturing |

_h\nanufacturing Admin I

_l Manufacturing User1 4|

|_{ Manufacturing Printer |
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The beauty of combining Active Directory’s capability to support millions of objects and its
capability to subdivide domains into organizational units is that a single domain will be all that
many companies ever need.

Trees and Forests

Microsoft’s use of the words #ree and forest can be confusing. You do not, for instance, need a
bunch of trees to make a forest. A tree is simply a set of domains that all have a similar DNS
naming structure, and a forest consists of all the trees within a single organization.

When the first server is installed in a new domain (for instance, foo. com), it becomes a domain
controller within that domain and also is the parent domain of a new tree. If you are not
adding to an existing forest, this tree also becomes the root tree of a new forest. Although you
have installed only one server, you now have a domain, a tree, and even a forest.

The real difference between a tree and a forest is not in the numbers. Within a single tree, all
the domains must fall under a contiguous namespace. Assume that you have created the domain
called foo.com in your New York office, and now want to create additional geographically
based domains in Hong Kong, Rome, and Fargo. If you want to allow permissions to flow with-
out the use of trusts, you need to put the new domains into the same tree. To do this, the new
domains will need to incorporate the existing DNS name.

In the next section, you will learn about trees and forests in more detail.

Trees

In the top graphic in Figure 1.3, notice how the DNS namespaces are in different branches.
These, therefore, cannot be in a single tree. In the bottom graphic, the three new domains nest
under the foo.com parent domain and share its DNS namespace. They are able to incorporate
into the tree.

FIGURE 1.3 Sample DNS namespaces

foo.com
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What all of this means is that if you have a company with four offices, you may want to
split up network administration by using four autonomous domains in a tree. As long as the
naming structure is not an issue, this is the easiest and most integrated approach to adding
domains.

Forests
Forests are similar to trees in that both are ways of connecting domains. Forests are created to
connect domains whose naming conventions make them incompatible for use in a single tree,
or can also be used to keep two domains distinct from each other.

The first tree you create also becomes the root tree of a new forest. As new domains are
added, you have three choices:

=  Create the new domain as a child domain in the existing tree. If you simply create the new
domain as a child domain, permissions and other configuration information automatically
are shared between the domains.

= Create the new domain as a new tree in the existing forest. Configuration data—the schema
and global catalog—will be shared, but the domains will be separate administrative entities.
The new tree will have automatic two-way transitive trusts with the old tree.

= Create the new domain as a new tree in a new forest. This provides the greatest degree
of administrative separation and makes interaction between the domains more difficult.
No configuration data is shared, and trusts must be set up to share resources between

forests.
4 Remember that Windows 2003 Active Directory will support millions of users
P and other objects. You should begin by assuming a single domain/tree/forest

is best, and only modify this plan based on particular requirements of your
company or client.

Upgrading a Server to a Domain Controller

Once a server has been installed with Windows Server 2003, you can upgrade it to a domain
controller through the Dcpromo utility. The following steps assume that the server will be the
first server installed into the domain and DNS is not already installed.

To upgrade a Windows Server 2003 member server to a domain controller, take the follow-
ing steps:
1. Select Start » Run. In the Run dialog box, type Dcpromo and click the OK button.

2. You will see the Welcome To The Active Directory Installation Wizard dialog box. Click
the Next button.

3. The Operating System Compatibility dialog box will appear notifying you that Windows
Server 2003 domain security does not support Windows 95 or Windows NT 4.0 Service
Pack 3 or earlier clients. Click the Next button.
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4. The Domain Controller Type dialog box will appear, as shown in Figure 1.4. Verify that
Domain Controller For A New Domain is selected and click the Next button.

FIGURE 1.4 Domain Controller Type dialog box

Active Directory Installation Wizard ]

Domain Controller Type
Speciy the role you want this server to have,

Do you wank this server to become a domain controller for 2 new domain or an
addtional domain cordraller for an existing domain?

Select this option to create a new child domain, new domain tree, or new forest,
Thiz server wil become the first domain controller in the new domain.

" Additional domain cantraller for an existing damain
/¥y Proceeding with this option vl delete all kieal accounts on this serves,

All cryptographic keys will be deleted and should be exported before
continung,

All enciypted data, such as EFS-encrypted files or e-mail, should be decrypled
befare contirming of it will be permanerily inaccessible,

<Back [ MNews | Cancel |

5. The Create New Domain dialog box will appear, as shown in Figure 1.5. Verify that Domain
In A New Forest is selected and click the Next button.

FIGURE 1.5 Create New Domain dialog box

Active Directory Installation Wizard ]

Create New Domain
Select which type of domain to create,

option if thiz iz the first domain in your organization or if pou veant the new
domain o be completely independent of pour current farest,

" Child domain in an existing domain tes

If you want the new domain to be a child of an existing domain, zelect this cption.
For example. you could create & new domain named
headauarters, example. microsoft.com as a child domain of the domain

example. microsoft.com.

" Doman tree in an existing forest

If you don't want the new domain to be a child of an existing domain, select this
option. Thiz will create a new domain fres that is separate from ary exsting rees,

<Back [ MNews | Cancel |

6. The New Domain Name dialog box will appear, as shown in Figure 1.6. Type in whatever
domain name you wish to use. In this example, we are using Sybex.Tocal. (The .local
extension is not a legal extension and therefore cannot be connected directly to the Internet.
If you are going to connect directly to the Internet, you must use a registered domain name.)
Once you have specified your Active Directory domain name, click the Next button.
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FIGURE 1.6 New Domain Name dialog box

Active Directory Installation Wizard x|
New Domain Mame
Specily a name for the new domain =,
o

Type the ful DS name for the new domain
[for example: headquarters. example. microsoft com).

FEull DMS name for ness domar:
[Swbeslocal

<Back [ MNews | Cancel |

7. The NetBIOS Name dialog box will appear, as shown in Figure 1.7. NetBIOS names are
used for compatibility with other Windows clients that are not using Windows 2000, Win-
dows XP, or Windows Server 2003. You would typically accept the default values in this
dialog box, then click the Next button.

FIGURE 1.7 NetBIOS Name dialog box

Active Directory Installation Wizard x|
NetBIOS Domain Name
Speciy a MetBI0S name for the new doman, %
~y

This i the name that users of earker versions of Windows will use to identify the new
domain. Click Newt to accept the name shown, of type a new name.

Domain NetBIOS name: SYBEX

<Back [ MNews | Cancel |

8. The Database And Log Folders dialog box will appear, as shown in Figure 1.8. You can
accept the default values for the location of the Database folder and the Log folder or you
can manually specify the location of these folders. Once you make your selection, click the
Next button.

9. The Shared System Volume name dialog box will appear, as shown in Figure 1.9. The shared
system volume is called SYSVOL and contains the domain’s public files. You can accept the
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default location or manually specify the location of the SYSVOL folder. The SYSVOL folder
must be installed on a NTFES partition. Once you make your selection, click the Next button.

FIGURE 1.8 Database And Log Folders dialog box

Active Directory Installation Wizard x|
Database and Log Folders
Speciy the folders to cortan the Active Directory database and log fles, =,
Ny

For best performanca and recoverabiléy. store the database and the log on separate
hard disks.

Where do you want to store the Active Directory database?
Database folder:

|C\MNDDWS\NTDS Browss...

where do pou want ko store the Active Directory log?
Log folder

|C|\\M1NDUWS\NTD‘3 Browse, .

< Back | Hext » | Cancel

FIGURE 1.9 Shared System Volume dialog box

10.

11.

Active Directory Installation Wizard x|
Shared System Volume
Speciy the folder to be shared as the system volume, %
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The SYSYDL folder stores the server's copy of the domain's public files. The contents
of the SYSVOL folder are rephcated to all domain contrallers in the domain.

The SvSWOL folder must be located on an NTFS volume:
Enter a bacation for the SYSYOL folder.

Folder locatian:

CAWINDOWSASYSvoLl Browse. .

<Back [ MNews | Cancel |

The DNS Registration Diagnostics dialog box will appear, as shown in Figure 1.10. This
dialog box appears because DNS has not been installed in the network. Select Install And
Configure The DNS Server On This Computer, And Set This Computer To Use This DNS
Server As Its Preferred Server and click the Next button.

The Permissions dialog box will appear, as shown in Figure 1.11. You can select Permis-

sions Compatible With Pre-Windows 2000 Server Operating Systems or Permissions Com-
patible Only With Windows 2000 or Windows Server 2003 Operating Systems. Make your
selection and click the Next button.
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FIGURE 1.10 DNS Registration Diagnostics dialog box

FIGURE 1.11 Permissions dialog box
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The Directory Services Restore Mode Administrator Password dialog box will appear, as
shown in Figure 1.12. This password is associated with restoring Directory Services if it
becomes corrupt or can not be accessed. Type in and confirm the Restore Mode Password
and click the Next button.

The Summary dialog box will appear. Verify that your selections are correct and click the
Next button.

The Active Directory Installation Wizard will configure the Active Directory, which will
take several minutes. During this process you will need to insert the Windows Server 2003
distribution CD.

If the server was installed with a dynamic IP address you will see an Optional Networking
Components dialog box notifying you that for DNS you must use a static IP address. Click
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the OK button. The Local Area Connection Properties dialog box will appear. If this is not
a practice server, you should configure an IP address based on your corporate standards.
Make your selections and click the OK button.

FIGURE 1.12 Directory Services Restore Mode Administrator Password dialog box

Active Directory Installation Wizard x|
Directory Services Restore Mode Administrator Password
This password iz used when you start the computer in Directory Services Restore -
Mode.

Type and confim the password you want to sssign to the Adminisirator account used
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The restare mode Administrator account iz different from the domain Administrator
account. The passwords for the accounts might be different, so be sue to remember
both.

Restore Maode Pazsword: ||

LConfirm password: [

For more infarmation about Directory Services Restore Mode, see fctive Directory Help

< Back | Hext » | Cancel |

16. The Completing the Active Directory Installation Wizard dialog box will appear. Click the
Finish button. You will be prompted to restart your computer. Click the Restart Now button.

Setting Up Your Computers for
Hands-On Exercises

The exercises in this book assume that you have two computers configured in a specified
manner. In order to complete all of the exercises throughout the book, you will install Windows
Server 2003 on one computer as a domain controller within Active Directory, and Windows XP
Professional on a second computer, which will act as a member computer of the domain. Both com-
puters need to be networked and your Windows Server 2003 computer will require Internet access.

ING titioning or installation of new operating systems. All data will be lost during

@:" You should make a complete backup of your computer before doing any repar-
this process!

Installing Windows Server 2003 as a Domain Controller

For the exercises to work properly, you should make sure that the computer that will act as your
server meets the list of requirements specified in Table 1.2. Your server should have a network
card installed, and it should have at least a 2.5GB drive that is configured with the minimum
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space requirements and partitions. Other exercises in this book assume that your server is
configured as follows:

= 2GB (about 2000MB) C: primary partition with the NTFS file system
*  500MB of free space (you will create a new partition with this free space in Chapter 4)

Of course, you can allocate more space to your partitions if it is available. Exercise 1.1
assumes that you are not currently running any previous versions of Windows and that you are
performing a clean install and not an upgrade. Your partitions should be created and formatted,
or you can create the primary partition through the installation process.

In Exercise 1.1, you will install Windows Server 2003, then upgrade the server to a domain
controller. Before you start, you should note what values you will use for the following options
for the domain controller:

= Name and organization

=  Computer name

*  Workgroup name

*  Administrator password (if one will be assigned)

=  Domain name

o In this chapter the installation process assumes that you are using a 32-bit edi-
ITE tion of Windows Server 2003. If you are using a 64-bit Itanium-based server,
then refer to the Microsoft website for installation instructions.

Installing Windows Server 2003 as a Domain Controller

Collecting Information and Preparing Installation

1. Boot your computer using the Windows Server 2003 distribution CD.

2. The text mode portion of Setup will start. If you have a SCSI or RAID driver that is not

provided through the Windows Server 2003 CD, you would press F6; otherwise ignore
these prompts and setup will continue.

3. The Welcome To Setup dialog box will appear. Press Enter to continue.
4. The Windows License Agreement dialog box appears. Press F8 to continue.

5. Inthe next dialog box, you can pick a partition that already exists, or you can choose free
space and create a new partition. The partition you use must be formatted with NTFS since
you will be upgrading this server to a domain controller.

6. Afteryou select your partition (and it is formatted), the installation files will be automatically
copied to your computer. This requires no user intervention. Once this process is complete,
the computer will reboot.
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EXERCISE 1.1 (continued)

Installing Windows

7.

10.

11.

12.

13.

14.

15.

16.

After the installation process detects and installs device drivers and copies any needed
files, the Regional And Language Options dialog box will appear. Make your selections and
click Next to continue.

The Personalize Your Software dialog box appears. Fill in the Name and Organization
boxes and click the Next button.

The Your Product Key dialog box appears. From the product key located on the yellow
sticker on the back of the Windows Server 2003 CD folder, type in the 25-character product
key and click the Next button.

The Licensing Modes dialog box appears. Accept the default values and click the Next
button.

The Computer Name And Administrator Password dialog box appears. Specify the computer
name you want to use and type and confirm the Administrator password. Click the Next
button to continue.

If you have a Plug and Play modem installed, you will see the Modem Dialing Information
dialog box. Select the applicable options and click the Next button.

The Date And Time Settings dialog box will appear. Configure the appropriate date and
time settings and click the Next button.

The Network Settings dialog box appears. Specify Typical Settings and click the Next
button to continue.

The Workgroup Or Computer Domain dialog box appears. Select the No, This Computer
Is Not On A Network, Or Is On A Network Without A Domain. Make this computer

a member of the following workgroup: Workgroup. Click the Next button to
continue.

Based on your selections, the Windows installation process will automatically copy any
needed files, perform some final tasks, and automatically restart.

Upgrading Your Server to a Domain Controller

17.
18.

19.

Select Start » Run. In the Run dialog box, type Dcpromo and click the OK button.

You will see the Welcome To The Active Directory Installation Wizard dialog box. Click the
Next button.

The Operating System Compatibility dialog box will appear notifying you that Windows
Server 2003 domain security does not support Windows 95 or Windows NT 4.0 Service
Pack 3 or earlier clients. Click the Next button.
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EXERCISE 1.1 (continued)

20. The Domain Controller Type dialog box will appear. Verify that Domain Controller For A
New Domain is selected and click the Next button.

21. The Create New Domain dialog box will appear. Verify that Domain In A New Forest is
selected and click the Next button.

22. The New Domain Name dialog box will appear. Type in whatever domain name you wish
to use. In this example, we are using Sybex.local. If you are going to connect directly to
the Internet, you must use a registered domain name. Once you have specified your Active
Directory domain name, click the Next button.

23. The NetBIOS Name dialog box will appear. Accept the default values in this dialog box,
then click the Next button.

24. The Database And Log Folders dialog box will appear. Accept the default values for the
location of the Database folder and the Log folder and click the Next button.

25. The Shared System Volume name dialog box will appear. Ensure SYSVOL is pointing to an
NTFS partition, and accept the default location and click the Next button.

26. The DNS Registration Diagnostics dialog box will appear. Select Install And Configure The
DNS Server On This Computer, And Set This Computer To Use This DNS Server As Its
Preferred Server and click the Next button.

27. The Permissions dialog box will appear. Select Permissions Compatible Only With Win-
dows 2000 or Windows 2003 Operating Systems and click the Next button.

28. The Directory Service Restore Mode Administration Password dialog box will appear.
Leave the password as blank and click the Next button.

29. The Summary dialog box will appear. Verify that your selections are correct and click the
Next button.

30. The Active Directory Installation Wizard will configure the Active Directory, which will take
several minutes. During this process you will need to insert the Windows Server 2003
distribution CD.

31. Since the server was installed with a dynamic IP address you will see an Optional Network-
ing Components dialog box notifying you that for DNS you must use a static IP address.
Click the OK button. The Local Area Connection Properties dialog box will appear. Without
assigning a static IP address, click the OK button. You will see a notification dialog box that
you have chosen not to use a static IP address. Click the OK button.

32. The Completing the Active Directory Installation Wizard dialog box will appear. Click the
Finish button. You will be prompted to restart your computer. Click the Restart Now button.

33. After the server restarts, log on as Administrator.
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Installing Windows XP Professional within the
Windows 2003 Domain

Once Windows Server 2003 has been installed and configured as a domain controller, you will
install Windows XP Professional. The computer that will be installed with Windows XP Profes-
sional must meet the minimum requirements listed in Table 1.3.

TABLE 1.3 Hardware Requirements for Windows XP Professional

Component Minimum Requirement Recommended Requirement

Processor Intel Pentium (or compatible) Intel Pentium Il (or compatible)
233MHz or higher 300MHz or higher

Memory 64MB 128MB

Disk space 1.5GB of free disk space 2GB or more of free disk space

Network None Network card and any other hard-

ware required by your network
topology if you want to connect to
a network or if you will install over
the network

Display Video adapter and monitor Video adapter and monitor with
with VGA resolution SVGA resolution or higher

Peripheral devices Keyboard, mouse, or other Keyboard, mouse, or other pointing
pointing device device

Removable storage CD-ROM or DVD-ROM drive 12x or faster CD-ROM or DVD-ROM

) Windows XP Professional is covered in MCSE: Windows XP Professional Study
TE Guide, Second Edition, by Lisa Donald with James Chellis (Sybex, 2003).

If you do not have a computer already installed with Windows XP Professional, you will use
Exercise 1.2 to install Windows XP Professional on a computer within the domain you created
in Exercise 1.1 as part of the Windows Server 2003 installation. If you already have Windows XP
Professional installed on a computer, use Exercise 1.3 to join your existing Windows XP Pro-
fessional computer to the domain you created in Exercise 1.1. Before you start, note the following
information that you will need to provide as a part of the installation process:

=  Windows XP Professional Product Key

*  Name of the registered user
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Organization name
Computer name

Administrator password

Installing Windows XP Professional as a part of a Windows 2003 Domain

Information Collection

1.
2.

Boot your computer with the Windows XP CD inserted into your CD-ROM drive.

The Welcome To Setup screen appears. Press Enter to set up Windows XP Profes-
sional.

The License Agreement dialog box appears. Press F8 to agree to the license terms if you
wish to continue.

In the next dialog box, if needed, create a partition, and then specify the C: partition as the
one you want to use to set up Windows XP Professional. Then press Enter.

If you create a partition, in the next dialog box choose NTFS (Quick Format) for the file
system and press Enter to continue. The file copying will take a few minutes to complete
and your computer will reboot automatically.

Installing Windows

6.

10.

11.

12.

You will see a series of informational screens as the system does some background
installation tasks.

The Regional And Language Options dialog box will appear. Verify that the settings are
correct, and click the Next button.

In the Personalize Your Software dialog box, type your name and organization. Click the
Next button.

In the Your Product Key dialog box, type the 25-character product key (this key can be
found on a yellow sticker on the installation folder). Click the Next button.

The Computer Name And Administrator Password dialog box appears. Type in the com-
puter name. You can also specify an Administrator password (or, since this computer
will be used for practice, you can leave the Password field blank if you want to). Click the
Next button.

If you have a Plug and Play modem installed, the Modem Dialing Information dialog box
appears. Specify the settings for your environment and click the Next button.

The Date And Time Settings dialog box appears. Verify that all of the settings are correct,
and click the Next button.
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EXERCISE 1.2 (continued)

13. Afterthe Networking Componentfiles are copied (which takes a few minutes), the Network
Settings dialog box appears. Confirm that the Typical Settings radio button is selected.
Then click the Next button.

14. In the Workgroup And Computer Domain dialog box, select Yes, Make This Computer
A Member Of The Following Domain and specify the domain name you specified in
Exercise 1.1 (for example, sybex.Tocal), then click the Next button.

15. The Join Computer To Domain dialog box will appear. For User Name, specify Administrator
and for Password, the password you specified in Exercise 1.1. Click the OK button. The
Setup components will be installed, which takes several minutes, and your computer will
reboot as part of this process.

Finalizing Installation

16. The Welcome To Network Identification Wizard will start. Click the Next button to
continue.

17. The User Account dialog box will appear. Click the Do Not Add A User At This Time radio
button and click the Next button.

18. The Completing The Network Identification Wizard dialog box will appear. Click the Finish
button.

19. In the Welcome To Windows dialog box, press Ctrl+Alt+Delete to start the logon
process.

20. Inthe Log On To Windows dialog box, confirm that the username is Administrator and
type in the password you specified in Exercise 1.1. Click the Options button. In the Log On
To field, click the arrow to the right of the dialog box, and from the drop-down menu select
the domain you specified in Exercise 1.1. Then click the OK button.

If you already have Windows XP Professional installed on a computer, you would use
Exercise 1.3 to join the existing computer to the domain you created in Exercise 1.1.

Joining an Existing Windows XP Professional Computer to a
Windows 2003 Domain

1. From Windows XP Professional, select Start, right-click My Computer, and select Properties.

2. From the System Properties dialog box, select the Computer Name tab, then click the
Network ID button.
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EXERCISE 1.3 (continued)

3. The Network Identification Wizard will start. Click the Next button.

4. Inthe Connecting To The Network dialog box, verify that the This Computer Is Part Of A
Business Network, And | Use It To Connect To Other Computers At Work option is selected
and click the Next button.

5. The next question will ask what kind of network you use. Verify that the My Company Uses
A Network With A Domain option is selected and click the Next button.

6. The Network Information dialog box will appear. Click the Next button.

7. The User Account And Domain Information dialog box will appear. For User Name, specify
Administrator, and for Password and Domain, specify the options you configured in
Exercise 1.1, then click the Next button.

8. The User Account dialog box will appear. Click the Do Not Add A User At This Time option
and click the Next button.

9. The Completing The Network Identification Wizard dialog box will appear. Click the Finish
button.

10. The Computer Name Changes dialog box will appear, notifying you that you need to
restart the computer for the changes to take effect. Restart the computer and log on as
Administrator to the domain you created.

Post-Installation Product Activation

Product activation is Microsoft’s way of reducing software piracy. Unless you have a volume
corporate license for Windows Server 2003 or are using a 64-bit version of Windows Server 2003
(which does not use product activation), you will need to perform post-installation activation.
This can be done online or through a telephone call.

After Windows Server 2003 is installed, you will have 14 days to activate the license. After
the 14-day grace period expires, you will not be able to restart Windows Server 2003 normally
if you log out of the computer or if the computer is restarted. However, you can start Windows
Server 2003 to Safe Mode. With Safe Mode, you will not have any networking capabilities, but
you would have access to any folders or files located on the server.

When you activate Windows Server 2003, product activation uses the 25-character product
key you provided during the Windows Server 2003 installation to create a product ID, which
is a unique 20-character ID for your computer. A non-unique hardware hash will also be
created based on general information for your server’s hardware configuration, which creates
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a hardware identifier. Based on product ID and the hardware identifier, a unique installation ID
is created. The installation ID is what activates Windows Server 2003.

When the installation ID is generated, you should store it in a safe place—for example,
within the Windows Server 2003 installation folder. Then, if you need to re-install Windows
Server 2003 on the same computer, you can use the installation ID that was previously gener-
ated. However, if you install Windows Server 2003 on a different computer, using a product key
that has already been used, a new installation ID will need to be generated, as the hardware hash
will not match.

'% Microsoft scans no personal information during product activation. This process

TE is completely anonymous.

To activate Windows Server 2003 over the Internet, you would take the following steps:
1. Select Start » All Programs » Activate Windows.

2. The Let’s Activate Windows dialog box will appear, as shown in Figure 1.13. Select Yes,
Let’s Activate Windows Over The Internet Now and click the Next button.

FIGURE 1.13 Let's Activate Windows dialog box

%, Activate Windows

Let's activate Windows

To help reduce softw ey, ple clivale your co W Y . Activation over the
Internet is quick and easy

You don't need to give your name or other personal information when you activate Windows.

Do yow want

To continue, c

3. The Register With Microsoft? dialog box will appear, as shown in Figure 1.14, which gives
you the option of registering Windows Server 2003 at the same time you activate it. In
this example, we will skip registering Windows by clicking the No, I Don’t Want To
Register Now; Let’s Just Activate Windows and click the Next button.
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FIGURE 1.14 Register With Microsoft? dialog box

To continue

4. You will see a Thank You! dialog box indicating that you have successfully activated your
copy of Windows.

Once Windows Server 2003 has been activated, you can see the Product ID listed through the
properties of My Computer as shown in Figure 1.15.

FIGURE 1.15 Product ID shown through My Computer Properties dialog box
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You can verify that Windows Server 2003 has been activated through Event
P Viewer in the Application Event Log. Event Viewer is covered in greater detail
in Chapter 10.

You will need an Internet connection to complete Exercise 1.4. In this exercise, you will
activate Windows Server 2003.

Activating Windows Server 2003

1. Select Start > All Programs » Activate Windows.

2. The Let's Activate Windows dialog box will appear. Select Yes, Let’'s Activate Windows
Over The Internet Now and click the Next button.

3. The Register With Microsoft? dialog box will appear. Click the No, | Don’t Want To Register
Now; Let’s Just Activate Windows and click the Next button.

4. Youwill see a Thank You! dialog box indicating that you have successfully activated your
copy of Windows.

Managing Licensing

Each Microsoft client must have a local client license. For example, if you have 100 computers
running Windows 2000 Professional and 100 computers running Windows XP Professional,
all 200 computers would have to have an appropriate client license. Additional licensing is
required if the client computers will connect to Windows Server 2003 servers.

In the following sections you will learn:

=  How to select a licensing mode
=  How to configure the License Logging service
=  How to administer licensing in a local environment

*  How to administer licensing in an enterprise environment

Understanding and Selecting a Licensing Mode

Windows Server 2003 supports two types of client licensing:
= Per Server licensing

= Per Seat licensing (which includes Per Device or Per User licensing)
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In the following sections, you will learn how to select which licensing option is right for your
network and how to administer licensing.

Using Per Server Licensing

The Per Server licensing mode is the traditional method for client licensing. In this mode, the
server must be licensed for each concurrent connection. For example, assume that you have five
users and three servers, as shown in Figure 1.16. All five users need to access each of the three
servers. Each of the three servers must be licensed per server, supporting five connections. If
you added more users, they could technically access the server as long as no more than five
concurrent users were accessing a single server at the same time. With Per Server licensing,
clients are granted access on a first-come, first-served basis. Once the maximum number of clients
for the license has been reached, any additional clients attempting to access the server will be
denied access.

FIGURE 1.16 Per Server Licensing

per per per
server = server = server
5 license 5 license 5 license

-
| |

=17 T o, T

Client Client Client Client Client

In an enterprise environment, where users need to access resources on multiple servers, Per
Server licensing can be very expensive. However, in small companies where clients only need to
access a single server, the per-server mode of licensing is less expensive than the Per Seat licensing
mode. This option is also useful if you are supporting remote clients or your server is providing
Internet services, and clients are only accessing a single server.

Using Per Seat (Per Device or Per User) Licensing

The Per Seat licensing mode is more practical for the enterprise environment. By purchasing a
Client Access License (CAL) for each device or user, each client is licensed at the client side to
access as many servers as needed.

When using the Per Seat licensing mode, you record the CALs. In Figure 1.17, note that the
servers are only licensed for the server software, and the right to access the server is licensed
at the client.
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FIGURE 1.17 Per SeatLicensing
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In environments where one user uses a computer, this would be referred to as Per Seat usage.
However, some environments have special considerations and must require you to create
license groups for Per Device and Per User licensing. You would create licensing groups in the
following scenarios:

= You may have more than one user using a computer—if, for example, your organization
has workers in shifts and users from different shifts all share a computer.

*  You have many users who share many devices—for example, students working in a school
computer lab.

= You have a single user who accesses many computers—for example, someone working in
a test lab.

The licensing that would be required in these scenarios is as follows:

If 10 or fewer users are sharing a single computer, then you only need one CAL.

= If one user is accessing multiple devices, you will need a CAL for each device.

You will learn how to create license groups in the “Administering Licensing in an Enterprise”
section.

Administering the License Logging Service

If the License Logging service is running, Administrators can manage and track licensing
through the Licensing option in Control Panel or the Licensing utility in Administrative Tools.
If you were managing licenses for a single server, you would use the Licensing option in Control
Panel. If you were managing licenses for an enterprise environment, you would use the Licensing
Tools within Administrative Tools.

If the License Logging service has not been started, then licensing is not monitored, although
it is still enforced. You can view the status and manage the License Logging service from Start »
Administrative Tools » Services. From Services, you would double-click the License Logging
service to see the dialog box shown in Figure 1.18.
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FIGURE 1.18 License Logging Properties dialog box
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In order to use license logging, the following settings should be applied:
= Configure Startup Type as Automatic.
= If the Service Status is Stopped, click the Start button to start the service.

L4 Failure to start the License Logging service will prevent you from managing
ING licenses through the Licensing option in Control Panel or through the Licensing

utility in Administrative Tools.

In Exercise 1.5, you will configure the License Logging service.

Configuring the License Logging Service

1. Select Start > Administrative Tools > Services.

2. Scroll down until you see the License Logging service, and double-click License Logging.
3. Click the Log On tab and under Log On As, click Local System Account.

4. Click the General tab. Under Startup Type, select Automatic.
5

Under Service Status, click the Start button. The service will start and the Service Status
will display Started. Click the OK button.

6. Close the Service window.
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Administering Licensing Locally

The Licensing option in Control Panel, as shown in Figure 1.19, is used to manage a local
server’s licensing. The following tasks can be managed:

*  Add or remove CALs for the Per Server licensing mode

= Convert Per Server licensing to Per Device or Per User licensing (a onetime conversion from
Per Server to Per Seat licensing is allowed, at no charge)

=  Configuration of replication frequency if the server’s licensing is managed on a centralized
licensing server

FIGURE 1.19 Choose Licensing Mode dialog box
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In the following sections, you will learn about managing specific tasks through the Licensing
option in Control Panel.

Managing Per Server Connections

If you are using Per Server licensing, you can add or remove licenses with the Add Licenses and
Remove Licenses buttons.

If you need to add additional licenses and you have purchased the Per Server licenses from
Microsoft, you would click the Add Licenses radio button. This brings up the New Client
Access License dialog box, shown in Figure 1.20. Within the Quantity field, specify how many
additional licenses you are adding and click the OK button. You will need to agree that you have
purchased the license and that you agree to the governing terms of the license agreement.

FIGURE 1.20 New Client Access License dialog box
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You would remove Per Server licenses from a server if you wanted to use them on another
server. You would complete this task by clicking the Remove Licenses button. The Select
Certificate To Remove Licenses dialog box will appear. Specify how many licenses you want to
remove and click the Remove button.

Switching from Per Server Connections to Per Device or
Per User Connections

Microsoft allows a one-time conversion from Per Server to Per Device or Per User Connections.
If you want to switch from Per Server connections to Per Device or Per User connections, in the
Choose Licensing Mode dialog box you would click the Per Device Or Per User radio button.
You will see a License Violation dialog box warning you that your change may violate the
license agreement. If you have met all of the terms of the license agreement, click the No button
(so that the request is not cancelled) to complete the conversion process.

,/ If you configure Per Server licensing, you can always convert to Per Device or
ITE Per User licensing. However, you can’t convert from Per Device or Per User
licensing to Per Server licensing.

In Exercise 1.6, you will administer Per Server licensing in a single server environment using
the Licensing option in Control Panel.

Managing Per Server Licensing in a Single Server Environment

1. Select Start » Control Panel > Licensing.

2. Fromthe Choose Licensing Mode dialog box, click the Add Licenses button. (If you receive
an error at this point, it's because the License Logging Service is not started.)

3. The New Client Access License dialog box will appear. In the Quantity field, select 1 and
click the OK button.

4. The Per Server Licensing Agreement dialog box will appear. Click the | Agree That: dialog
box and click the OK button.

5. Inthe Choose Licensing Mode dialog box, you will see that your Per Server concurrent
connections are listed as 6.

If you are using a production server, as opposed to a practice server, verify that your license
meets the Microsoft requirements.

Managing Per Device and Per Users are typically associated with enterprise environments
and are covered in detail in the following section.
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Administering Licensing in an Enterprise

If a network consists of multiple servers in an enterprise network (using Active Directory ser-
vices), then licensing should be administered on an enterprise level. The following topics relate
to administering licensing in an enterprise environment:

*  Determining and specifying which server is the site license server
= Using the Licensing utility in Administrative Tools
*  Viewing site licensing for a Windows 2000 or Windows 2003 site

Each of these topics is covered in greater detail in the following subsections.

Determining and Specifying the Site License Server

The site license server is responsible for managing all of the Windows licenses for the site. The
default license server is the first domain controller in the site. The site license server does not
have to be a domain controller but for best performance it is recommended that site license
server and domain controller be in the same site.

To determine what server is the site license server, you would take the following steps from
a domain controller:

1. Select Start » Administrative Tools » Active Directory Sites And Services.

2. The Active Directory Sites And Services window will be displayed. Expand Sites and click
on Default-First-Site. In the right-hand pane, you will see Licensing Site Settings, as shown
in Figure 1.21.

FIGURE 1.21 Active Directory Sites And Services window
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3. Double-click License Site Settings, and the Licensing Site Settings Properties dialog box will
appear, as shown in Figure 1.22. In the lower half of the dialog box, under Licensing
Computer, you will see the server that has been designated the site license server.

4. If you want to change the site license server, under Licensing Computer you click the Change
button. The Select Computer dialog box appears and you can specify the computer name
that will be the new site license server.
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FIGURE 1.22 Licensing Site Settings Properties dialog box
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Once you have determined which server is the site license server, you can manage licensing
for your site through the Licensing utility in Administrative Tools.

Using the Licensing

To access the Licensing utility, select Start » Administrative Tools » Licensing. This brings up
the Licensing utility shown in Figure 1.23.

FIGURE 1.23 Licensing utility
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If you click the Server Browser tab, then expand your domain and your server, you will see an
entry called Windows Server. Double-clicking Windows Server accesses the Choose Licensing
Mode dialog box, as shown in Figure 1.24. This allows you to specify whether you will manage
enterprise licensing through Per Server mode or Per Device or Per User mode.

FIGURE 1.24 Choose Licensing Mode dialog box
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Once you have selected your licensing mode, you can manage licensing from the main dialog
box of the Licensing utility, which contains four main tabs:

*  Purchase History
= Products View

= Clients

= Server Browser

Each of these tabs and the processes for creating and editing licensing groups and for
managing replication are covered in greater detail in the following subsections.

Purchase History

The Purchase History tab of Licensing (shown in Figure 1.23) displays the historical overview
of all licenses that have been added or deleted for the site. Specifically, you can see the date the
license was added or deleted, the product (Windows or other Microsoft product), the quantity
(added or deleted), the user who added the licenses, and a comment (if one was added). If you
click the heading for Date, Product, Quantity, Administrator, or Comment, the purchase history
will be sorted based on the category you selected.

You would add new licenses through the following process:

1. Select License » New License.
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2. The New Client Access License dialog box will appear. For Product, select Windows Server
and then specify the quantity for the licenses you have purchased. You can add a descriptive
comment in the comment field. Click the OK button when you are done.

3. ThePer Device Or Per User Licensing dialog box will appear. You must agree that you have
read and are bound to the license agreement for this product, then click the OK button.

4. The new licenses will appear in the Purchase History tab.

Products View

Through the Products View tab, shown in Figure 1.25, you can see the following information
for each product that is licensed on the server:

= Per Device or Per User licenses that have been purchased
= Per Device or Per User licenses that have been allocated
= Per Server licenses that have been purchased

= The number of connections for Per Server that have been reached

FIGURE 1.25 Product View tab of the Licensing utility
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If you look on the left-hand side of the Products View tab, you will see the licensing status
of each product. The following symbols are used to indicate license status:

Symbol License Status

g License is in legal compliance.

ﬁ License is not in legal compliance.

> License has reached legal limit, and you should consider purchasing

additional licenses.

Clients

Through the Clients tab, shown in Figure 1.26, you can see the following information for each
client that has accessed the server:

= The username of each user who has accessed the server
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= The licensed usage (access) to the server
= The unlicensed usage (access) to the server

*  The product (for example, Windows Server or Windows BackOffice) that was accessed by
the user

FIGURE 1.26 Clients tab of the Licensing utility
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If you look on the left-hand side of the Clients tab, you will see the licensing status of each
product. The following symbols are used to indicate license status:

Symbol License Status

ﬂ User’s license is in legal compliance.

;‘: User’s license is not in legal compliance.
[

Server Browser

The Server Browser tab, as shown in Figure 1.27, displays all of the sites, domains, and servers
within the Active Directory structure. You can view and configure licensing for the servers that
you have administrative rights to within the site.

FIGURE 1.27 Server Browser tab of the Licensing utility
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Creating and Editing Licensing Groups

You would create a license group if more than one person will be using a single computer.
In the following example, you will create a license group called WS1 that consists of three
users (who work different shifts) who share a single computer.

1. Select Start » Administrative Tools » Licensing. In the main menu of the Licensing
utility, select Options » Advanced » New License Group.

2. The New License Group dialog box will appear, as shown in Figure 1.28.
FIGURE 1.28 New License Group dialog box
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Specify a group name (in this example, it’s WS1) and a description (optional).

In the Licenses drop-down box, you would specify 1, as up to 10 users can share a single
computer.

5. To add users to this license group, click the Add button, which brings up the Add Users
dialog box, shown in Figure 1.29. Select the users you want to add by highlighting them
and then clicking the Add button. When you are done, click the OK button.

6. In the New License Group dialog box, click the OK button.
FIGURE 1.29 Add Users dialog box
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Once a license group has been created, you can edit the licenses or group members for the
license group through Options » Advanced » Edit License Group.

Managing Replication
In an enterprise environment, you can centrally manage licensing information by collecting and
storing all license information on a central server (the site license server) through the License
Logging service.

If your Windows Server 2003 server is not the site license server, you can configure how your
server will replicate information to the site license server through the following steps:

1. Select Start » Control Panel > Licensing.
2. From the Choose Licensing Mode dialog box, click the Replication button.

3. The Replication Configuration dialog box will appear, as shown in Figure 1.30. You can
configure replication to start at a specific time (every 24 hours) or specify that licensing
information should be replicated every x (number specified) hours.

FIGURE 1.30 Replication Configuration dialog box
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4 In sites with a large number of servers, staggering replication times on different
P servers can balance the load of traffic that is sent to a site license server.

Managing Software Installation
and Maintenance

To keep your Windows operating systems up-to-date and secure, you use Windows Update,
Automatic Update, Software Update Services (SUS), and the Microsoft Baseline Security
Analyzer (MBSA):

Windows Update This attaches to the Microsoft website through a user-initiated process and
allows the Windows users to update their operating systems by downloading updated files
(critical and non-critical software updates).
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Automatic Update This extends the functionality of Windows Update by automating the
process of updating critical files. With Automatic Update, you can specify whether you want
updates to be automatically downloaded and installed or whether you just want to be notified
when updates are available.

Software Update Services (SUS) This is used to deploy a limited version of Windows Update
to a corporate server, which in turn provides the Windows updates to client computers within
the corporate network. This allows clients that are limited to what they can access through a
firewall to still keep their Windows operating systems up-to-date.

Microsoft Baseline Security Analyzer (MBSA) This is a utility you can download from
the Microsoft website to ensure that you have the most current security updates.

In the following sections you will learn how to use Windows Update, Automatic Update,
Microsoft Software Update Services, and the Microsoft Baseline Security Analyzer.

Using Windows Update

Windows Update is available through the Microsoft website and is used to provide the most
current files for the Windows operating systems. Examples of updates include security fixes,
critical updates, updated help files, and updated drivers.

Sometimes the updates that are installed require that the computer be restarted before
the update can take effect. In this event, Windows Update uses a technology called chained
installation. With chained installation, all updates that require a computer restart are applied
before the computer is restarted. This eliminates the need to restart the computer more
than once.

If Windows Update detects any updates for your computer, you will see an update icon in the
notification area of the Taskbar.

The following steps are used to setup Windows Update from a Windows Server 2003 server
that is connected to the Internet:

1. Select Start > Help And Support.

2. The Help And Support Center dialog box will appear, as shown in Figure 1.31.
3. Under Support Tasks, click the Windows Update option.
4

The Welcome To Windows Update will appear, as shown in Figure 1.32. Click Scan For
Updates.

5.  Windows Update will look for all available updates based on your computer’s configuration.
A list of all updates for your computer will be listed, and you can selectively pick which
updates you want to download.

The results of the Windows Update search will be displayed on the left-hand side of the
Windows Update screen. You will see options for:

*  Welcome, which describes what Windows Update is and provides an option to Scan For
Updates
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FIGURE 1.31 Help And Support Center dialog box
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Pick Updates To Install, which lists what updates are available for your computer and
includes:

Critical Updates And Service Packs
Windows Server 2003 Family
Driver Updates

Review And Install Updates, which allows you to view all updates you have selected to
install and installs the updates

View Installation History, which allows you to track all of the updates you have applied to
your server

Personalize Windows Update, which customizes what you see when you use Windows Update
Get Help And Support, which displays help and support information about Windows Update
About Windows Update, which displays information about what Windows Update is used for

ITE and version number, Internet Explorer version, the software version information

%’ The information that is collected by Windows Update includes operating system

1.

2
3
4.
5
6

for any software that can be updated through Windows Update, Plug and Play ID
numbers for installed hardware, and region and language settings. Windows
Update will also collect the Product ID and Product Key to confirm that you are
running a licensed copy of Windows, but this information is only retained during
the Windows Update session, and this information is not stored. No information
that can be used to personally identify users of the Windows Update service is
collected.

You will use Windows Update in Exercise 1.7.

EXERCISE 1.7

Using Windows Update

Select Start » Help and Support.

The Help And Support Center dialog box will appear.

Under Support Tasks, click the Windows Update option.

The Welcome To Windows Update will appear. Click Scan For Updates.

Windows Update will look for all available updates based on your computer’s configuration.

A list of all updates for your computer will be listed. Click each option for Critical Updates
And Service Packs, Windows Server 2003 Family, and Driver Updates and check the
updates you want to install.

Click Review And Install Updates. In the Total Selected Updates section, click the Install
Now button.
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Using Windows Automatic Updates

Windows Automatic Updates extends the functionality of Windows Update by automating the
update process. With Automatic Updates, Windows Server 2003 recognizes when you have an
Internet connection and will automatically search for any updates for your computer from the
Windows Update website.

If any updates are identified, they will be downloaded using Background Intelligent Transfer
Services (BITS). BITS is a bandwidth-throttling technology that only allows downloads to occur
using idle bandwidth. This means that downloading Automatic Updates will not interfere with
any other Internet traffic.

)/ In order to configure Automatic Updates, you must have local administrative
@TE rights to the computer that Automatic Updates is being configured on. Requiring
administrative rights prevents users from specifying that critical security
updates not be installed. In addition, Microsoft will digitally sign any updates
that are downloaded. Automatic Updates will not install files that do not contain
a digital signature.

You configure Automatic Updates through the following process by selecting Start » Control
Panel » System and click the Automatic Updates tab. You will see the dialog box shown in
Figure 1.33.

FIGURE 1.33 Automatic Updates tab from System Properties
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You enable Automatic Updates by checking the option Keep My Computer Up To Date.
With This Setting Enabled, Windows Update Software May Be Automatically Updated Prior To
Applying Any Other Updates.

The settings that can be applied to Automatic Updates include:

*  Notify Me Before Downloading Any Updates And Notify Me Again Before Installing Them
On My Computer. This option will prompt you to accept the downloading of any updates
and you will be required to verify that you want the updates installed.

* Download The Updates Automatically And Notify Me When They Are Ready To Be

Installed. This is the default setting and will automatically download updates as a back-
ground process; however, you must verify that you want to install the updates.

*  Automatically Download The Updates, And Install Them On The Schedule That I Specify.
This allows you to specify the days and times you want Windows to search for updates—
for example, during non-business hours. You still have to verify that you want the updates
installed prior to the updates being applied to your server.

The bottom of the Automatic Updates tab has a Declined Updates button. If Windows
Update notifies you of an update and you decline the update—meaning you did not choose
certain updates initially—you can click this button at a later time and still access the update,
even if it was initially declined.

You will configure Automatic Updates in Exercise 1.8.

Configuring Automatic Updates
1. Select Start » Control Panel » System and click the Automatic Updates tab.
2. Verify that the Keep My Computer Up To Date option is checked.

3. Under Settings, select the Automatically Download The Updates, And Install Them On The
Schedule That | Specify option. Select Every Sunday at 2:00 A.M. and click the OK button.

Using Software Update Services

Software Update Services (SUS) is used to leverage the features of Windows Update within a
corporate environment by downloading Windows Update to a corporate server, which in turn
provides the updates to the internal corporate clients. This allows administrators to test and
have full control over what updates are deployed within the corporate environment.

SUS is designed to work in medium-sized corporate networks that are not using Systems
Management Server (SMS).

In the following sections, you will learn about:

*  Advantages of using SUS

= SUS server requirements
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= Installing and configuring the SUS servers
= SUS client requirements

=  Configuration of the SUS clients

)/ The current version of SUS, during the writing of this book, is SUS 1.0 with
A TE Service Pack 1.

@ Real World Scenario
Using SUS

You are the network administrator for a large company. You want to ensure that your Windows
servers and clients are kept up-to-date. You have a process that specifies that all updates must
be tested in a lab environment before they are deployed within the network. You want to
streamline the update process as much as possible with minimum cost and setup.

All of your client computers are running Windows 2000 Professional or Windows XP Professional
and all of the servers are running Windows 2000 Server or Windows Server 2003. They all have
the current Service Packs applied.

You decide to use Software Update Services. The software can be downloaded from the
Microsoft website at no charge and can be configured to automatically download any updates
based on the schedule you specify. You can then test all of the updates before they are configured
to be deployed within the internal network.

Advantages of Using SUS

There are many advantages to using SUS. The advantages include:

= SUS allows an internal server within a private intranet to act as a virtual Windows
Update server.

*  Administrators have selective control over what updates are posted and deployed from the
public Windows Update site. No updates are deployed to client computers unless they
are first approved by an administrator.

*  Administrators can control the synchronization of updates from the public Windows Update
site to the SUS server either manually or automatically.

»  Automatic Updates can be configured on client computers to access the local SUS server as
opposed to the public Windows Update site.

= Each update can be checked to verify that they are digitally signed by Microsoft, and any
updates that are not digitally signed are discarded.

»  Updates can be deployed to clients in multiple languages.
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= You can configure the SUS statistics server to log update access, which allows an adminis-
trator to track which clients have installed updates. The SUS server and the SUS statistics
server can coexist on the same computer.

*  Administrators can manage SUS servers remotely using HTTP or HTTPS if their web
browser is Internet Explorer 5.5 or higher.

SUS Server Requirements

In order to act as a SUS server, the server must meet the following requirements:

*  Be running Windows 2000 Server with Service Pack 2 or higher or Windows Server 2003
*  Be using Internet Explorer 5.5 or higher

= Have all of the most current security patches applied

*  Be running Internet Information Services (IIS)

*  Be connected to the network

= Have an NTFS partition with 100MB free disk space to install the SUS server software and
6GB of free space to store all of the update files

If your SUS server meets the following system requirements, it can support up to 15,000 SUS
clients:

= Pentium III 700MHz processor
=  512MB of RAM

Installing and Configuring the SUS Server

The SUS server should run on a server that is dedicated to running SUS, meaning that it will not
run any other applications other than IIS, which is required. Microsoft recommends that you
install a clean or new version of Windows 2000 Server or Windows Server 2003 and apply any
service packs or security-related patches.

shl You should not have any virus-scanning software installed on the server. Virus
ING scanners can mistake SUS activity for a virus.

Installing a SUS Server
The following steps are used to install the SUS server:

1. Download the SUS software from the Microsoft website. The URL for accessing the SUS
homepage is: http://go.Microsoft.com/fwlink/?1inkid=6930. The download file is
called SUS10SP1.exe. The SUS software is available in English and Japanese.

2. Once SUS is downloaded, the Welcome To The Microsoft Software Update Services Setup
Wizard screen will appear. Click the Next button.

- If IIS is not installed on the server, which is a prerequisite for SUS, you will
ITE receive an error. The installation of IIS is covered in Chapter 6.
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The End-User License Agreement dialog box will appear. Accept the terms of the agreement
and click the Next button.

The Choose Setup Type dialog box will appear. You can select Typical (which installs
Microsoft Software Update Services with default settings) or Custom (which customizes the
installation and settings of Microsoft Software Update Services). Click Typical to install
the SUS with default settings.

The Ready To Install dialog box will appear and a download URL will be specified, as shown
in Figure 1.34. The download URL is HTTP: //yourservername by default. Computers
running Automatic Updates must be configured to use this URL. Click the Install button.

FIGURE 1.34 Ready To Install dialog box
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The Completing The Microsoft Software Update Services Setup Wizard dialog box will
appear. Click the Finish button.

The SUS Administration website will automatically open in Internet Explorer.

Configuring a SUS Server

In the following sections, you will learn how to set the SUS server options, set synchronization,
approve updates, view the synchronization log, view the approval log, and monitor the SUS server.

SETTING SUS SERVER OPTIONS
You can configure the SUS server through the following steps:

1.

If the SUS Administration website is not open, you can open it from Internet Explorer
through the URL http://yourservername/SUSAdmin.

The Software Update Services screen will appear, as shown in Figure 1.35. Under the Other
Options section, click Set Options.

Within the Set Options selection, shown in Figure 1.36, you can select the following options:
Select A Proxy Server Configuration

Specify The Name Your Clients Use To Locate This Update Server
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FIGURE 1.35 Microsoft Software Update Services
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FIGURE 1.36 SetOptions
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Select Which Server To Synchronize Content From (Microsoft Windows Update Servers
Or Local Software Update Server)

Select How You Want To Handle New Versions Of Previously Approved Updates
(Automatically Approve New Versions Of Previously Approved Updates, Do Not Auto-
matically Approve New Versions Of Approved Updates, Default, or Recommended)

Select Where You Want To Store Updates (You Can Maintain The Updates On A
Microsoft Windows Update Server Or Save The Updates To A Local Update Folder)

Synchronize Installation Packages Only For These Locales (Allows You To Specify
Locales/Languages That You Are Storing Update Packages For)

Click the Apply button when you are done with your configuration settings.

SETTING SUS SERVER SYNCHRONIZATION

By default, SUS server synchronization is not defined. You can manually synchronize your
server with the Windows Update server or you can set a synchronization schedule to automate
the process. The following steps are used to configure SUS Server synchronization:

1.
2.

From the Software Update Services screen, click Synchronize Server.

The Synchronize Server screen will appear, as shown in Figure 1.37.

FIGURE 1.37 Synchronize Server
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You can select Synchronize Now (which forces a manual synchronization) or Synchroni-
zation Schedule. To set a synchronization schedule, click the Synchronization Schedule button.

The Schedule Synchronization—Web Page Dialog dialog box will appear (see Figure 1.38).
You can specify that you will not use a synchronization schedule (which means you will
need to manually synchronize your server) or synchronize your server using the specified
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schedule. You would typically schedule updates during non-peak network hours. When
you are done, click the OK button.

FIGURE 1.38 Schedule Synchronization—Web Page Dialog dialog box
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APPROVING UPDATES
Before updates can be deployed to SUS clients, the administrator must approve the updates. You
approve updates through the following steps:

1.

From the Software Update Services screen, click Approve Updates.

2. The Approve Updates screen will appear, as shown in Figure 1.39.

FIGURE 1.39 Approve Updates screen
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VIEWING THE SYNCHRONIZATION LOG
The following steps are used to view the synchronization log:

1. From the Software Update Services screen, click View Synchronization Log.

2. The Synchronization Log screen will appear, as shown in Figure 1.40.

FIGURE 1.40 Synchronization Log screen
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VIEW THE APPROVAL LOG
The approval log shows the update status for each item. Update status will be marked as New,
Approved, Not Approved, Updated, or Temporarily Unavailable.

The following steps are used to view the approval log:

1. From the Software Update Services screen, click View Approval Log.

2. The Approval Log screen will appear, as shown in Figure 1.41.

MONITORING THE SUS SERVER

The Monitor Server option allows you to see what updates have been cached into the server
memory. If the memory cache does not load automatically, you can click the Refresh
button.

1. From the Software Update Services screen, click Monitor Server.

2. The Monitor Server screen will appear, as shown in Figure 1.42.
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FIGURE 1.41 Approval Log screen
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FIGURE 1.42 Monitor Server screen
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SUS Client Requirements

SUS clients run a special version of Automatic Updates that are designed to support SUS. The
enhancements to Automatic Updates include:

= Support so that the client can receive updates from a SUS server as opposed to the public
Microsoft Windows Update site

= Support so that the administrator can schedule when downloading of updated files will occur

= Configuration support so that clients can be configured via group policy or through editing
the Registry

= Support for allowing updates when an administrative account or non-administrative
account is logged on

The only client platforms that SUS currently supports are:
= Windows 2000 Professional (with Service Pack 2 or higher)
*  Windows 2000 Server (with Service Pack 2 or higher)
*  Windows 2000 Advanced Server (with Service Pack 2 or higher)
=  Windows XP Home Edition (with Service Pack 1 or higher)
*  Windows XP Professional (with Service Pack 1 or higher)
= Windows Server 2003 (all platforms)

Configuration for the SUS Clients

There are two methods for configuring SUS clients. The method you use is dependent on
whether your network uses Active Directory.

In a non-enterprise network (not running Active Directory), you would configure Automatic
Updates through Control Panel using the same process that was defined in the “Using Auto-
matic Updates” section of this chapter. Each client’s Registry would then be edited to reflect
the location of the server that will provide the Automatic Updates.

Within an enterprise network, using Active Directory, you would typically see Automatic
Updates configured through group policy. Group policies are used to manage configuration and
security settings via Active Directory. Group policy is also used to specify what server a client
will use for Automatic Updates. If Automatic Updates are configured through Group Policy,

then Automatic Updates settings through Control Panel » System, Automatic Updates tab are
disabled.

Configuring a Client in a Non-Active Directory Network

The easiest way to configure the client to use Automatic Updates is through Control Panel >
System, Automatic Updates tab. However, you can also configure Automatic Updates through
the Registry. The Registry is a database of all of your server’s settings and can be accessed
by clicking Start » Run and typing Reged1it in the Run dialog box. Automatic Updates settings
are defined through HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\
WindowsUpdate\AU.

The Registry options that can be configured for Automatic Updates are specified in Table 1.4.
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TABLE 1.4 Registry Keys and Values for Automatic Updates

Registry Key Options for Values

NoAutoUpdate 0 Automatic Updates are enabled (default)
1 Automatic Updates are disabled

AUOptions 2 Notify of download and installation
3 Auto download and notify of installation
4 Auto download and schedule installation

ScheduledInstallDay 0 Every day
1 Sunday
2 Monday
3 Tuesday
4 Wednesday
5 Thursday
6 Friday
7 Saturday

UseWUServer 0 Use public Microsoft Windows Update site
1 Use server specified in WUServer entry

To specify what server will be used as the Windows Update server, you edit two Registry
keys, which are found at HKEY_LOCAL_MACHINE\Software\Pol1icies\Microsoft\Windows\
WindowsUpdate.

= The WUServer key sets the Windows Update server using the server’s HTTP name—
for example, http://intranetSUsS

= TheWUStatusServer key sets the Windows Update intranet SUS statistics server by using
the server’s HTTP name—for example, http://intranetSUsS

Configuring a Client in an Active Directory Network

If the SUS client is a part of an enterprise network using Active Directory, you would configure
the client via group policy. To configure group policy on a Windows Server 2003 domain
controller, you would take the following steps:

1. Select Start » Run. In the Run dialog box, type MMC.

2. From the MMC console, select File » Add/Remove Snap-in.
3. In the Add/Remove Snap-in dialog box, click the Add button.
4

In the Add Standalone Snap-in dialog box, select Group Policy Object Editor and click the
Add button.

5. For Group Policy Object, click the Browse button and select Default Domain Policy and
click the OK button.
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6. Inthe Select Group Policy Object dialog box, click the Finish button. In the Add Standalone
Snap-in dialog box, click the Close button. In the Add/Remove Snap-in dialog box, click
the OK button.

7. ExpandDefault Domain Policy\Computer Configuration\Administrative Templates\
Windows Components\Windows Update to access the Windows Update settings shown in
Figure 1.43.

FIGURE 1.43 Group Policy Settings for Windows Update
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8. Double-click the Configure Automatic Updates option. The Configure Automatic Updates
Properties dialog box will appear, as shown in Figure 1.44. The Automatic Update options
that can be configured through group policy are:

= Whether Automatic Updates are Not Configured, Enabled, or Disabled

*  How automatic updating is configured, either Notify For Download And Notify For
Install, Auto Download And Notify For Install, or Auto Download And Schedule The Install

»  The schedule that will be applied for the install day and the install time

9. To configure which server will provide automatic updates, you click the Next Setting button
on the Configure Automatic Updates Properties dialog box. This brings up the Specify
Intranet Microsoft Update Service Location Properties dialog box shown in Figure 1.45.
The Specify Intranet Microsoft Update Service Location Properties that can be configured
through group policy are:

»  The status of the Intranet Microsoft Update Service location as Not Configured,
Enabled, or Disabled

= The HTTP name of the server that will provide intranet service updates

=  The HTTP name of the server that will act as the intranet SUS statistics server
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FIGURE 1.44 Configure Automatic Updates Properties dialog box
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FIGURE 1.45 Specify Intranet Microsoft Update Service Location Properties dialog box
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10. To configure rescheduling of automatic updates, you click Next Setting button on the Specify
Intranet Microsoft Update Service Location Properties dialog box. This brings up the
Reschedule Automatic Updates Scheduled Installation Properties dialog box shown in
Figure 1.46. You can enable and schedule the amount of time that Automatic Updates waits
after system startup to proceed with a scheduled installation that was previously missed.

FIGURE 1.46 Reschedule Automatic Updates Scheduled Installation Properties dialog box
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11. To configure auto-restart for scheduled Automatic Updates installations, you click Next
Setting button on Reschedule Automatic Updates Scheduled Installation Properties dialog
box. This brings up the No Auto-Restart For Scheduled Automatic Updates Installations
dialog box shown in Figure 1.47. If an update requires the computer to restart, there are two
configuration options available: the computer will be updated the next time the computer is
restarted, or the restart is automatically performed as a part of the update.

) There are security templates called Wuau.adm (for Windows 2000 Server, if you
TE are using Service Pack 2 you will need to import this template. If you are using

Service Pack 3 or higher, the template is included as a part of the Service Pack
Update), which is available through the Software Update Services installation.
If you are using Windows Server 2003 you would use the System.adm security
template that automatically applies the group policy settings that are used by
SUS. Group Policies and security templates are described in more detail in
MCSE: Windows 2003 Active Directory Planning, Implementation, and Mainte-
nance Study Guide by Anil Desai with James Chellis (Sybex, 2003)
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FIGURE 1.47 No Auto-Restart Of Scheduled Automatic Updates Installations dialog box
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12. When you are done making setting changes, click the OK button.

Using the Microsoft Baseline Security Analyzer

The Microsoft Baseline Security Analyzer (MBSA) is a security assessment utility that can be

downloaded from the Microsoft website. It verifies whether your computer has the latest security
updates and whether there are any common security violation configurations (configurations
that could allow security breaches) that have been applied to your computer. The programs that
are scanned by MBSA include:

=  Windows NT 4

*  Windows 2000

*  Windows XP

*  Windows Server 2003

» IIS4and$

= Internet Explorer, versions 5.01 and higher

= SQL Server 7 and SQL Server 2000

*  Microsoft Office 2000 and Microsoft Office XP
*  Windows Media Player, versions 6.4 and higher
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In order to use MBSA, the computer must meet the following requirements:

= Be running Windows 2000, Windows XP, or Windows Server 2003 (MBSA is not
supported by Windows 95, Windows 98, or Windows Me)

*  Be running Windows Explorer 5.01 or higher
*  Have an XML parser installed for full functionality
=  Have the Workstation and the Server service enabled

= Have Client for Microsoft Networks installed

) MSBA replaces the Microsoft Personal Security Advisor (MPSA), an applica-
TE tion that was previously used to scan for possible security threats to your
computer.

A GUI version of MBSA can be run from Start All Programs » Microsoft Baseline Security
Analyzer. You can also open a command prompt and changing the path to Drive: Program
Files\Microsoft Baseline Security Analyzer and typing mbsa (after the Mbsasetup.msi
has been downloaded and installed from the Microsoft site) or from the command line using
mbsacli.exe.

@ Real World Scenario
Using MIBSA

You are the network administrator of a large company. In the past you have had problems with
security as security holes have become public knowledge and hackers have tried to gain
unauthorized access to your network. You also want to ensure that your configuration settings
meet the current standards for security that have been defined by Microsoft.

You decided to use the Microsoft Baseline Security Analyzer. The utility is constantly being
updated and will tell you if you have any configurations that could cause security problems or
if there are any known security problems with your current software.

Using the GUI Version of MBSA

Once you have installed MBSA, you can access it from Start » All Programs » Microsoft
Baseline Security Analyzer or by opening the command prompt and executing mbsa. exe. This
brings up the Baseline Security Analyzer utility shown in Figure 1.48.

You can select from Scan A Computer, Scan More Than One Computer, or View Existing
Security Reports.

When you click Scan A Computer, the Pick A Computer To Scan dialog box will appear, as
shown in Figure 1.49. You can specify that you want to scan a computer based on computer
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name or IP address. You can also specify the name of the security report that will be generated.
Options for the security scan include:

FIGURE 1.48

FIGURE 1.49
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= Check for SQL vulnerabilities

= Check for security updates (if you use this option and are using SUS, you can specify the
name of the SUS server that should be checked for the security updates)

Once you are done with your selections, click Start Scan.
Once the scan is complete, the security report will be automatically displayed, as shown in
Figure 1.50.

FIGURE 1.50 View Security Report dialog box
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If you have scanned multiple computers, you can sort the security reports based on issue
name, score (worst first), or score (best first).

Using mbsacli.exe

If you use MBSA from the command-line utility mbsac11 . exe, there are several options that
can be specified. You type mbsac1i.exe /hf (from the folder that contains mbsac1i.exe,
which is Drive: Program Files\Microsoft Baseline Security Analyzer) and can then
customize the command execution with the options defined in Table 1.5.

TABLE 1.5 mbsacli.exe /hf Command-line Options

Option Description

-h hostname Scans the specified host. You can specify that you want to scan
multiple host computers by separating the hostnames with a
comma.
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TABLE 1.5 mbsacli.exe /hf Command-line Options (continued)

Option Description

-th filename Scans the NetBIOS names of each computer that is to be
scanned and saves the information as text within the filename
you specify.

=T XXXX L XXXX L XXXX . XXXX Scans a computer based on the specified IP address. You

can scan multiple computers by IP address by separating each
IP address with a comma.

-fip filename Scans the computer’s IP addresses within the text file that was

specified, up to a maximum of 256 IP addresses.

-d domainname Scans the specified domain.

Specifies that all of the computers on the local network should
be scanned.

Summary

In this chapter, you learned about basic features of Windows Server 2003, how to install Windows
Server 2003, licensing for Windows Server 2003, and how to keep Windows Server 2003
up-to-date. We covered the following topics:

The basic features of Windows Server 2003, which include Active Directory, file and print
services, security, network and communications, application services, management services,
Storage Management Services, Internet Information Services, Terminal Services, Universal
Description, Discovery, and Integration services.

Preparation needed for installing Windows Server 2003, which included verifying that your
computer meets the hardware requirements for Windows Server 2003, making sure
your hardware is on the Hardware Compatibility List, checking system compatibility, and
understanding the installation options for Windows Server 2003.

How to install Windows Server 2003 and configure the server as a domain controller.
What post-installation activation is and how to activate Windows Server 2003.

The options for managing licensing with Windows Server 2003 clients and how to
administer licensing.

How to manage software installation and maintenance through Windows Update, Win-
dows Automatic Updates, Software Update Services, and Microsoft Baseline Security
Analyzer.
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Exam Essentials

Be able to manage Windows licensing. You should understand the options for licensing
Windows clients and how licensing can be administered in a local environment or within an
enterprise environment.

Be able to keep Windows up-to-date and secure. Understand the use of Windows Update,
Windows Automatic Updates, Software Update Services, and Microsoft Baseline Security
Analyzer. Be able to install and configure SUS servers and clients and administer software
updates. Know how to use the Microsoft Baseline Security Analyzer to identify possible security
weaknesses from a GUI interface and from the command line.

Key Terms

Before you take the exam, be certain you are familiar with the following terms:

Active Directory (AD) Microsoft Baseline Security Analyzer (MBSA)
Automatic Update organizational units (OUs)

Client Access License (CAL) Per Seat licensing

containers Per Server licensing

domain controller product activation

domains site license server

Hardware Compatibility List (HCL) Software Update Services (SUS)

License Logging service Windows Update
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Review Questions

1.  Youare the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers have
the most current software installed for their operating systems, including:

Critical Updates and Service Packs

Windows Server 2003 Family

Driver Updates

You want to automate the process as much as possible, and you want the client computers to
download the updates from a central server that you are managing. You decide to use Software

Update Services. You have several computers that you can use as the SUS server. Which of the
following computers meet(s) the requirements for being a SUS server?

Computer

Hardware/

Software Computer A Computer B Computer C Computer D
Operating  Windows Windows 2000 Windows Windows 2000
System Server 2003 Server (SP2) Server 2003 Server (SP3)

Partitions ~ FAT32with 10GB NTFS with 10GB  NTFS with 8GB  FAT32 with 8GB
free space free space free space free disk space

Additional Domaincontroller, Domaincontroller, Member server,IIS, Member server,
software most current [E most current [E most current [E IIS, most current IE

A. Computer A
B. Computer B
C. Computer C
D. Computer D

2. You were recently hired to manage the network for the Wacky Widgets Corporation. One of
your first tasks is to ensure that all of the operating systems and software that is being used is
properly licensed. Your network consists of a Windows 2003 domain that includes 10 Windows
Server 2003 servers and 250 Windows XP Professional client computers. All of the computers
within the network are located in a single site. You create a licensing strategy that specifies that
you will use a server called LicenseServer to manage all of the Windows licensing through
Administrative Tools > Licensing. You configure all of the servers with the License Logging
service. The next step you need to complete is determining which server is acting as the site
license server and changing the site license server to LicenseServer. Which of the following
options will allow you to configure the site license server?

A. Configure the site license server through the License Logging service.

B. Configure the site license server using Administrative Tools » Active Directory Sites
And Services.

C. Configure the site license server through Administrative Tools » Licensing.

D. Configure the site license server through Control Panel > Licensing.
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You are the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers have
the most current software installed for their operating systems, including:

Critical Updates and Service Packs
Windows Server 2003 Family
Driver Updates

You want to automate the process as much as possible, and you want the client computers to
download the updates from a central server that you are managing. You decide to use Software
Update Services. Which of the following client computers (with their current configuration) can
be used with Software Service Update? (Choose all that apply.)

A. Windows 98 (with most current Service Pack)
Windows Me (with most current Service Pack)
Windows 2000 Professional (Service Pack 2)
Windows XP Home Edition (Service Pack 1)

Windows XP Professional (no Service Pack)

mmo o ®

Windows Server 2003 member server (no Service Pack)

You are the network administrator for a Fortune 500 company. You are responsible for all client

computers at the central campus. You want to make sure that all of the client computers have

the most current software installed for their operating systems, including:

Critical Updates and Service Packs

Windows Server 2003 Family

Driver Updates

You want to automate the process as much as possible, and you want the client computers to

download the updates from a central server that you are managing. You decide to use Software

Update Services. The SUS server software has been installed on a server called SUSServer. You

want to test the SUS server before you set up group policy within the domain. You install

Windows XP Professional with the latest Service Pack on a test client. Which of the following

Registry entries needs to be made for the client in order to specify that the client should use

SUSServer for Windows Update? (Choose all that apply.)

A. HKEY_LOCAL_MACHINE\Software\Pol1icies\Microsoft\Windows\WindowsUpdate\
AU\UseWUServer and specify 0 for data

B. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\
AU\UseWUServer and specify 1 for data

C. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\
AU\WUServer and specify http://SUSServer

D. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\
AU\WUServer and specify SUSServer

E. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\
WUServer and specify http://SUSServer

F. HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\
WUServer and specify SUSServer
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You are the network administrator for a small company. Your company has one Windows
Server 2003 computer configured as a domain controller and 25 clients running Windows XP
Professional. You want to ensure that your server stays up-to-date through Windows Automatic
Update. Where should you configure your server to use Windows Automatic Update? (Choose
all that apply.)

A. Through the Registry

B. Through Group Policy

C. Start » All Programs » Accessories » System Tools » Windows Update

D. Start » Control Panel » System and click the Automatic Updates tab

You are the network administrator for a Fortune 500 company. You are responsible for all client

computers at the central campus. You want to make sure that all of the client computers have
the most current software installed for their operating systems, including:

Critical Updates and Service Packs
Windows Server 2003 Family
Driver Updates

You want to automate the process as much as possible, and you want the client computers to

download the updates from a central server that you are managing. You decide to use Software
Update Services. The SUS server software has been installed on a server called SUSServer. You

want to use group policy to define all of the Windows Update settings for the SUS clients. Where
would you configure this information within Group Policy?

A. Computer Configuration\Administrative Templates\Windows Components\
Windows Update

B. Computer Configuration\Windows Update

C. Computer Configuration\Administrative Templates\SUS Settings\Windows
Update

D. Software Settings\SUS Settings\Windows Update
You are the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers are

secure. You decide to use MBSA to scan your client computers for possible security violations.
Which of the following clients are supported by MBSA? (Choose all that apply.)

Windows 98 (with most current Service Pack)
Windows Me (with most current Service Pack)
Windows 2000 Professional (Service Pack 2)
Windows XP Home Edition (Service Pack 1)

Windows XP Professional (no Service Pack)

mmoowp

Windows Server 2003 member server (no Service Pack)
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You are the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers have
the most current software installed for their operating systems, including:

Critical Updates and Service Packs
Windows Server 2003 Family
Driver Updates

You want to automate the process as much as possible, and you want the client computers to
download the updates from a central server that you are managing. You decide to use Software
Update Services. The SUS server software has been installed on a Windows Server 2003 member
server called SUSServer. You want to use group policy to define all of the Windows Update
settings for the SUS clients. Which of the following template files should you use to apply the
group policy settings?

A. Wuau.adm

B. Sus.adm

C. System.adm

D. Security.adm

You are the manager of a testing lab. Your company develops applications that will run with
Windows Server 2003. As a part of your job, you install and configure servers that will be used
for testing purposes. You recently installed a Windows Server 2003 member server for testing
of alocal application, but did not register the product. After 14 days, you still have not registered
the product, and now you cannot access the server. The product key is being supplied through

your corporate IT department, but you will not have access to the information for two more
days. In the meantime, what process can you use to access local data on the computer?

A. Start the server using Automated System Recovery (ASR).

B. Boot the server using Safe Mode.

C. Start the server using the Recovery Console.

D. There is nothing you can do until you complete Windows Activation.

E. Boot the server using Safe Mode with Networking.

You are the network administrator for the computer lab at the University of Microsoft. Within
the lab 250 students use 25 computers on a regular basis. When you manage the licensing for the

lab, you receive error reports that you are out of licenses. You decide to implement license
sy p y P
groups to manage licensing. Which of the following options can be used to create a license group?

A. Administrative Tools » License Manager
B. Administrative Tools » Licensing

C. Control Panel » License Manager
D

. Control Panel » Licensing
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You are the network administrator for a small company. Your network consists of one Windows
Server 2003 server, which is configured as a domain controller, with 250 client computers.
You want to make license management as easy as possible. Which of the following utilities
should you use to configure licensing?

A. Administrative Tools > License Manager

B. Administrative Tools » Licensing

C. Control Panel > License Manager

D. Control Panel » Licensing

You are the network administrator for a Fortune 500 company. You are responsible for all client

computers at the central campus. You want to make sure that all of the client computers have
the most current software installed for their operating systems, including:

Critical Updates and Service Packs
Windows Server 2003 Family
Driver Updates

You want to automate the process as much as possible, and you want the client computers to
download the updates from a central server that you are managing. You decide to use Software
Update Services. The SUS server software has been installed on a server called SUSServer.
Which of the following options would you use to remotely manage the SUS server?

A. Start » Administrative Tools » SUSAdmin

B. Start » Administrative Tools » Software Update Services

C. From command-line through SUSAdmin

D. Internet Explorer through the URL http://yourservername/SUSadmin

You are the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers are
secure. You decide to use MBSA to scan your client computers for possible security violations.

You want to use the command-line version of MBSA to scan all of the computers on the local
network. Which of the following commands should you use?

A. mdsacli.exe /hf -n
B. mbsacli.exe /hf -n
C. mbsa.exe /hf -n
D

. mbsa.exe -n
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14. You are the network administrator for a small company. Your network consists of one Windows
Server 2003 server, which is configured as a domain controller, and 250 client computers.
You want to make license management as easy as possible. Which of the following requirements
must be met before you can manage licensing?

A. You must have the License Management service running.
B. You must have the License Logging service running.
C. You must have the License Query service running.
D. Nothing, license management is inherent in Windows Server 2003.

15. You are the network administrator for a Fortune 500 company. You are responsible for all client
computers at the central campus. You want to make sure that all of the client computers are
secure. You decide to use MBSA to scan your client computers for possible security violations.

You want to use the command-line version of MBSA to scan your computers based on IP
address. Which of the following commands should you use?

A. mbsacTli.exe /hf -1 XxxXX.XXXX.XXXX.XXXX
B. mbsacli.exe /hf -ip Xxxxx.XXXX.XXXX.XXXX
C. mbsa.exe /hf -ip xxxX.XXXX.XXXX.XXXX
D

mbsa.exe /ip XXXX.XXXX.XXXX.XXXX
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Answers to Review Questions

1.

C. In order to act as a SUS server, the following requirements must be met: the server must be
running Windows 2000 Server with Service Pack 2 or higher or Windows Server 2003. The server
must be using Internet Explorer 5.5 or higher. The server must have the most current security
patches applied. The server must be running Internet Information Services (IIS). The server must
be connected to the network. The server must have a NTFS partition with 100MB free disk space
to install the SUS server software and 6GB of free space to store all of the update files.

B. You can view and configure the site license server by selecting Start » Administrative Tools >
Active Directory Sites And Services. The Active Directory Sites And Services dialog box will be
displayed. Expand Sites and click Default-First-Site. In the right-hand pane, you will see Licens-
ing Site Settings. Double-click License Site Settings and the Licensing Site Setting Properties
dialog box will appear. In the lower half of the dialog box, under Licensing Computer, you will
see the server that has been designated the site license server. By default, the licensing server is
the first domain controller installed in the site. You can change the site license server through the
Licensing Computer dialog box.

C, D, F. The following clients can use Software Update Services: Windows 2000 Profes-
sional (with Service Pack 2 or higher), Windows 2000 Server (with Service Pack 2 or higher),
Windows 2000 Advanced Server (with Service Pack 2 or higher), Windows XP Home Edition
(with Service Pack 1 or higher), Windows XP Professional (with Service Pack 1 or higher), and
Windows Server 2003 (all platforms). These clients use a special version of Automatic Updates
that is required by Software Update Services.

B, E. The Registry key HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\
WindowsUpdate\AU\UseWUServer can be set to 0, which uses the public Windows Update
server, or 1, which specifies that you will specify the server for Windows Update in the HKEY_
LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate key. The
WUServer key sets the Windows Update server using the server’s HTTP name, for example,
http://intranetSUS.

D. You configure Automatic Update by selecting Start » Control Panel » System and clicking
the Automatic Updates tab. You can configure the schedule that your computer will use to scan for
updates and how updates should be applied to your computer.

A. You can configure Windows Update settings that are used in conjunction with Software
Update Services (SUS) through group policy. Within Group Policy, you edit Computer
Configuration\Administrative Templates\Windows Components\Windows Update.

C, D, E, F. MBSA will scan the following clients: Windows NT 4, Windows 2000, Windows XP,
and Windows Server 2003. Service packs are not required to use MBSA.

C. There are security templates called Wuau . adm (for Windows 2000 Server), which is available
through the Software Update Services installation, and System. adm (for Windows Server 2003),
which automatically applies the group policy settings that are used by SUS.
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B. After Windows Server 2003 is installed, you will have 14 days to activate the license. After the
14-day grace period expires, you will not be able to restart Windows Server 2003 normally if
you log out of the computer or if the computer is restarted. However, you can start Windows

Server 2003 in Safe Mode (not Safe Mode with Networking). With Safe Mode, you will not have
any networking capabilities, but you will have access to any folders or files located on the server.

B. Some environments have special considerations and will require you to create license
groups for Per Device and Per User licensing. You would create licensing groups if you have
more than one user using a computer—for example, if your organization has workers in shifts
and users from different shifts all share a computer. Another possibility might be that you have
many users who share many devices—for example, students working in a school computer lab. To
create a license group you would use Administrative Tools » Licensing. From the main menu,
you would then select Options » Advanced » New License Group.

D. If you only have one server, then you will be using Per Server licensing in a non-enterprise
environment. In this case, the preferred way to manage licensing is through Control Panel »
Licensing. In Enterprise Licensing, licensing considerations must be accomplished through
Administrative Tools » Licensing.

D. Toremotely manage a SUS server, openhttp://yourservername/SUSadmin from Internet
Explorer.

B. If you use MBSA from the command-line utilitymbsac11 . exe, there are several options that
can be specified. You type mbsac1i.exe /hf (from the folder that contains mbsac1i .exe)

and can then customize the command execution with an option such as -n, which specifies

that all of the computers on the local network should be scanned.

B. 1If the License Logging service is running, Administrators can manage and track licensing
through the Licensing option in Control Panel or the Licensing utility in Administrative Tools.
If you were managing licenses for a single server, you would use the Licensing option in Control
Panel. If you were managing licenses for an enterprise environment, you would use the Licens-
ing within Administrative Tools.

A. If you use MBSA from the command-line utility mbsac1i . exe, there are several options
that can be specified. You type mbsacli.exe /hf from the folder (Drive: Program Files\
Microsoft Baseline Security Analyzer) that contains mbsac1i .exe and can then customize
the command execution with an option such as /hf -7 xxxx. xxxx . xxxx . xxxx, which specifies
that computers with the specified IP address should be scanned.



