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Chapter 1

Getting to Know VIZ

WELCOME TO Mastering Autodesk VIZ 2005. Once again, Autodesk VIZ 20035 benefits from the
development of its sister product, 3ds max, to give architects and other design professionals an indis-
pensable design tool. VIZ 2005 gives designers cutting edge rendering technology, easier-to-use
architectural materials, improved communication with other software, enhancements to modeling
and animation tools, and improvements in the user interface.

This chapter introduces some of VIZ 2005’s special features and then gets you started working
with the VIZ 2005 interface.

¢ Introducing VIZ 2005 Features

¢ Getting Started

Touring the Interface

Working with Objects

Getting the View You Want

Working with the Custom UI and Defaults Switcher
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Introducing ViZ 2005 Features

With the new Architectural material (Figure 1.1), it has become far easier to render realistic real-
world materials in VIZ 2005. Featuring a preset list of commonly used building surfaces, this new
material type will certainly save you time texturing your models.

NOTE  Architectural is now the default material in VIZ 2005.

If you're an AutoCAD or Architectural Desktop user, you'll find that importing and linking your
building data into VIZ has been completely overhauled and greatly improved. A new Layer manager
has been designed to work seamlessly with your existing AutoCAD and/or Architectural Desktop

models and helps you to maintain the same project organization, materials, and layer standards.
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VIZ 2005 now includes mental ray, which was formerly sold as a separate high-end rendering plug-
in. mental ray is a film-quality rendering solution, fully integrated with VIZ 2005, that allows the
most realistic rendering possible today, including global illumination, caustics, soft shadows, area and
volume lights, ray tracing, reflections and refractions, motion blur, and depth-of-field effects. Mental
ray includes a robust shader language for those with a programming bent, and a highly efficient ren-
dering pipeline, where incremental changes in an animation are the only portions of the frames that
get rendered. In addition, VIZ 2005 now supports High Dynamic Range Image (HDRI) files, keep-
ing up with the cutting edge in computer graphics.

The radiosity rendering system that was introduced in VIZ 4 is still available, and it remains a time-
tested way to create accurate study models of a design by inserting light-fixture specifications. By sim-
ulating the way light works in the real world, radiosity rendering takes much of the guesswork out of
lighting design. With VIZ 2008, you won’t need to wait until a project is built to see if your lighting
design works the way you intended. Natural outdoor lighting has also been improved to give you a
realistic representation of your design.

If your computer is connected to a computer network, you can harness processor time from the
other computers to reduce the time it takes to render a single image or even an entire animation. A
new stand-alone command-line rendering tool with access to rendering presets (also available in VIZ
itself) allows for more efficient unattended processing of your rendered artwork. As with earlier ver-
sions of VIZ, you can also take advantage of multiprocessor systems to improve speed.

Autodesk VIZ 2005 is also designed to take advantage of the Internet both as a reader and pub-

lisher. With its Asset Browser and an Internet connection, you can quickly acquire 3D models and
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props that are available on the Web. You can also publish your own interactive content to the Web
in the form of wraparound panoramas, virtual reality worlds, and Shockwave 3D models. Render to
Texture, also known as Texture Baking, is a new feature that allows you to “bake” your beautifully
lit rendered views into surfaces for use in real-time interactive models.

Finally, VIZ 2005 offers a set of improvements based on user feedback. The interface has been
updated to match the improvements recently made to VIZ's sophisticated sibling, 3ds max 6. The
animation Track view has been better organized by being split into two specialized editors, the Dope
Sheet and the Curve Editor. There are numerous improvements to modeling tools including enhance-
ments to Editable Splines, patches, and polys. In addition, the new Shell modifier offers you a new
way of modeling by giving thickness to surfaces.

Getting Started

Although many of VIZ’s components are typical for a Windows program, quite a few are unique. To
begin exploring the VIZ 2005 interface, start the program by doing one of the following:

¢ Double-click the Autodesk VIZ 2005 icon on the Desktop.
¢ Choose Start » Programs » Autodesk VIZ 2005 > Autodesk VIZ 2005.

You'll see a variety of components in the VIZ window (see Figure 1.2)—some that are familiar
and others that are not.
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At the top, you see a typical menu bar and toolbar. There are two new floating toolbars called Lay-
ers and Extras. The Tab panel from VIZ 4 is gone, thus simplifying the interface. In the center, you
see the viewport area, which currently shows a perspective view. At the lower right corner of the
screen, you see the viewport navigation tools for adjusting your views in the main viewport. You also
see the time controls for creating animations, the prompt line and status bar, and something called the
MAXSecript Mini Listener (for creating macros). On the right side, you see the Command Panel,
which contains nearly all the tools you'll use to create and edit objects in VIZ. Let’s take a closer look
at each of these components.

Touring the Interface

VIZ offers a wealth of tools, and their sheer number can be overwhelming. To get a basic under-
standing of the VIZ window, let’s look at each of the window components individuaﬂy, starting with
the menu bar.

The Main Menu Bar

At the top of the screen is the main menu bar. Here, you find the typical Windows commands for
file maintenance, as well as commands specifically for Autodesk VIZ 2005.

The options in the menu bar are organized in the same way as they are in most other Windows
applications. Clicking an option issues a command, and you're expected to take some action. An
option that’s followed by three periods, called an ellipsis, opens a dialog box, usually to allow you to
make changes to settings related to the option. An option with a right-pointing arrow displays more
options in what is called a cascading menu.
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Try out the menu bar by taking a look at the Units Setup dialog box.
1. Choose Customize » Units Setup. The Units Setup dialog box displays.

2. Select the US Standard radio button, and make sure that Feet w/Decimal Inches is selected
below it, and that the Feet radio button is selected for Default Units.
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3. Click the System Unit Setup button and you will see another small dialog box. Make sure 1
system unit is set equal to 1 inch. Do not change anything else in the System Unit Setup dialog
box and click OK twice to close both dialog boxes.
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By checking the Units Setup dialog box, you ensure that in future exercises, you’H be working with
the same units that are discussed in this book.

NOTE  Autodesk VIZ 2005 is something of a chameleon. It can change its appearance, depending on the focus of your
modeling needs. If your VIZ 2005 window doesn’t look the way it does in the figures in this book, choose Customize
> Revert to Startup Layout. You'll see a warning message telling you that any user interface (UT) changes you have made
will be lost. Click OK to set up your VIZ windows to match the interface you see in this book.

The Main Toolbar

Just below the menu bar is the main toolbar. The tools on this toolbar offer tool tips to help you
remember their purpose.

To the far left of the toolbar are the Undo and Redo options.

[ |
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Next is a set of tools for selecting objects. These selection tools let you select objects by clicking
them or by selecting them by name. You can also set the method for selecting objects by using a selec-
tion window, which provides a way of indicating a selection by placing a rectangle, circle, or other
border around the objects.

Al ML

R

To the right of the selection tools are the transform tools. This set of tools lets you move, rotate,
and scale objects. You can also choose the reference coordinate system, set the center of the transform
using the pivot options, use different snap options, work with named selection sets, and use tools to
mirror and align objects.

$ O Efver  =[B8] 4 |6 & * | x| RILRS

The next group of tools to the right of the layer tools are the materials and rendering tools. The
materials tools give you control over the appearance of objects. With these tools, you can create color,
texture, opacity, and other material characteristics, and then apply these characteristics to objects in
your model. You can also open the new render dialog, select the render type, and perform a quick ren-
der with these buttons.

=B85 D view b

The rendering tools give you control over the output of your Autodesk VIZ 2005 model. Unlike
output from most applications, output from VIZ 20085 is most likely to be image, animation, or
web3d files. The rendering tools let you set the type and size of output, from single, Iarge format stills
to Video—ready animations,

TIP  If you’re working with a screen resolution of 1024X 768 or less, you won't see all the tools on the main toolbar.
Some of the tools are off the screen to the far right. To access these tools, place the cursor on the toolbar so that a hand icon
appears, and then click and dmg the toolbar to the rig})t, The hidden tools will emerge. You can also click the Rendering
tab to expose all the rendering tools. The smallest supported resolution in VIZ 2005 is 1024X 768, but the recom-
mended resolution is 1280X960 or higher.

Docked and Floating Toolbars

In addition to the main toolbar, you see two “ﬂoating” toolbars sitting on top of the perspective view
(see Figure 1.2) and one that is hidden. You can open hidden toolbars by right-clicking on a blank
part of the main toolbar. A context menu will appear listing the available toolbars. Let’s take a quick
look at the visible ﬂoating toolbars.

Two toolbars float over the Perspective viewport, the Layers toolbar and the Extras toolbar. As
with most toolbars, you can move these ﬂoating toolbars to the side or hide them altogether to gain
better access to objects in the main viewport.
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Layers are like overlays that help you organize the objects in your model. If you are an AutoCAD
or Photoshop user, you should have an idea of how layers work. You'll learn more about layers in

Chapter 5.
Er—
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You can dock the floating toolbars, or float the docked toolbars. You can try the following exer-
cise to see how to change the location of toolbars:

1. Click and drag the title bar of the Layers toolbar so that the toolbar is below the main toolbar
(see Figure 1.3). The Layers toolbar appears ghosted as a horizontal outline just before you

release the mouse button.

FIGURE 1.3
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2. When the outline is in the position shown in Figure 1.3, release the mouse button. The Layers
toolbar is now in a docked position.

3. Dock the Extras toolbar just to the right of the Layers toolbar (also just under the main toolbar).
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4. Right-click the two vertical lines (called the toolbar handle) on the left side of the Extras tool-

bar to open the ShOI‘tCLIt menu.
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TiP  You can also open the toolbar shortcut menu by régbt%lz’cking a blank part of the interface. For example, try rngt~
clicking next to the Extras toolbar and you'll see the shortcut menu that allows you to open or close any of the toolbars
by name.
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5. Select Float from the shortcut menu. The Extras toolbar returns to its floating position.
Another way to do this is to drag the toolbar by its handle down into the viewport.

6. Right-click the title bar of the Extras toolbar and notice that the Axis Constraints toolbar is
unchecked in the shortcut menu.
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7. Select the Axis Constraints toolbar from the shortcut menu to open it, and then dock both the
Extras and Axis Constraints toolbars to the right of the already docked Layers toolbar as
shown in Figure 1.4.
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In this brief exercise, you learned how to dock and float toolbars, and how to access the shortcut
menu where you can toggle the toolbars on and off.

Toolbar Flyouts

Youmay have noticed that some of the tools in the main toolbar show a small arrow in the lower right
corner of the tool icon.
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That arrow indicates that the tool is one of several offered in a ﬂyout. A ﬂyout is like a graphical
version of options in a menu bar. If you click and hold a tool that’s part ofa ﬂyout, you see a set of
other tools appear. For example, if you click and hold the Select and Uniform Scale tool, two addi-
tional tools appear.

Animation  Graph Editors |

OHCG you select an OptiOl’l from a ﬂyout, it becomes the default button that you see in the toolbar.
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The Viewport

At the center of the window is the viewport (see Figure 1.5). This is where you'll be doing most of your
modeling work. In a blank file, the viewport shows a grid that you can use as a reference for orienta-
tion and size. The grid is labeled with distances in the current, default unit setting, The labels also
indicate the X and Y axes.

FIGURE 1.5

A typical Perspective
viewport in the
opening screen

If you look in the lower left corner of the viewport, you see the world axis that indicates the ori-
entation of the X, Y, and Z axes. The world axis helps you get your bearings when looking at other
types of views.

Currently, the viewport shows the perspective view, as indicated by the label in the upper left cor-
ner. You can also tell that it’s a perspective view by the way the grid squares get smaller and converge
in the distance. As you’ﬂ see toward the end of this chapter, you can conﬁgure and view your model
in a variety of ways, depending on your needs.

Tools for Working with the Viewport

At the bottom of the window, there are several other options that are grouped into four sections: the
status bar, the prompt line, the time controls, and the viewport navigation tools (see Figure 1.6). Most
of these tools affect the viewport, either by modifying the display of the viewport directly or by affect-

ing the way you interact with objects within the viewport.

%
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FIGURE 1.6
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navigation tools

The viewport navigation tools give you control over the main graphic display in the center of the
window. With these tools, you can zoom and pan over the display, as well as alter the viewpoint of
your model. You can also switch between multiple views and a single view. Try the following:

1. Click the Min/Max Toggle button in the far lower right corner of the window. This is a tool
you'll be using often. You can also press Alt+W on the keyboard.

Min/Max Toggle

The graphic display changes to display four separate viewports. Each viewport shows a differ-
ent type of view, as shown in Figure 1.7. Notice that the viewports are labeled in their upper

left corners.

FIGURE 1.7

Four viewports,
showing the top, left,
front, and perspec-
tive views
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2. Right-click the upper left viewport, labeled Top. Notice that the border of the Top viewport
becomes highlighted in yellow.

3. Click the Min/Max Toggle tool again. Now the Top viewport fills the graphic area. Notice

how you can quickly expand the view of a viewport to see more detail.

4. Click the Min/Max Toggle tool again. Then right click anywhere within the Perspective

Viewport.
5. Click the Min/Max Toggle tool to restore your original window setup.

You've just seen how you can expand the graphic area into multiple viewports showing the top,
front, left, and perspective views. Several other views and viewport arrangements are available, as
you'll see later in this chapter.

TIP  You can set the current, active viewport to display a top, front, or left side view by pressing the T, I, or L key.
You can also press B for the bottom view. Pressing P will display the perspective view, and pressing U will display an
isometric user~defined view. If you bave added a camera, you can press C to select from a list of camera views. The hotkeys
of R for right view and K for back have been removed from the defaults in VIZ 2005. You can easily assign your own

hotkeys to commands; this procedure is covered later in the chapter.

To the left of the viewport navigation tools are time control tools. These tools give you control
over the animation functions of VIZ. Here, you can set your creations in motion by selecting the
length of time for your animation, as well as setting the precise location of objects within that
time frame.

Auta Key ISeIected 'l e | -l El (13 |bh|
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Near the bottom center of the interface there is a Iarge button with the symbol ofa key on it and

two smaller buttons to the right that are used to create animation keyframes, called keys.

The long horizontal elements across the bottom of the viewport are the time slider and track bar, used
for animation. You can hide the track bar to save space on the screen. Choose Customize » Show UI »
Show Track Bar to toggle this part of the interface off until you’re ready for making animations.

Just to the left of the animation controls are the transform type-in text boxes. This area displays
the location of your cursor in X, Y, and Z coordinates. It also displays other types of data, depending
on your current activity. For example, if you’re rotating an object, the coordinate readout displays the
rotation angle of the object being rotated. If you’re scaling the data, these text boxes will show per-
centages.

In addition to the transform type-ins, there is a Grid panel, which may lie hidden to the right if
your display is set to low resolution. To find it, place the cursor on the vertical bar just to the left of
the prompt line until you see a double—pointed arrow,

s s mA

| Click and drag to select and move objects

%
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When you see the arrow, click and drag to the left. The Grid panel will be revealed to the right

of the transform type-ins.
Giid=10.0
[ add Time Tag

You can display a grid in the current, active viewport by clicking this panel. Right-click the panel
to open a dialog box that lets you set the grid spacing and other grid parameters.

Finally, to the far left at the bottom of the VIZ window is the MAXScript Mini Listener. MAX-
Seript is a language that allows you to create custom macros in Autodesk VIZ 2005. A macro is like
a prerecorded series of instructions. The MAXScript Mini Listener serves two functions: the pink
area displays your activity when the MAXScript MacroRecord function is turned on, and the white area
provides a space where you can enter commands through the keyboard.
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Getting to Know the Command Panel

You'll be using the Command Panel for most of your work in VIZ. If you're an experienced
AutoCAD user, you might think of the Command Panel as the equivalent of the AutoCAD command
line; it’s a single entry point for nearly all of the program’s functions. The Command Panel offers
nearly all the tools for creating and editing in VIZ.

Across the top of the Command Panel, you see a set of six tabs, each displaying an icon.

v @ 2@ @ T||

From left to right, the tabs are Create, Modity, Hierarchy, Motion, Display, and Utilities. If you place
the cursor on a tab, you'll see a tool tip displaying the name of the tab. When you click a tab, the func-
tions relating to the tab appear in the rest of the Command Panel. Here’s a brief rundown of what
each tab offers:

Create Allows you to create two-dimensional and three-dimensional objects. You can also cre-
ate light sources, cameras, and helper objects that are used to determine distance and relationships
between objects. Light sources, cameras, and helpers are objects that don't appear when your view
is rendered.

Modify  Gives you control over the dimension and shape of your objects. You find tools to
extrude, twist, and bend your objects. You can also control methods for applying material defini-
tions to objects (called mapping coordinates) in this tab.

Hierarchy  Offers a set of tools aimed primarily at animation. The options in this tab let you
build relationships between objects to simulate joint movement or to constrain motion of one
object in relation to another. It also offers a way to control the location of an object’s pivot point.

Motion Another tab that gives you control over animation. Here, you can control the actual
motion of objects over time and view the trajectories of objects.

4~ 40
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Display  Lets you turn objects on or off in your model. There may be times when you don’t want
a particular object visible while you render your model or while you're editing a complex model
full of objects. Display lets you temporarily hide objects from view and lock them out from being
selected.

Udlities A kind of catchall tab that provides access to special features and plug-ins. This is
where you find the Camera Match utility that lets you match your model view to a photograph.
You can also get access to the MAXScript customization features in this tab.

TIP  You can move the Command Panel just like any toolbar or close the panel entirely by clicking the Close button (the
one with the X, in the upper right corner of the window). To bring the Command Panel back, right-click the blank area
of any toolbar and then select Command Panel from the shortcut menu. (You can also right~click the Command Panel’s
title bar to dock the panel on the left side of the screen.)

Understanding VI1Z’s Tools

There are a few ways of working in VIZ that are a bit unusual for a Windows program. In this section,
you'll explore the Create tab of the Command Panel as a way to understand some of VIZ's quirks.
There aren’t many, but understanding them now will make it easier for you to learn how to use the
program.

GETTING TO KNOW SCROLLING PANELS AND ROLLOUTS
Autodesk VIZ 2005 has a rich set of creation and editing tools—so many, in fact, that VIZ's program-

mers had to come up with a way to get to them easﬂy without making the program too arcane. T'wo of
these tools help you navigate its interface: the strolling panel and the rollout. A scroﬂing panel is an area that
can be scrolled up or down using a hand cursor. A rollout is a set of tools that can be opened or closed,
much like a drawer in a dresser. Let’s start by looking at how a scroﬂing panel works:

1. Click the Create tab of the Command Panel. Notice the row of icons just below the title of the
tab. These icons are buttons, or tools, that offer different categories of objects.

0™ v & u %

2. Place the cursor over the tool that looks like a movie camera. Notice that a tool tip displays,
offering the name of the tool.

3. Click the Camera tool. You see the options change below the tools.
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4. Click the Target button. A set of additional options appears. Although it may not be obvious,
these options extend beyond the bottom of the Command Panel.

5. Move your cursor down to a blank spot in the Command Panel. The cursor changes to a hand.

6. Click and drag upward with your mouse. Notice that the options in the Command Panel scroll
upward, following the motion of your mouse. This is an example of a scrolling panel. This
scrolling action exposes the rest of the options in the lower portion of the Command Panel.
Release the mouse button at any time once you've seen how this scrolling action works.

7. Place the cursor on a blank area again so that the hand cursor displays. Then click and drag
downward to view the Target and Free buttons under the Object Type bar.

8. You can also scroll the Command Panel by rolling the wheel on your mouse or by dragging
the dark gray slender vertical scroll bar on the right side of the command panel. Try both of
these methods.
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9. Another way to see more of the Command Panel is to increase its width by dragging the ver-
tical border between the Command Panel and the Viewport. Position your mouse along this
edge and drag to the left and expand the Command Panel to two and then three columns.
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10. The advantage to having a three-column Command Panel is obvious—you can see all the con-
trols within the Command Panel at once. The disadvantage is equally apparent—the viewport
becomes much smaller. Drag the Command Panel back to one vertical column to give yourself
the maximum amount of screen space. It’s better to learn how to scroll within the Command
Panel than to sacrifice valuable viewport space.

In this exercise, you see that the entire set of options can be changed by clicking a single tool. You
can also see that the set of tools can extend beyond the bottom of the Command Panel. You can scroll
the options upward or downward within the Command Panel in several ways. This allows VIZ to
offer a wide variety of options within the limited space of your display.

%

. ©
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The main toolbar also acts like a scrolling panel whenever a portion of the toolbar extends beyond
the screen area. For example, if your screen resolution is 1024X768, a portion of the Rendering tool-
bar isn’t visible to the right of the screen. If you place the cursor on a blank area of the Rendering toolbar,
it turns into a hand cursor. You can then click and drag to the left to display the additional tools.

When you clicked the Target button in step 4 of the preceding exercise, a set of options appeared
under a button labeled Parameters. There are three other buttons, labeled Depth of Field Parameters,
Object Type, and Name and Color. Notice the minus (—) sign to the far left of these buttons. These
buttons are called rollouts. They let you open and close a set of options to get them out of the way, or
to roll them out for use. Tty the following:

1. Click the rollout labeled Parameters. The options below the Parameters rollout disappear.
Also notice that the minus (—) sign to the left of the rollout changes to a plus (+) sign. This
indicates that the rollout is in its closed state. The plus tells you that there is more information
inside, waiting to be rolled out.

[+ Parameters |

2. Click the rollout labeled Name and Color. It also closes and displays a plus (+) sign to the left.

Right-click a black part of the interface within any one of the rollouts and you'll see a context
menu. Select Close AlL

w2 @@ T||
(s e AR
e —
Clos= Rolout
E openall

I + Obiect Trps
[« Mame and Color
([ Parameters
[ « Depth of Fisld Paramsters

+ Reset Rollout Order
I 1lze Tamel Digarce T

3. Notice that the Parameters and Depth of Field Parameters rollouts closed but Object Type
and Name and Color remained open. This is because all objects on the Create Panel have
Obj ect Type and Name and Color rollouts, and these always remain open. Any additional roll-
outs belong to the object you have chosen to create and can be controlled with this context
menu. Try dragging the Depth of Field Parameters rollout above the Parameters rollout.

AuloGnd

Taigel Free ]
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kg ik
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4. You will see a horizontal blue bar appear with an image of the rollout you are dragging ghosted.
When you release the mouse, the rollout you are dragging gets docked where the blue bar was.
Now the Depth of Field Parameters rollout should appear above the Parameters rollout.

H - Dbjct Tupe !
Aulofind [

[ Tae: [ BEERR
[—

1] + Depth of Field Parameten:
[ Faamser 1

5. Click the Parameters and Depth of Field Parameters rollouts again to display the options.

Now you can see how easy it is to control and customize the Command Panel interface. In this and
later chapters, you'll explore the rollouts that appear in the Command Panel and throughout the
program.

CREATING OBJECTS AND SETTING THEIR PARAMETERS

By now, you've seen most of VIZ’s interface and how it functions. However, you will want to know
about a few more tools and methods before you really delve into using VIZ. In the following exer-
cises, you'll get a chance to create a simple object, and in the process, you'll be introduced to a few
new tools.

1. In the Create tab of the Command Panel, click the Geometry tool at the top of the panel.

W@ &@m Tl
[O@ * & o %

You see the Object Type rollout with a set of object types.

AutaGid T
Box Cone
Sphere: GeaSphers
Cylindes Tube
Tans Puramid
Tezpal Plane |

2. Click the Box button. Additional rollouts appear in the Command Panel. These include
Creation Method, Keyboard Entry, and Parameters. Notice that a message displays in the
prompt line at the bottom of the screen that says, “Click and drag to begin creation process.”
Also, the cursor in the graphic area displays as a cross, telling you that you're in object crea-
tion mode.

3. Place the cursor at the center of the graphic area at coordinates 0,0 and click and drag diago-
nally to the upper right corner of the screen—don’t release the mouse button just yet. As you
move the mouse, a rectangle follows your cursor. Notice that the values in the Length and
Width input boxes in the Parameters rollout change as you move the mouse.

4~ 40
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4. Place the cursor so that the rectangle looks similar to the one shown in Figure 1.8, and then
release the mouse button. (You don’t need to match the rectangle in the figure exactly.) Now,
as you move the cursor, the rectangle changes in height. Notice that the Height parameter in
the Parameters rollout also follows the change in height.

FIGURE 1.8
The rectangle so far

5. Adjust the height so that the Height parameter shows about 20 and click your mouse. The box
is now fixed at the height you selected. It should look similar to Figure 1.9.

FIGURE 1.9
The finished box

You've just created your first object in VIZ, and in the process, you've seen how the dimensions
of an object are reflected in the Parameters rollout. Once you've created an object, you can continue
to modify its parameters, as the following exercise demonstrates.

1. In the Parameters rollout, locate the Width input box and click the upward-pointing arrow to
the right of the box several times. Arrows like this one are called spinners, and they allow you
to graphically adjust the value of the input box they are associated with. Notice that the box
in the perspective view begins to widen as the value in Width input box increases.

[- Parameters 1

Length[aTZ721" 2|

wWidth:[337 63z 'ﬁ

Height:| 24'9139" 3
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2. Click and hold down the left mouse button while pointing to the upward arrow of the Width
spinner. Notice that the box continues to grow in width as you hold down the mouse button.

3. Right-click the spinner arrow. The box shrinks in width to 0. Right-clicking the spinner

changes the spinner value to its default, which is O in this case.

4. Click and drag the mouse upward from the Width spinner. The box gradually grows in width.
Click and drag downward, and the width shrinks back down.

5. Click and drag the Width spinner upward until the cursor reaches the top of the screen. Then
continue moving the mouse upward. Notice that the cursor reappears at the bottom of the
screen. This circular action of the spinner lets you scroll continuously without being limited by
the screen area.

TIP  While adjusting a spinner, you can immediately undo any changes you make by right~clicking the mouse while still
holding the left mouse button. This allows you to quickly experiment with spinner settings while you work.

You've just seen how you can change the parameters of an object by using the spinner. Now let’s
take a look at the old-fashioned way of entering values into input boxes.

1. Click the Length input box in the Parameters rollout and type 20.J. Notice how the box’s
length changes.

2. Press the Tab key. Notice that the Width value is now highlighted.

Length[aTZ21" 2|
it [EERNEEEN 2|
Height[283.139" 2]

3. Type 20 for the width and press Tab again. The Height value is highlighted.

4. Enter 20 again. The box is now a cube 20 units square.

NOTE  You can also create a cube dirfctly by selming the Cube check box in the Creation Method rollout.

If there is a series of related input boxes—such as the Length, Width, and Height boxes in the pre-
vious exercise—the Tab key lets you advance from one value to the next. You'll find that numeric
input boxes and spinners are quite common throughout Autodesk VIZ 2008.

Tip  If you hold down the Ctrl key while you move a spinner, the rate of c})ange in the spinner value increases. The Alt
/eey has the opposite effect, detreasing the rate of flmnge. The bigber the numeric value in the spinner, the faster the rate of
clnmge, and vice versa. Also, if you r{gbt-fli{k a spinner, it sets the value to zero.




%{% i% 4343book.fm Page 19 Friday, June 18,2004 2:36 PM

A

—

'WORKING WITH OBJECTS | 19

Working with Objects

Now that you've seen the main elements of the VIZ interface, let’s take a look at how you interact
with objects in the viewport. You'll start by looking at a way to move the box you've just created.
Then you'll learn how you can view your box from different angles.

Selecting and Moving Objects

VIZ's basic editing tools are simple and straightforward, although it may take a little explaining for
you to grasp the finer points. As with most graphics programs, you use a selection tool to select
objects. This tool is typicaﬂy shown on the toolbar as an upward-pointing arrow that looks like the
standard Windows cursor.

1. Click the Select Object tool in the main toolbar.

Z 2005 pre-release NFR

Views Create Modifiers o

'l Ep iV
q [oelect Objert]

2. Click in a blank area of the viewport. This clears any selections that may currently be active.

3. Move the cursor over the box. Notice that the cursor turns into a plus (+) sign. This tells you
that the cursor has found a selectable object.

4. Click the box. A graphic displays, showing the X, Y, and Z orientation of the box in relation
to the viewport. Also notice that marks like 3D corner marks appear at the corners of the box.
These are called selection brackets, and they indicate graphically the objects that are selected.

[\j

With the box selected, you can go to the Modify tab of the Command Panel and edit its proper-

ties, Or you can use any number of other editing tools to affect the box.
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Let’s continue by looking at one of the more basic editing tools you'll use—the Select and
Move tool.

1. Click the Select and Move tool. Notice that the graphics indicating the box selection change
and new ones appear.

Aodifiers  Animation  Graph Edit
LLER [ O Bl Vew
:I g & QSeIect and Movek

2. Place the cursor on the box. It changes into the Select and Move icon.

3. Click the box. A graphic known as the Move gizmo displays, showing the X, Y, and Z orien-
tation of the box in relation to the viewport. Selection brackets also appear at the corners of

the bOX.

4. Place the cursor on the Z axis handle of the Move gizmo; the blue arrow represents the Z axis.
Notice that the Z axis label is highlighted in yellow and the X axis label turns back to red.
When you move the cursor away from the Z axis, the X axis is highlighted again and the Z axis
returns to blue.

The yellow highlighting shows you which axis is currently active. The Y axis is the default con-
straint direction. If you look at the Constraints toolbar to the left of the VIZ window, you’ll
see that the Y axis button is selected. As you’ve seen in this step, you can select an axis to con-
strain just by placing your cursor on the axis coordinate arrow.

TP  The axis that is highlighted in yellow is the last axis constraint that was used. For example) if you transform an
object in the Y direction, the next time you go to transform an objeft, the Y axcis will be highlighted.

5. Place the cursor on the XY plane handle of the Move gizmo. Notice that the XY plane handle
1s highlighted n yellow. Click and drag the box on the grid. The box now moves in the XY

plane. When you click and drag the X arrow, movement is constrained along the X axis only.

6. Click and drag the blue Z coordinate arrow upward. Now, movement is constrained in the Z
axis, away from and toward the grid. As you may guess, clicking and dragging the green Y coor-
dinate arrow constrains movement in the Y axis.

7. Click the Restrict to XY Plane tool in the Constraints toolbar.

[x ¥ z
3
Restrict ko ¥ Plane

8. Click and drag the box slowly in a circular motion, taking care not to click a coordinate arrow.
(You still must have the cursor over the box.) If you click an object in a location other than
the coordinate arrows, but still on the object, you can freely move the object in the XY plane.
Notice that the coordinate location of the object is displayed in the status line just below the
drafting tools.

4~ 40
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CONSTRAINING MOTION

The tools in the Constraints toolbar constrain the motion of an object in the X, Y, or Z axis. For example,
to constrain motioninthe X axis, clickthe Select and Move tool, and then click the X tool in the Constraints
toolbar. The selected object’s motion is constrained to the X axis. In 3D Studio VIZ 3 and before, this was
the only method available to constrain motion.

Another important function that the Constraints toolbar offers is the selection of the default free motion
plane. In step 8 of the preceding exercise, you were able to move the box freely in the XY plane, but you
were constrained to that plane. The Constraints toolbar lets you select the default plane to which you are
constrained. The Restrict to XY Plane tool is a flyout offering three options: XY, YZ, and ZX. You can select
the plane in which you want to constrain motion by selecting one of these three options. The XY option is
fine for nearly all of your work; every now and then, though, you’ll want to use one of the other options, so
it’s good to be aware of this tool. You can also access these constraint planes simply by dragging the appro-
priate parts of the Transform gizmo—it’s very intuitive.

Finally, a tool that is related to the transform tools is the Selection Lock Toggle tool.

_EQE w[o7sa &
ck TdSelection Lock Togale

This tool helps prevent the accidental loss of a selection due to a mouse click. It also allows you to use the
transform tools without actually placing the cursor on the selected objects. You can toggle this tool on and
off by clicking it or by pressing the spacebar while in a selection mode.

As you see, moving an object in VIZ is fairly straightforward. But what if you want to move an
object a specific distance or to a known position? The foﬂowing exercise demonstrates how this
is done.

1. With the box still selected and the Select and Move tool still active, click the Absolute/Offset
Mode Transform Type-In button at the bottom of the VIZ window.

:EX:IDID'D” slvfone

am [Ciffset Made Transform Type-In|

The tool changes to show that the Offset mode is active.

i :*Bx:|u'u" . QY:ID'D“. jz:|u'ﬁ" H

ranzform |O‘Ffset Made Transfarm Type-Inl

When the Absolute/Offset Mode Transform Type-In button is in the “up,” or Absolute,
mode, you can enter the specific coordinates of the point where you want to move your object.
When it’s in the “down,” or Offset, mode, you can enter a relative distance from the object’s
current location.

2. Click in the X input box in the coordinate readout and type 10.. The box moves 10 units to
the right.

%
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New!

3. Click and drag the Z axis coordinate readout spinner upward. The box moves vertically.

4. Click the Absolute/Offset Mode Type-In button to switch to Absolute mode. Then click in
the Z coordinate readout input box and enter 1.1. The box moves so that its base is exactly at
1 for the Z coordinate.

5. Right-click the X coordinate readout spinner. Remember that right-clicking a spinner con-
verts the value associated with the spinner to its default, which is O in this case. Notice that the
box moves to O for the X coordinate.

6. Right-click the spinners for the Y and Z coordinates in the coordinate readout. The box moves
to the center of the screen at the origin (coordinates 0,0,0).

Just as with the spinners in the Command Panel, the transform type-in spinners let you set values
by clicking and dragging. You can also return to the default values of zero by right-clicking the spin-
ners. The spinners in the coordinate readout appear when you turn on the Select and Move, Select
and Rotate, or Select and Scale tools from the main toolbar.

TIP  If you are used to earlier versions of VIZ, you can still use the floating Transform Type-In dialog box that appears
when you right~click the Select and Move, Rotate, and Scale tools.

Rotating and Scaling Objects

Besides the Move tool, the transform tools also include the Rotate and Scale tools. The look and
functionality of these Transform gizmos has been improved in VIZ 2005. Try the foHowing set of

exercises to see hOW these tOOIS WOfk.

TIP  You can also activate the Move, Rotate, and Scale tools by right~clicking an object and selecting Move, Rotate, or
Uniform Scale from the shortcut menu.

1. With the box selected, click the Select and Rotate tool in the main toolbar. A graphic known
as the Rotate gizmo, a kind of virtual trackball, displays showing rings for rotation about the

X, Y, and Z axes.
> E|‘|View 'I
)
G {3elect and Rotate]

%




G

4343book.fm Page 23 Friday, June 18,2004 2:36 PM

2.

3.

'WORKING WITH OBJECTS

Place the cursor on the ring that circumscribes the X axis. Notice that the ring is highlighted
in yellow. Click and drag the X axis ring upward. The box rotates about the X axis. A tangent
indicator arrow will appear indicating the direction of rotation and a transparent red slice
along with a text tool tip will appear displaying the amount of rotation.

Make sure the Absolute/Offset Mode Transform Type-In button is in the Absolute mode
and look at the coordinate readout. Notice that the X value is not zero, because you rotated
it in step 2. It now shows a number of degrees.

Right-click the X spinner in the coordinate readout to set the X value rotation back to zero.
Notice that the box snaps back to its original orientation.

The Select and Rotate tool’s methods are the same as those for the Select and Move tool. You can rotate
an object graphically by clicking and dragging the object, or, with an object selected, you can enter an exact
rotation value in the coordinate readout. When the Absolute/Offset Transform Type-In button is in the
Absolute mode, you can control the orientation in relation to the object’s original orientation when it was

created. In the Offset mode, you can control the orientation relative to the object’s current orientation.
Now try out the Scale tool:

1.

2.

3.

With the box selected, click the Select and Uniform Scale tool in the main toolbar. A graphic
known as the Scale gizmo displays, showing the X, Y, and Z orientation of the box in relation
to the viewport.

|"I" Oml\ﬁew vl!5‘| A |.§
L
¢ & " [select and Uniform Scale -

Click anywhere on the Scale gizmo or the box and drag the box upward. The box grows uni-
formly in size.

Click and hold the Select and Uniform Scale tool. Then select the middle tool, which is the
Select and Non-uniform Scale tool.

Animation  Graph Editors  Rendering  Cu
$ Ofufven  ~1B8] 4 |5
&R Select and Non-uniform Scale [

23
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4. Drag the XY plane handle of the Scale gizmo (highlighted in yellow) to nonuniformly scale
the box in the XY plane in this case. Similarly, the axis handles can be dragged to constrain the
scaling of an object to one axis.

Now, take a look at the coordinate readout. The values you see are percentages of scale. When
the Absolute/Offset Transform Type-In button is in the Absolute (up) position, the values are
percentages of the original size of the object. When it’s in the Offset position, the values are the
scale in relation to the current size, and are immediately reset to 100% when you release the mouse
button.

1. With the Absolute/Offset Transform Type-In tool in the Absolute position, click and drag
the Z spinner upward. Notice that the box grows in the Z axis.

2. Right-click the Y axis spinner. The box distorts to a O value in the Y axis.

3. Click in the X value input box and enter 100.. The box’s X value is restored to its
original size.

4. Press the Tab key to move to the Y value input box and enter 100..

5. Press Tab again to move to the Z input box and enter 100.. The box is now restored to its
original size.

The Select and Scale tool works in a slightly different way from the other two transform tools. For
one thing, a zero value in the coordinate readout doesn’t return the selected object to its original
shape. This is because the values in the coordinate readout represent percentages, where 100% is the
original size.

The new Scale gizmo allows you to both uniformly and nonuniformly scale an object by auto-
matically switching between scale modes. Which operation you perform depends on which part of

the Scale gizmo you drag.

1. Try dragging the center of the Scale gizmo. You will see the object get uniformly bigger or
smaller, when you drag up or down.
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2. This time, put your mouse over one of the edges of the Scale gizmo. When you drag over one
of the plane handles, you are performing a nonuniform scale in two directions at once. Look

closely at the gizmo and you can see the axes labeled. Try nonuniformly scaling the box in the
YZ plane.

3. The last operation you can perform using the Scale transform gizmo is a nonuniform scale in
one direction. To accomplish this, put your mouse directly over the axis handle at the tip of
an axis. For example, put your mouse over the green dot at the end of the Y axis and drag to
scale in that direction only.
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Once you master the mechanics of the new transform gizmos, you will find that you have much
finer and more intuitive control over your objects as compared to previous versions of VIZ.

Copying an Object

You've covered just about all the ways of moving, rotating, and scaling an object in the Perspective

viewport. If you want to copy an object, you use the same methods you would use to move, rotate,

or scale obj ects—with the addition of holding down the Shift key. Try the following steps to see how
copying, or cloning as it’s called in VIZ, works. (Copying is one of the forms of a more general func-
tion called cloning.)

1. Make sure that the Select and Move tool is active and that the box is selected.
2. While holding down the Shift key, drag the box to the right. A second box appears.
3. Release the mouse button. The Clone Options dialog box displays. This dialog box lets you

control the type Of COpy you’re rnaking, as Well as the name Of the new ObjCCt.

21

“lone Options i
Object Controller——
# Copy % # Copy
 Instance £ Inslance
£ Aeleence

Humber of Copies: [T =l
Hame: IBDNU2

| Cancel |

4. In the Object group of the Clone Options dialog box, make sure Copy is selected.
5. Click OK. The new box is now added to your model.

TiP  You may experience times when ‘you want fo make a copy of an object in exactly the same location as the origz’nal
object, To actomplisb this, Sfirst select the object you wish to copy, and then select Edit » Clone from the menu bar or
Cirl+V on the keyboard. You see the Clone Options dialog box that you saw in the preceding exercise. Set your options
and click OK. Note that the new copy doesn’t appear at first, because it occupies the same space as the original. (Y ou can
acromplisb the same t/az'ng by Skgft-l-[li[/eing an objeft with the Select and Move tool or by selating Clone * from the transform
qmd menu, which can be accessed by right-clicking the objezt.

4~ 40
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In step 4, you selected the Copy option in the Clone Options dialog box. This option creates a dis-
tinct copy of the original object. The other two options, Instance and Reference, create clones that
are linked to the original, so that changes in one object affect the other. You'll learn more about these

options in Chapter 2.

Selecting Multiple Objects

You've now learned how to select, move, and copy a single object, but what do you do if you want
to move or copy several objects at once? You can select multiple objects, or selection sets as they are called
in VIZ, using two methods. The first is one that is also employed in other graphics programs.

1. Click the Select Object tool on the main toolbar.
2. Click a blank area of the viewport to clear any selections you may already have.

3. Click and hold your mouse at a point below and to the left of the original box. Then drag to
the right and upward. Notice that a dotted rectangle follows your cursot, as shown in Figure

1.10.

4. Continue to drag the cursor up and to the right until it encloses both boxes. Then release the
mouse button. Both boxes are selected.

FIGURE 1.10
Placing the selection
rectangle around the

Click and drag from here.

boxes

Notice that selection brackets (or bounding boxes) appear at the corners of both boxes, and a
Transform gizmo appears between the two boxes, showing you that the two objects are selected. You
can select objects mna couple of other ways, which you'ﬂ learn about in a moment, but first, let’s use
the current selection to make a few more copies of the box.

1. Click the Select and Move tool in the main toolbar.

2. Shift and drag the Y axis arrow downward so that copies of the two boxes appear in the loca-
tion shown in Figure 1.11. (You don’t need to be exact about the placement of the copies.)

%
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FIGURE 1.11
Place the copies just
beyond your first

two boxes.

3. When you have the copies in place, release the mouse button.

4. Inthe Clone Options dialog box, make sure Copy is selected in the Object group and click OK.

The four boxes help to demonstrate some of the other selection methods available to you. First,
let’s look at another property of the selection window.

1. Click the Select Object tool.
2. Click a blank spot in the viewport to clear your selection set.

3. Click and drag the cursor from the point indicated in Figure 1.12.

FIGURE 1.12

Selecting points for a Click and drag from here.

crossing window

4. Drag the rectangle up and to the right so that it encompasses just a portion of all the boxes,
as shown in Figure 1.12. Then release the mouse button. Three of the four boxes are
selected.

Notice that you didn’t need to enclose the boxes completely to select them. In the current selection
mode, you only need to have the selection window cross over the desired objects. This is known as
a crossing window. If you’re an AutoCAD user, this type of window should be familiar to you.

%
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You can change the way the selection window works by using the Window/ Crossing Selection
tool. The following exercise demonstrates this.

1. Click a blank area in the drawing in order to clear your selection set.

2. Click the Window/ Crossing Selection tool in the Main toolbar.
3 [+ O R
|

Notice that the icon changes to one showing a sphere that's completely within a dotted rect-
angle. This tells you that you are now in Window Selection mode.

3. Clicka point below and to the left of the box in the center foreground, as shown in Figure 1.13.

FIGURE 1.13
Placing a selection

Click here to start the selection window.

window

4. Drag the rectangle up and to the right until it includes part of the boxes on the right, as shown
in Figure 1.13. Then release the mouse button. Notice that the only objects selected are the
two boxes on the left.

When you use Window Selection mode, only objects that are completely within the selected win-
dow are selected. Unlike with the crossing window, objects that are partially inside the selected
window are left out of the selection.

You can use the Ctrl key in conjunction with a window or crossing selection to continue to add
more objects to your selection set. You can also remove objects from your selection set by using the
Ctrl key with a window or crossing selection. Let’s see how adding and subtracting from selections
works:

1. Crrl+click and hold a point above and to the left of the box in the upper right of the viewport,
as shown in Figure 1.14.
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2. Drag the window down and to the right so that it completely encloses the two boxes to the
right. Then release the mouse button. Now all four boxes are selected.

3. Hold down the Ctrl key and then click the box in the upper right of the screen, as shown in
Figure 1.15. Now all boxes except the upper right one are selected.

= Ctrl+click h
/ S rl+click here.
/>\

Place a window
around this box.

FIGURE 1.14
Adding objects to
your selection set us-
ing the Ctrl key and a

window

FIGURE 1.15
Removing an object

using the Ctrl key

- e
and a click ‘ | .
‘ %
<
. /
/>\

You can change the shape of your selection window to help select objects. As in VIZ 4, there are
rectangular, circular, and polygonal selection window options. New to VIZ 2005 is the Lasso selec-
tion region that allows freeform sketching for a selection.

New!

1. Drag open the selection window ﬂyout and choose the Lasso button.

Create  Modfiers  Anime

2. Sketch a Lasso selection region by dragging the mouse in a freeform manner around two of the
boxes to select them.

4~ 40
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Right now, you have only afew objects in your model, but as your model develops, you'll find that
selecting obj ects in a crowded model becomes more of a challenge. Knowing about the different selec-

tion modes you’ve just used will goa long way toward making your work easier.
One more selection method will be an invaluable tool as your model becomes more complex. You
can select objects by their names, using the Select Objects dialog box. The following 1sa quick exer-

cise that will introduce you to this important tool.

1. Click the Select by Name tool in the main toolbar or press H on the keyboard.

Select by Hame

The Select Objects dialog box displays. Notice that it contains a list showing the names of the
object:s in your drawing. Right now, the list shows the default names given to the objects by
VIZ. You can always change the name of an object in the Command Panel. (You can rename

an object on every tab except Utilities.)

i
I & dphebelical
[0t By Tope
Baall2 3
Boxl3 By Celor
Bias0d € By Size
i
¥ Geomeiy All
¥ Shapes Hore
¥ Lights Irveert
[ Cameras
¥ Hepers
¥ Groups/&ssembies
¥ HRefs
L]l J 2| Selection Sets
al | Heee | et | E
¥ Diplay Subitrze ™ Case Sensilive
I~ Select Subties I Selest D Sebct | Careel |

2. Click the None button near the bottom left of the dialog box. This clears the selection set.

3. Click Box02 and then Ctrl+click Box04 in the list of object names. This list lets you select
multiple names as you would in a typical Windows list box. You can Shift+click to select a
group of adjacent names or Ctrl+click to select a group of individual names.

e ks
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4. Click the Select button. The two boxes are selected.

T ]
I & Aphabelicd
Bloxll 1 FiiTine
Boxlz By Celor
" By Size
Lizt Types:
¥ Geomeiy All
¥ | Shapes Hore
¥ Lights Invert
[¥ Caeias
¥ Hepers
[+ Groups/4ssembles
¥ HRefs
| J 2 Galestion Sets
& | oo | Invert_| :l]
¥ Display Subtree ™ Case Sensilive
I~ Seiect Suithies I Select Depend St %| Carcel |

The preceding exercise showed you how to select objects based on their names, but it also indi-
rectly showed you the importance of the names of objects. Giving objects meaningful names helps you
locate and select them more easily, especially in a crowded model.

NOTE  VIZ is a parametric, object-oriented program (unlike AutoCAD), and every object bas its own name. Each
object has its own parameters that can be accessed from the Modify tab.

Whenever you create an object in Autodesk VIZ 20085, you have the opportunity to give the new
object a name. If you don’t indicate a new name, VIZ provides a name for you. If the new object is
a copy of an existing one, the new name that VIZ provides is the name of the original object, with a
number appended to its name. If you don’t give an object a meaningful name when you create the
object, it’s easy enough to change it later. Just select the object, and then enter a new name in the object
name input box at the top of the Modify tab or in the Name and Color rollout of the Create tab.

@&/ @ @ Tl
o] ™

Naming Selection Sets

Suppose you've gone through a lot of effort selecting a set of objects, and you know you will want
to select the same set of objects again at a later time. VIZ offers the Selection toolbar, which lets you
name a selection set for later recall. Here’s how it works:

1. Make sure two of the boxes are selected. It doesn’t really matter which two, because you're just
practicing using the Selection toolbar.

2. Click inside the Selection input box that’s just to the left of the Mirror tool in the main
toolbar.

(&[T Rl
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3. Type the name Sample.l. You've just given the current selection set a name. (You can enter a
selection set name up to 15 characters long.)

4. Click in a blank area of the viewport to clear the current selection set.

5. Inthe main toolbar, click the downward-pointing arrow to the right of the Selection input box.
Select Sample. The two boxes you selected earlier are now the current selection set.

In these early stages of learning VI1Z, the concept of named selection sets may seem simple, but it’s
one tool you’ll hkely use quite a bit as you expand your skills.

Tip  The Edit option in the menu bar offers some additional selection commands, such as Select All, Select None, and
Select Invert. You can also use the Edit 3 Select By cascading menu to select objects by color or name.

Editing Named Selection Sets
Named selection sets are not ﬁxed in stone. YOLl can add to or subtract from them, or you can delete

them entirely through the Named Selection Sets dialog box.

1. Open the Named Selection Sets dialog box by choosing Edit > Edit Named Selection Sets,
or by dicking the Named Selection Sets button just to the left of the Selection input box you
used before. The Named Selection Sets dialog box appears with a list of all of the selection sets

that have been created.
| X J5ample M
T
¢ |[amed selection sets]

2. Click the plus (+) symbol next to your Sample named selection to see which objects are con-
tained within this set.

gal=
x| ne] %

%{} Sample
) Box3
Bl Box04

{+-Selected: 2
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3. Click Sample in the list. Then click the Select Objects by Name button in the Named Selection
Sets toolbar. The Select Objects dialog box displays. Select one of the names in the list that
doesn’t already appear in the Named Selection Sets dialog box, and then click the Select button.

[Jrared selecton sets I I=I Y
Rl aE N )

S R

4. Click the Add Selected Objects button within the Named Selection Sets dialog box.

[ amed seection sets M STEY
)= g/ela/n/?)

The name of the object you selected now appears in the list of objects contained in the selec-
tion set.

amed selecton sets S TEY
6 > |n[ = 00|20 2

tamed Selection Sets
=1{} Somple
&) Boxl2
&) Box3
&) Boxl4

5. Close the dialog box and deselect all by clicking off to the side in the viewport.

6. Select Sample from the Selection toolbar’s drop—down list to refresh the selection. Now you
see that three of the boxes are selected.

There are several other tools in the Named Selection Sets dialog box. These tools let you select
objects from a set, highlight selected objects, delete objects from a set, or remove a set altogether. You
can also create new named selection sets using the Create New Set tool at the far left of the Named
Selection Sets toolbar.

You've now seen most of the selection tools you’ﬂ need to get started with VIZ. You'll learn about
afew other selection tools as you work with VIZ, and you'll also get a chance to apply the tools you've
already learned as you start to build and edit 3D models in later chapters.

In the next section, you’ll learn about the tools that enable you to view your model from different
angles, and how these different views can aid you in creating and editing your model.

Getting the View You Want

So far in this chapter, you’ve done all of your work without making any modifications to the point of
view of your model. Now let’s take a look at ways you can control your view. Understanding the view-
port controls is essential for manipulating objects in your model, so take some time to become famil-
iar with all the tools discussed in this section.

4~ 40
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Understanding the Perspective Viewing Tools

If you look at the viewport tools in the lower right corner of the VIZ window, you’ll see some tools
that are common among most graphics programs. These include the magnifying glass and the hand.
Other tools in this area may be a bit more mysterious. In this section, you’H learn how these tools let
you get around in your model.

PANNING AND ZOOMING YOUR VIEW

Let’s start by looking at the tool with the hand icon, known as the Pan tool. Like similar tools in other
. . i . ,

programs, the Pan tool displaces your view up or down, or to the left or right. But in VIZ's Perspec-

tive viewport, you're also changing your point of view. Do the following to see what this means.

1. Click the Pan tool.

1A BT &

2. Click and drag the viewport to the left and upward until the boxes are roughly centered in the
viewport.

3. Click and drag the viewport in a circular fashion. Notice that your view of the model appears
to change as if you were moving sideways while Iooking at the boxes.

Next, try the Zoom tool.

1. Click the Zoom tool.

2. Click and drag the Zoom tool upward from the center of the viewport. Notice how you appear
to get closer to the boxes.

3. Clickand drag the cursor downward in the Viewport. Now you appear to be moving away from
the boxes.

4. Continue to click and drag downward until your view looks similar to the one shown in Figure 1.16.

You may have also noticed that, as you moved farther away, the grid became denser. Then, at a cer-
tain point, the grid changed to a wider interval. VIZ does this so that the grid doesn’t overwhelm the
view when it becomes too dense.

Again, as with other graphics programs, the Zoom tool enlarges or reduces your view. In addition
to the Zoom tool, the wheel of the mouse can also be used to zoom in and out within a VIEWPOIT. In
VIZ's Perspective viewport, zooming has the effect of moving you closer to or farther away from the
objects in your model.

%
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FIGURE 1.16
Zooming out to view
a larger area

Now, suppose you don't like the last view change you made and you want to go back to the pre-
vious view. Try the following steps to return to the previous view.

1. Choose Views » Undo View Change. You return to the previous view. (Alternatively, press
Shift+7.)

2. Choose Views » Undo View Change or press Shift+2Z again. Your view returns to the view
prior to the last view.

3. Choose Views » Undo View Change a third time. You return to the view you had before you

panned your view.

The Views » Undo View Change command lets you step back to a previous view in case the last
view change you made is one you don’t like. Views » Undo View Change undoes any view change,
regardless of which viewport tool you used last.

WARNING  Don’t confuse Views » Undo View Change with the Edit > Undo command. Edit > Undo undoes cre-

ation and editz'ng operations but not view [lmnges.

SAVING A VIEW YOU LIKE

If you happen to get a view that you know you want to go back to later, you can save the view with
the Views » Save Active command from the menu bar. Use it in the next exercise to save a view that
you’ll return to later in this chapter‘ And, as you’ll see n Chapter 8, you can also create a camera object
and align 1t to a view,

1. Click the Zoom Extents tool to set up your view for the next exercise. Zoom Extents causes
the viewport to display the entire model.

2. Save this view by choosing Views » Save Active Perspective View.

4~ 40
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The Zoom Extents tool repositions your view so that the entire model just fits within the viewport,
filling the viewport as much as possible. If you're an AutoCAD user, you're familiar with this tool,
because its counterpart in AutoCAD performs the same function.

TIP  You can restore the default perspective view (the one you see when you open a new file) in a blank file by clicking
the Zoom Extents tool or by choosing File » Reset to reset the design.

CHANGING YOUR VIEWING ANGLE

Two other tools are specifically designed for viewing 3D objects: Field-of-View and Arc Rotate
Selected. The Field-of-View tool changes your field of view. The Arc Rotate Selected tool lets you
rotate your view around a selected object.

The Field-of-View tool appears to do the same thing as the Zoom tool, but as you'll see in the fol-
lowing exercise, there is a significant difference between the Zoom and Field-of-View tools.

1. Save the current view by choosing Views > Save Active Perspective View. This lets you return
to the current view later.

2. Click the Field-of-View tool.

Field-of-Yiew

3. Place the cursor in the viewport and click and drag downward until your view looks similar to

Figure 1.17.

FIGURE 1.17
View of perspective
after increasing the

field of view =

—

In one sense, it appears as though you’ve zoomed out from the boxes, but if you compare this view
to the zoomed-out view in the previous exercise, you’ll notice a difference. When you use the Zoom
tool in the Perspective Viewport, your view changes as though you were physicaﬂy moving closer to
or farther away from the boxes. As the name imphes, the Field-of-View tool widens or narrows your
field of view, much as a zoom lens on a camera does. You're not actuaﬂy changing the distance from
the object; instead, you’re changing the area that your viewport displays. The Field-of-View tool has the
potential to distort your view, just as a super—wide—angle ﬁsh—eye lens or a super—telephoto lens tends

%
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to distort a photograph. Until you find yourself in a situation where you really need to change the
field of view, you may want to refrain from using the Field-of-View tool.
Now let’s take a look at the Arc Rotate Selected tool.

1. Return to the view you had before you used the Field-of-View tool by selecting Views >
Undo View Change.

2. Click the Select Object tool. Click in a blank space in the viewport to clear any selections that
may be active. In the next exercise, you'll see why this is significant.

3. Click the Arc Rotate Selected tool.

Arc Rotate Selected

(j@v_‘) ot You see a yellow circle with squares at each of the four cardinal points on the circle. If you

place the cursor inside the circle, the cursor looks like two overlapping ellipses.

4. Place the cursor on the square at the far left of the circle. Notice that the cursor changes shape
to what looks like a horizontal ellipse.

5. With the cursor on the square, slowly click and drag the cursor to the right. Notice how the
view rotates.

6. Place the cursor on the square at the top of the circle. Now the cursor changes to a vertically
oriented ellipse.

7. With the cursor on the square, click and drag the cursor downward. The view now rotates in
that direction.

The squares on the yellow circle are like handles that you can grab and turn to change your view ori-
entation. The left and right squares constrain the rotation to the horizontal plane, and the top and bot-
tom squares constrain the rotation to the vertical plane. If you prefer, you can adjust the view freely
without constraint in the vertical or horizontal direction by clicking and dragging the cursor anywhere
within the circle. You can also rotate the view by clicking and dragging anywhere outside the circle. The
following exercise demonstrates these features. Pay attention to the shape of the cursor in each step.

1. Place the cursor anywhere within the circle. Then slowly click and drag in a small, circular
motion. Notice how the view changes as if your point of view was rotating around the group
of boxes.

2. Place the cursor anywhere outside the circle. Then slowly click and drag in an up-and-down
motion. Now the view rotates around the circle as if you were tﬂting your head from side to side.

You may have noticed that the cursor changes, depending on whether you're inside or outside the
circle. This gives you further cues regarding the way the Arc Rotate tool affects your view.

You've been introduced to nearly all of the viewport tools. However, there’s one more feature of
the Arc Rotate Selected tool that you’ﬂ want to know about before you move on. The Arc Rotate

4~ 40
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Selected tool uses the center of the viewport as the center about which it rotates when no object is
selected. But the Arc Rotate Selected tool works in a slightly different way when objects are selected.
Try the following exercise to see how this variation works.

’T 1. Choose Views » Restore Active Perspective View to restore the view you saved earlier.
2. Click the Select Object tool from the main toolbar.

’E 3. Click the box in the left side in the back row.

4. Click the Arc Rotate Selected tool again.

5. Slowly click and drag the cursor within the circle. Notice how the view appears to be fixed at
the center of the selected box.

6. Slowly click and drag the cursor in a vertical motion outside the circle. The view appears to
rotate around the selected box.

.FB* 7. Return to the saved view by choosing Views » Restore Active Perspective View.
534 If you click and hold the Arc Rotate Selected tool, you’ﬂ see two other Arc Rotate tools in the Arc
@‘ Rotate ﬂyout. The tool at the top, called sirnply the Arc Rotate tool, rotates the view about the view center,

regardless of whether an object is selected. You've already seen how the second tool, the Arc Rotate Selected
tool, works. The tool at the bottom of the Arc Rotate ﬂyout is the Arc Rotate Sub—Object tool. This tool

rotates a view about a sub-object—level selection. You'll learn about sub—object—level editing in Chapter 4.

TIP You can Arc Rotate by holding down the Alt key on the keyboard and dragging the wheel button of your mouse
in a viewport. Don’t turn the wheel, but drag it as if the wheel was a middle mouse button. This is a huge timesaver because
you’ll find that you don’t have to spend time clicking the Arc Rotate button when “you want to rotate your viewing angle.

By being able to select an object or set of objects as the center of rotation for your view, you are better
able to set up your views for rendering or editing. The combination of the Zoom, Pan, and Arc Rotate
tools allows you to obtain just about any view you may need as you work within VIZ’s Perspective view-
port. But you aren’t limited to a perspective view of your model. In fact, there are many situations where
the perspective view is not ideal, especially when editing your model. In the next section, you’H look at
other VIEWpOTLt types that give you greater ﬂexibility in creating and editing objects in your model.

4~ 40
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Using Multiple Viewports

So far, you’ve done all your work in the Perspective Viewport, but this isn’t the only view you have
available. You saw earlier how you can divide the VIZ window so that it displays four equal view-
ports, each representing a different view. Let’s go back to that viewport arrangement to explore the
uses of some of VIZ's display tools. The first item you'll ook at is the way that the Field-of-View

tool changes when your active viewport changes.

1. Click the Min/Max Toggle tool in the set of viewport navigation controls.

VIZ’s window changes to display four viewports.

2. Right-click anywhere in the viewport labeled Top in the upper left corner of the display.
Notice that the Field-of-View tool changes to a magnifying glass with a rectangle. This is the
Region Zoom tool.

Also notice that the Top viewport now shows a thick border around it, indicating that it is the
current, active viewport.

3. Click the Region Zoom tool.

4. Click and drag the cursor on a point below and to the left of the boxes, as shown in Figure 1.18.
As you drag the cursor, you see a rectangle appear. Don’t release the cursor just yet.

5. Position the rectangle above and to the right of the bottom row of boxes, as shown in Figure 1.18,
and then release the mouse button. The view enlarges to the region you just indicated with the
Region Zoom tool.

FIGURE 1.18

Selecting a view to mEEEE IIII-II.III
111 HEEEN

enlarge with the Re-
gion Zoom tool
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The Region Zoom tool acts like the magnifying tools in many other graphics programs. Also, the
Zoom and Pan tools perform the same functions in orthogonal views in VIZ as they do in other pro-
grams, allowing you to zoom in and pan over the view.

You may have noticed two other tools in the viewport navigation controls that haven't been dis-
cussed yet: the Zoom All and Zoom Extents All tools. Now that you have multiple viewports dis-
played, you can try out these two tools.

1. Click the Zoom All tool.

2. Inany viewport, click and drag the cursor upward. Notice that the view in all of the viewports
is enlarged to take in as much of the four boxes as can be displayed.

3. Click and drag the cursor downward, and the views expand to show more of the model area.

4. Click the Zoom Extents All tool.
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Although not as frequently used as the other viewport navigation tools, the Zoom All tool and the
Zoom Extents All tool can be helpful when you need to adjust the overall view of your model in mul-
tiple viewports.

You should be aware that the Arc Rotate Selected tool you used in the Perspective viewport also
works in the other viewports. Tty it out on the Top viewport in the next exercise.

1. Click the Arc Rotate Selected tool.

2. Click and drag the cursor from the center of the Top viewport upward and to the right, so it
shows a view similar to Figure 1.19.

FIGURE 1.19
Top view after using

Arc Rotate Selected

The view changes to a type of 3D view known as an isometric projection. Also notice that the label
in the upper left corner of the viewport now reads User. This indicates that the view is a custom
view based on your changes.

3. Click the Zoom Extents tool to center the view in the viewport.

The 3D view in the upper left corner of the display differs in many ways from the perspective view.
But, as you’H see in the next section, it’s different only because a few of the settings for that viewport
are different from those of the Perspective Viewport.

Changing the Viewport Display and Configuration

If you compare the User viewport with the Perspective viewport, you notice two things that are dif-
y p p P port, y g
ferent. First, as mentioned in the previous exercise, the User viewport shows a 3D orthographic pro-
jection. The second difference is that the User viewport isn’t shaded; the boxes are displayed as simple
line outlines called a wireframe view. These display characteristics can be modified for each viewport.
play p
In the following exercise, you'll see how you can alter viewport settings to obtain specific view

g y 4 P g P

characteristics such as shading and perspective.

1. Right-click the User label in the upper right corner of the User viewport. A pop-up menu
displays.
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2. Select Smooth + Highlights from the menu. The boxes now appear shaded, just as they do in
the Perspective viewport.

3. Right-click the Perspective viewport label. Then select Wireframe from the pop-up menu.
The perspective view changes to a wireframe representation.

Notice that the pop-up menu is the same for both the User and Perspective viewports. This menu
gives you control over the display characteristics of the viewport. Try out a few other options in the
Viewport pop-up menu.

1. Right-click the User label, and then select Views » Perspective. The user view changes to a
perspective view. Notice that the label changes to read Perspective, so that you now have two
Perspective viewports.
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2. Right-click the Perspective label of the upper left viewport, and then select Views > Top. The

view now changes back to the original top view. Notice that the boxes are still shaded.
3. Right-click the Top label and select Wireframe. The view returns to its original state.

Now all the viewports show wireframe views of the boxes. Wireframe views are often better for
many types of editing operations. Wireframes also redraw faster when your model is very large and
full of complex geometry. Another type of view, called bounding box, is even faster than a wireframe
view, but bounding box views reduce the representation of objects to rectangular boxes.

Besides changing the way the viewport displays your model, wireframe view also gives you control
over the layout of the viewports themselves. The following exercise shows you the variety of layouts
you can create in VIZ.

1. Choose Customize » Viewport Configuration. The Viewport Configuration dialog box

displays.
[viewport Configuration 2|
Rendering Method | Lapout | Sale Frames Adsplive Degadation | Regaons |

Fendaring Level———————————  ~Renderng Opbions
" Smonth = Highlights ™ Dizable view
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" Facats + Highlights ™ Testure Corection
€ Facets [~ Z-bufter Winetrame: Objects
Lt Wiedramas ™ Force 2-5ided
& Wieirame ¥ Defauk Lighting
© Boundng Box £ ligh & 2Lights

I~ Edged Faces [¥ Shade Salected Faces

¥ Usa Selaction Bracksts

Transparency [ Displap Selected with Edged Faces
’V " Hore & Simgle © Best ™ Viewpoet Clipping
™ FastViewith Faces [5 2|

Appk To
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2. Click the Layout tab. You see the current viewport layout. Above it is a set of predefined
layouts.

viewport Configuration 3 2=l
RenderingMethod | Lapout | SaleFiames | Adeplive Degiadsiion | Regons |

Chick i viewport
imae lo select view
type.

] _cane

3. Click the layout that looks like three small rectangles stacked on the left side with one large
rectangle on the right.

viewport Configuration E 2l
RenderingMethod | Lapout | SaleFrames | Adeplive Degiadslion | Regons |
HREEEEINE
Chick i viewport
Leaft imae lo select view
- m
0K Cancel
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4. Click OK. The viewports change to the selected layout.

Users of previous versions of VIZ may find this layout comfortable. It has been the default layout
for a few of the early 3ds max and 3D Studio VIZ versions.

You aren’t limited to the canned layouts either. You may decide that you want the layout to reflect
amore traditional mechanical drawing layout, with a top, front, and right side view. Here’s how you
can set up such a viewport arrangement:

1. Choose Customize » Viewport Configuration.

2. With the Layout tab selected, click the layout showing four equal viewports, which is the right-
most layout in the bottom row of layout options.

3. Click the sample viewport labeled Front in the upper right corner of the large sample layout
and select Perspective in the pop-up menu.

4. Click the sample Perspective viewport in the lower right corner and select Right from the pop-
up menu.

5. Click the sample left viewport in the lower left corner and select Front from the pop-up menu.
The sample layout should now look like Figure 1.20.
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FIGURE 1.20
The four-viewport
layout with modifi-

cations

6. Click OK. Now you have a layout that shows the top, front, and right views, plus a perspective
view, arranged in a more traditional manner.

TP When VIZ dz'splays multiple viewports, you can resize those viewports on the fly by fli::]eing and dmgging the
viewport borders. Place the cursor on the border and, when you see a double-beaded arrow, click and drag to change
the viewport size.

As you can see from what you've learned so far, Autodesk VIZ 2005 provides a wide array of dis-
play options, but most of the time, you'll stick with one viewport layout that you are comfortable
with. For the purposes of this book, you'll use the default layout that shows the four equal-size
VIeWpOITts.

Before you conclude your tour of the VIZ interface, let’s see how the Move tool acts in the non-
Perspective viewports. The following exercise will give you a feel for the ways that you can use mul-
tiple viewports.

1. Click the Select and Move tool.

2. Inthe Top viewport, click and drag the cursor from a point below and to the left of the bottom
row of boxes.

ﬁ
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3. Drag the selection rectangle above and to the right of the two boxes in the lower row, so that
they are enclosed in the rectangle. The two boxes are selected.

4. Right-click in the Right viewport.

Tip By rz;gkt-clideing in a viewport, you can make it active without dismpting any selections you may have active at
the time.

5. In the Right viewport, click and drag the green Y arrow upward. Notice how the boxes move
in the front and perspective views as you do this.

6. Position the boxes so they are higher by about one-half the height of a box.

7. Click and drag the red X axis of the boxes to the right of the screen, so they merge with the
box to the right, as shown here.

8. You can discard this file. You won’t need it anymore.

In this exercise, you've seen a number of methods in action. First, the Select and Move tool can be
used to select objects as well as move them. This can help you move objects quickly by reducing the
number of clicks. But be careful, or you might select and move the wrong object when you're in a
hurry.

You also saw how you can right-click in a viewport to make it active. Had you simply clicked in
the Right viewport in step 4, you would have lost the selection set you created in step 3.

4~ 40
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Finally, you saw how objects in VIZ don’t conform to one of the basic rules of physics. In VIZ,
more than one object can occupy the same space at the same time. This characteristic can be useful in

a number of ways as you build models in Autodesk VIZ 2005.

Working with the Custom Ul and Defaults Switcher

New! The new Custom UTI and Defaults Switcher provides an easy and unified method for managing all the
myriad preference settings within VIZ 20085. Let'’s explore what the Custom UI and Defaults
Switcher has to offer.

1. Choose Customize » Custom UI and Defaults Switcher.

Rendering | Customize  MARScrick Help
JmE | 4 Customize User Ineface... EII

. Load Custam LT Scherme
| Save Custom UT Scheme
FRevatt to Startup Layout

Lack Ul Layout

2. Click on the DesignVIZ initial settings for tool options in the upper left of the dialog to see
the settings listed in Figure 1.21.

FIGURE 1.21

Custom UT and

L. Irilial setlirgs for boal aptisns: Ul sehemes:
Defaults Switcher
. Desior (2 mentaiiay MyCustaml)
settings

Oveniew

L Set Cancsl
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3. Scroll down in the dialog box and read through the changes that the DesignVIZ settings rep-
resent in the HTML file that is part of the Custom UI and Defaults Switcher dialog box.
There are two initial settings for tool options: DesignVIZ and DesignVIZ.mentalray.

Options | Lk

o Fropagets Materisls o Irstances
Pharuis Updatn Togghe
CopyRokate Dvag Mods Toggle

B

Eacigeound
Curstiomn Barchgr ound Toggle

Lights

- Genersl Parameters

¥ On  Targ. Dist: (ills}

Shadavs

W Onlv Usze Global Setiings

IAdu. Fay Traced 'I
Ercude... |

e —
T

L | Set | Cancsl

The DesignVIZ settings are configured to provide you with good rendering performance in
large scenes with many lights; this assumes you’'ll be using the radiosity renderer and photo-
metric lights.

The DesignVIZ.mentalray initial settings are meant to be used in conjunction with the mental
ray renderer. Each of these settings automatically configures multiple preferences in layers, the
Material Editor, Lights, Daylight System, Rendering, Cloning, Select by Name, i-drop, Inverse
Kinematics, and Viewport Shading.

NOTE  See Chapter 10 to learn more about the radiosity renderer and Chapter 11 to learn how to use the new mental
ray renderer.

On the right side of the Custom UI and Defaults Switcher dialog box, you’ll see a list of UI
schemes you have already saved. Here, you can conveniently select which UI scheme you’d like to use.
UI schemes hold in one place all the customization you can make to the keyboard hotkeys, toolbar,
quad menus, standards menus, and color schemes. To make changes to an existing Ul scheme, you’ﬂ
use the Customize User Interface dialog box.

1. Choose Customize » Customize User Interface to display this window.

2. Click each of the tabs at the top of this dialog to become familiar with all the ways you can
customize your user interface (changes can be made to the keyboard, toolbars, quads, menus,
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and colors). If you do decide to make any changes, simply click the Save button on the tab
within this dialog box to record your speciﬁc changes to disk.

3. Choose Customize » Save Custom UI Scheme. Open the Save As Type popup. You will
notice five different file formats that can be saved (and loaded) through Save (and Load) Cus-
tom Ul Scheme from the Customize menu. Each one of the lower four formats —UI File
(*.cui), Menu File (*.mnu), Color File (*.clr), and Shortcut File (* kbd)—correspond to each
of the tabs in the Customize User Interface dialog—T oolbars and Quads, Menus, Colors, and
Keyboard, respectively.

20
Saver: [SyUI =] «®mekEm-
| discrect
Icons
| llegacyuis

| MacroSarpts
8] Defaubu.

File pame: [vestariLei = s
Interiace Schemel.ul = M
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When you choose to save the first format in the Save Custom Ul Scheme dialog (Interface
Scheme format), you are saving a composite file that contains all the customization present in
all the other formats combined. It is this Interface Scheme format (*.ui) that is displayed in the
UI Schemes portion of the new Custom UI and Defaults Switcher.

Summary

In this introduction to Autodesk VIZ 2005, you’ve learned how to use the many different tools avail-
able in VIZ. You saw how some tools work in familiar ways, while others, like the spinners and roll-
outs, are a slight departure from other typical Windows programs. You were also introduced to some
of the basic object-creation and editing methods in VIZ. These basic methods are the foundation on
which you will build your skills in this program.

You've covered a lot of ground in this first chapter. Don’t worry if you can’t remember everything.
You'll be exposed to many of these tools frequently as you work through the following chapters. In
the next chapter, you'll take a closer look at how objects are created and edited.




