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Working with Maya Cloth
Robert Kosai and Kevin Vassey

Maya Cloth is a powerful deformation tool that can generate

complex motion which is difficult to achieve using traditional methods.

Packaged as part of Maya Unlimited, Cloth has been used with success on

several live action effects films such as The Matrix and The Lord of the

Rings trilogies as well as all CG productions such as Shrek 2. 

Cloth derives its motion using simulation based on a mass-spring sys-

tem. By setting up a garment for use with Maya’s Cloth Solver, you allow it

to perform the tedious tasks of deforming the garment to match the charac-

ter’s motion and posing while giving your animation a lot of nice secondary

action and an increased sense of fluidity and realism.

This chapter gives the experienced Maya Cloth user some ins and outs

to help you improve your work flow and master some of the intricacies of

this powerful tool. A step-by-step tutorial guides the new user of Maya

Cloth through the process of fashioning a skirt and animating it. Once you

grasp the major concepts, you can handle the second tutorial that demon-

strates how to deform a bracelet as an example of an alternate application

for Cloth.

Work Flow with Cloth
When you are working with Maya Cloth, as you would with real cloth, you must have a
plan before you start to “sew.” As part of the planning phase, you need a clear idea about
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the garment you will be creating. Many studios have artists whose job is to visualize and
then produce concept drawings of characters and their costumes. Emulating the look and
feel evoked from these concept drawings is the goal of the cloth animator. If you are working
on your own design, collect reference photos of items similar to your garment. Keep the ref-
erences pinned on the wall or under a coffee mug but always within arm’s reach, as they are
a constant reminder of what you’re striving toward and are handy to have when discussing
your work with others.

The next step is to design the panel layout of your intended garment. A good place to
begin is looking at your own clothing. Find where the seams are. Imagine the fabric
unstitched and laid flat. How many separate
pieces of fabric were used? Like a tailor, you
will want to measure to achieve a proper fit.
Maya panels are created from shaping
curves into the desired look (see Figure 1.1). 

There is no restriction on the number
of curves used to create panels, but keep in
mind the following two rules.

• The curves must form a closed loop.
• The curves must be coplanar, meaning

all curves must lie flat on the same
plane.

After you create the panels, you can
stitch them together into a single garment.
Initially, the shape will match the planar
contour of the panel curves, as shown here.

2 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.1: Vari-
ous valid panel
shapes
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To make the sewn panels look natural, let the
simulation run and allow it to settle into a stable con-
figuration (see Figure 1.2). In order to get the best
“fit” out of your cloth simulation, you will adjust
numerous attributes and create constraints that influ-
ence the motion characteristics.

Tutorial: Making a Skirt
This tutorial provides the steps to create a skirt that is
tailored around a female model’s waist and is about
ankle length. Like most artistic endeavors, achieving
the desired aesthetic can take many possible paths.
This example is one approach, and it is designed to
cover many concepts. Your goal is to produce a gar-
ment that simulates quickly and maintains stability
through a variety of animations. If you are working in
a collaborative environment, the ability to make quick revisions is essential as well.

Creating the Panels
The garment in Figure 1.2 is created from 4 panels stitched together and simulated to a
relaxed state. The first decision to make is the number of panels. Why not 2, 6, or 16? Build-
ing a garment with fewer panels does require less work to set up and is easier to manage if
changes are needed down the road, but the garment’s requirements ultimately drive panel
construction. Sometimes extra panels are necessary to put more fabric in a specific location,
to control tessellation resolution or to assign unique cloth properties to a particular portion
of a garment. In this case, we chose a 4-panel design because it tends to have few issues with
stretching around the waist and tends to drape nicely; certainly good results can be achieved
with other panel designs.

You will begin with 4 identical rectangular panel shapes, determining the width of each
by measuring the circumference of the model’s waist. Extra fabric is created at the bottom to
help generate folds. Once the general shape of the garment is blocked in, you can adjust indi-
vidual panels to achieve a better fit.

Creating a Guide Curve

The guide curve is the reference for where the cloth garment is to fit in relation to the model.
To create a guide curve, follow these steps:

1. Open clothModel.mb.
2. Create a curve using the EP Curve tool to draw around the waist of the model.

a. Select Inuyasha_skin and choose Modify → Make Live.
b. Choose Create → EP Curve Tool, and draw around the waist, finishing the curve

just short of the first point. Close the curve by choosing Edit Curves → Open/Close
Curves.

c. Scale the curve vertices away from the body slightly. Cloth is more stable if it has a
small cushion from the surface against which it collides.

■ Tutorial: Making a Skirt 3

Figure 1.2: The cloth garment settled after simulation
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3. Choose Edit Curves → Rebuild Curve ❒.
4. Set Rebuild Type to Uniform, set Parameter Range as 0 to 1, and set the number of

spans to 25. This will clean up the curve for use with some scripts later.
5. Rename the curve to skirtAttachCurve.
6. Measure the curve’s length. This will take the guesswork out of how much fabric is

needed. A properly fit garment will have fewer stability issues during simulation.
Choose Create → Measure
Tools → Arc Length Tool.
LMB click the curve and
drag. You should see the
length, from the beginning of
the curve, displayed (see Fig-
ure 1.3). 

Creating the Panel Curves

You now have a few guidelines to
help determine the shape of your
panels. Start each panel with a top
width that is 1⁄4 the length of the
reference curve. The height of each
panel will lie between the guide
curve and ankles. The width at the
bottom depends on the amount of
folding desired.

To create the panel curves,
follow these steps:

1. Choose Create → NURBS
Primitives → Square. This is a
quick way to start as it satis-
fies both conditions for panel
curves; that is, it is a closed
loop and coplanar. 
a. Set Rotate X to 90.
b. Scale X to one-quarter the

length of the skirtAttach-
Curve. 

2. Adjust the length, and tweak
the shape of the curves to
look similar to Figure 1.4.
The panel has a bit of a bell
shape. This will be significant
later when you enable cloth
simulation: gravity will pull
the fabric down, giving a nice
folding pattern along the bot-
tom of the skirt. 

4 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.3: The skirt attach curve is offset away from the
waist. The ArcLength tool displays the length of the curve.

Figure 1.4: An example of the skirt’s front panel curves
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It is easy for your curves to become non-coplanar. To reduce this possibility, work in an
orthographic view, and use the axis handles to move CVs.

3. Rename the group node to frontPanelCurves,
and move these curves off to the side.

4. Duplicate frontPanelCurves, and rename the
duplicate to rearPanelCurves. Move it so there is
no overlap.

5. Repeat step 4, and rename the group to side-
PanelCurves.

Managing Panel Curves Using Instancing

You should have three groups of panel curves similar
to those in Figure 1.5. Although you can directly align
them around the model, you will create instances of
each group and place them around the model instead. 

Using instancing has a few advantages:

• If there are symmetrical panels, in this case the
side panels, you have to update only one tem-
plate and it propagates through all the instances. 

• If you rotate your curves to get a closer fit
around the model, maintaining coplanar vertices
can be difficult.

• The template can remain in an orthographic
state, and the transform node of the instance can
be rotated independently.

To use instancing, follow these steps:

1. Create an instance of frontPanelCurves (Edit →

Duplicate, with the Instance option selected),
and rename it to frontPanelCurves_Instance.
Move it to the front of the model but not clip-
ping through it.

2. Instance rearPanelCurves, rename it to rear-
PanelCurves_Instance, and move it to the rear of
the model. 

3. Instance sidePanelCurves twice. Rename one
instance leftPanelCurves_Instance, and move it
to the character’s left side. Rename the other
instance rightPanelCurves_Instance, and move it to the character’s right side.

4. Adjust the relative positions of the instanced curves so that they do not overlap but
remain close to the model. If you want to adjust the shape of a panel, tweak the CVs of
the original panel curves, which are still orthographic. When finished, your scene
should look similar to the layout in Figure 1.6.

To see a completed version of the skirt panel curves, open skirt_curves.mb.

■ Tutorial: Making a Skirt 5

Figure 1.5: All the skirt’s panel curves laid out. These will
serve as templates for instancing.

Figure 1.6: Instanced panel curves are placed around the
model, and template curves remain in an orthographic
orientation.
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Creating the Garment
To go from the curves to an actual polygonal cloth mesh, you will create a Maya Cloth gar-
ment that is composed of the panels stitched together into a closed cylindrical surface. Fol-
low these steps:

1. Select frontPanelCurves_Instance, and choose Cloth → Create Garment. This com-
mand performs two steps. First, it creates a cloth panel node, which is represented by
the icon shown in Figure 1.7. Second, it creates a polygon plane that matches the con-
tour of the curves. 

2. Rename the garment to skirt_cloth.

Under Inputs for skirt_cloth in the Channel box (see Figure 1.8), you will see several
cloth-related items: cpSolver1, cpStitcher1, and cpCache1. These nodes give you control
over various characteristics of the simulation and of the mesh itself. 

3. The garment’s irregular tessellation aids in creating natural folds by reducing any bias
inherent in a patterned vertex layout; however, the default density is too low for our
purposes. Select cpStitcher, and raise Base Resolution to 65 (see Figure 1.9).

4. Select rightPanelCurves_Instance, and choose Cloth → Create Panel. Then create pan-
els for the rear and left panel instance curves in similar fashion. A panel represents a
piece of fabric in the shape of the panel curves. Each can have its own unique set of
properties and tessellation.

5. The cloth will not extend around the model until the panels are seamed together. Select
the leftmost curve in frontPanelCurves_Instance and the nearest curve that runs par-
allel to it in rightPanelCurves_Instance. Choose Cloth → Create Seam. The cloth mesh
should extend across both panels (see Figure 1.10). 

6. Continue around the model, creating seams between all the panels (see Figure 1.11). Be
sure to close the mesh by creating a seam between leftPanelCurves_Instance and front-
PanelCurves_Instance.

6 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.7: The
Cloth Panel Icon

Figure 1.8: The
cloth garment
inputs with the
stitcher resolu-
tion increased

Figure 1.9: The same cloth mesh at resolution 25 on the
left, 65 on the right
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Preparing the Garment for Simulation
When you run the simulation on the garment, the solver calculates the position of each vertex
for each frame based on the forces applied to it. Although the skirt will settle in the general
vicinity of the model’s waist, the goal is for the top of the skirt to wrap around at a specific
location, along the skirtAttachCurve. Fortunately, Maya provides methods to manipulate the
cloth with great accuracy. In this section, you will create a series of transform constraints that
will guide individual cloth vertices to their proper location on the skirtAttachCurve. Once
you run the simulation, the skirt should wrap and settle nicely around the model. This process
is labor intensive, but you will employ some MEL scripts to accelerate it.

Creating Guide Locators on the Skirt’s Waist

First, you need to create some guide locators to designate the destination of each cloth vertex
on the guide curve. Follow these steps:

1. Use the scene file you have been working on or open skirt_garmentBuilt.mb, which
has been prepared for this step.

2. Open the Script Editor and source attachLocators.mel.
3. You may need to edit the script if the names you gave for your cloth mesh and attach

curve do not match the names in these steps. If so, edit the first two lines of code in the
script.

string $attachCurve = “skirtAttachCurve”;
string $clothObject = “skirt_cloth”;

4. Select the top row of vertices in the cloth mesh, and execute attachLocators.mel. 

■ Tutorial: Making a Skirt 7

Figure 1.10: The cloth seam used to join the front and
right panels

Figure 1.11: The cloth garment extending across all panels
and joined by seams
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You should see a lot of loca-
tors, as in Figure 1.12. One set lies
directly on the cloth vertices and
another set directly on the attach
curve. A transform constraint is
associated with each locator
snapped onto the cloth vertex,
which forces the cloth vertex to fol-
low the path of the locator to which
it is constrained. If you animate the
locator from its existing position on
the cloth mesh to a position on the
attach curve, the vertex will follow
suit at simulation time. 

Constraining the Skirt to the Guide Locators

The locators on the attach curve are uniformly spaced around the skirtAttachCurve, and
there are an equivalent number of locators on the cloth mesh and on the curve. Now it is
time to connect the locators such that the transition onto the attach curve will be smooth.

Before you start, let’s hide a few things to reduce the possibility of making mistakes.

1. In perspective view, rotate so that you can look down over the locaters.
2. Disable the cloth simulation as scrubbing along the Timeline can inadvertently trigger

the simulation. In the Cloth menu set, choose Simulation → Disable Solver.
3. Turn off polygon and NURBS surface display for the perspective view.
4. Beginning from the front of the skirt, select a locator that is on a cloth vertex.

Shift+select a locator on the attach curve that is the shortest and straightest path from
the selected cloth locator (see Figure 1.13).

8 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.12: attachLocators.mel places locators on the
top row of the cloth mesh and on the attach curve.

Figure 1.13: Running attachLocators.mel generates two sets of locators. The cloth locator is
selected, followed by the attach curve locator.
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5. Choose File → Open Script → keyLocator.mel. Select the code and drag it onto the shelf
to create a button. (MM drag in Linux and Windows; Option-drag on Mac.) Execut-
ing this script by clicking the button snaps the cloth locator onto the attach curve loca-
tor and sets a keyframe to animate it.

6. Select the adjacent set of locators, cloth locator first, followed by the curve locator.
Press G to repeat the last command, and repeat this sequence for all the locators. Using
the hot keys speeds this process.

If all went well, when you scrub the Timeline from frames 1 through 5, the locators
will move from their position on the cloth mesh smoothly to the attach curve. When the
simulation runs, the top row of cloth vertices will follow these locators to their designated
spot on the attach curve.

Making the Model a Collision Object
In order for the skirt to drape around the model, you
must tell the solver that the garment should collide
against this object. To do so, follow these steps:

1. Select Inuyasha_skin and choose Cloth → Create
Collision Object. 

2. Look under the shape node in the Channel box.
You should see several collision-related attrib-
utes, as in Figure 1.14. Set Collision Offset and
Collision Depth to 0.5. These values tell the
cloth solver how much distance to keep between
the garment and the collision object. Measured
in centimeters, 0.5 is enough of a buffer to
prevent the collision object from poking
through the skirt but is small enough to keep it
from looking puffed out around the collision
model.

Assigning cpSolver and cpProperty Attributes
The cpSolver and cpProperty attributes largely define the shape of your cloth and how it
reacts to forces. The cpSolver node affects the garment on a global basis and is the single-
most important control over Cloth. It should be one of the first items you adjust when devel-
oping a new garment. Each panel has an assignable cpProperty, allowing flexibility on how a
garment should react at specified panel region.

These attributes play an important role in improving the stability of the garment.
Because the garment you develop can be used in a diverse range of animations, establishing
solid settings will pay big dividends throughout production. 

The cpSolver Attribute

Access the solver by choosing Simulation → Solvers → cpSolver1 ❒. You can also select the
cloth mesh and click the cpSolver1 Input in the Channel box. Now follow these steps:

1. Set Frame Samples to 2. This dictates how many subframe calculations the solver
makes before updating the cloth’s shape at the next frame interval. 

■ Tutorial: Making a Skirt 9

Figure 1.14: 
Collision Object
attributes. The
output goes to
the cpSolver1
node.
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Determining a good sampling rate is based on garment complexity, its intended use,
and a bit of trial and error. A flat, hanging curtain might be fine with a frame sample of 1 but
if it is flapping against gale force winds, a much higher value is required. Keep this number
as low as possible while maintaining stability through a typical motion; simulation times
increase noticeably with higher numbers. For a typical human character, you might want to
set a value that works successfully on a walk. When the motion becomes extreme, you can
keyframe the sample rate higher, which provides a more accurate solution and thereby
reduces the number of collision problems and poke-through issues.

2. Set Solver Scale to 2.5. This is an internal representation of the cloth’s size. Raising the
solver scale tells Maya to treat the cloth as a larger piece of fabric, although physically
its dimensions appear unchanged.

This change in size influences how the cloth folds and reacts to fields and properties (see
Figure 1.15). One way to give the impression of stiffer cloth is to use a lower solver scale.
Since a smaller amount of cloth is
solved versus what is visually repre-
sented, it will have less mass and
tend to drape less. Because this
value has a ripple effect though the
other attributes and properties, try
to work with the solver scale early
in development and establish a
standard value. One side-effect of
changing the solver scale is that
your cache in memory will be
deleted. Remember to save your
scene file before changing solver
scale if you want to keep the cur-
rent simulation.

3. Keep Relax Frame Length at 5. 

Because the seams stretch between panels during the initial garment creation, the cloth
will abruptly collapse during the first few frames of the simulation. The Relax Frame Length
helps the solver during this period by making the garment extra stretchy, allowing the stress
to disperse more evenly. Extremely large or complex garments may need a longer run-up
period. Allow the simulation to continue long after the relax period to let the cloth settle
using its normal property values. After the relax has completed and the solver’s initial state
has been saved, set this attribute to 0.

4. Turn on Output Statistics. Frame solve duration and overall elapsed time are displayed
every frame. On long, complex simulations, this is sometimes the only way you know
that Maya is functioning correctly (see Figure 1.16).

10 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.15: Identical cloth with the left at Solver Scale 1,
the right at 2.5

Figure 1.16:
Example output
statistics
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The cpProperty Attribute

To access properties, choose Simulation → Properties → cpDefaultProperty ❒, or select a
cloth panel and click the cpProperty node under INPUTS. Set the following values:

1. Set U and V Stretch Resistance to 150. For the skirt, increasing this value gives more
stability by reducing the chances of the cloth getting caught under the foot. It also
reduces the rubbery feel associated with low stretch resistance.

A certain amount of stretch is necessary for the simulation to work smoothly; however,
if the stretch and shear values are too low, there will be noticeable texture stretching, as you
can see in Figure 1.17. This is really distracting when any flat garment, such as a bed cover
or tablecloth, is being pulled.

2. Set Shear Resistance to 135. This value is often adjusted in parallel with stretch resis-
tance. Shearing occurs when cloth vertices begin to move in opposite directions, as in a
tearing motion.

3. Set Density to 0.03. By increasing the mass of the garment, density gives a greater feel
of weight by carrying more momentum when it moves. The look of the folds are also
affected (see Figure 1.18).

4. Set Air Damping to 0.001. A low value reduces the effect on the cloth as it moves
through space. It tends to hang down and feel heavier, whereas a high value creates a
more flaglike effect.

You can assign each panel a custom property by choosing Simulation → Properties →

Create Cloth Property. To assign a property to a specific panel, select the panel and
choose Simulation → Properties → cpPropertyName to display a list of all currently
available properties. 

■ Tutorial: Making a Skirt 11

Figure 1.17: The same cloth with stretch resistance at
50/50 and shear resistance at 45 versus stretch at 150/150
and shear at 135

Figure 1.18: The same cloth simulated at a density of 0.01
on the left and 0.03 on the right.
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The best way to understand the effects of the cpProperty attribute is to alter its values,
run a simulation, and watch the results. To this end, we have provided several QuickTime
movies, each showing a side-by-side comparison of a single property simulated at the default
value and with an altered value. You can find these in the images/cpPropertyExamples folder
on the CD. 

Running the Simulation
You are ready to begin your first simulation! Take a deep breath, and follow these steps:

1. Set the Timeline to frame 1.
2. Turn the solver back on. Choose Simulation → Enable Solver. It is on by default but

was previously turned it off when you constrained the skirt to the guide locators. Also,
turn on Polygon and NURBS Surfaces display if no geometry is visible.

3. Click Play.

It will take several seconds to start, but eventually you will see the simulation drawing
the cloth in toward the model. Notice that the hips and legs do not penetrate since you
made the skirt a collision object. Let the skirt settle for about 100 frames. Now is a good
time for a coffee break.

Be sure that the Timeline encompasses the start frame. Otherwise, the simulation will not
begin. You will see the playback progressing without the solver having any effect.

Once you’ve finished simulating, the motion should look similar to garmentSettle.mov.
When you scrub the Timeline, the cloth should update immediately as Maya saves the simula-
tion data into a cache. If you want to save your results, save the scene file. 

Setting Up Cloth for General Animation
If you are working on a film or a project of any length, chances are you will be using the
same character and cloth garment for several scenes. Building panels, stitching the garment,
and relaxing it for every animation would be a lot of repetitive work. The good news is that
once you have a relaxed garment, you can save its state with the solver attached to it. The
next time you open the scene file, you can start solving with the garment in the same fitted,
relaxed position. Because you allowed the cloth to settle over a long period of time, there
won’t be any abrupt motion as witnessed during the initial relax. Save this scene file as a
template and propagate copies of it for use in specific animations.

Saving the Relaxed Garment State
1. Use your scene file or open skirtAttach.mb. If there is no cache data, resimulate.
2. Pick a frame where the cloth has settled, somewhere between frame 100 and frame

150, select the skirt, and choose Simulation → Save As Initial Cloth State.
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Set the Timeline back to frame 1. Notice that the cloth no longer has the boxlike shape
of the panel curves but looks like the skirt at the frame where you performed the Save As Ini-
tial State. Any new simulation will begin using this shape as a starting point for the first
frame’s solve. If the cache is deleted or the timeline is set at or before the solver start frame,
the garment defaults to the initial state. One consequence of this action is that the cache
becomes invalid and should be deleted.

3. Choose Simulation → Delete Cache.

From this point forward, the simulation will begin from the relaxed state. If your char-
acter does not begin animation at the location where the garment was fitted, you can move it
to the character’s new position. Align your garment to the character’s position and choose
Simulation → Update Cloth State, followed by Simulation → Save As Initial Cloth State.
Update Cloth State changes the data stored in the cache to reflect the new garment position. 

Mesh Constraining Cloth to the Model
In this skirt example, in addition to saving the cloth state, you also need to constrain the
relaxed skirt to the collision model. This allows the cloth to move with and react to the char-
acter’s motion.

Earlier we used transform constraints to pin the skirt along the attach curve, but once
the character begins to move, it will be out of alignment because the transform locators were
not animated to the character’s motion. By using a mesh constraint, you can assign the top of
the skirt to follow the waist of the model. But, first, let’s do some cleanup.

1. In the Outliner, expand the hierarchy of skirt_cloth. Delete all the transform con-
straints that were created by the attachLocator.mel script.

2. Delete all the locators named attachSkirtLoc_*.
3. Delete all the locators named XFORM_attachSkirtCurve*.
4. Select the top row of the skirt’s vertices, Shift+select the character mesh, Inuyasha_skin,

and choose Constraints → Mesh.

This constraint maintains the offset between a cloth vertex and the model’s surface as it
animates. The result will look as if the top of the skirt is attached to the model. The charac-
ter is now ready for animation.

Animating the Skirt
After you develop the skirt, you can test its motion in a variety of simulations. Open
skirt_jump.mb to test the garment in an animated jump off a box. Although the skirt simu-
lates well in a standing pose, you will need to adapt the cpSolver and cpProperty settings to
deal with the abrupt motion and more extreme posing. 

Disable the solver and scrub the Timeline. It helps to look at the motion and see what
issues lie ahead. Keep an eye out for problem areas, including quick or jerky motion, extreme
bending of joints, and interaction with objects. Enable the solver, and allow the garment to
simulate. 
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At frame 16, our character crouches down in anticipation of the jump, but the skirt
clips through the box (see Figure 1.19). Convert the box into a collision object by selecting it
and choosing Cloth → Create Collision Object. Set the offset and depth to 0.5. When you
scrubbed through the animation, you might have noticed a similar crouch on the landing at
frame 40. This may not be an issue if the legs are off camera, but, in this case, add a ground
plane collision object.

Truncating the Cache
Because of the penetration, you will need to resimulate the portion where the skirt clips
through box. Fortunately, adjusting your settings in the middle of a simulation does not
mean starting over. You can delete the offending portion of the cache and start solving from
that point. Follow these steps:

1. Scrub the Timeline to the last good frame, about frame 8.
2. Choose Simulation → Truncate Cache.

You can only truncate the end portion of a cache. Any good frames following will be
lost, but this is usually not an issue. Once the simulation starts to go bad, it will not usually
recover on its own.

Inconsistencies between the cache and your setup can occur when using the truncate fea-
ture. For example, if you truncate the cache at frame 15 and set a new property value,
every frame now simulates with that new value; however, the cached frames were simu-
lated based on the old value. If you simulate fresh from the start, the results will differ. If
the character animation is locked and final, save a copy of the cache file because the result
may not be reproducible.  Otherwise, simulate clean from the start frame to ensure that
you can resimulate your garment with consistency.

14 c h a p t e r 1 ■ Working with Maya Cloth

Figure 1.19: The box before and after being made into a collision object
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Updating cpSolver and cpProperty Values
Click Play to continue the simulation. The skirt should now collide
against the box. Continuing the simulation to frame 26 reveals a new
problem in the form of some severe penetration of the cloth through the
collision surface (see Figure 1.20).

You can fix this by increasing frame samples or lowering the time
step. Both attributes work together to establish the amount of subframe
sampling. Sampling in smaller chunks improves the cloth’s position and
velocity accuracy. The negative side-effect is simulation time increases. To
minimize the cost, animate the frame sampling during high-stress times.
For the jump, try animating frame sampling from its default value of 2 at
frame 18 up to a value of 6 or more at frame 23. 

In addition to the increased sampling, the skirt should be stiffer
during this period to prevent the cloth from stretching and tangling. Set
keys for the values as shown in the following list. It helps to ramp up
your settings a few frames before the motion hits its extreme. In this way,
the properties reach full strength smoothly. The same is true for easing
out of these values during the landing.

cpProperty Frame 18 Frame 23 Frame 40 Frame 45
U/V Bend Resistance 10 50 50 10
U/V Bend Rate 0 0.2 0.2 0
U/V Stretch Resistance 350 750 750 350
Shear Resistance 300 600 600 300
Density 0.3 0.15 0.15 0.3
Thickness Force 5 5 5 5

Increasing Bend Resistance reduces unwanted self-collisions by making it more difficult
for the vertices to fold in on themselves. As the resistance increases, the folds tend to become
wider and flatter (see Figure 1.21). Since the character-
istics of the cloth change, it’s best to animate these val-
ues up during extreme motion where a value increase
will not be readily apparent.

Bend Rate works in conjunction with Bend
Resistance in that its effect becomes progressively
stronger as the bend angle increases. 

Stretch and Shear Resistance are increased
across the board to make the skirt less rubbery. Low
stretch and shear resistance tends to give cloth a
springy effect that can result in distracting motion.

Lowering Density gives the cloth less mass,
which reduces the effect of forces on the cloth during
the jump.

Thickness is the distance maintained between
vertices and other cloth objects as well as when it
folds in on itself. The thickness force is the factor of
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Figure 1.20:
Penetration at
frame 26 caused
by inadequate
frame sampling

Figure 1.21: Bend Resistance at 10 versus 150
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how strongly the cloth attempts to maintain this offset. This attribute
also minimizes the effect of self-collisions.

Once property attributes are set, you can use the Paint Cloth Pro-
perties tool to vary the values on a per vertex basis. Select the cloth
mesh, choose Simulation → Properties → Paint Cloth Properties Tool ❒.
The available attributes, which are shown in Figure 1.22, are in the Paint
section.

Since some of the cpProperty values have been altered globally, for
example, Thickness Force, you need to delete the cache and start the
simulation fresh (see Figure 1.23).

As the character begins to fall about frame 30, the skirt begins to
ride up the character’s legs. Pulling the skirt below the knees will help
keep it from pinching into the back of the legs as they bend during land-
ing. Increase the solver’s gravity to increase the downward force on the
skirt by using the following settings:

cpSolver1 Frame 25 Frame 30 Frame 35
Gravity 0, –980, 0 0, –3000, 0 0, –980, 0

The default is −980 in the Y axis, which is the Maya default for
normal gravity. The axes are based on world space coordinates. 

Creating a Gravity Constraint
Another way to add gravity is through a field constraint. Using the
solver’s gravity affects the entire garment. Sometimes you want a greater
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Figure 1.22: The
Paint Properties
tool. Painting on
the cloth mesh
creates a map
that becomes a
multiplier. The
darker region
indicates that
density is
reduced.

Figure 1.23: The skirt at frame 26
after applying new solver and pro-
perty values
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level of control over where the force is applied. In this
case, it can be useful to have this field at the bottom
hem. Follow these steps:

1. In the Dynamics menu set, choose Fields →

Gravity.
2. Select the area of the skirt where you want to

apply the field (see Figure 1.24), Shift+select the
gravity field, and choose Constraints → Field. 

Animate this field to add extra force. Increase
Magnitude to 2000, and set the direction vector to –1
in the Y axis to force the hem down. Attenuation
reduces the amount of force as the distance between
the cloth and the gravity field increases. Set this value
to 0 to maintain a uniform force throughout the 
animation.

View the final results in skirt_jump.mov on 
the CD.

Interacting with Collision Objects
Building a garment is only one aspect of working with Maya Cloth. You also want the gar-
ment to interact with other objects in the scene. If the character kneels, the cloth should rest
on the ground plane. If the character sits, the cloth should conform to the shape of the chair.
One character’s garment might affect the garment for a second character. Cloth allows virtu-
ally any NURBS (Non-Uniform Rational B-Spline), subdivision, or polygon surface to be
made into a collision object. 

To make a surface into a collision object, follow these steps:

1. Select any object or create a NURBS or polygon primitive.
2. In the Cloth menu set, choose Cloth → Create Collision Object. Under the Shapes

node, some new attributes appear:

Collision Offset This is the distance in centimeters, offset away from the collision
surface, that the solver will repel cloth. It creates a buf-
fer to reduce the possibility of the surface penetrating
the cloth. 

Collision Depth The depth is the distance within the
surface where the solver continues to apply a repelling
force. Once cloth has gone past the collision depth, the
solver no longer repels. If the depth gets too large, an
overlap is created where the vector of the repelling
force becomes unpredictable.

Collision Priority If two collision surfaces are simulta-
neously influencing a section of cloth, instability in the
form of vertex popping can become prevalent. The
lowest value is the highest priority collision object (see
Figure 1.25). 
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Figure 1.24: Selection of vertices where the gravity field
applies. A larger selection will have a greater overall effect
on the garment.

Figure 1.25: The cylinder has collision priority
1, and the cube is priority 2 on the left image.
The priorities are switched on the right.
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The direction of force from the collision surface is determined by its normal. If the
cloth gets sucked into the collision object, rather than being repelled, view the normals and
reverse their direction if they are pointed the wrong way (see Figure 1.26).

To view normals, select the object. For polygons, choose Display → Polygon Compo-
nents → Normals. For NURBS, choose Display → NURBS Components → Normals.

To reverse the direction of the normals, select the object. For polygons, choose Edit
Polygons → Normals → Reverse. For NURBS, choose Edit NURBS → Reverse Surface
Direction.

One cause of cloth/collision problems is a mismatch in resolution. When the collision
object has too low a resolution, the cloth will have penetration issues, and when dragged
over the collision object, it will tend to pop (see Figure 1.27). 

As much as low resolution can cause difficulty, complex collision surfaces can be
equally problematic. Hands and feet with their multiple digits and relatively small surface
areas can also poke through cloth. They can also intersect, causing other collision problems.
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Figure 1.26: 
Collision object
attributes in 
relation to the
geometry surface

Figure 1.27: 
The left sphere’s
resolution is too
low. The right
sphere has fewer
poke-through
issues as a result
of its higher
tessellation.
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In most cases, it is quicker and more stable to replace hands and feet with simpler collision
objects. You can fashion a polygon sphere that encompasses the entire hand and use that as
the collision object. Avoid collision objects that have sharp edges or if big gaps appear
between surfaces. These are also candidates for replacement with simpler collision objects.
Also, you can generate new, simpler surfaces by lofting and attaching surfaces together.

Often, collision objects are unavoidably animated to the point where cloth is stretched
beyond its designed limits. Imagine a character’s pants while the character is riding a horse.
Each thigh is applying an outward force while the back of the horse is pushing the cloth up.
For these extremes, you can increase the amount of fabric to be simulated by using the
cpProperty’s U and V scales. 

Affecting Cloth Motion Using Constraints 
Constraints are versatile tools that provide a great deal of added functionality and are inva-
luable in cases where the solver does not readily provide a solution. Each constraint has a
unique capability to control the motion of a garment. Constraints work on a per vertex
basis, which means they exert a fine level of influence. You’ve already used several types of
constraints in the tutorial for both construction and animation purposes. You used a trans-
form constraint to guide the top of the skirt onto the skirtAttachCurve; you created a mesh
constraint to keep the skirt pinned onto the character’s waist during animation; and you
added gravity field constraint to give extra downward pulling force on the hem.

Constraints are commonly used to create the sensation of additional forces being
applied to the cloth, including creating effects such as the wind blowing or some force pull-
ing on the cloth. Another category of constraints allows for part or all of the garment to
attach to other objects or to pass through them without collision. Used in this way, con-
straints can be an immense aid during difficult solves.

Quite frequently constraints are used for applying additional forces on the cloth. This
might be the wind blowing against a sail or some force pulling on the cloth, such as picking
up a napkin. There are constraints to allow objects to be parented onto a garment. This
makes adding details like buttons or jewels a simple affair. Garments can also be attached to
each other using a cloth constraint. If you had a vest over a shirt, adding this type of con-
straint helps keep the garments together, increasing the sense of friction and texture. A final,
essential constraint allows selected vertices to pass through collision objects or through itself
without repelling force.

These collision constraints are an immense aid during difficult solves where cloth gets
pinched or stretched too far. All constraints work on a per vertex basis, which is a major
benefit since it gives finer control over the constraint’s influence. This level of granularity
gives you much more artistic control and can make the difference in creating a convincing
performance.

These are only a few of the possibilities achievable, limited only by the requirements of
the animation and the cloth animator’s ingenuity. Let’s take a closer look at the different
kinds of constraints.

Transform Constraint
You can use transform constraints when a set of cloth vertices must travel to a certain loca-
tion or follow a particular path. Imagine tossing a towel into a basket. By constraining a
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small set of vertices, you not only guide the trajectory but also dictate timing and speed. The
solver calculates the motion for the section of the garment that is not affected by the con-
straint. Pay particular attention to the timing such that the cloth feels like it is being driven
by a natural force, e.g., the character’s arm tossing the towel. Otherwise transform con-
straints can give the distinct look that the cloth is being pushed or pulled in an unmotivated
fashion.

Open buildTransformConstraint.mb and click Play. The cloth falls due to the lack of
any constraints or collision objects. Gravity is the only force acting upon it. To create a con-
straint, follow these steps.

1. Set the Timeline to frame 1 and delete the cache. 
2. Select the upper-left vertex and Shift+select 

locator1.
3. In the Cloth Menu Set, choose Constraints →

Transform. A small box appears, indicating that
vertex has a constraint on it (see Figure 1.28).

Displaying constraints can slow your computer’s
refresh rate. An easy way to hide constraints is to turn
off locator display in the view port by toggling Show →

Locators.

4. Create another constraint on the upper-right
corner using locator2. As the cloth simulates, the
constrained vertices follow the locators. In the
Outliner, expand the hierarchy for cloth1. There
will be two constraint nodes. Select transform-
Constraint1 and look at the Channel box. Under
the shape node are attributes for the constraint
(see Figure 1.29). 

Constraint Weight Sets the constraint on and
off. Any value over 0 indicates the constraint
as turned on.

Is Soft Off, the default, which means the con-
strained vertices stick to the transform object
with no amount of play. Turning Is Soft on
allows for smoother cloth motion. The side-
effect is that the constrained region and transform object can separate.

Stiffness Sets the strength of attraction to the transform object when Is Soft is on. 

Damping Attempts to reduce the springy effect that occurs as the cloth vertices pull
away from the transform object. This also only is relevant when Is Soft is on.

Mesh Constraint
Mesh constraints are similar to transform constraints in that the vertices affected are
directly controlled by the object constraining them; however, a mesh constraint only works

Figure 1.28: Inside the box is an
example of a vertex constrained.

Figure 1.29: Transform constraint
attributes
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with collision objects. The end result is that the garment follows the collision object’s
motion. This is particularly useful for form fitting sections or where the garment is cinched
on. If a sleeve is taut near the shoulder but the cuff area is loose, mesh constraining the top
of the sleeve will ensure that it does not slide excessively. This idea can be expanded to cases
where cloth motion must be reduced for stability reasons. If a simulation begins failing due
to the character moving too quickly, constraining a section of the garment to the body for a
few frames can help reduce its activity. Just be sure to hide the constraint off camera or use
it in cases where the character fills very little screen space. In the opposite case where the
garment is up close and static, using mesh constraints can lock down popping vertices.

Let’s build a quick mesh constraint:

1. Open buildMeshConstraint.mb.
2. In the Outliner, select leftPanelCurve and Ctrl-select collsionCylinder.
3. Choose Constraints → Mesh.

The cloth should hang down under the cylinder.
The mesh constraint attributes are similar to those of
the transform constraint (see Figure 1.30). 

Cloth Constraint
Cloth Constraints bind one cloth garment to another.
If your garments are layered, it may be worthwhile to
consider solving the garments in sequence, with the
first garment simulated by itself and the second gar-
ment mesh constrained to the output of the first gar-
ment. The advantage is reduced solver complexity, but
the down side is that the garments do not interact.

If the garments are of equal weight, then a cloth
constraint is the appropriate choice. It is also useful in
special cases where two garments must be bound
together. An example would be a piece of fabric being
torn in half. You could create a cloth constraint to join
the two halves together and animate the constraint
weight from on to off, then use a series of cloth constraints to have the halves separate one
vertex at a time or create the constraint using a panel curve and animate its start and end
param values.

Let’s take a look at a cloth constraint:

1. Open buildClothConstraint.mb.
2. Select the left edge of vertices of cloth2, which are adjacent to cloth1 and Shift+select

cloth1.
3. Choose Constraints → Cloth. 
4. Under the constraint’s shape node, turn Stitch on.

The simulation for cloth2 is driven by the motion at the end of cloth1. The stitch fea-
ture attaches the two garments. This supersedes the Stiffness, Damping, and Offset attributes
(see Figure 1.31).
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Figure 1.30:
Constraining a
panel curve is a
convenient way
to constrain the
edge row of ver-
tices. Under
Inputs in the
Channel box for
the constraint
node is a curve
assigner. Setting
the Start and End
Param values
enables you to
specify a partial
section of the
curve to con-
strain.
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Field Constraint
The Field Constraint is really a whole set of constraints leveraging off existing elements
from the Dynamics package. Each of these fields can uniquely influence the shape and
motion of the cloth and is extremely useful when you want to animate the cloth beyond
what the solver gives you by default. Up to this point, gravity and the collision objects have
been the primary forces driving the garment’s motion, but additional forces generated from
fields can also play a role. Through the field you can specify the amount of force and its vec-
tor over the constrained region of cloth. This constraint is less direct than a manual tech-
nique like a transform constraint, but it tends to yield smoother, more natural motion.

As an example, if you want to get the feel that the cloth is being blown by the wind,
one way to start is by adding a uniform field:

1. Open buildFieldConstraint.mb.
2. In the Dynamics menu set, choose Fields → Uniform and set the following values:

Magnitude: 75 // Raise the force to an appreciable level
Attenuation: 0 // Keeps the force constant over distance
DirectionX: –1 // Sets the world space vector for force
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Figure 1.31: Two
cloth garments
held together
using the cloth
constraint
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3. Select a group of about a dozen vertices in the middle of the cloth, and Shift+select the
uniform field.

4. In the Cloth Menu set, choose Constraints → Field.

You should see the cloth being pushed in the region of the constraint. Try animating
the magnitude of the field or perhaps constraining a larger or different region of the cloth
and see how the results differ.

Collision Constraint
Collision constraints allow constrained vertices to pass through collision objects to other
cloth meshes or allow the vertices to intersect. Allowing self-intersection can be useful in
folding areas such as in the underarm region of a shirt. Sometimes, collision objects are ani-
mated to the point where cloth gets stretched beyond its designed limits. Adding a collision
constraint to allow the cloth to penetrate in a section that is off camera can give enough
looseness for the cloth to solve effectively. Let’s try that:

1. Open buildCollisionConstraint.mb and click Play. You should see the cloth simulate
over the sphere collision object.

2. Choose Simulation → Delete Cache and return to frame 1.
3. Select the lower half of the cloth vertices and choose Constraints → Collision.

Upon simulation, the cloth should pass right
through the collision sphere (see Figure 1.32). If you
look at the shapes node of the collision constraint, you
will see that both cloth and rigid collisions are turned
off. You can animate these independently. Often you
will want to allow self-intersections (cloth collision
off) but still respect the collision objects (rigid colli-
sions on). 

Button Constraint
The Button constraint can be used for adding any rigid
objects, such as pins, lapels, nametags, badges, and, of
course, buttons. Note that these objects cannot be col-
lision objects because this would create a cycle where
the collision object would affect the cloth solve and the cloth solve would affect the position
of the collision object. Because the solver cannot factor in the button object, clipping can
occur if the garment were to fold heavily. The easiest way to manage this problem is to manu-
ally rotate and possibly translate the button object under the cpButton transform node.

Unlike the cloth constraint, the button constraint allows rigid objects to be parented
onto the surface of the cloth under the cpButton transform node. This gives you extra 
control to animate the constrained object on top of the motion provided by the constraint.
One application is it to rotate the button object to prevent clipping with the cloth. Follow
these steps:

1. Open buildButtonConstraint. 
2. Select buttonSphere, and Shift+select cloth1.
3. Choose Constraints → Button.
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Figure 1.32: A
cloth garment
with a collision
constraint placed
on the bottom
half of the cloth
vertices (right)
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The sphere should follow the cloth. By default, the constraint maintains the offset
between the constrained object and the cloth. Choose Constraints → Button ❒, and turn off
Preserve Translation and Preserve Rotation, which will snap the constrained object to the
surface of the cloth. You can apply an additional offset within the option box.

Avoiding Cloth Problems During 
Character Animation
One of the most effective ways to help the simulation along is to take extra care during ani-
mation. The forces generated by collision objects are strong and tend to overwhelm everyth-
ing else. For example, it is virtually impossible for a field to be strong enough to force the
cloth through a collision object. Therefore, it is imperative that the animation of collision
objects works in a predictable fashion.

A common problem is that the character is often animated to the camera, which
means that any part of the character off camera is not given much attention. This can cause
nonanimated limbs to crash through the body or be left in odd positions. There is also the
temptation to fix a character’s animation when hidden behind a wall or other occluding
object. It is not uncommon to speed up or slow down a character’s motion or perhaps
rotate the character completely around to
get back on the correct path. This may look
fine from the camera’s angle, but the solver
factors in these forces, which will cause the
cloth to react unexpectedly.

Self-intersection in a collision object is
another area where animation changes can
make life a lot simpler. Although the goal is
always not to limit the performance of a
character, a pose can be so extreme that the
solver will have difficulty simulating without
introducing instability. The cylinder in Fig-
ure 1.33 is similar to an elbow or a knee
bent too far. You can see the eyelet-shaped
area where the collision surface reverses the
direction of force within a small distance. If
the cloth gets caught in this region, the
abrupt direction change manifests itself in
the form of the popping cloth vertices.

Manually Updating Cloth
At times, everything looks fine except for one bad frame. In this case, you can manually
manipulate the cloth geometry after the simulation and choose Simulation → Update Cloth
State to update the position information in the cache for the current frame. Use this com-
mand as a last resort. If you resimulate, these tweaks will be lost.

Figure 1.33: A self-intersecting collision object
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Polygon averaging can help if a small handful of vertices continually pop in and out. It
calculates a vertex’s position based on its neighbors. Be sure to use this in small doses as
averaging over large areas will cause the cloth to reduce in volume. To polygon average the
vertices:

1. Select the popping vertices.
2. In the Modeling menu set (press F3 to open it), choose Polygons → Average Vertices

(see Figure 1.34).

Use averaging as a post process step as the averaging information is not saved in the
cache. The node remains an input to the cloth even after deleting the cache. Remove polygon
averaging before running a new simulation. To do so:

1. Select the cloth mesh and open the attribute editor.
2. Select the tab for the polyAverageVertex node, click the Select button and click Delete.

If you have several nodes and you want to remove all of them, run the following MEL
code.

string $node, $polyAvgNodes[]
=lsType(“polyAverageVertex”) ;
for ($node in $polyAvgNodes){
if ($node != “<done>”)
delete $node;
}
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Figure 1.34: The result of polygon averaging on selected vertices
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Saving Your Work
After you simulate the garment, the cloth
updates in real time without recalculating
because the cache is stored in memory. This
information is saved on disk through a Maya
file format that has the .mcc extension. By
default, the .mcc file is stored in the same
folder with the same name as the scene file. In
previous versions of Maya, the cpSolver had
an attribute that listed the path to the cache
file. Maya 6 has the expanded notion of a
cpCache node. The most important thing to
keep in mind is that the cache is written to
disk only when your scene file is saved. In
other words, if you choose File → Exit, all the
simulation data is lost. A computer-related
mantra, which is definitely true for cloth, is to
save early and save often. You can manually
save the cache or back up a copy under a dif-
ferent filename. To save a file, follow these
steps:

1. Select the cloth garment, open the Attribute Editor, and select the cpCache node.
2. Set the cache name and click the disk icon to save (see Figure 1.35).

In older versions of Maya, you can save the cache through a MEL command:

cpSolver -saveCache “filepath/filename.mcc”

Maya automatically loads the cache listed in the cpCache node when the scene is
opened. You can also load an alternate cache file through the cpCache node by clicking the
folder icon shown in Figure 1.35.

And now on to some noncloth things you can do with Maya Cloth. 

Alternative Uses for Maya Cloth
Up to this point, you have learned how to create a cloth garment by constructing panel
curves and seaming them together. You also learned how to create a workable collision envi-
ronment for clothing animation. Sometimes though, in a 3D production, the work of a cloth-
ing animator does not just center on skirts and other garments; it can also involve props,
accessories, and even jewelry.

Cloth simulation is a great way to deform anything that behaves in a similar manner to
cloth. You can animate flags, banners, vines in a jungle, and even earrings with the help of
Maya Cloth. You can even go as far as animating the cord of a video game controller with
Cloth. So, the next time you are animating curtains, cords, towels, or even the fringe that
hangs off older lampshades, consider a cloth simulation.

Now, it is time to take your new knowledge of Maya Cloth a step further and see how to
use it for nongarment deformations in a production pipeline. Specifically, we will focus on
creating a bracelet for our female model and setting up its deformations using cloth simulation.
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Figure 1.35: The cpCache node
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Building the Bracelet Garment
We’ll now build a cloth garment that will be used to deform the bracelet around the left wrist
of our character. Follow these steps:

1. Open bracelet_sim.ma. You will see our character standing in the neutral position at
the origin.

2. We will deform the bracelet model you see around the left wrist. Select a part of the
bracelet, and press the F key to center it in your view.

3. Choose Create → NURBS Primitives → Square.
4. Select the new NURBS square’s group node, and press the W key to invoke the Trans-

late tool.
a. Turn on point snapping. MM drag over a surface in the view window. The NURBS

square you previously created should snap to the surface your mouse was over.
b. Turn off snapping, and make sure the only thing selected is the NURBS square

group node.
c. Rotate and scale the group node until, from the top view, a rectangular box is com-

pletely encompassing the bracelet.

Your top view should look similar to Figure 1.36.
Check the perspective view, and make sure the NURBS square is above the highest

point of the bracelet by at least a few units in the Y direction. Now follow these steps:

1. Select the group node of the NURBS square.
2. Choose Edit → Duplicate ❒.
3. Choose Edit → Reset Settings, and then duplicate the square.
4. Move the duplicated group node down in Y so that it is below the bracelet.

Your perspective view should look similar to Figure 1.37.
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Figure 1.36: The top view Figure 1.37: Two NURBS squares used to generate cloth
panels
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Now, in much the same way you built the garment earlier in this chapter, you will build
this garment. Follow these steps:

1. Select the top group’s curves individually.

Selecting the curves individually is more of a suggestion than a necessity. Based on studio
experience and workflow, problems have been encountered at the simulation stage when
groups were selected instead of individual curves.

2. Choose Cloth → Create Garment.
3. Select the bottom nurbsSquare2

group’s curves individually.
4. Choose Cloth → Create Panel.

You have just created two panels of a
garment that now need to be seamed
together to create the final garment that will
become the bracelet. Follow these steps:

1. Select the corresponding seam curves
along the thumb edge of each square.

2. Choose Cloth → Create Seam.

Repeat these steps for the other (pinky)
side of the garment. You should see a low-
poly surface appear within the box that the
seamed curves form. Your view should look
similar to Figure 1.38. This surface is the
cloth garment that will soon deform this
character’s bracelet.

Solver, Property, and Stitcher Resolution Settings

Now that you have created the actual cloth surface, you have to make sure your settings are
appropriate to get the best simulation possible and that your collision environment is ready
for your garment.

First, let’s get the resolution of the cloth set correctly. Follow these steps:

1. Select the cloth mesh.
2. Highlight cpStitcher in the Channel box.
3. Enter 250 for the resolution.

You want the resolution to be high enough to get a good simulation, but not so high as
to slow down your Maya session. The best way to find this number, until experience tells
you, is by trial and error. A resolution of 250 will be great for the quality of the simulation
and should not slow Maya significantly.

Next, we need to enter some better values for the cloth properties of the panels. Follow
these steps:

1. Select a panel node.
2. In the Channel box, highlight cpDefaultProperty.
3. Enter the values shown in Figure 1.39.
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Figure 1.38: The low-poly bracelet
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The cpDefaultProperty is the cloth property node connected to both panels of the
bracelet garment. The default settings are a good starting point, but will rarely give you an
acceptable cloth solve. Again, with experience, these values will become second nature. Until
then, starting with the values in Figure 1.39 will get you a lot closer to making happy cloth
than the defaults.

Now, the cloth solver needs its settings tweaked to give us a better simulation environ-
ment. Follow these steps:

1. Select the cloth mesh.
2. Highlight cpSolver in the Channel box.
3. Enter the values shown in Figure 1.40.

Again, the default settings for the solver will rarely give the best of conditions for simu-
lating your cloth. Figure 1.40 shows the settings that make a great starting place when dealing
with models of this scale in Maya.

The final step before beginning any simulations is to make sure your collision environ-
ment is ready for your new garment. Follow these steps:

1. Select the polygon model of the female character.
2. Choose Cloth → Create Collision Object.

a. Set Collision Offset to 0.2.
b. Set Collision Depth to 0.1.

These settings control how the cloth collides with the mesh. Once again, these default
settings will not always give you the desired results. You might need to raise these numbers
until your simulation is the distance above the skin you want. Especially in this case, when
dealing with a garment that should be close to the skin, you will have to massage these settings.

Simulating and Relaxing the Bracelet

Now that all our settings have better default values, and our collision environment is ready,
it’s time to simulate and relax the garment for propagation to files for animation.

Click Play to begin the simulation. You should see the expanded cloth mesh begin to col-
lapse around the wrist of the character and move around as it settles to a near stop. After the
bracelet settles, it should look similar to Figure 1.41.
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Figure 1.39: Good starting properties
for cloth

Figure 1.40: Good starting solver 
properties
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If simulation stops or appears to quit, make sure your Playback preferences are set to Play
Every Frame.

The Time Slider should be at the end of
the Timeline now. Rewind the simulation
and save your file. You should now have a
file called bracelet_sim.mcc in the scenes
directory of this project. Remember, this is
the cache file that Maya saves after a cloth
simulation.

Now, scrub the Timeline to the last
frame, and you should see the cloth garment
back around the wrist and settled. Because
you do not want to have to resimulate and
resettle this garment for every file it will
appear in, a few final steps are necessary.

1. Save the file as bracelet_simmed.ma.
2. Select the cloth mesh.
3. Choose Simulation → Save As Initial

Cloth State.
4. Rewind to the first frame.
5. Choose Simulation → Delete Cache.
6. Save the file.

Your garment development process is finished. Now we can move on to animating the
cloth and deforming the bracelet model.

Animating the Bracelet
Open the bracelet_animated.ma file. This file was created by importing the brace-
let_simmed.ma file from the previous section and animating the character without simulat-
ing any cloth.

You can disable the cloth solver in a file either by selecting the solver in the Attribute Edi-
tor and choosing Simulation → Disable Solver or by simply hiding the cloth mesh.

With the cloth mesh hidden, play the file and watch the animation. From frame 0 to
frame 98, the character moves from a neutral position to the first position of the animation.
At frame 101, the character begins the action of pointing with her left hand. See Figures 1.42
and 1.43.

Observing Motion and Simulating the Cloth

One of your most important tasks when first assigned a scene for which you will be animat-
ing the cloth is to watch the animation and look for any areas where the cloth might have a
hard time solving. These areas include, but are not limited to, pinching collision surfaces,
extremely fast animation, and intersecting collision surfaces.
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Figure 1.41: The bracelet after settling

4345c01_p3.1.qxd  1/1/05  10:32 AM  Page 30



In this scene, the character moves into the point pose quite quickly, creating a situa-
tion that should be flagged as a potential problem. Click the Play button to begin simulating
the cloth object. You might encounter problems, but most likely the simulation will com-
plete successfully.

Now that you have a baseline of settings to simulate with, you must decide exactly
how the bracelet should move and react. In other words, ask yourself questions such as the
following:

• How should cloth like this act?
• How can I add anything to the scene through the cloth animation?
• What information do the directors want to see from this scene?

The answers to these questions will steer you toward making the bracelet animation
great and getting it approved. If you see the need for changes, adjust the cloth properties or
add constraints. Animate, simulate, and playblast until you get the results you need. When
you have finished working, remember to rewind the animation and save the file. You should
now have a file called bracelet_animated.mcc in the scenes directory of your project.

Deforming the Bracelet Model

After the cloth has been properly simulated and a cache file has been saved, the next step is
deforming the actual bracelet model, which consists of a strand surface and multiple beads.
To accomplish this, you use a wrap deformer on the strand surface. A MEL script handles
sticking the beads to the strand surface throughout the animation.

Using Maya’s wrap deformer is an excellent way to animate a high-resolution garment
model based on the simulation of cloth. This works on skirts, vests, pants, shirts, jewelry,
accessories, and props.
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Figure 1.42: The beginning of the point animation Figure 1.43: The follow-through of the point animation
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To set up the wrap deformer, first select the surfaces you want to deform and then
select the influence object. Follow these steps:

1. Select the tubular strand surface of the bracelet.
2. Shift-select the cloth mesh.
3. From the Animation menu set, choose Deform → Create Wrap.

Click anywhere in the Timeline to see the strand surface following the cloth mesh and
being deformed appropriately. Playblast the animation to see your results in real time.

Constraining the Beads

Though the strand should be moving quite nicely with the cloth, there is still one problem to
solve. The beads, which should stay with the bracelet, are not moving along. They were not
included in the wrap deformer for a reason. If the beads were included earlier, they would be
moving along, but would be deforming inappropriately. They would squash and stretch based
on the cloth, instead of being hard. To solve this problem, you can use a MEL script called
UVGlue.mel, which you will find on the CD that accompanies this book. Follow these steps:

1. Open the Script Editor.
2. Choose File → Source Script.
3. Navigate to the mel directory of the Chapter 1 files and select UVGlue.mel.

This script works by having the user select a surface point on a NURBS surface and
executing the script with the UVGlue command. Follow these steps:

1. Rewind to the first frame of the animation.
2. Select any bead on the bracelet.
3. Set your view so that the whole bracelet is visible.
4. Hide the character geometry, as well as any other geometry obstructing your view of

the bracelet.
5. Make a display layer for the beads.
6. Set the beads layer to be templated.

This will allow you to select the strand surface points that line up with the beads with-
out actually selecting the beads themselves. Your view should look similar to Figure 1.44.

Now make sure that the strand is the only thing selectable in your view window. Fol-
low these steps:

1. Right-click over the strand geometry to open its marking menu.
2. Select Surface Point.
3. Left-click the strand surface in the middle of the top bead.

You should see two yellow lines cross each other at that point on the surface with a yel-
low point at their intersection. Your view should look similar to Figure 1.45.

You have just selected a surface point on the strand surface that should line up with the
center of the bead on the strand. Now, with that surface point selected, follow these steps.

1. Left-click in the Command line, or press the back tick (reverse apostrophe) key.
2. Type UVGlue.
3. Press Enter.

Upon successful completion of the script, a locator is created at the selected surface
point. Repeat these steps for the rest of the beads around the strand. When all the locators
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are created, untemplate the beads’ display layer. Make sure you are at the first frame of the
animation, and follow these steps:

1. Select a bead, and Shift-select the corresponding locator.
2. Parent the bead to the locator by choosing Edit → Parent.

Repeat these parenting steps until all the beads are parented to their corresponding
locators. Unhide the character geometry; switch to a perspective view that shows your work
to the best advantage, and playblast the animation. If everything was successful, the beads
should follow along through the animation.

What About Changes?

Inevitably, the first work you do on an animation will not quite meet the expectations of the
leads, the directors, or yourself. In this case, the bracelet is completely driven by the cloth
simulation. So, to handle changes, the only thing you need to do is resimulate the cloth. To
simplify this process, hide the bracelet geometry. Make sure you unhide the cloth mesh and
delete the cloth cache so that your new cloth properties take effect. Continue to edit proper-
ties and resimulate, making sure to unhide your bracelet now and again to check the defor-
mations. This process will continue until you get your animation approved.

Always Learning
This chapter introduced you to using Maya Cloth for everything from garment creation and
simulation to deforming jewelry. Cloth simulation can be a versatile tool when you face ani-
mating something out of the ordinary, but be patient: Sometimes animating cloth can be like
animating a marble with a straw. If you follow the directions given here, and use the settings
we provided, you will jump into your shots prepared and ready to go. The next time you
face animating the end of that feather duster or the most beautiful ball gown ever, don’t for-
get Maya Cloth.
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Figure 1.44: The templated beads Figure 1.45: The selected surface point
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