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Placed Images

A PAGE LAYOUT JUST wouldn’t be a page layout without including some placed images. To

add visual interest to a design, you’ll probably want to include a few photographs. And even

though you can create custom-drawn logos and shapes in InDesign, you may also want to add

images created in other vector-based drawing programs, such as Adobe Illustrator.

In this chapter we’ll explain how to import images of all types into your InDesign documents,

including TIFFs, EPS files, layered and multipage PDFs, and native file formats such as AI

(Adobe Illustrator format) and layered PSDs (Photoshop Documents). We’ll also explain how

to manage links and embed images using the Links palette, and how to apply, create, and edit

clipping paths.

■ 12.1 Importing a Graphic Image

■ 12.2 Setting Import Options

■ 12.3 Object Layer Options and Placed PSDs

■ 12.4 Copying to and from Adobe Illustrator

■ 12.5 Resizing Placed Images

■ 12.6 Updating Missing and Modified Links

■ 12.7 Embedding Images

■ 12.8 Object-Level Display Settings

■ 12.9 Applying and Editing a Photoshop Clipping Path

■ 12.10 Creating and Editing an InDesign Clipping Path

C H A P T E R  12
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12.1 Importing a Graphic Image

You can import graphics using the File > Place command (Mac: Cmd+D, Windows:

Ctrl+D). When the Place dialog opens, browse to a graphic image on your system and

click the Open button. With the loaded Place cursor, you can then click on an existing

frame, draw a frame, or click once anywhere on the page for InDesign to draw a frame for

you. In all three scenarios, the image is automatically placed in the frame.

The loaded Place cursor

The loaded Place cursor positioned over a frame

The loaded Place PDF cursor

The loaded Place PDF cursor positioned over a frame

To import a graphic image as you would in QuarkXPress, select an existing frame and

choose the Place command. In the resulting dialog, browse to the image and click the Open

button. The image appears at 100% of its size in the graphic frame. You can then resize the

image or apply one of the fitting commands, from the Object > Fitting submenu.

1. Select a frame.

Related Tasks

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.14 PageMaker
Toolbar

5.12 Display
Performance
Preferences

5.14 File Handling
Preferences

Shortcuts

Place
Mac: Cmd+D
Win: Ctrl+D

Copy to Clipboard
Mac: Cmd+C
Win: Ctrl+C

Paste from Clipboard
Mac: Cmd+V
Win: Ctrl+V

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Tip

You can drag and drop
multiple images at
once from a folder on
your system into an
InDesign document.
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12.1 Importing a Graphic Image (continued)

2. Choose File > Place to access the Place dialog and browse to the image.

3. Click Open to Place the image at 100% of its size (below left).

4. Apply the Fill Frame Proportionally command (Object > Fitting > Fill Frame Propor-

tionally) (below right).

For additional options, click Show Import Options in the Place dialog, or press the Shift

key as you click Open. It is also possible to import graphic images by dragging and drop-

ping them from a folder on your system into a document window. You can even drag an

image onto an existing frame to place it inside the frame.

Related Tasks

7.1 Frame/Shape
Overview

7.2 Selection Tool
vs. Direct
Selection Tool

11.5 Creating and
Applying Object
Styles

12.4 Object Layer
Options and
Placed PSDs

12.5 Copying to and
from Adobe
Illustrator

12.6 Resizing Placed
Images

14.2 Color-Managing
Imported
Graphics

Shortcuts

Direct Selection tool
Mac and Win: A

Fit content
proportionally
Mac: Opt+Shift+Cmd+E
Win: Alt+Shift+Ctrl+E

Fill frame
proportionally
Mac: Opt+Shift+Cmd+C
Win: Alt+Shift+Ctrl+C

Fit content to frame
Mac: Opt+Cmd+E
Win: Alt+Ctrl+E

Fit frame to content
Mac: Opt+Cmd+C
Win: Alt+Ctrl+C

Tip

Dragging a graphic over
a palette or document
title bar cancels the
import.
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12.2 Setting Import Options

InDesign accepts all graphic file formats used for prepress including TIFF, EPS, PDF,

DCS, as well as native file formats such as AI (Adobe Illustrator format), and PSD (Photo-

shop document).

To access additional import options, click Show Import Options in the Place dialog, or press Shift as
you click Open.

Import options vary depending on selected file type. PDFs and EPS files have their own

options dialogs, while all other file types are handled with the Image Import Options dialog.

Clipping paths and alpha channels allow you to extract an image from a photograph. If the image
you are importing contains a Photoshop clipping path or alpha channel, the Image panel of the
Image Import Options dialog allows you to apply and edit the path in InDesign. To do so, check the
Apply Photoshop Clipping Path box or choose an alpha channel from the menu. You can apply this
option later if you decide to leave it off during import.

In the Color panel, you can tell InDesign how you would like to color-manage the image you are
importing. Select and apply a color profile and rendering intent.

Related Tasks

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.14 PageMaker
Toolbar

Shortcuts

Place
Mac: Cmd+D
Win: Ctrl+D

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Tip

You can access import
options by holding
down Shift as you 
click Open in the Place
dialog.
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12.2 Setting Import Options (continued)

The Layers panel only appears when importing a native Photoshop PSD. In the Show Layers section
of the dialog, an eye icon appears next to each layer’s name; click the icon to turn a layer’s visibility
on or off. If the image contains Photoshop layer comps, you can choose to display one in InDesign
by selecting it from the Layer Comp drop-down menu. When editing a placed PSD in Photoshop
and then updating in InDesign, you have the option to keep the layer visibility overrides chosen
upon import, or to view layers as they are saved in the PSD; select either option from the When
Updating Link drop-down menu.

EPS Import Options Dialog

Read Embedded OPI Image Links: An Open Prepress Interface (OPI) workflow allows you to

place low-res EPS images that are used to reference high-res versions from an OPI server

during output. Enable this option to allow InDesign to act as an OPI server.

Apply Photoshop Clipping Path: If the EPS image you are importing contains a Photoshop

clipping path, the EPS Import Options dialog allows you to apply it in InDesign. Unlike

with a clipping path applied to a TIFF or PSD, you cannot edit a Photoshop path applied

to an EPS file in InDesign.

Proxy Generation: To use the preview embedded in the EPS image, select Use TIFF Or

PICT Preview. To create a preview in InDesign, select Rasterize The PostScript.

Related Tasks

5.12 Display
Performance
Preferences

5.14 File Handling
Preferences

7.1 Frame/Shape
Overview

7.2 Selection Tool
vs. Direct
Selection Tool

Shortcuts

Direct Selection tool
Mac and Win: A

Fit content
proportionally
Mac: Opt+Shift+Cmd+E
Win: Alt+Shift+Ctrl+E

Fill frame
proportionally
Mac: Opt+Shift+Cmd+C
Win: Alt+Shift+Ctrl+C

Tip

The following graphic
file formats are not rec-
ommended for pre-
press work: BMP, GIF,
PCX, PNG, PICT, WMF,
and low-res JPEG.
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12.2 Setting Import Options (continued)

Place PDF Dialog

Pages: You can choose to import a specific page, all pages, or a range of pages from a PDF

document into InDesign. It is also possible to select which page you would like to import

by entering a page number or clicking the left/right arrows under the preview window and

selecting the Previewed Page option.

Crop To: Choose how much of the page you would like to import. From the Crop To drop-

down menu, select Bounding Box, Art, Crop, Trim, Bleed, or Media.

Transparent Background: Enable this option to allow imported PDFs containing transpar-

ent backgrounds to remain transparent in InDesign.

With the exception of layer comps, the Layers panel of the Place PDF dialog has the same

functionality as the Layers panel of the Image Import Options dialog.

Related Tasks

11.5 Creating and
Applying Object
Styles

12.4 Object Layer
Options and
Placed PSDs

12.5 Copying to and
from Adobe
Illustrator

14.2 Color-Managing
Imported
Graphics

Shortcuts

Fit content to frame
Mac: Opt+Cmd+E
Win: Alt+Ctrl+E

Fit frame to content
Mac: Opt+Cmd+C
Win: Alt+Ctrl+C
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12.3 Object Layer Options and Placed PSDs

Clipping paths are great for extracting images from placed photographs. The downside is

that they can take a long time to draw, and their edges often appear too sharp. To get

around this, try extracting your images in Adobe Photoshop and then placing transparent

PSDs in InDesign CS2. It’s quicker and easier, and produces better-looking images overall.

Plus, you can take advantage of InDesign’s new Object Layer Options dialog, which allows

you to control layer visibility in placed PSDs—including layer comps.

1. Open the photograph in Photoshop CS2.

2. Extract the image using the Extract filter.

3. Create some effects using layers. You can also save your favorite layer effect combina-

tions as layer comps. When you’ve finished, save the file as a PSD and close it.

4. Import the PSD into your InDesign document using the File > Place command (Mac:

Cmd+D, Windows: Ctrl+D). To access the Image Import Options dialog, enable Show

Import Options before clicking Open.

Related Tasks

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.14 PageMaker
Toolbar

Shortcuts

Place
Mac: Cmd+D
Win: Ctrl+D

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Tip

The Object Layer
Options dialog also
allows you to control
layer visibility for
placed PDFs.
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12.3 Object Layer Options and Placed PSDs (continued)

5. Click the Layers tab at the top of the dialog to access the Layers panel. In the Show

Layers section, choose which layers to display by clicking the eye icons that appear

next to each layer’s name, or choose a layer comp from the menu. Any layer comp

comments saved in the PSD are displayed in the window beneath the Layer Comp

drop-down menu.

6. Click OK to place the PSD.

Related Tasks

5.12 Display
Performance
Preferences

5.14 File Handling
Preferences

7.1 Frame/Shape
Overview

7.2 Selection Tool
vs. Direct
Selection Tool

11.5 Creating and
Applying Object
Styles

Shortcuts

Selection tool
Mac and Win: V

Tip

Changing PSD layer 
visibility or layer comps
in InDesign does not
alter the original 
Photoshop file.

284

4420c12.qxd  6/15/05  7:38 PM  Page 284



12.3 Object Layer Options and Placed PSDs (continued)

7. To adjust layer visibility after the PSD is placed, choose Object > Object Layer

Options. In the resulting dialog, choose to show or hide different layers or select a dif-

ferent layer comp from the menu. Check the Preview option to view your changes in

the document as you make them. When you’ve finished, click OK to close the dialog

and apply your changes.

InDesign places an eye icon next to
the link’s name in the Links palette,
indicating that the image now contains
layer visibility overrides.

Related Tasks

12.1 Importing a
Graphic Image

12.2 Setting Import
Options

12.5 Copying to and
from Adobe
Illustrator

14.2 Color-Managing
Imported
Graphics

Shortcuts

Direct Selection tool
Mac and Win: A
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12.4 Copying to and from Adobe Illustrator

In addition to placing native .AI (Adobe Illustrator format) files, you can copy/paste or

drag and drop Illustrator objects into an InDesign document. With the proper settings

enabled, it is possible to edit simple objects in InDesign that have been copied from Illus-

trator, and vice versa.

To edit Illustrator objects in InDesign, you must enable the AICB option—Adobe Illustrator
Clipboard—in Illustrator’s File Handling & Clipboard preferences (top), and disable the Prefer PDF
When Pasting option in InDesign’s File Handling preferences (right). Once these preferences are
set, you can edit Illustrator paths using InDesign’s drawing tools.

Related Tasks

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.14 PageMaker
Toolbar

5.12 Display
Performance
Preferences

5.14 File Handling
Preferences

Shortcuts

Place
Mac: Cmd+D
Win: Ctrl+D

Copy to Clipboard
Mac: Cmd+C
Win: Ctrl+C

Paste from Clipboard
Mac: Cmd+V
Win: Ctrl+V

Tip

An Illustrator graphic
must be saved in lay-
ered PDF format in
order to adjust its layer
visibility in InDesign
using the Object Layer
Options dialog.
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12.4 Copying to and from Adobe Illustrator (continued)

When you’re copy/pasting or dragging and dropping an Illustrator graphic into InDesign, paths are
automatically grouped. Ungroup to edit them with InDesign’s drawing tools.

Of course, there are some limitations to the kinds of objects you can copy/paste and the

kinds of edits you can make. For example, InDesign converts any editable text copied

from Illustrator into objects that can be transformed but not edited with the Type tool.

InDesign also does not accept compound shapes or applied transparency (such as blend

modes and drop shadows).

However, colors and simple gradients copied from Illustrator can be edited in InDesign

using the Color and Gradient palettes.

To copy/paste or drag and drop editable paths from InDesign into Illustrator, enable the

Copy PDF To Clipboard option in InDesign’s preferences.

Related Tasks

7.1 Frame/Shape
Overview

7.2 Selection Tool
vs. Direct
Selection Tool

11.5 Creating and
Applying Object
Styles

12.1 Importing a
Graphic Image

12.2 Setting Import
Options

12.4 Object Layer
Options and
Placed PSDs

14.2 Color-Managing
Imported
Graphics

Shortcuts

Ungroup
Mac: Shift+Cmd+G
Win: Shift+Ctrl+G

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Tip

Objects copy/pasted
from Illustrator into
InDesign are not
treated as links, and
therefore do not
appear in the Links
palette.
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12.5 Resizing Placed Images

To resize a placed image within a frame, you must select it with the Direct Selection tool,

and then perform any one of the following actions:

■ Drag any one of the image bounding box nodes. Press the Shift key to constrain your

image to its original proportions as you drag.

■ Enter new Scale X and Y Percentages or new Width and Height values in either the

Transform palette or Control bar.

Related Tasks

2.7 Object Menu

3.2 Control Bar

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

3.12 Scale Tool

3.14 Free Transform
Tool

Shortcuts

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Scale tool
Mac and Win: S

Free Transform tool
Mac and Win: E

Transform palette
Mac and Win: F9
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12.5 Resizing Placed Images (continued)

■ Press S to access the Scale tool, then click and drag. Press the Shift key to constrain

your image to its original proportions or to limit the scale to one axis.

■ Access the Scale dialog by choosing Object > Transform > Scale. Enter values for Uni-

form or Non-Uniform scaling and click OK.

■ Press E to access the Free Transform tool and click and drag one of the image bound-

ing box nodes. Press the Shift key to constrain your image to its original proportions.

■ Use either of the keyboard shortcuts for incremental resizing (1% or 5%).

To resize a placed image and its frame container at the same time, select the frame with

the Selection tool and use any of the resizing methods described above while holding the

Command key (Mac) or the Ctrl key (Windows).

You can also resize an image within a frame by selecting it with the Direct Selection tool

and applying one of the commands from the Object > Fitting submenu: Fit Content To

Frame, Fit Content Proportionally, Fill Frame Proportionally.

Related Tasks

4.10 Links Palette

4.11 Object and
Layout Palettes

7.1 Frame/Shape
Overview

7.2 Selection Tool
vs. Direct
Selection Tool

8.2 Resizing Objects

Shortcuts

Increase/decrease
size of selected
object by 1%
Mac: Cmd+> (increase)/
Cmd+< (decrease)
Win: Ctrl+> (increase)/
Ctrl+< (decrease)

Increase/decrease
size of selected
object by 5%
Mac: Opt+Cmd+>
(increase)/Opt+Cmd+<
(decrease)
Win: Alt+Ctrl+>
(increase)/Alt+Ctrl+<
(decrease)

Fit content to frame
Mac: Opt+Cmd+E
Win: Alt+Ctrl+E

Fit frame to content
Mac: Opt+Cmd+C
Win: Alt+Ctrl+C

Tip

You can apply Fitting,
commands to a graphic
selection by using 
the buttons located 
on the far right of the
Control bar.

289

W
O

R
K

S
P

A
C

E
T

Y
P

O
G

R
A

P
H

Y
C

O
L
O

R
G

R
A

P
H

IC
S

O
U

T
P

U
T

P
A

G
E
 B

U
IL

D
IN

G

4420c12.qxd  6/15/05  7:38 PM  Page 289



12.6 Updating Missing and Modified Links

The Links palette is similar to the Picture Usage feature in QuarkXPress in that it allows

you to update and relink modified and missing links. When a link is edited outside InDesign,

it is considered “modified.” When a link is moved from its previous location on your system,

it is considered “missing.” In either scenario, InDesign displays a missing or modified icon

next to the link name in the palette.

When the Sort By Status option is enabled in the
Links palette menu, missing and modified links
always appear at the top of the palette list. You
can also choose to sort by name or by page.

To update a modified link, select it in the 
Links palette and click the Update Link button
located in the palette footer controls, or choose
Update Link from the palette menu. You can
also select and update several modified links 
at once.

To relink a missing item, select it in the palette and
click the Relink button, or choose Relink from the
palette menu. When the Locate File dialog opens,
browse to the link on your system and then click
Open. It is also possible to select and relink several
missing items at once.

When opening a document containing missing
or modified links, InDesign gives you the
option to update and/or relink immediately. To
do so, click the Fix Links Automatically button
or click Don’t Fix to update later.

Related Tasks

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.14 PageMaker
Toolbar

7.2 Selection Tool
vs. Direct
Selection Tool

12.8 Embedding and
Unembedding
Images

Shortcuts

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Go To Link
Mac: Opt-double-click
filename in Links palette
Win: Alt-double-click
filename in Links palette

Tips

You can select all of the
filenames in the Links
palette at once by 
Command/Ctrl-double-
clicking any one of them.

To locate where a link
is placed in a docu-
ment, select it in the
Links palette and click
the Go To Link button.

To locate a link on 
your system, select 
it in the palette and
choose Reveal In 
Finder (Mac), Reveal In
Explorer (Windows), or
Reveal In Bridge from
the palette menu.
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12.7 Emdedding Images

The more pages you add to a document, the more images you are going to place. As the

links add up, keeping track of all of them on your system grows increasingly harder. It’s

the nature of the beast, unfortunately. However, there is something you can do to make it

a little easier: embed the smaller links in the document.

When you embed an image it becomes part of the document, thereby eliminating the need

to refer to a separate file on your system. However, embedding images adds to a docu-

ment’s file size, which is why it is best to only embed smaller graphics such as end mark

icons and small vector graphics.

To embed an image, select it in the document or click the link name in the Links palette

and choose Embed File from the palette menu. You can also select and embed several

links at once.

Once you embed a file, an Embedded icon appears in the palette next to the link name.

To relink an embedded file, select it and choose Unembed File from the palette menu. As

with embedding, you can also select and unembed several links at once.

After choosing the Unembed File
command, InDesign displays a dia-
log asking if you’d like to relink to
the original file or create a new
file. Click Yes to relink to the origi-
nal and No if you’d like InDesign to
create a new file.

Unless it has been moved to a new location on your system, InDesign remembers the original

file location when relinking. When creating a new file, you must select a file location from the

Choose A Folder (Mac) or Browse For Folder (Windows) dialog and click the Choose button.

Related Tasks

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

7.2 Selection Tool
vs. Direct
Selection Tool

12.1 Importing a
Graphic Image

Shortcuts

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Go To Link
Mac: Opt-double-click
filename in Links
palette
Win: Alt-double-click
filename in Links
palette

Tip

To embed a text link,
select the filename in
the Links palette and
choose Unlink from the
palette menu. The file-
name is removed from
the Links palette.
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12.8 Object-Level Display Settings

InDesign allows you to apply settings from the Display Performance submenu not only to

an entire document, but to individual objects as well. This means that you can override

document-level display settings by applying the Fast Display, Typical Display, or High

Quality Display setting to selected objects.

For example, if working with High Quality Display enabled slows down your computer,

you may want to consider switching toTypical Display and then applying High Quality Dis-

play overrides to specific objects as needed.

To do this, you must enable the Allow Object-Level Display Settings option in the View >

Display Performance submenu. With the document display set to Typical Display, select an

object (or objects) with either selection tool and choose Object > Display Performance >

High Quality Display.

You can also set object-level display settings through the contextual menu. Select an

object (or objects) with either selection tool and Control-click (Mac) or right-click (Win-

dows) to access the Display Performance commands.

You can change object-level display at any time by selecting the object(s) and choosing a

different setting under the Object > Display Performance submenu. To clear local display

settings for a selected object (or objects), choose Use View Setting.

To clear all object-level display overrides and display all images in the document with the

chosen View setting, select View > Display Performance > Clear Object-Level Display Set-

tings.

Fast Display setting Typical Display setting High Quality Display setting

Related Tasks

1.4 Interface
Objects

2.7 Object Menu

2.9 View Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

5.12 Display
Performance
Preferences

Shortcuts

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Go to link
Mac: Opt-double-click
filename in Links
palette
Win: Alt-double-click
filename in Links
palette

Tip

Vector EPS images
never preview well on
screen. Thankfully in
InDesign, you can
change the display set-
ting by selecting the
image and choosing
Object > Display Perfor-
mance > High Quality
Display.
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12.9 Applying and Editing a Photoshop
Clipping Path

If the TIFF, JPEG, or PSD you are importing contains a Photoshop clipping path, you can

apply it via the Image panel of the Image Import Options dialog or the Clipping Path dia-

log. You can then edit the Photoshop path using InDesign’s path editing tools. Any edits

made to a Photoshop clipping path in InDesign are not applied to the original file—they

only affect the image as it appears in InDesign. (InDesign does not allow you to edit Pho-

toshop clipping paths applied to EPS files).

To apply a Photoshop path when placing an image, check the Apply Photoshop Clipping

Path box in the Image Import Options dialog.

To apply a Photoshop path after the image has been placed, select it with either selection

tool and choose Object > Clipping Path. At the top of the Clipping Path dialog, choose

Photoshop Path from the Type menu. If the image contains more than one Photoshop

path, you can select which one to apply in the Path menu below. To see the path as you

are applying it, click the Preview check box.

To remove any extraneous black or white edges from the path, contract it by entering a

value in the Inset Frame field. You can also invert a Photoshop path by clicking the Invert

check box.

Related Tasks

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

3.5 Pen Tools

3.7 Pencil Tools

3.19 Scissors Tool

4.10 Links Palette

4.19 Text Wrap
Palette

Shortcuts

Clipping path
Mac: Opt+Shift+
Cmd+K
Win: Alt+Shift+Ctrl+K

Place
Mac: Cmd+D
Win: Ctrl+D

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Pen tool
Mac and Win: P

Add Anchor
Point tool
Mac and Win: =

Tip

To open and edit an
image in Photoshop,
select it and click the
Edit Original button
located at the bottom of
the Links palette. Once
you save and close the
image in Photoshop,
InDesign automatically
updates it in the 
InDesign document.
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12.9 Applying and Editing a Photoshop
Clipping Path (continued)

The original image Applying a Photoshop clipping path 

Once you’ve applied points, you can move 
them on the Photoshop path using the 
Direct Selection tool. You can also use the
path editing tools included in the Pen and
Pencil toolsets to add or delete points, or 
convert their direction, or you can cut the
path using the Scissors tool.

CONVERTING CLIPPING PATHS TO FRAMES

You can convert a clipping path (applied from Photoshop or created in InDesign) into a

graphic frame. To do this, select the image with the Direct Selection tool, Control-click

(Mac) or right-click (Windows) to access the contextual menu, and choose Convert

Clipping Path To Frame. Once the command is applied, InDesign removes the clipping

path and replaces it with a graphic frame of the same shape.

Related Tasks

7.2 Selection Tool
vs. Direct
Selection Tool

12.1 Importing a
Graphic Image

12.2 Setting Import
Options

12.12 Creating a
Clipping Path 
in InDesign

13.1 Placing and
Editing Text
Wraps

Shortcuts

Delete Anchor Point
tool
Mac and Win: -

Convert Direction
Point tool
Mac and Win: Shift+C

Pencil tool
Mac and Win: N

Scissors tool
Mac and Win: C

Temporarily select
Convert Direction
Point tool
Mac: Pen tool+Opt, or
Direct Selection
tool+Opt+Cmd
Win: Pen tool+Alt, or
Direct Selection
tool+Alt+Ctrl

Temporarily switch
between Add/Delete
Anchor Point tools
Mac: Opt
Win: Alt

Text Wrap palette
Mac: Opt+Cmd+W
Win: Alt+Ctrl+W
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12.10 Creating and Editing an InDesign
Clipping Path

One way to extract an image from a photograph is to create a clipping path—but be wary

of the InDesign clipping path controls. They are clumsy and not very precise. It makes

more sense to create a clipping path in Photoshop and apply it to the image in InDesign.

However, if all you need to do is remove a simple solid-color background, an InDesign

path will suffice.

To create an InDesign clipping path, select a placed image with either selection tool and

choose Object > Clipping Path. At the top of the Clipping Path dialog, choose Detect

Edges from the Type menu. You can then adjust the Threshold and Tolerance settings by

entering values in the respective fields or dragging the sliders. To see the path as you are

applying it, click the Preview check box.

The Threshold slider determines how close a color must be to white before it is removed.

Apply lower values to drop a light color background and higher values to drop a dark one.

The Tolerance slider determines how close a pixel must be to the Threshold value in

order to be removed by the clipping path. Once the Threshold and Tolerance values are

set, you can contract the resulting path and remove any black or white edges by entering

a value in the Inset Frame field.

The original image

Related Tasks:

2.3 File Menu

3.3 Selection Tool

3.4 Direct Selection
and Position
Tools

4.10 Links Palette

4.19 Text Wrap
Palette

Shortcuts

Clipping path
Mac: Opt+Shift+
Cmd+K
Win: Alt+Shift+Ctrl+K

Place
Mac: Cmd+D
Win: Ctrl+D

Links palette
Mac: Shift+Cmd+D
Win: Shift+Ctrl+D

Tip

To eliminate the need
to create a clipping
path, try placing a
transparent Photoshop
file (.PSD) instead.
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12.10 Creating and Editing an InDesign
Clipping Path (continued)

Dropping the sky area of the image by applying an InDesign clipping path

To allow the clipping path to recognize any areas inside of an image as defined by the

Threshold and Tolerance settings, enable the Include Inside Edges feature. You can also

invert an InDesign path by clicking the Invert check box.

Enabling the Restrict To Frame option limits the clipping path to include only the image

areas within the graphic frame and not the areas cropped outside. With this option on,

adjusting the crop means re-creating the path. Therefore, in most cases it is best to leave

this option off.

You can edit the path later using the same dialog. To do so, select the image and choose

Object > Clipping Path. Using the dialog, you can adjust the settings or turn off the path

by choosing None from the Type menu.

You can also adjust an InDesign clipping path by selecting the image with the Direct

Selection tool and editing the points using the various drawing tools, including the Pen

toolset, the Pencil toolset, the Scissors tool, and the Direct Selection tool.

Related Tasks:

7.2 Selection Tool
vs. Direct
Selection Tool

12.1 Importing a
Graphic Image

12.11 Altering an
Embedded
Photoshop Path

13.1 Placing and
Editing Text
Wraps

Shortcuts

Selection tool
Mac and Win: V

Direct Selection tool
Mac and Win: A

Text Wrap palette
Mac: Opt+Cmd+W
Win: Alt+Ctrl+W

Tip

InDesign also allows
you to apply alpha
channels embedded in
a placed Photoshop
image (.PSD). You can
select and apply an
alpha channel in the
Import Options or Clip-
ping Path dialog.
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