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When most people think of a spreadsheet product such as Excel, they think of
crunching rows and columns of numbers. But, as you probably know already,
Excel is no slouch when it comes to presenting data visually, in the form of a
chart. This chapter presents an introductory overview of Excel’s charting abil-
ity, and contains enough information for a typical user to start creating and
customizing charts.

What Is a Chart?

I'll start with the basics. A chart is a visual representation of numeric values.
Charts (also known as graphs) have been an integral part of spreadsheets since
the early days of Lotus 1-2-3. Charts generated by early spreadsheet products
were extremely crude by today’s standards. But, over the years, quality and
flexibility have improved significantly. You’ll find that Excel provides you with
the tools to create a wide variety of highly customizable charts.
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wawl NOTE

¥ In the first edition of this book, | offered an apology for the relatively poor visual quality
of Excel charts. I'm pleased to be able to retract that apology for the Excel 2007 edition.
The charting feature in Excel 2007 has come a long way, and Excel is now capable of
producing charts with much better visual appeal.

Displaying data in a well-conceived chart can make your numbers more understandable.
Because a chart presents a picture, charts are particularly useful for summarizing a series
of numbers and their interrelationships. Making a chart can often help you spot trends
and patterns that might otherwise go unnoticed.

Figure 1-1 shows a worksheet that contains a simple column chart that depicts a com-
pany’s sales volume by month. Viewing the chart makes it very apparent that sales were off
in the summer months (June through August), but they increased steadily during the final
four months of the year. You could, of course, arrive at this same conclusion simply by
studying the numbers. But viewing the chart makes the point much more quickly.

A B C D E F 3 H 1 ] B
1 Sales by Month
2 Jan 186,983
3 Feb 179,005 Sales by Month
4 Mar 193,422 250,000
5 Apr 185,956
6 May 196,025 200,000
7 Jun 140,323 2
& Jul 139,302 150,000
9 Aug 134,922
10 Sep 184,773 100,000
11 Oct 201,233
12 MNov 218,035 50,000
13 Dec 240,093
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16
17
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Figure 1-1: A simple column chart depicts the sales volume for each month.

A column chart is just one of many different types of charts that you can create with Excel.
By the way, creating this chart was simple: I selected the data in A1:B13, and then I
pressed Alt+F1.

(3 ONTHE CD
All the charts pictured in this chapter are available in a workbook on the companion
CD-ROM. The file is named introductory examples.xlsx.

How Excel Handles Charts

Before you can create a chart, you must have some numbers — sometimes known as data.
The data, of course, is stored in the cells in a worksheet. Normally, the data that is used by
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a chart resides in a single worksheet, but that’s not a strict requirement. As you'll see, a
chart can use data that’s stored in any number of worksheets, and the worksheets can even
be in different workbooks.

A chart is essentially an “object” that Excel creates upon request. This object consists of
one or more data series, displayed graphically. The appearance of the data series depends
on the selected chart type. For example, if you create a line chart that uses two data series,
the chart contains two lines, and each line represents one data series. The data for each
series is stored in a separate row or column. Each point on the line is determined by the
value in a single cell, and is represented by a marker. You can distinguish the lines by their
thickness, line style, color, or data markers.

Figure 1-2 shows a line chart that plots two data series across a 6-year period. The series

are identified by using different data markers (squares versus circles), shown in the legend
at the bottom of the chart. The lines also use different colors, which is not apparent in the
grayscale figure.
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1 ZIP 85012 ZIP 85255 n
2 2001 214,000 356,879 . N
5 2002 247,250 285,070 Median Home Prices
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8 600,000
9 500,000
10 400,000
ll 300,000
12

200,000

13
14 100,000
15 0
16 2001 2002 2003 2004 2005 2006
17 Ll
18 —8—ZIP 85012 ——ZIP B5255
19 |
H 4 » W Sheetl | Sheet2 ~¥J [ m [

Figure 1-2: This line chart displays two data series.

A key point to keep in mind is that charts are dynamic. In other words, a chart series is
linked to the data in your worksheet. If the data changes, the chart is updated automati-
cally to reflect those changes.

After you've created a chart, you can always change its type, change the formatting, add
new data series to it, or change an existing data series so that it uses data in a different
range.

Charts can reside in either of two locations in a workbook:

¢ In a worksheet (an embedded chart)
* On a separate chart sheet

| Hed
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Embedded Charts

An embedded chart basically floats on top of a worksheet, on the worksheet’s drawing layer.
The charts shown previously in this chapter are both embedded charts.

As with other drawing objects (such as a text box or a shape), you can move an embedded
chart, resize it, change its proportions, adjust its borders, and perform other operations.
Using embedded charts enables you to view the chart next to the data that it uses. Or, you
can place several embedded charts together so that they print on a single page.

When you create an Excel 2007 chart, it’s always an embedded chart. The exception to this
rule is when you select a range of data and press F11 to create a default chart. Such a
chart is created on a chart sheet.

To make any changes to the actual chart in an embedded chart object, you must click it to acti-
vate the chart. When a chart is activated, Excel displays the three Chart Tools context tabs
shown in Figure 1-3: Chart Tools=>Design, Chart Tools=>Layout, and Chart Tools=>Format.

@ HY-0-8&m@ p-Bh)s Books - Microsoft Excel Chart Tecls R
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= g i — ]
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Chart1 - A ¥
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Figure 1-3: Activating a chart displays additional tabs on the Excel Ribbon.
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Chart Sheets

You can move an embedded chart to its own chart sheet, so you can view it by clicking a
sheet tab. When you move a chart to a chart sheet, the chart occupies the entire sheet. If
you plan to print a chart on a page by itself, using a chart sheet is often your better choice.
If you have many charts to create, you may want to put each one on a separate chart sheet
to avoid cluttering your worksheet. This technique also makes locating a particular chart
easier because you can change the names of the chart sheets’ tabs to provide a description
of the chart that it contains.

Figure 1-4 shows a chart on a chart sheet. When a chart sheet is activated, Excel displays
the Chart Tools context tabs, as described in the previous section.

wa) INOTE

Previous versions of Excel have a Size with Window option for charts on a chart sheet.
When this setting is enabled, the chart adjusts itself when you resize the workbook win-
dow (it always fits perfectly in the window). This feature is not available in Excel 2007.
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Figure 1-4: A chart on a chart sheet
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What's new in Excel 2007?

In Microsoft Office 2007, the charting feature has undergone some major changes. If
you've used the charting feature in a previous version of Excel, this sidebar provides a
summary of what's new and what's changed.

The Office 2007 charting engine is compatible with other Office 2007 apps such as
Word and PowerPoint. In most (but not all) cases, charts created in a previous version
can render without a problem in Office 2007. Excel 2007 offers the following charting
changes:

A chart is a shape: In Office 2007, an embedded chart’s container is a shape
object. Although you can‘t change the type of shape, you can format the shape
using most of the new shape-formatting options.

Built-in chart layouts: Each chart type has a number of different predefined lay-
outs that you can apply with a single mouse click.

Built-in chart styles: Each chart type has a number of different predefined styles
that you can apply with a single mouse click.

More colors: The old 56-color limitation has been lifted, and a chart can now use
any number of colors. And the default color choices are much more pleasing to the
eye than the gaudy colors in previous versions.

Enhanced formatting: Office 2007 provides many significant enhancements in for-
matting chart elements, including quite a few interesting graphic effects.

Chart Wizard: In previous versions, most users invoked the Chart Wizard to assist
with creating a chart. The Chart Wizard is no longer available.

Size with Window: In previous versions, charts located on a chart sheet had a Size
with Window command that would automatically resize the chart when the window
size was changed. This feature has been removed.

Create a series by dragging: You can no longer create a new chart series by
selecting cells and dragging the selection into a chart. However, you can accom-
plish the same effect by copying and pasting.

Direct manipulation of data points: In the past, you could select a data point in a
chart and move it — which also changed the underlying data. This rarely used
action no longer works.

Keyboard shortcut: Office 2007 supports a new shortcut key combination (Alt+F1)
to create an embedded chart (of the default type) from the current range selection.
Pressing F11 still creates a chart sheet from the current range selection.
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¢ Rotating 3-D charts: In previous versions, you could use your mouse to directly
manipulate the view of a 3-D chart. In Office 2007, changing the view requires the
use of a dialog box.

e Pattern fills: Pattern fills (such as diagonal lines) for chart elements are no longer
supported. However, if you open an older file that uses pattern fills, the patterns
will continue to display in Office 2007.
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¢ Double-clicking to format: In the past, double-clicking a chart element (for exam-
ple, an axis) displayed a formatting dialog box appropriate for that element.
Double-clicking no longer displays a formatting dialog box. However, Office 2007
features a stay-on-top formatting dialog box that lets you modify the selected
chart element.

¢ Adding text to a chart: In previous versions, you could add arbitrary text to a
chart by selecting the chart and then typing the text (Excel created a text box
automatically). That action no longer works in Office 2007. You need to explicitly
insert a text box.

® PivotCharts retain their formatting: In previous versions, custom formatting
applied to a PivotChart was lost when the underlying PivotTable was refreshed.
This annoying bug has been fixed in Office 2007.

* Log scale enhancements: If you use a logarithmic scale for a chart’s value axis, you
are no longer limited to base-10 numbers. In addition, the minimum and maximum
scale values for a log chart are no longer constrained to powers of 10.

e Chart templates: Chart templates are much easier to create and apply in Office
2007. However, they still suffer from some limitations.

* No built-in custom chart types: Previous versions of Excel included several built-in
custom chart types (including several combination charts). These custom chart
types are no longer available.

e Charts and dialog sheets: In Excel 2007, you can no longer add a chart to a dialog
sheet. (Dialog sheets are fairly obsolete, anyway.)

* Document themes: Office 2007 supports document themes. A theme can be
applied to a document to change its overall look by using different fonts, colors,
and graphic effects. Applying a document theme changes the appearance of the
charts.

® Object model changes: If you're a VBA programmer, you'll also discover some new
twists in the charting object model.

Noticeably absent from this list are any new chart types. Unfortunately, Microsoft
hasn’t added any new chart types in Office 2007. Maybe in the next release . . .
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Parts of a Chart

A chart is made up of many different elements, and all of these elements are optional. Yes,
you can create a chart that contains no chart elements — an empty chart. It’s not very use-
ful, but Excel allows it.

Refer to the chart in Figure 1-5 as you read the following description of the chart’s elements.

Income & Profit
Income Profit Margin
1 11
11.2% F
£200,000 Lt 11.0% 1
9.6%
9.3% Fol0%
5150,000 + | gs
- B%
$100,000 +-—
4%
550,000
r %
50 : . : 0%
lan Feb Mar Apr
E Income =@ Profit

Figure 1-5: Parts of a chart

This particular chart is a “combination” chart that displays two data series: Income and
Profit Margin. Income is plotted as vertical columns, and the Profit Margin is plotted as a
line with square markers. Each bar (or marker on the line) represents a single data point
(the value in a cell).

The chart has a horizontal axis, known as the category axis. This axis represents the cate-
gory for each data point (January, February, and so on). This axis doesn’t have a label
because the category units are obvious.

Notice that this chart has two vertical axes. These are known as value axes, and each one
has a different scale. The axis on the left is for the column series (Income), and the axis on
the right is for the line series (Profit Margin).

The value axes also display scale values. The axis on the left displays scale values from 0
to 250,000, in major unit increments of 50,000. The value axis on the right uses a different
scale: O percent to 14 percent, in increments of 2 percent. For a value axis, you can control
the minimum and maximum values, as well as the increment value.

A chart with two value axes is appropriate because the two data series vary dramatically in
scale. If the Profit Margin data was plotted using the left axis, the line would not even be
visible.
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If a chart has more than one data series, you'll usually need a way to identify the data series
or data points. A legend, for example, is often used to identify the various series in a chart. In
this example, the legend appears at the bottom of the chart. Some charts also display data
labels to identify specific data points. The example chart displays data labels for the Profit
Margin series, but not for the Income series. In addition, most charts (including the example
chart) contain a chart title and additional labels to identify the axes or categories.

| Hed

The example chart also contains horizontal gridlines (which correspond to the values on the
left axis). Gridlines are basically extensions of the value axis scale, which makes it easier
for the viewer to determine the magnitude of the data points.

In addition, all charts have a chart area (the entire background area of the chart) and a plot
area (the part that shows the actual chart, including the plotted data, the axes, and the
axis labels).

Charts can have additional parts or fewer parts, depending on the chart type. For example,
a pie chart (see Figure 1-6) has “slices” and no axes. A 3-D chart may have walls and a
floor (see Figure 1-7).

Marital Status (Age 18+)

8%

B Married
OSingle
ODivorced
B Widowed

Figure 1-6: A pie chart

Several other types of items can be added to a chart. For example, you can add a trend line
or display error bars.

CROSS-REFERENCE
Refer to Chapters 4 and 5 for additional information about the elements available for
various chart types.
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Figure 1-7: A 3-D column chart

Chart limitations

The following table lists the limitations of Excel charts.

ltem

Charts in a worksheet

Worksheets referred to by a chart

Data series in a chart

Data points in a data series

Data points in a data series (3-D charts)

Total data points in a chart

Limitation

Limited by available memory
255

255

32,000

4,000

256,000

Most users never find these limitations to be a problem. However, one item that
frequently does cause problems is the limit on the length of the SERIES formula. Each

argument is limited to 255 characters, and in some situations, that's simply not enough

characters. Refer to Chapter 3 for more information about SERIES formulas.
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Basic Steps for Creating a Chart

The previous version of Excel featured a Chart Wizard that guided the user through the
steps required in creating a chart. The Chart Wizard is not available in Excel 2007, but cre-
ating basic charts is still relatively simple. The following sections discuss how to create
and customize a basic chart in Excel 2007.

| Hed

Creating the Chart
Follow these steps to create a chart in Excel 2007:

1. Select the data to be used in the chart.

Make sure that you select the column headers, if the data has them. Figure 1-8 shows
some data that’s appropriate for a chart. Another option is to select a single cell within a
range of data. Excel will then use the entire data range for the chart.

2. Click the Insert tab, and then click a Chart icon in the Charts group.
The icon expands into a gallery list that shows subtypes (see Figure 1-9).
3. Click the Chart subtype, and Excel creates the chart of the specified type.
Figure 1-10 shows a column chart created from the data.

A B C D E |4
1 Projected  Actual
2 |Jan 2,000 1,895
3 |Feb 2,500 2,643
4 Mar 3,500 3,648

w

(=N =]

i <>+ Sheet6 | Sheet7 ] .
Figure 1-8: This data would make a good chart.

Tip

To quickly create a default chart, select the data and press Alt+F1 to create an embed-
ded chart, or press F11 to create a chart on a chart sheet. You can also use these key-
strokes to duplicate a chart. If you select an embedded chart or chart sheet and press
F11, a new default chart sheet is created using the selected chart’s data. If you select an
embedded chart and press Alt+F1, a new blank chart is created. Alt+F1 has no apparent
effect on a chart sheet.
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Figure 1-9: The icons in the Insert®>Charts group expand to show a gallery of chart subtypes.

A | B c D | E | F G H [ ) K| 'i
11 Projected  Actual
| 2 Jan 2,000 1,895
| 2 Feb 2,500 2,642 2000
4 Mar 2,500 3,648
s | 3,500
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Flgure 1-10: A column chart with two data series

Switching the Row and Column Orientation

When Excel creates a chart, it uses a set of rules to determine whether the data is
arranged in columns or in rows. Most of the time Excel guesses correctly, but if it
creates the chart using the wrong orientation, you can quickly change it by choosing



Chapter 1: Introducing Excel Charts @

Chart Toolse>DesigneoDatam>Switch Row/Column. This command is a toggle, so if changing
the data orientation doesn’t improve the chart, just choose the command again (or click the
Undo button).

The orientation of the data has a drastic effect on the look (and, perhaps, understandabil-
ity) of your chart. Figure 1-11 shows the column chart after changing the orientation.
Notice that the chart now has three data series, one for each month. If the goal is to com-
pare actual with projected for each month, this version of the chart is much more difficult
to interpret because the relevant columns are not adjacent.
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Figure 1-11: The column chart, after swapping the row/column orientation

Changing the Chart Type

After you've created a chart, you can easily change the chart type. Although a column
chart may work well for a particular data set, there’s no harm in checking out some other
chart types. You can choose Chart Tools>Designeo>Typer>Change Chart Type to display the
Change Chart Type dialog box and experiment with other chart types. Figure 1-12 shows
the Change Chart Type dialog box.

wawl  NOTE

If your chart uses more than one data series, make sure that a chart element other than a
data series is selected when you choose the Chart Tools=>Design=>Type>Change Chart
Type command. If a series is selected, the command only changes the chart type of the
selected series. Selecting a single series before you issue the Change Chart Type com-
mand is the basis of creating combination charts (see Chapter 2 for more information
about combination charts).

In the Change Chart Type dialog box, the main categories are listed on the left, and the
subtypes are shown as icons. Select an icon and click the OK button, and Excel displays
the chart using the new chart type. If you don’t like the result, click the Undo button.
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Change Chart Type Bx]
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Figure 1-12: The Change Chart Type dialog box

Tip

If the chart is an embedded chart, you can also change a chart’s type by using the icons
in the Insert=>Charts group. In fact, this method is more efficient because it doesnt
involve a dialog box.

Applying a Chart Layout

Each chart type has a number of prebuilt layouts that you can apply with a single mouse
click. A layout contains additional chart elements, such as a title, data labels, axes, and so
on. This step is optional, but one of the prebuilt designs might be just what you’re looking
for. Even if the layout isn’t exactly what you want, it may be close enough that you need to
make only a few adjustments.

To apply a layout, select the chart and use the Chart Tools=>Design=>Chart Layouts gallery.
Figure 1-13 shows how a column chart would look using various layouts.

Applying a Chart Style

The Chart Tools=>Design=>Chart Styles gallery contains quite a few styles that you can
apply to your chart. The styles consist of various color choices and some special effects.
Again, this step is optional.
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Figure 1-13: One-click design variations of a column chart

Tip

styles designed for the selected theme.

The styles displayed in the gallery depend on the workbook’s theme. When you choose
Page Layout=>Themes to apply a different theme, you'll see a new selection of chart

Adding and Deleting Chart Elements

In some cases, applying a chart layout (as described previously) gives you a chart with all
the elements you need. Most of the time, however, you’ll need to add or remove some chart
elements and fine-tune the layout. You do this using the controls on the Chart Tools=>

Layout tab.

For example, to give a chart a title, choose Chart Tools=>Layout =>Labels>Chart Title. The
control displays some options that determine where the title is placed. Excel inserts a title
with the text Chart Title. Click the text and replace it with your actual chart title.
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How to master Excel charting

I've had the pleasure of meeting some of the world's leading Excel chart experts.
These people come from a variety of disciplines, but they all have two attributes in
common: They are creative, and they are not afraid to experiment.

Yes, dear reader, the key to mastering Excel charting is to think outside the box (as
they say) and experiment. Just because Excel doesn’t support a particular type of chart
doesn’t mean that you can't create such a chart. This book provides plenty of chart
examples that might seem to be impossible to a typical Excel user. Yet, with a bit of
ingenuity (and a few tricks), Excel can do some amazing things.

So don't be afraid to experiment and try some wacky things. The more you play
around with Excel, the more you discover. And most of the good stuff isn't in the
Help system.

Figure 1-14 shows our column chart after adding a title and specifying that the legend
should appear at the bottom of the chart (using Chart Tools=>Layout>Legende>Show
Legend at Bottom).

Projected and Actual Sales

4,000
3,500
3,000

2,500 ——

2,000 —

1,500 - —

1,000 - —

500 - —

[ T T 1
lan Feb Mar

M Projected Actual

Figure 1-14: Our column chart after adding a title and moving the legend

Formatting Chart Elements

Every element in a chart can be formatted and customized in many ways. Many users are
content with charts that are created using the steps described earlier in this chapter. But
because you're reading this book, you probably want to find out how to customize charts
for maximum impact.
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Excel provides two ways to format and customize individual chart elements. Both of the
following methods require that you select the chart element first:

e Use the Ribbon controls on the Chart Tools=>Format tab.

* Press Ctrl+1 to display the Format dialog box that’s specific to the selected chart
element.

;%/ NorTE
The Ribbon controls allow only a small subset of the formatting options. For maximum
control, use the Format dialog box.

For example, assume that you’d like to change the color of the columns for one of the
series in the chart. Click any column in the series (which selects the entire series). Then,
choose Chart Tools=>Formatr>Shape Stylese>Shape Fill and choose a color from the dis-
played list. To change the properties of the outline around the columns, use the Chart
Tools=>Formatr>Shape Stylese>Shape Outline control. To change the effects used in the
columns (for example, add a shadow), use the Chart Tools>Format=>Shape Styles=>Shape
Effects control.

Alternatively, you can select a column in the chart, press Ctrl+1, and use the Format Data
Series dialog box shown in Figure 1-15. Note that this is a tabbed dialog box. Click a tab
along the left side to view additional controls. It’s also a stay-on-top dialog box, so you can
click another element in the chart. In other words, you don’t have to close the dialog box to
see the changes you specify.

R 7l f Format Data Series mw
Projected and Actual Sales
Series Options | | Ejj|
4'[_)00 Fil
3,500 L 5 O Mo fil

o gorder Coior | | @ goid fil
— Border Styles | | O Gradent fil
() picture or texture fil

2,500

.| 2,000
| 1500
1,000
500

Shadow -
O Aytomatic
[ trwert if negatwve

E— Color: i2 -

Transparency: |

3D Format

W Projected ™ Actual

Figure 1-15: Using the Format Data Series dialog box
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Working with Charts

The following sections cover these common chart modifications:

* Moving and resizing a chart

* Converting an embedded chart to a chart on a chart sheet
* Copying a chart

* Deleting a chart

¢ Adding chart elements

* Moving and deleting chart elements

e Formatting chart elements

* Copying a chart’s formatting

¢ Renaming a chart

¢ Printing charts

Tacy NOTE

Before you can modify a chart, you must activate it. To activate an embedded chart, click
it. Doing so activates the chart and also selects the element that you click. To activate a
chart on a chart sheet, just click its sheet tab.

Moving and Resizing a Chart

If your chart is an embedded chart, you can freely move and resize it with your mouse.
Click the chart’s border and then drag the border to move the chart. Drag any of the eight
“handles” to resize the chart. The handles consist of three dots that appear on the chart’s
corners and edges when you click the chart’s border. When the mouse pointer turns into a
double arrow, click and drag to resize the chart.

When a chart is selected, you can use the Chart Toolsw>Format=>Size controls to adjust the
height and width of the chart. Use the spinners, or type the dimensions directly into the
Height and Width controls. Oddly, Excel does not provide similar controls to specify the top
and left positions of the chart.

To move an embedded chart, just click its border at any location except one of the eight
resizing handles. Then drag the chart to its new location. You also can use standard cut
and paste techniques to move an embedded chart. Select the chart and choose Homer>
Clipboard=>Cut (or press Ctrl+X). Then activate a cell near the desired location and choose
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Homer>Clipboard=>Paste (or press Ctrl+V). The new location can be in a different work-
sheet or even in a different workbook. If you paste the chart to a different workbook, it will
be linked to the data in the original workbook. Another way to move a chart to a different
location is to choose Chart Tools =>Design>Location=>Move Chart. This command displays
the Move Chart dialog box, which lets you specify a new sheet for the chart (either a chart
sheet or a worksheet).

Converting an Embedded Chart to a Chart Sheet

When you create a chart using the icons in the Insert=>Charts group, the result is always
an embedded chart. If you’d prefer that your chart be located on a chart sheet, you can eas-
ily move it.

To convert an embedded chart to a chart on a chart sheet, select the chart and choose
Chart Toolst>Designt>Location>Move Chart to display the Move Chart dialog box shown in
Figure 1-16. Select the New Sheet option and (optionally) provide a different name for the
chart sheet.

Move Chart

Choose where you want the chart to be placed:

_J_J,JJ (%) New sheet: | Chart1
[dmf] © objectin:  |Sheet3 v

| OK. il [ Cancel

Figure 1-16: Use the Move Chart dialog box to move an embedded chart
to a chart sheet (or vice versa).

To convert a chart on a chart sheet to an embedded chart, activate the chart sheet and then
choose Charte>Tools>Designe>Location>Move Chart to display the Move Chart dialog box.
Select the Object In option and specify the sheet by using the drop-down control.

Copying a Chart

To make an exact copy of a chart, select the chart (an embedded chart or a chart sheet)
and choose Homer>Clipboard=>Copy (or press Ctrl+C). Then activate a cell near the desired
location and choose Home=>Clipboard=>Paste (or press Ctrl+V). The new location can be in
a different worksheet or even in a different workbook. If you paste the chart to a different
workbook, it will be linked to the data in the original workbook.

Another way to copy a chart is to press Ctrl while dragging an embedded chart (or while
dragging a chart sheet’s tab).
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Deleting a Chart

To delete an embedded chart, press Ctrl and click the chart (this selects the chart as an
object). Then press Delete. When the Shift key is pressed, you can select multiple charts
and then delete them all with a single press of the Delete key.

To delete a chart sheet, right-click its sheet tab and choose Delete from the shortcut
menu. To delete multiple chart sheets, select them by pressing Ctrl while you click the
sheet tabs.

Adding Chart Elements

To add new elements to a chart (such as a title, legend, data labels, or gridlines), use
the controls in the Chart Toolse>Layout group. These controls are arranged into logical
groups, and they all display a drop-down list of options.

Moving and Deleting Chart Elements

Some of the elements within a chart can be moved. The movable chart elements include
the plot area, titles, the legend, and data labels. To move a chart element, simply click it
to select it. Then drag its border. The easiest way to delete a chart element is to select it
and then press Delete. You can also use the controls in the Chart Toolse>Layout group

to turn off the display of a particular chart element. For example, to delete data labels,
choose Chart Tools=>Layout=>Labels=>Data Labels=>None.

Note that deleting a chart element by using the controls in the Chart Tools=>Layout group
deletes the element (it doesn’t just hide it). For example, assume that you add a chart title
and apply formatting to it. Then you use the Chart Toolse>Layout=>Labelse>Chart Titlew>
None command to hide the title. If you later decide that you want the title, the previously
formatted title is gone and you need to re-apply the formatting.

A few chart elements consist of multiple objects. For example, the data labels element con-
sists of one label for each data point. To move or delete one data label, click once to select
the entire element and then click a second time to select the specific data label. You can
then move or delete the single data label.

Formatting Chart Elements

Many users are content to stick with the predefined chart layouts and chart styles. For
more precise customizations, Excel allows you to work with individual chart elements

and apply additional formatting. You can use the Ribbon commands for some modifications,
but the easiest way to format chart elements is to right-click the element and choose
Format from the shortcut menu. The exact command depends on the element you select.
For example, if you right-click the chart’s title, the shortcut menu command is Format
Chart Title. Alternatively, you can press Ctrl+1 to display the Format dialog box for the
selected element.
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The Format command displays a stay-on-top tabbed dialog box, with options for the
selected element.

Figure 1-17 shows the Format Axis dialog box, which I displayed by right-clicking the ver-
tical axis and selecting Format Axis from the shortcut menu.

Format Axis
fisOntiens | | Axis Options
Mumber Minimum: @) Auto (O Fixed
Fill Maximum: @) Auto (O Fixed
Line Color Major unit: (&) Auto (O Fixed
Line Style Minor unit: (&) Autg O Fixed
Shadow [ values in reverse order

3-D Format [ Logarithmic scale

alignment Display units: | None v
Major tick mark type: | Outside w
Minor tick mark type: | None w
Axis labels: Mext to Axis | w
Horizontal axis crosses:
@ Automatic
O Auis value:

O Maximum axis value

Close

Figure 1-17: Each chart element has a formatting dialog box.
This one is used to format a chart axis.

Tip

If you've applied formatting to a chart element and decide that it wasn't such a good
idea, you can revert to the original formatting for the particular chart style. Right-click
the chart element and choose Reset to Match Style from the shortcut menu. To reset the
entire chart, select the chart area when you issue the command.

% NOTE
s In previous versions of Excel, double-clicking a chart element displayed its Format dialog
box. That mouse action does not work in Excel 2007.
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Copying a Chart’s Formatting

If you create a nicely formatted chart, and realize that you need to create several more
charts that have the same formatting, you have these three choices:

* Make a copy of the original chart, and then change the data used in the copied chart.
One way to change the data used in a chart is to choose the Chart Toolse>Designr>
Datar>Select Data command and make the changes in the Select Data Source
dialog box.

* Create the other charts, but don’t apply any formatting. Then, activate the original chart
and press Ctrl+C. Select one of the other charts, and choose Homer>Clipboard->Paster>
Paste Special. In the Paste Special dialog box, click the Formats option, and then click
the OK button. Repeat for each additional chart.

* Create a chart template, and then use the template as the basis for the new charts. Or,
you can apply the new template to existing charts. See Chapter 2 for more information
about chart templates.

Renaming a Chart

When you activate an embedded chart, its name appears in the Name box (located to the
left of the formula bar). It seems logical that you can use the Name box to change the name
of a chart — but you can't.

To change the name of an embedded chart, use the Chart Toolst>Layout->Propertiest>Chart
Name box. Just type the new name and press Enter.

Why rename a chart? If a worksheet has many charts, you may prefer to activate a particu-
lar chart by name. Just type the chart’s name in the Name box and press Enter. It’s much
easier to remember a chart named Monthly Sales as opposed to a chart named Chart 9.

Printing Charts

Printing embedded charts is nothing special; you print them the same way that you print a
worksheet. As long as you include the embedded chart in the range that you want to print,
Excel prints the chart as it appears on-screen. When printing a sheet that contains embed-
ded charts, it’s a good idea to preview first (or use Page Layout View) to ensure that your

charts do not span multiple pages. If you created the chart on a chart sheet, Excel always

prints the chart on a page by itself.
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2. TIP

JAOF
>< If you select an embedded chart and choose Office=>Print, Excel prints the chart on a
= page by itself (as if it were a chart sheet) and does not print the worksheet.

If you don’t want a particular embedded chart to appear on your printout, select the chart,
choose Chart Tools=>Format, and then click the dialog box launcher in the Size group (it’s
the small icon to the right of the word Size) to display the Size and Properties dialog box.
In the Size and Properties dialog box, click the Properties tab and deselect the Print Object
check box (see Figure 1-18).

Size and Properties

Sige | Properties | Alt Text

Object positioning

(®) Move and size with cells
) Move but don't size with cells
() Don't move or size with cells

Print object
Locked

Locking objects has no effect unless the sheet is protected. To
help protect the sheet, choose Format on the Home tab, and
then choose Protect Sheet, A password is optional.

Figure 1-18: Specifying that a chart should not be printed with the worksheet
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