ELL..

Excel in a Nutsheli

IN THIS CHAPTER

L 2

A brief history of Excel

The object model concept in Excel

The workings of workbooks

The user interface

The two types of cell formatting

Worksheet formulas and functions

Objects on the worksheet’s invisible drawing layer
Macros, toolbars, and add-ins for Excel customization
Internet features

Analysis tools

® 6 O O 6 6 6 0 0 o

Protection options

Microsoft Excel has been referred to as “the best application ever written for
Windows.” You may or may not agree with that statement, but you can’t deny
that Excel is one of the oldest Windows products and has undergone many re-
incarnations and face-lifts over the years. Cosmetically, the current version —
Excel 2007 — barely even resembles the original version. However, many of
Excel’s key elements have remained intact over the years, with significant
enhancements, of course.
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This chapter presents a concise overview of the features available in the more recent ver-
sions of Excel, with specific emphasis on Excel 2007. It sets the stage for the subsequent
chapters and provides an overview for those who may have let their Excel skill get rusty.

Tacy NOTE
e If you're an old hand at Excel, you may want to read only the section on the Excel user
interface and ignore or briefly skim the rest of the chapter.

The History of Excel

You probably weren’t expecting a history lesson when you bought this book, but you may
find this information interesting. At the very least, this section provides fodder for the next
office trivia match.

Spreadsheets comprise a huge business, but most of us tend to take this software for
granted. In the pre-spreadsheet days, people relied on clumsy mainframes or calculators
and spent hours doing what now takes minutes.

It Started with VisiCalc

Dan Bricklin and Bob Frankston conjured up VisiCalc, the world’s first electronic spread-
sheet, back in the late 1970s when personal computers were unheard of in the office envi-
ronment. They wrote VisiCalc for the Apple II computer, an interesting machine that seems
like a toy by today’s standards. VisiCalc caught on quickly, and many forward-looking com-
panies purchased the Apple II for the sole purpose of developing their budgets with
VisiCalc. Consequently, VisiCalc is often credited for much of Apple II's initial success.

Then Came Lotus

When the IBM PC arrived on the scene in 1982, thus legitimizing personal computers,
VisiCorp wasted no time porting VisiCalc to this new hardware environment. Envious

of VisiCalc’s success, a small group of computer enthusiasts at a start-up company in
Cambridge, Massachusetts, refined the spreadsheet concept. Headed by Mitch Kapor

and Jonathon Sachs, the company designed a new product and launched the software
industry’s first full-fledged marketing blitz. Released in January 1983, Lotus Development
Corporation’s 1-2-3 proved an instant success. Despite its $495 price tag (yes, people
really paid that much for a single program), it quickly outsold VisiCalc and rocketed to the
top of the sales charts, where it remained for many years. Lotus 1-2-3 was, perhaps, the
most popular application ever.
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Microsoft Enters the Picture

Most people don’t realize that Microsoft’s experience with spreadsheets extends back to
the early 1980s. In 1982, Microsoft released its first spreadsheet — MultiPlan. Designed
for computers running the CP/M operating system, the product was subsequently ported to
several other platforms, including Apple II, Apple III, XENIX, and MS-DOS. MultiPlan
essentially ignored existing software user-interface standards. Difficult to learn and use, it
never earned much of a following in the United States. Not surprisingly, Lotus 1-2-3 pretty
much left MultiPlan in the dust.

Excel partly evolved from MultiPlan, first surfacing in 1985 on the Macintosh. Like all Mac
applications, Excel was a graphics-based program (unlike the character-based MultiPlan).
In November 1987, Microsoft released the first version of Excel for Windows (labeled
Excel 2 to correspond with the Macintosh version). Excel didn’t catch on right away, but as
Windows gained popularity, so did Excel. Lotus eventually released a Windows version of
1-2-3, and Excel had additional competition from Quattro Pro — originally a DOS program
developed by Borland International, then sold to Novell, and then sold again to Corel (its
current owner).

Excel Versions

Excel 2007 is actually Excel 12 in disguise. You may think that this name represents the
twelfth version of Excel. Think again. Microsoft may be a successful company, but its
version-naming techniques can prove quite confusing. As you’ll see, Excel 2007 actually
represents the tenth Windows version of Excel. In the following sections, I briefly describe
the major Windows versions of Excel.

EXceL 2

The original version of Excel for Windows, Excel 2 first appeared in late 1987. It was
labeled Version 2 to correspond to the Macintosh version (the original Excel). Because
Windows wasn't in widespread use at the time, this version included a runtime version of
Windows — a special version with just enough features to run Excel and nothing else. This
version appears quite crude by today’s standards, as shown in Figure 1-1.

EXxceL 3

At the end of 1990, Microsoft released Excel 3 for Windows. This version offered a signifi-
cant improvement in both appearance and features. It included toolbars, drawing capabili-
ties, worksheet outlining, add-in support, 3-D charts, workgroup editing, and lots more.

EXcEL 4

Excel 4 hit the streets in the spring of 1992. This version made quite an impact on the
marketplace as Windows increased in popularity. It boasted lots of new features and
usability enhancements that made it easier for beginners to get up to speed quickly.

| Hed
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Figure 1-1: The original Excel 2 for Windows. Excel has come a long way since its original version.
(Photo courtesy of Microsoft Corporation)

EXCEL 5

In early 1994, Excel 5 appeared on the scene. This version introduced tons of new fea-
tures, including multisheet workbooks and the new Visual Basic for Applications (VBA)
macro language. Like its predecessor, Excel 5 took top honors in just about every spread-
sheet comparison published in the trade magazines.

ExceL 95

Excel 95 (also known as Excel 7) shipped in the summer of 1995. On the surface, it resem-
bled Excel 5 (this version included only a few major new features). However, Excel 95
proved to be significant because it presented the first version to use more advanced 32-bit
code. Excel 95 and Excel 5 use the same file format.

ExceL 97

Excel 97 (also known as Excel 8) probably offered the most significant upgrade ever. The
toolbars and menus took on a great new look, online help moved a dramatic step forward,
and the number of rows available in a worksheet quadrupled. And if you're a macro devel-
oper, you may have noticed that Excel’s programming environment (VBA) moved up several
notches on the scale. Excel 97 also introduced a new file format.
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ExceL 2000

Excel 2000 (also known as Excel 9) was released in June of 1999. Excel 2000 offered sev-
eral minor enhancements, but the most significant advancement was the ability to use
HTML as an alternative file format. Excel 2000 still supported the standard binary file
format, of course, which is compatible with Excel 97.
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ExceL 2002

Excel 2002 (also known as Excel 10) was released in June of 2001 and is part of Microsoft
Office XP. This version offered several new features, most of which are fairly minor and
were designed to appeal to novice users. Perhaps the most significant new feature was the
capability to save your work when Excel crashes and also recover corrupt workbook files
that you may have abandoned long ago. Excel 2002 also added background formula error
checking and a new formula-debugging tool.

ExceL 2003

Excel 2003 (also known as Excel 11) was released in the fall of 2003. This version had
very few new features. Perhaps the most significant new feature was the ability to import
and export XML files and map the data to specific cells in a worksheet. It also introduced
the concept of the List, a specially designated range of cells. Both of these features would
prove to be precursors to future enhancements.

EXCEL 2007

Excel 2007 (also known as Excel 12) was released in early 2007. Its official name is
Microsoft Office Excel 2007. This latest Excel release represents the most significant
change since Excel 97, including a change to Excel’s default file format. The new format is
XML based although a binary format is still available. Another major change is the Ribbon,
a new type of user interface that replaces the Excel menu and toolbar system. In addition
to these two major changes, Microsoft has enhanced the List concept introduced in Excel
2003 (a List is now known as a Table), improved the look of charts, significantly increased
the number of rows and columns, and added some new worksheet functions. For more, see
the sidebar, “What’s New in Excel 2007?".

ey NOTE

XML (eXtensible Markup Language) stores data in a structured text format. The new file
formats are actually compressed folders that contain several different XML files. The
default format's file extension is .x1sx. There's also a macro-enabled format with the
extension .x1sm, a new binary format with the extension .x1sb, and all the legacy for-
mats that you're used to.
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The Object Model Concept

If you've dealt with computers for any length of time, you've undoubtedly heard the term
object-oriented programming. An object essentially represents a software element that a
programmer can manipulate. When using Excel, you may find it useful to think in terms
of objects, even if you have no intention of becoming a programmer. An object-oriented
approach can often help you keep the various elements in perspective.

Excel objects include the following:

¢ Excel itself

* An Excel workbook

* A worksheet in a workbook

* Arange in a worksheet

e A button on a worksheet

e A ListBox control on a UserForm (a custom dialog box)

* A chart sheet

e A chart on a chart sheet

e A chart series in a chart
Notice the existence of an object hierarchy: The Excel object contains workbook objects,
which contain worksheet objects, which contain range objects. This hierarchy is called
Excel’s object model. Other Microsoft Office products have their own object model. The

object model concept proves to be vitally important when developing VBA macros. Even if
you don’t create macros, you may find it helpful to think in terms of objects.

The Workings of Workbooks

The core document of Excel is a workbook. Everything that you do in Excel takes place in
a workbook.

Beginning with Excel 2007, workbook “files” are actually compressed folders. You may be
familiar with compressed folders if you've ever opened a file with a . zip extension. Inside
the compressed folders are a number of files that hold all the information about your work-
book, including charts, macros, formatting, and the data in its cells.

An Excel workbook can hold any number of sheets (limited only by memory). The four
types of sheets are

e Worksheets
e Chart sheets



Chapter 1: Excel in a Nutshell o

e MS Excel 4.0 macro sheets (obsolete, but still supported)
e MS Excel 5.0 dialog sheets (obsolete, but still supported)

You can open or create as many workbooks as you want (each in its own window), but only
one workbook is the active workbook at any given time. Similarly, only one sheet in a
workbook is the active sheet. To activate a different sheet, click its corresponding tab at
the bottom of the window, or press Ctrl+PgUp (for the previous sheet) or Ctrl+PgDn (for
the next sheet). To change a sheet’s name, double-click its Sheet tab and enter the new
text for the name. Right-clicking a tab brings up a shortcut menu with some additional
sheet-manipulation options.

You can also hide the window that contains a workbook by using the View=>Window=>
Hide command. A hidden workbook window remains open but not visible. Use the View=>
Window=>Unhide command to make the window visible again. A single workbook can dis-
play in multiple windows (choose View=>Window=>New Window). Each window can display
a different sheet or a different area of the same sheet.

Worksheets

The most common type of sheet is a worksheet — which you normally think of when you
think of a spreadsheet. Every Excel 2007 worksheet has 16,384 columns and 1,048,576
rows. After years of requests from users, Microsoft finally increased the number of rows
and columns in a worksheet.

How Big Is a Worksheet?

It's interesting to stop and think about the actual size of a worksheet. Do the
arithmetic (16,384 x 1,048,576), and you'll see that a worksheet has 17,179,869,184
cells. Remember that this is in just one worksheet. A single workbook can hold more
than one worksheet.

If you're using a 1024 x 768 video mode with the default row heights and column
widths, you can see 15 columns and 25 rows (or 375 cells) at a time — which is about
.000002 percent of the entire worksheet. In other words, more than 45 million screens
of information reside within a single worksheet.

If you entered a single digit into each cell at the relatively rapid clip of one cell per
second, it would take you over 500 years, nonstop, to fill up a worksheet. To print
the results of your efforts would require more than 36 million sheets of paper—a
stack about 12,000 feet high (that's ten Empire State Buildings stacked on top of
each other).

| Hed
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tas) NOTE

Versions prior to Excel 2007 support only 256 columns and 65,536 rows. If you open
such a file, Excel 2007 enters compatibility mode to work with the smaller worksheet
grid. In order to work with the larger grid, you must save the file in one of the Excel

2007 formats. Then close the workbook and reopen it.

Having access to more cells isn’t the real value of using multiple worksheets in a work-
book. Rather, multiple worksheets are valuable because they enable you to organize your
work better. Back in the old days, when a spreadsheet file consisted of a single worksheet,
developers wasted a lot of time trying to organize the worksheet to hold their information
efficiently. Now, you can store information on any number of worksheets and still access it
instantly.

You have complete control over the column widths and row heights, and you can even hide
rows and columns (as well as entire worksheets). You can display the contents of a cell
vertically (or at an angle) and even wrap around to occupy multiple lines.

wa) NOTE

s By default, every new workbook starts out with three worksheets. You can easily add a
new sheet when necessary, so you really don’t need to start with three sheets. You may
want to change this default to a single sheet. To change this option, use the Officer>
Excel Options command, click the Popular tab, and change the setting for the option
labeled Include This Many Sheets.

Chart Sheets

A chart sheet holds a single chart. Many users ignore chart sheets, preferring to use
embedded charts, which are stored on the worksheet’s drawing layer. Using chart sheets
is optional, but they make it a bit easier to locate a particular chart, and they prove espe-
cially useful for presentations. I discuss embedded charts (or floating charts on a work-
sheet) later in this chapter.

Macro Sheets and Dialog Sheets

An Excel 4.0 macro sheet is a worksheet that has some different defaults. Its purpose is
to hold XLM macros. XLM is the macro system used in Excel version 4.0 and previous ver-
sions. This macro system was replaced by VBA in Excel 5.0 and is not discussed in this
book.

An Excel 5.0 dialog sheet is a drawing grid that can hold text and controls. In Excel 5.0
and Excel 95, they were used to make custom dialog boxes. UserForms were introduced in
Excel 97 to replace these sheets.
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What's New in Excel 20072

Here's a quick and dirty overview of the new features in Excel 2007:

A new tab/Ribbon user interface

New XML file formats

Worksheet tables

Significantly larger worksheet grid (1,048,576 rows x 16,384 columns)
Ability to use more memory

Unlimited conditional formats per cell

100 levels of undo

Maximum formula length increased to 8,000 characters
Support for 64 levels of nesting in a formula

Formula autocomplete

Better-looking charts

Workbook themes

Skins

Page Layout view

New conditional formatting options

Less confusing Excel Options dialog box

New collaboration features (requires SharePoint)
SmartArt and Improved WordArt

Compatibility checker

Easier pivot tables

Twelve new worksheet functions, plus integration of the Analysis ToolPak
functions

PDF output (via a downloadable add-in)
Resizable formula bar
Many new templates

More control over the status bar

| Hed
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The Excel User Interface

A user interface (UI) is the means by which an end user communicates with a computer pro-
gram. A Ul includes elements such as menus, dialog boxes, toolbars, and keystroke combi-
nations, as well as features such as drag and drop.

A New User Interface

Almost every Windows program you use employs the menu and toolbar approach. That is,
at the top of the screen is a menu bar that contains virtually every command that’s avail-
able in the application and below that, one or more toolbars, which provide shortcuts to
some of the more frequently used commands. For Excel, and most of the other Microsoft
Office applications, the days of menus and toolbars are over.

The new UI for Excel consists of components like the Ribbon, the Office Button, the Mini
Toolbar, and the Quick Access toolbar. The Quick Access toolbar is the only UI element
that can be customized by end users.

The Ribbon

The Ribbon is the primary UI component in Excel. It replaces the menu and most of the
toolbars that were common in previous versions, and is a very significant departure from
the interfaces of most Windows-based applications.

ONE-STOP SHOPPING

Microsoft felt that the commands contained in the old menu and toolbar system were
becoming so numerous that a new paradigm was necessary. One of the main goals for
developing the Ribbon was to provide the user with a single place to look for a particular
feature. Every commonly used command available in Excel would be contained in the
Ribbon (or in a dialog box accessed via the Ribbon). Although Microsoft succeeded in
putting most of the available commands on the Ribbon, it’s still a pretty big place. Long-
time Excel users will have to endure a certain amount of frustration while they get used to
the new layout.

Tacy NOTE
s A few commands failed to make the cut, but they are still available if you know where to
look for them. Right-click the Quick Access toolbar and choose Customize Quick Access
Toolbar. Excel displays a dialog box with a list of commands that you can add to your
Quick Access toolbar (QAT). Some of these commands aren't available elsewhere in the Ul.

Tass, GrRoups, AND TooLS

The Ribbon is a band of tools that stretches across the top of the Excel window. About the
vertical size of three of the old style toolbars, the Ribbon sports a number of tabs including
Home, Insert, Page Layout, and others. On each tab are groups that contain related tools.
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On the Home tab, for example, you find the Clipboard group, the Font group, and the
Alignment group.

After you get past the Ribbon, the tabs, and the groups, you get to the tools, which are
similar to the tools that existed on the old style toolbars with one major difference: their
different sizes. Tools that are used most often are larger than less-frequently used tools.
Half of the Clipboard group is consumed by the large Paste tool; the Cut, Copy, and Format
Painter tools are much smaller. Microsoft determined that the Paste tool is the most used
tool and thus sized it accordingly.

The Ribbon and all its components resize dynamically as the Excel window is resized hori-
zontally. Smaller Excel windows collapse the tools on compressed tabs and groups, and
maximized Excel windows on large monitors show everything that’s available. Even in a
small window, all Ribbon commands remain available. You just may need to click a few
extra times to access them.

Figure 1-2 shows three sizes of the Ribbon when the Home tab is displayed using an
increasingly smaller horizontal window size.
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Figure 1-2: The Ribbon sizes dynamically, depending on the horizontal size of Excel's window.

NAVIGATION

Navigation of the Ribbon is fairly easy with the mouse. You click a tab and then click a
tool. If you prefer to use the keyboard, Microsoft has added a feature just for you. Pressing
Alt displays tiny squares with shortcut letters in them that hover over their respective tab
or tool. Each shortcut letter that you press either executes its command or drills down to
another level of shortcut letters. Pressing Esc cancels the letters or moves up to the previ-
ous level. For example, a keystroke sequence of Alt+H+B+B adds a double border to the
bottom of the selection. The Alt key activates the shortcut letters, the H shortcut activates
the Home tab, the B shortcut activates the Borders tool menu, and the second B shortcut
executes the Bottom Double Border command. Note that it’s not necessary to keep the Alt
key depressed while you press the other keys.

| Hed
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CONTEXTUAL TABS

The Ribbon contains tabs that are visible only when they are needed. Generally, when a
previously hidden tab appears, it’s because you selected an object or a range with special
characteristics (like a chart or a pivot table). A typical example is the Drawing Tools con-
textual tab. When you select a shape or WordArt object, the Drawing Tools tab is made
visible and active. It contains many tools that are only applicable to shapes, such as shape-
formatting tools.

SCREENTIPS AND DIALOG ICONS

Hovering over a tool on the Ribbon displays a ScreenTip that explains the command the
tool will execute. ScreenTips are larger and, in most cases, wordier than the ToolTips from
previous versions. They range in helpfulness from one word to long paragraphs and even
pictures.

At the bottom of many of the groups is a small box icon (a dialog box launcher) that opens a
dialog box related to that group. Users of previous versions of Excel will recognize these
dialog boxes, many of which are unchanged. Some of the icons open the same dialog boxes
but to different areas. For instance, the Font group icon opens the Format Cells dialog box
with the Font tab activated. The Alignment group opens the same dialog box but activates
the Alignment tab. The Ribbon makes using dialog boxes a far less-frequent activity than
in the past because most of what can be done in a dialog box can be done directly on the
Ribbon.

GALLERIES AND LIVE PREVIEW

A gallery is a large collection of tools that look like the choice they represent. If you've
used previous versions of Excel, you may have noticed that the font names in the drop-
down box on the Formatting toolbar were in their own font. Galleries are an extension of
that feature. The Styles gallery, for example, does not just list the name of the style but
lists it in the same formatting that will be applied the cell.

Although galleries help to give you an idea of what your object will look like when an
option is selected, Live Preview takes it to the next level. Live Preview displays your
object or data as it will look right on the worksheet when you hover over the gallery tool.
By hovering over the various tools in the Format Table gallery, you can see exactly what
your table will look like before you commit to a format.

The Office Button Menu

Although menus are a thing of the past in Excel 2007, one holdout remains: the Office
Button menu. In the upper-left corner of the Excel window is a round Microsoft Office logo
that is known as the Office Button. Click it, and you see a traditional menu with menu com-
mands (see Figure 1-3). Saving workbooks, opening workbooks, and printing are a few of
the commands available.
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Figure 1-3: Clicking the Office Button displays a menu, and some of the menu items have
submenus.

The Office Button menu also contains the list of recent documents, just as it had in previ-
ous versions. The recent documents list has undergone a major overhaul, however; the
maximum number of documents on the list is now 50 from the previous of 9, with push-pin
icons next to each entry that can be used to hold that document in its place on the list
regardless of how many files you open and close.

At the bottom of the Office Button menu is the Excel Options button. This button opens the
Excel Options dialog box, which contains dozens of settings for customizing Excel.

Shortcut Menus and the Mini Toolbar

Excel also features dozens of shortcut menus. These menus appear when you right-click
after selecting one or more objects. The shortcut menus are context sensitive. In other

| Hed
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words, the menu that appears depends on the location of the mouse pointer when you
right-click. You can right-click just about anything — a cell, a row or column border, a
workbook title bar, and so on.

Right-clicking many items displays the shortcut menu as well as a Mini Toolbar. The Mini
Toolbar is floating toolbar that contains a dozen or so of the most popular formatting com-
mands. Figure 1-4 shows the shortcut menu and Mini Toolbar when a range is selected.
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Figure 1-4: The shortcut menu and Mini Toolbar appears when you right-click a range.

The Quick Access Toolbar

The Quick Access toolbar (or QAT) is a set of tools that the user can customize. By default,
the QAT contains three tools: Save, Undo, and Redo. If you find that you use a particular
Ribbon command frequently, right-click the command and choose Add to Quick Access
Toolbar. You can make other changes to the QAT from the Customization tab of the Excel
Options dialog box. To access this dialog box, right-click the QAT and choose Customize
Quick Access Toolbar.

Smart Tags

A Smart Tag is a small icon that appears automatically in your worksheet after you com-
plete certain actions. Clicking a Smart Tag reveals several clickable options.

For example, if you copy and paste a range of cells, Excel generates a Smart Tag that
appears below the pasted range (see Figure 1-5). Excel features several other Smart Tags,
and additional Smart Tags can be provided by third-party providers.
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Figure 1-5: This Smart Tag appears when you paste a copied range.

Task Pane

Excel 2002 introduced the task pane. This is a multipurpose user interface element that is
normally docked on the right side of Excel’s window (but you can drag it anywhere you
like). The task pane is used for a variety of purposes, including displaying the Office
Clipboard, providing research assistance, displaying pivot table fields, and mapping XML
data. Figure 1-6 shows the task pane that appears when you insert clip art.

Drag and Drop

Excel’s drag-and-drop UI feature enables you to freely drag objects that reside on the draw-
ing layer to change their position. Pressing Ctrl while dragging duplicates the selected
objects. These objects include shapes, embedded charts, and SmartArt.

Excel also permits drag-and-drop actions on cells and ranges. You can easily drag a cell or
range to a different position. And pressing Ctrl while dragging copies the selected range.

tasy NOTE

¥ You can disable the ability to drag and drop cells. To change this setting, choose
Officee>Excel Options to display the Excel Options dialog box. Click the Advanced tab
and clear the Enable Fill Handle and Cell Drag-And-Drop check box (located in the
Editing Options section).
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Figure 1-6: The Clip Art task pane allows you to search for and insert an image.
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Keyboard Shortcuts

In addition to the keyboard shortcuts for navigating the Ribbon, Excel has many other key-
board shortcuts that execute commands directly. For example, you can press Ctrl+C to
copy a selection. If you're a newcomer to Excel or if you just want to improve your effi-
ciency, do yourself a favor and check out the shortcuts listed in Excel’s Help system.
(Search for Excel Shortcut and Function Keys using the Search box or locate the topic
under the Accessibility chapter of Help’s table of contents.) The Help system contains
tables that summarize useful keyboard commands and shortcuts.

To ease the transition from previous versions to Excel 2007, Microsoft includes the Office
2003 Access Keys feature. Many Excel users are accustomed to navigating the old menu
system with their keyboard, and they would become much more inefficient if they had to
rely on the new Ribbon. If you type an Alt+letter sequence that isn’t a part of the Ribbon
but that did exist in Excel 2003, you get a ScreenTip near the top of the Excel window, like
the one shown in Figure 1-7.

Customized Onscreen Display

Excel offers some flexibility regarding onscreen display (status bar, formula bar, the
Ribbon, and so on). For example, by choosing Viewr>Workbook Views>Full Screen, you
can get rid of everything except the title bar, thereby maximizing the amount of visible
information. To get out of full-screen mode, right-click and choose Exit Fullscreen from the
shortcut menu (or press Esc). A little less drastic is pressing the Ctrl+F1 shortcut key to
hide (and restore) the Ribbon.
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View Developer
Office 2003 access key: ALT, L,
= i ﬂ ‘.'.- ‘ ' ' Continue typing the Office 2003 menu key 23]
= sequence, or press Escape to cancel. =i
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Figure 1-7: Using a keyboard sequence like Alt+I+R (for Insert>Row) can still be used to insert a
row and will display this ScreenTip during the process.

The status bar has also been enhanced in Excel 2007. Right-click the status bar, and you
see lots of options that allow you to control what information is displayed in the status bar.

Many other customizations can be made by choosing Officec>Excel Options and clicking the
Advanced tab. On this tab are several sections that deal with what displays onscreen.

Data Entry

Data entry in Excel is quite straightforward. Excel interprets each cell entry as one of the
following:

¢ Avalue (including a date or a time)
e Text
e A Boolean value (TRUE or FALSE)

e A formula

el NOTE
R

Formulas always begin with an equal sign (=).

Object and Cell Selecting

Generally, selecting objects in Excel conforms to standard Windows practices. You can
select a range of cells by using the keyboard (using the Shift key, along with the arrow
keys) or by clicking and dragging the mouse. To select a large range, click a cell at any
corner of the range, scroll to the opposite corner of the range, and press Shift while you
click the opposite corner cell.

You can use Ctrl+* (asterisk) to select an entire table. And when a large range is selected,
you can use Ctrl+. (period) to move among the four corners of the range.

| Hed
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Data-Entry Tips

The following list of data-entry tips can help those moving up to Excel from another
spreadsheet:

* To enter data without pressing the arrow keys, enable the After Pressing Enter,
Move Selection option on the Advanced tab of the Excel Options dialog box
(which you access from the Officem>Excel Options command). You can also
choose the direction that you want to go.

* You may find it helpful to select a range of cells before entering data. If you do
so, you can use the Tab key or Enter key to move only within the selected cells.

* To enter the same data in all cells within a range, select the range, enter the
information into the active cell, and then press Ctrl+Enter.

* To copy the contents of the active cell to all other cells in a selected range, press
F2 and then Ctrl+Enter.

e To fill a range with increments of a single value, press Ctrl while you drag the fill
handle at the lower-right corner of the cell.

e To create a custom AutoFill list, select the Edit Custom Lists button on the
Popular tab of the Excel Options dialog box.

* To copy a cell without incrementing, drag the fill handle at the lower-right corner
of the selection; or, press Ctrl+D to copy down or Ctrl+R to copy to the right.

* To make text easier to read, you can enter line breaks in a cell. To enter a line
break, press Alt+Enter. Line breaks cause a cell’s contents to wrap within the cell.

* To enter a fraction, enter 0, a space, and then the fraction (using a slash). Excel
formats the cell using the Fraction number format.

* To automatically format a cell with the currency format, type your currency sym-
bol before the value.

* To enter a value in percent format, type a percent sign after the value. You can
also include your local thousand separator symbol to separate thousands (for
example, 123,434).

¢ To insert the current date, press Ctrl+; (semicolon). To enter the current time into
a cell, press Ctrl+Shift+;.

* To set up a cell or range so that it accepts entries only of a certain type (or within
a certain value range), use the Datar>Data Tools=>Data Validation command.

If you're working in a table (created with the Insert>Tables>Table command), you’ll find
that Ctrl+A works in a new way. Press it once to select the table cells only. Press Ctrl+A a
second time, and it select the entire table (including the header and totals row). Press it a
third time, and it selects all cells on the worksheet.
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Clicking an object placed on the drawing layer selects the object. An exception occurs if
the object has a macro assigned to it. In such a case, clicking the object executes the
macro. To select multiple objects or noncontiguous cells, press Ctrl while you select the
objects or cells.

The Excel Help System

One of Excel’s most important features is its Help system. The Help icon, a blue circle
with a question mark in it, is located near the upper-right corner of the Excel window.
Clicking the Help icon or pressing the F1 function key displays the help window, as shown
in Figure 1-8.

B
) Excel Help - x
el M- -XK
- F Search -
Table of Contents ® *
g What's new |~
4 Getting help I
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Figure 1-8: The Excel Help system window.

The two primary methods for navigating help are the Search box and the Table of Contents.
Typing keywords into the Search box and clicking the Search button displays a list of rele-
vant help articles in the main window. The Table of Contents lists many related help arti-
cles in chapters. The Table of Contents window can be hidden when not in use. Note that
the Search button is actually a drop-down control. Click the small arrow, and you can
choose the general type of Help you need.

By default, the content shown is downloaded from the Microsoft Office Online Web site.

If you do not have Internet access or you prefer to limit Help to articles on your computer,
click the Connection status bar in the lower-right corner of the Help window. A small
menu appears that allows you to specify which help system to use and also includes a Help
icon — help for the Help system.
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Cell Formatting

Excel provides two types of cell formatting — numeric formatting and stylistic formatting.

Numeric Formatting

Numeric formatting refers to how a value appears in the cell. In addition to choosing from
an extensive list of predefined formats, you can create your own custom number formats in
the Number tab of the Format Cells dialog box . (Choose the dialog box launcher at the bot-
tom of the Home>Number group.)

Excel applies some numeric formatting automatically, based on the entry. For example, if
you precede a value with your local currency symbol (such as a dollar sign), Excel applies
Currency number formatting.

CROSS REF

Refer to Appendix B for additional information about creating custom number formats.

The number format doesn'’t affect the actual value stored in the cell. For example, suppose
that a cell contains the value 3.14159. If you apply a format to display two decimal places,
the number appears as 3.14. When you use the cell in a formula, however, the actual value
(3.14159) — not the displayed value —is used.

Stylistic Formatting

Stylistic formatting refers to the cosmetic formatting (colors, shading, fonts, borders, and
so on) that you apply in order to make your work look good. The Homer>Font and Homer>
Styles groups contain all the commands that you need to format your cells and ranges.

A new formatting concept in Excel 2007 is document themes. Basically, themes allow you to
set many formatting options at once, such as font, colors, and cell styles. The formatting
options contained in a theme are designed to work well together. If you're not feeling par-
ticularly artistic, you can apply a theme and know the colors won't clash. All the com-
mands for themes are in the Themes group of the Page Layout tab.

Don'’t overlook Excel’s conditional formatting feature. This handy tool enables you to spec-
ify formatting that appears only when certain conditions are met. For exaniple, you can
make the cell’s interior red if the cell contains a negative number. Excel 2007 includes
many new conditional formatting options, and the feature is much easier to use than in pre-
vious versions.

CRrOSS REF

See Chapter 19 for more information on conditional formatting.
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Tables

A Table is a specially designated range in an Excel 2007 worksheet. If you used Lists in
Excel 2003, you will already be familiar with some of what the Table object has to offer. If
not, don’t worry. Excel 2007 makes it easy to designate a range as a Table and makes it
even easier to perform many functions on that data.

| Hed

The data in a table is related in a specific way. The rows represent related objects, and

the columns represent specific pieces of information about each of those objects. If, for
instance, you have a table of library books, each row would hold the information for one
book. Columns might include title, author, publisher, date, and so on. In database terminol-
ogy, the rows are records, and the columns are fields.

If your data is arranged in this fashion, you can designate it as a table by selecting the
range and then choosing InsertoTables>Table. Excel inserts generic column headings if
none exist, color banding, and heading drop-down arrows into the data. These arrows, as
well as the Table Tools context tab on the Ribbon, provide quick access to many table-
related functions like sorting, filtering, and formatting. In addition, using formulas within
a table offers some clear advantages.

CRrOSS REF

See Chapter 9 for more information about the new Table feature in Excel 2007.

Worksheet Formulas and Functions

Formulas, of course, make a spreadsheet a spreadsheet. Excel’s formula-building capability
is as good as it gets. You will discover this as you explore subsequent chapters in this
book.

Worksheet functions allow you to perform calculations or operations that would otherwise
be impossible. Excel provides a huge number of built-in functions, and Excel 2007 includes
a few new functions. In addition, worksheet functions that formerly required the Analysis
ToolPak add-in are now incorporated into Excel.

CRrOSS REF

See Chapter 4 for more information about worksheet functions.

Most spreadsheets allow you to define names for cells and ranges, but Excel handles
names in some unique ways. A name represents an identifier that enables you to refer

to a cell, range, value, or formula. Using names makes your formulas easier to create and
read.
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CRross REF

| devote Chapter 3 entirely to names.

Objects on the Drawing Layer

As I mention earlier in this chapter, each worksheet has an invisible drawing layer, which
holds shapes, SmartArt, charts, pictures, and controls (such as buttons and list boxes). I
discuss some of these items in the following sections.

Shapes

You can insert a wide variety of shapes from Insert>Shapes. After you place a shape on
your worksheet, you can modify the shape by selecting it and dragging its handles. In addi-
tion, you can apply built-in shape styles, fill effects, or 3-D effects to the shape. Also, you
can group multiple shapes into a single drawing object, which you'll find easier to size or
position.

lllustrations

Pictures, clip art, and SmartArt can be inserted from the Inserte>Illustrations group.
SmartArt replaces Diagrams from previous versions and have been expanded to include
dozens of choices. Figure 1-9 shows some objects on the drawing layer of a worksheet.

A B C D E F G i ] K L i

4 %
II

A4 b W Shesti ¥

Figure 1-9: Objects on a worksheet drawing layer. Excel makes a great doodle pad.
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Linked Picture Objects

A linked picture is a shape object that shows a range. When the range is changed, the
shape object changes along with it. To use this object, copy a range and then choose
Home=>Clipboard—>Paster>Paste As Picturer>Paste Picture Link. This command is useful
if you want to print a noncontiguous selection of ranges. You can “take pictures” of the
ranges and then paste the pictures together in a single area, which you can then print.

| Hed

Controls

You can insert a number of different controls on a worksheet. These controls come in two
flavors — Form controls and ActiveX controls. Using controls on a worksheet and can
greatly enhance the worksheet’s usability — often, without using macros. To insert a con-
trol, choose Developerm>Controlse>Insert. Figure 1-10 shows a worksheet with various
controls added to the drawing layer.

“y NOTE
The Ribbon's Developer tab is not visible by default. To show the Developer tab, choose
Officec>Excel Options, navigate to the Popular tab, and check Show Developer Tab in
the Ribbon.

(3 ON THE CD

If you'd like to see how these controls work, the workbook shown in Figure 1-10 is avail-
able on the companion CD-ROM. The file is named worksheet controls.xlsx.

AlB c D E B G H I i]‘
1
2
3 565 Interest from scroller
4 Purchase Price: $345,000 5.65 Percent
5  Finance the 55,000 loan fee
] TRUE Loan Fee
7 Per. Dewn Payment | Loan Term 5281,000 Loan
L] 10  30-year fixed
£ FALSE 30-year =
10 i IW:' @ 15-year fixed TRUE  15-year 1
11 s 15 Year term
12
13 Loan Amount: FALSE  10% down
14 FALSE  15% down
15 4 » 5.65% Interest TRUE  20% down
16 20% Down payment
-
18
19 Amortization Schedule I
20
bk |
W 4+ M Parameters ~ AmortSched %0 0 | m I

Figure 1-10: Excel enables you to add many controls directly to the drawing layer of a worksheet.
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Charts

Excel, of course, has excellent charting capabilities. As I mention earlier in this chapter,
you can store charts on a chart sheet or you can float them on a worksheet.

Excel offers extensive chart customization options. Selecting a chart displays the Chart
Tools contextual tab, which contain all the tools necessary to customize your chart. Right-
clicking a chart element displays a shortcut menu.

You can easily create a free-floating chart by selecting the data to be charted and selecting
one of the chart types from the Insert=>Charts group.

CRrOSS REF

Chapter 17 contains additional information about charts.

Customization in Excel

This section describes two features that enable you to customize Excel — macros and
add-ins.

Macros

Excel’s VBA programming language is a powerful tool that can make Excel perform other-
wise impossible feats. You can classify the procedures that you create with VBA into two
general types:

* Macros that automate various aspects of Excel

* Macros that serve as custom functions that you can use in worksheet formulas

CRross REF
Part VI of this book describes how to use and create custom worksheet functions
using VBA.

Add-in Programs

An add-in is a program attached to Excel that gives it additional functionality. For example,
you can store custom worksheet functions in an add-in. To attach an add-in, use the Add-
Ins tab in the Excel Options dialog box.
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Excel ships with quite a few add-ins, and you can purchase or download many third-party
add-ins from online services. My Power Utility Pak is an example of an add-in.

CRross REF
Chapter 23 describes how to create your own add-ins that contain custom worksheet
functions.

Internet Features

Excel includes a number of features that relate to the Internet. For example, you can save
a worksheet or an entire workbook in HTML format, accessible in a Web browser. In addi-
tion, you can insert clickable hyperlinks (including e-mail addresses) directly into cells.

A CAUTION
In Excel 2003, HTML was a round-trip file format. In other words, you could save a work-
book in HTML format, reopen it in Excel, and nothing would be lost. That's no longer the
case with Excel 2007. HTML is now considered an export-only format.

You can also create Web queries to bring in data stored in a corporate intranet or on the
Internet.

Analysis Tools

Excel is certainly no slouch when it comes to analysis. After all, most people use a spread-
sheet for analysis. Many analytical tasks can be handled with formulas, but Excel offers
many other options, which I discuss in the following sections.

Database Access

Over the years, most spreadsheets have enabled users to work with simple flat database
tables (even the original version of 1-2-3 contained this feature). Excel’s database features
fall into two main categories:

e Worksheet databases: The entire database is stored in a worksheet. In Excel, a work-
sheet database can have no more than 1,048,575 records (because the top row holds the
field names) and 16,384 fields (one per column).

e External databases: The data is stored outside Excel, such as in an Access MDB file or
in SQL Server.

| Hed
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Generally, when the cell pointer resides within a worksheet database, Excel recognizes it
and displays the field names whenever possible. For example, if you move the cell pointer
within a worksheet database and choose the Data=>Sort & Filter=>Sort command, Excel
allows you to select the sort keys by choosing field names from a drop-down list.

A particularly useful feature, filtering, enables you to display only the records that you
want to see. When Filter mode is on, you can filter the data by selecting values from pull-
down lists (which appear in place of the field names when you choose the Data>Sort &
Filter=>Filter command). Rows that don’t meet the filter criteria are hidden. See Figure
1-11 for an example.

If you convert a worksheet database into a table (by using Insert=>Tables>Table), filtering
is turned on automatically.

A B C D E F G H i

1 Name |~ Annual salary| ~ | Monthly Salary| = |Location |~ Date Hired [ = Exempt =

2 JoeMorrisol #} | Sort Smallest to Largest Seattle 1/29/2000 TRUE

3 | Douglas Wil 21| Sort Largestto Smallest Portland 10/10/2006  TRUE

4 |Clark Bicker: Los Angeles 7312002 TRUE

5 | James mille Sort by Color * lLos Angeles 4/21/2000 FALSE

6 |Chris Pound| ¢ Seattle 5/24/2000  TRUE

7 Phillip A. To| Fiter by Color » Portland 6/18/2007  FALSE

& |Richard E. Saattla J6II00S  EALSE

9 |Steven H. K Mumber Eilters (] Equals... RUE

10 |StephenC. [l {Select Al ~ Does Not Equal... RUE

12 Charles 5. Bi %2317 T IALSE

13 | Michael Hay F42,342 Aireateraltian, laLsE 1
14 Ivan Silberst S ﬁ:g?? Greater Than Or Equal To... IALSE I
15 Tom Brown 42,957 = Less Than... IALSE

16 |Robert H. M [ 83,333 IALSE

- Less Than Or Egual To...

17 | Kurt Kamich @sio 2 ALSE

18 John T. Fost E:’ e . Between... laLse

19 ThomasE. A [w]55,133 Topl0... IALSE

20 | Rick Fogerty] 1] $5,033 bove A ALSE

21 |Jeffrey . Jo| I :-:;’ SR laLSE |

[l 55,
v} bt ) Belgw Average
23 Custom Ei
Custom Filter...

24 OK Cancel =

25 .

26

27

hei=3

W4k M Sheetl %7 _|. m

. P . .
Figure 1-11: Excel’s Filter feature makes it easy to view only the database records that meet your
criteria.

If you prefer, you can use the traditional spreadsheet database techniques that involve cri-
teria ranges. To do so, choose the Datam>Sort & Filter->Advanced command.

CRross REF
Chapter 9 provides additional details regarding worksheet lists and databases.

Excel can automatically insert (or remove) subtotal formulas in a table that is set up as a
database. It also creates an outline from the data so that you can view only the subtotals
or any level of detail that you desire.



Chapter 1: Excel in a Nutshell @

Outlines

A worksheet outline often serves as an excellent way to work with hierarchical data, such
as budgets. Excel can create an outline automatically by examining the formulas in your
worksheet (use the Data=>Outline>Subtotal command). After you've created an outline,
you can collapse or expand the outline to display various levels of details. Figure 1-12
shows an example of a worksheet outline.

1 = K
z = = =
3
1]z[3 A B [s D E F G H | J |
1 State lan Feb Mar Qtr-1 Apr May Jun Qtr-2 Total
2 califarnia 1,118 1,960 1,252 4,330 1,371 1,557 1,679 4,507 8,637
3 Washington 1,247 1,238 1,028 3.513 1,345 1,784 1,574 4,703 8,216
4 Oregon 1,460 1,954 1,726 5,140 1,461 1,764 1,144 4,369 9,509
= | 5 Arizona 1,345 1,375 1,075 3,795 1,736 1,555 1,372 4,663 8,458
= 6 West Total 5170 6,527 5,081 16,778 5813 6,660 5,769 18,242 35,020
[ 7 New York 1,429 1,316 1,993 4,738 1,832 1,740 1,191 4,763 9,50 =
8 New lersey 1,735 1,406 1,224 4,365 1,706 1,320 1,290 4,316 8,681
9 Massachusetts 1,099 1,233 1,110 3.442 1,637 1,512 1,006 4,155 7,597
10 Florida 1,705 1,792 1,225 4,722 1,946 1,327 1,357 4,630 9,352
=) | 1 EastTotal 5,568 5,747 5552 17,267 721 5,899 4884 17,864 35,131
12 Kentucky 1,109 1,078 1,155 3,342 1,993 1,082 1,551 4,626 7,968
13 Oklahoma 1,309 1,045 1,641 3,995 1,924 1,499 1,941 5,764 9,359
14 Missouri 1,511 1,744 1,414 4,669 1,243 1,493 1,820 4,506 9,225
15 Illingis 1,539 1,493 1,211 4,243 1,165 1,013 1,445 3,623 7,866
16 Kansas 1,973 1,560 1,243 4,776 1,495 1,125 1,387 4,007 8,783 |
= 17 Central Total 7441 6,920 6,664 1,025 7.820 6,212 8144 22,176 43,21
- 18 Grand Total 18,579 19,194 17,297 55.070 20,754 18.771 18.757 58,282 113,352
19 5
W 4 b M| Sheatl <73 0 m I

Figure 1-12: Excel can automatically insert subtotal formulas and create outlines.

Scenario Management

Scenario management is storing input values that drive a model. For example, if you have a
sales forecast, you may create scenarios such as best case, worst case, and most likely
case.

Excel’s Scenario Manager can handle only simple scenario-management tasks, but most
users find it adequate. However, it is definitely easier than trying to keep track of different
scenarios manually.

Pivot Tables

One of Excel’s most powerful tools is the pivot table, which enables you to display summa-
rized data in just about any way possible. Data for a pivot table comes from a worksheet
database (or table) or an external database, and is stored in a special cache, which enables
Excel to recalculate data rapidly after a pivot table is altered.

| Hed
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CRross REF

Chapter 18 contains additional information about pivot tables.

As a companion to a pivot table, Excel also supports the pivot chart feature. Pivot charts
enable you to link a chart to a pivot table. In Excel 2007, pivot charts have improved
significantly.

Auditing Capabilities

Excel also offers useful auditing capabilities that help you identify errors or track the logic
in an unfamiliar spreadsheet. To access this feature, choose commands in the Formulas=
Formula Auditing group.

CRrRoOSS REF

Refer to Chapter 21 for more information about Excel’s auditing features.

Solver Add-in

For specialized linear and nonlinear problems, Excel’s Solver add-in calculates solutions
to what-if scenarios based on adjustable cells, constraint cells, and, optionally, cells that
must be maximized or minimized.

Protection Options

Excel offers a number of different protection options. For example, you can protect formu-
las from being overwritten or modified, protect a workbook’s structure, and protect your
VBA code.

Protecting Formulas from Being Overwritten

In many cases, you may want to protect your formulas from being overwritten or modified.
To do so, you must unlock the cells that you will allow to be overwritten and then protect
the sheet. First select the cells that may be overwritten and choose Homer>Cellsw>
Format=>Lock to unlock those cells. (The command toggles the Locked status.) Next,
choose Homer>Cells>Format=>Protect Sheet to show the Protect Sheet dialog. Here you
can specify a password if desired.

)y NOTE
57 By default, all cells are locked. Locking and unlocking cells has no effect, however, unless

you have a protected worksheet.
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Beginning with Excel 2002, Excel’s protection options have become much more flexible.
When you protect a worksheet, the Protect Sheet dialog box (see Figure 1-13) lets you
choose which elements won’t be protected. For example, you can allow users to sort data
or use autofiltering on a protected sheet (tasks that weren’t possible with earlier versions).
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Protect Sheet E]

Protect worksheet and contents of locked cells

Password to unprotect sheet:

Allgw all users of this worksheet to:

Select locked cells A
Select unlocked cells I
[ Format cells

[]Format columns

D Format rows

[]insert columns

[ |1nsert rows

[:I Insert hyperlinks

[l Delete columns

[IDelete rows ™

I QK I[ Cancel ]

Figure 1-13: Choose which elements to protect in the Protect Sheet dialog box.

You can also hide your formulas so they won't appear in the Excel formula bar when the
cell is activated. To do so, select the formula cells and press Ctrl+1 to display the Format

Cells dialog box. Click the Protection tab and make sure that the Hidden check box is
selected.

Protecting a Workbook’s Structure

When you protect a workbook’s structure, you can’t add or delete sheets. Use the Review=>
Changes>Protect Workbook command to display the Protect Structure and Windows dialog
box, as shown in Figure 1-14. Make sure that you enable the Structure check box. If you
also mark the Windows check box, the window can’t be moved or resized.

Protect Structure and Windows E]
Protect workbook for

Structure
[ windows

Password (optional):

I OK I[ Cancel ]

Figure 1-14: The Protect Structure and Windows dialog box.
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CAuTION

Keep in mind that Excel is not really a secure application. The protection features, even
when used with a password, are intended to prevent casual users from accessing various
components of your workbook. Anyone who really wants to defeat your protection can
probably do so by using readily available password-cracking utilities.

Password-protecting a Workbook

In addition to protecting individual sheets and the structure of the workbook, you can
require a password to open the workbook. To set a password, choose Officer>Preparew>
Encrypt Document to display the Encrypt Document dialog box (see Figure 1-15). In this
dialog box, you can specify a password to open the workbook.

-

Encrypt Document
Encrypt the contents of this file
Password:

Caution: If you lose or forget the password, it cannot be
recovered. Itis advisable to keep a list of passwords and
their corresponding document names in a safe place.
(Remember that passwords are case-sensitive.)

Ok, ][ Cancel ]

Figure 1-15: Use the Encrypt Document dialog box to specify a password for a workbook.



