Chapter 1
AutoCAD and the User Interface

In This Chapter
Launching AutoCAD and using command line switches
Looking at the user interface of AutoCAD
Using commands and providing input
Getting help from AutoCAD

Being proficient with AutoCAD and its user interface can help make drafting tasks easier
based on how familiar you are with all the tools that are just a click away. The exercises
in this chapter give you an understanding of how to use the various interface elements that
AutoCAD has to offer to make sure you have the tools available when you need them.

The exercises in this chapter use the AutoCAD Classic workspace. To set the AutoCAD Classic
workspace current, choose Toolsr>Workspaces=>AutoCAD Classic. For more information on
using and creating workspaces, see Chapter 3.

Launching AutoCAD

AutoCAD is one of the most popular computer-aided drafting applications on the market
today. You can use it to design plans for residential homes and complex drawings such as
paper-converting machines and circuit boards. To become efficient with AutoCAD, you
should get to know as many methods of launching the program as possible.
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1. Howcan you start AutoCAD?
A. From the Start menu
B. From a shortcut on the desktop, taskbar, or Quick Launch toolbar
C. Insert the product CD/DVD into the CD/DVD-ROM
D

By opening a drawing file

Exercise 1-1: Launching AutoCAD

In this exercise, you add a shortcut to the desktop, the Start menu, and the Quick Launch
toolbar.
\3
P 1 Add an AutoCAD shortcut to the Windows desktop by creating a copy of the one
that appears in the AutoCAD 2008 folder. Choose Start=>(All) Programs= Autodesk.
Right-click the AutoCAD 2008 icon and choose Send To=>Desktop (Create Shortcut).
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1 Add a shortcut for AutoCAD to the Start menu. Right-click the AutoCAD short-
cut on the desktop and choose Pin to Start Menu.

v Add a shortcut for AutoCAD to the Quick Launch toolbar. Drag and drop the
AutoCAD shortcut from the desktop into place on the Quick Launch toolbar. If
the Quick Launch toolbar isn’t visible on the taskbar, right-click the taskbar and
choose Toolbars=>Quick Launch.

AutoCAD allows you to use what are called command line switches. Command line
switches automate some of the tasks that are normally performed each time you start
AutoCAD. Removing manual steps from the start-up process ensures that the drawings
you create are more consistent with each; then you can worry more about the models
that you need to create than all the intricate setup processes. You use them in con-
junction with desktop shortcuts that define the default template, workspace, and user
profile that are set up when AutoCAD first starts.

Command Line
Switch

/p

/t

/w

Description

Allows you to specify which user profile to use when AutoCAD
starts. For information on user profiles, see Chapter 3.

Allows you to specify which drawing template to use for the
default drawing that is created when AutoCAD launches. For more
information on drafting templates and creating a new drawing,
see Chapter 2.

Allows you to specify which workspace to use when AutoCAD
starts. For information on user workspaces, see Chapter 3.

You can use more than one command line switch at a time with a shortcut; you just
need to use them correctly. Figure 1-1 shows an example of using the /t and /w com-

mand line switches.
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In Exercise 1-2, you create a command line switch for AutoCAD. To access the shortcut proper-
ties in order to add a command line switch, right-click and choose
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Exercise 1-2: Customizing a Desktop Shortcut with Command Line Switches

In this exercise, you customize a desktop shortcut (see Exercise 1-1) to specify a tem-
plate for the default drawing and which workspace should be set current when
AutoCAD is first launched.

1. Access the Properties dialog box for your AutoCAD shortcut.
In the Properties dialog box, click the Shortcut tab.

2.
3. On the Shortcut tab, position the cursor at the end of the path to the acad.exe
file in the Target text box and click.

Press the spacebar once to add a space after the executable file’s path. Then
enter this text:

/t acad3d.dwt /w "3D Modeling"

The /t command line switch uses the drawing template acad3d. dwt that ships
with AutoCAD to create the default drawing, and the /w command line switch
sets the 3D modeling workspace current. After you add the text in the Target text
box, the text looks like the following:

"C:\Program Files\AutoCAD 2008\acad.exe" /t acad3d.dwt /w "3D
Modeling"

5. Click the General tab and change the name of the shortcut in the Name text box
near the top to My AutoCAD.

Click OK to save the changes.

NS

Double-click the shortcut to test the changes made.

AutoCAD launches with the default drawing based on the acad3d. dwt file and
the 3D Modeling workspace is set current.

If the name of the drawing template, profile, or workspace contains a space, you must
wrap the name with double quotation marks in order for AutoCAD to interpret the
command line switches properly.

For additional information on other command line switches that are available for use
with an AutoCAD shortcut, see the Customize Startup topic in the AutoCAD Online
Help system.

Navigating the User Interface

The AutoCAD user interface — or Ul as it’s often referred to — can be very overwhelm-
ing, but it doesn’t have to be. All you need is some understanding of how things are
laid out and what the various Ul elements are. AutoCAD, like other Windows-based
applications, has pull-down menus, toolbars, a document area, and a status bar area,
but AutoCAD also has some unique user interface elements that aren’t found in a lot

of other applications. Some of the unique interface elements are a Command Line
window, dynamic input tooltips, and dockable windows. Figure 1-2 shows many of the
different user interface elements that are found in AutoCAD.

9
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The drawing window (see Figure 1-3) is the main area in the middle of AutoCAD where
you add and modify objects in the designs that you create. When you create a new
drawing or open an existing drawing, a drawing window appears. Each open drawing
has its own drawing window. Along the bottom of each drawing window, you find these

items:

v A series of tabs similar to those found in a spreadsheet program; these tabs repre-
sent where you create your model (Model tab) and the layouts used for plotting

different views of your model.

You can turn off the Model tab and layout tabs if you don’t want them displayed.
In their place are two buttons that allow you to switch to a different layout tab.

v To the left of the tabs are navigation controls that allow you to scroll to the first,
last, next, or previous layout tab if all the tabs can’t be displayed along the bottom

of the drawing window at a time.

1 The drawing status bar along the bottom displays settings specific to the drawing,
such as the current annotation scale. If you disable the drawing status bar, the
options are displayed in the status bar area of the application window instead.
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Exercise 1-3: Navigating the Drawing Window

Practice using some of the user interface elements of the drawing window.

1.

Create a new drawing based on the ANST A (portrait) -Color Dependent
Plot Styles.dwt template that comes with AutoCAD.

In AutoCAD, choose Filec>New. In the Select Template dialog box, select the ANST
A (portrait) -Color Dependent Plot Styles.dwt template file and
click Open. The drawing templates that come with AutoCAD are located in the
Templates folder at C: \Documents and Settings\user name\Local
Settings\Application Data\Autodesk\AutoCAD 2008\R17.1\enu;
substitute user name with your Windows login name.

Turn to Chapter 2 to find out how to create a new drawing.
Click the Model tab and layout tabs to view the contents of each one.

Right-click one of the tabs and choose Hide Layout and Model Tabs to toggle the
display for the layout tabs.

To display the tabs again, right-click the Model or Layout button in the status bar
area and choose Display Layout and Model Tabs.

View the contents of each of the layouts by clicking the Model and Layout but-
tons in the application window’s status bar; they’re displayed to the right of the
button labeled LWT (as shown in Figure 1-4).

Click the Status Bar Menu button to the left of the Clean Screen icon on the appli-
cation status bar (refer to Figure 1-2). Choose Drawing Status Bar. Make sure that
a check mark is next to Drawing Status Bar.

Some of the icons in the status bar tray move to the bottom of the drawing
window along with the controls for annotation scale.

11
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6. Turn off the Drawing Status Bar setting.
Click the button to the right of the Layout button named Additional Layouts to
display a list of all the layouts in the drawing.

Press Ctrl+Page Up to navigate to the previous layout or Ctrl+Page Down to navi-
gate to the next layout in the drawing.

Command Line window

The Command Line window by default is displayed between the drawing window and
the status bar area. If you don’t like its position, you can dock it above or along the left
or right side of the drawing window. The Command Line window plays a key role in
inputting commands, options, and values to create and modify objects; it also displays
command prompts and messages to let you know what AutoCAD is waiting for.

If you want to gain additional room in the AutoCAD application window, you can close
the Command Line window. Press Ctrl+9 to toggle the display of the Command Line
window on and off. When the Command Line window is hidden, command prompts
and options are displayed in dynamic tooltips. Press F12 to toggle the display of
dynamic tooltips. For more information on dynamic input, see the “Dynamic input”
section later in this chapter.

Text window

The Text window displays a running history of the commands and options that you
previously entered in the Command Line window or at the dynamic input tooltip. You
won’t need the Text window very often, but if you need to see what you did a few com-
mands ago, press F2 to bring up the Text window.

Status bar

The status bar allows you to quickly access drafting settings and other settings that are
used for some of the features. Most of the settings on the status bar allow you to toggle
drafting settings on or off without opening a dialog box or remembering a shortcut key

combination. Also, you can right-click most buttons to access options that allow you to
change the behavior of the drafting settings.
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Table 1-1 lists the different buttons on the status bar.

Table 1-1 Status Bar Buttons
Button Name Description
163.0, 511,06, 0.0 Coordinates Toggles among absolute, relative, and polar
coordinate display settings
SNAP Snap Mode Toggles grid or PolarSnap on and off
GRID Grid Display Toggles the display of the grid on and off
ORTHO Ortho Mode Toggles ortho mode on and off
FOLAR Polar Tracking Toggles polar tracking on and off
OSNAP Object Snap Toggles running object snaps on and off
OTRALK Object Snap Tracking Toggles object snap tracking on and off
DUCS Dynamic UCS Toggles dynamic UCS on and off

Dynamic Input

Toggles dynamic input on and off

LM

LT Show/Hide Lineweight Toggles the display of lineweights on and off
MODEL Model/Paper Space Toggles between model and paper space
IE 4 Model/Layout and Toggles between model and paper space,

Additional Layouts

and switch paper space layouts

Minimize/Maximize and
Viewport Navigation

Toggles between maximized and minimized
viewport states, and allows you to switch
among different viewports

e ETY 1| Status Bar Tray

Displays the current notification icons for
the features that are in use in the current
session and drawing

Exercise 1-4: Using the Status Bar

In this exercise, you create a new drawing and use some of the drafting settings that

are available on the status bar.

’. Choose File=>New.

2. In the Select Template dialog box, double-click the acad.dwt drawing

template file.
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3. Choose Drawe>Line, or type line at the command prompt and press Enter.
4. Pick a point in the drawing window to start drawing a line.

5. On the status bar, click DYN until the button appears popped out. When a button
is popped out, the drafting setting is turned off, and in this case you toggled
Dynamic Input off.

Move the crosshairs in the drawing window; no dynamic input tooltips are dis-
played trailing the crosshairs. The dynamic input tooltip is an extension of the
Command Line window that displays the current command prompt and input
boxes that allow you to specify coordinate values, distances, or angles among
other values for the current command. For more information on dynamic input,
see the “Dynamic input” section later in this chapter.

6. Turn on Dynamic Input.

Move the crosshairs in the drawing window; the dynamic input tooltips display
trailing the crosshairs. With the LINE command active yet, you should see the
command prompt Specify next point and a down arrow that allows you to
access the available command options. After the command prompt, you see two
input boxes that allow you to specify the X- and Y-coordinate values for the end
point for the line.

7. Turn on ortho mode.

Move the crosshairs in the drawing window; you can draw a straight line only in
90-degree increments starting with 0 because ortho mode constrains the coordi-
nate value horizontal or vertical from the previous point specified.

8. Turn off ortho mode.
You can now create a line at any angle that you want to.
9. Press Esc to exit the LINE command.

Exercise 1-5: Controlling the Display of Controls on the Status Bar

For this exercise, open a drawing (a new one or one from a previous exercise). Practice
controlling the display of controls on the status bar.

1. onthe right side of the status bar area, click the Status Bar Menu button
(located to the left of the Clean Screen icon).

2. Select the controls that you want to display or hide on the status bar.

The items selected are displayed, and the ones that aren’t selected are currently
hidden. It’s a good idea to display only the controls that you frequently use.

Status bar tray

On the right side of the status bar is an area called the status bar tray. The status bar
tray provides access, via an icon, to features that you're currently using in the active
drawing or AutoCAD. When the icon for a feature is displayed, you can click or right-
click the icon to access settings and other options for the feature. As you work in a
drawing, certain situations cause a notification balloon to be displayed. The notifica-
tion balloon lets you know when you’'ve done something that affects your drawing,
such as adding a new layer that doesn’t match the current set of CAD standards or
completing a background plot. You can control the display of many of the icons or
toggle on and off the display of the status bar tray.
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Table 1-2 lists the different tray icons that are available in AutoCAD.

Table 1-2 Status Bar Icons
Button Name Description
ﬁ“’i Toolbar/Window Lock Controls whether toolbars and dockable windows

(palettes) can be moved. Locking/unlocking can
affect all toolbars or dockable windows. You can
specify which are floating or docked.

CAD Standards
Notification

Identifies that a drawing has CAD Standards associ-
ated with it. Access the tools related to CAD stan-
dards and receive notifications when the drawing
contains standards violations.

¢

External Reference

Identifies that External Reference drawings are

&

Notification attached. Receive notifications when the files have
been updated and need to be reloaded.
Plot Notification Accesses information about recently plotted draw-

ing files.

i

Attribute Extraction

Identifies that a table object in the drawing is linked

Notification to the attributes of blocks in the drawing and receive
notifications when the table object becomes out
of date.
Trusted Autodesk Indicates whether the drawing was created with an
DWG application developed by Autodesk or using RealDWG.

Clean Screen

Toggles the state of Clean Screen.

© O

<

Data Link Indicates if data in a table is linked to an external
data source.
Vault Indicates whether you are currently logged into

Autodesk Vault. The icon is available only when
Autodesk Vault is installed on your computer.

Exercise 1-6: Controlling the Display of Icons and Notification Balloons

For this exercise, open a drawing (a new one or one open from a previous exercise).
Practice changing the global settings for the status bar tray and notification balloons.

1. onthe right side of the status bar, click the Status Bar Menu button (located to
the left of the Clean Screen icon).

2. Choose Tray Settings.

3. In the Tray Settings dialog box, click Display Icons from Services so it’s
deselected.

4. Click OK.

The status bar tray is now hidden, with the exception of the Status Bar Menu and
Clean Screen buttons.
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5. Open the Tray Settings dialog box, re-enable Display Icons from Services, and
select Display Time and 5 seconds from the drop-down list.

The notification balloons now close automatically after 5 seconds.
6. Click OK.

Toolbars

Toolbars are some of the most commonly used user interface elements in a Windows-
based application. Toolbars allow you to quickly access commands from an organized
grouping of tools instead of using pull-down menus. A toolbar contains buttons that
you click to activate a command, and it has controls that allow you to select an option
from a drop-down list or enter text into a text box.

Some toolbars contain flyouts, which have multiple tools on them that perform similar
tasks. A flyout on a toolbar is indicated by a button displaying a black arrow in the
lower-right corner of the button’s image.

Figure 1-5 shows the main parts of a toolbar.
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Button Control
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You can dock toolbars along the edge of the application window, or you can have them
floating. The state that the toolbar is in doesn’t affect how the buttons and controls
work, but if a toolbar that contains a drop-down list is docked on the left or right side
of the application window, the control isn’t displayed. When a toolbar is docked, the
gripper bar is displayed at the top or left side of the toolbar based on how it’s docked;
if the toolbar is floating, a title bar appears at the top with the name of the toolbar.

Most people prefer toolbars to pull-down menus because they offer quick access to
commonly used commands, and toolbar icons make the commands easy to recognize.
AutoCAD comes with 37 toolbars, but you can create your own custom commands and
toolbars to access the commands that you use on a regular basis with ease. For more
information on creating your own custom commands and toolbars, see Chapter 3.

Exercise 1-7: Displaying, Hiding, and Repositioning a Toolbar
For this exercise, open a drawing (a new one or one from a previous exercise). Practice
displaying, hiding, and repositioning a toolbar.
1. Right-click any displayed toolbar and choose 3D Navigation from the shortcut
menu to display the 3D Navigation toolbar.

Toolbars that are currently displayed have a check mark next to them on the
shortcut menu, and the ones that are hidden don’t.
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2. If the 3D Navigation toolbar is currently docked, click the gripper bar and drag
the toolbar over the drawing window.

You can lock the position of toolbars and dockable windows by clicking the
Toolbars/Window Lock icon in the status bar tray.

3. Click the title bar of the 3D Navigation toolbar and drag the toolbar along the left
side of the application window of AutoCAD. Release the mouse button to dock
the toolbar.

When the toolbar gets close enough to be docked, the drag preview of the tool-
bar switches from a horizontal to a vertical orientation.

Hold down Ctrl when dragging a toolbar or dockable window to keep it from
docking along the edge of the application window.

4. Close the toolbar.

Menus

Menus — or pull-down menus — are located on the menu bar and allow you to access
more commands than any other user interface in AutoCAD (other than the command
prompt). You can find most of the commands that you need when working on a draw-
ing on one of the 12 menus in AutoCAD. The menus in AutoCAD contain commands
that have been organized into related groups; for instance, commands that create
objects are on the Draw menu, and ones used for dimensioning are on the Dimension
menu. The main menus that are available in AutoCAD are located along the top of the
application window. When clicked, they appear to drop down from the main menu’s
name.

AutoCAD also offers context-sensitive menus that are available when you right-click
the drawing window. Context-sensitive menus offer different options based on whether
a command is active or even whether any objects are selected in the drawing before
you right-click. Both the main and shortcut menus use submenus to organize options
that are similar. Submenus are indicated by a small black arrow that points to the
right.

Menu items use special indicators that let you know what happens when you click or
access the item without using the menu in the future:

1 A series of 3 periods (. . .): A dialog box displays when you choose the menu item.

v Shortcut key combination: The keyboard command is displayed to the right of
the menu item’s caption. For example, Ctrl+N is displayed next to the New menu
item. You can press Ctrl+N to start the NEW command.

If you hold down Shift before right-clicking, you can access the Object Snap Cursor
menu, which allows you to select an object snap override.

Dockable window's

Dockable windows — or palettes — are one of the newest user interfaces in AutoCAD.
They allow you to access settings and options without the need of closing them when
you’re done. AutoCAD offers a number of dockable windows that allow you to modify
the properties of an object; calculate distances; convert values to different units of
measurement; access reusable objects (blocks, materials, and visual styles) when creat-
ing or modifying a drawing; or work with sheet sets. AutoCAD comes with 14 dockable
windows, and you can launch most of them by choosing Toolst>Palettes.

17
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You can dock, as the name implies, dockable windows or have them float like a toolbar.
However, when docked or floating, a dockable window can still take up a moderate
amount of space in AutoCAD, which can reduce the available space you have for the
drawing window. That’s why you can auto-hide dockable windows. The Auto-hide set-
ting collapses the dockable window when the cursor isn’t over it, which helps to reduce
it to the same size as a docked toolbar. Figure 1-6 shows the common controls that all
dockable windows have in common. Manipulating the position and display of a dock-
able window is similar to manipulating a toolbar.
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Exercise 1-8: Manipulating the Display of a Dockable Window
For this exercise, open a drawing (a new one or one from a previous exercise). Practice
displaying, auto-hiding, and repositioning a dockable window.

1. Choose Tools=>Palettes>Properties.

2. If the Properties window is currently docked, click the gripper bar and drag it
over the drawing window.

3. Click the Auto-hide control on the title bar.

The dockable window collapses, and only the title bar is displayed. Moving the
crosshairs/cursor over the title bar causes it to expand.

4. Click the title bar and drag the palette to the right of the drawing window. Release
the mouse button when the preview of the palette changes to dock the palette.

Hold down Ctrl when dragging a toolbar or palette to keep it from docking along
the edge of the application window.



5. Click the Auto-hide control (which looks like the Minimize icon) to the left of the
gripper bar.

The dockable window collapses, and only the title bar is displayed. Moving the
crosshairs/cursor over the title bar causes it to expand.

6. Close the dockable window.

Click the X button on the dockable window or choose Tools=>Palettes=>
Properties.

Giving AutoCAD Directions

Q"“CE
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As you might have noticed by all the different user interfaces that AutoCAD offers, you
can start commands and input options in a number of ways. You can use commands to
start a specific task that displays prompts or a dialog box for input.

The easiest way to start a command is to type it in the Command Line window. After
you start a command, you do one of the following:

v Provide input if a prompt is displayed in the Command Line window or at a
dynamic input tooltip.
v Provide input in the controls of a dialog box that is displayed.

v Nothing; the command simply ends because no input is required.

Besides typing the command at the command prompt, how else can you start a command?
A. Choose a menu item from a pull-down menu or shortcut menu.

B. Use the Command Prompt window in Windows.

C. Use atoolbar or the dashboard.

It’s all in the name

Not all commands in AutoCAD are created equally: You can use some commands when
other commands are in use, whereas you can use certain commands only when no other
command is active. When you’re using a command that creates or modifies an object,
the command is usually a modal command that supports being used when another com-
mand is active. To use a command, you simply enter its name at the command prompt
and press Enter or select the associated user interface element to start a command.

When entering command names and options at the command prompt, press the space-
bar in most cases to start a command or option. The spacebar acts like the Enter key
unless the input that is being requested contains a space.

Transparent commands

You can use some commands in AutoCAD when a command is already active; these
commands are known as transparent commands. (You can also use transparent com-
mands when no command is active.) To use a command transparently, enter an apos-
trophe (*) in front of the command’s name. Transparent commands affect the properties
of a new object when it’s being created or affect the display of the drawing.

Chapter 1: AutoCAD and the User Interface
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For the most part, you don’t need to worry about entering an apostrophe () in front of
the command’s name when using a menu or toolbar to start a command because it’s
part of the macro for the user interface element.

Command alias

AutoCAD uses command aliases as an option to starting commands. A command alias is
an abbreviation that is assigned to a command. It’s used to access a command from the
command prompt without having to enter its full name. Command aliases are typically
one to three characters in length, but some aliases are longer. Examples of some aliases
are L for the LINE command and 3DO for 3DORBIT. Command aliases are stored in a file
named acad.pgp and are loaded automatically when you start AutoCAD.

Although AutoCAD ships with a number of command aliases, you can add your own
command aliases. They’re stored in the acad.pgp file. To open it, choose Tools=>
Customizer>Edit Program Parameters (acad.pgp). For additional information on creat-
ing and modifying command aliases, see the Define Custom Commands topic in the
Online Help system of AutoCAD. After modifying the acad. pgp file, you have to either
close and restart AutoCAD for the changes to take effect or use the REINIT command
to reload all the aliases in the acad. pgp file without restarting AutoCAD.

If you don’t remember the full name of a command but know the first few letters of it,
you can enter those at the command prompt and then press Tab until you find the
command you are looking for. After the command’s name is displayed at the command
prompt, press Enter to use it.

Repeating a command

When you're working in a drawing, you sometimes want to use the same command
multiple times in a row. AutoCAD allows you to repeat the previous command without
having to select it from a user interface element again, making it much more efficient
to continue using the command.

You can use these methods to repeat a previously used command:

v Press Enter when no command is active.
1 Press the spacebar when no command is active.

v Press the Up arrow key when no command is active and press Enter. You can
step back to retrieve previously used commands within the current session and
not just the most recently used command.

v Right-click the drawing window and choose Repeat Command Name.
v Right-click the drawing window and choose Recent Input=>command_name.

v Right-click the Command Line window and choose Recent
Commandswcommand_name.

Canceling the current command

Sometimes you might find yourself using a command, and all of a sudden you want to
stop using it and switch to a different one. If you don’t want to complete the current
command, press Esc or right-click and choose Cancel from the contextual menu.
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Before you press Esc, make sure that you don’t want to complete the current com-
mand. When you press Esc, you might lose some of the changes that you made.

Exercise 1-9: Starting and Canceling a Command

For this exercise, create a new drawing and set the AutoCAD Classic workspace cur-
rent. Then practice starting and canceling commands from a menu, toolbar, and com-
mand prompt.

1. Choose Draw=>Modelinge>Box.

2. Clicka point in the drawing window.

3. At the command prompt, enter ‘pan and press Enter.

4. Click in the drawing window and drag in any direction to pan. When you’re

finished panning, press Enter to resume the BOX command.
5. Right-click and choose Cancel to end the BOX command.

The BOX command exits without adding a new object to the drawing.

S

Click the Erase icon on the Modify toolbar.
7. Press Esc to cancel the ERASE command.
8. At the command prompt, enter co and press Enter.
CO is the command alias for the COPY command, so the COPY command starts.
9. Exit the COPY command with the method of your choice.
10. Repeat the last command with the method of your choice.

Press Enter or the spacebar or use one of the options from a shortcut menu.

Dynamic input

Dynamic input allows you to get prompts near the location of the crosshairs without
having to look up and down between the Command Line window and the drawing
window. Not only does dynamic input allow you to save on some neck strain, but it
keeps your focus in the drawing window where you do most of your work inside
AutoCAD.

Based on the current settings of dynamic input when it is enabled, AutoCAD provides
feedback to you on the current location of the crosshairs when no command is active
and then provides multiple ways to specify coordinates and values when certain com-
mands are active. For example, when the LINE command is active, dynamic input
tooltips allow you to input the X and Y coordinate for the line object to start at. Then
when the first point is selected, two dynamic input dimensions are displayed: one for
the distance of the line and the second for the angle of the time. For more information
on changing the way dynamic input works, see Chapter 3.

Dialog boxes

Command line input and options are the most common forms of providing information
to AutoCAD, but in some cases, it can be a complex process. When you can benefit
from a dialog box instead of a command line, a dialog box is provided. As in many
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other Windows-based applications, dialog boxes in AutoCAD collect information from
you through standard controls such as text boxes, radio buttons, check boxes, and
drop-down lists. You can display dialog boxes in two different states: modal and mode-
less. Modal dialog boxes don’t allow you to do anything else in AutoCAD until the
dialog box has been closed; a modeless dialog box allows you to interact with AutoCAD
while it’s displayed. Dockable windows (palettes) are a form of a modeless dialog box.

Many commands display a dialog box as the primary form of input, but they also allow
you to input information using the command prompt. In most cases, adding a hyphen
() in front of the command’s name switches the command from a dialog box to the
command prompts. For example, the HATCH command displays a dialog box, but the
-HATCH command displays a series of command prompts instead.

Some dialog boxes, such as the Options dialog box, don’t offer a single command to
access the options found in the dialog box, but rather many different commands and
system variables. As an example, if you want to disable background plotting, you use
the system variable BACKGROUNDPLOT because there is no -OPTIONS command. For
more information on system variables and the Options dialog box, see Chapter 3.

Some commands such as NEW and OPEN don’t have equivalent commands that start
with a hyphen but instead rely on the system variable FILEDIA. Set FILEDIA to 0 (zero),
and the commands display prompts instead of the Standard File Navigation dialog box.

Sending an S.0.S. to AutoCAD

AutoCAD is a very complex application that offers a lot of different tools to help with
many different general drafting tasks and some that are much more specific to an
industry. With all this complexity, there are times when you need a little help to keep
you on track with learning something new or trying to complete a task. The Online
Help system that AutoCAD offers does a pretty good job of giving answers to both gen-
eral and specific problems, but because AutoCAD is used by a very large, diverse
group of people, you might not find all the answers in the Online Help system.
Fortunately, because AutoCAD has a large user base, usually someone has encoun-
tered the specific problem that you have and might even have posted the solution on
the Internet in one of the many online forums out there.

Online help

The Online Help system that comes with AutoCAD is very complete for the most part,
with a few minor potholes here and there. The Online Help system is well integrated in
AutoCAD, and you can access it just about anywhere in the application to get context-
sensitive help when you need it most. To access help, choose Help=>Help or enter help
at the command prompt.

InfoCenter

InfoCenter (see Figure 1-7) replaces the Info Palette from previous versions and com-
bines the functionality of the Communication Center in one place. The InfoCenter is
located in the upper-right corner of AutoCAD on the menu bar and allows you to
search for information in the Online Help system as well as get information from your
favorite blogs or Web sites that post content in an RSS (Really Simple Syndication) file
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Exercise 1-10: Searching for Information Using InfoCenter

Practice searching for information in AutoCAD using the InfoCenter.

1. Click in the Search field and enter create 3D box.
2. Press Enter to start the search.

3. Position the cursor over the Create a Solid Box entry and click the star to the
right of the link.

The link is now marked as a favorite.

4. Click the Favorites button located on the right-side of the InfoCenter (refer to
Figure 1-7) and click the link that you added.

AutoCAD’s Online Help system launches and displays the topic.
5. Close the Online Help system and click the Communication Center.

Browse through the topics shown. (The information is pulled from a number of
different resources.) You can add your favorite RSS feeds to InfoCenter, which
AutoCAD searches when you use the Search field of InfoCenter.

6. Click the down arrow to the right of the InfoCenter Search button, and choose
Search Settings from the shortcut menu.

7. In the InfoCenter Settings dialog box, select RSS Feeds from the left pane, and
click New.

8. In the Add RSS Feed dialog box, enter http://hyperpics.blogs.com/beyond_
the_ui/index.rdf in the Enter a Location text box and then click Add.
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9. When the RSS Feed Confirmation message box is displayed, click OK.
10. Click OK to save the changes made in the InfoCenter Settings dialog box.

To see if the new RSS feed was added, click Communication Center in the
InfoCenter. You should see the five most recent items in the RSS feed listed in the
HyperPics: Beyond the Ul section.

Turning to the World Wide Web

The World Wide Web is a great resource for selling or buying things, but it also hap-
pens to be a great place to get help on AutoCAD. The Internet is bursting with sites
that offer information on AutoCAD and help when you’re stuck. Chances are good that
you can use a popular search engine such as Google (www.google.com) or Yahoo!
(www .yahoo.com) to find a solution to a problem that you might be having with
AutoCAD. If you can’t find a solution to your problem using a search engine, you can
use an online community site like AUGI (www . augi . com) or the online discussion
forums that Autodesk supports (www.autodesk.com/discussion) to post your
problem and wait for someone to respond with a solution. In addition to these Web
sites, I list resources on the Internet in Chapter 23.

Answers to Practice Opportunities

1. How can you start AutoCAD?
A, B, D. You can launch AutoCAD with the following methods:
¢ Choose Start =(All) Programs=>Autodesk=>AutoCAD 2008=>AutoCAD 2008.
¢ Double-click an AutoCAD drawing file in any folder on a local or network drive.
¢ Double-click the AutoCAD icon on the Windows desktop.
¢ Click the AutoCAD icon on the taskbar’s Start menu.
¢ Click the AutoCAD icon on the Quick Launch toolbar on the taskbar.
2. To access the shortcut properties in order to add a command line switch, right-click and
choose Properties.
3. Besides typing the command at the command prompt, how else can you start a command?

A and C. You can select a menu item from a pull-down menu or shortcut menu, or you can click
a button on a toolbar or the dashboard.



