Chapter 1

Creating a Web Site with
Expression Web

In This Chapter

Starting Expression Web for the first time
Exploring the workspace

Creating and saving a new Web site

Using a template to create a new Web site
Opening, closing, and deleting Web sites
Adding existing files to a Web site

Closing Expression Web

In this chapter, you get started with Expression Web: You get familiar with
the workspace and find out how to create and save Web sites. Before you
hang your shingle as a Web publisher, though, you should understand what
you're really doing when you create and publish a Web site. No doubt you’ve
already seen a Web site. Web sites are the places you visit as you make your
way around the World Wide Web. In the same way as a book is made up of
individual pages, a Web site is made up of individual files called Web pages.
Web pages contain the text, pictures, and other content you see when you
visit a Web site.

As you construct a Web site, you create Web pages and then string the pages
together by using hyperlinks. Hyperlinks are the highlighted words and pic-
tures inside the page that visitors can click to jump to a different location,
page, or Web site. Hyperlinks can also initiate a download or pop open an
e-mail window.

After your site is complete, you publish it. In other words, you make the site
visible to the rest of the world on the World Wide Web (or, if you're working
on an internal company site, on the company’s intranet). This process isn’t
automatic. For a Web site to be live, you must transfer the site’s files from
your computer to a Web server, a host computer that runs special Web server
software and is connected to the Internet 24 hours per day.
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If you're working on an intranet site, the publishing process is similar, except
that only people with a password to access the intranet can view your site.
An intranet is an internal company network based on the same type of tech-
nology as the Internet, with access restricted to people within that company.
Intranet sites generally contain information useful to company insiders, such
as policies, collaborative tools, and department announcements.

Many people gain access to a host Web server by signing up for an account
with an Internet service provider (or ISP) that makes Web server space avail-
able to its users. Others use a Web server maintained by their workplaces or
schools. Another option is to sign up with one of the many hosting compa-
nies that offer server space for free.

Starting Expression Web
for the First Time

The first time you start Expression Web, you need to jump through a few
basic setup hoops before you can get down to building your site.

To get started, on the Windows taskbar, choose Start=>All Programs=>
Microsoft ExpressiontMicrosoft Expression Web. Expression Web opens.
What happens next varies. Here are some dialog boxes you may encounter
and instructions for how to handle them:

v A dialog box may prompt you to enter your name and initials. Expression
Web uses these details to identify the Web sites and pages you create
and modify. If necessary, in the Name and Initials text boxes, enter your
name and initials, and click OK.

1 A message box prompts you to make Expression Web the default Web
page editor for HTML documents, which is another way of saying
“Expression Web wants to become the go-to program whenever you
want to create or update a Web page. Okay?” If you want to make
Expression Web your default HTML editor (and we suggest that you do),
click the Yes button.

If you click No, this message continues to pester you each time you
launch Expression Web unless you turn it off by deselecting the Always
Perform This Check When Starting Expression Web option.

v The Privacy Options dialog box appears, prompting you to select options
for tracking how Expression Web performs on your system and reporting
information back to Microsoft. We suggest that you select both options.
The Expression Web development team uses this information to make
future versions of Expression Web better.
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v A dialog box appears, prompting you to sign up for the Microsoft Update
service. This service offers automatic updates for Expression Web and
other Microsoft programs installed on your system. We suggest that you
choose to download and install updates when they are available.

Your screen should look like the one shown in Figure 1-1. If it doesn’t look like
it, close the program and restart it.

Expression Web has found the My Documents folder on your hard drive and,

inside it, has created a new folder named My Web Sites in which to store all
the Web sites you build.

Although Expression Web appears to be ready for you to start adding content
to the blank page that appears, please don’t. You must first create a Web site,
which is a specially designated folder in which Expression Web stores all
pages associated with the site. We tell you how to create a site in the section
“Creating and Saving a New Web Site,” a little later in this chapter.
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Touring the Expression Web Screen
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Now that you’re here, allow us to show you around the Expression Web work-
space so that you can start getting comfortable.

As you get used to working with Expression Web, you may want to customize
the workspace so that everything you need is visible on the screen and the
features you don’t use are tucked away from view. You can begin with the
simple tour that follows, but when you’re ready, feel free to experiment with
the layout of the Expression Web workspace.

To start the tour, step right this way. . . .

Workspace

The workspace is where you build your Web site and all its Expression Web
parts (refer to Figure 1-1). If you have more than one Web site open at the
same time, each Web site appears in its own Expression Web workspace
window (see Figure 1-2).
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Menu bar and toolbars

Like most other Windows programs, the menu bar at the top of the workspace
contains all the Expression Web commands. You find buttons for the most
commonly used commands on the Common toolbar, located just below the
menu. (Expression Web has many more toolbars, which contain buttons for
commands specific to a particular function. To show other toolbars, choose
View=>Toolbars and then click the name of the toolbar you want to see.)

The Standard toolbar deserves special mention. It contains a handful of
useful buttons not found on the Common toolbar — such as Spelling, Print,
Cut, Copy, and Paste and the Format Painter — but doesn’t have as many text
formatting options. We suggest using the Common toolbar most of the time,
and then popping open the Standard toolbar if you find that you need quick
access to its buttons.

Because the Common toolbar contains a lot of buttons, not all of them show
up if your screen resolution is set to 1024 x 768 or lower. Click the down
arrow at the far-right end of the toolbar to see all the buttons.

You can customize Expression Web toolbars by adding or removing com-
mands. To add a command to a toolbar, follow these steps:

1. On the right side of the toolbar you want to customize, click the down
arrow.

2. Choose Add or Remove Buttons->Customize.
The Customize dialog box appears.

3. If the Commands tab isn’t already showing, click it.

4. In the Categories list box, select the menu containing the command
you want to add.

5. In the Commands list box, click and drag the command onto the
toolbar.

As you drag, the cursor turns into an arrow pointing to a button.

As soon as you arrive at the toolbar with your command in tow, an inser-
tion point — it looks like a capital / — shows you where the button for
the command would appear if you were to release the mouse button.

6. Move the cursor along the toolbar until the insertion point arrives at
the spot on the toolbar where you want the button to live, and then
release the mouse button.

Voila! The button appears on the toolbar.

11
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7. If you want to add more buttons to the toolbar, repeat Steps 4 through
6 for each button addition. When you finish, click Close in the
Customize dialog box.

To remove a button from a toolbar, drag it down and off the toolbar. Expression
Web is picky about certain toolbar buttons. If you try to remove a toolbar
button and it doesn’t budge, you can’t remove it. Expression Web always lets
you remove a button you added, though.

The Expression Web menu bar and all its toolbars can be dragged around the
screen as free agents or fixed in various locations (called docking). When you
first launch Expression Web, the menu bar and Common toolbar are docked
at the top of the screen.

To move a docked toolbar, follow these steps:

1. Move your cursor over the left edge of the menu or toolbar until the
cursor turns into a four-pointed arrow.

2. Drag the toolbar away from its original location toward the center of
the screen.

The menu bar or toolbar pops away from its location, and its title bar
appears.

When you let go of the mouse button, the toolbar stays where you left it.
You can move it somewhere else by dragging its title bar.

You can redock the menu bar or a toolbar on any of the four sides of the
workspace window. To do so, drag the menu bar or toolbar where you want it
and, when it pops into its new spot, release the mouse button.

Expression Web Help tells you more about customizing the menus and toolbars.
To launch Help, choose Help=>Microsoft Expression Web Help or press F1.

Editing window

The editing window takes up the majority of the Expression Web workspace.
That’s where you add text, pictures, hyperlinks, and other goodies to your Web
pages. The filename of each open Web page appears on its own tab. Figure 1-3
shows a Web site with two Web pages open in the editing window. You can flip
between pages by clicking the pages’ tabs or by pressing Ctrl+Tab or Ctrl+
Shift+Tab. Expression Web points out pages that contain unsaved changes

by placing an asterisk next to the filename, like this: default.htm*.
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When you open a Web site, a Web Site tab also appears in the editing window.
This tab shows you the site’s list of files and folders or the contents of the
folder selected in the Folder List task pane. Chapter 13 gives you detailed
information about this tab. (In Chapter 2, we cover how to add and organize
Web pages). To close an open Web page, click the X button in the right-hand
corner of the editing window.

The editing window contains three different views: Design, Code, and Split:

v Design view shows you a rough idea of what your Web page will look
like to your visitors, and you’re likely to spend much of your time here.

Design view only approximates how your pages will look when viewed with
a Web browser, such as Internet Explorer, Mozilla Firefox, or Netscape.
How your page looks to your visitors depends on their individual browser
settings, which can vary from person to person. We tell you how to pre-
view your pages in different browsers in Chapter 2.

v Code view displays the page’s underlying HTML code. No matter whether
you know HTML, you can rest assured that the Expression Web code tools

13
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are superb. (The same could not be said of its predecessor, Microsoft
FrontPage.)

v~ Split view is the best of both worlds. A moveable bar divides the editing
window, with Code view on the top and Design view on the bottom. Using
Split view, you can work in the comfort of Design view while watching
the page’s underlying code change in real time. (And vice versa: If you
make changes to the code, you can press F5 to see the results in Design
view.) To change the size of each view, click the divider bar and drag it
up or down.

Switch between views by clicking the buttons at the bottom of the editing
window or by pressing Ctrl+PgUp or Ctrl+PgDn.

Split view might indeed be one of the strongest Expression Web features,
especially if you're an HTML newbie. Expression Web writes such clean, by-
the-book code that if you pay attention as you build your Web pages, you
pick up HTML almost painlessly. Why learn to use HTML? As powerful a pro-
gram as Expression Web is, as you become experienced with Web design, you
find that it’s often easier to tinker with code than to wade through commands
and dialog boxes. We gently introduce you to bits of code so that your intro-
duction to HTML feels more like stepping into a kiddie pool than plunging
headlong into the icy deep end.

Ouick Tag Selector bar

Look beneath the tabs in the editing window: That’s the Quick Tag Selector
bar. Click anywhere on your Web page, and the Quick Tag Selector bar shows
you all the HTML tags that apply to the item you clicked. You can click a tag
to select the element. For example, click <p> to select the whole paragraph in
Design view or Code view (or in both if you’re in Split view). Click the down
arrow next to a selected tag for more options. We cover using the Quick Tag
Selector bar in more detail in Chapter 14.

Task panes

Surrounding the editing window on either side are task panes for working in
detail with various aspects of your Web pages. They become useful as you
begin building and refining your site. When you launch Expression Web, the
Folder List task pane appears in the upper-left corner; the Tag Properties and
CSS Properties task panes are located below it, in the lower-left corner. On
the other side of the editing window, the Toolbox is in the upper-right corner,
with the Apply Styles and Manage Styles task panes in the lower-right corner.
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Expression Web has many other task panes for working with other controls.
All are listed on the Task Panes menu. Depending on what kind of Web site
you're building, you use some task panes more than others, but you will find
the Folder List task pane invaluable for managing your site’s folders and files.
And the style-related task panes (Apply Styles, Manage Styles, and CSS Prop-
erties) become your best friends as you format your pages to look the way
you want. (We get into detail about styles in Chapter 7.)

As with the menu bar and the toolbars, you can move and dock task panes.
For example, if you want more screen real estate for the editing window,
move all your task panes to one side or close the ones you aren’t using.

To move a task pane, follow these steps:

1. Move your cursor over the task pane’s title bar until the cursor turns
into a four-pointed arrow.

You can also right-click and, from the pop-up menu that appears, choose
Float.

2. Drag the task pane away from its original location toward the center
of the screen.

The task pane pops away from its location.

3. Keep the mouse button down (and don’t let go) until the task pane is
where you want it (and then let go).

If the task pane ends up in entirely the wrong place, don’t worry. Simply
grab hold of its title bar and drag it again.

Task panes are friendly screen elements that like to hang out with other task
panes more than they like floating around the screen by themselves. This
characteristic can be frustrating when you first start moving the task panes
around the workspace window.

You might notice this behavior. If you move a task pane on top of another task
pane, they join together into one big task pane family. Although this behavior
can be aggravating if that isn’t what you want, it’s actually a feature. In Figure
1-4, we dragged the Tag Properties (with CSS Properties in tow) into the Apply
(and Manage) Styles task pane. (We made it a little bigger so that you can see
all the tabs.)

In a task pane group, click the right and left arrows to scroll through the dif-
ferent task panes. Each task pane’s name appears on a tab. The active task
pane’s tab sits on top of the other tabs, and its name appears on the group’s
title bar.

15
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To make a task pane active, click its tab. To close the active task pane, click
the X on the tab bar. To close a whole group of task panes, click the X on the
group’s title bar.

If you don’t like your new task pane arrangement and you want to go back to
the way Expression Web placed them, choose Task Panes=>Reset Workspace
Layout.

Status bar

The bottom edge of the workspace window contains a few more useful good-
ies, such as the page size dimensions now displayed in Design view and which
version of HTML Expression Web is using to write your Web page’s code. (The
default is XHMTL 1.0 Transitional.) This may not mean much to you now, but
you find out more about setting the Design view dimensions in Chapter 8,
and we talk about HTML versions in a sidebar in Chapter 14.

Creating and Saving a New Web Site

If you already read the first part of this chapter and did enough idling, it’s
time to rev the engines and create your first Web site.

Here’s how to create and save a Web site with one page: the default home page.
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The care and naming of Web sites

Because you most likely will create and save
more than one Web site, you should think about
how you want to organize your sites’ files and
folders now, when you're just getting started.
If you don’t have any other Web sites in your
My Documents folder, Expression Web saves
your first Web site’s files in the folder My
Documents\My Web Sites\mysite.
When you create another new Web site,
Expression Web adds another Web site folder
inside My Documents\My Web Sites,
named mysite2, and places your new site’s
files there. The next folderis named mysite3,
and so on. Left to its own devices, Expression
Web creates a folder-and-file structure for each
new site inside the My Web Sites folder.

Although this method does keep everything nice
and tidy and separate, the problem is that it
doesn't scale well if you create more than a few
sites. s the site you created for Aunt Martha’s
knitting club mysite6 or mysitel6? We
suggest that you choose intuitive names for
your Web sites that indicate what the sites are
about (like knitclub ormarthaknit). We
also suggest that you store all your Web sites
inside the My Web Sites folder, which keeps
them separate from the morass of files in My
Documents, sequestered in their own little Web
site world.

To create and save your first Web site, follow these steps:

1. With Expression Web running, choose Filec>New=>Web Site.

1 -

The New dialog box appears with the Web Site tab displayed, as shown

You can also click the drop-down arrow to the right of the New Document
button on the Common (or Standard) toolbar and choose Web Site.

in Figure 1-5. The General and One Page Web Site options are selected.
The Description box displays a helpful little blurb about what the

selected options do.

The Specify the Location of the New Web Site text box displays the full
path and default folder name of the Web site. If you have no other Web
sites in My Documents, Expression Web assumes that you want to create
a unique folder for your Web site within the My Web Sites folder. In this
case, the path probably looks something like this: C: \Documents and
Settings\your user name\My Documents\My Web Sites\mysite
(or mysite2 or mysite3, for example).

Note: If you share a computer with other people and use the Windows
system of users and passwords to maintain separate settings, the My
Documents folder is located inside the Documents and Settings folder, in
a subfolder identified by your username.

17
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Type over the default folder name that Expression Web has assigned
for the Web site, and enter your own, unique folder name.

The easiest way to do this is to click twice at the end of the path shown
in the Specify the Location of the New Web Site text box and press the
Backspace key to erase the default folder name (leave the \ in place).
Then type a name for your Web site folder.

When naming folders, try to use only lowercase letters and underscores
(L) rather than spaces. Current standards require that filenames and
pathnames be in all lowercase; whenever you are working with anything
Web related, it just makes good sense to follow this simple rule. Also, try
keeping your folder names short. See the earlier sidebar “The Care and
naming of Web sites” for more information.

The full path should now look something like this: C: \Documents and
Settings\your name\My Documents\My Web Sites\folder_name,
where folder_name is your Web site name.

. Click OK.

The dialog box closes, and Expression Web opens a new workspace with
your Web site and its default.htm home page (if you chose to create a
one-page Web site).

To create additional Web sites, follow these steps again. Each new site opens
in its own workspace window.

When you launch Expression Web, it opens the last Web site you were work-
ing on, to the last page you had open.
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Congratulations — you created your first Web site! You're now ready to take
the next step, which could be in any number of directions:

v If you want to get to work adding content to your new home page, go to
Chapter 3, which talks about text, that most fundamental element of
most Web pages.

v To add more Web pages to your Web site, go to Chapter 2.

v If you're not sure where to go from here, read on.

Creating a New Web Site
from a Template

\\J

Templates are a good place to start if you need to throw together a Web site
quickly, or if the prospect of building a site from scratch seems daunting.
Expression Web comes with templates for several types of sites. Use the tem-
plate that most closely approximates the site you want, and then tweak it to
your heart’s content:

v Organization: Use one of these templates to design a Web site for your
professional organization or club. Visitors can read news, look at photos,
view an FAQ (frequently asked questions) page and find out how to con-
tact you.

v Personal: Use one of these templates as a springboard for designing
your own, personal Web site. You can add your résumé and contact
information, as well as a photo gallery of your work or a page listing
downloadable documents or links.

1~ Small Business: These types of templates are ideal for quickly building a
Web site for your small business. They contain predesigned pages for
news posts, press releases, products, services, and promotions; a links
page for more information; a site map; and contact information.

Even if you don’t end up using a template as the basis for your Web site,
you may want to take a look at what pages the Expression Web templates
contain and how they’re organized, to get ideas about how to put together
your own site.

All Expression Web site templates use a Dynamic Web Template (DWT). A
DWT contains common elements (such as logos and navigation links) that
appear on every page in the Web site so that it looks cohesive. ADWT can
save you a lot of time because after you build the template and apply it to a
new page, all you need to add is the content specific to that page. We talk
about Dynamic Web Templates in Chapter 11.

19
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To create a new Web site by using a template, follow these steps:

1. With Expression Web running, choose Filec>"Newr>Web Site.
2. Click Templates.

A list box appears, showing variations on the different types of tem-
plates. When you click a template name, Expression Web shows you a
picture of what the Web site template looks like in the Preview area.

3. In the list box, click the template you want to use.

4. In the Specify the Location of the New Web Site text box, enter the
name of the new Web site folder or accept the default given by
Expression Web.

We describe how to change the Web site folder name earlier in this
chapter.

If you want Expression Web to store the Web site’s files in another loca-
tion, click the Browse button and, in the New Web Site Location dialog
box, navigate to the folder you want and click the Open button. The
dialog box closes, and you return to the New dialog box. The path you
chose appears in the Specify the Location of the New Web Site text box.

If you want Expression Web to place the template in the Web site you
have open, select the Add to Current Web Site check box in the Options
area of the New dialog box.

5. In the New dialog box, click OK.

If another Web site is already open in Expression Web when you create a
Web site from a template, the Web site you just created appears in a new
workspace window.

After Expression Web creates the new Web site, a bunch of folders unfurl in the
Folder List task pane and on the Web Site tab. You see a file named default.
htm marked with a little house icon — that’s the site’s home page. (We talk more
about home page filenames in Chapter 2.) You also see a file named master.
dwt, which is the site’s Dynamic Web Template. It contains the design elements
common to all the pages in the site.

Building your site from one of these templates can be confusing if you're new
to using CSS styles to format and position page elements, or if you've never
worked with Dynamic Web Templates. But the templates are great examples
of how these technologies work together to build a Web site. (In Chapter 9,
we walk you through a template’s code step by step.) If tinkering with actual
changes seems too daunting, just create a site from a template and have a look
around. At the very least, you will probably come away with some ideas.
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Opening an Existing Web Site in
Expression Web

You can open most Web sites regardless of whether they were created in
Expression Web. Use the Open Site command to open Web sites whose files
are stored on your computer’s hard drive or on a network drive.

To open a Web site located on your hard drive or on a network drive, follow

these steps:

1. With Expression Web running, choose File=>Open Site.

~ You can also click the arrow next to the Open button on the Common
i toolbar and choose Open Site.

The Open Site dialog box appears, with the Web Sites location listed in

the Look In text box.

What ahout ASP.NET?

As we're sure you've already discovered,
Expression Web is a complex program, full of
features that the beginning-to-intermediate
Web designer (that's you!) are likely never to
use. For example, in Expression Web you can
create two types of Web pages: regular Web
pages, also known as HTML pages, and ASP.
NET pages.

An ASP.NET page looks, to the casual Web
surfer, like any other Web page. But from the
Web designer’s perspective, ASP.NET pages are
vastly more powerful and complicated to build.
ASP.NET pages can interact with Web server-
based databases and other sources of live data
and have specific hosting requirements. (They
must eventually be published on a Web server
that supports ASP.NET 2.0.) As such, they fall
into the intermediate-to-advanced category,
which is outside the scope of this book.

Thatisn't to say that you shouldn't try your hand
at creating ASP.NET pages. If your Web hosting
provider supports ASP.NET 2.0 and you're feeling

adventurous, go ahead and experiment with the
Expression Web ASPNET tools. The nice thing
is that the features are there if you need them
but don’t get in your way if you don't.

If you think that you want to give ASP.NET a spin,
here are a few resources for finding out more:

v Wikipedia, athttp://en.wikipedia.
org/wiki/Asp.net, clearly describes
what ASP.NET is all about.

v Expression Web Help covers the basics of
creating ASP.NET pages in Expression Web,
as well as how to use the different ASPNET
task panes and tools. The Help feature also
explains the different ASP.NET controls and
how to add them to . aspx pages. Choose
Help=>Microsoft Expression Web Help and
then click ASP.NET.

v Visit the Microsoft ASPNET Developer
Centerathttp://msdn.microsoft.
com/asp .net to find out about ASPNET
and the tools that use it.
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The Web Sites location is sort of a virtual bookmarking list for Web sites
that have been opened in Expression Web, regardless of whether they
were originally created in Expression Web. For example, if you open a
site created in Dreamweaver or FrontPage in Expression Web, it appears
in this list.

If you delete or move a Web site in Windows Explorer, the reference to it
still appears in the Web Sites list. It doesn’t mean that the site is still there;
it just means that Expression Web remembers that the site was there
once upon a time in recent memory:. If you try to open the site and the
location is out of date, you get an error message. For this reason, you
should always delete a Web site from within Expression Web. (We tell
you how, later in this chapter.) To remove an outdated Web site pointer
from the list, right-click and choose Remove.

If you don’t see the Web site you want to open, find it by using the short-
cuts on the left side of the dialog box.

2. Double-click the Web site, or click to select it and then click Open.

The Web site opens in a new workspace window.

Adding Existing Files to a Web Site

Let us compare a Web site to a manila file folder for a minute — any container
that can hold a bunch of stuff related to a particular project. If you're redesign-
ing your son’s bedroom, for example, your file folder might contain a random
assortment of bits and pieces: fabric swatches, paint chips, pages torn from
magazines, and rough sketches of the furniture layout.

Think of your Web site folder in a similar way. It should contain all the random
files you will use for your Web site, regardless of whether you include them in
their final form. For example, you may have written some brainstorming notes
about the text for certain Web pages in Microsoft Word. (We talk about past-
ing text into Web pages in Chapter 3.) Or, you might have created some PDF
files that you will make available for download. You also might have created
a logo and some icons and cropped and sized a collection of photos in your
graphics program. (We cover including pictures in a Web site in Chapter 5.)

All these files can and should go into your Web site folder, by either dragging
them directly into your Web site’s Folder List task pane or importing them.
There are two reasons for this:

v If you're going to use the file in its final form (such as a picture file or a
downloadable PDF), Expression Web needs to have the file in the Web
site so that it can create and maintain working links to that file. This
ensures that when you publish your site on the Internet, all the files for
the Web site get copied to the host server correctly. (You can exclude
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files you don’t need in their final form, such as text documents, when
you publish your Web site. We show you how in Chapter 12).

v Keep everything in one place so that you don’t have to remember where
all your stuff is.

You can open documents and work on them in their original programs from
within Expression Web. For example, if you import a Microsoft Excel spread-
sheet into your Web site, double-click the file’s icon in the Folder List task
pane to open it in Microsoft Excel.

If you have one or two files to bring into your Web folder, it’s a snap to drag

them from a folder on your computer or network into your Web site’s Folder
List task pane directly into a specific folder, as shown in Figure 1-6.
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If you have several files in different locations, or if you want to bring in entire
folders, you can load everything into the Import dialog box and import every-
thing in one fell swoop. When you import a file, Expression Web places a
copy of the file inside the open Web site and leaves the original file and its
location unchanged.

In this section, we show you how to add existing files to the Web site that’s
open in Expression Web. To import an entire Web site from the Internet into
Expression Web, take the Import Web Site Wizard for a spin. (We explain how
later in this chapter.)

In the following steps, we show you how to import single files from your com-
puter or local network into the Web site that’s open in Expression Web. At the
end of this set of steps, we tell you how to import entire folders.
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. With a Web site open in Expression Web, choose Filec> Import.

(If the File>Import menu item is grayed out, in the Folder List task pane,
click the Web site’s top-level folder to select it, and then choose Filew>
Import again.)

The Import dialog box appears.

. In the dialog box, click the Add File button.

The Add File to Import List dialog box appears. You use this dialog box
to poke around your hard drive or local network to find the files you
want to import.

. Navigate your hard drive or local network and select the files you

want to import.

To select multiple files, press and hold down the Ctrl key while clicking
file icons in the Add File to Import List dialog box. To select a range

of files, press and hold down the Shift key while clicking the first and
last file icons. If you don’t see the file you want to import, from the Files
of Type list box, choose All Files (*.*).

. Click the Open button.

The Add File to Import List dialog box closes, and the file appears in the
import list in the Import dialog box.

. To add another file to the import list, repeat Steps 2 through 4. When

you’re finished, click OK to close the dialog box and import the files.

If you would rather put off importing the files, click the Close button in
the Import dialog box. Expression Web saves the import list and closes
the dialog box, which you can later access by choosing Filec>Import.

To import a folder into your Web site, in Step 2 of the preceding list, click the
Add Folder button. The File Open dialog box appears, enabling you to choose
the folder you want to import. Click the folder and then click the OK button.

The File Open dialog box closes, and the folder’s contents appear in the
import list.

Deleting a Web Site

SMBER

If you have old Web sites lying around on your computer or network and taking
up precious storage space, feel free to get rid of them. May we suggest, however,

that you take a good look around first? You might have used a particularly
nice combination of colors or a page layout that you want to hang on to for
future reference.

Although you can delete a Web site by using Windows Explorer, we recom-
mend doing all your Web site file cleanup from inside Expression Web. This
way, Expression Web stays in the loop about your site’s whereabouts.
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® Okay, there’s one advantage to using Windows Explorer to delete a Web site:
The site’s files get thrown into Recycle Bin, giving you a chance to retrieve
them if you have a change of heart. But Expression Web gives you another
option, which we explain in the following instructions.

To delete a Web site that’s open in Expression Web, follow these steps:

1. In the Folder List task pane, click the Web site’s top-level folder and
then press the Delete key.

Alternatively, in the Folder List task pane, right-click the Web site’s top-
level folder and, from the pop-up menu, choose Delete.

The Confirm Delete dialog box appears and warns you that deleting a
Web site is a permanent action. It also gives you two options:

® Delete only hidden metadata files from this Web site, preserving all
other files and folders. This option tells Expression Web to pretend
that the Web site doesn’t exist when listing Web sites in the Open
Site dialog box, but doesn’t delete the files and folders. This choice
is a good one if you think that the Web site contains some elements
that you might want to use in the future.

e Delete this Web site entirely. This option is a one-way street. After
you select it and click OK, the Web site is toast.

2. In the dialog box, select the Delete This Web Site Entirely option and
then click OK.

The dialog box closes, and Expression Web deletes the Web site.

Closing a Web Site and
Closing Expression Web

Closing a Web site is easy. You can use either one of these methods:

ﬁ v Click the X in the right-hand corner of the workspace window. If you
. have only one Web site open, this method also closes Expression Web.

v Choose Filem>Close Site. Use this option if you want to close the current
Web site but keep Expression Web running.

\BER To close Expression Web, close the last open Web site or choose Filew>Exit.
‘x&
& If you haven’t saved your files yet, Expression Web prompts you with a
friendly reminder to do so before closing.
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