
Boost Your Efficiency

You can use Microsoft Excel 2007 to work 
with numbers. In fact, wherever you use
numbers — doing taxes, running a small
business, maintaining a budget, or anything
else — Excel can help make your work easier,
quicker, and more accurate.

Excel 2007 provides you with many ways to
enter, present, explore, and analyze data. This
chapter focuses on ways in which you can
boost your efficiency when using Excel. You
learn how to use the Excel AutoFill feature, to
group and outline, to check the accuracy of
your data and more.

The AutoFill feature enables you to fill a row or
column quickly with a series of values,
numbers, dates, or times generated from one

or more values you have entered. This chapter
will show you how to use the AutoFills that
come standard with Excel and how to create
your own AutoFills.

You can use grouping and outlining to hide
parts of your worksheet, enabling you to focus
in on the data in which you are interested,
thereby making data analysis easier. This
chapter steps you through the process of
grouping and outlining.

Sometimes you may want to double-check the
accuracy of your data. One of the final tasks in
this chapter teaches you how you can increase
the accuracy of your data entry by letting
Excel read back your data to you.
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1 Click in the cell in which you
want to create a validation list.

2 Click the Data tab.

3 Click Data Validation in the Data
Tools group.

l The Data Validation dialog box
appears.

4 Click the Settings tab.

5 Click here and then select List.

6 Click and drag to select the valid
entries, or type = followed by
the range name.

7 Click OK.

Validate with a

VALIDATION LIST
Excel enables you to restrict the values a user can
enter in a cell. By restricting values, you ensure that
your worksheet entries are valid and that calculations
based on them thereby are valid as well. During
data entry, a validation list forces anyone using your
worksheet to select a value from a drop-down menu
rather than typing it and potentially typing the wrong
information. In this way, validation lists save time
and reduce errors.

To create a validation list, type the values you want
to include into adjacent cells in a column or row. You

may want to name the range. See Task #11 to learn
how to name ranges. After you type your values, use
the Data Validation dialog box to assign values to your
validation list. Then copy and paste your validation list
into the appropriate cells by using the Paste Special
Validation option.

You may want to place your validation list in an out-
of-the-way place on your worksheet or on a separate
worksheet. 
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l Excel creates a validation list in
the cell you selected.
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PASTE YOUR VALIDATION LIST

1 Click in the cell that
contains your validation
list.

2 Click the Home tab.

3 Click the Copy button in
the Clipboard group.

4 Select the cells in which
you want to place the
validation list.

5 Click Paste in the
Clipboard group.

A menu appears.

6 Click Paste Special.
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l The Paste Special dialog box appears.

7 Click Validation ( changes to ).

8 Click OK.

Excel places the validation list in the cells
you selected.

l When users make an entry into the cell,
they must pick from the list.

Chapter 1: Boost Your Efficiency

Did You Know?
Validation lists can consist of numbers,
names of regions, employees, products,
and so on.

Remove It!
To remove a validation list, click in any cell that contains the
validation list you want to remove, click the Home tab, and
then click Find and Select in the Editing group. A menu appears.
Click Go To Special. The Go To Special dialog box appears. Click
Data validation, click Same, and then click OK. The Go To
Special dialog box closes. Click the Data tab and then click
Data Validation in the Data Tools group. A menu appears. Click
Data Validation. The Data Validation dialog box appears. Click
Clear All and then click OK.
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1 Click in the cell in which you
want to create a data entry rule.

2 Click the Data tab.

3 Click Data Validation in the Data
Tools group.

l The Data Validation Dialog box
appears.

4 Click the Settings tab.

5 Click here and select a validation
criterion.

6 Click here and select a validation
criterion.

7 Type the criteria or click and
drag to select the cells with the
criteria you want to use.

Validate with

DATA ENTRY RULES
You can use data entry rules to ensure that data
entered has the correct format, and you can restrict
the data entered to whole numbers, decimals, dates,
times, or a specific text length. You can also specify
whether the values need to be between, not
between, equal to, not equal to, greater than, less
than, greater than or equal to, or less than or equal
to the values you specify.

As with all data validation, you can create an input
message that appears when the user enters the cell,

as well as an error alert that displays if the user
makes an incorrect entry. Error alerts can stop the
user, provide a warning, or just provide information.

After you create your data entry rule, copy and paste
it into the appropriate cells by using the Paste Special
Validation option. See Task #1 under Paste Your
Validation List to learn how to copy and paste
your data entry rule.
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8 Click the Input Message tab.

9 Type a title for your message.

0 Type an input message.

6
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! Click the Error Alert tab.

@ Click here and select a
style.

Choose Stop if you want
to stop the entry of
invalid data.

Choose Warning if you
want to display a
warning to the user, but
not prevent entry.

Choose Information 
to provide information 
to the user.

# Type a title.

$ Type an error message.

% Click OK.

!!

##
$$

@@

%%
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Excel creates the data entry rule.

l When you click in the cell, Excel displays
your input message.

l When you enter invalid data, Excel
displays your error alert.
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Important!
After you create your data entry
rules, use the steps outlined in
Task #1 under Paste Your
Validation List to place your data
entry rules in the cells in which
you want them.

Did You Know?
If you use cells to specify your
validation criteria in Step 7,
you can change the criteria as
needed without changing the
validation rule.

Did You Know?
When you make an incorrect entry,
the Stop Error Alert style displays
the error message you entered
and prevents you from making an
entry that does not meet your
criteria. The Warning Alert style
and the Information Alert style
allow you to enter data that does
not meet your criteria.
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1 Type the initial value for the
series you want to create.

2 Select the cell or cells.

3 Click the Fill handle.

Extend a series with

AUTOFILL
AutoFill gives you a way to ensure accurate data
entry when a particular data series has an intrinsic
order: days of the week, months of the year, numeric
increments of two, and so on.

To use AutoFill, start by typing one or more values
from which you will generate other values. Select the
cell or cells you want to extend. Selecting two or
more cells determines the step size, or increment, by
which you want to jump in each cell. With the cells

selected, click the Fill handle in the lower-right corner
and drag. When you release the mouse button, Excel
fills the cells with values.

After filling the cells, Excel provides a menu button.
Click the button to open a menu that enables you to
change the fill. You can copy the initial value; fill the
series one day at a time; or extend it by weekdays,
months, or years, depending on the type of fill you
create.
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4 Drag the desired number of cells
and release the mouse.

l Excel fills the cells with a series.

l The AutoFill Options button
appears.

5 Click the button.

A menu appears.

6 Click Copy Cells ( changes
to ).

8
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l Excel changes the series
to a copy of the original
cell.

7 Type a pattern of
entries.

8 Repeat Steps 2 to 4.
77

9

l Excel fills the cell with the pattern.
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Did You Know?
When you release the mouse button after creating a series, the AutoFill Options
button ( ) appears. Click the button to view a menu of options. If you want to
fill with the days of the week, you can click Fill Days or Fill Weekdays to fill with
Monday through Friday ( changes to ). You can also click the Fill Formatting
Only option ( changes to ) to change the formatting of the cell without
changing the contents. Click the Fill Without Formatting option ( changes to )
to change the contents of the filled cells without changing the formatting. You can
extend a series in any direction: up, down, left, or right.
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ADD A SYMBOL

1 Click in the cell in which you
want to insert a symbol.

2 Click the Insert tab.

3 Click Symbol in the Text group.

Insert

SYMBOLS OR SPECIAL
CHARACTERS
In Excel, you are not restricted to the standard
numerals, letters, and punctuation marks on your
keyboard. You can also select from hundreds of special
characters, such as foreign letters and currency
characters such as the Euro (€). Each font has a
different set of special characters. A smaller set of
standard characters, called symbols, is always
available as well; they include dashes, hyphens, and
quotation marks.

Symbols and special characters serve many uses in
Excel. Many financial applications, for example, call

for currency symbols. Symbols and special characters
are useful in column and row heads as part of the
text describing column and row content, for example,
Net sales in €.

Using symbols and special characters in the same cell
with a value such as a number, date, or time usually
prevents the value from being used in a formula. If
you need to use a symbol in a cell used in a formula,
use a number format. If you need to create a custom
number format, see Task #98.
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l The Symbol dialog box appears.

4 Click here and then select a font.

5 Click the Symbol you want.

6 Click Insert.

l The character appears in the cell.

7 Click Close.

The Symbol dialog box closes.

10
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ADD A SPECIAL CHARACTER

1 Click in the cell in which
you want to insert a
special character.

2 Click the Insert tab.

3 Click Symbol in the Text
group.
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l The Symbol dialog box appears.

4 Click the Special Characters tab.

5 Locate the character you want and click it.

6 Click Insert.

l The character appears in the cell.

7 Click Close.

The Symbol dialog box closes.
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Did You Know?
In Excel, entries are numbers, dates, times, letters,
or special characters. You can only use numbers,
dates, and times in numeric calculations. Excel
treats letters and special characters as blanks or
zeroes in calculations. To have a currency symbol
appear with a value, as in $400, and use the cell
value in a calculation, you must apply a currency,
accounting, or custom format.

Did You Know?
Excel fonts are based on Unicode, a set of 40,000
characters enabling the display of characters from
approximately 80 languages, including right-to-left
alphabets such as Hebrew. To use a language other
than English, attach an appropriate keyboard and
use the Control Panel to set the Regional and
Language options.
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ADD A GROUP

1 Click and drag to select the rows
or columns to hide.

2 Click the Data tab.

3 Click Group in the Outline group.

You can also select the rows or
columns and then press
Shift+Alt+Right Arrow.

Hide rows by

GROUPING AND OUTLINING
You can use the Excel grouping and outlining feature
to hide sets of columns and/or rows. For example,
you can hide the details relating to weekly sales
so you can compare monthly sales. Your outlines
can include up to eight levels of detail.

Outlining a set of rows or columns creates a clickable
button on the far left or top of your worksheet. The
button displays either a minus sign or a plus sign,
depending on what is displayed in the worksheet.
Click the minus sign to hide rows or columns, and

the plus sign to display them again. Adjacent to the
button is a solid line that indicates, by its length, the
approximate number of rows or columns Excel has
hidden.

Outlining was designed for use with structured
information such as lists but can be used with
any worksheet. When you outline a PivotTable,
outlining has the same effect as it does in any other
worksheet.
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l The Group dialog box appears.

4 Click to select either the Rows or
the Columns option ( changes
to ).

Click Rows if you want to group
rows.

Click Columns if you want to
group columns.

5 Click OK.

12
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l Excel creates a new left
or top margin with a
minus sign.

6 To hide the rows, click
the minus sign.

The rows disappear, and
a plus sign replaces the
minus sign.
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l To display the rows again, click the plus
sign.

REMOVE A GROUP

1 Click the Data tab.

2 Click Ungroup.

l The Ungroup dialog box appears.

3 Click to select either the Rows or the
Columns option ( changes to ).

Click Rows if you want to ungroup rows.

Click Columns if you want to ungroup
columns.

4 Click OK.

Excel removes the group.
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Did You Know?
You can nest outlines; that is, you can place one
group of outlined rows or columns inside another.
For example, within each year, you can group each
month, and within each month, you can group
each week.

Did You Know?
You can also hide rows and columns by clicking
and dragging the lines that separate the column
letters or the row numbers. Also, if you click and
drag over column letters or row numbers and then
right-click, a menu appears. Click Hide to hide
the column or row or Unhide to display hidden
columns or rows.
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1 Click the Home tab.

2 Click Find & Select in the Editing
group.

A menu appears.

3 Click Replace.

Alternatively, you can press
Ctrl+H to open the Find and
Replace dialog box.

FIND AND REPLACE
formats

Cells can contain numbers, text, comments, formats,
and formulas. With Excel, you can search for any
of these elements to view them, replace them, or
perform some other action. You may, for example,
find and replace values to correct mistakes, or perhaps
you need to return to a value to add a comment or
apply formatting.

The Excel Find and Replace dialog box is available on
the Home tab in the Editing group or by pressing
Ctrl+H. The Find feature is part of Find and Replace
and is available on the Home tab in the Editing group
or by pressing Ctrl+F.

To find and replace formats, specify what you are
seeking and with what you want to replace the item
you are seeking. Click the Options button in the Find
and Replace dialog box to specify additional details.
Use the Within drop-down menu to indicate whether
to search the current worksheet or the current
workbook. Click the Formatting button to restrict
your search to characters formatted in a certain way,
such as bold or percentages.

11
22
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33

l The Find and Replace dialog box
appears.

4 Click Options if your dialog box
does not look like the one shown
here. 

Note: The Options button allows
you to toggle between the short
and long form of the dialog box.

5 Click here and select Choose
Format from Cell.

14
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The Find and Replace
dialog box disappears.

6 Click in a cell that has
the format you want to
replace.

This example selects
green fills.

l The Find and Replace
dialog box reappears.

l A preview of the format
you selected appears.

7 Click here and select
Choose Format from cell.

The Find and Replace
dialog box disappears.
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8 Click in a cell that has the format you want to
use as a replacement.

This example selects a cell with no fill.

The Find and Replace dialog box reappears.

l A preview of the format you selected appears.

9 Click Replace All.

l Excel replaces the formats.

Excel replaces all of the green fills with plain fills.

0 Click OK.

! Click Close.

l You can click Replace to make one change at
a time.

l If you want to find instead of replace formats,
click Find All or Find Next to highlight cells in
the worksheet but not replace formats.
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Important!
Before you start a new Find
and/or Replace, make sure you
clear all formats by clicking the
down arrow next to the two
Format buttons and then clicking
Clear Find Format and Clear
Replace Format.

Did You Know?
In the Find and Replace dialog
box, clicking a Format button
opens the Find Format or Replace
Format dialog box. You can use
these dialog boxes to specify the
Number, Alignment, Font, Border,
Fill, or Protection you want to
find and/or replace.

Did You Know?
When searching for text or values,
type the text or value you are
looking for in the Find What field.
Type the text or value you want
to replace it with in the Replace
With field.
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ADD A COMMENT

1 Click in the cell to which you
want to add a comment.

2 Click the Review tab.

3 Click New Comment in the
Comments group.

ADD COMMENTS 
to your worksheet

A comment is a bit of descriptive text that enables
you to document your work when you add text or
create a formula. If someone else maintains your
worksheet, or others use it in a workgroup, your
comments can provide useful information. You can
enter comments in any cell you want to document or
otherwise annotate.

Comments in Excel do not appear until you choose to
view them. Excel associates comments with
individual cells and indicates their presence with a
tiny red triangle in the cell’s upper-right corner. View

an individual comment by clicking in the cell or
passing your cursor over it. View all comments in a
worksheet by clicking the Review tab and then
clicking Show All Comments.

When you track your changes, Excel automatically
generates a comment every time you copy or change
a cell. The comment records what changes in the
cell, who makes the change, and the time and date
of the change. To learn more about tracking changes,
see Task #34.

44
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33

l A comment box appears.

l A tiny red triangle appears in the
upper-right corner of the cell.

4 Type your comment.

Note: To apply bold and other
formatting effects, select the text,
right-click, click Format Comment,
and then make changes as
appropriate.

5 Click outside the comment box
when you finish.

The comment box disappears.

Move the cursor over the cell to
display your comment again.

16
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6 Click Edit Comment in
the Comments group
to edit a comment.

7 Click Delete in the
Comments group to
delete a comment.
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DISPLAY ALL COMMENTS

8 Click Show All Comments in the
Comments group.

l You can now see all the comments in the
worksheet.

To close the comment boxes, click Show
All Comments again.

9 To cycle through comments click Previous
or Next in the Comments group.
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Did You Know?
To set the name that displays when you enter a
comment, click the Office button, and then click Excel
Options. The Excel Options dialog box appears. Click
Popular and then type the name you want to appear
in the comment box in the User Name field.

Did You Know?
When a comment gets in the way of another
comment or blocks data, you can move it. Position
your cursor over the comment box border until the
arrow turns into a four-sided arrow. Click and drag
the comment to a better location and then release
the mouse button. Your comment remains in this
position until you display all comments again.
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READ CELLS

1 Click and drag to select the cells
you want Excel to read.

2 Click either the Speak by
Columns or the Speak by Rows
button.

l Click Speak by Columns if you
want Excel to read down the
columns.

l Click Speak by Rows if you want
Excel to read across the rows.

Let Excel

READ BACK YOUR DATA
If you have a large amount of data to enter, especially
numbers, you may want to check the accuracy of
your data entry by having the data read back to you
while you match it against a printed list. Excel can
read back your data. All you have to do is specify the
data you want to read, click a button, and Excel
begins reading. You can choose to have Excel read
across the first row and then move to the next row,
or down the first column and then move to the next
column. You can also have Excel read data as you
enter it.

However, before Excel can read your data, you must
add the following buttons to the Quick Access
toolbar: Speak Cells, Speak Cells — Stop Speaking
Cells, Speak Cells by Columns, Speak Cells by Rows,
and Speak Cells on Enter. To learn how to add
buttons to the Quick Access toolbar, see Task #95.
You can find the buttons needed for this task in the
Commands Not in the Ribbon section.

11

33
3 Click the Speak Cells button.

Excel reads the cells.

l To stop the reading of cells, click
the Speak Cells — Stop Speaking
Cells button.

18
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SPEAK CELLS ON ENTER

4 Click the Speak on
Enter button.

Excel says, “Cells will
now be spoken on
Enter.”

5 Enter data into your
worksheet.

Excel reads the data as
you enter it.55

44

66
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6 Click the Speak on Enter button again.

Excel says, “Turn off Speak on Enter.”

Excel stops reading the data as you enter it.
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Important!
To have Excel read your worksheet, you must have
speakers attached to your computer and you must
set the Speech, Sound, and Audio Devices option
in the Control Panel properly. Click the Start
button, Settings, and then Control Panel to check
these device settings.

Did You Know?
You can also check the accuracy of your data entry
by performing a spell check. Just click the Review
tab, Proofing, and then Spelling. If your worksheet
has errors, the Spelling dialog box appears and
offers suggestions for the correct spelling. You can
accept one of the suggestions or click one of the
other dialog box options.
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1 Click and drag to select the cells
with which you want to create
your custom list.

2 Click the Office button.

A menu appears.

3 Click Excel Options.

Create your own 

SORT OR AUTOFILL
In Excel, you can sort your data alphabetically, by
days of the week, or by months of the year. See
Chapter 4 to learn more about sorting your data. You
can also automatically fill cells with the days of the
week or months of the year by using Excel’s AutoFill
feature. See Task # 3 to learn more about AutoFill. 

If you have a data series you use often, you can
create your own custom list and use it to fill cells
automatically or to sort a list. For example, you
collect data by region and you always list the data

in the following order: North East, South East, North
Central, South Central, North West, and South West.
You can create a custom list that enables you to
AutoFill and sort based on your list.

Use the Custom List dialog box to create your custom
list. You can type your list into the Custom List dialog
box or import your list from cells in your worksheet.
You access your custom list the same way you would
any other custom list or AutoFill.

22
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The Excel Options dialog box
appears.

4 Click Popular.

5 Click the Edit Custom Lists
button.

20
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l The Custom Lists dialog
box appears.

l The range you selected in
Step 1 appears here.

You can click and drag or
type the range in the
Import list from cells field.

l Alternatively, you can
type your list here and
then click Add.

6 Click Import.
66

77
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l Your list appears as a custom list.

7 Click OK.

Your list is ready to use.
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Did You Know?
To create an AutoFill using your custom list, type the
first item in your list. Click and drag the fill handle
located in the lower-right corner of the cell. Excel
fills the cells with your custom list. If Excel does not
fill the cells with your custom list, click the AutoFill
Options button ( ) that appears and then click
Fill Series ( changes to ).

Did You Know?
To sort using the custom list you created, click and
drag to select the items you want to sort. Click the
Data tab and then click Sort in the Sort & Filter
Group. The Sort dialog box appears. In the Order
field, click Custom List. The Custom List dialog box
appears. Click your list and then click OK. For
detailed instructions, see Chapter 4.
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