
Introducing 
Excel Programming

A s you probably know, Microsoft Excel is an
electronic worksheet you can use for a variety of
purposes, including the following: maintain lists;

perform mathematical, financial, and statistical
calculations; create charts; and analyze your data with a
PivotTable. Excel can also help you locate data, find
trends in your data, and present your data to others.
This book is about automating the tasks you perform in
Excel by using Visual Basic for Applications (VBA). You
can use VBA to automate those repetitive tasks you
perform frequently. For example, if the layout of your
monthly report rarely changes, you can use VBA to set
up your report each month.
VBA is a programming language; however, you do not
have to be a programmer to automate the tasks you
perform in Excel. You can also automate a task by using
the macro recorder to create a macro. A macro is a

recording of the steps you want to automate. You just click
a button to turn on the macro recorder and begin
performing the steps as you normally would. Excel records
each step and creates the VBA code. When you finish, you
click the Stop Record button. When you select your macro
in the Macro dialog box and click the Run button, Excel
plays back the steps you recorded. For example, if you
record the steps necessary to create your monthly report,
all you have to do each month thereafter is click a button
and Excel automatically sets up your report.
With VBA, you can do more that just create macros. You
can use VBA to edit macros, create new functions, create
custom applications, and create add-ins. For these tasks,
you must learn the VBA programming language. This
book teaches VBA. It is based on Office 2007; code you
write for Office 2007 may not be compatible with earlier
versions of Excel.

1 Click the Developer tab.

Note: See the section, “Introducing Macros,” to learn how to
display the Developer tab.

Use the options in the Code group to automate your tasks.

2 Click either of these Record Macro buttons to record a
macro.

Note: See the section, “Record a Macro,” for more details.

3 Click Macros to run a macro.

Note: See the section, “Run a Macro,” for more details.
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• Use the options in the Controls group to add check boxes,
fields, and other form controls to your worksheet.

• Use the options in the XML group to work with XML.

4 Click here or press Alt+F11.

Excel moves to the Visual Basic for Applications Editor (VBE).
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You can also use Microsoft Visual Studio Tools for the Microsoft Office System (Visual Studio) to develop
programs for Microsoft Office products. With Visual Studio, you can write in languages such as Visual Basic
.NET, Visual C#, and Managed Extensions for C++. Visual Studio is not part of Microsoft Office; you must
purchase it. Microsoft supports both VBA and Visual Studio.

Visual Studio is more difficult to learn than VBA and setting up and using Visual Studio is much more
difficult than setting up and using VBA. However, Visual Studio offers better security, a more sophisticated
development environment, and built-in Web services.

5
6

Use the VBE to write and edit code.

Note: See Chapter 2 to learn more about the VBE.

5 Click the proper module to access your
macros or the VBA code you have written.

6 Type or edit your code here.

7 Press Alt+F11 to return to Excel.

The VBA returns you to Excel.
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Introducing 
Macros

Y ou can use macros to automate many of the tasks
you perform in Excel. For example, if you
frequently format your data in a particular way,

you can use Excel’s macro recorder to record the steps
you use to format your data. You can then play back the
recorded steps whenever you want to apply your format.
Any series of commands you can execute in Excel, you
can also record and play back.
The commands you use to create and execute macros are
located on the Developer tab. By default, the Developer
tab does not display in Excel. To display it, you must
choose the Show Developer Tab in the Ribbon option in
the Excel Options dialog box.
You begin recording macros by clicking Record Macro on
the Developer tab or by clicking the Record Macro button
on the status bar. Both commands open the Record Macro
dialog box. For detailed instructions on how to use the

Record Macro dialog box, see the section, “Record a
Macro.”
When you record a macro, you can record it using an
absolute reference or a relative reference. If you record
using an absolute reference, when Excel plays back your
macro, it plays back the exact cells you clicked when you
recorded the macro. If you record using a relative
reference, Excel plays back the relative location of the
cells you used when you recorded your macro. Click the
Use Relative References button on the Developer tab to
record using a relative reference. To learn more about
absolute and relative references, see the section, “Record
a Macro.”
When you save a workbook that has macros, you must
save it as a macro-enabled workbook. Excel gives macro-
enabled workbooks an .xlsm file extension.

SHOW THE DEVELOPER TAB

1 Click Customize Quick Access Toolbar and then click More
Commands.

The Excel Options dialog box appears.

2 Click Popular.

3 Click Show Developer Tab in the Ribbon ( changes to ).

4 Click OK.

The Developer tab appears in the Ribbon.

• Click to record a macro.

• Click to record with a relative reference.

• Click to change macro security.

• Click to run macros.

• Click to open the Visual Basic Editor.

1

1

3
2

4

Introducing Macros

4

04_132302 ch01.qxp  7/27/07  9:19 PM  Page 4



Ch
apter 1: U

sin
g M

acros an
d Form

 Con
trols

5

1

2

4

3

5

SAVE A WORKBOOK

1 Click the Microsoft Office button.

A menu appears.

2 Click Save As ➔ Excel Macro-Enabled
Workbook.

The Save As dialog box appears.

3 Click here and then select the folder in which
you want to save your workbook.

4 Type the name you want to give your
workbook.

5 Click Save.

Excel saves your workbook as a macro-enabled
workbook.

Because of problems with macro viruses, Excel
disables all macros by default when you open a
workbook. You can click the Macro Security button
on the Developer tab to change the default setting.
To learn more about macro security, see the
sections, “Set Macro Security,” “Create a Digital
Signature,” and “Assign a Digital Signature to a
Macro.”

If you have programming experience or aptitude,
you can edit Excel macros by using the Visual Basic
Editor, which is available by pressing the Visual
Basic button on the Developer tab.

You can use the Macro dialog box to run a macro.
To open the Macro dialog box, click the Macro
button on the Developer tab, press Alt+F8, or place
the View Macros button on the Quick Access
toolbar.

To place the View Macros button on the Quick
Access toolbar, click the Microsoft Office button,
and then click Excel Options. The Excel Options
dialog box appears. Click Customize. The Customize
the Quick Access Toolbar pane appears. In the
Choose Commands From field, choose Popular
Commands and then click View Macros. Click the
Add Button. Click OK. The View Macros button
appears on the Quick Access toolbar.
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Set Macro 
Security

B ecause of increasing problems with computer
viruses, specifically macro viruses, the default
Excel macro security setting disables all macros

when you open a workbook, and allows you to decide on
a case-by-case basis whether you want to enable them.
This is true whether you created the macros or someone
else created them.
You can change the Excel macro security setting. Excel
provides four options:

• Disable all macros without notification: This
option disables all macros and does not provide you
with any security alerts to let you know macros exist.

• Disable all macros with notification: This is the
default setting. It notifies you if macros are present
so you can enable them on a case-by-case basis.

• Disable all macros except digitally signed
macros: This option disables all macros except
those digitally signed by a trusted publisher. If the

publisher has digitally signed the macro but you
have not opted to trust the publisher, you can
enable the macro or trust the publisher. See the
“Extra” information in the section, “Run a Macro,”
to learn how to trust a publisher.

• Enable all macros (not recommended; potentially
dangerous code can run): This option allows you to
run all macros. Because potentially dangerous code
can run, Microsoft does not recommend this option.

Changes you make to macro security in Excel do not
change the macro security in other Office programs.
Macro creators use digital signatures to verify the safety
of the macros they create. You can create your own
digital signature by using the Microsoft Selfcert.exe tool,
or you can obtain a digital certificate from a commercial
certificate of authority vendor. For more information on
the Microsoft Selfcert.exe tool, see the next section,
“Create a Digital Signature.”

1 Click the Developer tab.

Note: See the section, “Introducing Macros,” to learn how to
display the Developer tab.

2 Click Macro Security in the Code group.
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The Trust Center dialog box appears.

3 Click to select a macro setting ( changes to ).

4 Click OK.

Excel changes your macro security setting.
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I f you create a workbook that contains macros,
you should consider using a digital signature. A
digital signature provides assurance that the

workbook file is valid and no one has altered it. You
can create a personal digital signature by using the
Microsoft Selfcert.exe tool. Projects signed with digital
signatures created with the Selfcert.exe tool only
work on computers that have the certificate in their
Personal Certificates store.
Digital signatures that you create with the
SelfCert.exe tool work well for personal workbooks;
however, if you plan to distribute your workbook to
users outside your workgroup, you should consider
acquiring a commercial digital signature file. When
you use a commercial digital signature file, the digital
ID attaches to the macro and remains with it; if
anyone alters the macro, Excel notifies the user that

someone has changed the macro and therefore the
macro should not be trusted.
The most common provider of commercial digital
certification is VeriSign, Inc. You can find out more
about obtaining a commercial certification from
VeriSign at www.verisign.com. 

Create a Digital Signature

1 Click Start.

2 Click All Programs ➔ Microsoft Office ➔
Microsoft Office Tools ➔ Digital Certificate
for VBA Projects.

2

1

3

4

The Create Digital Certificate dialog box
appears.

3 Type the name you want to give your
certificate.

4 Click OK.

Excel creates a Personal Digital Certificate.

To view the certificates in your Personal
Certificate store, open Internet Explorer. On the
Internet Explorer menu, click Tools and then
click Internet Options. The Internet Options
dialog box appears. Click the Content tab. Click
the Certificates button. The Certificates dialog
box appears. Click the Personal tab. All of your
personal certificates appear.
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Record a 
Macro

A macro enables you to automate common tasks.
You can use a macro to record any series of
commands you can execute in Excel. For

example, if you frequently apply a certain format to your
worksheet, you can record the steps for creating the
format and then play them back each time you want to
apply the format.
Clicking the Macro Recorder button opens the Record
Macro dialog box in which you can name your macro,
assign your macro to a shortcut key, and tell Excel where
you want to store your macro. You can name your macro
anything you want, with the following limitations: the
name must start with a letter; it can only contain letters,
numbers, and underscores; and it cannot contain any
spaces. You can assign any uppercase or lowercase letter
to act as the shortcut key.

In the Record Macro dialog box, the Store Macro In field
tells Excel where to store your macro. You can choose to
store your macro in the Personal Macro Workbook, a New
Workbook, or This Workbook. Use the Personal Macro
Workbook option if you want to make your macro
available to all Excel files. After you have stored a least
one macro in the Personal Macro Workbook, the
workbook opens whenever you open an Excel file. Use
the New Workbook option if you have specialized macros
that you want to use with multiple files. If you store your
macro in a new workbook, you can use the macros
whenever that workbook is open. Use the This Workbook
option if you want your macro to be in the workbook in
which you are currently working.

1 Click the Developer tab.

Note: See the section, “Introducing Macros,” to learn how to
display the Developer tab.

• Alternatively, click the Record Macro button on the status
bar and skip step 2.

2 Click Record Macro in the Code group.
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The Record Macro dialog box appears.

3 Type the name you want to give your macro.

4 Type the shortcut key you want to assign to your macro.

Press Shift as you type to assign an uppercase key.

5 Click here and then select the workbook in which you
want to store your macro.

6 Type a description of your macro.

7 Click OK.
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A macro you create in Excel can have a relative, absolute, or mixed reference. If you use a relative reference,
Excel performs the macro based on a relative location. For example, suppose you move up two cells from cell
A3 to A1 when creating your macro. When you run your macro, if you are in cell C3, Excel moves up two cells
from cell C3 to C1. However, if you use an absolute reference, Excel performs the macro based on the exact
cell addresses. For example, suppose again that you move up two cells from cell A3 to A1. When you run your
macro, if you are in cell C3, Excel moves from there to the cells you used when you recorded your macro. That
is, Excel moves from cell A3 to cell A1.

By default, Excel creates macros with an absolute reference. To create a macro with a relative reference, click
the Use Relative Reference button on the Developer tab to toggle the relative reference option on. To create a
macro with both a relative and an absolute reference — a mixed reference — toggle the Use Relative Reference
on and off as needed as you create your macro.

8

9

0

You are now ready to record your macro.

8 Perform the steps you want to record.

This example changes the number format.

9 Click the Developer tab.

• Alternatively, click the Stop Recording button
on the status bar and skip step 10.

0 Click Stop Recording in the Code group.

Excel stops recording your macro.

Your macro is ready for you to use.

Note: See the section, “Run a Macro,” to learn how
to run a macro.
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Assign a Digital 
Signature to a Macro

A digital signature provides assurance that a
workbook file is valid and no one has altered it.
There are two types of digital signatures:

personal digital signatures and commercial digital
signatures. You can create a personal digital signature by
using the Microsoft Selfcert.exe tool, or you can purchase
a digital signature. Refer to the section, “Create a Digital
Signature,” to learn how to create digital signatures.
After you create a digital signature, you must attach it to
your workbook. Attaching a digital signature is similar to
sealing an envelope. If an envelope arrives sealed, you
have some level of assurance that no one has tampered
with its contents.
Use the Digital Signature dialog box to attach a digital
signature. The Visual Basic Editor is a separate Excel

module that you can use to edit your macro. You access
the Digital Signature dialog box by opening the Visual
Basic Editor. The Digital Signature dialog box lists valid
certificates. You can use the Digital Signature dialog box
to view certificates and to select the one you want to use.
Unless you have on your computer a valid digital
signature certificate for the signature used to sign a
macro, Excel removes the digital signature if you modify
a macro in a workbook, and you must reattach it. If you
are not sure if a workbook has a digital signature, you
can check the signature by reviewing the Digital
Signature dialog box. If a workbook has a digital
signature, the name of the signature appears in the
Certificate Name field. If you click the Remove button in
the Digital Signature dialog box, Excel removes the
digital signature.

1 Click the Developer tab.

Note: See the section, “Introducing Macros,” to learn how to
display the Developer tab.

2 Click Visual Basic in the Code group.

1
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Assign a Digital Signature to a Macro
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The Visual Basic Editor appears.

3 Click Tools ➔ Digital Signature.
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If you have macro security
enabled, Excel displays a warning
just below the Ribbon when you
open a workbook containing a
signed macro. You can click the
Options button located next to
the warning to open the
Microsoft Office Security
Options dialog box, where you
can indicate that you trust the
publisher. Excel then saves the
name of the publisher in the
Trusted Publishers section of the
Trust Center.

If you click the Macro Security
button on the Developer tab, the
Trust Center dialog box appears.
Click Trusted Publisher to display
a list of your trusted publishers.
If you no longer want to trust
macros from a publisher listed
on the Trusted Publishers page,
click the name of the publisher
and then click Remove. The next
time you open a workbook with
a macro from a removed
publisher, Excel again warns you
about its macros.

Unless you have your macro
settings set to enable all macros,
Excel checks all documents you
open for macros. See the section,
“Set Macro Security,” for more
information. If you have a file
that you do not want Excel to
check, you can store it in a
trusted location. In the Trust
Center dialog box, click Trusted
Locations to define a trusted
location.

4

5

6 7

Denise E... Denise Eth... Code Signing None 1/1/2012

The Digital Signature dialog box appears.

4 Click Choose.

The Select Certificate dialog box appears.

Note: See the section, “Create a Digital Signature,” to
learn how to create a digital signature.

5 Click the signature you want to apply.

6 Click OK to close the Select Certificate dialog box.

7 Click OK to close the Digital Signature dialog box.

Excel attaches the digital signature to your
workbook.
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Run a 
Macro

M acros enable you to perform quickly tasks that
would normally take multiple steps. When you
run a macro, Excel replays the steps you

recorded when you created the macro. You can run any
macro located in any workbook as long as the workbook
in which the macro is located is open. To run a macro,
you can press the shortcut key you assigned when you
created the macro or you can select the macro from the
Macro dialog box.
When you create a macro, you can choose to store it in
one of three locations: the current workbook, a new
workbook, or the Personal Macro Workbook. By default,
the Macro dialog box lists all of the macros in open
workbooks. If a macro is stored in the Personal Macro
Workbook, the workbook opens as a hidden file each

time you open a file. By default, the macros in the
Personal Macro Workbook always appear in the Macro
dialog box.
You can use the Macros In field to limit the number of
macros listed in the Macro dialog box. To see the macros
in any open workbook, including the Personal Macro
Workbook, select the All Open Workbooks option. To see
the macros from a specific workbook, select the name of
the workbook from the Macros In drop-down list. To see
global macros stored in the Personal Macro Workbook,
select the Personal.xlsb option.
To run a macro from another workbook, the macro must
be from a signed source or you must enable all macros.
You can set the security setting for macros. See the
section, “Set Macro Security,” for more information.

1 Select the cells to which you want to
apply your macro.

2 Click the Developer tab.

Note: See the section, “Introducing
Macros,” to learn how to display
the Developer tab.

3 Click Macros in the Code group.

Alternatively, click Alt+F8.

1

2

3

4

Run a Macro
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The Macro dialog box appears.

4 If your macro does not appear in the
Macro dialog box, click here and
then select the workbook that
contains your macro.

04_132302 ch01.qxp  7/27/07  9:20 PM  Page 12



Ch
apter 1: U

sin
g M

acros an
d Form

 Con
trols

13

Excel differentiates between macros listed in the
Macro dialog box by placing the name of the
workbook that contains the macros in front of the
macro name. For example, Excel lists a macro
named Sum_Expenses in the Personal Macro
Workbook as PERSONAL.XLSB!Sum_Expenses. If
the macro Sum_Cells exists in both the Budget.xlsm
and Expenses.xlsm workbooks, Excel treats them as
two different macros. The Macro dialog box lists
them as Budget.xlsm!Sum_Cells and
Expenses.xlsm!Sum_Cells.

If you have macro security enabled, the Trust Center
checks the macros when you open a workbook to
see if the macros are valid. If there are any
problems, Excel displays a warning just below the
Ribbon. You can click the Options button located
next to the warning to open the Microsoft Office
Security Options dialog box.

In the Microsoft Office Security Options dialog box,
click Help Protect Me from Unknown Content
(Recommended) to disable the macros, click Enable
the Content to enable the macros, or click Trust All
Documents from this Publisher to add the macro
publisher to the Trusted Publisher list. Excel does
not display a warning when you open workbooks
with macros if the publisher is on the Trusted
Publisher list.

5 6
Dollar_Money_Format

5 Click the name of the macro you want to run.

6 Click Run.

Excel runs the macro.

• In this example, the macro adds dollar signs and
removes the decimal places.

You can also run your macro by pressing the
shortcut key you assigned when you created
your macro.
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Create and Launch a 
Keyboard Shortcut

A keyboard shortcut is a combination of keys you
press to execute a command. You can use a
keyboard shortcut to launch an Excel macro

command. You can assign an uppercase or lowercase key
to a macro when you create it, or assign one later by
using the Macro Options dialog box. You execute a macro
keyboard shortcut by pressing the Ctrl key along with
that uppercase or lowercase key. Refer to the section,
“Record a Macro,” to learn how to create a macro.
Keyboard shortcuts are case sensitive. For example, Excel
interprets a lowercase m and an uppercase M as two
different keys. To execute a macro you have assigned to
a lowercase letter, press Ctrl plus the letter, such as
Ctrl+m. To execute a macro you have assigned to an
uppercase letter, press Ctrl and Shift plus the letter, such
as Ctrl+Shift+M.

If you assign the same keyboard shortcut to macros in
two different workbooks, you may execute the wrong
macro if you use the shortcut while you have both
workbooks open. Excel cannot discern from which
workbook you want the macro. You can use the Macro
Options dialog box to reassign one of the conflicting
macros to a new key.
You should also be careful not to assign the macro to a
keyboard shortcut that Excel uses. If you do, Excel
executes your macro instead of the command it created.
For example, by default, Ctrl+o opens the Open dialog
box. If you assign o to a macro, your macro overrides
Excel’s assignment.

CREATE A KEYBOARD SHORTCUT

1 Click the Developer tab.

2 Click Macros in the Code group.

The Macro dialog box appears.

3 Click the desired macro.

4 Click Options.

3

1

4

2

7

5
6

8

Plain Money Format

Create and Launch a Keyboard Shortcut
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The Macro Options dialog box appears.

5 Type the desired shortcut key.

Press Shift as you type to assign an uppercase key.

6 Type a description.

7 Click OK.

8 Click Close to close the Macro dialog box.
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If you do not use a macro shortcut frequently, it is
easy to forget the keyboard shortcut you assigned
to your macro. If you forget your keyboard shortcut,
you can view it in the Macro Options dialog box.

You can execute a macro by assigning the macro to a
picture, clip art, shape, or SmartArt. For example, if
you want to assign a macro to a picture, you start by
inserting the picture into your worksheet by clicking
the Insert tab and then clicking Picture. The Insert
Picture dialog box appears. In the Look In field,
select the folder in which you stored the picture you
want to insert. The pictures in that folder appear.
Click the picture you want to insert and then click
the Insert button. The picture appears in the
worksheet. Click and drag the picture to place it
where you want it and then  double right-click the
picture. A menu appears. Click Assign Macro. The
Assign Macro dialog box appears. Click the macro
you want to assign to the picture and then click OK.
Excel assigns the macro to the picture. Click the
picture when you want to execute the macro.

1

LAUNCH WITH A KEYBOARD SHORTCUT

1 Select the cells in which you want the macro
to execute.

2 Press Ctrl and the shortcut key.

• The macro executes.

3 Repeat steps 1 and 2 to execute the macro
again.
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Assign a Macro to the 
Quick Access Toolbar

Y ou can assign a macro to the Excel Quick Access
toolbar. You can execute macros assigned to the
Quick Access toolbar using a shortcut key or the

Macro dialog box; however, using the Quick Access
toolbar means you can access the macros by clicking the
appropriate button.
When you add a button to the Quick Access toolbar, you
can specify whether it should appear on the toolbar of all
Excel workbooks or only on the Quick Access toolbar in
the workbook you specify. By default, the button appears
in all workbooks. If you have placed your macro in the
Personal Macro Workbook, you will probably want your
macro button to appear in all workbooks. If your macro is
only available to a single workbook, your macro button
should only appear on the Quick Access toolbar for that
workbook.

You can use the Customize the Quick Access Toolbar
pane of the Excel Options dialog box to add a macro
button to the Quick Access toolbar. The Customize the
Quick Access Toolbar pane has a number of options you
can set. You can use the Modify button to specify the
button you want to use to represent your macro. You can
specify where on the Quick Access toolbar your button
appears and whether the Quick Access toolbar appears
above or below the Ribbon. You can click the Reset
button to return the Quick Access toolbar to its default
state.
Deleting a macro does not remove the macro button from
the Quick Access toolbar. You use the Remove button on
the Customize the Quick Access Toolbar pane of the Excel
Options dialog box to remove a macro button.

1 Click Customize Quick Access Toolbar and then click
More Commands.

The Excel Options dialog box appears.

2 Click here and then click Macros.

3 Click here and then click the workbook in which the
button should appear.

4 Click the macro you want to assign to the Quick
Access toolbar.

5 Click Add.

• The macro appears in the box on the right. Macros
display on the Quick Access toolbar in the order 
shown here.

• Click to move the macro up.

• Click to move the macro down.

6 Click Modify.

• Click if you want the Quick Access toolbar to appear
below the Ribbon ( changes to ).

1

1

3

4

6

5

2

Assign a Macro to the Quick Access Toolbar

16
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You can add commands you frequently use to the
Quick Access toolbar. Click the Microsoft Office
button. A menu appears. Click the Excel Options
button located in the bottom-right corner. The Excel
Options dialog box appears. Click Customize.
The Customize the Quick Access Toolbar page
appears. Click the down arrow next to the Choose
Commands From field and select All Commands.
Click the command you want to add to the Quick
Access toolbar and then click the Add button. Click
OK. Excel returns you to your workbook, and the
command you chose appears on the Quick Access
toolbar.

You can add commands you cannot find in the
Ribbon by choosing Commands Not in Ribbon in
the Choose Commands From field. If a command
from a previous version of Excel is not in the
Ribbon, you may find it listed under Commands
Not in the Ribbon. For example, in previous versions
you could format your documents quickly by using
AutoFormat. Excel 2007 uses styles, but you can
still access AutoFormat through the Commands Not
in Ribbon feature.

7

8

9

0

The Modify Button dialog box appears.

7 Click the button you want to use to represent
your macro.

8 Click OK to close the Modify Button dialog box.

9 Click OK to close the Excel Options dialog box.

• Click to return the Quick Access toolbar to its
default state.

• Click the macro and then click the Remove
button to remove a macro.

The button appears on the Quick Access toolbar.

0 Click the button to execute your macro.
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Delete a 
Macro

Y ou can delete macros you no longer need by
clicking the Delete button in the Macro dialog box.
Because the Macro dialog box only displays

macros in open workbooks, the workbook that contains
the macro must be open before you can delete it.
The Personal Macro Workbook stores macros you want to
make available to all workbooks. Excel creates the
Personal Macro Workbook when you choose to store your
first macro in it. After Excel creates the Personal Macro
Workbook, the workbook opens as a hidden file every
time you open Excel. To learn more about storing macros
in the Personal Macro Workbook, see the section,
“Record a Macro.”
If your macro is in a hidden workbook such as the
Personal Macro Workbook, you must unhide the
workbook before you can delete the macro. If you try to

delete a macro from the Personal Macro Workbook prior
to unhiding it, Excel displays the following message:
“Cannot edit a macro on a hidden workbook, Unhide the
workbook using the Unhide command.” You can unhide
the Personal Macro Workbook and other hidden
workbooks by executing the Unhide command on the
View tab.
If you unhide the Personal Macro Workbook, make sure
you hide it again using the Hide command on the View
tab after you delete the macros. Hiding the workbook
prevents you from making inadvertent changes to it.
You cannot undo the deletion process, but if you delete a
macro by mistake, you can close the workbook without
saving. Of course, if you close without saving, you will
lose all of the work you have done since saving. Your
only other alternative is to re-create the macro.

UNHIDE A WORKBOOK

1 Click the View tab.

2 Click Unhide in the Window group.

PERSONAL.XLSB

1

2

3

4

Delete a Macro
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The Unhide dialog box appears.

3 Click the workbook you want to unhide.

4 Click OK.

Excel unhides the workbook.
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Typically, you do not share the Personal Macro
Workbook with other users. Excel creates a different
Personal Macro Workbook for each username on a
computer. If you have multiple users on your
computer with different usernames, Excel creates a
different Personal Macro Workbook for each of
them. You can copy a Personal Macro Workbook
from one user to another. The Personal Macro
Workbook is stored in the XLStart folder and is
named PERSONAL.XLSB. In Windows XP, you can
usually find the XLStart folder by following this
path: C:\Documents and Settings\username \
Application Data\Microsoft\Excel\XLStart. In
Windows Vista, you can usually find the XLStart
folder by following this path: C:\Users\username\
Application Data\Microsoft\Excel\XLStart.

Each user can only have one PERSONAL.XLSB file.
If a user already has a Personal Macro Workbook,
you should rename the old PERSONAL.XLSB file
and place the new PERSONAL.XLSB file in the
user’s XLStart folder. All files stored in the XLStart
folder open when you open Excel, and so both files
become available each time the user opens Excel. If
you have other files you want to open when you
open Excel, place them in the XLStart folder.

3

4

1

2

5

Plain Money Format

DELETE A MACRO

1 Click the Developer tab.

2 Click Macros in the Code group.

The Macro dialog box appears.

3 Click the macro you want to delete.

4 Click Delete.

A message box appears, asking you to confirm
that you want to delete the macro.

5 Click Yes.

Excel deletes the macro.
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Add a Form Control 
to a Worksheet

Y ou can add controls to a worksheet to make it
easier to enter data into a cell. Form controls can
help users who are not familiar with Excel and

can increase the accuracy of data entry by limiting a
user’s options. For example, you can add check boxes to
your worksheet so it looks like a paper form. You can
also add a list box from which users can select an entry.
Excel provides nine controls you can add to a worksheet.
You add controls by selecting the control you want from
the Forms Control menu. After you add a control, you
can adjust its size by dragging the side or corner handles.
When you add a control or right-click a control to edit,
you are in design mode. In design mode, you can modify
the properties and size of the control, but you cannot test
its functionality.

When you place a control on a worksheet, it sits on top
of the worksheet. You can size it so it appears to be
located in a cell, but controls are separate from cells and
you can place them anywhere on the worksheet. A
control can cover any portion of a cell or range of cells.
After you add controls to a worksheet, you can assign
them values. See the section, “Assign Values to a Form
Control,” for more information on assigning control
values. Form control options are located on the Developer
tab. See the section, “Introducing Macros,” to learn how
to display the Developer tab.

1 Click the Developer tab.

Note: See the section, “Introducing Macros,” to learn how to
display the Developer tab.

2 Click Insert in the Controls group.

The Forms Control menu appears.

3 Click to select the control you want to add.

3

1

2

4 5

Add a Form Control to a Worksheet
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4 Drag the cursor to create the control.

5 Drag the handles on the sides and corners to adjust the
size.
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You can add the controls listed in the following table to your worksheets.

CONTROL CONTROL NAME DESCRIPTION

Button Runs an associated macro when the user clicks it.

Combo box Displays a list of items as a menu.

Check box Selects or deselects an option.

Spinner Scrolls up and down through a list of numeric values.

List box Displays a list of items for selection.

Radio button Selects one of a group of items when the user clicks it.

Group box Places related controls together.

Label Provides information about an associated control.

Scroll bar Increases or decreases a value when the user clicks the arrows or drags the bar.

6

6 Place your pointer on the border of a control and
drag the control to change its location.

The control appears on the worksheet.

• Right-click the control to place it in design mode.

• To cancel design mode, click any cell in the
worksheet.

• To remove a control, right-click the control to
select it and then press Delete.
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Assign Values to 
a Form Control

A fter you add a control to a form, you can assign
it the values you want associated with the
control. For example, if your worksheet contains

a list box, you can assign the list of values that you want
to appear when users access the list box. Some controls
enable you to define a range of valid numeric values for
the control. For example, if you use a spinner, you define
the starting value and the maximum value for the
control. For combo boxes and list boxes, you can place
the options associated with the control in a range of cells.
For example, if you use a combo box, you tell Excel the
list of values used by the control by entering the range of
cells containing the values. The values can be located on
another worksheet or even in another workbook, as long
as Excel can access the workbook when users view the
worksheet that contains the control.

You can link a cell to a control. If you link a cell to a
control, the value associated with a user selection
becomes the value of the linked cell. If you use a combo
box control or list box control, the value in the linked cell
is a number that represents the user’s selection. Excel
assigns the number based on the position of the selected
value in your list. If the list contains the values
Computer, Monitor, and Keyboard, and the user selects
Monitor, the linked cell receives the value 2, because
Monitor is second in the list.
With a control such as a check box, you can tell Excel
whether you want the option to be initially selected or
unselected. Each option — selected or unselected — has a
value associated with it.

1 Right-click the selected control.

A menu appears.

2 Click Format Control.

The Format Object dialog box appears.

3 Click the Control tab.

The available fields are different, depending on the
control type.

This example uses a list box.

4 Drag to select a range, or type the range that lists
the valid values.

5 Click a cell to assign a linked cell.

The value associated with your selection appears in
the linked cell.

6 Type the number of values in your list.

7 Click OK.

1

2

3

5
6

4

7

Assign Values to a Form Control
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8Monitor

8 Select the desired control value.

• Excel places a numeric value representing the
control selection in the linked cell.

When working with a value selected from a list box or combo box control, you may want to use that selection
to set the value of another cell. For example, assume you have the following Excel list in cells H2:I4.

Example:
Computer     $1295

Monitor      $995

Keyboard     $55

You can use the Index function to determine the price, based on the equipment selection. For example,
if the user selects Monitor from the control, Excel places a value of 2 in the linked cell. If you want
users to find the cost of the selection, you type a formula similar to the following, assuming that C2 is
the linked cell:

Example:
=INDEX($H$2:$1$4, C2, 2)

The Index function actually creates an array of the Excel list and uses the control selection to determine which
element in the array to return, in this case the price, The function uses three arguments: Array, Row_num,
and Column_num.
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Add a Macro to 
a Form Control

Y ou can assign a macro to any form control on a
worksheet. For example, if a user clicks a radio
button control, you can have Excel add a postage

amount to an invoice.
You can create one macro for each control on a
worksheet. You create a macro either by recording a
series of keystrokes or by writing a VBA procedure in the
Visual Basic Editor. When you select the Assign Macro
menu option, Excel automatically creates a new macro
with the name of the control followed by an underscore
and an event name, such as _Click. Excel assigns the
control name to the control when you add it to your
worksheet. For example, the first OptionButton control
you add to a worksheet is named OptionButton1. If you

create a macro for the option button, Excel gives the
macro the name OptionButton1_Click.
The portion of the macro name following the underscore
character corresponds to an action, commonly referred to
as an event. For example, with an OptionButton control,
the user clicks the radio button to select the option, and
so the event is Click. If you create a macro for a combo
box control, Excel assigns Change to the name of the
event because you want to execute the macro when the
value of the control changes. The event extension tells
Excel to monitor the control and execute the macro
whenever a user clicks the control.
No matter which option you select — recording or writing
VBA — Excel assigns the same name to the macro.

1 Right-click your control.

A menu appears.

2 Click Assign Macro.

1

2

3

Add a Macro to a Form Control
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The Assign Macro dialog box appears.

Excel assigns a default macro name for the selected
control.

3 Click Record and then record your macro.

Note: See the section, “Record a Macro,” for more
information.
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The macros you assign to a control only execute when the corresponding event occurs for the control. For
example, you may have a macro assigned to a control that computes the total amount to be paid when the
user clicks the control. If you change the values needed to compute the total amount after a user clicks the
control, Excel does not update the total until the user clicks the control again.

If you no longer want a macro to be assigned to a control, right-click the control and then click the Assign
Macro option. In the Assign Macro dialog box, clear the macro name from the Macro Name field and then
click OK. Excel removes the macro assignment from the control, but the macro remains as part of the
workbook. To remove the macro from the workbook, click the View tab and then click Macros in the Macros
group to display the Macro dialog box. Select the macro you want to delete and then click Delete.

4

4 Click the control with the assigned macro.

Excel executes the associated macro.

• In this example, Excel assigns postage to the
invoice.
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