%% é 3738x.book Page 1 Monday, June 25,2007 11:37 PM

R

The Basics

In this part:

*

L K R R 4

Chapter 1: Exploring the AutoCAD and AutoCAD LT Interface
Chapter 2: Creating Your First Drawing

Chapter 3: Setting Up and Using AutoCAD’s Drafting Tools
Chapter 4: Organizing Objects with Blocks and Groups
Chapter 5: Keeping Track of Layers, Blocks, and Files




%I% é 3738x.book Page 2 Monday, June 25,2007 11:37 PM

+/@



%I% é 3738x.book Page 3 Monday, June 25,2007 11:37 PM

Chapter 1

Exploring the AutoCAD and
AutoCAD LT Interface

Before you can start to use AutoCAD 2008’s new capabilities, you'll need to become familiar with the
basics. If you're completely new to AutoCAD, you'll want to read this first chapter carefully. It intro-
duces you to many of AutoCAD’s basic operations, such as opening and closing files, getting a close-up
look at part of a drawing, and changing a drawing. If you're familiar with earlier versions of AutoCAD,
you should review this chapter anyway to get acquainted with features you haven't already used.

Autodesk has recently changed its AutoCAD update strategy to release new versions every year.
Part of this strategy is to introduce new items that focus on a particular category of features. This latest
version, AutoCAD 2008, includes several new features focused on 2D drafting. AutoCAD now sports
anew tool panel called a dashboard which includes the most common tools needed to produce tech-
nical drawings of all types. The ability to setup the scale of drawings has been improved and there are
more learning resources at your fingertips.

You'll get a chance to explore these new features in Part 4 as you work through this book; but
for now, let’s get started with some basics.

Topics in this chapter:

Using the AutoCAD Window
Opening an Existing File
Getting a Closer Look with the Zoom Command

Saving a File as You Work

* 6 & o o

Making Changes and Opening Multiple Files

TIP Inthis chapter, and throughout the rest of the book, when 1say AutoCAD, I mean both AutoCAD
and AutoCAD LT. Some topics apply only to AutoCAD. In those situations, you’ll see an icon indi-
cating that the topic applies only to AutoCAD and doesn’t apply to AutoCAD LT. If you’re using
AutoCAD 2008 LT, these icons can help you focus on the topics that are more relevant to your work.

Taking a Guided Tour

In this section, you'll get a chance to familiarize yourself with the AutoCAD screen and how you
communicate with AutoCAD. As you do the exercises in this chapter, you'll also get a feel for how
to work with this book. Don’t worry about understanding or remembering everything you see in
this chapter. You'll get plenty of opportunities to probe the finer details of the program as you work
through the later chapters. To help you remember the material, you'll find a brief exercise at the end
of each chapter. For now, just enjoy your first excursion into AutoCAD.
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NOTE AutoCAD 2008 is designed to run on Windows 2000, Windows XP and Windows Vista.
This book was written using AutoCAD 2008 on Windows XP Professional with a Windows Classic
desktop theme.

If you already installed AutoCAD and are ready to jump in and take a look, proceed with the
following steps to launch the program:

1. Choose Start » All Programs > Autodesk » AutoCAD 2008 > AutoCAD 2008. You can also
double-click the AutoCAD 2008 icon on your Windows Desktop. LT users will use
AutoCAD LT 2008 in place of AutoCAD 2008.

2. The opening greeting, called a splash screen, tells you which version of AutoCAD you're
using, to whom the program is registered, and the AutoCAD dealer’s name and phone num-
ber, should you need help. If this is the first time you've started AutoCAD after installing it,
you'll also see a dialog box asking you to register the product.

3. After the splash screen closes, you see the Workspace screen. (You won't see this in LT.) This
screen allows you to select between the 2D drawing workspace called 2D Drafting & Annota-
tion and the 3D workspace called 3D Modeling. A third option called AutoCAD Classic offers
the 2D drawing workspace from earlier versions of AutoCAD. Workspaces are saved arrange-
ments of the AutoCAD window. You'll explore the 3D Modeling workspace in Part 4.

4. Youmay also see the New Features Workshop screen, which offers a set of tutorials showing
you the new features of AutoCAD 2008. Click the No, Don’t Show Me This Again or Maybe
Later radio button, and click OK. You can always get to the New Features Workshop screen
from the AutoCAD help menu by choosing Help > New Features Workshop.

5. The AutoCAD window displays a blank default document named Drawingl. dwg, as shown in
Figure 1.1. AutoCAD users may see the Sheet Set Manager palette to the left of the AutoCAD
window, which doesn’t appear in Figure 1.1, to show more of the drawing area. LT users may
see the Info palette to the left of the AutoCAD window.
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If this is the first time you’ve started AutoCAD since you installed it, you're asked to register
and authorize AutoCAD in step 2. If you're using the Trial version, you can use the default serial
number 000-00000000 for the one-month trial. After you’ve entered the registration information,
you see the New Features Workshop window described in step 4.

Let’s look at the AutoCAD window in detail. Don’t worry if it seems like a lot of information.
You don’t have to memorize it, but by looking at all the parts, you'll be aware of what is available

in a general way.

IF YOUR AUTOCAD WINDOW DOESN’T LOOK LIKE FIGURE 1.1

Asyou sawin step 3 in the opening exercise, you have a choice between three workspaces when you start
AutoCAD. If you didn’t see the Workspace screen, and your drawing opens to a 3D Modeling workspace
(see Figure 1.2, later in this chapter), do the following to get to the 2D Drafting & Annotation workspace:

1. Clickthe Workspaces list in the upper-left corner of the AutoCAD window, and select 2D Drafting &
Annotation. LT users can select 2D Drafting & Annotation from the floating Workspaces toolbar.

Bl AutoCAD 2008 - [Drawing2.dveg]
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2. AutoCAD users, choose File » New. Then, in the Select Template dialog box, choose acad.dwt and
click Open. LT users can skip this step.
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If you did step 2, the default filename is Drawing2 . dwg instead of Drawingl.dwg. Aside from
that, your AutoCAD window will look similar to Figure 1.1, which shows AutoCAD in a moderate

resolution screen.
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The AutoCAD Window
The AutoCAD program window is divided into six parts:

¢ Menu bar
Toolbars
Drawing area

Command window

* 6 o o

Status bar
Dashboard

Figure 1.1, shown earlier in this chapter, shows a typical layout of the AutoCAD program win-
dow. Along the top is the menu bar, and just below that are the Workspaces and Standard Annotation
toolbars. At the bottom are the Command window and the status bar. To the right is the Dashboard. The
drawing area occupies the rest of the screen. AutoCAD calls the window layout a workspace; you can
save and recall a workspace at any time using the Workspaces toolbar. The workspace in Figure 1.1
is called the 2D Drafting & Annotation workspace.

TIP  Your screen may show the drawing area in black. You can set the drawing area background
color by using the Options dialog box. Appendix A describes how to do this. The figures in this
book show the drawing area background in white for clarity.

Figure 1.2 shows AutoCAD’s 3D Modeling workspace, which has a different set of screen elements.
Figure 1.2 also shows a standard AutoCAD drawing file with a few setting changes to give ita 3D
appearance. Beneath these external changes, the underlying program is the same.

TIP Youw’ll learn more about workspaces later in this chapter and in Chapter 26.
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The menu bar at the top of the drawing area (as shown in Figure 1.3) includes drop-down menus
from which you select commands in a typical Windows fashion. The toolbars and Dashboard pro-
vide a variety of commands through tool buttons and drop-down lists.

::S::ntgar’ the Workspaces toolbar  Standard Annotation toolbar Communication Center
Workspaces toolbar, 2 ‘ : e
and the Standard e Pt g I g aeu's sole— mupgama o
Annotation toolbar. ar E ]
LT users may see a = e
floating Workspaces L T
toolbar instead of the |
docked version shown Dashboard
at far right. (not shown)

The drawing area occupies most of the screen. Everything you draw appears in this area. As you
move your mouse around, crosshairs appear to move within the drawing area. This is the drawing
cursor that lets you point to locations in the drawing area.

At the bottom of the drawing area is a set of tabs. These tabs give you access to the Layout views
of your drawing. These views let you lay out your drawing as in a desktop publishing program.
You'll learn about the Layout tabs in Chapter 8. The arrows to the left of the tabs let you navigate
the tabs when there are more tabs than can fit in the AutoCAD window.

TURNING ON THE TABS

If you don’t see the tabs, don’t worry. AutoCAD can be set up to hide the tabs, but you can easily restore them
to view. To turn them on, locate the Model tool in the status bar at the bottom of the AutoCAD window.

&P [oTRack [oucs [ove L R L 4|

Right-click the Model tool, and then select Display Layout and Model Tabs. The tabs will appear just
below the drawing area. To hide the tabs, right-click any tab, and select Hide Layout and Model Tabs.

The Command window, located just below the Layout tabs, gives you feedback about AutoCAD’s
commands as you use them. You can move and resize this window just as you move and resize tool-
bars. By default, the Command window is in its docked position, as shown in Figure 1.4.
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Below the Command window is the status bar (see Figure 1.4). The status bar gives you infor-
mation at a glance about the state of the drawing. For example, the coordinate readout toward the
far left of the status bar tells you the location of your cursor.

PICKING POINTS IN THE DRAWING AREA

Now that you've seen the general layout of AutoCAD, try using the coordinate readout and the
drawing cursor to get a sense of how the parts of the AutoCAD screen work together:

1. Move the cursor around in the drawing area. As you move it, notice how the coordinate read-
out changes to tell you the cursor’s location. It shows the coordinates in an X, Y, Z format.

2. Place the cursor in the middle of the drawing area, and click the left mouse button. Move the
cursor, and a rectangle follows. This is a window selection; you’ll learn more about this win-
dow in Chapter 2. You also see a coordinate readout following the cursor and a message ask-
ing youto Specify opposite corner:.This display at the cursor is called the dynamic input.
You'll learn more about it a little later in this chapter.

TIP 1f you don’t see the dynamic input display, click the button labeled DYN in the status bar to
turn it on.

3. Move the cursor a bit in any direction; then, click the left mouse button again. Notice that the
window selection disappears, as does the dynamic input display.

4. Try picking several more points in the drawing area. Notice that as you click the mouse, you
alternately start and end a window selection.

If you happen to click the right mouse button, a shortcut menu appears. A right-click frequently
opens a menu containing options that are context sensitive. This means the contents of the shortcut
menu depend on the location where you right-click as well as the command that is active at the time
of your right-click. If there are no appropriate options at the time of the right-click, AutoCAD treats
the right-click as an .I. You’ll learn more about these options as you progress through the book. For
now, if you happen to open this menu by accident, press the Esc key to close it.

THE UCS ICON

In the lower-left corner of the drawing area, you see an L-shaped arrow. This is the User Coordinate
System (UCS) icon, which tells you your orientation in the drawing. This icon becomes helpful as
you start to work with complex 2D drawings and 3D models. The X and Y arrows indicate the X and
Y axes of your drawing. The little square at the base of the arrows tells you that you're in what is
called the World Coordinate System. Chapter 21 discusses this icon in detail. For now, you can use it
as a reference to tell you the direction of the axes.

+/@
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IF YOU CAN’T FIND THE UCS ICON

The UCS icon can be turned on and off, so if you’re on someone else’s system and you don’t see the
icon, don’t panic. If you don’t see the icon or it doesn’t look as it does in this chapter, see Chapter 21
for more information.

THE COMMAND WINDOW

At the bottom of the screen, just above the status bar, is a small horizontal window called the Com-
mand window. Here, AutoCAD displays responses to your input. By default, it shows two lines of text.
The bottom line shows the current messages, and the top line shows messages that have scrolled by
or, in some cases, components of the current message that don't fit in a single line. Right now, the bot-
tom line displays the message Command (see Figure 1.4, earlier in this chapter). This prompt tells you
that AutoCAD is waiting for your instructions. When you click a point in the drawing area, you see
the message Specify opposite corner:. Atthe same time, the cursor starts to draw a window selec-
tion that disappears when you click another point. The same message appears in the dynamic input
display at the cursor.

As a new user, pay special attention to messages displayed in the Command window and the
dynamic input display because this is how AutoCAD communicates with you. Besides giving you
messages, the Command window records your activity in AutoCAD. You can use the scroll bar to
the right of the Command window to review previous messages. You can also enlarge the window
for a better view. (Chapter 2 discusses these components in more detail.)

Now, let’s look at AutoCAD’s window components in detail.

TIP The Command window and the dynamic input display allow AutoCAD to provide text feed-
back to your actions. You can think of these features as a chat window to AutoCAD—as you enter
commands, AutoCAD responds with messages. As you become more familiar with AutoCAD, you
may find you don’t need to rely on the Command window and dynamic input display as much.
For new and casual users, however, the Command window and dynamic input display can be
helpful in understanding what steps to take as you work.

The Drop-Down Menus

As in most Windows programs, the drop-down menus on the menu bar provide an easy-to-understand
way to access AutoCAD's general controls and settings. In these menus, you'll find the commands and
functions that are the heart of AutoCAD. By clicking menu items, you can cut and paste items to and
from AutoCAD, change the settings that make AutoCAD work the way you want it to, set up the mea-
surement system you want to use, access the help system, and much more.

The drop-down menu options perform three basic functions:

¢ Display a dialog box that contains settings you can change.
¢ Issue a command to create or modify your drawing.
¢ Offer an expanded set of the same tools found in the Draw and Modify toolbars.

As you point to commands and options in the menus, AutoCAD provides additional help for
you in the form of brief descriptions of each menu option, which appear in the status bar.

- @
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Here’s an exercise to let you practice with the drop-down menus and get acquainted with the
way you issue AutoCAD commands:

1. Click View in the menu bar. The list of items that appears includes the commands and set-
tings that let you control the way AutoCAD displays your drawings. Don’t worry if you
don’t understand them yet; you'll get to know them in later chapters.

[EljautoCAD 2008 - [Drawingl.dwg]
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WARNING LT users won’t see the Render option in the View menu.

2. Move the highlight cursor slowly down the list of menu items. As you highlight each item,
notice that a description of it appears in the status bar at the bottom of the AutoCAD win-
dow. These descriptions help you choose the menu option you need.

TIP I1fyoulook carefully at the command descriptions in the status bar, you’ll see an odd word at the
end. This is the keyboard command equivalent to the highlighted option in the menu or toolbar.
You can type these keyboard commands to start the tool or menu item that you’re pointing to. You
don’t have to memorize these command names, but knowing them will be helpful to you later if
you want to customize AutoCAD.

3. Some of the menu items have triangular pointers to their right. This means the command has
additional choices. For instance, highlight the Zoom item, and another set of options appears
to the right. This second set of options is called a cascading menu. Whenever you see a drop-
down menu item with the triangular pointer, you know that this item opens a cascading
menu offering a more detailed set of options.

4. Other drop-down menu options are followed by an ellipsis (...). This indicates that the
option displays a dialog box. For instance, move the highlight cursor to the Tools option in
the menu bar.

TIP 1f you prefer, you can click and drag the highlight cursor over the drop-down menu to select
an option.
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5. Click the Draw option from the menu bar, and then click the Rectangle command. Notice
that the Command window now shows the following prompt:

Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:

AutoCAD is asking you to select the first corner for the rectangle, and, in brackets, it’s offer-
ing a few options that you can take advantage of at this point in the command. Don’t worry
about those options right now. You'll have an opportunity to learn about command options
in Chapter 2. You also see the same prompt, minus the bracketed options, in the dynamic
input display at the cursor.

6. Click a point roughly in the lower-left corner of the drawing area, as shown in Figure 1.5.
Now, as you move your mouse, a rectangle follows the cursor, with one corner fixed at the
position you just selected. You also see the following prompt in the Command window,
with a similar prompt in the dynamic input display:

Specify other corner point or [Area/Dimensions/Rotation]:
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7. Click another point anywhere in the upper-right region of the drawing area. A rectangle
appears (see Figure 1.6). You'll learn more about the different cursor shapes and what they

mean in Chapter 2.

At this point, you’'ve seen how most of AutoCAD’s commands work. Many drawing and editing
functions display messages in the Command window. These messages are also displayed in the
dynamic input display. You'll find that dialog boxes are displayed when you want to change set-
tings. Also, be aware that many of the drop-down menu items are duplicated in the toolbars, which
you'll explore next.
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COMMUNICATING WITH THE COMMAND WINDOW AND DYNAMIC INPUT DISPLAY

AutoCAD is the perfect servant: It does everything you tell it to, and no more. You communicate
with AutoCAD by using the drop-down menus and the toolbars. These devices invoke AutoCAD
commands. A command is a single-word instruction you give to AutoCAD, telling it to do some-
thing, such as draw a line (the Line tool in the Draw toolbar) or erase an object (the Erase tool in the
Modify toolbar). Whenever you invoke a command, by either typing it or selecting a menu or tool-
bar item, AutoCAD responds by presenting messages to you in the Command window and the
dynamic input display or by displaying a dialog box.

The messages in the Command window often tell you what to do next, or they display a list of options,
usually shown in square brackets. A single command often presents a series of messages, which you
answer to complete the command. These messages serve as an aid to new users who need a little help.
If you ever get lost while using a command or forget what you’re supposed to do, look at the Command
window for clues. As you become more comfortable with AutoCAD, you’ll find that you won’t need to
refer to these messages as frequently.

As an additional aid, you can right-click to display a context-sensitive shortcut menu. If you’re in the
middle of a command, this menu displays a list of options specifically related to that command. For
example, if you right-click your mouse before picking the first point for the rectangle command in the
previous exercise, a menu opens, displaying the same options that are listed in the Command prompt
plus some additional options.

Finally, the dynamic input display allows you to enter dimensional data of objects as you draw them.
Besides echoing the command-line messages, the dynamic input display shows the coordinates and
angles of objects you’re drawing and editing. As you enter coordinate or angle values through the key-
board, they appear in the dynamic input display. If you’re used to earlier versions of AutoCAD, you can
easily turn off the dynamic input display by clicking the DYN button in the status bar. When the
dynamic input display is turned off, your keyboard input appears in the Command window.
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The Dashboard
The menu bar provides most of the commands you need in a format that most Windows users will
find easy to understand, and many users are more comfortable using the menu bar. If you prefer
using toolbars with their graphic icons, you can start to use the Dashboard. The Dashboard offers
many of the same commands as the menu bar but in a more compact format that is quicker to access.
The Dashboard is a collection of lists, buttons, and tools that invoke commands. These tools are
grouped into eight control panels, each with an icon that shows its function (see Figure 1.7). In typical
Windows fashion, each tool offers a ToolTip that provides a short description, which helps you under-
stand what the icons represent.

FIGURE 1.7 ol xl
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NOTE If the Dashboard doesn’t appear on the screen, you can choose Tools > Palettes > Dash-
board to restore it to the window.

If you move the arrow cursor onto one of the control-panel tools and leave it there for a moment,
you'll see a ToolTip appear just below the cursor. As a new user, you'll find these ToolTips helpful
because they show you the name of the tool. In addition, when I ask you to select a tool, I'll use the name
shown in the ToolTip. For example, if you hover over the icon in the upper-left corner of the Dashboard,
you'll see a ToolTip appear with the name of the control panel, 2D Draw.
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Take a moment to examine the top portion of the Dashboard where the 2D Draw control panel
resides. You'll be instructed to use the tools in this control panel frequently throughout the early
part of this book, so it will be helpful for you to get a feel for their arrangement and what they con-
tain. You'll get a closer look at the Dashboard and control panels in Chapter 2.

In addition to the visible tools, a few tools are hidden from view. You can expand the list of tools to
select more tools. Click and hold the downward-pointing arrow to the far right of the row of tools (see
Figure 1.8). The set of tools expands into a fly-out toolbar. While continuing to hold down the mouse
button, you can point to the tool you want in the fly-out toolbar and then release the mouse.

FIGURE 1.8
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In most cases, you'll be able to guess what each tool does by looking at its icon. The icon with an
arc in the 2D Draw control panel, for instance, indicates that the tool draws arcs; the one with the
circle shows that the tool draws circles; and so on. For further clarification, the ToolTip gives you
the name of the tool.

The Toolbars

The menu bar and Dashboard offer the most frequently used tools, but you'll eventually find that
you need to use a set of tools geared toward a specific task. AutoCAD offers a number of toolbars
that contain tools for specific types of drawing functions. For example, the View toolbar offers a set
of tools that quickly give you a 3D view. The Inquiry toolbar contains tools that display information
about your drawing.

AutoCAD displays the Workspaces and Standard Annotation toolbars in its default 2D Drafting
& Annotation workspace. As you work though this book, occasionally you'll be asked to open other
toolbars. To get familiar with the process, try opening a one now.

1. Right-click the Workspaces or Standard Annotation toolbar. A shortcut menu of toolbars
appears, displaying a long list of toolbars, as shown in Figure 1.9.

2. Locate and select View in the shortcut menu (see Figure 1.9). The View toolbar appears.
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3. Youwon't need the View toolbar right now, so go ahead and close it by clicking the X in the
upper-right corner of the toolbar.

You may have noticed that the shortcut menu displays a check mark next to the name of a tool-
bar that is currently open (see Figure 1.9). You can click a checked toolbar name to close the tool-
bar. AutoCAD remembers your toolbar arrangement between sessions. When you exit and then
reopen AutoCAD later, the AutoCAD window appears just as you left it.

NOTE Ifyour drawing becomes too cluttered with toolbars, you can drag a toolbar to the border of
the AutoCAD window, and it will automatically merge with the border. This is called its docked posi-
tion. If you don’t want the toolbar to dock but instead want it to appear floating near the border of
the AutoCAD window, you can do the following: First, change the shape of the toolbar to conform
to the orientation of the border. Do this by clicking and dragging the toolbar’s border. Next, press
and hold the Ctrl key as you click and drag the toolbar into position near the border. This prevents
the toolbar from automatically falling into a docked position.

MENUS VERSUS THE KEYBOARD

Throughout this book, you’ll be told to select commands and command options from the drop-down
menus and toolbars. For new and experienced users alike, menus and toolbars offer an easy-to-remember
method for accessing commands. If you’re an experienced AutoCAD user who is used to the earlier ver-
sions of AutoCAD, you can type commands directly from the keyboard. Most of the keyboard commands
you know and love still work as they did.

Another method for accessing commands is to use accelerator keys, which are special keystrokes that open
and activate drop-down menu options. You may have noticed that the commands in the menu bar and the
items in the drop-down menus all have an underlined character. By pressing the Alt key followed by the key
corresponding to the underlined character, you activate that command or option without having to engage
the mouse. For example, to choose File > Open, press Alt, then F, and then finally O (Alt+F+O).

- @



%% é 3738x.book Page 16 Monday, June 25,2007 11:37 PM

16 | CHAPTER 1 EXPLORING THE AUTOCAD AND AUTOCAD LT INTERFACE

Many tools and commands have keyboard shortcuts; shortcuts are one-, two-, or three-letter abbrevia-
tions of a command name. As you become more proficient with AutoCAD, you may find these shortcuts
helpful. As you work through this book, the shortcuts will be identified for your reference.

Finally, if you’re feeling adventurous, you can create your own accelerator keys and keyboard short-
cuts for executing commands by adding them to the AutoCAD support files. Chapter 25 discusses how
to customize menus, toolbars, and keyboard shortcuts.

SAVING YOUR PREFERRED WORKSPACE

You may find that you prefer a specific arrangement of toolbars that you’d like to be able to recall
at will. You can rearrange the toolbars and then save the arrangement as a named workspace. Doing
so can be useful if you must share your AutoCAD workstation with someone else who prefers their
own AutoCAD window layout or if you want to set up different arrangements for different types
of work. For example, you might want to save the current AutoCAD window layout with the Tool
palettes out of the way, while someone else prefers the default AutoCAD setup. To save the current
setup under a new name, do the following:

1. In the Workspaces toolbar, click in the drop-down list, and select Save Current As to open
the Save Workspace dialog box.

%
ame: ' j Save
Cancsl I

2. Enter My Custom Layout in the text box, and click Save. The current arrangement of
AutoCAD components is saved under the name My Custom Layout.

3. Torecallaworkspace, select the name of the saved workspace from the drop-down listin the
Workspaces toolbar.

You may have noticed a house icon in the Workspaces toolbar. This is the My Workspace tool,
which offers a quick way to restore your favorite workspace. You can customize the My Workspace
tool to recall any AutoCAD window layout you like. You’ll learn more about creating and custom-
izing workspaces in Chapter 26.

Working with AutoCAD

Now that you've been introduced to the AutoCAD window, you're ready to try using a few
AutoCAD commands. First, you'll open a sample file and make a few modifications to it. In the
process, you'll become familiar with some common methods of operation in AutoCAD.

Opening an Existing File
In this exercise, you'll get a chance to see and use a typical Select File dialog box. To start, you'll
open an existing file:

1. From the menu bar, choose File > Close. A message appears, asking whether you want to
save the changes you’'ve made to the current drawing. Click No.

%
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2. Choose File > Open to open the Select File dialog box. This is a typical Windows file dialog box,
with an added twist: The large Preview box on the right lets you preview a drawing before you
open it, thereby saving time while searching for files. To the left is a panel known as the Places
List in which you can find frequently used locations on your computer or the Internet.

[Bllselect File 2ix|
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My Documents
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™ Sglect Iniial View
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Files o pyoe:[Draniog ["dwg] =] Ceed |

TIP 1fyoudon’tseeaPreview box in the Select File dialog box, click the word Views in the upper-
right corner, and then select Preview from the list that appears.

3. In the Select File dialog box, open the Look In drop-down list, and locate the 2008acad2008\
samplefiles\Mastering AutoCAD 2008\Projects\Chapters 01 folder. (You may need
to explore the list to find it.) The file list changes to show the contents of the \AutoCAD 2008\
Projects\Chapter 01 folder.

4. Move the arrow cursor to the cTip.dwg file, and click it. Notice that the c1ip.dwg filename
now appears in the File Name input box above the file list. Also, the Preview box now shows
a thumbnail image of the file. Be aware that files from older versions of AutoCAD may not
show a thumbnail.

TIP The cTlip.dwg drawing is included on the companion website. If you can’t find this file, be
sure you installed the sample drawings from the companion website. See the Readme file on the
book’s website for installation instructions.

5. Click the Open button at the bottom of the Select File dialog box. AutoCAD opens the
cTip.dwg file, as shown in Figure 1.10.

The cTip. dwg file opens to display a Layout tab view of the drawing. You'll know this by looking
at the tabs at the bottom of the AutoCAD window. Currently, the Layout1 tab is highlighted.

|l:_§ |L ________
I((DDI\M}M&U
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FIGURE 1.10
The Layout1 view of
the c1ip.dwg file

k C:Mastering AutoCAD 2008%Projects',Chapter 01 clip.dwg

You may recall that a layout is a type of view that lets you lay out different views of your drawing
in preparation for printing. Also notice that the AutoCAD windows title bar displays the name of the
drawing. This offers easy identification of the file.

This particular file contains both 2D drawings and a 3D model of a typical locking clip. The
Layout] tab view shows a top, front, and right-side view as well as an isometric view.

Getting a Closer Look

One of the most frequently used commands is Zoom, which gives you a closer look at part of your
drawing. This command offers a variety of ways to control your view. In this section, you'll enlarge
a portion of the clip drawing to get a more detailed look. To tell AutoCAD which area you want to
enlarge, you use what is called a zoom window.

You'll start by switching to a Model Space view of the drawing. The Model tab places you in a
workspace where you do most of your drawing creation and editing. Follow these steps:

1. Click the Model tab at the bottom of the AutoCAD window.
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Your view changes to show the full 3D model with the 2D representations of the model.

i £\ Mastering AutoCAD 2008 Projects’Chapter D1 clip.dwg

14] 4]k W} Model { Leyout] f

2. Choose View » 3D Views » Plan View » World UCS. You can also type PLANJW... Your
display changes to a two-dimensional view looking down on the drawing, as shown in the
top image of Figure 1.11.

@ Click the Zoom Window button on the Standard toolbar.

You can also choose View » Zoom » Window from the drop-down menu or type the
command ZJW..

3. The Command window and the dynamic input display show the Specify first corner:
prompt. Look at the top image in Figure 1.11. Move the crosshair cursor to a location similar
to the one shown in the figure; then, left-click the mouse. Move the cursor, and the rectangle
appears with one corner fixed on the point you just picked; the other corner follows the cursor.

4. The Command window and dynamic input display now show the Specify first corner:
and Specify opposite corner: prompts. Position the other corner of the zoom window so
it encloses the lower image of the clip, as shown in the top image in Figure 1.11, and left-click
the mouse again. The clip enlarges to fill the screen (see the bottom image in Figure 1.11).

In this exercise, you used the Window option of the Zoom command to define an area to enlarge
for your close-up view. You saw how AutoCAD prompts you to indicate first one corner of the win-
dow selection and then the other. These messages are helpful for first-time users of AutoCAD. You'll
use the Window option frequently—not just to define views, but also to select objects for editing.

- @
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FIGURE 1.11
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Getting a close-up view of your drawing is crucial to working accurately, but you'll often want
to return to a previous view to get the overall picture. To do so, choose View » Zoom > Previous

from the menu bar.
Do this now, and the previous view—the one showing the entire clip—returns to the screen.
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You can quickly enlarge or reduce your view by clicking the Zoom Realtime button in the 2D
Navigate control panel. Follow these steps to change your view with the Zoom Realtime button:

1.

3. While still holding the left mouse button, move the cursor upward. Your view zooms in to
enlarge your view. When you have a view similar to the one shown in Figure 1.12, release
the mouse button. (Don’t worry if you don’t get exactly the same view as the figure. This is
just for practice.)

4. You're still in Zoom Realtime mode. Click and drag the mouse again to see how you can
further adjust your view. To exit, you can select another command besides a Zoom or Pan,
press the Esc key, or right-click your mouse and choose Exit from the shortcut menu.

5. Right-click now, and choose Exit from the shortcut menu to exit the Zoom Realtime command.

FIGURE 1.12
. . f& C:\Mastering AutoCAD 2008 Projects’Chapter D1\ clip.dvg
The final view you

want to achieve in
step 3 of the exercise

Click the Zoom Realtime button on the 2D Navigate control panel of the Dashboard.
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You can also right-click and choose Zoom from the shortcut menu. The cursor changes to a
magnifying glass.

. Place the Zoom Realtime cursor slightly above the center of the drawing area, and then click

and drag downward. Your view zooms out to show more of the drawing.
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As you can see from this exercise, you have a wide range of options for viewing your drawings,
just by using a few buttons. These buttons are all you need to control the display of 2D drawings.

Saving a File as You Work

It's a good idea to save your file periodically as you work on it. As with any Windows program, you
can save it under its original name (choose File > Save) or under a different name (choose File >
Save As), thereby creating a new file.

By default, AutoCAD automatically saves your work at 10-minute intervals under a name that
is a combination of the current filename plus a number and that ends with the . sv$ filename exten-
sion; this is known as the Automatic Save feature. Using settings in the Options dialog box or system
variables, you can change the name of the autosaved file and control the time between autosaves.
See Chapter 3 for details.

TIP Bydefault,in Windows XP, the Automatic Save file is stored inC: \Documents and Settings\
User Name\Local Settings\Temp\.You can find the exact location for your system by typing
Savefilepathg at the Command prompt. This file location is often set as a hidden folder, so you may
need to set up Windows Explorer to display hidden folders before you can get to the Automatic Save
file. See Appendix A for information on how to do this.

Making Changes

You'll frequently make changes to your drawings. One of AutoCAD’s primary advantages is the
ease with which you can make changes. The following exercise shows you a typical sequence of
operations involved in changing a drawing;:

1. Use the File > Save As menu option to save the current C11ip.dwg file under the name
MyF1irst. For convenience, you can save your files in the My Documents folder.

2. From the 2D Draw control panel, click the Erase tool (the one with a pencil eraser touching
paper). This activates the Erase command. You can also choose Modify > Erase from the
drop-down menu.

Notice that the cursor has turned into a small square; this square is called the pickbox. You
also see Select objects: in the Command window and the dynamic input display. This
message helps remind new users what to do.

3. Move the pickbox over the drawing, placing it on various parts of the clip. Don’t click anything
yet. Notice that as you hover over objects with the pickbox, they're highlighted. This helps you
see the objects the pickbox is likely to select, should you click the left mouse button.

4. Place the pickbox on the crosshatch pattern of the clip (see Figure 1.13), and click. The cross-
hatch changes in appearance from a dark highlight to a light highlight. The pickbox and the
Select objects: prompt remain, indicating that you can continue to select objects.

5. Press . The crosshatch disappears. You've just erased a part of the drawing.

In this exercise, you first issued the Erase command, and then you selected an object by using a
pickbox to click it. The pickbox tells you that you must select items on the screen, and it shows you
what you're about to select by highlighting objects as you hover over them. Once you've clicked an
object or a set of objects, press . to move on to the next step. This sequence of steps is common to
many of the commands you’ll work with in AutoCAD.

TIP You canalso click an object or a set of objects and then press the Delete key without using the
Erase tool.
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FIGURE 1.13
Erasing a portion
of the clip
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Click here.

Opening Multiple Files

You can have multiple documents open at the same time in AutoCAD. This can be especially help-
ful if you want to exchange parts of drawings between files or if you want another file open for
reference. Try the following exercise to see how multiple documents work in AutoCAD:

1. Choose File » New to open the Select Template dialog box.

NOTE Ifyou see the Create New Drawing dialog box after step 1, click the Start from Scratch but-
ton and select Imperial; then, click OK, and AutoCAD will display a default document. You’ll
learn more about the Create New Drawing dialog box in Chapter 2.

2. Make sure acad. dwt is selected, and then click Open.

3. Choose Window > Tile Vertically to get a view of both drawing files. The options in the
Window drop-down menu act just like their counterparts in other Windows programs that
allow multiple-document editing.

TIP When you create a new file in AutoCAD, you’re actually opening a copy of a template file, as
you saw in step 1. A template file is a blank file that is set up for specific drawing types. The
acad. dwt file is a generic template set up for Imperial measurements. Another template file
called acadiso.dwt is a generic template useful for metric measurements. Other templates are
set up for specific drawing-sheet sizes and measurement systems. You’ll learn more about tem-
plates in Chapter 6.
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4. Let’s see what can be done with these two files. Click in the window with the clip drawing
to make it active.

5. Choose View » Zoom > All to get an overall view of the drawing.

6. Click the 2D version of the clip at the bottom of the drawing to select it. A series of squares
and arrows appears on the drawing. These are called grips, and you’ll learn more about them
in the next chapter.

7. Click and hold the mouse button on the selected object, but avoid clicking any of the blue
squares. Also avoid dragging the object. You'll see a small rectangle appear next to the cursor.

i Orawingzdwg B [=1E3 ]| & c:\Mastering AutoCAD 2008\ Projects) Chapter oy [=] 3}
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8. While still holding the left mouse button, drag the cursor to the new file window. When you
see the clip appear in the new drawing window, release the mouse button. You've just copied
part of a drawing from one file to another.

9. This ends the exercises for this chapter. Save the file and then exit AutoCAD.

NOTE You can also use the standard Windows Copy and Paste options (Edit > Copy and Edit >
Paste from the menu bar) to copy objects from one window to the other.

Now you’ve had two files open at once. You can have as many files open as you want, as long
as your computer has adequate memory to accommodate them. You can control the individual
document windows as you would any window, using the Window drop-down menu or the win-
dow control buttons in the upper-right corner of the document window.

Adding a Predrawn Symbol with the Tool Palette

In the preceding exercise, you saw how you can easily copy an object from one file to another by
using a click-and-drag method. AutoCAD offers a Tool Palettes window that lets you click and
drag predrawn objects into your drawing.

- @
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You can open the Tool Palettes window by clicking the Tool Palettes Window tool in the Stan-
dard Annotation toolbar. Once it’s open, you can select a tab containing the predrawn objects you
want to use and then click the specific object you want to add. The object appears at the cursor,
ready for you to select a location.

Maetric samplas
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In addition to predrawn objects, the Tool palettes offer a way to quickly add fill patterns and
other components to your drawing. They’re great tools to help you manage your library of custom,
predrawn symbols. Chapter 25 shows you how to use and customize the Tool palettes.

The Bottom Line

Using the AutoCAD Window AutoCAD is a typical Windows graphics program that makes
use of menus, toolbars, and palettes. If you've used other graphics programs, you'll see at least
a few familiar tools.

Master It Name the components of the AutoCAD window that let you select a function.

Solution AutoCAD offers the menu bar, toolbars, and the Dashboard to give you access to
the most common functions.

Getting a Closer Look with the Zoom Command One of the first things you'll want to learn
is how to manipulate your views. The Zoom command is a common tool in graphics programs.

Master It Name two ways of zooming into a view.

Solution Choose View > Zoom » Window, and then click two points to define a zoom
window. Another option is to use the Realtime tool in the 2D Navigate control panel.

Saving a File as You Work Nothing is more frustrating than having a power failure cause a
loss of hours of work. It’s a good idea to save your work frequently. AutoCAD offers an
autosave feature that can be a lifesaver if you happen to forget to save your files.

Master It How often does the AutoCAD autosave feature save your drawing?

Solution Autosave saves a copy of a drawing every 10 minutes by default. This interval
can be set by the user.

Making Changes and Opening Multiple Files As with other Windows programs, you can
have multiple files open and exchange data between them.

Master It With two drawings open, how can you copy parts of one drawing into the other?

Solution Select the parts you want to copy, and click and hold on any selected part. When
you see a small rectangle appear below the cursor, drag the parts into the other drawing.
Alternately, you can use the standard Windows Copy and Paste functions.
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