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Page title - and subtitle

Loram ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euismod tincidunt ut lacreet dolore magna aliquam erat
volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat. Duis
autem val aum iriure dolor in hendrerit in vulputate velit esse molestia
consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et lusto odio dignissim gul blandit praesent luptatum zzril
delenit augue duis dolore te faugait nulla facilisi.

Heading goes here
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam

nonummy nibh euvismod tincidunt ut laoreet dolore magna aliguam erat
volutpat.

Loram ipsum dolor sit amat, consectatuar adipiecing alit, sed diam
nonummy nibh euismod tincidunt ut lacreet dolore magna aliquam erat
wvolutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamecorper suscipit lobortis nisl ut aliquip ax ea commodo consequat. Duis
aubtem val eum iriure dolor in hendrerit in vulputate velit esse molestie
consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et lusto odio dignissim qui blandit praesent luptatum zzril
delanit augua duls dolore ta faugait nulla facilisi.

Heading goes here

Loarem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euvismod tincidunt ut lacreet dolore magna aliguam erat
volutpat.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euismod tincidunt ut lasreat delore magna aliguam arat
volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamcorper suscipit lobortis nisl ut aliguip ex ea commodo consequat. Duis
autem val aum irtura dolor in hendrerit in vulputate velit asse molastia
consaquat, val illum delore au feugiat nulla facilisis at vero aros at
accumsan et iusto odio dignissim qui blandit praesent luptatum zzril
delenit augue duis dolore te feugait nulla facilisi.



PHOTOSHOP 10
DREAMWEAVER

For the longest time, Web designers lived in a schizophrenic world. On one side, Adobe Photoshop ruled the artists’
roost with the most powerful graphics program available. On another side, Macromedia Dreamweaver was the Web pro-
fessional’s choice for clean code output and feature-rich visual layout. Not only did these two programs not work togeth-
er easily, but their parent companies actively competed against each other with rival products. While some designers
kept to one company or the other, there was a constant drumbeat from those who craved the best of both worlds.

With the release of Adobe Creative Suite 3 Web, the disparate worlds of Photoshop and Dreamweaver were united.
For the first time, Photoshop and Dreamweaver were available in one package—and, best of all, engineered to work to-
gether. Web designers everywhere can now benefit from the enhanced workflow and smoothly move from comp to Weh
page or from Web layout to graphics editor and back again.

There are two major pathways between Photoshop and Dreamweaver. First graphics saved in Photoshop’s native
file format, PSD, can now be opened by Dreamweaver. Dreamweaver converts the Photoshop file into a Web-ready for-
mat (GIF, JPEG, or PNG) through a user-controlled interface titled Image Preview.

The other path from Photoshop to Dreamweaver lies through the clipboard. A selection copied or cut in Photoshop
can bhe pasted in Dreamweaver and doing so invokes the Image Preview dialog for optimizing the exported image.

Given the iterative nature of the design process for most Web designers, it is essential that the workflow between
Photoshop and Dreamweaver be a two-way street. Once a Photoshop-generated image is placed in a Dreamweaver
design, it can be sent to Photoshop for further modification. Again, the clipboard serves as the conduit from Photoshop to
Dreamweaver; however, the altered graphic is automatically saved with the previously chosen Web-oriented settings, so
there is no need to repeat the export process.

In the following chapter, you'll begin by creating a comp (a.k.a. a composition) in Photoshop. Designers new to this
program will learn numerous essential techniques including working with layers and extracting a figure from its back-
ground. On the Dreamweaver site, the basic operations—such as establishing a site and creating a new page—will be
enhanced with the development of a Cascading Style Sheet (CSS)-based, Web standards—compliant layout. Subsequent
chapters in this part of the book will cover the integration of hoth Photoshop-created foreground and background images
into the Dreamweaver design.



THE FLOW: PROTOSROP T0 DREAMWEAVER

As noted earlier, there are two distinct ways for moving graphics from Photoshop to
Dreamweaver. Here's an overview of the first approach (see Figure I-1):

1. Create your graphic comp in Photoshop.

2. Save any individual component (primarily foreground images) as a na-
tive Photoshop (PSD) file.

3. Open PSD file in Dreamweaver and convert it to Web-ready format.

FIGURE I-1

The second method (Figure I-2) requires the following steps:

1. Select desired image in Photoshop.

2. Copy or cut the selection to the clipboard.

3. Paste the clipboard in Dreamweaver and convert the image to a Web-
ready format.

FIGURE [-2

To modify an image placed in a Web page in Photoshop (Figure I-3), you'll follow
these steps:

1. Selectthe image in Dreamweaver and, from the Property inspector,
choose Edit (the Photoshop icon).

2. Image opens in Photoshop for modifications.

3. Select and copy the modified image.

4. In Dreamweaver, paste the copied image.

EIGURE -3




Adobe Photoshop is rightly well known for uses in digital photography, print preparation, and even, with the introduc-
tion of Photoshop Extended, medical imagery. Although lesser known, Photoshop’s Weh capabilities are equally robust.

Factor in the ubiquity of Photoshop in design houses around the world and its newly introduced Dreamweaver connectiv-
ity, and you have a tool ready to create a comp for almost any Web site.

Given its full-featured implementation as a graphics editor, it's no wonder that Photoshop is often overwhelming
to those new to the software. This chapter—and the others following it in this part—takes a learn-by-doing approach.
Here, you'll build up a sample composition in Photoshop to be converted to a Web page in Dreamweaver. As you move
through the design process, you'll encounter core techniques essential to working in Photoshop. The core Photoshop

techniques covered in this chapter are:

e Working with layers
e Making a selection
e Extracting images from the background

Later chapters in this part build on the design foundation you put down in Photoshop and extend your work to its
ultimate goal: a Dreamweaver Web site.

CREATING THE COMP




INITIALIZING THE COMP

While there is no direct interaction between Photoshop and Dreamweaver detailed

in this chapter, that doesn’t mean there is no workflow between the two. Part of any
design process is the initial visualization of the project and, whether you sketch out
your ideas on paper or in a graphics tool, it's always good to consider your end result.
If your site requirements demand an HTML-based site rather than a Flash-based one,
your design direction is going to be influenced by what's possible with modern Web
standards—compliant implementations. For example, a race car spinning onto the mid-
dle of your homepage and then zooming off to reveal the previously hidden content is
probably better suited for a Flash presentation, even though it could possibly be done
with advanced JavaScript techniques.

When considering a design for an HTML-based page, it's a good idea to keep
these questions in mind:

e Where are the natural divisions in this design that will translate into a
CSS layout?

e Which figures are in the foreground and can be inserted as <img> tags?

e Which graphics are best displayed as background images and defined in a

CSS style?

As | go along, I'll point out where these considerations would occur to me so you
can get a sense of how to apply them to your own work.

The example comp created during this exercise is for a fictitious Web design
company called Chocolate Dipped Design. You can start the comp in Photoshop by
creating a new page:

1. From Photoshop’s main menu, choose File » New.

2. When the New dialog box (Figure 1-1) opens, enter Chocolate Dipped
Comp in the Name field.

Although not critical, it's a good idea to name your pages upfront when
defining them in Photoshop. The name appears in the document title bar,
which is handy when working with a number of open files. Moreover, the

Throughout this
book, | use the term
HTML to refer to both
HTML and XHTML-
coded pages. XHTML
is the most recent
incarnation of the
HTML language and
incorporates a
standards-based
coding approach;

the default document
type (or doctype) for
Dreamweaver CS3

is XHTML 1.0 Tran-
sitional. As HTML
encompasses all
variations, you’ll find
it used consistently in
these pages.
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name becomes the suggested filename that appears in the Save dialog box—a minor timesaver, true, but in
the often hectic world of Web design, every little bit helps.

From the Preset menu, select Webh.

The Web preset provides a variety of common Web page sizes, including 800 x 600 and 1024 x 768, in addi-
tion to the standard sizes for Web banner ads such as Leaderboard and Wide Skyscraper.

From the Size menu, choose 1024 x 768.

FIGURE 1-1
lame: Chocolits Doped Comp o, r— |
presat: [T ~ [ Conenl ]
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Color ode: REBCole ~ 8B -
Background Contests: White r P
% Advanced 2.25M

What size Web page is often the first decision a Web designer faces. The answer depends on a number

of factors, primarily related to the client’s needs and experience. If the visitor logs in from a previous or
existing site, you'll be able to get an idea of the screen resolution employed by your client’s audience. If the
vast majority is using a lower resolution, such as 800 x 600, you'll need to work within those restraints.

If, on the other hand, a significant proportion is viewing the site with 1024 x 768 or higher, you can safely
increase your design space to those dimensions. The trend in computing is definitely toward larger monitors
with higher resolutions, but it's always vital to put the client’s interest first.

Leave Resolution set to 72 pixels per inch and Color Mode to RGB 8 bit.
These default settings reflect standard monitor output.
From the Background Contents menu, choose White and click OK.

What color you start your comp with is a personal choice; some designers prefer transparent over white.
| typically choose white because that is the default background color for rendered Web pages.

Choose File »> Save As. When the Save As dialog opens, navigate to a folder to store your images or
create a new one. Keep the suggested name as well as the default options and click OK.
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Photoshop opens your new document full size with the magnification set to as
close to 100 percent as possible given your program window size. You can change the
magnification as needed by using the Zoom tool.

SETTING PREFERENCES

To better allow you to work the way you want to work, Photoshop has a full comple-
ment of preference settings: ten entire categories of them, in fact. Although Photo-
shop offers a great number of optional settings, when you are creating Web comps,
there is one change that is highly recommended. Web pages are presented primarily
in a pixel-based medium, and it's a good idea to switch Photoshop’s basic unit of
measurement to pixels. This setting instructs Photoshop to display all positioning—
on rulers as well as X and Y coordinates in the Info panel—and dimensional—uwidth
and height—information the way browsers render the page: in pixels. Additionally,
Web designers should set the type unit of measurement to pixels. While print design-
ers used to working with points may be thrown off their game, pixels are one of more
frequently used units of measurements in CSS for text.

To establish the proper preferences for working on the Web, follow these steps:

1. Choose Edit P> Preferences P Units & Rulers (Windows) or Photoshop P
Preferences P Units & Rulers (Mac). See Figure 1-2.
2. From the Rulers menu, choose pixels.

3. From the Type menu, choose pixels.

FIGURE 1-2

4. Click OK.

Photoshop is rife with
keyboard shortcuts,
and | recommend
memorizing those
that will increase
your productivity the
most. Among those |
use most frequently
are Ctrl+Alt+0 (Win-
dows) or Cmd+0pt+0
(Mac) for setting

the magnification to
100 percent and its
companion, Ctrl+0
(Windows) or Cmd+0
(Mac), for seeing the
entire image.
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If you worked with
previous versions of
Photoshop to create
Web designs, you
may be wondering
whatever happened
to ImageReady.
ImageReady, a Web-
oriented bitmap edi-
tor previously paired
with Photoshop, has
been discontinued.
For similar—and
arguably more
advanced—function-
ality, turn to Adobe
Fireworks, part of the
Adobe CS3 Web suite
and covered else-
where in this book.

Photoshop to Dreamweaver

WORKING WITH LAYERS

| remember the first time | opened an example file from an experienced Photoshop
designer. The image before me was a relatively simple-appearing logo with a curved
framed and highlighted lettering. Okay, | thought, he’s got text surrounded by a round-
ed rectangle against a textured background; | suspected the figure was comprised

of 4, maybe 6, separate objects total. | opened the Photoshop Layers palette to take
a look at how it was made and almost fainted when the 43 different elements were
revealed. Layers are essential in Photoshop.

Every object—whether text string, rectangle, or digital image—is placed on
its own layer in Photoshop in the Layers palette. Layers are stacked above or below
one another and easily rearranged if necessary. You can hide or display layers or lock
them against further editing. As you'll see later in this chapter, layers can even have
effects applied to them.

Layer groups are used to keep the potential multitude of layers orderly. A layer
group is represented by a folder icon and can contain other layer groups as well as
layers. Layer groups can also be hidden or locked as needed.

While both layers and layer groups can, and often are, created on the fly, it's a
good idea to prime the canvas as it were and create your basic structure. You can
start by creating the three primary layer groups:

1. Choose Window P> Layers or, from the docked palette group, click
Layers to expand the Layers palette (Figure 1-3).
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FIGURE 1-3
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. Click the folder icon in the bottom of the Layers palette to create a new group.

A new Layer group appears titled Group 1 (Figure 1-4). You can easily rename your layer groups with more
appropriate labels.

FIGURE 1-4
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. Double-click the Group 1 name and rename it Footer.
. Repeat steps 2 and 3 twice more to create group layers named Gontent and Header.

You'll note that new layer groups are added above the currently selected one. Layers can be easily moved
from one position to another.

. Drag the Header layer group down below the Content layer group. Release your mouse button when you
see a black line appear below Content.

Layer groups can be stacked above or below another layer group or within it. Again, Photoshop gives you a
visual indicator.

. Drag the Footer layer group into the Content layer group. When you see a black border surrounding Content,
release your mouse button (Figure 1-5).

FIGURE 1-5
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7. Press Gtrl+AR+Z (Windows) or Gmd+0pt+Z (Mac) twice to undo the last two operations and restore the
layer groups to their original order of Header, Content, and Footer.

The undo keyboard commands standard in many other programs Ctrl+Z (Windows) and Cmd+2Z
(Mac) are effective only for the last operation in Photoshop; pressing the keyboard shortcut

a second time undoes your undo command, effectively redoing it. To undo the last series of
operations, you’ll need to bring in the Alt/0pt key: use Ctrl+Alt+Z (Windows) or Cmd+0pt+Z

(Mac) for multiple undo commands.

8. Select Header and insert a new layer by clicking Create a new layer at the bottom of the Layers palette

(Figure 1-6).

FIGURE 1-6

9. Choose File > Save.

With the basic structure of the Web comp done, you're ready to begin adding content.

MAKING SELECTIONS

The act of selection is at the heart of working in Photoshop. In order to effectively alter a portion of an image, you must se-
lect it first. In testament to selection’s central place in the mechanics of Photoshop, there are easily more than a dozen ways
you can make a selection. Moreover, whether you've drawn it out freehand with the Lasso tool, surrounded it with the Mar-
quee tool, or automatically chosen it with the Magic Wand, your selection can be adjusted or fine-tuned in myriad of ways.

Flash to Dreamweaver Photoshop to Bridge to Additional Workflows
Fireworks to Dreamweaver
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Selections aren't just for modifying bitmaps, howev-
er—you can also use them to create a graphic element.
Often Web comps cry out for a splash of color to delin-
eate or otherwise decorate a page. Whereas in other

Ps' CORE TECHNIQUES
e tusn /(1K [1|G 1V1TH LAYERS

in Photoshop it's common practice to define the area

you want to color with a selection. In the example comp, AN[I [AYEH GH[]UPS

you'll create selections in both the header and footer Every graphic element created in Photo-
areas that will, in short order, contain gradient fills.

CPERELERLEREERERE &

shop is placed on its own layer in the Layers
palette (Windows > Layers). Layers can be

1. From T[he Layers palette, selec? the Header organized into layer groups; both layers and
layer inserted in the last exercise. layer groups can be arranged and modified
When defining color areas, it's important in a number of ways. PhOFOShOP supporisg
to realize that you need to tell Photoshop variety of types of layers including object,

fill, and adjustment layers.

where you want your selection to go.

2. From the Tools palette, select the Click Create a new layer (second icon
Rectangular Marquee tool, the second from the right at the bottom of the Lay-
item from the top (Figure 1-7). ers palette) to insert a standard layer. :
FIGURE 1-7 Click Create a new group (the folder =
icon at the bottom of the Layers pal- -
— ette) to add an organizing folder to =

the Layers palette.
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To move a layer or layer group direct-
ly above or below another element

in the Layers palette, drag it until a
single black line appears in your in-
tended destination.
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To place a layer into a layer group, drag
the layer onto the group until a black
rectangle surrounds the layer group.
The same technique can be used to
nest one layer group inside another.

(continued)
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(continued)

* |fyou prefer not
to use a mouse
to move your
layers or layer
groups, select
the element you
want to move
inthe Layers
palette and
choose Layer
» Arrange
from the main
menu.

Layers or layer
groups can be
hidden by tog-
gling the eye
icon in the ad-
jacent column
or locked by
selecting the
layer and click-
ing the padlock
icon at the top
of the Layers
palette.

Photoshop to Dreamweaver

3. Make sure you can see the entire width of the image.

If necessary, use the Zoom tool (the magnifying glass icon just above the
foreground/background color swatches) to increase or decrease the magni-
fication; press Alt (Windows) or Opt (Mac) while clicking to zoom out.

4. Choose View P Rulers.

The horizontal and vertical rulers are very helpful to any layout and are
recommended throughout the process.

5. Drag out a rectangle that starts above the top-left portion of the page
and spans the full width of the image, with a height of approximately 150
pixels (Figure 1-8).

FIGURE 1-8

T Chocsiate Dipped Comp @ 8575 (Layee 1. RGBT
Il (3 103 LN i N

You don't have to be exact with your drawing—you’ll adjust the height
shortly. However, before you can, you need to fill the selection with pixels.

6. Choose the Paint Bucket tool from the middle of the Tools palette and
click once in the selection.

The selection fills with the current foreground color; if the color is white,
you won't notice a change, but the selection is filled nonetheless.

7. With the marquee still active, choose Edit » Free Transform.

The Options bar, located at the top of the Photoshop document window,
changes to display the transformation controls.

8. Change the H (Height) value to 160 px and press Tab (Figure 1-9).

FIGURE 1-9
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9. Double-click the filled marquee to apply the ‘
transformation. ps CURE TECHNIQUE
If you attempt to do anything else before
applying the transformation, Photoshop
gives you the option to do so or discard the MAK' NG A SH_E[:“[]N

change.

For many Photoshop operations, making a
selection is the critical first step.

10. Choose Select P> Deselect.

11. Choose File > Save.
Here are the key tools and commands

Your first comp element—a simple, single color rect- relating to Photoshop selections:
angle (Figure 1-10)—is now complete. Now you can add
a gradient to spice it up. * Marquee tool—Draw out your
selection with the Marquee tool.
FIGURE 1-10 There are two primary varieties:

e Rectanglar and Elliptical. Press Shift
while drawing out your marquee to
create a square or circular selection,
respectively.

T ke gl €y L L LD ke

Lasso tool—For selections that are
more organic, use the Lasso tool.
Three variations are available: Free-
form, for drawing freehand shapes;

Al] [] | NG GHA[”ENTS Polygonal, for creating multi-sided

selections; and Magnetic, for draw-
Gradients serve many purposes in design. While some ing a freehand selection that adheres

are purely decorative, others provide a sense of dimen- to the edge of an object.
sion, as with drop shadows. In Photoshop, gradients are
a special type of fill. Photoshop comes ready to roll with

CICEELLIREEEEEEEREE FREE R

|
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Magic Wand—Use the Magic

1

a full library—in fact, eight different libraries—of gradi- V\_/ahd to select pixels of the same or
ents. But, naturally, the real power comes from creating S|m|Ia.r color. In.crease the Tolerance -
your own custom gradients. level in the Options bar to select a :

wider range of color; decrease it to

In this next phase of building the comp, you're first select ess.

going to add a bright green to dark gray gradient to the (continued)
previously created page element in the header. Then,
you'll create a mirrored, but shorter, element in the footer.

o
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(continued)

Quick Select—Found in the Magic Wand
menu group, Quick Select allows you to
“paint” your selection. As you move your
cursor, the Quick Select tool expands the
selection to include pixels of a similar
color range.

Select Inverse—O0Often it’s easier to
initially select the portion of an image
surrounding your desired selection.
Once you've accomplished that task,
choose Select D> Inverse to reverse
your selection.

Save Selection—Once a selection has
been made, you can save itin the alpha
channel of your image. This is very useful
when editing images in Photoshop from
Dreamweaver; that workflow (Dream-
weaver to Photoshop and back to Dream-
weaver) relies on copying the selection
before returning to Dreamweaver.

Deselect—After your selection is com-
plete, removing the selection is vital.
Press Ctrl+D (Windows) or Cmd+D (Mac)
to deselect any selection.

Fireworks to Dreamweaver
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1.

Choose the Magic Wand from the Tools pal-
ette and click once in the previously created
header rectangle.

Because the image is a solid color, the entire
rectangle is selected.

It’s important to select a specific area

for the gradient; otherwise, the gradi-
ent is applied to the entire document.

Click the Paint Bucket tool to expose the
pop-up menu and select the Gradient tool
(Figure 1-11).

FIGURE 1-11
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In the Options bar, click the gradient color
swatch to open the Gradient Editor.

The Gradient Editor has two major sections:
Presets and the properties area. After you
define your gradient colors, you can establish
a new preset for reuse.

Double-click the first color stop on the
bottom-left side of the gradient (Figure 1-12)
to open the color picker.

The initial default gradient—and the one
you'll create—has two color stops, one at
either end of the gradient preview. You can
add as many color stops as you'd like by sim-
ply clicking along the bottom of the preview.
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FIGURE 1-12

5. Inthe color picker, enter hexadecimal for solid green, 00ff00, in the # field (Figure 1-13). Alternatively, you
can enter R:0 G:255 B:0. Click OK when you're done to close the picker.

FIGURE 1-13
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6. Double-click the second color stop on the far right of the preview gradient to again open the color picker.
7. Inthe # field, enter 66666 and click OK.

Your new gradient is ready (Figure 1-14); save it as a preset so it can be reused later in the comp.

CHAPTER
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FIGURE 1-14

8. Inthe Name field, enter Header Footer and press Tah. Click New. Click OK when you're done.

Now you can apply the gradient you constructed. The area needed to be filled with the gradient is already
selected—all you need to do is provide the direction.

9. Press Shift and drag your cursor from the top of the selection to its bottom. Release your mouse button to
complete the gradient (Figure 1-15).

FIGURE 1-15
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You can draw out gradients in any direction; pressing Shift constrains the line drawn to be straight.
The next series of steps pulls together everything covered up to this point in the chapter.

1. Inthe Layers palette, select Footer.
2. Insertanew layer by clicking Greate a new layer.

3. Select the Rectangular Marquee tool and draw out a selection from the lower right of the document that
spans the width of the page and is about 50 pixels high (Figure 1-16).

Photoshop to Dreamweaver Fireworks to Dreamweaver Flash to Dreamweaver Photoshop to Bridge to Additional Workflows
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8.

FIGURE 1-16
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Select the Paint Bucket tool and fill the selected area with the foreground color.
Choose Edit P Free Transform.

Change the H (Height) value to 50 px (Figure 1-17) and press Tab. Double-click the filled area to apply the
transformation.

FIGURE 1-17

Select the Gradient tool and, with the last gradient still selected, drag your cursor from the bottom of the
selected area to its top, while pressing Shift. (See Figure 1-18.)

FIGURE 1-18
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Choose File > Save.
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Now the basic header and footer graphics are good to go. As you can see, the creation process goes much quicker
once you're familiar with the toolset.

INSERTING IMAGES

Photoshop positively excels when working with bitmapped images, whether they are digital photographs or previ-
ously created art. Once brought onto your canvas, they can be altered in almost immeasurable ways: rescaled, rotated,
flipped, distorted, color corrected, blended—the list goes on and on.

This exercise focuses on a few central bitmap operations to build up sections of the Weh page comp. These opera-
tions include:

Placing an external image in your comp
Duplicating images
Rotating and moving images on the canvas

Removing an image from its background

The first task is to bring in a bit of scrollwork to give the gradient a little more depth and subtlety.

1.

If you haven't already downloaded the book exercise files, do so now. The files can be obtained from www.
wiley.com/go/adobecs3webworkflows; download the zipped files and uncompress them to a
folder on your system.

In the Layers palette, select the gradient layer inside the Header group folder.

When images are brought into Photoshop, they automatically create a new layer; by preselecting a group
folder, the new layer will be put just where you want it to go.

Choose File » Place. \When the Place dialog opens, navigate to the book exercise files and open the
Chapter 1 folder. Locate the spiral.gif file and click Place.

The inserted image is initially placed in the center of the document and marked with an X-shaped line and
border with sizing handles (Figure 1-19).
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FIGURE 1-19

. Place your cursor inside the image and drag it over the top gradient, until it is about 150 pixels from the left
and 50 pixels from the top (Figure 1-20). After you've placed it where you like, double-click the image to
confirm the move.

FIGURE 1-20

You'll notice some artifacting as the spiral overlays the gradient; you'll handle that in the next step by ad-
justing the opacity of the image.

. With the spiral image still selected in the Layers palette, change the Opacity value, located in the top right
of the Layers palette, to 10% (Figure 1-21). You can either use the slider or manually alter the value.

FIGURE 1-21

The design goal here is to break up the gradient somewhat, but not so much that it overpowers the rest of
the comp. Now that you have your basic filigree graphic, add a few more to heighten the effect.
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You can always use
the Options bar to
precisely position
your images, includ-
ing the rotation angle.
Often, however, the
visual approach is
better suited to this
type of work.

Photoshop to Dreamweaver

. Right-click (Windows) or Gontrol-click (Mac) on the spiral layer. From

the pop-up menu, choose Duplicate Layer. \When the Duplicate Layer
dialog box appears, change the name to spiral 2.

The layer is cloned and inserted on top of the original. Now you can try
out a few of Photoshop’s bitmap transformation tools.

Drag spiral 2 to the right about 50 pixels and position it close to the
top of the document. Rotate the image about 15 degrees counterclock-
wise by moving your cursor outside the bottom-left corner of the graphic
until you see the curved two-headed arrow and dragging up (Figure 1-22).
When you find a suitable position, double-click the image to complete the
transformation.

FIGURE 1-22

. Repeat step 6 to duplicate another image layer; name this one spiral

3. Move the new image a bit further to the right of spiral 2 and down
75 pixels or so. Rotate the new spiral clockwise about 20 degrees.
Double-click the image when you're done (Figure 1-23).

FIGURE 1-23
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Now, you can apply the same techniques to the footer.

9. Repeat step 6 again to duplicate another layer and name it spiral 4.

Drag the layer to the Footer group above Layer 2, which holds the /-{’ere are a couple of
bottom gradient. tips to help speed up
this detailed work.
10. Drag the selected image down to the footer region and place it on the left First, you can dupli-
side of the document, positioned so that the top of the graphic does not cate a layer by drag-
go above the gradient. The lower portion of the spiral will spill out of the ging it to the Create

document (Figure 1-24). a new layer icon on
the bottom of the Lay-
ers palette. Your new
layer will be called
LayerName copy,
which you can modify
by double-clicking
on it and entering a
new name. To vary
the look of the spiral,
choose EditW Trans-
form W Flip Vertical
or EditW Transform
» Flip Horizontal.
Finally, cloned layers
B i can be moved hori-
— ]
| _ the left and right ar-
ses QL - row keys, so that ev-
ery spiral stays in the
same plane.

FIGURE 1-24

11. Continue to duplicate the spiral layer and place it along the bottom gradi-
ent until the full span is filled. Remember to vary the angle of the image
to avoid a discernible pattern (Figure 1-25).

FIGURE 1-25

Not all the graphics you might want to incorporate in a \Web page come ready to
be placed. Who hasn't seen the perfect image for a design—if only it were flipped
the other way or a slightly different size? Modifications like these are one-step opera-
tions in Photoshop (most of which can be found in the Edit P> Transform commands),
but another common problem—isolating an image from its background—requires a
bit more work.

Perhaps to better handle the full range of images, Photoshop provides a number
of ways to pull out a section of a graphic. The following exercise walks you through

INITIALIZING THE COMP // SETTING PREFERENCES // CHAPTER
WORKING WITH LAYERS // MAKING SELECTIONS
ADDING GRADIENTS // INSERTING IMAGES //




one approach—using a Quick Mask—that has consistently worked well for me. A number of other methods are
described in the Core Techniques sidebar “Extracting an Image from the Background” that appears near the end of
this chapter.

1. In Photoshop, choose File > Open and navigate to the Chapter 1 folder. Select strawberries_bg.jpg.
(See Figure 1-26.)

FIGURE 1-26

The goal here is to extract the two strawberries from their background without extracting the surrounding
drop shadow. If you retained the shadow, it would be much harder for the image to blend into the comp. It's
better to isolate just the desired figure and apply your own shadow, as needed.

2. From the Tools palette, select the Magic Wand and click into anywhere in the brown background.

The first step in this technique is to select the portion of the image you want to keep. You could use any
of the available selection tools, such as lasso or polygon lasso, to do this but in this case the Magic Wand
does an adequate job quickly. The selection does not have to be exact as it is refined in the following steps.
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3. Choose Select P Inverse Selection.

Because you want to select the strawberries rather than the background, the selection is reversed. Al-
though it may appear to you that little has changed, note that the marquee previously surrounding the outer
border is now gone and only the strawberries are selected (Figure 1-27).

FIGURE 1-27

Another approach to create the selection is to use the Quick Select tool (found in the Magic
Wand group) to paint over the strawberries, being careful not to move into the shadow. With
this method, there’s no need to invert the selection.
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4. Press Q to create a Quick Mask.

The nonselected background is now tinted red to indicate the application of the Quick Mask (Figure 1-28).

FIGURE 1-28

Masking is a key concept in Photoshop. As the name implies, a mask is used to hide part of what lies be-
neath, which, in Photoshop, is an image. What is hidden in Photoshop can't be altered, so masks are also
used to protect parts of a graphic. Entering into Quick Mask mode changes whatever is selected into a tem-
porary mask. When you exit the Quick Mask mode, the temporary mask is reverted to the selection.

5. From the Tools palette, select the Brush tool, located in the second tool grouping on the palette.

The real power in the Quick Mask technique comes from using the Brush tool to fine-tune the selection by
drawing with either black or white. When abstracted, a mask is shown in black and white; the mask itself
is black, while the unmasked portion is white. In Quick Mask mode, you use black to extend the mask and
white to extend the unmasked, or selected, area.
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6.

8.

10.

Make sure that the foreground color is black and begin painting over the shadow surrounding the strawber-
ries. You might find it helpful to zoom in on the section you're working on by pressing Gtrl++ (Windows) or
Cmd++ (Mac) (Figure 1-29).

FIGURE 1-29

Continue to work your way around the strawberries. If you extend the mask into the desired figure, switch
the foreground color to white by clicking the curved two-headed arrow above the foreground and back-
ground color swatches and apply your brush from within the strawberries.

Understanding the relationship between drawing with black to extend the mask and drawing with white
to push back the mask was my “Oh, wow!” moment with this technique. By zooming in and changing the
brush size (in the Options bar), I'm able to precisely control the boundaries of the mask and, thus, the
selection.

To see the results of your progress, press Q to exit Quick Mask mode and review the current selection
marquee. Press @ again to continue refining the mask.

When you're done, press Q a final time to leave Quick Mask mode. With your selection finalized, press
Gtrl+C (Windows) or Gmd+GC (Mac) to copy it to the clipboard.

Since it's a signature element in the design, you may want to reuse it at some later point, so it's a good
idea to save the isolated image separately.

Choose File > New to create a new PSD file. In the New dialog, keep the default dimensions Photoshop
picked up from the clipboard and change the Background Contents to Transparent. Click OK.
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11. When the new file opens, press Gtrl+V (Windows) or Cmd+V (Mac) to paste it to the clipboard
(Figure 1-30).

FIGURE 1-30

8 Untitied1 @ 100% (Layer 1 IR
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You'll notice the image appears, minus the background. Now, take one more step to clean it up before
saving.

12. Choose the Grop tool, fourth from top of the Tools palette, and drag out a rectangle from the top-left cor-
ner that encloses the strawberries. Double-click inside the cropped area to confirm your choice.

13. Choose File » Save As and store the file in your Chapter 1 folder as just_strawberries.psd.

14. Select the Ghocolate Dipped Gomp document and, in the Layers palette, select the Header layer group.
Drag the just_strawberries image onto the Chocolate Dipped Comp document (Figure 1-31).

Naturally, you could have used the copy/paste method, but in this circumstance dragging from one docu-
ment to the other is just as effective and a bit faster.

The strawberries are a bit too big for the comp, so you'll want to scale the image down.
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FIGURE 1-31
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15. In the Options bar, make sure Show Transform Controls is selected. Click the lower right corner of the
bounding box around the strawberries, press Shift to constrain the aspect ratio and drag toward the upper
left corner, rescaling the image. Release your mouse when the W and H values are approximately 60%.

16. Drag the rescaled strawberries into the header area, about 200 pixels from the left and 50 from the top.
Double-click inside the strawberries to confirm the move.

17. Press Gtrl+S (Windows) or Cmd+$ (Mac) to save your changes. Figure 1-32 shows the final result.

FIGURE 1-32
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In this chapter, you got a solid

P CURE TECHNIQUES foundation for creating the basic
graphic elements of a comp. In the

E=a, next chapter, you'll complete the

EXTRACTING AN IMAGE i ot an o
FH[]M THE BAEKGH[]”N[] ed text before moving on to con-

struct the layout in Dreamweaver

H

Figures isolated from their normal background provide powerful in the final chapter of this part.
imagery and are often incorporated into Web designs. In addi-
tion to copying and pasting a selection, Photoshop offers three
key methods for extracting an image from the background: the
Extract filter, Background Eraser, and Quick Mask.

CECEETERE TR TR FERT TP ERTTFRE AT PR E Y

AR MMM )

i

e The Extract filter is Photoshop’s dedicated user inter-
face for the task of isolating an image from its back-
ground. Choose your image and select Filter > Extract.
When the Extract filter appears, select the Edge High-
lighter tool and draw around the portion of the image
you want to keep. Then click the Fill tool and click within
the desired section. Click Preview to see the results and
fine-tune the background selection with the Cleanup tool

R

— and the foreground with the Edge Touchup tool.
= — e The Background Eraser tool changes any pixels it en-
- counters to transparent. You simply draw over the un-
- wanted portion of your image to remove the background.
= » The Quick Mask technique (used in this section’s ex-
m" ercise) converts a selection into a mask that can then
T be easily adjusted and returned to a selection. When in
R _ _ _
S Quick Mask mode, draw with black using the brush tool
E— to extend the mask (and consequently, the background)

or white to extend the unmasked area (the foreground).
You can easily go back and forth between the Quick
Mask and selection by toggling the letter Q.
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