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Working with Excel 2007
or Excel 2010

Extensive changes were made in the Excel 2007 user interface. Excel's
familiar drop-down menus with their familiar commands were replaced by the
Ribbon. (The Excel 2010 Ribbon is virtually unchanged from the Excel 2007
version.) If you're a long-time Excel user, you'll probably find the ribbon
interface confusing and infuriating, although some people profess to like it.

At the end of this chapter I suggest several ways to make the change to Excel
2007 or 2010 easier for Excel 2003 users.

What's New in Excel 2007 and 2010

Let's look at the changes that were introduced in Excel 2007. They're listed
in decreasing order of what I consider to be their importance for the average user.

The Ribbon

The Ribbon is the major component of what's officially called the Office
Fluent user interface; it replaces the familiar drop-down menus and toolbars of
eatlier versions of Excel. The Ribbon is essentially a multi-row toolbar.
Clicking on one of a series of tabs located on something similar to the Excel
2003 menu bar dizplays the Ribbon for that particular tab. The primary tab
captions are Home, Insert, Page Layout, Formulas, Data, Review, and View.
Figure 1-1 shows the Home tab of the Ribbon. (The appearance of the Ribbon
may be different, depending on your screen width and/or resolution.)

Other tabs may be displayed depending on context. If a chart is the active

window, the Design, Layout and Format tabs are displayed. The Developer tab,
for working with VBA procedures, is only displayed if the user previously opted
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to display it. The Add-Ins tab appears only if custom menu commands or
toolbuttons have been added to the Ribbon; these appear in the Menu Comimands
and Toolbar Commands groups, respectively.
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Figure 1-1, The Excel 2007 Home tab.

New File Formats

Microsoft has moved to new XML-based file formats. Instead of the familiar
xls file extension, indicating an Excel workbook, there are now a number of
workbook file types. Table 1-1 shows the most important of these new file types.
The filename extension now consists of four letters. The first two characters, xl,
identify the document as an Excel file. The third character, either s, t or a,
identifies the file as spreadsheet, template or add-in. The final character, either x
or m, identifies the file as either macro-free or macro-enabled. In addition to
these file types, the .xlsb file format identifies a workbook in binary format,
while the .crix file format is used to save chart templates.

Table 1-1. New File Formats in Excel 2007/2010

xisx A workbook containing no macros (the default Excel 2007/2010 file
format)

xlsm A workbook containing one or more macros (either VBA or Excel 4
macro language)

Xlsb  The Excel 2007/2010 Binary file format.

xlam  An Add-in workbook containing either VBA procedures or Excel
4.0 macros).

xltx  An Excel template, without VBA or Excel 4 macro language code.
xltm  An Excel template with VBA macro code or Excel 4 macro sheets.
.crtx  An Excel chart template.

A Much Larger Worksheet

Worksheets now have more rows and columns: 1,048,576 rows by 16,384
columns for a total of 17,179,869,184 cells in each worksheet. (The column
designation now ends at XFD instead of IV.) Granted, Excel 2003's 256 columns
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was sometimes not enough — many people wanted to have at least 365 columnns,
one for each day of the year — but seventeen billion cells in each worksheet
seems a bit much,

Larger Limits for Some Features

There are larger limits for a number of Excel features. Excel 2003 allowed
three levels of conditional formatting; in Excel 2007/2010, the number of
conditional formats is limited by available memory. The number of levels of
nested functions in a formula in Excel 2003 was seven; the new limit is 64 levels.
The number of sort levels in Excel 2003 was three; the new limit is 64 levels. A
more complete list of Excel 2007/2010 specifications can be found at the end of
this chapter.

New Worksheet Functions

There are more built-in functions, but this is largely because the 89
Engineering functions, loaded in Excel 2003 with the Analysis ToolPak Add-In,
are now a permanent part of the list of functions. Apart from the Engineering
functions, only five new functions have been added: SUMIFS, AVERAGEIF,
AVERAGEIFS, COUNTIFS and IFERROR. These are discussed in Chapter 3,
"Excel Formulas and Functions".

The Downside

There are some changes that, in my opinion, are not for the better. Since
there are no menus, VBA code that installs a new menu command in, for
example, the Tools menu of Excel 2003 doesn't work as it did before. If you're
lucky, the custom menu command will appear in the Add-Ins tab. The same is
true of custom toolbuttons; they also appear in the Add-Ins Tab. If you're not
lucky, the VBA code that installs a custom menu command or custom toolbutton
may have to be modified.

What's New in Excel 2010

There have been a few changes in Excel 2010 from the previous version,
Excel 2007. Among the more substantive changes are: changes in some
functions (see "Changes to Functions in Excel 2010" in Chapter 3), the Equation
Tool to display an equation in a text box (see "Entering an Equation in a Text
Box" later in this chapter), and the ability to customize the Ribbon, not just the
Quick Access Toolbar (see "Customizing the Ribbon" in Chapter 23).
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The Excel 2007 /2010 Document Window

An Excel workbook is a document that appears in its own document window.
Although vou can have several workbooks open at the same time and can see
several displayed on the screen simultaneously, only one workbook can be the
active workbook. The default Excel 2007/2010 workbook contains three
worksheets; only one worksheet in the active workbook can be the active
worksheet.

Figure 1-2 shows the Excel 2007 document window. The Excel 2010
window is essentially identical. In Figure 1-2, reading from the top down you'll
see the application title bar, the Ribbon tabs (Home, Insert, Page Layout, etc.),
the Ribbon (the Home tab of the Ribbon is displayed), the Quick Access Toolbar
{with New, Open, Save, etc, toolbuttons), the formula bar, the rows and columns
of cells, and, at the bottom, the sheet tabs, the horizontal seroll bar and the status
bar. To the left of the formula bar is the Name Box or cell reference areq,
displaying the cell reference of the currently selected cell. Depending on your
monitor, your screen may show a different number of rows or colurans and a
different view of the Ribbon,

Oia i Book2 - Microsoft Excel - m‘
- vt w
_ Canpri 3 SR o - General o, - Aw }}
P B i U Aa EEWEa § % e "y 7 e
iy : - % Find &
- FoEsiden A iEE ¥ i B 27 e Select -
Yl g L8 G BZU EER MR ENEE D s
Al - L, ¥
- '
heetl, “Shest2 - Sheetd  ¥J. i i R inabia i i
Ready 3 B0k~ e Y |

Figure 1-2. The Excel 2007 document window, showing the Home tab.
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button ¥| that allows you to increase the size of the formula bar to
accommodate long formulas. You can also right-click in the formula bar to
display a shortcut menu that allows you to expand the formula bav.

Hiding, Moving or Resizing a Document Window

1f you click on the Minimize button (the ~ bution in the upper right corner
of the document) the window will be closed and only the title bar will appear in
the tray. To restore the window, click on the document in the tray.

If you click on the Restore Window button (the ~  button in the upper right
comner of the document), the window size will be reduced so that it no longer
completely fills the document window. To restore it to its full size, click the
Restore Window button again.

To manually change the size of a window, click and drag any of its borders
or corners; the mouse pointer changes shape when you click on a border or
corner. You can adjust the document to any size you desire.

To change the position of a document within the Excel window, click on the
title bar and drag the document. 1t can even extend off-screen.

Working with Excel 2007/2010

In my view, some of the most confusing changes that were made in Excel
2007 were those that corresponded to commands in the File menu of Excel 2003,
and in the Options command in the Tools menu, These two changes will be
discussed first.

The Office Button (Excel 2007)

t""«» . The Office Button, shown at the left, is located at the lefi of the
~%,) Ribbon tabs, Pressing this button displays the Office Button
window, shown in Figure 1-3.

The Office Button window is the approximate equivalent of the File menu in
Excel 2003. In addition to the commands found in the Excel 2003 File menu
(New, Open, Close, Save, Save As, Print, Exit, ctc.), clicking on the Excel
Options button at the bottom of the window displays the Options window. The
Options window contains the options that were located in the Excel 2003
Options command of the Toels menu and is described in a following section.
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Figure 1-3. The Excel 2007 Office Button window

The File Tab (Excel 2010)

The Excel 2007 Office Bufton was confusing to new users. (Why did
Microsoft disguise the former File menu as a simple logo?) Excel 2010 got rid
of the Office Button and replaced it with the File tab, shown in Figure 1-4.

The File tab of the Ribbon contains the following buttons: Save, Save As,
Open, Close, Info, Recent, New, Print, Save & Send, Help, Options and Exit.
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Figure 1-4. The Excel 2010 File tab.

The Excel Options Window

Pressing the Excel Options button in the Office Button window (Excel 2007)
or the Options button in the File tab of the Ribbon (Excel 2010} displays the
Excel Options window. The menu of options, shown in Figure 1-3, is in the left
pane of the window. There are nine options available: Five of these (Popular,
Formulas, Save, Advanced, Customize) contain most of the options that are
found in the Excel 2003 Options command in the Tools menu. Figure 1-5 shows
the Excel 2010 General options window; the Excel 2007 window is similar but
called the Popular Options window.
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Figure 1-5. The Excel 2010 Options window, showing General options,

One of the five Options windows, the Advanced Options window, is so large
that it requires that you scroll down to view all the options. One of the most
frustrating things about Excel 2007/2010, even for experienced Excel users, is
the difficulty of finding the location of a desired option. Table 1-2 is a guide to
help Excel 2003 users navigate their way to Excel 2007/2010 options.

The Ribbon: An Overview

Commands on the Ribbon are represented by icons. Related icons are
organized in groups. For example, the Cut, Copy and Paste icons are located in
the Clipboard group in the Home tab of the Ribbon. Many of the icons on the
Ribbon are identical to Excel 2003 toolbuttons. Some icons have a drop-down
button that, when clicked, displays a menu of options.

The appearance and arrangement of icons on the Ribbon depends on the size
of the document window. If the window fills the complete screen, the icons in
the Ribbon are usnally arranged in two rows, If the size of the window is made
smaller, the icons may be arranged in three rows, and some groups may not
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Table 1-2. A Guide to Excel 2007/2010 Options

Excel 2003 Where to Find It in
Option Tab Option Excel 2007/ 2010 Options
General RIC]1 reference style _ Formulas
Number of recently used files Advanced: Display
Number of sheets in new workbook General (2010), Popular (2007)
Standard font and size General (2010), Popular (2007)
View Show Formula Bar, Status bar, etc  Advanced: Display
Show Comment indicator, ete Advanced: Display
Show scroll bars, sheet tabs Advanced: Display options for
this workbook
Show gridlines, row &column Advanced: Display options for
headers, page breaks, etc. this warksheet
Edit Allow Edit Directly in Cell Advanced: Editing options
Allow Drag-and-Drop Editing Advanced: Editing options
Automatic % entry Advanced: Editing options
Move selection after Enter Advanced: Editing options
Extend formats and formulas Advanced: Editing options
Fixed decimal Advanced: Editing options
Enable AutoComplete Formula
Calculation Calculation: Automatic, manual Formula
Tteration Formula
Update remote references Advanced: When calculating this
workbook
Precision as displayed Advanced: When calculating this
workbook
1904 date system Advanced: When calculating this
workbook
Save external link values Advanced: Wheun calculating this
workbook
Custom Lists General (2010), Popular (2007)
Chant Plot empty cells as (see Chapter 4)
International  Number handling Advaneed: Editing options
Save AutoRecover every ? Minutes Save
Error Checking Enable background error checking  Formula
Color Standard and custom colors {Use color palette for object)
Error-checking rules Formula
Spelling Diclionary Proofing
AutoCorrect Options Proofing
Security File encryption settings Prepare — Encrypt Document
File sharing settings Prepare — Restrict Permission
Digital signatures Prepare — Digital Signature

Transition Menu key, formula evaluation, entry Advanced: Lotus compatibility
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display all available icons. For the screen shots of the Ribbon that are shown in
this chapter, windows were resized so that icons were displayed in three rows.
For that reason, the images may not look exactly like what you see on your
computer screen.

The appearance of a command provides information about its form or
availability:
* A command with an ellipsis (...), such as Paste Special..., indicates that
the command opens a dialog box to obtain user input.

* Many buttons or commands display submenus, indicated by the
symbol at the bottom of the button or the B symbol at the right edge of
the command.

» Some commands are dimmed (i.e., appear as gray characters) when the
command is unavailable. Some tabs appear on the Ribbon only when
they are available,

* Some commands change the text of their command depending on
circumstances. For example, you click on the Add Comment button in
the Review tab of the Ribbon to add a comment to a cell; if you select a
cell that already has a comment, the button text changes to Edit
Comment so that you can edit the text of the comment.

* Some commands are preceded by a check mark if the option has been
selected previously. To remove the selection, depending on the
command you either click on the check mark or select the command
again,

Shortcut Menus

Although Excel's menus have been replaced by the Ribbon, Excel still
provides "context-sensitive" shortcut menus. For example, if you press the right
mouse button while you select a worksheet element with the mouse pointer, a
menu is displayed containing commands that apply to the selection. If you select
a column with the right mouse button, a shortcut menu is displayed that contains
editing and formatting commands appropriate for a column. In Excel 2007/2010,
many of these shortcut menus are accompanied by the Mini Toolbar, described in
a following section.

Keyboard Access to the Ribbon

You can access icons on the Ribbon by using the keyboard rather than the
mouse. First, press the Alt key to display the KeyTips for the Ribbon icons.
Figure 1-6 shows some KeyTips in the Formulas tab of the Ribbon.
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Figure 1-6. KeyTips displayed in the Home tab,

To activate a particular icon, press the keyboard letter that appears in the
KeyTip over the icon. Depending on which letter you press, additional KeyTips
may appear, and you may have to press additional keys.

To remove the KeyTips, press the Alt key a second time,

The Home Tab

Perhaps this tab, shown in Figure 1-1, should have been named the Format
tab. This tab of the Ribbon contains the following groups: Clipboard, Font,
Alignment, Number, Styles, Cells and Editing. Many of the icons in the Home
tab of the Ribben correspond to toolbuttons on the Excel 2003 Standard toolbar
(Cut, Copy, Paste and the Format Painter) or to toolbuttons on the Formatting
toolbar (Font and Font Size, Bold, Italic and Underline, Align Left, Center and
Align Right, etc,), as well as a number of icons that perform actions that are in
the Edit, Insert or Format menus of Excel 2003 (Insert or Delete cells, rows or
columns, Find or Replace, Format cells, rows, columns or sheet).

Navigating Around the Workbook

Use the Switch Windows icon in the Window group in the View tab of the
Ribbon to switch between one workbook and another. All open workbooks are
listed in the drop-down menu; the active workbook is indicated with a check
mark.

Use the Hide icon to hide a workbook. Most commonly [ use Hide with

workbooks that contain macros. A macro is still available for use even when it's
hidden.

Inserting or Deleting Worksheets

The default Excel 2007/2010 workbook contains three worksheets. You can
change the defauit, so that all new workbooks will have, for example, only one
worksheet., In Excel 2010, click on the File tab, press the Options button, click
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on the General button, and in the "When Creating New Workbooks" group,
change the "Include this many sheets” option. In Excel 2007, click on the Office
Button, press the Excel Options button, click on the Popular options button, and
in the "When Creating New Workbooks" group, change the "Include this many
sheets” option.

To insert an additional worksheet in an existing workbook, press the Insert
Worksheet button (located to the right of the sheet tabs, see Figure 1-7). A nice
feature of this button is that the sheet is added to the right of the existing sheets,
instead of to the left of the selected sheet, so that Sheet 4 follows Sheet 3, for
example.

Excel Tip. You can right-click the sheet tab of a worksheet to display the
shortout menu, and then choose Insert or Delete.

In Excel 2003, if you increase the number of sheets in a workbook, not atl of
them may be visible. In Excel 2007/2010, as you increase the number of sheets,
the area that displays the sheet tabs widens, permitting more sheet tabs to be
visible, but the horizontal scroll bar narrows correspondingly. You can change
the size of the sheet tab area by dragging the small button between the sheet tabs
and the scroll bar.

21
22

M4-b | Sheetl | Sheet2  Sheetd .~¥J

Figure 1-7. Excel 2007/2010 sheet tabs, with the Insert Worksheet button.

To select a worksheet, simply click on the sheet tab. If the workbook
contains a large number of worksheets, the tab for the sheet that you want to
select may not be visible. Use the tab scroll buttons, located to the left of the
sheet tabs, to scroll through the sheet tabs, From left to right, these four buttons
allow you to jump to the first sheet tab, scroll toward the first sheet tab, scroll
toward the last sheet tab, or jump to the last sheet tab. When the desired sheet
tab is visible, click on it.

You can select a specific sheet by right-clicking on any of the scroll buttons,
to display the list of all visible sheets. Choose the desired sheet from the shortcut
menu, as illustrated in Figure 1-8.
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Figure 1-8. Right-click to display the list of all sheets in a workbook,

Changing the Name of a Worksheet

When vou create a new workbook, the sheet tabs have the default names
Sheet], Sheet2, etc. To rename a sheet, double-click on the sheet tab, or right-
click to display the shortcut menu and choose Rename. The sheet name will be
highlighted and you can enter a more descriptive name, as, for example, in Figure
1-9, Click outside the sheet tab to exit from edit mode.

A worksheet name can have a maximum of 31 characters.

25

26

M 4> Wi Summary - January - February | March ¥ & 0
Ready

Figure 1-9, Descriptive sheet names are helpful.

Rearranging the Order of Sheets in a Workbook

To move a sheet tab, just click and drag it. The mouse pointer shape
becomes an icon showing a sheet at the end of the arrow pointer (Figure 1-10).
An arrow above the sheet tab indicates where the tab will be inserted.
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Figure 1-10. Moving a sheet tab with the mouse.

To make a copy of a worksheet, hold down the Cirl key while dragging the
sheet tab. A small + sign appears in the icon (Figure 1-11).

25 L—&
26
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Figure 1-11. Copying a sheet with the mouse.

Selecting Multiple Worksheets: [Group] Mode

To make a non-adjacent selection of worksheets (e.g., Sheetl and Sheet3),
hold down the Ctrl key while clicking on each sheet tab, To select a contiguous
range of sheets, click on the sheet tab at one end of the range, then hold down the
Shift key and click on the sheet tab at the other end of the range. Ali the sheet
tabs in the range will be selected. To select all the sheets in a workbook, you ¢an
right-click on any sheet tab; this displays a shortcut menu that will allow you to
Select All Sheets.

You are now in Group Edit mode; [Group] appears in the title bar at the top
of the worksheet, and the sheet tabs of all grouped sheets are shown as selected
(Figure 1-12).

Once you have grouped sheets, any changes you make in one of them, such
as entering or editing data or applying formatting, will be applied to all sheets in
the group.

26
4 > M| Sheetl, Sheet2 . Sheet3 . *J,
Ready

Figure 1-12. Appearance of sheet tabs in [Group] mode.

To Ungroup sheets, click on any ungrouped sheet tab. If all sheets have been
selected, right-click on any sheet tab and choose Ungroup Sheets from the
submenn,

You can also copy, move, delete or print a selection of sheets when in
[Group] mode.
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Excel Tip. If you have grouped a number of sheets, choosing Insert Sheet

from the Cells group on the Home tab will insert an equal number of
worksheets.

Changing the Color of Sheet Tabs

You can color-code sheet tabs as an aid in organizing your work, Right-click
on the sheet tab and then choose Tab Color from the shortcut menu.
Alternatively, you can click on the Format button in the Cells group in the Home
tab of the Ribbon, and then click on Tab Color.

Using Move or Copy Sheet or Delete Sheet

To move or copy sheets within a workbook, or from one workbook to
another, use the Move or Copy Sheet... command (Figure 1-13) in the Format
submenu in the Cells group in the Home tab. Since you can easily move sheets
within a workbook by using the mouse, the more important use of Move or Copy
Sheet is to send a sheet, or a copy of a sheet, from one workbook to another.

Move or Copy
| Move selected sheets
To book:

Book3

Before sheet:

=
|Sheet2 [ |
| Sheet3 8
{move to end)

Figure 1-13, The Move or Copy Sheet dialog box.
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Navigating Around the Worksheet

You can move around a worksheet either by means of the mouse or by using
keystrokes.

Use the arrows in the vertical and horizontal scroll bars (the gray bars on the
right edge and at the bottom of the window) to scroll through the worksheet. A
single click of the mouse on an arrow moves the worksheet one row or column,
The position of the scroll box (the white square in the gray bar) indicates the
position of the window relative to the worksheet. You can also scroll through the
worksheet by clicking on an arrow and holding down the mouse button, by
dragging the scroll box with the mouse, or by ¢licking in the gray space on either
side of the scroll box, Table 1-3 lists keystroke commands for cursor movement.

Table 1-3, Keys for Cursor Movement

Arrow keys Move lett, right, up, down one cell
Enter Move down one cell

Tab Move right one cell

Home Move to the beginning of a row
End Move to the end of a row

Page Up Move to the top of the window
Page Down Move to the bottom of the window
Alt + Page Up Move to the left of the window
Alt + Page Down Move to the right of the window

Selecting a Range of Cells
You can select a range of cells on the worksheet in several ways:

+ Click on the cell in one corner of the range, hold down the mouse
button and drag to the cell in the opposite corner of the range. The
range of cells will be highlighted. The size of the selection (e.g.,
10R x 3C) is displayed in the reference area (the Name Box} of the
formula bar, until you release the mouse button.

¢+ Click on the cell in one corner of the range, then hold down the Shift
key and click on the cell in the diagonally opposite corner of the range.
The range of cells will be highlighted.

+ Select a complete row or column of cells by clicking on the row or
column heading. The row or column will be highlighted.
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Selecting Non-Adjacent Ranges

To select non-adjacent ranges, select the first range, then hold down the Cirl
key while selecting the second range. Both cell ranges will be highlighted
(Figure 1-14).

A B C D
time

1 (sec) [Alt (Bl [Ch
0 5.00E-03 0.00E+00
3 02 472E-03  260E-04 171E-05
4 06 421E-03  650E-04  137E-04
5 1.0 376E-03  9.04E-04  338E-04
6 14 3.35E-03  1.06E-03  5.90E-04
7 18 299E-03  114E-03  872E-04
8 22 267E-03  116E-03  1.17E-03
9 26 238E-03  116E-03  146E-03
10 30 212E-03  1.12E-03  1.76E-03
11 4.0 1.60E-03  976E-04 243E-03
12 5.0 120E-03  8.04E-04  3.00E-03
13 6.0 9.02E-04  B41E-04  3.46E-03
14 7.0 6.78E-04  502E-04  3.82E-03
15 8.0 510E-04  387E-04  4.10E-03
16 9.0 3.83E-04 297E-04  4.32E-03
17 10.0 288E-04  226E-04  4.49E-03

18

Figure 1-14. Selecting non-adjacent ranges.

Extending a Selection

To extend the range of a cell selection you just made, hold down the Shift
key, select the last cell in the selection, and drag to include the additional cells.
Alternatively, hold down the Shift key and use an arrow key to extend the
selection. You can also decrease the number of cells in the selection in the same
way,

Selecting a Block of Cells

A block of cells is a range of cells containing values and bounded by empty
cells, There are several shortcuts for selecting cells within a block:

+ Use Ctrl + Shift + (arrow key) to select in the appropriate direction.

« Select a cell at a boundary of the block (at the top, bottom or side of
the block). Move the mouse pointer over the edge of the selected cell
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until the pointer changes to the arrow pointer (Figure 1-15 Left). Hold
down the Shift key and double-click on the bottom edge of the selected
cell to select all cells in the column from the top to the bottom of the
block, as shown in Figure 1-15 Right. You can select cells from top to
bottom, from bottom to top, from left to right or from right to left
within a block. You can also select multiple columns or rows in the

same way.

A B A B8
1 X Y 1 X Y
2 | D,mu_ml -2.303 2 [ 0100 | -2303
3 [ 02001 -1.609 3| 0200 | -1609
4| 0300  -1.204 41 0300 | -1204
5| 0400 0916 51 0400 | -0916
6| 0500  -0.693 6| 0500 | -0693
7| 0600 -0511 7| 0600 | 0511
8§ | 0700 0357 g | o700 | -0357
9| 0800 -0.223 9| 0800 | -0223
0| 0900 -0.105 10] 0900 | -0.105

Figure 1-15. Using the mouse pointer to select a block of data.
Left: Selecting a cell edge. Right: Selecting the block of data
by double-clicking while holding down the Shift key.

Entering Data in a Worksheet

As you type a value in a cell, the characters appear in the formula bar and the
active cell. You can complete the entry in several ways.

+ Press the Enter key. This moves the selection to the cell below

(although you can change the default option so that the selection is not
moved). This is the usual way for entering data in cells.

» Press the Enter button * in the formula bar. The cell remains
selected. This method is useful if you want to examine a value or
formula after entering.

To cancel the entry and revert to the original contents of the cell, press the
Cancel button % or the Esc key.

Excel Tip. To enter the same formula or value in a range of cells, select the
range of cells, type the value, then press Ctrl + Enter.
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Entering Numbers

Excel has a remarkable ability to recognize the type of value that you have
entered: a number, a percent, a debit value, as currency, in scientific notation, as
a date or time, or even as a fraction. The number will be displayed in the cell in
the proper format. Table 1-4 illustrates number formats recognized by Excel.

Table 1-4. Number Formats Recognized by Excel
AsEntered  AsDisplayed As Displayed in As Used in

Type at Keyboard in Cell Formula Bar Calculation
Percent 15% 15% 15% 0.15
Scientific 2e-3 2.00E-03 0.002 0.002
Currency $50 $50 50 50
Currency $20000 $20,000 20000 20000
Debit (5000) -5000 -5000 -5000
Fraction 2 5/8 2 5/8 2.625 2.625
Date 7/4 4-Jul 7/4/2010* "
Date*** 8/3/28 8/3/2028 8/3/2028 "
Date*** 8/3/38 8/3/1938 8/3/1938 **
Time 4:30 4:30 4:30:00 AM -
Time 16:00 16:00 4:00:00 PM "
Time 4p 4:00 PM 4:00:00 PM "

* Enters current year.
** See Chapter 3 for a discussion of date and time calculations.
*¥% A 2-digit year in the range 00-29 is assumed to be in the 21st century.
Since the slash character indicates either a date or a fraction, if you enter
what you intended to be a fraction, such as 1/3, it will be interpreted as a date,
specifically 3-Jan. To prevent Excel from converting the entry to a date, enter a

zero and a space before the fraction (0 1/3). The zero indicates that the entry is a
number, and the value will appear in the formula bar as 0.333333333333333.

How Excel Stores and Displays Numbers

Excel can accept numbers in the range from =IE-307 to
£9.99999999999999E+307,

Excel stores numbers with 15-significant-figure accuracy. These are
displayed in the formula bar and used in all calculations, no matter what number
formatting has been applied. Thus the fraction 1/3 appears in the formula bar as
0.333333333333333, and m as 3.14159265358979.
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Excel switches between floating-point and scientific notation for best display
of values. The formula bar can display numbers up to 21 characters, including
the decimal point. Thus 1E-19 entered on the keyboard will be displayed as
0.0000000000000000001 (21 characters) in the formula bar, while 1E-20 will
appear as 1E-20. Similarly, 1E20 is displayed as 100000000000000000000,
while 1E21 appears as 1E21. Since a total of 21 characters can be displayed, the
number of significant figures determines the magnitude of a number less than 1
that can be displayed in non-E format in the formula bar. Thus 1.2343E-15

appears as 0.0000000000000012345, while 1.23456E-15 is displayed as
1.23456E-15.

Entering Text

If you enter text characters (any character other than the digits 0 — 9, the
decimal point, or the characters -+, -, *, /, ~, $, %) in a cell, Excel will recognize
the entry as text. For example, Chestnut Hill MA 02167-3860 is a text entry.
Each cell can hold up to 32,767 characters (but only 1,024 will display in a cell).
You can distinguish text entries from number eniries in the following way: text
entries are left-aligned, and numbers are right-aligned. Of course, if you format

the alignment of a cell to be right-aligned, its value will be right-aligned whether
the value is a number or text.

You can format individual characters in a cell using Bold, Italic, Underlined,

etc., or with different fonts, by highlighting the character(s) in the formula bar
and then applying the formatting.

Excel Tip., Sometimes it is necessary to enter a number or a date as a text
value. To do this, begin the entry with a single quote.

Entering Formulas

Instead of entering a number in a cell, you can enter an equation (called a
Jormula in Microsoft Excel) that will calculate and display a result. Usually
formulas refer to the contents of other cells by using cell references, such as A2, a
reference to a cell, or B5:B12, a reference to a range of cells. The value displayed
in a cell containing a formula will be automatically updated if values elsewhere in
the worksheet are changed. Formulas can contain values, arithmetic operators and
other operators, cell references, the wide range of Excel's worksheet functions,
and parentheses.

The rules for writing formulas (the syniax) are as follows:
+ A formula must begin with the equal sign (=).

» The arithmetic operators are addition (+), subtraction (-),
multiplication (*), division (/) and exponentiation (*). Other types of
operator are described in Chapter 3.
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» Parentheses are used in the usual algebraic fashion to prevent errors
caused by the hierarchy of arithmetic operations (multiplication or
division is performed before addition or subtraction, for example).

Some examples of simple formulas:

=A1+273.15 Adds 273.15 to the value in cell A1,

=A2A2+137A2-5 Evaluates the function x2 + 13x — 5,
where the value of x is stored in cell
A2,

=SUM(B3:B47) Sums the values contained in cells
B3 through B47.

=(-C3+SQRT(C3*24*C2*"CAM(2*C2) Finds one of the roots of the
quadratic equation whose

coefficients a, b and ¢ are stored in
cells C2, C3 and C4, respectively.

Excel formulas are discussed in much greater detail in Chapters 3 and 6.

There are some techniques that you can use for entering worksheet formulas.

« Type formulas in lowercase to facilitate detection of typographical errors.
When you enter a formula, Excel converts functions and cell references to
uppercase. If you type the formula =offset($d$1,5,1), Excel will convert it to
=0OFFSET($D$1,5,1) when you enter the formula; but if you type "ofsett”
instead of "offset,” Excel won't recognize it and will display the error message
#NAME?. When you examine the formula, you'll easily see that the incorrect
function name remained in lowercase letters.

« Enter cell or range references in formulas by selecting, not by typing. This
makes it less likely that you will enter an incorrect reference and also makes
entering complicated references (such as external references) much easier.

« If formulas contain terms identical to those used in other cells, you can Copy
that part of the formula from the formula bar and Paste it into the new
formula.

Excel Tip. Formulas that return the wrong result because of errors in the
hierarchy of calculation are common. When in doubt, use parentheses.

Editing Cell Entries

When you select a cell that contains an entry, the contents of the cell appear
in the formula bar. As soon as you begin to enter a new value, the old value
disappears. To make minor editing changes in the old entry, place the mouse
pointer in the text in the formula bar at the point where you want to edit the
entry. The mouse pointer becomes the vertical insertion-point cursor. You can
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now edit the text in the formula bar using the Copy, Cut, Paste or Delete
commands or keys. Complete the entry using the Enter button in the formula bar,
or by pressing the Enter key on the keyboard.

Alternatively, you can use Excel's Edit Directly In Cell feature: use function
key F2 or double-click on the cell to enter edit mode. You can use the right and
left arrow keys to move through the formula, or Ctrl+(arrow key) to jump to the
next element of the formula, or Ctrl+Shift+(arrow key) to select the next element
of the formula.

Excel uses colors to show range references in formulas and the
corresponding ranges on the worksheet. When you enter Edit mode, by clicking
in the formula bar, double-clicking on the cell, or pressing F2, the precedents
(inputs} to the formula will appear in color and the cotresponding inputs
indicated by similarly colored cell or range borders (blue for the first input,
green for the second, and so on). Each of these colored outlines has a handle in
the bottom right corner; you can change the range of a formula input by dragging
its handle.

Excel Tip. To select (highlight} a word or reference for editing, double-click
on it.

The Order in Which Excel
Performs Operations in Formulas

If several operators are combined in a single formula, Excel evaluates the
formula in the following order: reference operators (colon, space, comma),
negation (minus), percent (%), exponentiation ("}, multiplication and division (*
and /), addition and subtraction (+ and -}, concatenation (&), comparison (=, <, >,
<= 2= <Y,

If an expression contains operators with the same precedence (multiplication
and division or addition and subtraction), Excel evaluates the operators from left
1o right.

Expressions enclosed in parentheses are evaluated first, no matter where they
appear in the formula.

Adding a Text Box

You can add visible comments or other information to a worksheet by typing
them into one or more worksheet cells. Another way to add comments, in a much
more fiexible form, is by using a text box.
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To create a text box, click on the Text Box icon - | in the Text group in the
Insert tab, or click on the Text Box toolbutton if you have added it to the Quick
Access Toolbar (see Chapter 23 for instructions on how to customize the Quick
Access Toolbar). The mouse pointer will change to a crosshair, Position the
crosshair pointer where you want to place the text box, and click and drag to
outline it (the text box can be moved and sized later). An empty text box will be
displayed with a blinking text cursor. Type the desired text within the box.

Text box input has many features of a simple word processor: you can Cut,
Copy or Paste text, make individual portions of text bold, italic or underlined, use
different font styles, etc., as shown in Figure 1-16. The text within the box can be
formatted with the Alignment tooibuttons or with the Alignment command.

A B C D E

Textin a text box can be Bold, /talic,
Underlined, orcan contain characters in
differentfonts, such aso. or p by using
the Symbol font.

D LW AN -

Figure 1-16. A text box.

To move a text box, click on it to select it, place the mouse pointer on the
border of the text box and drag it to its new position. To resize a text box, select
it (white handles will appear), then place the mouse pointer on one of the handles
and click and drag to move the border of the box. If you hold down the Ctrl key
while dragging, you make a copy of the text box (a small plus sign appears
beside the mouse pointer); if you hold down the Alt key, the text box will align
with the cell gridlines; if you hold down the Shift key, the text box can only be
dragged in either horizontal or vertical alignment with its original position.

Entering an Equation in a Text Box

In addition to the Equation Editor (see "Using the Equation Editor" in
Chapter 2), Excel 2007/2010 provides the Equation Tool that allows you to write
and edit equations inside a text box on a worksheet,

The Equation button, shown here on the right, is not active until -
you use the Text Box button to draw a text box. When you click on iy
the Equation button (located in the Insert tab of the Ribbon in the  cquation
Symbols group), the text "Type equation here" is displayed in the ’
text box, and the Design tab with Equation Tools is displayed.

The Equation Tools Design tab contains icons for inserting a wide range of
equation elements. Or you can press the drop-down button below the Equation
button to choose from a menu of built-in equations: area of a circle, binomial
theorem, expansion of a sum, Fourier series, Pythagorean theorem, quadratic
formula, Taylor expansion and two trigonometric equations.
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Once the Equation buiton is made active, you don't need to draw text boxes
for additional equations — just press the Equation button and a new text box will
be created, containing the text "Type equation here".

Entering a Cell Comment

You can attach a cell comment to a cell, for documentation purposes. A
comment appears on the worksheet in a small box similar to a Screen Tip. A
small red triangle in the upper right corner of the cell indicates that the cell
contains a comment. When the mouse pointer is moved over a cell that contains
a cell comment, the cell comment appears.

To add a comment to a cell, click on New Comment in the Comments group
of the Review tab. Enter the text of the comment in the box (Figure 1-17). To
exit, simply click on any cell outside the comment box.

To edit a comment, select the cell containing the comment, then click on Edit
Comment in the Comments group of the Review tab. To delete a comment,
select the cell containing the comment, then click on Delete Comment, or click
on Clear in the Editing group of the Home tab, and choose Commenis from the
submenu,

To turn display of comments and/or comment indicators on or off, click on
the Office Button, press the Excel Options button, click on Advanced in the list
of options, scroll down to the Display group, and press the appropriate button in
the Comments category.

Joseph Billo;
Comment text goes here

Figure 1-17. A cell comment,

Opening, Closing
and Saving Documents

Commands for managing documents are in the File tab of the Ribbon (Excel
2010) or in the Office Button window (Excel 2007). Clicking on the Excel 2007
Office Button displays the Office Button window, shown in Figure 1-3, that

contains the commands that were in the Excel 2003 File menu: New, Open,
Save, Save As, Print, Close, and Exit, plus a list of recently used documents.
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Opening or Creating Workbooks

Use the Open command to locate and open an existing document; or New to
create a new document. The New dialog box gives you a choice of opening
either a new worksheet or any of the built-in or user-created template sheets.

To open an existing workbook or worksheet from the desktop, simply
double-click on it. This will open the document (and will start Excel as well if it
isn't already running). If you start Excel first, it will open a new blank
workbook.

The List of Recently Used Files

In Excel 2003, a list of recently used files was displayed at the bottom of the
File menu. In Excel 2007/2010, the list of recent files has an added feature: you
can "pin" a file to the list so that it remains even after many other files have been
opened.

To keep a file pinned in the recently used files list, click on the Office Button
to display the list of Recent Documents (Excel 2007) or click on the File tab and
then click the Recent button to display the list of Recent Workbooks (Excel
2010). Click the pin icon next to the filename; click again to unpin the file.

To clear all unpinned files from the list of recently used files (Excel 2010
only), click on the File tab and then click the Recent button to display the list of
Recent Workbooks, Right-click any file in the list and select Clear Unpinned
Items, then press "Yes".

Using Close or Exit

You can close a document either with the Close button in the File tab (Excel
2010) or the Office Button window (Excel 2007) or by using the Close button on
the document title bar. You will be asked if you want to save changes.

When you use the Exit button in the File tab (Excel 2010) or the Office
Button window (Excel 2007), you close all open documents {you will be asked if
you want to save changes) and then exit from Excel.

Using Save or Save As...

When you save a newly created workbook, the Save dialog box will prompt
you to assign a name to the document. Excel 2007/2010 automatically appends a
four-letter filename extension (e.g., xlsx) to identify the fite format type.

A document name can contain up to 218 characters (the name includes the
complete path to the file, including drive letter, server name, folder path, file
name and the filename extension). File names can include spaces but not any of
the following characters: slash (/), backslash (\), greater-than sign (>), less-than
sign (<), asterisk (*), question mark (?), quotation mark ("), pipe symbol (]),
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colon (:), semicolon (;}. Sheet names can include most of the preceding
characters, but can’t include question mark (?), colon (:), backslash (\} or asterisk
(*) (wildcard characters or file delimiters).

You can use Save As... to create a backup copy of a workbook by giving the
copy a different name.

To Save a Flle for Use in Excel 2003

If you transmit an Excel 2007/2010 workbook to an Excel 2003 user, you
may want to send it in Excel 2003 format, since some users of Excel 2003 may
be unable to open documents in Excel 2007 format.

Excel 2010. Click on Save As in the File tab of the Ribbon. In the Save As
dialog box, choose "Excel 97-2003 Workbook (*.xls)" in the Save As Type list
box.

Excel 2007. Click on the Microsoft Office Button, and then click Save As,
In the list of file types, choose Excel 97-2003 Workbook (Excel 2007).

Excel features that are specific to Excel 2007/2010 (for example, 16,384
columns) will not be displayed when the workbook is opened in Excel 2003, but
they will still be available even if the workbook is edited, saved in Excel 2003
format, and then reopened in Excel 2007/2010.

If you want to save all Excel workbooks in Excel 97-2003 format without
going through the above, click on Options in the File tab of the Ribbon (Excel
2010) or click on Excel Options in the Office Button window (Excel 2007) to
display the Excel Options window. Click on Save in the list on the left side of
the window. In the Save Workbooks category, click on the Save Files In This
Format drop-down button to display the list of file formats, and choose Excel 97-
2003 Workbook. Now you can just choose Save and your document will be
saved in the old format.

Editing a Worksheet

Most commands for editing and formatting a worksheet are located in the
Home tab.

Inserting or Deleting Rows or Columns

In Excel 2003, the commands for deleting cells, rows or columns were
located in the Edit menu, while the corresponding commands for inserting were
located in the Insert menu. Excel 2007 located all of these commands in a more
logical manner, in the same Home tab of the Ribbon.

To insert an entire column of blank cells, click on a column header (the gray
rectangle at the top of the column) to select (highlight) an entire column. Then
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click on the Insert icon in the Cells group in the Home tab. A new column will
be inserted to the left of the column you selected. Insert a new row in a similar
way; the new row will be inserted to the left of the selected row. Multiple rows
ot columns can be inserted in a similar fashion, by selecting as many rows or
columns as you want to insert,

If you click on the drop-down button at the bottom of the Insert icon to
display the Insert submenu, illustrated in Figure 1-18 Left, you can choose to
insert cells, rows, columns, or a new worksheet. Deleting cells, rows, columns or
a worksheet is done in a similar way, using the Delete icon (Figure 1-18 Right).

e - fomd - e )

. . = X B

£ f il = == J:f_hl
UInsert’| Delete Format Insert [Delete’|Format
| 3= Insert Cells... | 5% Delete Cells...

jﬂ'-‘- Insert Sheet Rows | 5 :V' Delete Sheet Rows

':5J Insert Sheet Columns W' Delete Sheet Columns
ted Insert Sheet | W Delete Sheet

Figure 1-18. The Insert (left) and Delete (right) icons

To insert additional cells within a row or column, select the cell range above
or to the left of which you want to insert cells and click on Insert Cells... in the
Insert menu (Figure 1-18 Left). Excel usually makes a pretty good guess whether
the cells should be shifted to the right or down to make the proper insertion, but
always check to make sure. Then chick OK in the dialog box (Figure 1-19).
Deleting cells is done in a similar manner,

r

-~

Insert SR>

Insert
' Shift cells right

© shift cells down;

| Entire row

Entire column

Figure 1-19. The Insert dialog box.
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Format |

Cell Size

¢ Row Height..,
AutoFit Row Height
Column Width...

AutoFit Column Width

Default Width...

Visibility
Hide & Unhide 2| Hide Rows
: Organize Sheets Hide Columns I
I Bename Sheet Hide Sheet
Move or Copy Sheet... Unhide Rows
Tab Color » Unhide Columns
Protechion

iy Protect Sheet..,
ey Lock Cell

7' Format Celis..

Figure 1-20. The Format Cells menu, showing the Hide/Unhide submenu.

Hiding Rows or Columns

If you have a spreadsheet with many columns or rows of intermediate
formulas that lead to a final result, you can hide these intermediate calculations,
in order to make the spreadsheet less cluttered. First, select the rows or columns
to be hidden. Click on Format in the Cells group in the Home tab of the Ribbon,
¢click on Hide & Unhide in the drop-down menu, and choose Hide Rows or Hide
Columns from the submenu (Figure 1-20).

Using Cut, Copy and Paste

Single cells, ranges of cells, or whole rows or columns can be copied or cut
from the worksheet and inserted into other locations. In general the destination
will be the same size as the range of copied or cut cells, although the contents of
a single cell can be copied into a range.
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First, select the cell or range that you wish to copy or cut. Then click on
Copy or Cut in the Clipboard group of the Home tab, or press Ctrl+C (Copy) or
Cul+X (Cut). A marquee (a dashed line) will appear around the selected cells
and a copy of the cells will be placed on the Clipboard. Next, sclect the
destination cell or range. You can now transfer the copy to the destination by
clicking on the Paste button in the Clipboard group, or by pressing Ctrl +V
{Paste),

Excel Tip. When performing a Paste operation, instead of selecting a
destination range that is the same size as the copied or cut range, you should
always select the single cell that is the upper left corner of the destination
range.

You can also copy or cut text in the formula bar and paste it in a worksheet
cell. Select the text to be copied or cut, then copy or cut as described previously.
Complete the operation by clicking the Enter button in the formula bar. Then
paste in the desired cell.

Using Paste Special...

When you copy a cell and then paste it, Excel transfers the cell's contents,
format and comment, if present. You can choose to transfer only some of these
cell attributes by using Paste Special.... in the drop-down menu of the Paste
button. Paste Special permits you to paste only formulas, formats or comments.
In addition, you can convert formulas to constants by choosing Values.

T 1 & Cut
| (X3 copy
Paste |
‘ F Format Painter

oY Paste

Paste Link
i3 Paste Spedial...
& Paste as Hyperlink

@ As Picture yo

Figure 1-21. The Paste menu, showing the Paste Special... command.
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To display the Paste Special dialog box, you must first copy cell contents.
After copying, select a cell or range in which you want the copied values to be
placed. In the Clipboard group in the Home tab, click on the drop-down arrow of
the Paste icon to display the Paste options (Figure 1-21) and click on Paste
Special... to display the Paste Special dialog box (Figure 1-22).

If you press one of the Operation buttons in the Paste Special dialog box, the
value in the destination cell will be added to, subtracted from, multiplied by, or
divided by the value in the copied cell.

r

Paste Special &2 mr
Paste
9 &u ) All using Source theme
Formulas All except borders
Values Column widths
§ Formats Formulas and number formats
E Comments Values and number formats
fl .; Validation
| | Operation
@' None Multiply
| © Add ) Divide
'| Subtract
! :
. Skip blanks Transpose
| [ Paste Link T ere——t
\

Figure 1-22. The Paste Special dialog box.

If the cell in either the source or the destination contains a formula, then the
formula will be enclosed in parentheses and joined to the contents of the
destination cell by the arithmetic operator. You may wish to experiment to see
exactly how this works. Relative references in the source will be changed in the
same way as in a normal Paste operation. You can also Copy cells that contain
formulas and press both the Values button and one of the Operation buttons to
either Add, Subtract, Multiply or Divide.

If you check the Skip Blanks check box, ouly non-blank cells in the source
will be pasted.
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Using Paste Special to Transpose Rows and Columns

If values in the source range are arranged in rows, you can convert the data to
column format, or vice versa, as shown in Figure 1-23,

First, copy the cells, then select a cell or range in which you want the
transposed values to be placed. Display the Paste Special dialog box, check the
Transpose box, then press OK.

- 5] G Y — G
1 pH 6.00 6.20 etc pH Absorbance
2 Absorbance 0.903 0.861 etc 6.00 0.903
6.20 0.861
etc. etc

Figure 1-23. Rows and columns transposed.
(Left) Before using and (Right) after using Paste Special (Transpose).

One limitation of Transpose: The copied cells cannot be pasted over any part
of the source range.

Copying and Pasting a Picture of Cells

In Excel 2003, if you hold down the Shift key while selecting the Edit menu,
the Copy command becomes Copy Picture.... This feature is now found in the
Paste menu in the Clipboard group in the Home tab of the Ribbon. Choose the
"As Picture” command from the submenu to display the Copy as Picture dialog
box (Figure 1-24). You can choose the appearance and format of the copied
cells,

Copy Picture LT S

Appearance '

@ iAs shown on screen; Il

As shown when printed

| Format
| @ Picture
Bitmap

|

Figure 1-24. The Copy Picture dialog box.
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Using Clear

Pressing the Clear button in the Editing group in the Home tab of the Ribbon
displays a submenu with Clear All, Clear Formats, Clear Contents, and Clear
Comments. If you choose Clear Formats from the submenu, for example, you
can remove only formats from selected cells, Choosing Clear Contents will
delete the cell value but not the format.

Excel Tip.  You can add the Clear All toolbutton £ to the Quick Access
Toolbar. See Chapter 23 for instructions on how to customize the Quick
Access Toolbar.

Copy, Cut or Paste Using Drag-and-Drop Editing

You can also copy, cut or paste using Excel's "Drag-and-Drop” method.
With this method you cut and paste or copy and paste a selection by using only
the mouse pointer.

To use this method, Drag and Drop must be enabled. Click on the File tab
and press the Options button (Excel 2010) or click on the Office Button and press
the Excel Options button (Excel 2007). Press the Advanced button and check the
"Enable fill handle and cell drag-and-drop" box in the Editing Options group.

To cut and paste by Using Drag-and-Drop, select the range of cells to be
moved. Position the mouse pointer over a border of the selection (top, bottom or
side). The mouse pointer will change to an arrow. Drag the selection toward the
desired position. The border of the selection will be indicated as you drag it
(Figure 1-25). Finally, position the selection as desired and release the mouse
button.

A = C D E F
1 X 0%
2 [ 0100 2303
3] 0200 -1609 D4:E12 |
4] 0300 -1204
51 0400 0916
6| 0500 -0693 N
i 0.600 -0.511
8| 0700 -0357
9| 080 -0223
10| 0900  -0105
11

S
Ll

Figure 1-25. Cutting and Pasting cells using Drag-and-Drop editing.
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To copy the selection instead of cutting, hold down Ctrl while dragging. A
small plus sign will appear near the arrow pointer.
To insert the selection, hold down the Shift key while dragging. The

insertion point of the selection will be indicated by a horizontal or vertical bar as
you drag (Figure 1-26).

1 X Y

2 0400 0916
3 0500 0693
4 0600 -0511
5 0100  -2.303
6 0200 -1609
74 0300 , -1.204 4
8 ! 0700 L0357 !
9 0800 -0.223
10 0900  -0.105
11

Figure 1-26. Inserting cells using Shift+ Deag-and-Drop.

Duplicating Values or Formulas in a Range of Cells

To copy a value or formula in one cell into a range of cells, highlight the
source cell whose value you want to duplicate, plus the destination cells below or
to the right of where you want the value duplicated. Then click on the Fill button
in the Editing group of the Home ribbon and choose Down, Right, Up or Left
from the submenu.

If the cell contains a number or a text label, the value will be duplicated in
the rest of the cells. If the cell contains a formula, the formula will be copied into
the selected cells, except that Microsoft Excel uses relative referencing when
formulas are copied. For example, if cell A2 contains the formula =A1+1, and
Fill Down is used to copy the formula into a range of cells below cell A2, the
formula copied into cell A3 will be =A2+1, and so on.

Cell references are adjusted when you insert or delete rows or columns, too.
If you insert a new column o the left of column A in the preceding example, the
formula in cell B2, which used to be cell A2, will read =B1+1,

To use the Across Worksheets option in the Fill submenu, you must select
multiple sheets beforehand (see "Selecting Multiple Worksheets: [Group] Mode"
earlier in this chapter). When you choose Across Worksheets from the submenu,
the Fill Across Worksheets dialog box (Figure 1-27) will appear; you can choose
to fill Contents, Formats or both.
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Figure 1-27. The Fill Across Worksheets dialog box.

Absolute, Relative and Mixed References

A relative reference such as A1, becomes A2, A3, etc., as you Fill Down a
formula into cells below the original formula. To keep the address of a cell fixed
when you use the Fill commands, precede both its letter and number designation
by a dollar sign (e.g., $A$1). An absolute reference such as $A%1 remains $A$1
as you Fill Down. You will find this absolute cell addressing useful if you wish

to use a constant in a formula.

Occasionally it is useful to use mixed references. A mixed reference is a
reference such as A$1 or $A1; the row or the column designation, respectively,

will remain constant when you Fill Down or Fill Right.

A B
1 X Y
2 [Co700,1 2303
3| 02001% -1609
4| 0300  -1.204
5| 0400 0918
6| 0500 0693
7| 0600  -0.511
8 | 0700 -0.357
9| 0800 -0.223
10| 0900 -0.105
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0.800

0.900
=]

Y
-2 303
-1.609
-1.204
-0.916
-0.693
-0.511
-0.357
-0.223
-0.105

Figure 1-28. Two views of the same worksheet, showing formulas (left} and values
(right}). The formula in cell A4 has been filled down into AS:A12.
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Relative References When Using Copy or Cut

If you copy and paste a formula, its references will be transferred using
relative referencing. Thus, if you copy the formula =A1+1 from cell A2 and paste
it in cell A10, the formula in cell A10 will be =A9+1, If you copy the formula
from cell A2 and paste it in cell C2, the formula in cell C2 will be =C1+1. (This
is probably not the formula you want.)

On the other hand, if you cut the formula in cell A2 and paste it anywhere in
the worksheet, it will still be the formula =A1+1.

Thus the difference (with respect to cell references) between copy and paste
and cut and paste is that cut adjusts relative references so that they still refer to
the original cells, while copy does not adjust relative references, with the result
that they refer to different cells,

The best way to copy a formula to a different row and column without
altering relative references is to copy it from the formula bar, click the Enter box
10 complete the copy operation, and then paste in the destination cell.

Using Autofill to Fill Down or Fill Right

Excel's AutoFill feature lets you Fill Down or Fill Right simply by using the
mouse pointer. To use AutoFill to Fill Down a formula in a cell, select a cell by
clicking on it. You will see a small black square on the lower right corner of the
selected cell. Position the mouse pointer exactly over the small black square (the
AutoFill handle or simply the fill handlej. The mouse pointer becomes a small
black cross. Click and drag in the usual way to select a range of cells. 1f the cell
contains a formula, it will be copied into the rest of the range just as if you had
used Fill Down or Fill Right; relative references in the formula will be adjusted
appropriately. If the cell contains a number or a text label, the value will be
duplicated in the rest of the cells. With AuwoFill you can also Fill Up and Fill
Left.

Excel Tip.  To Fill Down a value or formula to the same row as an
adjacent block of values, select the source cell and double-click on the fill
handle.

Using Autofill to Create a Series

AutoFill provides an additional feature: you can use it to create a series.
There are several ways to create a series. For example, to create the series of
integers 1, 2, 3, . in column A, you can either:

* Enter the value 1 in cell A1, enter the formula =A1+1 in cell A2, and
then use Fill Down to create the series. You can then use Copy and
Paste Special (Values) to convert the formulas to values.
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+ Use Series... from the Fill submenu of the Editing group in the Home
tab. With Series (Figure 1-29) you enter the start value, the end value
and the increment.

g e

Series
: Series in Type i
| @ Rows @ Linear '
Columns Growth
' Date
AutoFill
H i Trend '
! |
! !
| Step value: Stop value:
. oK ; ' Cancel
!\: Er S B N 0

Figure 1-29. The Series dialog box.

* Use AutoFill, This is by far the simplest and most convenient method.
If you select a cell containing a number formatted as a date or time, or
a text label containing a number, and use AutoFill to fill a range of
cells, AutoFill creates a series using the selected cell as the starting
value. The value of the series being entered in the active cell is
displayed in a Screen Tip box as you drag the AutoFill handle.

If you select a cell containing a date, Excel will create a date series. For
example, if you select a cell containing 29-Jan and use AutoFill to Fill Right, the
series 29-Jan, 30-Jan, 31-Jan, 1-Feb, 2-Feb... will be created. A cell containing
the text "Sunday" will produce the series Sunday, Monday, Tuesday,...; "Sample
1" preduces Sample 1, Sample 2, Sample 3,....

If you select two cells, AutoFill will create a series based on the cells you
select, as shown in the second and third examples of Figure 1-30.

Excel Tip.  To prevent AutoFill from creating a sevies, hold down the Ctrl
key as you position the black cross pointer over the fill handle. A small plus
sign will appear to the right of the black cross pointer. Click and drag in the
usual way to fill rather than create a series.
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Figure 1-30. Some examples of the use of AutoFill to produce a series. (Above) Cells
before using AutoFill. (Below) Series produced by AutoFill.

The AutoFill Shortcut Menu

If you use the right mouse button to drag down the Fill Handle to create a
date series, a shortcut menu will be displayed when you release the mouse button
(Figure 1-31).

You can then choose to create a series of consecutive dates (Fill Days), a
series consisting only of weekdays (Fill Weekdays), a series consisting of a
single date in each month (Fill Months) or a series consisting of a single date in

each year (Fill Years).
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Copy Cells

Fill Series

| Fill Formatting Only

| Fill Without Farmatting

Fill Days '

| Fill Weekdays N
4 |

Fill Months

Fill Years

Series. ..

Figure 1-31. The AutoFill shorteut menu.

Formatting Worksheets

You can use commands in the Home tab of the Ribbon to change and
improve the appearance of the worksheet and to modify the way number values
are displayed.

Using Column Width... and Row Height...

When Excel creates a blank worksheet, all rows are the same default height,
all columns the same width. You can change the width of columns, or the height
of rows, to improve the appearance of a worksheet or to eliminate wasted space
so that you can get more information on a single page. You can also hide rows or
columns by reducing their height or width to zero. The data they contain will
still be still there, but it will be hidden.

To change the width of a column or the height of a row, click on the Format
button in the Cells group in the Home tab of the Ribbon, then choose from the
Cell Size group in the drop-down memi, You can enter a value for the height of
a row or width of a column (one width unit corresponds to the width of one
character of the current font). Column widths and row heights can also be
adjusted by choosing the appropriate Autofit option from the submenu. You can
adjust the column width or row height to fit a single selected cell or a range of
cells, or to be the best fit to the widest entry in a whole column or row.
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Figure 1.32, The Format menu,

You can also change the column width by using the mouse pointer. Place the
cursor on the separator bar between cohumnn headings, on the right of the column
whose width you want to change. The cursor changes to a double-headed arrow:

4+V. Click the mouse button and drag to the right or left to change column width.
The column width is displayed in an "InfoBox" as you drag the separator bar.

Excel Tip. To adjust several columns at a time fo the same width, select the
columns and then perform the column width adjustment with the mouse
pointer on any of the selected columns. When you release the mouse buiton,
all the columns will have the adjusted width. You can also get a "best fit"
simply by double-clicking on the row or column separator bar. To adjust
several rows or columns at once, select the columns and double-click on any
row or column separator bar.



42 Excel for Chemists

Formatting Cells

Formatting allows you to change the appearance of values in cells. You can
format cells either by using icons in the Home tab of the Ribbon, by using
toolbuttons on the Quick Access Toolbar, by using the Mini Toolbar, or by
clicking on the Format Cells.., command to display the Format Cells dialog box.

The Mini Toolbar

The Mini Toolbar is a formatting toolbar that can be used to format text. It
appears automatically when you select (highlight) the contents of a cell, either in
the cell or in the Formula Bar. A faint image of the Mini Toolbar will appear
above the text. If you move the mouse toward the Mini Toolbar, the image
intensifies; if you move the mouse away, it fades. If you do neither, it
disappears after a few seconds.

Arial - 10 ~

BI.{_'A‘A'-

|M | ![nrrc&sa Font Size |
4 b ———————— S

Figure 1-33. The Mini Toolbar appears when formatting text in a cell.

A different Mini Toolbar appears when you select text in a chart.

Calibri(E~ 18 -~ A" A" i i Gy

Chart Tit!eg et

M,M o s bl
’M-“"

Figure 1-34. The Mini Toolbar appears when formatting text in a chart.

i

In Excel 2010 only, if you click on the drop-down list of fonts or font sizes
and move the mouse downwards to hover over a font or size from the list, the
text in the cell will temporarily display the formatting.
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Figure 1-35. Using the Mini Toolbar to change font size.

If you right-click on an object — a cell, textbox, row, column, etc. — you will
display a shortcut menu with commands appropriate for that object, plus a Mini
Toolbar.

To disable the Mini Toolbar in Excel 2010, click on the File tab and click on
the Options button. Click on the General options button and uncheck the “Show
Mini Teolbar On Selection' box. For Excel 2007, ¢lick on the Office Button and
click on the Excel Options button. Click on the Popular options button and
uncheck the "Show Mini Toolbar On Selection' box.

The Format Cells Dialog Box

The Format Cells dialog box is identical to the dialog box in Excel 2003. To
display the dialog box, click on the Format button in the Cells group in the Home
tab of the Ribbon. Click on Format Cells in the drop-down menu (Figure 1-32).

The Format Cells dialog box has Font, Alignment and Number tabs to format
values within cells, Border and Patterns tabs to format cells, and the Protection
tab to set the security of values within cells, The possibilities for Font,
Alignment, Border and Patterns are many and varied, and only some of these
possibilities will be discussed here. Number formatting is important for scientific
spreadsheets; it is discussed in detail in a following section.

Excel Tip. Click on the small button = at the bottom right of the Font,
Alignment or Number groups in the Home tab of the Ribbon to display the
complete Format Cells dialog box.
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Using Alignment

The Alignment tab in the Format Cells dialog box provides a number of
formatting options for the alignment of values in cells. There are option buttons
for both horizontal and vertical alignment (Figure 1-36). The Vertical orientation
options are useful if you want to add a text label to a narrow column. The
Orientation "inclinometer” allows you to display text on any angle.

-

Format Cells

Text alignment Orientation

| | Horizontal: [ ile |
General v1| Inde ' ' IR
Vertical: o = |
Bottom =l

| Text control
| wrap text "0
& Shrink to fit

; || Merge cells

{ | Right-todeft
Text direction:

1 ——
Context 1 v]

Figure 1-36. The Alignment dialog box.

To use the Merge Cells option, first select the range of cells to be merged,
check the Merge Cells box and press OK. You can also use the Merge and
Center button in the Alignment group in the Home tab of the Ribbon, or
customize the Quick Access Toolbar with the Merge and Center toolbutton (see
Chapter 23 for instructions on how to customize the Quick Access Toolbar).

1 Centered Across Selected Columns
2

Figure 1-37, Using Merge and Center.

For the most common horizontal alignment options you can use the
alignment toolbuttons 2E ¥E& I in the Alignment group in the Home tab of
the Ribbon to align text in cells left, centered or right, respectively.
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Figure 1-38. Examples of using Wrap Text.

You can also format a text entry in a cell so that the text wraps and is
displayed in more than one line (Figure 1-38), by checking the Wrap Text box in
the Format Cells dialog box. Excel breaks the text at a space character. Text can
be aligned vertically and wrapped.

If you select text in a text box, the Alignment button is not active. To change
the alignment of text in a text box, you must press the Orientation button in
the Alignment group. Only vertical orientations are available.

o X -- o)

1§

{ | Font: Font style: '
|| Calibri | Regular
: | | Italic &
{ | Agency ' |Bold B
i | | Aharoni {Bald Italic ;
| P Algerian ' :
| Underiine: Color:
| None [v] || ¥ Normai font
I Effects Preview
S e i v
I Superscript AaBbCcYyZz
| Subacript i it e SR o ]

| Thisis a TrueType font. The same font will be used on both your printer and your soreen,

i —

Figure 1-39. The Font dialog box.
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Using Font

The Font tab (Figure 1-39) in the Format Cells dialog box allows you to
format cells in any of the installed fonts. In addition, you can format individual
characters in various font styles or sizes, or as strikethrough, superscript or
subscript characters.

You can also use Greek letters, as shown in the text box example in Figure 1-
16, by formatting the Roman letter using the Symbol font. Of course, you must
know the correspondence between Roman and Greek letters: The Roman S
becomes the Greek X, for example.

The Alternate Character Set

You can enter symbols that are in the so-called alternate character set; an
example is shown in Figure 1-40. The characters produced may be different for
each different font.

A
1 T; %
Figure 1-40, A special character (°) typed by using the alternate character set.

The characters are obtained by holding down the Alt key and typing the four-
digit ASCII code for the character, using the numeric keypad. (If you're using a
laptop without a numeric keypad, you'll need to hold down both the Fn and the
Alt keys and then press the keys labeled with small digits 1 — 9, color-coded to
match the Fn key.)

Table 1-5. Some Useful Alternate Characters

symbol 4-digit code symbol 4-digit code
€ 0128 (Euro) B 0223  (Greek beta)
£ 0163 (Pound) w0181 (Greek mu)
¥ 0165 (Yen) A 0197 (Angstrom)
. 0149  (bullet) 0160 {(unbreakable space)
. 0183  (centered dot) ° 0186  (superscript)
x 0215  (multiply) ! 0183  (superscript)
+ 0247 (divide) 2 0178  (superscript)
* 0177  (plus or minus) 3 0179  (superscript)
° 0176  (degree) — 0151 {(em dash)

If you use a different font, you'll have to experiment to see what alternate
characters are produced.
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The range of useful characters obtainable in this way is rather limited. Table
1-5 shows some useful characters obtained using the Arial font. The complete
set of alternate characters is listed in Appendix J.

Entering Subscripts and Superscripts

You can enter subscripts and superscripts in text, as in Figure 1-41. First,
highlight the characters to be subscripted or superscripted, either in the formuia
bar or directly in the cell. Choose the Font tab in the Format Cells dialog box,
check the Subscript or Superscript check box (see Figure 1-39), press the OK
button, and then enter the text by pressing the Enter key or the Enter button.

A
1 CyHz01

2 BaCly2H,0

3 H,S0, + 2NaOH == Na;S0; + 2H,0

Figure 1-41. Subscripts in Excel.

Using Border and Patterns

The Border tab in the Format Cells dialog box allows you to place a border
around one or more sides of a selected cell or range. This is useful if you want to
emphasize comments, instructions or values. The Patterns tab is used to change
the background color or pattern of cells.

BOSTON COLLEGE OATE 41511996

CQFFICE OF THE UNIVERSITY REGISTRAR

CHESTNLUT HILL, MASSACHUSETTS 02167 ACADEMIC YEAR 1996

SEMESTER 965
COURSE CH 222 01 INTROANORGANIC CHEM
INSTRUCTOR BILLC, E JOSEPH
MEETING PLACE
STUDENT'S NAME |10 NUMBER | HOOL | GLASS | MaJOR CREDIT GRADE

Figure 1-42. Using Border to create a custor report form,
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The Border option is often used to underline headings, or in a sheet in which
the gridlines have been removed, to create a custom form. Figure 1-42 shows a
portion of a sheet produced in this way. To remove the existing gridlines, click
on Options in the Office Button window or in the File tab, click on Advanced,
and in the "Display options for this worksheet” group, and uncheck the Show
Gridlines box.

The built-in template sheets provided with Excel (click on New in the File
tab in Excel 2010 or click on New in the Qffice Button window in Excel 2007)
are good examples of the use of Border and Patterns to create custom forms.

Using the Format Painter Toolbutton

The Format Painter button in the Clipboard group in the Home tab of the
Ribbon, or the Format painter toolbutton ., copies and pastes formats from one
cell or range to another cell or range. To use it, do the fotlowing: Select the cell
or range with the desired format(s), click the Format Painter toolbutton (this
copies the formats), and click on a cell or drag across a range of cells to paste the
format(s).

Excel Tip. To use the Format Painter button to "paint" a format on a series
of non-adjacent cells or ranges, select the cell with the desired format, and
then double-click on the Format Painter button. This will keep the button in
the "pressed” position, allowing you to click on several cells or ranges to
paste the format. When you're done, click once on the button to return it to
the "unpressed” state.

Number Formatting

The formatting described in the preceding sections — bold text, italic text,
alignment of text, adjusting column widths, etc. — is sometimes referred to as
swylistic formatting. In addition, it is possible to change the way number values
are displayed in cells. This type of formatting, called number formatting, is
described in the following sections.

Using the Number Formatting Toolbuttons

You can also format number values in cells by using the number formatting
toolbuttons shown following,

60 Increases the number of decimal places.
oo Decreases the number of decimal places.

% Formats the number in percent style, with no decimal places.
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Formats the number in curtency style, with two decimal places.

Formats a number with commas and two decimal places.

Excel Tip. There isn't a toolbutton to format number values in scientific
Jormat. You can apply scientific format conveniently by using the shortcut
key sequence Cirl+Shift+". See Appendix E for a complete list of shortcut

keys.

Using Excel's Built-In Number Formats

To change the way a number is displayed in a cell, click on the drop-down
list box button (labeled "General") at the top of the Number group in the Home
tab of the Ribbon. The list, shown in Figure 1-43, displays most of the available
Number, Currency, Date, Time, Percentage,

number format categories —

Scientific, etc,

%
R
10

General - |

Mo specific format

Number
40317.00

Cuwrrency
540,317.00

Accounting
540,317.00

Short Date
5/19/2010

Long Date
Wednesday, May 19, 2010 |

Time
12:00:00 AM

Percentage
4031700.00%

Fraction
40317

Scientific
4.03E-04

More Number Formats...

Figure 1-43. The Number Format drop-down menu.
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For example, selecting a cell and then choosing Number from the list of
categories will display the value in the cell to two decimal places (the default);
you can change the number of displayed decimal places using the Decimal Places
box. You can also display values as percentages or in exponential notation, for
example,

Another route to number formatting is to click on the Format button in the
Cells group in the Home tab of the Ribbon and then click on Format Cells in the
drop-down menu (Figure 1-32). Click on the Number tab to display the Number
Format dialog box (Figure 1-44). The number formats in the Category list
correspond to the formats shown in Figure 1-43.

-

Format Cells R X

m— 1 e . I - 1 -
r il Alignment | Font | Border | Fill | Protection

Category:
|| [

Sampie

| | {Currency

[ | | |Accounting General format cells have no specific number format.
] iDate

i1 |Time

I | | |Percentage

| Fraction

.[ o;( f i

Figure 1-44. The Number Format diatog box.

The appearance of the Number dialog box will be different, depending on the
number format category you select.

If you choose the Custom category, you will see the number formatting code
that was applied to the cell. If you scroll through the list of codes, you'll see that
many of them are quite complex (see Figure 1-45). For the meaning of the built-
in number format code symbols, see Table 1-6 or go to "Number Format Codes"
in Excel's On-Line Help.
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Custom Number Formats

You can create your own custom number formats. First, choose the Custom
category from the list of number formats, This will display the list of (so far)
built-in number formats. To add a new, user-defined number format (it will be
added at the bottom of the list), type the format in the Type box. For example, if
you want to display numbers to four decimal places, type 0.0000 in the Type
box. The new format will be stored in the list of formats so that you can apply it
to other cells; the format is available in all sheets in the workbook.

Table 1-6 lists the formatting symbols you can use to create your own custom
formats.

I ¢ : LY 1l
| Format Cells Lo . S,

. D I T TR
Number | Alignment | Font | Border | Fil | Protection

Category:
General " Sampie

| Number

{Currency

| Accounting Type:

|Date

i Time

|Percentage
Fracton

| Scientific

General

SeRlaiaTnl .

000; [Re"é(
J_} (5=,220)

,£20_);Red](8%, v

&'0 00}

Tvpe the number format code, using one of the existing codes as a starting point.

R
) |
W
2
Il
o

Figure 1-45, The Number Format dialog box showing number formatting codes.

For example, to format a column of telephone numbers, use the custom
format (##3) #f- #### This will format a cell entry such as 6175523619 in the

atomic weight values shown in Figure 1-47, so that they are aligned on the
decimal. (Note that, since the format contains seven ? symboels and the atomic
weight of Na has only six digits to the tight of the decimal point, there is an
additional space to the right of the number.)
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A B

H 1.00797

0 15.9994
Na 22 939768
4 S 32.066

Figure 1-46. Values aligned on the decimal point by using the ? formatting symbol.

You can create some fairly sophisticated number formats. For example, the
format $#.0,, (dollar sign, number sign, period, zero, comma, cornma) formats
financial entries rounded to millions, with one decimal; the value 21180000 is
displayed as $21.2.

You can use number formatting to add umits to a number value. For
example, the format #” g" appends the grams unit g to a number value; the value
50 is displayed as 50 g, as shown in Figure 1-47.

A
A\

1 50g

Figure 1-47, Units added to a value by means of number formatting,

Table 1-6, Number Formatting Symbols

< gk

“text"

[RED]

Placeholder for digit.

Placeholder for digit. Displays an extra zero if the number has
fewer digits than the number of zeros specified in the format.
Placeholder for digit. Same as 0, except that a space character is
displayed. Also used when formatting a number as a fraction.
Thousands separator (if used with # or 0). Used alone, it rounds
and truncates to the thousands place (millions place if two
commas are used, etc.)

Converts to percent.

Converts to scientific format. Use E- to include sign with
negative exponents only, E+ to include sign with both positive
and negative exponents,

Converts to a fraction. Usually used in the form # 72/?7 or
##/##. The number of ? or # symbols determines the accuracy of
the display.

Text characters can be included in a format by enclosing them in
quotes. You can sometimes get away without the quotes, but it's
safer to use them.

Text placeholder. If the cell contains a text entry, the text is
displayed in the format where the @ symbol appears.

Displays the characters in the cell in red. You can also use
[BLUE], [GREEN], [YELLOW], etc.
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Custom Date Formats

You can create custom date formats by using the year, month and day
formats listed in Table 1-7. Day or month formats can have one-, two-, three- or
four-letter formats; year formats can have either two- or four-letter formats. For
example, the number format dddd, mmmm d, yyyy applied to a date entered as
8/3/38 will display Wednesday, August 3, 1938,

Table 1-7. Date Formatting Symbols*

d Displays the day as a number without leading zeros (1-31)
Displays the month as a number without leading zeros (1-12)

dd Displays the day as a number with leading zeros (01-31)

mm Displays the month as a number with leading zeros (01-12)

ddd Displays the day as an abbreviation (Sun-Sat)

mmm Displays the month as an abbreviation (Jan-Dec)

dddd Displays the day as a full name (Sunday-Saturday)

mmmm  Displays the month as a full name (January-December)

vy Displays the year as a two-digit number, ¢.g., 97

YYYY Displays the year as a four-digit number, e.g., 1997

* See Chapter 12, "Other Language Versions of Excel", for date formatting
symbols for some other languages.

Time Formats
Excel's built-in or custom time formats use the symbols in Table 1-8,
Table 1-8. Time Formatting Symbols

h Displays the hour without leading zeros (0-23)

hh Displays the hour with leading zeros (00-23)

m Displays the minutes with leading zeros (0-59)

mm Displays the minutes with leading zeros (00-59)

s Displays the seconds without leading zeros (0-59)

S8 Displays the seconds with leading zeros (00-59)

5.000 Displays seconds to the millisecond

AM/PM  Displays the hour as AM or PM instead of 24-hour time
[h] Displays elapsed time in hours

[h]):mm Displays elapsed time in hours and minutes
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Variable Number Formats

Different number formats can be applied to positive, negative, zero and text
values entered into a cell, A complete format consists of four sections separated
by semicolons, for positive, negative, zero and text values, respectively. If only
one number format is specified, it applies to all values. If two number formats
are specified, then the first one applies to positive numbers and zero, the second
to negative numbers, For example, the format $####;[Red])$# ### formats
positive amounts in black, Excel's default color, and negative amounts in red.

Conditional Number Formats

Conditional number formats can be created by using the syntax [condition,
value] format statement. Condition is one of the symbols <, >, =, >=, <=, <>;
value may be any number. Format statement may be any built-in or custom
format. For example, the number format

[>1] "Number too large"
displays any input less than 1 but otherwise issues an error message.
Several conditions may be combined using semicolons. The number format
[>99914 #4,,%;#" ppm"
displays the values 110 and 21560 as 110 ppm and 2.16%, respectively.

Formatting Numbers Using "Precision as Displayed"”

To permanently change all values stored on a worksheet to their displayed
values, use the Precision As Displayed option. Once this command has been
invoked, you can't restore the original values.

To apply Precision as Displayed, click on the File tab and press the Options
button (Excel 2010) or click on the Office Button and press the Excel Options
button (Excel 2007); click on Advanced and check the Set Precision As
Displayed box. Because this is an irreversible change, Excel asks you to confirm
the change. '

To change only a selected range of values to "precision as displayed", use the
FIXED worksheet function (see "Text Functions" in Chapter 3).

Excel Tip. You can apply the same formatting to multiple worksheets simply
by grouping the sheets (click on the first sheet tab in the range of sheets to be
Jormatted, then hold down the Shift key and click on the last sheet in the
range). When you apply the desired formatting fo the active sheet, it will be
applied to all sheets in the group.
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Conditional Formatting (Part I)

The number formatting tools that we have seen described in preceding
sections can only change the way the number appears in the cell: as a floating
point number, in scientific notation, etc. But none of the number formatting tools
allows you to apply stylistic formatting to a cell based on the value in that cell —
to display a number in italics if it is negative, for example. Conditional
formatting provides this capability.

Conditional formatting allows you to do one of two things: to apply stylistic
formatting to a cell based on the value in that cell, or to apply formatting to a cell
based on values in several cells (in the same or different worksheets or
workbooks). The former — formatting a cell based on the value in that cell —
will be described here; the latter will be reserved for Chapter 3, Excel Formulas
and Functions,

Conditional formatting has been improved significantly in Excel 2007/2010.
In Excel 2003, you can format cells that contain values that satisfy one of eight
criteria: between, not between, equal to, not equal to, greater than, less than,
greater than or equal to, Jess than or equal to. In Excel 2007/2010 many more
criteria can be applied in addition to the ones listed. Other possibilities include
highlighting cells that contain error values, specified text or date values,
duplicate or unique values, top N values (e.g., top 10), top Nth percent, above or
below average. Figure 1-48 illustrates some of the most popular options
provided by Excel 2007/2010 conditional formatting.

As an example of the use of conditional formatting, consider the case of a
worksheet that contains a column of values. If any value in the column is above
90 (for example), the measurement is out of range and needs to be examined
more closely. You can flag these out-of-range values with conditional
formatting. After highlighting the range of cells to be formatted, click on
Conditional Formatting in the Styles group of the Home tab, click on Highlight
Cells Rules in the drop-down list, and then click on Greater Than... in the
submenu, to display the Greater Than dialog box. Enter the value 90 as the
criterion, choose Light Red Fill as the format, and press OK. The cells satistying
the criterion will be highlighted, as illustrated in Figure 1-50.
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' New Rule...

Top/Bottom Rules »

Data Bars 4

Color Scales b

Icon Sets .

A Date Occurring...
Clear Rules k

Manage Rules... i
; rr S Duplicate Values...

' More Rules...

Figure 1-48. Some of the choices for Conditional Formatting.

r

Greater Than

Format cells that are GREATER THAN:

e

Lok ][ cone |

Figure 1-49. The Greater Than dialog box.
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1 7.88248
2| 86.42525
3 | 27.06193
4| 7087202
6 | 735115
7 | 22.08262
8 7431941
9 | 13.85085
10 | 88.59572
11 11.99503
12| 5.40923
13| 96.69842
14| 751717
15 29.25795

Figure 1-50. A portion of a range of cells with conditional formatting.

f

| Select a Rule Type:

» Format all cells based on their values

» Format only celis that contain

i | » Format only top or bottom ranked values

' » Format only values that are above or below average
E » Format only unique or duplicate values

» Use a formula to determine which cells to format

| Eormat... |
i

Figure 1-51. The New Formatting Rule dialog box.
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Users more comfortable with the Excel 2003 Conditional Formatting dialog
box can choose More Rules.., in the Highlight Cells Rules submenu (see Figure
1-48) to go directly to the New Formatting Rule dialog box, shown in Figure 1-
51. This dialog box provides a greater range of formatting options than the built-
in options of, for example, the Greater Than dialog box shown in Figure 1-49,

In addition to formatting cells with font color, cell border or cell background,
the Excel 2007/2010 conditional formatting allows you to flag cells with data
bars, color scales, or icons. The gallery of icons is shown in Figure 1-52.

i g

Conditional] Format  Celi
Formatting v as Table ~ Styles -

—:i Highlight Cells Rules * |

Hi Top/Bottom Rules  » |

' E[ Data Bars ’

| E Color Scales v
T mm— e S Y
. e ® ®00

4] New Rule.. | -

A @aoe 940
2% Clear Rules g E G
@00 £1n

(%] Manage Rules...

+AuS 2RANY
. . ol all wl llfl

0000 3w
ﬁa@%{} el all wl ni“:
XX XcXe |

More Rules..,
Figure 1-82. The gallery of Conditional Formatting icons.

Like other formatting, you can apply a conditional format to a range of cells
or apply it to one cell and then Copy it to other cells.
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Printing Documents

Commands for printing documents are located in the File tab of the Ribbon
(Excel 2010) or in the Office Button window (Excel 2007). :

Excel 2010. If you click on the Print button in the File tab, a dialog box is
displayed (Figure 1-53) that contains most of the options in the Excel 2003
Print... and Page Setup... menu commands. You can choose pages to be
printed, number of copies, two-sided printing, collated sheets, portrait or
landscape orientation, paper size, margins, etc. For users more comfortable with
the Excel 2003 Page Setup dialog box, there is a Page Setup hyperlink at the
bottom right corner of the dialog box; see the following section for a description
of the Page Setup dialog box. The Print Preview view of the document (not
shown in Figure 1-53) is also displayed on the right side of the window.

Home Insert Page Layout Formulas Data Review

Printer

.3_1". hp Laser)et 1320 PCL6 on JOSEPH

.

Setlings

Print Actrve Sheets

Share
Pages: . to
Help 1
| Print One Sided
AT, e oF i i
:] Options
I_L‘; Exit ’ :=‘r!!=ﬂtfd : -
Portrait Orientation v

| Letter
MNormal Margms

| No Scaling

D Print chaetc af —
M shee { their adiua

Fignre 1.53. The Excel 2010 Print window.
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Excel 2007. If you click on the Print button in the Office Button window, the
"Print and preview the document” window is displayed (Figure 1-54).

i Preview and print the document

Nev

i b Print
i | WJe Select a printer, number of copies, and
Cpen other printing options before printing.

4.5 Quick Print i g
w7 Send the workbook directly to the default HE
printer without making changes. i

% Print Preview Bk

- Mﬁ» Preview and make changes to pages before ‘ 1
' printing.

EF'.-E'Ft L

Prepare ¥

{:‘3 Send »

Publish *»

close

| =] Excel Options |1 X Extt Excel

Figure 1-54, The Excel 2007 "Print and preview the document" window.

Choosing Print in the "Print and preview the document” window displays the
Print dialog box, identical to the Excel 2003 dialog box (see Figure 2-44 in
Chapter 2), which allows you to specify the pages to be printed, and the number
of copies. You can also select a printer, if you have more than one printer
connected.

Choosing Print Preview in the "Print and preview the document” window
activates the Print Preview tab of the Ribbon (Figure 1-55). The Page Setup
button displays the Page Setup dialog box, identical to the Excel 2003 dialog
box.
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Figure 1-55. The Excel 2007 Print Preview tab of the Ribbon.

Print Preview is useful in other ways besides showing what your finished
worksheet will look like when printed. If you preview your worksheet and then
return to the document window, page breaks will be displayed on the worksheet
as dashed lines, to assist you in adjusting colurmn widths, for example, before
printing.

Using Page Setup

The Page Setup dialog box, identical to the Excel 2003 version, contains four
tabs: Page, Margins, Header/Footer, and Sheet. These dialog boxes are shown in
Chapter 2, Figures 2-40, 2-41, 2-42 and 2-43. Use the Page tab to choose Portrait
or Landscape orientation. Use the Margins tab to change margins, Use the
Header/Footer tab to select header or footer text from a list of built-in options or
create a custom header or footer. Use the Sheet tab of the Page Setup dialog box
to enter a Print Area (range of cells that will be printed) or Rows To Repeat At
Top (row or rows that will be printed at the top of each printed page), or to turn
on or turn off the printing of gridlines, row and column headings, etc.

Excel Tip. Click on the small burton '+ at the bottom right of the Page Setup
or Sheet Options groups in the Page Layout tab to display the Page or Sheet
tab of the Page Setup dialog box.

A new document has no header and no footer; these are the default values.
To enter a header or footer, choose the Header/Footer tab in the Page Setup
dialog box, which will display list boxes with a wide range of buili-in formats for
header and footer. You can also create custom headers or footers by pressing the
Custom Header.., or Custom Footer.., button. The Header or Footer dialog boxes
are identical; each enables you to enter filename, sheet name, page number, date,
time or other information.

To adjust margins, use the Margins tab of the Page Setup dialog box, or click
on the Page Layout tab of the Ribbon and click on the Margins icon to display
the drop-down menu of margin settings (Figure 1-56).
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Page Layout
W U)o e | e s
IMargins| Orientation Size  Print Breaks Background Print
o v Area ~ . Titles
Normal :
Top: 0.75° Bottom: 0,75 |
left: 0.7 Rignt: 077 ¢ B Z U B
| | Header 0.3° Footern 03" |
1 Wide
[ Top: 1 Bottom: 1
Left: 1 Right: 1
______ -4 Header: 0.5 Footer: 0.5
Narrow i
Top: 0.75 Bottom: 0.75" |
Left: 0.25 Right: 0.25
Header: 0.3° Footer 0.3

Custom Margins...

Figure 1-56. The Page Layout tab of the Ribbon, showing the Margins drop-down
menu.

To squeeze the maximum amount of worksheet information on a single page,
you can decrease the margin widths. The default margin values are 0,75 inch left
and right and 0.7 inch top and bottom. If you set the margins to zero, any header
and footer information will still be printed, usually right on top of data in your
worksheet, so delete the header and/or footer information by choosing “(none}"
from the list box.

You can choose Print Row And Column Headings and/or Print Cell Gridlines
by choosing the Sheet tab in the Format Cells dialog box. If you de-select Cell
Gridlines, they will still be displayed on the screen but they will not be printed.

You may need to use Print Black and White if your worksheet uses color.
Colors may be printed as various patterns by your printer; to remove the paiterns
and produce text in cells in black and white, check the Print Black and White
Cells box.

Using Print
If you choose the Print command and simply press the OK button, Excel will

print the rectangular array of sheets that includes all filled cells. [t’s a good idea
to use Print Preview before printing; the total number of pages to be printed will
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be displayed in the status bar. This will tell you whether you can print the whole
worksheet, or whether you need to specify a range of pages to be printed.

If you choose Print Preview or Page Setup, Excel displays the automatic page
breaks as dashed lines in the worksheet. You can insert a forced page break if
you want to print a portion of a worksheet page. To insert a horizontal page
break, select an entire row as if you were going to insert a row. Then click on the
Breaks button in the Page Setup group in the Page Layout tab of the Ribbon, and
choose Insert Page Break from the submenu. The page break will be inserted
immediately above the selected row. A forced vertical page break is inserted in a
similar fashion, the page break is inserted immediately to the left of the selected
column, If you want to insert both a vertical and a horizontal page break, select a
single cell within the worksheet; the page breaks will be immediately above and
to the left of the cell.

Printing a Selected Range of Cells in a Worksheet

To print a selected range of cells within a worksheet, you must first select
(highlight) the range to be printed.

Excel 2010. Choose Print in the File tab of the Ribbon and press the drop-
down button at the right of Print Active Sheets to display the drop-down menu
shown in Figure 1-57, Click on Print Selection. Then press the Print button.

| Print Active Sheets
' Only print the active sheets
i | Print Active Sheets
i | Only print the active sheets

Print Entire Workbook
Print the entire workbook

Print Selection
Only print the current selection

Ignore Print Area

Figure 1-57, The Print Active Sheets drop-down menu.

Excel 2007. Choose Print from the Office Button window. Press the
Selection button in the Print What category box in the lower left corner of the
dialog box. Then press the Print button.
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Using Set Print Area

To specify a range of cells to be printed each time you choose Print, you
must use Set Print Area. You can do this in at least two different ways:

» Display the Page Setup dialog box (see earlier), and choose the Sheet
tab. Click in the Print Area text box to select it. Now select the range
of cells that you want to print (you can move the dialog box out of the
way if necessary), and press the OK button. To cancel a Print Area
selection, delete the reference within the Print Area text box.

¢ First, select the range of cells to be printed, then press the Print Area
button in the Page Setup group in the Page Layout tab of the Ribbon,
and choose Set Print Area from the submenu. The range to be printed
will be indicated by Page Break lines. Choose Remove Print Area
from the submenu to cancel the Print Area,

If the Print Area you selected requires more than one page, you can go to
Page Setup and change the value in the Reduce/Enlarge box to less than 100%.
Sheets printed with values less than about 60% are difficult to read, though. To
obtain the appropriate reduction value automatically, after you've selected the
area to be printed, choose the Page tab and press the Fit To 1 Pages Wide By |
Tall button.

Printing Row or Column Headings
for a Multi-Page Worksheet

If you are printing a multi-page worksheet, you can duplicate row or column
headings antomatically on each printed page. Click on the Print Titles icon in the
Page layout tab of the Ribbon, or display the Page Setup dialog box and choose
the Sheet tab. Select the Rows To Repeat At Top or the Columns To Repeat At
Left text box by clicking the cursor in it. Now select the range of cells that you
want to have printed on every page as a title (you can move the dialog box out of
the way if necessary). Then click the OK button. The headings will appear at the
top or left of each printed page.

Protecting Data in Workbooks

First of all, we should distinguish between security and protection. Security
means protecting your computer from viruses. Protection means preventing users
from modifying documents or viewing particular workbooks, worksheets or
formulas; a number of ways of protecting data will be described in the following
sections,
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Protecting a Workbook

You can protect the structure of a workbook so that worksheets in the
workbook can't be moved, deleted, hidden, unhidden, or renamed, new
worksheets can't be inserted, and windows are the same size and in the same
position each time the workbook is opened. Values and formulas in the
workbook can still be modified, though; to prevent this, see "Protecting a
Worksheet" later in this chapter.

To protect a workbook, click on Protect Workbook in the Protection group in
the Review tab of the Ribbon, and choose Protect Structure and Windows from
the drop-down menu, to display the dialog box (Figure 1-58).

Protect Structure and Windows lg@

i g%
| Protect workbook for 5

i/ Structure

|| Windows

Password {optional):

A

Figure 1-58. The Protect Workbook dialog box.

Check the boxes for Structure and/or Windows, enter a password if necessary
(you will be asked to confirm it), and then press OK.

Protecting a Workbook
by Making It a Read-Only Workbook

If you make a workbook read-only, users can view formulas in cells, and
change values and formulas, but the changes cannot be saved.

To make a workbook read-only, the document should be closed. In the
Windows Start menu, choose Programs, and then Windows Explorer. In the
Exploring window, open the drive or folder that contains the file and select the
document name. Choose Properties from the File menu, choose the General tab,
and check the Read-only check box.,

Hiding a Worksheet

To hide a worksheet, click on the Format button in the Cells group in the
Home tab of the Ribbon, choose Hide & Unhide in the drop-down menu, and
choose Hide Sheet in the submenu. However, anyone can view this sheet simply
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by choosing Unhide from the submenu. You can hide a sheet so that most users
can't view it, by using VBA: you set the Visible property of the sheet to
VeryHidden, as described in the following paragraph. You may need to read
Chapter 16, "Visual Basic for Applications: An Introduction”, {irst.

To make a sheet VeryHidden, switch to the Visual Basic Editor by pressing
Alt+ F11. If the Project Window is not visible, display it by pressing Ctrl+R. In
the hierarchy tree for the desired workbook, click on the name of the sheet you
wish to hide. '

If the Properties Window is not visible, display it by pressing F4. In the
Properties Window, locate the Visible property (at the bottom of the list when the
Alphabetic tab is selected). Click on the Visible box; this will cause a drop-down
list button to appear in the properties list. Choose the xiSheetVeryHidden
property, as shown in Figure 1-60.

Properties - Sheet3 e

[r= .
|| Sheet3 Worksheet -

Alphabetic | Categorized |

) Sheet3
{Dzsoia‘-,'PageBrea%as False
DisplayRightToLeft False
EnableAutoFilter False
EnableCalculation True
EnableQutlining False
EnablePivotTable False
EnableSelection 0 - xiNoRestrictions

qiNan

hame Sheet3
Scrollarea
StandardWidth 8.43

gy
.
¥

Figure 1-59. The VBA Properties Window.

When vou switch back to the Excel workbook, the sheet tab will not be
visible and the sheet name will not appear in the Unhide Sheet submenu.
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Protecting a Worksheet
by Locking or Hiding Cell Contents

You can lock cells (prevent them from being selected by the user) or hide the
contents of the cells. For example, you may want the user to be able to enter
values in certain cells while protecting the rest of the worksheet. If you protect
cells in this way, before you access the Protect Sheet dialog box you must specify
which cells will be protected or unprotected. You do this by using the Format
Cells menu.

The process for doing this is somewhat complicated. First you select cells to
be locked or unlocked, or cells whose contents will be hidden or visible, and set
their status using the Protection tab of the Format Cells dialog box. Then you put
the status into effect by choosing Protect Sheet from the Format drop-down
menu.

Before you begin, it's important to know that when a new worksheet is
opened, the status of @i/ cells in the document is Locked. To lock only a limited
range of cells in a document (as you will most often want to do), first set the
status of all the cells in the document to Unlocked and then select the range of
cells that you want to be locked.

Format Cells L F .

Number | Algnment | Font | Border E Fil
| /| Locked
| Hidden

Locking celis or hiding formulas has no effect until you protect the worksheet (Review tab, Changes
group, Protect Sheet button).

Figure 1-60. The Protection tab of the Format Cells dialog box.
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As an example, let's protect a worksheet so that it has only a single
unprotected cell. The user will only be able to enter a value in this cell; all other
cells in the sheet will be locked. Here's how to do it: First, select the cell you
want 1o be the unlocked cell. Now click on Format in the Cells group in the
Home tab of the Ribbon and choose Format Cells from the drop-down menu.
Choose the Protection tab to display the dialog box (Figure 1-60). In a new
worksheet, by default all cells are locked, so simply uncheck the Locked box so
that the cell you selected will be unlocked. Then press OK.

Locking or unlocking cells has no effect unless the worksheet is protected.
Activate the worksheet to be protected. Click on Format in the Cells group in the
Home tab of the Ribbon and choose Protect Sheet from the submenu. This will
display the Protect Sheet dialog box (Figure [-61). Here you can choose to
prevent users from carrying out one or more actions on the whole worksheet
(inserting or deleting rows or columns, etc.) or on specified cells. After choosing
options from the list, you can enter a password if you desire (you will be asked,
in a second dialog box, to confirm the password), in which case users will not be
able to unprotect the sheet

| Protect Sheet Sl X
{¥/| Protect worksheet and contents of locked cells

Password to unprotect sheet:

Allow ali users of this worksheet to:

elect unlocked cells

{Format celis

| Format columns

| |Format rows

[ lInsert columns

| Insert rows

| Insert hyperlinks

Delete columns

Delets rows v

OK Cancel

L e 3

Figure 1-61. The Protect Sheet with Password dialog box.,
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To Lock a Range of Cells in a New Document

1. Select all cells in the document by clicking on the row/column
header button in the upper left corner of the worksheet.

Click on Format in the Cells group in the Home tab of the Ribbon
and choose Format Cells from the drop-down menu. Choose the
Protection tab, uncheck the Locked option, and press the OK button.
This un-protects all cells in the worksheet.

I3

3. Now select the range of cells that you want to protect. Click on
Format in the Cells group in the Home tab of the Ribbon and choose
Format Cells from the drop-down menu, choose the Protection tab,
check the Locked option, and press the OK button.

4. Click on Format in the Cells group in the Home tab of the Ribbon
and choose Protect Sheet from the submenu, to display the Protect
Sheet dialog box. You can enter a password if you wish (Figure 1-
61). If you merely want to prevent yourself from making accidental
changes, no password is necessary. If you want to protect the
document from changes by others, you need a password; make sure
that you will be able to retrieve it when you need it.

Controlling the Way Documents
Are Displayed

Although only one worksheet at a time can be the active window, Excel
provides a number of ways to view data in several different worksheets, or
different areas of the same worksheef, at the same time.

Using New Window and Arrange All

If you have more than one document open, you can view several ot them
simultaneously in a number of ways. One way is to resize and move the
documents so that the desired part of each can be seen in the window. Another
way is to use the New Window and Arrange All icons in the Window group in
the View tab of the Ribbon. The latter method can be used to view multiple
documents, or multiple sheets in the same workbook, as described in the
following paragraph,

To view multiple worksheets in the active workbook, click on New Window.
A second window will be opened for the active workbook. If, for example, the
workbook is named Viscosity Data, the windows will be named Viscosity Data: 1
and Viscosity Data:2. Activate each window in (urn and click on the sheet that
you want to display. Now choose Arrange All, Excel displays the Arrange
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Windows dialog box (Figure 1-62). You can arrange the windows horizontally
(one above the other) or vertically (side by side). If you have created a separate
chart sheet from data in a worksheet, Arrange All provides a convenient way to
work with a sheet and observe changes in the associated chart. With Arrange
All, chart documents are reduced in size so that the whole chart appears in the
window; worksheet documents are not reduced in size. Figure 1-63 illustrates a
worksheet/chart combmatlon displayed using the Arrange {Vertical) option.
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Figure 1-62. The Arrange Windows dialog box.

Figure 1-63. Two windows arranged vertically
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With three open documents, the Tiled option arranges the documents with
the active sheet occupying the left half of the screen; the other two sheets each
occupy one-quarter of the screen, one above the other. With four documents
Tiled, each occupies one-quarter of the screen. Click on any document to make it
the active sheet. Double-click anywhere on the solid border between the
windows to undo the arrangement.

Different Views of the Same Worksheet

As your worksheets get larger and more complicated, it becomes impossible
to view all of a single worksheet at once, or even all cells in one row or column
at one time. Excel provides several convenient ways to display separate portions
of a single worksheet on the screen at the same time, so that you can view one
part while entering or changing data in another part.

Click on New Window in the Window group of the View tab to display a
second window of the active document, Use the Arrange All button to display
two windows, either Horizontal or Vertical, of the active sheet.

You can resize and move the windows so that the desired parts of the
worksheet can be seen at the same time.  Click on the Title Bar at the top of a
window and drag it to a suitable position for viewing; click on the side or bottom
of a window and drag to resize it. This is useful if you want to Cut or Copy
several cell ranges and then Paste them into another area of a worksheet, but the
two areas of the worksheet are far apart.

You can set different display options for the two windows. Display values in
one window and formulas in another to see the effect of changes to the formulas.

Excel Tip. To remove a workbook view, click on the window you want to
remove (the active window has a blue title bar, the inactive one is "grayed
out”). Now click on the Close button in the upper right corner of the active
window.

Using Split Screens

Use the Split icon in the Window group in the View tab of the Ribbon to split
a document window vertically or horizontally into two windows. To split the
screen vertically, select an entire column as if you were going to insert a column.
Then click on the Split icon. This creates a split in the window, to the left of the
selected column, as illustrated in Figure 1-64, with each part of the window
displaying the active document. Each part of the document now has its own
scroll bar, and you can scroll one part of the document while the other part
remains fixed. A horizontal split is accomplished in a similar way.
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You can also split the document window by placing the mouse pointer on
either split button (the small rectangles at the right end of the horizontal scroll bar
and at the top of the vertical scroll bar), and then click and drag the button.

The document window can be split both horizontally and vertically, by first
selecting a single worksheet cell, and then clicking on the Split icon.

To remove a split, press the Split icon, or slide the split button back to its
original position.

Excel Tip. To remove a split from a window, it's not necessary to slide the

split button back fo its original position at the top or lefi-hand side of the
scroll bar. Just place the mouse pointer on the split button and double-click.

A E.ioF . l.Gl.H Jo LK M

i Grade Sheet
2 | Hour Exams

Oral Final
3 Name #1 #2 #3 report Paper Exam Total Grade
4 CAPICELLA, Jason 15 4 27 17hH 45 23 1438 D
5 CHUNG, Min-Yin 18 13 | 44 | 175 | 45 47 615 C+
6 FERREIROQ, Kathy 24 16 | 32 | 20 45 52 63.0 B-
7 GANGE, Eric 28 13 | 43 20 40 51 650 B-
8 GREALEY, John 22 4 | 40 | 175 | 40 56 |632] Cx
9 HAPPERSBACH, Bill 28 12 | W | 475] 45 59 638 C+
10 HOGAN, Derek 37 (T e 50 60 737 B
11 LAROZI, Patrick 27 12 | 38 20 45 58 667 B-

Figure 1-64. A document with a split screen.

Using Freeze Panes

Freeze Panes (in the Window group of the View ribbon) can be used to
create a similar split document window, but the upper or left part of the window
is fixed and cannot be scrolled. Split panes are useful to display fixed row or
column headings (or both) while scrolling through the rest of the worksheet.

To use the Freeze Panes feature to split a document window horizontally into
two windows, select an entire row as if you were going to insert a row. Then
click on the Freeze Panes button in the Window group of the View ribbon, and
click on Freeze Panes in the drop-down menu. The portion of the window above
the selected row will be frozen. (There are also built-in commands to freeze
cither the top row or the leftimost column of the sheet.
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To split the window both horizontally and vertically, select the cell whose
upper left corner defines the location of the split, and click on Freeze Panes.

To unfreeze, simply click on the Freeze Panes button.

A

Grade Sheet
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Oral Final

ke | > Major #1 #2 #3 report Paper Exam Total
4 CAPICELLA, Jason 863162407 CHEMISTRY 15 4 {27 (175 | 45 | 23 1438
5 CHUNG, Min-Yin 325417108 CHEMISTRY 18 13 44 175 45 47 615
6 FERREIRQ, Kathy 011083979 EVENINGC 24 16 32 20 45 52 630
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7 | GANGE, Eric 436860962 95 CHEMISTRY 28 13 43 20 40 51 850
& GREALEY, John 123757619 96 CHEMISTRY 22 14 40 175 4 56 632
9 HAPPERSBACH,Bill 761132171 95 CHEMISTRY 28 12 30 175 45 59 6838
10 HOGAN, Derek 547710365 94 BIOCHEMIST 37 17 37 20 50 60 737
11 LAROZI, Patrick 533421804 96 CHEMISTRY 27 12 38 20 45 58 66.7

Figure 1-65, A document displayed with Freeze panes.

Using Zoom

You can change the Zoom setting of the worksheet: decrease the zoom
setting to see more rows and columns at a reduced size, or increase the setting for
easier viewing of small details. To change the zoom setting, click on the Zoom
button in the View tab to display the Zoom dialog box. You can choose from
several built-in zoom settings or enter a custom setting. If you choose Fit
Selection, the zoom setting will be adjusted to display the selected range of rows
or columns, or the selected chart, text box, etc., in the window.

You can also use the Zoom Slider, located at the bottom right corner of the
window, to change the zoom level.

Figure 1-66. The Excel 2007/2010 Zoom slider.

Excel Tip. Click on the Zoom Level button to the lefi of the Zoom Slider to
display the Zoom dialog box.

Easing the Transition
from Excel 2003 to Excel 2007/2010

There are some things that Excel 2003 users can do to make the transition to
Excel 2007/2010 easier. You can customize the Quick Access Toolbar to look
almost exactly like the Excel 2003 toolbar, you can use shortcut keys, or you can
install a Classic Menus utility to provide the familiar Excel 2003 menus.
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Customize the Quick Access Toolbar

I customized the Quick Access Toolbar (see Chapter 23 for instructions on
how to customize it) with familiar toolbuttons to make it look like the Standard
and Formatting toolbars of Excel 2003, in the "Toolbars share one row" form.
Figure 1-67 shows part of the customized Quick Access Toolbar.

9-0 QBB By EEFE WS =4 EC

Figure 1-67. A customized Quick Access Toolbar.

Use Shortcut Keys

You can use shortcut keys to carry out many menu or toolbutton commands.
Table 1-9 shows a list of the more common ones, and Appendices G and H
contain a much more extensive list.

Table 1-9. Shortcut Keys for Excel 2003 Menu Commands

File menu Insert menu
New Cul+N Cells... Ctrl + plus
Open Ctrl+ 0O Rows Ctrl + pluz
Save Ctrl + S Columns Ctrl + plus
Edit menu Worksheet Shift + F11
Undo Ctit + 7 Function... Shift + F3
Redo Ctrl+Y Name »
Cut Cirl+ X Define... Ctrl + F3
Copy Ctrl + C Create... Ctrl + Shift + F3
Paste Cul+Vv Format menu
Fill » Cells... (Number tab)  Curl+ |
Fill Down Cirl+D Cells... (Font tab) Ctri+F
Fill Right Cirl+ R Row »
Clear» Hide Ctrl + zero
Contents Delete Colomn »
Delete... Ctrl + minus Hide Cul+9
Find Cul + F Tools menu
Replace... Coe+H Macro »
Go To... Ci+G Macros... Alt +F8

Yisual Basic Editor Alt+F11

Display Classic Menus

The introduction of Excel 2007 was quickly followed by the appearance of
several commercial products that, when installed in Excel 2007/2010, provide
"classic menus"” -- that is, menus that Jook and operate very much like the Excel
2003 menus, You can find several of these products by searching on the web for
"excel classic menus” or you can install the Classic Menus utility that is provided
on the CD-ROM that accompanies this book.
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The Classic Menus workbook contains VBA code that displays a version of
the Excel 2003 Worksheet Menu Bar and Chart Menu Bar in Excel 2007/2010.
The menus are located in the Add-Ins tab of the Ribbon. Most of the commands
found in the Excel 2003 Worksheet Menu Bar are available. Figure 1-68 shows
the Toels menu with the Macro submenu.

A few menu commands, such as the Customize... command in the Tools
menu, are absent from the menus because they are not applicable to Excel
2007/2010.

Tools " Data - Chart - Window ~ Help -

<

Spelling...

3

& B

Research...

Error Checking...

Show Text To Speech Toolbar

Shared Workspace...

Share Workbook,., | J K
Track Changes b

Protection

Online Collaboration 4

Goal Seek...

Scenarios...

Formula Auditing »

Macro ¢ :3 Macros...

Add-Ins... 2 Record New Macro..,
AutoCorrect Options... A\ Security..,

Options... 4 . s
Yptions. ¥4 visual Basic Editor

Figure 1-68. Excel 2003 Classic Menus installed in Excel 2010.

The VBA procedure in the Classic Menus workbook runs automatically
when you open the workbook. You can install the classic menus by opening the
document each time you want to have the menus available, but there are easier
approaches. You can save the workbook as an Add-In; this will make the menus
available each time you start Excel, provided the Classic Menus Add-in is
checked in the Manage Excel Add-Ins list. This allows you to turn off the
Classic Menus by unchecking the Add-In.
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Excel Tip: Double-click on the Add-Ins tab to keep the classic menus
displayed

The following box lists some of the differences between Excel 2003 menus
and Classic Menus,

Differences between Excel 2003 Menus and Classic Menus

There is no separate Chart menu bar that appears when a chart is selected.
The Chart menu is located in the "Classic Menus" menu bar; Chart menu
commands become active when you select a chart.

In all menus:

1. Letters are not underlined in the menu bar to indicate accelerator keys; for
example, File instead of File.

2. Shortcut keys are not shown in menu commands, but are still available: for
example, Ctrl-C for Copy.

In the File menu:
1. Recent files do not have a number preceding the filename for usc as a
shortcut key.

In the Edit menu:
1. Shift+Edit to change Copy to Copy Picture... has not yet been
implemented.

In the View menu:
1. The Toolbars command has been omitted, because there are no toolbars to
be displayed.

In the Tools menu:

1. The Customize.., command has been omitted because there are no menus or
toolbars to be customized.

2. Inthe Add-Ins... command, only the Solver and Analysis ToolPak add-ins
will have their menu commands added to the Tools menu. To make the
command appear in the Tools menu, after loading the add-in, click on the
File menu,

In the Chart menu:
1. The Chart Options... command is not available. Use the Layout tab of the
Excel 2007/2010 ribbon.
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Excel 2007/2010 Workbook and
Worksheet Specifications

Worksheet size*
Maximum column width
Maximum row height
Number precision
Largest allowed positive number
Largest allowed negative number
Smallest allowed negative number
Smallest allowed positive number
Levels of Undo*
Number of worksheet functions*
Maximum number of...
open workbooks
characters in a cell (text)
characters in a formula
sheets in a workbook
colors in a workbook*
custom number formats
windows in a workbook
panes in a window
arguments in a function*
nested levels of functions*
sort levels in a single sort

* indicates changes from Excel 2003

1,048,576 rows by 16,384 columns
255 characters
409 points
15 digits
9.99999999999999E+307
-9.99999999999999E+307
-2.225E-308
2.225E-308
100
341

Limited by available memory
32,767

8192

Limited by available memory
16,000,000

Between 200 and 250
Limited by system resources
4

255

64

64








