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Managing a library of music and other media content can be a challenging
task, and iTunes is a powerful tool for this, even if you're not planning to use
an iPod right away. A good understanding of how iTunes manages your digi-
tal media collection helps you to get the most out of your digital media expe-
rience and allows you to spend more time enjoying your media collection

rather than managing it.
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Understanding iTunes

iTunes is pretty much the only game in town to get the most out of all of the features on your iPod,
but even for non-iPod users, it can be a great tool for managing an ever-increasing library of digital
content. For those who have experience with other media-management applications, however, it's
important to understand that iTunes takes a slightly different philosophy to how it manages your
content, and it's important to get a good understanding of these differences so that you can get
the most benefit out of it.

Types of audio content supported by iTunes

There is a popular misconception among non-iPod owners that all of the content that you putinto
iTunes must come from the iTunes Store. Nothing could be further from the truth. Not only does
iTunes support any standard audio CD that you give it, but it also supports the MP3 format — the
most popular digital audio format available on the Internet today.

In addition to the MP3 format, iTunes provides support for the Advanced Audio Coding (AAC) for-
mat. Contrary to another common misconception, this is not an Apple proprietary format, but is
actually an MPEG standard audio format originally designed to replace the MP3 format. It is also
the standard audio format used by other devices such as the Sony PlayStation 3 and the Nintendo
Wii,and many other modern portable music players and cellular phones have also added support
for this format.

Content that you do purchase from the iTunes Store comes in AAC format, and iTunes imports your
CDs in this format by default, but you can import any standard MP3 file directly into iTunes without
needing to convert it first,and you can play these same files on your iPod,iPhone, or Apple TV with-
out having to worry about converting them to another format. Changing your default import for-
mat is discussed later in this chapter.

is the default format used by the Microsoft Windows Media Player application and
many Windows-compatible portable media players. Although iTunes does not sup-

port the WMA format directly, the Windows version of iTunes offers to automatically

convert any unprotected WMA files to your preferred format as you import them, as
discussed later in this chapter. Note that this option is not available to Mac users, as
Mac OS X does not include the necessary WMA components.




iTunes also provides support for several other less-commonly used formats, including Apple

Lossless format, Waveform audio format (WAV), and Audio Interchange File Format (AIFF). These
are lossless formats in that they preserve the full original sound quality of the source, but they also
consume a lot of storage space as a result.

Understanding lossless and lossy

Digital music formats fit into two broad categories: lossless and lossy.

Lossless, as the name implies, refers to those formats that preserve the full sound quality of the
original recording. Common lossless formats include WAV, AIFF, and Apple Lossless. The WAV and
AIFF formats are essentially a direct copy of the audio from an original CD, while the Apple Lossless
format performs lossless compression on the audio file to reduce the size slightly, although still
without losing any of the original audio fidelity. This is the same way in which a ZIP file on your
computer works — when you ZIP up a document or other file, the size is reduced, but you don't
lose any of the actual information.

The problem is that even with compression, lossless files are generally still very large — between
6MB and 10MB per minute of audio.To solve this problem,a number of lossy compression methods
were developed.

The idea here is, because most people’s ears cannot hear the full fidelity of most audio recordings,
a simple analysis can be performed to throw out those sounds that are of a frequency above or
below normal hearing range. By selectively discarding information that the average listener can’t
hear anyway, the remaining music can be stored in a much smaller file.

The most common lossy formats are MP3, AAC, and WMA. Each of these formats can be set to dif-
ferent bit-rates, with the simple rule of thumb being that the lower the bit-rate, the smaller the file
but the lower the sound quality. Bit-rates are expressed in kbps (short for kilobits per second), and
although many audio enthusiasts prefer much higher bit-rates, most users consider 128 kbps to be

the lowest acceptable quality for a digital audio file.

Changing your default audio format

If you're importing existing media files that are directly supported by iTunes, such as MP3 or AAC
files, these are simply left in their original format and cataloged into your iTunes library. No conver-
sion ever takes place with an existing supported media file format during import.



However, when importing CDs or WMA files, it's necessary for iTunes to convert the audio into a

supported digital media file format. Rather than pestering you each time, iTunes uses a default for-
mat that you set under your iTunes preferences.To set your import preferences, follow these steps:

1. Open your iTunes preferences, click the General tab, and then click the Import Settings

button. A screen similar to the one shown in figure 1.1 appears.

Import Settings

Import Using: [" AAC Encoder |+]
Setting: ( High Quality (128 kbps) |+]
Details

64 kbps {(mono)/ 128 kbps (stereo), optimized
for MMX/SSE2.

™ Use error correction when reading Audio CDs

Use this option if you experience problems with the
audio quality from Audio CDs. This may reduce the
speed of importing.

Mote: These settings do not apply to songs
downloaded from the iTunes Store.

[ Cancel ) @

1.1 The iTunes Import Settings preferences dialog box

2. Select the format you want iTunes to use for imports from the Import Using drop-
down menu. The format chosen here is used as the default for all conversion operations —
importing from CD, converting WMA files automatically, or even converting tracks manually.

The choices are

AAC Encoder. The default encoder used by iTunes.This is a lossy format that provides
reasonable quality at lower file sizes. This is the best-quality lossy encoder in iTunes, but
the AAC file format is not as widely supported as MP3.

AIFF Encoder. An uncompressed, lossless format that is just a direct copy of the audio
from a CD.

Apple Lossless Encoder. A lossless compression format. Files encoded using the Apple
Lossless Encoder are the same quality as the original CD, but they are compressed to
about 50 to 80 percent of their original size using lossless compression.



You can easily compute the size of an MP3 or AAC file based on the bitrate you've cho-
sen. The bitrate is actually just the number of bits of data stored for each second of
audio. So for a 128 kbps audio file, each second of audio requires 128,000 bits of
data. Because there are 8 bits in a byte, with a given bitrate and length of a song, you

can figure out almost exactly how much space each track takes up if you want to do the

math.
For example, for a 5-minute track encoded at 128 kbps

5 minutes = 300 seconds
128 kbps x 300 seconds = 38,400 kilobits of data
38,400 kilobits / 8 = 4,800K

For a quick approximate calculation, however, you can just multiply the bitrate by 7.5
and this tells you approximately how many kilobytes each minute of a song takes up.

Another good rule of thumb is to remember that a 192 kbps track is 50 percent larger
than a 128 kbps track, and a 256 kbps track is twice the size of a 128 kbps track.

MP3 Encoder. The standard digital audio file format used by most content and digital
audio software and hardware.This provides the widest range of compatibility with other
software and hardware; however, the MP3 encoder in iTunes generally requires a slightly
higher bit-rate to be used than AAC to produce the same audio quality.

WAV Encoder. An uncompressed, lossless format that is just a direct copy of the audio
from a CD.

3. Select a quality setting from the Setting drop-down menu. For the MP3 and AAC lossy
formats, select one of the predefined quality settings. Each quality setting corresponds to a
specific bit-rate for that format. If you would like to set your own specific bit-rate, select
Custom and an additional dialog box opens to allow you to select a more specific bit-rate.
Note that this does not apply to AIFF, Apple Lossless, or WAV formats, as these formats pro-
vide the same quality as the original audio.

Once you have actually imported your music into iTunes you can view the size of

your files by enabling the Size column in the View => Options menu in iTunes.




Types of video content supported by iTunes

iTunes also supports organizing and viewing your video content. Although the world of digital

audio formats is much more well-defined, with MP3 being the dominant standard, the world of
online digital video content is a great deal murkier, with a wide variety of different formats out
there and no clear standard.

iTunes uses QuickTime as its underlying video engine, and you can therefore use any video format
supported by QuickTime in iTunes.In a default configuration, this includes the QuickTime MOV for-
mat, as well as the H.264 and MPEG-4 video formats. A number of plug-ins are available for
QuickTime, however, that extend this video playback to include numerous other popular formats
such as WMV and DivX.

Keep in mind, however, that although iTunes supports any video format compatible with
QuickTime, this is not the case with Apple media hardware.These devices are limited to the H.264
and MPEG-4 formats, and have certain additional limitations on maximum resolutions and bit-
rates that are discussed in Chapter 9.This becomes important if you plan to watch your video con-
tent on any device other than your computer.

How iTunes organizes and stores media

iTunes takes a considerably different approach from many other media-management applications
in terms of how media content is organized on your computer. Basically, iTunes expects that you
are performing all of your music and other media management using the iTunes application as the
front-end, and it takes care of all of the little details like file and folder management for you in the
background..

Ironically, it's often the most experienced digital media users that have the hardest time coming to
grips with how iTunes works. If you've been collecting digital media for a long time, even with
another media-management application, you may have become used to managing your media
collection through a file and folder structure.You've probably become quite comfortable with this
organization and grown to expect that things are only ever where you put them and nowhere else.

However, the problem with a file and folder structure is that it's limiting by its very nature. Say you
choose to organize your music into a folder structure by Artist and Album, with each song file
named after the track. Now, how do you find all the music of a particular genre? How do you deal
with songs from albums with various artists such as movie soundtracks? For a few tracks, this may
not be much of a challenge, but it can quickly become unwieldy as your library grows to thousands
of songs — which it will.



Most digital audio formats already include room for tags stored within the files themselves to con-

tain information such as the artist, album, song title, and genre. In most cases this information is
already at least partially filled in for your existing media files — it merely needs to be read in and
put to good use, which is essentially what iTunes does as you import your media files into your
iTunes library.The information from the tags is stored in a database for quick access, and so iTunes
can generally find a given track for you much faster than you could otherwise.

If you want to actually see a specific file, simply select the track in iTunes and choose

File &> Show in Finder (Mac) or Show in Windows Explorer (Windows); iTunes opens

[T the appropriate window to that location, with the selected file highlighted.

So what about the files themselves? Well, the point is that you don't really need to care where
those files are.There'’s no longer a need to deal with the original files — you can locate, play, copy,
organize, and retag your media from within iTunes, and it takes care of all of the other trivial details
like file storage for you automatically under the hood.

Need to copy a set of tracks? Try highlighting a single track or set of tracks in iTunes
and then drag-and-drop them directly onto a Finder or Windows Explorer window.

(-1, 1{TII iTunes copies those files to that location.

Configuring Your Library Storage
Settings

Armed with a basic understanding of the types of media that you can use in iTunes and how it’s all
stored, the next step is to actually get that content into iTunes. Of course, there’s always a tempta-
tion to jump right in, but this is one of these situations where just a little bit of initial understand-
ing and planning can help you avoid a whole bunch of headaches later.

Selecting a location for your iTunes media

By default, iTunes stores its library folder under your Music/iTunes/iTunes Music folder on a Mac or
your My Music\Music\iTunes Music folder in Windows. Both of these folders are normally located on
your system drive, and if you're importing a large library, this may not be the ideal place for it. Even
if you choose to leave your existing media files where they are, the iTunes Music Folder path is still
used for tracks that you import from audio CDs, as well as any content purchased from the iTunes
Store, including podcasts.



Although iTunes stores its library database on the system drive by default, you can specify any
location you like for the storage of your media content, and it does not need to be stored with the

actual database. You seldom need to be concerned with changing the database location — it
doesn’t grow particularly large. Your media content, however, can quickly take over your entire

hard drive if you're not careful.

Note that it is possible to move your media content to another location in the future, and | discuss
thatin Chapter 13. However, moving the media content can still be a time-consuming process,and
it's better to plan ahead and place it in a location where you want to keep it for the long run now.

To change the location of your iTunes music folder, follow these steps:

1. Open your iTunes preferences and click the Advanced tab, as shown in figure 1.2.

Advanced

] o0 BE L L B o

General Playback Sharing Store Parental Apple TV Devices  Advanced

iTunes Music folder location

[ Change... |
\ Reset )

Media Library:iTunes:

a Keep iTunes Music folder organized
Places files into album and artist folders, and names the files based on
the disc number, track number, and the song title.

ECODV files to iTunes Music folder when adding to library

Streaming Buffer Size: ( Large B:

Use iTunes for Internet playback: [ Set )

Reset all dialog warnings: [ Reset |

a Keep MiniPlayer on top of all other windows
a Keep movie window on top of all other windows
[T Display visualizer full screen

Eﬂroup compilations when browsing

[ Cancel ) (I)

1.2 The Advanced tab of the iTunes preferences dialog box

2. Click Change.

3. From the file browser dialog box that appears, specify a new folder location and click
OK; this is the folder that contains your media content. The actual library database

remains in your Music or My Music folder.
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4. Backin the Advanced tab, click the check boxes to select the other options you want to

apply with regard to your folder location. There are two to choose from:

Keep iTunes Music folder organized. This option determines whether iTunes reorgan-
izes content in your iTunes Music folder as you change the tags and other information.
For example, if you change the Artist field for a track, iTunes moves that track into a new
folder according to the new artist name.This only affects tracks that are located in the
iTunes Music folder.

Copy files to iTunes Music folder when adding to library. When this option is enabled,
any existing files that you import into your iTunes library are copied to the iTunes Music
folder.iTunes uses the copy for its library, but the original file is also left in its original
location. If this option is not selected, iTunes simply references each file from its original
location. It does not rename or move the file in any way, even if you later update the track
information. Further, iTunes stores the full path to each file,and so if you rename or move
the file later, iTunes will lose track of it, resulting in a broken link to the file. Note that con-
tent imported from CDs or downloaded from the iTunes Store (including podcast sub-
scriptions) is always placed in the iTunes Music folder, regardless of this setting. Further, if
you import a track that is already in the iTunes Music folder, it is moved or renamed if this
option is enabled because it’s already in the iTunes Music folder.

5. Click OK so that the new settings take effect. The remaining options on the Advanced
tab do not apply to your iTunes library storage.

The basic point that you should keep in mind here is that iTunes considers your iTunes Music folder
to be its home folder. Anything in this folder can be reorganized and managed (subject to the
options mentioned in the previous steps). Files outside of this folder location are never managed
or reorganized by iTunes.In fact, if you remove a track from your iTunes library, iTunes doesn’t even
offer to delete the file if it's not already located in your iTunes Music folder.

Keep in mind that if you're concerned about maintaining your own file system organization and
choose not to copy files into your iTunes Music folder when importing them, you should ensure
that your file and folder layout is already set up the way you want it, as it is not easy to move or
rename these files once they’ve been imported into iTunes. Personally, unless you have a very spe-
cific reason to maintain your own file and folder organization, | strongly recommend letting iTunes
manage your file organization for you. You save a lot of time and hassle in the long term, particu-
larly if you ever need to move your library to another drive or another computer, and after all,aren’t
computers supposed to make our lives easier?

11
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folder during import, and so if you're importing a large number of media files, you

Note need to make sure that you have enough disk space for this. Alternatively, you can

move all of the files into the iTunes Music folder manually before adding them to
your iTunes library. If they're already in your Music folder, then iTunes just imports

them in-place and reorganizes them as necessary.

Adjusting your CD import settings

Importing an audio CD into iTunes is normally as simple as putting it into your computer’s CD
drive. With default import settings, iTunes simply asks you if you want to import the CD, and then
does this for you. If you want to be a bit more selective about what you import from CD, however,
you can either adjust your import settings to not automatically prompt you, or simply select No
when asked to import your newly inserted CD.

If you choose No, iTunes displays the CD in your Source list on the left-hand side and a list of the
tracks it contains, as shown in figure 1.3.

LIERARY = Name | Time | Artist | Album _ Genre
n Music 1 # O Canada 1:13 Band Of The Royal ... O Canada Classical
E Movies 2 # The Royal Regiment 2:40 Band Of The Royal ... O Canada Classical
3 # God Bless the Prince of Wales 1:01 Band Of The Royal ... O Canada Classical
2 TV shows 4 @ Toronto City 2:47 Band Of The Royal ... O Canada Classical
1§ Podcasts 5 @ Men of Dieppe 2:08 Band Of The Royal .. O Canada Classical
a Audiobooks 6 @ Fantasy on British Sea Songs 6:05 Band Of The Royal ... O Canada Classical
[ iPod Games 7 ® Brutish Tubadiers 2:47 Band Of The Royal ... O Canada Classical
%. Radio 8 # Eagle Squadron 3:27 Band Of The Royal ... O Canada Classical
a Gl 9 # Scottish Rhapsody 9:18 Band Of The Royal ... O Canada Classical
10 #@ Fanfare Prelude on the "ltalian ... 2:09 Band Of The Royal ... O Canada Classical
STORE 11 @ In the Miller Mood 10:02 Band Of The Royal ... O Canada Classical
iTunes Store
Purchased
¥ DEVICES
» | Bedroom v
> |_ Living Room...
¥ PLAYLISTS
(2 Party Shuffle
m Phase Music
» [ Audiobooks
¥ [ Faverites
Mix Du Jour
Sleep Music
[8] Unplayed ...
[ 4] 805 Gold

1.3 The iTunes CD track listing
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From here, you can choose specific tracks that you want to import simply by placing a check mark
beside them, and unchecking the tracks that you do not want to import — a useful feature if you
only want to grab a single track or two from a CD, rather than importing the entire disc.

&

eniu MP3 format for your imported music, you might want to consider ripping your CDs

less than acceptable. If you're concerned about audio quality and want to use the

using a third-party tool such as Exact Audio Copy (EAC) from www.exactaudiocopy.de
and then converting them to MP3 using the popular L.A.M.E. conversion tool, which
can be downloaded from lame.sourceforge.net.The result is a standard MP3 file that

you can just import directly into iTunes.

Changing CD track information

When you insert a CD, iTunes tries to look up the correct track information for it using the Gracenote
CD Database (or CDDB). You can turn this behavior off by unchecking the Automatically retrieve
CD track names from the Internet option in your Importing preferences.

If'you're not connected to the Internet when you insert your CD, or iTunes doesn't
retrieve the track information for some other reason, you can force it to try again by

choosing Advanced => Get CD Track Names.

For most commercial CDs, it does a pretty reasonable job, but keep in mind that the information
that goes into CDDB is based on user submissions,and it's only as accurate as the information pro-
vided by end users like you. If you notice an error, you can easily correct it before importing your
CD simply by editing the information in the CD track listing as you would for any other file in
iTunes:

1. Select a CD track.

2. Choose File => Get Info from the iTunes menu. You should see a dialog box similar to the
one shown in figure 1.4.

3. Fillin the correct information for that track.

4. Click OK.

13
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If you want to change an entry for several tracks at once, such as for an incorrectly spelled album
name, you can simply select all of the tracks you want to change and follow the previous steps to
edit the common properties for all of them.

[ Summary |Info| Video Sorting Options  Lyrics  Artwork L
Name
|0 Canada ]
Artist Year
Band Of The Royal Regiment Of Canada ] [1998
Album Artist Track Number
1 of 11
Album Disc Number
0 Canada | 1 of 1
Grouping BPM
Composer
Calixa Lavallée
Comments
Genre
Classical 8 [ Part of a compilation
revioss ) (et ) o

1.4 The iTunes CD track properties window

and Next buttons at the bottom-left corner of the window. If you're changing infor-

It Mation on multiple tracks, you can use these buttons to quickly navigate through

the entire set of tracks. You can even use the keyboard shortcuts 8+P and 88+N,

respectively,on a Mac, or Ctrl+P and Ctrl+N in Windows.

If you've corrected some obvious error in the track information from CDDB, why not share your
experience with the rest of the world? Follow these steps to submit your own information to
CDDB:

1. With the CD still inserted in your computer, select Advanced => Submit CD Track
Names to submit your changes to the CDDB database. You should see a dialog box simi-
lar to the one shown in figure 1.5. Note that as long as the CD is still inserted, you can also
display this dialog box at any time by right-clicking the CD in the iTunes Source list and
choosing Get Info. Once you eject the CD, the option is grayed out.
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2. Fillin the requested information in the dialog box in figure 1.5 for the CD. At a mini-

mum, you should include the artist, album, and genre information.

e D

Artist
[Band of the Royal Regiment of Canada

Composer

Album Disc Number
Footsteps in Time 1 of 1
Genre Year
Classical () 1998

"] Compilation CD 1 Gapless Album

( Cancel ) @

1.5 The CD Info dialog box

3. If the album has more than one artist, type Various Artists in the Artist field, and click
the Compilation CD check box. Note that the Compilation CD check box is only for albums
with multiple artists, not albums that are merely special collections of a single artist’s work.

4. If the CD is designed to be played back with no breaks of silence in between tracks,
click the Gapless Album check box. More on gapless playback is discussed in Chapter 4.

Keep in mind that your submission won't show up immediately, as there’s a review process for user-
submitted changes, but it can certainly help the CDDB team to keep its information accurate.

Importing your existing media files

If you already have a collection of media files lying around on your computer, you can import
them directly into iTunes. iTunes does not offer any means of converting from another media-
management application such as Windows Media Player, but if your files are correctly tagged,
most of the information you need is already contained within the actual files.

The easiest and most obvious way to get the tracks into iTunes is simply by dragging-and-drop-
ping a track onto the iTunes window. You can also do this with complete folders.

15
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particularly where video files are concerned. If a file format is incompatible and can-
not be imported into iTunes, you often get no feedback — it just doesn't appear in

your library.

If you're importing a lot of content, and drag-and-drop doesn’t work for you, then you can use the
Add To Library option found under the iTunes File menu.

1. Choose File => Add to Library. You are presented with a standard file browser dialog box.

2. From the file browser, select the media files or folder that you would like to import
into iTunes.

3. Click OK.

D Add Folder to Library. These function in exactly the same way that the Mac’s single

Note Add to Library option does, although you need to select the appropriate option

depending on whether you're adding individual files or an entire folder.

Importing playlists from another application

If you've come from another media-management application, chances are that you've collected
more than a few playlists in your time over there. Although iTunes doesn't offer a direct conversion
option, if your playlists are in the M3U format, or can be exported into this format (most common
media players can do this), then you can import them into iTunes manually.

1. Make sure the media files on the playlist you are importing are already imported to
your library. If the media files are not already imported, your imported playlist may not
function correctly.

Export your playlists into an M3U format from your existing media player.
In iTunes, choose File => Library > Import Playlist. A file browser dialog box appears.

Browse to and select the saved M3U file on your computer.

v W N

Click OK. Your M3U file is imported into iTunes as a new playlist with the name of the
M3U file.
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