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Excel in a Nutshell
In This Chapter

● A brief history of Excel

● What’s new in Excel 2010

● The object model concept in Excel

● The workings of workbooks

● The user interface

● The two types of cell formatting

● Worksheet formulas and functions

● Objects on the worksheet’s invisible drawing layer

● Macros, toolbars, and add-ins for Excel customization

● Internet features

● Analysis tools

● Protection options

Microsoft Excel has been referred to as “the best application ever written for Windows.” You may 
or may not agree with that statement, but you can’t deny that Excel is one of the oldest Windows 
products and has undergone many reincarnations and face-lifts over the years. Cosmetically, the 
current version — Excel 2010 — barely even resembles the original version. However, many of 
Excel’s key elements have remained intact over the years, with significant enhancements, of 
course.

This chapter presents a concise overview of the features available in the more recent versions of 
Excel, with specific emphasis on Excel 2010. It sets the stage for the subsequent chapters and 
provides an overview for those who may have let their Excel skills get rusty.
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Part I: Basic Information12

The History of Excel
You probably weren’t expecting a history lesson when you bought this book, but you may find 
this information interesting. At the very least, this section provides fodder for the next office 
trivia match.

Spreadsheets comprise a huge business, but most of us tend to take this software for granted. In 
the pre-spreadsheet days, people relied on clumsy mainframes or calculators and spent hours 
doing what now takes minutes.

It started with VisiCalc
Dan Bricklin and Bob Frankston conjured up VisiCalc, the world’s first electronic spreadsheet, 
back in the late 1970s when personal computers were unheard of in the office environment. They 
wrote VisiCalc for the Apple II computer, an interesting machine that seems like a toy by today’s 
standards. VisiCalc caught on quickly, and many forward-looking companies purchased the 
Apple II for the sole purpose of developing their budgets with VisiCalc. Consequently, VisiCalc is 
often credited for much of Apple II’s initial success.

Then came Lotus
When the IBM PC arrived on the scene in 1982, thus legitimizing personal computers, VisiCorp 
wasted no time porting VisiCalc to this new hardware environment. Envious of VisiCalc’s success, 
a small group of computer enthusiasts at a start-up company in Cambridge, Massachusetts, 
refined the spreadsheet concept. Headed by Mitch Kapor and Jonathan Sachs, the company 
designed a new product and launched the software industry’s first full-fledged marketing blitz.

Released in January 1983, Lotus Development Corporation’s 1-2-3 proved an instant success. 
Despite its $495 price tag (yes, people really paid that much for a single program), it quickly out-
sold VisiCalc and rocketed to the top of the sales charts, where it remained for many years.

Microsoft enters the picture
Most people don’t realize that Microsoft’s experience with spreadsheets extends back to the early 
1980s. In 1982, Microsoft released its first spreadsheet — MultiPlan. Designed for computers run-
ning the CP/M operating system, the product was subsequently ported to several other plat-
forms, including Apple II, Apple III, XENIX, and MS-DOS. MultiPlan essentially ignored existing 
software UI standards. Difficult to learn and use, it never earned much of a following in the United 
States. Not surprisingly, Lotus 1-2-3 pretty much left MultiPlan in the dust.

Excel partly evolved from MultiPlan, and first surfaced in 1985 on the Macintosh. Like all Mac 
applications, Excel was a graphics-based program (unlike the character-based MultiPlan). In 
November 1987, Microsoft released the first version of Excel for Windows (labeled Excel 2 to cor-
respond with the Macintosh version). Excel didn’t catch on right away, but as Windows gained 
popularity, so did Excel. Lotus eventually released a Windows version of Lotus 1-2-3, and Excel 
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Chapter 1: Excel in a Nutshell 13

had additional competition from Quattro Pro — originally a DOS program developed by Borland 
International, then sold to Novell, and then sold again to Corel (its current owner).

Excel versions
Excel 2010 is actually Excel 14 in disguise. You may think that this name represents the 14th ver-
sion of Excel. Think again. Microsoft may be a successful company, but its version-naming tech-
niques can prove quite confusing. As you’ll see, Excel 2010 actually represents the 11th Windows 
version of Excel. In the following sections, I briefly describe the major Windows versions of Excel.

Excel 2
The original version of Excel for Windows, Excel 2 first appeared in late 1987. It was labeled 
Version 2 to correspond to the Macintosh version (the original Excel). Because Windows wasn’t 
in widespread use at the time, this version included a runtime version of Windows — a special 
version with just enough features to run Excel and nothing else. This version appears quite crude 
by today’s standards, as shown in Figure 1-1.

Figure 1-1: The original Excel 2 for Windows. Excel has come a long way since its original version. 
(Photo courtesy of Microsoft Corporation)

Excel 3
At the end of 1990, Microsoft released Excel 3 for Windows. This version offered a significant 
improvement in both appearance and features. It included toolbars, drawing capabilities, work-
sheet outlining, add-in support, 3-D charts, workgroup editing, and lots more.
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Part I: Basic Information14

Excel 4
Excel 4 hit the streets in the spring of 1992. This version made quite an impact on the market-
place as Windows increased in popularity. It boasted lots of new features and usability enhance-
ments that made it easier for beginners to get up to speed quickly.

Excel 5
In early 1994, Excel 5 appeared on the scene. This version introduced tons of new features, 
including multisheet workbooks and the new Visual Basic for Applications (VBA) macro lan-
guage. Like its predecessor, Excel 5 took top honors in just about every spreadsheet comparison 
published in the trade magazines.

Excel 95
Excel 95 (also known as Excel 7) shipped in the summer of 1995. On the surface, it resembled 
Excel 5 (this version included only a few major new features). However, Excel 95 proved to be 
significant because it presented the first version to use more advanced 32-bit code. Excel 95 and 
Excel 5 use the same file format.

Excel 97
Excel 97 (also known as Excel 8) probably offered the most significant upgrade ever. The tool-
bars and menus took on a great new look, online help moved a dramatic step forward, and the 
number of rows available in a worksheet quadrupled. And if you’re a macro developer, you may 
have noticed that Excel’s programming environment (VBA) moved up several notches on the 
scale. Excel 97 also introduced a new file format.

Excel 2000
Excel 2000 (also known as Excel 9) was released in June of 1999. Excel 2000 offered several 
minor enhancements, but the most significant advancement was the ability to use HTML as an 
alternative file format. Excel 2000 still supported the standard binary file format, of course, which 
is compatible with Excel 97.

Excel 2002
Excel 2002 (also known as Excel 10 or Excel XP) was released in June of 2001 and is part of 
Microsoft Office XP. This version offered several new features, most of which are fairly minor and 
were designed to appeal to novice users. Perhaps the most significant new feature was the capa-
bility to save your work when Excel crashes and also recover corrupt workbook files that you 
may have abandoned long ago. Excel 2002 also added background formula error checking and a 
new formula-debugging tool.

Excel 2003
Excel 2003 (also known as Excel 11) was released in the fall of 2003. This version had very few 
new features. Perhaps the most significant new feature was the ability to import and export XML 
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Chapter 1: Excel in a Nutshell 15

files and map the data to specific cells in a worksheet. It also introduced the concept of the List, a 
specially designated range of cells. Both of these features would prove to be precursors to future 
enhancements.

Excel 2007
Excel 2007 (also known as Excel 12) was released in early 2007. Its official name is Microsoft Office 
Excel 2007. This release represented the most significant change since Excel 97, including a change 
to Excel’s default file format. The new format was XML based although a binary format is still avail-
able. Another major change was the Ribbon, a new type of UI that replaced the Excel menu and 
toolbar system. In addition to these two major changes, Microsoft enhanced the List concept intro-
duced in Excel 2003 (a List is now known as a Table), improved the look of charts, significantly 
increased the number of rows and columns, and added some new worksheet functions.

 

XML (Extensible Markup Language) stores data in a structured text format. The new file 
formats are actually compressed folders that contain several different XML files. The 
default format’s file extension is .xlsx. There’s also a macro-enabled format with the 
extension .xlsm, a new binary format with the extension .xlsb, and all the legacy for-
mats that you’re used to.

Excel 2010
The current version, Excel 2010, was released in early 2010 and is also known as Excel 14. If you 
think you’ve spotted a typo in the previous sentence, you’re wrong. Yes, even big companies can 
be superstitious; Microsoft skipped Version 13 of Office and went from Version 12 to Version 14.

Excel 2010 builds on the improvements introduced in Excel 2007, and it offers several new 
enhancements. See the sidebar, “What’s new in Excel 2010?”

The Object Model Concept
If you’ve dealt with computers for any length of time, you’ve undoubtedly heard the term object-
oriented programming. An object essentially represents a software element that a programmer 
can manipulate. When using Excel, you may find it useful to think in terms of objects, even if you 
have no intention of becoming a programmer. An object-oriented approach can often help you 
keep the various elements in perspective.

Excel objects include the following:

 Excel itself

 An Excel workbook

 A worksheet in a workbook

 A range in a worksheet

 A button on a worksheet
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Part I: Basic Information16

 A ListBox control on a UserForm (a custom dialog box)

 A chart sheet

 A chart on a chart sheet

 A chart series in a chart

What’s new in Excel 2010?

Here’s a quick summary of what’s new, relative to Excel 2007:

● 64-bit version: If your hardware supports it, you can install the 64-bit version, which lets 
you create much larger workbooks.

● Sparkline charts: Create small, in-cell charts to summarize a range of data graphically.
● Pivot table Slicers: A new way to filter and display data in pivot tables.
● Pivot table formatting options: You have more control over the appearance of pivot table 

reports.
● File tab: The File tab replaces the Office button, which is located to the left of the other 

tabs. Clicking it displays Backstage View, a screen that lets you perform various operations 
on your workbook. This view essentially replaces the traditional File and Print menus — 
plus quite a bit more.

● Draft mode for charts: If you use many highly formatted charts, you can choose to display 
them in draft mode for improved performance.

● Conditional formatting enhancements: Data bar conditional formatting can display in a 
solid color, and the bars provide a more accurate display.

● Function enhancements: Many of Excel’s statistical functions have been improved in terms 
of numeric accuracy. The old versions of these functions are still available and have been 
relegated to a new function category called Compatibility.

● Image editing enhancements: You have much more control over the appearance of 
graphic images inserted into a workbook.

● Paste preview: When you copy a range, the Paste command displays various options 
(with preview).

● Ribbon customization: End users can customize the Ribbon by adding new tabs and groups.
● Equation editor: Create and display (noncalculating) mathematical equations.
● Faster processing: Microsoft made some improvements to the calculation engine, and files 

load a bit faster.
● New security features: Workbooks downloaded from the Internet or from e-mail attach-

ments are opened in Protected View mode. Workbooks can be designated as “trusted,” 
and they don’t need to reside in special trusted folders.

● Updated Solver: Excel 2010 includes a new version of the Solver add-in.
● Enhancements to VBA: Many operations that used to require old XLM macros can now be 

performed directly using VBA macro commands.

New Feature
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Chapter 1: Excel in a Nutshell 17

Notice the existence of an object hierarchy: The Excel object contains workbook objects, which 
contain worksheet objects, which contain range objects. This hierarchy is called Excel’s object 
model. Other Microsoft Office products have their own object model. The object model concept 
proves to be vitally important when developing VBA macros. Even if you don’t create macros, 
you may find it helpful to think in terms of objects.

The Workings of Workbooks
The core document of Excel is a workbook. Everything that you do in Excel takes place in a workbook.

Beginning with Excel 2007, workbook “files” are actually compressed folders. You may be famil-
iar with compressed folders if you’ve ever used a file with a .zip extension. Inside the com-
pressed folders are a number of files that hold all the information about your workbook, including 
charts, macros, formatting, and the data in its cells.

An Excel workbook can hold any number of sheets (limited only by memory). The four types of 
sheets are

 Worksheets

 Chart sheets

 MS Excel 4.0 macro sheets (obsolete, but still supported)

 MS Excel 5.0 dialog sheets (obsolete, but still supported)

You can open or create as many workbooks as you want (each in its own window), but only one 
workbook is the active workbook at any given time. Similarly, only one sheet in a workbook is the 
active sheet. To activate a different sheet, click its corresponding tab at the bottom of the win-
dow, or press Ctrl+PgUp (for the previous sheet) or Ctrl+PgDn (for the next sheet). To change a 
sheet’s name, double-click its Sheet tab and type the new text for the name. Right-clicking a tab 
brings up a shortcut menu with some additional sheet-manipulation options.

You can also hide the window that contains a workbook by using the View➜Window➜Hide com-
mand. A hidden workbook window remains open but not visible. Use the View➜Window➜Unhide 
command to make the window visible again. A single workbook can display in multiple windows 
(choose View➜Window➜New Window). Each window can display a different sheet or a different 
area of the same sheet.

Worksheets
The most common type of sheet is a worksheet — which you normally think of when you think of 
a spreadsheet. Excel 2010 worksheets have 16,384 columns and 1,048,576 rows.

 

Versions prior to Excel 2007 support only 256 columns and 65,536 rows. If you open 
such a file, Excel 2010 enters compatibility mode to work with the smaller worksheet 
grid. In order to work with the larger grid, you must save the file in one of the Excel 
2010 formats. Then close the workbook and reopen it.
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Part I: Basic Information18

Having access to more cells isn’t the real value of using multiple worksheets in a workbook. 
Rather, multiple worksheets are valuable because they enable you to organize your work better. 
Back in the old days, when a spreadsheet file consisted of a single worksheet, developers wasted 
a lot of time trying to organize the worksheet to hold their information efficiently. Now, you can 
store information on any number of worksheets and still access it instantly.

You have complete control over the column widths and row heights, and you can even hide rows 
and columns (as well as entire worksheets). You can display the contents of a cell vertically (or at 
an angle) and even wrap around to occupy multiple lines. In addition, you can merge cells 
together to form a larger cell.

 

By default, every new workbook starts out with three worksheets. You can easily add a 
new sheet when necessary, so you really don’t need to start with three sheets. You may 
want to change this default to a single sheet. To change this option, choose the 
File➜Options command, click the General tab, and change the setting for the option 
labeled Include This Many Sheets.

Chart sheets
A chart sheet holds a single chart. Many users ignore chart sheets, preferring to use embedded 
charts, which are stored on the worksheet’s drawing layer. Using chart sheets is optional, but 
they make it a bit easier to locate a particular chart, and they prove especially useful for presen-
tations. I discuss embedded charts (or floating charts on a worksheet) later in this chapter.

Macro sheets and dialog sheets
This section discusses two obsolete Excel features that continue to be supported.

How big is a worksheet?

It’s interesting to stop and think about the actual size of a worksheet. Do the arithmetic (16,384 × 
1,048,576), and you’ll see that a worksheet has 17,179,869,184 cells. Remember that this is in just 
one worksheet. A single workbook can hold more than one worksheet.

If you’re using a 1600 x 1200 video mode with the default row heights and column widths, you 
can see 24 columns and 49 rows (or 1,176 cells) at a time — which is about .0000068 percent of 
the entire worksheet. In other words, more than 14.6 million screens of information reside within a 
single worksheet.

If you entered a single digit into each cell at the relatively rapid clip of one cell per second, it 
would take you over 500 years, nonstop, to fill up a worksheet. To print the results of your 
efforts would require more than 36 million sheets of paper — a stack about 12,000 feet high 
(that’s ten Empire State Buildings stacked on top of each other).
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An Excel 4.0 macro sheet is a worksheet that has some different defaults. Its purpose is to hold 
XLM macros. XLM is the macro system used in Excel version 4.0 and earlier. This macro system 
was replaced by VBA in Excel 5.0 and is not discussed in this book.

An Excel 5.0 dialog sheet is a drawing grid that can hold text and controls. In Excel 5.0 and Excel 
95, dialog sheets were used to make custom dialog boxes. UserForms were introduced in Excel 
97 to replace these sheets.

The Excel User Interface
A UI is the means by which an end user communicates with a computer program. A UI includes 
elements such as menus, dialog boxes, toolbars, and keystroke combinations, as well as features 
such as drag and drop.

A new UI
Almost every Windows program you use employs the menu and toolbar approach. That is, at the 
top of the screen is a menu bar that contains virtually every command that’s available in the appli-
cation, and below that is one or more toolbars, which provide shortcuts to some of the more fre-
quently used commands. With the release of Office 2007, the days of menus and toolbars are over.

The new UI for Excel consists of components like the Ribbon, Backstage View, the Mini Toolbar, 
and the Quick Access toolbar.

The Ribbon
The Ribbon is the primary UI component in Excel. It replaces the menu and most of the toolbars 
that were common in previous versions, and it is a very significant departure from the interfaces 
of most Windows-based applications.

One-stop shopping
Microsoft felt that the commands contained in the old menu and toolbar system were becoming 
so numerous that a new paradigm was necessary. One of the main goals for developing the 
Ribbon was to provide the user with a single place to look for a particular feature. Every com-
monly used command available in Excel would be contained in the Ribbon (or in a dialog box 
accessed via the Ribbon). Although Microsoft succeeded in putting most of the available com-
mands on the Ribbon, it’s still a pretty big place.

The Ribbon in Office 2007 received mixed reviews. Some people hated it, and others loved it. For 
some, the hatred was so severe that they sought Excel 2007 add-ins that restored the old menus. 
Others set up online petitions, asking Microsoft to restore the old menus for Office. Fact is, the 
Ribbon is here to stay. Once you get used to the Ribbon, it really is easier to use than the convo-
luted menu system that it replaced.
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A few commands failed to make the cut and do not appear in the Ribbon. But they are 
still available if you know where to look for them. Right-click the Quick Access toolbar 
and choose Customize Quick Access Toolbar. Excel displays a dialog box with a list of 
commands that you can add to your Quick Access toolbar. Some of these commands 
aren’t available elsewhere in the UI. In Excel 2010, you can also add new commands to 
the Ribbon: Right-click the Ribbon and select Customize The Ribbon.

Tabs, groups, and tools
The Ribbon is a band of tools that stretches across the top of the Excel window. About the verti-
cal size of three of the old-style toolbars, the Ribbon sports a number of tabs including Home, 
Insert, Page Layout, and others. On each tab are groups that contain related tools. On the Home 
tab, for example, you find the Clipboard group, the Font group, the Alignment group, and others.

Within the groups are the tools, which are similar to the tools that existed on the old-style tool-
bars with one major difference: their different sizes. Tools that you use most often are larger than 
less-frequently used tools. For example, nearly half of the Clipboard group is consumed by the 
large Paste tool; the Cut, Copy, and Format Painter tools are much smaller. Microsoft determined 
that the Paste tool is the most used tool and thus sized it accordingly.

The Ribbon and all its components resize dynamically as you resize the Excel window horizon-
tally. Smaller Excel windows collapse the tools on compressed tabs and groups, and maximized 
Excel windows on large monitors show everything that’s available. Even in a small window, all 
Ribbon commands remain available. You just may need to click a few extra times to access them.

Figure 1-2 shows three sizes of the Ribbon when the Home tab is displayed using an increasingly 
smaller horizontal window size.

Figure 1-2: The Ribbon sizes dynamically, depending on the horizontal size of Excel’s window.

Navigation
Using the Ribbon is fairly easy with a mouse. You click a tab and then click a tool. If you prefer to 
use the keyboard, Microsoft has added a feature just for you. Pressing Alt displays tiny squares 
with shortcut letters in them that hover over their respective tab or tool. Each shortcut letter that 
you press either executes its command or drills down to another level of shortcut letters. 
Pressing Esc cancels the letters or moves up to the previous level.
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For example, a keystroke sequence of Alt+HBB adds a double border to the bottom of the selec-
tion. The Alt key activates the shortcut letters, the H shortcut activates the Home tab, the B 
shortcut activates the Borders tool menu, and the second B shortcut executes the Bottom Double 
Border command. Note that it’s not necessary to keep the Alt key depressed while you press the 
other keys.

Contextual tabs
The Ribbon contains tabs that are visible only when they are needed. Generally, when a previ-
ously hidden tab appears, it’s because you selected an object or a range with special characteris-
tics (like a chart or a pivot table). A typical example is the Drawing Tools contextual tab. When 
you select a shape or WordArt object, the Drawing Tools tab is made visible and active. It con-
tains many tools that are only applicable to shapes, such as shape-formatting tools.

ScreenTips and dialog box launchers
Hovering over a tool on the Ribbon displays a ScreenTip that explains the command the tool will 
execute. ScreenTips are larger and, in most cases, wordier than the ToolTips from previous ver-
sions.

At the bottom of many of the groups is a small box icon (a dialog box launcher) that opens a dia-
log box related to that group. Users of previous versions of Excel will recognize these dialog 
boxes, many of which are unchanged. Some of the icons open the same dialog boxes but to dif-
ferent areas. For instance, the Font group icon opens the Format Cells dialog box with the Font 
tab activated. The Alignment group opens the same dialog box but activates the Alignment tab. 
The Ribbon makes using dialog boxes a far less-frequent activity than in the past because most 
of the commonly used operations can be done directly on the Ribbon.

Galleries and Live Preview
A gallery is a large collection of tools that look like the choice they represent. If you’ve used pre-
vious versions of Excel, you may have noticed that the font names in the drop-down list box on 
the Formatting toolbar were in their own font. Galleries are an extension of that feature. The 
Styles gallery, for example, does not just list the name of the style, but lists it in the same format-
ting that will be applied to the cell.

Although galleries help to give you an idea of what your object will look like when an option is 
selected, Live Preview takes it to the next level. Live Preview displays your object or data as it 
will look right on the worksheet when you hover over the gallery tool. By hovering over the vari-
ous tools in the Format Table gallery, you can see exactly what your table will look like before 
you commit to a format.

Backstage View
The big round Office Button in Excel 2007 has been replaced by a File tab that takes you to the 
Backstage View (see Figure 1-3). This is where you perform most of the document-related activi-
ties: creating new workbooks, opening files, saving files, printing, and so on.
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Figure 1-3: Clicking the File tab takes you to the Backstage View.

Backstage View also contains the list of recent documents (up to 50), with a pushpin icon next to 
each entry that you can use to keep that document at the top of the list regardless of how many 
files you open and close.

Plus, Backstage View gives you access to the Excel Options dialog box, which contains dozens of 
settings for customizing Excel.

Shortcut menus and the Mini Toolbar
Excel also features dozens of shortcut menus. These menus appear when you right-click after 
selecting one or more objects. The shortcut menus are context sensitive. In other words, the 
menu that appears depends on the location of the mouse pointer when you right-click. You can 
right-click just about anything — a cell, a row or column border, a workbook title bar, and so on.

Right-clicking many items displays the shortcut menu as well as a Mini Toolbar. The Mini Toolbar 
is a floating toolbar that contains a dozen or so of the most popular formatting commands. 
Figure 1-4 shows the shortcut menu and Mini Toolbar when a range is selected.
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Figure 1-4: The shortcut menu and Mini Toolbar appear when you right-click a range.

Customizing the UI
The Quick Access toolbar is a set of tools that the user can customize. By default, the Quick 
Access toolbar contains three tools: Save, Undo, and Redo. If you find that you use a particular 
Ribbon command frequently, right-click the command and select Add to Quick Access Toolbar. 
You can make other changes to the Quick Access toolbar from the Quick Access Toolbar tab of 
the Excel Options dialog box. To access this dialog box, right-click the Quick Access toolbar and 
select Customize Quick Access Toolbar.

A new feature in Excel 2010 lets you customize the Ribbon; this is done in the Customize Ribbon 
tab of the Excel Options dialog box. You can customize the Ribbon in these ways:

 Add a new tab

 Add a new group to a tab

 Add commands to a group

 Remove groups from a tab

 Remove commands from custom groups

 Change the order of the tabs
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 Change the order of the groups within a tab

 Change the name of a tab

 Change the name of a group

 Move a group to a different tab

 Reset the Ribbon to remove all customizations

That’s a fairly comprehensive list of customization options, but there are some actions that you 
cannot do:

 You cannot remove built-in tabs — but you can hide them.

 You cannot remove commands from built-in groups.

 You cannot change the order of commands in a built-in group.

Smart Tags
A Smart Tag is a small icon that appears automatically in your worksheet after you complete cer-
tain actions. Clicking a Smart Tag (or pressing Ctrl) reveals several options.

For example, if you copy and paste a range of cells, Excel generates a Smart Tag that appears 
below the pasted range (see Figure 1-5). Excel features several other Smart Tags, and additional 
Smart Tags can be provided by third-party providers.

Figure 1-5: This Smart Tag appears when you paste a copied range.
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Task pane
Excel 2002 introduced the task pane. This is a multipurpose UI element that is normally docked 
on a side of Excel’s window (but you can drag it anywhere you like). You can use the task pane 
for a variety of purposes, including displaying the Office Clipboard, providing research assistance, 
displaying pivot table fields, and mapping XML data. Figure 1-6 shows the task pane that appears 
when you insert clip art.

Figure 1-6: The Clip Art task pane allows you to search for and insert an image.

Drag and drop 
Excel’s drag-and-drop UI feature enables you to freely drag objects that reside on the drawing 
layer to change their position. Pressing Ctrl while dragging duplicates the selected objects. These 
objects include shapes, embedded charts, and SmartArt.

Excel also permits drag-and-drop actions on cells and ranges. You can easily drag the contents of 
a cell or range to a different position. And pressing Ctrl while dragging copies the selected range.

 

You can disable the ability to drag and drop the contents of cells. To change this set-
ting, choose File➜Options to display the Excel Options dialog box. Click the Advanced 
tab and clear the Enable Fill Handle and Cell Drag-and-Drop check box (located in the 
Editing Options section).

Keyboard shortcuts
In addition to the keyboard shortcuts for navigating the Ribbon, Excel has many other keyboard 
shortcuts that execute commands directly. For example, you can press Ctrl+C to copy a selection. 
If you’re a newcomer to Excel or if you just want to improve your efficiency, do yourself a favor 
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and check out the shortcuts listed in Excel’s Help system. (Search for keyboard shortcuts using 
the Search box or locate the topic under the Accessibility chapter of Help’s Table of Contents.) 
The Help system contains tables that summarize useful keyboard commands and shortcuts.

To ease the transition from previous versions, Microsoft includes the Office 2003 Access Key fea-
ture. Many Excel users are accustomed to navigating the old menu system with their keyboard, 
and they would become much more inefficient if they had to rely on the new Ribbon. If you type 
an Alt+letter sequence that isn’t a part of the Ribbon but that did exist in Excel 2003, you get a 
ScreenTip near the top of the Excel window, like the one shown in Figure 1-7.

Figure 1-7: Using a keyboard sequence like Alt+I+R (for Insert➜Row) can still be used to insert a row and 
will display this ScreenTip during the process.

Customized on-screen display
Excel offers some flexibility regarding on-screen display (status bar, Formula bar, the Ribbon, 
and so on). For example, by choosing View➜Workbook Views➜Full Screen, you can get rid of 
everything except the title bar, thereby maximizing the amount of visible information. To get out 
of full-screen mode, right-click and select Exit Fullscreen from the shortcut menu (or press Esc). 
A little less drastic is pressing the Ctrl+F1 shortcut key to hide (and restore) the Ribbon.

The status bar at the bottom of the screen can be customized. Right-click the status bar, and you 
see lots of options that allow you to control what information is displayed in the status bar.

Many other customizations can be made by choosing File➜Options and clicking the Advanced 
tab. On this tab are several sections that deal with what displays on-screen.

Data entry
Data entry in Excel is quite straightforward. Excel interprets each cell entry as one of the following:

 A value (including a date or a time)

 Text

 A Boolean value (TRUE or FALSE)

 A formula

 

Formulas always begin with an equal sign (=).
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Object and cell selecting
Generally, selecting objects in Excel conforms to standard Windows practices. You can select a 
range of cells by using the keyboard (by pressing the Shift key, along with the arrow keys) or by 
clicking and dragging the mouse. To select a large range, click a cell at any corner of the range, 
scroll to the opposite corner of the range, and press Shift while you click the opposite corner cell.

Data-entry tips

The following list of data-entry tips can help those moving up to Excel from another 
spreadsheet:

● To enter data without pressing the arrow keys, enable the After Pressing Enter, Move 
Selection option on the Advanced tab of the Excel Options dialog box (which you access 
from the Office➜Excel Options command). You can also choose the direction that you 
want to go.

● You may find it helpful to select a range of cells before entering data. If you do so, you can 
use the Tab key or Enter key to move only within the selected cells.

● To enter the same data in all cells within a range, select the range, enter the information 
into the active cell, and then press Ctrl+Enter.

● To copy the contents of the active cell to all other cells in a selected range, press F2 and 
then press Ctrl+Enter.

● To fill a range with increments of a single value, press Ctrl while you drag the fill handle at 
the lower-right corner of the cell.

● To create a custom AutoFill list, select the Edit Custom Lists button on the Popular tab of 
the Excel Options dialog box.

● To copy a cell without incrementing, drag the fill handle at the lower-right corner of the 
selection; or, press Ctrl+D to copy down or Ctrl+R to copy to the right.

● To make text easier to read, you can enter line breaks in a cell. To enter a line break, press 
Alt+Enter. Line breaks cause a cell’s contents to wrap within the cell.

● To enter a fraction, type 0, a space, and then the fraction (using a slash). Excel formats the 
cell using the Fraction number format.

● To automatically format a cell with the currency format, type your currency symbol before 
the value.

● To enter a value in percent format, type a percent sign after the value. You can also 
include your local thousand separator symbol to separate thousands (for example, 
123,434).

● To insert the current date, press Ctrl+; (semicolon). To enter the current time into a cell, 
press Ctrl+Shift+;.

● To set up a cell or range so that it accepts entries only of a certain type (or within a certain 
value range), choose the Data➜Data Tools➜Data Validation command.
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You can use Ctrl+* (asterisk) to select an entire table. And when a large range is selected, you 
can use Ctrl+. (period) to move among the four corners of the range.

If you’re working in a table (created with the Insert➜Tables➜Table command), you’ll find that 
(beginning with Excel 2007) Ctrl+A works in a new way. Press it once to select the table cells 
only. Press Ctrl+A a second time, and it selects the entire table (including the header and totals 
row). Press it a third time, and it selects all cells on the worksheet.

Clicking an object placed on the drawing layer selects the object. An exception occurs if the 
object has a macro assigned to it. In such a case, clicking the object executes the macro. To 
select multiple objects or noncontiguous cells, press Ctrl while you select the objects or cells.

The Excel Help System
One of Excel’s most important features is its Help system. The Help icon, a blue circle with a 
question mark in it, is located near the upper-right corner of the Excel window. Clicking the Help 
icon or pressing the F1 function key displays the Help system window, as shown in Figure 1-8.

Figure 1-8: The Excel Help system window.

The two primary methods for navigating Help are the Search box and the Table of Contents. 
Typing keywords into the Search box and clicking the Search button displays a list of relevant 
Help articles in the main window. The Table of Contents lists many related Help articles organized 
by chapters. The Table of Contents window can be hidden when not in use. Note that the Search 
button is actually a drop-down control. Click the small arrow, and you can choose the general type 
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of Help you need. By default, the content shown is downloaded from the Microsoft Office Web 
site: http://office.microsoft.com. If you do not have Internet access or you prefer to limit 
Help to articles on your computer, click the Connection status bar in the lower-right corner of the 
Help window. A small menu appears that allows you to specify which Help system to use.

Cell Formatting
Excel provides two types of cell formatting — numeric formatting and stylistic formatting.

Numeric formatting
Numeric formatting refers to how a value appears in the cell. In addition to choosing from an 
extensive list of predefined formats, you can create your own custom number formats in the 
Number tab of the Format Cells dialog box. (Choose the dialog box launcher at the bottom of the 
Home➜Number group.)

Excel applies some numeric formatting automatically, based on the entry. For example, if you 
precede a value with your local currency symbol (such as a dollar sign), Excel applies Currency 
number formatting. If you append a percent symbol, Excel applies Percent formatting.

 

Refer to Appendix B for additional information about creating custom number formats.

The number format doesn’t affect the actual value stored in the cell. For example, suppose that a 
cell contains the value 3.14159. If you apply a format to display two decimal places, the number 
appears as 3.14. When you use the cell in a formula, however, the actual value (3.14159) — not the 
displayed value — is used.

Stylistic formatting
Stylistic formatting refers to the cosmetic formatting (colors, shading, fonts, borders, and so on) 
that you apply in order to make your work look good. The Home➜Font and Home➜Styles 
groups contain commands to format your cells and ranges.

A formatting concept introduced in Excel 2007 is document themes. Basically, themes allow you 
to set many formatting options at once, such as font, colors, and cell styles. The formatting 
options contained in a theme are designed to work well together. If you’re not feeling particularly 
artistic, you can apply a theme and know the colors won’t clash. All the commands for themes 
are in the Themes group of the Page Layout tab.

Don’t overlook Excel’s conditional formatting feature. This handy tool enables you to specify for-
matting that appears only when certain conditions are met. For example, you can make the cell’s 
interior red if the cell contains a negative number. Excel 2007 introduced many new conditional 
formatting options, and Excel 2010 refined them.

05_475362-ch01.indd   2905_475362-ch01.indd   29 4/14/10   9:25 PM4/14/10   9:25 PM



Part I: Basic Information30

 

See Chapter 19 for more information on conditional formatting.

Tables
A table is a specially designated range in a worksheet. Converting a range into a table makes it 
easier to perform many operations on that data.

The data in a table is related in a specific way. The rows represent related objects, and the col-
umns represent specific pieces of information about each of those objects. If, for instance, you 
have a table of library books, each row would hold the information for one book. Columns might 
include title, author, publisher, date, and so on. In database terminology, the rows are records, 
and the columns are fields.

If your data is arranged in this fashion, you can designate it as a table by selecting the range and 
then choosing Insert➜Tables➜Table. Excel inserts generic column headings if none exist; the col-
umn heading includes drop-down controls. These drop-down controls, as well as the Table Tools 
context tab on the Ribbon, provide quick access to many table-related features like sorting, filter-
ing, and formatting. In addition, using formulas within a table offers some clear advantages.

 

See Chapter 9 for more information about the table feature.

Worksheet Formulas and Functions
Formulas, of course, make a spreadsheet a spreadsheet. Excel’s formula-building capability is as 
good as it gets. You will discover this as you explore subsequent chapters in this book.

Worksheet functions allow you to perform calculations or operations that would otherwise be 
impossible. Excel provides a huge number of built-in functions, including dozens of new functions 
introduced in Excel 2010.

 

See Chapter 4 for more information about worksheet functions.

Most spreadsheets allow you to define names for cells and ranges, but Excel handles names in 
some unique ways. A name represents an identifier that enables you to refer to a cell, range, 
value, or formula. Using names makes your formulas easier to create and read.

 

I devote Chapter 3 entirely to names.
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Objects on the Drawing Layer
As I mention earlier in this chapter, each worksheet has an invisible drawing layer, which holds 
shapes, SmartArt, charts, pictures, and controls (such as buttons and list boxes). I discuss some 
of these items in the following sections.

Shapes
You can insert a wide variety of shapes from Insert➜Shapes. After you place a shape on your 
worksheet, you can modify the shape by selecting it and dragging its handles. In addition, you 
can apply built-in shape styles, fill effects, or 3-D effects to the shape. Also, you can group multi-
ple shapes into a single drawing object, which you’ll find easier to size or position.

Illustrations
Pictures, clip art, and SmartArt can be inserted from the Insert➜Illustrations group. Figure 1-9 
shows some objects on the drawing layer of a worksheet.

Figure 1-9: Objects on a worksheet drawing layer. Excel makes a great doodle pad.

Linked picture objects
A linked picture is a shape object that shows a range. When the range is changed, the shape 
object changes along with it. To use this object, select a range and press Ctrl+C to copy it. Then 
choose Home➜Clipboard➜Paste➜Linked Picture. This command is useful if you want to print a 
noncontiguous selection of ranges. You can “take pictures” of the ranges and then paste the pic-
tures together in a single area, which you can then print.
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Controls
You can insert a number of different controls on a worksheet. These controls come in two flavors — 
Form controls and ActiveX controls. Using controls on a worksheet can greatly enhance the work-
sheet’s usability — often, without using macros. To insert a control, choose Developer➜Controls➜

Insert. Figure 1-10 shows a worksheet with various controls added to the drawing layer: a check 
box, two sets of option buttons, and a scroll bar.

 

The Ribbon’s Developer tab is not visible by default. To show the Developer tab, right-
click the Ribbon and select Customize The Ribbon to display the Excel Options dialog 
box. In the list box on the right, place a check mark next to Developer.

 

If you’d like to see how these controls work, the workbook shown in Figure 1-10 is avail-
able on the companion CD-ROM. The file is named worksheet controls.xlsx.

Figure 1-10: Excel enables you to add many controls directly to the drawing layer of a worksheet.

Charts
Excel, of course, has excellent charting capabilities. As I mention earlier in this chapter, you can 
store charts on a chart sheet or you can float them on a worksheet.

Excel offers extensive chart customization options. Selecting a chart displays the Chart Tools 
contextual tab, which contains basic tools to customize your chart. For more control, press Ctrl+1 
to display the Format dialog box for the selected elements. In addition, right-clicking a chart ele-
ment displays a shortcut menu.

You can easily create a free-floating chart by selecting the data to be charted and selecting one 
of the chart types from the Insert➜Charts group.

 

Chapter 17 contains additional information about charts.
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Sparkline graphics
A new feature in Excel 2010 is Sparkline graphics. A Sparkline is a chart that occupies a single 
cell. Sparklines are usually used in groups to provide a quick overview of trends in your data. 
Figure 1-11 shows a worksheet with Sparklines.

Figure 1-11: Sparkline graphics shows trends in your data.

Customizing Excel
This section describes two features that enable you to customize Excel — macros and add-ins.

Macros
Excel’s VBA programming language is a powerful tool that can make Excel perform otherwise 
impossible feats. You can classify the procedures that you create with VBA into two general 
types:

 Macros that automate various aspects of Excel

 Macros that serve as custom functions that you can use in worksheet formulas

 

Part VI of this book describes how to use and create custom worksheet functions 
using VBA.
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Add-in programs
An add-in is a program attached to Excel that gives it additional functionality. For example, you 
can store custom worksheet functions in an add-in. To attach an add-in, use the Add-Ins tab in 
the Excel Options dialog box.

Excel ships with quite a few add-ins, and you can purchase or download many third-party add-
ins from online services. My Power Utility Pak is an example of an add-in (use the coupon in the 
back of the book to order a copy at a discounted price).

 

Chapter 23 describes how to create your own add-ins that contain custom worksheet 
functions.

Internet Features
Excel includes a number of features that relate to the Internet. For example, you can save a work-
sheet or an entire workbook in HTML format, accessible in a Web browser. In addition, you can 
insert clickable hyperlinks (including e-mail addresses) directly into cells.

You can also create Web queries to bring in data stored in a corporate intranet or on the Internet.

Analysis Tools
Excel is certainly no slouch when it comes to analysis. After all, most people use a spreadsheet 
for analysis. Many analytical tasks can be handled with formulas, but Excel offers many other 
options, which I discuss in the following sections.

Database access
Over the years, most spreadsheets have enabled users to work with simple flat database tables. 
Excel’s database features fall into two main categories:

 Worksheet databases: The entire database is stored in a worksheet. In theory, an Excel 
worksheet database can have no more than 1,048,575 records (because the top row 
holds the field names) and 16,384 fields (one per column). In practice, such a large data-
base is not possible.

 External databases: The data is stored outside Excel, such as in an Access file or in SQL 
Server.

Generally, when the cell pointer resides within a worksheet database, Excel recognizes it and dis-
plays the field names whenever possible. For example, if you move the cell pointer within a work-
sheet database and choose the Data➜Sort & Filter➜Sort command, Excel allows you to select 
the sort keys by choosing field names from a drop-down list.
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A particularly useful feature, filtering, enables you to display only the records that you want to 
see. When Filter mode is on, you can filter the data by selecting values from pull-down menus 
(which appear below the field names when you choose the Data➜Sort & Filter➜Filter command). 
Rows that don’t meet the filter criteria are hidden. See Figure 1-12 for an example.

If you convert a worksheet database into a table (by using Insert➜Tables➜Table), filtering is 
turned on automatically.

Figure 1-12: Excel’s Filter feature makes it easy to view only the database records that meet your criteria.

If you prefer, you can use the traditional spreadsheet database techniques that involve criteria 
ranges. To do so, choose the Data➜Sort & Filter➜Advanced command.

 

Chapter 9 provides additional details regarding worksheet lists and databases.

Excel can automatically insert (or remove) subtotal formulas in a table that is set up as a data-
base. It also creates an outline from the data so that you can view only the subtotals or any level 
of detail that you desire.

Outlines
A worksheet outline is often useful when working with hierarchical data, such as budgets. Excel 
can create an outline automatically by examining the formulas in your worksheet (use the 
Data➜Outline➜Subtotal command). After you’ve created an outline, you can collapse or expand 
the outline to display various levels of details. Figure 1-13 shows an example of a worksheet outline.
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Figure 1-13: Excel can automatically insert subtotal formulas and create outlines.

Scenario management
Scenario management is storing input values that drive a model. For example, if you have a sales 
forecast, you may create scenarios such as best case, worst case, and most likely case.

Excel’s Scenario Manager can handle only simple scenario-management tasks, but most users 
find it adequate. However, it is definitely easier than trying to keep track of different scenarios 
manually.

Pivot tables
One of Excel’s most powerful tools is the pivot table, which enables you to display summarized 
data in just about any way possible. Data for a pivot table comes from a worksheet database (or 
table) or an external database, and it is stored in a special cache, which enables Excel to recalcu-
late data rapidly after a pivot table is altered.

 

Chapter 18 contains additional information about pivot tables.

As a companion to a pivot table, Excel also supports the pivot chart feature. Pivot charts enable 
you to link a chart to a pivot table.

Auditing capabilities
Excel also offers useful auditing capabilities that help you identify errors or track the logic in an 
unfamiliar spreadsheet. To access this feature, choose commands in the Formulas➜Formula 
Auditing group.

 

Refer to Chapter 21 for more information about Excel’s auditing features.
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Solver add-in
For specialized linear and nonlinear problems, Excel’s Solver add-in calculates solutions to what-
if scenarios based on adjustable cells, constraint cells, and, optionally, cells that must be maxi-
mized or minimized. Excel 2010 comes with a new version of Solver.

Protection Options
Excel offers a number of different protection options. For example, you can protect formulas 
from being overwritten or modified, protect a workbook’s structure, and protect your VBA code.

Protecting formulas from being overwritten
In many cases, you may want to protect your formulas from being overwritten or modified. To do 
so, you must unlock the cells that you will allow to be overwritten and then protect the sheet. 
First select the cells that may be overwritten and choose Home➜Cells➜Format➜Lock to unlock 
those cells. (The command toggles the Locked status.) Next, choose Home➜Cells➜Format➜
Protect Sheet to show the Protect Sheet dialog box. Here you can specify a password if desired.

 

By default, all cells are locked. Locking and unlocking cells has no effect, however, 
unless you have a protected worksheet.

When you protect a worksheet, the Protect Sheet dialog box (see Figure 1-14) lets you select 
which elements won’t be protected. For example, you can allow users to sort data or use 
AutoFiltering on a protected sheet.

Figure 1-14: Select which elements to protect in the Protect Sheet dialog box.

You can also hide your formulas so they won’t appear in the Excel Formula bar when the cell is 
activated. To do so, select the formula cells and press Ctrl+1 to display the Format Cells dialog 
box. Click the Protection tab and make sure that the Hidden check box is selected.
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Protecting a workbook’s structure
When you protect a workbook’s structure, you can’t add or delete sheets. Use the Review➜

Changes➜Protect Workbook command to display the Protect Structure and Windows dialog 
box, as shown in Figure 1-15. Make sure that you enable the Structure check box. If you also mark 
the Windows check box, the window can’t be moved or resized.

Figure 1-15: To protect your workbook’s structure, select the Structure check box.

 

Keep in mind that Excel is not really a secure application. The protection features, even 
when used with a password, are intended to prevent casual users from accessing vari-
ous components of your workbook. Anyone who really wants to defeat your protection 
can probably do so by using readily available password-cracking utilities.

Password-protecting a workbook
In addition to protecting individual sheets and the structure of the workbook, you can require a 
password to open the workbook. To set a password, choose File➜Info➜Protect Workbook➜

Encrypt With Password to display the Encrypt Document dialog box (see Figure 1-16). In this 
dialog box, you can specify a password to open the workbook.

Figure 1-16: Use the Encrypt Document dialog box to specify a password for a workbook.
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