
9Lesson 1, Navigating and Organizing in Snow Leopard

What you’ll learn 
in this lesson:
• Navigating the file and 

folder structure

• Multiple ways to 
view files

• Searching for files 
and folders on your 
computer

• The purpose of the 
Home folder

Navigating and Organizing 
in Snow Leopard

This lesson will guide you through the diff erent components of the 
Mac OS X interface while explaining how to customize the interface 
to make it your own.

Starting up
Because this lesson is about copying and moving fi les, you’ll perform this step later in the 
chapter as part of the lesson. Make sure you have the Digital Classroom DVD that came with 
this book near by to use when needed. If you are upgrading to Snow Leopard and do not have 
it installed on your Mac, jump ahead to Lesson 12, “Installing Snow Leopard and Applications,” 
and then return to this lesson once the installation is complete.

See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

1

Lesson 1
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1
The Finder
The core user interface component of Mac OS X is the Finder. The Finder is the visual 
connection between you and the computer. Without the Finder, you’d be relegated to a cryptic, 
code-based method of interacting with your computer—entering commands and instructions 
by typing instead of using your mouse. 

The Finder provides windows for navigating fi les on your hard drive, looking at the fi les, and a 
number of ways for interacting with your Mac. It also displays any hard drives, CDs, DVDs, and 
external drives you have connected to your computer. Let’s take a closer look at the Finder.

A

B C D E F G H I J K L M N O P Q

A. Hard drive. B. Finder. C. Dashboard. D. Mail. E. Safari. F. iChat. G. Address Book. H. iCal. I. Preview. J. iTunes. 
K. Time Machine. L. System Preferences. M. Dictionary. N. Applications. O. Documents. P. Downloads. Q. Trash.
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1
Finder windows
The primary way of navigating and working with fi les and folders on your Mac is through 
Finder windows. As the name implies, a Finder window allows you to see all the fi les and 
folders that are stored on your computer. Let’s take a look at how Finder windows work.

1 Open a new Finder window by double-clicking the hard drive icon in the upper-right 
corner of your desktop screen. A new Finder window appears on your screen. When you 
open a Finder window in this manner, it shows you the contents of the hard drive that 
you double-clicked to create the Finder window.

 Think of your hard drive as a fi ling cabinet. Within your hard drive (or fi ling cabinet) 
are fi les and folders containing things like photos, songs, and word processing documents. 
Think of a folder as an organizational component where you can store fi les of varying 
types. Everything that you see on the hard drive is either a fi le or a folder. In the Finder 
window that you just opened, you should see four folders: Applications, Library, System, 
and Users. These are the four main folders that are used by Snow Leopard. You will rarely 
work with the System and Library folders, as they are reserved for the operating system. 
Now let’s look a little deeper into the folder structure of your hard drive.

2 Press the Column view button ( ) at the top of the Finder window and select the 
Applications folder in the fi rst column of folders that are displayed in the Finder window. 
In the second column of the Finder window, all the application fi les are displayed. 
The Applications folder is the main folder where all your application fi les are stored in 
Snow Leopard.

The Finder window displaying the Applications folder and all the application fi les within that folder.
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1
3 Scroll down to the bottom of the second column and click Utilities. Again, the Finder 

window displays a new column with the contents of the Utilities folder. You can also tell 
what folder you are currently viewing by looking at the name of the Finder window 
at the top of the window. For example, after clicking the Utilities folder, you see that 
folder’s name displayed at the top of the window.

4 Click the lower right corner of the Finder window where there are three small diagonal 
lines, and drag to the left. This allows you to resize the Finder window, and controls 
how much content is displayed. If you make your Finder window too small, a scroll 
bar appears at the bottom of the window that allows you to scroll from one column to 
the other.

Resizing a Finder window that is too small to display all the content generates a scroll bar 
at the bottom of the Finder window to make navigating your fi les and folders easier.

5 There are three buttons in the upper left corner of each Finder window: the Close 
button ( ), the Minimize button ( ), and the Zoom button ( ).

 Press the green Zoom button to resize the Finder window to fi t all its content. 
Sometimes, if you are very deep into your folder structure, the Finder can only zoom 
your window as big as your screen. In these cases, you still have a scroll bar at the bottom 
of the Finder window to assist with navigating your folders and fi les.

6 Press the green Zoom button again, and your window returns to its previous size.
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1
7 Press the yellow Minimize button ( ). Your Finder window does a fun genie eff ect that 

minimizes the Finder window to a small icon in the Dock at the bottom of your screen. 
You’ll learn more about the Dock in the next lesson.

Clicking on the yellow Minimize button minimizes the Finder window to the Dock using Mac OS X’s genie eff ect.

To get a really good look at the eff ect that Mac OS X uses to minimize windows, hold down the 
Shift key on your keyboard while you click on the yellow Minimize button.

8 Move your cursor to the right side of the Dock. As you hover over each icon, it displays 
the icon’s name. When you see the Utilities window, click that icon and the window is 
maximized on the screen.

9 Press the red Close button ( ) to close the Utilities window.
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1
The toolbar
Every Finder window that you open contains a toolbar at the top of the window that is, by 
default, divided into fi ve areas. Let’s explore the toolbar in more detail.

Navigating fi les and folders
1 Double-click the hard drive icon to open a new Finder window. Select the Library 

folder in the fi rst column, then the Preferences folder in the second column, then the 
Audio folder in the third column.

 From this point forward in this book, to direct you to a specifi c folder, the following 
path annotation will be used /Library/Preferences/Audio. The fi rst forward slash 
indicates the main or root level of your hard drive. You navigate to the Library folder, 
then the Preferences folder inside the Library folder, then the Audio folder inside of the 
Preferences folder. You’ll often see this type of annotation used when describing a folder 
path in Mac OS X.

2 The fi rst area of the toolbar you’ll work with includes the navigation buttons, indicated 
by a left ( ) and right arrow ( ). Click the left arrow, and you are taken to your previous 
view; now the focus is on the Preferences folder.

The toolbar contains buttons that assist in navigation, viewing fi les, previewing fi les, and searching fi les.

3 Click the left arrow again to move back one more level in your viewing order. The 
current folder that you should be working in is the folder that is currently highlighted.

4 From the menu bar at the top of your screen, choose View > Show Path Bar. This 
displays the path bar at the bottom of each Finder window, which assists you when 
navigating fi les and folders, and allows you to easily identify your current folder path.

5 Click the right arrow button in the toolbar to move forward in your view history. This 
button is only available when you’ve already used the back button because the Finder 
already knows the last folder that was viewed. Otherwise, the Finder doesn’t know where 
you want to go.

6 Click the right arrow button again. You are now back to your original location of 
/Library/Preferences/Audio. This is easily identifi able in the path bar at the bottom 
of the Finder window. Think of this as a trail that allows you to fi nd your way back to 
where you started.

The path bar is a useful tool that allows you to quickly view your 
current path structure.

7 Press the red Close button ( ) to close this window.
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1
Changing how fi les and folders are displayed
Snow Leopard’s default view is the column view. It is the view that you’ve been working with, 
so far throughout this lesson. Let’s explore other viewing methods that Snow Leopard off ers.

1 Double-click the hard drive icon to open a new Finder window.

2 Press the fi rst button ( ) in the view section of the toolbar to display the fi les as icons. 
This view is a simpler method of viewing fi les and folders, and is useful for viewing fi les 
that have a preview; such as photos.

3 Navigate to /Library/Application Support/Apple/iChat Icons/Planets. A folder of 
photos exemplifi es the benefi t of the icon view because you get a nice preview of each 
icon and of what the fi le looks like.

4 In icon view, you see a slider in the lower right corner of the Finder window. Click and 
drag the slider to the right to make the fi le icons larger; click and drag the slider to the 
left to make the fi le icons smaller. Another benefi t of the icon view is that whatever size 
you set these icons to using the slider becomes the default size whenever you choose this 
view in Snow Leopard.

In icon view, you can adjust the size 
of the icons by dragging the slider.

5 Press the second button ( ) in the view section of the toolbar to change the view of 
the fi les to list view. This view displays the icons at a much smaller size than icon view 
but reveals pertinent information about each fi le, such as the date that the fi le was last 
modifi ed and the fi le’s size and kind.

 By default, fi les are sorted alphabetically when viewing them in list view. You can 
easily change this order by clicking any of the categories above the list of fi les in the 
Finder window.

6 Click the Name category, and the arrow to the right of Name changes direction, 
indicating that the sort order has been changed from ascending to descending.

7 Click the Name category again to switch back to ascending order. You can also sort by 
Date Modifi ed, Size, and Kind by clicking any of the header categories.

8 In the path bar at the bottom of the Finder window, double-click the hard drive icon to 
navigate to that location, then open the Applications folder.
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1
9 Press the fourth button ( ) in the view section of the toolbar to change the view of 

the fi les to Cover Flow view. Cover Flow view is a very dynamic way of viewing fi les, 
allowing you to quickly browse through a folder to see the contents of each fi le. This is a 
very useful view when working with a folder full of images.

Cover Flow view provides a dynamic method for browsing fi les within a folder.

 Click the right arrow ( ) in the main area of the Cover Flow view to browse the various 
fi les within the Applications folder.

 For a quicker method, click the slider in the main area of the Cover Flow view to 
browse the fi les.

10 Scroll through the list of fi les below the main area of the Cover Flow view and click a 
fi le to select it. The fi le is displayed in the main area of the Cover Flow view.
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1
Moving and copying fi les
The Finder is the primary location where you will be moving and copying (organizing) fi les 
on your computer. What is the diff erence between moving and copying? Well, moving a fi le 
relocates that fi le to a diff erent area on your computer, and the fi le no longer exists in its 
original source location. Copying, on the other hand, duplicates the fi le to a diff erent area 
on your computer, and the fi le exists in both the source and destination locations. How the 
Finder determines whether a fi le is copied or moved depends on a couple of factors. To further 
understand copying and moving fi les, you’ll copy fi les from the enclosed DVD.

Source Destination
Move

Source Result Destination

Source Destination
Copy

Source Result Destination

Moving a fi le causes the original fi le to be removed from the source location. 
Copying a fi le leaves the fi le in both the source and destination locations.

Copying fi les
In this section, you will copy fi les from the DVD supplied with this book to understand the 
process of copying fi les.

1 Insert the included DVD into your computer’s DVD drive.

2 When the DVD disc icon appears on your desktop (the main viewing area), double-click 
it to view the contents of the DVD.

3 Press the third button ( ) of the view section of the toolbar to display the fi les using 
column view; then select the sllessons folder to display its contents.
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4 Drag the sl01lessons folder from the Finder window to the desktop. You’ll notice a cursor 

that displays a green circle with a plus sign ( ), indicating that the folder you are dragging 
will be copied.

Dragging a fi le or folder from one volume to another makes a copy of that fi le or folder.

At this point, it’s important to understand that the sl01lessons folder was copied, not 
moved. The reason for this is that the sl01lessons folder was copied from a volume that is 
separate from your hard drive, a volume being defi ned as a single, accessible storage area. 
In this case, the DVD is that separate storage volume. Whenever a fi le or folder is dragged 
from one volume to another, the fi le or folder is automatically copied, not moved. 
Notice that the sl01lessons folder still resides on the DVD from which it was dragged.

5 Close all open Finder windows by pressing the Close button ( ) in each Finder window.

You can also close Finder windows using the keyboard shortcut Command+W.
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1

What is a shortcut?

As you are beginning to see, there are many ways to do the same thing within Snow Leopard. 
Shortcut keys are a way of performing repetitive tasks more effi  ciently. You perform shortcut 
keys by holding down a modifi er key, then pressing other keys on the keyboard. For example, 
to close an open Finder window using a shortcut key, hold down the Command key on your 
keyboard with one fi nger (preferably your thumb), then press the W key. The combination of 
these two keys tells Mac OS X to close the active Finder window.

Click the File drop-down menu in the menu bar at the top of your screen. If you chose the 
item Close Window, you’ll notice a shortcut key listed to the right of the menu item. This is 
that command’s shortcut key. You’ll notice a multitude of shortcut keys listed next to each menu 
command, and you’ll notice even more of those shortcuts as you continue working with Snow 
Leopard and with other applications. Does that mean you need to know all of these shortcut 
keys? Absolutely not! If you fi nd that you are continually going to the menu bar to perform the 
same action over and over again, learn the keyboard shortcut. You’ll fi nd yourself becoming a 
much more effi  cient user by doing so.

 Double-click the sl01lessons folder on your desktop to open it. You see a number of 
pictures inside the sl01lessons folder. If you look at the very bottom of the Finder 
window, you can see more detailed information about the sl01lessons folder. Specifi cally, 
you see that there are eight items within the folder and the amount of space remaining 
on the volume where this folder resides.

The bottom of the Finder window displays valuable information about the contents of a folder 
and the amount of space left on the volume.

Moving fi les
Files are moved whenever they are dragged to a diff erent location within the same volume or 
disk. During a move, the fi le is relocated and no longer exists in its original location.

1 Close any Finder windows that are currently open on your screen.

2 Double-click the hard drive icon on your desktop to open a new Finder window.

3 Make sure that your view is set to column, and navigate to /Users/Home folder/
Pictures, where Home folder is the icon within the Users folder that has a house icon 
( ) next to it. The Home folder will be discussed in more detail later in this lesson.
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4 Select the sl01lessons folder on your desktop with your mouse, then drag and drop 

it onto the Pictures folder in the Finder window. This time, you’ll notice that the 
sl01lessons folder is moved to the Pictures folder and is no longer available on the 
desktop. This is because the Pictures folder and the desktop are on the same volume. 
When a fi le or folder is moved from one location to another on the same volume, the 
fi le or folder no longer resides in the source location.

Dragging the sl01lessons folder from the desktop to the Pictures folder moves the 
folder because both the source and destination locations reside on the same volume.

If you need to copy a fi le from one location to the other within the same volume, you can do so by 
clicking on the fi le or folder in the source location and choosing Edit > Copy from the menu bar. 
Then click the destination folder and choose Edit > Paste. For an even faster method, simply hold 
down the Option key on your keyboard while your drag a fi le or folder from one location to the 
other; instead of moving the fi le or folder, the system copies it.
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1
Organizing fi les and folders
As you work with fi les and folders in Snow Leopard, you’ll want to stay organized by grouping 
fi les into folders that represent a category where fi les will be stored.

1 Make sure you are still viewing the Pictures folder within your Home folder and are in 
Column view.

2 Click the Pictures folder to highlight it, then choose File > New Folder. The folder 
name defaults to untitled folder and is highlighted, meaning that you can change the 
name of the folder by simply typing. Type Nature and press Return on your keyboard. 
Pressing Return commits the name change.

3 Click the Pictures folder again to highlight it and choose File > New Folder. Name this 
folder Creative.

4 Repeat step 3 to create a New York folder.

5 Click the sl01lessons folder within the Pictures folder. Drag the Boat.jpg fi le and drop it 
onto the Creative folder. Repeat this for the Bridge.jpg fi le.

6 With the sl01lessons folder still selected, hold down the Command key and click the 
Apple.jpg, Clouds.jpg, Ice.jpg, and Sweet Gum.jpg fi les. Drag any of the highlighted fi les 
to the Nature folder.

Holding down the Command key when selecting fi les allows you to non-contiguously select more 
than one fi le at a time.

7 With the sl01lessons folder still selected, hold down the Shift key and click Liberty.jpg 
and NYC.jpg. Drag any of the highlighted fi les to the New York folder. The sl01lessons 
folder is now empty.

Holding down the Shift key when selecting fi les allows you to select a range of contiguous fi les.

8 Click each of the folders that you created earlier in this exercise to see the fi les that you 
have moved. Each folder now contains fi les related to each category.

9 The sl01lessons folder is now empty and is no longer needed. Click the sl01lessons 
folder, drag it to the bottom of your screen, and drop it on the Trash icon at the right 
side of the Dock. The Trash icon now appears full, meaning that it contains a fi le.

When you drag fi les to the Trash icon, 
the icon changes to a full trash can.
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1
10 Dragging a fi le to the Trash icon moves it from its current location but doesn’t actually 

delete the fi le. If you double-click the Trash icon in the Dock, you can see the sl01lessons 
folder within the Trash folder.

11 Close the Trash folder.

12 In the menu bar at the top of the screen, choose Finder > Empty Trash. 

13 You’ll receive a dialog box asking if you are sure you want to permanently erase the 
items in the Trash. Press the Empty Trash Button. This permanently removes the contents 
of the Trash folder.

Quick Look
So far in this lesson, you’ve seen how easy it is to change the diff erent viewing options within 
a Finder window, which allows you to see your fi les and folders in diff erent ways. There will be 
times, however, when you have a folder that contains pictures where you’d like to see those fi les 
in more detail without opening them with another program. That’s where Quick Look comes 
in. Although Quick Look is not new in Snow Leopard, it is a welcome tool that allows you to 
preview fi les on your computer quickly and easily.

1 Open a new Finder window, if there isn’t one already open, and navigate to the Nature 
folder within the Pictures folder that you created in the previous exercise.

2 Select the fi le called Apple.jpg and press the Quick Look button ( ) in the toolbar. The 
Finder displays a full-sized preview of the fi le for you to examine.

Quick Look allows you to quickly see a preview of a fi le without opening it in a separate application.
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1
3 When you are fi nished, press the Close button ( ) in the upper left corner of the Quick 

Look window.

4 Select the Clouds.jpg fi le and this time, press the spacebar on your keyboard. Pressing the 
spacebar is the shortcut to quickly open a fi le using Quick Look.

5 Press the double-arrow button ( ) at the bottom of the Quick Look window to view 
the fi le at full screen.

6 Let go of your mouse for a few seconds; all navigation tools temporarily disappear, giving 
you an unobstructed view of the image.

7 Move your cursor on screen; a navigation bar appears, giving you two options, Exit Full 
Screen and Close. Choose Exit Full Screen, then press the Close button to close the 
Quick Look window.

Moving your cursor back onto the Full Screen view displays the navigation 
bar, allowing you to Exit Full Screen, or Close the window.

8 Close any open Finder windows.

When you are in Full Screen mode in Quick Look, you can also exit Full Screen mode by 
pressing the Esc key on your keyboard.

As you can see, Quick Look can be an extremely useful tool when browsing visually 
relevant fi les such as photos and other graphics. Experiment on your own with Quick 
Look by viewing some of your own images that you’ve copied to your hard drive.

The sidebar
In addition to the toolbar, every Finder window also has a sidebar. The sidebar is an area that 
contains available resource locations on your computer, including hard drives, shared network 
drives, frequently visited locations, and popular searches. Let’s examine how the sidebar can 
make easy work of navigating your computer.

1 Double-click the hard drive icon on your desktop to open a new Finder window.
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2 Notice that the hard drive of your computer is selected in the sidebar and its contents 

are displayed in the main area of the Finder window. This is what the Devices section is 
for. You can see in the following fi gure that any external hard drives that you plug into 
your computer also show up in this category. Clicking any of these drives in the sidebar 
displays that drive’s contents.

The sidebar displays available resource locations, as 
well as commonly accessed areas of your computer.

 The Shared section of the sidebar displays any computers on the same network as yours 
that have File Sharing enabled. If you don’t see this section on your screen, it’s because 
there are no shared computers on your network to display.

3 Click the Applications entry under the Places section of the sidebar. You are immediately 
taken to the Applications folder on your computer, the same location that you’ve been 
manually navigating to thus far in this lesson. The Places section of the sidebar displays 
commonly accessed areas of your computer for quick navigation.
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1
4 Select the Today entry in the Search For section of the sidebar. This displays all fi les that 

were opened today, including applications. This can be useful when trying to locate fi les 
that you just opened and need to quickly access again. The fi les listed on your computer 
will most likely be diff erent than the following example.

The Search For section allows you to quickly see fi les that have been opened within a specifi c time frame or within 
a certain category.

5 Click the All Images entry in the Search For section of the sidebar. This displays all the 
images on your computer. Although not particularly useful in itself, it does demonstrate 
the power of Smart Folders, which you’ll learn about later on in this lesson. Smart 
Folders can be customized to suit your particular needs.

The Home folder
Probably the most important folder to you as a Snow Leopard user is the Home folder. The 
Home folder is a central storage location for all your fi les and is designated by a house icon ( ); 
it protects your information from other users of your computer, and organizes your information 
for quick access. The Home folder is also what allows each user on a computer to have a 
customized working environment that complements the way they like to work. Every user 
account created on your computer has its own Home folder where that user can store his or her 
information. Let’s explore the Home folder in more detail.
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1 Choose File > New Finder Window or press Command+N on your keyboard. When 

you create a new Finder window in this manner, your Home folder is displayed 
automatically by default.

2 Set the view method to List view. There are nine folders created inside of your Home 
folder automatically, although you are certainly not limited to those nine. You can add as 
many as you like, but you’ll fi nd that most categories that you need are covered within 
the default folders that are provided.

Desktop
The Desktop of your computer—the area where your hard drives are displayed and the large 
space image is visible by default— can also be accessed as a folder. There are actually two 
desktop folders, let’s take a look at how you access them.

1 Navigate to the Applications folder on your computer.

2 Find the application called TextEdit and double-click it to launch the application. 
TextEdit is a basic text-editing application provided with Snow Leopard, in which you 
can type documents.

3 In the Untitled window that appears, type This is my fi rst fi le.

Creating a fi le using TextEdit.

 When an application is opened in Snow Leopard, the name of the application appears in 
the menu bar in the upper left corner of your screen. This tells you that the application is 
currently active. If, by chance, you click on the desktop of your computer, Finder appears 
in the upper left corner of your screen, indicating that the Finder is now the active 
application. If you’ve done this, be sure to click the TextEdit window to make TextEdit 
the active application.
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1
4 Choose File > Save. Because this fi le has never been saved, Mac OS X automatically 

opens the Save As dialog box, which asks for a name for the fi le. Type My File in the 
Save As text fi eld.

5 Choose Desktop from the Where drop-down menu.  

6 Click the arrow to the right of the Save As text fi eld to display the standard Save 
As dialog box, which provides more options than the ones available in the Where 
drop-down menu.

7 Press Save. The fi le is saved to your Desktop folder.

Clicking the arrow to the right of the Save As fi eld displays an expanded window that allows 
you to save your fi le in a specifi c location.
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1
8 Quit TextEdit by choosing TextEdit > Quit TextEdit.

 This is where the concept of the Desktop folder becomes more evident. If you look on 
your computer’s desktop, you see the fi le that you just saved, My File. However, if you 
navigate to the Desktop folder using a Finder window, you see that My File also resides 
there. It’s important to understand that these are not two separate locations; they are one 
and the same. Anything that you copy to the main desktop of your computer always 
appears in the Desktop folder of your Home folder as well.

The main desktop and the Desktop folder are one and the same.

Documents
The Documents folder is a catchall for the majority of documents that you create on your 
computer. Word documents, TextEdit documents, and any other application fi les that you create 
can be stored here. Some programs even automatically use your Documents folder to store the 
support fi les required by the application.

Downloads
This folder can be used to store fi les that you have downloaded from the Internet and other 
locations. Safari, the Web browser supplied with Snow Leopard, uses this folder any time you 
download a fi le from the Internet.
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Library
This folder is reserved for system fi les that are specifi c to your user account. You will spend the 
least amount of time in this folder, and it’s actually recommended that unless you are directed to 
modify this folder by a support professional, or you are an advanced user, you should leave this 
folder alone.

Movies
Simply stated, this folder is an area to store movies. Applications such as iMovie, which is a 
movie-editing program created by Apple as part of the iLife suite of applications, uses this folder 
to store imported movie fi les and editing information about your movies.

Music
This folder can be used to store all the digital music that you’ve downloaded to your computer. 
You probably won’t spend too much time directly in this folder. The free iTunes music player 
uses this folder to store all music imported using iTunes or downloaded from the iTunes Music 
Store. If you’re already using iTunes, you’ll notice that an iTunes folder already exists in this 
location. Another application that uses this folder is GarageBand, which is also an application 
that Apple provides as part of the iLife suite of applications.

Pictures
Earlier in this lesson, you moved a folder of images into the Pictures folder as an organizational 
step. The Pictures folder is a central repository where you can store all the images that you 
copy to your computer. The iPhoto application, which is an application created by Apple as 
part of the iLife suite of applications, uses your Pictures folder to store your photos as well as 
information about them. If you’re already using iPhoto, you’ll notice that there is an iPhoto 
Library located within your Pictures folder. The Photo Booth application, which ships with 
Snow Leopard, also stores fi les within the Pictures folder for easy organization.

Public
The Public folder allows you to share fi les with other users, and vice versa. File Sharing is 
discussed in Lesson 3, “Using Snow Leopard with a Group.”

Sites
Every copy of Snow Leopard ships with powerful, fully functional web server software, allowing 
you to create and share web pages with anyone on your network and potentially anywhere 
in the world! Although sharing web pages beyond the boundaries of your network is beyond 
the scope of this book, Lesson 7, “ Creating and Using Your Own Network,” discusses how to 
enable the web server software on your computer and how to share a basic web page.

When writing out a folder path for fi les in your Home folder, you often see it written like this: 
~/Pictures/Christmas Vacation. The tilde (~) indicates your Home folder. So to access the folder, 
you would open your Home folder, the Pictures folder, then the Christmas Vacation folder.
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Now that you understand the concept behind the Home folder and what each folder is used 
for, you can begin storing fi les in their appropriate locations. Don’t forget that within each 
folder, you can create subfolders to further organize your fi les. For instance, in the Documents 
folder, you may create a subfolder called recipes where you store all the recipes that you’ve 
typed out on your computer for later retrieval. 

Finding your fi les
No matter how careful or experienced you are as a computer user, you’re bound to move, copy, 
or save a fi le in a location that you hadn’t intended to. Or maybe you do know where you saved 
the fi le, but there are so many fi les displayed that it’s diffi  cult to fi nd the fi le you’re looking for. 
Regardless of the reason for your frustration, Snow Leopard off ers a number of useful methods 
that make fi nding your fi les easier and faster than looking for them manually. Let’s explore some 
of the diff erent methods that can be used to fi nd your fi les.

Smart Folders
Smart Folders in Snow Leopard are, well, smart! They are diff erent from the standard folders that 
you created earlier in this lesson, which are basically storage locations where you can organize 
your fi les. Smart Folders add a level of intelligence that allows you to work more effi  ciently and 
fi nd fi les with ease by establishing criteria by which the folder automatically displays those fi les. 

So far, in the Pictures folder of your Home folder, you’ve organized some photos into logical 
categories. This will make it easier to fi nd a photo in the future. Let’s say, however, that you can’t 
remember what category you fi led your photo in and you want to just look at all the images 
in your Pictures folder. That would be rather diffi  cult to do, as everything is fi led inside one of 
several folders within the Pictures folder. In the following steps, you’ll create your own Smart 
Folder to fi nd all the images in your Pictures folder.

1 Open a new Finder window and navigate to the ~/Pictures folder.

2 Choose File > Find. This changes your Finder window into a Search window.

3 In the Search bar below the toolbar, click Pictures to limit the search to only the 
Pictures folder.

4 In the criteria bar below the Search bar, choose Kind from the fi rst drop-down menu, 
Image from the second drop-down menu, and JPEG from the third drop-down menu. 
You are now fi nding all images that are in the JPEG format inside of the Pictures folder.

Smart Folders allow you to defi ne search criteria for each folder.
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5 At the far right of the Search bar, press the Save button. A dialog box appears, asking 

where you would like to save your Smart Folder.

6 Type Images in the Save As text fi eld.

7 You can save this Smart Folder anywhere you’d like. In this example, leave it set to the 
Saved Searches folder and leave the Add To Sidebar checkbox selected.

Selecting the Add To Sidebar check box causes the Smart Folder to appear in 
the sidebar of every Finder window for easy access.

8 Press Save. If you look at the sidebar of any Finder window, you now see your Smart 
Folder called Images. If you click this Smart Folder in the sidebar, you see all the JPEG 
fi les that exist in the Pictures folder.

9 Click the Apple.jpg fi le to select it. Note the path in the path bar at the bottom of the 
Finder window.

 It’s important to understand that none of the fi les that appear within a Smart Folder 
actually reside in that Smart Folder. It simply displays images that match the criteria 
that are defi ned by the Smart Folder. You’ll notice that this image actually resides in 
the ~/Pictures/Nature folder. The exact same fi le can appear in multiple Smart Folders 
if it meets the criteria of all those Smart Folders, but the actual fi le only resides in 
one location.

 What makes Smart Folders so powerful is that they are dynamic. This means that as 
you add pictures to the diff erent categories of your Pictures folder or even add new 
categories, Smart Folders that you have created display those new images automatically 
because the images match the search criteria defi ned within the Smart Folders.

 Let’s create another Smart Folder to see how more than one criterion can be used to 
fi nd applications that have been opened within the last two days.

11 Open a new Finder window and navigate to the Applications folder.

12 Press Command+F on your keyboard to display the search window.

13 Click Applications in the Search bar.

14 In the criteria bar, choose Kind from the fi rst drop-down menu, and Application from 
the second drop-down menu. This displays all applications in the Applications folder.
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15 Click the plus sign (+) to the right of the criteria bar to add another criterion by which 

to fi lter the applications. Choose Last opened date from the fi rst drop-down menu, 
within last from the second drop-down menu, type 2 in the text fi eld, and choose days 
from the last drop-down menu.

Defi ning multiple search criteria in a Smart Folder refi nes what the Smart Folder displays.

16 Press the Save button to the right of the Search bar to save these settings as a 
Smart Folder.

17 Name this folder Recent Applications, save it in the Saved Searches folder, and leave 
the Add To Sidebar checkbox selected.

18 Press Save.

 Now that you’ve seen the capabilities of Smart Folders, your only limit is your 
imagination. Smart Folders can simplify your computing experience and save you a lot of 
time by displaying what you want to see in one folder.

Burn Folders
Burn folders are another special type of folder that allow you to prepare fi les to be burned to 
a CD or DVD disk. Depending on which computer you own, your ability to write CDs and 
DVDs will depend on which model Mac you purchased. All recent Macs have the ability to 
write to or burn a CD but not all models can write to or burn a DVD.

1 Make sure there are no Finder Windows open on your screen. Choose File > New Burn 
Folder. A folder is created on your Desktop. You can name this folder whatever you like 
but for this exercise, you’ll leave the name as Burn Folder.

A burn folder allows you to copy fi les to this 
folder and later be written to a CD/DVD.

2 Choose File > New Finder Window and open the Pictures folder in the Home folder.

3 Drag the Nature, Creative, and New York folders onto the Burn Folder on the Desktop.
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4 Double-click the Burn Folder to display its contents. Note that each folder has an arrow 

in the lower left corner of each folder’s icon. This indicates that each folder is an alias, 
which is a pointer to the original folders. The original folders still reside in the Pictures 
folder. Aliases are covered in more detail in Lesson 2, “Customizing the OS X Interface 
to Suit Your Needs.”

5 With the current Finder Window displaying the contents of the Burn Folder, you’ll 
notice a Burn button in the upper right corner of the Finder Window. Press the Burn 
button to initiate writing to a CD or DVD. Don’t worry, you won’t actually burn a disk 
here, you’ll just walk through the steps.

The burn button in the upper right corner of the Finder Window 
initiates the writing of fi les to a CD or DVD disk.

6 A Burn Disc dialog box is displayed indicating that it is ready to burn the fi les to a disc. If 
you insert a blank disc at this point, the fi les will be written to that disc. Press the Cancel 
button to abort the process.

The Burn disc dialog box asks for a blank disc to begin burning the fi les to a CD or DVD.

7 Close any open Finder windows and drag the Burn Folder to the Trash.

SnowLeopard.indb   33SnowLeopard.indb   33 9/9/2009   3:45:23 PM9/9/2009   3:45:23 PM



34

Finding your files

Mac OS X Snow Leopard Digital Classroom

1
Spotlight
Spotlight is a search tool built into Snow Leopard that allows you to search and fi nd fi les on 
your computer or other computers on your network with unbelievable ease. You’re bound to 
encounter a situation where you’ve saved a fi le somewhere on your computer, but simply can’t 
recall where you saved it. But unless you remember what you named the fi le, the process of 
fi nding that fi le can be lengthy.

Spotlight solves that problem by providing an extremely powerful tool for fi nding fi les on your 
computer. It is to your computer what Google is to the World Wide Web. Although Spotlight is 
not new in Snow Leopard, its functionality has been enhanced to provide you, the user, with a 
simple and elegant method for fi nding fi les on your computer. You already used Spotlight in the 
previous exercise when you created a Smart Folder. Although Spotlight can be accessed using 
the Search fi eld in any Finder window, you’ll access Spotlight directly in the following steps. 
Let’s see how easy it is to fi nd fi les using Spotlight.

1 Click the Spotlight icon ( ) in the upper right corner of your screen, or use the 
keyboard shortcut, Command+spacebar, to launch Spotlight.

 Let’s say that you remember saving a fi le called Clouds.jpg (you did this in a previous 
exercise) somewhere on your computer, but can’t remember where.

2 In the Spotlight search text fi eld, type clouds. Immediately, under the Top Hit section of 
the search results, you see that the Clouds.jpg fi le is listed.

 Notice that you didn’t even have to type the entire name of the fi le; Spotlight 
automatically searched your computer for fi les that contained the word Clouds in the 
name and displayed the results.

3 Hover your cursor over the Clouds.jpg entry in the search results, and notice that the fi le 
path is displayed, showing you exactly where the fi le is stored.

Hover your cursor on an item in the search results list and 
the fi le path is displayed.

4 Click the item in the search results, and Spotlight opens the image using the 
Preview application.

5 Choose Preview > Quit Preview to close the application.
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Beyond fi lenames
You’ve just seen how quickly you can fi nd a fi le on your computer by using Spotlight, and 
typing in the name of the fi le in Spotlight’s search fi eld. However, what happens if you can’t 
remember the fi lename? This is where Spotlight’s power reveals itself. You see, whenever you 
copy, save, update, or delete a fi le on your computer, the Spotlight Store goes to work. The 
Spotlight Store is a database stored on your computer that keeps track of a fi le’s content and 
metadata. What’s metadata? Let’s ask Spotlight.

1 Click the Spotlight icon ( ) in the upper right corner of your screen and type 
metadata in the search text fi eld.

2 In the search results, click the Defi nition entry for a description of metadata. The 
Dictionary application on your computer is launched and the defi nition of Metadata is 
displayed in a new window.

Spotlight also displays word defi nitions.

 As you can see, Spotlight searches much more than just a fi le’s name. As a matter of 
fact, it searches more than fi les; it also searches defi nitions and even web pages. As the 
Dictionary reveals, metadata is data that describes other data. For example, images often 
contain metadata describing what type of camera was used to capture an image, as well 
as keywords about the image that may have been entered by the photographer. In the 
following steps, you’ll search for photos on your computer that were taken using a 
Canon camera.

3 Press Command+spacebar on your keyboard and type Canon in the search text fi eld. A 
number of fi les are displayed in the search results, all categorized neatly in a list.
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4 Look under the Images category. You see all the images that you copied to the 

Pictures folder.

A search for “Canon” yielded many results for fi les that did not contain 
the word in the fi lename but did contain the word within the metadata.

 How did Spotlight know that these fi les should be listed when a search for Canon was 
performed? Metadata. Metadata is embedded within each fi le by the digital camera 
that took the picture, and Spotlight recognized that Canon was contained within 
that metadata.

5 Click the Bridge.jpg fi le to open it with the Preview application.

6 Choose Tools > Show Inspector to display information about the fi le.

7 Click the More info button ( ), then click the TIFF button to display the Metadata 
information for that category; you can see the make and model of the camera that was 
used to capture this image.
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8 Choose Preview > Quit Preview to exit the application.

 In addition to metadata, Spotlight also indexes the contents of each fi le automatically. 
Remember the fi le called My File that you created earlier in this lesson? Let’s say that 
you can’t remember what you named the fi le, but you remember maybe a sentence 
or two from the content that was typed within that fi le. Spotlight can search for that 
information as well.

9 Press Command+spacebar on your keyboard and type this is my in the search text 
fi eld. The fi rst fi le listed under the Documents category is My File, the fi le that you 
created earlier.

 Now you can begin to understand how powerful Spotlight’s search capabilities are 
and how you can put them to use in your daily computing experiences. Spotlight also 
searches your e-mail messages, contacts, calendar events, and much more, which enhances 
your ability to fi nd what you need.

Self study
Practice what you’ve learned in this lesson by copying your own fi les to your computer. Use 
the relevant categories within your Home folder to make fi nding your fi les easier. Then use 
Spotlight’s search capabilities to fi nd specifi c fi les based on their content or metadata. Practice 
navigating the folder structure of your hard drive. Try to become more comfortable with the 
Finder windows and the diff erent views that allow you to browse your fi les in diff erent ways.

Review

Questions
1 How do you force a fi le to be copied when moving that fi le within the same volume?

2 What is the purpose of the Home folder?

3 What type of folder can fi lter fi les on your computer based on specifi c search criteria?

Answers
1 Hold down the Option key on your keyboard while moving the fi le.

2 The Home folder provides a location for you to store your fi les where they are not 
accessible to other users on the computer. It also allows each user on a computer to have 
his or her own personalized working environment separate from everyone else.

3 A Smart Folder.
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