
1Lesson 1, Importing your Photos into Adobe Photoshop Elements

What you’ll learn 
in this lesson:
• Adding files to the 

Organizer

• Understanding 
workspaces

• Using the Photo 
Downloader

• Creating an album

Importing your Photos into Importing your Photos into 
Adobe Photoshop ElementsAdobe Photoshop Elements

Adobe Photoshop Elements is an easy-to-use solution for organizing 
and editing your digital photos. You will be up-and-running, creating 
beautiful photographs before you know it. To start, you’ll need to 
import images from your camera or computer.

Starting up
You will work with several fi les from the Lessons folder in this lesson. Make sure that you have 
copied the Lessons folder from the supplied DVD onto your hard drive. In order to access these 
fi les in the Organizer, you need to import them, which you will do in this lesson. 

Before you start, note that the Photoshop Elements Editor remembers the last panel layout that 
you used. Before starting, make sure your tools and panels are consistent with the examples 
presented in these lessons by resetting the panels, by choosing Window > Reset Panels within 
the Editor.

If you aren’t ready to start working with your own images, you can jump ahead to “Adding 
Files and Folders to the Organizer” on page 11 to start working with fi les from the DVD that 
came with this book.

Lesson 1
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How Photoshop Elements works

Adobe Photoshop Elements 8 Digital Classroom

1

See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

How Photoshop Elements works
The fact that you’re reading this book indicates that you probably already own or are 
considering purchasing a digital camera. It’s probably also accurate to say that you’ve been 
taking pictures and truly enjoying the fl exibility that digital photography has to off er. The 
ability to shoot as many images as you like—or at least as many as will fi t onto your camera’s 
memory card—is one advantage that digital photography has over traditional fi lm cameras. 
Another advantage is that you can choose which images to keep and which ones to delete from 
your camera’s memory card, instead of sifting through the photos that you had developed at 
your local photo store, picking out the good ones, and throwing the bad ones away. With digital 
photography, you only pay for the good photos!

So you’ve fi gured out how to shoot pictures with your digital camera but you’ve found that 
the clunky interface on your camera requires a lot of time to sift through the images in order 
to delete the poor photos that you don’t want. In addition, your photos may be accumulating 
on your camera’s memory card, requiring you to constantly remove images to make room for 
new ones. These are only a few of the problems that people are faced with in this new world of 
digital photography, and this is where Adobe Photoshop Elements fi lls a void.

Photoshop Elements provides you with the ability to import, organize, adjust, and output your 
images in limitless ways. Photoshop Elements makes organizing and editing photos a snap, by 
giving you the tools needed to accomplish everyday tasks without the complexity of the full 
version of Photoshop. With Photoshop Elements, you can utilize keywords, tags, ratings, and 
other features to identify your images so that you can search for and fi nd them easily in the 
future.  You’ll never lose an image again. Let’s get started!

1
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1
The welcome screen
When you launch Photoshop Elements, the Welcome screen opens automatically. The welcome 
screen is a gateway to the workspaces that are available within Photoshop Elements. Workspaces 
are diff erent environments built into Photoshop Elements that allow you to perform diff erent 
tasks. You’ll get a closer look at workspaces later in this book.

When you launch Photoshop Elements, the welcome screen appears. The welcome screen is the 
launch pad from which you will navigate to diff erent areas of Photoshop Elements. There are 
two main categories available in the welcome screen:

Organize ( ): This is like a digital fi ling cabinet. You can rename your fi les, add keywords, add 
ratings, and categorize your photos. Lessons 1 and 2 cover the Organizer.

Edit ( ): This is where you can make adjustments to your photos. Fix exposure, color, and 
contrast, remove redeye, and much more. Lessons 3, 4, and 5 are focused on editing.

From the Adobe Photoshop Elements Welcome screen, you can launch the Organizer, Editor, or sign on to Photoshop.com to 
share your images.

PSE8.indb   3PSE8.indb   3 10/13/2009   3:46:25 PM10/13/2009   3:46:25 PM



4

Getting photos into the Organizer using the Photo Downloader
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1
Getting photos into the Organizer using the Photo Downloader
The Photoshop Elements Organizer is your creative hub. It can be used to organize your entire 
photo library, as well as perform a few quick editing tasks. It is not a simple fi le browser like 
your operating system uses; it is more of a photo management system, allowing you to organize, 
tag, and manipulate content. Before you can use it to the fullest, you must fi rst import your 
images into the Organizer.

Getting photos from a camera or card reader
Photos that you shoot with your digital camera are not usually stored on the camera, but on 
a removeable memory card plugged into your camera.  To get the photos from your camera 
onto your computer, you must have a physical connection from your camera to your computer. 
This connection is usually in the form of a USB cable supplied with your camera. With many 
computers, it is also possible to remove the memory card from the camera and insert it into a 
card reader. This method generally off ers faster importing of your photos, but either method 
ultimately yields the same results. For details on how to connect your camera to your computer, 
consult the instructions that you use with your camera. Photos are copied onto your computer 
using the Adobe Photoshop Elements 8.0 Photo Downloader. The Photo Downloader allows 
you to choose the location on your computer where you would like the fi les copied during 
import.

Import photos automatically
When you plug your camera or card reader into your computer, Windows prompts you with a 
dialog box asking what you want to do. Depending on the applications that you have installed, 
your dialog box will look slightly diff erent than the one shown in the fi gure below. If you 
choose Organize and Edit using Adobe Photoshop Elements Organizer 8.0, the Adobe Photoshop 
Elements 8.0 Photo Downloader displays on your screen.
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1
The AutoPlay dialog box appears when you connect a camera or card 
reader on a Windows computer. This dialog doesn’t appear on Mac OS.

Import photos manually
Depending on your confi guration, Windows may not display a dialog box asking you which 
application to use to access the photos on your camera’s memory card, and you may have to 
launch the Photo Downloader manually. To do so, press the Organize button ( ) from the 
welcome screen, then follow the steps below to import the photos.

1 Select File > Get Photos and Videos > From Camera or Card Reader.

2 From the drop-down menu in the Source area, choose the digital camera or card reader. 

Once you have selected a device, all photos on it are loaded into the viewer.

3 In the Import Settings section, press the Browse button to choose the folder you would 
like to copy your photos to. If you are using a single folder to hold all your images, 
you can create a subfolder based on a variety of options in the Create Subfolder(s) 
drop-down menu.
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4 If you would like to automatically rename the photos as they are being copied to your 

computer, choose a renaming method from the Rename Files section.

5 Set the Delete Options to control what happens to the original photos on the camera or 
card reader after they are copied to your computer.

6 Press Get Photos to copy your photos. Press Cancel if you are not connected to a camera 
or card reader. 

The Photo Downloader
During import from a camera or card reader, Photoshop Elements uses the Adobe Photoshop 
Elements Photo Downloader. The Photo Downloader aids you when importing fi les into 
Photoshop Elements. This dialog box has two diff erent modes: Standard and Advanced.

Standard mode
In Standard mode, the Photo Downloader provides you with some basic options. The 
Source section allows you to defi ne a specifi c device (camera or card reader) from which to 
import fi les.

Standard mode in the Photo Downloader off ers a quick and easy way 
to import your photos.
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The Import Settings section allows you to determine what occurs during import as you’re 
importing images.

Location: The location on your hard drive from which you would like the fi les to be 
imported.

Create Subfolder(s): Organizes the photos into subfolders based on a variety of date formats, 
including shot date and import date.

Rename Files: Renames the fi les during import so that they correspond to the date the 
photos were taken, today’s date (current date), or a custom name.

Delete Options: Determines what to do with the original photos on the camera or card 
reader once the fi les have been imported onto your hard drive. You have the following choices: 
Do Not Delete Originals, Verify and Delete Originals, or Delete Originals immediately after 
copying them.

Advanced mode
In advanced mode, thumbnail previews of all the images on the camera or card reader are 
displayed and you can choose which photos you would like to download to your hard drive. 
Additional options are also available.

Advanced mode in the Photos Downloader off ers additional options, such as the ability to apply metadata to images during import.

Open Organizer when Finished: Opens the Elements Organizer workspace after importing 
the photos.

Automatically Fix Red Eyes: Analyzes your photos on import and automatically fi xes red 
eye in any image.
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Automatically Suggest Photo Stacks: Suggests that multiple photos that appear similar be 
grouped together in a stack.

Make 'Group Custom Name' a Tag: Applies the custom name tag of the specifi ed group to 
the selected photos. Use this option only if you have assigned custom groups.

Import into Album: Allows you to import the photos into an existing album, or allows you 
to create one during import.

Advanced mode lets you apply metadata to your photos during import. Metadata is information 
about the photos that you are importing, such as the photographers name, the date the image 
was taken, copyright status, and more. Metadata is discussed in greater detail in Lesson 2, 
“Organizing Your Photos.” Below are options you can choose when applying Metadata.

Template to Use: Allows you to use a pre-confi gured metadata template to automatically 
apply common metadata to your images.

Creator: Type the name of the person who took the photograph.

Copyright: Type copyright information related to each image.

Click the Automatically Download checkbox to automatically launch the Adobe Photo 
Downloader and import the photos on the card using the default preferences.

Get photos from a scanner
Photoshop Elements can be used to operate many scanners, allowing you to scan your 
traditional photos and prints, and open them directly in the program.

1 If the Photo Downloader dialog box is open, you will need to press Cancel before you 
can perform this step. Choose File > Get Photos and Videos > From Scanner.

The Get Photos from Scanner dialog box.

2 Choose your scanner from the drop-down menu.

3 Press the Browse button to choose the folder in which you would like to save your scans.
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4 From the Save As drop-down menu, select the format in which you would like to save 

your image. See Appendix C for an explanation of fi le format options.

5 Press OK to begin scanning, or press Cancel if you are not connected to a scanner and 
are simply exploring this option.

You can have Photoshop Elements automatically fi x red eyes in your scanned image by clicking 
the checkbox for Automatically Fix Red Eyes. This option is also available in the Photo 
Downloader when using the Advanced dialog box.

Get photos and videos by searching 
If you have photos and videos in diff erent locations on your hard drive, but aren’t exactly 
certain of the location, you can have Photoshop Elements search for them. 

1 Select File > Get Photos and Videos > By Searching.

You can search through your entire hard drive or in specifi c folders to add images to Photoshop Elements.

2 Set search options such as location, exclusion size, and automatic red eye fi x from the 
Search Options section.

3 Press the Search button to have Photoshop Elements search your hard drive for any 
folder containing photo and video fi les. If you do not want Photoshop Elements to 
perform this search at the time, press Cancel and go to the next section, “Setting a 
Watch Folder.”
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4 When the search is complete, select the folders that you would like to import photos 

from, then press Import Folders.

To select more than one folder, press the Ctrl key while clicking the folders. 

Setting a Watch Folder
Manually adding individual photos and videos to Photoshop Elements can be a time-
consuming process. To make this process easier, you can set a Watch Folder. This action allows 
the program to automatically import any new fi les that are found in the specifi ed folder, such as 
the default Pictures folder used by Windows. Note that the Watch Folder feature is not available 
on the Mac OS version of Photoshop Elements; only the Windows version.

1 Choose File > Watch Folders.

Setting a Watch folder makes it easy to import images.

2 Press the Add button and browse to fi nd the folder you want to add to the Watch list. You 
can add multiple folders if you want.

3 Press OK if you have chosen a Watch folder, or Cancel if you do not want to set up a 
Watch folder.
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Adding fi les and folders to the Organizer
In cases where you already have photos on your computer, you simply need to add them to 
the Organizer. In this example, you’ll use the fi les provided on the DVD that accompanies 
this book. 

The Organizer is empty until content is imported.

1 Choose File > Get Photos and Videos > From Files and Folders. In the Get Photos and 
Videos from Files and Folders dialog box that appears, navigate to the Lessons folder that 
you copied to your computer from the DVD.
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1
2 Select the Lessons folder and press the Get Media button. The photos begin to load into 

the Organizer.

You can select a single folder and import all photos from it, and any subfolders as well.

3 A dialog box appears, asking if you would like to import the keywords that are attached 
to the photos. Click Select All to import all keywords and all the lesson keywords, and 
press OK. Keywords help you organize your images and are discussed in more detail in 
later lessons.

If the photos you are importing have keywords attached, you can choose to import them as well.
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After you import images, only the imported images are displayed. A warning dialog box appears, 
informing you that the only fi les you are currently viewing in the Organizer are those that were 
just imported. Click the Don’t show again checkbox, if you’d prefer that this dialog box didn’t 
pop up each time you import media. Press OK to close the dialog box.

4 By default, the images displayed in the Organizer are categorized by date. Choose View 
> Show File Names to add the fi lenames to the display. If there is a checkmark next to 
Show File Names, the feature is already enabled. Choosing Show File Names when it is 
already selected disables the feature.

If the fi lenames still don’t display in the Organizer after choosing View > Show File Names, 
drag the thumbnail slider to the right until the fi lenames appear.

Getting a still image from a video frame
Adobe Photoshop Elements can import video clips as well as photographs and other images. 
Although Photoshop Elements is not designed to do video editing, it can manage video clips 
either imported from some cameras, created using video software such as Adobe Premiere 
Elements, or that you obtained from friends and family. It can also take a single frame of a video 
clip and save it as a still image. Let’s see how Photoshop Elements can be used to do this.

1 Make sure that you’ve imported the Lessons folder, as discussed in the “Adding fi les and 
folders to the Organizer” section earlier in this lesson.

2 From the Organizer, choose View > Media Types and uncheck all options except for 
Video. This hides everything in the Organizer that is not a video fi le. You should see one 
fi le remaining in the Organizer, called Claire Bike Ride.avi.

 Hiding and showing media types makes it easy to see only certain media types with which 
you want to work. This is only one method of refi ning what you see in the Organizer. In 
the next lesson, you’ll see how applying keywords and tags to your media can streamline 
this process as well.
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1
3 Choose Edit > Deselect to make sure that you don’t have any fi les selected in the 

Organizer, then press the arrow on the right side of the Fix tab in the upper-right corner 
of the workspace. From the drop-down menu, choose Quick Photo Edit ( ). This loads 
the Editor Workspace, which is used to extract a still frame from a video clip. The features 
of the Editor Workspace are covered in more detail in Lesson 2, “Organizing Your 
Photos.”

Choose Quick Photo Edit.

4 Choose File > Import > Frame from Video.

The Frame From Video dialog box allows you to choose a video clip and grab still images.

5 In the Frame From Video dialog box, press the Browse button, and navigate to the 
Lessons folder that you copied to your hard drive. Select the fi le named Claire Bike 
Ride.avi and press Open.
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1Getting a still image from a video frame

6 The video clip that you selected is displayed within the Frame From Video dialog box. 
Use the player controls below the video clip to play, pause, stop, go forward, and go 
backward in the video. When the desired clip is visible, press the Grab Frame button or 
press the Spacebar on your keyboard to grab a still frame of the video. You can grab as 
many frames as desired.

Press the Grab Frame button or press the Spacebar on your keyboard while the video is playing 
to grab still frames from the video.

7 When you have grabbed the desired number of frames, press Done.

8 All your clips appear in the bin at the bottom of the Editor workspace. When you are 
fi nished, close each fi le from the bin by selecting each fi le in the bin and pressing the 
Close button in the main window of the Editor. You will be prompted to save fi les 
upon closing them. Save them to the Lessons folder making sure that the Include in the 
Organizer checkbox is checked.

9 Press the Organizer button ( ) in the menu bar at the top of the workspace. You will 
probably only see the original video clip at this point because the other media types are 
still hidden. Choose View > Media Types and make sure there is a checkmark next to 
all the listed options. This ensures that you can see everything in the Organizer. All the 
images that you grabbed from the video clip should now be visible in the Organizer. If 
you can’t see all of the images, choose View > Refresh or press F5 on your keyboard to 
have the Organizer to refresh the view of the images.
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Workspaces
Workspaces are diff erent environments built into Photoshop Elements that allow you to 
perform diff erent tasks on your pictures. Photoshop Elements utilizes two main workspaces: 
the Organizer and the Editor. Each workspace launches as its own individual application. When 
you are in the Organizer workspace, which is the default workspace after importing images 
into Photoshop Elements, you can press the Fix tab in the upper right corner of the Organizer 
workspace and then press the Edit Photos button in the Task pane to launch the Editor 
workspace. Conversely, if you are in the Editor workspace, you can switch to the Organizer 
workspace by pressing the Organizer button ( ) in the menu bar at the top of the screen.

Organizer basics
Because the Organizer workspace is the default workspace after importing your photos, 
most of your initial time will be spent here getting your photos, well, organized! In Lesson 2, 
“Organizing Your Photos,”  you’ll discover in greater detail how you can organize and fi nd 
photos that you’ve imported into Photoshop Elements, but for now, you’ll look at some of 
the basics.

Creating an album
The concept of albums in Photoshop Elements is pretty straightforward. In fact, at some point 
you’ve probably created albums the old-fashioned way, by taking photos that were shot with a 
traditional fi lm camera and developed, then putting them into an album book. You did this to 
keep your photos organized.

Albums in Photoshop Elements are very similar to those albums that you created in the past, 
only now they are digital. Albums allow you to organize photos that are related. For example, 
it might be an event, person, or group. You can also create Album Groups, which can organize 
multiple albums into a unique category or group. You can organize your photos any way you 
like, and albums make the process easy. Let’s see how!

1 Make sure that the Organizer workspace is active and that all your images are being 
displayed by choosing View > Media Types and ensuring that there is a checkmark 
next to each option listed. This displays all the photos that have been imported into 
the Organizer.

2 Choose View > Show File Names to display each image’s fi lename.

3 Choose Date (Newest First) from the Media Browser Arrangement drop-down menu at 
the top of the workspace to sort the images by date.
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1
4 Scroll down toward the bottom of the Organizer and click once on the photo named 

IMG_0840.JPG to select it. Now hold down the Shift key on your keyboard and click 
once on the photo named IMG_0903.JPG. This selects the photos chosen, and all the 
photos in between them.

Hold down the Shift key and click to select a range of photos.

5 Press the Create new album or album group button ( ) in the Albums panel and choose 
New Album. The Album Details panel appears.
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1
6 In the Album Name text fi eld, type AIRSHOW and press Done. A new album is now 

displayed in the Albums panel.

The Album Details panel allows you to give 
your album a name.

7 To view the fi les in the new album you just created, click once on the AIRSHOW 
album. This displays only the photos of that album in the Organizer. When an album is 
active, it becomes highlighted in the Albums panel, and the album name appears in the 
upper left corner of the main Organizer window after the word Find.

8 To stop viewing a particular album, click the album again to display all photos.

The album becomes highlighted when it is being displayed.

9 Hold down the Ctrl key and click on all the images of planes fl ying in the air. 
Ctrl+clicking allows you to select non-contiguous photos in the Organizer.
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1
10 Press the Create new album or album group button in the Albums panel and choose 

New Album. Name this album Planes in fl ight and press Done. Albums provide an 
effi  cient means for organizing your photos. Now you’ll create an album group to further 
organize the albums you’ve created.

11 Press the Create new album or album group button in the Albums panel and choose 
New Album Category. Name this category July 2008 Airshow, and press OK

12 Click and drag the two albums you’ve created, and drop them on top of the July 2008 
Airshow album category. The albums are now contained within the category.

Drag and drop the albums on top of the album 
category for further organization.

How to get help
As you explore and work with Photoshop Elements, you’re bound to have questions. 
Fortunately, help is close at hand. Below are some useful resources for obtaining help when you 
need it.

Photoshop help
Adobe Photoshop Elements provides detailed and searchable help that can be accessed quickly 
and easily by choosing Help > Photoshop Elements Help or Help > Organizer Help depending 
on if you’re currently in the Editor or Organizer workspace, respectively. You can also access 
help from either workspace by pressing the F1 key on your keyboard. If you are connected 
to the Internet, you are directed to Adobe’s on-line help, which contains the most up-to-date 
information available. If you do not have an Internet connection, Photoshop Elements directs 
you to a local copy of the help fi les that still contains a plethora of information but may not be 
completely current. Answers to your questions are only a click away. 
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1
Support Center
You can access the Photoshop Elements Support Center online at www.adobe.com/support/
photoshopelements/. The Support Center contains current information related to support issues 
that other users have had and what their solutions are. The Support Center also contains How-
to videos demonstrating features of Photoshop Elements.

The Inspiration Browser
Adobe has released a service called Photoshop.com that allows you to upload and store photos 
online to share with friends and family. Photoshop Elements integrates with this service. 
When you sign up for this free service, you are provided with additional features in Photoshop 
Elements not otherwise available. Refer to Lesson 6, “Sharing Your Photos,” for more 
information about Photoshop.com.

If you return to the welcome screen by pressing the welcome screen button ( ) in the 
Organizer, there will be an area on the lower left side of the welcome screen to sign into your 
Photoshop.com account. Upon signing in, new options are displayed on the welcome screen. 
Press the Tips and Tricks link in the lower-right corner of the Welcome Screen to open the 
Adobe Elements Inspiration Browser. The Inspiration Browser contains tutorials posted by 
users like you who have found new and creative ways of using Photoshop Elements software. 
You can even post your own tutorials showing new ways of using Photoshop Elements that 
you’ve discovered.

The Inspiration Browser.
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1
Self study
Now that you have had some practice importing photos into the Organizer, you can see how 
useful it is for organizing all your images. Practice on your own by importing your own photos 
using the various methods covered in this lesson and organizing them into albums. The more 
organized you are with your photos, the easier it is to locate them.

Review

Questions
1  Where are the four places from which you can get photos and videos?

2 How can you select a range of non-contiguous photos to add to an album in the 
Organizer? 

3 Which workspace must be used to extract a still image from a video clip?

Answers
1 You can get them from a camera or card reader, a scanner, fi les and folders, and by 

searching your hard drive.

2 Ctrl+click any image in the Organizer.

3 The Editor workspace.

PSE8.indb   21PSE8.indb   21 10/13/2009   3:46:54 PM10/13/2009   3:46:54 PM



PSE8.indb   22PSE8.indb   22 10/13/2009   3:46:54 PM10/13/2009   3:46:54 PM




