
Making Excel 
More Efficient
If you find yourself spending a major part 
of your day working with Excel, you can 
make those chores go faster — and so 
make your overall work life more 
productive — by making Excel as efficient 
as possible.

For example, you can launch common 
commands more quickly by placing them 
on the Quick Access Toolbar, which requires 
just a single click to launch a command. 
Similarly, you can customize the Ribbon 
with your own tabs and groups to reduce 
the time it takes to perform certain tasks.

You can also make Excel more efficient 
by using the mouse wheel to zoom, 
automatically inserting decimal points, 
pinning Excel to the Windows 7 taskbar, 
creating binary workbooks, applying 
formatting across multiple worksheets, 
and using dialog box controls to input 
worksheet data.

In this chapter, you will learn how to 
perform these and many other tasks that 
boost your Excel efficiency.
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33 The Excel Options dialog 
box appears.

● Excel automatically 
displays the Quick Access 
Toolbar tab.

3 Click the Choose 
Commands From  
drop-down arrow.

4 Click the command 
category you want to use.

1 Click the Customize 
Quick Access Toolbar 
button.

● If you see the command 
you want, you can click 
it; Excel adds the button 
for that command to the 
Quick Access Toolbar, 
and you can skip the rest 
of the steps in this 
section.

2 Click More Commands.

You can make Excel easier to use by 
customizing the Quick Access Toolbar to 
include the Excel commands you use most 
often. Because you launch Quick Access 
Toolbar buttons with a single click, adding 
your favorite commands to the toolbar saves 
you time.
By default, the Quick Access Toolbar contains 
three buttons — Save, Undo, and Redo — 
but you can add any of hundreds of Excel 
commands.
In a default Excel configuration, the Quick 
Access Toolbar appears above the Ribbon as 

part of the Excel title bar. However, this 
position only allows you to add a few buttons, 
as there is only so much space in the title bar. 
To get much more space to add buttons, you 
should move the Quick Access Toolbar below 
the Ribbon.
You can also export your Quick Access 
Toolbar customizations to a file so that other 
people can import the same customizations. 
For more information, see the section, “Export 
Ribbon Customizations to a File.”

Customize the Quick 
Access Toolbar
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● Excel adds a button for 
the command to the 
Quick Access Toolbar.

5 Click the command you 
want to add.

6 Click Add.

● Excel adds the command.

● To remove a command, 
you can click it and then 
click Remove.

7 Click OK.

More Options!
You can increase the space available to 
the Quick Access Toolbar by moving it 
below the Ribbon. This gives the toolbar 
the full width of the Excel window, so you 
can add many more buttons. Click the 
Customize Quick Access Toolbar button 
and then click Show Below the Ribbon.

More Options!
If the command you want to add appears 
on the Ribbon, you can add a button for 
the command directly from the Ribbon. 
Click the Ribbon tab that contains the 
command, right-click the command, and 
then click Add to Quick Access Toolbar. 
Excel inserts a button for the command on 
the Quick Access Toolbar.
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 The Excel Options dialog 
box appears.

● Excel automatically 
displays the Customize 
Ribbon tab.

● Use these lists to choose 
the commands you want 
to add.

● These lists show the 
existing tabs and groups.

● To display a tab’s groups, 
you can click the tab’s 
plus sign (+).

Display the Customize 
Ribbon Tab
1 Right-click any part of the 

Ribbon.

2 Click Customize the 
Ribbon.

You can improve your Excel productivity by 
customizing the Ribbon with extra commands 
that you use frequently.
Keep in mind that you cannot modify any of 
the default tabs and groups in Excel, other 
than hiding tabs you do not use. Instead, you 
customize the Ribbon by adding a new group 

to an existing tab, and then adding one or 
more commands to the new group.
Alternatively, you can add a new tab to the 
Ribbon, add your own groups to that tab, and 
then add your commands.

Customize 
the Ribbon
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 The Rename dialog box 
appears.

4 Type a name for the 
group.

5 Click OK.

 Excel adds the new group 
to the tab.

Add a New Group
1 Click the tab you want to 

customize.

2 Click New Group.

● Excel adds the group.

3 Click Rename.

More Options!
You can get more space on the Ribbon 
and reduce clutter by removing any tabs 
you do not use. For example, if you do 
not use the Excel reviewing tools, then 
you might prefer to hide the Review tab 
to reduce the number of tabs you see 
on-screen. In the list of tabs that appears 
below the Customize the Ribbon drop-
down list, deselect the check box beside 
any tab you want to hide.

Try This!
You can change the order in which the tabs 
appear in the Ribbon. For example, if you 
use the tools in the Data tab more often 
than those in the Home tab, then you can 
move the Data tab to be the first tab in the 
Ribbon. Use the up and down arrow 
buttons that appear to the right of the tab 
list to modify the order. You can also use 
these buttons to modify the order of the 
groups within any tab.

➥continued
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 The Rename dialog box 
appears.

4 Type the name you want 
to use.

5 Click OK.

6 Repeat steps 3 to 5 to 
rename the new group.

Add a New Tab
1 In the Customize Ribbon 

tab of the Excel Options 
dialog box, click New Tab.

● Excel adds the tab.

● Excel adds a new group 
within the tab.

2 Click the new tab.

3 Click Rename.

Although you will mostly prefer to add one or 
more custom groups to the default Excel tabs, 
this is not always convenient because it reduces 
the amount of space available to the other 
groups in the tab. This can cause the buttons 
to appear cluttered, making it harder to find 
the button you need.

In such cases, a better customization method is 
to create your own tabs and populate them 
with custom groups and commands.
You can also export your Ribbon customizations 
to a file so that other people can import the 
same customizations. For more information, see 
the section, “Export Ribbon Customizations to 
a File.”

Customize the 
Ribbon (continued)
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11 Add a Command
1 Click the Choose 

Commands From drop-
down arrow.

2 Click the command 
category you want to use.

3 Click the command you 
want to add.

4 Click the custom group 
you want to use.

5 Click Add.

● Excel adds the command.

● To remove a custom 
command, click it and 
then click Remove.

6 Click OK.

● Excel adds the new tab or 
group, as well as the new 
command, to the Ribbon.

Try This!
You can also customize the tabs that appear 
only when you select an Excel object. Excel calls 
these tool tabs, and you can add custom groups 
and commands to any tool tab. Right-click any 
part of the Ribbon, and then click Customize 
the Ribbon to display the Excel Options dialog 
box with the Customize Ribbon tab displayed. 
Click the Customize the Ribbon list and then 
click Tool Tabs. Click the tab you want to add, 
and then follow the steps in this section to 
customize it.

Remove It!
Right-click any part of the Ribbon, 
and then click Customize the Ribbon; 
the Excel Options dialog box appears 
with the Customize Ribbon tab 
displayed. To restore a tab, click the 
tab, click Restore Defaults, and then 
click Restore Only Selected Ribbon 
Tab. To remove all customizations, 
click Restore Defaults and then click 
Restore All Ribbon Tabs and Quick 
Access Toolbar Customizations. 
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 The Excel Options dialog 
box appears.

● Excel automatically 
displays the Customize 
Ribbon tab.

3 Click Import/Export.

4 Click Export All Ribbon 
and Quick Access Toolbar 
Customizations.

1 Right-click any part of the 
Ribbon.

2 Click Customize the 
Ribbon.

You can make it easy to apply Ribbon and 
Quick Access Toolbar customizations on 
another computer by exporting your own 
customizations to a file.
Customizing the Ribbon or the Quick Access 
Toolbar is not a difficult process, but it can be 
time-consuming, particularly if you want to 
make a substantial number of changes. If you 
use Excel 2010 on another computer, it is 
likely that you will want to have the same 

customizations on the other computer so that 
you are dealing with a consistent interface no 
matter where you do your spreadsheet work. 
Rather than wasting valuable time repeating 
the same customization steps on the other 
computer, you can export your customizations 
to a file. You can then import that file on the 
other computer, and Excel automatically 
applies the customizations for you.

Export Ribbon 
Customizations to a File
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Apply It!
To apply the Ribbon and Quick Access Toolbar customizations on another computer 
running Excel 2010, you need to import the customization file that you exported by 
following the steps in this section. Note, however, that importing a customization file 
replaces any existing customizations that you have created.
On the computer you are customizing, right-click any part of the Ribbon, and then click 
Customize the Ribbon to open the Excel Options dialog box with the Customize Ribbon 
tab displayed. Click the Import/Export drop-down arrow and then click Import 
Customization File. In the File Open dialog box, locate and then click the customization 
file, and then click Open. When Excel asks you to confirm that all of your existing 
customizations will be replaced, click Yes and then click OK. Excel applies the Ribbon 
and Quick Access Toolbar customizations.

 Excel saves the 
customizations to the file.

8 Click OK.

 The File Save dialog box 
appears.

5 Choose a location for the 
customization file.

6 Type a name for the file.

7 Click Save.
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 The Excel Options dialog 
box appears.

3 Click the Advanced tab.

1 Click the File tab button.

2 Click Options.

If you frequently zoom in or out of a 
worksheet, you can save time by configuring 
Excel to enable you to zoom using the wheel 
on your mouse.
Zooming a worksheet is a useful technique. 
For example, you might want to zoom out of a 
large worksheet to get a sense of the overall 
structure of the worksheet data. Similarly, 
zooming in on a section of a worksheet enables 
you to focus on just that section.

You normally zoom either by using the 
controls in the View tab’s Zoom group, or by 
using the Zoom slider that appears in the 
bottom-right corner of the Excel window. 
These techniques are fine if you only zoom 
occasionally. However, if you use the zoom 
feature frequently, it is a good idea to configure 
Excel to zoom using the mouse wheel.

Configure Excel to Use the 
Mouse Wheel for Zooming
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5 Click OK.

 You can now zoom in 
and out of your Excel 
spreadsheets by turning 
the mouse wheel.

4 Click to select the Zoom 
on Roll with IntelliMouse 
option.

Note: Although the option name 
specifies the Microsoft IntelliMouse, 
this option works with any mouse 
that comes with a standard scroll 
wheel.

Try It!
When you activate the Zoom on Roll 
with IntelliMouse check box, rolling 
the mouse wheel forward causes 
Excel to zoom in on the worksheet 
by 15 percent with each scroll of the 
wheel; rolling the mouse wheel 
backward causes Excel to zoom out 
of the worksheet by 15 percent with 
each scroll.

Did You Know?
When the Zoom on Roll with IntelliMouse check 
box is deactivated, rolling the mouse wheel 
causes Excel to scroll the worksheet: roll the 
wheel back to scroll down, and roll the wheel 
forward to scroll up. This is a useful technique, 
and you can still use it even when the Zoom on 
Roll with IntelliMouse check box is activated. In 
that case, hold down the Ctrl key and roll the 
mouse wheel to scroll the worksheet.
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 The Excel Options dialog 
box appears.

3 Click the Advanced tab.

1 Click the File tab.

2 Click Options.

In certain cases, you can make your Excel  
data-entry chores more efficient by changing the 
direction that Excel moves the selection when 
you press Enter after you finish editing a cell.
Generally, you enter the data vertically in a 
column of cells. Excel allows you to do this by 
automatically moving the selection down to 
the next cell when you press Enter.
However, in some cases you might need to 
enter a large amount of data in a row, either 

from left to right or from right to left, or in a 
column from top to bottom. Although you can 
use the arrow keys to force the selection to 
move in the direction you want, the Enter key 
is larger than the arrow keys and is thus faster 
to use and less prone to error. Therefore, you 
can configure Excel to move the selection in 
the direction you prefer when you press Enter.

Move in a Different Direction 
When You Press Enter
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Did You Know?
If you have only a few data items to enter, you can force Excel to move the selection in 
the direction of the next cell entry by using the arrow keys. For example, suppose you 
are entering data in a row from left to right. When you finish editing a cell, press the 
right arrow key, which moves the selection to the next cell on the right. Similarly, you 
can press the left arrow key to move the selection to the left, or you can press the up 
arrow key to move the selection up.

6 Click OK.

 Excel now moves the 
selection in the direction 
you specified when you 
press Enter to confirm a 
cell entry.

4 Make sure that the After 
Pressing Enter, Move 
Selection check box is 
selected.

5 Click the Direction  
drop-down arrow, and 
select the direction that 
you want Excel to move 
the selection after you 
press Enter.
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 The Excel Options dialog 
box appears.

3 Click the Advanced tab.

1 Click the File tab.

2 Click Options.

You can make certain Excel data entry tasks 
more efficient by configuring Excel to 
automatically insert a decimal point.
Many Excel data entry tasks require you to 
type a long list of values that use the same 
number of decimal places. The most common 
example is a list of currency amounts, which 
always have two decimal places. When you are 
entering such values, you type the digits to the 
left of the decimal point, the decimal point 

itself, and then the digits to the right of the 
decimal point. In a long list of values, the extra 
step required to type the decimal point is a 
repetitive action that just slows you down.
To speed up this kind of data entry, you can 
configure Excel to add the decimal point for 
you automatically. For example, if you tell 
Excel to automatically add two decimal places, 
then when you type a number such as 123456, 
Excel adds the value to the cell as 1234.56.

Automatically Insert 
a Decimal Point
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 Excel now automatically 
inserts the number of 
decimal places you 
specified when you enter 
a numeric value into a 
cell.

● Excel displays Fixed 
Decimal in the status bar 
to remind you that it will 
automatically insert the 
decimal point.

4 Click to select the 
Automatically Insert a 
Decimal Point check box.

5 Use the Places spin box 
to specify the number of 
decimal places you want 
Excel to add automatically.

6 Click OK.

Did You Know?
Even in Fixed Decimal mode, Excel still 
drops trailing zeroes from your cell 
entries. For example, if you choose 2 in 
the Places spin box and you then enter 
12340 in a cell, Excel displays the entry 
as 123.4. If you always want to see two 
decimal places — that is, 123.40 — 
then you must format the cells using a 
two-decimal numeric format, such as 
Number or Currency.

Try This!
If you choose a number other than 2 in the 
Places spin box and you always want Excel 
to display that number of decimal places, 
you must format the cells with a custom 
numeric format. In the Home tab, click the 
dialog box launcher in the Number group. In 
the Category list, click Custom, and then in 
the Type text box type 0, a decimal point (.), 
and then a 0 for each decimal place that you 
want displayed. For example, the format 
0.000 always displays three decimal places.
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 The Excel Options dialog 
box appears.

3 Click the Advanced tab.

1 Click the File tab.

2 Click Options.

To avoid wasting time waiting for a long 
workbook recalculation to finish, you can 
configure Excel to warn you when an 
operation might take an excessively long time.
In a typical worksheet with only a few 
formulas, the number of operations required to 
recalculate the worksheet might run into the 
dozens or hundreds, which Excel can handle 
instantly. A mid-size worksheet might require a 
few thousand or even a few tens of thousands 
of operations to recalculate, but even such 
larger sheets typically complete recalculation in 
a second or two.

In a massive worksheet that contains many 
linked formulas or one or more large data 
tables, the number of operations required to 
recalculate the sheet can run into the millions. 
If that number exceeds 33,554,000 operations, 
Excel warns you that the recalculation might 
take some time. You can configure that 
threshold to a lower or higher number.
If a large data table is causing slow workbook 
recalculations, you can configure Excel to bypass 
data tables when it recalculates workbooks. For 
more information, see Chapter 4.

Configure When Excel Warns 
You About Long Operations
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Did You Know?
Although you’re unlikely to ever come across 
such an operation, the maximum value that 
you can specify in the When This Number of 
Cells (In Thousands) is Affected spin box is 
999,999,999. Note, too, that although you can 
enter a value as small as 1 in the spin box, 
low values are not recommend because they 
generate excessive warnings. Unless you have 
a very slow computer, do not go under ten 
million operations (10,000 in the spin box).

4 Make sure that the Alert 
the User When a 
Potentially Time 
Consuming Operation 
Occurs check box is 
selected.

5 Use the When This 
Number of Cells (In 
Thousands) is Affected 
spin box to specify the 
threshold at which Excel 
displays the long 
operation warning.

Note: The number in the spin box 
is shown in thousands. So, for 
example, if you enter 1,000 into 
the spin box, then the threshold is 
one million cells.
6 Click OK.

 Excel now warns you 
about time-consuming 
operations when the 
number of cells affected 
will be equal to or 
greater than the number 
you specified.

Remove It!
If you have a fast computer with a lot 
of memory, then Excel should be able 
to handle almost all real-world 
calculations relatively quickly, so you 
do not need Excel to warn you. In that 
case, deactivate the warning by 
following steps 1 to 3 and then 
clicking to select the Alert the User 
When a Potentially Time Consuming 
Operation Occurs check box.
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● Windows 7 adds the 
Excel icon to the taskbar.

Note: If Excel is already running, 
you can also right-click the taskbar 
icon and then click Pin This Program 
to Taskbar.

Pin a Program Using a 
Command
1 Click the Start button.

Note: If you see the Excel icon on 
the main Start menu, skip to step 4.
2 Click All Programs.

Note: After you click All Programs, 
the name changes to Back.
3 Click Microsoft Office.

4 Right-click Microsoft Excel 
2010.

5 Click Pin to Taskbar.

You can quickly and easily launch Excel by 
pinning the Excel icon to the Windows 7 
taskbar.
If you use Excel every day, Windows offers 
some methods for starting the program that 
are easier than going through the menus. For 
example, you can pin the Excel icon to the 
Start menu so that the program is just two 
mouse clicks away. You do this by right-clicking 
the Excel icon and then clicking Pin to Start 
Menu. However, if you use Excel frequently, 
you might prefer to have it just a single mouse 
click away. You can achieve this by pinning 
Excel to the Windows 7 taskbar.

As with previous versions of Windows, the 
Windows 7 taskbar displays an icon for each 
running program. However, one of the new 
features with the revamped Windows 7 taskbar 
is the capability of storing program icons, 
much like the Quick Launch Toolbar in 
previous versions of Windows. Once you have 
Excel pinned to the taskbar, you can then 
launch the program by clicking the icon.
You can pin Excel to the taskbar either by 
running the Pin to Taskbar command, or by 
clicking and dragging the program icon to the 
taskbar.

Pin Excel to the 
Windows 7 Taskbar
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● Windows 7 adds the 
Excel icon to the taskbar.

Pin a Program Using 
Your Mouse
1 Click Start.

Note: If you see the Excel icon on 
the main Start menu, skip to step 4.
2 Click All Programs.

Note: After you click All Programs, 
the name changes to Back.
3 Click Microsoft Office.

4 Click and drag the 
Microsoft Excel 2010 icon 
to any empty section of 
the taskbar.

5 When you see the Pin to 
Taskbar banner, drop the 
icon.

Change It!
As you drop program icons onto the 
taskbar, Windows 7 displays the icons 
from left to right in the order you added 
them. If you prefer the Excel icon to be in 
a different place on the taskbar, click and 
drag the icon to the left or right and then 
drop it in the new position.

Remove It!
If you decide you no longer require Excel 
to be pinned to the taskbar, you should 
remove it to reduce taskbar clutter and 
provide more space for other taskbar icons. 
To remove the pinned Excel icon, right-click 
the icon and then click Unpin this Program 
from Taskbar.
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 The Save As dialog box 
appears.

4 Select a location for the 
new workbook.

5 Type a name for the new 
workbook.

Note: Because the new workbook 
will have a different file extension 
(.xlsb), you do not need to change 
the filename if you do not want to.
6 Click the Save As Type 

drop-down arrow.

1 Open the workbook you 
want to convert.

2 Click the File tab.

3 Click Save As.

If you have a large or complex Excel workbook, 
you can make it open and save faster by 
converting it to the Excel binary file format.
The standard file formats in Excel — Excel 
Workbook and Excel Macro-Enabled 
Workbook — are based on the OpenOffice 
XML Standard, where XML is short for 
eXtensible Markup Language. XML files are 
really just complex text files that Excel reads 
line-by-line when you open the file, and writes 
line-by-line when you save the file. Excel has 
been optimized to read and write XML code 

extremely quickly, and so the standard Excel 
file formats are fine for most worksheets.
However, if you have a worksheet that is very 
large — for example, several thousand rows or 
more, or several hundred columns or more — 
or is very complex, then the standard file 
formats may take a while to open and save. To 
improve the performance of such files, you can 
convert them to the Excel Binary Workbook 
file format. This is identical to the Excel 
Macro-Enabled Workbook format, except that 
it uses binary code (which Excel can read and 
write much faster) instead of XML code.

Make a Workbook Faster 
by Saving it as Binary

03_577769-ch01.indd   2203_577769-ch01.indd   22 3/27/10   9:00 AM3/27/10   9:00 AM



23

Chapter 1: Making Excel More Efficient

77

88

8 Click Save.

 Excel saves the new file 
using the Excel Binary 
Workbook file format.

7 Click Excel Binary 
Workbook.

Did You Know?
The Excel Binary Workbook file format is 
compatible with Excel 2010 and Excel 2007. 
If you want to improve file performance 
while maintaining compatibility with earlier 
versions of Excel, save your workbook using 
the Excel 97-2003 Workbook file format. 
This is a binary format that is compatible 
with Excel 97 and all later versions of the 
program.

Did You Know?
Other than improved performance when 
opening and saving a file, there is no 
difference between the Excel Binary 
Workbook file format and the Excel 
Macro-Enabled Workbook file format. 
Both formats support the same features, 
create files of approximately the same 
size, and have the same performance 
once the files are loaded into Excel.
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Arrange the 
Workbook’s WIndows
● Excel creates a second 

window for the workbook 
and appends ‘:2’ to the 
name of the new 
window.

Note: Excel also appends ‘:1’ to the 
name of the original window.
4 Click Arrange All.

Create a New 
Workbook Window
1 Open the workbook you 

want to work with.

2 Click the View tab.

3 Click New Window.

You can make a large spreadsheet easier to 
manage by creating a second window for the 
workbook.
When you are building a spreadsheet, you 
often have to refer to existing sheet data. For 
example, when you construct a formula, you 
may need to refer to specific cells. Similarly, 
once your spreadsheet is working, you often 
need to monitor a cell value. For example, if 
you change the data in one part of the sheet, 
you might want to see how that change affects 
the result of a formula elsewhere in the sheet.

This is easy with a small spreadsheet where you 
can see everything on the screen. However, 
larger spreadsheets do not fit into a single 
screen, so the data you need to reference or 
monitor might not be visible, requiring that 
you scroll through the sheet to see it.
A better solution is to create a second window 
for the workbook and then arrange those 
windows side-by-side (vertically or 
horizontally). This enables you to display what 
you are currently working on in one window, 
and what you need to reference or monitor in 
the second window. 

Open a New Window 
for a Workbook
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 The Arrange Windows 
dialog box appears.

5 Click to select the 
Horizontal option.

● If your worksheet has just 
a few columns, you can 
click to select the Vertical 
option, instead.

6 Click to select the 
Windows of Active 
Workbook option.

7 Click OK.

 Excel arranges the 
workbook’s windows.

8 When you are done with 
the second window, click 
its Close button to return 
to using just the original 
workbook window.

Try This!
If you are using the new window to monitor 
either the first few rows or columns in the 
workbook, then you might find it easier to 
split the worksheet into panes instead of 
creating a new window. In the View tab, click 
the Split button and then click and drag the 
pane borders to define the area you want to 
monitor. The areas inside each pane scroll 
independently, so you can keep the data in 
the other area in view at all times.

Did You Know?
If you are using the new window to 
monitor a particular cell value in 
another part of the workbook, Excel 
offers another method for doing this: 
the Watch Window. You use this 
window to monitor the current value of 
one or more cells. To learn how to use 
this window, see Chapter 4.
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 The Data Validation 
dialog box appears.

4 Click the Settings tab.

5 In the Allow drop-down 
list, click the type of data 
you want to allow in the 
cell.

6 In the Data drop-down 
list, click the operator you 
want to use to define the 
allowable data.

7 Specify the validation 
criteria, such as the 
Maximum and Minimum 
allowable values as 
shown here.

Note: The criteria boxes you see 
depend on the operator you chose 
in step 6.

1 Click the cell you want to 
restrict.

2 Click the Data tab.

3 Click Data Validation.

You can make Excel data entry more efficient 
by setting up data entry cells to accept only 
certain values.
When you build a spreadsheet, you may find 
that some cells can only take a particular range 
of values. For example, an interest rate cell 
should take a decimal value between 0 and 1 (or 
a whole number between 0 and 100 if you have 
formatted the cell with the Percent number 
format). Similarly, a cell designed to hold a 
mortgage amortization term should probably 
take whole number values between 15 and 35.

To ensure that the proper values are entered, 
you can set up a cell with data validation 
criteria that specify the allowed value or values. 
You can work with numbers, dates, times, or 
even text length, and you can set up criteria 
that are between two values, equal to a specific 
value, greater than a value, and so on. Excel 
also lets you tell the user what to enter by 
adding an input message that appears when 
the user selects the cell.

Allow Only Certain 
Values in a Cell
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More Options!
It is often a good idea to also configure an 
error message that displays when the user 
tries to enter data outside of the range you 
have specified. Follow steps 1 to 3 to open 
the Data Validation dialog box, and then click 
the Error Alert tab. Make sure the Show Error 
Alert After Invalid Data is Entered check box is 
selected ( ), and then specify the Style, Title, 
and Error Message.

8 Click the Input Message tab.

9 Make sure the Show Input 
Message When Cell Is Selected 
check box is activated ( ).

0 Type a message title.

! Type the message you want to 
display.

@ Click OK.

Remove It!
If you no longer need to use data 
validation on a cell, you should clear 
the settings. Follow steps 1 to 3 to 
display the Data Validation dialog box 
and then click the Clear All button. 
Excel removes all the validation 
criteria, as well as the input message 
and the error alert. Click OK.

● When the cell is selected, the 
input message appears.
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3 Click the tab of the next 
worksheet you want to 
include in the group.

● Excel displays [Group] in 
the title bar to remind 
you that your worksheets 
are currently grouped.

Note: If you select a tab 
accidentally, click the tab again to 
remove the worksheet from the 
group.
4 Repeat step 3 for each 

worksheet you want to 
include in the group.

5 Release the Ctrl key.

1 Click the tab of the first 
worksheet you want to 
include in the group.

2 Press and hold Ctrl.

You can speed up the creation of spreadsheet 
models by applying text and formatting to 
multiple worksheets at once.
In most workbooks, the worksheets are related 
in some way, but they generally have 
significantly different structures. However, in 
certain cases each worksheet uses an identical 
structure. For example, each worksheet might 
have the same overall title. Similarly, in a 
budget workbook each worksheet might have 
not only the same title, but also the same 
headings (Income, Expenses, and so on).

If you just have a small number of worksheets, 
you can also complete one worksheet’s 
structure, copy the range, and then paste it into 
the other sheets. For a large number of sheets, 
however, Excel offers a much faster method. 
You can collect all the worksheets into a group 
where Excel treats the collection of sheets as a 
single worksheet. This means that any data you 
enter into one sheet is automatically entered on 
the same spot in every other sheet in the group; 
similarly, any formatting applied to one sheet is 
also applied to the entire group.

Apply Text or Formatting 
to Multiple Worksheets
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worksheet in the group.

● The data and formatting 
you added to the original 
worksheet also appear 
in the other worksheets 
in the group.

6 Add the text and other 
data you want to display 
on the grouped 
worksheets.

7 Apply the formatting that 
you want to use on the 
grouped worksheets.

More Options!
If you have a workbook with a large number of 
worksheets and you want to include most or all 
of those sheets in your group, do not click each 
worksheet tab individually. To group every sheet, 
right-click any tab and then click Select All Sheets; 
alternatively, click the first tab you want to include 
in the group, hold down Shift, and then click the 
last tab you want to include.

Remove It!
To exclude a worksheet from the 
group, hold down Ctrl and click 
the worksheet’s tab. To collapse 
the entire group, either click any 
tab that is not part of the group, or 
right-click a grouped tab and then 
click Ungroup Sheets.
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 The Office Clipboard task 
pane appears.

3 Click Options.

4 Click Show Office 
Clipboard Automatically.

 Excel now displays the 
Office Clipboard 
automatically whenever it 
contains two or more 
items.

Display the Office 
Clipboard 
Automatically
1 Click the Home tab.

2 In the Clipboard group, 
click the dialog box 
launcher icon.

You can make the Office Clipboard easier to 
use and more efficient by configuring Office to 
display the Clipboard quickly.
A clipboard is a memory location that is used 
to store data temporarily. Windows comes with 
a clipboard that stores data that you either cut 
or copy, and you can then paste the data to a 
document.
The Windows Clipboard can only store one 
item at a time, which is not always convenient 
or useful. However, Office 2010 comes with 
its own memory storage area — called the 
Office Clipboard — that can store up to 24 cut 

or copied items. You can paste the most 
recently cut or copied item using the Paste 
command, but to paste an older item, you 
must display the Office Clipboard, and then 
double-click the item you want to paste.
Unfortunately, displaying the Office Clipboard 
takes a few steps, so if you use this tool 
frequently, you might prefer a faster method. 
You can configure Office to display the Office 
Clipboard automatically either as soon as it 
contains at least two items, or whenever you 
press Ctrl+C twice in succession.

Quickly Display the 
Office Clipboard
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More Options!
By default, the Office Clipboard icon appears in the notification area of the Windows 
taskbar. When you have the Office Clipboard displayed and you cut or copy an item in 
any Office application, the icon displays a notification that says “X of 24 - Clipboard,” 
where X is the number of items on the clipboard.
If you find these notifications distracting and not very useful, you can turn them off. Click 
the Home tab, and then click the Clipboard group’s dialog box launcher icon to open 
the Office Clipboard. Click the Options button and then click to deactivate the Show 
Status Near Taskbar When Copying command. To disable the actual icon, click to 
deactivate the Show Office Clipboard Icon on Taskbar command.

 The Office Clipboard task 
pane appears.

3 Click Options.

4 Click Show Office 
Clipboard When Ctrl+C 
Pressed Twice.

 Excel now displays the 
Office Clipboard 
automatically whenever 
you press Ctrl+C twice in 
a row.

Display the Office 
Clipboard Using the 
Keyboard
1 Click the Home tab.

2 In the Clipboard group, 
click the dialog box 
launcher icon.
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4 Click and drag on the 
worksheet at the spot 
where you want the 
control to appear.

● As you drag, Excel 
displays the border of 
the control.

5 When the c ontrol is the 
size and shape you want, 
release the mouse.

Add a Control to a 
Worksheet
1 Click the Developer tab.

2 Click Insert.

3 Click the control you 
want to add.

● In this case, you need to 
click a control from the 
Form Controls section of 
the Insert Controls 
gallery.

You can make worksheet data entry easier and 
more accurate by using dialog box controls 
such as check boxes, option buttons, lists, and 
spin boxes.
If you are building a worksheet for data entry, 
your main concerns should be speed and 
accuracy. That is, you want users to be able to 
input data as quickly as possible, while still 
making the entered data as accurate as possible. 
The easiest way to achieve both goals in Excel 
is to add dialog box controls — also called 
form controls — to your worksheet. These are 
controls such as check boxes and lists that you 
are familiar with from dialog boxes.

The benefit to using form controls is that they 
reduce the amount of typing required by the 
user entering data. For example, rather than 
having the person type Yes or No in a cell, 
they can activate or deactivate a check box, 
instead. Similarly, rather than having the user 
memorize a cell’s possible inputs, you can 
provide a list of the allowable values.
To use worksheet form controls, you must first 
customize the Ribbon to display the Developer 
tab, as described in the first Tip.

Use Dialog Box Controls 
to Input Data
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Important!
To use the worksheet form controls, you 
must customize the Excel Ribbon to 
display the Developer tab. Right-click 
any part of the Ribbon and then click 
Customize the Ribbon. The Excel Options 
dialog box appears with the Customize 
Ribbon tab displayed. In the Customize 
the Ribbon list box, click to select the 
Developer option, and then click OK.

● Excel adds the control to 
the worksheet.

6 If the control comes with 
a text label, right-click the 
control.

7 Click Edit Text.

Note: You can also double-click the 
text.
 Excel opens the label text 

for editing.

8 Type the name you want 
to use for the control.

9 Click outside the control.

 Excel removes the 
selection handles from 
the control.

Note: To select the control later on, 
hold down Ctrl and click the control.

➥continued

Did You Know?
When you are dragging the control on the 
worksheet, you can make the control’s 
border snap to the worksheet’s cells by 
holding down the Alt key as you drag. If 
you want the control to be a perfect square, 
hold down Shift as you drag. If you want 
the control to be centered on the spot 
where you start dragging, hold down Ctrl as 
you drag.
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 The Format Control 
dialog box appears with 
the Control tab displayed.

3 Click inside the Cell 
Link box.

4 Click the cell you want to 
use to store the control’s 
value.

● Excel inserts the cell 
address in the Cell 
Link box.

5 Click OK.

 When the user changes 
the value of the control, 
the new value appears 
in the linked cell.

Link a Control to a 
Worksheet Cell
1 Right-click the control.

2 Click Format Control.

Adding a form control to a worksheet does not 
do very much by itself. To make the control 
useful, you must link it to a worksheet cell. 
That way, when the user changes the state or 
value of the control, the resulting change is 
reflected in the linked cell.
The value you see in the linked worksheet cell 
depends on the type of control. A check box 
inserts the value TRUE when it is checked, 
and FALSE when it is unchecked. Option 
buttons return a number based on the selected 

option: the first option returns 1, the second 
option returns 2, and so on. Scroll bars and 
spin boxes return a value from a range of 
values that you specify. List boxes and combo 
boxes get their items from a worksheet range, 
and they return the position of the selected 
item in the list, where the first item in the list 
returns 1, the second item returns 2, and so 
on. To get the actual list value, you must use 
the INDEX() worksheet function, as described 
in the second Tip.

Use Dialog Box Controls 
to Input Data (continued)
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More Options!
If you add a scroll bar or spin box control to the worksheet, you must configure the 
control to return a value from a specified range. Right-click the control and then click 
Format Control. In the Control tab of the Format Control dialog box, use the Minimum 
Value and Maximum Value spin boxes to specify the range. Use the Incremental Change 
spin box to specify how much the control value changes when the user clicks a scroll or 
spin arrow. Click OK.
Important! When you click an item in a list control, the item’s position in the list appears 
in the linked worksheet cell. To get the actual item, you need to add the following 
formula to a cell:
= INDEX(input_range, cell_link)
Replace input_range with the address of the range that holds the list values, and 
replace cell_link with the address of the control’s linked cell. 

Populate a List Control 
with Values
1 Add the list items in a 

vertical or horizontal 
range on the worksheet.

2 Right-click the list box or 
combo box control.

3 Click Format Control.

 The Format Object dialog 
box appears with the 
Control tab displayed.

4 Click inside the Input 
Range box.

5 Select the range that 
includes the list values.

● Excel inserts the range 
address in the Input 
Range box.

6 Click OK.

● The values from the 
worksheet range appear 
as items in the list control.
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2 Click the File tab.

3 Click Info.

4 Click Check for Issues.

5 Click Check Accessibility.

1 Open the workbook you 
want to check.

If you have a workbook that will be used by 
people with disabilities, you should check that 
workbook for accessibility problems that could 
make it harder for the disabled to read and 
navigate the document.
Spreadsheets that seem ordinary to most 
people can pose special challenges to people 
with disabilities. For example, a person with a 
visual impairment might have trouble seeing 
images, charts, form controls, and other 
non-text elements. Similarly, a person with 
physical disabilities might have trouble 
navigating a worksheet.

Fortunately, such problems are often easily 
fixed. For example, adding a text description — 
called alt text — to a chart or other non-text 
element helps the visually impaired understand 
what the element does; avoiding non-standard 
worksheet structures such as merged cells helps 
the physically disabled navigate a worksheet.
You can use the Accessibility Checker task pane 
to look for these and other accessibility 
problems, and learn how to fix them.

Check for Accessibility 
Problems
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Important!
If you know your worksheet will be used by people with disabilities, you should build a 
new sheet with accessibility as your goal. Here are a few pointers for making a 
worksheet more accessible:
● Make extensive use of text headings to annotate the worksheet and make it easier 

to understand the structure of the sheet. In particular, every row and column should 
have a unique heading.

● Do not overuse white space such as blank rows and columns. White space usually 
helps make a worksheet look less cluttered, but a sheet that has little or no white 
space is much easier for the disabled to navigate. Use Excel formatting such as row 
heights and column widths to create space within the worksheet.

● Use named ranges whenever possible, as named ranges are relatively easy to navigate 
using the Go To command in Excel. (To name a range, select it, click the Formulas 
tab, and then click Define Name.)

● Excel uses the Additional 
Information section to tell 
you why you should fix 
the problem and the 
steps required to fix it.

● Excel displays the 
Accessibility Checker 
task pane.

6 Click an item in the 
Inspection Results 
section.
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