Lesson 1

What you'll learn
in this lesson:

Exploring Dreamweaver’s
primary features

Introducing new
features in CS5

Understanding how web
sites and web pages work

Coding HTML/XHTML:
the basics

Dreamweaver
CS5 Jumpstart

Whether you are a novice web designer or an experienced developer,
Dreamweaver is a comprehensive tool you can use for site design,
layout, and management. In(this lesson, you’ll take a tour of
Dreamweaver’s key features and get a better understanding of how
web pages work.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace.
See “Resetting the Dreamweaver workspace” on page 3.

You will work with several files from the dwO1lessons folder in this lesson. Make sure that you
have loaded the dwlessons folder onto your hard drive from the supplied DVD. See “Loading
lesson files” on page 3.

Note: If you want to get started creating a page, jump ahead to “Tag structure and attributes”
on page 18. Otherwise, the next few pages provide you with an overview of key capabilities and
features of Dreamweaver CS5.
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What is Dreamweaver?

See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

What is Dreamweaver?

Dreamweaver is an excellent coding and development tool for new and experienced users alike,
and it has quickly become the preferred web site creation and management program, providing
a creative environment for designers. Whether you design web sites, develop mobile phone
content, or script complex server-side applications, Dreamweaver has something to offer.

Design and layout tools

Dreamweaver’s many icon-driven menus and detailed panels make it easy to insert and format
text, images, and media (such as video files and Flash movies). This means that you can create
great-looking and functional web pages without knowing a single line of code—Dreamweaver
takes care of building the code behind the scenes for you. Dreamweaver does not create
graphics from scratch; instead, it is fully integrated with Adobe Photoshop CS5, so you can
import and adjust graphics from within the application.
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The Insert panel features objects in several categories that let
you easily add images, web forms, and media to your page.

Site management and File Transfer Protocol

Dreamweaver has everything you need for complete site management, including built-in file
transfer protocol (FTP) capabilities between a server and your local machine, reusable objects
(such as page templates and library items), and several safety mechanisms (such as link checkers
and site reports) so that you can ensure that your site works well and looks good. If you're
designing your pages with Cascading Style Sheets (CSS), the Browser Compatibility Check and
CSS Adpvisor features will help you to locate and troubleshoot any potential display issues that
may occur across different web browsers.
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What is Dreamweaver?

Coding environment and text editor

Dreamweaver lets you work in a code-only view of your document that acts as a powerful text
editor. Edit HTML code directly and switch views to see the results of your code as you work.
Features such as color-coding, indentation, and visual aids make Dreamweaver a perfect text
editing or coding environment for web designers of any level.

For more experienced developers, Dreamweaver also supports popular coding and scripting
languages, such as JavaScript, and several server-side languages, including ColdFusion, PHP, and
ASPNET. Specialized insert menus and code panels help you to build pages and applications in
the language of your choice.

BasicHTML.html = ChUsers\agiaquent\Desktop\dwlessonfiles\dw0llessons\BasicHTML html|
Split | Diesign Live Code F\_{ Live View Inspect @v . C Title: ;'laht-é-ﬁﬂ'euﬁer-é ‘
| & & & & address: | fie ]

<!DOCTYPE html PUBLIC "-//W3C//DID XHTML 1.0 Transitional//EN" -
"http://www.w3.org/TR/xhtmll/DID/xhtmll-transiticnal .dtd"> ]
<html xmlna="http://www.Ww3.org/l999/xheml">

<head>

<meta http-equiv="Content-Type™ content="text/html; charset=utf-8" />

<title>Put a title here</title>

</head>

[Users/agiaquent/Desktop /dwlessonfiles /dwi Uessons BasicHTML hitml - .

<body>
<p>My text and pictures go here...</p>
<p»<strong>My Bold Title</strong></p>

<p>This text will appear inside of its own paragraph</p>

</body>
</html>

Code view is a full-featured text editor that color-codes tags and scripts for editing that’s easier to decipher.

"\ Scripting languages, such as those used to build interactive web pages or e-commerce sites, fall into
two categories: client-side and server-side. Client-side languages (such as JavaScript) run in your
browser, while server-side languages (such as ColdFusion) require special software installed on the
server to run.

Who uses Dreamweaver?

Dreamweaver’s popularity is a result of its diversity. Its ability to take a site from conception
through to launch—and maintenance afterward—makes it a preferred tool among industry
professionals, businesses, and educational institutions. However, it remains easy and accessible
enough for novice designers to get up-and-running quickly. Its not unusual to see
Dreamweaver utilized for personal projects or by small businesses and media professionals, such
as photographers and painters, to maintain a web presence.
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An overview of features

An overview of features

This book is dedicated to exploring, learning, and putting to use all that Dreamweaver has to
offer. This section looks at some of the application’s key features.

Three different points of view: When you edit a document, Dreamweaver lets you see your
work in one of three views: the Design, Split, or Code view. Dreamweaver’s easy-to-use Design
view lets you build visually and see everything come to life as you create your pages. More
experienced web designers and coders can use the Code view to edit a document’s HTML
code and scripts directly, enhanced with easy-to-read color-coding and visual aids.

For those who like something in between, the Split view provides a split-pane Design and
Code view all at once.You can easily change views at any time with a single click in the
Document toolbar.
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The Split view lets you edit your page visually while seeing the code being created behind the scenes.
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An overview of features

Built-in FTP: You can easily upload and download files to and from your web server using the
Files panel’s drag-and-drop interface, or use the Get/Put button at any time to post pages you're
currently working on. There’s no need for separate software. Dreamweaver also provides Check

In/Check Out functionality and synchronization features for easy management.

Page and code object Insert panels: You can find intuitive icons for most common web
page elements in a categorized Insert panel, from which you can add elements to your page
with a single click.You can use additional panels to fine-tune any page element to ensure that
you see exactly what you want. Included in the default Insert panel are tools for formatting text,
building forms, and creating layouts. Customize a Favorites tab with your most-used icons.

@ Common E

Layout —i

»

Forms

Data

Spry

InContext Editing
Text

m

Favorites

Color Icons
Hide Labels b

B Widget
Date

-Ej Server-Side Indude -

The Insert panel is divided into several
categories geared toward specific tasks.

Customizable workspace layouts: You can save combinations and positions of panels and
toolbars for easy recall at any time. Save multiple workspace layouts for difterent users, or create
different workspaces for specific tasks, such as coding or designing page layouts.

Favorites *
IE Image @
Draw AP Div

You can customize the Favorites panel with icons
from any of the other Insert panel categories.
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Live View

Powerful visual aids: Take advantage of the precision youre accustomed to in other design
programs through Dreamweaver’s guides, rulers, measuring tools, and customizable positioning
grid. Dreamweaver’s Design-Time style sheets let you customize the look of your page
exclusively for the editing process, making layout quicker and easier without permanently

altering the page’s appearance.

Samplelayout.html* = C\Users\agiaguent\Desktophdwlessonfiles\dwillessons\Samplelayout.html
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Rulers, a document grid, and guides help you to size and position page items with precision.

CSS Styles panel: Take advantage of the vast design and formatting options that CSS provides
through Dreamweaver’s full-featured CSS Styles panel, which lets you create, edit, and manage
styles on-the-fly from a single panel.

Live View

Experience tells you that visual web editors often display differently from the browsers they’re
emulating. As script-driven interactivity gains popularity, the need to accurately design the
different states of your page (including menus, panels, and interface elements) has become
increasingly important. The static nature of Design view in Dreamweaver might no longer meet
users’ advanced needs.
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Live View

Dreamweaver’s Live View mode uses the WebKit rendering engine (which is also the basis for
the Safari web browser and Adobe AIR) to give you a more accurate preview of your page,
usually just as a browser would render it.

Samplelayout.html x C\Users\agiaquent\Desktop\dwilessonfiles\dw01lessons\SampleLayout.html -/
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Live View enables you to interact with your pages.

When you select Live Code while in Live View mode, you can see, in real time, how visually
changing your page affects the code behind the scenes.You can preview your code as classes are
added and removed using JavaScript, as dynamic content is inserted using Spry, and much more.

It’s one thing, however, to preview these states, and another to effectively work with them.The
Freeze JavaScript button (or the F6 key) freezes your page in a particular state (for example,
with a menu locked open and a hover eftect in place).You can then edit those interactively
displayed elements directly in Dreamweaver, without having to use the Preview in Browser
feature (F12) and your favorite web browser.
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Related files

Related files

Web-based projects are becoming more complex than ever before, and you often find that even
a single page is composed of a variety of assets. These assets can include Cascading Style Sheets
(CSS), external JavaScript files, or even server-side includes. Dreamweaver CS5 has a feature that
will help you be much more effective at designing and managing sites and applications with
multiple assets.

The Related Files bar runs across the top of your document window, just below the document
tabs. The bar shows you all the various files that combine to create your finished page. Switch
between these files using the Related Files bar without losing the visual preview of their parent
page. Design view (or Live View) always shows the parent file, but you can now edit any of the
related files without losing their important visual context.

CSSstyles.css SpryMenuBar.js  SpryMenuBarVertical.css

The Related Files bar shows you the various files that are part of your
finished page.

Code Navigator

Using the Code Navigator, you can easily jump to any of the related files (including the specific
rules within) that combine to create the final display of a selected element. It is not necessary

to look through multiple style sheets to find a specific rule. It’s now just a context menu-click
away in Dreamweaver. With the Code Navigator, when you hover over a CSS rule you are able
to see the properties and values and click on them to navigate to that specific code. As with
related files, you an do this without losing the visual context that’s so important to creating

interactive experiences.

Z cssstyl

font-family: Arial, Helvetica, sans-serif;
body

font-size: 12px;

background-color: #660000;

margin: 0px;

background-image: url(images/bg.qif);
background-repeat: repeat-x;

Cmd+0Opt+click to show [ Disable & indicator

The Code Navigator allows you to easily jump to any
of your related files.
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Photoshop smart objects

Photoshop smart objects

Dreamweaver CS5 offers support for Photoshop smart objects, meaning you can drag a PSD file
into a web page within Dreamweaver, optimize the image for the web, and even resize it. If you
later update the original PSD file, a red arrow appears on the image in Dreamweaver, indicating
that the source file has changed.You can then click the Update from Original button in the
Property Inspector, and a new version of the image is created.

Image Preview

optens | Fie | [pec [ Preview Saved settings:
Il [
Format: JPEG X 35.20K 5 sec @56kbps PES fually
Quakty: 80 [7]
Smoothing: Mo Smoothing - | R(DI[(;\Z[ }9
|| Progressive browser display

[#] sharpen color edges

Ru:255 G:255 B: 255 fffff

[¥]Remove unused colors

Smart objects provide easier optimizing and updating of graphics.
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How web sites work

How web sites work

Before embarking on the task of building web pages (and in turn, a web site), it’s a good idea
to know the basics of how web sites work, how your users view them, and what you need to
know to make sure your web site looks and works its best.

A simple flow chart

‘What happens when you type in a web site address? Most people don’t even think about it; they
just type in a URL, and a web site appears in a flash. They likely don’t realize how many things
are going on behind the scenes to make sure that pages gets delivered to their computers so that
they can do their shopping, check their e-mail, or research a project.

User Machine (client) http://www.yoursite.com/ Web Host (server)

‘ <html> @ ‘

When you type in a URL or IP address, you are connecting to a remote computer (referred
to as a server) and downloading the documents, images, and resources necessary to reconstruct
the pages you will view at that site. Web pages aren’t delivered as a finished product; your web
browser (Internet Explorer, Firefox, Safari, and so on) is responsible for reconstructing and
formatting the pages based on the HTML code included in the pages. HTML (Hypertext
Markup Language) is a simple, tag-based language that instructs your browser how and where
to insert and format pictures, text, and media files. Web pages are written in HTML, and
Dreamweaver builds HTML for you behind the scenes as you construct your page in the
Design view.

An Internet Service Provider (ISP) enables you to connect to the Internet. Some well-known
ISPs include America Online and Earthlink.You view web pages over an Internet connection
using a browser, such as Internet Explorer, Firefox, or Safari. A browser can decipher and display
web pages and their content, including images, text, and video.

Domain names and IP addresses

When you type in a web site address, you usually enter the web site’s domain name (such as
eBay.com). The web site owner purchased this domain name and uses it to mask an IP address,
which is a numerical address used to locate and dial up the pages and files associated with a
specific web site.

So how does the web know what domains match what IP address (and in turn, which web
sites)? It uses a Domain Name Service (DNS) server, which makes connections between
domain names and IP addresses.
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An introduction to HTML

Servers and web hosts

A DNS server is responsible for matching a domain name with its companion IP address. Think
of the DNS server as the operator at the phone company who connects calls through a massive
switchboard. DNS servers are typically maintained by either the web host or the registrar from
which the domain was purchased. Once the match is made, the request from your user is routed
to the appropriate server and folder where your web site resides. When the request reaches the
correct account, the server directs it to the first page of the web site, which is typically named

index.html, default.html, or whatever the server is set up to recognize as a default starting page.

A server is a machine very much like your desktop computer, but it’s capable of handling traffic
from thousands of users (often at the same time!), and it maintains a constant connection to

the Internet so that your web site is available 24 hours a day. Servers are typically maintained
by web hosts, companies that charge a fee to host and serve your web site to the public. A
single server can sometimes host hundreds of web sites. Web hosting services are available from
a variety of providers, including well-known Internet service companies, such as Yahoo!, and
large, dedicated hosting companies, such as GoDaddy. It is also common for a large company to

maintain its own servers and web sites on its premises.

The role of web browsers

A web browser is an application that downloads and displays HTML pages. Every time you
request a page by clicking a link or typing in a web site address, you are requesting an HTML
page and any files it includes. The browser’s job is to reconstruct and display that page based on
the instructions in the HTML code, which guides the layout and formatting of the text, images,
and other assets used in the page. The HTML code works like a set of assembly instructions for
the browser to use.

An introduction to HTML

HTML is what makes the Web work; web pages are built using HTML code, which in turn is
read and used by your web browser to lay out and format text, images, and video on your page.
As you design and lay out web pages in Design view, Dreamweaver writes the code behind the
scenes that is necessary to display and format your page in a web browser.

Contrary to what you may think, HTML is not a programming language, but rather a simple
text-based markup language. HTML is not proprietary to Dreamweaver—you can create and
edit HTML in any text editor, even simple applications such as Windows Notepad and Mac OS
X’s TextEdit. Dreamweaver’s job is to give you a visual way to create web pages without having
to code by hand. If you like to work with code, however, Dreamweaver’s Code view, discussed
earlier, is a fully featured text editor with color-coding and formatting tools that make it far
easier to write and read HTML and other languages.

Lesson 1, Dreamweaver CS5 Jumpstart 17
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An introduction to HTML

Tag structure and attributes

HTML uses tags, or bracketed keywords, that you can use to place or format content. Many tags
require a closing tag, which is the keyword preceded by a forward slash (/).

1

Choose File > Open. When the Open dialog box appears, navigate to the dwO1lessons
folder. Select BasicHTML.html and press Open.

Select the Split button in the Document toolbar to see the layout as well as the code that
makes up the page.

Take a look at line 10 (indicated at the left edge of the Code panel). The text My Bold
Title is inside a Strong tag, which is simply the word strong contained within angled
brackets. Any words or characters inside these tags are formatted in bold, and appear as
shown in the Design view.
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A look at the code reveals the tags used to_format text in your page.

Tags can also accept CSS rules that specify additional information for how the tag should
display the content. CSS rules can take a number of difterent values, such as a size, a
color, or a direction in which to align something. Take a look at the line that reads This
text will appear inside of its own paragraph. This line is enclosed in a p (paragraph) tag, which
separates it from the other text by a line above and below.You can add a class rule to this

to align the text in whichever direction you want.

Highlight the entire line that reads This text will appear inside of its own paragraph at the
bottom of the Design view.

With the CSS button selected in the Property Inspector, locate the paragraph align
buttons. Press the Align Center button (=).
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An introduction to HTML

5 In the New CSS Rule dialog box, type .center into the Selector Name text field, and
press OK.

T
Mew C55 Rule

Selector Type:
Choose a contextual selector type for your CS5 rule.

Class (can apply to any HTML element) -

Selector Name:

Choose or enter a name for your selector.

| -

-
] r
Less Specific | | More Specific
Rule Definition:

Choose where your rule will be defined.

(Gissoment e )

Name a newly created style in the New CSS Rule dialog box.

6 The text is now centered. Take a look at the Code view, and notice that the .center rule
has been added to the opening <p> tag.
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Align or format text in the Property Inspector, and then see the appropriate rules and attributes created in your code.
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An introduction to HTML

"\ For more information on formatting text with CSS rules, please see Lesson 3, “Adding Text
and Images.”

7 Choose File > Save to save your work, then choose File > Close.

The structure of an HTML document

Although you use many HTML tags to format text, certain tags are devoted to establishing
structures, such as lists, tables, or, most importantly, the HTML documents themselves. The
HTML tag is the most fundamental tag. It is used to specify the beginning and end of HTML

in a document:
<html></html>

Inside the main HTML tags are two tags that define the key areas of your web page: the head
and the body. The head of your page contains items that are not visible to your user, but are
important nonetheless, such as search engine keywords, page descriptions, and links to outside
scripts or style sheets. You create the head of the document inside the HTML tags using the
<head> tag:

<html>
<head></head>
</html>

The body of your page is where all the visible elements of your page are contained. Here is
where you place and format text, images, and other media.You define the body of the page
using the <body> tag:

<html>
<head></head>
<body>

My text and pictures go here...

</body>
</html>

Whenever you create a new HTML document in Dreamweaver, this framework is created
automatically before you add anything to the page. Any visual elements you add to the page are
added, using the appropriate HTML code inside the <body> tags.
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An introduction to HTML

Placing images in HTML

You use some tags in HTML to place items, such as pictures or media files, inside a web page.
The <img> tag is the most common example; its job is to place and format an image on the
page. To place an image and see the resulting code, follow these steps:

1T Choose File > Open. When the Open dialog box appears, navigate to the dwO1lessons
folder. Select the Images.html file and press Open to edit the file.

2 Ifnecessary, click the Split button in the Document toolbar so that you’re viewing both
the layout and the code for your page. In the Design view portion of the Split view, click
below the line of text to place your cursor underneath it. This is where you’ll place a
new image.
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[
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[y ! ¢!DOCIIEE EDML FUBLIC "-//RIC//DID HIEL g :
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Enter the Split view before you insert the image onto your page.
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3 From the Common category in the Insert panel on the right side of the screen, click
on the Images element (&) and choose Image. When the Select Image Source dialog
box appears, select the file named gears.jpg, located in the images folder within the
dwO1lessons folder.

Common ¥
Hyperlink il

Email Link

»

Mamed Anchor

Horizontal Rule

m

Table

Insert Div Tag
~ Images : Image
% Image Placeholder k

E Rollover Image
Fireworks HTML

Wk @ @

17 Draw Rectangle Hotspot i
b Draw Oval Hotspot
12 Draw Polygon Hotspot

Choose Image from the Common tab on
the Insert bar.

4 Press OK (Windows) or Choose (Mac OS); when the Image Tag Accessibility Attributes
dialog box appears, type the words Gears Image in the Alternate text field, and press
OK to place the image.

Image Tag Accessibility Attributes
Alternate bext‘ E
Long description:  http:// (] Coger)

If you don't want to enter this information when inserting

objects, change the Accessibility preferences.

Attach alternate text to your image.
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ﬁk The Image lag Accessibility Attributes dialog box appears when you add images, to provide
additional information for users with special needs (such as the visually impaired). You should
always provide each image with alternative text, but you can disable this panel by choosing Edit
> Preferences (Windows) or Dreamweaver > Preferences (Mac OS). In the Accessibility category,
uncheck the Images option.

5 The code shows that the HTML <img> tag has been used to place the image. Click
once on the image in the document window to select it. The Property Inspector at the
bottom of the page displays and sets the properties for the image.

6 In the Border text field of the Property Inspector, type 3 to set a three-pixel border
around the image, then press Enter (Windows) or Return (Mac OS). Click on the
background of the page to deselect and note the appearance of the border. The <img>
tag now contains the border attribute, which is set to a value of 3, just the way you typed
it in the Property Inspector.

Images.html* x S\Users\agiaquent\Desktop! dwlessanfiles\dwlllessons\Images.hitml
Spiit | Design || | LiveCode |[FY | Live View {4 (" | Tifle: Your First Image

&5 (™ 2 Address: | file:///C|/Users /agiaquent/Desktop/dwlessanfiles jdwd llessons/Images.himl | [ |

<!DOCTYPE HIML PUBLIC "-//W3C//DID HIML 4.01//EN® "http://www.w3.org/TR/htmld/strict.dcd™> -
<html>

<head>

<meta http-equiv="Content-Type” content="text/html; charset=ucf-2"»

<title>Your First Image</titler

</head>

<body>

<p>Flace an Image Below to Spice Things up...</p>

<p><img src="images/gears.jpg” width="100" height="100" border="3"></p>

As you change or add options to a selected image, Dreamweaver changes code behind the scenes.

7 Choose File > Save to save your work, then choose File > Close.

Note that in HTML, images and media are not embedded, but placed. This means that
the tags point to files in their exact locations relative to the page. The tags count on those
files always being where they’re supposed to be in order to display them. This is why
HTML pages are typically very lightweight in terms of file size.
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Colors in HTML

In Dreamweaver’s various panels and in your code, each color is referred to by a six-character
code preceded by a pound sign. This code is called hexadecimal code, and is the system that
HTML pages use to identify and use colors.You can reproduce almost any color using a unique
hexadecimal code. For example, you represent dark red in HTML as #CC0000.

The first, middle, and last two digits of the hexadecimal code correspond to values in the

R GB spectrum. For instance, white, which is represented in RGB as R:255 G:255 B:255, is
represented in HTML as #FFFFFF (255]255]255). Choosing colors is easy, thanks to a handy
Swatches panel, which you can find in many places throughout the work area.

The Swatches panel makes it easy to
work with colors.

"\ The color pickers in Adobe Photoshop and Illustrator also display and accept hexadecimal codes,
making it easy to copy and paste colors between these applications and Dreamweaver.

Case sensitivity and whitespace rules

HTML is a flexible language that has very few rules regarding its own appearance. Based on
how strictly you want to write it, HTML can be either very specific about whether tags are
written in upper- or lowercase (called case sensitivity), or not specific at all. To see how HTML
treats whitespace, follow these steps.

1 Choose File > Open. When the Open dialog box appears, navigate to the dwO1lessons
folder. Select the Whitespace.html file, then press Open.
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2 Ifyour file is not in Split view, press the Split button in the Document toolbar, so
that you can view both the layout and the code. Notice three seemingly identical tags
beneath line 9 in your code:

‘Whitespace.html >
| Gode [ Splt | Design || | Live Code |7 Live View || Inspect
G O G Address: |_ﬁ 11/C|Msers faglaquent/Desktop/dy s
<!DOCTYEE HIML PUBLIC “-//W3C//DTD HTML  » L9000 [8000 e B0 P80 8900 B BB e,

\Whitespace.htm|

o 4.01 Transitional//EN" RE
5 "http://www.w3.org/TR/htnl4/loose.ded™> E
| o D | e
ki <head> EE
g <meta http-equiv="Content-Type" content= 3 o .0
E: “text/html; charget=UTF-8"> E This is one sentence. This is another.
* <title>Untitled Document</title> E
e </head> 03
®
{!} <body> F
EE|

i

o
Ll

]

All these tags are valid, even though they have very different case structures.

All three tags use a completely different case structure, but all are valid and are treated
in the same way. Take a look at the text that reads This is one sentence. This is another. The
code shows a lot of space between the two lines, but the Design view shows no space at
all. This is because both whitespace and line returns between two pieces of text or tags
are not recognized.

Whitespace.html
| Code [ Spit | Design i|mmigﬁ||mm|w|@,@'c

G2 O () Address: | fle:/1/CUUsers/agaauentiDeskiop/dnessonfies/dn0 lessons Whitespace.hr

I <!DOCTYPE HIML PUBLIC "-//W3C//DID HIML 211 | O FORPOPR L O s, OO, PO - PO L OO
4.01 Transitional//EN" T P
“http://www.w3.org/TR/htmld/locae .ded™> E
SIml> L4 Text Text Text
<head> 55

<meta http-equiv="Content-Type" content=
"text/html; charset=UTF-87>
<title>Untitled Document</titlex

</head>

&£ (ot f D

<body>

<body>

<p><font color="#cc0000">Text</font>
<FONT COLOR="#cc0000">Text</FONI>
<f0nT color="#cc0000™>Text</fONE>
</E>
<p align="center~ S SEIEERGEREELGELITN

I

S|
FEETT T T

b

Despite the large amount of space between the two sentences, they appear side-by-side in the Design view.
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3 To create a line return, or a new paragraph, you need to enter the necessary HTML
tags. In the Design view at the bottom, position your cursor after the first sentence, then
press Shift+Enter (Windows) or Shift+Return (Mac OS) twice. This creates two line
returns—you can see that each line return is created in your code by a <br> (break) tag.
‘When rendered in the browser, the <br> tag adds blank lines between the sentences,
however the sentences are technically within the same paragraph.

‘Whitespacehtml* x
P o Oy Address; | fleficl)
<!DOCTYPE HIML PUBLIC "-//W3C//DID HIML 4.01 =

fDesktop)d

D— Transiticnal//EN™

"http://www.w3.org/TE/html4/loose.dtd™>
R <i:emt> Text Text Text
3 <head>

4 <meta http-equive"Content-Type" contents=
"text/html; charsec=UTF-8">

L] <title>Untitled Document</title>
& </ head>
7

]

This is one sentence.

This is another.

<body>r

<body>
11 <p><font color="#cc0000">Text</fonts
1z <FONT COLOR="#cc0000">Text</FONT>
<I0nT color="#cc0000">Texce/£0NT>
</p>
<p align="center”>This is one aznt!m.l-d)r)
<br>
<k>This i3 another.</b>

R[F @ e soat

4 To create a new paragraph, position your cursor before the phrase, This is another, and
press Enter (Windows) or Return (Mac OS).The text is separated by a line above and
below, and is wrapped inside a set of <p> (paragraph) tags.

‘Whitespace html* x

D, 1 <!DOCTYPE HIML FUBLIC "-//W3C//DID HIML 4.01 =
Transiticnal//EN™
“http://www.w3.org/TR/htnld/ loose.ded™>
| D Text Text Text
| 3 <head>
+=( 4 <meta http-equiv="Content-Type" content= _
&l “text/html; charset=UTF-8> This is one sentence.
¥| s <title>Untitled Document</title>
= & </ head>
e {This is another.
G & <bodyr
]
10 <body>
11 <p»<font color="#cc0000">Text</font>
& 12 <FONT COLOR="4#cc0000">Text</FONI>
| <IOnT color="#cc0000">Text</IONT:
@ 14 </p>
15 «<p align="center”>Thiz is one sentence.<br>
16 <br>
17 <>
| 18 <p align-"cen:er"‘)(b*l’hia iz another.</b>
18 </p>

Dreamweaver creates a new paragraph each time you press the Enter or Return key.
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"\ Other than a standard single space (such as the ones used between words), several consecutive
spaces created by the spacebar are ignored, and are displayed as only one space in Design view and
in a browser.

5 Choose File > Save to save your work then choose File > Close.

Tag hierarchy

HTML tags follow a certain order of weight, or hierarchy, to make sure that everything displays
as it should. The tag at the top of the hierarchy is the <htm[> tag, and every other tag you create
is contained within it. Tags such as the <body> tag always hold smaller tags, such as the <p>
(paragraph), <img> (image), and <strong> (bold) tags. In addition, structural tags (such as those
that create paragraphs, lists, and tables) hold more weight than formatting tags such as <strong>
(bold) and <em> (italic). Take this line of code, for example:

<strong><p>Big bold paragraph</p></strong>

Although code such as this may work in certain browsers, it isn’t recommended, because the
<strong> tag technically holds less weight than the <p> tag.The following code represents a
safer and more proper way to include the bold type:

<p><strong>Big bold paragraph</strong></p>

Dreamweaver generally does a great job of keeping tags properly nested, or contained within
each other. When you choose to manipulate the code by hand, you should always keep good
coding techniques in mind.

XHTML 1.0 Transitional

The latest recommended version of HTML is XHTML 1.0, a stricter version of HTML

that makes the language more compatible with newer platforms, such as mobile phones and
handheld devices, which require code to be perfectly formed. XHTML combines elements of
HTML and XML, a language used to describe data. XML, or Extensible Markup Language, has
become a popular method of exchanging information among seemingly unrelated applications,
platforms, and systems. By default, Dreamweaver creates new web pages using the XHTML 1.0
Transitional standard.
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What's the difference?

Although tags and attributes remain the same, the structure of the language changes with
XHTML, becoming stricter. Whereas HTML was very forgiving of sloppy coding practices
such as overlapping or unclosed tags, XHTML requires all tags to be closed and properly nested.
HTML doesn’t care which case you use when constructing tags, but in XHTML, all tags must
be lowercase.

For example, a <br> (break) tag, which normally doesn’t require a closing tag, now must be
closed.You can write tags to self-close by using a forward slash—making sure there is a space
between the (br) and the forward slash—and then closing the bracket like so:

<br />

The result is a well-formed language that takes advantage of newer browsers and device
platforms, while remaining compatible with older browsers. Working with XHTML in
Dreamweaver requires nothing more than selecting XHTML 1.0 Transitional as the Document
Type (DocType) when creating a new page.

Explorations in code

Although this book occasionally refers to the code for examples, hand-coding 1s not a primary
goal of the included lessons. The best way to learn how code represents the layouts you are
building visually 1s to switch to the Code view and explore what’s happening behind the scenes.

It’s important to remember that every button, panel, and menu in Dreamweaver represents some
type of HTML tag, attribute, or value; very rarely will you learn something that is unrelated or
proprietary to Dreamweaver alone. Think of the Dreamweaver workspace as a pretty face on
the HTML language.
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A look at the Welcome Screen

A common fixture in most CS5 applications is the Welcome Screen, which is a launching

pad for new and recent documents. In Dreamweaver, the Welcome Screen appears when the
application launches or when no documents are open. From the Welcome Screen, you can
create new pages, create a new site, open a recent document, or use one of Dreamweaver’s many
starter pages or layouts.

Open a Recent ltem Create New Top Features (videos)
T dwo1leszonzWhitaspace. himi T HTML CSS Inzpect Mode
= dw1lessona/images. himl % ColdFusion "
s ey EE ©SS Enable/Disable
7 dwiilkessons/BasicHTML htmi %] PHP
£5 Open.. | asPveserpt EH Oynamicaly-Relatsd Fles
- ;
| XSLT (Entire page}
g Live View Navigati
™ css EE S
T JavaScript |" BrowserLab integration
- A
| ML
- 5 More...
n Dreamweaver Ste...
£ More...
] Getting Started »
|] mew Features » DW
hj Resgurces »
E Dreamweaver Exchange »
| Don'tshow again

The Welcome Screen appears when you launch the application, or when no documents are open.

Here’s what you’ll find on the Welcome Screen:

Open a Recent Item: A list of the last few documents you worked on appears in the leftmost
column, or you can browse to open a different file using the Open button (&) at the bottom.

Create New: In addition to HTML pages, you can choose from a variety of new document
formats, such as CSS, JavaScript, and XML. Dreamweaver is not just a web page-building tool,
but also a superior text editor, making it ideal for creating many non-HTML files.You can also
define a new Dreamweaver site using the link at the bottom, or choose the More folder for
even more new file options.

Top Features (videos): On the far right side of the Welcome Screen, there is a column

that contains Top Features videos. These videos explore some of the new top features of
Dreamweaver CS5, such as CSS Inspect Mode, Dynamically-Related Files, and BrowserLab
Integration. The videos are located on Adobe’s web site, adobe.com, and when you click on one,
Dreamweaver launches the site in your web browser to give you access to the video.
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Creating, opening, and saving documents

The lessons throughout this book require that you create, save, and open existing files.You can
accomplish most file-related tasks from the File menu at the top, or from the Welcome Screen
that appears when you launch Dreamweaver.

Creating new documents

Dreamweaver creates text files, commonly in the form of HTML files (or web pages). It can
also create files in a variety of text-based languages, including CSS, XML, JavaScript, and even
Flash ActionScript.

You can create blank files that you build from the ground up, or get started with a variety of
layout templates and themes.You can create new documents from the File menu or from the
Welcome Screen.

Mew Document (=5
Page Type: Layout:
k T HML <nane>
“3 Elancbaoe = HTML template 1 column fived, centered
5 Library item 1 column fixed, centered, header and foot
-3 Blank Template % XSLT (Entre page) 1 column kiquid, centered
S ¥SLT (Fragment) 1 column iquid, centered, header and foot .
. = Actonsapt 2 column fived, left sidebar <Ho preview>
53 Fage fiom Tempiate | = o 3 column fixed, left sidehar, header and fo
; D) avasat :muu: :m:' 'ﬂ:mm header 2nd {
= - col xed, r .
ﬂ Pegefiom Sampls | T YL 2 column liquid, left sidebar
) - ) 2 column iquid, left sidebar, header and fo
v Other = ASP JavaSeript 2 column liquid, right sidebar 3
[E ASPvBSopt 2 colume iquid, right sideber, header and { T - document
) ASPMETCE 3 column fixed
o ASPaETVE 3 column fixed, header and footer
‘: ColdFusion 3 eolumn iquid
T ColdFusion companent 3 column liquid, header and footer DocType: XHTML 1.0 Transitonal
=
_— e Layout C55 Add to Head
Attach CSS file: =
Enable InContext Editing
Learn more about Business Catabyst
jJj TR " | InContext Editing
Fr— —

The New Document dialog box gives you a choice of new files in a variety of formats and templates.

1 To create a new document, choose File > New.The New Document dialog box appears.

2 Select Blank Page and under the Page Type column, choose HTML. Under Layout,
choose <none> to start a new blank document. Leave the DocType drop-down menu at
its default. Press Create.

Choose File > Save or File > Save As to start the process of saving your document.

When prompted, choose a location for your file and assign it a name. Note that you must
save HTML files with an .html extension, or they will not be interpreted properly in a
browser. This rule applies for files of any type (such as .xml, .css, and .cfm).
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ning a recently opened document

To open a document you've worked on recently, Choose File > Open Recent or, from the
Welcome Screen, select a document under the Open a Recent Item column.

Dw

JBE* DREAMW

Open a Recent ltem

ﬂ dwi1lessons/Whitespace.html
Al

&
‘E dwi1lessons/images. html
J

dw01lessons/SampleLayout himl

%% dwo1lessons/PhotoshopDoc. htmi

|| dwotlessons/BasicHTML himl I
N

%7 dwi3lessons/exd_sticky himl

JHle] Edit View Insert Modify Format Commi

MNew... Ctrl+M

Open... Ctrl+O

Browse in Bridge... Ctrl+Alt+0

Open Recent 3 1 Whitespace.html

Open in Frame... Ctrl+Shift+0 2 BasicHTML.html

Close Ctrl+W 3 Images.html k

Close All Ctrl+Shift+W 4 Samplelayout.htrml

Foere o ST 5 Samplelayout.html
--------------------------------------------------------- & BasicHTML.html

Reopen Documents on Startup

Choose a file from the Welcome Screen or choose File > Open Recent to
select a recently opened file.

Now that you've seen what Dreamweaver can do, it’s time to put what you’ve learned into
practice. Move to the next lesson so that you can begin building your first Dreamweaver site!

Self study

Explore the ready-to-use CSS layouts available in Dreamweaver by choosing File > New,
then selecting HTML from the Page Type column. Browse the options listed in the Layout
column and open a few layouts. Identify some that you'd like to use as a starting point for any
future project.
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Review

Review

Questions

1 From what two locations in Dreamweaver can a new document be created?
2 In what three views does Dreamweaver allow you to view and edit documents?

3 True or False:When a web page is requested, it is delivered to a user’s browser as a
completed, flat file ready for viewing.

Answers
1 From the Welcome Screen or by choosing File > New.
2 Design, Split, and Code views.

3 False. Files are delivered individually; the browser uses HTML code to assemble the
resources together to display a finished page.
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