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Getting Acquainted with Flash CS5

In This Chapter

Introducing Flash

Figuring out what you can create with Flash CS5
Knowing when not to use Flash CS5

Starting Flash

Perusing the screen

Using Help

Creating your first animation

Closing Flash

Once upon a time in a galaxy that seems far, far away by now,
there was the Internet, which contained only plain,

unformatted text. Then came the Web, and we gained text
formatting and graphics. Then the Web grew up a little,
and Web page graphics got fancier with things such
as small animations in banner ads. But people, being
used to movies and TV, wanted an even more ani-
mated and interactive Web experience. Along came
Flash.

Ra nbow
Resources

Flash is the software that runs some of the coolest
Web sites around. When you surf the Web and see
sites that contain animation across the entire page

or buttons that do spectacular stunts when you click
them, you'’re probably seeing some Flash magic. If you
create a Web site, you can use Flash to rev up the basics

and actively respond to users’ choices so that your view-

ers will say, “Wow!” Even a lot of video that you see on the
Internet, such as at YouTube.com, uses a compressed Flash video
format (FLV).

In this chapter, you find out what Flash is all about, what the Flash screen
looks like, and how to use Help. Then you create your first, simple animation
so that all the rest of this book makes sense.
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Want a great new way to create a Flash Web site without using Flash? Yes, it’s
possible! You can design the site in Adobe Photoshop or Illustrator and then
use Adobe Flash Catalyst to create the site. For more information, see Part VI.

Discovering Flash
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Flash offers a powerful system for creating animation for the Web. In a nut-
shell, here’s an overview of how you use the system:

1. Create a Flash movie by creating graphics and animating them over the
duration of the movie.

Besides animated graphics, you can add navigational buttons, check
boxes, and other user interface elements. You can add a few Flash com-
ponents to a Web site or create an entire Web site.

2. Use the Publish command in Flash to publish the movie into a Flash
Player file that a browser can display.

At the same time, Flash creates the appropriate HyperText Markup
Language (HTML) code that you need for your Web page.

3. Insert HTML code into your HTML document that references the Flash
Player file.

This is similar to adding a graphic to a Web page. Or you can use the
HTML code alone as a new Web page for a fully Flashed page.

4. Upload the new or edited HTML document and the Flash Player file to
the location where you keep other files for your Web pages.

5. Open your browser, navigate to your Web page, and presto! — there’s
your cool animation, navigation, or other Flash element on your
Web page.

You need Flash Player to see the effects that Flash creates. These days, Flash
Player comes installed with most computer systems and browsers, so most
people can view Flash-driven Web sites immediately without any special
download or preparation. When you display a Web site that contains Flash
effects, your system uses Flash Player to play the animation. Users who don’t
have Flash Player can download it for free from Adobe at www.adobe . com/
go/flashplayer.

Web sites continue to grow more and more sophisticated. By using anima-
tion, special effects, and interactive techniques, you can distinguish your
Web site from the also-rans. Creating animation isn’t hard, and you don’t
have to be a professional graphic artist, either. Anyone can create simple
animations to enhance a Web site; it just takes a little time.
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To find great Web sites that use Flash, check out the Adobe site at www .
adobe.com/cfusion/showcase/index.cfm and look at some examples.
Don’t get discouraged by seeing some truly sophisticated results at these
sites. You can start with a simple, animated site and go from there. (Chapter
19 lists ten great Flash designers and where you can find their work.)

Understanding What Vou Can Create
with Flash CS5

You can use Flash CS5 to create simple animation to add to your Web page.
Or you can create an entire Web page or site with Flash and incorporate text,
graphics, interactive buttons, user interface components, and animation. You
can even program applications in Flash.

This book helps you use Flash to create a simple or complex Web site or
application for the iPhone. The following list describes some ways that you
can manipulate text, graphics, and sound by using Flash CS5:

1~ Create still or animated text on your Web page. You can choose to
stop the animation after a few seconds or repeat it while your viewers
view the page.

1~ Use Flash tools to create your own graphics for your Web page or to
import graphics. You can lay out an entire Web page graphically or add
graphics to only a part of a Web page, as shown in Figure 1-1.
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Thanks to the New York Philharmonic, wow . nyphi 1 . org, for permission. Photo by Chris Lee
Figure 1-1: The New York Philharmonic Web site uses Flash to
create an ever-changing display on its home page.
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1~ Animate graphics and make objects appear and disappear by using
the transparency feature. Objects can move, get bigger or smaller, or
rotate. Flash also lets you morph — that is, transform — shapes into new
shapes.

v~ Fill shapes and text with gradients, which are colors that gradually
change into new colors. You can even fill shapes and text with bitmap
images that you import into Flash. For example, you could fill the let-
ters of your name with dozens of flowers. (You aren’t a flower child any
more?)

1 Create Web page buttons that not only lead your viewers wherever
you want them to go but also change shape or color at the same time.
You can make buttons change when you pass your mouse over them.
People who view your page can click a button to display a movie (anima-
tion) or start a small application.

1 Add sound or video to your movie. It’s easy to add sound effects in
Flash. You can control how long the sound or music plays and whether
it loops to play continuously. You can play video files as well.

1 Create menus that viewers can use to navigate your site. You can
create navigation tools as well as forms, check boxes, and other inter-
face elements that look a lot more stylish than plain HTML ones.

As you can see, you can go far with Flash if you want. And why not? It’s
great fun!

Determining When Not to Use Flash CS5

If Flash CS5 is so wonderful, why doesn’t every Web site designer use it? Why
aren’t most Web sites created completely with Flash?

Here’s the other side of the story.

Although the vector graphics and animation of Flash load quickly, they don’t
load as quickly as plain text and simple graphics. Adding a movie to your
Web page adds to its loading time. There’s no point in using Flash if you want
simple pages consisting of mostly text and a few graphics that you want to
stay put and not move.

You can create certain graphic effects more easily by using bitmap graphics.
Painted brush stroke and textured effects are examples. Artists create these
types of graphics by using graphics editing software, and the results are bit-
maps. Similarly, to add photographs to your Web page, you need to insert
electronic image files. Flash creates vector graphics (defined mathematically),
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which are different from bitmap graphics (defined by lots of dots). However,
you can import bitmap graphics into Flash. Find out more about bitmap and
vector graphics in Chapter 2.

If you want simple animation, such as a few blinking dots or a marquee effect,
animated GIFs (the animated bitmap graphics that you often see on the Web)
might be smaller than Flash movies, so they load faster. You can create ani-
mated GIFs by using animated GIF editing software.

Some sites don’t lend themselves to animation. Animation can distract from
your content, and overdoing animation can make a serious site seem silly.
Animation is great, but it has its place. Also, although Flash has some fea-
tures that allow accessibility for people with disabilities, it still isn’t as acces-
sible as plain HTML. You need to determine whether animation is right for
your Web site.

Getting the Right Start

Well begun is half done, as the saying goes. The easiest way to begin using
Flash CS5 is with a shortcut or alias right on your desktop. Double-click the
Flash icon, and you’re on your way. (See the book’s companion Web site for
information on installing Flash.)

Starting Flash on a PC

Whether you installed Flash from the DVD or by downloading it from the
Adobe Web site onto your PC, you might or might not have a shortcut on
your desktop. To create one, choose Start=>All Programs=>Adobe Flash
Professional CS5. With your desktop visible, press the Ctrl key and drag the
Adobe Flash CS5 item onto the desktop.

To rename the shortcut, click the shortcut on your desktop. Then click the
text beneath the icon. Type Flash CS5 (or whatever you want) and press
Enter. Just double-click the icon to open Flash.

Starting Flash on a Mac

You might find it handy to add the Flash CS5 icon to your Dock for easy
launching. To do this, click the Finder icon on the extreme left of the Dock
to bring up a new Finder window. Navigate in the Finder window to the
Applications folder, and in the Applications folder, double-click the Adobe
Flash Professional CS5 folder to open it. Click and drag the Flash CS5 appli-
cation icon to the Dock. A copy of the Flash CS5 application icon appears
on the Dock.

15
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Creating a new movie

Files that you create by using Flash are commonly called movies. When you
start Flash, the startup screen appears (by default), as shown in Figure 1-2.

In the Create New section, click one of several options to immediately open a
new movie file. These options let you create movies for various types of uses,
such as mobile devices and further programming. For the purposes of this
book, we assume that you want to create a general-use movie using the latest
technology, which is the ActionScript 3.0 option. (ActionScript 3.0 is the
latest version of Flash’s programming language.) However, if you're creating
an iPhone application, choose iPhone.

If you already opened a movie and have the menus available, choose Filer>
New. In the New Document dialog box, select ActionScript 3.0 on the General
tab and then click OK. You usually start by creating or importing some graph-
ics. (To find out more about working with graphics, see Chapter 3.)

o
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Figure 1-2: The Startup screen.
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Opemnq an emstmq movie

If you want to work on a movie that you already created when you first open
Flash, choose the movie from the Open a Recent Item section of the Startup
screen, or click Open to find the file. If you already opened a movie and

have the menus available, press Ctrl+O (Windows) or 8+0 (Mac) or choose
Filec>Open; then double-click the movie to open it. The first frame appears on
your screen, and you can edit the movie any way you want.

When you open more than one movie, you see a tab at the top for each
movie. You can click the tabs to move from movie to movie. The tabs appear
in the order you created or opened the movies.

Taking a Look Around

The Flash screen is different from screens in other programs that you might
be used to, so take the time to get to know it. You can also customize the
Flash screen. Figure 1-3 shows one possible display.
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Figure 1-3: The Flash screen.
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If your screen opens with several rectangular panels strewn about or docked
on various sides, don’t worry about them now. We explain how to open and
use these panels throughout this book, but you don’t need them for this
chapter. If they drive you crazy, right-click (Windows) or Control-click (Mac)
each panel’s title bar and choose Close or Close Group in the menu that
appears.

Tooling around the toolbars

Flash contains two toolbars in the Mac version: the Edit bar and the
Controller. In Windows, Flash also offers the Main toolbar. To display or hide
these toolbars, choose Windowr>Toolbars and click the toolbar that you
want to display or hide. Here is a description of the toolbars:

1 Main toolbar (Windows only): Contains commonly used commands,
such as Open, Save, and Print. By default, Flash does not display the
Main toolbar.

1~ Controller: Lets you control the playback of movies. For more informa-
tion, see Chapter 9.

1~ Edit bar: Helps you work with the symbols, scenes, and the user
interface (UI). The bar, shown in Figure 1-3, appears below the menu.
It includes a button to access symbols (which we cover in Part 1), a
button for editing scenes, and a zoom control. We discuss the Timeline
later in the chapter, in the “Following a timeline” section. For detailed
information about the Timeline and scenes, see Chapter 9.

Using panels

Panels give you access to the many Flash tools and settings. You access the
panels from the Window menu. We discuss the specific panels throughout
this book. In this section, we explain how to keep control over your panels.

Most panels are dockable, which means they can sit at the side or bottom of
your Flash window without covering up your work and they fit together in a
group with other panels. You can also stack undocked panels on top of each
other. You control panels by doing the following:

~ Dock a panel. Drag it by its title bar to the side or bottom of your
screen. When you see a blue bar highlight, release the mouse button.
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1 Undock a panel. Drag it by its title bar.

* Open or close a panel. Choose it from the Window
menu.

1 Close an undocked panel. Click its Close button.

1~ Close a docked panel. Right-click (Windows) or
Control-click (Mac) its title bar and choose Close.

1~ Collapse a group of panels to icons. Click the
double right arrow at the top of the group of docked
panels.

You can also stack panels. Drag a panel (by its title bar)
to another panel to stack it below the first one. You can
also collapse or expand panels: A collapsed panel dis-
plays only its title bar, so it doesn’t take up much space.
Just click its title bar. Repeat the process to expand the
panel again.

A set of icon panels, shown in Figure 1-4, provides short-
cuts to often-used panels. You click the button to both
open and close its panel.

The Tools panel contains all the tools you need to

draw and edit objects. At the bottom of the Tools panel
are options that modify how the tools function. (See
Chapters 3 and 4 for a complete description of the Tools
panel.)

Chapter 1: Getting Acquainted with Flash CS5
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Figure 1-4: The icon
panels look like toolbar
buttons. Use them to
open and close panels.

The Property inspector, shown in Figure 1-5, is another important panel. This
panel displays information about selected objects, such as size, name, and
location. You can modify objects in the Property inspector as well. It’s con-
text sensitive, which means that its contents change according to what you're
doing. For example, if you select a graphic object, the Property inspector pro-
vides settings relating to that object, and you can use the Property inspector

to edit that object.

By default, the Property inspector is grouped with the Library (which we

explain in Chapter 2).

The Property inspector has several controls for changing its configuration:

19
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Figure 1-5: The Property inspector.
Table 1-1 Flash Menus
Menu UseltTo
Flash (Mac only) Set preferences, create keyboard shortcuts, and quit
Flash.
File Open and close files, save files, import and export files, print, pub-

lish movies for the Web, send a movie via e-mail, and quit Flash.
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Menu UseltTo

Edit Undo and redo commands; cut, copy, and paste to and from the
Clipboard; delete, duplicate, select, and deselect objects; find
and replace; copy and paste entire frames and motions on the
Timeline; edit symbols (see Chapter 7); set preferences (Windows
only); customize the Tools panel; map fonts; and create keyboard
shortcuts for commands (Windows only).

View Zoom in and out; show or hide the ruler, grid, and guides; choose
a preview mode; and specify snapping preferences for objects for
easy placement.

Insert Insert symbols (see Chapter 7); insert and delete Timeline features,
such as frames and keyframes (see Chapter 9); insert layers (see
Chapter 6); and add scenes (see Chapter 9).

Modify Modify symbols, bitmaps, shapes, frames, Timeline features and
effects, scenes, or the entire movie (the document). Transform,
align, group, and ungroup objects; arrange objects; and break
objects apart.

Text Format text, check spelling, and embed fonts.

Commands Reuse and manage saved commands. A command is any action
that you take in Flash, such as drawing or editing an object. You
can save commands from the History panel. (See Chapter 4.)

Control Control the playing of movies, test movies and scenes, access cer-
tain interactive functions, and mute sounds.

Debug Debug ActionScript code. (See Chapter 10.)

Window Open lots of things, including a duplicate window, panels that help

you control objects, the Library (see Chapter 2), windows for cre-
ating interactive controls (see Chapter 10), workspaces, and the
Movie Explorer (to help manage your movie — see Chapter 12).

Help You can find a wide variety of help resources, including Adobe
online forums.

Many menu commands offer keyboard shortcuts. You can also create your
own keyboard shortcuts. (See the bonus chapter, available at the book’s
companion Web site, www . dummies.com/go/flashcs5£d, for instruc-
tions.) The shortcuts are displayed on the menus, next to the command
name. Here are some of the most commonly used keyboard shortcuts.

v Ctrl+N (Windows) or 38+N (Mac): Open the New Document dialog box so
you can start a new movie.
v Ctrl+O (Windows) or 88+0 (Mac): Open an existing movie.

v Ctrl+S (Windows) or 38+S (Mac): Save your movie. Use this shortcut
often!

1 Ctrl+Q (Windows) or 3+Q (Mac): Exit Flash.

21
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v Ctrl+X (Windows) or 8+X (Mac): Cut to the Clipboard. Chapter 4
explains more about using the Clipboard.

v Ctrl+C (Windows) or 8+C (Mac): Copy to the Clipboard.

v Ctrl+V (Windows) or 88+V (Mac): Paste from the Clipboard. The copy
goes at the center of the display.

v~ Ctrl+Shift+V (Windows) or 88+Shift+V: Paste in Place (the same location
as the original).

v Ctrl+Z (Windows) or $8+Z (Mac): Undo. Would you believe that by
default Flash remembers your last 100 actions and can undo them? What
arelief! And if you choose Windowr>Other Panelst>History, the History
panel lists each action so you know what the next Undo will undo. Think
of it as a journey into the long-forgotten past. (See Chapter 4 for more
on the History panel, and see the Bonus Chapter at the book’s compan-
ion Web site for details on customizing the number of Undos that Flash
remembers.)

1 Ctrl+Y (Windows) or 38+Y (Mac): Redo. This redoes actions that you
undid by using the Undo command. (Got that?) This button remembers
just as many actions as the Undo command. If you undo more actions
than you want, Redo until you're back where you want to be. Using the
Undo and Redo commands is like traveling through Flash time — and it
gives you lots of slack while you're working.

We mention other keyboard shortcuts throughout this book when we discuss
their corresponding commands.

Although it’s not a shortcut, note that you can find the Zoom Control box

in the upper-right corner of the Stage — that is, when the Edit bar is open.
(Choose Windowr>Toolbars=>Edit Bar if necessary.) Click the arrow and
choose a zoom factor to zoom in and out. Zooming doesn’t change the actual
size of objects — it just makes them look bigger or smaller.

You aren’t limited to the choices on the Zoom drop-down list. Type a number in
the Zoom Control box and press Enter (Windows) or Return (Mac) to set your
own zoom factor. For example, type 85 to set the zoom factor to 85%.

Customizing the workspace T —

For the best in customization, you can save any Name: Default-+color

layout of panels you like. Set up the panels and

choose Window=>WorkspaceroNew Workspace. In Cance

the New Workspace dialog box that opens, shown

in Figure 1-6, give the layout a name and click Figure 1-6: Make your very own
OK. To restore that layout at any time, choose workspace.

Window=>Workspace and choose your very own
layout. Choose Window=>WorkspaceroManage Workspaces if you need to
rename or delete a workspace.
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You can access the same workspace features on the right side of the Menu
bar. It’s easy to choose a new workspace by just clicking the Workspace
drop-down list.

Staging your movies

The white box in the center of your screen is the Stage. Think of the Stage
as a movie screen where you place objects. You can place graphics and text
there and then animate them. Flash also plays back movies on the Stage.

Around the edge of the Stage is a gray area called the Pasteboard. You can
use the Pasteboard to store graphics that you plan to use soon but don’t
want on the Stage just yet. (For more permanent storage, use the Library,
as we explain in Chapter 2.) You can also store data and other nongraphical
content on the Pasteboard. Content that you put on the Pasteboard doesn’t
appear in your Flash movie.

Following a timeline

The Timeline window divides your movie into frames. Each frame represents
a tiny stretch of time, such as /4 of a second. Creating a movie is simply a
matter of assembling frames, which are then quickly played in order.

Chapter 9 explains in detail how to make using the Timeline completely pain-
less. For now, you should just understand the essentials. See Figure 1-7 for
the basic Timeline.
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Figure 1-7: The Timeline is your key to managing animation.

On the left side of the Timeline is the layer list. When you open a new movie,
you see only one layer, unimaginatively named Layer 1. A layer is like a sheet
of transparent acetate on which you draw objects. Layers help you keep
objects from running into each other, causing unfortunate, messy results.
You organize your entire movie by using layers. For example, if you want to
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keep some text constant throughout the movie but animate a bouncing dot,
you would give the dot its own layer and animate it on that layer. The layer
list has room for more layers, and you can add as many layers as you want.
(Chapter 6 gives you the lowdown on layers.)

You can drag the upper edge of the Timeline to make room for more layers.
Hover the mouse cursor over the top of the Timeline’s gray title bar until you
see the two-headed arrow and then drag upward.

To the right of Layer 1, you see a bunch of rectangles, each representing a
frame. (Actually, before you start using the Timeline, they’re just potential
frames, like unexposed frames on a roll of film.) By default, each frame lasts
%4 of a second. Each layer has its own row of frames because you can have
different animations or objects on each layer.

A keyframe is a frame that defines some change in your animation. In some
animations, every frame is a keyframe. Other animations need keyframes for
only the first and last frames.

The playhead indicates the current frame in the animation and consists of a
red rectangle as well as a vertical hairline that crosses a frame on all layers.
Before you create any animation, the playhead is always on Frame 1.

You don’t use the Timeline until you’re ready to animate. While you work,
however, you should organize your objects on separate layers. Don’t worry —
you can always move an object from one layer to another.

Next to the Timeline tab is the Motion Editor tab. We discuss the Motion
Editor in Chapter 9. For now, it’s good to know that the Motion Editor gives
you detailed control over your animations.

Getting Help in a Flash

This book is all that you need to start creating great animations, but we
would be remiss if we didn’t tell you about the Flash Help system. To use
Flash Help, choose Helpr>Flash Help.

Help’s multiple manuals

Flash Help contains three sections:

1~ Using Flash CS5 Professional is the main Help manual.

1 ActionScript 3.0 Language and Components Reference is a manual on
the latest version of ActionScript, Flash’s programming language. (See
Chapter 10 to find out more.)
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You don’t need to program Flash to use it, if you are interested only in
graphics and animation.

1~ Additional Resources (adobe.com) brings you to the Adobe.com Search
Community Help page, where you can search through discussion groups
and other support resources.

To search for a term, click the Search button. Then type the term and click
Search. You can then choose from the list of topics.

Finding more help on the Web

Adobe offers support on its Web site. Choose Help=>Flash Support Center.
There, you can search the knowledge base and tutorials for answers to your
questions.

Try It — You'll Like [t

Perhaps by now you're getting impatient to try out Flash. Getting started is
easy. You collect a few ideas, put together some art, add animation, save
your movie, and publish it. Then you view it in a browser either online or
offline. That’s the gratifying part. In the following sections, you get to try out
Flash by working through a basic animation. The rest of the book explains
these concepts in more detail.

Conceiving your first animation

Suppose that you want to add an animated logo

to a home page that you already set up. You Rainbow
want the animation to run when the page loads sesources
and then stop. Figure 1-8 shows the Rainbow

Resources company logo — unanimated, of

course — that you can find on this book’s Web

site, at www.dummies.com/go/flashcs5£d.

Suppose that you want the word Rainbow to Figure 1-8: A company logo that
fly into your page from the right and the word could stand some animation.
Resources to fly in from the left. At the same time,

you want the graphic to rotate 180 degrees. The following section shows you
how to create this animation.

Creating flashy drawings

You can use Flash to create a company logo, but importing one from this
book’s Web site is simpler. Often, you import existing graphics (such as a
company logo) from a file rather than create them from scratch. (Chapter 3
explains how to import and manipulate graphics.)
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&“ If you're going through the steps and make a mistake, choose Edit=>Undo (or

press Ctrl+Z or 8+Z) and try again. You can use Undo repeatedly to undo
several steps, if necessary.

To import the Rainbow Resources logo into Flash, follow these steps. (The
steps might vary if you're importing some other graphic in a different format.)
1. Start Flash.

See the instructions in the section “Starting Flash on a PC” or “Starting
Flash on a Mac,” earlier in this chapter, if you need help.

2. In the Create New section of the Startup screen, choose ActionScript 3.0.
You see a spanking-new movie on your screen.

3. Go to www.dummies.com/go/flashcs5£d and download the Bonus
Content, which contains the rainbow.gif image file.

You'll need to unzip the file and extract the image file. Extract this image
file to the location where you plan to save your Flash movie.

4. Choose File>Import=>Import to Stage.
The Import dialog box opens.

5. Browse the dialog box until you find rainbow.gif in the location
where you saved it, and then double-click the file to open it.

You see the logo onscreen. You need to break the logo into pieces and
make it a vector graphic so that you can animate sections of it separately.

6. Choose Modify->Bitmapr>Trace Bitmap.
The Trace Bitmap dialog box appears.

7. In the Trace Bitmap dialog box, set the color threshold to 100, the
minimum area to 1, the corner threshold to Many Corners, and the
curve fit to Pixels. Click OK.

In our example, we chose to use settings that reproduce the bitmap
as faithfully as possible. Flash creates a vector graphic and breaks the
graphic into individual components. The entire graphic, however, is
selected.

8. Click anywhere outside the graphic to deselect it.

You have your logo! Now you need to set it up for animation.

Turning your objects into symbols

In the logo that you imported in the preceding section, each letter is a sepa-
rate object, which can get pretty confusing. Each line in the logo’s design

is also separate, but you want your words — and the little design — to stay
together. So, you must combine each word and the logo into a symbol. A
symbol helps keep objects together and is required for some kinds of anima-
tion. (See Chapter 7 for the scoop on symbols.)
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To turn the words and the logo into symbols, follow these steps:

1.

To get a better view of your image, click the Zoom Control drop-down
list (upper-right corner of the Stage area) and choose 200%.

If you don’t see the Zoom Control drop-down list, choose Window=>
Toolbars=>Edit Bar to display it.

Use the scroll bar to scroll the words of the logo into view, if necessary.

2. Click the Selection tool on the Tools panel if it’s not already selected.

3. Click the upper-right corner of

10.

the word Rainbow (just above
and to the right of the w) and R b
Ow
k,

drag to the lower-left corner of
the first letter, R.

Dragging from right to left makes
it easier to avoid selecting the
logo at the same time. The entire
word should be selected. If it
isn’t, click outside the word and
try again. Your screen should

look like Figure 1-9. . . )
Figure 1-9: Selecting text to prepare it for

. Choose Modify=>Convert to animation.

Symbol.

. In the Convert to Symbol dialog box, choose Graphic from the Type

drop-down list, enter Rainbow in the Name text box, and then click OK.

When you click OK, Flash places a box around the word so you can see
that it’s one object.

. Repeat the procedure outlined in Steps 3-5 with the word Resources.

In this case, you might want to start clicking and dragging from the
upper-left area of the word; then choose Modify=>Convert to Symbol
again, enter Resources in the Name text box, and click OK. Now all the
letters of the word Resources are a single object.

. Click above and to the left of the logo and drag to the lower right to

select the entire logo.

. Hold down the Shift key and click each word to remove both words

from the selection.

The design portion of the logo is selected.

. Choose Modify~>Convert to Symbol.

The Convert to Symbol dialog box opens.

Enter Lines in the Name text box, and then click OK in the Convert to
Symbol dialog box.

Flash creates a symbol from the lines of the logo’s design.
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See Chapter 7 to find out more about what symbols are and how to use them.
Symbols are important building blocks in Flash movies.

Putting your graphics on layers

You need to place different pieces on different layers when you’re animat-
ing. You use layers to organize your movie and keep shapes separate so that
they don’t interfere with each other. (See Chapter 6 for the complete story on

layers.)

To split your three symbols onto three separate layers, you can use a conve-
nient feature of Flash CS5: Distribute to Layers. Follow these steps:

1. Click the Selection tool on the Tools panel if it’s not already selected.

2. Drag diagonally across the entire logo, including the two words, to

select it.

You should see two rectangles inside one bigger rectangle. All three

objects in the logo are selected.

3. Choose Modify=>Timeline=>
Distribute to Layers.

You now have three new layers,
named Rainbow, Resources,
and Lines. The three objects of
the logo have been distributed
to the three new layers and
removed from Layer 1. Your
layer list should look like Figure
1-10.

4. Click the Zoom Control drop-
down list (at the upper-right
corner of the Stage area) and
choose 100%.

5. Click outside the Stage to dese-
lect any objects.

6. To save the file, choose

TIMEIIME

al Laver1

al >
2l Rainbow

al Resources

al o F ¢ T

Figure 1-10: In addition to the original Layer 1,
you now have three new layers.

Filez>Save and choose the same location you used for the rainbow.

gif image file.

We don’t recommend saving the file in the Flash CS5 program folder
because it might get lost among your Flash program files.

7. Give your movie a name, such as movie of the year, and click Save.

Flash creates a file named movie of the year.fla.Flashadds .fla
for you because that’s the filename extension for Flash movies.

You’re now ready for the animation process.
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Making graphics move

We explain earlier in this chapter that your goal is to have the word Rainbow
fly in from the right and the word Resources fly in from the left. You also want
the graphic to rotate 180 degrees at the same time. What you see now is how
the animation should end — the last frame of the movie.

Now go back and create the beginning of your movie. Flash can fill in all the
blanks in between. This type of animation is called a motion tween. Follow
these steps to create the animation:

1. Right-click (Windows) or Control-click (Mac) the word Rainbow and
choose Create Motion Tween.

Oops! The other two symbols disappear! That’s okay. Flash created
the motion tween and automatically set the length of the animation to
24 frames, or one second (using the default setting of 24 frames to a
second). The playhead is now on Frame 24, but the other two symbols
don’t exist at the 24th frame yet. Note that the Rainbow row in the
Timeline turns blue to indicate that it has a motion tween.

2. Click Frame 1 on the Timeline.

You can click Frame 1 on any layer. Whew! The other two symbols
reappear.

3. Repeat Steps 1 and 2 for the word Resources and for the lines.

Your Timeline should now look like Figure 1-11. Be sure to click Frame 1
to place the playhead on that frame.

e | momoNEsOR |
s@apQO!l s 1w 15 20 Dzs
ql Laver 1 + o+« O l:,|
s 7 N,
H Resources o o+ Wi
B Rainbow e o Wiy
al a3 t mH ]2 2400fps 10

Figure 1-11: The Timeline indicates three motion tweens, each
lasting 24 frames.

4. To move the Rainbow symbol to its proper location for Frame 1, click
the Rainbow symbol, then press and hold down the Shift key while
you drag the word Rainbow to the right, just off the Stage into the
gray area.
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10.

11.

12.
13.

14.

15.

You might need to use the horizontal scroll bar or choose a lower zoom
percentage in the Zoom Control drop-down list to see the gray area.
Pressing Shift keeps the object from moving up or down while you drag
to the right. By clicking the first frame and moving the word, you set its
position at the beginning of the animation.

. To move the Rainbow symbol to its proper location for Frame 24 (the

end of the motion tween animation), click Frame 24 in the Rainbow
layer. Then press the Shift key and drag the Rainbow symbol back to
its original position.

You now see a dot in Frame 24 on the Rainbow layer. On the Stage, you
see a magenta line indicating the movement of the Rainbow symbol. The
motion tween is now complete.

. Click Frame 1 on the Resources layer.

The playhead is now on Frame 1, and the Resources symbol has a blue
selection border.

. Press the Shift key and drag the Resources symbol to the left, just off

the Stage.

. Click in Frame 24 on the Resources layer, press Shift, and then drag

the Resources symbol back to its original location.

You now see a dot in Frame 24 on the Resources layer and a horizontal
line on the Stage showing the motion of the Resources symbol. The
motion tween is now complete.

. To return to Frame 1 and select the Lines symbol, click in Frame 1 of

the Lines layer.

Choose Modify~ Transform=>Rotate 90° CW to rotate the design 90
degrees clockwise.

Repeat the Modify~ Transform=>Rotate 90° CW command to rotate the
design a total of 180 degrees.

This sets up the desired position of the Lines symbol at Frame 1.
Click Frame 24 of the Lines layer.

Again, choose Modify~> Transformr>Rotate 90° CW twice to rotate the
Lines symbol a total of 180 degrees.

Because you only rotated the Lines symbol — you didn’t move it — you
don’t see a line on the Stage.

If necessary, drag the horizontal scroll box until the Stage is in the
center of your screen.

Otherwise, you won’t be able to see the entire animation — and you
don’t want to miss this one!

Click the first frame of any layer.

This takes you to the start of your movie. Your screen should look like
the one shown in Figure 1-12.
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Figure 1-12: Before you run the animation, Rainbow appears to the right
and Resources to the left, and the Lines symbol is rotated.

16. Press Enter (Return) and watch the animation. (Start writing your
Academy Award acceptance speech.)

17. Save your movie again by choosing Filer>Save.

Publishing your first animation for posterity

You can’t watch the animation in a Web browser until you publish your
movie and insert it into an HTML document. To do so, follow these steps:

1. Click an empty area of the Stage to change the display of the Property
inspector.

If the Property inspector isn’t open, choose Windowr>Properties. You
may need to click the Property inspector’s label to expand it or bring it
to the forefront. You should see the Edit button in the Publish section.
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2. In the Property inspector, click the Edit button next to the Profile:
Default label.

The Publish Settings dialog box opens. (We cover publish settings in
detail in Chapter 13.)

3. Click the HTML tab.
4. Deselect the Loop check box in the Playback section.
We want the animation to play only once.
5. Click the Publish button, and then click OK to close the dialog box.

With scarcely a blip, Flash publishes your movie and creates two files,
named Movie of the Year.swf (assuming you used that name) and
Movie of the Year.html. They're in the same folder as your . fla
movie file. Movie of the Year.swf is the file that your browser
reads to play the animation. Movie of the Year.html contains the
HTML code required to display your movie on a Web page.

6. Open your Web browser.

7. Choose Filem>Open (or Open File) and find Movie of the Year.
html (or whatever you named your movie file).

You might need to click Browse and navigate to the file.
8. Double-click the file.

Your browser opens the HTML document and reads its instructions to
play the Flash movie.

9. Sit back and watch it roll.

Don’t blink, or you’ll miss it. (If you do miss it, click the Refresh or
Reload Current Page button in your browser.) You can see the movie in
Figure 1-13.

10. When you finish watching the movie, close your browser.

You can find the Movie of the Year files (. £f1a, .html, and . swf) on this
book’s Web site, www . dummies.com/go/flashcs5£d.

Exiting Flash

When you finish creating something in Flash, choose File>Exit (Windows)
or Flashe>Quit (Mac). If you see a message asking whether you want to save
changes to the movie, click Yes if that’s what you want to do.
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Figure 1-13: The Movie of the Year animation in detail.
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