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Chapter1

Working in Autodesk Maya

Maya'’s working environment has evolved to accommodate both the individual artist as well as
a team of artists working in a production pipeline. The interface presents tools, controls, and
data in an organized fashion to easily allow you to bring your fantastic creations to life. Maya’s
interface is made up of four views: the perspective, front, side, and top. Each camera can be cus-
tomized. Additional cameras can also be created. In each camera view or viewport is a viewing
cube located in the upper right corner. The cube allows you to quickly set the current camera to
a specific view by clicking on a highlighted area of the cube.

Understanding the way Maya organizes data about the objects, animation, textures, lights,
dynamics, and all the other elements contained within the 3D environment of a scene is essential
to understanding how the interface is organized. Maya uses what’s known as the Dependency
Graph to keep track of the various packets of data, known as nodes, and how they affect each other.
Any single element of a Maya scene consists of multiple nodes connected in a web, and each one of
these nodes is dependent on another. Maya'’s interface consists of editing windows that allow you
to connect these nodes in an intuitive way and edit the information contained within each node.

There is usually more than one way to accomplish a task in Maya. As you grow comfortable
with the interface, you'll discover which editing windows best suit your working style.

This chapter is a brief overview of what professionals need to understand when working in
Maya. You'll learn what types of nodes you'll be working with and how they can be created and
edited in Maya. You'll also learn how to work with projects and scene data as well as the various
windows, panels, and controls that make up the interface. This will help you whether you are
working alone or as part of a team of artists.

If you've never used Maya before, we strongly encourage you to read the Maya documenta-
tion as well as Introducing Maya 2012 by Dariush Derakhshani (Sybex, 2011). This chapter is
about working with nodes, but it is not meant to be a comprehensive guide to each and every
control within Maya. That information is contained within the Maya documentation.

In this chapter, you will learn to:

¢ Understand transform and shape nodes
¢ Createa project
¢ Useassets
L 4

Create file references

Creating and Editing Maya Nodes

A Maya scene is a system of interconnected nodes that are packets of data. The data within a
node tells the software about what exists within the world of a Maya scene. The nodes are the
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building blocks you, as the artist, put together to create the 3D scene and animation that will
finally be rendered for the world to see. So if you can think of the objects in your scene, their
motion, and appearance as nodes, think of the Maya interface as the tools and controls you use
to connect those nodes. The relationship between these nodes is organized by the Dependency
Graph, which describes the hierarchical relationship between connected nodes. The interface
provides many ways to view the graph, and these methods are described in this chapter.

Any given workflow in Maya is much like a route on a city map. There are usually many
ways to get to your destination, and some of them make more sense than others depending on
where you're going. In Maya, the best workflow depends on what you're trying to achieve, and
there is typically more than one possible ideal workflow.

There are many types of nodes in Maya that serve any number of different functions. All the
nodes in Maya are considered Dependency Graph (DG) nodes. Let’s say you have a simple cube
and you subdivide it once, thus quadrupling the number of faces that make up the cube. The
information concerning how the cube has been subdivided is contained within a DG node that
is connected to the cube node.

A special type of DG node is the directed acyclic graph (DAG) node. These nodes are made
of two specific types of connected nodes: transform and shape. The arrangement of DAG nodes
consists of a hierarchy in which the shape node is a child of the transform node. Most of the
objects you work with in the Maya viewport, such as surface geometry (cubes, spheres, planes,
and so on), are DAG nodes.

To understand the difference between the transform and shape node types, think of a trans-
form node as describing where an object is located and a shape node as describing what an object
is. Transform nodes retain translation, rotation, and scale information. Often it is necessary to
freeze a node’s transforms. Freezing transformations sets the translation and rotation values to
zero and scale values to 1.0 without altering the position of the node. Doing this allows you to add
animation and mathematical expressions to zeroed values instead of complex numbers. In addi-
tion, freezing the transforms on a node that is a child of another node, forces the child to adopt the
transforms of the parent.

The simple polygon cube in Figure 1.1 consists of six flat squares attached at the edges to
form a box. Each side of the cube is subdivided twice, creating four polygons per side. That
basically describes what the object is, and the description of the object would be contained in
the shape node. This simple polygon cube may be 4.174018 centimeters above the grid, rotated
35 degrees on the x-axis, and scaled four times its original size based on the cube’s local x- and
y-axes and six times its original size in the cube’s local z-axis. That description would be in the
transform node (see Figure 1.1).

FIGURE 1.1

A shape node
describes the
shape of an object
and how it has
been constructed;
atransform node
describes where
the objectis
located in

the scene.
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Maya has a number of workspaces that enable you to visualize and work with the nodes and
their connections. The following sections describe how these workspaces work together when
building a node network in a Maya scene.

Using the Hypergraph

The Hypergraph is a picture of the nodes and their connections in Maya. A complex scene can
look like a very intricate web of these connections. When you need to know how a network of
nodes is connected, the Hypergraph gives you the most detailed view. There are two ways to
view the Hypergraph:

& The hierarchy view shows the relationships between nodes as a tree structure.
& The connections view shows how the nodes are connected as a web.

You can have more than one Hypergraph window open at the same time, but you are still
looking at the same scene with the same nodes and connections.
This short exercise gives you a sense of how you would typically use the Hypergraph:

1. Create a new Maya scene.
2. Create a polygon cube by choosing Create » Polygon Primitives > Cube.

3. You will be prompted to draw a polygon on the grid by dragging on the grid (see
Figure 1.2). Drag a square on the grid, release the cursor, and then drag upward on the
square to turn it into a three-dimensional cube. Release the mouse button to complete the
cube. At this point, feel free to make your own decisions about the size and position of
the cube on the grid.

FIGURE 1.2

Maya prompts you
to draw the base
of the cube on the
grid in the scene.

Orag the base on the grid, then pull up for height.

4. Select the cube in the viewport, and choose Window » Hypergraph: Hierarchy to open
the Hypergraph in hierarchy mode. You'll see a yellow rectangle on a black field labeled
pCubel. The rectangle turns gray when deselected.
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INTERACTIVE CREATION

By default Maya creates objects using the Interactive Creation method, which allows you to draw
on the canvas as you create your geometry. To turn this feature off, choose the Create > Polygon
Primitives menu, and deselect the Interactive Creation option at the bottom of the menu.

While the Interactive Creation mode is on, you can deselect the Exit On Completion method; this
means that each time you draw on the grid, you will continue to create cubes until you switch to
another tool.

5. Move the mouse over the rectangle labeled pCube and then right-click. Choose Rename
from the pop-up window. Rename the cube myCube.

6. Select myCube, and from the Hypergraph menu, choose Graph > Input And Output
Connections. This switches the view to the connections view just as if you had originally
opened the Hypergraph by choosing Window > Hypergraph: Connections. It’s the same
Hypergraph, but the view mode has changed, allowing you to see more of the scene.

NAVIGATING THE HYPERGRAPH

You can navigate the Hypergraph by using the same hot key combination you use in the viewport:
Alt+MMB-drag pans through the Hypergraph workspace, and Alt+RMB-drag zooms in and out.
Selecting a node and pressing the f hot key focuses the view on the currently selected node. (MMB
means clicking with the middle mouse button, and RMB means clicking with the right mouse but-
ton.) It is also possible to zoom in using the scroll wheel on your mouse.

When you graph the input and output connections, you see the connected nodes that make
up an object and how the object appears in the scene. In the current view, you should see the
myCube node next to a stack of connected nodes labeled polyCubel, myCubeShape, and ini-
tialShadingGroup, as shown in Figure 1.3. (The nodes may also be arranged in a line; the actual
position of the nodes in the Hypergraph does not affect the nodes themselves.)

FIGURE 1.3 A.0.0 Hypergraph InputQutputl
The node net- Edit WView Bookmarks Graph Rendering Options
work appears in
the Hypergraph.
This shape node
(myCubeShape)

is connected to
two other nodes,
whereas the
transform node
(myCube) appears
off to the side.

Traversal Depth: Unlimited
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The myCube node is the transform node. The myCubeShape node is the shape node. In the
Hypergraph, the shape and transform nodes are depicted as unconnected; however, there is
an implied connection, as you'll see later. This is demonstrated when you rename the myCube
node; the shape node is renamed as well.

In Maya, the construction history feature stores a record of the changes used to create a par-
ticular node. The polyCubel node is the construction history node for the myCubeShape node.
When you first create a piece of geometry, you can set options to the number of subdivisions,
spans, width, height, depth, and many other features that are stored as a record in this history
node. Additional history nodes are added as you make changes to the node. You can go back
and change these settings as long as the history node still exists. Deleting a history node makes
all the previous changes to the node permanent (however, deleting history is undoable).

1. Keep the Hypergraph open, but select the cube in the viewport.
2. Change the menu set in the upper left of the main interface to Polygons.

3. Press the 5 key on the keyboard to switch to shaded mode. Choose Mesh » Smooth. The
cube will be subdivided and smoothed in the viewport.

In the Hypergraph you'll see a new polySmoothFacel node between the polyCubel node
and the myCubeShape node (see Figure 1.4). This new node is part of the history of the cube.

FIGURE 1.4
Performing a
smooth operation
on the cube when
construction his-
tory is activated
causes a new
polySmoothFace1
node to be inserted
into the node
network.

Traversal Depth: Uinlimited

4. Select the polySmoothFacel node, and delete it by pressing the Backspace key on the key-
board. The cube will return to its unsmoothed state.

5. Select the transform node (myCube), and press the s hot key. This creates a keyframe on
all the channels of the transform node. A keyframe stores the current attribute values at
a particular time on the timeline. Animation is created by interpolating between key-
framed values.

You'll see a new node icon appear for each keyframed channel with a connection to the
transform node (see Figure 1.5).
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WORKING WITH HISTORY

Over the course of a modeling session, the history for any given object can become quite long and
complex. This can slow down performance. It’s a good idea to periodically delete history on an object
by selecting the object and choosing Edit > Delete By Type > History. You can also choose to delete
the history of all the objects in the scene at once by choosing Edit » Delete All By Type > History.
Once you start animating a scene using deformers and joints, you can use the Delete By Type >
Non-Deformer History option, which will remove the construction history nodes while preserving
connections to animation nodes such as deformers.

You can turn off the history globally by clicking the Construction History toggle switch on the
status line, as shown here.

Help

E “é L_i i

FIGURE 1.5
The attributes of
myCube’s trans-
form node have ]
been keyframed. | %
The keyframe I .
nodes appear in the
Hypergraph.

Traversal Depth: Unlimited

6. Hold the cursor over any line that connects one node to another. A label appears describ-
ing the output and input attributes indicated by the connection line.
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Connecting Nodes with the Connection Editor

Connections between nodes can be added, deleted, or changed using the Hypergraph and
the Connection Editor.

1.
2.

Start a new Maya scene.

Create a locator in the scene by choosing Create > Locator. A simple cross appears at

the center of the grid in the viewport. This locator is a simple nonrendering null that
indicates a point in space. Locators are handy tools that can be used for a wide variety of
things in Maya.

Press the w hot key to switch to the Move tool; select the locator at the center of the grid,
and move it out of the way.

Press the g hot key to create another locator. The g hot key repeats the last action you per-
formed, in this case the creation of the locator.

Create a NURBS sphere in the viewport by choosing Create » NURBS Primitives »
Sphere. If you have Interactive Creation selected, you'll be prompted to drag on the grid
in the viewport to create the sphere; otherwise, the sphere will be created at the center of
the grid based on its default settings.

NURBS

A Non-Uniform Rational B-Spline (NURBS) object is a type of surface that is defined by a network of
editable curves. Chapter 3, “Modeling 1,” introduces how to create and model NURBS surfaces.

6.

9.

Move the sphere away from the center of the grid so you can clearly see both locators and
the sphere.

Use the Select tool (hot key = q) to drag a selection marquee around all three objects.

Open the Hypergraph in connections mode by choosing Window » Hypergraph:
Connections. You should see eight nodes in the Hypergraph (see Figure 1.6).

locatorl and locator2 are the two transform nodes for the locators. locatorShapel and
locatorShape?2 are the two shape nodes for the locators. nurbsSpherel is the transform
node for the NURBS sphere. And nurbsSphereShapel is the shape node for the sphere; it’s
connected to MakeNurbSpherel, which is the history node, and to initialShadingGroup.
The initialShadingGroup node is the default shading group that is applied to all geom-
etry; without this node, the geometry can’t be shaded or rendered. When you apply a new
shader to an object, the connection to initialShadingGroup is replaced with a connection
to the new shader. A shader is a node that determines how a surface appears in Maya as
well as how it reacts to virtual lights.

In the Hypergraph window, use Alt+RMB to zoom out a little.

7
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FIGURE 1.6 fANO Hypergraph InputQOutputl
The input and out- < sl e

put connections
of the two locators
and the sphere

are graphed in the
Hypergraph.

—
o

ﬂ nurbespherel

Traversal Depth: Unlimited

10. Select the locatorl, locator2, and nurbsSpherel nodes, and drag them away from the other
nodes so you can work on them in their own space.

11. In the Hypergraph, MMB-drag the locatorl node over the nurbsSpherel node.

12. From the pop-up menu, choose Other at the bottom (Figure 1.7). A new dialog box will
open; this is the Connection Editor.

FIGURE 1.7
You can connect VoW BookTmarys
two nodes in the
Hypergraph by
MMB-dragging one
on top of the other
and choosing from
the options in the

Graph

Traversal Depth: Unlimized
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The Connection Editor is where you create and edit connections between nodes. The left
side of the panel represents the output of a selected node, in this case the locatorl node. The
output is the controlling node; the right side is the input, and in this case is nurbsSpherel,
which will be controlled based on whatever connections you make in the list.

The list represents the attributes of each node. Any of the attributes that have a plus sign
next to them can be expanded to reveal nested attributes. For instance, find the Translate
attribute in the left side of the column, and expand it by clicking the plus sign (The term
translate in Maya refers to an object’s position; when you use the Move tool to change the
position of an object in 3D space you are “translating” the object) You'll see that Translate
has TranslateX, TranslateY, and TranslateZ. This means you can choose either to select the
Translate attribute, which will automatically use all three nested attributes as the output
connection, or to expand Translate and choose one or more of the nested TranslateX, Y, or
Z attributes as the output connection. In some situations, a connection becomes unavail-
able (grayed out), indicating that the connection between the two attributes cannot be
made, usually because the connection is not appropriate for the selected attributes (see
Figure 1.8).

FIGURE 1.8 Hypergraph
The Connection E |
Editor specifies
which attributes
are connected
between nodes.

ghostCustomSteps

ghostDriver
transiate

rotate

Translate

selectHandle

locatorl nurbsSpherel

Clear All

13. Select the Translate attribute on the left. You'll notice that many of the selections on the
right side become grayed out, meaning that they cannot be connected to Translate. This is
because Translate is a vector—it is an output consisting of three connections (TranslateX,
TranslateY, and TranslateZ). The vector can be connected only to other vectors on the
right side of the list.
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14. On the right side, scroll down and select Translate. Both connections in the list are now
italicized, indicating that there is a connection to this attribute. If one of the other attri-
butes on the right were italicized, it would indicate that another node is already con-
nected to that attribute (see Figure 1.8). Once the connection is created, you can close the
Connection Editor.

15. In the viewport, switch to wireframe mode if you are not already in wireframe mode. You
can do this by pressing 4 on the keyboard or clicking the wireframe icon on the icon bar
at the top of the viewport window; the wireframe icon is the wireframe cube.

16. In the viewport, you'll notice that the sphere has snapped to the same position as the
locator. Select the sphere, and try to move it using the Move tool (hot key = w). The sphere
is locked to the locator, so it cannot be moved. Select the locator, and try to move it; the
sphere moves with the locator. The output of the locator’s Translate attributes are the
input for the sphere’s Translate.

INCOMING CONNECTIONS

In wireframe view, an object will be highlighted in purple if it has an incoming connection from
the selected object.

17. Select the nurbsSpherel node in the Hypergraph, and MMB-drag it on top of locator2.

18. From the pop-up list, choose Rotate (see Figure 1.9). The Connection Editor opens again.

FIGURE 1.9 feNnn Hypergraph InputQutput2

The nurbSSpherel Edit View Bookmarks Graph Rendering Opt Show Help

node is MMB- 2z o T R = R )
dragged on top of

the locator2 node.

You can use the

pop-up menu to
specify the con-
nection or open the
Connection Editor.

T
§ J nurbsspherel

rotate

selectHandle

transMinusRotatePivot
translate
Other... Shift+Drop

Moare...

Traversal Depth: Unlimited
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SPECIFYING CONNECTIONS

In some cases when you choose to make a connection from the pop-up window, Maya will automati-
cally make it for you without opening the Connection Editor; however, in other cases, even when
you choose what seems like an obvious connection from the list, Maya will still open the Connection
Editor so you can make exactly the connection you want.

19. Now the nurbsSpherel node is listed on the left, and locator2 is on the right. Find the
Rotate attributes, expand the list, and choose RotateX from the list.

20. On the right side, find the Rotate attribute, expand it, and choose RotateY. This causes the
RotateX of the nurbsSpherel node to control the RotateY of the locator.

21. In the viewport, select the sphere, and switch to the Rotate tool (hot key = e).

22. Drag up and down on the red circle of the tool to rotate the sphere around its x-axis. The
locator rotates around its y-axis.

USE THE CONNECTION EDITOR TO MAKE SIMPLE CONNECTIONS

The Connection Editor is best used when you want to make a one-to-one relationship between attri-
butes on two nodes. In other words, the value of the output connection needs to equal exactly the
value of the input connection. More complex connections can be made using expressions, special
nodes, or Set Driven Key. All of these options will be discussed throughout the book.

You can break a connection by selecting a highlighted node on either side of the Connection
Editor again. The node listed in the Connection Editor will no longer be highlighted, indicating
that the connection is broken. You can also select the connecting line in the Hypergraph and
press the Delete key to break the connection.

Creating Node Hierarchies in the Outliner

The Outliner shows a hierarchical list of the nodes in the scene in a form similar to the outline of
a book. It is another way to view the transform and shape nodes in a scene and a way to create
hierarchical relationships between nodes through parenting. The Outliner does not show the
connections between nodes like the Hypergraph; rather, it shows the hierarchy of the nodes in
the scene. To see how this works, try the following exercise:

1. Open the miniGun_v01.ma file from the Chapterl/scenes directory on the DVD. The
scene consists of a minigun model in three parts.

2. Open the Outliner by choosing Window » Outliner.
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OUTLINER LAYOUT PRESETS

The Outliner can be opened as a separate panel or, like many of the panels in Maya, can be opened
inaviewport. A popular window arrangement is to split the viewports into two views, with the left
view set to the Outliner and the right view set to the perspective view. You can open this arrange-
ment by going to the menu bar in a viewport window and choosing Panels > Saved Layouts > Persp/
Outliner. You can also click the third layout button on the left side of the interface just below the
toolbox (as shown here).

3. At the top of the Outliner is a menu bar. In the Display menu, make sure DAG Objects
Only is selected and Shapes is deselected (see Figure 1.10).

FIGURE 1.10
The Display menu
at the top of the
Outliner

In the Outliner, you'll see three nodes listed: gunBarrels, housing, and mount, in addition
to the four default cameras and several set nodes (don’t worry about the set nodes). These
are the three transform nodes for the pieces of the minigun. Select each node, and you’ll
see the corresponding part highlighted in the perspective view. At the moment, each
piece is completely separate and unconnected.

4. Select the housing node, and switch to the Rotate tool (hot key = e).

5. Rotate the objects; nothing else is affected. Try translating housing using the Move tool
(hot key = w); again, nothing else is affected. In Maya, “translating” means moving an
object in 3D space.

6. Use Undo (hot key = Ctrl+z) a few times until the housing node returns to its original
location and orientation.
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FIGURE 1.11
When the
gunBarrels node is
made a child of the
housing object, it
inherits changes
made to the hous-
ing object’s trans-
form node.

10.

11.

12.

13.

CREATING AND EDITING MAYANODES

In the Outliner, select the gunBarrels object. Then Ctrl+click the housing object
(Cmd+click on the Mac), and choose Edit » Parent from the main Maya menu at the top.

Parenting one object to another means you have made one transform node the child of
the second. When an object is a child node, it inherits its position, rotation, scale, and
visibility from the parent node. In the Outliner, you'll notice that the housing node has a
plus sign beside it and the gunBarrels node is not visible. The plus sign indicates that the
node has a child node.

Click the plus sign next to the housing node to expand this two-node hierarchy. The gun-
Barrels node is now visible as the child of the housing node.

Select the housing node, and try rotating and translating it. The gunBarrels node follows
the rotation and translation of the housing node (see Figure 1.11).

Unlike the situation presented in the “Connecting Nodes with the Connection Editor”
section earlier in this chapter, the rotation and translation of the gunBarrels object are not
locked to the rotation and translation of the housing node; rather, as a child, its rotation,
translation, scale, and visibility are all relative to that of its parent.

Select the gunBarrels node, and try rotating and translating the object; then rotate and
translate the housing node. You'll see the gun barrels maintain their position relative to
the housing node. You could create an animation in which the gun barrels rotate on their
own z-axis to spin around while firing, while the housing node is animated, rotating on
all three axes in order to aim.

Hit Undo a few times (hot key = Ctrl+z) until both the housing and gunBarrel objects are
back to their original positions.

In the Outliner, select the housing node, and MMB-drag it on top of the mount node. This
is a way to quickly parent objects in the Outliner.

Click the plus signs next to the mount and housing nodes in the Outliner to expand the
hierarchy. The lines indicate the organization of the hierarchy; the gunBarrels node is
parented to the housing node, which is parented to the mount node.

13
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SHIFT+CLICK TO EXPAND THE HIERARCHY

You can expand an entire hierarchy with one click in the Outliner. Just Shift+click the plus sign for
the hierarchy you want to expand.

14.

15.

16.

17.

18.

19.

Select the mount node, and choose Edit » Duplicate (hot key = Ctrl+d). This makes a
copy of the entire hierarchy. The duplicated mount node is named mountl.

Select the mountl node, and switch to the Move tool (hot key = w). Pull on the red arrow
of the tool to move the duplicate along the x-axis about two units.

Select the mount node, and then Ctrl+click the mountl node in the Outliner (Cmd+click
on the Mac).

Choose Edit » Group (hot key = Ctrl+g) to group these two nodes under a single
parent node.

A group node is a transform node that has no shape node. It’s just a location in space used
to organize a hierarchy. Like a parent node, its children inherit its rotation, translation,
scale, and visibility.

Select the groupl node, and Shift+click the plus sign next to it in the Outliner to expand
the group and all its children.

Double-click the label for the groupl node in the Outliner to rename it; rename the
group guns.

RENAMING NODES

You’ll notice that the duplicate mount node has been renamed mount1 automatically. Nodes on the
same level of the hierarchy can’t have the same name. The child nodes do have the same name, and
this is usually a bad idea. It can confuse Maya when more complex connections are made between
nodes. Whenever you encounter this situation, you should take the time to rename the child nodes

so that everything in the scene has a unique name.

20.

CERT 21.
OBJECTIVE

22.

Select the mountl node in the guns hierarchy, and choose Modify » Prefix Hierarchy
Names.

In the pop-up window, type right_. This renames the top node and all its children so that
“right_" precedes the name. Do the same with the other mount node, but change the pre-
fix to left_.

Select the guns group, and choose Modify » Center Pivot. This places the pivot at the
center of the group. Try rotating the guns group, and you'll see both guns rotate together
(see Figure 1.12).
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FIGURE 1.12
The guns group
isrotated as a
single unit.

Each member of the hierarchy can have its own animation, so both gun barrels can rotate
around their z-axes as they fire, the two housing nodes could be animated to aim in different
directions, and the two guns could rotate as one unit, all at the same time. The entire group can
be parented to another node that is part of a vehicle.

Displaying Options in the Outliner

There are several options in the Outliner for displaying nodes and their hierarchical arrange-
ments. You can see that the default perspective, top, side, and front cameras are visible as nodes
at the top of the Outliner. Also, there are a number of sets such as the defaultLightSet that
appear at the bottom of the Outliner. These sets are mainly used for organization of data by
Maya and are usually not directly edited or altered.

1. In the Display menu of the Outliner, select the Shapes option to display the shape nodes
of the objects. The shape nodes appear parented to their respective transform node. You
can select either the transform node or the shape node in the Outliner to select the object.

ACCESSING OUTLINER OPTIONS

You can right-click in the Outliner to quickly access the Outliner’s display options rather than use
the menu at the top of the Outliner.

2. In the Display menu, activate the visibility of attributes by selecting the Attributes
(Channels) option.

Each node now has an expandable list of attributes. Most of the time you may want this
option off, because it clutters the Outliner and there are other ways to get to these attri-
butes. Ultimately, how you use these options is up to you.
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FIGURE 1.13

The Outliner can
display shape
nodes as well as
other types of
nodes in the scene.
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3. Turn off the Attributes display, and turn off the DAG Objects Only option. This allows

you to see all the nodes in the scene in the Outliner list as opposed to just the DAG nodes.

DAG stands for “directed acyclic graph,” and DAG objects are those objects that have
both a shape and a transform node. It’s not crucial to understand exactly what directed
acyclic graph means as long as you understand that it is an arrangement in which a
shape node is parented to a transform node. When you turn off DAG Objects Only in

the Outliner, you'll see all the nodes in the Maya scene appear. Many of these are default
utility nodes required to make Maya function, such as the layerManager node or the dyn-
Controllerl node. Many other nodes appear when you create a new node or connection.
An example of this is a keyframe or an expression node.

When you turn off DAG Objects Only, the list can get quite long. To find a node quickly,
type the node’s name in the field at the very top of the Outliner. This hides all nodes
except the named node. Clearing the field restores the visibility of all nodes in the
Outliner (see Figure 1.13).

renderPartition
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Additional viewing options are available in the Show menu, which contains options for
displaying only nodes of a certain type. Throughout this book the Outliner will be used
extensively, so you'll have lots of practice working with this panel.

4. In the Display menu of the Outliner, turn the DAG Objects Only option back on. Save the
scene as minGun_v02.ma.

To see a finished version of the scene, open miniGun_v02.ma from the chapterl\scenes
directory on the DVD.

SEARCHING FEATURES IN THE OUTLINER

CERT A complex scene in Maya can easily have hundreds of nodes. Just one character often has associated
OBJECTIVE geometry, dozens of animation controls, joints, textures, and so on. Add another character to the
scene with their own set of node networks, and the Outliner can become very cluttered very quickly.
Establishing an organized naming system for the nodes in your scenes has many benefits, one of
which is that you can use the search feature in the Outliner to filter what is displayed, thus making
it easy to access the nodes you need. Take the time to name your nodes in such a way as to make

searching easy. The following illustrates how the search feature can be used in a complex scene.

Let’s say you have a scene with two complex characters, one named Larry and the other named Cecil.
Both characters have similar rigs that use NURBS curves to control their animation rigs, and both
have geometry, joints, shaders, and so on. When naming the nodes associated with each character,
you make sure that all larry nodes start with the name “larry.” So, Larry’s skin geometry might
be named “larry_SKIN_GEO,” while his clothes would use names like “larry_ PANTS_GEO.” Using
capital letters in this case is purely personal preference; the important thing is that the name of
each node starts with “larry.” Cecil would use the same convention; his skin geometry would be
“cecil_SKIN_GEO,” and his pants would be “cecil PANTS_GEO.” You end the names using GEO, so
you know that this is a geometry node.

The controls for the animation rig use names like “larry_ LEFT _HAND_wrist_CTRL1,” “larry_
SPINE_CTRI1,” and “larry_ NECK_CTRL1.” You get the idea. You can see that each of these nodes
belongs to Larry, nodes for the left side of the body are clearly identified, the associated body part
isidentified, and they end with the letters CTRL. The same goes for Cecil.

Now here’s where this type of organization, or something similar, is helpful in the Outliner. At the top
of the Outliner is a blank field. To filter the nodes listed in the Outliner, you need to type some text
and either precede or follow the text with an asterisk (*). The asterisk tells Maya to show all nodes
that use the text before or after the asterisk in the name. So if you want to see all nodes associated
with larry, type larry*. If you want to see all the control nodes for both Cecil and Larry, type *CTRL*.
In this case, there may be text before and after the CTRL letters, so use an asterisk before and after
CTRL. If you want to see the controls associated with Cecil’s hands, type cecil*HAND?*, and so on.

The following images show variations on how to search through the Outliner with this method. If
nothing appears in the Outliner when you type some text, check to see whether the asterisk is in
the right place. To find one specific node, type its full name without the asterisk.
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The Channel Box

The term channel is, for the most part, interchangeable with attribute. You can think of a channel
as a container that holds the attribute’s value. The Channel Box is an editor that lists a node’s
attributes for quick access. The Channel Box displays the node’s attributes, which are most fre-
quently keyframed for animation.

The Channel Box is located on the right side of the screen when the view mode at the end of
the status bar is set to Show The Channel Box/Layer Editor (see Figure 1.14).

FIGURE 1.14
The icon in the

upper right of the IS e Crne 0 Laver o
interface toggles

the visibility of the

Channel Box/Layer

Editor.

There are two tabs on the very right side of the screen that allow you to quickly switch
between the Channel Box and the Attribute Editor, as shown in Figure 1.15. (The Attribute
Editor is discussed in detail later in this chapter.) These tabs are visible when both the Attribute
Editor icon and the Channel Box icon are activated on the status bar in the upper-right corner of
the interface.



CREATING AND EDITING MAYANODES | 19

FIGURE 1.15

The two tabs on
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This exercise gives a quick tour of how to work in the Channel Box:

1. Create a new scene in Maya, and create a NURBS Sphere on the grid (Create » NURBS
Primitives > Sphere). You'll be prompted to draw the sphere on the grid if Interactive
Creation mode is on; if not, the sphere will appear at the center of the grid. Either option
is fine.

2. Make sure the Channel Box is visible on the right side of the screen. To do this, click the
icon at the farthest right of the status bar (shown in Figure 1.14). This is a toggle to display
the Channel Box. Click it until the Channel Box appears, as in Figure 1.16.

FIGURE 1.16
The Channel

Box displays the
channels for the
currently selected
object.
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3. The Channel Box will list the currently selected object. Select the sphere, and you'll see
nurbsSpherel appear. The list below it shows the attributes for the nurbsSpherel’s trans-
form node.

The lower half of the Channel Box lists the connections to this node. You'll see the name
of the associated shape node under SHAPES, and below this a section for the inputs. In
this case, the input is the history node, named makeNurbSpherel, which contains the
original settings used to create the sphere. If you delete history on the sphere, these attri-
butes will no longer be accessible.

4. In the upper section of the Channel Box, under nurbsSpherel, try selecting the fields and
inputting different values for Translate, Scale, and Rotate. The sphere updates its position,
size, and orientation.

5. In the Visibility channel, select the word On in the field, and type 0. The sphere disap-
pears. Input the value 1, and it reappears. Visibility is a Boolean, meaning it is either on or
off, 1 or 0.

6. Select the Translate X field so it is highlighted. Shift+click the Rotate Z value, and all the
values in between are also selected.

7. Type 0in the Translate X field while they are selected and press the Enter key. Doing so
sets all the Translate and Rotate values to the same value, places the sphere at the center
of the grid, and returns it to its original orientation (see Figure 1.17).

FIGURE 1.17 nurbsSpherel
You can quickly I
“zero out” the
Translate and
Rotate channels
by Shift+clicking
their fields and
entering 0. SHAPES

apheresShapel

makeNurbSpherel

8. In the makeNurbSphere section under INPUTS, highlight the Start Sweep channel. Enter
a value of 90, and the sphere opens up. If this is hard to see, switch to shaded mode by
pressing 5 on the keyboard. You're altering the construction history of the sphere so it is
no longer a closed surface.

9. Select the word Sections so it is highlighted in blue. MMB-drag in the viewport view back
and forth. Doing so creates a virtual slider so you can change the value of the field inter-
actively instead of numerically. This should work for all the channels (most of the time).

10. Set the timeline to frame 1 by clicking on the far left of the time slider where it is labeled
1, and press the s hot key. You'll see all the channels turn orange, indicating that they
have been keyframed. The s hot key keyframes all the available channels.
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11. Move the timeline to frame 24, and change some settings on both the transform node (the
upper half of the Channel Box) and under makeNurbSpherel in the INPUTS section.

12. Press the s hot key again to set another key. Play the animation, and you’ll see the sphere
update based on the keyframed changes.

If the animation seems to play too quickly, you need to change the preferences so that
playback matches the frame speed of the animation. To do so, choose Windows >
Settings/Preferences > Preferences. In the Preferences window, choose Time Slider on
the left column and set PlayBack Speed to Real-Time [24 FPS].

The s hot key keyframes everything, even those channels you may not need to keyframe.
You can use the Channel Box to keyframe specific channels.

13. Rewind the timeline, and choose Edit > Keys > Delete Keys to remove all the keyframes
on the sphere.

14. Highlight Translate X and Shift+click Translate Z so that the translation channels are all
selected.

15. Right-click these values, and choose Key Selected (see Figure 1.18).

FIGURE 1.18 Channel Box [ Layer Editor :
Right-click the !
selected channels,
and choose Key
Selected to key-
frame just those
specific channels.

nels  Edit

nurbsSpherel

16. Move to frame 24, and enter different values in the Translate fields.

17. Shift-select the Translate fields in the Channel Box, right-click, and choose Key Selected.
This places a keyframe on just the selected channels, which is often a cleaner and more
efficient way to work because you're placing keyframes only on the channels you need
to animate and not on every keyable channel, which is what happens when you use the s
hot key. Now try playing the animation.

BE THRIFTY WITH KEYFRAMES

Creating extra, unnecessary keys leads to a lot of problems, especially when you start to refine the
animation on the Graph Editor (discussed in Chapter 5, “Animation Techniques”). Keyframes also
canincrease the scene size (the amount of storage space the scene uses on disk). Be cheap with your
keyframes, and use the Key Selected feature to keyframe only the channels you need. Avoid using
the s hot key to create keys on everything.
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18. To remove keys, you can highlight the channels, right-click, and choose Break
Connections. This removes any inputs to those channels. The values for the current
keyframe will remain in the channels.

The channels are color coded to show what kind of input drives the channel:
¢ Pinkindicates a keyframe.
¢ Purpleindicates an expression.

& Yellow indicates a connection (as in a connection from another node or channel made in
the Connection Editor).

Brown indicates a muted channel.

Gray means the channel is locked.

LOCKING AND MUTING CHANNELS

You can mute a channel by right-clicking it and choosing Mute Selected from the pop-up menu.
When you mute a channel, the keyframes on that channel are temporarily disabled; as long as the
channel is muted, the animation will not update. This is useful when you want to disable the key-
frames in a channel so that you can focus on other aspects of the animation. Locking a channel is
another option available when you right-click selected channels in the Channel Box. A locked chan-
nel prevents you from adding keyframes to a channel regardless of whether it has been animated.
Animation techniques are explored further in Chapter 5.

The Channel Box will be explored throughout the book and used frequently, particularly in
the chapters concerning animation.

The Attribute Editor

The Attribute Editor is a tabbed panel that gives detailed information and access to a node’s
attributes. The tabs at the top of the editor allow you to move between the attributes of all the
upstream (input) and downstream (output) connected nodes. This exercise gives a brief tour on
how to use the Attribute Editor:

1. Create a new scene in Maya. Create a polygon cube on the grid (Create > Polygon
Primitives » Cube).

2. Select the cube, and open its Attribute Editor. There are several ways to do this:

¢ Right-click and hold the right mouse button over the cube, and choose pCubel from
the context menu.

Select the cube, and choose Window » Attribute Editor.

Click the Show Or Hide The Attribute Editor icon in the upper right of the Maya
interface (Figure 1.19).
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FIGURE 1.19
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3. With the Attribute Editor open, choose the pCubel tab at the top (Figure 1.20). The panel
that opens contains the attributes for the cube’s transform node, much like the upper sec-
tion of the Channel Box described in the previous section. It also contains options for set-
ting limits on the transform attributes.

FIGURE 1.20 Attribute Editor
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Many of the settings can be accessed through the Attribute Editor’s rollout panels. These
are collapsible sections of grouped settings.

4. In the Attribute Editor, on the pCubel tab, click the triangle next to mental ray. This
reveals mental ray—specific settings related to the cube. Note that there are subsections
under mental ray that are also collapsible.

5. Choose the pCubeShapel tab at the top of the Attribute Editor. This tab contains settings
related to the shape node. For example, expand the Render Stats section, and you'll see a
list of settings that control how the shape will appear in a render.

6. Choose the polyCubel tab, and you'll see the construction history settings. If you delete
history on the cube, this tab will no longer appear.

7. Expand the Poly Cube History rollout. If you right-click any of the fields, you get a con-
text menu that offers options, such as expressions, key setting, or locking, much like the
fields in the Channel Box (Figure 1.21).

8. In the Subdivisions Width field, highlight the text and type =. Doing so lets Maya know
that you want to add an expression to the field.

9. Complete the expression by typing 9*2 after the equals sign (see Figure 1.22); then press
the Enter key on your keyboard’s numeric keypad. Doing so adds an expression to this
attribute that makes the Subdivisions Width value equal to 18. Note that the field turns
purple and the slider can no longer be moved.

23



24 |CHAPTER1 WORKINGINAUTODESKMAYA

FIGURE 1.21
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FIGURE 1.22
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Note that a new tab called expressionl is added to the top of the Attribute Editor; this is a
new expression node that is now part of the cube’s node network.

If the number of connected nodes is too large to fit within the tab listing at the top, you can
use the two arrow buttons to the right of the tabs to move back and forth between the tab list-
ings. Likewise, if not all connections are visible, you can use the Go To Input and Go To Output
Connection buttons to the right of the field indicating the node name.

The Notes field at the bottom is useful for typing your own notes if you need to keep track of
particular settings or leave a message for yourself or other users (see Figure 1.23). You can col-
lapse this section by dragging the bar above it downward, thus making more room for the other
settings in the Attribute Editor.

FIGURE 1.23
Messages can be
entered in the
Notes section at
the bottom of the
Attribute Editor.
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LOAD ATTRIBUTES

You can use the Load Attributes button at the bottom of the Attribute Editor if the attribute display
needs to be refreshed. Maya automatically updates the editor when new attributes are added, but
occasionally it misses an update and needs to be refreshed.

The Attribute Editor is the workhorse panel of Maya. Throughout this book we will use it
constantly. Make sure you are comfortable with the core concepts of how to switch between
node settings using the tabs as well as how to change the available values.

Working with Shader Nodes in the Hypershade

The Hypershade, as the name suggests, is similar in function to the Hypergraph. It gives a
visual display of how nodes in a Maya scene are connected. The Hypershade is mostly con-
cerned with shaders—nodes used to define the color and material properties of renderable
objects in a scene. These include materials (also known as shaders), textures, lights, cameras, and
shading utilities. However, it is not unusual to use the Hypershade Work Area to make connec-
tions between other types of nodes as well. In this exercise, you'll use the Hypershade to con-
nect several types of nodes.

1. Create a new scene in Maya. Create a NURBS cone on the grid. You'll be prompted to
draw the cone on the grid if Interactive Creation mode is on; if it is not, the cone will
appear at the center of the grid. Either option is fine.

2. Switch to smooth shaded mode by pressing 6 on the keyboard, or click the Smooth Shade
All and Textured icons on the viewport’s menu bar (Figure 1.24).

FIGURE 1.24
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3. Open Hypershade by choosing Window » Rendering Editors > Hypershade.

The Hypershade Editor is made up of several frames. On the left side is a list and a visual
menu of the nodes you can create in Hypershade. The list is divided into sections for the
Maya nodes, mental ray nodes, and a customizable list for your own favorites at the very
top. Clicking a category in the list filters the node creation buttons to the right of the list,
which helps to cut down on the amount of time you need to hunt for specific nodes. To
add a node to the Favorites list, MMB-drag the node button from the right on top of the
Favorites menu. You can also search through the nodes by typing in the field at the very
top of the list. For example, typing mia in this field filters the node creation buttons so
that all the mia (mental images architectural) nodes are displayed (see Figure 1.25).
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FIGURE 1.25
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Materi...

The right side of the Hypershade contains a visual display of the nodes in the scene at
the top and the Work Area at the bottom (Figure 1.26). The upper section is organized by
tabs named Materials, Textures, Utilities, Rendering, Lights, Cameras, Shading Groups,
Bake Sets, Projects, and Asset Nodes. If you want to access all the file textures used in the
scene, you can choose the Textures tab to see them listed with preview icons.

FIGURE 1.26
The Hypershade
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workspace for con-
structing render
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This image shows
an example of a
shader network
graphed in the
Work Area.
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4. On the left side of the Hypershade, click Surface in the list of Maya nodes. Click the Blinn
button to create a new Blinn material.

You can see the new blinn1 material listed on the Materials tab; it also appears in the
Work Area.

HYPERSHADE TABS

If tabs appear to be missing, you can revert to the default tab layout by choosing Tabs > Revert To
Default Tabs, as shown here. This clears the current tabs and replaces them with the default Materials,
Textures, Utilities, Rendering, Lights, Cameras, and other default tabs. You can use the Tabs menu
to create your own custom tabs and determine which tabs you want visible and in what order.

DEFAULT SCENE MATERIALS

All Maya scenes start with three materials already created: lambert1, particleCloud1, and shad-
erGlow1. The lambert1 material is the default material applied to all newly created geometry, the
particleCloud1 materialis a special material reserved for particle cloud objects, and the shaderGlow1
node sets the glow options for all shaders in the scene.

5. Select the blinnl material in the Work Area, and from the menu at the top of the Hypershade
choose Graph » Input And Output Connections. This displays all the upstream and down-
stream nodes connected to blinnl. Upstream nodes are nodes that plug into a node and
affect its attributes; downstream nodes are ones that are affected by the node.

The blinn1SG node is a downstream node known as a shader group, connected to blinn1.
All materials have a shader group node connected to them. This node is a required part
of the network that defines how the shader is applied to a surface and is often used when
creating complex mental ray shader networks and overrides (see Figure 1.27).
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FIGURE 1.27
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6. In the viewport, select the cone. You can apply the blinnl material in several ways to
the cone:

¢ MMB-drag the material icon from the Hypershade on top of the cone in the viewport
window.

¢ Select the cone, right-click the blinnl node in the Hypershade, and choose Assign
Material To Selection (Figure 1.28).
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¢ Right-click the surface in the viewport, and choose Assign New Shader to create a new
shader or choose Assign Existing Material to assign a shader you've already created.

7. In the Work Area of the Hypershade, select the blinnl node. This opens the Attribute
Editor for the Blinn shader, if it’s not open already. This is where you can adjust the set-
tings that define the look of the material.

8. In the Attribute Editor for the blinnl node, rename the material coneShader by typing in
the field at the top of the editor.
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USE THE SHELF BUTTONS TO CREATE A NEW SHADER

You can assign a new material to a surface using the buttons in the rendering shelf at the top of the
Maya interface (shown here). If you select an object and click one of these buttons, a new shader is
created and assigned to selected objects. If no objects are selected, then it just creates anew shader,
which you’ll find on the Materials tab of the Hypershade.

Deformation A an Dynamics  Rendedng  PairtEFfec

r o ac

Elinn Material: Assign a new Blinn material to the active objects

9. Click the checkered box to the right of the Color slider. This opens the Create Render
Node window (Figure 1.29).

FIGURE 1.29 ee6 Create Render Node
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10. Select 2D Textures from the list on the left, and click the Grid button on the right side of
the panel to create a grid texture; this is applied to the color channel of the cone and is
visible on the cone in the viewport when textured and smooth shaded mode is on (hot
key = 6). See Figure 1.30.
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FIGURE 1.30
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11. Select coneShader in the Work Area of Hypershade, and right-click its icon. Choose
Graph Network. You'll see that the coneShader node now has the gridl texture node as
well as the place2dTexturel node attached (Figure 1.31).

FIGURE 1.31
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12. Click the place2dTexturel node in the Work Area, and its attributes will be displayed in
the Attribute Editor.



CREATING AND EDITING MAYANODES ‘ 31

13. Type 0.5 in the first field next to Coverage and press Enter. This reduces the coverage of
the grid texture in U space by one half.

NURBS UV TEXTURE COORDINATES

NURBS surfaces have their U and V texture coordinates based on the parameterization of the sur-
face, unlike polygon meshes, which require defined UV coordinates. You can use the attributes in
the place2dTexture node to position textures on NURBS surfaces. NURBS surfaces are discussed in
Chapter 3, and UV coordinates are discussed in Chapter 11, “Texture Mapping.”

14. Select the gridl node in the Work Area of the Hypershade to open its settings in the
Attribute Editor.

15. Expand the Color Balance rollout, and click the color swatch next to Default Color. This
opens the Color History. Set the color to red.

DEFAULT COLOR

The default color of the texture is the color “behind” the grid texture. Any part of the surface thatisnot
covered by the grid (based on the settings in the place2dTexture1 node) will use the default color.

16. In the left panel of the Hypershade, select 2D Textures in the Maya list, and click the
Ramp button to create a ramp node. At the moment, it is not connected to any part of the
coneShader network. This is another way to create render nodes in the Hypershade.

NAVIGATING THE HYPERSHADE WORK AREA

You can zoom in or out while in the Work Area of the Hypershade by holding the Alt button while
dragging with the right mouse button; likewise, you can pan by holding the Alt button while
MMB-dragging.

17. Select the grid1 texture to open its settings in the Attribute Editor.

18. Inthe Work Area of the Hypershade, MMB-drag the ramp texture from the Work Area all
the way to the color swatch next to the Filler Color in the grid’s Attribute Editor. Hold the
middle mouse button while dragging; otherwise, you'll select the ramp texture, and the
Attribute Editor will no longer display the gridl texture attributes (see Figure 1.32).
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FIGURE 1.32
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19. Select the coneShader node in the Work Area of the Hypershade, and choose Graph >
Input And Output Connections from the Hypershade menu. In the Work Area, you can
see that the ramp texture is connected to the grid1 texture. The grid1 texture is connected
to the coneShader, and the shader is connected to the blinn1SG node (see Figure 1.33).

FIGURE 1.33
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20. Select the blinn1SG node, and graph its input and output connections. The cone’s shape
node appears (if the bottom caps option was on in the creation options for the NURBS
cone, you'll see a second shape node for the cone’s bottom cap surface). The blinn1SG
node is also connected to the render partition and the light linker, which defines which
lights are used to light the cone (see Figure 1.34).
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GRAPHING SHADER NETWORKS

You can graph the shader network at any time to refresh the view of the connected nodes in the Work
Area. Just right-click the node you want to graph and choose Graph Network, or click the Input/
Output connections button at the top of the Hypershade (shown here). More options for displaying
the network are available in the Graph menu at the top of the Hypershade.
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FIGURE 1.34
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connections of the
blinn1SG node are
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The Hypershade is a very powerful and easy-to-use editor. You can build complex networks
of nodes quickly just like rearranging building blocks. You can see how nodes are connected by
holding the mouse pointer over the lines that connect the nodes.

The previous sections of this chapter revealed the many ways Maya nodes can be displayed,
connected, and edited in a Maya scene. You should make sure that you are comfortable with
the basics of working with the editors described. You will rely on them heavily throughout the
book, and through the various exercises you will gain proficiency in using them.

Creating Maya Projects

Organization is the key to creating a successful animation. Whether you are working by your-
self or with others in a production pipeline, you'll want to know where to find every file related
to a particular project, whether it’s a scene file, a texture map, an image sequence, or a particle
disk cache. To help you organize all the files you use to create an animation, Maya offers you the
option of easily creating a Maya project, which is simply a directory with subfolders where each
file type related to your scenes can be stored.
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Creating a New Project

Creating a new project is very simple. Projects can be created on your computer’s primary
hard drive, a secondary drive, or a network drive. The scene files used for each chapter in this
book are stored in their own project directories on the DVD that comes with the book. Maya
uses a default project directory when one has not been specified. This is located in your

My Documents\maya\projects folder in Windows or Documents\maya\projects on a Mac.
As an example, you'll create a project directory structure for the examples used in this chapter.

1.

FIGURE 1.35
The Project Win-

Start a new Maya 2012 scene. You'll note that an empty scene is created when you
start Maya.

. Choose File » Project Window.

The Project Window dialog box opens. Click the New button to the right of the Current
Project field. In the Current Project field, type Mastering_Maya_Chaptero01 (see
Figure 1.35).

To the right of the Location field, click the folder icon to browse your computer. The
Select Location window opens and lets you determine where on your computer or net-
work you want the project to be stored. Or you can simply type the path to the directory.
The project folder can be a subfolder of another folder if you like.
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In the Primary Project Locations section, you'll see a large number of labeled fields. The
labels indicate the various types of files a Maya scene may or may not use. The fields indi-
cate the path to the subdirectory where these types of files will be located.

When you click the New button as mentioned in step 3, Maya automatically fills in all the
fields (see the left side of Figure 1.36).
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The fields contain the name of the subdirectory relative to the project file. So when you
choose to use the default settings, all Maya scene files (files with the .mb or .ma file exten-
sion) will be stored in a folder labeled Scenes. The path to that folder will be, in this
example, Mastering_Maya_ChapterOl\Scenes.

EDITING DEFAULT FILE LOCATIONS

If you decide you want to store the scene files in a different directory, you can type the path to that
directory in the field or click the folder icon to the right of the field to set a different folder path.

5. Click Accept. Maya will take a few moments to create the project directory and all sub-
folders on the specified drive.

6. Use your computer’s file browser to locate the new project; then expand the folder, and
you’ll see all the subfolders.

Editing and Changing Projects

You may not need to use every folder Maya creates for you, or you may decide to change where
Maya looks for elements, such as file textures. If youre working on a number of different proj-
ects, you may need to switch the current project. All of these options are available in the Maya
File menu.

1. To edit the current project, choose File > Project Window. The Project Window dialog box
opens with all the paths to the project subdirectories. You can type a new directory path



36

CHAPTER1 WORKINGINAUTODESK MAYA

into any one of these fields or click the folder icon to browse your computer’s directory.
Then click the Accept button. If a folder does not already exist, Maya will create it for you.

RELINKING FILES AFTER CHANGING PROJECT SETTINGS

If you edit the project, Maya will look in the newly specified folders from this point on, but files
used prior to editing the project will not be copied or moved. You’ll need to move these files using
the computer’s file browser if you want Maya to easily find them after editing the project.

2. To switch projects, you can choose File > Set Project or choose a project listed in the
Recent Projects menu.

When working on a project with a number of other animators, you can choose to share the
same project, which is a little risky, or each animator can create their own project directory
structure within a shared folder. The latter example is a little safer because it prevents two peo-
ple from having the same project open or overwriting each other’s work. Later in the chapter,
you’'ll learn how multiple animators can share parts of the scene using file references.

It is possible to work on a scene file outside the current project. This happens usually when
you forget to set the project using the File > Set Project option. Make a habit of setting the cur-
rent project each time you start to work on a scene; otherwise, linked files such as textures,
dynamic caches, and file references can become broken, causing the scene to behave unpredict-
ably (which is a nice way of saying the scene will fall apart and possibly crash Maya).

While working on the project files for this book you’ll want to copy the entire project to your
local drive and then use the Project Window dialog box to choose the corresponding chapter
project directory as the current project. This way, all the linked files in the scenes should behave
correctly and the exercises will function.

OVERRIDING PROJECT SETTINGS

You can choose to override a project setting for an individual scene element. For instance, by default,
Maya looks to the source images directory for file textures. However, when you create a file texture
node, you can use the Browse button to reference a file anywhere on your machine or the network.
This is usually not a great idea; it defeats the purpose of organizing the files in the first place and
can easily lead to broken links between the scene and the texture file. It’s a better idea to move all
file textures used in the scene to the sourceimages directory or whatever directory is specified
in your project settings.

Organizing Complex Node Structures with Assets

A production pipeline consists of a number of artists with specialized tasks. Modelers, riggers,
animators, lighters, technical directors (TDs), and many others work together to create an ani-
mation from a director’s vision. Organizing a complex animation sequence from all the nodes
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in a scene can be a daunting task. Assets are a workflow management tool designed to help a
director separate the nodes in a scene and their many attributes into discrete interfaces so each
team of specialized artists can concern itself only with its own part of the project.

Assets are a collection of nodes you choose to group together for the purpose of organization.
An asset is not the same as a group node; assets do not have an associated transform node and
do not appear in the viewport of a scene. For example, a model, its animation controls, and its
shaders can all be placed in a single asset. This example demonstrates some of the ways you can
create and work with assets.

Creating an Asset
In this example, you'll create an asset for the front wheels of a vehicle:

1. Open the vehicle_v01.ma file from the Chapterl\scenes directory on the DVD. You'll
see a three-wheeled vehicle. In the Outliner, the vehicle is grouped.

2. Expand the vehicle group in the Outliner. The group consists of subgroups for the two
front wheels, the rear wheel, the chassis, the suspension, and a NURBS curve named
steering.

3. Select the steering node in the Outliner. This is the animation control for the steering.
Switch to the Rotate tool (hot key = e), and drag the green circular handle of the Rotate
tool to rotate the steering node on the y-axis. The front wheels match the arrow’s orienta-
tion (see the left image in Figure 1.37).

FIGURE 1.37

The Y rotation of
each front wheel is
connected to the

Y rotation of the
steering control
(left). The X rota-
tion of each front
wheel is connected
to the Y translate
of the steering
control, giving
the animator the
ability to tilt the
wheels if needed
(right).

If you select one of the front_wheel groups in the Outliner, you'll see that its Rotate Y
channel is colored yellow in the Channel Box, indicating it has an incoming connection.
The steering curve’s Y rotation is connected to both front_wheel groups” Y connection.

4. Select steering again, and switch to the Move tool (hot key = w).

5. Move steering up and down along the y-axis by dragging the green arrow of the Move
tool. The front wheels rotate on the x-axis based on the height of the steering object, mak-
ing them tilt (see the right image in Figure 1.37).
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FIGURE 1.38
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If you look in the Channel Box for either of the front_wheel groups, you'll see that the Rotate
X channel is colored orange, indicating that it has been keyframed. In fact, the Rotate chan-
nels of the group use what’s known as a driven key to determine their values. The keyframe’s
driver is the Y translation of the arrow group. You'll learn more about using this technique
in Chapter 5.

Select the vehicle group node.

Drag the red arrow of the Move tool to translate the vehicle back and forth along the
x-axis. All three wheels rotate as the car moves.

If you expand the front_wheell group in the Outliner and select the wheellRotate child
group node, you'll see that the Rotate Z channel is colored purple in the Channel Box,
indicating an expression is controlling its z-axis rotation. You can open the Attribute Editor
for the front_wheell group and switch to the Expression4 tab to see the expression (see
Figure 1.38). (The field isn’t large enough to display the entire expression; you can click the
field and hold down the right arrow button on the keyboard to read the whole expression.)
Creating expressions will be covered in Chapter 5.

¥ Extra ALt

This model uses a very simple rig, but already there are a lot of nodes connected to the
vehicle geometry to help the job of the animator. To simplify, you can create an asset for
just the wheels and their connected nodes so the animator can focus on just this part of the
model to do its job without having to hunt through all the different nodes grouped in the
Outliner.

In the Outliner, expand the vehicle group and the two front_wheel groups.

Ctrl+click front_wheell, wheellRotate, front_wheel2, wheel2Rotate, and the steering
curve node (Cmd+click on the Mac).

Open the Hypergraph in connections mode (Window > Hypergraph: Connections).

In the Hypergraph menu, choose Graph » Input And Output Connections (see
Figure 1.39).

In the Hypergraph, select the node named timel and the vehicle node, and drag them out
of the way of the other nodes.

Drag a selection over all the nodes except timel and vehicle. These nodes include the
group nodes, keyframe nodes, and expression nodes all related to controlling the rotation
of the front wheel groups.
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FIGURE 1.39
The vehicle group
is expanded, and
several of the
nodes related to
the front wheels
are selected and
graphed on the
Hypergraph.

14. In the Hypergraph menu, choose Edit > Asset » Advanced Assets > Create » Options
(Options is selected by clicking the small square to the right of the command list in
the menu).

THE OPTIONS BOx

The small square to the right of a listing in the menu indicates the options. When you select just
the listing in the menu, the action will be performed using the default settings. When you click
the Options box to the right of the menu listing (shown here), a dialog box will open allowing you
to change the options for the action. In this book, when you’re asked to choose options, this means
you need to click the Options box to the right of the menu listing.

15. In the Create Advanced Assets Options dialog box, type front_wheels in the Name field.
Make sure all the settings under Include Options and Publish Options are deselected. All
of the keyframes and expressions are applied to the rotation of the wheel groups, not the
geometry nodes contained in the groups, so you needn’t worry about including the con-
tents of the groups in the asset (see Figure 1.40).

16. Choose the Create Asset option.

PREVIEW THE ASSET CONTENTS

The Preview Contents option selects all the nodes that will be included in the asset when you click
the Apply button, but it will not actually create the asset. This is so you can verify that you have all
the various nodes you want included in the asset before creating it.
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FIGURE 1.40

The options are set
for the container
that will hold all
the selected nodes
in the Hypergraph.

Create Asset Effect

Include Options

Apply and Clase

17. Click Apply and Close to create the asset.

In the Hypergraph, you'll see a gray box labeled front_wheels; this box is also visible
in the Outliner. The timel and vehicle nodes are still visible in the Hypergraph. It may
appear as though they have been disconnected, but that’s not actually the case.

18. Select the front_wheels asset in the Hypergraph, and graph its input and output connec-
tions (Graph » Input And Output Connections). The connections to the timel and vehicle
nodes are visible again.

19. Select the front_wheels asset in the Hypergraph, and click the Expand Selected Assets(s)
icon on the Hypergraph toolbar (or double-click the container). You will see the nodes
within the container (see Figure 1.41).

FIGURE 1.41
Expanding the
view of a container
in the Hypergraph
makes the con-
nections between
nodes within the
container visible.

Traversal Depth: Unlimited
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20. Double-click the thick border of the asset to collapse it, or click the Collapse Selected
Assets icon at the top of the Hypergraph.

You can select a node inside the container and remove it from the container by right-click-
ing the node and choosing Remove From Container.

21. Save the scene as vehicle_v02.ma.

TIPS ON WORKING WITH ASSETS

Here are some tips for working with assets:

# To delete an asset, select it and choose (from the Hypergraph menu) Edit > Asset > Remove
Asset. Don’t select the asset and delete it; deleting the asset will delete the contents from the
scene as well.

® You can remove all the assets in a scene, without deleting their contents, by choosing Edit >
Delete By Type » Assets from the main Maya menu.

4 Inthe Outliner, you can expand the asset node to reveal the contents. Note that the wheel groups
are no longer shown as children of the vehicle group but are now inside the asset group. The
nodes themselves still behave as children of the vehicle group. If you change the position of the
vehicle, the wheels will still rotate and move with the vehicle.

@ Assets can be created in the Hypershade as well and can contain any type of node, including
shaders and textures.

€ You can create assets without going into the Hypershade. Just select the nodes in the scene,
and use the options in the Assets menu.

4 Ifyou choose Set Current Asset from the Advanced Assets submenu, all new nodes created in
the scene will automatically become part of the specified asset.

€ Youcanuse the Create Assets With Transform option in the Assets menu to create an asset with
a selectable transform handle. Translating or rotating the asset will also translate and rotate
the contents of the asset.

Publishing Asset Attributes

You can publish selected attributes of the container’s nodes to the top level of the container. This
means that the animator can select the asset node and have all the custom controls available in
the Channel Box without having to hunt around the various nodes in the network. You can also
template your asset for use with similar animation rigs.

In this exercise, you'll publish the attributes of the front_steering asset:

1. Continue with the file from the previous section, or open vehicle_v02.ma from the
chapterl\scenes folder on the DVD.

2. In the Outliner, select the front_wheels asset, and expand the node by clicking the plus
sign to the left of the node. Select the steering node from within the asset.
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3. In the Channel Box, select the Translate Y channel, and from the Edit menu in the
Channel Box, choose Publish To Asset » Options.

4. In the Publish Attribute Options dialog box, choose both Selected Channel Box Attributes
and Custom Name.

5. Type wheelTilt in the Custom String field. Click Apply and then click Close (see
Figure 1.42).

FIGURE 1.42 ann D Publish Attribute Options
The Translate Y J
attribute of the Publish: ® Se
steering node
is published to
the container Atribute name:
under the name
wheelTilt.

SHAPES

peringShape

6. Select the front_wheels asset in the Outliner; you'll see the wheelTilt channel has been
added in the Channel Box. If you change this value between -1 and 1, the arrow control-
ler moves up and down, and the front wheels tilt.

PUBLISH ATTRIBUTES FROM THE ATTRIBUTE EDITOR

If you need to publish a specific attribute that does not appear in the Channel Box, you can open the
Attribute Editor for the appropriate node, right-click the attribute name, and choose the publish
options from the context menu.

Using the Asset Editor
The Asset Editor can help you further customize and manage your scene’s assets. You can use it
as another way to publish specific attributes of an asset.

1. Open the scene vehicle_v03.ma from the chapterl\scenes folder on the DVD.

In the Outliner you’ll see two containers: one named front_wheels and another named
carPaint, which holds the blue paint shader applied to the car.

2. To open the Asset Editor, choose Assets > Asset Editor. The editor is in two panels; on
the left side you'll see all the assets in the scene.
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The Asset Editor opens in view mode. In the list of assets on the left, you can click the
plus sign in the square to see the nodes contained within each container. You can see the
attributes of each node listed by clicking the plus sign in the circle next to each node.

3. Select the front_wheels container, and click the pushpin icon above and to the right of the
asset list to switch to edit mode. On the right side of the editor, you'll see the wheelTilt
attribute you created in the previous section.

4. Select the arrow next to wheelTilt on the right panel, and the wheels asset expands to
reveal the Translate channel of the steering node. This is the attribute originally pub-
lished to the container as wheelTilt.

5. In the list on the left below the Translate channels, expand the Rotate attributes of the
steering node. Select Rotate Y, and click the second icon from the top in the middle bar
of the Asset Editor. This publishes the selected attribute to the container with a custom
name.

6. A dialog box will open, prompting you to name the selected attribute. Name it steer (see
Figure 1.43).

FIGURE 1.43 A06 Asset Editor - front_wheels
Attributes can be Display Show Assets Template View Help :

published to the bl Templata:
container from ? # ¥ front_wheels

within the Asset ~ steering

Editor.

[ wheerTilt

lished name:

Cancel

Note that steps 5 and 6 are just another way to publish an attribute; the end result is the
same as when you published the wheelTilt attribute from the Channel Box in the previ-
ous section.
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FIGURE 1.44
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7. Steer now appears in the right side of the Asset Editor. The view on the right side of the
Asset Editor shows the attributes grouped by node. If you want to see just the published
attributes, choose View » Mode » Flat from the Asset Editor’s menu bar.

8. Select the front_wheels asset in the Outliner, and open its Attribute Editor.

9. Expand the Asset Attributes rollout, and turn on Black Box (see Figure 1.44). When you
do this, the only attributes that appear in the Channel Box are the ones that have been
published to the asset (wheelTilt and steer). Likewise, in the Outliner, you can no longer
expand the asset node.

front_wheels

container:

attributes. ~  Published Attributes

¥ steering

¥  Asset Attributes

leon Narme

¥  Templates

Group By Node ~

Template Name

Template Path

The Black Box option allows you to restrict access to an asset’s attributes so that other artists
working on the team can focus on just the attributes they need.

The Asset Editor has a number of advanced features, including the ability to create templates
of complex assets that can be saved to disk and used in other scenes for similar assets.

File References

File referencing is another workflow tool that can be used when a team of artists is working on
the same scene. For example, by using file references, an animator can begin animating a scene
while the modeler is still perfecting the model. This is also true for any of the other team mem-
bers. A texture artist can work on textures for the same model at the same time. The animator
and texture artist can import a reference of the model into their Maya scene, and each time the
modeler saves a change, the model reference in the other scenes will update (when the animator
and texture artist reload either the scene or the reference).
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FILE REFERENCING VS. IMPORTING

File referencing is not the same as importing a Maya scene into another Maya scene. When you
import a Maya scene, all the imported nodes become fully integrated into the new scene and have
no links to any external files. On the other hand, file references maintain a link to external files
regardless of whether the referenced files are open or closed. You can alter a referenced file in a
scene, but doing so is not a great idea; it can break the link to the referenced file and defeats the
purpose of file referencing in the first place.

Referencing a File
In this example, you'll reference a model into a scene, animate it, and then make changes to the
original reference to get a basic idea of the file referencing workflow:

1. Find the vehicleReference_v01l.ma scene and the street_v01.ma scene in the chapterl\
scenes directory of the DVD. Copy both of these files to your local hard drive. Put them in
the scenes directory of your current project.

2. Open the scene street_v01l.ma from the scenes directory of the current project (or
wherever you placed the file on your local drive). The scene contains a simple street
model. A locator named carAnimation is attached to a curve in the center of the street.
If you play the animation, you'll see the locator zip along the curve.

3. To bring in a file reference, choose File > Create Reference. The Reference dialog box
will open.

4. Find the vehicleReference_v01.ma scene that you copied to your local drive. Select
it and choose Reference in the Reference dialog box. After a few moments, the car will
appear in the scene (see Figure 1.45).

FIGURE 1.45
The referenced
vehicle appears in
the scene with

its associated
containers.
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In the Outliner, you'll see the vehicleReference_v01:vehicle node as well as the vehicleRef-
erence_v01:front_wheels and carPaint container nodes. The container node is an asset
with both the wheelTilt and steer attributes created in the previous section.

REFERENCING MAYA SCENES

You don’t need to do anything special to the scene you want to reference; it can be a standard Maya
scene. When you reference a file in a scene, all of its associated nodes appear using the referenced
file’s scene name as a prefix. You can change this to a custom string using the options in the Create
Reference tool.

10.
11.

12.

13.

14.

15.

16.
17.

In the Outliner, select the carAnimation locator, and then Ctrl+click the vehicleReference_
v01:vehicle node.

Switch to the Animation menu set, and choose Constrain » Parent > Options.

In the options for the Parent constraint, turn off Maintain Offset, make sure both
Translate All and Rotate All are selected, and set the weight to 1.

Click Add to make the constraint. The car is now constrained to the locator and will zip
along the curve in the center of the street.

Try setting keyframes on the wheelTilt and steer attributes of the vehicleReference_
v0l:front_wheels node.

Save the scene to your local scenes directory as street_v02.ma.

Open the vehicleReference_v01.ma scene from the directory where you copied this file
on your local drive.

Expand the vehicle group and the chassis subgroup.

Select the body subgroup. Set its Scale Y attribute to 0.73 and its Scale Z attribute to 1.5.
The Scale Y attribute is the second scale field in the Attribute Editor; the Scale Z attribute
is the third scale field.

Open the Hypershade (Window > Rendering Editors > Hypershade), and select the blue-
Paint material.

In the Attribute Editor for the bluePaint material, click the blue color swatch next to the
color channel, and use the Color History to change the color to red.

Save the scene using the same name (vehicleReference_v01l.ma).

Open the street_v02.ma scene. The car model has all the changes you created in the
vehicleReference_v01.ma scene. It is red, and the body is much wider (see Figure 1.46).
Play the animation or scrub on the Time slider to see this.



FILEREFERENCES | 47

FIGURE 1.46

The changes made
to the body shape
and color in the
vehicleRefer-
ence_v01.ma file
are reflected in the
referenced model
in the street scene.

This is the basic file referencing workflow; however, a file referencing structure can be made
much more complex to accommodate the needs of multiple teams. In addition, a referenced file
can use other references so that a file referencing tree can be constructed by layering several
levels of file references. This kind of structure is best planned out and agreed upon in the begin-
ning in order to minimize confusion and keep a consistent workflow.

Using Reference Proxies

You can use proxy objects for your file references to temporarily substitute higher-resolution
objects with lower-resolution objects. This can make animating the scene a little easier because
the lower-resolution objects will improve performance and update faster in Maya as you play the
animation on the timeline.

Multiple versions of the model can be created and used as proxies to facilitate different needs
in the scene. A proxy should be the same size and roughly the same shape as the referenced file.

1. Open the street_v03.ma scene from the chapterl\scenes directory on the DVD. This
scene has the same street as before with the same animated locator.

2. First bring in the file reference by choosing File > Create Reference > Options.

3. Under General Options in the Reference Options dialog box, turn on Group and Locator
(see Figure 1.47). This will create a locator in the scene and a parent reference to the loca-
tor. Set File Type to Maya Ascii.
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FIGURE 1.47 'l Reference Options =]
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REFERENCE GROUPING

For the reference and proxy to share the same translation, rotation, and scale animation, the refer-
ence must have Group enabled when it is brought into the scene. Otherwise, when you animate the
proxy and then switch to the reference, animation placed on the transform node of the proxy will
not be transferred to the reference.

4. C(lick the Reference button in the References dialog box, and choose the vehicleReference_
v01.ma file from the chapterl\scenes directory that you copied to your local disk.

When the reference loads, you'll see that it is parented to a locator named vehicleReference_
v01RNlocator in the Outliner.

5. In the Outliner, MMB-drag the vehicleReference_v01RNlocator on top of the carAnimation
locator.
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6. Then select the vehicleReference_v01RNlocator, open the Channel Box, and set all of its
Translate and Rotate channels to 0 (Figure 1.48).
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Choose File » Reference Editor to open the Reference Editor dialog box.

In the bottom half of the Reference Editor dialog box, select the vehicleReference_vO1RN
node. Choose Proxy > Add Proxy » Options.

In the Proxy Options dialog box, type loRes into the Set Proxy Tag To field. Click the
Proxy button.

Use the Proxy dialog box to choose the ToResCar_v01.ma scene from the chapterl
\scenes directory on the DVD.

Choose Proxy » Add Proxy » Options. This time, edit the Set Proxy To field so that it
reads mediumRes, and click the Proxy button.

Use the Proxy dialog box to select the medResCar_v01.ma scene from the chapterl
\scenes folder on the DVD.

The Reference Editor won't look much different except that the icon next to the vehi-
cleReference listing in the lower half has changed to the double-diamond icon, indicating
that the reference has proxies available.

To switch to the proxy, make sure vehicleReference_v01PM is selected in the Reference
Editor.
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14. From the menu bar in the Reference Editor, choose Proxy > Reload Proxy As > vehi-

cleReference_v01PMI1 (loResCarv(0l.ma). After a moment, the original vehicle is replaced
with the lower-resolution version.

15. Try using this menu to switch to the mediumRes version of the vehicle. The vehicle

should be replaced with a slightly higher-resolution version. If you play the animation,
the vehicle still moves along the animation curve (Figure 1.49).

16. To bring back the reference, select the original from the list in the Proxy > Reload Proxy

As menu.

The Reference Editor can be used to change proxies; remove proxies; and load, duplicate,

unload, and reload references. When a reference is unloaded, it is removed from the scene.

The Bottom Line

Understand transform and shape nodes. DAG nodes have both a transform node and a
shape node. The transform node tells where an object is located; the shape node describes
how it is made. Nodes can be parented to each other to form a hierarchy.

Master It Arrange the nodes in the miniGun_v03.ma file in a hierarchical structure so
the barrels of the guns can rotate on their z-axis, the guns can be aimed independently,
and the guns rotate with the turret.

Create a project. Creating a project directory structure keeps Maya scene files and con-
nected external files organized to ensure the animation project is efficient.

Master It Create a new project named Test, but make sure the project has only the
scene, source images, and data subfolders.

Use assets. An asset is a way to organize the attributes of any number of specified nodes
so that their attributes are easily accessible in the Channel Box. This means that members
of each team in a pipeline only have to see and edit the attributes they need to get their job
done, thus streamlining production.



THEBOTTOMLINE| 51

Master It Create an asset from the nodes in the miniGun_v04.ma scene in the chap-
terl\scenes folder. Make sure that only the Y rotation of the turret, the X rotation of the
guns, and the Z rotation of the gun barrels are available to the animator.

Create file references. File references can be used so that as part of the team works on a
model, the other members of the team can use it in the scene. As changes to the original file
are made, the referenced file in other scenes will update automatically.

Master It Create a file reference for the miniGun_v04.ma scene; create a proxy from the
miniGun_loRes.ma scene.






