
Chapter 1

Introducing Your New Best Friend
In This Chapter
� Introducing the new features of Dreamweaver 8

� Examining your Web site objectives

� Finding your way around in Dreamweaver

Welcome to the wonderful world of Dreamweaver 8. If you’re an experi-
enced Web designer, you’re going to love the power and sophistica-

tion of this Web editor. If you’re new to building Web sites, you’ll appreciate
its simplicity and intuitive interface. Either way, this chapter starts you on
your way to making the most of Dreamweaver by introducing you to the
menus and panels that make this program so useful.

Dreamweaver can help you with every aspect of Web development, from
designing simple pages, to fixing links, to publishing your pages on the World
Wide Web. Dreamweaver can handle the simplest HTML, as well as some of
the most complex and advanced features possible on the Web, including
Cascading Style Sheets and Dynamic HTML (see Chapters 8 and 9 for more
information on these features). Dreamweaver also integrates a powerful
HTML text editor into its easy-to-use graphical design environment so you
can work in the HTML code if you prefer.

If you already work in another Web design program or you’re updating a site
that was created in another program, don’t worry — you can use Dreamweaver
to modify existing Web pages and continue to develop your Web site without
losing all the time you’ve already invested. For example, if you’ve been working
in a program such as Microsoft FrontPage or Adobe GoLive, you can change to
Dreamweaver to edit and develop your site further. All Web design programs
create HTML pages, and those pages can be opened in any other Web design
program. At the end of this chapter, in the “Working on Web Pages Created in
Another Web Design Program” section, you find a few warnings about the chal-
lenges you may encounter because the code can vary slightly from program to
program, but once you clean up those differences, you should be fine.

In this chapter, you find an introduction to the new features in Dreamweaver 8,
get a tour of the desktop, and gain an overview of what makes Dreamweaver
such a powerful Web design program. 
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So What’s New in Dreamweaver 8?
Now the good stuff. All those requests you make to Macromedia, all that
wishful thinking . . . believe it or not, they heard you and many of the little —
and not so little — things we all have been wanting in this program are finally
here, as well as a few extras you might expect! 

The following list provides you a quick overview of some of the new features
you find in version 8:

� When you first launch Dreamweaver 8, you’ll notice a few changes to the
Workspace. Although it has no dramatic changes, the programmers at
Macromedia have added some clever new features, including a magnify-
ing glass feature complete with a little icon in the status bar just below
the work area. Much like the magnifiers common in image-editing pro-
grams, this new feature enables you to zoom in to view page elements in
greater detail or zoom out to see the full layout of a larger page.

� You’ll find some of the most extensive changes in the way Dreamweaver
handles CSS — important upgrades as Cascading Style Sheets become
increasingly popular among professional designers. Among other things,
you’ll find improved CSS rendering, better support for positioning, and a
more unified CSS panel that includes the Rule Tracker, Property Grid,
and a new Composite view.

� You can find one of my favorite new feature sets on the Edit menu. Paste
Special enables you to paste formatted text (and even tables) from other
programs, such as Microsoft Word or Excel, with options about what for-
matting is kept. You can choose to paste text with structural formatting,
such as tables and paragraph marks; with or without basic formatting,
such as bold and italics; and you can even opt to clean up the often
problematic paragraph formatting from Word as you paste in the text. 
If you specify your choices in Dreamweaver’s Preferences, anytime 
you use the paste feature your text is inserted based on your favorite
options.

� Going beyond the predesigned templates included in previous versions,
Dreamweaver now includes Starter Pages, which not only include topic-
based designs. They actually include text. Of course, you can edit the
text; but if you’re creating a calendar of events or a product catalog, for
example, the general text already in place on these pages gives you a
head start. 

� If you prefer working in Code view, where you can see all the HTML tags,
you’ll find a few enhancements to that interface, including a new toolbar
that provides quick access to common commands and the capability to
selectively expand and collapse code so you can focus on the area you
are working on.
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� I always recommend that you design your pages for the broadest audi-
ence, and that definitely includes designing for the disabled, such as the
blind who use special browsers that read Web pages aloud. Macromedia
has always been good about including accessibility features, and I’m
pleased to see those features support the Priority 2 Web Content
Accessibility Guidelines.

Introducing the Many Components 
of Dreamweaver

Dreamweaver can seem a bit overwhelming at first. It has so many features,
and they are spread out in so many panels, toolbars, and dialog boxes that
you can easily get lost. If you prefer to learn by poking around, have at it (and
feel free to skip ahead to the next chapter where you start building your first
Web page). If you want a tour before you get started, the next few sections
introduce you to the interface and provide an overview of the basics of
Dreamweaver. You also discover where to find common features and func-
tions, which the rest of the book covers in more detail.

The Workspace
When you launch Dreamweaver, the Start Screen appears in the main area of
the program (and it reappears anytime you don’t have a file open). From the
Start Screen, you can choose to create a new page from one of the many
Dreamweaver pre-made templates, or you can create a new blank page by
selecting HTML from the Create New options in the middle column. When
you select HTML, Dreamweaver creates a new blank HTML page in the main
Workspace, as shown in Figure 1-1. You can type text directly into any page in
the Workspace and apply basic formatting with the many formatting options
described later in this chapter.

You build HTML pages, templates, style sheets, and so on in the Workspace,
which consists of a main window that shows the page you’re working on sur-
rounded by a number of panels and menus that provide tools you can use to
design and develop your pages (shown in Figure 1-1). The Dreamweaver
Workspace consists of the following basic components: the menu bar (at the
very top), the Insert bar (just below it), the Document window (the main area
of the screen, just below the Insert bar), the Properties inspector (at the
bottom of the screen), and the Vertical Docking panels (to the right of the
Document window) that expand and collapse as needed. More detailed
descriptions of each of these follows.
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The Document window
The big, open area in the main area of the Workspace is the Document window,
which is where you work on new and existing pages. If you use the Designer
interface in Design view, you see your page as it would display in a Web
browser. If you want to see the HTML code behind your page, click the Code
button at the top of the work area. Choose the Split button to see the HTML
code and Design view simultaneously (which you can see in Figure 1-2). 

Pages viewed on the World Wide Web may not always look exactly the way
they do in the Document window in Dreamweaver because not all browsers
support the same HTML features or display them identically. For best results,
always test your work in a variety of Web browsers, and design your pages to
work best in the browsers that your audience are most likely to use. Fortu-
nately, Dreamweaver includes features that help you target your page designs
to specific browsers, such as the Check Target Browsers feature covered in
Chapter 3.)

Insert bar

Tag selector

Menu

Document toolbar Document window Vertical Docking panels

Properties inspector

Figure 1-1:
The

Workspace
includes 
the main

Document
window,

surrounded
by the Insert
bar, Vertical

Docking
panels, 
and the

Properties
inspector.
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Customizing the interface
The docking panels, palettes, and bars in Dreamweaver provide easy access
to most of the program’s features. The default settings put the Properties
inspector at the bottom of the page, the Insert bar at the top, and the panels
on the right, but you can move these elements around the screen by selecting
them and use drag and drop to move them to another part of the screen. You
can also close any or all the panels on the right by clicking the tiny Options
icon in the top right of each panel and selecting Close Panel from the drop-
down list (it looks like three bullet points with lines next to them and a little
arrow underneath, and it’s really, really small). You can close them all at once
by choosing Window➪Hide Panels (or by clicking the arrow in the middle of
the row of panels), and you can access any or all the panels through the vari-
ous options on the Window menu. If you want to open a particular panel —
the CSS Styles panel, for example — choose Window➪CSS Styles and it
expands to become visible on your screen. The Properties inspector, Insert
bar, and panels are integral parts of this program, and you find a lot more
information about them throughout the book. Check out the Cheat Sheet at
the front of this book for a handy reference to the Properties inspector
options. In Chapter 2, you discover how to use some of the most common
features, such as the icon for inserting an image on the Insert bar at the top
of the screen. 

Figure 1-2:
When you
select text
in Design
view, the

correspond-
ing text 
is auto-

matically
highlighted

in Code
view.
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The Insert bar
The Insert bar, located at the top of the screen, comes with eight subcate-
gories, each with a different set of icons representing common features. Click
the small arrow to the right of the name to access the drop-down list to
switch from displaying the buttons on one subcategory to showing the but-
tons for another. The options are

� Common bar: Displays icons for many of the most common features,
including links, tables, and images.

� Layout bar: Displays layer and table options essential for creating com-
plex layouts.

� Forms bar: Surprise! This one features all the most common form ele-
ments, such as radio buttons and boxes.

� Text bar: Displays common text-formatting features, including para-
graphs, breaks, and lists.

� HTML bar: Offers a mishmash of raw HTML, such as rules, tables,
frames and, scripts.

� Application: Use these options when building dynamic Web pages pow-
ered by database material.

� Flash elements: A single icon allows you to place a Flash file on your
Web page.

� Favorites: Right-click (Windows) or Control+click (Mac) to customize
your most-used HTML elements.

At the very end of the drop-down list, you find the Show as Tabs option,
which enables you to display the names of the Insert bars as tabs across the
top of the screen, as shown in Figure 1-3. 

The Favorites Insert bar is blank by default, and you can customize it to hold
your own collection of options. Simply right-click (Windows) or Control+click
(Mac) in the bar and you can easily customize this bar.

Throughout the book, I refer to these Insert bars by their full names, such as
the Forms Insert bar or the Layout Insert bar. You find more information on
each of these in their relevant chapters. For example, Chapter 12 covers the
Forms Insert bar in detail; and Chapters 13, 14, and 15 cover the Application
Insert bar.

Figure 1-3 shows the Insert bar with the Common options visible and each
name displayed in a tab across the top of the screen.
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The Properties inspector
The Properties inspector is docked at the bottom of the page in Dreamweaver.
If you prefer it at the top of the screen, you can drag it up there, and it locks
into place; but I rather like that it’s handy, yet out of the way, at the bottom of
the screen.

The Properties inspector displays the properties of a selected element on the
page. A property is a characteristic of HTML — such as the alignment of an
image or the size of a cell in a table — that you can assign to an element on
your Web page. If you know HTML, you recognize these as HTML attributes.

When you select any element on a page (such as an image), the inspector
changes to display the relevant properties for that element, such as the
height and width of an image. You can alter these properties by changing the
fields in the Properties inspector. You can also set links and create image
maps using the options in the Properties inspector.

Figure 1-4 shows the image options displayed in the Properties inspector,
including height and width, alignment, and the URL (Uniform Resource
Locator or, more simply, Web address) to which the image links.

At the bottom-right corner of the Properties inspector, you see a small arrow.
Click this arrow (or double-click in any open inspector space) to reveal addi-
tional attributes that let you control more advanced features, such as the
image map options when a graphic is selected.

Figure 1-3:
The

Common
Insert bar
provides

access for
forms,
tables,

images, 
and more.
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Figure 1-5 shows the Properties inspector when you select a table. Notice
that the fields in the inspector reflect the attributes of an HTML table, such
as the number of columns and rows. (See Chapter 6 to find out more about
HTML tables.)

The Docking panels
The Docking panels, shown in Figure 1-6, are located to the right of the work
area (although you can easily move them anywhere on the screen). The Docking
panels display a variety of important features in Dreamweaver, including all the
files and folders in a site (in the Files panel), Cascading Style Sheets (in the CSS

Figure 1-5:
Attributes of

a selected
HTML table

or cell.

Figure 1-4:
The

Properties
inspector

displays the
attributes 

of any
selected
element,
such as 

an image
shown here.
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panel) and more. You can open and close panels by clicking the small arrow to
the left of the panel’s name. To display more panels, select the panel name from
the Window menu. To hide all the visible panels at once, click the tab with the
small arrow in the middle, left of the row of panels.

The following list offers a description of some of the elements that you
access through the Docking panels (the others are described in greater detail
in their respective sections of the book).

� Files panel: Shown in Figure 1-6, the Files panel lists all the folders and
files in a Web site and helps you manage the structure and organization
of the site. You can move files in and out of folders and even create new
folders in this panel, and Dreamweaver automatically adjusts any related
links. The Files panel is also where you access FTP (file transfer protocol)
capabilities to upload or download files from a server. You can use the
Connect button at the top of this panel to dial quickly into your server
and use the Get Files and Put Files arrows to transfer pages. (See
Chapter 2 for more about the Files panel and built-in FTP features.)

Figure 1-6:
The Dock-
ing panels

provide
easy access
to CSS, tags,

and all the
files in a

Web site,
such as the

list shown
here in

Kathryn
LeMieux’s

cartoon site.
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� Assets panel: The Assets panel, shown in Figure 1-7, automatically lists
all the images, colors, external links, multimedia files, scripts, templates,
and Library items in a Web site. You can add a stored item, such as a
graphic, to a Web page simply by dragging the element into the work
area. You find more on templates and Library items in Chapter 4.

These features work only if you define your site using the Site Definition
dialog box (by choosing Site➪Manage Sites) and then identifying the
main folder of your Web site. If you find that the Library or other options
aren’t available, follow the steps in Chapter 2 to define your site (a setup
process you should go through for all your sites). 

� CSS panel: The Cascading Style Sheets panel includes Layers and CSS
Styles panels. CSS styles are similar to style sheets used in word pro-
cessing and desktop publishing programs, such as Microsoft Word and
QuarkXPress. You define a style and name it, and the style is then
included in the CSS Styles panel (see Figure 1-8). The Layers panel pro-
vides access to layers options, which enable you to precisely position
elements on a page. (For more information about CSS and layers, see
Chapters 8 and 9.)

Figure 1-7:
The Assets

panel
presents

like items in
a central

place.
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� Tag panel: The Tag panel provides access to attributes and behaviors. In
Dreamweaver, behaviors are scripts (usually written in JavaScript) that
you can apply to objects to add interactivity to your Web page.
Essentially, a behavior is made up of a specified event that, when trig-
gered, causes an action. For example, an event may be a visitor clicking
an image, and the resulting action may be that a sound file plays.

Figure 1-9 shows the Tag panel’s Attributes tab, which displays all the
attributes of a selected element. You can change attributes in the
Attributes tab as well as in the Properties inspector. (Chapter 9 provides
more information on creating and applying behaviors.)

Figure 1-9:
The

Attributes
panel

displays 
all the

attributes of
a selected

element.

Figure 1-8:
The CSS

panel
makes it
easy to

manage
styles and

layers.
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� History panel: The History panel, shown in Figure 1-10, keeps track of
every action you take in Dreamweaver. You can use the History panel to
undo multiple steps at once, to replay steps you performed, and to auto-
mate tasks. Dreamweaver automatically records the last 50 steps, but you
can increase or decrease that number by choosing Edit➪Preferences➪
General (Windows) or Dreamweaver➪Preferences➪General (Mac), and
changing the maximum number of history steps.

� Application panel: This panel includes the Database, Bindings, Server
Behaviors, and Components panels. These features are used only if you
work with a database-driven site (the most technically complex of the
features covered in this book). You find more on database options in
Chapters 13, 14, and 15.

� Frames panel: If you create a site design that uses frames, a set of HTML
tags that enable you to divide a screen into sections made up of sepa-
rate pages, you use the Frames panel to manage the different pages on
the screen, such as the three frames shown in Figure 1-11.

Figure 1-11:
The Frames
panel helps
manage the

different
pages that
make up a
frameset.

Figure 1-10:
The History

panel keeps
track of 
all your

actions in
Dream-
weaver.

22 Part I: Fulfilling Your Dreams 

05_596497 ch01.qxd  9/16/05  7:53 PM  Page 22



The menu bar
At the top of the screen, the Dreamweaver menu bar provides easy access 
to all the features that you find in the Insert bar, Properties inspector, and
panels, as well as a few others that are available only from the menu. The fol-
lowing sections provide a general description of each of the menu options.

The File menu
You find many familiar options, such as New, Open, and Save, on the File
menu, shown in Figure 1-12. You also find a Revert option, which is similar to
the Revert feature in Adobe Photoshop. This sophisticated undo feature
enables you to return your page quickly to its last-saved version if you don’t
like the changes you made.

The File menu also includes access to Design Notes, a unique feature that
associates private notes with HTML and other files. Take a look at Chapter 4
for more information about Design Notes and other Dreamweaver features
that make collaboration easier.

You can also find features useful for checking your work in Web browsers on
the File menu. Most Web design programs include some way of previewing
your work in a browser. Dreamweaver takes this feature two steps further by
enabling you to check your work in a number of browsers and even test the
compatibility of your pages in different versions of different browsers.

Figure 1-12 shows the Check Page options, which includes Check Accessibility,
Check Links, and Check Target Browsers — all great tools for testing your
work. The Check Target Browsers option enables you to specify a browser
and version, such as Safari 2.0, Netscape 6, or Internet Explorer 6.0. When
you do a browser check, Dreamweaver generates a report listing any HTML
features you use that the chosen browser doesn’t support. 

The Check Links feature verifies all the links in a site and produces a report
with all broken and unresolved links. The Check Accessibility feature checks
to make sure the page displays properly in browsers for the blind and other
systems for the disabled.

The Edit menu
The Edit menu contains many features that you may find familiar, such as
Cut, Copy, and Paste. One feature that may be new to you is the Edit with
External Editor option, which enables you to open an element in another pro-
gram, such as an image editor, and make changes without ever closing
Dreamweaver.
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You also find the Preferences settings on the Edit menu (Windows) or on the
Dreamweaver (Mac). Before you start working with a new program, go
through all the Preferences options to ensure that the program is set up the
best way for you.

The View menu
The View menu provides access to some helpful design features, such as
grids and rulers, as well as the new zoom features. The Visual Aides option
on the View menu gives you the option of turning on or off the borders of
your HTML tables, frames, and layers, as well as controlling visibility of
image maps and other invisible elements. This option is useful because you
often want to set the border attribute of these HTML tags to zero so that
they’re not visible when the page displays in a browser. However, while you
work on the design of your page in Dreamweaver, seeing where elements,
such as tables and layers, start and stop is very useful. Checking the frame
options on the View menu lets you see the borders in Dreamweaver even if
you don’t want them visible to your site’s visitors.

The Insert menu
As shown in Figure 1-13, the Insert menu offers access to a number of fea-
tures unique to Web design. From this menu, you can insert elements such as
a horizontal rule, a Java applet, a form, or a plug-in file.

Figure 1-12:
The Check

Target
Browsers

feature
produces a

list of HTML
tags that

older
browsers do
not support.
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Dreamweaver offers extra support for inserting Flash and Shockwave
Director files, both of which are products from Macromedia. (You can find
out more about using multimedia files in Chapter 11.)

The Modify menu
The Modify menu is another place where you can view and change object
properties, such as the table attributes shown in Figure 1-14. The properties
(usually called attributes in HTML) let you define elements on a page by set-
ting alignment, height, width, and other specifications.

Page Properties
To alter properties for an entire page, such as text and link colors, use the
Page Properties dialog box shown in Figure 1-15. Available from the Modify
menu or by clicking the Page Properties button at the bottom of the
Properties inspector, the Page Properties panel also enables you to specify
the background color or to use an image as a page background.

Figure 1-13:
The Insert

menu
makes

adding a
variety of

elements to
your pages,

including
multimedia
files, easy.
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The Text menu
You can easily format text with the Text menu by using simple options, such
as bold and italic, as well as more complex features, such as font styles and
custom style sheets. Text formatting options have evolved dramatically on
the Web. Just a few years ago, you didn’t even have the option of specifying a
particular font style or controlling leading and spacing. Today you have more
control than ever over the look of your Web pages, although these options
aren’t yet universally supported. The Text menu also features options that

Figure 1-15:
The Page

Properties
dialog box

provides
access to

background
and text

color
attributes.

Figure 1-14:
The Modify

menu
makes

changing
object

properties,
such as 

the table
attributes

shown 
here, easy.
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enable you to quickly create headers and subheads, check spelling, and
create lists.

The Commands menu
The Commands menu, shown in Figure 1-16, provides access to a host of
options in Dreamweaver. These options include the Start and Play Recording
features, which let you quickly save a series of steps and then repeat them.
To use this feature, choose Commands➪Start Recording, perform whatever
actions you want to record — for example, copying and pasting some text —
and then choose Stop Recording. To perform any action again, choose
Commands➪Play Recorded Command. You can download an action by
choosing Commands➪Get More Commands, which automatically launches a
browser and takes you to the Macromedia Web site. You can download new
commands from the Web site that add functionality to Dreamweaver.

The Clean Up XHTML and Clean up Word HTML options on the Commands
menu help you correct incorrect or redundant HTML code, and the Clean Up
Word HTML feature is designed especially to correct the common problems
caused by the Save As HTML feature in Microsoft Word.

The Add/Remove Netscape Resize Fix option on this menu inserts or removes
a JavaScript script designed to help correct an old Netscape bug by automati-
cally reloading the page when users resize their browser windows.

Figure 1-16:
The

Commands
menu offers
easy access

to some of
Dream-

weaver’s
most

advanced
features.
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The Create Web Photo Album option launches Macromedia Fireworks and
uses it to automate the creation of a photo album with a series of images. If
you choose Optimize Image in Fireworks, a selected image automatically
opens in the optimization area in Fireworks. (Both these commands require
that you have Fireworks installed.)

The Site menu
The Site menu provides access to the options you need to set up your site, a
process required before many of the other Dreamweaver features work prop-
erly. (Chapter 2 covers this process.) The Site menu also gives you easy
access to the Check In and Check Out features, which are options that can
help you keep a team of designers from overwriting each other’s work.
(Chapter 4 talks about this feature.)

The Window menu
The Window menu lets you control the display of panels and dialog boxes,
such as Insert, Properties, and Behaviors. To make these panels visible,
select the panel name so that a check mark appears next to the feature you
want to display; to hide them, select again to remove the check mark. Other
panels and dialog boxes, such as CSS Styles and HTML Code Inspector, are
also listed on the Window menu for easy access.

The Help menu
The Help menu provides easy access to help options that can assist you in
figuring out many features of Dreamweaver. You also find access to the
Dreamweaver template and example files on the Help menu. 

Templates and examples provide visual samples of common HTML designs,
such as tables and frames, and provide design ideas and great shortcuts for
creating complex layouts.

The status bar
The status bar appears at the bottom left of any open Dreamweaver docu-
ment. On the right end of the status bar, you can see tool icons that control
the on-screen display of your document. On the left end, you find a row of
HTML codes that indicate how elements on your page are tagged. If you place
your cursor in bold text that is centered, for example, the status bar might
display <BODY><CENTER><B>. This feature makes double-checking the kind of
formatting applied to any element on your page easy. 

You can also use the status bar to quickly make a selection on your page. For
example, if you click the name of a tag in the status bar, the section of your
page where that tag is applied is highlighted. This makes selecting a certain
section of a page, such as a page, easier.
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Working on Web Pages Created in
Another Web Design Program

In theory, all Web design programs should be compatible because HTML files
are, at their heart, just ordinary text files. You can open an HTML file in any
text editor, including Macintosh TextEdit and Windows Notepad. However,
HTML has evolved dramatically over the years and different Web programs
follow different standards, which can cause serious conflicts when a page cre-
ated in one program opens in another.

One of the reasons Dreamweaver is so popular is because it creates very
clean code and is considered more accurate and more respectful of HTML
standards than other programs. Dreamweaver is also better at creating pages
that work in different browsers and on different platforms, but importing files
created in another Web program can be challenging, even in Dreamweaver. 

To help with the transition, Dreamweaver includes some special features,
such as the Clean Up Word HTML option, designed to fix some of the
common problems with Microsoft Word’s HTML code. 

Before you start working on a site that was developed in another program,
you need to import the site into Dreamweaver. I recommend you make a
backup of the site first so you have a copy of all the original pages (strange
things can happen when you open a site created in another program). You
find step-by-step instructions for importing an existing Web site in Chapter 2.

The following sections describe the most popular HTML editors and what
you need to know if you’re moving files from one of these programs to
Dreamweaver.

Microsoft FrontPage 
Microsoft FrontPage is one of the most popular HTML editors on the market,
in large part because it’s a part of the immensely popular Microsoft Office.
FrontPage offers some powerful features as well as an attractive bundle of
programs for Web developers, including Image Composer, a graphics pro-
gram designed for creating images for the Web. FrontPage also includes Web
components that you can use to add interactive features, such as a simple
search engine or a discussion area, to your Web site. Web components work
only if their corresponding programs reside on the Web server that you use,
but many commercial service providers now offer FrontPage Web components. 

If you are migrating a site from FrontPage to Dreamweaver, first make note of
any FrontPage Web components that you use, such as search engines or forms.
Dreamweaver doesn’t offer these same built-in features, and you won’t be able
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to continue editing them in Dreamweaver the way you did in FrontPage.
Although you don’t need to alter the code for these components, thanks to the
Dreamweaver respect for unique code, you can’t edit FrontPage’s built-in com-
ponents in Dreamweaver.

If you use CSS or layers in FrontPage, you need to pay special attention to
those features as you convert your site to Dreamweaver. Microsoft FrontPage
isn’t as good as Dreamweaver at creating high-end features that work in both
Netscape Navigator and Microsoft Internet Explorer, so you probably want to
improve your code if you expect viewers to use any browser other than
Internet Explorer. Because CSS and layers are more complex than HTML to
code, you probably don’t want to edit this code manually — converting from
other editors to Dreamweaver can get pretty tricky. Tables can also get messy
when you switch from one program to another. In some cases, you may find
that the simplest solution is to delete the elements that you created in
FrontPage and re-create them in Dreamweaver. (For more on CSS and layers,
check out Chapters 8 and 9.)

Microsoft Word
Although Microsoft Word is a word processor and is not considered an HTML
editor per se, it does have HTML output capabilities. As a result, you will
likely encounter pages that have been created and saved in Microsoft Word
at some point. The problems you find in HTML code generated from Word are
similar to the problems generated from FrontPage: They both tend to create
unusual and sometimes redundant code that deviates from HTML standards.
Because Word-generated HTML is so common, Dreamweaver includes a spe-
cial Clean Up Word HTML command. To use this feature, choose Commands➪
Clean Up Word HTML and then specify the code you want altered in the Clean
Up Word HTML dialog box. When you use this feature, Dreamweaver removes
excess code, which can help your pages load faster and work better in differ-
ent browsers.

After you use Dreamweaver to clean up Word HTML, you should not expect
to edit the file in Word again. The code may be cleaner, but depending on the
formatting options you’ve used, Word may no longer be able to read it.

Adobe GoLive
Adobe GoLive offers some great features for easy page design and a lot of
similarities to Dreamweaver, so you should have little if any trouble migrating
a site from GoLive to Dreamweaver.

30 Part I: Fulfilling Your Dreams 

05_596497 ch01.qxd  9/16/05  7:53 PM  Page 30



If you have included any JavaScript actions in your pages using GoLive, you
may not be able to edit them in Dreamweaver, but the actions should still
work when the page displays in a browser. Likewise, CSS and other Dynamic
HTML features created in GoLive do not always work well in Dreamweaver
unless you know how to edit the code manually. If your page contains any
actions or DTHML features, you may find re-creating the page in
Dreamweaver your best option.

Not long before the writing of this book, Adobe purchased Macromedia and
although, to date, no announcement has been made about changes to GoLive,
I imagine that both GoLive and Dreamweaver are likely to see changes in the
future that will either make them more compatible or make one of them obso-
lete. I’m betting on Dreamweaver, not only because I’m the author of this
book, but because it has the largest market share; but it’s hard to predict
what will happen to GoLive, which is also a strong Web design program.

Other HTML editors
In the early days of the Web, lots of different visual HTML editors were being
used. Today only a few major ones are left. The few that I discuss here seem
to capture most of the market. Still, you may find yourself inheriting sites
built in really old editors such as Claris HomePage, or Symantec VisualPage.
Each of these programs present fewer problems than either Frontpage or
GoLive because they aren’t capable of creating the complex, high-end fea-
tures that are hardest to migrate from one program to another.

For the most part, you can open any HTML page with Dreamweaver and con-
tinue developing it with little concern. If you run into problems, remember
that you always have the option of re-creating the page from scratch in
Dreamweaver — a sure way to get rid of any unwanted code. You may also
want to use the Dreamweaver Clean Up XHTML feature to identify poten-
tially problematic code. To use this feature, choose Commands➪Clean Up
XHTML and then select the elements you want to alter in the Clean Up 
HTML dialog box.

No matter what program your site is originally created in, as you consider
how best to convert your work into Dreamweaver, pay special attention to
unusual code output, nonstandard rules about HTML tags and syntax, and
sophisticated features such as CSS, Dynamic HTML, and sophisticated pro-
gramming, such as ASP, Java, or CGI scripts. These Web page elements are
most likely to cause problems when you import them into Dreamweaver.
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