
Unraveling the
Knoppix Toolkit
Maze

Linux is famous as an operating system that includes almost everything a
software user could ever want right out of the box — and for free. The
Knoppix developers had quite a time deciding which of the thousands of

packages to include, but they did their homework, made their decisions, and
you’re the one who benefits. This chapter can’t cover everything that comes on
the Knoppix disk — that would be a book in itself! — but it does take a look
at important apps such as K3b and the GIMP that you’ll probably find your-
self using at one time or another.

If you don’t know how to boot Knoppix, you’ll want to learn
before you go much further. Head to Appendix A, “Booting
Knoppix,” for complete instructions. You have to be running
Knoppix to really learn from this book.

Beautifying Knoppix
Out of the box, Knoppix has what could be called “uglification issues.” It just
ain’t as pretty and user-friendly as it could be. One of the first things you may
want to do when you start up Knoppix is make it look a bit nicer, so that using
it won’t cause you to constantly grit your teeth at the old, jagged, ugly fonts.

Then, after making your changes, you want to make sure you save your choices
so that when you next boot Knoppix, you won’t have to reconfigure the appear-
ance of the OS again. That’s covered in depth in the Introduction, but if you
somehow skipped over it, for now just select Knoppix➔Configure➔Save
Knoppix, choose a hard drive or USB flash drive to save onto, and then choose
that source the next time you boot Knoppix.

˛ Making Knoppix
look nicer

˛ Setting up printers

˛ Enjoying multimedia

˛ Burning CDs with
K3b

˛ Using text editors

˛ Working with office
software
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4 Part I — Navigating the Amazing Knoppix Toolkit

Replacing System Fonts
The default fonts are definitely ugly. Blech! We think the best solution is to download and
install the Microsoft Web fonts, which are attractive and common. However, if you’re not using
the persistent home directory, you’re going to have a problem. You’ll be able to install the fonts,
but when you restart Knoppix, you’ll have to reinstall all the fonts again, because all of your work
will have been blown away. With the persistent Knoppix disk image, all of your work is saved, so
you can count on your newly installed fonts being there.

To install the Microsoft Web fonts, use KPackage, the KDE software installation tool; it’s a front
end to Debian’s APT (Advanced Package Tool). From the Knoppix menu, choose Utilities ➔

Manage Software in Knoppix to start KPackage. When KPackage opens, select the All tab, as
shown in Figure 1-1.

FIGURE 1-1: KPackage makes it relatively easy to install and manage software.

Then follow these steps:

1. In KPackage, select Special ➔APT:Debian➔Update. APT downloads a list of the software
available in the APT repositories Knoppix knows about. This can take a few minutes, so just
relax.

05_597841 ch01.qxp  11/22/05  7:10 PM  Page 4



5Chapter 1 — Unraveling the Knoppix Toolkit Maze

Don’t know what APT is or how to use it? The author of this chapter has prepared “Updating
Your Computer with Debian’s APT,” a presentation for his Linux students that covers the basics,
which you can download from www.granneman.com/presentations. (It’s available
under a Creative Commons license). Alternatively, read the official Debian documentation, APT
HOWTO, at www.debian.org/doc/manuals/apt-howto/index.en.html.

2. When the APT update completes, go to the All tab and select File ➔ Find Package.
Enter the package name, msttcorefonts, as the search term, and click Find.

3. After KPackage finds the package, close the Find Package window and click the Install
button at the bottom of the right pane.

4. An Install window opens. Click the Install button at the bottom. (Yes, this is kind of silly,
which is why I prefer to use the command line instead of KPackage for installing soft-
ware. Using the command line is discussed later in this chapter.) Finally, KPackage begins
to actually download and install the software you want onto your system.

5. When it’s finished, close KPackage.

If you’re curious, the Microsoft fonts have been placed into /usr/share/fonts/truetype/
msttcorefonts.

However, you can’t start using your newly installed fonts just yet. You need to restart X, and for-
tunately that’s pretty straightforward (unlike using KPackage). From the Knoppix menu, select
Logout ➔ End Current Session. After X restarts, you need to log back in, and now you can
finally start making intelligent font choices!

Remember that if you’re not using the persistent Knoppix disk image, when you reboot, you’re
going to have to repeat this entire process, again and again, in a Sisyphean task that will never
end. Set up and use the persistent Knoppix disk image!

Now assign some nice new fonts in appropriate places on your system. Keep in mind that this
chapter walks through only the major apps on Knoppix, so you’re on your own to change fonts
on any other apps you use that aren’t covered here.

First, fix KDE itself. From the Knoppix menu, select Control Center, expand Appearance &
Themes, and select Fonts. The Fonts Control Center displays, as shown in Figure 1-2.
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6 Part I — Navigating the Amazing Knoppix Toolkit

FIGURE 1-2: Changing fonts in the KDE Fonts Control Center

Ugh, what terrible defaults! Lucida typewriter is ugly, Helvetica is so 1960s, and Smooth is any-
thing but. To pick something better, click Adjust All Fonts; then, in the Select Font window, check
the box next to Font. Find and choose either Bitstream Vera Sans or Arial (I prefer Bitstream Vera
Sans). Notice, however, that the Fixed Width font does not change. To fix that one, click Choose
next to Fixed Width and then select Andale Mono, which is a great monospace font. Click Apply
at the bottom of the Fonts screen, and you should immediately see your new fonts in action. Close
the Control Center.

Next, open the Konqueror file manager (the Personal Files icon on the panel that looks like a
house), and select Settings ➔ Configure Konqueror. The Configure window opens, as shown in
Figure 1-3.

Once again, Helvetica is the default. Change it to Bitstream Vera Sans or Arial or another font
that you like better. Don’t click OK yet; while this window is open, you also can fix the fonts
Konqueror uses when it’s acting as a Web browser.

Change the value for Height for Icon Text to 10 lines (the default is 1), so that it’s easier to read.

Scroll down the left-hand list of icons until you get to Fonts, shown in Figure 1-4.
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7Chapter 1 — Unraveling the Knoppix Toolkit Maze

FIGURE 1-3: Changing the fonts for the Konqueror file manager

FIGURE 1-4: Changing the fonts Konqueror uses when it displays 
Web pages
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8 Part I — Navigating the Amazing Knoppix Toolkit

Change the fonts on that screen to ones that you like better. The following are our 
recommendations:

� Standard font: Verdana or Bitstream Vera Sans

� Fixed font: Andale Mono (if you have it on your system, it’s much better than anything
in the Courier family)

� Serif font: Bitstream Vera Serif or Times New Roman (use Times New Roman only if
you must; Bitstream Vera Serif is far easier to read)

� Sans serif font: Verdana or Bitstream Vera Sans

� Cursive font: Lucida Calligraphy, Lucida Handwriting, and Bradley Hand ITC are great,
but none of those is available, so choose Arioso.

� Fantasy font: Comic Sans MS isn’t bad (you’re hardly ever going to need this font), but
you can pick anything goofy.

Click OK to make the changes and close this window. You can close Konqueror if you’d like.
Now that you’ve changed your system fonts, move on to program fonts.

Changing Application Fonts
You’ll probably find yourself using Mozilla Firefox, KMail, and OpenOffice.org often. You can
change their fonts to make these programs more usable, too.

Fixing Firefox Fonts
To set up Firefox’s fonts, click the Mozilla icon on the panel (yes, it should be the Firefox icon,
but it isn’t), and then choose Edit ➔ Preferences, click the General icon, and select Fonts &
Colors (see Figure 1-5).

Make these changes:

� Proportional: Sans Serif

� Serif: Bitstream Vera Serif or Times New Roman

� Sans serif: Bitstream Vera Sans or Verdana

� Monospace: Andale Mono

Click OK and then OK again to close the Fonts & Colors window. Now isn’t that a lot better?

Replacing KMail Fonts
Open KMail from the K menu by selecting Internet ➔ KMail. Choose Settings ➔ Configure
KMail, and then click the Appearance icon on the left. You’ll see the Fonts tab shown in 
Figure 1-6.
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9Chapter 1 — Unraveling the Knoppix Toolkit Maze

FIGURE 1-5: Changing Firefox’s font options

FIGURE 1-6: Change the fonts that KMail uses
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10 Part I — Navigating the Amazing Knoppix Toolkit

If you check the Use Custom Fonts box, the options in the main part of the screen are
“ungrayed.” Choose an item from the Apply To drop-down list, and select a font for it; then
choose another item from the list, make a font choice, and so on, until all of them have been
changed. At that point, click OK, and your new font choices will be applied to KMail.

You can choose any fonts you want, of course. We would change everything except Fixed Width
font to Bitstream Vera Sans, Verdana, or Arial — basically, something that’s pleasant and read-
able. For Fixed Width font, try Andale Mono if you have it or Bitstream Vera Sans Mono if you
don’t. Click OK to close KMail’s configuration window, and you’re good to go.

We recommend changing Composer to Andale Mono to stick to plain text for email, which
means a monospaced font.

Switching OpenOffice.org Fonts
Whatever you do, do not open OpenOffice.org (OOo) and expect to configure the fonts. Oh, no.
It’s not that simple. Instead, from the K menu, select OpenOffice.org 1.1.4 ➔ OpenOffice.org
1.1.4 Printer Administration (see Figure 1-7).

FIGURE 1-7: Isn’t it obvious that you should configure fonts 
when you configure printers? No? We don’t think so, either.

Click the Fonts button to open the Fonts window. Then click Add, which opens the Add Fonts
window. Click the button labeled “...” in the Source directory area of the window, navigate to
/usr/share/fonts/truetype/msttcorefonts, and click Select. Back in the Add Fonts
window, check the Create Soft Links Only box, and then click Select All, followed by OK. You
are told that many new fonts were added, so click OK to close that window. Click Close to get
rid of the Fonts window, and then click Close again to finally exit Printer Administration.
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11Chapter 1 — Unraveling the Knoppix Toolkit Maze

If it’s any consolation, this process is much improved in the OpenOffice.org 2.0 release, which is
still in beta at the time of this writing. You’ll see it in a future release of Knoppix.

To start OOo, click on the program’s icon (the one with the birdies) on the panel. After OOo
opens (and it’ll take a while!), select Tools ➔ Options, click on the + next to Text Document to
expand it, and finally select Basic Fonts (Western).

Because you first added all of the Microsoft fonts, OOo (in an effort to achieve maximum com-
patibility with all the drones using Microsoft Word) changes everything except Heading to
Times New Roman, and changes Heading to Arial. Now you’re just like the rest of the world.

Setting Up Printers
Once upon a time, an old IT pro was counseling some new IT youngsters gathered around him.
He was speaking sagely about keeping your “clients” happy, when someone asked him, “Master,
what’s the number one thing we can do to keep our computer users from calling us, complain-
ing?” His answer? “Here it is, grasshopper: Make sure they can print. Not being able to print
causes angry calls faster than anything else.”

Now, that was before the advent of the Internet into popular consciousness, so his answer might
be a bit different today, with network access being the new number one concern. Even so, print-
ing would still come in a close second. People get very cranky when they can’t print, with good
reason: Much as we’d like to believe that we live in the age of the paperless office, experience has
proved otherwise.

Fortunately, Knoppix makes it pretty easy to set up printers. Of course, if your printer doesn’t
work under Linux (Samsung, for example), Knoppix ain’t gonna fix that, but if you’re trying to
use a printer that’s supported under Linux, then you should be able to use it with your Knoppix
Live CD.

To get started, from the Knoppix menu, choose Configure ➔ Configure printer(s). Knoppix
opens the KDE printer configuration tool, shown in Figure 1-8.

KDE’s print system uses CUPS (the Common Unix Printing System) by default, and installs sev-
eral so-called pseudo printers by default, including Print to File (PDF), Print to File (PostScript),
Send to Fax, and Mail PDF File. All are very cool, and all work well (of course, to fax, you need a
working modem).
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12 Part I — Navigating the Amazing Knoppix Toolkit

FIGURE 1-8: The KDE (and Knoppix) printer config utility

In addition to pseudo printers, you can add plain ol’ real printers as well. To do so, choose Add➔

Add Printer/Class. The KDE Printer Wizard opens, and you just walk through the necessary steps
to get things set up and working. For example, here’s how to connect an HP LaserJet 6L to a
Xandros Linux machine shared through Samba:

1. Introduction: Click Next.

2. Backend Selection: Choose SMB shared printer (Windows). Click Next.

3. User Identification: Choose Normal Account and enter a Login and Password for the
Xandros box. Click Next.

4. SMB Printer Settings: Enter the SMB Workgroup name (MILTON, in this example),
the SMB Server name (Cromwell, in this example), and the share name of the Printer
(hplj6l, in this example). Click Next.

5. Printer Model Selection: Select HP as the Manufacturer and LaserJet 6L as the Model.
Click Next.

6. Driver Selection: Select HP LaserJet 6L (foomatic + hpijs) [recommended] as the best
driver among six options. Click Next.

7. Printer Test: Skip until the process has completed because it rarely works for some rea-
son. Click Next.

8. Banner Selection: Leave No Banner selected. Click Next.
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13Chapter 1 — Unraveling the Knoppix Toolkit Maze

9. Printer Quota Settings: The default (no quota) is fine. Click Next.

10. Users Access Settings: The default enables anyone using this Knoppix computer to print,
which is fine. Click Next.

11. General Information: Name is required, so type in something short that identifies the
printer, such as hplj6l. Fill in Location and Description if you feel like it. Click Next.

12. Confirmation: Look things over. Click Finish.

And now there’s a new printer you can use in Knoppix! To test it, select the printer, right-click
on it, choose Test Printer, and click Print Test Page. In a moment or two, a test page should
appear in your printer.

If the test page is borked and doesn’t look right, try changing your driver: Click on the printer to
select it, choose the Properties tab in the bottom half of the window, and click the Driver but-
ton. Click the Change button, and try a different driver. Lather, rinse, and repeat as needed until
your printer works.

If you can’t find your printer in the list of supported devices, or things just aren’t working, head 
to the Linux printing mother lode at LinuxPrinting.org, found, surprisingly enough, at www.
linuxprinting.org. If you can’t find the info you need at that Website, it’s time to get a
new printer.

Here’s how you can improve printing in Mozilla (and Firefox, if you install that program using
Klik). Open Mozilla, go to a page you’d like to print, and select File ➔ Print. Notice that Mozilla
prints only to the default printer. If you only have one printer, this isn’t a big deal, but if you use
a laptop that connects to several printers, this can be a pain. Conversely, look at how KDE
applications print. All KDE apps pass along the print request to Kprinter, which, as you’ve seen,
is a really nice front end for printing. You can choose any of the printers you’ve defined already,
or print directly to Postscript or PDF, or print to PDF and have KMail email the resulting PDF,
and many other neat options.

In Mozilla’s Print dialog box, click the Properties button. In the Printer Properties dialog box,
change the Print Command from lpr ${MOZ_PRINTER_NAME:+’-P’}${MOZ_PRINTER_
NAME} to kprinter --stdin. Click OK to close the Printer Properties dialog box, and then
click Print to close the Print dialog box. You’ll see Mozilla printing, but then Mozilla passes the
job along to Kprinter and the KDE Print dialog opens. Make the appropriate choices and click
Print. In essence, you’re telling Mozilla to pass the print job along to Kprinter, which makes
things far handier.

You can pretty much use this trick with any program that doesn’t use KDE’s print system. Just
find where you can specify the printer and enter kprinter --stdin. Test it to make sure
things work, and enjoy your slick printing system.

There’s one exception (isn’t there always?): Adobe Acrobat Reader. To set it up, open Acrobat
Reader from the K menu by selecting Multimedia ➔ Viewers ➔ Acrobat Reader. Once it’s run-
ning, open a PDF (you might need to download one first; to find one, search Google for “file-
type:pdf knoppix”, which should produce oodles of them) and click Print. In the Printer
Command box, enter kprinter without the --stdin. And remember — you only need to do
this for non-KDE apps.
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14 Part I — Navigating the Amazing Knoppix Toolkit

Enjoying Multimedia
Multimedia makes computing fun, whether it’s music, video, images, or any combination of
these. While it’s doubtful that you’ll ever use Knoppix as a true multimedia box acting as the
hub of your digital life, it’s still really cool that this Live CD comes with software that you can
use to enjoy your multimedia files. Let’s walk through the highlights of the software, taking brief
looks at some of the best multimedia on any OS, not just Linux.

Listening to Sound
Noise. Notes. Speech. Lines from a movie. Verses from a song. With Knoppix, you can hear it
all . . . and change it as well.

Listening to Music with XMMS
Linux users have a huge variety of audio players from which to choose, with more coming out
every day, but Knoppix includes an old standby that many people still use and rely upon:
XMMS, the X Multimedia System.

Open XMMS from the K menu by selecting Multimedia ➔ XMMS. To use XMMS effectively,
you need to be able to see it, and by default the interface is built for folks with perfect eyes who
are also looking at the program through powerful electron microscopes. Right-click on a blank
area of the program and select Options ➔ DoubleSize. That’s much better! Once you master
XMMS and its interface, you can go back to the regular size, but for now, use the enlarged view.

Besides the main XMMS window, you really need to display the Playlist Editor window, so click
the PL button (or right-click on the program and choose Playlist Editor). The Playlist Editor
window opens, docked to XMMS. Resize the playlist by grabbing the bottom right corner 
and dragging it so that it’s bigger. That makes it easier to see the songs that you have queued.
Figure 1-9 shows XMMS with a docked Playlist Editor.

FIGURE 1-9: XMMS is simple and effective.
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XMMS plays tunes in a wide variety of formats, including MP3, OGG (a patent-free alterna-
tive to MP3 — and it sounds better, too!), WAV, and CD audio (in fact, XMMS plays videos in
the MPEG format as well). You can add songs to the XMMS playlist by clicking on the +FILE
icon, which opens a Load Files dialog box. Navigate to your music, find the files you want to
hear, select them, close the dialog, and click the Play button in XMMS. Assuming that your
sound card is supported, you should hear your music.

Here’s another way to add music to your playlist: Open the Konqueror file manager, navigate to
your songs, select the ones you want to hear, and drag them onto the XMMS playlist. Much
easier, especially if you always have Konqueror open to manage files.

XMMS isn’t a complicated program. If you’ve ever used any audio player on a computer, you’ll
probably figure out XMMS pretty quickly. If you get stuck, or you just want to learn more about
XMMS, as well as download skins and plug-ins, visit the project’s home page at www.xmms.org.

Editing Sound Files with Audacity
Audacity is a free audio recorder and editor that can import digital audio files, manipulate them
in an astonishing variety of ways, and then export them. Before you can use Audacity, though,
you need a sound file to edit. The sidebar “Converting MP3s to WAVs” explains how you can
acquire a sound file.

Once you have a sound file, open Audacity (see Figure 1-10) from the K menu by selecting
Multimedia ➔ Audacity.

FIGURE 1-10: Audacity, when you first open it
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Converting MP3s to WAVs

At IT Conversations (www.itconversations.com), you can listen to streaming audio of inter-
views and talks by some of the leading thinkers in technology. Streaming audio is cool, but we
prefer to have files on our machine for convenience; fortunately, IT Conversations also makes
everything available as a download in MP3 format. You can download a bunch of MP3 files, but
some of us can’t listen to someone talk while we try to write and work!

You can, however, convert the MP3s into CD audio, so you can listen to the interviews and talks
while you’re driving around in your car (if the CD player in your car handles MP3s, you can skip
this section). To convert the MP3s into WAVs, run the following script, which you can name
mp32wav and place in your ~/bin directory:

for i in *.[mM][pP]3 ; do

# convert uppercase to lowercase & space to underscore

name=$(echo $i | tr ‘[A-Z ]’ ‘[a-z_]’)

# replace .mp3 with .wav

name=${name//.mp3/.wav}

# convert mp3 to wav

mp3-decoder $i --wav $name

done

WAV files are a lot bigger than MP3 files, so make sure you have enough space on your
hard drive. A rough rule of thumb is that every 1MB of an MP3 will turn into 10MB of a
WAV. Knoppix uses your RAM as its “hard drive,” and you may quickly use it up if you’re
not careful. Run df -h to see how much space you have available on your /ramdisk. If
you don’t have a lot of RAM, check how much is available on one of your “real” hard
drives. If you see that you have space on a “real” hard drive, mount it with write access
(right-click on the icon on the Knoppix desktop, select Properties, go to the Device tab,
uncheck Read only, and mount the drive).

At the end of the process, you should have several WAV files that you could burn to a CD-R/W to
listen to in your car (to find out how to burn them, see the “Burning CDs with K3b” section later in
this chapter). Keep an eye on your available space, though. When we tried to burn the WAV for
Professor Clayton Christensen’s “Capturing the Upside” (available from www.itconversations.
com/shows/detail135.html), however, it was too big—in fact, at 1 hour and 48 minutes, his
talk would take almost two CDs!

05_597841 ch01.qxp  11/22/05  7:10 PM  Page 16



17Chapter 1 — Unraveling the Knoppix Toolkit Maze

If you get an error message when you first open Audacity informing you Error Initializing
Audio: There was an error initializing the audio i/o layer. You will not be
able to play or record audio. Error: Host error, another program is using your sound
card. Are you listening to music with XMMS? Close it! Are your system alert sounds beeping and
booping? Turn them off (from the K menu, select Control Center ➔ Sound & Multimedia ➔ System
Notifications, check the box next to Apply To All Applications, and click Turn Off All Sounds)! For
more help on this issue, see www.audacityteam.org/wiki/index.pl?LinuxIssues.

With Audacity running, open your sound file. (We opened clayton_christensen_-
_capturing_the_upside.wav by selecting File ➔ Open and navigating to the file.)
Audacity imports the file — slowly, because it’s a big one — and displays it as shown in 
Figure 1-11.

FIGURE 1-11: Audacity with a WAV file, open and ready to edit

The entire file is visible, with the waveform showing the progress of the audio. For this example,
we want to break the file roughly in half, say around the first hour mark, at a nice pause (and not
just cut Prof. Christensen off in the middle of a sentence). Click somewhere near the hour mark
and then click the Play button. When you hear what sounds like a good place to stop, click the
Pause button, hold down the Shift key, and press and hold the left arrow key until the cursor
gets all the way back to the beginning of the WAV file. (You can use the mouse, although it does
have a tendency to slip and you end up cutting off the speaker in the middle of a thought.) Be
sure to click the Stop button in Audacity before continuing or you won’t be able to use the Edit
menu. With the first hour selected, choose Edit ➔ Cut, immediately choose File ➔ New, and, in
the new window, choose Edit ➔ Paste.
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If the new waveform doesn’t look like it did just a few seconds before, that’s because Audacity has
spread this new one out — if you scroll to the right, you can see the whole file. To return to the
previous view, go to View ➔ Fit in Window, and everything is scrunched together again.

To save the new WAV file, select File ➔ Export As WAV, navigate to the location where you
want to save the file, and enter an appropriate filename; for this example, that might be 
clayton_christensen_-_capturing_the_upside_1.wav (remember that it was
taken from the beginning of the original file, so it’s now part one).

Close this file and go back to the original. Once again, select File ➔ Export As WAV, navigate,
and save the file as clayton_christensen_-_capturing_the_upside_2.wav
(because it’s the second half of the original file). The original WAV file isn’t needed any longer,
so you can delete it to reclaim that disk space.

Now there are two files of CD-burnable length; you can burn them both using K3b (discussed
later in this chapter) and enjoy Prof. Christensen’s brilliant observations in your car during those
long road trips. That’s just one of the many, many things possible with Audacity. To use the pro-
gram to the maximum of its capabilities, you really need to investigate Audacity further. You can
start with a visit to Audacity’s home page at http://audacity.sourceforge.net, and
then move on to a Google search for “audacity tutorial.” You’ll find a lot of great stuff.

Viewing Images
Who doesn’t like importing and viewing pictures of their friends? And then using software to
distort their friends’ heads so they look like yumpkin-headed freaks before emailing the results
to other friends? Yes, Knoppix makes it all possible. In fact, that’s its new motto: “Knoppix:
Making Yumpkin-Heads Possible for Years.” OK, that part’s a silly joke — but the rest is true.
Honest!

Using Kuickshow
When it’s time to view pictures, you’re looking for three things: speed, wide compatibility with a
variety of image formats, and the capability to automatically resize an image when it’s larger than
the monitor. Knoppix comes with Kuickshow (see Figure 1-12), a program that nicely meets
those three goals. Open Kuickshow from the K menu by selecting Graphics➔ Kuickshow:

Theoretically, once Kuickshow is open, you choose File ➔ Open and navigate to the image you
want to see, select it, and then view it in Kuickshow. In reality, many folks use the Konqueror file
manager to navigate to the image they want, right-click it, and select Open With ➔ Kuickshow.
Kuickshow opens, displaying the image. If you want to view other images in the directory, the
quickest way is to press PgDn/Page Down on your keyboard to view the next image, and PgUp/
Page Up to view the previous image.

There aren’t any menus visible in Kuickshow, because it’s kind of a bare-bones app. You can,
however, make a few changes to the image you’re viewing in Kuickshow. To see your options,
right-click the image and take a look at the contextual menu (shown in Figure 1-13).
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FIGURE 1-12: Kuickshow, open and ready to display 
pictures

FIGURE 1-13: The Kuickshow contextual 
menu offers many options.

Everything is pretty self-explanatory in this menu, so it’s easy to use. Don’t forget that it’s avail-
able at any time with a simple right-click.

Editing Images with GIMP
Think of the GIMP (the GNU Image Manipulation Program) as an attempt to create an open-
source PhotoShop. Now, it’s not there yet . . . but it’s getting better all the time, and it’s probably
good enough for the needs of at least 90 percent of users. Certainly, if you’re using Knoppix to
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perform some quick ‘n’ dirty work, you’ll find that the GIMP is probably just right. You’ll also
find that it’s a big, complicated program, worthy of a book on its own. There is no way to cover
even a fraction of the GIMP’s capabilities here, but we’ll point out a couple of things to whet
your interest in this fascinating addition to Knoppix.

From the K menu, select Graphics ➔ GIMP Image Editor and then open an image from within
the program, right-click an image, and choose Open With. Unfortunately, KDE in Knoppix
isn’t set to include the GIMP by default in the list of Open With programs, so you need to add
it. Here’s how: Select Open With ➔ Other. The Open With window appears. Click the + next
to Graphics to expand it, and then choose GIMP Image Editor. Before you click OK, check the
box next to Remember Application Association for This Type of File if you plan to use the
GIMP quite a bit.

GIMP displays an image much like what’s shown in Figure 1-14. (This particular image is of
Libby, a wonderful dog of one of the authors, back when she was a puppy.)

FIGURE 1-14: The GIMP, ready to edit an image of a really cute little dog

Three windows are open. From left to right, they are the main toolbox, which contains the basic
tools you use to work on your images; the image window, containing the picture you’re manipu-
lating; and a window containing several panels joined together, including Layers, Channels,
Paths, Brushes, Patterns, and Gradients (let’s call it the dialog window). Notice the menus — the
main toolbox has the highest-level menus that govern the image in general, the image window
contains all the goodies that enable you to change the image in an almost bewildering variety of
ways, while the dialog window lacks menus, which is just fine.

If you know PhotoShop or Fireworks or any other image-manipulation program, then dive into
the GIMP and start discovering where it has placed the equivalents to the commands you know.
Don’t expect to find everything — as mentioned earlier, the GIMP isn’t yet up to the capabilities
of the proprietary programs, but it’s gaining fast.
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If your experience with image manipulation is neither deep nor broad), check out the GIMP’s
Website (www.gimp.org) for documentation and just start playing. Jump in with a picture on
which you can test techniques and see what happens.

Although most people end up using the GIMP simply to crop and resize images, here’s one cool
trick that shows you how powerful the program really is. The two most fun menus are Filters
and Script-Fu: Filters apply pre-made changes to your picture that alter how it looks, with
effects involving light, distortion, and colors; and Script-Fu enables developers to write scripts
that perform several actions on a photo, changing it in amazing ways, especially for those of us
who don’t really know what we’re doing. You can access one of our favorites by selecting 
Script-Fu ➔ Decor ➔ Old Photo. Use the dialog box that appears to make some selections and
then click OK. The result is truly cool. Figure 1-15 shows the Script-Fu’d picture of Libby,
which looks like it was taken around the turn of the century (not the most recent one).

FIGURE 1-15: That same really cute little dog, circa 1900

The changes are kind of hard to see in a book with grayscale images, so you just have to try it
out for yourself. There are a lot more where that came from — enough to make it possible even
for someone who isn’t a graphics expert to do some cool things, thanks to a great program, clever
programming, and some welcome hand-holding. Acquaint yourself at least a little bit with the
GIMP: It’s the open-source gold standard for image manipulation.
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For more information on the GIMP, check out the program’s Website at www.gimp.org. Users
have written a lot about the GIMP online; search Google and you’re sure to find much more
information about virtually every aspect of the app.

Manipulating Graphics via the Command Line with ImageMagick
The GIMP is a great program, but it’s a GUI app. If you want speed or scriptability, turn to
ImageMagick, a command-line program that is amazingly comprehensive and powerful.

man imagemagick tells you just about everything you can do with the program. There’s a lot
there, and it bears your careful reading. For more info, see the program’s Website, at www.
imagemagick.org.

Let’s look at a couple of ways that you can use ImageMagick. It is hoped that these will start to
give you some ideas that will inspire you to do far cooler things (if you develop something, share
it with us — we’re always looking to add new tricks to our toolbox).

Here’s an example. In preparing this book, we took a lot of screenshots. We could use KDE’s
screen capture utility, KSnapshot (available from the K menu by selecting Graphics ➔ More
Applications ➔ KSnapshot), but it doesn’t save files in TIFF format, which is what our publish-
ers want. So we used ImageMagick and the following six lines, inserted at the bottom of the
.bashrc file in /home/knoppix:

# take screenshot of chosen window, incl. kde frame
alias window=’sleep 3; import -depth 8 -frame window.tif’
# take screenshot of selected area
alias selection=’sleep 3; import -depth 8 selection.tif’
# take screenshot of entire screen
alias screenshot=’sleep 3; import -depth 8 -window root
screen.tif’

After adding these lines to .bashrc, don’t forget to run source ~/.bashrc so you can
immediately begin using your new commands.

The sleep 3 command gives you three seconds to get things set up before the screenshot is
taken; if you need more (or less) time, change the number. The import command, part of
ImageMagick, does the real work. It grabs an image of the window, a selection of the screen that
you specify by clicking and dragging a box, or the entire screen, depending on the name of the
file at the end of the command. If you don’t want the image to be a TIFF, change the extension
to .jpg, .gif, or whatever else you’d like.

We used -depth 8 in the command because if you don’t, ImageMagick takes a 16-bit TIFF
image, which causes the GIMP and other image programs in Knoppix to complain. If you’re not
saving the image as a TIFF, remove the depth option.
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Here’s another way you can use ImageMagick: to convert a lot of images from one format to
another. If you have a folder full of TIFFs that you want to convert to JPGs, for example, cd to
the directory containing the images and run the following:

for i in *.tif ; do convert “$i” “${i%.tif}.jpg” ; rm $i ; done

This is a for loop that works on every TIFF in the directory. It converts the file from a TIFF to
a JPEG, and removes the original TIFF image to keep things neat and clean. Don’t want the
original file removed? Then get rid of rm $i ; and the original TIFF will remain.

If you’ll be using this command a lot, turn it into an alias. If you want the freedom to use differ-
ent image formats on the fly, create an executable file, named converting or something like
that, in your ~/bin directory, place the following line in the file, and save it:

for i in *.$1 ; do convert “$i” “${i%.$1}.$2” ; rm $i ; done

Notice that you’re including variables now. To use your script, run the following command:

$ converting tif jpg

tif replaces $1, and jpg replaces $2 in the script. Want to convert a batch of PNGs to GIFs?
Use converting png gif instead, and so on.

The final ImageMagick example is one that one of us wrote one night to offer some digital pho-
tos on a Website for people to download and use as wallpaper. You can try it too: Gather 50 or
so images and begin opening each one in the GIMP, saving the original image in several differ-
ent common desktop dimensions, including 1024 × 768, 800 × 600, and 640 × 480. You might
also want a thumbnail image of about 200 × 150 so folks could have an idea of the image before
they start downloading it. You want the JPEGs to be of the highest quality, except for the
thumbnails, which don’t need to look as nice.

Manually changing multiple images is boring and tedious, so use the following script, which you
can place in a file named photoresize in the ~/bin directory:

for i in *.jpg ; do
width=$(identify “$i” | sed -re ‘s/^.* ([0-9]+)x[0-9]+ . ;
*$/\1/g’ )
i=”${i%.jpg}”
if test $width -eq 1600 ; then
for size in 1600x1200 1024x768 800x600 640x480 ; do
convert “$i.jpg” -resize $size -compress none -quality ;

100 “${i}_${size}.jpg”
done
size=200x150
convert “$i.jpg” -resize $size -compress JPEG -quality ;

75 “${i}_${size}.jpg”
fi
done

After making it executable with chmod 744 photoresize, the script ran perfectly. Most of
our images were 1600 × 1200, but not all. We needed some way to only work with the largest
images, and the identify command was it. Running identify sample.jpg gives you
information about the image that looks like this: sample.jpg JPEG 1600x1200
DirectClass 8-bit 641kb 0.0u 0:01. Now you know the dimensions, but if you only care
about the width, that’s where sed (stream editor, an old Unix command) comes in.
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Basically, sed and some regular expression work get the number that corresponds to the width
of the original image and write that number to the width variable.

For more on regular expressions, see Andrew Watt’s Beginning Regular Expressions at (www.
wrox.com/WileyCDA/WroxTitle/productCd-0764574892.html).

Now the script performs a test: Does the number in the width variable equal 1600? If not,
nothing happens, and the image is skipped. If it does match, the oh-so-versatile convert com-
mand kicks in and changes the dimensions of each image, while also using the highest quality
and no compression. Each file is renamed to include the dimensions in the filename to make
things clear.

Yes, convert can change more than just file types and dimensions. In fact, it can do a whole
lot more. man convert should be your next stop.

When the whole process is finished, you’ll have a nice collection of photographs in a variety of
common dimensions, ready for upload to a Website to be shared (under a Creative Commons
license!) with anyone. If you’d like to see one of the author’s, head to www.granneman.com/
personal/photos/. Every photo on those pages appears courtesy of ImageMagick.

Watching Video
Digital movies have been getting more and more popular over the last several years as the
Internet pipes coming into our homes and businesses have been getting larger and faster.
Although ultimately limited in a few key ways, Knoppix enables you to listen to and watch those
movies and videos.

Checking Out Video with xine
xine is hardly my favorite video player, for a simple reason: Its UI is pretty bad. Don’t get us
wrong: The underlying xine video engine is great, but the xine interface is almost baffling in its
complexity and lack of clues and feedback. Regardless, that’s what Knoppix includes, and so
that’s what we’ll peek at.

You can use APT to install other video players with better UIs. In particular, check out mplayer,
Kaffeine, or Totem.

Open xine from the K menu by selecting Multimedia ➔ Video ➔ xine media player, but you’ll
probably use it more often by right-clicking a video file and choosing Open With ➔ xine. Figure
1-16 shows a video file opened in xine.
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FIGURE 1-16: Xine, playing Thomas A. Edison’s “May Irwin 
Kiss” (1896)

To control playback, right-click the movie and use the items in the menu. Although xine is
pretty simple, it’s simply not very pretty to use.

Burning CDs with K3b
Here’s a common scenario: Someone’s computer won’t boot, and he’s just got to get his data off
that machine. As you’ll find out in Chapters 4 and 5, it’s really easy to take care of that problem
with Knoppix, a NIC, some Ethernet, and a network, but that’s not always possible. If the user
has a CD-R/W on that machine, though, you can still save his bacon by burning a CD. It’s not
tremendously hard to burn CD-RWs from the command line, but it’s easier to use a nice GUI,
and K3b is easily the best CD-burning GUI available for Linux, perhaps even on any platform.

Open K3b from the K menu by selecting Multimedia ➔ K3b. The first time you open it, K3b
asks you to confirm your burner’s write speeds. It probably defaults to 0, which is obviously of no
help, so bump it up to the correct speed and click OK.

This might be obvious, but K3b won’t work unless you have a CD-R/RW device installed on your
system, and Knoppix needs to have recognized it. To confirm that K3b sees your CD-R/W, open
K3b, select Settings ➔ Configure K3b, and choose the Devices button on the left. Your CD-R/W
should be listed. If it isn’t, click Add Device and help K3b try to find your burner. If you need
broader help getting your CD-R/RW hardware to work, take a look at the CD-Writing HOWTO
at www.tldp.org/HOWTO/CD-Writing-HOWTO.html.

Here’s something else you need to consider: You can’t burn a CD if Knoppix is taking up your only
CD-R/W drive! If you have two CD drives, you’re set: Boot Knoppix in one and use the other to
burn. If you only have one CD-R/W drive, you may need to install Knoppix on your hard drive
(see Appendix B) to free your CD drive for the burn (you can uninstall Knoppix after you’ve
checked your new CD).

05_597841 ch01.qxp  11/22/05  7:10 PM  Page 25



26 Part I — Navigating the Amazing Knoppix Toolkit

K3b is divided into two main areas: a file and folder navigation area in the top half of the win-
dow and a project view in the bottom half, as shown in Figure 1-17.

FIGURE 1-17: K3b’s main window

K3b makes it very easy to get started by providing buttons for the four most common tasks in
the project view. To burn a data CD for backup, choose New Data CD Project. The project view
area changes to Current Projects, as shown in Figure 1-18.

Using the top half of the window, navigate to the items you want to burn and begin dragging
them into the bottom half of the window. As you add items, the bar at the bottom of the win-
dow shows you how much space you’ve taken up on your CD and how much you have left.
Gone over the limit? Just select an item in the project and press your Delete key to remove it
from the burn. Once you’ve correctly specified the items you want to save onto a CD, click the
Burn button in the bottom right of the K3b window.

A new window opens up: Data Project. This is an extremely important window because it
enables you to tell K3b exactly how you want to burn your CD. You have several options here,
and selecting the wrong one can mean the difference between a successful backup and a shiny
hunk of plastic.

To lessen the chance that you’ll end up with a bad burn, this section covers the key changes you
need to make. There’s not enough space in the book to cover everything, but K3b has informa-
tive built-in help. If you’re unsure about an option, just click the What’s This button (the one
that looks like a question mark) in the upper-right corner of the window, and then select the
option in the window about which you’d like more information.
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FIGURE 1-18: Creating a Data CD Project in K3b

Setting Burn Speed
The first thing to set is the speed at which you’re going to burn your CD. Do this on the Data
Project window’s Writing tab (see Figure 1-19).

If you leave Speed set to Auto, K3b tries to burn at maximum speed. This may or may not work.
Experience has shown that it’s a good idea to burn at a slower speed to ensure that the burn is
not problematic, no matter what software you use. If you have the time and patience, 4x is slow
and steady and almost always works. Granted, it takes about 15 minutes or so to burn a full
700MB disc, but if you do something else while you’re burning, it’s not a big deal. If you’re not
that patient, start out fast, test your results, and be prepared to slow things down gradually, test-
ing after each burn until you find the optimum speed for your hardware and your media.

If you leave On the Fly selected, K3b does just that: write the files directly to the CD-R/W
without first creating an ISO image. If your hardware is fast enough, this should be no problem.
If your hardware is slow, however, or if you’re experiencing problems burning, check On the Fly;
K3b will first create an ISO image of your data, and then burn that ISO image to disc, a process
that takes longer but is more likely to result in a good burn. If you uncheck On the Fly, Remove
Image is no longer grayed out; however, you should probably leave Remove Image checked so
that K3b erases the ISO it created once it has successfully burned it to disc, thus reclaiming your
storage for Knoppix.
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FIGURE 1-19: The Writing tab of the K3b Data Project window

Remember that Knoppix is using your RAM as its hard drive, so you may not be able to write
an ISO image unless you have enough RAM to hold it. To find out how much space you’ve 
got, run the df -h command in Konsole and note how much free space is available on the
/ramdisk row. If you don’t have enough room, check how much is available on one of your
mounted hard drives. If there’s space, mount the hard drive with write access (right-click on the
icon on the Knoppix desktop, select Properties, open the Device tab, uncheck Read Only, and
mount the drive). One last step: Tell K3b that you want it to use your hard drive to hold the
ISO by changing the path for Write Image File To (which is no longer grayed out once you
uncheck On the Fly on the Writing tab) so that it points to your newly mounted writable hard
drive. Yes, it’s a lot of work, but that’s what happens when you’re using a Live CD.

It’s generally a good idea to select Verify Written Data (the final option on the Writing tab),
which compares what was burned to the original data, thereby letting you know if something
didn’t work correctly.

Burning in Sessions
You need to change the settings on the Data Project’s Settings tab (see Figure 1-20) only if you
plan to add content to your CD over several different burning sessions.
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FIGURE 1-20: Setting the kind of session you’re using in K3b

Most of the time, you’ll probably fill a CD completely, so you want the default: No Multisession.
If you’re going to use several different sessions, you don’t want K3b to “close” the disc until you’re
finished. To do this correctly, use Start Multisession for the first burn, Continue Multisession for
the next burns except the last one, and then complete your CD-R/W with Finish Multisession,
which tells K3b that it’s all right to close the disc. You’ll use the default No Multisession most
often, but it’s good to know how to create a multiple-session CD if you need one.

Keeping Yourself Informed
The Volume Desc tab is shown in Figure 1-21.

None of the information on the Volume Desc tab prevents a successful burn, but you’ll probably
want to spend a moment here just so things are organized and clear. In other words, this tab
really isn’t for the computer — it’s for the human user. Fill things out as you see fit.

Understanding Filesystems
The Data Project’s Filesystem tab (see Figure 1-22) is very important, especially if you want to
make sure that your disc can be used on both Linux and other operating systems. For backups,
this is an essential consideration. If you never have to touch a Windows machine, this tab may
not be as significant to you, although there are still things here that you will probably want to set.
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FIGURE 1-21: Describing the disc you’re burning in K3b

FIGURE 1-22: Tell K3b what kind of filesystem you want to place on your 
new CD.
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Checking the boxes in the File Systems section is key if you’re after cross-platform compatibil-
ity. There’s a wide variety of standards for CDs, and in typical fashion in the computer world,
they don’t always agree. For instance, when you burn a CD, you can stick to ISO9660 standards,
but all filenames must be in all capital letters, and they have to be a maximum of eight charac-
ters, plus the period and the extension. DOS, anyone? You can also use the Rock Ridge exten-
sions, which enable UNIX systems (including Linux and Mac OS X) to read CDs that contain
files with names of up to 255 characters, as well as support UNIX-like things such as owners,
groups, permissions, and symbolic links. However, Windows does not support Rock Ridge
(worth $50 billion and with 30,000 employees, Microsoft can’t support Rock Ridge?), so don’t
use it as your only filesystem if you want to access your data on that operating system.

If you want to make sure that Windows users can read the content of your discs, enable Joliet
extensions, which support up to 64 characters in filenames (although there’s a way around this,
as you’ll shortly see). Users of Linux and Mac OS X can also read CDs that use Joliet, but Mac
OS 9 and earlier will truncate filenames at 31 characters, a major limitation of pre-OS X Macs.

UDF, which stands for Universal Disk Format, is used mainly for DVDs, but CD-R/Ws can
also use it. It allows for 127-character filenames, including spaces. The idea is that you can write
to CDs and DVDs just like you write to floppies, USB drives, or hard drives: just drag and drop.
For UDF to work, though, you need very recent hardware and special drivers if you’re using
Windows or Mac OS (most Linux distros now include support for UDF-based discs). If you’re
shooting for wide compatibility, you probably should avoid UDF at this time.

With an understanding of these different filesystems, the options on the Filesystem tab start to
make more sense, don’t they? If your disc is only going to be used on Linux machines (or Linux
and Mac OS X), check Generate Rock Ridge Extensions. If you use Rock Ridge but you don’t
want symbolic (or “soft”) links included on your burn, check Discard All Symlinks. If you are
concerned about including soft links, but you want to make sure that you don’t accidentally
include links to files that aren’t included in your burn project, make sure that you check Discard
Broken Symlinks.

In addition, remember that if you’re using Rock Ridge, you can tell K3b to include information
about file permissions along with the burn. To do this, check Preserve File Permissions
(Backup). As the name implies, this creates an exact backup of your files — not just the data, but
also the meta-information about who owns it and what they can do with it.

If you want to include Windows machines in your burn, check both Generate Rock Ridge
Extensions and Generate Joliet Extensions. Your Linux machines will see files of up to 255
characters, while Windows will see files truncated to 64 characters . . . unless you check a box on
the next tab, which we’ll get to in just a moment.

The options in the Whitespace Treatment area of the window can be useful if you want to get
rid of spaces in the filenames on your disc. No change does just that — files that have spaces in
their names still do. Nowadays, this isn’t really a problem for Linux boxes, so we just usually
leave K3b set to that.

Over the years, the standards for burning CDs have morphed in many different directions.
Fortunately, most modern hardware and modern operating systems support most of these add-
ons and extensions, but it’s still a good policy to test all burned CDs on the various CD readers
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that you plan to use before you rely on those discs! It would be a shame to make backups of your
vital data onto CD, intending to transfer the data to a different machine, only to find out after
you’ve repurposed the original box that the different computer can’t read your discs. Testing is
always worth the time it takes.

Fine-Tuning CD-R/W Filesystems
The Data Project’s Advanced tab (see Figure 1-23) enables you to make changes to the basic
CD-R/W filesystems.

FIGURE 1-23: You can change the basic CD-R/W filesystems in K3b.

Getting beyond the 64-character limit for the Joliet extension was mentioned earlier. Here’s how
to do it: Check Allow 103 Character Joliet Filenames, and you almost double your allowed file-
name length on Windows machines. Does this break the official Joliet standard? Yup. Does it
appear to work anyway in Windows? Yup, so go for it (but remember to test first). Also remem-
ber that you can get up to 255 characters in your filenames using Rock Ridge but only 103 char-
acters using Joliet. Still, for all but the longest of filenames, 103 characters should suffice.

The Allow Untranslated Filenames option has nine sub-options. Checking Allow Untranslated
Filenames activates eight of those sub-options — weirdly, you must enable Allow Max Length
Filenames (37 Characters) if you want it because that option isn’t included by choosing the parent
option.
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In essence, checking either Allow Untranslated Filenames or any of its sub-options breaks the
ISO9660 standard. We recommend going ahead and selecting Allow Untranslated Filenames any-
way; in for a penny, in for a pound, as they say. Realize that your CD will not play in MS-DOS, but
how concerned about that are you? We’ve burned countless discs with that option on, and we’ve
never had a problem in either Linux or Windows playing those CDs. Your mileage may vary, though.

The Input Charset section enables you to specify the language character set you’re using in your
filenames. If you don’t specify anything, K3b uses the default of ISO-8859-1, which covers
Western European languages, such as the one you’re using to read this book. If you’re using dif-
ferent characters (such as Russian, Asian, or Hebrew, for example) in your filenames, specify the
character set you need by checking Force Input Charset and choose from the drop-down menu.
If the option you want to use isn’t listed (UTF-8 isn’t there, for instance), you can manually
enter it.

It does take some time to examine all of these options, but if you want to do your burns cor-
rectly, you have to know how to use the program.

Ready, Set, Burn
OK, it’s time to burn. Click the Burn button in the upper right corner of the window. Depending
on the speed of your burner and the speed you’ve chosen for your burn, you’ll shortly be done.
While K3b works, it displays a progress bar showing you what it’s doing and how far it has pro-
gressed. If you get an error, take a look at the info that K3b provides because it can help diagnose
the problem.

You can create other kinds of CDs besides simple data disks, but that’s probably what you’ll use
Knoppix for most of the time. The four main tasks are listed in the project area, but check out
the Tools menu for other possibilities. Keep in mind that Knoppix comes with most of the soft-
ware that K3b needs to work its magic, but a few things are missing for space reasons. For exam-
ple, the transcode package isn’t included, so you can’t encode audio and video from DVD or AVI
files, and you also don’t have eMovix, so you won’t be able to burn video CDs that will boot and
automatically play. (You can add these on your own, however.) Conversely, you can create
SVCDs (Super Video CDs), believe it or not.

The first place to go for information about K3b is the project’s home page, at www.k3b.org.
There’s not a lot there, unfortunately, but you might find something useful, such as the latest
news about software releases. However, the mailing list, found at www.sourceforge.net/
mailarchive/forum.php?forum_id=1927, is currently averaging a couple of hundred
emails a month, so you might be able to find help there, maybe even from Sebastian Trueg, the
creator and maintainer of K3b.

If you want to learn more about burning CDs and DVDs, an excellent and up-to-date resource is
Andy McFadden’s CD-Recordable FAQ, which you can find at www.cdrfaq.org. For Linux-
specific information, see the CD-Writing HOWTO at the Linux Documentation Project, www.
tldp.org/HOWTO/CD-Writing-HOWTO.html. It’s several years old, but still has good
stuff in it.

If you want to bypass K3b completely and just use the command line, IBM’s developerWorks site has
a great tutorial, at www-106.ibm.com/developerworks/linux/library/l-cdburn.
html, called Burning CDs on Linux. IBM’s site requires free registration, but it’s not onerous.
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Using Text Editors
Linux is a testament to the continued power and relevance of plain ol’ text files. Virtually all
configuration information is stored in text files, and many programs are really just scripts in text
files. Learn how to edit text files effectively, and you’re well on your way to becoming a mighty
Linux (and Knoppix) guru!

Editing Configuration Files on the Command Line with vim
Want to start a discussion that will quickly become a debate and eventually escalate into an
argument? With all the innocence you can muster, ask a bunch of Linux users, “Which is better?
Emacs or vi?” . . . and then step back and watch the fireworks. It’s one of the oldest debates in
the *nix world, and Knoppix comes down squarely in the middle: It includes both text editors,
leaving the choice up to the user.

We believe that vi (actually vim, or “vi improved”) is the better of the two editors, and will
explore it here. If you want to learn about emacs, there’s plenty of information on the Web and
in a lot of books. You should still learn vim, though, because while you can’t be sure that emacs is
on every single *nix machine you’ll run into, you can be certain that vi (and probably vim) will be
installed. Learn vi, and you increase the likelihood that you can fix a machine by changing con-
fig files.

Knoppix includes both console- and GUI-based versions of vim. This section covers only the
console version, for a couple of reasons. First, if you learn to use vim on the console, moving to
the GUI is a piece of cake. Second, the GUI may not always be available, but the console will.

Suppose that you need to edit your hosts file so that you can more easily ssh to a couple of the
boxes on your LAN. Open Konsole (it’s the black icon on the panel) and run cp /etc/hosts
to copy the file to your home directory. Now type vim hosts and press Enter, and the newly
copied hosts file opens (see Figure 1-24).

FIGURE 1-24: Editing a copy of the /etc/hosts file with vim.
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If you’ve never used vim (or even emacs) before, you’re probably a bit confused at this point. What
do you do? Why doesn’t anything appear when you start typing? How do you save? Or quit?

The first thing to understand is that vim operates in one of several different modes at a time.
When you first open vim, it’s in command mode, in which you use your keyboard to move the
cursor around, delete information, cut, copy, and paste, and run commands that affect your file
(because this is a console app, you can’t use your mouse). You want to position the cursor so that
you can enter some data. To do so, use the arrow keys on your keyboard (because Knoppix sup-
ports them), or use the following key commands:

� h: Moves the cursor one character to the left.

� j: Moves the cursor one character down.

� k: Moves the cursor one character up.

� l: Moves the cursor one character right.

To learn more about vim and all of its commands, just type vim on the command line, and then :
help to enter vim’s built-in help system (enter :q to get out of help, of course), or look on the Web
by searching for “vim tutorial,” “vim help,” “vim tips,” or “.vimrc” if you want to find sample
vim config files that people have posted, which can teach you a lot.

Position the cursor at the end of the first line and press a. You’re now in the insert mode, in
which you can insert characters and text into your file. The letter a (append) indicates that you
want to append text after the character your cursor is on, while the letter i (for insert) means
that you want to begin inserting before the character your cursor is on (again, you can use other
commands to signify precisely where you want to begin placing text into the file).

For this example, press Enter so you’re on a new line and then enter three new lines into the
hosts file, pressing Enter after each one to start the next:

192.168.0.10      dante
192.168.0.15      chaucer
192.168.1.20      virgil

You know you should save your work often, but you can’t do that while you’re inserting text. The
solution? When you’re in insert mode, press Esc to return to command mode. Now enter :w
(colon, w) to write out (save) the file. To write and immediately quit (exit), use :wq (colon, w, q);
to quit without saving your work, use :q! (colon, q, exclamation point).

For this example, there are a couple of problems in what you just entered, and here’s how to fix
them. Chaucer is temporarily offline, so it doesn’t need to be in the hosts file. You’re still in
command mode, so maneuver the cursor (using the arrow keys or key commands) until it’s
somewhere in the Chaucer line. To delete a line, enter dd while in command mode; the entire
line disappears.

The second problem is a typo in the line about Virgil: The IP address is 192.168.0.20, not
192.168.1.20. That’s easy to correct: Position the cursor over the 1, press x to delete just that
character, press i to enter insert mode, type a 0, press Esc to go back into command mode, and
finish with :wq, which writes the file out and quits vim.
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Vim really isn’t that difficult to work with — it just takes some getting used to. Once you’re
comfortable with the basics, it’s easy to keep expanding your vim knowledge base, with scripts
and macros and regular expressions and all sorts of other fun, powerful stuff. The sooner you can
do just a little bit with vim, the sooner you’re on your way to using Knoppix more effectively.

Editing Configuration Files Using the GUI Editor Kate
At last count, there were more than 7,000 text editors available for Linux. OK, that’s an 
exaggeration . . . though not much of one. Knoppix includes a few text editors, and they serve
their purpose. Probably the easiest-to-use-right-out-of-the-box GUI text editor on the Knoppix
disk is Kate. Kate is powerful and officially targeted at developers, although anyone can use it.

From the K menu, select Editors ➔ Kate. Kate opens, as shown in Figure 1-25.

FIGURE 1-25: Kate, the text editor, ready to edit text

If you’re reading this book, you’ve used a text editor sometime in your life, even if it was just
Notepad. Kate is very easy to use for simple tasks because it’s pretty much like every other text
editor in the world, but it contains a lot of special features that make it appropriate for more
sophisticated work as well.

There’s only space to point out a few of Kate’s features here. The best way to learn more about
Kate is to go through all the menus, playing with the options and trying things out.

Ever wanted to view different parts of the same file at the same time? Select View ➔ Split
Vertical, which enables you to do just that. To return to the single display of a file, select View ➔

Close Current View.
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Need to run a command against the file you’re working on, but don’t want to switch to Konsole?
Click the Terminal button at the bottom of the window; a resizable console frame appears,
already targeted at the directory in which your file resides. Perfect for a quick wc -w file.txt
(to find out the number of words in your file) or to run ifconfig to grab your machine’s IP
address and paste it into your file. To close the console, click the Terminal button again.

Finally, do you need to directly open a file on another machine accessible only via SSH, and find
that downloading, editing, and uploading it again would be too much trouble? No problem.
Kate supports KDE’s built-in networking transparency, so select File ➔ Open, and in the
Location box enter fish://username@other.computer.com (you can use an IP address instead
of the domain name, if you want). You may have to accept the machine’s SSH key if this is the
first time you’ve connected to it (answer in the affirmative if asked). Enter a password when
you’re prompted, and boom! You’re connected to that machine over a secure connection. Select
the file you need, click Open, edit it, save it, close it, and you’re done. You just remotely edited a
file as though it were sitting right on your machine. Pretty cool, eh?

Kate, like any KDE app supporting the built-in libraries providing network transparency, can work
with files using a variety of protocols, including FTP, SFTP, SMB, NFS, and WebDAV. For a quick
overview of KDE’s network transparency, see www.osdir.com/Article2159.phtml. For
more information on some of these protocols and their usage in Knoppix, take a look at Chapter 3.

Working with Office Software
Like Dilbert, many folks spend their days sitting in offices, working for the Man, trying to earn
their daily bread. If you’re among them, having Knoppix in your arsenal at least provides you
with a cool operating system while you do your time in cubical prison.

Enjoying Interoperability with OpenOffice.org
Office suites are important. In 1984, Apple introduced the first office suite — AppleWorks — a
collection of integrated software that enabled users to create text documents, crunch numbers, and
work with data (software to give presentations came later). Although it was underpromoted by
Apple, and ran only on the Apple II instead of the new Mac, it still proved to be incredibly popu-
lar. When Microsoft released Office 95 to coincide with the release of Windows 95, there was no
looking back. Now, many people spend most of their workday inside their software office suite.

Microsoft may currently dominate the office suite software market, but things are slowly starting
to change. A free, high-quality, open-source office suite has been a long time in coming, and one
is finally here: OpenOffice.org (known as OOo to devotees). It runs on Mac OS X, Windows,
and Linux; it provides a word processor, spreadsheet, and presentation program; and it exchanges
documents with Microsoft’s Office suite beautifully. It’s an essential tool for any computer user,
and it comes with Knoppix.
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Unlike some other office suites, OpenOffice.org is not designed to lock in users by forcing them
into proprietary data formats. Because it has this philosophy, OOo supports a wide variety of
formats, including some that may surprise you.

Most users of OOo know that it reads and writes Microsoft Office formats pretty well. You can
open Word, Excel, and PowerPoint files and templates, and it’s a pretty sure thing that OOo will
display them much like the original Microsoft apps would. In addition, you can save files using
Microsoft’s Word, Excel, or PowerPoint formats, and most users of those programs should have
no problem opening and using your documents. In fact, they’ll probably never know that you
used something other than a Microsoft program unless you tell them.

OOo actually enables you to save your work in a cornucopia of formats, including the following
(listed by application):

� OOo Writer gives you the options of OpenOffice.org 1.0, Microsoft Word 97/2000/XP,
Microsoft Word 95, Microsoft Word 6.0, Rich Text Format (RTF), StarWriter, text, and
HTML.

� OOo Calc provides OpenOffice.org 1.0, Microsoft Excel 97/2000/XP, Microsoft Excel 95,
Microsoft Excel 5.0, Data Interchange Format, dBASE, StarCalc, CSV, and HTML.

� OOo Impress allows for OpenOffice.org 1.0, Microsoft PowerPoint 97/2000/XP,
StarDraw, StarImpress, and HTML.

The OpenOffice.org formats are good. They tend to be much smaller in size than their
Microsoft counterparts (because they’re really just zipped XML-formatted text files); they’re
open and available to anyone, rather than closed and proprietary; and they’re the basis for efforts
by the Organization for the Advancement of Structured Information Standards (OASIS) to
standardize on a common, open, XML-based format for office suites (predictably, Microsoft has
taken a “wait and see” approach to OASIS’ goals). However, as with most everything in the
open-source world, OOo gives you options and leaves the final decision up to you.

One of the most useful file types that OOo supports is Adobe’s PDF. Using OOo 1.1, create a
text document and then select File ➔ Export as PDF, or, if you prefer to use the toolbar, click the
Export Directly as PDF button, visible in the center of Figure 1-26.

FIGURE 1-26: The OpenOffice.org function 
toolbar, with the Export Directly as PDF 
button in the center, between the Edit 
and Print buttons.

OOo creates excellent PDFs, readable by any Linux, Mac OS X, or Windows user. It really is a
fantastic benefit and, as with so many of the really cool things about OOo, it’s 100 percent free
and built in to the program.
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In addition to PDF, OOo now supports a format that may surprise some of you: Macromedia’s
Flash. Yup, that’s right. Macromedia Flash, the cause of so many annoying animated advertisements
and useless splash pages on the Web, is now available for export by OOo users—specifically, OOo
Impress users. If you create a presentation, select File➔Export; from the File Format drop-down
menu, choose Macromedia Flash (SWF) (.swf); and you’re done.

Complaints about Flash aside, the capability to export to this format is a pretty useful feature.
Flash is widely supported (to the tune of more than 90 percent of Web users, according to
Macromedia), and it produces small files that are completely cross-platform. An exported pre-
sentation can be placed on a company Website, and users can open it with their Web browsers to
view it. If a user clicks on a slide, the next one loads.

OOo is a powerful, deep program, and it’s constantly getting better. If you’re using Knoppix,
however, you’re probably not going to use OOo to write your next novel. Instead, you’re more
likely to recover or quickly edit a few documents. The capability to export those documents in a
variety of popular formats is an essential feature of OOo that makes it a key part of your
Knoppix toolkit.

The first place to go for information about OOo is, not surprisingly, www.openoffice.org.
This is the mothership for OOo users, where you can download the program, read the latest OOo
news, get some aid if you need it, and contribute to the project if you’re so inclined.

The most active online forums for OOo can be accessed at www.oooforum.org, an excellent
resource.

Another great place to look is www.openoffice-support.net, which includes tutorials,
descriptions, and HowTo’s. The tutorials in particular are quite nice, especially for anyone desiring
a lot of screenshots to help in learning the basics of OOo.

Desktop Publishing with Scribus
Scribus is an open-source desktop publishing application that enables you to design, create, and
produce documents for publication that contain complex layouts, such as newsletters, brochures,
ads, fliers, and even magazines. In addition, because Scribus outputs as PDF (perfect for hand-
ing off to your local print shop), you can generate PDFs with advanced features — such as forms
and passwords — hitherto only available with the purchase of Adobe’s full Acrobat package
(which is expensive and does not run on Linux). Scribus brings the full world of desktop pub-
lishing (DTP) to Linux and Knoppix — an amazing achievement.

From the K menu, select Office ➔ Scribus. Figure 1-27 shows the Scribus workspace.

Scribus is enormous in capabilities and features, so big that it really needs a book of its own.
There’s no way to cover the program in any meaningful way here, especially for those who may
be new to DTP, so our advice is to just jump in. If you’ve ever used PageMaker or Quark, you
should be right at home in Scribus; if you haven’t, Scribus is an excellent program in its own
right that you can use to bring yourself up to speed with the world of DTP. Consider it a
tremendous bonus that Knoppix makes it easy for anyone to try out this truly amazing program,
a harbinger of open source’s maturity and growth.
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FIGURE 1-27: Scribus, the open-source desktop publishing program

For some excellent overviews of Scribus’ capabilities, see www.linuxdevcenter.com/pub/a/
linux/2004/09/02/scribus.html and www.linuxjournal.com/article/7054.

For details on Scribus, go to the program’s Website, at www.scribus.net. There’s a ton of
great information there, including documentation (a lot!), tutorials, a wiki, downloads, and more.

Viewing PDFs with Adobe Acrobat Reader
Linux comes with a wide variety of PDF readers, and Knoppix itself includes KGhostView, GV
(GhostView), and Xpdf, in addition to the official one, Adobe’s own Acrobat Reader.

You can start Acrobat Reader from the K menu by selecting Multimedia ➔ Viewers ➔ Acrobat
Reader, but you’ll more commonly click on a PDF you’ve downloaded, or on a link on a Web
page that points to a PDF; and your PDF reader will open, already displaying the file you want
to read. Knoppix comes with Adobe’s Acrobat Reader as the default app to view PDFs, so you
don’t need to change anything.

Acrobat Reader supports text selection, which can come in handy if you want to get some text
out of a PDF and into another program. To turn this on, click on the text selection icon on the
toolbar, shown in the center of Figure 1-28.
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FIGURE 1-28: Use the text 
selection icon to grab 
text out of a PDF.

Note two caveats about text selection, however: First, it won’t work in every PDF, only those that
have not “protected” their content (most don’t, but some do), and second, sometimes text selection
acts weird. For example, one of us grabbed some text out of a PDF we had created and then pasted
what we’d copied into a text editor. Every instance of the letter “l” was left out! Very weird.

Acrobat Reader is good if you need to quickly read or print a PDF, but if you need to do some
serious work, the command line might be a better option for you. You probably know about the
ps2pdf command, which converts PostScript documents into PDFs, but there are others you
should know about as well, and all of them are built into Knoppix:

� pdf2ps: Converts a PDF to Postscript, which can sometimes help you get around some
stupid restrictions that someone put into place with his PDF. Try pdf2ps, and then turn
around and immediately do ps2pdf, and you’ll often have a usable PDF, sans silly DRM
restrictions. Here’s the syntax:

pdf2ps sample.pdf

� pdftotext: Converts a PDF directly to plain text. This works very well. Of course, all
formatting is lost, but you have the text, which you can now use in any imaginable way.
Here’s the syntax:

pdftotext sample.pdf

� tiff2pdf: Converts a TIFF image into a PDF. The TIFF must be an 8-bit image, or
the command won’t work. Here’s the syntax:

Sample: tiff2pdf sample.tiff > sample.pdf-

As you can see, there’s more than one way to skin a PDF. Go ahead and use Adobe Acrobat
Reader, but keep an eye on KPDF, another PDF viewer with a lot of promise, and don’t forget
these really useful commands — they may come in handy at times.

Knoppix is still using the now ancient Adobe Acrobat Reader 4.0, and version 7.0 just came out.
The latest is in fact the greatest, and I’m hoping that it winds up in Knoppix soon.

For a good overview of several PDF readers for Linux, check out LWN’s “The Grumpy Editor’s
Guide to PDF Viewers,” available at www.lwn.net/Articles/113094. In particular, KPDF
is going to radically improve once KDE 3.4 comes out, and a later revision of Knoppix includes
that version of KDE, which is great news. KDE.News has the story at http://dot.
kde.org/1102870587.
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Comparing Two or More Files with Kompare
Kompare is a GUI wrapper for the diff program, an ancient (since the 1970s!) UNIX utility that
displays the differences between two text files. Here’s an example that explains how Kompare —
and diff — works. One of us has been working on a poem for a while (more than 12 years), and
periodically it is edited. The original file is titled hoarding_our_lives.txt; after a few ten-
tative changes, it was saved as hoarding_our_lives_2.txt. After reading the second one,
it wasn’t clear which one was better, but trying to compare the two files was a bit of a pain. Enter
Kompare.

Start Kompare from the K menu by selecting Development ➔ Kompare. The Compare Files or
Folders window opens, and you’re asked to choose your files. Here’s our advice: don’t do it yet!
Instead, choose the diff icon on the left side of the window, enter /usr/bin/diff in the Diff
Program textbox, and then go back to choosing the files you want to compare by clicking the
Files icon. The Source file in this example is hoarding_our_lives.txt, and the
Destination file is hoarding_our_lives_2.txt (you’d choose your own, of course). Then
click the Compare button. Kompare opens, looking like what is shown in Figure 1-29.

FIGURE 1-29: Kompare compares two files, highlighting the differences.

Kompare is really a neat tool if you want to see the differences between two files. It has high-
lighted the following differences between the two poem files:
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� Line 2 is in file 1 but not in file 2.

� There’s one difference between line 12 in file 1 and line 11 in file 2.

� There’s one difference between line 17 in file 1 and line 16 in file 2.

� Line 20 in file 1 has been broken into 2 lines in file 2.

After comparing two files, Kompare enables you to decide which changes to accept — in other
words, which file is the “correct” one, which will then overwrite the problematic line(s) in the
other file. To facilitate this, you can choose Difference ➔ Apply Difference, but that applies
changes in only one direction: from left to right. That’s not necessarily what you want to do. For
example, you might like some things about file 1, and some about file 2. The trick is getting
Kompare to work the way you want.

First take care of the stuff in file 1, the one on the left, that you like. For example, you could
click on line 12 in file 1 and choose Difference ➔ Apply Difference (or you can press the space-
bar on your keyboard). Boom! Immediately the two files have the same line 12. You can do the
same for line 20 in file 1.

To arrange it so that file 2 overwrites file 1, you need to change the order in which Kompare dis-
plays the files by selecting File ➔ Swap Source with Destination, which switches the display of
the two files in Kompare (but not the actual files themselves —hoarding_our_lives.txt
and hoarding_our_lives_2.txt are still in the same folder as before; it’s just the way
they’re shown in Kompare that changes). When you do that, you’re first asked to save the two
files, so click the Save button. Now you can select line 2 in file 2 (now on the left side of the win-
dow) and unify the two files, and then do the same for line 16 in file 2. Select File ➔ Save All, and
everything’s unified. Whether you’re a closet poet or have some other need to compare docu-
ments, Kompare will come in handy. You’re bound to have plenty of opportunities to use this
great tool yourself.

Summary
When you ask most people how they use their computers, besides Internet-related activities
(which the next chapter covers), they respond with things such as listening to music, burning
CDs, writing documents, looking at pictures, and printing. Knoppix enables users to do all that
and more. You might not use Knoppix day in and day out to write your novel, for example, but it
truly comes in handy when you need it.
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