
The hourglass in Windows and the watch and spinning beach ball in
Mac OS are icons that most people would prefer not to see when
working in Photoshop. Although eliminating them is not always pos-

sible, you can go some way toward doing that. You can do this by managing
your resources wisely. To that end, it’s worth spending a few minutes fine-
tuning Photoshop to squeeze the maximum performance out of it.

Reducing Startup Time
What better place to start fine-tuning than by reducing the time it takes to
launch Photoshop? The following sections show you several ways to launch
Photoshop more quickly.

Disabling Plug-ins
Each time you launch Photoshop, it loads plug-ins and presets into memory.
The problem is that you may or may not need many of the plug-ins during
the course of a session, but they eat into the memory allocation regardless.
So, how do you alleviate this problem? Well, if you find there are some plug-ins
that you use rarely, if ever, during your Photoshop sessions, you can disable
them temporarily and enable them on the rare occasions when you do need
them. The tradeoff in faster loading and more free memory may be worth the
odd occasion when you may need to quit Photoshop, enable the plug-in, and
relaunch Photoshop.

To disable a plug-in, navigate to the Plug-Ins folder inside the Photoshop
install folder and then insert a ~ (tilde) in front of the plug-in name, folder,
or directory. For example, a good candidate to start with is the Digimarc
plug-in, used to read and write watermarks. If your workflow never makes
use of watermarking, loading it into memory each time you launch Photoshop
is pointless.
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You can also install or move the infrequently used plug-ins out of the plug-ins folder and into a
new folder (it cannot be a subfolder because Photoshop will still see it and load into memory any
plug-ins that it finds). Plug-ins are easier to move around on Mac OS than they are on the PC
(though some do require an install or simply their serial number to be entered after they are
launched).

If you do move the infrequently used plug-ins into this secondary folder, you can load them all
in one go, as you need them; doing so, however, still requires a relaunch of Photoshop, unfortu-
nately. To load a plug-in, hold down Ctrl+Shift (Windows), Ô+Shift (Mac OS) immediately
after you launch Photoshop and then specify the additional plug-ins folder when asked.

CROSS-REFERENCE Photoshop can also follow any shortcuts (Windows) or
aliases (Mac OS) that it finds in the plug-ins folder. To take advantage of this little trait,
see Chapter 5.

While you’re in the Plug-Ins folder, you can safely disable some of the files in the File Formats
folder that have been gathering dust because you have rarely, if ever, used them since you
installed Photoshop. Some of the prime candidates to consider are as follows:

� FilmStrip—Animation file format used by Adobe Premiere and After Effects

� PCX—PC Paintbrush file developed by Zsoft

� PhotoCD—A file format developed by Kodak for storing images on a CD

� Pixar—A file format designed specifically for exchanging files with PIXAR image
computers

� Targa—Used widely by high-end paint programs and ray tracing packages

Managing Fonts
If you are a font lover, you may have too many fonts enabled at any one time. That can add con-
siderably to the launch time while Photoshop scans the fonts folders. Chances are, you use a font
management utility to activate fonts as you need them, but if you don’t, they can hog precious
resources. Look at the splash screen in Figure 1-1 to see how long Photoshop is taking to scan
for available fonts; if it’s taking an inordinate amount of time, that’s a good indicator that you
need to manage your fonts. There are several font management utilities on the market: Suitcase
for Window and Mac OS and FontAgent for Mac OS are very popular. If you cannot afford a
good font management utility, look into disabling at least some of the infrequently used fonts in
the system’s fonts folder by using the font management utility that comes with your operating
system.
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FIGURE 1-1: Watch the splash screen for signs of items’ taking too long to load.

Managing Presets
When you launch Photoshop, in addition to fonts it loads brushes, swatches, gradients, styles,
patterns, contours, custom shapes, and tool presets into memory. If you have gone to town and
loaded all the weird and wonderful sets you can find—and there are plenty of freebies out there
to tempt you—don’t have them sitting in the background eating resources just in case you may
need them one fine day. Be strong willed and use the Preset Manager (Figure 1-2) to ferret out
the infrequently used items in the preset libraries and then either delete them one by one, en
masse by selecting multiple items, or by choosing Reset from the palette menu (see Chapter 2).
You can access the Preset Manager from the Edit menu.

TIP Make sure you save the set with another name when you delete items and do not
overwrite the original set. That way, you can always revert to the original by using the
Load button.

Managing Profiles
Many devices install ICC color profiles that you will never use, or will use rarely. Over time, they
can add up and not only affect launch time but also eat into your precious resources. The thing
to do is to move them so that the OS cannot see them and, by association, neither can
Photoshop.

If you are not sure where color profiles reside on your system, you can easily find the folders 
by doing a Search (Windows) or a Find (Mac OS) for .icm and .icc. When you find the
folder(s), move the infrequently used color profiles into a backup folder. Do not create the backup
folder inside the folder in which you found the files. If you do, the system will still see them, and,
by association, so will Photoshop.

Chapter 1 — Optimizing Performance
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FIGURE 1-2: You can select multiple items in the Preset 
Manager by Shift-clicking, or add and subtract from a 
selection by holding down Ctrl (Windows), Ô (Mac OS), 
and then clicking an item.

Setting Preferences
Photoshop ships with factory settings, known more popularly as Preferences, sometimes short-
ened to Prefs, that you have the option of accepting or rejecting and, in their place, specifying
your own.

Naturally, the settings in Preferences affect your resources. To ration your resources, especially if
they are on the meager side, you can tell Photoshop how you would like it to display and save
files, how many history states you would like to keep, and other preferences. Most of the settings
you want to affect can be found in one dialog box (Figure 1-3).

Windows users can access the Preferences dialog box from Edit ➜ Preferences (Ctrl+K), whereas
Macintosh users can access it from Photoshop ➜ Preferences (Ô+K).

TIP The options that you elect in the Preferences dialog are saved each time you exit
Photoshop and loaded when you launch Photoshop. Sometimes the file that they are
saved in can become corrupted. If that happens, hold down Ctrl+Alt+Shift (Windows),
Ô+Opt+Shift (Mac OS) a split second after you launch Photoshop and elect to delete the
Preferences when prompted. You will have to reset the options by entering the Preferences
dialog box, but that can be a small price to pay for curing Photoshop’s erratic behavior.
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FIGURE 1-3: The Preferences dialog box can be accessed using the keyboard shortcut 
Ctrl+K (Windows), Ô+K (Mac OS).

Cache Settings for Image Cache Levels
When you view an image in the document window at anything less than 100% magnification,
Photoshop can use downsampled, low-resolution cached versions of the 100% view for speedier
redraws. This can be helpful if you constantly work on large images and you need to zoom out
frequently. However, it will take longer to open files while Photoshop creates the low-resolution
previews.

You can specify the number of cache levels in the Preferences ➜ Image & Memory Cache screen
(Figure 1-4). Needless to say, the higher the number of cache levels, the more resources
Photoshop needs to consume. If you have limited RAM, or scratch disk space, you may wish to
set the level to 1 or 2; the default is 4 levels. You can go as high as 8 levels, which will give you
cached views at 66.67, 50, 33.33, 25, 16.67, 12.5, 8.33, and 6.25%. Setting the cache level to 1 is
the same as turning it off because only the current view is cached at that setting.

NOTE Although the cached views can help with speedier redraws, you’ll do well to
remember that any reading that you take based on a cached view will be misleading; for
example, when you sample a color or use a cached view to judge the effect of a filter, such
as USM, it will not be based on actual pixels. For critical readings, always view the image
at 100% magnification (View ➜ Actual Pixels).
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FIGURE 1-4: Specifying high cache levels can help with redraws but also consumes more
resources; Level 2 is a good compromise.

Pixel Doubling for Faster Screen Redraws
When you use tools or commands to move pixel data, you can force Photoshop to create faster
redraws if you have the option Pixel Doubling selected in Preferences ➜ Display & Cursors
(Figure 1-5). The feature works by doubling the size of the pixels temporarily (effectively halv-
ing the resolution) and, after the tool or command has been applied, restoring them to how they
were before the tool or command was applied.

This is not so useful on small files or when plenty of RAM is still available to Photoshop, but
when you’re working on large files and Photoshop is making use of the scratch disk, you may
wish to select the option. Selecting this option has no effect on the actual pixels in the image; it
affects only the preview.

Reducing Overheads by Reducing Histories
The Histories feature has become one of the most widely used and “can’t-do-withouts” in
Photoshop. Its major downside is that it’s another resource hog, and it’s by no means a small-
time operator but one that steals and hordes resources big time; imagine a congregation of Friar
Tucks descending after Lent on a pantry stocked with finite provisions and you should get the
picture!
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FIGURE 1-5: To help speed up screen redraws, you can select “Pixel Doubling” in the 
Display & Cursors section of the Preferences dialog.

You can change several options to conserve and stretch your provisions. The first one is the num-
ber of History states that Photoshop saves in RAM or on your scratch disk. The higher the
number, the more resources are eaten up. However, the higher the number, the more undos
available to you should you need to step back to a previous state. You need to strike a good bal-
ance between a fallback position and the ability to cruise faster.

By default, Photoshop saves 20 history states. You can change this number at any time in the
Preferences ➜ General screen, under History States (Figure 1-6). If you find that you rarely, if
ever, go back beyond, say, 5 to 10 history states, then reducing the number will allow the saved
resources to be used elsewhere. If you find yourself constantly trying to find states that have dis-
appeared from the History palette, then increase the default number and just put up with slower
performance, which may not be noticeable on small files or if you have large reserves of RAM
and fast, independent scratch disks.
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FIGURE 1-6: You can control the number of history states that Photoshop saves in RAM, 
or in the scratch disk temporary file, from the General section of the Preferences dialog.

Reducing Palette Thumbnail Size
Leaving the Preferences dialog for the time being, the palettes also have options that can affect
performance. For example, the Layers, Channels, and Paths palettes all store thumbnails by
default, and these thumbnails are continually updated as you work on the image. However, to
draw and update the thumbnails, Photoshop uses resources that may be gainfully employed else-
where. If your resources are painfully low, you may like to select None or the smallest thumbnail
size. To customize the palette previews, select Palette Options from the palette’s menu and then
choose an option that suits your needs (Figure 1-7).

Do You Really Need That Snapshot?
Apart from the maximum number of saved histories, which you can specify in the Preferences
dialog, you can set other history options that affect performance by selecting History Options
from the History palette menu (Figure 1-8).

The first two options in the History Options dialog box, “Automatically Create First Snapshot”
and “Automatically Create New Snapshot When Saving,” are the ones that consume extra
resources.
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FIGURE 1-7: Palette previews can consume resources. Select “None” or the smallest thumbnail
size to conserve resources.

FIGURE 1-8: Histories, though indispensable, can consume 
resources. You can set the number of saved histories in 
Preferences and set snapshot preferences in History Options.

Of the two, the first option is actually quite handy, even if it does consume extra resources. It can
get you out of a tight spot if you accidentally flattened a multilayered file or pressed Ctrl+S
(Windows), Ô+S (Mac OS)—easily done—when you meant to press another keyboard shortcut
and don’t discover your mistake until well into the editing session, by which time the earlier his-
tory states have been overwritten, including the open, first state. When you click the snapshot,
the document will revert back to the state it was in when it was first viewed in Photoshop, which
may not be the same as the version on disk if you changed its color profile in any way when the
document was opened.

The second option (Automatically Create New Snapshot When Saving) is one that you can
probably live without, but again, you’ll just have to decide whether to take advantage of it. Just
remember that it will consume extra resources if enabled.
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NOTE Snapshots are not saved with a document, nor are they kept in memory. After
the document is closed, snapshots are purged from memory, along with the document’s
history states.

The RAM Connection
A Photoshop legend goes, “If you need to test your RAM, use Photoshop.” It will root out any
inherent problems, as a good farmer roots out weeds. Photoshop will put your RAM under
stress, thus revealing any flaws, as few applications will do—or so the legend goes. The legend
has spread because it’s probably rooted in equal amounts of truth and folklore.

You may ask, where’s the connection between this legend and Photoshop performance? Well, if
any of your RAM chips have gone south, as it were, Photoshop performance will degrade, and
corrupted data may follow in its wake. Photoshop relies very heavily on two things for good per-
formance: masses of RAM and a fast scratch disk (which basically is hard disk space used to
temporarily page data out of RAM). A dual processor can make a difference, but not all pro-
cesses in Photoshop can take advantage of dual processors.

Therefore, you come back to RAM, and the more RAM you can allocate to Photoshop, the
more it will use in order to process your images faster, relying less on the scratch disk, which can
slow it down (as is discussed later in this chapter). However, Photoshop currently can make use
of only 4GB of RAM. Because of the limitation, the less you can waste in allocating to functions
that you may not use, the more will be available for tools and commands before Photoshop starts
to page data to the scratch disk.

There is good reason for Photoshop’s being probably one of the most RAM-hungry programs.
Continuous tone images are made of pixels (picture elements). An average image can contain
millions of pixels. When you open a file or manipulate it in any way, Photoshop has to keep track
of and update the information required to describe each pixel’s color, luminosity, and location,
among other things.

What’s more, because of the method used for storing information about each pixel, as soon as
you duplicate the pixels in order to work on an image, the resources required to keep track of the
extra data have to be similarly multiplied. Furthermore, now that Photoshop supports most
operations on 16-Bits/Channel files, the resources needed to simply open a file in 16-bit mode
need to be doubled. Then there are the files in Large Document Format (PSB), 32-bit files in
High Dynamic Range (HDR) files, and on and on. So, anything you can do to speed the work-
flow will help you accomplish your tasks in Photoshop that much quicker.

Assigning RAM for Optimal Performance
If the processor in your computer is the brain, the RAM can be likened to its heart. All the soft-
ware on your computer, from the operating system to applications to widgets, relies heavily on it
for their speed and efficiency. As mentioned previously, Photoshop can guzzle RAM as a
Mercedes G500 5L guzzles gasoline. So, you need to give it as much RAM as you can possibly
afford. The key word here is afford because the operating system also needs a plentiful supply of
RAM; therefore, it’s a bad idea to starve it while indulging Photoshop.

Chapter 1 — Optimizing Performance
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Photoshop gets its share of RAM from the figure allocated to it in Preferences. When it has
used up that allocation, it pages out the data to the hard disk (allocated to it as the scratch disk
in Preferences), and the end result is it runs more slowly. Knowing that, you may be tempted to
max out the RAM allocation to 100% in order to make it run faster. Not a good idea! If any-
thing, allocating too much memory to Photoshop may slow down the performance by forcing
the operating system and Photoshop to swap pages in and out of memory. So, what amount of
available RAM should you allocate? Well, as with all things in nature, that depends.

Photoshop can use a maximum of only 4GB of RAM. This limitation is imposed by hardware
and the operating systems, among other things that only geeks and engineers with degrees in
astrophysics understand fully. Suffice it to say, if you have 4GB of RAM installed, or more, you
can safely increase the RAM allocation to 70%. Doing so will ensure that Photoshop uses as
much RAM as it possibly can, up to the 3.7GB limit (or thereabouts, because the OS will
reserve some of the 4GB for itself ). If you do not have more than 4GB of RAM installed, you
should reduce the allocation to something like 50–60%, especially if you are experiencing slow
performance in Photoshop, which includes Camera Raw. To allocate RAM, go to Preferences ➜
Memory & Image Cache and specify a percentage in the Memory Usage section of the dialog
box (Figure 1-9).

NOTE You will need to restart Photoshop before the revised allocation can have an
effect.

FIGURE 1-9: If you experience slow performance, try reducing the RAM allocation to 
50–60% in the Memory Usage section of the Memory & Image Cache section of the 
Preferences dialog box.
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Assigning Scratch Disks
Photoshop uses a temporary file for storing data and performing computations when there is
insufficient RAM. It places this temporary file, commonly referred to as a scratch disk, on your
hard disk, or it can spread it across several hard disks. When you exit Photoshop, this temporary
file is deleted, and a fresh one is created the next time you launch Photoshop.

By default, Photoshop uses your primary, startup hard drive as the scratch disk. This is some-
thing to be avoided because it can hinder performance if your OS also uses it to for its virtual
memory needs. Because Mac OS uses the primary hard drive to place its paging file, you are
almost guaranteed conflict on a Mac. To overcome this potential conflict of interests, you can tell
Photoshop which hard disk to place its scratch disk on, provided, of course, that you have more
than one hard disk installed in your computer. If you have just the one disk but it’s partitioned,
selecting a different partition to the one containing the OS virtual memory files won’t speed up
performance. In fact, performing some operations may even take longer because the read/write
heads will have to travel farther.

Although Windows users have a choice of easily assigning different hard disks for the paging
file, thus avoiding conflict between the Photoshop scratch disk and the system’s paging file, Mac
OS users will find it a lot harder to assign a different hard drive for its virtual memory (in fact,
you have to be an advanced user of Terminal to do it!) and may find it easier to assign a different
hard drive for Photoshop to use as a scratch disk.

You can assign scratch disk(s) from the Preferences ➜ Plug-Ins & Scratch Disks screen (Fig-
ure 1-10). It’s possible to assign up to four hard disks, or partitions, and Photoshop will see them
as one large storage space for the temporary file. Photoshop supports up to 64EBs (an exabyte is
equal to 1 billion gigabytes) of scratch disk space—more than sufficient for most needs!

Regardless of the number of hard disks you assign, make sure the minimum size is three to five
times the RAM allocated to Photoshop. Furthermore, it should be a fast hard drive and, if that
hard disk is partitioned, the first partition should be assigned. Do not assign removable media,
such as a Zip drive, or a network drive as a scratch disk. If you assign dedicated partitions that do
not store any other files, defragging should not be required.

Needless to say, the more space you can spare, the lower the likelihood that you will encounter
the dreaded “Scratch disk is full” error at the crucial moment.

Single Scratch Disks vs. RAID
If you work on large files and have maxed out on the amount of RAM you can allocate to
Photoshop, you can increase Photoshop performance by investing in a RAID 0 array
(Redundant Array of Individual Disks) and assigning it as a scratch disk. Because all the disks in
an array can read and write simultaneously, the striped data can be accessed much more quickly
than it would be from a single large disk.

There are several types of RAID arrays on the market. The configuration in a RAID 0 level
array, sometimes called a striped array, allows two or more disks to be combined into one larger
volume and the activity shared over all the disks for improved performance. However, it’s not a
true RAID, because it does not offer redundancy; in other words, the failure of just one drive in
the array will result in all data’s being lost. Although such a shortcoming may defeat the whole
purpose for creating a true RAID array, the raw speed gained by sacrificing fault tolerance to
backup data makes it ideally suited for storing temporary, swap files.
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FIGURE 1-10: Photoshop stores its temporary file on a scratch disk. You can specify in 
the Plug-Ins & Scratch Disks section of the Preferences dialog box which hard drive, 
and how many, to use as a scratch disk or disks.

A RAID array can be composed of two or more Serial ATA drives, SCSI drives, or FireWire
800 drives. Although a software RAID array made of two serial, fast ATA drives will be much
faster than a single drive, for speed, a fast SCSI disk array will be hard to beat; however, it will
also cost much more. The third possibility, a multichannel FireWire 800 array, devised by adding
extra controllers, can even exceed a SCSI disk array for speed and is now a viable alternative.

16-Bits/Channel vs. 8-Bits/Channel
A debate is raging on the benefits of using 16-Bits/Channel files, also known as high-bit, as
opposed to the more traditional 8-Bits/Channel files. Basically, and speaking in nutshells, a 16-
BPC image can contain 65,536 levels, whereas an 8-BPC image can contain only 256 levels.
(In fact, Photoshop shows only 32,768 levels for images in 16-BPC, which is closer to 15-BPC;
it also sees any file above 8-BPC as 16-BPC.) Therefore, it seems natural to assume that because
16-BPC images contain more bits, they must contain more information and be superior in every
way to images in 8-BPC mode.

Based on the “more bits = more information” theory, the advocates of 16-BPC maintain that you
can achieve superior results if you work in high-bit mode. However, the advocates of a 8-BPC
workflow maintain that although for a very limited number of images that may be true, for the
majority of the images the extra overheads in file size, RAM, larger and faster scratch disks,
slower workflow, and so forth do not justify the end results, which are very hard to discern when
images are output to print.
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Both camps agree that there is more flexibility during image editing in 16-BPC because of fewer
quantization errors and, therefore, less banding and overall image degradation, though some of
this banding may not actually translate to print. Quantization errors are attributed to the round-
ing off of numbers when fractions are recalculated to the nearest binary number; only binary
numbers, not fractions, can represent digital values. But to benefit from editing in 16-BPC, you
must start with a file in 16-BPC mode.

You may have noticed that Photoshop gives you the option of changing from 8-BPC mode to
16-BPC mode. If you fall for this option, don’t be fooled into thinking you will somehow
increase the detail. Changing modes upward can be likened to changing a file in a small color
space to a larger color space, or a family of four moving from a small apartment to a large man-
sion. Though they may find that they have more space to move around, they ostensibly remain
the same width and height and have maintained the same number of members. In other words,
you will have more space between the colors but not necessarily more colors (more space
between the family members but no additional offspring). If anything, you will increase the
chance of degradation by having to make larger adjustment moves and introducing quantization
errors.

There is a middle way being adapted by digital photographers who work in Raw mode:

1. Process the raw file in Camera Raw and then open it in Photoshop in 16-BPC mode.

2. Do any major tonal and color corrections.

3. Save the file as a master file.

4. Duplicate the document.

5. Convert it down to 8-BPC.

6. Do any major edits that require hefty resources, such as multiple adjustment layers,
duplicate blending layers, layer styles, multiple type layers, and so on.

7. Optimize the 8-BPC version for output.

NOTE Printers, overall, can handle only 8-BPC files. If you send a 16-BPC file to a
printer, it will be converted on the fly to 8-BPC before output.

While this debate is raging, you may wish to do your own tests, which are easy to perform:

1. Duplicate a 16-BPC file.

2. Convert the copy to 8-BPC (Image ➜ Mode ➜ 8-Bits/Channel).

3. Perform the same edits on the original and the copy (use adjustment layers and drag
them into the other file).

4. Send the files to your desktop printer, or convert the 16-BPC to 8-BPC and then
send both to a four-color offset printer and a photographic printer for good measure,
such as a Fuji Frontier or a LightJet.
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If you find no discernible difference between the prints, or the difference is insignificant, you
will be in the best position to decide whether to work in 16-BPC or only in 8-BPC mode from
the get-go and enjoy cruising through your workload.

Saving Files
When you save your files, you have another prime opportunity to save time and optimize
Photoshop performance. The following sections discuss how, where, and when you can save time
and space as you save your files.

Saving Files in 16-Bits/Channel Mode
Not only can working on files in 16-Bits/Channel mode slow down many of the processes, such
as applying filters, using the Extract command, rotating content, and so forth (as was discussed
previously in the chapter) but also saving files can take considerably longer. If you have finished
correcting the image and optimizing it for output, there’s no benefit in keeping it in 16-Bits/
Channel mode, other than keeping the option open for editing it again at some future date.
Convert it to 8-Bits/Channel mode before saving it or sending it to your printer if speed and
space are a higher priority for you.

Saving Files in CMYK Mode
After you have optimized and purposed a CMYK document, you can remove the embedded
profile, which can reduce file size and help speed the saving process. This can amount to a con-
siderable saving of disk space and time if you are purposing hundreds of files. To remove a profile,
choose Image ➜ Mode ➜ Assign Profile. In the Assign Profile dialog box (Figure 1-11), select
Don’t Color Manage This Document.

TIP If a special recipe was used to do the conversion to CMYK, it’s usually a good
idea to keep notes of the settings used in case you need to match conversions or you are
asked to edit the file.

FIGURE 1-11: You can remove a profile from a document by choosing 
Image ➜ Mode ➜ Assign Profile and then “Don’t Color Manage This 
Document.” 
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Reducing Layers and Channels
The number of layers and alpha channels in your file can also impact on the size of the file and
consequently the time it takes to save it. You can minimize the file size and the time it takes to
save the file by deleting any empty layers, merging others that do not benefit from being stan-
dalone layers, and deleting alpha channels that you no longer require.

Maximizing File Compatibility
When you save a file in the native Photoshop file format (PSD), you can include a flattened,
composite version, as well as all the layers, layer sets, adjustment layers, blend modes, and styles
that go to make up your file. The flattened version can then be used by older versions of
Photoshop and applications that do not support all the Photoshop features used to create the
file. However, the downside is that it can take considerably longer to save the file and can
increase the file size unacceptably, especially if you are working on very large files.

If you feel your workflow is unlikely to benefit from a file that also includes a flattened version,
you can elect never to include a flattened version, or to do so always, or sometimes (Figure 1-12).
To tell Photoshop how you would like to save PSD files, open the Preferences dialog, choose
File Handling from the pop-up menu at the top of the dialog box, and then select an option for
Maximize PSD File Compatibility.

FIGURE 1-12: You can save time and disk space by electing not to save a flattened version 
with your PSD file automatically or to do it on a case-by-case basis.
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CAUTION It has to be said that Adobe has been putting out couched warnings
about the blend modes “possibly” changing in a future version of Photoshop and hinting
(almost insisting with Photoshop 7.0) that you should include a flattened version. The
company says that the composite version may be the only true representation you will see
when you open your file. If you choose never to include a flattened version when you save
in the PSD format, you may like to factor that veiled warning into your decision-making
process. However, many people are ignoring it, especially people who work on very large
files, because Photoshop can take a considerable time to generate a composite when the
file is saved to disk.

Faster Access When Switching Applications
When you switch from Photoshop to another application, if there is data on the clipboard,
Photoshop can “export” it to the system clipboard for pasting into the other application.
However, because Photoshop files can be extremely large, it can cause a delay while it “exports”
the data on the clipboard. What happens, in fact, is that the data is converted to WMF or PICT
format, depending on the OS, and that’s what can cause the delay.

If you find yourself waiting more often than you actually use the data on the clipboard, you can
tell Photoshop not to export the data on the clipboard, thus ensuring speedier handovers. To
turn off the option for exporting clipboard data—the option is turned on by default—go to
Preferences ➜ General and deselect the checkbox for “Export Clipboard.” Regardless of whether
this option is selected, it has no effect on Photoshop’s performance while you are working inside
Photoshop; only when you have a large amount of data on the clipboard, have forgotten to purge
it (Edit ➜ Purge ➜ Clipboard), and then try to exit Photoshop will you notice the difference
(Figure 1-13).

You can always select the Export Clipboard option again on the rare occasions when you actu-
ally need to use the data on the clipboard in the other application. If you want to cover all bases,
you can leave the option selected in Preferences and, before you make the switch to another
application, purge the data from the clipboard—but chances are you will forget in your excite-
ment. To purge data on the clipboard, go to Edit ➜ Purge and select Clipboard from the 
submenu.

Chapter 1 — Optimizing Performance

17

03_597884 ch01.qxd  8/31/05  10:10 PM  Page 17



FIGURE 1-13: To ensure speedier switches between applications, make sure “Export 
Clipboard” is not selected. 

Summary
That about wraps it up as far as optimizing your system performance is concerned. Applying the
suggestions in this chapter should help to cut down the time you spend waiting for Photoshop
to do something. Of course, it goes without saying that how well you look after your OS by
doing general housekeeping required by a Unix-based OS will have a direct effect on
Photoshop’s performance. Furthermore, it’s always a good policy to check the condition of your
hard drives by using the various utilities. Some of these utilities are bundled with your OS,
whereas others can be purchased or downloaded for free from the Internet. Two good places to
begin your search are www.versiontracker.com and www.tucows.com.
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