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Chapter 1

Exploring the User Interface

Autodesk Revit MEP 2012 utilizes a ribbon interface, allowing for easy access to the tools needed 
for mechanical, electrical, and plumbing (MEP) design and modeling. Having a good knowledge 
of where tools are located and how to access commands easily is the best way to be efficient in 
your use of Revit MEP 2012. Improvements and changes have been made to the user interface for 
this version, through the addition of available tools in contextual tabs and improved tooltip func-
tionality for modeling pipes.

If you are transitioning to Revit MEP 2012 from a release prior to Revit MEP 2010, the ribbon-
style interface will be totally new to you. The ribbon works well in Revit because it allows many 
of the tools to be organized in one area of the interface, which gives you more screen real estate 
for viewing the model. Although the user interface is customizable, you are limited in the 
amount of customization and number of features that you can change. At first this may seem a 
bit restrictive but, like any software, after you work with it enough it will become more familiar 
and your efficiency will increase.

Some features have been added to improve workflow and efficiency, and typical workflow 
features that were previously accessed through buttons in the interface are now available as part 
of the interface itself. 

Knowing your way around the Revit MEP 2012 user interface is the first step to reaping the 
benefits of utilizing a building information modeling (BIM) solution for your building projects.

In this chapter, you will learn to do the following:

Navigate the ribbon interface•u	

Utilize user interface features•u	

Use settings and menus•u	

The Ribbon
If you are familiar with the Revit MEP user interface prior to the 2010 version, transitioning to 
the ribbon-style interface may indeed take some getting used to. Once you understand the way 
that the ribbon is set up and how you can customize it to better suit your workflow, though, you 
will see that it is an optimal interface for a BIM and design application.

Tabs
The ribbon portion of the user interface consists of several tabs, each organized by panels that 
relate to the topic of the tab. Each panel contains one or more buttons for the relevant features 
available in Revit MEP 2012. You can access a tab by simply clicking the name at the top of the 
ribbon. Although each tab is designed to provide a unique set of tools, some of the features of 
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4  | Chapter 1  Exploring the User Interface

Revit are repeated on different tabs. Depending on your screen resolution, some of the buttons 
on panels may become compressed to fit on your screen. The panels and tools for each tab are 
described here (not all panels are shown for each tab):

Home ​  ​ The Home tab is the main tab for MEP modeling tools. This tab is divided into pan-
els that are specific to each of the main disciplines. This tab is where you will find the tools to 
build an MEP model. Each of the discipline panels has a small arrow in the lower-right cor-
ner that provides quick access to the MEP settings dialog box for that discipline.

Insert ​  ​ The Insert tab contains the tools for bringing other files into your Revit projects. The 
tab is organized by panels for linking and importing files, and it also contains tools for load-
ing Revit families. The small arrow at the lower right of the Import panel is for accessing the 
Import Line Weights dialog box, where you can associate imported computer-aided design 
(CAD) color numbers to a Revit line weight. The Insert tab also contains the Autodesk Seek 
panel, which provides a search window for content available on the Autodesk Seek website.

Annotate ​  ​ On the Annotate tab, you will find the tools needed to add annotations to your 
model views along with drafting tools for creating details. The Dimension and Tag panels 
can be extended by clicking the arrow next to the panel name, which reveals the tools for 
establishing dimension settings and determining the default tags to be used upon initial 
placement. The Symbol button is used for placing annotation families onto views or sheets. 
The small arrow at the lower-right corner of the Text panel provides access to the Type 
Properties dialog box for creating or modifying text styles.

Analyze ​  ​ Tools for model analysis and systems checking are located on the Analyze tab. 
Other tools on this tab allow you to add color to your ductwork and piping based on defined 
criteria. The Spaces & Zones panel contains the tools for placing Space objects and Space 
Separator lines. The Check Systems panel contains tools for checking MEP systems to ensure 
proper connectivity and valid system assignments of components.
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The Ribbon |  5

Architect ​  ​ Revit MEP 2012 is capable of modeling much more than just the components of an 
MEP engineering system. The Architect tab contains tools that allow you to model architec-
tural components or to create conceptual mass objects. The Room & Area panel contains the 
Legend button, which allows you to apply color fill to your views based on defined criteria.

Collaborate ​  ​ You need tools that allow you to keep your model coordinated with other disci-
plines and work within a multiuser environment. These tools can be found on the Collaborate 
tab. The Worksets panel has a drop-down list for switching worksets, and the Coordinate panel 
contains tools for copying and monitoring objects from linked files. The Coordinate panel also 
has a tool for locating face-hosted elements that have lost their association to their host. You can 
check for clashes between model objects by using the Interference Check tool on the Coordinate 
tab. The Editing Requests button on the Synchronize panel allows you to see any requests that 
have been made to modify elements you are borrowing or own.

View ​  ​ You can use the tools on the View tab to create different types of views. This tab also 
has tools for managing the views you have open in the drawing area. On the Graphics panel, 
there are tools for creating view templates and filters. The Sheet Composition panel has tools 
for creating sheets as well as for adding match lines or revisions. The User Interface button 
allows you to toggle the visibility of key user interface features including the Properties pal-
ette, System Browser, and Project Browser.

Manage ​  ​ On the Manage tab, you can find the tools needed to establish project settings. The 
Inquiry panel has tools that can be used to locate specific objects in your project model and 
to display any warnings associated with your project. Along with the settings that can be 
accessed from the tools on the Settings panel, the Additional Settings button is a drop-down 
list of even more options. The MEP Settings button is located on the Settings panel. This is 
where you can establish settings related to MEP components and system behavior.

Modify ​  ​ The Modify tab is located at the end of the tabs so that it is closer to the center of the 
user interface, for easy access. The Modify tab has the tools needed to make changes to compo-
nents or line work in your project views. The tools on the Modify panel have been arranged with 
the more commonly used tools having larger buttons. Some of the tools that have multiple-use 
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6  | Chapter 1  Exploring the User Interface

options have a separate button for each use, such as the Mirror, Split, and Trim/Extend tools. 
The tools for creating groups, assemblies, or parts are located on the Create panel.

If you are running any external applications or macros, the Add-Ins tab will appear on your 
ribbon as the next-to-last tab. The buttons or other features provided by the external application 
will appear on the tab as configured.

The Modify button appears in the Select panel on every tab. This button allows you to exit 
from any active command, giving you an alternative to using the Esc key multiple times or 
selecting another tool.

Contextual Tabs
In addition to the tabs provided by default on the ribbon, other tabs appear when you select 
objects in your project. These contextual tabs contain tools specific to modifying the selected 
object. Contextual tabs appear in the location of the Modify tab and are identified by their 
green color and a name that applies to the selected object. A contextual tab for a selected 
object is an extension of the Modify tab, which is why the base Modify tab is so compact 
compared to the other tabs. This allows for the selection-specific tools to appear on the right 
side of the Modify tab. The top of Figure 1.1 shows the contextual tab for an air terminal 
selected in the model of a project. The standard tools on the Modify tab are available at the 
left but not shown in this figure for clarity.

When you select an object in the model that is part of a system, an additional contextual tab 
appears with tools for editing the system. These tabs are completely separate from the standard 
Modify tab and contain only tools for system editing. If you select an object on a system, the sys-
tem tab will appear along with the contextual Modify tab, as shown at the bottom of Figure 1.1. 
However, if you select an actual system, only the system tab appears. The panels and buttons on 
contextual tabs cannot be removed or rearranged on the ribbon. The buttons cannot be added to 
the Quick Access toolbar.

Figure 1.1 
Contextual tab for 
an air terminal 
(top), and contex-
tual tab for a duct 
system (bottom)
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The Ribbon |  7

Family Editor Tabs
The tabs in the Family Editor environment differ from those in the Project File environment. 
When you open a family file, the tabs on the ribbon contain some familiar tools, but many of 
them are specific to the creation and modification of family components. The tabs available in 
the Family Editor environment are as follows:

Home ​  ​ The Home tab in the Family Editor environment contains tools for creating solid 
geometry and lines, adding system connectors, and creating and managing references.

Insert ​  ​ The Insert tab in the Family Editor environment contains tools for bringing other 
files into your family file. The tools for linking are visible but disabled, because importing is 
the only available method for bringing a CAD file into a Revit family file.

Annotate ​  ​ On the Annotate tab within the Family Editor environment, you will find the 
types of annotation tools that can be used in a family file. The Dimension panel can be 
expanded to establish dimension styles within the family file.

View ​  ​ The View tab in the Family Editor environment is limited to tools for managing the 
family views. Section views can be created and camera positions can also be established for 
3D views.

Manage ​  ​ In the Family Editor environment, the Manage tab is populated with tools for 
establishing settings within the family file. The MEP Settings button allows you to establish 
load classifications and demand factors, while the Additional Settings button drops down for 
access to general settings.
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8  | Chapter 1  Exploring the User Interface

Modify ​  ​ The Modify tab in the Family Editor environment is the same as the one found in 
the Project File environment. This tab is also compact, allowing for a contextual tab when 
objects within the family are selected.

The Load Into Project button is available on each tab in the Family Editor environment. This 
allows you to load the family into another open file at any time.

Customizing the Ribbon
You can customize the ribbon interface to better suit your workflow. For example, you can rear-
range the order of the tabs by holding down the Ctrl key and clicking a tab name to drag it to a 
new location.

You can move panels on a tab to different locations on the tab by clicking a panel name and 
dragging it to a new location. Figure 1.2 shows the Mechanical panel being dragged from its 
location on the Home tab. The panels to the right will slide over to fill in the space left by the 
moved panel.

You cannot move a panel from one tab to another, however. If you attempt to drop a panel 
onto another tab, it will return to its original location on its original tab.

You can remove panels from a tab and place them in another location on your screen. You 
can dock floating panels together by dragging one panel over the other, and you can move the 
docked panels as a group by clicking and dragging the gray grip that appears when you hover 
your mouse pointer over a floating panel. If you use dual monitors, you can even drag a panel 
to the second monitor. The panel’s new position is maintained when you restart the software, 
but the panel will not appear until a file is opened. Keep in mind that moving tools to another 
screen may actually hinder your workflow efficiency.

Back to Normal

You can return a floating panel to its default location by clicking the small button in the upper-right 
corner of the panel.

If you want to return the entire ribbon interface to its default settings, you can do so by locating 
and deleting the UIState.dat file and then reopening the application. Deleting this file will also 
remove any customization done to the Quick Access toolbar.

Figure 1.2 
Moving a tab panel
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Quick Access Toolbar |  9

You can control the visibility of the ribbon tabs by clicking the small button to the right of the 
tabs. This button will cycle through the different display options. You can also click the small 
arrow next to the button to display and select a specific option.

You can establish the switching behavior of the tabs on the ribbon to determine which tab is 
displayed when you exit a tool or command. When you click a tool, the contextual Modify tab 
for that tool appears. The interface will stay on the Modify tab when you exit the tool, or you 
can set it to return to the previous tab. These settings are located on the User Interface tab of the 
Options dialog box, which is discussed later in this chapter.

Quick Access Toolbar
As you are working, you may find yourself taking extra steps to switch tabs in order to access 
the desired tools. The Quick Access toolbar (QAT) is a place where you can put frequently used 
tools for instant access.

You can add tools from any of the standard tabs to the QAT simply by right-clicking that tool’s 
button or drop-down and selecting the Add To Quick Access Toolbar option. The tool will be 
placed at the end of the QAT. To manage the tools available on the QAT, you can click the small 
arrow button at the far right of the QAT, as shown in Figure 1.3. Each button on the QAT is listed, 
and removing the check mark next to it will turn off its visibility in the QAT.

Figure 1.3 
Quick Access  
toolbar custom
ization menu
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10  | Chapter 1  Exploring the User Interface

The option at the bottom of the list allows you to set the location of the QAT either above 
or below the ribbon. Setting it below the ribbon moves it closer to the drawing area for easier 
access. Moving it to this location does not take the place of the Options Bar, however. If you add 
several buttons to the QAT, you may want to move it below the ribbon so that it does not crowd 
out the filename on the title bar.

Clicking the Customize Quick Access Toolbar option in the drop-down menu opens the dia-
log box shown in Figure 1.4. In this dialog box, you can change the order of the buttons as they 
appear from left to right, create separator lines, or delete buttons.

You can also right-click a button on the QAT for quick options such as removing the button, 
adding a separator line, or accessing the customization dialog box.

User Interface Features
The Revit MEP 2012 user interface is full of features designed to help you design and model 
efficiently. Some items are new, some have been modified, and some are the same as they have 
always been. The title bar at the top of the screen will still inform you of what file you are in and 
what view is currently active in the drawing area.

Options Bar
Despite the functionality of the ribbon with its contextual tabs, the Options Bar is still an important 
part of the user interface. This should be the first place you look when a tool or object in the project 
is selected. Though the number of options that appear may be limited for each command you use, 
they are important to the task in which you are engaging. When placing Space objects, for example, 
pay close attention to the Upper Limit and Offset options to ensure proper space height.

Figure 1.4 
Customize Quick 
Access Toolbar 
dialog box
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You can dock the Options Bar at the top of the screen, below the ribbon (which is the default 
location), or at the bottom of the screen, just above the status bar. Right-click on the Options Bar 
to change its docked position.

Properties Palette
The Properties palette is a modeless dialog box that allows you to access the properties of items 
in your project. This feature reduces the number of mouse clicks necessary to access the proper-
ties of a model object or project component. You can dock the Properties palette to the sides of 
the screen, or it can float. If you dock the Properties palette to the same side of the screen as the 
Project Browser, the two features will split the docked space, as shown in Figure 1.5.

If you do not have the Properties palette turned on, you can access it by clicking the Properties 
button located on the Modify tab or the contextual Modify tab of a selected object, or you can right-
click anywhere in the drawing area. The Properties palette will remain on until you close it.

When no object is selected in the model or in a drafting view, the Properties palette will dis-
play the properties of the current view in the drawing area. You can select a view in the Project 
Browser to view its properties in the Properties palette.

The top section of the Properties palette acts as the Type Selector when an object is selected 
or a tool is chosen for placing an object. When an object is selected, you can switch to the prop-
erties of the current view by using the drop-down list located just below the Type Selector, as 
shown in Figure 1.6.

Figure 1.5 
Project Browser 
and Properties 
palette docked 
together

066812c01.indd   11 7/17/11   11:45:58 PM
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The properties shown in the Properties palette are instance properties. You can click the Edit 
Type button to display the Type Properties dialog box for a selected item or view. When view-
ing the instance properties of an object or view, the scroll bar at the right side of the palette will 
hold its position when you move your mouse pointer away from the palette. The scroll bar will 
remain in position even when other items are selected in the model.

When you make a change to a parameter in the Properties palette, you can click the Apply 
button at the bottom-right corner of the palette to set the change. Alternatively, you can simply 
move your mouse pointer away from the palette, and the change will be applied.

View Control Bar
The View Control Bar is often overlooked, but it contains tools that are important to the display 
of the contents in the drawing area. There are a few changes to the View Control Bar in the Revit 
MEP 2012 release.

The Visual Styles button now provides access to the Graphic Display Options dialog box. 
This dialog box has been updated with settings to control the visual display of the view. One 
of the new settings allows you to apply a transparency to surfaces in 3D views by selecting the 
Ghost Surfaces check box, as shown in Figure 1.7. The Shaded With Edges style is no longer 
available in the Visual Styles menu. The option to show the edges of objects is now a check box 
in the Graphic Display Options dialog box.

Figure 1.6 
Properties palette Type Selector

Drop down
for changing
properties
displayed

Figure 1.7 
Graphic Display 
Options dialog box
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A new button has been added to the View Control Bar that enables you to save and lock the 
orientation of a 3D view. When a 3D view is locked, you can tag items in the view. You can zoom 
and pan in a locked view but you cannot orbit the model. 

The button menu has options for unlocking the view, to allow orbiting, and for returning 
to the saved orientation. When you unlock a view, any tags applied in the view will not be dis-
played until it is returned to its saved orientation.

Another new button is for worksharing display options. This button contains a menu for con-
trolling the display of worksets based on the settings defined in your project.

The Settings option on this button menu takes you to the Worksharing Display Settings dia-
log box, where you can establish the colors used for the various options of worksharing display. 
You can apply colors to worksets based on who owns them, whether they are up-to-date, or 
simply by their name. Figure 1.8 shows the dialog box and settings for worksets colored by their 
name. Notice that, in the Apply Colors column, you can choose to show a workset’s color in the 
view by selecting its check box.

When you choose an option for worksharing display, a box will appear in the upper-left 
corner of the drawing area, indicating the option being displayed, as shown in Figure 1.9. These 

Figure 1.8 
Worksharing  
Display Settings 
dialog box
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settings take precedence over any view filters that may be applied to the view. If you override 
the graphics of a category in the view, only the changes to line weight will be applied (color 
overrides will not display).

To turn the Sun Path on or off in a view, you use the Sun Settings button. You can access the 
Sun Path settings by clicking the Edit button in the Graphic Display Options parameter of a 
view’s properties or from the Visual Styles button menu.

In the Visual Styles button menu, the Consistent Colors setting enables colors of objects to 
appear in a shaded view with the same consistency, regardless of the objects’ orientation to a 
light source. So when you are viewing the model in a 3D view, the color of all sides of an object 
looks the same. With the new Graphic Display Options dialog box, you can now add shadows 
to a view that is set to Consistent Colors. The Realistic setting allows the rendering materials 
of objects to be displayed in an editable view. This setting works only if you have Hardware 
Acceleration turned on.

Take some time to explore the new visual styles by completing the following exercise. If you 
do not have Hardware Acceleration turned on, you can do so by clicking the Options button 
on the Application menu and going to the Graphics tab. You must do this prior to opening the 

Figure 1.9 
3D view with 
worksharing  
display activated
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file. If activating Hardware Acceleration causes problems because of your video driver, you can 
choose not to activate it and skip step 5:

	 1.	 Open the Ch1_Project.rvt file found at www.sybex.com/go/masteringrevitmep2012.

	 2.	 Click the Visual Styles button on the View Control Bar. Set Visual Style to Shaded. Zoom, 
pan, and orbit the view, and make note of the variations in color based on the model 
orientation.

	 3.	 Click the Visual Styles button and select Graphic Display Options. In the dialog box, 
select the Show Edges and Ghost Surfaces check boxes and then click Apply. Notice the 
change to the view. Deselect the Ghost Surfaces check box and click OK.

	 4.	 Click the Visual Styles button and change the style to Consistent Colors. Notice that the 
colors remain a consistent shade when you zoom, pan, and orbit the view.

	 5.	 Click the Visual Styles button and change the style to Realistic. Notice that the render 
material defined for the objects is now displayed.

	 6.	 Click any object in the model. If you do not already have the Properties palette active, 
click the Properties button on the Properties panel of the contextual tab. Take some time 
to become familiar with the behavior of the Properties palette.

Status Bar
Improvements have been made to the status bar for Revit MEP 2012. The status bar not only 
reports information about a selected item and prompts with instructions for multilevel com-
mands, but it also has an active workset indicator and design options indicator. The workset 
name is now displayed in front of its editable status.

Workset indicator Design Options indicator

You can access the Worksets dialog box by clicking the Worksets button next to the active 
workset window. You can switch between active worksets by clicking the window and selecting 
the desired workset. These are the same tools as found on the Collaborate tab, but having them 
on the status bar eliminates the need to switch tabs on the ribbon to access them. This also elim-
inates the need to add the tools to the Quick Access toolbar (QAT). The Design Options window 
displays the active design option, and you can access the Design Options dialog box by clicking 
the button.

The Editable Only and Press And Drag check boxes are located on the status bar. The 
Editable Only check box is for filtering a selection by only those objects that are editable in a 
worksharing environment, and the Press And Drag check box allows you to drag objects in the 
model without having to select them first. So, you can click an object and immediately drag it 
when the box is selected. When the check box is deselected, you must first click to select the 
object, release your mouse button, and then click the object again to drag it. In some cases, 
you may want to deselect this box to avoid moving objects inadvertently when working in a 
crowded area of the model.
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You can access any editing requests by clicking the small button next to the active workset 
indicator. This will open the Editing Request dialog box, which displays any pending requests by 
others to borrow elements. This dialog box also displays any requests made by you to other users. 
Next to the button is an indicator that shows the number of requests that are currently pending.

When a user places a request to edit an element that you own or are borrowing, you will 
receive a notification dialog box of the request. The request will remain in the list of pending 
requests until action is taken.

Info Center
The Info Center is the portion of the title bar that gives you quick access to the Help menu or 
information about Revit MEP 2012. The search window allows you to search for information 
about a topic.

You can easily access the Subscription Center by clicking the button with a key on it. Any 
topics found in the search window or listed in the Subscription Center panel can be added to 
your Favorites list by clicking the star icon to the right of the topic. Clicking the star button on 
the Info Center will list all your favorite topics. The Help menu is displayed by clicking the 
question mark button. Revit MEP 2012 has a web-based Help menu. You can access additional 
information by clicking the arrow next to the Help button, as shown in Figure 1.10.

The Communication Center button is the one with the radar device on it. The 
Communication Center provides information about product updates and announcements.

User Interface Control
Many components of the Revit MEP 2012 user interface can be turned on or off for workflow 
efficiency or to maximize screen real estate. The User Interface button, located at the far right 
of the View tab, allows you to select which user interface components are visible, as shown in 
Figure 1.11.

Figure 1.10 
Additional Help 
options
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The User Interface button provides not only a way to display or remove interface compo-
nents for more screen real estate, but also a way to access the Recent Files screen, which can-
not be accessed from the Switch Windows drop-down button, until it has been activated by 
using this button.

Menus and Settings
The menus within Revit MEP 2012 offer access to many tools for user interface settings. Right-
click context menus also contain various tools based on the selected item.

The Application menu includes options for exporting, printing, opening, and saving files. This 
menu also has an Options button for accessing settings that establish the behavior of the inter-
face as well as the location of directories and files used for working on projects. You access the 
Application menu by clicking the Revit logo button in the upper-left corner of the user interface. 
The Options button is located in the lower-right corner of the menu, as shown in Figure 1.12.

Figure 1.11 
User Interface  
button options

Figure 1.12 
Application menu
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18  | Chapter 1  Exploring the User Interface

Clicking the Options button opens the Options dialog box, which has several tabs for dif-
ferent settings within Revit MEP 2012. The General tab now contains a slider that allows you to 
control how frequently your file will update when working in a worksharing environment and 
utilizing the Model Updates option of the new worksharing display features.

The General tab is also where you define your username for Revit MEP 2012. This is impor-
tant for worksharing because Revit uses this name to identify you for editing requests, workset 
ownership, and element borrowing.

The User Interface tab shown in Figure 1.13 is where you can set some general behavior for 
the interface. For example, you can choose between a light gray or dark gray theme for the inter-
face from the Active Theme drop-down list.

The Tab Display Behavior section in the center of the tab is where you define how the ribbon 
tabs will behave after an action is completed. There are settings for the behavior in both the 
Project and Family Editor environments. The check box for displaying a contextual tab on selec-
tion allows you to have the ribbon tab switch immediately to the contextual tab when an object 
is selected. If that check box is not selected, the contextual tab will still appear on the ribbon, but 
it will not automatically become the active tab.

Figure 1.13 
User Interface  
tab of the Options 
dialog box
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In addition, you can define the level of information provided by tooltips from the Tooltip 
Assistance drop-down menu. If you are still learning the function of different tools within Revit 
MEP 2012, you may want to set this option to High so that you will receive detailed descriptions 
of how tools work when you hover over them with your mouse pointer. If you find that the toolt-
ips interfere with your workflow, you can set this option to None.

What Do I Type?

With Tooltip Assistance set to at least Minimal, you can see the keyboard shortcut for a tool by 
hovering your mouse pointer over it. The keyboard shortcut is shown in parentheses next to the 
name of the tool.

Keyboard Shortcuts
On the User Interface tab of the Options dialog box is a button that enables you to customize 
your keyboard shortcuts. Clicking this button activates the Keyboard Shortcuts dialog box. In 
this dialog box, you can filter the commands to make the list easier to manage and edit. You can 
even filter by specific tabs or menus, as shown in Figure 1.14.

Figure 1.14 
Filter options 
for the Keyboard 
Shortcuts list
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Shortcut Access

You can access the Keyboard Shortcuts dialog box by clicking the User Interface button on the View 
tab. There is even a keyboard shortcut for the Keyboard Shortcuts dialog box: KS.

You can sort the list in ascending or descending alphabetical order by clicking the desired 
column. Once you have located a command for which you want to create a keyboard shortcut, 
you can select the command to activate the Press New Keys text box at the bottom of the dialog 
box. Input the desired keys that will activate the command. You can input up to five characters 
for a keyboard shortcut. Reserved keys cannot be used for keyboard shortcuts; you can find the 
reserved keys by using the filter in the Keyboard Shortcuts dialog box. Click the Assign button 
to apply the shortcut to the selected command.

You can create multiple shortcuts for a single tool, and you can use the same shortcut keys for 
multiple tools. When you create a shortcut that is used for multiple tools, you must use the status 
bar to determine which tool to use when working in your project. When you type the shortcut, the 
first matching command will be displayed on the status bar. You can use the up- or down-arrows 
to cycle through available commands for the shortcut. Once the desired command is displayed on 
the status bar, you can activate it by pressing the spacebar. You can remove a keyboard shortcut 
from a command by selecting the specific shortcut and clicking the Remove button.

You can export your keyboard shortcut settings by clicking the Export button at the bottom 
of the Keyboard Shortcuts dialog box. This will save your settings as an XML file that can be 
edited in a spreadsheet program. Using a spreadsheet is another way to manage and share your 
keyboard shortcuts. The XML file can then be imported into Revit by using the Import button, 
allowing you to set a standard for keyboard shortcuts in a multiuser work environment.

Common Shortcuts

Clark is responsible for teaching a Revit MEP 2012 class. He has established keyboard shortcuts 
that fit his workflow best and allow for efficient use of the software. Because he is so familiar with 
these shortcuts, he wants to share them with his students so that they will all be using the same 
ones during class.

Clark exports his shortcut settings to a file, which he imports into Revit MEP 2012 on the computers 
in the classroom. Prior to importing the custom settings, he exported the default settings so that 
they can be used later if necessary. During class he notes that the settings provided are preferred, 
but each student can further customize them if doing so results in improved efficiency.
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Graphics
The Graphics tab of the Options dialog box allows you to set the selection, highlight, and alert 
colors used in the drawing area. The drawing area’s background color can be inverted if you are 
more comfortable using a black background. Settings for temporary dimensions are also avail-
able to make them more readable, as shown in Figure 1.15. You can set the background for tem-
porary dimensions to transparent or opaque (this setting is not shown in the figure).

Settings for the appearance and behavior of the SteeringWheels and ViewCube can be found 
on their respective tabs in the Options dialog box.

Context Menus
Though the ribbon interface is designed for efficient workflow, context menus can be the easiest, 
most effective way to access settings or make changes to components of your Revit projects. A 
context menu is one that appears when you right-click in open space, on an item in the Project 
Browser, or on an object in the drawing area. Right-clicking in open space in the drawing area 
activates a context menu that includes the Repeat and Recent Commands tools. The last com-
mand used can be activated by using the Enter key or by clicking the Repeat option on the 
context menu. The Recent Commands option displays a list of recently used commands for easy 
access during repetitive work. Figure 1.16 shows a context menu and the recent commands used 
during a working session. The Recent Commands list displays the last five commands used.

Figure 1.15 
Temporary dimen-
sion appearance 
settings

Figure 1.16 
Context menu 
showing recent 
commands
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The options displayed on a context menu depend on the object selected when the menu is 
accessed. One nice feature of Revit MEP 2012 is the ability to define the selection set when the 
Select All Instances option is chosen. Figure 1.17 shows that you have the option to select only 
the objects in the active view or to select them throughout the entire project. This makes the 
Select All Instances feature much more useful, as you don’t have to worry about objects that 
should not be selected being inadvertently included in the selection set.

There is no longer a View Properties or Element Properties option in the context menus (as in 
versions prior to 2011) because of the addition of the Properties palette. The Properties option at 
the bottom of a context menu allows you to toggle the Properties palette on or off.

You can also right-click an element in the Project Browser to access a context menu. Right-
clicking a view will activate a menu with options for applying or creating a view template from 
that view. You can also save the view to a new file, as shown in Figure 1.18.

Figure 1.17 
Selection set 
options

Figure 1.18 
Context menu for 
a view selected 
in the Project 
Browser
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When you right-click a family in the Project Browser, you get a context menu with options 
to edit, rename, or reload the family. You can right-click a family type in the Project Browser to 
access its type properties or to select the instances in the project without having to locate one of 
the instances in the model, as shown in Figure 1.19.

You can also use a right-click context menu to manage linked files through the Project Browser. 
Figure 1.20 shows the options available on a context menu when a linked Revit file is selected in 
the Project Browser.

The Bottom Line

Navigate the ribbon interface. ​  ​ The ribbon is an efficient user interface style that works well 
in Revit. The ability to house numerous tools in a single area of the interface allows for maxi-
mum screen real estate for the drawing area.

Master It ​  ​ Along with the standard tabs available on the ribbon interface, contextual 
tabs also are available while you’re working on a project. Explain what a contextual tab is 
and how it may differ throughout your workflow.

Figure 1.19 
Context menu  
for a selected  
family type

Figure 1.20 
Context menu for 
a linked file in the 
Project Browser
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Utilize user interface features. ​  ​ Many features are available in the Revit MEP 2012 user 
interface that allow for quick access to tools and settings. The use of keyboard shortcuts can 
also improve workflow efficiency.

Master It ​  ​ To enhance workflow efficiency, it is important to know how to access fea-
tures of the user interface. What tool can be used to activate or remove user interface 
features?

Use settings and menus. ​  ​ Establishing settings for your user interface is another way to create 
a working environment that is the most efficient and effective for you to use Revit MEP 2012.

Master It ​  ​ The use of keyboard shortcuts has been part of design and drafting software 
for a long time. The ability to customize the shortcuts to best suit your workflow is key to 
improved efficiency. How can the settings for keyboard shortcuts be accessed? How can 
the settings be shared among users?
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