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What you’ll learn in 
this lesson:
• An overview of 

Dreamweaver CS6 
features

• How the Web works

• An introduction to HTML

Lesson 1

Whether you are a novice web designer or an experienced developer, 
Dreamweaver is a comprehensive tool you can use for site design, 
layout, and management. In this lesson, you’ll take a tour of 
Dreamweaver’s key features and get a better understanding of how 
web pages work.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

Before you start, be sure to register your book at www.digitalclassroombooks.com/CS6/Dreamweaver 
to learn about updates to any of the lesson fi les and gain access to the accompanying video 
tutorials on any Internet connected computer, tablet, or smartphone.

You will work with several fi les from the dw01lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

Dreamweaver CS6 Jumpstart
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If you want to get started and create a page, jump ahead to “Tag structure and attributes” later 
on in this lesson. Otherwise, the next few pages provide you with an overview of key capabilities 
and features of Dreamweaver CS6.

See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the supplied DVD.

What is Dreamweaver?
Dreamweaver is an excellent web design and development tool for new and experienced 
users alike. Over the years it has become the preferred website creation and management 
program, providing a creative environment for both designers and developers. Whether 
you design websites, develop mobile phone content, or script complex server-side 
applications, Dreamweaver has something to off er. 

Design and layout tools
Dreamweaver’s many icon-driven menus and detailed panels make it easy to insert and 
format text, images, and media (such as video fi les and Flash movies). This means that you 
can create attractive and functional web pages without knowing a single line of code—
Dreamweaver takes care of building the code behind-the-scenes for you. Dreamweaver 
does not create graphics from scratch; instead, it is integrated with Adobe Photoshop CS6, 
so you can import and adjust graphics from within the application.

The Insert panel features objects in several 
categories that let you easily add images, 
web forms, and media to your page.

1
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What is Dreamweaver?

Site management and File Transfer Protocol 
Dreamweaver has everything you need for complete site management, including built-in 
File Transfer Protocol (FTP) capabilities between a server and your local machine; reusable 
objects (such as page templates and library items); and site optimization tools (such as link 
checkers and site reports), so that you can ensure that your site functions properly and 
looks good. If you’re designing your pages with Cascading Style Sheets (CSS), then the 
W3C Validation, the Browser Compatibility Check, and the CSS Advisor features will 
help you locate and troubleshoot any potential display issues that may occur across diff erent 
web browsers.

Coding environment and text editor
Dreamweaver lets you work in a code-only view of your document that acts as a powerful 
text editor. Features such as color-coding, indentation, and visual aids make Dreamweaver 
an excellent text editing or coding environment for web designers of any level.

Code view is a full-featured text editor that color-codes, tags, and scripts for editing that’s easier to decipher.

For more experienced developers, Dreamweaver supports popular coding and scripting 
languages, such as JavaScript, in addition to several server-side languages, including 
ColdFusion, PHP, and ASP.NET. Specialized insert menus and code panels help you build 
pages and applications in the language of your choice.

Scripting languages, such as those used to build interactive web pages or e-commerce sites, fall 
into two categories: client-side and server-side. Client-side languages (such as JavaScript) run in 
your browser, while server-side languages (such as ColdFusion) require that special software be 
installed on the server in order to run.
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Mobile design and development features
The tools in Dreamweaver have evolved as the Web has evolved. The most recent versions 
of the application have numerous features designed to help make your website look and 
function well in the rapidly growing arena of mobile phones and devices. The Multiscreen 
Preview feature allows you to preview your pages in common screen sizes for smartphones 
and tablets and can be accessed by choosing Window > Multiscreen Preview.

Additionally, there is support for creating Media Queries, which are a CSS3 feature aimed 
at creating unique page layouts for diff erent-sized screens. For more advanced users there is  
support for jQuery Mobile, which creates unique user interfaces for touchscreen devices. 
There is also support for creating native applications for iOS and Android operating 
systems with the new addition of the PhoneGap integration added in Dreamweaver CS6.

Multiscreen Preview allows you to test your pages in common screen sizes for mobile and other devices.

Who uses Dreamweaver?
Dreamweaver’s popularity is a result of its fl exibility. Its ability to build a site from 
conception to launch—and provide continued maintenance afterward—makes it a preferred 
tool among industry professionals, businesses, and educational institutions. However, it 
remains easy and accessible enough for novice designers to get up-and-running quickly. It’s 
not unusual to see Dreamweaver utilized for personal projects or by small businesses and 
media professionals, such as photographers and painters, to maintain a web presence.
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Dreamweaver’s workspace features
This book is dedicated to exploring, learning, and putting to use all that Dreamweaver has 
to off er. This section looks at some of the application’s key features.

Four diff erent points of view: When you work with a document, Dreamweaver lets 
you see your work in one of four views: Code, Split, Design, or Live view. Dreamweaver’s 
default Design view lets you add elements to your page in a visual fashion, either by 
dragging objects onto the page from the Insert panel, or by directly adding text, image or 
multimedia content. More experienced web designers and coders can use the Code view 
to edit a document’s HTML code and scripts directly, enhanced with easy-to-read color-
coding and visual aids. 

For those who like something in between, the Split view provides a split-pane Design 
and Code view all at once. You can easily change views at any time with a single click in 
the Document toolbar. The Live view is a type of “reality check” that allows you to view 
your page in a native web browser, eliminating the need to leave the program in order to 
preview your designs.

The Split view lets you edit your page visually while also seeing the code being created behind the scenes.
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Built-in FTP: You can easily upload and download fi les to and from your web server 
using the Files panel’s drag-and-drop interface. You can also use the Get/Put button at 
any time to post pages you’re currently working on. In either case, there’s no need for 
separate software. Dreamweaver also provides Check In/Check Out functionality and 
synchronization features; these allow multiple people to work more safely and effi  ciently 
on the same site.

Page and code object Insert panels: You can fi nd intuitive icons for most common 
web page elements in a categorized Insert panel, from which you can add elements to 
your page with a single click. You can use additional panels to fi ne-tune any page element 
to ensure that you see exactly what you want. Included in the default Insert panel are 
tools for formatting text, building forms, and creating layouts. You can also customize a 
Favorites tab with your most-used icons.

Customizable workspace layouts: You can save combinations and positions of panels 
and toolbars for easy recall at any time. Save multiple workspace layouts for diff erent users, 
or create diff erent workspaces for specifi c tasks, such as coding or designing page layouts.

You can choose a specifi c workspace layout in order to create an 
arrangement of panels that suits you best.
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Powerful visual aids: Take advantage of the precision you’re accustomed to in other 
design programs through Dreamweaver’s guides, rulers, measuring tools, and customizable 
positioning grid; many of these features are found and can be activated within the View 
menu. Dreamweaver’s Design-Time style sheets let you customize the look of your page 
exclusively for the editing process, making layout quicker and easier without permanently 
altering the page’s appearance.

Rulers, a document grid, and guides help you size and position page items with precision.

CSS Styles panel: Take advantage of the vast design and formatting options that CSS 
provides through Dreamweaver’s full-featured CSS Styles panel, which lets you create, 
edit, and manage styles on-the-fl y from a single panel.
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Live View and Live Code
Experience tells you that visual web editors often display diff erently than the browsers 
they’re emulating. As script-driven interactivity gains popularity, the need to accurately 
design the diff erent states of your page (including menus, panels, and interface elements), 
has become increasingly important. The static nature of the Design view in Dreamweaver 
often times does not meet users’ advanced needs.

Dreamweaver’s Live View mode uses the WebKit rendering engine (which is also the basis 
for the Safari and Google Chrome web browsers), to give you a more accurate preview of 
your page in the same way that a browser would render it.

Live View enables you to preview your page as if it were in a web browser.

When you are in the Live View mode, the Live Code feature is enabled. Live Code allows 
you to see, in real time, how visually changing your page aff ects the code behind the scenes. 
If you have added interactive elements such as drop-down menus or accordion panels, then 
you can visually select an item on the page and see how the HTML code might be aff ected. 

Also useful is the Freeze JavaScript button (or the F6 key). This feature freezes your page in a 
particular state (for example, with a menu locked open and a hover eff ect in place). You can 
then edit those interactive elements directly in Dreamweaver.
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CSS Inspection and the Enable/Disable Feature
Another feature that is enabled when in Live View is the Inspect Mode. This mode allows 
users to peek at the visual model and structure of a page by hovering over elements on 
the page. When hovering in Inspect Mode you can see the relationships between the 
HTML elements on your page and the styles assigned to them. This is useful because it 
dramatically shortens the time it takes to locate any given style for any given object on the 
page. However, when paired with the Enable/Disable feature, the Inspect Mode becomes 
even more powerful.

The Enable/Disable feature allows you to temporarily “turn off ” an applied style on your 
page. This can be very useful when dealing with unfamiliar or complex designs where half 
the battle is simply understanding what styles are being used. Disabling a style will remove 
its properties so that you can visually observe the results. Keep in mind that disabling is 
always temporary, and that it is just as easy to restore the style by clicking Enable.

In the Inspect Mode, mousing over the elements in the Design view reveals the HTML and CSS code.
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Related files
Web-based projects are becoming more complex than ever before, and you often fi nd that 
even a single page is composed of a variety of assets. These assets can include Cascading 
Style Sheets (CSS), external JavaScript fi les, and more. Dreamweaver CS6 has a feature 
that will help you become much more eff ective at designing and managing sites and 
applications with multiple assets.

The Related Files bar runs across the top of your document window, just below the 
document tabs. The bar shows you all the various fi les that, when combined, create your 
fi nished page. You can switch between these fi les using the Related Files bar without 
losing the visual preview of their parent page. Design view (or Live View) always shows 
the parent fi le, but you can now edit any of the related fi les without losing their important 
visual context.

The Related Files bar shows you the various fi les that are part of your fi nished page.

DWCS6_06Pass.indb   18DWCS6_06Pass.indb   18 5/2/12   5:15 PM5/2/12   5:15 PM



1

19Lesson 1, Dreamweaver CS6 Jumpstart

Code Navigator

Code Navigator
The Code Navigator ( ) is a feature enabled in the Design view that appears when you hover 
over an element on the page. Clicking on the Navigator will let you see a quick summary 
of any CSS styles that have been applied, and if you choose to, you can click on the style in 
order to view the code directly. The benefi t is that it is no longer necessary to manually hunt 
through your style sheets to fi nd a specifi c rule; it’s just a click away in Dreamweaver.

The Code Navigator allows you to easily view the location and properties of your CSS styles in the Design View.
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Photoshop smart objects
Dreamweaver off ers support for Photoshop smart objects, meaning you can drag a PSD fi le 
into a web page within Dreamweaver, optimize the image for the Web, and even resize it.

Inserting a native Photoshop fi le into Dreamweaver will trigger an automatic conversion into a 
suitable web graphic such as JPG, PNG, or GIF.

Also, if you decide to update the original PSD fi le at a later time, then a red arrow appears 
on the image in Dreamweaver to indicate that the source fi le has changed. You can then 
click the Update from Original button in the Property Inspector and a new version of the 
image will be created.

Support for Content Management Systems 
Enjoy authoring and testing support for content management systems like WordPress, 
Joomla! and Drupal. A CMS/blog software like WordPress provides users with an easy 
way to publish content online and has features such as automatic archiving and database 
integration. In the past, designers have been frustrated with creating the page designs for 
a CMS using Dreamweaver because these systems generally rely on a relatively complex 
combination of dynamic pages (often PHP) that could not be previewed in Dreamweaver. 
For designers or users who are not code-savvy, the complexity of these fi les can be 
daunting. Dreamweaver can now help you discover the related fi les needed to put together 
the pages in your CMS framework.

Dreamweaver does this by previewing the fi les of a CMS framework in the Design view 
(as long as you have a testing server defi ned), using the built-in Live View option. With 
this feature, Dreamweaver CS6 also lets you interact directly with a database, which means 
you can now test online forms, insert and modify database records, and more.
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HTML and CSS Starter Pages

HTML5, CSS3, and PHP code hinting
For advanced users, there is now built in code-hinting support for HTML5 and CSS3 
syntax. This means the “library” of HTML and CSS syntax that is now available within 
Dreamweaver is larger than ever, which is a good sign for those designers and developers 
who need to build modern web pages. 

Additionally, advanced users who use the scripting language PHP will be happy to learn 
that Dreamweaver CS6 now has improved support for PHP syntax. This includes code 
completion and syntax checking, as well as full support for all core functions, constants, 
and classes. PHP code hints have also been improved substantially.

 
Dreamweaver provides support for HTML5, CSS3, and PHP code-hinting.

HTML and CSS Starter Pages
HTML and CSS Starter Pages have been around in Dreamweaver for a few versions now.
These pages allow you to get a jumpstart on building page layouts by choosing from a 
variety of pre-built page layouts that you can subsequently modify. In Dreamweaver CS6, 
the code for these starter pages is new and improved for modern web browsers and comes 
with plenty of code commenting behind the scenes to help you start modifying your pages 
quickly. You can view starter pages by choosing File > New. The Layout column features a 
number of page layouts. CSS starter pages can also be found by clicking on the Page From 
Sample button.
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Subversion
Dreamweaver has improved support for Subversion, a version control system similar to 
CVS and Visual SourceSafe (VSS). Subversion is typically used by companies to maintain 
a team environment on larger projects that require changes to be logged and versions to be 
controlled. Without Subversion, if you wanted to maintain versions, you would have to do the 
work yourself by maintaining folders and copies of previous versions. With Subversion, all fi les 
are kept on the Subversion server. Changes are tracked so that you can restore your project 
to any previous state. Subversion is enabled by choosing Site > New Site ( or Site > Manage 
Sites), choosing Version Control and then clicking the Access menu and choosing Subversion.

Business Catalyst integration
Adobe’s Business Catalyst is an online service that provides a variety of features such as 
online store/shopping cart capabilities, email marketing, web form functionality, analytics 
extension, and more. With the Business Catalyst extension in Dreamweaver you can log-
in to Business Catalyst and synchronize multiple sites at once. Dreamweaver can be used to 
access and edit the style module used on your Business Catalyst connected sites. 

How websites work
Before embarking on the task of building web pages (and in turn, a website), it’s a good 
idea to know the basics of how websites work, how your users view them, and what you 
need to know to make sure your website functions and looks its best. 

A simple flow chart
What happens when you type in a website address? Most people don’t even think about 
it—they just type in a URL (Uniform Resource Locator) and the website appears. They 
most likely don’t realize how many things are going on behind the scenes to make sure 
that pages gets delivered to their computer so that they can do their shopping, check their 
e-mail, or research a project.

http://www.yoursite.com/User Machine (client) Web Host (server)

When you type a URL or IP address in the address bar of a web browser, you are 
connecting to a remote computer (called a server), and downloading the documents, images, 
and resources necessary to render the pages you will view while on the site. Web pages 
aren’t delivered as a fi nished product; your web browser is responsible for reconstructing 
and formatting the pages based on the HTML code included within the pages. HTML 
(Hypertext Markup Language) is a simple, tag-based language that instructs your browser 
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how and where to insert and format pictures, text, and media fi les. Web pages are written in 
HTML, and Dreamweaver builds the HTML as you construct your page in the Design view.

An Internet Service Provider (ISP) enables you to connect to the Internet. Some well-
known ISPs include Verizon, Comcast, and EarthLink. You view web pages over an 
Internet connection using a browser, such as Internet Explorer, Firefox, or Safari. A browser 
can decipher and display web pages and their content, including images, text, and video.

Domain names and IP addresses
When you type in a website address, you usually enter the website’s domain name (such as 
DigitalClassroom.com). The website owner purchased this domain name and uses it to mask 
an IP address, which is a numerical address used to locate and dial up the pages and fi les 
associated with a specifi c website. 

So how does the Web know what domains match up with what IP address, and in 
turn, with what websites? It uses a Domain Name Service (DNS) server, which makes 
connections between domain names and IP addresses. 

Servers and web hosts
A DNS server is responsible for matching a domain name with its companion IP address. 
Think of the DNS server as the operator at a phone company who connects calls through 
a massive switchboard. DNS servers are typically maintained by either the web host or 
the registrar from which the domain was purchased. Once the match is made, the request 
from your user is routed to the appropriate server and folder where your website resides. 
When the request reaches the correct account, the server then directs it to the fi rst page of 
the website, which is typically named index.html, default.html, or whatever the server is 
set up to recognize as a default starting page.

A server is a machine very much like your desktop computer, but it’s capable of handling 
traffi  c from thousands of users (often at the same time!), and it maintains a constant 
connection to the Internet so that your website is available 24 hours a day. Servers are 
typically maintained by a web host. Web hosts are companies that charge a fee to host and 
serve your website to the public. A single server can sometimes host hundreds of websites. 
Web hosting services are available from a variety of providers, including well-known 
Internet service companies such as Yahoo!, and other large, dedicated hosting companies. It 
is also common for a large company to maintain its own servers and websites on its premises. 

The role of web browsers
A web browser is an application that downloads and displays HTML pages. Every time 
you request a page by clicking a link or typing in a website address you are requesting an 
HTML page and any fi les that it includes. The browser’s job is to reconstruct and display 
that page based on the instructions in the HTML code, which guides the layout and 
formatting of the text, images, and other assets used within the page. The HTML code 
works like a set of assembly instructions for the browser to use.
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An introduction to HTML
HTML is what makes the Web work; web pages are built using HTML code, which in 
turn is read and used by your web browser to lay out and format text, images, and video 
on the page. As you design and lay out web pages in Design view, Dreamweaver writes the 
code behind the scenes that is necessary to display and format your page in a web browser.

Contrary to what you may think, HTML is not a programming language, but rather a 
simple text-based markup language. HTML is not proprietary to Dreamweaver—you can 
create and edit HTML in any text editor, even in simple applications such as Windows 
Notepad and Mac OS X’s TextEdit. Dreamweaver’s job is to give you a visual way to 
create web pages without having to code by hand. If you like to work with code, however, 
Dreamweaver’s Code view is a fully featured text editor with color-coding and formatting 
tools that make it easier to write and read HTML and other languages.

Tag structure and attributes
This exercise is for users who are completely new to HTML and Dreamweaver, and it 
will cover basic concepts such as the role of tags in HTML documents. HTML uses tags, 
or bracketed keywords, that you can use to place or format content. Many tags require a 
closing tag, which is the keyword preceded by a forward slash (/). 

1 Launch Dreamweaver. Choose File > Open. When the Open dialog box appears, 
navigate to the dw01lessons folder. Select BasicHTML.html and press Open. 

2 Select the Split button in the Document toolbar to see the layout as well as the code 
that makes up the page.

Take a look at line 10 (indicated at the left edge of the Code panel). The text My Bold 
Title is inside a Strong tag, which is simply the word strong contained within angled 
brackets. Any words or characters inside these tags are formatted in bold, and appear as 
shown in the Design view.

A look at the code reveals the tags used to format text in your page.
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Tags can also accept CSS rules that specify additional information for how the tag 
should display the content. CSS rules may have one or more properties, such as size, 
color, or alignment. Take a look at the line that reads: This text will appear inside of its own 
paragraph. This line is enclosed in a p (paragraph) tag, which separates it from the other 
text by a line above and below. You can add a CSS class rule to this to align the text. 

3 Highlight the entire line that reads: This text will appear inside of its own paragraph at the 
bottom of the Design view.

4 With the CSS button selected in the Property Inspector panel at the bottom of the 
page, locate the paragraph align buttons. Press the Align Center button ( ).

5 In the New CSS Rule dialog box, type .center into the Selector Name text fi eld, and 
press OK.

Name a newly created style in the New CSS Rule dialog box.
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6 The text is now centered. Take a look at the Code view, and notice that the .center 
rule has been added to the opening <p> tag. This is not the only method of centering 
a paragraph using CSS, but it begins to introduce you to the practice of integrating 
HTML and CSS.

Align or format text in the Property Inspector, and then see the appropriate rules and attributes created in your code.

For more information on formatting text with CSS rules, please see Lesson 3, “Adding Text and 
Images.”

7 Choose File > Save to save your work, then choose File > Close.
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The structure of an HTML document
In HTML a pair of tags is referred to as an “element.” For example, in the last exercise 
you created a style for one of the paragraph elements on the page. HTML elements defi ne 
the structure of a page and examples include lists, images, tables, and even the HTML 
documents themselves. The HTML element is the most fundamental element you will use. 
It is used to specify the beginning and end of HTML in a document:

<html></html>

The HTML element consists of two tags that contain two key sections of your web page: 
the head and the body. The head element of your page contains items that are not visible 
to your user, but are important nonetheless. Search engine keywords, page descriptions, 
and links to outside scripts or style sheets are all found in the head element. You create the 
head of the document inside the HTML tags using the <head> tags:

<html>
<head></head>
</html>

The body of your page is where all the visible elements of your page are contained. This is 
where you insert text, images, and other media. You defi ne the body of the page using the 
<body> element:

<html>
<head></head>

<body>

My text and pictures go here...

</body>
</html>

Whenever you create a new HTML document in Dreamweaver, this structure is created 
automatically before you add anything to the page. Any visual elements you add to the 
page are added, using the appropriate HTML code inside the <body> element.
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Placing images in HTML
You use some elements in HTML to place items, such as pictures or media fi les, inside a 
web page. The <img> element is the most common example; its job is to place and format 
an image on the page. To place an image and see the resulting code, follow these steps:

1 Choose File > Open. When the Open dialog box appears, navigate to the dw01lessons 
folder. Select the Images.html fi le and press Open to edit the fi le.

2 If necessary, click the Split button in the Document toolbar so that you’re viewing 
both the layout and the code for your page. In the Design view portion of the Split 
view, click below the line of text to place your cursor underneath it. This is where 
you’ll place a new image.

Enter the Split view before you insert the image onto your page.
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3 From the Common category in the Insert panel on the right side of the screen, click 
on the Images element and choose Image. When the Select Image Source dialog 
box appears, select the fi le named gears.jpg, located in the images folder within the 
dw01lessons folder and press OK (Windows) or Choose (Mac OS).

Choose Image from the Common tab in the Insert bar.

4 When the Image Tag Accessibility Attributes dialog box appears, type the words 
Gears Image in the Alternate text fi eld, and press OK to place the image.

Attach alternate text to your image.

The Image Tag Accessibility Attributes dialog box appears when you add images to provide 
additional information for users with special needs (such as the visually impaired). You should 
always provide each image with alternate text, but you can disable this panel by choosing 
Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS). In the Accessibility 
category, uncheck the Images option. 
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5 The code shows that the HTML <img> element has been used to place the image. 
Click once on the image in the document window to select it. The Property Inspector 
at the bottom of the page displays and sets the properties for the image. 

6 Choose File > Save to save your work, then choose File > Close.

Note that in HTML, images and media are not embedded, but placed. This means 
that the elements contain additional information known as attributes and values that 
point to the location of an image fi le and may even contain other information such as 
the width and height values.

Colors in HTML
In Dreamweaver’s various panels and in your code, each color is referred to by a six-
character code preceded by a pound sign. This code is called the hexadecimal code, and it 
is the system that HTML pages use to identify and use colors. You can reproduce almost 
any color using a unique hexadecimal code. For example, you represent dark red in 
HTML as #CC0000.

The fi rst, middle, and last two digits of the hexadecimal code correspond to values in the 
RGB spectrum. For instance, white, which is represented in RGB as R:255 G:255 B:255, 
is represented in HTML as #FFFFFF (255|255|255). Choosing colors is easy, thanks to a 
handy Swatches panel, which you can fi nd in many places throughout the work area. 

The Swatches panel makes it easy to work with colors.

The color pickers in Adobe Photoshop and Illustrator also display and accept hexadecimal codes, 
making it easy to copy and paste colors between these applications and Dreamweaver.
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Case sensitivity and whitespace rules
HTML is a fl exible language that has very few rules regarding its own appearance. Based 
on how strictly you want to write it, HTML can be either very specifi c about whether tags 
are written in upper- or lowercase (called case sensitivity), or not specifi c at all. To see how 
HTML treats whitespace, follow these steps.

1 Choose File > Open. When the Open dialog box appears, navigate to the dw01lessons 
folder. Select the Whitespace.html fi le, and then press Open. 

2 If your fi le is not in Split view, press the Split button in the Document toolbar at the 
top of the page, so that you can view both the layout and the code. The fi rst three 
paragraphs have diff erent amounts of space between them in the HTML but will be 
rendered on the page one after the other.

The browser ignores any white space between the paragraphs.

This tells you that whitespace and line returns are ignored by the browser. You have 
to begin making a distinction between code that is readable by humans versus the way 
a web browser interprets and renders code.
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3 You will see there are a few diff erent ways to format your text. In the Design view, 
click once after the sentence that reads, This is one sentence, and then press Shift+Enter 
(Windows) or Shift+Return (Mac OS) twice. This creates two line returns—you can 
see that each line return is created in your code by a <br> (break) tag. When rendered 
in the browser, the <br> tag adds blank lines between the sentences; however the 
sentences are technically within the same paragraph. This is sometimes referred to as a 
hard return. This method is actually not the ideal way to add new lines on your page, 
although it does occasionally come in handy.

To create a line return, hold down the Shift key while pressing the Enter or Return key.

4 To create a new paragraph, position your cursor before the phrase This is another, and 
press Enter (Windows) or Return (Mac OS). The text is separated by a line above 
and below, and is wrapped inside a set of <p> (paragraph) tags. This is the preferred 
method of adding paragraphs.

Other than a standard single space (such as the space used between words), several consecutive 
spaces created by the spacebar are ignored and are displayed as only one space in Design view and 
in a browser.

5 Choose File > Save to save your work then choose File > Close.
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Element hierarchy
HTML elements should have a well-formed hierarchy or nesting structure in order to make 
sure that everything displays as it should. The element at the top of the hierarchy is the 
<html> element, and every other element you create is contained within it. Elements such 
as the <body> end up nesting all the other elements on a page, such as the <p> (paragraph), 
<img> (image), and <strong> (bold) elements. In addition, structural elements (such as 
those that create divs, paragraphs, lists, and tables) hold more weight than formatting tags 
such as <strong> (bold) and <em> (italic). Take this line of code, for example:

<strong><p>Big bold paragraph</p></strong>

Although code such as this may work in certain browsers, it isn’t structured well because 
the <strong> tag technically holds less weight than the <p> tag. The following code 
represents a better way to include the bold type:

<p><strong>Big bold paragraph</strong></p>

Dreamweaver generally does a great job of keeping tags properly nested or contained 
within each other. When you choose to manipulate the code by hand, you should always 
keep good coding techniques in mind.

XHTML 1.0 Transitional
The language of HTML has continued to evolve over the years and there are a few 
diff erent page types currently in use. Unless you specifi cally change it, the default page 
type that Dreamweaver creates is named XHTML 1.0 Transitional. To keep things simple 
for now, think of XHTML (which was introduced around the year 2000), as a stricter 
version of the HTML language that was used to build the fi rst web pages in the 1990s, 
when the Web was fi rst created (for now, we’ll refer to this as HTML 4.0, although the 
technical details are a bit more complicated). XHTML was designed to make web pages 
more compatible with newer platforms, such as mobile phones and handheld devices. 
XHTML combines elements of HTML and XML, a language used to describe data. 
XML, or Extensible Markup Language, has become a popular method of exchanging 
information among seemingly unrelated applications, platforms, and systems. 

What’s the difference?
The diff erence between the HTML 4.0 specifi cation and XHTML is not terribly dramatic. 
The structure of the language changes somewhat with XHTML in that it becomes stricter. 
Whereas HTML 4.0 was very forgiving of coding practices such as overlapping or unclosed 
tags, XHTML requires that all tags be closed and properly nested. HTML 4.0 doesn’t care 
which case you use when constructing tags, but in XHTML, all tags must be lowercase. 
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Here’s an example of how HTML and XHTML might diff er. The break element is used to 
push or “break” content to the next line on a page. In HTML, you can do this by simply 
adding the opening tag <br>. In XHTML, all opening tags must also have a closing 
tag. The long way to do this would be <br></br>. However, there is special syntax in 
XHTML that lets you get away with less code, and this syntax is called self-closing. You 
can write tags to self-close by using a forward slash—making sure there is a space between 
the br and the forward slash—and then closing the bracket like so:

<br />

The result is a well-formed language that takes advantage of newer browsers and device 
platforms, while remaining compatible with older browsers. As noted previously, working 
with XHTML in Dreamweaver requires nothing more than creating a new page.

Explorations in code
Although this book occasionally refers to the code for examples, hand-coding is not a 
primary goal of these lessons. The best way to learn how code represents the layouts you 
are building visually is to switch to the Code view and explore what’s happening behind 
the scenes.

It’s important to remember that every button, panel, and menu in Dreamweaver represents 
some type of HTML tag, attribute, or value; very rarely will you learn something that is 
unrelated or proprietary to Dreamweaver alone. Think of the Dreamweaver workspace as 
a pretty face on the HTML language.
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A look at the Welcome Screen
A common fi xture in most CS6 applications is the Welcome Screen, which is a launching 
pad for new and recent documents. In Dreamweaver, the Welcome Screen appears when 
the application launches or when no documents are open. From the Welcome Screen, 
you can create new pages, create a new site, open a recent document, or use one of 
Dreamweaver’s many starter pages or layouts.

The Welcome Screen appears when you launch the application, or when no documents are open.

Here’s what you’ll fi nd on the Welcome Screen:

Open a Recent Item: A list of the last few documents you worked on appears in the 
far left column, or you can browse to open a diff erent fi le using the Open button at the 
bottom.

Create New: In addition to HTML pages, you can choose from a variety of new 
document formats, such as CSS, JavaScript, and XML. Dreamweaver is not just a web 
page-building tool, but also a superior text editor, making it ideal for creating many non-
HTML fi les. You can also defi ne a new Dreamweaver site using the link at the bottom, or 
choose the More folder for even more new fi le options.
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Top Features (videos): On the far right side of the Welcome Screen, there is a column 
that contains link to videos of Top Features. These videos explore some of the new top 
features of Dreamweaver CS6, including Fluid Grid Layouts, Business Catalyst, and the 
CSS Transitions panel among others. The videos are located on Adobe’s website, adobe.com, 
and when you click on one, Dreamweaver launches the site in your web browser to give 
you access to the video.

Creating, opening, and saving documents
The lessons throughout this book require that you create, save, and open existing fi les. 
You can accomplish most fi le-related tasks from the File menu at the top, or from the 
Welcome Screen that appears when you launch Dreamweaver.

Creating new documents
Dreamweaver creates text fi les most commonly in the form of HTML fi les (or web 
pages). It can also create fi les in a variety of text-based languages, including CSS, XML, 
JavaScript, and even Flash ActionScript. 

You can create blank fi les that you build from the ground up, or you can get started with a 
variety of layout templates and themes. You can create new documents from the File menu 
or from the Welcome Screen. Here, you’ll create a new page using the File menu.

The New Document dialog box gives you a choice of new fi les in a variety of formats and templates.
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1 To create a new document, choose File > New. The New Document dialog box appears. 

2 Select Blank Page and under the Page Type column, choose HTML. Under Layout, 
choose <none> to start a new blank document. Leave the DocType drop-down menu 
at its default. Press Create.

3 Choose File > Save or File > Save As to start the process of saving your document.

4 When prompted, choose a location for your fi le and assign it a name. Note that you 
must save HTML fi les with an .html extension, or they will not be interpreted properly 
in a browser. This rule applies for fi les of any type (such as .xml, .css, and .cfm).

Opening a recently opened document

To open a document you’ve worked on recently, Choose File > Open Recent or, from 
the Welcome Screen, select a document under the Open a Recent Item column.

Now that you’ve seen what Dreamweaver can do, it’s time to put what you’ve learned into 
practice. Move to the next lesson so that you can begin building your fi rst Dreamweaver site!
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Self study
Explore the ready-to-use CSS layouts available in Dreamweaver by choosing File > New, 
then selecting HTML from the Page Type column. Browse the options listed in the Layout 
column and open a few layouts. Identify some that you’d like to use as a starting point for 
any future project.

Review 
Questions
1 From what two locations in Dreamweaver can a new document be created?

2 In what three views does Dreamweaver allow you to view and edit documents?

3 True or False: When a web page is requested, it is delivered to a user’s browser as a 
completed, fl at fi le ready for viewing.

Answers
1 From the Welcome Screen or by choosing File > New. 

2 Design, Split, and Code views. 

3 False. Files are delivered individually; the browser uses HTML code to assemble the 
resources together to display a fi nished page.
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