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Introduction to the IDE

WHAT’S IN THIS CHAPTER

 ➤ Confi guring the Visual Studio IDE for Visual Basic development

 ➤ Understanding projects and solutions

 ➤ Creating a simple project

 ➤ Copying solutions

WROX.COM CODE DOWNLOADS FOR THIS CHAPTER

There are no code downloads for this chapter.

INTRODUCING THE IDE

The chapters in the fi rst part of this book describe the Visual Studio integrated development 
environment (IDE). They explain the most important windows, menus, and toolbars that 
make up the environment, and show how to customize them to suit your needs. They explain 
some of the tools that provide help while you are writing Visual Basic applications and how to 
use the IDE to debug programs.

Even if you are an experienced Visual Basic programmer, you should at least skim this 
 material. The IDE is extremely complex and provides hundreds (if not thousands) of 
 commands, menus, toolbars, windows, context menus, and other tools for editing, running, 
and debugging Visual Basic projects.

Even after you’ve read these chapters, you should periodically spend some time wandering 
through the IDE to see what you’ve missed. Every month or so, spend a few minutes exploring 
little-used menus and right-clicking things to see what their context menus contain. As you 
become a more profi cient Visual Basic programmer, you will fi nd uses for tools that you may 
have dismissed or not understood before.

1
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4 ❘ CHAPTER 1 INTRODUCTION TO THE IDE

This chapter explains how to get started using the IDE. It tells how to confi gure the IDE for 
 different kinds of development. It explains Visual Basic projects and solutions, and shows how 
to create, run, and save new projects. This chapter is mostly an introduction to the chapters that 
 follow. The other chapters in this part of the book provide much more detail about particular tasks, 
such as using the IDE’s menus, customizing menus and toolbars, and using the Windows Forms 
Designer to build forms.

DIFFERENT IDE APPEARANCES

Before you start reading about the IDE and viewing screen shots, it’s important to understand 
that the Visual Studio IDE is extremely customizable. You can move, hide, or modify the menus, 
toolbars, and windows; create your own toolbars; dock, undock, or rearrange the toolbars and 
windows; and change the behavior of the built-in text editors (change their indentation, colors for 
different kinds of text, and so forth).

NOTE These chapters describe the basic Visual Studio development environment 
as it is initially installed. After you’ve moved things around to suit your needs, 
your IDE may look nothing like the pictures in this book. If a fi gure doesn’t look 
exactly like what you see on your computer, don’t worry too much about it.

To avoid confusion, you should probably not customize the IDE’s basic menus and toolbars too 
much. Removing the help commands from the Help menu and adding them to the Edit menu will 
only cause confusion later. Moving or removing commands will also make it more diffi cult to follow 
the examples in this and other books, and will make it more diffi cult to follow instructions given by 
others who might be able to help you when you have problems.

Instead of making drastic changes to the default menus and toolbars, hide the menus and toolbars 
that you don’t want and create new customized toolbars to suit your needs. Then you can fi nd the 
original standard toolbars if you decide you need them later.

The screens shown in this book may not look exactly like the ones on your system for several other 
reasons as well. Visual Studio looks different on different operating systems. The fi gures in this 
book were taken on a computer running Windows 8 so they display the Windows 8 look and feel. 
Additionally, some commands may not behave exactly the same way on different operating systems.

Visual Studio will also look different depending on which version you have installed. The 
free Visual Basic 2012 Express Edition product has fewer tools than other editions such as the 
high-end Team Suite. The fi gures in this book were captured while using Team Suite, so if you have 
another version, you may not see all of the tools shown here. Menu items, toolbars, and other details 
may also be slightly different for different versions. Usually you can fi nd moved items with a little 
digging through the menus and customizations.
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IDE Confi gurations ❘ 5

FOR MORE INFORMATION

You can learn about Visual Studio’s free Express editions at http://www
.microsoft.com/express. Learn about Visual Basic in general at the Visual 
Basic homepage: http://msdn.microsoft.com/vbasic.

Finally, you may be using different confi guration settings from the ones used while writing this 
book. You can confi gure Visual Studio to use settings customized for developing projects using 
Visual Basic, C#, web tools, and other technologies. This book assumes your installation is 
 confi gured for Visual Basic development, and the screen shots may look different if you have selected 
a different confi guration. The following section says more about different IDE confi gurations and 
tells how you can select a particular confi guration.

IDE CONFIGURATIONS

When you install it, Visual Studio asks you what kinds of development settings you want to use. The 
most obvious choice for a Visual Basic developer is Visual Basic Development Settings. This choice 
customizes Visual Studio to work more easily with Visual Basic, and is a good selection if you will 
focus on Visual Basic development.

Another reasonable choice is General Development Settings. This option makes Visual Studio behave 
more like Visual Studio 2003. It’s a good choice if you’re used to Visual Studio 2003, or if you expect 
to use other Visual Studio languages, such as C#, somewhat regularly because these settings are fairly 
effective for C# development and Visual Basic development.

This book assumes that you have confi gured 
Visual Studio for Visual Basic development. If you 
have chosen a different confi guration, some of the 
 fi gures in this book may look different from what 
you see on your screen. Some of the menu items 
available may be slightly different, or may appear 
in a different order. Usually, the items are available 
somewhere, but you may have to search a bit to 
fi nd them.

If you later decide that you want to switch 
 confi gurations, open the Tools menu and select 
Import and Export Settings to display the Import 
and Export Settings Wizard. Select the Reset All 
Settings option button and click Next. On the 
second page, tell the wizard whether to save your 
current settings and click Next. On the wizard’s 
fi nal page (shown in Figure 1-1), select the type of 
confi guration you want and click Finish. When 
the wizard is done, click Close.

FIGURE 1-1: Use the Tools menu’s Import and 

Export Settings command to change the Visual 

Studio confi guration.
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6 ❘ CHAPTER 1 INTRODUCTION TO THE IDE

PROJECTS AND SOLUTIONS

Visual Studio groups fi les into projects and solutions. A project is a group of fi les that produces 
some specifi c output. This output may take many forms such as a compiled executable program, a 
dynamic-link library (DLL) of classes for use by other projects, or a control library for use on other 
Windows forms.

A solution is a group of one or more projects that should be managed together. For example, 
 suppose that you are building a server application that provides access to your customer order 
 database. You are also building a client program that each of your sales representatives will use to 
query the server application. Because these two projects are closely related, it might make sense 
to manage them in a single solution. When you open the solution, you get instant access to all the 
fi les in both projects.

Both projects and solutions can include associated fi les that are useful for building the application 
but that do not become part of a fi nal compiled product. For example, a project might include the 
application’s proposal and architecture documents. These are not included in the compiled code, 
but it can be useful to associate them with the project so they are easy to fi nd, open, and edit while 
you are working on the project.

When you open the project, Visual Studio lists those documents along with the program fi les. If you 
double-click one of these documents, Visual Studio opens the fi le using an appropriate application. 
For example, if you double-click a fi le with a .doc, .docm, or .docx extension, Visual Studio 
normally opens it with Microsoft Word.

To associate one of these fi les with a project or solution, right-click the project fi le at the top of the 
Solution Explorer (more on the Solution Explorer shortly). In the context menu that appears, select 
the Add command’s New Item entry, and use the resulting dialog box to select the fi le you want to add.

CUT OUT CLUTTER

You can add any fi le to a project or solution, but it’s not a good idea to cram dozens 
of unrelated fi les into the same project. Although you may sometimes want to refer 
to an unrelated fi le while working on a project, the extra clutter brings additional 
chances for confusion. It will be less confusing to shrink the Visual Basic IDE to 
an icon and open the fi le using an external editor such as Word or WordPad. If you 
won’t use a fi le very often with the project, don’t add it.

STARTING THE IDE

When you launch Visual Studio, it initially displays the Start Page shown in Figure 1-2 by default. 
The Start Page’s Recent Projects section lists projects that you have worked on recently and provides 
links that let you open an existing project or website, or create a new project or website. The Get 
Started tab contains links to help topics that may be useful to beginners.
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Starting the IDE ❘ 7

Click the Guidance and Resources tab to see general development topics such as a development 
 overview, information about managing source code, and information about unit testing.

Click the Latest News tab to see an RSS feed listing current articles and stories about Visual Studio 
development. To change the feed, simply enter a new URL in the tab’s text box.

Use the links on the left of the Start Page to open or create new projects. Click New Project to start 
a new project. Click Open Project to browse for a project to open. Click one of the Recent Project 
links to quickly open a project that you have recently edited.

Instead of displaying the Start Page, Visual Studio can take one of several other actions when it 
starts. To change the startup action, open the Tools menu and select Options. Then select the Show 
All Settings check box at the bottom of the dialog box so you can see all of the options and open 
the Environment folder’s Startup item. In the At Startup drop-down box, you can select one of the 
 following options:

 ➤ Open Home Page

 ➤ Load Last Loaded Solution

 ➤ Show Open Project Dialog Box

 ➤ Show New Project Dialog Box

FIGURE 1-2: By default, Visual Studio initially displays the Start Page.
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8 ❘ CHAPTER 1 INTRODUCTION TO THE IDE

 ➤ Show Empty Environment

 ➤ Show Start Page

Pick one and click OK.

CREATING A PROJECT

After you open Visual Studio, you can use the Start Page’s New Project link or the File menu’s New 
Project command to open the New Project dialog box shown in Figure 1-3.

FIGURE 1-3: The New Project dialog box lets you start a new project.

Use the Templates tree view on the left to select the project category that you want. Then select a 
specifi c project type on the right. In Figure 1-3, the Windows Forms Application project type 
is selected. Enter a name for the new project in the text box at the bottom.

After you fi ll in the new project’s information, click OK to create the project.

NOTE Visual Studio initially creates the project in a temporary directory. If you 
close the project without saving it, it is discarded.
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Creating a Project ❘ 9

Figure 1-4 shows the IDE immediately after starting a new Windows Forms Application project. 
Remember that the IDE is extremely confi gurable, so it may not look much like Figure 1-4 after you 
have rearranged things to your liking (and I’ve arranged things to my liking here).

1

2

3 5

6

7

4

FIGURE 1-4: Initially a new project looks more or less like this.

The key pieces of the IDE are labeled with numbers in Figure 1-4. The following list briefl y 
describes each of these pieces:

 1. Menus — The menus contain standard Visual Studio commands. These generally manipu-
late the current solution and the modules it contains, although you can customize the menus 
as needed. Visual Studio changes the menus and their contents depending on the object you 
currently have selected. In Figure 1-4, a Form Designer (marked with the number 4) is open 
so the IDE is displaying the menus for editing forms.

 2. Toolbars — Toolbars contain tools that you can use to perform frequently needed actions. 
The same commands may be available in menus, but they are easier and faster to use in 
toolbars. The IDE defi nes several standard toolbars such as Formatting, Debug, and Image 
Editor. You can also build your own custom toolbars to hold your favorite tools. Visual 
Studio changes the toolbars displayed to match the object you currently have selected.

 3. Toolbox — The Toolbox contains tools appropriate for the item that you currently have 
selected and for the project type that you are working on. In Figure 1-4, a Form Designer 
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10 ❘ CHAPTER 1 INTRODUCTION TO THE IDE

is selected in a Windows Forms application so the Toolbox contains tools appropriate for a 
Form Designer. These include Windows Forms controls and components, plus tools in the 
other Toolbox tabs.

 4. Form Designer — A Form Designer lets you modify the graphical design of a form. Select a 
control tool from the Toolbox, and click and drag to place an instance of the control on the 
form. Use the Properties window (marked with the number 6) to change the new control’s 
properties. In Figure 1-4, no control is selected, so the Properties window shows the 
form’s properties rather than a control’s.

 5. Solution Explorer — The Solution Explorer lets you manage the fi les associated with 
the  current solution. For example, in Figure 1-4, you could select Form1.vb in the Project 
Explorer and then click the View Code button (the second icon from the right at the 
top of the Solution Explorer) to open the form’s code editor. You can also right-click 
an object in the Solution Explorer to get a list of appropriate commands for that object.

 6. Properties — The Properties window lets you change an object’s properties at design time. 
When you select an object in a Form Designer or in the Solution Explorer, the Properties 
window displays that object’s properties. To change a property’s value, simply click the 
property and enter the new value.

 7. Error List — The Error List window shows errors and warnings in the current project. 
For example, if a program uses a variable that is not declared, this list will say so.

If you look at the bottom of Figure 1-4, you’ll notice that the Error List window has a series of tabs. 
The Task List tab displays items fl agged for further action such as To Do items. The Immediate 
window lets you type and execute Visual Basic commands, possibly while a program is running, 
but paused.

The Output tab shows output printed by the application. Usually an application interacts with the 
user through its forms and dialog boxes, but it can display information here, usually to help you 
debug the code.

WHAT WINDOWS?

If you don’t see the Error List, Task List, and other windows, they are probably 
hidden. You can display many of them by selecting the appropriate item in the 
View menu. Commands to display some of the more exotic windows are located in 
other menus, such as the View menu’s Other Windows submenu and the Debug 
menu’s Windows submenu.

As soon as you create a new project, it is ready to run. If you open the Debug menu and select Start 
Debugging, the program will run. It displays only an empty form containing no controls, but the 
form automatically handles a multitude of mundane windowing tasks for you.

c01.indd   10c01.indd   10 18/07/12   9:09 AM18/07/12   9:09 AM



Saving a Project ❘ 11

Before you write a single line of code, the form lets you resize, minimize, restore, maximize, and 
close the form. The form draws its title bar, borders, and system menu, and repaints itself as needed 
when it is covered and restored. The operating system also automatically handles many tasks such 
as displaying the form in the Windows taskbar and Task Manager. Some operating systems, such as 
Windows 7 and Vista, automatically generate thumbnail previews for the Flip and Flip 3D tools that 
you display by pressing Alt+Tab or Windows+Tab, respectively. Visual Basic and the operating 
system do a ton of work for you before you even touch the project!

The form contains no controls, can’t open fi les, doesn’t process data, in fact doesn’t really do 
anything unique, but a lot of the setup is done for you. It handles the windowing chores for you so 
you can focus on your particular problem.

SAVING A PROJECT

Later chapters explain in depth how to add controls 
to a form and how to write code to interact with the 
form. For now, suppose you have built a project 
complete with controls and code.

If you try to close Visual Studio or start a new project, 
the dialog box shown in Figure 1-5 appears. Click 
Save to make the Save Project dialog box shown in 
Figure 1-6 appear. Click Discard to throw away the 
existing project. Click Cancel to continue editing 
the current project.

READY TO RUN

If you’re using the Visual Basic environment settings, you can simply press F5 to 
start the program.

FIGURE 1-5: Before closing Visual Studio or 

starting a new project, you must decide what 

to do with the previous project.

FIGURE 1-6: Use this dialog box to save a new project.
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12 ❘ CHAPTER 1 INTRODUCTION TO THE IDE

As you work with the new project, Visual Studio saves its form defi nitions and code in a temporary 
location. Each time you run the program, Visual Studio updates the fi les so it doesn’t lose 
everything if it crashes. The fi les are still temporary, however.

When you are ready to make the new project permanent, open the File menu and select Save All to 
display the Save Project dialog box shown in Figure 1-6.

The Name fi eld shows the name that you originally gave the project when you created it. Verify 
that the name is okay or change it.

Next, enter the location where you want the project saved. The default location is similar to the 
rather non-intuitive value shown in Figure 1-6. (This image was taken while I was logged in as 
the user named Developer. When you save a project, the “Developer” part of the location would be 
replaced with your username.)

Be sure to pick a good location before you click Save. The next time you build a project, the 
default will be the location you specify now so you won’t need to be quite as careful in the future, 
assuming you want to build a lot of projects in the same directory.

If you check the Create Directory for Solution box, Visual Studio enables the Solution Name text 
box and adds an extra directory above the project directory to hold the solution. This is most 
useful when you want to include more than one project in a single solution. For example, you might 
want several projects in the same solution to sit in a common solution directory.

If you have Team Foundation Server installed, you can check the Add to Source Control box to 
place the new project’s code under source control.

After you have entered the project name and location, and optionally specifi ed a separate solution 
directory, click Save.

“SAVE AS” SURVIVAL SKILLS

The File menu’s Save As commands let you save particular pieces of the  solution 
in new fi les. For example, if you have a project named Offi ceArrangerMain 
selected in Project Explorer, the File menu contains a command named Save 
Offi ceArrangerMain As. This command lets you save the project fi le with a new 
name. Unfortunately it doesn’t make a new copy of the whole project; it just makes 
a copy of the project fi le. That fi le contains information about the project on a high 
level such as references used by the project, fi les imported by the project, and the 
names of the forms included in the project. It does not contain the forms themselves.

Many beginners try to use the File menu’s Save As commands to make copies of a 
project or a solution, but that doesn’t work. Instead, use Windows Explorer to 
fi nd the directory containing the whole project or solution and make a copy of the 
entire directory.

Similarly, if you want to back up a project or send someone a copy of a project, you 
need to use the entire solution directory, not just one or two of the many fi les that 
Visual Studio creates.
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Summary ❘ 13

SUMMARY

This chapter explained how to get started using the Visual Studio integrated development 
 environment. It showed how to confi gure the IDE for different kinds of development and explained 
that different confi gurations might make your version of Visual Studio look different from the 
screen shots shown in this book. It explained what Visual Basic projects and solutions are, 
and showed how to create, run, and save a new project.

The next few chapters describe parts of the IDE in greater detail. Chapter 2, “Menus, Toolbars, 
and Windows,” describes the commands available in the IDE and the menus, toolbars, and 
secondary windows that hold them.
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