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Excel in a Nutshell
In This Chapter

● What’s new in Excel 2013?

● The object model concept in Excel

● The workings of workbooks

● The user interface

● The two types of cell formatting

● Worksheet formulas and functions

● Objects on the worksheet’s invisible drawing layer

● Macros, toolbars, and add-ins for Excel customization

● Internet features

● Analysis tools

● Protection options

Microsoft Excel has been referred to as “the best application ever written for Windows.” You may or 
may not agree with that statement, but you can’t deny that Excel is one of the oldest Windows prod-
ucts and has undergone many reincarnations and face lifts over the years. Cosmetically, the current 
version — Excel 2013 — barely even resembles the original version. However, many of Excel’s key 
elements have remained intact over the years, with significant enhancements, of course.

This chapter presents a concise overview of the features available in the more recent versions of 
Excel, with specific emphasis on Excel 2013. It sets the stage for the subsequent chapters and pro-
vides an overview for those who may have let their Excel skills get rusty.
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Part I: Basic Information10

Excel: What Is It Good For?
Much of the appeal of Excel is that it’s so versatile. Excel’s forte, of course, is performing numerical 
calculations, but Excel is also very useful for non-numeric applications. Here are just a few uses 
for Excel:

➤ Number crunching: Create budgets, tabulate expenses, analyze survey results, and perform 
just about any type of financial analysis you can think of.

➤ Creating charts: Create a wide variety of highly customizable charts.

➤ Organizing lists: Use the row-and-column layout to store lists efficiently.

➤ Text manipulation: Excel is a good tool for cleaning up and standardizing text-based data.

➤ Accessing other data: Import data from a wide variety of sources.

➤ Creating graphical dashboards: Summarize a large amount of business information in a 
concise format.

➤ Creating graphics and diagrams: Use Shapes and SmartArt to create professional-looking 
diagrams.

➤ Automating complex tasks: Perform a tedious task with a single mouse click with Excel’s 
macro capabilities.

This book focuses on a single aspect of Excel: formulas. As you’ll see, formulas play a significant role 
in all the tasks listed here.

What’s New in Excel 2013?
When a new version of Microsoft Office is released, sometimes Excel gets lots of new features — and 
sometimes it gets very few new features. In the case of Office 2013, Excel got quite a few new fea-
tures, but nothing truly earth-shattering.

Here’s a quick summary of what’s new in Excel 2013, relative to Excel 2010:

➤ Cloud storage: Excel is tightly integrated with Microsoft’s SkyDrive web-based storage.

➤ Support for other devices: Excel is available for other devices, including touch-sensitive 
devices, such as Windows RT tablets and Windows phones.

➤ New aesthetics: Excel has a new “flat” look and displays an (optional) graphic in the title bar. 
Cursor movements and chart updates are animated, making it easier to see changes. Color 
schemes are no longer supported, and the Ribbon is hidden by default.

➤ Single document interface: Excel no longer supports the option to display multiple work-
books in a single window. Each workbook has its own top-level Excel window and Ribbon.

New Feature
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Chapter 1: Excel in a Nutshell 11

➤ New types of assistance: Excel provides recommended pivot tables and recommended 
charts.

➤ Fill Flash: This is a new way to extract (by example) relevant data from text strings. You can 
also use this feature to combine data in multiple columns.

➤ Support for Office Apps: You can download or purchase apps that can be embedded in a 
workbook file.

➤ Pivot charts: You can create pivot charts without creating a pivot table.

➤ New Slicer option: The Slicer feature, introduced in Excel 2010 for use with pivot tables, has 
been expanded and now works with tables.

➤ Timeline filtering: Similar to Slicers, a Timeline makes it easy to filter data by dates.

➤ Quick Analysis: This feature provides single-click access to various data analysis tools.

➤ Enhanced chart formatting: Modifying charts is significantly easier.

➤ New worksheet functions: Excel 2013 supports dozens of new worksheet functions.

➤ Backstage: The Backstage screen has been reorganized and is easier to use.

➤ New add-ins: Three new add-ins are included (for Office Professional Plus only): PowerPivot, 
Power View, and Inquire.

The Object Model Concept
If you’ve dealt with computers for any length of time, you’ve undoubtedly heard the term “object-
oriented programming” (OOP). An object essentially represents a software element that a program-
mer can manipulate. When using Excel, you may find it useful to think in terms of objects, even if you 
have no intention of becoming a programmer. An object-oriented approach can often help you keep 
the various elements in perspective.

Excel objects include the following:

➤ Excel itself

➤ An Excel workbook

➤ A worksheet in a workbook

➤ A range in a worksheet

➤ A button on a worksheet

➤ A ListBox control on a UserForm (a custom dialog box)

➤ A chart sheet

➤ A chart series in a chart

05_9781118490440-ch01.indd   1105_9781118490440-ch01.indd   11 3/5/13   10:36 AM3/5/13   10:36 AM



Part I: Basic Information12

Notice the existence of an object hierarchy: The Excel object contains workbook objects, which con-
tain worksheet objects, which contain range objects. This hierarchy is called Excel’s object model. 
Other Microsoft Office products have their own object model. The object model concept proves to 
be vitally important when developing VBA macros. Even if you don’t create macros, you may find it 
helpful to think in terms of objects.

The Workings of Workbooks
The core document of Excel is a workbook. Everything that you do in Excel takes place in a workbook.

Beginning with Excel 2007, workbook “files” are actually compressed folders. You may be familiar 
with compressed folders if you’ve ever used a file with a .zip extension. Inside the compressed folders 
are a number of files that hold all the information about your workbook, including charts, macros, 
formatting, and the data in its cells.

Tip  

If you’re the curious type, make a copy of an XLSX workbook file and add a .zip exten-
sion to the filename. Then unzip the file to see what’s inside.

An Excel workbook can hold any number of sheets. The four types of sheets are

➤ Worksheets

➤ Chart sheets

➤ MS Excel 4.0 macro sheets (obsolete, but still supported)

➤ MS Excel 5.0 dialog sheets (obsolete, but still supported)

You can open or create as many workbooks as you want (each in its own window), but only one 
workbook is the active workbook at any given time. Similarly, only one sheet in a workbook is the 
active sheet. To activate a different sheet, click its corresponding tab at the bottom of the window, or 
press Ctrl+PgUp (for the previous sheet) or Ctrl+PgDn (for the next sheet). To change a sheet’s name, 
double-click its Sheet tab and type the new text for the name. Right-clicking a tab brings up a short-
cut menu with some additional sheet-manipulation options.

You can also hide the window that contains a workbook by using the View➜Window➜Hide com-
mand. A hidden workbook window remains open but not visible. Use the View➜Window➜Unhide 
command to make the window visible again. A single workbook can display in multiple windows 
(choose View➜Window➜New Window). Each window can display a different sheet or a different 
area of the same sheet.

Worksheets
The most common type of sheet is a worksheet — which you normally think of when you think of a 
spreadsheet. Excel 2013 worksheets have 16,384 columns and 1,048,576 rows.
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Chapter 1: Excel in a Nutshell 13

Note  

Versions prior to Excel 2007 support only 256 columns and 65,536 rows. If you open 
such a file, Excel enters compatibility mode to work with the smaller worksheet grid. To 
work with the larger grid, you must save the file in one of the newer Excel formats (XLSX 
or XLSM). Then close the workbook and reopen it. XLSM files can contain macros; XLSX 
files cannot.

Having access to more cells isn’t the real value of using multiple worksheets in a workbook. Rather, 
multiple worksheets are valuable because they enable you to organize your work better. Back in the 
old days, when a spreadsheet file consisted of a single worksheet, developers wasted a lot of time 
trying to organize the worksheet to hold their information efficiently. Now, you can store information 
on any number of worksheets and still access it instantly.

You have complete control over the column widths and row heights, and you can even hide rows 
and columns (as well as entire worksheets). You can display the contents of a cell vertically (or at an 
angle) and even wrap around to occupy multiple lines. In addition, you can merge cells together to 
form a larger cell.

Chart sheets
A chart sheet holds a single chart. Many users ignore chart sheets, preferring to use embedded 
charts, which are stored on the worksheet’s drawing layer. Using chart sheets is optional, but they 
make it a bit easier to locate a particular chart, and they prove especially useful for presentations. I 
discuss embedded charts (or floating charts on a worksheet) later in this chapter.

How big is a worksheet?
It’s interesting to stop and think about the actual size of a worksheet. Do the arithmetic (16,384 × 
1,048,576), and you’ll see that a worksheet has 17,179,869,184 cells. Remember that this is in just 
one worksheet. A single workbook can hold more than one worksheet.

If you’re using a 1920 x 1200 video mode with the default row heights and column widths, you can 
see 29 columns and 47 rows (or 1,363 cells) at a time — which is about .0000079 percent of the 
entire worksheet. In other words, more than 12.6 million screens of information reside within a sin-
gle worksheet.

If you entered a single digit into each cell at the relatively rapid clip of one cell per second, it would 
take you more than 500 years, nonstop, to fill up a worksheet. To print the results of your efforts 
would require more than 36 million sheets of paper — a stack about 12,000 feet high (that’s 10 
Empire State Buildings stacked on top of each other).
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Part I: Basic Information14

Macro sheets and dialog sheets
This section discusses two obsolete Excel features that continue to be supported.

An Excel 4.0 macro sheet is a worksheet that has some different defaults. Its purpose is to hold XLM 
macros. XLM is the macro system used in Excel version 4.0 and earlier. This macro system was 
replaced by VBA in Excel 5.0 and is not discussed in this book.

An Excel 5.0 dialog sheet is a drawing grid that can hold text and controls. In Excel 5.0 and Excel 95, 
dialog sheets were used to make custom dialog boxes. UserForms were introduced in Excel 97 to 
replace these sheets.

The Excel User Interface
A user interface (UI) is the means by which an end user communicates with a computer program. 
Almost every Windows program that you use employs a menu and toolbar approach. That is, at the 
top of the screen is a menu bar that contains virtually every command available in the application, 
and below that is at least one toolbar, which provides shortcuts to some of the more frequently used 
commands.

With the release of Office 2007, though, the days of menus and toolbars are over. The UI for Excel 
consists of the following components:

➤ Tabs and the Ribbon

➤ The Quick Access toolbar

➤ Right-click (shortcut) menus

➤ The mini-toolbar

➤ Dialog boxes

➤ Keyboard shortcuts

➤ Task panes

The Ribbon
The Ribbon is the primary UI component in Excel. Replacing the traditional menu and most toolbars 
common in previous versions, its introduction in Excel 2007 was a significant departure from the 
interfaces of most Windows-based applications.

Microsoft felt that the commands contained in the old menu and toolbar system were becoming so 
numerous that a new paradigm was necessary. One of the main goals for developing the Ribbon was 
to provide the user with a single place to look for a particular feature. Every commonly used com-
mand available in Excel would be contained in the Ribbon (or in a dialog box or task pane accessed 
via the Ribbon). Although Microsoft succeeded in putting most of the available commands on the 
Ribbon, it’s still a pretty big place.
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Chapter 1: Excel in a Nutshell 15

When introduced in Office 2007, the Ribbon received mixed reviews. Some people hated it, and oth-
ers loved it. For some, the hatred was so severe that they sought Excel 2007 add-ins that restored the 
old menus. Others set up online petitions, asking Microsoft to restore the old menus for Office. Fact 
is, the Ribbon is here to stay. After you get used to the Ribbon, it really is easier to use than the con-
voluted menu system that it replaced.

Note  

A few commands failed to make the cut and do not appear on the Ribbon, but they are 
still available if you know where to look for them. Right-click the Quick Access toolbar 
and choose Customize Quick Access Toolbar. Excel displays a dialog box with a list of 
commands that you can add to your Quick Access toolbar. Some of these commands 
aren’t available elsewhere in the UI. You can also add new commands to the Ribbon: 
Right-click the Ribbon and select Customize The Ribbon.

Tabs, groups, and tools
The Ribbon is a band of tools that stretches across the top of the Excel window. About the vertical 
size of three of the old-style toolbars, the Ribbon sports a number of tabs, including Home, Insert, 
Page Layout, and others. On each tab are groups that contain related tools. On the Home tab, for 
example, you find the Clipboard group, the Font group, the Alignment group, and others.

Within the groups are tools, which are similar to the tools that existed on the old-style toolbars with 
one major difference: their different sizes. Tools that you use most often are larger than less-fre-
quently used tools. For example, nearly one-half of the Clipboard group is consumed by the large 
Paste tool; the Cut, Copy, and Format Painter tools are much smaller. Microsoft determined that the 
Paste tool is the most used tool and thus sized it accordingly.

The Ribbon and all its components resize dynamically as you resize the Excel window horizontally. 
Smaller Excel windows collapse the tools on compressed tabs and groups, and maximized Excel win-
dows on large monitors show everything that’s available. Even in a small window, all Ribbon com-
mands remain available. You just may need to click a few extra times to access them.

Figure 1-1 shows three sizes of the Ribbon when the Home tab is displayed, using an increasingly 
smaller horizontal window size.

Figure 1-1: The Ribbon sizes dynamically, depending on the horizontal size of Excel’s window.
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Navigation
Using the Ribbon is fairly easy with a mouse. You click a tab and then click a tool. If you prefer to use 
the keyboard, Microsoft has a feature just for you. Pressing Alt displays tiny squares with shortcut let-
ters in them that hover over their respective tab or tool. Each shortcut letter that you press either 
executes its command or drills down to another level of shortcut letters. Pressing Esc cancels the let-
ters or moves up to the previous level.

For example, a keystroke sequence of Alt+HBB adds a double border to the bottom of the selection. 
The Alt key activates the shortcut letters, the H shortcut activates the Home tab, the B shortcut acti-
vates the Borders tool menu, and the second B shortcut executes the Bottom Double Border com-
mand. Note that you don’t have to keep the Alt key depressed while you press the other keys.

Contextual tabs
The Ribbon contains tabs that are visible only when they are needed. Generally, when a hidden tab 
appears, it’s because you selected an object or a range with special characteristics (like a chart or a 
pivot table). A typical example is the Drawing Tools contextual tab. When you select a shape or 
WordArt object, the Drawing Tools tab is made visible and active. It contains many tools that are 
applicable only to shapes, such as shape-formatting tools.

Dialog box launchers
At the bottom of many of the Ribbon groups is a small box icon (a dialog box launcher) that opens a 
dialog box related to that group. Some of the icons open the same dialog boxes but to different 
areas. For instance, the Font group icon opens the Format Cells dialog box with the Font tab acti-
vated. The Alignment group opens the same dialog box, but activates the Alignment tab. The Ribbon 
makes using dialog boxes a far less–frequent activity than in the past because most of the commonly 
used operations can be done directly from the Ribbon.

Galleries and Live Preview
A gallery is a large collection of tools that look like the choice they represent. The Styles gallery, for 
example, does not just list the name of the style but also displays it in the same formatting that will 
be applied to the cell.

Although galleries help to give you an idea of what your object will look like when an option is selected, 
Live Preview takes it to the next level. Live Preview displays your object or data as it will look right on 
the worksheet when you hover over the gallery tool. By hovering over the various tools in the Format 
Table gallery, you can see exactly what your table will look like before you commit to a format.

Backstage View
The File tab is unlike the other tabs. Clicking the File tab doesn’t change the Ribbon but takes you to 
the Backstage View (see Figure 1-2). This is where you perform most of the document-related activi-
ties: creating new workbooks, opening files, saving files, printing, and so on.
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Figure 1-2: Clicking the File tab takes you to the Backstage View.

The Open tab in Backstage View also contains the list of recent documents (as many as 50), with a 
pushpin icon next to each entry that you can use to keep that document at the top of the list regard-
less of how many files you open and close.

Plus, Backstage View gives you access to the Excel Options dialog box, which contains dozens of set-
tings for customizing Excel.

Shortcut menus and the mini toolbar
Excel also features dozens of shortcut menus. These menus appear when you right-click after select-
ing one or more objects. The shortcut menus are context sensitive. In other words, the menu that 
appears depends on the location of the mouse pointer when you right-click. You can right-click just 
about anything — a cell, a row or column border, a workbook title bar, and so on.

Right-clicking items often displays the shortcut menu as well as a mini toolbar, which is a floating 
toolbar that contains a dozen or so of the most popular formatting commands. Figure 1-3 shows the 
shortcut menu and mini toolbar when a cell is selected.
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Part I: Basic Information18

Figure 1-3: The shortcut menu and mini toolbar appear when you right-click a cell or selected range.

Dialog boxes
Some Ribbon commands display a dialog box, from which you can specify options or issue other 
commands. You’ll find two general classes of dialog boxes in Excel:

➤ Modal dialog boxes: When a modal dialog box is displayed, it must be closed to execute the 
commands. An example is the Format Cells dialog box. None of the options you specify is 
executed until you click OK. Or click the Cancel button to close the dialog box without mak-
ing any changes.

➤ Modeless dialog boxes: These are stay-on-top dialog boxes. An example is the Find and 
Replace dialog box. Modeless dialog boxes usually have a Close button rather than OK and 
Cancel buttons.

Some Excel dialog boxes use a notebook tab metaphor, which makes a single dialog box function as 
several different dialog boxes. An example is the Format Cells dialog box, shown in Figure 1-4.
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Figure 1-4: Tabbed dialog boxes make many options accessible without overwhelming the user.

Customizing the UI
The Quick Access toolbar is a set of tools that the user can customize. By default, the Quick Access 
toolbar contains three tools: Save, Undo, and Redo. If you find that you use a particular Ribbon com-
mand frequently, right-click the command and choose Add to Quick Access Toolbar. You can make 
other changes to the Quick Access toolbar from the Quick Access Toolbar tab of the Excel Options 
dialog box. To access this dialog box, right-click the Quick Access toolbar and choose Customize 
Quick Access Toolbar.

You can also customize the Ribbon by using the Customize Ribbon tab of the Excel Options dialog 
box. Choose File➜Options to display the Excel Options dialog box.

You can customize the Ribbon in these ways:

➤ Add a new tab.

➤ Add a new group to a tab.

➤ Add commands to a group.

➤ Remove groups from a tab.

➤ Remove commands from custom groups.
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➤ Change the order of the tabs.

➤ Change the order of the groups within a tab.

➤ Change the name of a tab.

➤ Change the name of a group.

➤ Move a group to a different tab

➤ Reset the Ribbon to remove all customizations.

That’s a fairly comprehensive list of customization options, but there are some actions that you 
cannot do:

➤ You cannot remove built-in tabs — but you can hide them.

➤ You cannot remove commands from built-in groups.

➤ You cannot change the order of commands in a built-in group.

Task panes
Yet another user interface element is the task pane. Task panes appear automatically in response to 
several commands. For example, to work with a picture, right-click the image and choose Format 
Picture. Excel responds by displaying the Format Picture task pane, shown in Figure 1-5. The task 
pane is similar to a dialog box except that you can keep it visible as long as it’s needed.

New Feature 

The role of task panes has increased dramatically in Excel 2013. For example, when 
working with a chart, you can access a task pane that has an extensive selection of com-
mands for every element within the chart.

Many of the task panes are very complex. For example, the Format Picture task pane has four icons 
along the top. Clicking an icon changes the command lists displayed below. Click an item in a com-
mand list, and it expands to show the options.

By default, the task pane is docked on the right side of the Excel window, but you can move it any-
where you like by clicking the title text and dragging. Excel remembers the last position, so the next 
time you use that task pane, it will be where you left it. There’s no OK button in a task pane. When 
you’re finished using a task pane, click the Close button (X) in the upper-right corner.

Keyboard shortcuts
Excel has many useful keyboard shortcuts. For example, you can press Ctrl+D to copy a cell to selected 
cells below it. If you’re a newcomer to Excel — or you just want to improve your efficiency — I urge you 
to check out the Help system. (Search for keyboard and go from there.) Learning these shortcuts is key 
to becoming proficient in Excel. The Help file has tables that summarize useful keyboard commands 
and shortcuts.

05_9781118490440-ch01.indd   2005_9781118490440-ch01.indd   20 3/5/13   10:36 AM3/5/13   10:36 AM



Chapter 1: Excel in a Nutshell 21

Figure 1-5: The Format Picture task pane allows you to adjust and format an embedded picture.

Customized onscreen display
Excel offers some flexibility regarding onscreen display (status bar, Formula bar, the Ribbon, and so 
on). For example, click the Ribbon Display Options control (in the title bar) and you can choose how 
to display the Ribbon. You can hide everything except the title bar, thereby maximizing the amount 
of visible information.

The status bar at the bottom of the screen can be customized. Right-click the status bar and you see 
lots of options that allow you to control what information is displayed in the status bar.

Many other customizations can be made by choosing File➜Options and clicking the Advanced tab. 
On this tab are several sections that deal with what displays onscreen.

Object and cell selecting
Generally, selecting objects in Excel conforms to standard Windows practices. You can select a range 
of cells by using the keyboard (press the Shift key, along with the arrow keys) or by clicking and drag-
ging the mouse. To select a large range, click a cell at any corner of the range, scroll to the opposite 
corner of the range, and press Shift while you click the opposite corner cell.

You can use Ctrl+* (asterisk) to select an entire table. And when a large range is selected, you can use 
Ctrl+. (period) to move among the four corners of the range.

Clicking an object placed on the drawing layer selects the object. An exception occurs if the object 
has a macro assigned to it. In such a case, clicking the object executes the macro. To select multiple 
objects or noncontiguous cells, press Ctrl while you select the objects or cells.
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The Excel Help System
One of Excel’s most important features is its Help system. The Help icon (a question mark), is located 
near the upper-right corner of the Excel window. Clicking the Help icon or pressing the F1 function 
key displays the Help system window. Figure 1-6 shows an example.

By default, the content shown is downloaded from the Microsoft Office website. If you do not have 
Internet access or you prefer to limit Help to articles on your computer, click the arrow to the right of 
the title of the Help window and choose Excel Help from Your Computer.

Cell Formatting
Excel provides two types of cell formatting — numeric formatting and stylistic formatting.

Numeric formatting
Numeric formatting refers to how a value appears in the cell. In addition to choosing from an 
extensive list of predefined formats, you can create your own custom number formats in the 
Number tab of the Format Cells dialog box. (Choose the dialog box launcher at the bottom of the 
Home➜Number group.)

Changing your mind
You can reverse almost every action in Excel by using the Undo command, located on the Quick 
Access toolbar. Click Undo (or press Ctrl+Z) after issuing a command in error, and it’s as if you never 
issued the command. You can reverse the effects of the past 100 actions that you performed by exe-
cuting Undo more than once.

Click the arrow on the right side of the Undo button to see a list of the actions that you can reverse. 
Click an item in that list to undo that action and all the subsequent actions you performed.

You can’t reverse every action, however. Generally, anything that you do using the File button can’t 
be undone. For example, if you save a file and realize that you’ve overwritten a good copy with a 
bad one, Undo can’t save the day. You’re just out of luck unless you have a backup of the file. Also, 
changes made by a macro cannot be undone. In fact, executing a macro that changes the workbook 
clears the Undo list.

The Redo button, also on the Quick Access toolbar, performs the opposite of the Undo button: 
Redo reissues commands that have been undone. If nothing has been undone, this command is 
not available.
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Figure 1-6: The Excel Help system window.

Excel applies some numeric formatting automatically, based on the entry. For example, if you pre-
cede a value with your local currency symbol (such as a dollar sign), Excel applies Currency number 
formatting. If you append a percent symbol, Excel applies Percent formatting.

Cross-Ref 

Refer to Appendix B for additional information about creating custom number formats.

The number format doesn’t affect the actual value stored in the cell. For example, suppose that a cell 
contains the value 3.14159. If you apply a format to display two decimal places, the number appears 
as 3.14. When you use the cell in a formula, however, the actual value (3.14159) — not the displayed 
value — is used.

Stylistic formatting
Stylistic formatting refers to the cosmetic formatting (colors, shading, fonts, borders, and so on) that 
you apply to make your work look good. The Home➜Font and Home➜Styles groups contain com-
mands to format your cells and ranges.
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A formatting concept introduced in Excel 2007 is document themes. Basically, themes allow you to set 
many formatting options at once, such as font, colors, and cell styles. The formatting options con-
tained in a theme are designed to work well together. If you’re not feeling particularly artistic, you 
can apply a theme and know the colors won’t clash. All the commands for themes are in the Themes 
group of the Page Layout tab.

Don’t overlook Excel’s conditional formatting feature. This handy tool enables you to specify format-
ting that appears only when certain conditions are met. For example, you can make the cell’s interior 
red if the cell contains a negative number.

Cross-Ref 

See Chapter 19 for more information on conditional formatting.

Tables
A table is a specially designated range in a worksheet. Converting a range into a table makes it easier 
to perform many operations on that data.

The data in a table is related in a specific way. The rows represent related objects, and the columns 
represent specific pieces of information about each of those objects. If, for instance, you have a table 
of library books, each row would hold the information for one book. Columns might include title, 
author, publisher, date, and so on. In database terminology, the rows are records, and the columns 
are fields.

If your data is arranged in this fashion, you can designate it as a table by selecting the range or a cell 
in the range and then choosing Insert➜Tables➜Table. Excel inserts generic column headings if none 
exist; the column heading includes drop-down controls. These drop-down controls, as well as the 
Table Tools context tab on the Ribbon, provide quick access to many table-related features like sort-
ing, filtering, and formatting. In addition, using formulas within a table offers some clear advantages.

Cross-Ref 

See Chapter 9 for more information about using tables.

Worksheet Formulas and Functions
Formulas, of course, make a spreadsheet a spreadsheet. Excel’s formula-building capability is as good 
as it gets. You will discover this as you explore subsequent chapters in this book.

Worksheet functions allow you to perform calculations or operations that would otherwise be impos-
sible. Excel provides a huge number of built-in functions, including dozens of new functions intro-
duced in Excel 2013.
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See Chapter 4 for more information about worksheet functions.

A name represents an identifier that enables you to refer to a cell, range, value, or formula. Using names 
makes your formulas easier to create and read. As you’ll see, Excel handles names in some unique ways.

Cross-Ref 

I devote Chapter 3 entirely to names.

Objects on the Drawing Layer
Each worksheet has an invisible drawing layer, which holds shapes, SmartArt, charts, pictures, and 
controls (such as buttons and list boxes). I discuss some of these items in the following sections.

Shapes and illustrations
The Insert➜Illustrations group contains a variety of tools that let you insert various shapes, clip art, 
photos, and diagrams. Figure 1-7 shows some objects on the drawing layer of a worksheet.

Figure 1-7: Objects on a worksheet drawing layer. Excel makes a great doodle pad.

Cross-Ref
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Controls
You can insert a number of different controls on a worksheet. These controls come in two flavors — 
Form controls and ActiveX controls. Using controls on a worksheet can greatly enhance the work-
sheet’s usability — often without using macros. To insert a control, choose Developer➜Controls➜

Insert. Figure 1-8 shows a worksheet with various controls added to the drawing layer: a check box, 
two sets of option buttons, and a scroll bar.

Note  

The Ribbon’s Developer tab is not visible by default. To show the Developer tab, right-
click the Ribbon and choose Customize the Ribbon to display the Excel Options dialog 
box. In the list box on the right, place a check mark next to Developer.

On the Web 

To see how these controls work, the workbook shown in Figure 1-8 is available at this 
book’s website. The file is named activex worksheet controls.xlsx.

Figure 1-8: Excel enables you to add many controls directly to the drawing layer of a worksheet.

Charts
Excel, of course, has excellent charting capabilities. Enhancements in Excel 2013 make creating and 
customizing charts easier than ever.

Excel offers extensive chart customization options. Selecting a chart displays the Chart Tools contex-
tual tab, which contains basic tools to customize your chart. For more control, press Ctrl+1 to display 
the Format task pane for the selected elements. In addition, right-clicking a chart element displays a 
shortcut menu.
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You can easily create a free-floating chart by selecting the data to be charted and selecting one of 
the chart types from the Insert➜Charts group.

Cross-Ref 

Chapter 17 contains additional information about charts.

Sparkline graphics
A feature introduced in Excel 2010 is Sparkline graphics. A Sparkline is a chart that occupies a 
single cell. Sparklines are usually used in groups to provide a quick overview of trends in your data. 
Figure 1-9 shows a worksheet with Sparklines.

On the Web 

The workbook, which includes other Sparkline examples, is available at this book’s web-
site. The file is named sparkline examples.xlsx.

Figure 1-9: Sparkline graphics shows trends in your data.
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Customizing Excel
This section describes two features that enable you to customize Excel — macros and add-ins.

Macros
Excel’s VBA programming language is a powerful tool that can make Excel perform otherwise impos-
sible feats. You can classify the procedures that you create with VBA into two general types:

➤ Macros that automate various aspects of Excel

➤ Macros that serve as custom functions that you can use in worksheet formulas

Cross-Ref 

Part VI of this book describes how to use and create custom worksheet functions using 
VBA.

Add-in programs
An add-in is a program attached to Excel that gives it additional functionality. For example, you can 
store custom worksheet functions in an add-in. To attach an add-in, use the Add-Ins tab in the Excel 
Options dialog box.

Excel ships with quite a few add-ins, and you can purchase or download many third-party add-ins 
from online services. My Power Utility Pak is an example of an add-in. (Use the coupon at the back of 
the book to order a copy at a discounted price.)

Cross-Ref 

Chapter 24 describes how to create your own add-ins that contain custom worksheet 
functions.

Internet Features
Excel includes a number of features that relate to the Internet. For example, you can save a work-
sheet or an entire workbook in HTML format, accessible in a web browser. In addition, you can insert 
clickable hyperlinks (including e-mail addresses) directly into cells.
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In versions prior to Excel 2007, HTML was a round-trip file format. In other words, you 
could save a workbook in HTML format and then reopen it in Excel, and nothing would 
be lost. That’s no longer the case. HTML is now considered an export-only format.

You can also create web queries to bring in data stored in a corporate intranet or on the Internet.

New Feature 

A new feature in Excel 2013 makes it easy to store your work on the Internet so you can 
access your files no matter where you are.

Analysis Tools
Excel is certainly no slouch when it comes to analysis. After all, most people use a spreadsheet for 
analysis. Many analytical tasks can be handled with formulas, but Excel offers many other options, 
which I discuss in the following sections.

Database access
Over the years, most spreadsheets have enabled users to work with simple flat database tables. 
Excel’s database features fall into two main categories:

➤ Worksheet databases: The entire database is stored in a worksheet.

➤ External databases: The data is stored outside Excel and is accessed as needed.

Scenario management
Scenario management is storing input values that drive a model. For example, if you have a sales fore-
cast, you may create scenarios such as best case, worst case, and most likely case.

Excel’s Scenario Manager can handle only simple scenario-management tasks, but most users find it 
adequate. However, it is definitely easier than trying to keep track of different scenarios manually.

Pivot tables
One of Excel’s most powerful tools is the pivot table, which enables you to display summarized data 
in just about any way possible. Data for a pivot table comes from a worksheet database (or table) or 
an external database, and it is stored in a special cache, which enables Excel to recalculate data rap-
idly after a pivot table is altered.

Caution
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Chapter 18 contains additional information about pivot tables.

As a companion to a pivot table, Excel also supports the pivot chart feature. Pivot charts enable you 
to link a chart to a pivot table. In Excel 2013, you can create a pivot chart directly, without a compan-
ion pivot table.

Auditing capabilities
Excel also offers useful auditing capabilities that help you identify errors or track the logic in an 
unfamiliar spreadsheet. To access this feature, choose commands in the Formulas➜Formula 
Auditing group.

Cross-Ref 

Refer to Chapter 21 for more information about Excel’s auditing features.

Solver add-in
For specialized linear and nonlinear problems, Excel’s Solver add-in calculates solutions to what-if 
scenarios based on adjustable cells, constraint cells, and, optionally, cells that must be maximized or 
minimized.

Protection Options
Excel offers a number of different protection options. For example, you can protect formulas from 
being overwritten or modified, protect a workbook’s structure, and protect your VBA code.

Protecting formulas from being overwritten
In many cases, you may want to protect your formulas from being overwritten or modified. To do so, 
you must unlock the cells that you will allow to be overwritten and then protect the sheet. First select 
the cells that may be overwritten and choose Home➜Cells➜Format➜Lock to unlock those cells. (The 
command toggles the Locked status.) Next, choose Home➜Cells➜Format➜Protect Sheet to show 
the Protect Sheet dialog box. Here you can specify a password if desired.

Cross-Ref
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By default, all cells are locked. Locking and unlocking cells has no effect, however, 
unless you have a protected worksheet.

When you protect a worksheet, the Protect Sheet dialog box (see Figure 1-10) lets you select which 
elements won’t be protected. For example, you can allow users to sort data or use AutoFiltering on a 
protected sheet.

Figure 1-10: Select which elements to protect in the Protect Sheet dialog box.

You can also hide your formulas so they won’t appear in the Excel Formula bar when the cell is acti-
vated. To do so, select the formula cells and press Ctrl+1 to display the Format Cells dialog box. Click 
the Protection tab and make sure that the Hidden check box is selected.

Protecting a workbook’s structure
When you protect a workbook’s structure, you can’t add or delete sheets. Use the Review➜Changes➜

Protect Workbook command to display the Protect Structure and Windows dialog box. Make sure 
that you enable the Structure check box.

 

Keep in mind that Excel is not really a secure application. The protection features, even 
when used with a password, are intended to prevent casual users from accessing vari-
ous components of your workbook. Anyone who really wants to defeat your protection 
can probably do so by using readily available password-cracking utilities.

Note

Caution
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Password-protecting a workbook
In addition to protecting individual sheets and the structure of the workbook, you can require a pass-
word to open the workbook. To set a password, choose File➜Info➜Protect Workbook➜Encrypt With 
Password to display the Encrypt Document dialog box (see Figure 1-11). In this dialog box, you can 
specify a password to open the workbook.

Figure 1-11: Use the Encrypt Document dialog box to specify a password for a workbook.
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