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Chapter 1

Exploring the User Interface
Autodesk® Revit® MEP 2014 is similar to the majority of the software produced by Autodesk 
in that it utilizes a ribbon interface. This allows for not just ease of access to the tools needed 
for mechanical, electrical, and plumbing (MEP) design and modeling, but also a familiarity 
between those different software packages, making the transition between them easier.

Although this book is titled Mastering Autodesk Revit MEP 2014, having a good knowledge of 
where tools are located and how to access the commands easily is the best way to efficiently use 
Revit MEP 2014, hence this chapter on the user interface. Improvements and changes have been 
made to the user interface for this version, through the addition of tools in contextual tabs and 
improved functionality.

If you are transitioning to Revit MEP 2014 from a release prior to Revit MEP 2010, the ribbon-
style interface will be totally new to you. The ribbon works well in Revit because it allows many 
of the tools to be organized in one area of the interface, which gives you more screen real estate 
for viewing the model. Although the user interface is customizable, you are limited in the 
amount of customization and number of features that you can change. At first this may seem a 
bit restrictive but, like any software, with familiarity comes an increased proficiency.

Some features have been added to improve workflow and efficiency, and typical workflow 
features that were previously accessed through buttons in the interface are now available as 
part of the interface itself.

With the 2013 release came the availability of another version of Revit. This is Autodesk® Revit® 

and it combines all the features of Autodesk® Revit® Architecture, Autodesk® Revit® Structure, 
and Autodesk® Revit® MEP. This version is available to those who purchase the Building Design 
Suites packages released by Autodesk, and gives users the option to deploy/install either each 
separate version of Revit or the all-inclusive one, giving them all the available Revit tools in one 
box. Knowing your way around the Revit MEP 2014 user interface is the first step to reaping the 
benefits of utilizing a building information modeling (BIM) solution for your building projects.

In this chapter, you will learn to do the following:

66 Navigate the ribbon interface

66 Utilize user interface features

66 Use settings and menus

The Ribbon
If you are familiar with the Revit MEP user interface prior to the 2010 version, transitioning to 
the ribbon-style interface may indeed take some getting used to. Once you understand the way 
that the ribbon is set up and how you can customize it to better suit your workflow, though, you 
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4  | Chapter 1  Exploring the User Interface

will see that it is an optimal interface for a BIM and design application. If you are transitioning 
from an earlier ribbon interface, you will inevitably notice some changes to the location and 
order of the tabs and the introduction of additional tabs/commands.

Using Tabs
The ribbon portion of the user interface consists of several tabs, each organized by panels that 
relate to the topic of the tab. Each panel contains one or more buttons for the relevant features 
available in Revit MEP 2014. You can access a tab by simply clicking the name at the top of the 
ribbon. Although each tab is designed to provide a unique set of tools, some of the features of 
Revit are repeated on different tabs. Depending on your screen resolution, some of the buttons 
on the panels may become compressed to fit on your screen. The panels and tools for each tab 
are described here (not all panels are shown for each tab):

Systems    The Systems tab, shown in Figure 1.1, is the main tab for MEP modeling tools. 
Formerly the Home tab, this tab has been renamed to allow for continuity between Autodesk 
Revit MEP and Autodesk Revit. The tab is divided into panels that are specific to each of the 
main disciplines. The Systems tab is where you can find the tools to build an MEP model. 
Each of the discipline panels has a small arrow in the lower-right corner that provides quick 
access to the MEP settings dialog box for that discipline.

Figure 1.1 
The Systems tab

Architecture    There will always be a need for creating architectural elements in a Revit 
MEP model, whether this is purely during a Copy/Monitor operation or you are building an 
as-built model and have no architect to work with. This tab features most of the architectural 
tools required for this, with the most notable exception of Structural Beams. There are, of 
course, other ways to skin a cat, and creating beams by using the Floor tool is one way to get 
around this deliberate omission by Autodesk. From the Build panel with the basic architect’s 
tools to openings, grids, and rooms, these are all available on the Architecture tab. Note that 
access to Color Schemes and Area And Volume Computations is available by clicking the 
down arrow on the Room & Area panel, as shown in Figure 1.2.

Figure 1.2 
The Architecture 
tab

Insert    Whether you want to link another Revit project file, overlay Design Web Format (DWF) 
markup, or insert 2D elements from another file, the Insert tab contains all these tools and more 
for bringing other files or objects into your Revit projects, as shown in Figure 1.3. The tab is 
organized by panels for linking and importing files, and it also contains tools for loading Revit 
families. The small arrow at the lower right of the Import panel is for accessing the Import 
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The Ribbon |  5

Line Weights dialog box, where you can associate imported computer-aided design (CAD) 
color numbers to a Revit line weight, as indicated in Figure 1.4. The Insert tab also contains the 
Autodesk Seek panel, which provides a search window for content available on the Autodesk 
Seek website.

Figure 1.3 
The Insert tab

Figure 1.4 
Import Line 
Weights dialog box

Annotate    On the Annotate tab, you can find the tools needed to add annotations to your 
model views along with drafting tools for creating details. The Dimension and Tag panels 
can be extended by clicking the arrow next to the panel name, which reveals the tools for 
establishing dimension settings and determining the default tags to be used upon initial 
placement, as shown in Figure 1.5. The Symbol button is used for placing annotation families 
onto views or sheets. The small arrow at the lower-right corner of the Text panel provides 
access to the Type Properties dialog box for creating or modifying text styles, as shown in 
Figure 1.6. 

Figure 1.5 
The Annotate tab
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6  | Chapter 1  Exploring the User Interface

Figure 1.6 
Text Type Proper-
ties dialog box

Analyze    Tools for model analysis and systems checking are located on the Analyze tab. 
Other tools on this tab allow you to add color to your ductwork and piping based on defined 
criteria. The Spaces & Zones panel contains the tools for placing Space objects and Space 
Separator lines. The Check Systems panel contains tools for checking MEP systems to ensure 
proper connectivity and valid system assignments of components. Note that access to Color 
Schemes and Area And Volume Computations is available by clicking the down arrow on the 
Spaces & Zones panel, as shown in Figure 1.7, while Building and Space properties, as shown 
in Figure 1.8, can be accessed from the arrow on the Reports & Schedules panel.

Figure 1.7 
The Analyze tab

Some new tools on the Energy Analysis panel allow for choosing a mass model or the build-
ing components to establish an energy analysis model.

Massing & Site    The Massing & Site tab combines the conceptual tools used for creating 
masses and the Modeling By Face objects. It provides MEP users access to site tools, includ-
ing topography, site and parking components, and building pads or foundations, as shown in 
Figure 1.9. Site Settings, as indicated in Figure 1.10, for adjusting contour separation and site 
cut material, can be accessed by clicking the arrow on the Model Site panel.
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Figure 1.8 
Building/Space 
Type Settings

Figure 1.9 
The Massing &  
Site tab

Figure 1.10 
Site Settings

604199c01.indd   7 5/15/13   9:54 AM



8  | Chapter 1  Exploring the User Interface

Collaborate    You need tools that allow you to keep your model coordinated with other disci-
plines and work within a multiuser environment. These tools can be found on the Collaborate 
tab. The Worksets panel has a drop-down list for switching worksets (much like switching 
between active layers in other CAD programs, but not to be used as such), and the Coordinate 
panel contains tools for copying and monitoring objects from linked files. The Coordinate panel 
also has a tool for locating face-hosted elements that have lost their association to their host. 
You can check for clashes between model objects by using the Interference Check tool on the 
Coordinate tab. The Editing Requests button on the Synchronize panel allows you to see any 
requests that have been made to modify elements you are borrowing or own. You also have the 
option to connect to a Revit Server Accelerator by clicking the arrow, as shown in Figure 1.11.

Figure 1.11 
The Collaborate tab

View    Figure 1.12 shows the View tab; here you can use the tools to create different types 
of views. This tab also has tools for managing the views you have open in the drawing area. 
On the Graphics panel, there are tools for creating view templates and filters. The arrow on 
the base of this panel accesses Graphic Display Options, as shown in Figure 1.13. The Sheet 
Composition panel has tools for creating sheets as well as adding match lines or revisions. 
The User Interface button allows you to toggle the visibility of key user-interface features 
including the Properties palette, System Browser, and Project Browser.

Figure 1.12 
The View tab

Figure 1.13 
Graphic Display 
Options
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Manage    On the Manage tab, you can find the tools needed to establish project settings. The 
Inquiry panel has tools that can be used to locate specific objects in your project model, and to 
display any warnings associated with your project. Along with the settings that can be accessed 
from the tools on the Settings panel, the Additional Settings button is a drop-down list of even 
more options. The MEP Settings button is located on the Settings panel. This is where you can 
establish settings related to MEP components and system behavior. The Selection panel, as indi-
cated in Figure 1.14, has tools that allow the user to save, load, and edit a selection set of objects 
for use in a filter list.

Figure 1.14 
The Manage tab

Modify    The Modify tab is located at the end of the tabs so that it is closer to the center of 
the user interface, for easy access. The Modify tab has the tools needed to make changes 
to components or linework in your project views. The tools on the Modify panel have been 
arranged with the more commonly used tools having larger buttons. Some of the tools that 
have multiple-use options have a separate button for each use, such as the Mirror, Split, and 
Trim/Extend tools. The tools for creating groups, assemblies, or parts are located on the 
Create panel, as shown in Figure 1.15.

Figure 1.15 
The Modify tab

If you are running any external applications or macros, the Add-Ins tab appears on your ribbon 
as the next-to-last tab. The buttons or other features provided by the external application appear 
on the tab as configured. Some third-party applications create an additional tab on the ribbon.

The Modify button appears in the Select panel on every tab. This button allows you to exit from 
any active command, giving you an alternative to using the Esc key multiple times or selecting 
another tool. A new feature to this panel is the drop-down that contains options for selection in the 
drawing area. These options also appear as icons on the status bar. Figure 1.16 shows the various 
selection options available. Notice that you can now select elements by clicking anywhere on the 
element by using the Select Elements By Face option. However, this option does not work when a 
view is set to Wireframe.

Figure 1.16 
New selection 
settings
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10  | Chapter 1  Exploring the User Interface

You may need to experiment with combinations of these settings to achieve the results that 
suit your workflow. Note that if you deselect the Select Underlay Elements check box, you cannot 
select non-MEP components such as doors, walls, or windows that may exist in your model.

Using Contextual Tabs
In addition to the tabs provided by default on the ribbon, other tabs appear when you select  
objects in your project. These contextual tabs contain tools specific to modifying the selected object. 
Contextual tabs appear in the location of the Modify tab and are identified by their green color  
and a name that applies to the selected object. A contextual tab for a selected object is an extension 
of the Modify tab, which is why the base Modify tab is so compact compared to the other tabs.  
This allows for the selection-specific tools to appear on the right side of the Modify tab. The top  
of Figure 1.17 shows the contextual tab for an electrical distribution board selected in the model of  
a project. The standard tools on the Modify tab are available to the left, but are not shown in this 
figure for clarity.

Figure 1.17 
Contextual tab for 
an electrical distri-
bution board (top), 
and contextual tab 
for an electrical 
system (bottom)

When you select an object in the model that is part of a system, an additional contextual tab 
appears with tools for editing the system. These tabs are completely separate from the standard 
Modify tab and contain only tools for system editing. If you select an object on a system, the 
system tab appears along with the contextual Modify tab, as shown at the bottom of Figure 1.17. 
However, if you select an actual system, only the system tab appears. The panels and buttons on 
contextual tabs cannot be removed or rearranged on the ribbon. The buttons cannot be added to 
the Quick Access toolbar.

Using Family Editor Tabs
The tabs in the Family Editor environment differ from those in the Project File environment. 
When you open a family file, the tabs on the ribbon contain some familiar tools, but many of 
them are specific to the creation and modification of family components. The tabs available in 
the Family Editor environment are as follows:
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Create    The Create tab in the Family Editor environment contains tools for creating solid 
geometry and lines, adding system connectors, and creating and managing references, as 
shown in Figure 1.18.

Figure 1.18 
The Family Editor— 
Create tab

Insert    Figure 1.19 shows the Insert tab in the Family Editor; this environment contains tools 
for bringing other files into your family file. The tools for linking are visible but disabled, 
because importing is the only available method for bringing a CAD file into a Revit family 
file. The arrow on the Import panel accesses the same dialog box as in the project environment 
and can be seen earlier in Figure 1.4.

Figure 1.19 
The Family Editor—
Insert tab

Annotate    On the Annotate tab within the Family Editor environment, you can find the types 
of annotation tools that can be used in a family file. The Dimension panel can be expanded to 
establish dimension styles within the family file, as shown in Figure 1.20. Text styles, as indi-
cated previously in Figure 1.6, can be accessed from the arrow on the Text panel.

Figure 1.20 
The Family Editor—
Annotate tab

View    The View tab in the Family Editor environment is limited to tools for managing the 
family views. Section views can be created and camera positions can also be established for 
3D views, as shown in Figure 1.21.

Figure 1.21 
The Family Editor—
View tab

Manage    In the Family Editor environment, the Manage tab, shown in Figure 1.22, is popu-
lated with tools for establishing settings within the family file. The MEP Settings button 
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12  | Chapter 1  Exploring the User Interface

allows you to establish load classifications and demand factors, while the Additional Settings 
button drops down for access to general settings.

Figure 1.22 
The Family Editor—
Manage tab

Modify    The Modify tab in the Family Editor environment is the same as the one found in 
the Project File environment, as shown in Figure 1.23. This tab is also compact, allowing for a 
contextual tab when objects within the family are selected.

Figure 1.23 
The Family Editor—
Modify tab

The Load Into Project button is available on each tab in the Family Editor environment. This 
allows you to load the family into another open file at any time.

Customizing the Ribbon
You can customize the ribbon interface to better suit your workflow. For example, you can rear-
range the order of the tabs by holding down the Ctrl key and clicking a tab name to drag it to a 
new location.

You can move panels on a tab to different locations on the tab by clicking a panel name  
and dragging it to a new location. Figure 1.24 shows the Mechanical panel being dragged from 
its location on the Systems tab. The panels to the right slide over to fill in the space left by the 
moved panel.

Figure 1.24 
Moving a tab panel

You cannot move a panel from one tab to another, however. If you attempt to drop a panel 
onto another tab, it returns to its original location on its original tab.

You can remove panels from a tab and place them in another location on your screen. You can 
dock floating panels together by dragging one panel over the other, and you can move the docked 
panels as a group by clicking and dragging the gray grip that appears when you hover your mouse 
pointer over a floating panel. If you use dual monitors, you can even drag a panel to the second 
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monitor. The panel’s new position is maintained when you restart the software, but the panel does 
not appear until a file is opened. Keep in mind that moving tools to another screen may actually 
hinder your workflow, your efficiency, and possibly the stability of the program itself.

Back to Normal

You can return a floating panel to its default location by clicking the small button in the upper-
right corner of the panel.

If you want to return the entire ribbon interface to its default settings, you can do so by browsing 
to %USERPROFILE%\AppData\Roaming\Autodesk\Revit\Autodesk Revit 2014, and delet-
ing the UIState.dat file, and then reopening the application. Deleting this file also removes 
any customization done to the Quick Access toolbar.

You can control the visibility of the ribbon tabs by clicking the small button to the right of the 
tabs. This button cycles through the different display options. You can also click the small arrow 
next to the button to display and select a specific option, as shown in Figure 1.25.

Figure 1.25 
Ribbon visibility

You can establish the switching behavior of the tabs on the ribbon to determine which tab is 
displayed when you exit a tool or command. When you click a tool, the contextual Modify tab 
for that tool appears. The interface stays on the Modify tab when you exit the tool, or you can 
set it to return to the previous tab. These settings are located on the User Interface tab of the 
Options dialog box, which is discussed later in this chapter.

Quick Access Toolbar
As you are working, you may find yourself taking extra steps to switch tabs in order to access 
the desired tools. Figure 1.26 shows the Quick Access toolbar (QAT) as a place where you can 
put frequently used tools for instant access.

Figure 1.26 
Quick Access 
toolbar
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You can add tools from any of the standard tabs to the QAT simply by right-clicking that 
tool’s button or drop-down and selecting the Add To Quick Access Toolbar option. The tool will 
be placed at the end of the QAT. To manage the tools available on the QAT, you can click the 
small arrow button to the far right of the QAT, as shown in Figure 1.27. Each button on the QAT 
is listed, and removing the check mark next to it turns off its visibility in the QAT.

Figure 1.27 
Quick Access tool-
bar customization 
menu

The option at the bottom of the list allows you to set the location of the QAT either above 
or below the ribbon. Setting it below the ribbon moves it closer to the drawing area for easier 
access. Moving it to this location does not take the place of the Options Bar, however. If you add 
several buttons to the QAT, you may want to move it below the ribbon so that it does not crowd 
out the filename on the title bar.

Clicking the Customize Quick Access Toolbar option in the drop-down menu opens the 
dialog box shown in Figure 1.28. In this dialog box, you can change the order of the buttons 
as they appear from left to right, create separator lines, or delete buttons.

You can also right-click a button on the QAT for quick options such as removing the button, 
adding a separator line, or accessing the customization dialog box.

User Interface Features
The Revit MEP 2014 user interface is full of features designed to help you design and model 
efficiently. Some items are new, some have been modified, and some are the same as they have 
always been. The title bar at the top of the screen still informs you of what file you are in and 
what view is currently active in the drawing area.

Options Bar
Despite the functionality of the ribbon with its contextual tabs, the Options Bar, shown in 
Figure 1.29, is still an important part of the user interface. This should be the first place you look 
when a tool or object in the project is selected. Although the number of options that appear may 

604199c01.indd   14 5/15/13   9:54 AM



User Interface Features |  15

be limited for each command you use, they are important to the task in which you are engaging. 
When placing rectangular or oval duct, for example, pay close attention to the Width, Height, 
and Offset options to ensure proper location.

Figure 1.28 
Customize Quick 
Access Toolbar  
dialog box

Figure 1.29 
Options Bar

You can dock the Options Bar at the top of the screen, below the ribbon (which is the default 
location), or at the bottom of the screen, just above the status bar. Right-click the Options Bar to 
change its docked position.

Properties Palette
The Properties palette is a modeless dialog box that allows you to access the properties of items 
in your project. This feature reduces the number of mouse clicks necessary to access the proper-
ties of a model object or project component. You can dock the Properties palette to the sides of 
the screen, or it can float. If you dock the Properties palette to the same side of the screen as the 
Project Browser, there are two options for how they can be displayed. You can either show both, 
split in the docked space as seen in Figure 1.30, or you can have them both occupy the same 
docked space, depending on how you drag them to the docked space. A gray box appears to 
indicate whether they will split or share the space.

When the Properties palette and Project Browser are sharing the same docked space, you can 
access either one by the tabs that appear at the bottom. To remove either one from the shared 
docked space, click and drag its tab away from the dock.

If you do not have the Properties palette turned on, you can access it by clicking the Properties 
button located on the Modify tab or the contextual Modify tab of a selected object, or you can 
right-click anywhere in the drawing area. The Properties palette remains on until you close it.
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Figure 1.30 
Project Browser and 
Properties palette 
docked together

When no object is selected in the model or in a drafting view, the Properties palette displays 
the properties of the current view in the drawing area. You can select a view in the Project 
Browser to view its properties in the Properties palette.

The top section of the Properties palette acts as the Type Selector when an object is selected 
or a tool is chosen for placing an object. When an object is selected, you can switch to the prop-
erties of the current view by using the drop-down list located just below the Type Selector, as 
shown in Figure 1.31.

Figure 1.31 
Properties palette

Type selector

Drop-down for
changing properties
displayed
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The properties shown in the Properties palette are instance properties. You can click the Edit 
Type button to display the Type Properties dialog box for a selected item or view. When viewing 
the instance properties of an object or view, the scroll bar on the right side of the palette holds 
its position when you move your mouse pointer away from the palette. The scroll bar remains in 
position even when other items are selected in the model.

When you make a change to a parameter in the Properties palette, you can click the Apply 
button at the bottom-right corner of the palette to set the change. Alternatively, you can simply 
move your mouse pointer away from the palette, and the change will be applied.

View Control Bar
The View Control Bar is often overlooked, but it contains tools that are important to the display 
of the contents in the drawing area. There are a few changes to the View Control Bar in the Revit 
MEP 2014 release.

The Visual Styles button provides access to the Graphic Display Options dialog box. This 
dialog box has settings to control the visual display of the view. These include Model Display, 
Shadows, Lighting, Photographic Exposure, Background, and the ability to save these settings 
as a view template, as shown in Figure 1.32.

Figure 1.32 
Graphic Display 
Options dialog box

The View Control Bar, shown in Figure 1.33, essentially remains the same as the previous 
version, with the options for scale, level of detail, visual style, sun path, shadows, rendering, 
view crop, and crop region visible. The ability to save and lock the orientation of a 3D view also 
remains the same. When a 3D view is locked, you can tag items in the view. You can zoom and 
pan in a locked view, but you cannot orbit the model.

604199c01.indd   17 5/15/13   9:54 AM



18  | Chapter 1  Exploring the User Interface

Figure 1.33 
View Control Bar 
and Lock 3D view 
options

Highlight Displacement Sets
Analytical Model Toggle
Temporary View Properties
Worksharing Display
Reveal Hidden Elements
Temporary Hide/Isolate
3D View Lock
Show/Hide Crop Region
Crop View Toggle
Rendering Dialog
Shadows Toggle
Sun Path Toggle
Visual Styles
View Detail Level
View Scale

When you unlock a view, any tags applied in the view are not displayed until it is returned to 
its saved orientation.

The Temporary Hide/Isolate, Reveal Hidden Elements, and Worksharing Display tools 
remain the same from the previous release. A few new buttons have been added for 2014. The 
Temporary View Properties button allows you to temporarily override the properties of a view, 
especially one whose view properties are controlled by a template. This enables you to change 
visibility settings without having to duplicate the view. Figure 1.34 shows the options available 
with this setting. When activated, a border appears around the drawing area.

Figure 1.34 
Temporary View 
Properties applied 
to a view

The Show Analytical Model button allows you to toggle the visibility of the analytical model 
on and off. The last button changes the view so that any displacement sets are highlighted, as 
shown in Figure 1.35.

Figure 1.35 
Displacement sets 
highlighted in a  
3D view
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When your project has worksets, the Worksharing Display tool can be useful for collaboration 
on a project and can save you time by helping you to avoid trying to make changes to objects that 
are not editable. The Worksharing Display Settings option on this button menu takes you to the 
Worksharing Display Settings dialog box, where you can establish the colors used for the vari-
ous options of worksharing display. You can apply colors to worksets based on who owns them, 
whether they are up to date, or simply by their name. Figure 1.36 shows the dialog box and settings 
for worksets colored by their name. Notice that, in the Show Color column, you can choose to show 
a workset’s color in the view by selecting its check box.

Figure 1.36 
Worksharing  
Display Settings 
dialog box

When you choose an option for worksharing display, a box appears in the upper-left corner 
of the drawing area, indicating the option being displayed, as shown in Figure 1.37 (colors are 
labeled for black-and-white print). These settings take precedence over any view filters that may 
be applied to the view. If you override the graphics of a category in the view, only the changes to 
line weight are applied (color overrides do not display).

Figure 1.37 
3D view with work-
sharing display 
activated

(Purple)

(Yellow)

(Magenta)
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To turn the Sun Path on or off in a view, you use the Sun Settings button on the View Control 
Bar, as shown in Figure 1.38. The Sun Settings option takes you to a dialog box where you can 
define the type of solar study performed, the project location, and the time of day.

Figure 1.38 
Sun Path visual 
display options 

In the Visual Styles button menu shown in Figure 1.39, the Ray Trace option gives you a fully 
rendered view. In both this option and in Realistic mode, any rich photorealistic content (RPC) 
objects display correctly.

Figure 1.39 
Visual styles

Take some time to explore the visual styles by completing the following exercise. If you do 
not have Hardware Acceleration turned on, you can do so by clicking the Options button on the 
application menu and choosing the Graphics tab. You must do this prior to opening the file. If 
activating Hardware Acceleration causes problems because of your video driver, you can choose 
not to activate it and skip step 5:

	 1.	 Open the Ch1_Project.rvt file found at www.sybex.com/go/masteringrevitmep2014.

	 2.	 Click the Visual Styles button on the View Control Bar, and select Shaded. Zoom, pan, and 
orbit the view, and make note of the variations in color based on the model orientation.

	 3.	 Click the Visual Styles button and select Graphic Display Options. In the dialog box 
that appears, deselect the Show Edges radio box and set Transparency to 50%; then click 
Apply. Notice the change to the view. Change Transparency back to 0% and click OK.

	 4.	 Click the Visual Styles button and change the style to Consistent Colors. Notice that the 
colors remain a consistent shade when you zoom, pan, and orbit the view.

	 5.	 Click the Visual Styles button and change the style to Realistic. Notice that the render 
material defined for the objects is now displayed.

	 6.	 Click the Visual Styles button and change the style to Ray Trace. Notice that the perfor-
mance considerably slows, but the image should be more like a rendered image.

	 7.	 Click any object in the model. If you do not already have the Properties palette active, 
click the Properties button on the Properties panel of the contextual tab. Take some time 
to become familiar with the behavior of the Properties palette.
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Status Bar
The status bar for Revit MEP 2014 not only reports information about a selected item and shows 
prompts with instructions for multilevel commands, but also has an active workset indicator 
and design options indicator. The selection options that are available on the Selection panel of 
the ribbon also show up on the status bar as icons, as shown in Figure 1.40. 

Figure 1.40 
Status bar

Active Workset and Editable Status Active Design Option (if applicable) Selection Option Icons

You can access the Worksets dialog box by clicking the Worksets button next to the active work-
set window. You can switch between active worksets by clicking the window and selecting the 
desired workset. These are the same tools as found on the Collaborate tab, but having them on the 
status bar eliminates the need to switch tabs on the ribbon to access them. This also eliminates  
the need to add the tools to the Quick Access toolbar. The Design Options window displays the 
active design option, and you can access the Design Options dialog box by clicking the button.

The Editable Only check box is for filtering a selection by only those objects that are editable 
in a worksharing environment. You can access any editing requests, as shown in Figure 1.41, by 
clicking the small button next to the active workset indicator. This opens the Editing Request 
dialog box, which displays any pending requests by others to borrow elements. This dialog box 
also displays any requests made by you to other users. Next to the button is an indicator that 
shows the number of requests that are currently pending.

Figure 1.41 
Workset editing 
requests

When a user places a request to edit an element that you own or are borrowing, you receive 
a notification dialog box of the request. The request remains in the list of pending requests until 
action is taken.

Info Center
The Info Center is the portion of the title bar that gives you quick access to the Help menu or 
information about Revit MEP 2014. The search window allows you to search for information 
about a topic, as indicated in Figure 1.42.

Figure 1.42 
Info Center

You can easily access the Subscription Center by clicking the button with a key on it. Any 
topics found in the search window or listed in the Subscription Center panel can be added to 
your Favorites list by clicking the star icon to the right of the topic. Clicking the star button on 
the Info Center lists all your favorite topics. The Help menu is displayed by clicking the question 
mark button. Revit MEP 2014 has a web-based Help menu. You can access additional informa-
tion by clicking the arrow next to the Help button, as shown in Figure 1.43.
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Figure 1.43 
Additional Help 
options

The Communication Center button is the one with the satellite dish on it. The Communication 
Center provides information about product updates and announcements.

Exchange Apps
Figure 1.44 shows the button for the Autodesk Exchange App store. This takes the user to a 
website where applications written for the Revit platform are listed. These take the form of 
applications, either free or available for purchase, that can be loaded into Revit to provide 
enhanced performance and additional functionality.

Figure 1.44 
Exchange apps

User Interface Control
Many components of the Revit MEP 2014 user interface can be turned on or off for workflow effi-
ciency, or to maximize screen real estate. The User Interface button, located at the far right of the 
View tab, allows you to select which user interface components are visible, as shown in Figure 1.45.

Figure 1.45 
User Interface  
button options
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The User Interface button provides not only a way to display or remove interface components 
for more screen real estate, but also a way to access the Recent Files screen, which cannot be 
accessed from the Switch Windows drop-down button until it has been activated by using the 
User Interface button.

Menus and Settings
The menus within Revit MEP 2014 offer access to many tools for user interface settings. Context 
menus, available by right-clicking an item, also contain various tools based on the selected item.

The application menu includes options for exporting, printing, opening, and saving files. This 
menu also has an Options button for accessing settings that establish the behavior of the interface 
as well as the location of directories and files used for working on projects. You access the appli-
cation menu by clicking the Revit logo button in the upper-left corner of the user interface. The 
Options button is located in the lower-right corner of the menu, as shown in Figure 1.46.

Figure 1.46 
Application menu

The Options dialog box has several tabs for different settings within Revit MEP 2014. The 
General tab, as shown in Figure 1.47, contains a slider that allows you to control how frequently 
your file updates when working in a worksharing environment and utilizing the Model Updates 
option of the worksharing display features.

The General tab is also where you define your username for Revit MEP 2014. This is impor-
tant for worksharing, because Revit uses this name to identify you for editing requests, workset 
ownership, and element borrowing.
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Figure 1.47 
Options dialog 
box—General tab

This is also where you establish your default view discipline. This is important because it 
assigns this discipline to each new view that you create, unless defined by a view template.

The User Interface tab, shown in Figure 1.48, is where you can set some general behavior for 
the interface. For example, you can choose between a light gray or dark gray theme for the inter-
face from the Active Theme drop-down list. This tab is also where you determine which ribbon 
tabs and tools are available.

Figure 1.48 
User Interface tab 
of the Options  
dialog box
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The Tab Switching Behavior section in this screen is where you define how the ribbon tabs 
behave after an action is completed. There are settings for the behavior in both the Project 
Environment and the Family Editor. The check box for displaying a contextual tab on a selection 
allows you to have the ribbon tab switch immediately to the contextual tab when an object is 
selected. If that check box is not selected, the contextual tab still appears on the ribbon, but it does 
not automatically become the active tab.

In addition, you can define the level of information provided by tooltips from the Tooltip 
Assistance drop-down menu, shown in Figure 1.49. If you are still learning the functions of dif-
ferent tools within Revit MEP 2014, you may want to set this option to High so that you receive 
detailed descriptions of how tools work when you hover over them with your mouse pointer. If 
you find that the tooltips interfere with your workflow, you can set this option to None.

Figure 1.49 
Tooltip assistance

Keyboard Shortcuts
On the User Interface tab of the Options dialog box is a button that enables you to customize 
your keyboard shortcuts. Clicking this button activates the Keyboard Shortcuts dialog box. In 
this dialog box, you can filter the commands to make the list easier to manage and edit. You can 
even filter by specific tabs or menus, as shown in Figure 1.50.

Figure 1.50 
Filter options 
for the Keyboard 
Shortcuts list
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Shortcut Access

You can access the Keyboard Shortcuts dialog box by clicking the User Interface button on the 
View tab. There is even a keyboard shortcut for the Keyboard Shortcuts dialog box: KS.

You can sort the list in ascending or descending alphabetical order by clicking the desired 
column. Once you have located a command for which you want to create a keyboard shortcut, 
you can select the command to activate the Press New Keys text box at the bottom of the dialog 
box. Input the desired keys that will activate the command. You can input up to five characters 
for a keyboard shortcut. Reserved keys cannot be used for keyboard shortcuts; you can find the 
reserved keys by using the filter in the Keyboard Shortcuts dialog box. Click the Assign button 
to apply the shortcut to the selected command.

You can create multiple shortcuts for a single tool, and you can use the same shortcut keys for 
multiple tools. When you create a shortcut that is used for multiple tools, you must use the status 
bar to determine which tool to use when working in your project. When you type the shortcut, 
the first matching command is displayed on the status bar. You can use the arrow keys on your 
keyboard to cycle through available commands for the shortcut. Once the desired command is 
displayed on the status bar, you can activate it by pressing the spacebar. You can remove a key-
board shortcut from a command by selecting the specific shortcut and clicking the Remove but-
ton, as shown in Figure 1.51.

Figure 1.51 
Removing a key-
board shortcut

You can export your keyboard shortcut settings by clicking the Export button at the bottom of 
the Keyboard Shortcuts dialog box. This saves your settings as an XML file that can be edited in 
a spreadsheet program. Using a spreadsheet is another way to manage and share your keyboard 
shortcuts. The XML file can then be imported into Revit by using the Import button, allowing 
you to set a standard for keyboard shortcuts in a multiuser work environment.

What Do I Type?

With Tooltip Assistance set to at least Minimal, you can see the keyboard shortcut for a tool by 
hovering your mouse pointer over it. The keyboard shortcut is shown in parentheses next to the 
name of the tool.
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Common Shortcuts

Clark is responsible for teaching a Revit MEP 2014 class. He has established keyboard shortcuts 
that fit his workflow best and allow for efficient use of the software. Because he is so familiar 
with these shortcuts, he wants to share them with his students so that they will all be using the 
same ones during class.

Clark exports his shortcut settings to a file, which he imports into Revit MEP 2014 on the com-
puters in the classroom. Prior to importing the custom settings, he exported the default settings 
so that they can be used later if necessary. During class he notes that the settings provided are 
preferred, but each student can further customize them if doing so results in improved efficiency.

Graphics
The Graphics tab of the Options dialog box allows you to set the selection, highlight, and alert 
colors used in the drawing area. The drawing area’s background color can be inverted if you are 
more comfortable using a black background. Settings for temporary dimensions are also available 
to make them more readable, as shown in Figure 1.52. You can set the Background for temporary 
dimensions to Transparent or Opaque.

Figure 1.52 
Temporary dimen-
sion appearance 
settings

If you are experiencing graphics issues, you may need to change the Graphics Mode settings. 
Hardware acceleration works best when you are using an Autodesk-certified video driver. Certified 
and recommended drivers are available for download from here: http://usa.autodesk.com/
adsk/servlet/syscert?id=18844534&siteID=123112.

Settings for the appearance and behavior of the SteeringWheels and ViewCube can be found 
on their respective tabs in the Options dialog box.
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Context Menus
Although the ribbon interface is designed for efficient workflow, context menus can be the easiest, 
most effective way to access settings or make changes to components of your Revit projects. A con-
text menu is one that appears when you right-click in open space, on an item in the Project Browser, 
or on an object in the drawing area. Right-clicking in open space in the drawing area activates a 
context menu that includes the Repeat and Recent Commands tools. The last command used can 
be activated by pressing the Enter key, or by clicking the Repeat option on the context menu. The 
Recent Commands option displays a list of recently used commands for easy access during repeti-
tive work. Figure 1.53 shows a context menu and the recent commands used during a working 
session. The Recent Commands list displays the last five commands used.

Figure 1.53 
Context menu 
showing recent 
commands

The options displayed on a context menu depend on the object selected when the menu is 
accessed. One nice feature of Revit MEP 2014 is the ability to define the selection set when the 
Select All Instances option is chosen. Figure 1.54 shows that you have the option to select only 
the objects in the active view or to select them throughout the entire project. This makes the 
Select All Instances feature much more useful, because you don’t have to worry about objects 
that should not be selected being inadvertently included in the selection set.

Figure 1.54 
Selection set 
options
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There is no longer a View Properties or Element Properties option in the context menus 
(as in versions prior to Revit MEP 2011) because of the addition of the Properties palette. The 
Properties option at the bottom of a context menu allows you to toggle the Properties palette 
on or off.

You can also right-click an element in the Project Browser to access a context menu. Right-
clicking a view activates a menu with options for applying or creating a view template from 
that view. You can also save the view to a new file, as shown in Figure 1.55.

Figure 1.55 
Context menu for a 
view selected in the 
Project Browser

When you right-click a family in the Project Browser, you get a context menu with options 
to edit, rename, or reload the family. You can right-click a family type in the Project Browser to 
access its type properties or to select the instances in the project without having to locate one of 
the instances in the model, as shown in Figure 1.56.

Figure 1.56 
Context menu for a 
selected family type
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You can also use a context menu to manage linked files through the Project Browser. 
Figure 1.57 shows the options available on a context menu when a linked Revit file is selected 
in the Project Browser.

Figure 1.57 
Context menu for 
a linked file in the 
Project Browser

The Bottom Line
Navigate the ribbon interface.    The ribbon is an efficient user interface style that works well 
in Revit. The ability to house numerous tools in a single area of the interface allows for maxi-
mum screen real estate for the drawing area.

Master It    Along with the standard tabs available on the ribbon interface, contextual 
tabs also are available while you’re working on a project. Explain what a contextual tab is 
and how it may differ throughout your workflow.

Utilize user interface features.    Many features are available in the Revit MEP 2014 user 
interface that allow for quick access to tools and settings. The use of keyboard shortcuts can 
also improve workflow efficiency.

Master It    To enhance workflow efficiency, it is important to know how to access fea-
tures of the user interface. What tool can be used to activate or remove user interface 
features?

Use settings and menus.    Establishing settings for your user interface is another way to create 
a working environment that is the most efficient and effective for your use of Revit MEP 2014.

Master It    The use of keyboard shortcuts has been part of design and drafting software 
for a long time. The ability to customize the shortcuts to best suit your workflow is key to 
improved efficiency. How can the settings for keyboard shortcuts be accessed? How can 
modified keyboard settings be reset?
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