
Tip 1: Changing the Look of Excel 7

Changing the Look of Excel
With Excel 2013, what you see isn’t necessarily what you have to live with. This tip describes several 
ways to change the look of Excel. Some changes affect only the appearance. Other options allow you 
to hide various parts of Excel to make more room for displaying your data — or maybe because you 
prefer a less-cluttered look.

Cosmetic changes
When the preview version of Microsoft Office 2013 became available, there was a minor uproar 
about its appearance. Compared to previous versions, the applications looked “flat” and many com-
plained about the overall white color.

When the final version was released, Microsoft added two alternative Office themes: light gray and 
dark gray. To switch to a different theme, choose File➜Options to display the Excel Options dialog 
box. Click the General tab and use the Office Theme drop-down list (see Figure 1-1). The theme 
choice affects the appearance of the title bar, row and column borders, task panes, the taskbar, and a 
few other items. The theme you choose applies to all other Office 2013 applications.

Figure 1-1: Selecting a different Office theme.

Figure 1-1 shows another option: Office Background. Use this drop-down list to select a background 
image that appears in the Excel title bar. Fortunately, one of the options is No Background.
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Tip 1: Changing the Look of Excel8

Hiding the Ribbon
To hide the Ribbon, click the Ribbon Display Options drop-down menu in the Excel title bar. You’ll 
see the choices shown in Figure 1-2.

Figure 1-2: Choosing how the Ribbon works.

Using options on the View tab
The View tab, shown in Figure 1-3, has three groups of commands that determine what you see 
onscreen.

➤ Workbook Views group: These options control the overall view. Most of the time, you’ll use 
Normal view. Page Layout view is useful if you require precise control over how the pages 
are laid out. Page Break Preview also shows page breaks, but the display isn’t nearly as nice. 
The status bar has icons for each of these views. Custom Views enable you to create named 
views of worksheet settings (for example, a view in which certain columns are hidden).

➤ Show group: The four checkboxes in this group control the visibility of the Ruler (relevant 
only in Page Layout view), the Formula bar, worksheet gridlines, and row and column 
headings.

➤ Zoom group: These commands enable you to zoom the worksheet in or out. Another way to 
zoom is to use the Zoom slider on the status bar.

Figure 1-3: Controls on the View tab.
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Hiding other elements
To hide other elements, you must make a trip to the Advanced tab of the Excel Options dialog box 
(choose File➜Options). Figure 1-4 shows workbook display options and worksheet display options. 
These options are self-explanatory.

Figure 1-4: Display options on the Advanced tab of the Excel Options dialog box.

Hiding the status bar
You can also hide the status bar, at the bottom of the Excel window. Doing so, however, requires VBA 
code.

 1. Press Alt+F11 to display the Visual Basic Editor.

 2. Press Ctrl+G to display the Immediate window.

 3. Type this statement and press Enter:

Application.DisplayStatusBar = False

The status bar will be removed from all open workbook windows. To redisplay the status bar, repeat 
those instructions, but specify True in the statement.
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Customizing the Quick Access Toolbar
If you find that you continually need to switch Ribbon tabs because a frequently used command 
never seems to be on the Ribbon that’s displayed, this tip is for you. The Quick Access toolbar is 
always visible, regardless of which Ribbon tab is selected. After you customize the Quick Access tool-
bar, your frequently used commands will always be one click away.

Note  

The only situation in which the Quick Access toolbar is not visible is when the title bar is 
hidden (by choosing Auto-Hide the Ribbon from the Ribbon Display Options drop-down 
list in the title bar).

About the Quick Access toolbar
By default, the Quick Access toolbar is located on the left side of the Excel title bar, and it includes 
three tools:

➤ Save: Saves the active workbook.

➤ Undo: Reverses the effect of the last action.

➤ Redo: Reverses the effect of the last undo.

Commands on the Quick Access toolbar always appear as small icons, with no text. When you hover 
your mouse pointer over an icon, you see the name of the command and a brief description.

As far as I can tell, the number of icons that you can add to your Quick Access toolbar is limitless. But 
regardless of the number of icons, the Quick Access toolbar always displays a single line of icons. If 
the number of icons exceeds the Excel window width, it displays an additional icon at the end: More 
Controls. Click the More Controls icon, and the hidden Quick Access toolbar icons appear in a pop-up 
window.

Adding new commands to the Quick Access toolbar
You can add a new command to the Quick Access toolbar in three ways:

➤ Click the Quick Access toolbar drop-down control, which displays a down-pointing arrow 
and is located on the right side of the Quick Access toolbar (see Figure 2-1). The list contains 
several commonly used commands. Select a command from the list, and Excel adds it to your 
Quick Access toolbar.

➤ Right-click any control on the Ribbon and choose Add to Quick Access Toolbar. The control is 
added to your Quick Access toolbar, positioned after the last control.

➤ Use the Quick Access Toolbar tab of the Excel Options dialog box. A quick way to access this 
dialog box is to right-click any Quick Access toolbar or Ribbon control and choose Customize 
Quick Access Toolbar.
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Figure 2-1: The Quick Access toolbar drop-down menu is one way to add a new command to the Quick Access 
toolbar.

Figure 2-2 shows the Quick Access Toolbar tab of the Excel Options dialog box. The left side of the dia-
log box displays a list of Excel commands, and the right side shows the commands that are now on the 
Quick Access toolbar. Above the command list on the left is a drop-down control that lets you filter the 
list. Select an item from the drop-down list, and the list displays only the commands for that item.

Figure 2-2: Use the Quick Access Toolbar tab in the Excel Options dialog box to customize the Quick Access 
toolbar.
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Some of the items in the drop-down list are described here:

➤ Popular Commands: Displays commands that Excel users commonly use.

➤ Commands Not in the Ribbon: Displays a list of commands that you cannot access from the 
Ribbon.

➤ All Commands: Displays a complete list of Excel commands.

➤ Macros: Displays a list of all available macros.

➤ File Tab: Displays the commands available in the back stage window.

➤ Home Tab: Displays all commands that are available when the Home tab is active.

In addition, the drop-down list contains an item for every other tab.

Sometimes, you need to do some guessing to find a particular command. For example, if you want to 
add the command that displays the Excel Options dialog box, you can find it listed as Options, not 
Excel Options.

Note  

Some commands simply aren’t available. For example, I’d like the Quick Access toolbar 
to display the command to toggle the “dashed line” page break display on a worksheet. 
The only way to issue that command is to display the Advanced tab of the Excel Options 
dialog box and then scroll down until you find the Show Page Breaks checkbox. No com-
mand for doing so can be added to the Quick Access toolbar.

To add an item to your Quick Access toolbar, select it from the list on the left and click Add. If you add 
a macro to your Quick Access toolbar, you can click the Modify button to change the text and choose 
a different icon for the macro.

Notice the drop-down control above the list on the right. This lets you create a Quick Access toolbar 
that’s specific to a particular workbook, which is most useful when you add workbook-specific macro 
commands to the Quick Access toolbar. Most of the time, you’ll use the setting labeled For All 
Documents (Default).

The only time you ever need to use the Quick Access Toolbar tab of the Excel Options dialog box is 
when you want to add a command that’s not on the Ribbon or add a command that executes a 
macro. In all other situations, it’s much easier to locate the command on the Ribbon, right-click the 
command, and choose Add to Quick Access Toolbar.

Only you can decide which commands to put on your Quick Access toolbar. In general, if you find 
that you use a particular command frequently, it should probably be on your Quick Access toolbar.
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Performing other Quick Access toolbar actions
Here are some other things you can do with your Quick Access toolbar:

➤ Rearrange the Quick Access toolbar icons. If you want to change the order of your Quick 
Access toolbar icons, you can do so on the Customization tab of the Excel Options dialog 
box. Select the command and then use the up- and down-arrow buttons on the right to 
move the icon.

➤ Display the Quick Access toolbar below the ribbon. To change the position of the Quick 
Access toolbar, choose the down-pointing arrow control and select Show below the Ribbon.

➤ Remove Quick Access toolbar icons. The easiest way to remove an icon from your Quick 
Access toolbar is to right-click the icon and choose Remove from Quick Access Toolbar. You 
can also use the Quick Access Toolbar tab of the Excel Options dialog box. Just select the 
command in the list on the right and click the Remove button.

➤ Share your Quick Access toolbar. Use the Import/Export button to save a file that contains 
your Quick Access toolbar customization. You can then share this file with others. 
Unfortunately, this file also contains any Ribbon customizations that you might have made 
(see Tip 3). In other words, you can’t share your Quick Access toolbar without also sharing 
your Ribbon customizations.

➤ Reset the Quick Access toolbar. If you want to return the Quick Access toolbar to its default 
state, display the Quick Access Toolbar tab in the Excel Options dialog box and click the 
Reset button and choose Reset Only Quick Access Toolbar. All your customizations disap-
pear, and the Quick Access toolbar then displays its three default commands. 
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Customizing the Ribbon
Tip 2 describes how to customize the Quick Access toolbar by adding Ribbon commands, but some 
users prefer to make some changes to the Ribbon itself.

You can customize the Ribbon in these ways:

➤ Add a new tab.

➤ Add a new group to tab.

➤ Add commands to a group.

➤ Remove groups from a tab.

➤ Remove commands from custom groups.

➤ Change the order of the tabs.

➤ Change the order of the groups within a tab.

➤ Change the name of a tab.

➤ Change the name of a group.

➤ Reset the Ribbon to remove all customizations.

That’s a fairly comprehensive list of customization options, but you cannot do some actions:

➤ You cannot remove built-in tabs — but you can hide them.

➤ You cannot add commands to built-in groups.

➤ You cannot remove commands from built-in groups.

➤ You cannot change the order of commands in a built-in group.

Note  

Unfortunately, you can’t customize the Ribbon (or Quick Access toolbar) by using VBA 
macros. However, developers can write RibbonX code and store it in workbook files. 
When the file is open, the Ribbon is modified to display new commands. Writing 
RibbonX is relatively complicated and is the subject of several complete books.

How to customize the Ribbon
You customize the Ribbon in the Customize Ribbon tab of the Excel Options dialog box (see Figure 3-1). 
The quickest way to display this dialog box is to right-click anywhere in the Ribbon and choose 
Customize the Ribbon.
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Figure 3-1: The Customize Ribbon tab of the Excel Options dialog box.

Customizing the Ribbon is very similar to customizing the Quick Access toolbar, which is described in 
Tip 2. The only difference is that you need to decide where to put the command within the Ribbon. 
Here’s the general procedure:

 1. Right-click any part of the Ribbon, and choose Customize the Ribbon. Excel displays the 
Customize Ribbon tab of the Excel Options dialog box. 

 2. Use the drop-down list on the left (labeled Choose Command From) to display various 
groups of commands.

 3. Locate the command you want in the list box on the left and select it.

 4. Use the drop-down list on the right (labeled Customize the Ribbon) to choose a group of tabs.

  Main Tabs refers to the tabs that are always visible; Tool Tabs refers to the context tabs that 
appear when a particular object is selected.

 5. In the list box on the right, select the tab and the group where you want to put the command.

  You must click the “plus sign” controls to expand the hierarchical lists. Remember that you 
cannot add commands to built-in groups, so you may need to use the New Tab or New 
Group buttons to add a tab or group.

 6. Click the Add button to add the selected command from the left to the group on the right.

When you are finished making your Ribbon changes, click OK to close the Excel Options dialog box.
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New tabs and groups are given generic names, so you’ll probably want to give them more meaning-
ful names. Use the Rename button to rename the selected tab or group. You can also rename built-in 
tabs and groups.

Although you cannot remove a built-in tab, you can hide the tab by unchecking the check box next 
to its name.

Figure 3-2 shows a part of a customized Ribbon. In this case, I added a group to the View tab. The 
new Text To Speech group has five commands. I inserted this new group between the Zoom and the 
Window groups.

Figure 3-2: The View tab, with a new group added.
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Understanding Protected View
There’s an excellent chance that you’ve already encountered an Excel feature known as Protected 
View. Although it may seem like Excel is trying to keep you from opening your own files, Protected 
View is all about protecting you from malware.

Malware refers to something that can harm your system. Hackers have figured out several ways to 
manipulate Excel files so that harmful code can execute. Protected View essentially prevents these 
types of attacks by opening a file in a protected environment (sometimes called a sandbox).

If you open an Excel workbook that you downloaded from the web, you’ll see a colorful message 
above the Formula bar (see Figure 4-1). In addition, Excel’s title bar displays the text [Protected View].

Figure 4-1: This message tells you the workbook was opened in Protected View.

If you’re certain that the file is safe, click Enable Editing. If you don’t enable editing, you’ll be able to 
view the contents of the workbook, but you won’t be able to make any changes to it.

If the workbook contains macros, you’ll see another message after you enable editing: Security 
Warning. Macros Have Been Disabled. If you’re sure that the macros are harmless, click Enable Content.

What causes Protected View?
Protected View kicks in for the following:

➤ Files downloaded from the Internet

➤ Attachments opened from Outlook

➤ Files that open from potentially unsafe locations, such as your Temporary Internet Files 
folder

➤ Files that are blocked by File Block Policy (a feature that allows administrators to define 
potentially dangerous files)

➤ Files that were digitally signed, but the signature has expired

You have some control over how Protected View works. To change the settings, choose File➜Options 
and click Trust Center. Then click the Trust Center Settings button and click the Protected View tab in 
the Trust Center dialog box. Figure 4-2 shows the options. By default, all three options are checked.
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Figure 4-2: Change the Protected View settings in the Trust Center dialog box.

If you want to explicitly open a file in Protected View, choose File➜Open to display the Open dialog 
box. Select your file and then click the arrow to the right of the Open button. One of the options dis-
played is Open in Protected View.

If you enable editing in a workbook that opened in Protected View and then save the workbook, it 
will no longer open in Protected View.

Printing and copying
In some situations, you don’t care about working with the document. You just want to print it. 
Unfortunately, it’s not even possible to print a workbook unless you exit Protected View. Choose 
File➜Print and then click the Enable Printing button to exit Protected View.

Note that you can copy worksheet data from a Protected View document and paste it to another 
workbook. Formulas are not copied, but the current formula results are.

Forcing a file to open in Normal view
If you download a workbook and you’re absolutely certain that it’s safe, you can force it to open in 
Normal view. After downloading the workbook:

 1. Right-click the workbook name (or icon) and choose Properties from the shortcut menu.

  The Properties dialog box appears.

 2. Click the General tab (see Figure 4-3).

 3. Click the Unblock button.

 4. Click OK to close the Properties dialog box.
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After performing these steps, the workbook will open in Excel in Normal view (not Protected View).

Figure 4-3: Forcing a workbook to open in Normal view.
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Understanding AutoRecover
If you’ve used computers for any length of time, you’ve probably lost some work. You forgot to save 
a file, or maybe the power went out and your unsaved work was lost. Or maybe you were working on 
something and didn’t think it was important, so you closed it without saving — and later realized 
that it was important. The AutoRecover feature in Excel can make these types of “doh!” moments less 
frequent.

As you work in Excel, your work is periodically saved, automatically. It happens in the background, so 
you don’t even know that it’s happening. You have the ability to access these autosaved versions of 
your work — even workbooks that you never explicitly saved.

This feature consists of two components:

➤ Versions of a workbook are saved automatically, and you can view them.

➤ Workbooks that you close without saving are saved as draft versions.

Recovering versions of the current workbook
To see whether any previous versions of the current workbook are available, choose File➜Info. The 
section labeled Versions lists the available old versions (if any) of the current workbook. Figure 5-1 
shows that two autosaved versions of the active workbook are available.

Figure 5-1: Two autosaved versions of this workbook are available.

You can open an autosaved version by clicking its name. Remember that opening an autosaved ver-
sion won’t automatically replace the current version of your workbook. Therefore, you can decide 
whether the autosaved version is preferable to the current version. Or you can just copy some infor-
mation that may have been accidentally deleted and paste it into your current workbook.

When you close the workbook, the autosaved versions are deleted.

Recovering unsaved work
When you close a workbook without saving your changes, Excel asks whether you want to save your 
changes. If that unsaved workbook has an autosaved version, the dialog box informs you of that fact, 
as shown in Figure 5-2.
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Figure 5-2: If you close a workbook without saving, Excel tells you whether an autosaved version will be available.

To recover a workbook that you closed without saving, choose File➜Info➜Manage Versions and 
choose Recover Unsaved Workbooks. You see a list of all unsaved versions of your workbooks. You 
can open them and (hopefully) recover something that you needed. These drafts are also listed in the 
recent file list, which displays when you choose File➜Recent.

Draft versions of unsaved workbooks are deleted after four days or until you edit the file.

Note  

You can choose how AutoRecover works in the Save tab of the Excel Options dialog box. 
For example, you can change the autosave time interval (the default is 10 minutes), turn 
off autosave for a particular workbook, or disable this feature for all workbooks.
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Using a Workbook in a Browser
Microsoft’s Office Web Apps enable you to create, view, and edit workbooks directly in a browser. 
The experience isn’t exactly the same as using the desktop version of Excel, but it’s very similar. A key 
advantage is that you can access your workbooks from any location, and Excel need not be installed 
on the computer you use.

Note  

This tip assumes that you have a Microsoft SkyDrive account (free) and are logged in. 
You can also use SharePoint.

After creating a workbook, choose File➜Save As and choose a location on your SkyDrive. This action 
saves your workbook on the cloud, and also saves a copy in your local SkyDrive folder. The two ver-
sions are synched.

Open your web browser and navigate to skydrive.com. Locate the workbook and click it. The work-
book appears in the Excel Web App. Figure 6-1 shows a workbook displayed in the Google Chrome 
browser. As you can see, it’s remarkably similar to the desktop version of Excel.

The Excel Web App is lacking some features, compared to the desktop version. For example, the fol-
lowing are not supported by the Excel Web App:

➤ Macros

➤ Add-ins

➤ Data validation

➤ Comments

➤ Shapes and other inserted objects

Some features, such as worksheet protection, prevent the workbook from being opened.

Cloud computing is a great idea, and it could be a significant part of the future of computing. But it 
can also be frustrating because you’re at the mercy of your Internet provider and Microsoft. What if 
you need to get some work done, and the file you need is on the cloud? The message shown in 
Figure 6-2 could be frustrating.
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Figure 6-1: Viewing a workbook in a web browser.

Figure 6-2: The downside to storing your work in the cloud.
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Saving to a Read-Only Format
If you need to share information in a workbook with someone — and be assured that the informa-
tion remains intact and isn’t altered — you have several choices.

Send a printed copy
Printing a workbook on paper is the low-tech approach. If the recipient is not nearby, this option may 
also require some type of delivery service.

Send an electronic copy in the form of a PDF file
PDF files (for Portable Document Format) is a common file format, and just about everyone has soft-
ware installed that displays PDF files.

To save a workbook as a PDF file, choose File➜Export➜Create PDF/XPS Document and click the 
Create PDF/XPS button to display the Publish as PDF or XPS dialog box. Click the Options button for 
additional options:

➤ Choose the pages

➤ Specify what to save (the current range selection, the selected sheet(s), or the entire 
workbook

➤ Save document properties and accessibility information

For best results, use Excel’s Page Layout view (View➜Workbook View➜Page Layout) before saving, 
so you’ll see exactly how the pages will break. Figure 7-1 shows Adobe Reader displaying an Excel 
workbook that was saved as a PDF file.

Note  

Excel provides another option: XPS format (for XML Paper Specification). This is 
Microsoft’s format. When exporting from Excel, it’s limited to a single worksheet, and it 
doesn’t support images. An XPS viewer is installed with Windows. This format is not 
widely used.
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Figure 7-1: Adobe Reader displaying a PDF file created from an Excel workbook.

Send an MHTML file
Many Excel users don’t know about this file format. An MHTML faithfully renders an Excel workbook 
in a single file that can be opened with many browsers, including Internet Explorer, Opera, and 
Mozilla Firefox (extension required). Choose File➜Save As to display the Save As dialog box. Then 
select Single File Web Page (*.mht, *.mhtl) from the Save As Type drop-down menu.

Figure 7-2 shows a workbook that was saved as an MHTML file, displayed in the Internet Explorer 
browser. Note the worksheet tabs displayed along the bottom.
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If you need to send a read-only, non-alterable workbook, the MHTML format is probably your best 
choice (assuming that the recipient has a browser that supports this format).

Figure 7-2: An Excel workbook saved as an MHTML file and displayed in a web browser.
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Generating a List of Filenames
This tip describes how to retrieve a list of filenames in a folder and display them in a worksheet.

This technique uses an Excel 4 XLM macro function in a named formula. It’s useful because it’s a rela-
tively simple way of getting a list of filenames into a worksheet — something that normally requires 
a complex VBA macro.

Start with a new workbook and then follow these steps to create a named formula:

 1. Choose Formulas➜Define Name to display the New Name dialog box.

 2. Type FileList in the Name field.

 3. Enter the following formula in the Refers To field (see Figure 8-1):

=FILES(Sheet1!$A$1)

 4. Click OK to close the New Name dialog box.

Figure 8-1: Using the New Name dialog box to create a named formula.

Note that the FILES function is not a normal worksheet function. Rather, it’s an old XLM style macro 
function that is intended to be used on a special macro sheet. This function takes one argument (a 
directory path and a file specification) and returns an array of filenames in that directory that match 
the file specification.

A normal worksheet formula cannot use these old XLM functions, but named formulas can.

After defining the named formula, enter a directory path and file specification into cell A1. For example:

E:\Backup\Excel\*.xl*

Then this formula displays the first file found:

=INDEX(FileList, 1)

If you change the second argument to 2, it displays the second file found, and so on.
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Figure 8-2 shows an example. The path and file specification is in cell A1. Cell A2 contains this for-
mula, copied down the column:

=INDEX(FileList,ROW()-1)

The ROW function, as used here, generates a series of consecutive integers: 1, 2, 3, and so on. These 
integers are used as the second argument for the INDEX function. Note that cell A21 (and cells below 
it) displays an error. That’s because the directory has only 19 files, and the formula is attempting to 
display files that don’t exist.

When you change the directory or filespec in cell A1, the formulas update to display the new filenames.

Figure 8-2: Using an XLM macro in a named formula can generate a list of filenames in a worksheet.

Note  

If you use this technique, you must save the workbook as a macro-enabled file (with an 
*.xlsm or *.xls extension).
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Generating a List of Sheet Names
Oddly, Excel doesn’t provide a direct way to generate a list of sheet names in a workbook. This tip 
describes how to generate a list of all the sheets in a workbook. Like the previous tip (“Generating a 
List of Filenames”), this tip uses an Excel 4 XLM macro function in a named formula.

Start with a workbook that has lots of worksheets or chart sheets. Then follow these steps to create a 
list of the sheet names:

 1. Insert a new worksheet to hold the list of sheet names.

 2. Choose Formulas➜Define Name to display the New Name dialog box.

 3. Type SheetList in the Name field.

 4. Enter the following formula in the Refers To field (see Figure 9-1):

=REPLACE(GET.WORKBOOK(1),1,FIND(“]”,GET.WORKBOOK(1)),””)

 5. Click OK to close the New Name dialog box.

Figure 9-1: Using the New Name dialog box to create a named formula.

Note that this formula uses the GET.WORKBOOK function — which is not a normal worksheet func-
tion. Rather, it’s an old XLM-style macro function intended for use on a special macro sheet. Using an 
argument of 1 returns an array of sheet names, and each name is preceded by the workbook name. 
The REPLACE and FIND functions remove the workbook name from the sheet names.

To generate the sheet names, enter this formula in cell A1, and then copy it down the column:

=INDEX(SheetList,ROW())
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Figure 9-2 shows this formula in the range A1:A10. The workbook has seven sheets, so the formula 
returns a #REF! error when it attempts to display a nonexistent sheet name. To eliminate this error, 
modify the formula as follows:

=IFERROR(INDEX(SheetList,ROW()),””)

Figure 9-2: Using a formula to display a list of sheet names.

The list of sheet names will adjust if you add sheets, delete sheets, or rename sheets — but the 
adjustment doesn’t happen automatically. To force the formulas to update, press Ctrl+Alt+F9. If you 
want the sheet names to adjust automatically when the workbook is calculated, edit the named for-
mula to make it “volatile.”

=REPLACE(GET.WORKBOOK(1),1,FIND(“]”,GET.WORKBOOK(1)),””)&T(NOW())

What good is a list of sheet names? Figure 9-3 shows a table of contents created by using the 
HYPERLINK function. The formula in cell B1 is

=HYPERLINK(“#”&A1&”!A1”,”Go to sheet”)

Clicking a hyperlink activates the worksheet and selects cell A1. Unfortunately, Excel doesn’t support 
hyperlinking to a chart sheet, so you get an error if a hyperlink points to a chart sheet.
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Figure 9-3: Creating a list of hyperlinks.

Note  

If you use this technique, you must save the workbook as a macro-enabled file (with an 
*.xlsm or *.xls extension).
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Using Document Themes
Over the years, I’ve seen hundreds of Excel workbooks that were created by others. A significant per-
centage of these workbooks have one thing in common: They are ugly!

In an effort to help users create more professional-looking documents, Microsoft designers (starting 
with Office 2007) incorporated the concept of Office document themes. Using themes is an easy (and 
almost foolproof) way to specify the colors and fonts and a variety of graphical effects in a document. 
Best of all, changing the entire look of your document is a breeze. A few mouse clicks is all it takes to 
apply a different theme and change the look of your workbook.

Importantly, the concept of themes is incorporated into other Office applications. Therefore, a com-
pany can easily create a standard look for all its documents.

Elements within Excel that are controlled by document themes are

➤ Cells and ranges that use theme colors (as opposed to standard colors)

➤ Tables

➤ Charts

➤ Conditional formatting (but not always)

➤ Sparkline graphics

➤ Pivot tables

➤ PivotTable slicers and timelines

➤ Shapes

➤ SmartArt

➤ WordArt

➤ Sheet tab colors

Figure 10-1 shows a worksheet that contains various Excel elements. These items all use the default 
theme, which is known as Office Theme.

Figure 10-2 shows the same worksheet after applying a different document theme. The different 
theme changes the fonts, colors (which may not be apparent in the figure), and graphical effects for 
the SmartArt diagram.
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Figure 10-1: The elements in this worksheet use default formatting.

Figure 10-2: The worksheet, after applying a different theme.
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Applying a theme
Figure 10-3 shows the theme choices that appear when you choose Page➜Layout➜Themes. This 
display is a live preview. As you move your mouse over the theme choices, the active worksheet dis-
plays the theme. When you see a theme you like, click it to apply the theme to all worksheets in the 
workbook.

A theme applies to the entire workbook. You cannot use different themes on different worksheets 
within a workbook.

Figure 10-3: The built-in Excel theme choices.

When you specify a particular theme, you find that the gallery choices for various elements reflect 
the new theme. For example, the chart styles that you can choose from vary, depending on which 
theme is active.

Note  

Because themes use different fonts and font sizes, changing to a different theme can 
affect the layout of your worksheet. For example, after you apply a new theme, a work-
sheet that printed on a single page may spill over to a second page. Therefore, you may 
need to make some adjustments after you apply a new theme. For best results, decide 
on a theme before you do too much work on the file.
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Customizing a theme
Office 2013 includes quite a few themes. If that’s not enough, you can modify them and even create 
your own themes.

Notice that the Page Layout➜Themes group contains three other controls: Colors, Fonts, and Effects. 
You can use these controls to change just one of the three components of a theme. For example, if 
you like the Urban theme but prefer different fonts, apply the Urban theme and then specify your 
preferred font set by using the Page Layout➜Themes➜Fonts control.

Each theme uses two fonts (one for headers and one for the body), and in some cases, these two 
fonts are the same. If none of the theme choices is suitable, choose Page Layout➜Themes➜Fonts➜

Create New Theme Fonts to specify the two fonts you prefer (see Figure 10-4). When you use the 
Home➜Fonts➜Font command, the two fonts from the current theme are listed first in the drop-
down list.

Figure 10-4: Use this dialog box to specify two fonts for a theme.

Use the Page Layout➜Themes➜Colors command to select a different set of colors. Also, if you’re so 
inclined, you can even create a custom set of colors by choosing Page Layout➜Themes➜Colors➜

Customize Colors. This command displays the dialog box shown in Figure 10-5. Note that each 
theme consists of 12 colors. Four of the colors are for text and backgrounds, six are for accents, and 
two are for hyperlinks. The first ten are the colors that appear in theme color selector controls. As you 
specify different colors, the Preview panel in the dialog box is updated.
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Figure 10-5: If you’re feeling creative, you can specify a set of custom colors for a theme.

Theme effects operate on graphical elements, such as SmartArt, shapes, and charts. You can’t cus-
tomize theme effects.

If you customize a theme by using different fonts or colors, you can save the new theme by choosing 
Page Layout➜Themes➜Save Current Theme. Your customized themes appear in the theme list in 
the Custom category. Other Office applications, such as Word and PowerPoint, can use these theme 
files.
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Understanding Excel Compatibility Issues
The most recent version of Excel is known as Excel 2013, and it’s version 15. Microsoft’s version num-
bering is a bit misleading because they’ve only released 12 versions of Excel for Windows. The first 
version was Excel 2, and they skipped right over versions 6 and 13.

Besides Excel 2013, three other versions of Excel for Windows are still widely used: Excel 2003, Excel 
2007, and Excel 2010.

If you create workbooks only for Excel 2013 users, you can skip this tip because you don’t have to be 
concerned with compatibility. But if you create workbooks for those who use an earlier version, you 
need to understand compatibility.

The Excel 2013 file formats
The current Excel file formats (all of which were introduced in Excel 2007) are

➤ .xlsx: A workbook file that doesn’t contain macros

➤ .xlsm: A workbook file that contains macros

➤ .xltx: A workbook template file that doesn’t contain macros

➤ .xltm: A workbook template file that contains macros

➤ .xlsa: An add-in file

➤ .xlsb: A binary file that’s similar to the old .xls format but able to accommodate the new 
features

➤ .xlsk: A backup file

With the exception of .xlsb, these are all “open” XML files, which means that the file format is not pro-
prietary and other applications can read and write these types of files.

Note  

The XML files are actually zip-compressed text files. If you rename one of these files to 
have a .zip extension, you can examine the contents using any of several zip file utilities — 
including the zip file support built into Windows. Taking a look at the innards of an Excel 
workbook is an interesting exercise for curious-minded users.

The Office Compatibility Pack
Normally, those who use a version prior to Excel 2007 can’t open workbooks saved in the newer Excel 
file formats. But, fortunately, Microsoft has released a free Compatibility Pack for Office 2003 and 
Office XP.

If an Office 2003 or Office XP user installs the Compatibility Pack, he can open files created in Office 
2007 or later and save files in the newer format. The Office programs that are affected are Excel, 
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Word, and PowerPoint. This software doesn’t endow the older versions with any new features — it 
just gives them the capability to open and save files in the new format.

To download the Compatibility Pack from Microsoft, search the web for Office Compatibility Pack.

It’s important to understand the limitations regarding version compatibility. Even though your col-
league is able to open your file, there is no guarantee that everything will function correctly or look 
the same.

Checking compatibility
If you save your workbook to an older file format (such as .xls, for versions prior to Excel 2007), Excel 
automatically runs the Compatibility Checker. The Compatibility Checker identifies the elements of 
your workbook that will result in a loss of functionality or fidelity (cosmetics).

Figure 11-1 shows the Compatibility Checker dialog box. Click the Select Versions to Show button to 
limit the compatibility-checking to a specific version of Excel.

Figure 11-1: The Compatibility Checker is a useful tool for those who share workbooks with other people.

The bottom part of the Compatibility Checker lists the potential compatibility problems. To display 
the results in a more readable format, click the Copy to New Sheet button.

Keep in mind that compatibility problems also can occur with Excel 2007 and Excel 2010, even 
though these versions use the same file format as Excel 2013. You can’t expect features that are new 
to Excel 2013 to work in earlier versions. For example, if you add slicers to table (a new feature in 
Excel 2013) and send it to a colleague who uses Excel 2010, the slicers won’t be displayed. In addi-
tion, formulas that use any of the new worksheet functions will return an error. The Compatibility 
Checker identifies these types of problems.
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Where to Change Printer Settings
If you want to print a copy of a worksheet with no fuss and bother, use the Quick Print option. One 
way to access this command is to choose File➜Print (which displays the Print pane of Backstage 
view) and then click the Print button.

However, if the default print settings aren’t good enough, you must make some adjustments. A little 
tweaking of the print settings can often improve your printed reports.

Unfortunately, Excel has no one-stop location for adjusting print setting. You can adjust print set-
tings in three places:

➤ The Print settings screen in Backstage view, which opens when you choose File➜Print.

➤ The Page Layout tab of the Ribbon.

➤ The Page Setup dialog box, which opens when you click the dialog launcher in the lower-
right corner of the Page Layout➜Page Setup group on the Ribbon. You can also access the 
Page Setup dialog box from the Print settings screen in Backstage view.

Table 12-1 summarizes the locations where you can make various types of print-related adjustments 
in Excel 2013.

Table 12-1: Where to Change Printer Settings

Setting Print Settings 
Screen

Page Layout 
Tab of Ribbon

Page Setup 
Dialog Box

Number of copies X

Printer to use X

What to print X

Specify worksheet print area X X

1-sided or 2-sided X

Collated X

Orientation X X X

Paper size X X X

Adjust margins X X X

Specify manual page breaks X

Specify repeating rows and/or columns X

Set print scaling X X

Print or hide gridlines X X

Print or hide row and column headings X X

continued
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Table 12-1: Where to Change Printer Settings (continued)

Setting Print Settings 
Screen

Page Layout 
Tab of Ribbon

Page Setup 
Dialog Box

Specify the first page number X

Center output on page X

Specify repeating rows or columns X

Specify header/footers and options X

Specify how to print cell comments X

Specify page order X

Specify black-and-white output X

Specify how to print error cells X

Launch dialog box for printer-specific 
settings

X X

This table might make printing seem more complicated than it really is. The key point to remember is 
this: If you can’t find a way to make a particular adjustment, it’s probably available from the Page 
Setup dialog box.
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